Subject: FVWM: Does 'exec' need '&'?

From: [email-masked] (Mark B. Hamby)
Date: Wed, 1 Nov 1995 13:52:48 -0600

One more question: Does the 'exec' builtin need a '&' at the end?

This:		exec xterm &
Or this:	exec xterm

Thanks,

Mark Hamby
Logicon RDA
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Gail Mara Gurman)
Date: Wed, 1 Nov 1995 13:43:41 -0800 (PST)

> One more question: Does the 'exec' builtin need a '&' at the end?

Personally, I think it's worth putting in the '&'. It can't hurt, can it?
For OpenWin apps, I use toolwait instead (e.g., "Exec toolwait xrolo"). I
haven't tried it with other applications, but it probably works for them too.

However, this reminds me about a question I had. Do you need the "exec"? 
I've been leaving it out with no problem. E.g.:

AddToMenu Games		"Boing" 	Exec xboing &
+			"Doom"		Exec sunxdoom -2 &
+			"Hearts"	Exec xhearts &
+			"Mahjongg"	Exec mahjongg -P -C > /dev/null &
+			"Minesweeper"	Exec xvmines > /dev/null &
+			"Solitaire"	Exec exec xsol &

Gail