Subject: FVWM: Re: Please send your .fvwm2rc

From: Eric Ding <[email-masked]>
Date: Wed, 01 Nov 1995 16:26:51 -0800

Hi Bret,

here's my .fvwm2rc... it's got some pixmaps that don't come with the
distribution, but hope it helps!

Eric
--
# fvwm 2.0 resource file

WindowFont -adobe-helvetica-bold-r-normal--*-120-*-*-*-*-*-*
IconFont -adobe-helvetica-bold-r-normal--*-100-*-*-*
EdgeScroll 100 100
EdgeResistance 250 50

ModulePath /u/ericding/lib/fvwm2
PixmapPath /u/ericding/lib/fvwm2:/u/ericding/lib/fvwm:/u/ericding/Pictures/xpm
IconPath   /u/ericding/lib/fvwm2:/u/ericding/lib/fvwm

HilightColor   Black #5f9da0
DeskTopSize 2x2
MenuStyle Black #60a0c0 SlateGrey -adobe-helvetica-bold-r-normal--*-120-*-*-*-*-*-* mwm
XorValue 25

Style "*"		BorderWidth 5,HandleWidth 5
Style "*"		Color Black/gray64
Style "*"		IconBox 105 1 700 300
Style "*"		MWMFunctions,MWMButtons,MWMDecor,MWMBorder
Style "*"		HintOverride,RandomPlacement,SmartPlacement,NoPPosition
Style "Fvwm*"		NoTitle,NoHandles,Sticky,WindowListSkip,BorderWidth 0
Style "Fvwm Pager"	StaysOnTop
Style "FvwmPager"	StaysOnTop
Style "FvwmBanner"	StaysOnTop
Style "FvwmButtons"	NoTitle,NoHandles,Sticky,WindowListSkip,BorderWidth 0
Style "FvwmIconMan"	HandleWidth 5, BorderWidth 5
Style "FvwmTalk"	HandleWidth 5, Title, BorderWidth 5
Style "*x-face*"	NoTitle,NoHandles,WindowListSkip
Style "*lock"		NoTitle,NoHandles,Sticky,WindowListSkip
Style "*xbiff"		NoTitle,NoHandles,Sticky,WindowListSkip
Style "xload"		NoTitle,NoHandles,Sticky,WindowListSkip
Style "Cm"		Sticky,NoIconTitle,WindowListSkip
Style "mh-e"		Icon mailtool2.xpm, IconBox 1043 54 -1 -1
Style "xcalc"		Icon xcalc.xpm, Sticky
Style "xmag"		Icon mag_glass.xpm
Style "userload"	Sticky, NoButton 2
Style "CONSOLE*"	Sticky
Style "*logout"		Sticky,NoTitle,NoHandles,WindowListSkip
Style "Morning*Evening"	Sticky, IconBox 403 883 520 902

# Arrow Keys
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# Keyboard accelerators
Key F1		A	C	GotoPage 0 0
Key F2		A	C	GotoPage 1 0
Key F3		A	C	GotoPage 0 1
Key F4		A	C	GotoPage 1 1
Key F5		A	A	Warp mh-e "mh-e -f my-mh-rmail -geometry -100+100"
Key F6		A	A	Warp Athena "xterm -T Athena -n Athena -bg midnightblue -fg lightyellow -cr lightyellow -fn 6x13 -geometry 80x40 -e telnet gaston.mit.edu"
Key F7		A	A	Warp morningandEvening morneve
Key F8		A	A	Warp cm cm
Key F9		A	C	Next [CurrentDesk xterm] Focus
Key F10		A	C	Next [CurrentDesk emacs] Focus
Key L5          A       A       RaiseLower
Key L7          A       A       Iconify

Mouse 1		R   	A       Menu "Main" Nop
Mouse 2		R    	A      	WindowList
Mouse 3		R    	A       Menu "Apps" Nop

# Title bar buttons
Mouse 0		1    	A      	Menu Window_Ops2 Delete
Mouse 0		2    	A     	Maximize-Func
Mouse 0		4    	A     	Iconify

Mouse 1		T	A	Move-or-Raise
Mouse 1		FS	A	Resize-or-Raise

Mouse 1		I	A	Move-or-Iconify
Mouse 2		I	A	Iconify
Mouse 3		I	A	Move-or-Iconify

Mouse 2		FST	A	Menu Window_Ops2 Delete
Mouse 3		FST	A	RaiseLower

Mouse 2		W	M	Resize
Mouse 3         W       M       Move-or-Raise

#################### Initialization Functions ####################

AddToFunc InitFunction	"I" Module FvwmButtons
+			"I" Desk 0 0

AddToFunc RestartFunction	"I" Module FvwmButtons

######################## Complex Functions #######################

AddToFunc Toggle-Page	"I" EdgeScroll 0 0
+			"I" EdgeScroll 100 100

# This one moves the window if you drag the mouse, only raises the window
# if you click, or does a RaiseLower if you double click
AddToFunc Move-or-Raise	"M" Move
+			"C" Raise
+			"D" RaiseLower

# This one maximizes vertically if you click (leaving room for the
# GoodStuff bar at the bottom, or does a full maximization if you double
# click, or a true full vertical maximization if you just hold the mouse
# button down.
AddToFunc Maximize-Func	"M" Maximize 0 100
+			"C" Maximize 0 80
+			"D" Maximize 100 100

# This one moves and then lowers the window if you drag the mouse, only
# lowers the window if you click, or does a RaiseLower if you double click
AddToFunc Move-or-Lower	"M" Move
+			"M" Lower
+			"C" Lower
+			"D" RaiseLower

# This one moves or (de)iconifies
AddToFunc Move-or-Iconify	"M" Move
+				"D" Iconify
+				"D" Raise

# This one resizes and then raises the window if you drag the mouse, only
# raises the window if you click, or does a RaiseLower if you double click
AddToFunc Resize-or-Raise	"M" Resize
+				"M" Raise
+				"C" Raise
+				"D" RaiseLower

AddToFunc Warp	"I" Next [$0] Iconify -1
+		"I" Next [$0] Focus
+		"I" None [$0] Exec $1 

AddToFunc XPMBack "I" Exec xpmroot /u/ericding/Pictures/xpm/$0
AddToFunc ImageBack "I" Exec xv -root -quit /u/ericding/Pictures/images/$0

AddToFunc Rsh-Func "I" Exec rxterm $0 white:gray30 80x40 $DISPLAY "-cr white -title $0 -e ~rod/bin/tcsh -l"

############################# Menus ##############################

AddToMenu Quit-Verify "Really Quit Fvwm?" Title
+	"Restart fvwm"		Restart fvwm2
+	"Start twm"		Restart twm
+	"Start vtwm"		Restart vtwm.gamma
+	"Start mwm"		Restart mwm
+	"Start olwm"		Restart /usr/openwin/bin/olwm
+	""			Nop
+	"Yes, Really Quit"	Quit

AddToMenu Module "Modules" Title
+	"Buttons"	Module FvwmButtons
+	"Clean-Up"	Module FvwmClean
+	"Debug"		Module FvwmDebug
+	"Icon Box"	Module FvwmIconBox
+	"Icon Manager"	Module FvwmIconMan
+	"Identify"	Module FvwmIdent
+	"SaveDesktop"	Module FvwmSave
+	"Talk"		Module FvwmTalk
+	"WinList"	Module FvwmWinList

AddToMenu Apps "Applications" Title
+	"Archie%mini.xarchie.xpm%"	Exec LD_LIBRARY_PATH="" xarchie
+	"Athena"	Exec xterm -T Athena -n Athena -bg midnightblue -fg lightyellow -cr lightyellow -fn 6x13 -geometry 80x40 -e telnet gaston.mit.edu
+	"Boing%mini.xboing.xpm%"	Exec xboing -speed 2 -maxvol 13 -sound
+	"Calendar"	Exec cm -icon_position 0 0
+	"Cricketerm%mini.xterm.xpm%"	Exec xterm -rv -title cricketerm -n cricketerm
+	"Emacs"		Exec emacs
+	"mh-e"		Exec mh-e -f my-mh-rmail -geometry -100+100
+	"Mule"		Exec mule
+	"Mosaic L10N"	Exec xmosaic-cjk
+	"Netscape%mini.netscape.xpm%"	Exec netscape -install
+	"XEmacs"	Exec xemacs

AddToMenu XPM_Backgrounds "Beehive" XPMBack background1.xpm
+	"Stained Glass"	XPMBack background2.xpm
+	"Rain Shower"	XPMBack background3.xpm
+	"Puzzle"	XPMBack background4.xpm
+	"Velvet"	XPMBack background5.xpm
+	"Tiles"		XPMBack background6.xpm
+	"Maze"		XPMBack background7.xpm
+	"Carpet"	XPMBack background8.xpm
+	"Waves"		XPMBack background9.xpm

AddToMenu "Backgrounds" "Backgrounds" Title
+	"Default"	Exec xsetroot -default
+	"Light Gray"	Exec xsetroot -solid gray80
+	"LightBlue"	Exec xsetroot -solid LightBlue
+	"Plum1"		Exec xsetroot -solid Plum1
+	"Big Fish"	Exec xsetroot -bitmap /u/ericding/Pictures/bitmaps/bigfish.bmp
+	"Cool XPM's"	Popup XPM_Backgrounds
+	""		Nop
+	"Beauty"	ImageBack fullbeauty.jpg
+	"Fantasia"	ImageBack fantasia.gif
+	"Hitchhiker"	ImageBack hgttg.gif
+	"SR-71A"	ImageBack sr71a.gif
+	"2010"		ImageBack 2010.gif

AddToMenu "Rxterm" "Sparc 20" Title
+	"Calgary"	Rsh-Func Calgary
+	"Grenoble"	Rsh-Func Grenoble
+	"Nirvana"	Rsh-Func Nirvana
+	"Toro"		Rsh-Func Toro
+	"Weisshom"	Rsh-Func Weisshom
+	""		Nop
+	"Sparc 10"	Title
+	"Antofalla"	Rsh-Func Antofalla
+	"Marmolejo"	Rsh-Func Marmolejo
+	"Missouri"	Rsh-Func Missouri
+	"Olympus"	Rsh-Func Olympus
# +	"Semeru"	Rsh-Func Semeru

AddToMenu Xterms "Clearcase" Exec xterm -rv -e /usr/atria/bin/cleartool setview ericding_view
+	"10x20"	Exec xterm -bg antiquewhite -fn 10x20
+	"Green"	Exec xterm -bg darkgreen -fg lavender -cr lavender
+	"Blue"	Exec xterm -bg skyblue4 -fg beige -cr beige
+	"Pink"	Exec xterm -bg pink -fg black -cr black
+	"Rxterm" Popup Rxterm

AddToMenu Bell	"Loud"	Exec xset b 100
+		"Quiet"	Exec xset b 30
+		"Off"	Exec xset b 0

AddToMenu Keyclick	"Loud"	Exec xset c 100
+			"Quiet"	Exec xset c 13
+			"Off"	Exec xset c 0

AddToMenu Utilities	"Bell"			Popup Bell
+			"Keyclick"		Popup Keyclick
+			"Xmag"			Exec xmag
+			"Xcalc"			Exec xcalc
+			""			Nop
+			"Refresh Screen"	Refresh

# This defines the most common window operations
AddToMenu Window_Ops "Window Ops" Title
+	"Move%mini.move.xpm%"		Move-or-Raise
+	"Resize%mini.resize.xpm%"	Resize-or-Raise
+	"Raise%mini.raise.xpm%"		Raise
+	"Lower%mini.lower.xpm%"		Lower
+	"(De)Iconify%mini.iconify.xpm%"	Iconify
+	"(Un)Stick%mini.stick.xpm%"	Stick
+	"(Un)Maximize"			Maximize
+	""				Nop
+	"Destroy%mini.destroy.xpm%"	Destroy
+	"Delete%mini.exit.xpm%"		Delete
+	""				Nop
+	"ScrollBar"			FvwmScroll 2 2

# A trimmed down version of "Window_Ops", good for binding to decorations
AddToMenu "Window_Ops2" "Move%mini.move.xpm%" Function Move-or-Raise
+	"Resize%mini.resize.xpm%"	Resize-or-Raise
+	"Raise%mini.raise.xpm%"		Raise
+	"Lower%mini.lower.xpm%"		Lower
+	"Iconify%mini.iconify.xpm%"	Iconify
+	"(Un)Stick%mini.stick.xpm%"	Stick
+	""		Nop
+	"Destroy%mini.destroy.xpm%"	Destroy
+	"Delete%mini.exit.xpm%"		Delete
+	""		Nop
+	"ScrollBar"	FvwmScroll 2 2

AddToMenu "Main" "*cross.xpm*" Nop
+	""		Nop
+	"Quit/Restart"	Popup Quit-Verify
+	""		Nop
+	"Applications"	Popup Apps
+	"Backgrounds"	Popup Backgrounds
+	"Xterms%mini.xterm.xpm%"	Popup Xterms
+	"Utilities"	Popup Utilities
+	"Windows"	Popup Window_Ops
+	"Modules"	Popup Module
+	""		Nop
+	".Xresources"	Exec xrdb -load /u/ericding/.Xresources
+	"XLock%mini.xlock.xpm%"	Exec nice /usr/openwin/bin/xlock -mode flame

######################### FvwmButtons #########################
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #909090

# Font
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmButtonsGeometry +0+769

# Layout: specify rows or columns, not both
*FvwmButtonsRows 2

*FvwmButtons Xterm   rterm.xpm   Exec "cricketerm" xterm -rv -title cricketerm -n cricketerm
*FvwmButtons Emacs kitchen-sink.xpm   Exec "emacs" emacs
*FvwmButtons Mail    mail2.xpm   Warp mh-e "mh-e -f my-mh-rmail -geometry -100+100"
*FvwmButtons Athena  athena.xpm   Exec "Athena" xterm -T Athena -n Athena -bg midnightblue -fg lightyellow -cr lightyellow -fn 6x13 -geometry 80x40 -e telnet gaston.mit.edu
*FvwmButtons Netscape  netscape.xpm Warp netscape "netscape -install"
*FvwmButtons xv xv.xpm  Exec "xv" xv
*FvwmButtons Frame frame.xpm Warp FrameMaker maker

*FvwmButtons xlock xlock.xpm Exec "" /usr/openwin/bin/xlock -mode flame
#*FvwmButtons Paging clamp1.xpm Function Toggle-Page
*FvwmButtons(3x1) - whatever SwallowModule "FvwmPager" FvwmPager 0 0
*FvwmButtons(2x1) - NULL Swallow "xload" Exec nice -16 xload -font -adobe-helvetica-bold-r-\*-\*-10-\* -bg antiquewhite -geometry -1500-1500
*FvwmButtons - NULL Swallow "audio-xbiff" Exec audio-xbiff -geometry -1500-1500

########################## Window-Identifier #########################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager ####################################
*FvwmPagerBack #909090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry +1-1
*FvwmPagerLabel 0 Jesus Reigns!
*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +370-1
*FvwmWinListUseIconNames

########################## FvwmIconBox ################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       5
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      background5.xpm
#
# mouse bindings
#
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module "FvwmIdent" FvwmIdent
#
# Key bindings
#
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
#
# FvwmIconBox built-in functions
#
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file spcifications
#
*FvwmIconBox            "*"             unknown1.xpm
*FvwmIconBox            "Fvwm*"         -
*FvwmIconBox            "FvwmButtons"   -
*FvwmIconBox		"cm"		-
*FvwmIconBox		"*clock"	-
*FvwmIconBox            "rxvt"          term.xpm
*FvwmIconBox            "xterm"         xterm.xpm
*FvwmIconBox            "editres"       editres.xpm
*FvwmIconBox            "xman"          xman.xpm
*FvwmIconBox            "xbiff"         mail1.xpm
*FvwmIconBox            "audio-xbiff"   mail1.xpm
*FvwmIconBox            "xmh"           mail1.xpm
*FvwmIconBox            "xcalc"         xcalc.xpm
*FvwmIconBox		"Mosaic"	mosaic.xpm
*FvwmIconBox		"Athena"	athena.xpm
*FvwmIconBox		"xv"		xv.xpm
*FvwmIconBox		"emacs"		toolbox.xpm
*FvwmIconBox		"mh-e"		mail2.xpm

*FvwmIconMan*nummanagers	1
*FvwmIconMan*resolution		page
*FvwmIconMan*background		slategrey
*FvwmIconMan*foreground		white
*FvwmIconMan*font		-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconMan*action		click1 Iconify
*FvwmIconMan*action		click3 Module "FvwmIdent" FvwmIdent
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Brian P Millett)
Date: Thu, 2 Nov 1995 08:45:22 -0600

Bret A. Schuhmacher writes:
 |I'll take anything you
 |have to offer (beggars can't be choosers, you know ;-)).
 |

Well, Bret, here is my simple fvwm2rc that I've set up to run most of
the openwin apps that you get in openwindoze.
--
# this is a sample .fvwmrc file for fvwm-2.
# Apparantly, you can retrieve sample .fvwmrc's from 
# 	ftp://ftp.best.com/pub/tdgilman/Fvwmrcs
# you can also submit your favourite .fvwmrc to
#	[email-masked] 
# if you want to.

# small up triangle
ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0

# some other ButtonStyles:
# large up triangle
#ButtonStyle 2 4 50x25@1 75x75@0 25x75@0 50x25@1
# large down triangle
#ButtonStyle 4 4 50x75@1 25x25@1 75x25@1 50x75@0
# big box
#ButtonStyle 2 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# little box
#ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# tall box
#ButtonStyle 6 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# dot
#ButtonStyle 4 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# an up arrow:
#ButtonStyle 2 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# an X
#ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0

EdgeResistance 700 100
WindowFont		-*-lucidatypewriter-medium-r-*-*-12-*-*-*-*-*-*-*
IconFont		fixed
EdgeScroll 100 100

ModulePath /usr/local/lib/X11/fvwm2
PixmapPath /usr/local/include/X11/pixmaps/
IconPath   /usr/local/include/X11/bitmaps/

HilightColor   Black #5f9ea0
DeskTopSize 2x1
MenuStyle   Black grey SlateGrey -*-lucidatypewriter-medium-r-*-*-*-*-100-100-*-*-*-* mwm
ClickTime 750

ColormapFocus FollowsMouse

Style "*"           BorderWidth 5,HandleWidth 5,Color Black/#60a0c0,Icon unknown1.xpm,ClicktoFocus
Style "*"           ActivePlacement, SmartPlacement
Style "*"           MWMFunctions,MWMDecor,MWMButtons,HintOverride
Style "*"           DecorateTransient,IconBox 0 -10 -280 -1
Style "Fvwm*"       NoTitle, NoHandles, Sticky, WindowListSkip,
Style "Fvwm*"       BorderWidth 0,CirculateSkipIcon
Style "Fvwm Pager"  StaysOnTop
Style "FvwmPager"   StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "FvwmButtons" NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmButtons" BorderWidth 0, CirculateSkip
Style "FvwmButtons" Icon toolbox.xpm,ClickToFocus
Style "*lock"       NoTitle, NoHandles, Sticky, WindowListSkip
Style "*lock"	    RandomPlacement
Style "xbiff"       NoTitle, Sticky, WindowListSkip,ClickToFocus
Style "*emacs*"	    Icon xemacs.xpm,ClicktoFocus
Style "Maker"       StartsOnDesk 1,RandomPlacement,ClickToFocus
Style "matlab"      StartsOnDesk 3
Style "signal"      StartsOnDesk 3 
Style "rxvt"        Icon  term.xpm,SloppyFocus,IconBox -70 1 -1 -140
Style "XTerm"       Icon xterm.xpm,IconBox -70 1 -1 -140
Style "XTerm"       Color black/#aa80aa,MWMBorder,MWMButtons
Style "Appointment" Icon datebook.xpm, NoButton 2, NoButton 4,ClickToFocus
Style "xcalc"       Icon xcalc.xpm, NoButton 2,RandomPlacement,ClickToFocus
Style "xmh"         Icon mail1.xpm, NoIconTitle,StickyIcon
Style "xmh"	    RandomPlacement, StartsOnDesk 2, NoButton 2
Style "xman"	    Icon xman.xpm,RandomPlacement,ClickToFocus
Style "xvgr"	    Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "matlab"	    Icon math4.xpm,ClickToFocus
Style "xmag"	    Icon mag_glass.xpm,RandomPlacement, ClickToFocus
Style "xgraph"      Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "sppeed6"     Icon math3.xpm,NoTitle,ClickToFocus
Style "sppeed6_user" Icon math4.xpm,NoTitle
Style "xmosaic"     NoPPosition, color Green/Yellow,ClickToFocus

#############################################################################

# Stuff to do at start-up

AddToFunc "InitFunction" "I" Desk 0 0
+              "I" Exec xsetroot -solid "#bfa498"
+              "I" Exec exec xterm -fn 5x8 -fg OrangeRed -bg white -sb -g 80x6+0+0 -name Console -T Console -C -e su -&
+              "I" Module FvwmButtons
+              "I" Desk 0 1
+              "I" Exec exec xterm -ls -sl 240 -sb -geo 80x25

AddToFunc "RestartFunction" "I" Exec xsetroot -solid "#bfa498"
+              "I" Module FvwmButtons

############################################################################
# Now define some handy complex functions

# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

# This one maximizes vertically if you click (leaving room for the GoodStuff bar at the
# bottom, or does a full maximization if you double click, or a true full vertical 
# maximization if you just hold the mouse button down.
AddToFunc "maximize_func" "M" Maximize 0 100
+              "C" Maximize 0 80
+              "D" Maximize 100 100

# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Lower" "M" Move
+              "M" Lower
+              "C" Lower
+              "D" RaiseLower

# This one moves or (de)iconifies:
AddToFunc "Move-or-Iconify" "M" Move
+              "D" Iconify

# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Resize-or-Raise" "M" Resize
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

AddToFunc "Resize-or-Lower" "M" Resize
+              "C" Lower
+              "D" RaiseLower

##############################################################################
#now define the menus - defer bindings until later

# This menu is invoked as a sub-menu - it allows you to quit,
# restart, or switch to another WM.
AddToMenu "Quit-Verify" "Really Quit Fvwm?" Title
+              "Yes, Really Quit" Quit
+              "Restart fvwm2" Restart /usr/local/bin/X11/fvwm2
+              "Start olwm" Restart /usr/openwin/bin/olwm
+              "" Nop
+              "No, Don't Quit" Nop

# Provides a list of modules to fire off
AddToMenu "Module-Popup" "Modules" Title
+              "FvwmButtons" Module FvwmButtons
+              "Clean-Up" Module FvwmClean
+              "Identify" Module FvwmIdent
+              "SaveDesktop" Module FvwmSave
+              "Debug" Module FvwmDebug
+              "Pager" Module FvwmPager 0 3
+              "FvwmWinList" Module FvwmWinList

###################################### BPM STUFF ###

AddToMenu "ArchieMenu" "Archie Hosts" TITLE
+              "" Nop
+              "archie.unl.edu" Exec exec xterm -l -sb -sl 512 -e telnet archie.unl.edu &
+              "archie.internic.net" Exec exec xterm -l -sb -sl 512 -e telnet archie.internic.net&
+              "archie.rutgers.edu" Exec exec xterm -l -sb -sl 512 -e telnet archie.rutgers.edu &
+              "archie.ans.net" Exec exec xterm -l -sb -sl 512 -e telnet archie.ans.net &
+              "archie.sura.net" Exec exec xterm -l -sb -sl 512 -e telnet archie.sura.net &

AddToMenu "LoginMenu" "Host Remote Logins" TITLE
+              "" Nop
+              "Terra" Exec exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T terra -n Terra -e rlogin terra.terraweb.com &
+              "Luna" Exec exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T luna -n Luna -e rlogin luna.terraweb.com &
+              "Mundo" Exec exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T mundo -n Mundo -e rlogin mundo.terraweb.com &
+              "Thunder" Exec exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T thunder -n Thunder -e rlogin thunder.techapp.com &
+              "Caramello" Exec exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T caramello -n Caramello -e rlogin caramello.techapp.com &
+              "whois" Exec exec xterm -ls -sl 240 -sb -e telnet nic.ddn.mil &
+              "Archie" Popup ArchieMenu
+              "Telnet" Exec exec xterm -sl 240 -sb -geo 80x25 -T Telnet -n Telnet -e telnet &
+              "EVP" Exec exec xterm -sb -sl 512 -e telnet future &

AddToMenu "LockMenu" "Lock Methods" TITLE
+              "Bat" Exec exec xlock -allowroot -mode bat
+              "Rorschach" Exec exec xlock -allowroot -mode blot
+              "Bounce" Exec exec xlock -allowroot -mode bounce
+              "Clock" Exec exec xlock -allowroot -mode clock
+              "Flame" Exec exec xlock -allowroot -mode flame
+              "Forest" Exec exec xlock -allowroot -mode forest
+              "Galaxy" Exec exec xlock -allowroot -mode galaxy
+              "Geometry" Exec exec xlock -allowroot -mode geometry
+              "Grav" Exec exec xlock -allowroot -mode grav
+              "Helix" Exec exec xlock -allowroot -mode helix
+              "Fractals" Exec exec xlock -allowroot -mode hop
+              "Hyper" Exec exec xlock -allowroot -mode hyper
+              "Kaleid" Exec exec xlock -allowroot -mode kaleid
+              "Laser" Exec exec xlock -allowroot -mode laser
+              "Life" Exec exec xlock -allowroot -mode life
+              "Life3d" Exec exec xlock -allowroot -mode life3d
+              "Maze" Exec exec xlock -allowroot -mode maze
+              "Mountain" Exec exec xlock -allowroot -mode mountain
+              "Pyro" Exec exec xlock -allowroot -mode pyro
+              "Qix" Exec exec xlock -allowroot -mode qix
+              "Rect" Exec exec xlock -allowroot -mode rect
+              "Rock" Exec exec xlock -allowroot -mode rock
+              "Rotor" Exec exec xlock -allowroot -mode rotor
+              "Sphere" Exec exec xlock -allowroot -mode sphere
+              "Spiral" Exec exec xlock -allowroot -mode spiral
+              "Spline" Exec exec xlock -allowroot -mode spline
+              "Swarm" Exec exec xlock -allowroot -mode swarm
+              "Wator" Exec exec xlock -allowroot -mode wator
+              "World" Exec exec xlock -allowroot -mode world
+              "Worm" Exec exec xlock -allowroot -mode worm
+              "Swirl" Exec exec xlock -allowroot -mode swirl
+              "Image" Exec exec xlock -allowroot -mode image
+              "Blank" Exec exec xlock -allowroot -mode blank
+              "Random Mode" Exec exec xlock -allowroot -mode random

AddToMenu "LayoutMenu" "Layout Helps" TITLE
+              "Xcolorsel" Exec exec xcolorsel &
+              "Xfontsel" Exec exec xfontsel &

AddToMenu "ToolsMenu" "X11 Tools" TITLE
+              "Screen Locks" Popup LockMenu
+              "Layout Helps" Popup LayoutMenu

AddToMenu "RootMenu3" "System Tools" TITLE
+              "X11 Tools" Popup ToolsMenu
+              "" Nop
+              "Modules" Popup Module-Popup
+              "" Nop
+              "Exit Fvwm " Popup Quit-Verify

#
#	OpenWindows default root menu file - Programs submenu
#

AddToMenu "OpenwindowsMenu" "Openwindows Programs" Title
+              "File Manager..." Exec exec $OPENWINHOME/bin/filemgr &
+              "Text Editor..." Exec exec $OPENWINHOME/bin/textedit &
+              "Mail Tool..." Exec exec $OPENWINHOME/bin/mailtool &
+              "Calendar Manager..." Exec exec $OPENWINHOME/bin/cm &
+              "" Nop
+              "Command Tool..." Exec exec $OPENWINHOME/bin/cmdtool &
+              "Shell Tool..." Exec exec $OPENWINHOME/bin/shelltool &
+              "" Nop
+              "Clock..." Exec exec $OPENWINHOME/bin/clock &
+              "Calculator..." Exec exec $OPENWINHOME/bin/calctool &
+              "Performance Meter..." Exec exec $OPENWINHOME/bin/perfmeter &
+              "Print Tool..." Exec exec $OPENWINHOME/bin/printtool &
+              "Audio Tool..." Exec exec $OPENWINHOME/bin/audiotool &
+              "Tape Tool..." Exec exec $OPENWINHOME/bin/tapetool &
+              "CD Player Tool..." Exec exec /usr/local/bin/workman &
+              "" Nop
+              "Image Tool..." Exec exec $OPENWINHOME/bin/imagetool &
+              "Snapshot..." Exec exec $OPENWINHOME/bin/snapshot &
+              "Icon Editor..." Exec exec $OPENWINHOME/bin/iconedit &
+              "Binder..." Exec exec $OPENWINHOME/bin/binder &
+              "AnswerBook..." Exec exec $OPENWINHOME/bin/answerbook &
+              "" Nop
+              "Demos..." Exec exec $OPENWINHOME/bin/filemgr -d $OPENWINHOME/demo/add &

AddToMenu "WebMenu" "Web Browsers" TITLE
+              "Mosaic" Exec exec Mosaic -display $HOSTDISPLAY &
+              "Mozilla" Exec exec netscape -install -display $HOSTDISPLAY &
+              "Arena" Exec exec arena -display $HOSTDISPLAY &
+              "HotJava" Exec exec hotjava -display $HOSTDISPLAY &

AddToMenu "X11Menu" "X11 Programs" TITLE
+              "Sokoban" Exec exec xsokoban&
+              "Cbzone" Exec exec cbzone &
+              "Dog Fight" Exec exec acm &
+              "FirePower" Exec exec xfire &
+              "Galaga" Exec exec xgal &
+              "" Nop
+              "XV " Exec exec xv &
+              "XPaint " Exec exec xpaint &
+              "Xman " Exec exec xman &
+              "Xmag " Exec exec xmag &
+              "Calculator " Exec exec xcalc &

###########################################################
# This menu will fire up some very common utilities
AddToMenu "Programs" "Programs" Title
+              "Emacs" Exec exec xemacs &
+              "Web Browsers" Popup WebMenu
+              "X11 Programs" Popup X11Menu
+              "Openwindow Programs" Popup OpenwindowsMenu
+              "Host Logins" Popup LoginMenu

#
# This defines the most common window operations
AddToMenu "Window" "Window Ops" Title
+              "New Window " Exec exec xterm -ls -sl 240 -sb &
+              "" Nop
+              "Move" Function Move-or-Raise
+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
+              "Lower" Lower
+              "(De)Iconify" Iconify
+              "(Un)Stick" Stick
+              "(Un)Maximize" Function maximize_func
+              "" Nop
+              "Kill" Destroy
+              "Close" Delete
+              "" Nop
+              "Refresh Screen" Refresh
+              "" Nop
+              "New Console" Exec exec xterm -fn 5x8 -fg OrangeRed -bg white -sb -g 80x6+0+0 -name Console -T Console -C -e su -&

#############################################################################
# One more complex function - couldn't be defined earlier because it used 
# pop-up menus
#
# This creates a motif-ish sticky menu for the title-bar window-ops
# pop-up
# Menu acts like normal twm menu if you just hold the button down,
# but if you click instead, the menu stays up, motif style
AddToFunc "window_ops_func" "C" PopUp Window Ops2
+              "M" PopUp Window Ops2
# Motif would add
#       Delete  "DoubleClick"  

##############################################################################
# This defines the mouse bindings

# First, for the mouse in the root window
# Button 1 gives the Utilities menu
# Button 2 gives the Window Ops menu
# Button 3 gives the WindowList (like TwmWindows)
# I use the AnyModifier (A) option for the modifier field, so you can hold down
# any shift-control-whatever combination you want!

#     Button	Context Modifi 	Function
Mouse 1		R   	A       Menu "Programs" Nop
Mouse 2		R    	A       Menu "Window" Nop
Mouse 3		R    	A       Menu "RootMenu3" Nop

# Now the title bar buttons
# Any button in the left title-bar button gives the window ops menu
# Any button in the right title-bar button Iconifies the window
# Any button in the rightmost title-bar button maximizes
# Note the use of "Mouse 0" for AnyButton.

#     Button	Context Modifi 	Function
Mouse 0		1    	A      	Function "window_ops_func"
Mouse 0		2    	A     	Function "maximize_func"
Mouse 0		4    	A     	Iconify

# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-raise,
# and Resize-or-Raise. 
# Button 1 in the corner pieces, with any modifiers, gives resize or raise
Mouse 1		FS	A	Function "Resize-or-Raise"
Mouse 2		FS	A	Function "Resize-or-Lower"
# Button 1 in the title, sides, or icon, w/ any modifiers, gives move or raise
Mouse 1		T	A	Function "Move-or-Raise"
Mouse 2		T	A	Function "Move-or-Lower"

# Button 1 in an icons gives move for a drag, de-iconify for a double-click,
# nothing for a single click
# Button 2 in an icon, w/ any modifiers, gives de-iconify

Mouse 1		I	A	Function "Move-or-Iconify"
Mouse 2		I	A	Iconify

# Button 2 in the corners, sides, or title-bar gives the window ops menu
Mouse 2		FST	A	Function "window_ops_func"
# Button 3 anywhere in the decoration (except the title-bar buttons)
# does a raise-lower
Mouse 3		TSIF	A	RaiseLower

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm
Mouse 3         W       M       RaiseLower

################## FvwmButtons button-bar ################################
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #908090

# Font
*FvwmButtonsFont -*-lucidatypewriter-medium-r-*-*-10-*-*-*-*-*-*-*

# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -1-1

# xterm or rxvts on remote machines can be done like this
# Output re-direction is csh style, not sh style
# You will want to substitute your own hosts here!

*FvwmButtons Luna   rterm.xpm  Exec	"Luna"  exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T Luna -n Luna -e rlogin luna.terraweb.com &
*FvwmButtons Terra   rterm.xpm  Exec	"Terra"  exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T Terra -n Terra -e rlogin terra.terraweb.com &
*FvwmButtons Mundo  rterm.xpm  Exec	"Mundo"  exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T Mundo -n Mundo -e rlogin mundo.terraweb.com & 
*FvwmButtons Caramello  rterm.xpm  Exec	"Caramello"  exec xterm -ls -sl 240 -sb -display $HOSTDISPLAY -geo 80x25 -T Caramello -n Vlad -e rlogin caramello.techapp.com & 
*FvwmButtons Xcalc   rcalc.xpm   Exec "Calculator" xcalc &
*FvwmButtons mail  mail2.xpm  Swallow "coolmail" Exec coolmail -f /var/mail/bpm -geometry 50x50 &
*FvwmButtons xclock  clock.xpm   Swallow "xclock" Exec xclock -bg \#908090 -geometry -1500-1500 -padding 0 &
*FvwmButtons(7x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 3

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -*-lucidatypewriter-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -*-lucidatypewriter-medium-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Misc
*FvwmPagerLabel 1 Vlad
*FvwmPagerLabel 2 WWW
*FvwmPagerLabel 3 Terra
*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -*-lucidatypewriter-medium-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green
	
############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
#
# mouse bindings
#
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent

#
# Key bindings
#
*FvwmIconBox            "FvwmButtons"   toolbox.xpm

-- 
Brian Millett                    
Technology Applications Inc.     "Heaven can not exist,
(314) 530-1981                          If the family is not eternal"
[email-masked]                   F. Ballard Mashburn
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].