Subject: FVWM: menu suggestion

From: [email-masked] (Todd Fries)
Date: Wed, 22 Nov 1995 17:18:02 -0600 (CST)

I don't know if it should be an optional behavior, a configurable option,
or the semantics of the implementation, I just know it would be very
useful if someone would allow a menu that currently looks like this:

 __________
|__________|
|__________|
|__________|_________
|__________|_________|
|__________|_________|
|__________|_________|
|__________|_________|
|__________|_________|
           |_________|
           |_________|
           |_________|
           |_________|
           |_________|
           |_________|
           |_________|
	    ........
	    (and forever into oblivion)
	    ........
           |_________|
           |_________|

to look like this:

 __________
|__________|
|__________|
|__________|___________________
|__________|_________|_________|
|__________|_________|_________|
|__________|_________|_________|
|__________|_________|_________|
|__________|_________|_________|
           |_________|_________|

(you get the idea)

or maybe even 3 rows, depending on 'what is appropriate'.  I don't have a
clue to suggest what is appropriate, it is just that the xlock menu of
possible modes is getting a bit too long :-)  and so I thought maybe this
could be a 'To-Do' useful feature to be added SOMEHOW.

I leave it up to you guys to decide 'how' and 'what is good'.

Have fun!

--
Todd [email-masked]
http://www.cs.umr.edu/~tfries
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Mon, 27 Nov 1995 09:06:37 -0500

>>>>> "Todd" == Todd Fries <[email-masked]> writes:

Todd> I don't know if it should be an optional behavior, a configurable option,
Todd> or the semantics of the implementation, I just know it would be very
Todd> useful if someone would allow a menu that currently looks like this:
....
Todd> to look like this:
....
Todd> (you get the idea)

Todd> or maybe even 3 rows, depending on 'what is appropriate'.  I don't have a
Todd> clue to suggest what is appropriate, it is just that the xlock menu of
Todd> possible modes is getting a bit too long :-)  and so I thought maybe this
Todd> could be a 'To-Do' useful feature to be added SOMEHOW.

Todd> I leave it up to you guys to decide 'how' and 'what is good'.

Sounds like a potentially good idea.  I've added it to the ever
growing TO-DO list, although I don't know how difficult it'd be to
implement.

Chuck