Subject: FVWM: Doing stupid things

From: "Brian E. Gallew" <[email-masked]>
Date: Thu, 2 Nov 1995 11:14:36 -0500 (EST)

I've got a setup where I have two physical displays: 0.0 and 0.1.  I would
*really* like to be able to start up different things (e.g. different versions
of FvwmButtons) depending upon which display I'm using.  I can't seem to force
either FvwmCpp or FvmwM4 to do what I want (or maybe I'm just stupid).

=====================================================================
| It's nice to be important, but it's *important* to suck up to the |
| sysadmin  -- Me                                                   |
=====================================================================
| Finger [email-masked] for my public key.                            |
=====================================================================

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 3 Nov 1995 08:56:16 GMT

> either FvwmCpp or FvmwM4 to do what I want (or maybe I'm just stupid).

Ages ago I submitted a patch to put the screen number as a constant for the
FvwmCpp program. As a result I now run fvwm using:

fvwm-pre-2.0 -f "FvwmCpp .fvwmrc2"

and in my .fvwmrc2 file I can control the position of the pager using:

#if SCREEN==1
*FvwmPagerGeometry 180x88-1+925
#else
*FvwmPagerGeometry 180x88-310+925
#endif

Seems to work for me.

-- 
Kit Smithers                    [email-masked],  [email-masked]
-------------------------------------------------------------------------------
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 3 Nov 1995 11:49:07 +0100

I'm normally starting up vuewm, but sometimes I want to switch to fvwm
on both screens. I'm doing it like this (excuse my poor style):

	#! /bin/csh
	# Kill all vuewm
	@ v = `ps -e | grep vuewm | wc -l`
	if ($v > 0) then
	  ps -e | grep vuewm | awk '{print "kill -9 " $1}' | sh
  
	  # restart fvwm2 
	  @ num = `grep dev /usr/lib/X11/X0screens | grep -v "#" | wc -l`
	  set host = `uname -n`
	  if ($num > 1) then
	    @ num--
	    while( $num > -1 )
	      set disp = $host":0.$num"
	      fvwm2 -d $disp -s -f "FvwmCpp -Cppprog /lib/cpp -Cppopt \
		-DSCREEN$num .fvwm2rc" >& /dev/null &
	      @ num --
	    end
	  else
	    fvwm2 -f "FvwmCpp -Cppprog /lib/cpp .fvwm2rc" >& /dev/null &
	  endif
	endif

and formatting my .fvwm2rc in accordance with normal cpp rules:

	#ifdef SCREEN0
	/* these options go on screen 0 */
	*FvwmButtons emacs - Exec "" exec /usr/local/bin/emacs &
	#endif

	#ifdef SCREEN1
	/* these options is for screen 1 */
	*FvwmButtons xemacs - Exec "" exec /usr/local/bin/xemacs &
	#endif

	#if !defined(SCREEN0) && !defined(SCREEN1)
	/* these options are used on a single screen configuration */
	#endif

Best Regards,

Mats Nilsson

-- 
Mats Nilsson 		   Mailing address:	Visiting address:
ELEKTA INSTRUMENT AB	   P.O. Box 7593	Birger Jarlsgatan 53
Tel: +46-8-4025518	   S-103 93 Stockholm	Tel: +46-8-402 5400
Email: [email-masked]	   Sweden		Fax: +46-8-402 5500
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].