Subject: Re: FVWM: Re: blanking screen for a long time

From: Lars Wirzenius <[email-masked]>
Date: Wed, 8 Nov 1995 12:05:53 +0200

Robert Nation:
> Note that, if people find that the black intro screen is slowing things
> down, 

I don't know if it slows things down (it only takes a couple of seconds
on my machine, at the worst), but the black screen is bad from a user
interface point of view, since it scares people.  I think the idea of
hiding out the windows popping up and down and losing and getting borders
is a good one, for the ordinary user if not the debugger.  How about instead
of completely blacking out the screen, fvwm puts up a small info window:

	-----------------------
	|                     |
	|  Restarting Fvwm    |
	|                     |
	|  Please hold...     |
	|                     |
	-----------------------

Nicely centered and so on, of course.

Naturally, making it possible to configure the window manager and modules
without restarting would be even nicer... :-)

-- 
Lars Wirzenius <[email-masked]> <[email-masked]>
MIME and PGP mail welcome.  Key: finger @kruuna, or check keyservers.
Publib 0.5: ftp://ftp.cs.helsinki.fi/pub/Software/Local/Publib/
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Todd Fries <[email-masked]>
Date: Wed, 8 Nov 1995 07:07:46 -0600 (CST)

> without restarting would be even nicer... :-)

'FvwmTalk' is the 'manual' implementation of this; however, I've also
split my .fvwmrc into several files:

$ls -l ~/.fvwmrc
lrwxrwxrwx   1 tfries   Coders         12 Oct 11 08:16 /home/todd/.fvwmrc -> ./.
fvwm/fvwm
$ls -l ~/.fvwm
total 46
lrwxrwxrwx   1 tfries   users           7 Nov  4 14:59 fvwm -> ./fvwm2
-rw-r--r--   1 tfries   users        1384 Nov  8 06:52 fvwm-funcs
-rw-r--r--   1 tfries   users        1595 Nov  5 07:01 fvwm-keys
-rw-r--r--   1 tfries   users        8647 Nov  5 16:14 fvwm-menus
-rw-r--r--   1 tfries   users        4154 Nov  5 07:50 fvwm-modules
-rw-r--r--   1 tfries   users        1788 Nov  5 07:00 fvwm-mouse
-rw-r--r--   1 tfries   users         105 Nov  4 15:10 fvwm-paths
-rw-r--r--   1 tfries   users        1794 Nov  7 23:29 fvwm-style
-rw-r--r--   1 tfries   users         764 Nov  5 08:26 fvwm2

$cat fvwm2
Read "/home/todd/.fvwm/fvwm-paths"
Read "/home/todd/.fvwm/fvwm-style"
Read "/home/todd/.fvwm/fvwm-funcs"
Read "/home/todd/.fvwm/fvwm-menus"
#############################################################################
# One more complex function - couldn't be defined earlier because it used
# pop-up menus
#
# This creates a motif-ish sticky menu for the title-bar window-ops
# pop-up
# Menu acts like normal twm menu if you just hold the button down,
# but if you click instead, the menu stays up, motif style
AddToFunc "window_ops_func" "C" PopUp Window Ops2
+              "M" PopUp Window Ops2
AddToFunc "Close"
+ "C" Delete
+ "D" Destroy

Read "/home/todd/.fvwm/fvwm-mouse"
Read "/home/todd/.fvwm/fvwm-keys"
Read "/home/todd/.fvwm/fvwm-modules"

And then the following 'PopUp Menu' works wonders:

AddToMenu ReReadIt "*fvwm.xpm*" Title
+ "&Key bindings" Read /home/todd/.fvwm/fvwm-keys
+ "&Mouse bindings" Read /home/todd/.fvwm/fvwm-mouse
+ "M&odules" Read /home/todd/.fvwm/fvwm-modules
+ "&Paths" Read /home/todd/.fvwm/fvwm-paths
+ "&Styles" Read /home/todd/.fvwm/fvwm-style

Note I've not taken the time to setup something that will re-read
the fvwm-menus; that would require putting this 'ReReadit' function in most
likely 'fvwm2' and also the menu this is called from...or maybe I could bind it
to a goodstuff button...hrm..

-- 
<a href=mailto:[email-masked]>Todd T. Fries</a>
<a href=http://www.cs.umr.edu/~tfries/>My Homepage!</a>
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jeff S. Elam <[email-masked]>
Date: Wed, 8 Nov 1995 08:11:44 -0800 (PST)

> of completely blacking out the screen, fvwm puts up a small info window:

Please hold what?  ;-)

-Jeff E.

---

From: Kai Grossjohann <[email-masked]>
Date: Thu, 9 Nov 95 10:40:15 +0100

>>>>> "Lars" == Lars Wirzenius <[email-masked]> writes:

  Lars> How about instead of completely blacking out the screen, fvwm
  Lars> puts up a small info window:

How do you all like the ctwm way of doing this?  It uses a graphic.

        \kai{}
--
~/.signature

---

From: Dave Nelson <[email-masked]>
Date: Thu, 09 Nov 1995 04:55:23 -0600

>How do you all like the ctwm way of doing this?  It uses a graphic.

	I hate it.  I don't like fvwm's current black screen either.
I really wish there was a way to turn that off.

/dcn

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 9 Nov 1995 13:18:05 -0500

>>>>> "Dave" == Dave Nelson <[email-masked]> writes:

>> How do you all like the ctwm way of doing this?  It uses a graphic.

Dave>   I hate it.  I don't like fvwm's current black screen either.
Dave> I really wish there was a way to turn that off.

Well, you might get your wish for the next patchlevel...

Chuck