Subject: FVWM: XPaint and Shape?

From: [email-masked] (Gail Mara Gurman)
Date: Tue, 10 Oct 1995 15:39:35 -0700 (PDT)

How can I, in xpaint, make a pixmap with no background so that fvwm uses
its shape?

Gail
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eli Burke <[email-masked]>
Date: Wed, 11 Oct 1995 10:41:16 -0400 (EDT)

> How can I, in xpaint, make a pixmap with no background so that fvwm uses

	Well, this is a rather convoluted way to do it, but I don't know
off the top of my head of any better way. 
	1. Create your pixmap, and set the background to all one color.
	   Save it as a pixmap, and then pull up the .xpm file in your
	   favorite editor. (don't worry, it is a text file)
	2. scroll down to the picture part (the top of the file is a list
	   of the colors and what character equals what color) and look
	   at it to determine what ascii character is your background color
	3. go to the top of the file, and find the character that is your
	   background character. change the two colors on the line to "none"

I've included a fragment of an xpm file below-- my "transparent" character
is the space " " and the line for it reads "  m none c none",
If your background character were "." then you'd make it ". m none c none",

/* XPM2 C */
static char ** nuke.xpm  = {
"32 32 11 1",
"   m none  c none",
".  m black  c #000000000000",
"X  m black  c #373837",
"                                ",
"              ........          ",
"          ....XXXXoooo..        ",
"       ..XXXXXXXXXXXXOOo.       ",

I hope that was reasonably clear.. if not, send me email and I'll try to
explain it a little bit better.

-- 
Eli Burke
[email-masked] 
http://csugrad.cs.vt.edu/~eburke/ 
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Tuan Hoang)
Date: Wed, 11 Oct 95 10:57:52 -0500

I found that you can use the program "pixmap" to reedit your bitmap
and paint over the background with the clear color button. Better yet just 
use pixmap to draw your icon. I'm not sure where to get it 'cause it
was already available on my system.

regards,

On Wed, 11 Oct 1995 10:41:16 -0400 (EDT) Eli Burke  wrote:

> Date: Wed, 11 Oct 1995 10:41:16 -0400 (EDT)
> From: Eli Burke <[email-masked]>
> Cc: [email-masked]
> Priority: non-urgent
> Precedence: bulk
> X-Majordomo: 1.92
> 

Tuan Hoang												  
-------------------------------------------------------------------------
Strategic Semiconductor Operation
Austin Design Centre
Paging Products Group

TEL:   512-891-2484                          Motorola                     
FAX:   512-891-8631                          6501 William Cannon Dr. West 
email: [email-masked]          Mail Drop OE22               
or     [email-masked]              Austin, Texas 78735-8598     
-------------------------------------------------------------------------