Subject: FVWM: Re: Release 2.1

From: [email-masked]
Date: Wed, 18 Oct 95 10:16:38 +0100

Thanks god, there is anybody alive!
So my congratulation to make a new
distribution release, i've been waiting a long time for.

So here my ideas for the Fvwm 3.0 Release:

        - seperate the Window Border and Menue Outline, 
	  to get the bowman direction back and to make 
	  it much easier to make a new outline (Lost95)

	- add drag&drop to root window and modules
	  ,especialy FvwmButton, with Motif Compatibility
	  I hope that the lesstif people will make a library,
	  so that having a drop target in fvwm will not
	  require Motif.
          An other way to integrate drag&drop is to use the 
          rdd library.
          
	- DrawOut Module, an evolutionary step of the 
	  FvwmButton Module,  to save screen space
	
	- RollOut Module, nearly the same as DrawOut
	
	- FvwmCosy Module for having an Cosy like
	  enhanced interface:
	  in the middle you select with the button the
	  desired Desk or can toggle to see the Pager of the 
	  Desk

	- FvwmClippbord Module, (part of FvwmCosy) where to
          drag images out of the web browser, switch the
          desk to another application and take it from the 
          clippboard

        - Make a Fvwm-library, that every application using
          this will easy be able to use Fvwm features.
        
        - Support Session Management through Fvwm library 

I think these steps will make the Fvwm more than only a
Window Manager. So let's talk about the next release, now

		Gruss
			
			Kay

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Andrew Cosgriff)
Date: Thu, 19 Oct 1995 09:18:50 +1000

I think it's about time we decided on what the F in FVWM stands for, since
it's been in doubt ever since fvwm 0.9 something, when it was no longer
considered "feeble" :)

Andrew.

---

From: "Giao H. Phan" <[email-masked]>
Date: Thu, 19 Oct 1995 02:37:42 -0400

> it's been in doubt ever since fvwm 0.9 something, when it was no longer
We could always lame out and use the recursize approach.
FVWM's Virtual Window Manager

---

From: NoRM <[email-masked]>
Date: Thu, 19 Oct 1995 08:55:56 +0100 (BST)

> Window Manager. So let's talk about the next release, now

I don't have any real ground-breaking ideas myself, right now, but one 
feature I would like to see in fvwm is pie menus.

For more information visit Don Hopkins' discussion at:
http://www.kaleida.com/u/hopkins/piemenu/piemenus.html

Norman R. McBride                            http://www.city.ac.uk/~sk385/
Computing Services, City University, England        [email-masked] (MIME)

"...the extreme case best illustrates the norm..."            Stephen King
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: BENJAMIN THOMAS KETTERIDGE <[email-masked]>
Date: Thu, 19 Oct 1995 09:27:14 +0100

>it's been in doubt ever since fvwm 0.9 something, when it was no longer
Every time this comes up, I suggest Flexible - it seems to suit fvwm quite
well because of its strengths in user configuration and modularity.

Ben.

| URL=http://www.dcs.aber.ac.uk/~btk/ | email=[email-masked] | _|--|_   o   |
+-------------------------------------+----------------------+  (\/)  +---+ |
|  Tel: (01970) 622403 [Int: 2403]    |  or: (01970) 627842  |   vv    / \  |
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Sverre H. Huseby" <[email-masked]>
Date: Thu, 19 Oct 1995 10:08:15 +0100

[Andrew Cosgriff]

|   I think it's about time we decided on what the F in FVWM stands
|   for, since it's been in doubt ever since fvwm 0.9 something, when
|   it was no longer considered "feeble" :)

I think tradition sais it's unknown, so it should be left that
way. Anyway, a cool Unix program should have something weird about its
name. An unknown name is rather weird, so fvwm is a cool
program. (Yeah, bad logic, I know...)

Sverre.

-- 
finger [email-masked]
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Peter Funk <[email-masked]>
Date: Thu, 19 Oct 1995 10:42:26 +0100 (MEZ)

Andrew Cosgriff:
ac> I think it's about time we decided on what the F in FVWM stands for, since
ac> it's been in doubt ever since fvwm 0.9 something, when it was no longer
ac> considered "feeble" :)

Giao H. Phan:
gp> We could always lame out and use the recursize approach.
gp> FVWM's Virtual Window Manager

I've had a look into my english dictionary and stumbled over the
many adjectives starting with 'f':
   'featureless', 'fiddly', 'fiery', 'flaky', 'flawless', 
   'flashy', 'flexible', foamy', 'foolproof', 'forwardlooking', 
   'fragile', 'frail' ...
Since there are so many choices it is very hard to decide.  

I would prefer a positive adjective like 'final' or 'free'.
May be it should be left open as it is.

Regards, Peter
-=-=-
Peter Funk, Oldenburger Str.86, D-27777 Ganderkesee, Germany
office: +49 421 2041925 (ArtCom GmbH, Grazer Str.8, D-28359 Bremen)
echo '[q]sa[ln0=aln256%Pln256/snlbx]sb3135071790101768542287578439snlbxq'|dc
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 19 Oct 1995 15:47:41 -0400

>>>>> "Peter" == Peter Funk <[email-masked]> writes:

Peter> Since there are so many choices it is very hard to decide.

Peter> I would prefer a positive adjective like 'final' or 'free'.
Peter> May be it should be left open as it is.

I think that would be best.  The FVWM now stands for "_Fill in the
blank with whatever F word you like best _Virtual _Window _Manager" :)

Chuck

---

From: [email-masked] (Gail Mara Gurman)
Date: Thu, 19 Oct 1995 13:36:51 -0700 (PDT)

> blank with whatever F word you like best _Virtual _Window _Manager" :)

I agree. Personally, I find that the F word varies depending on whether I'm
enjoying the features of fvwm or cursing the bugs.

Gail

---

From: "Randall S. Winchester" <[email-masked]>
Date: Thu, 19 Oct 1995 17:15:16 -0400 (EDT)

I am glad that Chuck spoke up first with this as I am sure many of us feel,
or were quietly mumbling to our selfs, that any old F word will do.

Randall

---

From: Andy (Flognat) Eskilsson <[email-masked]>
Date: 20 Oct 1995 03:13:10 +0100

Why not just call it "THE `F' word.." (It's 10 o'clock and do you know
what windowmanager your children are using?)

	/andy

---

From: tim werner <[email-masked]>
Date: Fri, 20 Oct 1995 06:34:49 -0400

>it's been in doubt ever since fvwm 0.9 something, when it was no longer

I've always assumed it should stand for "free".  But, since that is so
obvious, and since no one ever suggests that, it must stand for
something else very specific, no?

---

From: Charles Durst <[email-masked]>
Date: Mon, 23 Oct 1995 23:53:41 -0400

> it's been in doubt ever since fvwm 0.9 something, when it was no longer

My 3 cents ...

I think the GNU recursive-acronym joke is getting a little tired.

I agree with the folks who don't feel the need to make it stand for
anything.

How about actively making it stand for nothing?

If we can have an "X" window system, or a "C" programming language, why
not an "F" Virtual Window Manager?

--
			      .-------------------------------------.
Charles Durst                 |  Email: [email-masked]        |
			      `-------------------------------------'
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alan Wild <[email-masked]>
Date: Tue, 24 Oct 1995 18:32:42 -0400 (EDT)

> not an "F" Virtual Window Manager?

This is off topic, but I gotta say it.  "C"'s name was derived from the name
of it's two predecccor languages, "BCPL" and "B".  

As far as FVWM is concerned.  Let's just not worry about it.  It's cool like
it is.

-Alan

-- 

-*-Alan Wild "Speed News Guy" WWW:http://www.spd.louisville.edu/~arwild01/-*-
VM:[email-masked] E-mail:[email-masked]
*thissignaturewaswrittentosavebandwidth.ifyoucanreadthisyouneedtoseeaneyedr.*