Subject: FVWM: Re: For your approval...pl37

From: Timothy Demarest (ITD) <[email-masked]>
Date: Sat, 07 Oct 1995 10:54:55 +0900

On Fri, 06 Oct 1995 17:30:16 -0400  Charles Hines wrote:

  > think the first official release will be called 2.1.  Also, I'd like
  > to go to the following scheme for versions:
  > 
  >                           FVWM Version M.I.P
  > 
  > Where M is the Major version number (HUGE changes)
  >       I is the Minor version number (Significant changes)
  >       P is the patchlevel           (Patches/Small changes)
  > 
  > So the first release will be 2.1.0.
  > 
  > Or should we stick with the letter convention from 1.xx?  I suppose it
  > doesn't matter, eh?
  > 
  > Chuck

Chuck:

PLEASE go with the M.I.P format for the version!  I personally *hate*
using a letter in the version number.

My 2 en...

Timothy Demarest            Radiation Effects Research Foundation (RERF)
[email-masked]         Department of Information Technology
CIS: 100212,562             5-2 Hijiyama Park, Minami-ku Hiroshima 732, Japan
[\+] Support DAN!           http://www.rerf.or.jp/~demarest/NewChiba.html

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thanh Ma <[email-masked]>
Date: Sat, 7 Oct 1995 12:17:00 -0400 (EDT)

Please incoporate the below in makefile.h for i386SVR4Architecture.
This is on UnixWare. 

Thanks.

Thanh Ma
[email-masked]

...
#ifdef i386SVR4Architecture
LOCAL_LIBRARIES = XPM_LIBRARIES $(XLIB) -lnsl -lsocket -L$(FVWM_SRCDIR)/libs -l$(LIB)
#else
LOCAL_LIBRARIES = XPM_LIBRARIES $(XLIB) $(FVWM_SRCDIR)/libs/lib$(LIB).a 
#endif /* i386SVR4Architecture */
#endif /* HPArchitecture */
#endif /* SunArchitecture && OSMajorVersion > 5 */
#endif /* AlphaArchitecture */
...
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Mon, 9 Oct 1995 09:18:12 -0400

>>>>> "Thanh" == Thanh Ma <[email-masked]> writes:

Thanh> Please incoporate the below in makefile.h for i386SVR4Architecture.
Thanh> This is on UnixWare.

I'll add that for the next release.

Chuck

*******************************************************************************
Charles K. Hines
IBM Logic Synthesis developer [BooleDozer (TM)]
and Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

Internet e-mail:     [email-masked]

IBM Internal e-mail: [email-masked]   (preferred from workstation)
                     HINESC at FISHKILL       (preferred from mainframe)
                     HINESC at FSHVMFK1       (discouraged, but I'll get it)

*******************************************************************************
 "dis ting could have possabiwities if I put my twisted widdle mind to it!"
                                                        - Bugs Bunny

 "I have a paper plate in my head because they were all out of the metal ones"
                                                        - Rick Overton
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 10 Oct 1995 23:10:45 +0900

Well, no-window-name/no-icon-name/no-class patch which is applied to
pl34 is too buggy (I think this code is not tested:), and should go away
(But, I do not think this patch's policy is bad).

chuck_hines> pl 36 to 37
chuck_hines>        1. Fixed coredump due to incomplete backout of NoName/NoClass patch

I doubt this fixes is done:)

In HandlePropertyNotify(), code says:

      if (!XGetWMName(dpy, Tmp_win->w, &text_prop))
        return;
      free_window_names (Tmp_win, True, False);
      Tmp_win->name = (char *)text_prop.value;

In fact, XGetWMName() simply calls XGetTextProperty. Let us see
XGetTextProperty(3X) manuals.

	If the specified property does not exist on the window,
	XGetTextProperty sets the value field to NULL,...

So, text_prop.value may be NULL. In old ways, If property is NULL,
property turns to be NoName (yes, this is the internal constant value).
But now, it seems that fvwm allows to set Tmp_win->name to NULL. I
think this is the policy change of fvwm, and that's o.k.

But, free_window_names() does not consider this fact. see misc.c:

      if (tmp->name != tmp->icon_name && tmp->name != NoName)
        XFree (tmp->name);
      tmp->name = NULL;

WOW! we are going to XFree(NULL) :-)

I hope fvwm's iconname/windowname handling is fixed before 2.1 release.

***

If you, all the patch maker, want to release patch, please check your
code does not have a bug, or say "I have not tested" :-)

- -
Makoto 'MAR_kun' MATSUSHITA
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Gerhard den Hollander <[email-masked]>
Date: Mon, 16 Oct 1995 11:14:57 +0100 (MET)

Hoi Charles Hines:

> Ok, pl37 is at ftp.hpc.uh.edu:

> pl 36 to 37
>        1. Fixed coredump due to incomplete backout of NoName/NoClass patch
>        2. Fix for multiple env var expansion core dump from Sverre H. Huseby
>        3. Small doc fixes (spelling, etc)
>        4. Imakefile/configure.h enhancements from Randall S. Winchester
>        5. Updated system.fvwmrc (FvwmIconBox changes from Nobutaka Suzuki)

> If there aren't any big things wrong with it now, which I really hope
> there aren't, I imagine that the next release will be the first official
> one.  Since everyone is already referring to the current one as 2.0, I

> Or should we stick with the letter convention from 1.xx?  I suppose it

I prefer the M.I.P version

	Gerhard,  <@jason.nl>   == The Acoustic Motorbiker ==
 --
   __O	Mounting a horse can often be fun
 =`\<,  An elephant too; though he weighs half a ton
(=)/(=) Even a mouse (though his hole is quite small)
        But the hedgehog can never be buggered at all.