Subject: FVWM: HELP COMPILE FVWM 2.xxxs

From: [email-masked]
Date: Fri, 20 Oct 1995 14:20:19 +0100 (BST)

PLEASE  COULD YOU HELP ME COMPILE FVWM version 2.0.38
I GET THE FOLLWING ERROR

----------------------------------------------------------------------
>>jh110@shoshone 126 % ls
BUGS            MakeMakefiles*  documentation/  makefile.h      xpmroot/
ChangeLog       Makefile        fvwm/           modules/
FAQ             README          fvwm-2.xx.lsm   sample.fvwmrc/
INSTALL         TO-DO           fvwm_icons/     utils/
Imakefile       configure.h     libs/           version.h
>>jh110@shoshone 127 % make
making all in ./libs...
making all in ./fvwm...
rm -f fvwm2
cc -o fvwm2 add_window.o  bindings.o  borders.o  builtins.o  colormaps.o  colors.o  complex.o  decorations.o  events.o  focus.o  functions.o  fvwm.o  icons.o  menus.o  misc.o  module.o  move.o  placement.o  read.o  resize.o  style.o  virtual.o  windows.o -O -xF -DSYSV -DSVR4 -xF -Wa,-cg92   -L/usr/openwin/lib -L/pkg/xpm-3.4c -lXpm -lXext -lX11 ../libs/libfvwm2.a  -lsocket -lnsl 
ld: fatal: library -lXpm: not found
ld: fatal: File processing errors.  No output written to fvwm2
*** Error code 1
make: Fatal error: Command failed for target `fvwm2'
Current working directory /home/jh110/wm/fvwm/fvwm
*** Error code 1
make: Fatal error: Command failed for target `all'

-------------------------
CONTENT OF configure.h
-------------------------

#define XPM

#ifdef XPM
#define XPM_LIBRARIES   -L/pkg/xpm-3.4c -lXpm
/* #define XPM_INCLUDES -I/usr/local/bind/include */
#endif

-------------------------------------------------------

 HERE IS MY XPM  LOCATION

-------------------------------------------------------

>>jh110@shoshone 113 %  cd /pkg/xpm-3.4c/lib
/pkg/xpm-3.4c/lib
>>jh110@shoshone 114 % ls
libXpm.a        libXpm.so       libXpm.so.4.3
>>jh110@shoshone 115 % ls
libXpm.a        libXpm.so       libXpm.so.4.3
>>jh110@shoshone 116 % cd ..
/pkg/xpm-3.4c
>>jh110@shoshone 117 % ls
Iconf     bin/      include/  lib/      man/

--------------------------------------------------------

I TRIED TO SPECIFY WHERE  libXpm WAS AS BELOW BEFORE COMPILING BUT NO SUCCESS
--------------------------------------------------------

>>jh110@shoshone 120 %  -L/pkg/xpm-3.4c -lXpm

--------------------------------------------------------

ENVIRONMENT solaries 2.3  UNIX

THANKS IN ADVANCE

[email-masked]

HILARY JUMA
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randall S. Winchester" <[email-masked]>
Date: Fri, 20 Oct 1995 14:29:52 -0400 (EDT)

Change;
#define XPM_LIBRARIES   -L/pkg/xpm-3.4c -lXpm
To:
#define XPM_LIBRARIES   -L/pkg/xpm-3.4c/lib  -lXpm

Do not forget to rerun MakeMakefiles.
Randall