Subject: FVWM: Re: pl36 ready, willing, and able

From: [email-masked] (Gail Mara Gurman)
Date: Tue, 3 Oct 1995 14:37:55 -0700 (PDT)

I just ftp'd pl36. I haven't compiled it yet, but I noticed something that I
noticed in previous versions and forgot about. Throughout the FAQ and 
fvwm.man (may be in other places, but I didn't check), the word "quote" is
spelled "qoute". This is true for "quoting" and other variations. If this is
a typo, it's a pretty consistent one.

Gail
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Gail Mara Gurman)
Date: Tue, 3 Oct 1995 16:22:01 -0700 (PDT)

>        4. Small changes to configure.h defaults, plus added XPMINCLUDE
>           and FVWM_MAN_DIR

XPMINCLUDE is still not getting into the Makefiles. As a result, even though
I set XPMINCLUDE to "/work/include", I get a lot of stuff like this from
MakeMakefiles:

makedepend:  icons.c: makedepend:  cannot find include file "X11/xpm.h"
makedepend:  	not in X11/xpm.h
makedepend:  	not in ./X11/xpm.h
makedepend:  	not in /usr/openwin/include/X11/xpm.h
makedepend:  	not in /usr/include/X11/xpm.h
makedepend:  cannot open "X11/xpm.h"

---

From: [email-masked] (Gail Mara Gurman)
Date: Tue, 3 Oct 1995 16:32:07 -0700 (PDT)

I just realized *why* XPMINCLUDE isn't getting used. Actually, it is, but
not properly.

This is from fvwm/Imakefile:

EXTRA_INCLUDES = -I. $(XPMINCLUDE)

This should be:

EXTRA_INCLUDES = -I. XPMINCLUDE

Easy to fix. :)

Gail

---

From: Thanh Ma <[email-masked]>
Date: Wed, 4 Oct 1995 16:40:13 -0400 (EDT)

Hi,

1) I prefer a shorter filename like: fvwm-2.0b-pl36.tar.gz
2) Trying to compile it under UnixWare 2.0 and got the below warnings
   wherever MWMBorders is referenced:
UX:acomp: WARNING: "borders.c", line ... : integer overflow detected: op "<<"

   I changed fvwm.h from:
#define MWMBorders              (1<<31)
   to
#define MWMBorders              ((unsigned int)1<<31)

to get rig of the warmings.

3) gethostbyname is used by FvwmCpp and FvwmM4. The Imakefiles however
   do not have -lsocket defined. So I added:
LOCAL_LIBRARIES = $(XLIB) -L../../libs -lfvwmlib     -lsocket

4) FvwmButtons.c: line 459 (return;). Would this statement ever be reachable ?
5) FvwmGrabWindow.c: line 631 (return;). Would this statement ever be reachable ?
6) FvwmTalk/FvwmTalk.c: line 446: changed
                              &nitems, &bytes_aft
   to:
            (unsigned long *) &nitems, (unsigned long *) &bytes_aft

Now, if we could remove the 'return' from 4) and 5). Then I have 100% clean
compilation. That is NO WARNINGS.

Thanh Ma
[email-masked]

---

From: Thanh Ma <[email-masked]>
Date: Wed, 4 Oct 1995 16:59:56 -0400 (EDT)

should not

.IP  HilightColor \fitextcolor backgroundcolor\fP
    -               -                            -
    ^               ^                            ^
be 

.IP "HilightColor \fItextcolor backgroundcolor\fP"

Thanh