Subject: FVWM: pl36 Restart

From: Karl Eichwalder <[email-masked]>
Date: Wed, 4 Oct 95 14:12 MET

%n fvwm
%v pre-2.0-patchlevel-36
%c GCC 2.6.3, GNU Emacs 19.29
%l kernel >= 1.2.13, libc 4.6.27, XFree 3.1.2

The Restart module refuses to restart fvwm2; it relys on fvwm.

Karl.
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 5 Oct 1995 09:31:33 -0400

>>>>> "Karl" == Karl Eichwalder <[email-masked]> writes:

Karl> %n fvwm
Karl> %v pre-2.0-patchlevel-36
Karl> %c GCC 2.6.3, GNU Emacs 19.29
Karl> %l kernel >= 1.2.13, libc 4.6.27, XFree 3.1.2

Karl> The Restart module refuses to restart fvwm2; it relys on fvwm.

Really?  I've used the following all along with no problems:

AddToMenu Quit-Verify   "Really Quit Fvwm?" Title
+                       "Yes, Really Quit"  Quit
+                       "Restart Fvwm2"     Restart fvwm2
+                       "Restart Fvwm"      Restart fvwm
+                       "Start ctwm"        Restart ctwm
+                       "Start twm"         Restart twm
+                       "Start mwm"         Restart mwm
+                       "Start dummy"       Restart xterm
+                       ""                  Nop
+                       "No, Don't Quit"    Nop

I believe that the restart code does have some small bugs though.
I'll see what I can find.

Chuck

*******************************************************************************
Charles K. Hines
IBM Logic Synthesis developer [BooleDozer (TM)]
and Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

Internet e-mail:     [email-masked]

IBM Internal e-mail: [email-masked]   (preferred from workstation)
                     HINESC at FISHKILL       (preferred from mainframe)
                     HINESC at FSHVMFK1       (discouraged, but I'll get it)

*******************************************************************************
 "dis ting could have possabiwities if I put my twisted widdle mind to it!"
                                                        - Bugs Bunny

 "I have a paper plate in my head because they were all out of the metal ones"
                                                        - Rick Overton
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Karl Eichwalder <[email-masked]>
Date: Thu, 5 Oct 95 19:12 MET

>>>>> "Charles" == Charles Hines <[email-masked]> writes:
 
    Charles> + "Restart Fvwm2" Restart fvwm2

This line was missing (it was an oversight by me); and after eleminating
another M4-ooops "Restart fvwm2" now works.  Karl.