Subject: Re: FVWM: AutoRaise

From: Jeff S. Elam <[email-masked]>
Date: Mon, 16 Oct 1995 09:25:37 -0700 (PDT)

Forwarded message:
> 
> Jose M. Pereira writes:
>  > -----BEGIN PGP SIGNED MESSAGE-----
>  > 
>  > "MS" == Mark Scott <[email-masked]> writes:
>  > 
>  >   MS> I use the AutoRaise feature of FVWM (with a time delay of course....) &
>  >   MS> have noticed that very, very often when using Motif applications, if I'm
>  >   MS> not very deliberate when dragging down an application pulldown menu,
>  >   MS> FVWM often raises the application main window "in front" of the pulldown
>  >   MS> menu. The FVWM pull down menus are always fine. I'm not being
>  > 
>  > If you look at the code of FvwmAuto (which works the same way as the AutoRaise
>  > feature of 1.24), this is what is expected, I'm afraid. "very deliberate when
>  > dragging", in more technical terms, means "change focus to the menu before the
>  > autoraise timeout expires".
> 
> I've noticed the problem when I wasn't running FvwmAuto.  Am I just
> hallucinating, or is the problem in the core fvwm code?
> 
> -Elan
> 

Yes, I see this problem on any window with the "StaysOnTop" Style.  Any
pulldown menu in a "StaysOnTop" window has to be clicked on TWICE to get the
menu to stay on top.

I'm using 2.0pl35 and I don't use FvwmAuto.

-Jeff E.

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jose M. Pereira <[email-masked]>
Date: Mon, 16 Oct 95 19:22:12 +0100

"Jeff" == Jeff S Elam <[email-masked]> writes:
In article <[email-masked]> Jeff S. Elam
<[email-masked]> writes:

  Jeff> Yes, I see this problem on any window with the "StaysOnTop" Style. Any
  Jeff> pulldown menu in a "StaysOnTop" window has to be clicked on TWICE to
  Jeff> get the menu to stay on top.

  Jeff> I'm using 2.0pl35 and I don't use FvwmAuto.

Of course, I forgot that! "StaysOnTop" is a thinly disguised "autoraise"
feature. It means:

 'after any window config. change (desktop change, paging, new window, raise,
etc...), send this window a "Raise" command'

That's why you need that 2nd click...
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].