Subject: FVWM: Circulate, Skips and good ol Warp Rings

From: [email-masked] (Jon Mountjoy)
Date: Mon, 9 Oct 1995 20:54:45 +0100 (MET)

Hello,

Anybody out there remember Warp Rings?  

I have been playing around with the Next and Prev (pathlevel 37),
trying to coax FVWM into allowing me to push a button
and have it move the cursor to the next window on the current
screen.  And of course, I want to move back as well.

However, the Next/Prev seem to move to the windows in
creation order.  I want it just to circulate between
those currently visible on my little portion of the virtual map.

Is this possible?  Has anybody got any ideas?  Of course, the Warp
Ring behaviour was even better.  (One could dynamically configure
which windows were to be in a ring, and then warp between them)

Thanks,
Jon
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dave Goldberg <[email-masked]>
Date: Mon, 09 Oct 1995 16:42:51 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> Jon Mountjoy writes:
	> [...] I want it just to circulate between those currently
	> visible on my little portion of the virtual map.

	> Is this possible?  Has anybody got any ideas?  Of course,
	> the Warp Ring behaviour was even better.  (One could
	> dynamically configure which windows were to be in a ring,
	> and then warp between them)

Here's how I get Next and Prev to move between only those windows on
the current page, and some other examples you may find useful:

# non-iconified windows on the current page of the current desk
Key Next A 2 Next [!iconic CurrentScreen CurrentDesk] Focus
Key Prior A 2 Prev [!iconic CurrentScreen CurrentDesk] Focus

# non-iconified windows on the current desk
Key Next A 2M Next [!iconic CurrentDesk] Focus
Key Prior A 2M Prev [!iconic CurrentDesk] Focus

# non-iconified windows
Key Next A 2C Next [!iconic] Focus
Key Prior A 2C Prev [!iconic] Focus

# any window or icon on the current page of the current desk,
# including those otherwise skipped
Key Next A MC Next [CurrentScreen CurrentDesk CirculateHit] Focus
Key Prior A MC Prev [CurrentScreen CurrentDesk CirculateHit] Focus

# any window or icon on the current desk including those otherwise
# skipped
Key Next A 2MC Next [CurrentDesk CirculateHit] Focus
Key Prior A 2MC Prev [CurrentDesk CirculateHit] Focus

# any window or icon including those otherwise skipped
Key Next A MCS Next [CirculateHit *] Focus
Key Prior A MCS Prev [CirculateHit *] Focus

I agree that a warp ring is better, though there'd have to be some way
to set up the ring on the fly to make it worthwhile.  Just about
anything you could hardcode into a ring can be handled with the
current behavior of Next and Prev.

Dave Goldberg
Post: The Mitre Corporation MS B020 202 Burlington Rd. Bedford, MA 01730
Phone: 617-271-3887
Domain: [email-masked]  UUCP: {your neighborhood}!linus!mdf!dsg