Subject: FVWM: fvwm 2.0 pl 38

From: "Stephen P. Hill" <[email-masked]>
Date: Fri, 27 Oct 1995 16:07:14 -0500

A question:

How can I make a menu appear on a GoodStuff/FvwmButtons menu 
button AND have different menus for each mouse button?  I have 
the following already:

	*FvwmButtons Telnets whatever   Popup "Telnets"

but I want one menu for left-button, another for middle, and 
Telnets for right.  Is it possible?

I didn't see it in the docs but I seem to remember someone 
talking about it before.

-----
Stephen P. Hill
[email-masked]
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jim Nicholson <[email-masked]>
Date: Fri, 27 Oct 1995 22:08:22 -0400 (EDT)

> Telnets for right.  Is it possible?

Along those same lines, I've been wondering about something: can 
GoodStuff/FvwmButtons be configured so that a button BOTH swallows an app 
at startup _AND_ launches a different app when clicked?

- Jim

---

From: [email-masked]
Date: Mon, 30 Oct 1995 08:09:36 GMT

> Date: Fri, 27 Oct 1995 22:08:22 -0400 (EDT)
> From: Jim Nicholson <[email-masked]>
> Sender: [email-masked]
> Mime-Version: 1.0
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> Content-Transfer-Encoding: 7BIT
> Priority: non-urgent
> Precedence: bulk
> X-Majordomo: 1.92
> 

I dont know about the fvwmbuttons stuff but I have different actions
bound for each mouse button to the title bar buttons. Or at least I
have two different actions thus:

Mouse 1         3       A     	Close
Mouse 2         3       A     	Menu Window-Ops2 Close
Mouse 3         3       A     	Menu Window-Ops2 Close

Note that this works on title bar button 3, which for historical reasons is my
default top left button.

-- 
Kit Smithers                     [email-masked], [email-masked]
-------------------------------------------------------------------------------
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jim Nicholson <[email-masked]>
Date: Tue, 31 Oct 1995 21:43:06 -0500 (EST)

> Note that this works on title bar button 3, which for historical reasons is my

What I want is for GoodStuff/FvwmButtons to swallow one app, but launch 
another on click.

For example, I can have GoodStuff swallow "coolmail", an xbiff. When I 
click on the swallowed "coolmail", it (coolmail) launches my mail reader. 
Unfortunately, not every swallowable program has this kind of behavior. 
I'd like to have GoodStuff _not_ pass the click events to the swallowed 
program, but rather interpret them itself.

What I want is to take an application like "xdaliclock" that's been 
swallowed, and have GoodStuff launch ANOTHER app (maybe plan or 
xcalendar) when I click the button.

- Jim