Subject: FVWM: FvwmCpp

From: [email-masked] (Gail Mara Gurman)
Date: Thu, 12 Oct 1995 09:49:51 -0700 (PDT)

Okay, I just looked at the man page (I know, I should have done that before
writing my last post), and it explains how to use a different cpp. However,
I still think the default should be the value of CPP in the Makefile.

Meanwhile, Mark's suggestion isn't working. I created a file called
.fvwm-styles with one line:

    #define INFO NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0

I call it in .fvwmrc like this just before my Style assignments:

    FvwmCpp .fvwm-styles

The result is the following message:

    fvwm: bad style command: INFO

Am I missing something?

Gail
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Gail Mara Gurman)
Date: Thu, 12 Oct 1995 11:09:19 -0700 (PDT)

> G> Am I missing something?
> Yes. This isn't what I suggested :-).
> The CPP define *must* go in the same file that contains the
> styles. You have to split off the styles from the rest of you .fvwmrc
> file. All your style directives should be moved to .fvwm-styles (or
> whatever you use).

Yes, I realized this after I sent that message. I put the two appropriate
Style lines in with the #define statement in the .fvwm-styles file, but it
still didn't work.
 
Gail

---

From: Mark Borges <[email-masked]>
Date: Thu, 12 Oct 1995 12:04:31 -0600

>> On Thu, 12 Oct 1995 09:49:51 -0700 (PDT),
>> Gail Mara Gurman(G) wrote:
G> However, I still think the default should be the value of CPP in
G> the Makefile.
Good idea.

G> Meanwhile, Mark's suggestion isn't working. I created a file called
G> .fvwm-styles with one line:

G>     #define INFO NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0

G> I call it in .fvwmrc like this just before my Style assignments:

G>     FvwmCpp .fvwm-styles

G> The result is the following message:

G>     fvwm: bad style command: INFO

What's happening to you is that FvwmCpp reads the #define INFO
performs any expansions (none) in your case, and then passes the
result to fvwm (comment lines in your case). Subsequently, INFO is not
defined for the rest of your .fvwmrc file, you try to use it, and fvwm
issues the error.

  -mb-