Subject: FVWM: Mini icons.

From: Roy Dragseth <[email-masked]>
Date: Wed, 18 Oct 1995 16:55:26 MET

Hi, fellow fvwm users.

I have a suggestion on the color usage in the menu icon package: Use
the 32 colors that is defined in the AIcons package (found at
ftp.x.org I think). We are still a large amount of people stuck with
8bit displays or worse, and I need as many free colors I can get to
use some data visualization programs (I prefer not be forced to use
private colormaps).

What is AIcons? It is a LARGE collection of pixmaps & bitmaps
approx. 5000 items. A lot of very cool icons. They all use the same 32
colors. 

Attached is the default colormap from the AIcons package,
colormap.xpm:
/* XPM */
static char * colormap_xpm[] = {
/* width height ncolors chars_per_pixel */
"6 5 30 1",
/* colors */
" 	c black",
".	c DarkSlateGrey",
"X	c SlateGrey",
"o	c grey",
"O	c gainsboro",
"+	c white",
"@	c navy",
"#	c blue",
"$	c DodgerBlue",
"%	c SkyBlue",
"&	c lavender",
"*	c cyan",
"=	c purple",
"-	c firebrick",
";	c SeaGreen",
":	c LimeGreen",
">	c green",
",	c PaleGreen",
"<	c magenta",
"1	c red",
"2	c tomato",
"3	c orange",
"4	c gold",
"5	c yellow",
"6	c violet",
"7	c sienna",
"8	c peru",
"9	c tan",
"0	c wheat",
"q	c LemonChiffon",
/* pixels */
" .XoO+",
"@#$%&*",
"=-;:>,",
"<12345",
"67890q"};

Just a small suggestion, I'm gonna convert all icons to this colormap
anyhow.

Oh, is icons in the titlebar gonna show up soon?

Best regards,
Roy.

---
INSTITUTE OF MATHEMATICAL SCIENCES,
Dept. of Mathematics and Statistics
Univ. of Tromsoe, N-9037 Tromsoe, Norway.
Tlf. +47 77 64 40 00, Fax +47 77 64 47 65.
Roy Dragseth, Ph. D. st.
direct call:    +47 77 64 40 31
email:          [email-masked]
HTTP adress:    http://www.math.uit.no/~royd

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 18 Oct 1995 12:27:24 -0400

>>>>> "Roy" == Roy Dragseth <[email-masked]> writes:

Roy> Hi, fellow fvwm users.
Roy> I have a suggestion on the color usage in the menu icon package:
Roy> Use the 32 colors that is defined in the AIcons package (found at
Roy> ftp.x.org I think). We are still a large amount of people stuck
Roy> with 8bit displays or worse, and I need as many free colors I can
Roy> get to use some data visualization programs (I prefer not be
Roy> forced to use private colormaps).

I've been meaning to reduce the number of colors anyways, but a small
standard colormap for the pixmaps is even better.  It looks like a
good representative of colors.

Roy> Just a small suggestion, I'm gonna convert all icons to this
Roy> colormap anyhow.

Do you have a script or program to do this, or are you going to do it
all by hand?  If you have a script or program, you could send it to me
and I'll run it on my stuff for the next patchlevel, or you could
point me to a tar file after you convert them.  The only reason I
didn't use the quantize_pixmaps script is that it doesn't handle
transparent colors well.  So, if you have another way to do it...

Roy> Oh, is icons in the titlebar gonna show up soon?

Perhaps eventually, but not soon.

Thanks,
Chuck

*******************************************************************************
Charles K. Hines
IBM Logic Synthesis developer [BooleDozer (TM)]
and Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

Internet e-mail:     [email-masked]

IBM Internal e-mail: [email-masked]   (preferred from workstation)
                     HINESC at FISHKILL       (preferred from mainframe)
                     HINESC at FSHVMFK1       (discouraged, but I'll get it)

*******************************************************************************
 "dis ting could have possabiwities if I put my twisted widdle mind to it!"
                                                        - Bugs Bunny

 "I have a paper plate in my head because they were all out of the metal ones"
                                                        - Rick Overton
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].