Subject: FVWM: A couple of FVWM 2.0 questions.

From: "Ludvig A. Norin" <[email-masked]>
Date: Sat, 23 Sep 1995 16:34:21 +0200

Hello Chuck and all others,

I am peeping at fvwm 2.0 as it develops. I wonder wether the function
"OpaqueResize" from fvwm 1.x has been renamed, accidently removed or 
permanently removed?

I've checked the manpages, the FAQ, ChangeLog and the fvwmrc conversion 
script, and found nothing. 

Almost the same goes for the fvwm 1.x statement "include". I've found that
one can use the Statement "Read" with the same functionality, but I
think this is a think worth mentioning in the FAQ.

One last thing i am wondering about is the special effect that the title
bars get when you style them as "sticky" in fvwm 2.0 - a "MACiotic" effect
with horizontal lines (try making a window sticky, if you haven't seen it
folks, it's really nice). Is there any way of getting this effect on
non-sticky windows, too? This migh be a FAQ thing too.

Well, Chuck, keep on the good work, and Nation, thanks for what's done!

Sincerly
Ludvig A. Norin
[email-masked]

-- Even those who doesn't dare to live dies someday

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Mon, 25 Sep 1995 10:45:32 -0400

>>>>> "Ludvig" == Ludvig A Norin <[email-masked]> writes:

Ludvig> Hello Chuck and all others,
Ludvig> I am peeping at fvwm 2.0 as it develops. I wonder wether the
Ludvig> function "OpaqueResize" from fvwm 1.x has been renamed,
Ludvig> accidently removed or permanently removed?

Ludvig> I've checked the manpages, the FAQ, ChangeLog and the fvwmrc
Ludvig> conversion script, and found nothing.

I believe that it was intentionally permanently removed, since it eats
a fair amount of system resources to do that, unless you have a really
fast server & video card.  I'll add it to the FAQ.

Ludvig> Almost the same goes for the fvwm 1.x statement
Ludvig> "include". I've found that one can use the Statement "Read"
Ludvig> with the same functionality, but I think this is a think worth
Ludvig> mentioning in the FAQ.

The 'include' command in 1.xx was actually due to the m4 processing
which could be optionally compiled in (on by default, I believe).
This should probably be added to the FAQ as well.  If you use the
FvwmM4 module to read in your .fvwm2rc file, this functionalitly would
return, I believe.

Ludvig> One last thing i am wondering about is the special effect that
Ludvig> the title bars get when you style them as "sticky" in fvwm 2.0
Ludvig> - a "MACiotic" effect with horizontal lines (try making a
Ludvig> window sticky, if you haven't seen it folks, it's really
Ludvig> nice). Is there any way of getting this effect on non-sticky
Ludvig> windows, too? This migh be a FAQ thing too.

Not possible to do on non-sticky windows, at least not yet.  Added it
to the FAQ.

Along these lines, I have to admit that I was rather partial to the
sticky window having a different std color in 1.xx, but Rob changed
the way it was done due to it being difficult to do in the code
cleanly.  I'd like to find a way to revive that, and if I happen to
find a clean way to make it all more generic, perhaps we can get the
title bar lines to be a more generic attribute as well.  No guarantees
though.

Ludvig> Well, Chuck, keep on the good work, and Nation, thanks for
Ludvig> what's done!

I'll try...

Chuck

*******************************************************************************
Charles K. Hines
IBM Logic Synthesis developer [BooleDozer (TM)]
and Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

Internet e-mail:     [email-masked]

IBM Internal e-mail: [email-masked]   (preferred from workstation)
                     HINESC at FISHKILL       (preferred from mainframe)
                     HINESC at FSHVMFK1       (discouraged, but I'll get it)

*******************************************************************************
 "dis ting could have possabiwities if I put my twisted widdle mind to it!"
                                                        - Bugs Bunny

 "I have a paper plate in my head because they were all out of the metal ones"
                                                        - Rick Overton
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Eric Ding)
Date: Mon, 25 Sep 95 10:09:22 PDT

> "OpaqueResize" from fvwm 1.x has been renamed, accidently removed or 

It's now called OpaqueMoveSize.

Eric

---

From: [email-masked]
Date: Tue, 26 Sep 1995 11:44:29 +0900

I just reply to only [email-masked].

>> "OpaqueResize" from fvwm 1.x has been renamed, accidently removed or 

ericding> It's now called OpaqueMoveSize.

It is not right. OpaqueMoveSize in fvwm-2 is equivalent to OpaqueMove
in fvwm-1.

Here is a list of fvwm-1 and fvwm-2 features equivalence list. I think
it may have some error (because I made this list when pre2.0p1? ...).

- -
Makoto 'MAR_kun' MATSUSHITA

** Fvwm-1 commands **

AppsBackingStore				(obsoleted)
AutoRaise delay					(obsoleted, use FvwmAuto)
BackingStore					(obsoleted)
BoundaryWidth Width				Style (BoundaryWidth width)
ButtonStyle button# WidthxHeight		<-
CenterOnCirculate				(obsoleted)
CirculateSkip windowname			Style (CirculateSkip)
CirculateSkipIcons				Style (CirculateSkipIcon)
ClickTime delay					<-
ClickToFocus					Style (ClickToFocus)
Cursor  cursor_num cursor_type			(obsoleted)
DecorateTransients				Style (DecorateTransient)
DeskTopScale Scale				(obsoleted, use FvwmPager)
DeskTopSize HorizontalxVertical			<-
DontMoveOff					(obsoleted)
EdgeResistance scrolling moving			<-
EdgeScroll horizontal vertical			<-
Font fontname					MenuStyle (arg4)
Function FunctionName				AddToFunc (not compatible)
HiBackColor colorname				HilightColor (arg1)
HiForeColor colorname				HilightColor (arg2)
Icon windowname bitmap-file			Style (Icon iconname-file)
IconBox left top right bottom			Style (IconBox l t r b)
IconFont fontname				<-
IconPath path					<-
Key keyname Context Modifiers Function		<-
Lenience					Style (Lenience)
MenuBackColor colorname				MenuStyle (arg2)
MenuForeColor colorname				MenuStyle (arg1)
MenuStippleColor colorname			MenuStyle (arg3)
Module ModuleName				<-
ModulePath path					<-
Mouse Button Context Modifiers Function		<-
MWMBorders					Style (MWMBorder)
MWMButtons					Style (MWMButtons)
MWMDecorHints					Style (MWMDecor)
MWMFunctionHints				Style (MWMFunctions)
MWMHintOverride					Style (HintOverride)
MWMMenus					MenuStyle (arg5)
NoBorder windowname				Style (NoBorder)
NoBoundaryWidth Width				Style (HandleWidth width)
NoPPosition					Style (NoPPosition)
NoTitle windowname				Style (NoTitle)
OpaqueMove percentage				OpaqueMoveSize percentage
OpaqueResize					(obsoleted, use FvwmPager)
Pager  X_Location Y_Location			(obsoleted, use FvwmPager)
PagerForeColor colorname			(obsoleted, use FvwmPager)
PagerBackColor colorname			(obsoleted, use FvwmPager)
PagerFont fontname				(obsoleted, use FvwmPager)
PagingDefault pagingdefaultvalue		(obsoleted)
PixmapPath path					<-
Popup PopupName					AddToMenu (not compatible)
RandomPlacement					Style (RandomPlacement)
SaveUnders					(obsoleted)
SloppyFocus					Style (SloppyFocus)
SmartPlacement					Style (SmartPlacement)
StartsOnDesk windowname desk-number		Style (StartsOnDesk desk-number)
StaysOnTop windowname				Style (StaysOnTop)
StdBackColor colorname				Style (BackColor color)
StdForeColor colorname				Style (ForeColor color)
StickyBackColor colorname			(obsoleted)
StickyForeColor colorname			(obsoleted)
Sticky windowname				Style (Sticky)
StickyIcons					Style (StickyIcon)
StubbornIcons					(obsoleted)
StubbornIconPlacement				(obsoleted)
StubbornPlacement				(obsoleted)
Style windowname options			<-
SuppressIcons					Style (NoIcon)
WindowFont fontname				<-
WindowListSkip windowname			Style (WindowListSkip)
XORvalue number					<-

** fvwm-1 built-in functions ***

Beep						<-
CirculateDown [ name window_name ]		Next (not compatible)
CirculateUp [ name window_name ]		Prev (not compatible)
Close						<-
CursorMove horizonal vertical			<-
Delete						<-
Desk arg1 arg2					<-
Destroy						<-
Exec name command				<-
Focus						<-
Function					<-
GotoPage  x y					<-
Iconify [ value ]				<-
Lower						<-
Maximize [  horizontal vertical ]		<-
Module name ModuleName				Module ModuleName
Move [ x y ]					<-
Nop						<-
Popup						<-
Quit						<-
Raise						<-
RaiseLower					<-
Refresh						<-
Resize [ x y ]					<-
Restart  name WindowManagerName			<-
Stick						<-
Scroll horizonal vertical			<-
Title						<-
TogglePage					(obsoleted)
Wait name					<-
Warp [ name window_name ]			Next or Prev (not compatible)
WindowsDesk new_desk				<-
WindowList arg1 arg2				<-

*** New in fvwm-2 **

Destory
DestoryMenu
KillModule
Menu menu-name double-click-action
Next [conditions] command
None [arguments] command
Prev [conditions] command
Read filename
Recapture
+
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eric Ding <[email-masked]>
Date: Mon, 25 Sep 95 10:09:22 PDT

Eric