Subject: FVWM: fvwm-pre-2.0-patchlevel-35 configure.h

From: "Randall S. Winchester" <[email-masked]>
Date: Thu, 21 Sep 1995 10:05:32 -0400 (EDT)

I had to make two changes to configure.h. 
One is new for pl-35, the other I have always made. I think both of these 
changes should be made for pl-36. (A patch follows.)

This first one is that I had to put the following back;
/* Imake command needed to put modules in desired target location */
/* Use the second version if it causes grief */
#define TARGET_DIR BINDIR=FVWMDIR
/* #define TARGET_DIR */

If you just "#define TARGET_DIR", you will have your modules installed
in the X11 bin directory (/usr/local/X11R6/bin in my case). The intent
is to have them installed in FVWMDIR (i.e /usr/local/X11R6/lib/X11/fvwm2).
Otherwise you may not be able to run fvwm and fvwm2 concurently.

The second one  is that I always comment out;
/*************************************************************************
 *
 * Really, no one but me should need this 
 *
 ************************************************************************/
/*
#if defined __sun__ && !defined SYSV
#define BROKEN_SUN_HEADERS          
#endif
*/

Here is the patch;
*** 1.1	1995/09/20 20:30:43
--- configure.h	1995/09/21 14:04:06
***************
*** 20,27 ****
  
  /* Imake command needed to put modules in desired target location */
  /* Use the second version if it causes grief */
! /* #define TARGET_DIR BINDIR=FVWMDIR */
! #define TARGET_DIR

  /* If you want Imake to leave your binary in the standard place where
--- 20,27 ----
  
  /* Imake command needed to put modules in desired target location */
  /* Use the second version if it causes grief */
! #define TARGET_DIR BINDIR=FVWMDIR
! /* #define TARGET_DIR */

  /* If you want Imake to leave your binary in the standard place where
***************
*** 100,108 ****
--- 100,110 ----
   * Really, no one but me should need this 
   *
   ************************************************************************/
+ /*
  #if defined __sun__ && !defined SYSV
  #define BROKEN_SUN_HEADERS          
  #endif
+ */
  /***************************************************************************
   *
   * In theory, this stuff can be replaced with GNU Autoconf 

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Mon, 25 Sep 1995 10:09:10 -0400

>>>>> "Randall" == Randall S Winchester <[email-masked]> writes:

Randall> I had to make two changes to configure.h.
Randall> One is new for pl-35, the other I have always made. I think
Randall> both of these changes should be made for pl-36. (A patch
Randall> follows.)

Randall> This first one is that I had to put the following back;
Randall> /* Imake command needed to put modules in desired target location */
Randall> /* Use the second version if it causes grief */
Randall> #define TARGET_DIR BINDIR=FVWMDIR
Randall> /* #define TARGET_DIR */

Randall> If you just "#define TARGET_DIR", you will have your modules
Randall> installed in the X11 bin directory (/usr/local/X11R6/bin in
Randall> my case). The intent is to have them installed in FVWMDIR
Randall> (i.e /usr/local/X11R6/lib/X11/fvwm2).  Otherwise you may not
Randall> be able to run fvwm and fvwm2 concurently.

Good point.  Done for next patchlevel.

Randall> The second one  is that I always comment out;
Randall> /*************************************************************************
Randall>  *
Randall>  * Really, no one but me should need this
Randall>  *
Randall>  ************************************************************************/
Randall> /*
Randall> #if defined __sun__ && !defined SYSV
Randall> #define BROKEN_SUN_HEADERS
Randall> #endif
Randall> */

Well, if Rob is really the only one who should need that, it makes
sense to comment it out by default, I guess.  I put an #if 0 around it
for the next patchlevel.

Chuck

*******************************************************************************
Charles K. Hines
IBM Logic Synthesis developer [BooleDozer (TM)]
and Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

Internet e-mail:     [email-masked]

IBM Internal e-mail: [email-masked]   (preferred from workstation)
                     HINESC at FISHKILL       (preferred from mainframe)
                     HINESC at FSHVMFK1       (discouraged, but I'll get it)

*******************************************************************************
 "dis ting could have possabiwities if I put my twisted widdle mind to it!"
                                                        - Bugs Bunny

 "I have a paper plate in my head because they were all out of the metal ones"
                                                        - Rick Overton
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].