Subject: FVWM: what's the HotKey for mouse?

From: BingYU <[email-masked]>
Date: Thu, 19 May 2005 16:46:18 -0700

Hi list 

this is my key binding 
Key Left        A       SM      CursorMove -30 +0
which means Ctrl+Alt+Left the cursor will move 1/3 left of the screen 

I find this is very useful for us to move the cursor of the mouse 

Now my question is whether there is a key binding to achieve this kind of
action: right/left/middle  click of the mouse

Thank you for you attetion!

-- 
Your reasoning powers are good, and you are a fairly good planner.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 19 May 2005 11:09:48 +0100

On Thu, May 19, 2005 at 04:46:18PM -0700, BingYU wrote:
> Now my question is whether there is a key binding to achieve this kind
> of action: right/left/middle click of the mouse

There's the 'FakeClick' command, but don't expect it to work all the
time.

-- Thomas Adam

--  
"One of us is a cigar stand, and one of us is a lovely blue incandescent
guillotine" -- Stephen Malkmus, "Type Slowly" from "Brighten The Corners"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Arno Venner <[email-masked]>
Date: Thu, 19 May 2005 12:55:12 +0200

Hi BingYU,

>Thank you for you attetion!
A mouse Action looks like:

(copied from http://www.fvwm.org/screenshots/desktops/Thomas_Adam-desk-1280x960/config)

// start quote

# Handle some Mouse bindings now...
# Recall that mouse formats look like this:
#
# +------------+
# | ||  ||  || |
# |	           |
# +------------+
#   1   3   2
# Binding Functions
#
# "I" stands for Immediate
# "M" stands for Motion
# "C" stands for Click
# "H" stands for Hold
# "D" stands for Double Click

# ---------------------------------------------------------------------------
# Contexts:
#     R = Root Window                 rrrrrrrrrrrrrrrrrrrrrr
#     W = Application Window          rIrrrrFSSSSSSSSSFrrrrr
#     F = Frame Corners               rrrrrrS13TTTT642Srrrrr
#     S = Frame Sides                 rIrrrrSwwwwwwwwwSrrrrr
#     T = Title Bar                   rrrrrrSwwwwwwwwwSrrrrr
#     I = Icon                        rIrrrrFSSSSSSSSSFrrrrr
#                                     rrrrrrrrrrrrrrrrrrrrrr
# Numbers are buttons: 1 3 5 7 9   0 8 6 4 2
#
# Modifiers: (A)ny, (C)ontrol, (S)hift, (M)eta, (N)othing
# ---------------------------------------------------------------------------

# click in the root menu
Mouse 1    R       A	Menu FvwmMenuRoot
Mouse 2	   R       A	WindowList
Mouse 3    RFT     A	Menu FvwmMenuWindowOps

// end quote

So - if you add the following lines
Mouse 1        A       SM      CursorMove -30 +0
Mouse 2        A       SM      CursorMove -30 +0
Mouse 3        A       SM      CursorMove -30 +0

That should do ... at least when your mouse is not over an open window,
which fetches its actions ...

greetings,

Arno Venner

---

From: Nacho <[email-masked]>
Date: Thu, 19 May 2005 12:57:41 +0200

> action: right/left/middle  click of the mouse

Maybe you already know it... if you press Shift+NumLock you can make clicks 
with the "5" of the numeric pad, this is a X feature I think, but if you don't
need it to use it in a Fvwm function maybe it serves your purpose.

Regards:

Nacho

-- 
No book comes out of a vacuum (G. Buehler)
http://www.lascartasdelavida.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 19 May 2005 14:12:49 +0100

On Thu, May 19, 2005 at 12:55:12PM +0200, Arno Venner wrote:
> | || || ||  
> |  1  3  2 

I really need to fix my diagrams:

1 2 3 

is the correct order for mouse-clicks.

-- Thomas Adam

---

From: BingYU <[email-masked]>
Date: Fri, 20 May 2005 08:26:25 -0700

Thank you a million!

This is what I needed. 

It really get the job done! 
Although the cursor move a little slower(this garantee it has high accuracy)

-- 
If your life was a horse, you'd have to shoot it.

---

From: Nacho <[email-masked]>
Date: Sat, 21 May 2005 09:13:43 +0200

> Thank you a million!

You are wellcome ;-)

> Although the cursor move a little slower(this garantee it has high accuracy)

I think this is customizable, in the same way that the resolution of a real
mouse... I would just have a look at the X documentation, try google and it
should find it quickly.

Regards:

Nacho

---

From: Cameron Simpson <[email-masked]>
Date: Mon, 23 May 2005 13:13:11 +1000

On 21May2005 09:13, Nacho <[email-masked]> wrote:
| > It really get the job done! 
| > Although the cursor move a little slower(this garantee it has high accuracy)
| 
| I think this is customizable, in the same way that the resolution of a real
| mouse... I would just have a look at the X documentation, try google and it
| should find it quickly.

Unfortunately "the X documentation" is pretty large.
Try "man xset"; it has controls for the mouse acceleration.
-- 
Cameron Simpson <[email-masked]> DoD#743
http://www.cskk.ezoshosting.com/cs/

Maybe we can eventually make language a complete impediment to understanding.
        - Matthew Austern <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].