Subject: Re: FVWM: Session Management under fvwm2

From: Thomas Adam <[email-masked]>
Date: Sat, 7 May 2005 22:08:33 +0100 (BST)

--- Felix Karpfen <[email-masked]> wrote:
> It would help at least one novice to have an example of an entry in
> the (personal) configuration file that shows how to make a routinely
> used menu into a permanent entry whenever fvwm2 is started.

If I understand you, you just want to add something like:

DestroyMenu mymenu
AddToMenu mymenu
+ "program1" Exec exec prog1
+ "program2" Exec exec prog2 -option
 
Although I doubt that is what you want -- can you provide a clearer
example of what you're actually wanting to do?

-- Thomas Adam

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Felix Karpfen <[email-masked]>
Date: Tue, 10 May 2005 07:15:54 +1000

On Sat, 07 May 2005 22:08:33 +0100, Thomas Adam wrote
(<[email-masked]>):

>> It would help at least one novice to have an example of an entry in the
>> (personal) configuration file that shows how to make a routinely used
>> menu into a permanent entry whenever fvwm2 is started.
> 

 My apologies for failing to mention one important item - I access fvwm2
 via fvwm-themes. 
 
 Here is the content of my "personal" directory:
 
  [felixk@carrot felixk]$ ls -l .fvwm/themes/personal/
 total 64
 -rw-r--r--  1 felixk felixk   96 Apr 18  2003 bindings-extra
 -rw-r--r--  1 felixk felixk 8008 Feb 28 11:52 functions-appbind
 -rw-r--r--  1 felixk felixk  776 Apr 28 21:33 functions-appbind-extra
 -rw-r--r--  1 felixk felixk   94 Apr 18  2003 functions-extra
 -rw-r--r--  1 felixk felixk 1459 Apr 18  2003 globalfeel
 -rw-r--r--  1 felixk felixk  678 Mar 16 12:32 menus-extra
 -rw-r--r--  1 felixk felixk    0 Apr 18  2003 menus-programs-extra
 -rw-r--r--  1 felixk felixk   80 Aug 14  2004 startup
 -rw-r--r--  1 felixk felixk   95 Apr 18  2003 startup.01.bk
 -rw-r--r--  1 felixk felixk   68 Apr 18  2003 stroke-extra
 
 And these are the current entries in my "startup" file (which I imagine
 needs additions):
 
 AddToFunc InitFunction
 + I Exec sleep 5 
 + I Exec exec xearth -label -wait 240         
 
 The programs that I load routinely are the Opera browser, the Pan
 newsreader and the Gnome terminal.  I load each of them onto a different
 page and envisage that the pages need to be specified in the start-up
 file. It would be great if the programs opened at the point at which
 they were closed when fvwm2 was shutdown.  Not really necessary since
 Opera and Pan do this by default.
 
 I hope that I have the terminology correct.
 
 Thank you for the prompt reply.
 Felix Karpfen
-- 
Felix Karpfen
Public Key 72FDF9DF (DH/DSA)