Subject: FVWM: Simple quastions

From: Bambero <[email-masked]>
Date: Sat, 07 May 2005 12:05:03 +0200

Hello

I almost end my configuration and it looks great.
But there are some things I can't set.

1. Is it possible to turn off icons (left edge of desktop) of iconified 
windows.
   I use taskbar and i dont need them.

2. Clicking on the clock in the FvwmTaskBar should run command (ex. 
calendar).

3. I use function:

DestroyFunc FuncFvwmIconifyOrFocusAndRaise
AddToFunc   FuncFvwmIconifyOrFocusAndRaise
+ I ThisWindow (Iconic) Iconify off
+ I TestRc (NoMatch) ThisWindow (Raised) Iconify on
+ I ThisWindow (!Iconic) Focus
+ I ThisWindow (!Iconic) Raise

It works fine but doesn't iconify Maximized windows. How to fix that ?

4. Is it possible to dynamicaly generate Menus content using conditions 
without using external functions ?

DestroyMenu FvwmTaskBarMenu
AddToMenu FvwmTaskBarMenu
+ "Iconify"                  FvwmIconify (if window is not iconified)
+ "DeIconify"                FvwmIconify (if window is iconified)

Thanks for any help.
Bambero

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Sat, 7 May 2005 12:38:46 +0100

> Hello

Hello -

> 1. Is it possible to turn off icons (left edge of desktop) of
> iconified windows. I use taskbar and i dont need them.

Style * NoIcon

> 2. Clicking on the clock in the FvwmTaskBar should run command (ex   .
> calendar)                                                            .

man FvwmTaskBar

> It works fine but doesn't iconify Maximized windows. How to fix that ?

Try replacing the second line with:

+ I TestRc (NoMatch) ThisWindow (Raised|Maximized) Iconify on

> 4. Is it possible to dynamicaly generate Menus content using
> conditions without using external functions ?

How do you mean?  Using PipeRead gives good flexibility.

-- Thomas Adam

--  
"One of us is a cigar stand, and one of us is a lovely blue incandescent
guillotine" -- Stephen Malkmus, "Type Slowly" from "Brighten The Corners"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bambero <[email-masked]>
Date: Sat, 07 May 2005 16:03:06 +0200

>+ I TestRc (NoMatch) ThisWindow (Raised|Maximized) Iconify on
Doesn't work.