Subject: FVWM: mouse binding?

From: "Fletcher Mattox" <[email-masked]>
Date: Wed, 27 Apr 2005 15:32:22 -0500

I want to be able to click any part of a window and have it RaiseLower
the window (using focus-follows mouse mode).  So my first, naive attempt
was the obvious:

Mouse 1                W       A       RaiseLower

But I quickly learned that this breaks cut-n-paste by usurping
the left button.  Similar for the middle button.  The right button
is a little better, but I find that it still usurps an application's
use of the right button (e.g. firefox).

Am I asking fvwm to do something impossible?

Thanks
Fletcher
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 27 Apr 2005 17:11:07 -0400

> Am I asking fvwm to do something impossible?

Not at all.
You have to be using one of the later 2.5.x releases,
(I'm not sure when this was implemented).
Look in the man page for the substring 'clickraise'.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: "Fletcher Mattox" <[email-masked]>
Date: Thu, 28 Apr 2005 13:51:03 -0500

> Look in the man page for the substring 'clickraise'.

Perfect.  All it took is an upgrade to 2.5.12.  Thanks so much!
With 2.5.12 I can't seem to restart any of the modules in my .fvwmrc
when I click "restart fvwm", but that's a different problem.
If I can't figure it out, I'll be back.

Thanks
Fletcher

---

From: Dan Espen <[email-masked]>
Date: Thu, 28 Apr 2005 15:04:50 -0400

> Perfect.  All it took is an upgrade to 2.5.12.  Thanks so much!

Glad to hear it.

> If I can't figure it out, I'll be back.

If you are setting ModulePath in your .fvwm2rc, don't.

---

From: Nick Fortune <[email-masked]>
Date: Thu, 28 Apr 2005 21:32:30 +0100

> If you are setting ModulePath in your .fvwm2rc, don't.

Does it break things if we do? What should we do instead
if we have non-distribution modules and can't (or don't want)
to install them in FVWM_MODULEDIR?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 28 Apr 2005 17:12:56 -0400

Nick Fortune <[email-masked]> writes:
> Does it break things if we do?

Only if you install a new release and the modules are in
a new location.

> What should we do instead

Append or prepend to the ModulePath:

ModulePath ${HOME}/lib/fvwm/modules:+

Note the colon, plus sign.

---

From: Nick Fortune <[email-masked]>
Date: Fri, 29 Apr 2005 07:06:39 +0100

> Note the colon, plus sign.

That's what I thought. Ta.