Subject: FVWM: fvwm-root: may it NOT stretch image?

From: Dedeco <[email-masked]>
Date: Fri, 01 Apr 2005 21:30:27 -0300

Hello,
    I have this line on my .fvwm2rc to make my root window nice:
+ "I" Exec "fvwm-root" /path/to/image.png

   The image I have isn't the exact ratio of the screen (it is taller) 
and I want it to be shown centered and fully appearing. Currently is is 
stretched to the sides of the screen and top aligned with it (so the 
bottom of it isn't shown). Checking "$man fvwm-root" I found that the 
command doesn't have this option, right? How can I do then?

Thanks in advance,

Dedeco

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nuno Alexamdre <[email-masked]>
Date: Sat, 02 Apr 2005 16:38:42 +0200

> and I want it to be shown centered and fully appearing.
>  How can I do then?
> Thanks in advance,
> Dedeco

Hi,
You can use another tool to acomplish that.
I use [1] fbsetbg, which is just a wrapper used by fluxbox to set the
wallpaper, with [2] feh.
I'd recomend that you take a closer look at it :>
+ I Test (init) Exec fbsetbg -l
sets the last used wallpaper.

* you may need to edit the script(fbstebg) to change the path where the
last wallpaper used is stored.

[1] http://www.xs4all.nl/~hanb/software/fluxbox/fbsetbg.html
[2] http://www.linuxbrit.co.uk/feh
-- 
                nuno alexandre 
0416 95FD B8B2 AB9A 16C4  323D 9628 6E7B D4C9 1A22

---

From: Rouben Rostamian <[email-masked]>
Date: Sun, 3 Apr 2005 13:32:32 -0400

> command doesn't have this option, right? How can I do then?

I second Nuno Alexamdre's recommendation of feh for this
purpose.  It works very nicely with fvwm.  In particular,
it handles transparent elements very well.

However I use feh directly, without appeal to fbsetbg or any
another auxiliary program.  In init I have:

+ I Exec feh --bg-scale /path/to/image.png

-- 
Rouben Rostamian