Subject: FVWM: fvwm crashes on resize when xmms is running

From: "Tommy C. Li" <[email-masked]>
Date: Tue, 26 Apr 2005 16:31:17 -0700

Hello,

I've noticed that fvwm crashes on resize whenever xmms is playing.

I'm pretty sure it is the same root problem as posted here:
http://www.hpc.uh.edu/fvwm/archive/0501/msg00065.html

But I've gotten more information to perhaps pinpoint the problem.

I've found a way in which the problem, or at least one variant of it,
can be reproduced every time.

1. Play a song with XMMS.
2. Resize the Konqueror window.

Interestingly enough, fvwm doesn't crash unless XMMS is actually playing
the song. I've tried using XMMS with different output plugins and
options, but it always reliably crashes fvwm.

Here an strace excerpt of fvwm's final moments:

---

> write(26, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(28, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(28, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(3, "\16\30\2\0\233\0\340\2", 8)   = 8
> read(3, "\1\30\31\206\0\0\0\0\321\0\0\0\0\0\0\0001\0038\2\0\0\0"..., 32) = 32
> write(3, "+\30\1\0", 4)                 = 4
> read(3, "\1\2\32\206\0\0\0\0\233\0\340\2\0\0\0\0\1\0\0\0\21\0\0"..., 32) = 32
> ioctl(3, FIONREAD, [0])                 = 0
> write(10, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(14, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(16, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(18, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(20, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(22, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(24, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(26, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(28, "\377\377\377\377\0\0\0@+\0\0\0\243\241\0\0\233\0\340\2"..., 172) = 172
> write(3, "\16\30\2\0\233\0\340\2", 8)   = 8
> read(3, "\1\30\33\206\0\0\0\0\321\0\0\0\0\0\0\0001\0038\2\0\0\0"..., 32) = 32
> write(3, "+\30\1\0", 4)                 = 4
> read(3, "\1\2\34\206\0\0\0\0\233\0\340\2\0\0\0\0\1\0\0\0\21\0\0"..., 32) = 32
> ioctl(3, FIONREAD, [0])                 = 0
> write(3, "\24\0\6\0\233\0\340\2%\0\0\0\0\0\0\0\0\0\0\0@B\17\0", 24) = 24
> read(3, "\1\0\35\206\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0(\0"..., 32) = 32
> open("/dev/tty", O_RDWR|O_NONBLOCK|O_NOCTTY) = -1 ENXIO (No such device or address)
> writev(2, [{"*** glibc detected *** ", 23}, {"free(): invalid pointer", 23}, {": 0x", 4}, {"080f6833", 8}, {" ***\n", 5}], 5*** glibc detected *** free(): invalid pointer: 0x080f6833 ***
> ) = 63
> rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
> tgkill(19526, 19526, SIGABRT)           = 0
> --- SIGABRT (Aborted) @ 0 (0) ---
> +++ killed by SIGABRT +++
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  4
>   Minor opcode:  0
>   Resource id:  0x26000c7
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  4
>   Minor opcode:  0
>   Resource id:  0x26000c6
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  15
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  40
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  18
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  12
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  18
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  18
>   Minor opcode:  0
>   Resource id:  0x260009e
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  40
>   Minor opcode:  0
>   Resource id:  0x26000a1
> X Error: BadWindow (invalid Window parameter) 3
>   Major opcode:  40
>   Minor opcode:  0
>   Resource id:  0x26000a1
> kded: Fatal IO error: client killed
> kdeinit: Fatal IO error: client killed
> kdeinit: sending SIGHUP to children.
> The application 'gkrellm2' lost its connection to the display :0.0;
> most likely the X server was shut down or you killed/destroyed
> the application.
> klipper: Fatal IO error: client killed
> kicker: Fatal IO error: client killed
> konsole: Fatal IO error: client killed
> Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
> klauncher: Exiting on signal 1
> klauncher: Fatal IO error: client killed
> kdeinit: sending SIGTERM to children.
> kdeinit: Exit.

---

-- 
Tommy C. Li

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Espen, Dan" <[email-masked]>
Date: Tue, 26 Apr 2005 20:46:06 -0400

On Tue, 2005-04-26 at 16:31 -0700, Tommy C. Li wrote:
>                              From: 
> Tommy C. Li
> <[email-masked]>
>                                To: 
> [email-masked]
>                           Subject: 
> FVWM: fvwm crashes on resize when
> xmms is running
>                              Date: 
> Tue, 26 Apr 2005 16:31:17 -0700
> (19:31 EDT)
> 
> Hello,
> 
> http://www.hpc.uh.edu/fv

It doesn't crash for me.
If you have a gdb stack trace, that might be helpful.