Subject: FVWM: Wait (?) bug

From: jpkotta <[email-masked]>
Date: Mon, 04 Apr 2005 01:25:10 -0500

I first noticed this bug in a key binding to start my web browser.  I  
would make the key strokes and then realize that I wanted to be on a  
different desktop.  The browser takes a second to start, so I would try to  
switch desktops before it was up.  Then FVWM would suddenly crash.

Here's a minimal config:

     DestroyFunc TestFunc
     AddToFunc TestFunc
     + I     Exec sleep 1 ; xterm
     + I     Wait Xterm

     Key     T       A       A       TestFunc

If you hit 'T' then some other key before xterm comes up, FVWM will  
crash.  FVWM doesn't crash if you hit 'T', or if another window is  
focused.  The sleep simulates time the browser takes to start up,  
otherwise it's hard to reproduce with xterm.

I suspect that Wait is causing the trouble, because I have no problems  
without it.

Thanks,

jpkotta
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Guillaume Lovet <[email-masked]>
Date: Tue, 05 Apr 2005 14:59:01 +0200

Dear all,

How to change the ButtonStyle from Flat to 3D when the mouse cursor goes 
over that button (but no click yet) ?

Thx,

G.

---

From: Thomas Adam <[email-masked]>
Date: Tue, 5 Apr 2005 19:31:24 +0100

On Tue, Apr 05, 2005 at 02:59:01PM +0200, Guillaume Lovet wrote:
> Dear all,
>
> How to change the ButtonStyle from Flat to 3D when the mouse cursor
> goes over that button (but no click yet) ?

I don't believe that's possible in Fvwm yet.

-- Thomas Adam

--  
"One of us is a cigar stand, and one of us is a lovely blue incandescent
guillotine" -- Stephen Malkmus, "Type Slowly" from "Brighten The Corners"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 19 Apr 2005 21:36:25 -0400

> I suspect that Wait is causing the trouble, because I have no problems  

I tried this with Fvwm compiled from current CVS.
I don't get any core dump.  Each time I type T another
window appears.  I can type other characters as that's going on.

Tell us what release you are using.
If you know how to extract a stack trace from the core file
that would help too.

-- 
Dan Espen                           E-mail: [email-masked]