Subject: FVWM: Windows moveing

From: Bambero <[email-masked]>
Date: Thu, 28 Apr 2005 14:02:42 +0200

Hello

Is it possible to move the window when the mouse button is holded on 
titlebar ?
Just drag the window in other place ...

Bambero
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tapio Raevaara <[email-masked]>
Date: Thu, 28 Apr 2005 16:02:16 +0300

>Just drag the window in other place ...

Everything is possible! Put the following lines into your config file:

# Explanation: [Mouse] button [1] on [T]itlebar with [A]ny modifier
# -> call function [FuncMoveWindow]
Mouse 1 T A FuncMoveWindow

# And the function itself:
# On mouse [M]otion -> [Move] window
DestroyFunc FuncMoveWindow
AddToFunc FuncMoveWindow
+ M Move

That should do the trick. :)

---

From: Bambero <[email-masked]>
Date: Thu, 28 Apr 2005 16:58:41 +0200

>That should do the trick. :)
Works !!!

Thanks so much.

---

From: Bambero <[email-masked]>
Date: Thu, 28 Apr 2005 17:18:35 +0200

>That should do the trick. :)
Hm .. But when i add it after:

Mouse 1 WT A Raise

Raise doesn't works

Is it possible to add this functions together ?

---

From: Tapio Raevaara <[email-masked]>
Date: Thu, 28 Apr 2005 19:41:22 +0300

>Is it possible to add this functions together ?

In this case you need to combine many actions in a single function:

Mouse 1 T A FuncMoveOrRaise
Mouse 1 W A Raise

DestroyFunc FuncMoveOrRaise
AddToFunc FuncMoveOrRaise
+ C Raise # C = Click, M = Move, D = double click, H = hold
+ M Move

There's an excellent beginner's guide in
http://www.zensites.net/fvwm/guide/ . I recommend, that covers this
topic well.