Subject: FVWM: Question related to Gimp 2.2 menus and fvwm 2.5.6

From: [email-masked]
Date: Mon, 18 Apr 2005 14:39:02 +0200

Hello all.

I used to participate a little in this forum years ago but stopped because
I had so few skills compared to fvwm dev that I couldn't help. But I still
use fvwm
daily on all my machines.

So I have a question : I use fvwm 2.5.6 (didn't succeed to switch to 2.5.12
that
crashes unexpectadly) and switched to Linux Debian Sarge from Woody, kernel
2.6.8
and the Gimp 2.2. When I tear off menus from the Gimp, they are no more
decorated.
More : the menus are pinned and so are said "sticky" by fvwm.

I tried customizatons in the Gimp about "windows to windowsmanagers",got
out ewmh by recompiling fvwm without the support. played with some ewmh
parameters,
all without success. I browsed the FAQs and did some googling with no
chance.
So excuse-me if I was to weird to find obvious answers before disturbing
the list.

I have the DecorateTransient param in my Gimp windows style.

All appears as if this Gimp menus were considered real menus by fvwm. But
I prefer the old way of considering them as usual transient windows that I
can
reduce to only title bar, very confortable with all the menus you need in
the Gimp.

In a previous version of the Gimp, I created a FvwmButton that succeded in
swallowing
the menus but the result is that they are no more independant witch is
unconfortable to
maximize screen usage. How can I get this behaviour back ?

      Fab.

******************************************************************
This message and any attachments (the "message") are confidential and intended solely for the addressee(s). Any unauthorised use or dissemination is prohibited. E-mails are susceptible to alteration.Neither SOCIETE GENERALE nor any of its subsidiaries or affiliates shall be liable for the message if altered, changed or falsified.                         ***************
Ce message et toutes les pieces jointes (ci-apres le "message") sont confidentiels et etablis a l'intention exclusive de ses destinataires. Toute utilisation ou diffusion non autorisee est interdite. Tout message electronique est susceptible d'alteration.La SOCIETE GENERALE et ses filiales declinent toute responsabilite au titre de ce message s'il a ete altere, modifie ou falsifie.
******************************************************************
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 18 Apr 2005 09:44:54 -0400

[email-masked] writes:
>       Hello all.
> 
> So I have a question : I use fvwm 2.5.6 (didn't succeed to switch to
> 2.5.12 that crashes unexpectadly) and switched to Linux Debian Sarge
> from  Woody, kernel 2.6.8  and the Gimp 2.2. When   I tear off menus
> from the Gimp, they are no more decorated.

I've got current CVS Fvwm here, and gimp2.1.
The gimp tearoff menus are decorated.
I don't see any special settings in my config file for gimp.

> More : the menus are pinned and so are said "sticky" by fvwm.

They aren't sticky either.

>  I  tried    customizatons    in  the    Gimp   about   "windows  to
> windowsmanagers",got  out ewmh   by  recompiling  fvwm without   the
> support. played with some  ewmh parameters,  all without success.  I
> browsed the FAQs and did some googling with no chance.  So excuse-me
> if I  was  to weird to   find obvious answers before  disturbing the
> list.

There are 'ignorehints' settings for Gnome and Ewmh,
no need to compile out the feature.

> I have the DecorateTransient param in my Gimp windows style.

Use FvwmIdent to verify that your style matches the transient
window for the menu.

-- 
Dan Espen                           E-mail: [email-masked]