Subject: Re: FVWM: Drag to create an xterm

From: Uwe Pross <[email-masked]>
Date: Fri, 1 Apr 2005 09:41:59 +0200

Hi there,

On 31 Mar 2005 at 13:24:46 -0500, Stephen Dennison wrote:

> > AddToFunc StrokeFuncWrapper
> > + I SetEnv StrokeStart +$[pointer.x]+$[pointer.y]
> > + I StrokeFunc DrawMotion FeedBack StrokeWidth 2 EchoSequence

I have not done anything with strokes yet. But using the
StrokeFunc option I get drawn the stroke (which looks
pretty ugly) I would prefer to get drawn a recangle grid
like when using ResizeOutline. Maybe one could use another
program which starts immediately, draws the outline and is
replaced by the started program after key release.

> > I can't think of anyway to identify the geometry of the
> > drawn rectangle, ... 

That's exaclty one of my point. I cannot find a way to bind
something on botton release.

> To use it, you click the middle mouse button, drag
> diagonally, release the button at any time, and click
> again to set the lower right bounds.

That's close but a bit circumstantial ;-) 

Maybe one can write a new fvwm function which uses the
resizeoutline functionality and start a program on key
release.

Cheers Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise your mail is discarded by a filter.
=-"-"-= http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alex Wallis <[email-masked]>
Date: Fri, 1 Apr 2005 20:11:38 +0930

On Fri, 1 Apr 2005 09:41:59 +0200

> resizeoutline functionality and start a program on key

In theory one could devise a function where drawing a penguin with libstroke would recompile your kernel.

You guys really should take a good look at the excellent examples of ALL fvwm features and functions that are included with fvwm-themes. If only for educational purposes.

Here's a snippet from the libstroke config...

# The Stroke bindings work as the mouse bindings, but:
# 1. The first argument defines the stroke motion on a telephone grid:
#
#          1   2   3
#
#          4   5   6
#
#          7   8   9
#
#    Or on a numeric pad grid if the sequence starting with 'N'
#
#          7   8   9
#
#          4   5   6
#
#          1   2   3
#
#   We use the numeric pad grid since we have one on our machine.
#   The 0 sequence defines a single click or very small motions.
#
# 2. The second argument is the mouse button for the old way of
#    handling stroke. A 0 is for the StrokeFunc, the new way to use stroke.
#
# We use mostly simple stroke motion. For complex stroke motions we need
# to consider many sloppy stroke motions for each action.
</snip>

The config file then goes on to configure a few dozen functions.

Because fvwm-themes has been designed and developed by actual fvwm developers, it's an extremely useful guide to learning fvwm tips & tricks. Worthy of installing just as a learning tool.

The fact that's it's also the most powerful theme engine I've ever seen or used is merely a bonus.

My 2 cents worth anyway.

Alex