Subject: FVWM: multiple sessions - xscreensaver

From: Tim Hanson <[email-masked]>
Date: Wed, 23 Mar 2005 21:59:12 -0800

I am a vnc user and have all remote sessions run FVWM.  I have
controlled xscreensaver from .fvwm2rc since I started using FVWM years
ago. 

Now, xscreensaver loads (inappropriately) in every vnc session.  How do
I make FVWM start xscreensaver only on screen :0?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Thu, 24 Mar 2005 13:20:48 +0100

Hi there,

> I make FVWM start xscreensaver only on screen :0?

You could use xdpyinfo to determine the actual screen, e.g:

xdpyinfo | sed '2,$d' | grep ':0.0' >& /dev/null && \
	xscreensaver

This could be done in an external script or in an fvwm-Exec
call.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise your mail is discarded by a filter.
=-"-"-= http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].