Subject: FVWM: Can the icons on the desktop be removed?

From: Eric Sun <[email-masked]>
Date: Fri, 25 Mar 2005 23:53:32 +0800

Dear all,

Probobaly a silly question.
Can I remove the icons of the iconified windows on the desktop?
Since I have used the FvwmTaskBar, all icons have been placed
in the taskbar. So I don't want the icons on the desktop any more.
How can I do this? Thanks!

Best regards,
Eric
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Mar 2005 11:27:20 -0500

> Can I remove the icons of the iconified windows on the desktop?

Style * NoIcon

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Eric Sun <[email-masked]>
Date: Sat, 26 Mar 2005 00:56:24 +0800

> > Can I remove the icons of the iconified windows on the desktop?

Dan, Thanks!

This fixed most of the problem. But, still some programs, like XTerm, 
RXVT, XMMS and GSview, resist to show their icons on desktop.
Any idea?

Eric

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Mar 2005 12:03:19 -0500

> RXVT, XMMS and GSview, resist to show their icons on desktop.

I haven't tried this, but:

Style * IconOverride, NoIcon

---

From: Thomas Adam <[email-masked]>
Date: Fri, 25 Mar 2005 17:29:17 +0000

On Fri, Mar 25, 2005 at 11:53:32PM +0800, Eric Sun wrote:
> Probobaly a silly question. Can I remove the icons of the iconified
> windows on the desktop? Since I have used the FvwmTaskBar, all icons
> have been placed in the taskbar. So I don't want the icons on the
> desktop any more. How can I do this? Thanks!

Style * NoIcon

-- Thomas Adam

--  
"One of us is a cigar stand, and one of us is a lovely blue incandescent
guillotine" -- Stephen Malkmus, "Type Slowly" from "Brighten The Corners"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Vilar <[email-masked]>
Date: Fri, 25 Mar 2005 18:32:13 +0100

> RXVT, XMMS and GSview, resist to show their icons on desktop.

I think

    Style * IconOverride

should do the trick.

Greetings,

David

-- 
David Vilar Torres			RWTH Aachen
Tel: (+49) 241 80 21611			Lehrstuhl f. Informatik VI
Fax: (+49) 241 80 22219			Ahornstr. 55
[email-masked]		D-52056 Aachen (Germany)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Fri, 25 Mar 2005 18:09:40 +0000

> Style * IconOverride, NoIcon

You might want to make that:

Style ** IconOverride, NoIcon

So that it really does apply to all windows.

-- Thomas Adam

---

From: Eric Sun <[email-masked]>
Date: Sat, 26 Mar 2005 07:42:54 +0800

Sorry. I made a mistake.
Now, it's ok and no icons on desktop any more.
My FVWM is now wonderful. Many thanks!