Subject: FVWM: Mail Icon on the TaskBar doesn't appear!

From: Eric Sun <[email-masked]>
Date: Thu, 24 Mar 2005 23:42:42 +0800

Dear all,

I just installed the FVWM for the first time.
I've edited a simple .fvwm2rc file which satifies me.
But a small problem here:
I notice that there is a space to the right of the date & time area.
After reading the man page, it seems this space is left for a mail icon.
How can I get this icon appearing? Or, if I just don't want it, how to 
remove this space.

BTW, I'm using 2.5.12. Attached below is my .fvwm2rc.

Thanks in advance!

Eric

#################
AddToFunc InitFunction I Exec xloadimage -onroot $HOME/.fvwm/wallpaper.jpg

DeskTopSize 1x1

####################
# Taskbar Settings #
####################
AddToFunc StartFunction I Module FvwmTaskBar
Style "FvwmTaskBar" NoTitle, WindowListSkip, !Handles, BorderWidth 4
DestroyModuleConfig FvwmTaskBar: *
*FvwmTaskBar: Font -misc-simsun-medium-r-normal-*-*-100-*
*FvwmTaskBar: SelFont -misc-simsun-medium-r-normal-*-*-100-*
*FvwmTaskBar: StatusFont fixed
*FvwmTaskBar: ClockFormat %b %d %a %R
*FvwmTaskBar: Colorset 9
*FvwmTaskBar: IconColorset 9
*FvwmTaskBar: FocusColorset 9
*FvwmTaskBar: StartName FVWM
*FvwmTaskBar: StartCommand Popup mainmenu Rectangle +0+0 +0 +505p

#################################
# Border Colors and Title Fonts #
#################################
Style * Color Wheat/Midnightblue, BorderWidth 4, HandleWidth 4
HilightColor Midnightblue Wheat
WindowFont -misc-simsun-medium-r-normal-*-*-100-*

###################
# Window Focusing #
###################
Style * SloppyFocus, MouseFocusClickRaises

##############################
# Decorate Transient Windows #
##############################
Style * DecorateTransient
Style "xmms" NoTitle
Style "MPlayer" NoTitle

####################
#TaskBar MiniIcons #
####################
Style "XTerm" MiniIcon /home/sunyy/.fvwm/icons/mini/xterm.xpm
Style "RXvt" MiniIcon /home/sunyy/.fvwm/icons/mini/rxvt.xpm
Style "GSview" MiniIcon /home/sunyy/.fvwm/icons/mini/gsview.xpm
Style "GQview" MiniIcon /home/sunyy/.fvwm/icons/mini/gqview.xpm
Style "xmms" MiniIcon /home/sunyy/.fvwm/icons/mini/xmms.png

#############
# Main Menu #
#############
AddToMenu mainmenu "FVWM start" Title
+ "fcitx%/home/sunyy/.fvwm/icons/mini/chinese.xpm%"     Exec fcitx
+ "firefox%/home/sunyy/.fvwm/icons/mini/firefox.xpm%"   Exec firefox
+ ""                                                    Nop
+ "rxvt%/home/sunyy/.fvwm/icons/mini/rxvt.xpm%"         Exec rxvt
-geometry 100x32
+ "xterm%/home/sunyy/.fvwm/icons/mini/xterm.xpm%"       Exec xterm
-geometry 80x24
+ ""                                                    Nop
+ "acroread%/home/sunyy/.fvwm/icons/mini/acroread.png%" Exec acroread
+ "gimp%/home/sunyy/.fvwm/icons/mini/gimp.png%"         Exec gimp-2.2
+ "gqview%/home/sunyy/.fvwm/icons/mini/gqview.xpm%"     Exec gqview
+ "gsview%/home/sunyy/.fvwm/icons/mini/gsview.xpm%"     Exec gsview
+ ""                                                    Nop
+ "realplay%/home/sunyy/.fvwm/icons/mini/realplay.png%" Exec realplay
+ "xmms%/home/sunyy/.fvwm/icons/mini/xmms.png%"         Exec xmms
+ ""                                                    Nop
+ "kill%/home/sunyy/.fvwm/icons/mini/kill.xpm%"         Destroy

###############
# Menu Styles #
###############
MenuStyle * BorderWidth 2
MenuStyle * Font -misc-simsun-medium-r-normal-*-*-100-*

####################
# TitleBar Buttons #
####################
Mouse 1 1 N  Delete
Mouse 1 2 N  Maximize 100 -40p
Mouse 1 4 N  Iconify
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 24 Mar 2005 17:16:14 +0000

On Thu, Mar 24, 2005 at 11:42:42PM +0800, Eric Sun wrote:
> reading the man page, it seems this space is left for a mail icon. How
> can I get this icon appearing? Or, if I just don't want it, how to
> remove this space.

You can remove it by using:

*FvwmTaskBar: Mailbox none

You can make it active, by doing:

*FvwmTaskBar: Mailbox /path/to/mbox

-- Thomas Adam

--  
"One of us is a cigar stand, and one of us is a lovely blue incandescent
guillotine" -- Stephen Malkmus, "Type Slowly" from "Brighten The Corners"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].