Subject: FVWM: Stick take no effect?

From: [email-masked]
Date: Sat, 12 Mar 2005 21:06:56 +0800

Hi,all
I have define this key,
Mouse 2 1		A	Stick
But,when i press the button 1 with middle mouse click,it take no effect,
so it is,the sticky doesnot work at all.Other window can easily cover
the Sticky window.
if i change the key to 
Mouse 2 1		A	Exec exec xterm
it does work,and pop up a xterm window.

how could i do then?

-- 
Nothing for happy.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 12 Mar 2005 23:19:51 +0000

> so it is,the sticky doesnot work at all.Other window can easily cover

The sticky window is the one that appears on all desks, it does not
necessarily stays on top of windows. What you want is Style StaysOnTop
(change window layer statically) or Layer (change layer dynamically).

> it does work,and pop up a xterm window.

Do the following:

  Mouse 2 1             A       Layer 0 6

You may even bind a function that toggles between Layer 4 and Layer 6
(left as an exercise).

Regards,
Mikhael.