Subject: FVWM: No maximise possible for xterms. emacs ..

From: Wolfgang Pfeiffer <[email-masked]>
Date: Sat, 12 Feb 2005 23:51:46 +0100

Here:
________________________________________

Debian Linux/ppc

PowerbookG4

Some lines from /var/log/XFree86.0.log:

II) RADEON(0): Panel size found from DDC: 1280x854
(II) RADEON(0): Valid Mode from Detailed timing table: 1280x854
(II) RADEON(0): Total of 1 mode(s) found.

kernel 2.6.8

fvwm 2.5.12 compiled on Nov 20 2004 at 22:31:48
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM,
Bidi text, Xinerama, XRender, XFT, NLS

dpkg -l | grep xfree
ii  xfree86-common 4.3.0.dfsg.1-1 X Window System (XFree86) infrastructure
ii  xserver-xfree8 4.3.0.dfsg.1-1 the XFree86 X server

_______________________________________

I'm trying this since hours: Getting an xterm- or emacs-window
maximised to the full available screen-size here. To no avail so far:
After of a maximisation of xterm there's always a small space left on
the right-hand side and at the bottom of the window. I made a
screenshot of it:

<http://www.wolfgangpfeiffer.com/picture.png>

After these failures I moved my .fvwm dir out of the way, restarted
FVWM without any configs in $HOME, ran the "fvwm 95 script", and the
situation didn't change at all.

In this newly created .fvwm dir I then edited .fvwm/functions: Here's the
diff  between the changed functions file and the old, original
("functions.old") file:

________________________________________________
 diff -u functions functions.old 
--- functions   2005-02-12 22:07:56.574475512 +0100
+++ functions.old       2005-02-12 22:06:06.760169824 +0100
@@ -56,9 +56,9 @@
 #------------------------------------------------------------------------------
 
 DestroyFunc Maximize-Func
-AddToFunc Maximize-Func M      Maximize 0 100
+AddToFunc Maximize-Func M      Maximize 0 98
 +                      C       Maximize 0 100
-+                      D       Maximize 100 100
++                      D       Maximize 100 98
 
 #------------------------------------------------------------------------------
 # This one resizes and then raises the window if you drag the mouse,
______________________________________________________

And again: no changes. Same situation as before.

I then emptied .xinitrc: Nothing.
Moved .Xresources out of the way: Nothing.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

When I removed .Xdefaults, at least a full horizontal maximization was
possible, but still not a full vertical one:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Here's .Xdefaults:
_________________________________________________

!XTerm*font:-misc-fixed-medium-r-*-*-*-200-*-*-*-*-iso8859-15
!XTerm*font:-misc-fixed-medium-r-*-*-*-120-*-*-*-*-iso8859-1
!XTerm*font:-*-helvetica-*-i-normal-*-*-120-*-100-*-92-iso8859-15

!XTerm*font:-*-*-*-*-*-120-*-*-*-*-utf-8
*font:-misc-fixed-medium-r-*-*-*-120-*-*-*-*-iso8859-15

Emacs.pane.menubar.margin: 0
!Emacs.pane.toolbar.margin: 0
!Emacs*toolbar*margin: 0
Emacs.ToolBar: off
Emacs.menu*.font: -adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1
Emacs.Background: black
Emacs.Foreground: white

xclock*background: black
xclock*foreground: green
xclock*geometry: +0+825

*customization: -color

! Uncomment this to use color for the bold attribute
*VT100*colorBDMode: on
! *VT100*colorULMode: on

! Uncomment this to use the bold/underline colors in preference to other colors
! *VT100*colorAttrMode: on

! Uncomment this to use color for underline attribute

*VT100*colorULMode: on
*VT100*underLine: off

*VT100*color0: black
*VT100*color1: red3
*VT100*color2: green3
*VT100*color3: yellow3
*VT100*color4: DodgerBlue1
*VT100*color5: magenta3
*VT100*color6: cyan3
*VT100*color7: gray90
*VT100*color8: gray50
*VT100*color9: red
*VT100*color10: green
*VT100*color11: yellow
*VT100*color12: SteelBlue1
*VT100*color13: magenta
*VT100*color14: cyan
*VT100*color15: white
! *VT100*colorUL: green4
*VT100*colorUL: DarkGoldenrod3
! *VT100*colorBD: white
*VT100*colorBD: blue
*VT100*cursorBlink: true
*VT100*cursorOffTime: 500
*VT100*cursorOnTime: 850
*VT100*cutToBeginningOfLine: false
*VT100*cutNewline: false
*VT100*saveLines: 500

_________________________________________________

And in the end I even deleted ~/.gtkrc and ~/.gtkrc-mine: Nothing. 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

OTH, I have no problems to maximise a Firefox window to the *complete*
size of the available screen. Ditto with openoffice, XFig, Xpdf. I.e. even
with my old settings before I tried to resolve the problem.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I don't want to play any more: I need knowledge :)

Any hints on how to fix this situation? Or at least on what might be
going on there?

Thanks in anticipation

Regards
Wolfgang

-- 
Wolfgang Pfeiffer
http://profiles.yahoo.com/wolfgangpfeiffer
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 12 Feb 2005 18:24:17 -0500

Wolfgang Pfeiffer <[email-masked]> writes:
> maximised to the full available screen-size here.

Question 5.16 in the FAQ.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Wolfgang Pfeiffer <[email-masked]>
Date: Sun, 13 Feb 2005 03:37:37 +0100

> Question 5.16 in the FAQ.

That's it. Thanks ... :) ...

For Google:

I put that near the end of the styles file:

-------------
Style xterm ResizeHintOverride
Style emacs ResizeHintOverride 
---------------

the diff:

-----------------
$ diff -u  styles styles.050213 
--- styles      2005-02-13 03:13:55.271529336 +0100
+++ styles.050213       2005-02-13 03:05:53.385787104 +0100
@@ -42,9 +42,6 @@
 #DT 1 for the CDE "desk icon"
 #Style popup_* CirculateSkip, WindowListSkip
 
-Style xterm ResizeHintOverride
-Style emacs ResizeHintOverride
-
 # Read the layers settings (stays OnTop, Put or OnBottom)
 Read .fvwm-layers
--------------------

Nice Sunday

Best regards
Wolfgang

---

From: Soumen Dass <[email-masked]>
Date: Sun, 13 Feb 2005 09:56:02 +0530

> Question 5.16 in the FAQ.

I am using this link for the FAQ: http://www.fvwm.org/documentation/faq/ 
But there is no 5.16 Question (after 5.15, 6.1 starts). Could you please 
point out the latest FAQ?
--
Soumen Dass [Registered Linux User # 272639 - Linux nova 
2.4.22-1.2115.nptl i686]

The proof that IBM didn't invent the car is that it has a steering wheel
and an accelerator instead of spurs and ropes, to be compatible with a 
horse.
		-- Jac Goudsmit
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Wolfgang Pfeiffer <[email-masked]>
Date: Sun, 13 Feb 2005 17:18:28 +0100

> point out the latest FAQ?

5.16 seems to be very fresh. Perhaps too new to find it somewhere in
the "Official" FAQ's ... :) 

But this is one of these situations where Google's coming in :) ... :

<http://www.mail-archive.com/[email-masked]/msg05765.html>

HTH

Best Regards
Wolfgang