Subject: FVWM: thumbnail problem

From: Ingo Wardinski <[email-masked]>
Date: Mon, 14 Feb 2005 17:40:34 +0100

Hi all,
I try to get the thumbnail application running, but I ran into
problems like:
> usage: xwd [-display host:dpy] [-debug] [-help] [-root|-id \
<id>|-name <name>] [-nobdrs] [-out <file>] [-xy] [-add value] [-frame]

convert: Unable to read dump file header (-).
convert: Missing an image file name.

when I wanted to thumbnail a xterm or whatever.
My config is:

DestroyFunc Thumbnail
AddToFunc Thumbnail
+ I Raise
+ I PipeRead "xwd -silent -id $[w.id] | convert -scale \
    66 -frame 1x1 -mattecolor black -quality 0 \
    xwd:- png:$[HOME]/.fvwm/icon.tmp.$[w.id].png \
    && echo WindowStyle IconOverride, Icon \
    $[HOME]/.fvwm/icon.tmp.$[w.id].png, StaysOnBottom \
    || echo Nop"
+ I Iconify

DestroyFunc DeThumbnail
AddToFunc DeThumbnail
+ I DestroyWindowStyle
+ I Exec exec rm -f $HOME/.fvwm/icon.tmp.$[w.id].png

Any help would be very appreciated
cheers
ingo

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ingo Wardinski <[email-masked]>
Date: Thu, 17 Feb 2005 14:50:38 +0100

[ On Wednesday, February 16, 2005 at 21:13:29 (+0530), Soumen Dass wrote: ]
> Subject: Re: FVWM: thumbnail problem
>
> Ingo Wardinski wrote:
> > DestroyFunc Thumbnail
> > AddToFunc Thumbnail
> > + I Raise
> Seems fine to me. Try putting the xwd related part in a single line 
> (upto && part).

The problem is solved by discarding the silent option from the xwd
call. I guess my xwd is a bit outdated (running fvwm2.5.12 on SunOS
5.8). Anyway.
The problem now, my sun beeps everytime when I thumbnail a
window and get the message:

convert: Unable to frame image (frame is less than image size)

The current setting is

SetEnv fvwm_icon_size 64
DestroyFunc Thumbnail
AddToFunc Thumbnail
+ I Raise
+ I PipeRead "xwd -id $[w.id] | convert -scale $[fvwm_icon_size] -frame 1x1 -mattecolor black -quality 0 xwd:- png:$[HOME]/.fvwm/icon.tmp.$[w.id].png  && echo WindowStyle IconOverride, Icon $[HOME]/.fvwm/icon.tmp.$[w.id].png, StaysOnBottom || echo Nop"
+ I Iconify

I have to say that I tried several values for fvwm_icon_size, no
success.
Any suggestions a very appreciated
cheers
ingo