Subject: FVWM: firefox disapera on full screen.

From: Manu J <[email-masked]>
Date: Mon, 7 Feb 2005 09:23:40 +0530

Hi,
i'm running 2.5.11 and on pressing F11 firefox disappers from the screen
and the window list.I read through the archives.This was reported in the past.
Has his been fixed in 2.5.12?

--Manu

-- 
The shortest route to my heart is through my inbox
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: stu <[email-masked]>
Date: Mon, 7 Feb 2005 12:01:52 +0200

On Mon, 7 Feb 2005 09:23:40 +0530
Manu J <[email-masked]> wrote:

> Hi,
> i'm running 2.5.11 and on pressing F11 firefox disappers from the
> screen and the window list.I read through the archives.This was
> reported in the past.

Works properly for me - fvwm 2.5.12 and mozilla firefox 1.0.

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
   
Powered by Debian GNU/Linux

---

From: Bjoern Steinbrink <[email-masked]>
Date: Mon, 7 Feb 2005 11:39:43 +0100

> Has his been fixed in 2.5.12?

Fails here with fvwm 2.5.12, too. Sometimes it suceeds in going into
fullscreen mode, but then fails to switch back, i.e the window
disappears.

Bjoern

---

From: Manu J <[email-masked]>
Date: Mon, 7 Feb 2005 17:54:17 +0530

> fullscreen mode, but then fails to switch back, i.e the window

Running fvwm 2.5.12 now.Fails again.
As someone mentioned before if it's firefox doing exotic things why
doesn't it fail on XFCE?

--Manu

---

From: Jindrich Makovicka <[email-masked]>
Date: Mon, 07 Feb 2005 14:49:48 +0100

> fullscreen mode, but then fails to switch back, i.e the window

By mistake, I sent my reply only to Manu, so I am reposting it, with 
some corrections:

Firefox (and GTK2 Mozilla suite) binary from mozilla.org uses some 
hackish way of setting fullscreen, instead of using EWMH fullscreen hint 
properly. This is because Firefox is compiled for older versions of GTK, 
which didn't contain gtk_window_fullscreen(). If you build your own from 
source tarball with recent GTK, fullscreen will work. Also, at least 
Debian Firefox binary works for me, and probably packages for other 
distributions will too. I am not sure if it's really a FVWM bug, the 
whole fullscreen issue in X is _very_ fishy.

Regards,
-- 
Jindrich Makovicka

---

From: Dan Espen <[email-masked]>
Date: Mon, 07 Feb 2005 09:22:18 -0500

> >>Has his been fixed in 2.5.12?
...
> whole fullscreen issue in X is _very_ fishy.

Works flawlessly here using X, firefox from Mandrake 10.1
with latest Fvwm.

Well, actually, the menubar disappears, but I guess that's
on purpose.

-- 
Dan Espen                           E-mail: [email-masked]