Subject: FVWM: Battery state program

From: Tim Hanson <[email-masked]>
Date: Thu, 24 Feb 2005 04:06:33 -0800

Does anyone know of a little graphic (Swallowable into FvwmButtons) that
keeps track of battery life on a laptop?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 24 Feb 2005 13:44:17 +0000

> keeps track of battery life on a laptop?

xapm

-- Thomas Adam

-- 
I know nothing, and understand even less.

---

From: Rouben Rostamian <[email-masked]>
Date: Thu, 24 Feb 2005 08:45:22 -0500

> keeps track of battery life on a laptop?

That depends whether APM or ACPI is used for your laptop's
power management.  I use APM.  There is a very nice utility,
called asapm, that works with APM.  It has a 48x48 display
that shows the battery life graphically and numerically.
I swallow it into FvwmButtons.

You can get asapm from http://www.tigr.net/afterstep/download/

Asapm is a part of the Afterstep window manager however it
works just fine as a stand-alone utility in fvwm.  You don't
need the rest of Afterstep to compile and run asapm.

-- 
Rouben Rostamian

---

From: Tim Hanson <[email-masked]>
Date: Thu, 24 Feb 2005 06:58:49 -0800

Alas, it's ACPI.  It's a shame, because xosview has a prominent place in
my FvwmButtons display.  That also takes out xapm and others.  I wonder
if GNOME has something.

On Thu, 2005-02-24 at 15:09 +0100, Philipp Tölke wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Tim Hanson wrote:
> xosview has an option to do this:
> 
> $ xosview +battery - and it is swallowable:
> 
> <snip ~/.fvwm/config>
> Swallow "XOsview" 'Exec xosview -usedlabels -labels \
>                    -geometry -10000-10000 -disk -load \
>                    +cpu +mem +swap -net -battery -page -int'
> </snip>
> - --
> Philipp Tölke
> 
> Somehow I reached excess without ever noticing when I was
> passing through satisfaction.  -- Ashleigh Brilliant
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.0 (GNU/Linux)
> 
> iD8DBQFCHeAs3pjW15ah/noRAgGHAJ4ybQJGiRo9JF9LJrQeOkJKcqTqdQCg+OK4
> p9jgix0fzI0OSEsU9yb/8sY=
> =PNue
> -----END PGP SIGNATURE-----

---

From: David Vilar <[email-masked]>
Date: Thu, 24 Feb 2005 16:44:33 +0100

> my FvwmButtons display.  That also takes out xapm and others.  I wonder

I use wmacpi (http://himi.org/wmacpi/). The problem, at least in the
debian version, is that the main window doesn't refresh properly
outside window maker only the active icon does, thus, as far as I
know, making it impossible to swallow in FvwmButtons. Is there a way
to swallow an icon instead of the main window of a program?

Greetings,

David

-- 
David Vilar Torres			RWTH Aachen
Tel: (+49) 241 80 21611			Lehrstuhl f. Informatik VI
Fax: (+49) 241 80 22219			Ahornstr. 55
[email-masked]		D-52056 Aachen (Germany)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Parv <[email-masked]>
Date: Thu, 24 Feb 2005 13:45:07 -0500

in message <[email-masked]>,
wrote Rouben Rostamian thusly...
> > Does anyone know of a little graphic (Swallowable into
> > FvwmButtons) that keeps track of battery life on a laptop?
> 
> That depends whether APM or ACPI is used for your laptop's power
> management.  I use APM.  There is a very nice utility, called
> asapm, that works with APM.

I like it too.  It works w/ both APM & ACPI (well works w/ ACPI as
FreeBSD 5.3/i386 has /dev/apm for both to provide the relevant
information).

  - Parv

--

---

From: Chris Debenham <[email-masked]>
Date: Fri, 25 Feb 2005 15:51:20 +1100

On Thu, Feb 24, 2005 at 08:45:22AM -0500, Rouben Rostamian wrote in a legally binding way:
> Date: Thu, 24 Feb 2005 08:45:22 -0500
> From: Rouben Rostamian <[email-masked]>
> To: [email-masked]
> Cc: Tim Hanson <[email-masked]>
> Subject: Re: FVWM: Battery state program
> 

I use a fvwmscript to watch acpi battery level.
I have a small shell script 'bat_level' that just does
"acpi  | sed -e 's/^.*, \([0-9]*\)%.*$/\1%/g'"
to get the % value
This is called by FvwmApplet-ACPI (attached) which just displays this.
Swallow this via
*PanelBar: (2x1 Swallow (Kill) "FvwmApplet-ACPI" "FvwmScript FvwmApplet-ACPI") 

And bobs-your-uncle there it is. Change fonts etc to match your desktop as
needed

Chris

-- 
Is There Life Before Coffee?