Subject: FVWM: Resize problem on lyx

From: Uwe Pross <[email-masked]>
Date: Mon, 14 Feb 2005 18:03:56 +0100

Hi there,

I found a strange problem on my fvwm 2.5.11 when resizing
lyx. The window contents of the program are not resized. It
seems that the resize event is not passed to the program.
After executing WindowShade on-off or Recapture lyx updates
its contents.

The problem does not occur with version 2.4.3.

Any ideas where to look at?

Thanks in advance.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise your mail is discarded by a filter.
=-"-"-= http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Feb 2005 22:15:11 +0100

> Any ideas where to look at?

I've once looked into this, and I think it's a lyx problem.  I've
read something about incorrect Xt calls on the lyx website (?) and
that the lyx developers know that the problem is caused by these
calls.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Fri, 18 Feb 2005 10:59:44 +0100

Hi there,

On 17 Feb 2005 at 22:15:11 +0100, Dominik Vogt wrote:

> I've once looked into this, and I think it's a lyx
> problem.  I've read something about incorrect Xt calls on
> the lyx website (?) and that the lyx developers know that
> the problem is caused by these calls.

Thanks, Dominik. I was pretty sure that it is lyx fault.
But actually it is pretty difficult to explain to my collegues
why lyx works with older versions but not with newer.

Maybe can write a workaround using FvwmEvent e.g.:

*FvwmEvent: Cmd Function
*FvwmEvent: property_change CheckResizeLyx

Function CheckResizeLyx Current ("lyx") RecaptureWindow

Maybe I get this work.

Cheers, Uwe