Subject: FVWM: xterm under fvwm

From: Erich Hoffmann <[email-masked]>
Date: Tue, 1 Feb 2005 21:27:34 +0100

Hello all.

I hope this isn't too often answered, my googeling (which sure may
be insufficient) didn't help, partly because the combination of "fvwm2"
and "xterm" gave such a wealth of results.

   On a fvwm2-2.4.18 on a Slackware 10 system I'd like to use xterm.
I have 2 desktops with 3x3 viewports.  When an xterm is started on
one viewport, the function keys (F1 for "menu", F10 for "emacs" &c)
won't work any more on the same desktop - only on the other one.  More,
when I have that xterm running and I press a function key > 9 , a tilde
( ~ ) shows up on xterm.  The other desktop keeps working fine.  I have
the same problem with rxvt, while gnome-terminal and kterm work fine.

Hope I can express myself, my computer english is somewhat poor.

Thanks for any help,

erich

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Spaceborne Calin <[email-masked]>
Date: Thu, 3 Feb 2005 15:33:43 +0100 (CET)

--- Erich Hoffmann <[email-masked]> a écrit : 
> won't work any more on the same desktop - only on the other one. 

please post our keybindings from the config file

> More,

this is not fvwm related 

> Hope I can express myself, my computer english is somewhat poor.

		
Découvrez le nouveau Yahoo! Mail : 250 Mo d'espace de stockage pour vos mails ! 
Créez votre Yahoo! Mail sur http://fr.mail.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erich Hoffmann <[email-masked]>
Date: Mon, 7 Feb 2005 07:58:57 +0100

Hello!

>  --- Erich Hoffmann <[email-masked]> a écrit : 
[...]
> please post our keybindings from the config file

Here it is:

~~~~~~~~~~~~~~~~~~~~~~~\

DeskTopSize 3x3
Module FvwmPager 0 1
# [...]
# some simple default key bindings:
Key Next         A       SCM     Next [*] Focus
Key Prior        A       SCM     Prev [*] Focus
# [...]
# "Running Linux" p. 370 
Key Up      A   C   Scroll +0    -100
Key Down    A   C   Scroll +0    +100
Key Left    A   C   Scroll -100    0
Key Right   A   C   Scroll +100    0
Key Left    A   M   GotoDesk -1 0 1
Key Right   A   M   GotoDesk +1 0 1
#
# FVWM FAQ 3.9.
# 
Key Tab A M WindowList Root c c NoDeskSort
Key F2  R   N   Exec kppp
Key F3  R   N   Exec kmail
Key F4  R   N   Exec opera
Key F5  R   N   Exec kdvi
Key F6  R   N   Exec kghostview
Key F7  R   N   Exec mozilla
Key F8  R   N   Exec gvim -geometry 92x40
Key F9  R   N   Exec emacs .
Key F10  R   N   Exec exec xterm -geometry 90x40
Key F11  R   N   Exec gnome-terminal 
Key F12 R N Exec xterm -geometry 90x40 -e slrn

~~~~~~~~~~~~~~~~~~~~~~~/

Thank you,

erich

---

From: Spaceborne Calin <[email-masked]>
Date: Mon, 7 Feb 2005 17:01:42 +0100 (CET)

> > please post our keybindings from the config file

If i recall correctly this means that those keys start the programs 
only in the context of the root window
Maybe you should use A instead of R like this

Key F10 A N Exec exec xterm 

I don't have a man page here so i can't verify