Subject: FVWM: WindowShade draw error

From: Uwe Pross <[email-masked]>
Date: Mon, 14 Feb 2005 22:34:47 +0100

Hi there,

I noticed a strange drawing behaviour when using the
following setup on at least 2.5.12:

TitleStyle Height 16
Style * HandleWidth 4
BorderStyle -- HiddenHandles NoInset 

The border of a shaded window seems to be broken. A
screenshot can be found at
http://www-user.tu-chemnitz.de/~uwp/download/windowshade16.gif

The problem disapears when setting window height to another
value than 16:
http://www-user.tu-chemnitz.de/~uwp/download/windowshade15.gif
http://www-user.tu-chemnitz.de/~uwp/download/windowshade17.gif

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise your mail is discarded by a filter.
=-"-"-= http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikko Heiskanen <[email-masked]>
Date: Tue, 15 Feb 2005 20:12:08 +0200

> http://www-user.tu-chemnitz.de/~uwp/download/windowshade17.gif

I'm wondering if that could be font-related. Have you tried with xft?

Mikko

---

From: Uwe Pross <[email-masked]>
Date: Tue, 15 Feb 2005 19:58:14 +0100

Hi there,

> I'm wondering if that could be font-related. Have you tried with xft?

I tried:

WindowFont -*-fixed-medium-r-*-*-13-*-*-*-*-*-*-*
WindowFont -*-fixed-medium-r-*-*-16-*-*-*-*-*-*-*
WindowFont -*-helvetica-medium-r-*-*-16-*-*-*-*-*-*-*
WindowFont "xft:Sans:Medium:Roman:size=10:encoding=iso10646-1"

which changes the titlebar font but the problem remains :-\

Cheers, Uwe