Subject: FVWM: placement method: not on active window

From: Emilie Ann Phillips <[email-masked]>
Date: Mon, 7 Feb 2005 11:18:49 -0500

Is there a placement style that avoids putting a new window on top of
the currently focused window?

EmilieAnn
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Rubin <[email-masked]>
Date: Mon, 07 Feb 2005 12:05:27 -0500

Kind of.  There is

Style * MinOverlapPlacement
or
Style * MinOverlapPercentPlacement

Either of these styles tells fvwm to place windows overlapping either the 
smallest total amount of other stuff or the smallest percent of other stuff. 
You can configure it in even more detail with

Style * MinOverlapPlacementPenalties normal ontop icon sticky below strut

where normal, ontop, icon, sticky, below and strut are all numbers indicating 
the priority of overlapping that particular thing.  So setting strut to 75 will 
pretty much guarantee that your ewmhbasestruts are never overlapped.  Also there is

Style * MinOverlapPercentPlacementPenalties cover_100 cover_95 cover_85 cover_75

Although I'm not 100% sure how those arguments work it is explained in the fvwm 
man page.  Hope this is what you were looking for.

-Scott