Subject: FVWM: peksystray displaying just a black rectangle?

From: Manu J <[email-masked]>
Date: Mon, 7 Feb 2005 21:18:30 +0530

Hi,
I'm trying to get a system tray working in fvwm and neither
peksystray or docker works for me.

When i run peksystray all it displays is a black rectangular bar.
And when i launch xmms or gaim which has system tray plugins enbaled
the peksystray catches the events but icons fails to show up  in the black
rectangular bar.
Here is the output i get when i run peksystray and the launch xmms with
system tray plugin enabled.

[09:20 PM][manu:manu]$ peksystray 
handle_event
Width: 1         Heught:1       Border: 0
add_tray_icon: 10485811
handle_event

if i run xmms withour peksystray i get the xmms system tray icon on my 
desktop which woks (opens a menu etc).This is not true for gaim.

So how can i get peksystray working ? :-)

I have seen lots of configs with peksystray swallowed...can't figure
out what's wrong with mine.

Info
----
fvwm 2.5.12
Slackware 10.0

--Manu

-- 
The shortest route to my heart is through my inbox
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Vincent Bernat <[email-masked]>
Date: Mon, 07 Feb 2005 18:00:22 +0100

OoO Vers la fin de l'après-midi  du lundi 07 février 2005, vers 16:48,

> out what's wrong with mine.

I  have the same  problem here.  There are  also configs  that swallow
directly the  dock icon, however, newer  apps does not  display a dock
icon if there is no Freedesktop-compliant systray.
-- 
printk("Penguin %d is stuck in the bottle.\n", i);
	2.0.38 /usr/src/linux/arch/sparc/kernel/smp.c
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark <[email-masked]>
Date: Tue, 8 Feb 2005 00:56:40 +0100

Hi, I kinda had the same issue here, it is just that peksystray really updates 
it's background poorly or something.. didn't really catch all the apps also 
so now I use kicker (from kde). Just remove all options except systray and 
swallow it in a fvwmbuttons.

If u want it transparant you will need to run kdesktop as well .. 

Mark