Subject: Re: FVWM: Multiple "Untitled" X-applications

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 3 Jan 2005 17:39:38 +0000

On 30 Dec 2004 23:32:23 +0200, Mikko Heiskanen wrote:
> 
> I have a problem with an idea to use a program multiple times in
> FvwmButtons for different mailboxes (wmymail). The problem is that the
> wmymail doesn't allow to give another name for the executed instance
> from commandline

> I tried to use sleep 1 with the command execution, but the results
> remain same. I would greatly appreciate any help as the wmymail program
> is something I really would like using in this setup.

Try to ask the author of wmymail to add configurable window name (or
resources) from the command line. It is just several lines of code.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Mikko Heiskanen)
Date: Tue, 4 Jan 2005 13:43:13 +0200 (EET)

Mikhael Goikhman
> resources) from the command line. It is just several lines of code.

We tried to hack wmymail, but ended up killing X with it :D
I found a workaround. I used program invocation like this:

*MAIL1 (Title box1, Swallow (UseOld, Kill) "Untitled" \
    `Exec sleep 1 && MAIL=$[HOME]/Mail/box1 && wmymail -w`, \
#         ^^^^^^^
    Action (Mouse 1) `Exec $[MAILPRG] -f $[HOME]/Mail/box1`)

*MAIL2 (Title box2, Swallow (UseOld, Kill) "Untitled" \
	`Exec sleep 2 && MAIL=$[HOME]/Mail/box2 && wmymail -w`, \
#         ^^^^^^^
    Action (Mouse 1) `Exec $[MAILPRG] -f $[HOME]/Mail/box2`)

... And so on. It works, only takes so many secons to start
up, as you have mailboxes. And for those of you who are going
to try the wmymail program, a word of warning: do NOT use
wmymail's -c switch, which executes a user defined MUA
program on click. It deleted my inbox! That's why I use Titles
on FvwmButtons.

Mikko