Subject: FVWM: Another key mapping question...(hopefully not FAQbait

From: Glenn Forbes Fleming Larratt <[email-masked]>
Date: Tue, 11 Jan 2005 11:17:07 -0600 (CST)

As an experiment, I've created the config

Key Home W      M       Move +0 +0
Key Left W      M       Move +0 w
Key End W       M       Move +0 -0
Key Up W        M       Move w +0
Key Down W      M       Move w -0
Key Prior W     M       Move -0 +0
Key Right W     M       Move -0 w
Key Next W      M       Move -0 -0
Key Insert W    M       Iconify

..with the idea that, by holding down the Meta key and pressing the
appropriate cardinal direction key, the focused window will jump to
that edge/corner of the desktop.

Problem: Mozilla uses Meta-Left for "Back".

Is there any way to define an exception case for a particular window,
or do I need to suck it up and configure (and learn) a different Modifier?

	-g

				Glenn Forbes Fleming Larratt
				Rice University Networking
				[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 11 Jan 2005 20:02:46 +0000

> or do I need to suck it up and configure (and learn) a different Modifier?

You may try to additionally press Shift or NumLock to make it trigger by
Mozilla and not by fvwm.

Or define an exception (you need 2.5.11+ for this):

  Key (Mozilla-bin) Left W M --
  Key (Firefox-bin) Left W M --
  Key               Left W M Move +0 w

Regards,
Mikhael.