Subject: FVWM: How to define a double click on FvwmButtons?

From: Yin susu <[email-masked]>
Date: Thu, 20 Jan 2005 02:30:26 +0800

As,i know,
*MyButtons: (1x5, Frame 0, Icon 48x48/gimp.png, \
  Action(Mouse 1) "Exec exec gimp")
use this,I can start up gimp by click on the button.

  But how could i start gimp by double click on the buttons?
It seems mouse 3 or mouse 4 does no effect.

-- 
Happy for nothing
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephen Dennison <[email-masked]>
Date: Wed, 19 Jan 2005 14:10:10 -0500

> It seems mouse 3 or mouse 4 does no effect.

Try binding a function to the mouse button you'd like to double click.
 Then in the function have it run the gimp on double click and
optionally something else on single click.
Ex:
*MyButtons: (1x5, Frame 0, Icon 48x48/gimp.png, \
 Action(Mouse 1) DoSomething)

DestroyFunc DoSomething
AddToFunc DoSomething
+ C Echo here is an optional single click if you want it for something
+ D Exec exec gimp

---

From: Tavis Ormandy <[email-masked]>
Date: Wed, 19 Jan 2005 19:58:11 +0000

>   But how could i start gimp by double click on the buttons?

Define a function that starts gimp on double click, for example:

AddToFunc DoubleExec D Exec $*

Then bind Mouse 1 to "DoubleExec gimp" instead.

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Yin susu <[email-masked]>
Date: Fri, 21 Jan 2005 00:05:10 +0800

en,I have tried this,But something isnot go in the right way.

When I Click/Double click,It can run the echo command.
Only when I click the button by three times,the gimp will be run.

So,it does a effect to exec gimp by click the button 3 times...

---

From: jpkotta <[email-masked]>
Date: Thu, 20 Jan 2005 11:16:57 -0600

I have a similar problem with FvwmIconMan.  I have this:

*DesktopIconMan: action     Mouse   3       N       sendcommand  
WindowMenuOrCloseIconMan

DestroyFunc WindowMenuOrCloseIconMan
AddToFunc WindowMenuOrCloseIconMan
+ I     Menu WindowOpsSmall c+0 -101m
+ D     Close

I have to triple click to close, but if I change it to '+ C Close', it  
closes with a single click.

jpkotta