Subject: FVWM: FvwmButtons geometry bug

From: jpkotta <[email-masked]>
Date: Mon, 31 Jan 2005 00:42:32 -0600

For a while I've had a button bar at +0+0, but now I want to move it.   
Unfortunately, I've had quite a bit of trouble doing this.  When I use the  
config below, with the "Module FvwmButtons DesktopButtons -g +0+116", I  
get a really small (16x16) FvwmButtons at the correct location.  If I use  
"Module FvwmButtons DesktopButtons", I get an FvwmButtons at +0+0 and of  
the correct size.

Thanks,

jpkotta

Version info:

fvwm 2.5.12 compiled on Oct 24 2004 at 03:36:42
with support for: ReadLine, XPM, PNG, Shape, XShm, SM, Xinerama, XRender,  
XFT, NLS

Config file:

KillModule FvwmButtons
DestroyModuleConfig DesktopButtons: *

*DesktopButtons: Geometry +0+116
*DesktopButtons: ButtonGeometry 16x16
*DesktopButtons: Columns 8
*DesktopButtons: BoxSize smart

*DesktopButtons: (8x8, Frame 0, Swallow "xclock" "Exec exec xclock")

Module FvwmButtons DesktopButtons -g +0+116
#Module FvwmButtons DesktopButtons
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Tue, 1 Feb 2005 14:43:16 +1100

> When I use the  

Hmmm, there seems to be a bug with the "ButtonGeometry" command.

For now, use the "Size" command.

ie.

KillModule FvwmButtons DesktopButtons
DestroyModuleConfig DesktopButtons: *
 
*DesktopButtons: Geometry +0+116
# *DesktopButtons: ButtonGeometry 16x16
*DesktopButtons: Columns 8
*DesktopButtons: BoxSize smart

*DesktopButtons: (Size 32 32, Frame 0, Swallow "xclock" "Exec exec xclock")

Module FvwmButtons DesktopButtons

I'll look into the ButtonGeometry bug later.

SCoTT. :)