Subject: FVWM: FvwmButtons and fullscreenmodes in recent fvwm broken?

From: Trilobit <[email-masked]>
Date: Fri, 14 Jan 2005 18:02:08 +0100

Hi,

I recently updated my Debian Linux Box.
And so I got version 2.5.12 of fvwm installed.
After starting X11 with the new fvwm and my old working configuration
for 2.5.x FvwmButtons hangs using 99percent of CPU time.
And, after moving a window (in not opaque style), seems to freeze fvwm
for some seconds. And so, giving after the freeze following error message
 (the only on in the whole .xsession-errors file):
----------------------------
FVWM][FlushMessageQueue]: <<ERROR>> Failed to write descriptor to 'FvwmButtons':
- select rc=0
- terminate signal=N
---------------------------
So I installed, just for testing, version 2.5.8 from www.fvwm.org, the problem
had gone.

Some days later I was watching a movie with mplayer, I realised that the fullscreen
window of it did not pop up in front of every window (somewhere above Layer 7),
but stayed at Layer 4, hidden by FvwmButtons which stays fixed at Layer 7.
I hadn't changed the mplayer version for months, so I don't think it is an mplayer
problem. And gqview has the same problem now. :-( 

So I think it could possibly be fvwms problem, am I right?
Is there a possibility to make fullscreen windows go to the very top, maybe with
scripting (but only if the window is truly in fullscreen mode)?

PS: Now I'm using fvwm 2.5.8 on an Debian-testing-Linux x86 Box,
with XFree86 Version 4.3.99.12.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Jan 2005 12:55:17 -0500

>  (the only on in the whole .xsession-errors file):

Possibly you have a ModulePath statement in your config file.
Remove it.

> but stayed at Layer 4, hidden by FvwmButtons which stays fixed at Layer 7.

FvwmButtons doesn't go to Layer 7 by default, look in your config.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Trilobit <[email-masked]>
Date: Sat, 15 Jan 2005 12:03:30 +0100

Dan Espen writes:
> Trilobit  writes:

No I don't have an "ModulePath" statement in my fvwm config files,
neither in the system wide nor my own config.
I'm sure because I grep'ed for it.

> FvwmButtons doesn't go to Layer 7 by default, look in your config.
No you missunderstood. I configured FvwmButtons to stay on Layer 7, so that no
window can overlap it, except for apps which use fullscreen, like mplayer or gqview.
Now FvwmButtons stays really ever over everything even over the fullscreen 
windows (e.g. from mplayer). 
Laying fullscreen apps to Layer 8 is no solution because:
1.) then they are ever in front even in windowed mode and don't go behind
2.) I have to configure it for every single fullscreenapp
Laying FvwmButtons in Layer 4 is no solution because then every other
window can cover it. :-(
So I need a flexible solution like a script I fear, or something is broken 
in new fvwm versions.

thx for advance
Mario

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 16 Jan 2005 05:42:16 +0100

On Fri, Jan 14, 2005 at 06:02:08PM +0100, Trilobit wrote:
> [SNIP]

For this problem try:

Style *  EWMHUseStackingOrderHints

There is a "long" discussion on this subject starting here:

http://www.hpc.uh.edu/fvwm/archive/0410/msg00199.html

Regards, Olivier