Subject: FVWM: Fvwm and skype

From: [email-masked]
Date: Sat, 11 Dec 2004 12:02:29 +0100

Hi there,

I have a question regarding an application called skype,
which enables one to use your pc as a telephone via internet.
When skype starts up the main application is started but also
a little window is opened which contains nothing but a little
skype-related icon. This window can be found in the windowlist
and i have the feeling that there should be some better place
where this icon can be put to... Does someone know what this
window is ment for and is there a 'predefined way' to handle
this window. i have other applications showing similar
behaviour.

>From the FvwmIdent Module launched on the skype window

Name: skype
Icon Name: skype
Class: Skype
Resource: skypedoc
Transient: no

my fvwm is...

fvwm 2.5.12 compiled on Oct 29 2004 at 20:48:13
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM, Bidi text, Xinerama, XRender, XFT, NLS

fvwm comes with NO WARRANTY, to the extent permitted by law. You may
redistribute copies of fvwm under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

sincerely
Matthias Pfeifer, germany

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Christian Schröder <[email-masked]>
Date: Sat, 11 Dec 2004 13:18:10 +0100

[email-masked] wrote:
| Hi there,
|
| a little window is opened which contains nothing but a little
| skype-related icon. This window can be found in the windowlist

this small icon is a sys-tray icon. There is no way to switch it off in
skype itself.

| and i have the feeling that there should be some better place
| where this icon can be put to... Does someone know what this

You could use a sys-tray programm. Like peksystray or some addons for
gnome-panel, xfce-panel, the kde panel has a notification area too.

you can swallow peksystray in a FvwmButtons bar.

| window is ment for and is there a 'predefined way' to handle
| this window. i have other applications showing similar
| behaviour.
|
| From the FvwmIdent Module launched on the skype window

You could put a special style on skypedoc which skips the windowlist.
But the systray programm is a better solution IMO.

Regards
Christian

- --
~   » celebrate the winter of sorrow «

Did you move a lot of KOREAN STEAK KNIVES this trip, Dingy?

---

From: Micha Feigin <[email-masked]>
Date: Sat, 11 Dec 2004 18:24:31 +0200

> where this icon can be put to... Does someone know what this

This window is meant to go into the dockbar for kde or gnome (like the rectangle
with icons on the right of the windows task bar). There is a program called
docker, that may be able to swallow it.

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>