Subject: FVWM: raise when WarpToWindow

From: Emilie Ann Phillips <[email-masked]>
Date: Thu, 16 Dec 2004 15:52:02 -0500

Dear All,

>From reading the man page, I believe that WarpToWindow should not
raise the window in question.  However, when I use WarpToWindow it
does raise the window. So
a) did I missread the man page?
b) is there some way to not raise the window?
I am using FVWM version 2.4.19

The following .fvwm2rc is sufficient to produce the behavior

AddToFunc Set-Reference
        + I Piperead 'echo "Setenv $0_Id  $[w.id]"'
AddToFunc Goto-Reference
        + I Piperead "echo 'WindowId $$$$[$0_Id] WarpToWindow 50 50'"
Key 1           W       MS      Set-Reference 1
Key 1           A       M       Goto-Reference 1

EmilieAnn
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Thu, 16 Dec 2004 22:31:42 +0000

> I am using FVWM version 2.4.19

There is, this solution is tested with 2.5.12, I think it should work for you.

>         + I Piperead "echo 'WindowId $$$$[$0_Id] WarpToWindow 50 50'"

With something like this:

WindowId $0 Piperead "echo WindowId root WarpToWindow $(($[w.x]+($[w.width]/2)))p $(($[w.y]+($[w.height]/2)))p"

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].