Subject: FVWM: ReadDecorFace error ??

From: Soumen <[email-masked]>
Date: Mon, 06 Dec 2004 23:02:47 +0530

Hi,

I'm using fvwm 2.5.9 on my Intel PIII 950 mhz with 2.4.22-1.2115.nptl
kernel (Fedora Core1).

Upon starting FVWM, the following error messages are sent to console:

<messages>
[FVWM][ReadDecorFace]: <<ERROR>> unknown style Font: Font               
       xft:Verdana:antialias=True:pixelsize=10_cdim: --- not moved
0x08138f78 'FvwmTaskBar'
</messages>

There is no problem in displaying the font. I have also tried changing
the font but this persists with _any_ font I use. Any ideas?

Regards,
-- 
Soumen Dass < soumen_dass at mtnl dot net dot in >
Registered Linux User # 272639 - Linux nova 2.4.22-1.2115.nptl i686

"Laugh while you can, monkey-boy."
-- Dr. Emilio Lizardo
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 12 Dec 2004 13:30:11 +0100

On Mon, Dec 06, 2004 at 11:02:47PM +0530, Soumen wrote:
>        xft:Verdana:antialias=True:pixelsize=10

There seems to be a syntax error in some configuration line,

>_cdim: --- not moved 0x08138f78 'FvwmTaskBar'

It's a debug message you can safely ignore.

> the font but this persists with _any_ font I use. Any ideas?

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Soumen <[email-masked]>
Date: Sat, 18 Dec 2004 17:05:24 +0530

On Sun, 12 Dec 2004 13:30:11 +0100
Dominik Vogt <[email-masked]> wrote:

> > I'm using fvwm 2.5.9 on my Intel PIII 950 mhz with
> > 2.4.22-1.2115.nptl kernel (Fedora Core1).
> > 
 
It could be due to these fonts I'm using:

SetEnv      ALxftFont1  "xft:Verdana:antialias=True:pixelsize=10"
SetEnv      ALxftFont2  "xft:Tahoma:antialias=True:pixelsize=12"

The fonts are being used in Titlebar & menus. They are being displayed
properly. If it is displaying them properly, then why this error is
coming up?

Thanks for your response,

He who loses, wins the race,
And parallel lines meet in space.
		-- John Boyd, "Last Starship from Earth"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 18 Dec 2004 09:24:05 -0500

> properly. If it is displaying them properly, then why this error is

Without seeing where you really are using those fonts, it's hard to
tell.  One way I was able to generate that message is by doing this:

AddToDecor DecorBase AddButtonStyle 2 Font \
 "xft:Verdana:bold:antialias=True:pixelsize=14"

The error indicates that the word "Font" is invalid in a AddButtonStyle
command.

-- 
Dan Espen                           E-mail: [email-masked]