Subject: FVWM: background color of a button

From: jpkotta <[email-masked]>
Date: Thu, 09 Dec 2004 17:44:56 -0600

I'm playing with my decor styles.  I have a gradient for the background of  
the title and a miniicon for button 1 (the only button I have).  What I  
want is for the button's background color to be the same as the first  
color of the gradient.  In my current setup, all I can do is set the  
button to the miniicon; I can't set the color.  If I use UseTitleStyle, I  
can get a gradient, but that doesn't look good.

	TitleStyle      Active (HGradient 64 blue2 black -- Flat)
	TitleStyle      Inactive (HGradient 64 grey51 black -- Flat)
	TitleStyle      LeftJustified

	#ButtonStyle     all     -- UseTitleStyle Flat
	ButtonStyle     all     Active (Solid blue2 -- Flat)
	ButtonStyle     all     Inactive (Solid grey51 -- Flat)
	ButtonStyle     1       MiniIcon -- Flat

Thanks,

jpkotta

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 12 Dec 2004 13:51:21 +0100

> 	ButtonStyle     1       MiniIcon -- Flat

You need to use multiple button styles, but the "ButtonStyle"
command resets the old settings.  You need to use AddButtonStyle:

  buttonstyle all active (solid blue2 -- flat)
  buttonstyle all inactive (solid grey51 -- flat)
  addbuttonstyle 1 miniicon
  ^^^

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]