Subject: FVWM: wmacpi - works only when iconified - and what about fvwmbuttons?

From: hubert lubaczewski <[email-masked]>
Date: Mon, 29 Nov 2004 19:33:36 +0100

hi
i'm runnig linux debian unstable with fvwm 2.5.12 and wmacpi 2.0.
i wanted to make something like wm's wharf with wmacpi and some other
docklets.
but the problem is that when i run wmacpi it doesnt refresh it's
display.
it just keeps the same thing anf doesn't change a bit.
when i switch to another page/desktop and then come back - display of
wmacpi is refreshed, but again frozen.
i was able fo work around it using
Style wmacpi Iconic (if i recall correctly).
since then - it works. when i start wmacpi, it comes as icon, and
displays everything just fine.
but then i added it to my fvwmbuttons instance with simple
*depeszWharf: (1x1, Swallow(Close,Respawn,UseOld) 'wmacpi' 'Exec exec wmacpi')
and, to my surprise, i got exectly the same result as before - i.e. it
doesn't refresh itself.

do you have any clue on what might be broken?

best regards

depesz

-- 
hubert lubaczewski
Network Operations Center
eo Networks Sp. z o.o.

---

From: David Vilar <[email-masked]>
Date: Tue, 30 Nov 2004 10:25:08 +0100

> but the problem is that when i run wmacpi it doesnt refresh it's

This seems to be a bug of wmacpi, at least in the debian version:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=280495

Greetings,

David

-- 
David Vilar Torres			RWTH Aachen
Tel: (+49) 241 80 21611			Lehrstuhl f. Informatik VI
Fax: (+49) 241 80 22219			Ahornstr. 55
[email-masked]		D-52056 Aachen (Germany)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].