Subject: FVWM: fvwm, xnest, grabfocus, grab all events...

From: xavier <[email-masked]>
Date: Thu, 4 Nov 2004 10:26:25 -0500

Hi,

I'm trying to  use xnest, to work around the 255 clients limit of X.

so inside xnest, i'm launching  (of course) fvwm.

however, almost all my keybindings, mouse actions (thoses
called with a modifier) are interpreted by my main fvwm ;
so i can't resize windows with alt+click, i'm forced 
to try to grab the edge of the window to be resized to do that.
(alt+click resize the xnest window)

is there any way to pass every thing to xnest when xnest is focused ?

i looked at GrabFocus, FPGrabFocus, but it seems that
it's not what i'm looking for.

thanks

-- 
xavier
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 Nov 2004 12:05:59 -0500

> I'm trying to  use xnest, to work around the 255 clients limit of X.

If you tell us the X server you are using, perhaps there
is a way to increase that.

> is there any way to pass every thing to xnest when xnest is focused ?

What you are looking for is per window key bindings to override
the global bindings you've set for Fvwm.  Unless I haven't been
paying attention, I don't think there is a way to do that.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: xavier <[email-masked]>
Date: Thu, 4 Nov 2004 15:30:33 -0500

> is a way to increase that.

i tried :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=233569

bottom line :Breaking binary compatibility
with Xlib modules is probably a very bad idea.

> paying attention, I don't think there is a way to do that.

wouldn't it be nice to be able to do that ?

so if you want to use, say,
shift left and shift right to move your mouse for 10 pixels,
and in gnome-term you perfer using it for switching 
from tab to tab, you have the possibility ?

clobbering functions keys is pretty common...

(F1 is so sparsingly used that i use it for launching xterm...
however, when i need F1, i'd like to have the choice...)

thanks

---

From: Scott Smedley <[email-masked]>
Date: Fri, 5 Nov 2004 10:30:03 +1100

Hi Xavier,

> wouldn't it be nice to be able to do that ?

Yep. & you can.

Key M A M Function Mail
Key (Xnest) M A M --

The above invokes my emailer (mutt) when I press Alt-M _except_ when an
Xnest window is focussed, whereby the Alt-M binding is passed through to the
(in this case) nested FVWM session.

The same logic can be used for your gnome-term windows or whatever else
you'd like.

This feature was introduced in FVWM 2.5.11.

Bye,

SCoTT. :)

---

From: Parv <[email-masked]>
Date: Fri, 5 Nov 2004 00:17:00 -0500

in message <[email-masked]>,
wrote Scott Smedley thusly...
>
> Key M A M Function Mail
> Key (Xnest) M A M --
> 
> The above invokes my emailer (mutt) when I press Alt-M _except_
> when an Xnest window is focussed, whereby the Alt-M binding is
> passed through to the (in this case) nested FVWM session.
...
> This feature was introduced in FVWM 2.5.11.

Ooh! Wow! Thanks much Scott for bringing to my attention.

(And i thought i had read the "new features/changelog" close enough
to remember it myself.)

Now, i think that key binding syntax should be synchronized w/ one
of the existing syntaxes(?) (e.g. (Menu)Style, functions like Test)
.. not that i have any problems w/ the current (non)situation.

  - Parv

--

---

From: [email-masked] (Mark Rainford)
Date: Fri, 05 Nov 2004 09:31:52 +0000

If you want your customary key combinations to go to the Xnest'ed fvwm try this oddity when Xnest has the focus: press the NumLock key, work in the Xnest window, unpress NumLock when finished in the Xnest window. It works with VNC - YMMV. If I needed this a lot I'd try to get the outer fvwm to press/unpress NumLock for me.

I've never got to the bottom of whether this is a bug, a feature or maybe even deliberate functionality. The outer fvwm ignores everything I do when NumLock is down because I don't have that modifier in any of my key combinations. This means the keys go through to the fvwm inside the VNC session. Somewhere along the line the NumLock modifier seems to get dropped, so by the time the keypresses reach the nested fvmw, they match my normal WM config. and do the expected operations on the windows in the nested session.

-- 

Regards,  Mark.

---

From: xavier <[email-masked]>
Date: Fri, 5 Nov 2004 09:24:32 -0500

> The same logic can be used for your gnome-term windows or whatever else

waahoo, awesome !
way cool.

it works !

thanks a lot !