Subject: FVWM: (un)shade windows with BorderWidth 0

From: Frank Gruellich <[email-masked]>
Date: Sat, 6 Nov 2004 21:05:11 +0100

Hello again

thanks to Scott and Mikhael for helping with this Title thing.

There occures another strange effect then a windows style is BorderWidth
0 and it's unshaded.  This is my setup for now:

  Style * NoTitle, NoHandles, BorderWidth 0, WindowShadeSteps 25
  
  DestroyFunc	ToggleShade
  AddToFunc	ToggleShade
  + I ThisWindow (Shaded) WindowStyle NoTitle
  + I ThisWindow (Shaded) UpdateStyles
  + I ThisWindow (Shaded) WindowShade false
  + I TestRc (1) Break
  + I WindowStyle TitleAt$0
  + I UpdateStyles
  + I WindowShade
  + I WindowStyle Title
  
  DestroyFunc	StartFunction
  AddToFunc	StartFunction
  + I exec fvwm-root -r $HOME/.fvwm/backgrounds/background.png
  
  DestroyFunc	InitFunction
  AddToFunc	InitFunction
  + I Exec xterm +sb -g 128x48+120+75
  
  Key Left	TFISW CS ToggleShade Left
  Key Down	TFISW CS ToggleShade Bottom
  Key Up	TFISW CS ToggleShade Top
  Key Right	TFISW CS ToggleShade Right

I can shade, the title appears like a charm, but when I unshade the
window its content isn't refreshed anymore.  I made some screenshots:
<URL:http://www.der-frank.org/tmp/fvwm-shade.html>.  It happens with any
window I've tried (xterm, aterm, xcalc, FvwmConsole, mozilla).  The
application stayes alive, eg. if it's a shell, I can send commands to it
and close it, too.  Neither this, 'Refresh', 'RefreshWindow',
'UpdateStyle' nor 'UpdateDecor' make the window to redraw itself.  I can
issue a 'WindowStyle BorderWidth 0' again to the window to work around
this.  It doesn't happen with BorderWidth 1.

According to the manpage zero is a valid value for BorderWidth.  I am
using CVS from some hours ago.  What did I wrong?

Thanks in advance,
 regards, Frank.
-- 
Sigmentation fault
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Sun, 7 Nov 2004 16:20:25 +1100

Hi Frank,

> another strange effect then a windows style is BorderWidth 0

If you unshade before you remove the title it appears to work ok:

  DestroyFunc ToggleShade
  AddToFunc	ToggleShade
  + I ThisWindow (Shaded) WindowShade false
  + I TestRc (Match) WindowStyle NoTitle
  + I TestRc (Match) UpdateStyles
  + I TestRc (Match) Break
  + I WindowStyle TitleAt$0
  + I UpdateStyles
  + I WindowShade
  + I WindowStyle Title

SCoTT. :)