Subject: FVWM: FocusFollowsMouse and NeverFocus styles

From: George "Nephrite" Potapov <[email-masked]>
Date: Wed, 3 Nov 2004 11:48:54 +0300

Is this a correct behavior, or a bug?

I set 

Style FvwmButtons NeverFocus

and then 

Style * FocusFollowsMouse

After that FvwmButtons start assuming focus when I move mouse over it which is not needed. If those commands are used in reverse order (i.e. FocusFollowsMouse first, and then NeverFocus) then FvwmButtons stop accepting mouse clicks.

I need that FvwmButtons accept mouse clicks but not keyboard focus, which is achieved with NeverFocus without using FocusFollowsMouse.

-- 
wbr,
George 'Nephrite' Potapov
Inline Technologies
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Christian Schröder <[email-masked]>
Date: Wed, 03 Nov 2004 11:58:24 +0100

Hi,
> Is this a correct behavior, or a bug?

it is correct.

> I need that FvwmButtons accept mouse clicks but not keyboard focus, which is achieved with NeverFocus without using FocusFollowsMouse.

you have to change the order of your commands.

the
style *
overrides any other
style specialwindow
wihich was stated before.

Regards
Christian

---

From: George "Nephrite" Potapov <[email-masked]>
Date: Thu, 4 Nov 2004 10:21:11 +0300

> wihich was stated before.

But I already stated in my previous message that changing order doesn't do what I want.