Subject: FVWM: way to "dump" current config values?

From: [email-masked]
Date: Sun, 28 Nov 2004 07:37:03 +0000

I fired up fvwm-themes in order to help get started with
building a nice fvwm environment for myself.  I really like
one of the themes that come bundled with it and I'd like to
use that as a basis for building my own. However, there is
no single config file for these themes.  As near as I can
tell, it reads a twisty maze of files under a share dir.
Is there a way to "dump" the config of FVWM at a given time
so that I might use it as my .fvwm2rc?

Thanks
GJ
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 28 Nov 2004 09:02:57 +0000

> so that I might use it as my .fvwm2rc?

fvwm-themes-config --expand-rc >long-fvwm2rc

Although the whole idea under fvwm-themes is not to have one long config,
but one small config for every logical thing, so you may just create your
own partial theme (a matter of one mkdir+cp command) with, for example,
only window buttons tweaked without a need to edit menus, and so on.

Regards,
Mikhael.