Subject: FVWM: (fwd) help on fvwm

From: Xue Ruini <[email-masked]>
Date: Wed, 17 Nov 2004 11:33:17 +0800

I am using a perl script of fvwm-theme (not the project of sf.net) to change my
decors dynamically. For example, the command: fvwm-theme -decor 23oz would generaet:

ButtonStyle 1 ActiveUp Pixmap 23oz/options_activeup.xpm
ButtonStyle 6 ActiveUp Pixmap 23oz/iconify_activeup.xpm
ButtonStyle 4 ActiveUp Pixmap 23oz/maximize_activeup.xpm
ButtonStyle 2 ActiveUp Pixmap 23oz/close_activeup.xpm
ButtonStyle 1 ActiveDown Pixmap 23oz/options_activedown.xpm
ButtonStyle 6 ActiveDown Pixmap 23oz/iconify_activedown.xpm
ButtonStyle 4 ActiveDown Pixmap 23oz/maximize_activedown.xpm
ButtonStyle 2 ActiveDown Pixmap 23oz/close_activedown.xpm
ButtonStyle 1 Inactive Pixmap 23oz/options_inactive.xpm
ButtonStyle 6 Inactive Pixmap 23oz/iconify_inactive.xpm
ButtonStyle 4 Inactive Pixmap 23oz/maximize_inactive.xpm
ButtonStyle 2 Inactive Pixmap 23oz/close_inactive.xpm
ButtonStyle All -- Flat UseTitleStyle
TitleStyle ActiveUp MultiPixmap Main 23oz/title_active.xpm, LeftEnd 23oz/titleleft_active.xpm, RightEnd 23oz/titleright_active.xpm
TitleStyle ActiveDown MultiPixmap Main 23oz/title_active.xpm, LeftEnd 23oz/titleleft_active.xpm, RightEnd 23oz/titleright_active.xpm
TitleStyle Inactive MultiPixmap Main 23oz/title_inactive.xpm, LeftEnd 23oz/titleleft_inactive.xpm, RightEnd 23oz/titleright_inactive.xpm
TitleStyle -- Flat

BorderStyle -- HiddenHandles !NoInset Raised
TitleStyle LeftJustified Height 25
Style * Font         -*-arial-bold-r-normal-*-10-*-*-*-*-*-*
Style * HandleWidth  4
Style * ForeColor    #B0B0B0
Style * BackColor    #808080
Style * HilightFore  #D0D0D0
Style * HilightBack  #909090

I integrate it in to Menu and use PipeRead 'fvwm-theme -decor 23oz', which works
fine.

However, I find it not so good to deal with too many decors for I have to write
the different command line. Then, I tried to use AddToDecor, and I changed the
script and gave the following output:

------------------------------------------------
DestroyDecor MyDecor
AddToDecor MyDecor
+ ButtonStyle Reset
+ ButtonStyle All -- Flat UseTitleStyle
+ AddButtonStyle 1 ActiveUp Pixmap 23oz/options_activeup.xpm
+ AddButtonStyle 6 ActiveUp Pixmap 23oz/iconify_activeup.xpm
+ AddButtonStyle 4 ActiveUp Pixmap 23oz/maximize_activeup.xpm
+ AddButtonStyle 2 ActiveUp Pixmap 23oz/close_activeup.xpm
+ AddButtonStyle 1 ActiveDown Pixmap 23oz/options_activedown.xpm
+ AddButtonStyle 6 ActiveDown Pixmap 23oz/iconify_activedown.xpm
+ AddButtonStyle 4 ActiveDown Pixmap 23oz/maximize_activedown.xpm
+ AddButtonStyle 2 ActiveDown Pixmap 23oz/close_activedown.xpm
+ AddButtonStyle 1 Inactive Pixmap 23oz/options_inactive.xpm
+ AddButtonStyle 6 Inactive Pixmap 23oz/iconify_inactive.xpm
+ AddButtonStyle 4 Inactive Pixmap 23oz/maximize_inactive.xpm
+ AddButtonStyle 2 Inactive Pixmap 23oz/close_inactive.xpm
+ TitleStyle ActiveUp MultiPixmap Main 23oz/title_active.xpm, \
        LeftEnd 23oz/titleleft_active.xpm, RightEnd 23oz/titleright_active.xpm
+ TitleStyle ActiveDown MultiPixmap Main 23oz/title_active.xpm, \
        LeftEnd 23oz/titleleft_active.xpm, RightEnd 23oz/titleright_active.xpm
+ TitleStyle Inactive MultiPixmap Main 23oz/title_inactive.xpm, \
        LeftEnd 23oz/titleleft_inactive.xpm, RightEnd 23oz/titleright_inactive.xpm
+ TitleStyle -- Flat UseTitleStyle
+ BorderStyle -- HiddenHandles !NoInset Raised
+ TitleStyle LeftJustified Height 25

Style * UseDecor MyDecor

Style * Font         -*-arial-bold-r-normal-*-10-*-*-*-*-*-*
Style * HandleWidth  4
Style * ForeColor    #B0B0B0
Style * BackColor    #808080
Style * HilightFore  #D0D0D0
Style * HilightBack  #909090
---------------------------------------

I do not know where I have made mistakes, because this output will not take
effect on the current opened windows as before. I have to open a new window to see the
effect. Moreover, if I put these codes in FvwmConsole directly, only some
windows will be affected.

Any advice would be appreciated! Thanks in advance!

Xue Ruini
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Nov 2004 18:25:46 +0000

> decors dynamically. For example, the command: fvwm-theme -decor 23oz would generaet:
[...]
> script and gave the following output:
[...]

Unfortunately, I have no time now to try the configurations you posted.
But why exactly do you need to add AddToDecor? Try to stick to the output
that works. Or explain the problem with the Suzanne's script again.

Also try UpdateDecor. However decors are not the suggested way to do it.

Regards,
Mikhael.