Subject: FVWM: Schedule command "failing"

From: Vincent Bernat <[email-masked]>
Date: Sun, 31 Oct 2004 22:35:14 +0100

Hello !

I have written this snippet  of code to  change randomly my  wallpaper
every 15 minutes :

,----
| DestroyFunc RandomWallPaper
| AddToFunc RandomWallPaper
| + I Exec cd $[FVWM_WALLPAPERS] ; python -c "import glob, random, os ; os.system('Esetroot -scale %s' % random.choice(glob.glob('*.jpg')))"
| 
| DestroyFunc RescheduleRandomWallPaper
| AddToFunc RescheduleRandomWallPaper
| + I RandomWallPaper
| + I Deschedule 35
| + I Schedule 900000 35 RescheduleRandomWallPaper
`----

I call RescheduleRandomWallPaper  at start. However, after some  time,
RescheduleRandomWallPaper is not scheduled any more. Any idea why ?
-- 
die_if_kernel("Whee... Hello Mr. Penguin", current->tss.kregs);
	2.2.16 /usr/src/linux/arch/sparc/kernel/traps.c

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Sun, 31 Oct 2004 22:29:30 +0000

> RescheduleRandomWallPaper is not scheduled any more. Any idea why ?

Schedule is not reliable, if the server is grabbed it doesn't fire :(

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].