Subject: FVWM: Keystrokes to Mozilla

From: Michelle Konzack <[email-masked]>
Date: Tue, 5 Oct 2004 12:29:53 +0200

Hello, 

Now I have gotten a new Multimedia-Keyboard (KB.2925, WTX) and detected
the Keycodes with xev

  ____ ( '/home/michelle/.xmodmap/DE_de' ) _____________________________
 /
|  keycode 237 = XF86AudioMedia
|  keycode 160 = XF86AudioMute
|  keycode 174 = XF86AudioLowerVolume
|  keycode 176 = XF86AudioRaiseVolume
|  keycode 164 = XF86AudioStop
|  keycode 144 = XF86AudioPrev
|  keycode 153 = XF86AudioNext
|  keycode 162 = XF86AudioPause
|  keycode 235 = scaron
MyComputer

|  keycode 161 = ccaron
Calculator

|  keycode 178 = ecaron
Home

|  keycode 236 = rcaron
EMail

|  keycode 234 = 
Mozilla_Back

|  keycode 233 = 
Mozilla_Forward

|  keycode 232 = 
Mozilla_Stop

|  keycode 229 = 
Mozilla_Search

|  keycode 231 = 
Mozilla_Refresh

|  keycode 230 = 
Mozilla_Favorites

|  keycode 222 = 
Power

|  keycode 223 = 
Sleep

|  keycode 227 = 
Wake

 \______________________________________________________________________

Because xmms-xf85audio does not work properly with xmms-rplay I use:

  ____ ( '/home/michelle/.fvwm/keys' ) _________________________________
 /
|  key	XF86AudioMedia             A N	Exec eject
|  key	XF86AudioPlay              A N	Exec xmms --play
|  key	XF86AudioPause             A N	Exec xmms --play-pause
|  key	XF86AudioStop              A N	Exec xmms --stop
|  key	XF86AudioMute              A N	Exec tdcamvol --mute
|  key	XF86AudioPrev              A N	Exec xmms --rew
|  key	XF86AudioNext              A N	Exec xmms --fwd
|  key	XF86AudioLowerVolume       A N	Exec tdcamvol --lower 5
|  key	XF86AudioRaiseVolume       A N	Exec tdcamvol --raise 5
|  
|  # key     scaron                  A N     Exec 
|  key     ccaron                  A N     Exec mozilla
|  key     ecaron                  A N     Exec exec xterm -geometry 95x30+7+100   -fn 10x20 -title "Midnight Commander" -name "mc" -n "mc" -bg blue -fg white -e /usr/bin/mc
|  key     rcaron                  A N     Exec exec xterm -geometry 80x28+125+160 -fn 10x20 -title "mutt" -name "mutt" -n "mutt" -e /usr/bin/mutt
 \______________________________________________________________________

This is working fine now...

But now I have the Mozilla-Buttons and do not know, how to bind the to
the Mozilla-Functions... 

And yes, I have creates a nes keysym.h with "MyCompute", "Calculator",
"Home", "EMail", "Mozilla_Back", "Mozilla_Forward", "Mozilla_Stop",
"Mozilla_Search", "Mozilla_Refresh", "Mozilla_Favorites", "Power",
"Sleep" and "Wake".

Recompiled xfree86 (Debian, WOODY) and gotten what I have expected.

Should I send it to the developers of xfree86 ?

But for now, I do not know, how to bind the keys to Mozilla...

Can anyone help me please ?

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: Dan Espen <[email-masked]>
Date: Tue, 05 Oct 2004 10:42:06 -0400

Michelle Konzack <[email-masked]> writes:
> Hello,=20
...
> the Mozilla-Functions...=20
> 
> And yes, I have creates a new keysym.h with "MyCompute", "Calculator",

That is up to you, but I don't think they would want a keysum named
"Mozilla_Refresh", maybe just plain "Refresh".
There are a lot of unused keysyms in that file that
can be used.

> But for now, I do not know, how to bind the keys to Mozilla...

http://www.mozilla.org/unix/customizing.html#keys

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michelle Konzack <[email-masked]>
Date: Wed, 6 Oct 2004 08:09:30 +0200

Hello Dan,

> There are a lot of unused keysyms in that file that

My problem is, that I have a Multi-User/Language environement...
Using "other" keysyms let me run into trouble...

I have already tried this...
Collecting all needed keysys and then filtering against keysyms.h

> http://www.mozilla.org/unix/customizing.html#keys

OK...

Greetings
Michelle