Subject: FVWM: Xinerama / EwmhBaseStruts / Maximize

From: "Ronald Schaten" <[email-masked]>
Date: Fri, 8 Oct 2004 01:23:22 +0200 (CEST)

Hey...

I'm using fvwm for about three weeks now, and I'm really impressed.
Everything seems to be possible with this WM... :-)

But there's one thing I haven't found yet: I use a Xinerama setup with two
screens. I'd like to see a gkrellm and a FvwmPager on the right border of
the left screen, but they should not get covered when I maximize a window.

I can use something like 'EwmhBaseStruts 0 68 0 0', so the windows leave
out the space, but this setting affects the right screen, too. I cannot
maximize windows on the right screen.

Another idea is to use 'Maximize -68p 100', but I think that would have
the same results (even if I didn't test it).

Is there a way to set one of these for each screen separately? Or is there
a workaround for this ("if window on screen 0 then maximize -68p 100 else
maximize 100 100")?

Ciao,
Ronald.

-- 
http://www.schatenseite.de

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Oct 2004 03:51:21 +0200

> Everything seems to be possible with this WM... :-)

That's the idea :-)

> a workaround for this ("if window on screen 0 then maximize -68p 100 else

The following function issues "maximize -68p 100" if the pointer's
x position is < 1024 and "maximize 100 100" otherwise.

  addtofunc mymaximize
  + i piperead `if [ $[pointer.x] -lt 1024 ]; then echo maximize -68p 100; else echo maximize 100 100; fi`

This one uses -68p if the right edge of the window is on the left
screen:

  addtofunc mymaximize2
  + i piperead `if [ $(( $[w.x] + $[w.width] )) -le 1024 ]; then echo maximize -68p 100; else echo maximize 100 100; fi`

You get the idea.  If fvwm does not support it, you can often
pass some variable to a shell and let it do the calculations.
It's a bit confusing because the inner $[w.x] etc is expanded by
fvwm, while all remaining $... are expanded by the shell.  The man
page documents all the variable fvwm supports (section COMMAND
EXPANSION).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]