Subject: FVWM: Code to toggle title stopped working

From: Micha Feigin <[email-masked]>
Date: Wed, 6 Oct 2004 01:15:05 +0200

I got a piece of code some time ago to toggle the title bar on and
off. It worked with 2.5.11 but now is not working with the snapshot
august 3. It is only removing the title, but not returning it, and I
was wondering if there is a problem with the code or if there was a
bug/change in fvwm.

The code:

DestroyFunc title-bar-toggle
AddToFunc title-bar-toggle
+ "I" ThisWindow (State 11) WindowStyle Title
+ "I" TestRc (!Match) WindowStyle !Title
+ "I" State 11 toggle

Thanks
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Oct 2004 02:38:18 +0200

On Wed, Oct 06, 2004 at 01:15:05AM +0200, Micha Feigin wrote:
> august 3.

I'm not sure whether this information is correct.  As far as I
know, combining styles and states broke on 2nd of April (after the
2.5.10 release) and was fixed on 3rd of October (after the 2.5.11
release):

 2.5.10              : ok
 April 1 and earlier : ok
 April 2             : depends on time of snapshot
 April 3             : broken
 August 3            : broken
 2.5.11              : broken
 October 2           : broken
 October 3           : depends on time of snapshot
 October 4 and later : ok
 2.5.12              : ok

> It is only removing the title, but not returning it, and I

As this problem seems to bite quite a few people, I will release
2.5.12 soon.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]