Subject: FVWM: Changing titlebar button positions on the fly

From: Dorothy Robinson <[email-masked]>
Date: Sun, 17 Oct 2004 19:34:17 -0700

Is there any way to make FVWM completely "forget" a titlebar button once 
it's there?  For instance, I define these functions:

AddToFunc ButtonFunctions
+ I Mouse 1         $[MaxButton]   A   Maximize 0 100
+ I Mouse 2         $[MaxButton]   A   Maximize 100 0
+ I Mouse 3         $[MaxButton]   A   Maximize
+ I Mouse 1         $[KillButton]  A   Delete
+ I Mouse 1         $[MinButton]   A   Iconify

AddToFunc TwmButtonOrder
# Buttons 2-4 in TWM "native" order
+ I SetEnv MenuButton 1
+ I SetEnv MaxButton  2
+ I SetEnv KillButton 3
+ I SetEnv MinButton  4
+ I Function ButtonFunctions

AddToFunc WindozeButtonOrder
# These do the buttons in windoze order
+ I SetEnv MenuButton 1
+ I SetEnv KillButton 2
+ I SetEnv MaxButton  4
+ I SetEnv MinButton  6
+ I Function ButtonFunctions

Then I re-load the ButtonStyles like so:
AddButtonStyle $[MenuButton] Inactive pixmap buttons/AquaGray.xpm

If I start with TwmButtonOrder and then do "Function WindozeButtonOrder, 
I can't figure out how to make Button 3 disappear.  I can undefine its 
function or give it an invisible icon, but it's still in the titlebar, 
as can be seen if the buttons are raised or sunken.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Dorothy Robinson
http://www.twobarleycorns.net
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 18 Oct 2004 18:03:08 +0100 (BST)

> it's there?  For instance, I define these functions:

Look at using FvwmEvent to change TitleButtons on the fly. As to what the
event is, is left up to how you want the window to react. :)

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________ALL-NEW Yahoo! Messenger - all new features - even more fun!  http://uk.messenger.yahoo.com