Subject: FVWM: configuration for kiosk

From: Volker Katz <[email-masked]>
Date: Thu, 14 Oct 2004 20:50:02 +0200

Hello,
I have to setup a linux-box in a kiosk-mode. Therefore I wanted to use 
fvwm even though I'm not familiar to it.
I want to have a titel for every window and just one button in the top 
left corner. The button should be a typicall "x" for our windows-user.  
Resizing should not be possible and perhaps moving too.
At the moment my .fvwm2rc looks like this:
---------------my .fvwm2rc--------------------------
Emulate win
Style "*" ClickToFocus
Style "*" MWMFunctions
Style "*" HintOverride
Style "*" MWMDecor
OpaqueMoveSize 100
EdgeScroll 100 100
EdgeResistance 250 10
Style "*" RandomPlacement
Style "*" NoPPosition
DeskTopSize 1x1

# Should be an "x"-Button - but isn't. Told at
# http://www.linux-magazin.de/Artikel/ausgabe/1996/09/Fvwm/fvwm-abb1.gif
ButtonStyle 1   4       26x29@1 34x21@1 50x35@1 70x21@1
                        79x29@1 63x48@1 79x65@1 70x75@0
                        50x61@0 34x75@0 26x65@0 44x48@1 26x29@0

# Close Window by pushing button on top-right
Mouse   1       1       A       Close
# No mouse-actions allowed:
Mouse   0       R       A       nop
Mouse   0       W       A       nop
Mouse   0       T       A       nop
Mouse   0       S       A       nop
Mouse   0       F       A       nop
Mouse   0       I       A       nop
---------------------------------------------------------
How can I get the button from top-left to top-right? And why doesn't it 
look like an "X". 

Thank you very much!

Best regards
  Volker

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 14 Oct 2004 15:02:52 -0400

Volker Katz <[email-masked]> writes:
> Hello,
> ... button should be a typicall "x" for our windows-user.  
...
>                         50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
..,
> How can I get the button from top-left to top-right? And why doesn't it 

The top right would be button 2, not 1.

The second number is the number of points in the vector.
You want 13, not 4.

You need backslashes at the end of each line:

ButtonStyle 2 13        26x29@1 34x21@1 50x35@1 70x21@1 \
                        79x29@1 63x48@1 79x65@1 70x75@0 \
                        50x61@0 34x75@0 26x65@0 44x48@1 26x29@0

Go here for more info on buttons:

http://www.fvwm.org/screenshots/vectorbuttons/

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Volker Katz <[email-masked]>
Date: Fri, 15 Oct 2004 09:43:12 +0200

Hello,
Am Donnerstag, 14. Oktober 2004 21:02 schrieb Dan Espen:
> > How can I get the button from top-left to top-right? And why
> > doesn't it look like an "X".
thank you very much! The Button looks right and is at the right place 
now! 
There is still another problem: Not every window get's the frame with 
titel and button. I'm using a java-programm - 
http://www.nmichael.de/software/efa.html
I've testest it using KDE and Windows. When using them ervery window has 
it's own frame. 
Now using fvwm on another machine you get for example a login-window, 
but you don't have any chance to cancle without a close-button. 
Some windows are great - others miss a frame. 

How can I solve that?

Thanks.& best regards
   Volker

---

From: Volker Katz <[email-masked]>
Date: Fri, 15 Oct 2004 12:19:22 +0200

Am Freitag, 15. Oktober 2004 09:43 schrieb Volker Katz:
> I've testest it using KDE and Windows. When using them ervery window
> has it's own frame.
ok, now I know, that I have problems with transient windows. I put this 
in my config-file:
Style "*" DecorateTransient
and removed this:
Style "*" MWMFunctions

Now I have a titel-bar at my transient window, but I'm still missing the 
close-Butten. How can I reach this? 

Thanks & best regards
  Volker

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 15 Oct 2004 10:41:59 +0000

> close-Butten. How can I reach this? 

Please read FAQ question 3.22 and use the suggested config.

Regards,
Mikhael.

---

From: Volker Katz <[email-masked]>
Date: Fri, 15 Oct 2004 13:22:35 +0200

Am Freitag, 15. Oktober 2004 12:41 schrieb Mikhael Goikhman:
> > Now I have a titel-bar at my transient window, but I'm still
> > missing the close-Butten. How can I reach this?
I'm sorry. I've read this question in the faq bevore, but I still don't 
get it. 
Now I have thoe follwing settings:
Style "*" ClickToFocus
Style "*" MWMButtons
Style "*" HintOverride
Style "*" MWMDecor
Style "*" DecorateTransient
Style "*" SmartPlacement
OpaqueMoveSize 100
EdgeScroll 100 100
EdgeResistance 250 10
DeskTopSize 1x1
ButtonStyle 2 - Clear MWMDecorMin
Mouse   1       2       A       Close
Mouse   0       R       A       nop
Mouse   0       W       A       nop
Mouse   0       T       A       nop
Mouse   0       S       A       nop
Mouse   0       F       A       nop
Mouse   0       I       A       nop

Like I said bevore, I just want to have button 2 in every window - 
including transient windows.

Thanks & best regards
  Volker

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 15 Oct 2004 11:41:48 +0000

> ButtonStyle 2 - Clear MWMDecorMin

I have nothing to add to FAQ. FAQ explains that the first line above
informs fvwm that your button 2 is a minimize (iconify) button. As such
this button is hidden when applications ask to disable iconify function.

Please do what the FAQ 3.22 says to fix your windows-like button layout:

  ButtonStyle 2 - Clear

Regards,
Mikhael.

---

From: Volker Katz <[email-masked]>
Date: Fri, 15 Oct 2004 14:52:44 +0200

> informs fvwm that your button 2 is a minimize (iconify) button. As
> such this button is hidden when applications ask to disable iconify
> function.
>
Thanks a lot! I made a silly mistake!
Now, these thinks work like I want them to. There a still some oddments 
left. I will have a look on them on Monday.

Have a nice weekend!
Best regards
  Volker