Subject: FVWM: FvwmTaskBar with fullscreen

From: David Sun <[email-masked]>
Date: 11 Oct 2004 15:27:22 +0800

Hi, all
I am new to fvwm, sorry if I pose a old question here.

I am using fvwm 2.4.18, and when I running some application in
fullscreen mode, the taskbar becomes unavailable.

My question is, is it possible to wake up the taskbar when it's covered
by some other fullscreen applications? say something like
autohide-autoshowup, but the simple autohide option of FvwmTaskBar does
not work here because the taskbar becomes completely invisible. or some
key binding?

thanks for your advice
David

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Oct 2004 11:51:53 +0200

> not work here because the taskbar becomes completely invisible. or some

I recommend to use a key binding:

  key f1 a n All (FvwmTaskBar) Layer 0 99

puts the TaskBar above all other windows, and

  key f2 a n All (FvwmTaskBar) Layer 0 4

puts it back where is belongs (upon pressing f1/f2).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: David Sun <[email-masked]>
Date: 11 Oct 2004 19:02:53 +0800

thanks Dominik
the method really works !^_^

and two more newbie questions:
1. (emerge when reading the fvwm2 manual) what does the default layer=4
means? all the application windows sharing a common default layer?
2. how can we tell if two application windows are in the same layer or
not? say we start a application window and then another.

thanks again
David

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Oct 2004 15:27:10 +0200

On Mon, Oct 11, 2004 at 07:02:53PM +0800, David Sun wrote:
> means?

> all the application windows sharing a common default layer?

Yes, unless the fvwm config or the application requests something
else.

> not? say we start a application window and then another.

If you can raise one above the other and vice versa, they are in
the same layer.  Otherwise, the upper window is on a higher layer.
For more information, you can run the FvwmIdent module.  Among
other bits of information, it displays the window's layer.

(While you are on the fvwm mailing lists, please write replies
below the quoted sections of the original mail).

Ciao

Dominik ^_^  ^_^