Subject: FVWM: Toggle command problems

From: Me <[email-masked]>
Date: Tue, 12 Oct 2004 10:46:24 +1000

Hi,

After "borrowing" this code from another fvwm user a long time ago it
turns out that
it's no longer working and is baffling me. Perhaps i'm missing
something obvious.

AddToFunc   ToggleWindowTitle
+ I ThisWindow (State 11) ThisWindow WindowStyle Title
+ I TestRc (!Match) ThisWindow WindowStyle NoTitle
+ I ThisWindow State 11 toggle

Yet this seems to work just fine (toggling obviously works):

AddToFunc   ToggleWindowTitle
+ I ThisWindow (State 11) Echo "Window title is turned on"
+ I TestRc (!Match) Echo "Window title is GONE"
+ I ThisWindow State 11 toggle

If i manually toggle the State it will work once more. It seems there
is a problem with
my TestRc line ... any ideas?

(Am running Fvwm 2.5.11)

Craig
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Oct 2004 11:42:22 +0200

> my TestRc line ... any ideas?

The state flags get overwritten by the WindowStyle command.
Please upgrade to 2.5.12 or downgrade to 2.5.10.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: Micha Feigin <[email-masked]>
Date: Tue, 12 Oct 2004 11:15:48 +0200

> it's no longer working and is baffling me. Perhaps i'm missing

I had this problem also. There is a bug in 2.5.11 which has been fixed
about 3 days after 2.5.11 went out. Its in current cvs and will be in
2.5.12. Either upgrade to cvs or wait for next version and it will be
solved.

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Oct 2004 23:10:03 +0200

> 2.5.12. Either upgrade to cvs or wait for next version and it will be

What do you mean with "will be in 2.5.12"?  2.5.12 has bee
released a week ago. :-)

Ciao

Dominik ^_^  ^_^