Subject: FVWM: notes on FvwmScript

From: "Rouben Rostamian" <[email-masked]>
Date: Sat, 2 Oct 2004 20:36:15 -0400

This afternoon I played some with the FvwmScript module as
it comes with Fvwm 2.5.11.  I noticed several inaccuracies
in the documentation plus one thing that seems to be a bug.
I have included my notes below.

-- 
Rouben Rostamian

--- errata in the documentation ----------------------------------

1.
In the sentence:

The second part contains instructions whom are executed...

   *** change "whom" to "which"

2.
In the sentence:

Display a menu whom lets user to choose a option.

   *** change "whom" to "which"
   *** change "a option" to "an option"

3.
In the sentence:

Return the string whom is between position int1 and...

   *** change "whom" to "which"

4.
In two places in the man page we have examples with "Case Message of".

   *** change "Message" to "message" in both places because this
       is apparently case-sensitive

5.
Under the "ANATOMY OF A SCRIPT" section, the five parts of a
FvwmScript are defined.  It says: "And the last [that is, the
fifth] part contains the description of widgets."

However under the "MAIN OF A SCRIPT" section, it says: "The second
part of the script contains the description for every widget...".

   *** the "second part" should be "last part".

--- a bug -------------------------------------------------------

It appears that a "for-loop" insists that its lower index be 1.
The following does not work:

     For $i=4 To 9 Do

--- two suggestions for enhancement -----------------------------

1.
Currently we have several Get* functions, such as GetValue,
GetHilight, etc.  A GetIcon is missing.  (GetIcon id) should
return the `Icon' field of a ItemDraw or PushButton widget.

2.
It would be nice to get FvwmScript's variables to be interpreted
in all context.

For instance, if we have:

Init
 Begin
   Set $w=48
  End

then in the definition of the following widget, $w is not recognized:

Widget 3
Property
 Size       $w $w   ##### PROBLEM: we expect $w to be 48 here but it is not
 Position   10 10
 Type       ItemDraw
 Icon       mypixmap.xpm
End

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 3 Oct 2004 04:56:27 +0200

> I have included my notes below.

Thanks for the help.

> --- errata in the documentation ----------------------------------
[snip]

Corrected.

> The following does not work:

Fixed.

> --- two suggestions for enhancement -----------------------------

Unfortunately, I can't help with that, but I would accept a patch.

>  Size       $w $w   ##### PROBLEM: we expect $w to be 48 here but it is not

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]