Subject: FVWM: xsession-errors is more then 600 MBytes after 16 days

From: Michelle Konzack <[email-masked]>
Date: Sun, 12 Sep 2004 23:05:55 +0200

Hello, 

I am in the Land of exploding xsession-errors files...

I am using 2.5.10 and fvwm filles up my ~/xsession-errors with:

  ____ ( '/home/michelle/.xsession-errors' ) ___________________________
 /
|  s   0/765  0/ 2, g   2/763  2/ 0: +++ near border traditional 0x08154a00 'FvwmTaskBar'

One time at start up and then starting a program (here 'gaim')

|  _cdim: --- not moved 0x08154d28 'Anmeldung'

and then millions of lines like this

|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'
|  _cdim: --- using StaticGravity 0x08154d28 'ButtonBar1'

while open and closing one of my two ButtonPanel
Moving a window arround gives me tonns of messages too.

 \______________________________________________________________________

I think, this is inacceptable... 
How can I deactivate logging of this crap ?

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: Tavis Ormandy <[email-masked]>
Date: Sun, 12 Sep 2004 22:42:55 +0100

> How can I deactivate logging of this crap ?

try this patch

--- fvwm/events.c       2003-08-28 21:26:14.000000000 +0100
+++ fvwm/events.c.new   2003-11-01 11:02:59.000000000 +0000
@@ -512,7 +512,7 @@
        return;
 }
 
-#define CR_DETECT_MOTION_METHOD_DEBUG
+/* #define CR_DETECT_MOTION_METHOD_DEBUG */
 /* Try to detect whether the application uses the ICCCM way of moving its
  * window or the traditional way, always assuming StaticGravity. */
 static inline void __cr_detect_icccm_move(

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].