Subject: FVWM: TRouble with Performance during switching between Desktops

From: Dirk Rydvan <[email-masked]>
Date: Mon, 27 Sep 2004 18:20:31 +0200

Mikhael Goikhman wrote:

>On 27 Sep 2004 08:59:33 +0200, Dirk Rydvan wrote:
>  
>
>>We want use FVWM instead KDE to improve performance - so far so good.
>>
>>But there are a performance problem on FVWM. We have seen this only on
>>a poor java application. ( poor but very important ... )
>>
>>If I change the Desktop - the application will redrawed and this takes
>>a while. A few seconds are necessary to show the complete window item.
>>(it takes more time than KDE)
>>
>>If I change only the Page in the Desktop - the application will showed
>>very fast. ( better than KDE) And the +bs option (backing store) works
>>only between the Pages in the Desktop.
>>    
>>
>
>If this java application is free, then tell its name, maybe someone can
>take a look at it.
>
>  
>
>>A easy way to solve the Problem is, to create  only one Desktop and
>>seperate this in 10 Pages. But a have a Problem - we need a Label for
>>each Workspace (Page). That is not possible with FvwmPager. FvwmPager
>>provides only Labels for Desktops.
>>
>>What can I do?
>>    
>>
>
>The pages do not have names, just a pair of numbers. You may try to solve
>this problem by disabling desk labels in FvwmPager and adding your own
>labels for each page. I.e. create this FvwmButtons layout:
>
>   Label-1 Label-2 Label-3 Label-4 Label-5
>  +-------+-------+-------+-------+-------+
>  | Page1 | Page2 | Page3 | Page4 | Page5 |
>  +-------+---------------+-------+-------+    <-- FvwmPager with no labels
>  | Page6 | Page7 | Page8 | Page9 | Page0 |
>  +-------+-------+-------+-------+-------+
>   Label-6 Label-7 Label-8 Label-9 Label-0
>
>Regards,
>Mikhael.
>  
>
Thanks for answer!

###################

The application is a properitary telecomunication network umbrella 
monitoring tool.

There is anything in the FVWM or X core that handles desktops differnet 
to pages.
I see this on some slow applications (old UNIX servers over WAN).
Also, the X backing store option  (/usr/X11R6/bin/X +bs -wm) has only 
effect in an Desktop between pages.

May be, that KDE (I dont like KDE memory waste, but is true) uses only 
pages, to improve
the performance during switching the virtuall workspaces.

I have no problem to change my config from desktops to pages.

(MoveToDesk   --> MoveToPage)
(StartsOnDesk   --> StartsOnPage and so on)

But we need good labels for the workspaces ......

###################

a pager without labels? I agree, but in "man FvwmPager" (2.4.18) is only 
one option showed:

*FvwmPager: ShapeLabels
              Causes the pager to hide the labels of all but the current 
desk.
              This turns off label hilighting.

I need only a flat, simply design, that means in this case 10 Pages in 
one desktop.
This only one desktop is every time the current desk.

fvwm2rc:
DesktopSize 10x1
FvwmPager  0 0

+----------+----------+----------+----------+-----
|          |          |          |          |
|          |          |          |          |
+----------+----------+----------+----------+-----
|own label1|own label2| ..       |..        |..

as substitude for this:

fvwm2rc:
DesktopSize 1x1
"I" FvwmPager  0 9
*FvwmPager: Label 0 "Label1"
*FvwmPager: Label 0 "Label2"

+----------+----------+----------+----------+-----
|          |          |          |          |
|          |          |          |          |
+----------+----------+----------+----------+-----
|Label1    |Label2    | ..       |..        |..

shapelabels create this:

fvwm2rc:
DesktopSize 10x1
"I" FvwmPager  0 0
*FvwmPager: ShapeLabels

+----------+----------+----------+----------+-----
|          |          |          |          |
|          |          |          |          |
+----------+----------+----------+----------+-----
|                               Desk 0

(disables only highlighting for Desk 0)

##############################

I think it's difficult............

Dirk

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Mon, 27 Sep 2004 18:03:32 +0100

It's well hidden, you want the `Font none` setting.

> I think it's difficult............

No, very easy! I wrote a mini tutorial on creating FvwmButtons panels a
while ago if you're interested, there are different approaches but this
one describes the way I do it:

http://forums.gentoo.org/viewtopic.php?t=162177

I think you're describing something like this:

DestroyModuleConfig FvwmPagerLabels: *
*FvwmPagerLabels: Columns 10
*FvwmPagerLabels: Rows 3
*FvwmPagerLabels: Frame 1
*FvwmPagerLabels: (1x1, Title "Stuff0")
*FvwmPagerLabels: (1x1, Title "Stuff1")
*FvwmPagerLabels: (1x1, Title "Stuff2")
*FvwmPagerLabels: (1x1, Title "Stuff3")
*FvwmPagerLabels: (1x1, Title "Stuff4")
*FvwmPagerLabels: (1x1, Title "Stuff5")
*FvwmPagerLabels: (1x1, Title "Stuff6")
*FvwmPagerLabels: (1x1, Title "Stuff7")
*FvwmPagerLabels: (1x1, Title "Stuff8")
*FvwmPagerLabels: (1x1, Title "Stuff9")
*FvwmPagerLabels: (10x2, Swallow FvwmPager `FvwmPager 0 0`)

Which looks something like this:

http://dev.gentoo.org/~taviso/fvwmpagerlabels.png
-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dirk Rydvan <[email-masked]>
Date: Tue, 28 Sep 2004 09:10:19 +0200

>http://dev.gentoo.org/~taviso/fvwmpagerlabels.png
Thank You! Yes that is easier than my quick and dirty solution to
set the var label_h =0 in the sourcefile x_pager.c

But how I can let stay the button pressed?
This button should simply show the actual workspace.

The best way is to draw a label in the center of each page, in the 
FvwmPager.
(yes, like KDE .... - my boss and the users want this, and without that 
I can
cancel my FVWM dreams.)

Where in the source can I add this?????

Thanks!

Dirk