Subject: FVWM: Warp after window close

From: Mikko Heiskanen <[email-masked]>
Date: Sun, 19 Sep 2004 21:01:11 +0300

Hi,
is it possible to have focus move to nearest window, after closing
a window? I tried the following:

*FvwmEvent-NewWindow: StartDelay 4
*FvwmEvent-NewWindow: add_window FuncFocusWindow
*FvwmEvent-OldWindow: Cmd
*FvwmEvent-OldWindow: PassId
*FvwmEvent-OldWindow: destroy_window FuncFocusWindow
DestroyFunc FuncFocusWindow
AddToFunc FuncFocusWindow
	+ I ThisWindow ("My Window") Move 200p 100p
	+ I Focus
	+ I WarpToWindow 50p 50p
AddToFunc StartFunction I FvwmEvent FvwmEvent-NewWindow
FvwmEvent-OldWindow

I think the Oldwindow FocusFunc focuses the window being closed.
Now, I couldn't find a way to achieve what I want.
I started to use fvwm with no mouse, and now I need to either
focus with mouse or alt-tab after closing a window.
I am using 2.5.10.

Thanks,
Mikko
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 19 Sep 2004 22:29:28 +0200

> focus with mouse or alt-tab after closing a window.

Try this:

  *FvwmEvent-FocusNext: Cmd
  *FvwmEvent-FocusNext: destroy_window FuncClosestWindow
  
  DestroyFunc FuncClosestWindow
  AddToFunc FuncClosestWindow
  + I Direction C FocusAndWarp
  
  DestroyFunc FocusAndWarp
  AddToFunc FocusAndWarp
  + I Focus
  + I WarpToWindow 50p 50p

However, this gives focus to the window closest to the pointer
even if a window is closed that does not have the focus.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]

---

From: [email-masked] (Mikko Heiskanen)
Date: Mon, 20 Sep 2004 11:00:15 +0300 (EEST)

Dominik Vogt
>  =20
>  =20

Thank you.
Now it focuses to the window opened before the window being closed 
(regardless on which desk), which is more then I could have hoped for!

Mikko