Subject: FVWM: possible bug?

From: jpkotta <[email-masked]>
Date: Sat, 04 Sep 2004 14:27:39 -0500

I have 2 sticky Eterms that I launch at startup.  I have a function to 
(un)hide them via shading.  The trouble is that each time I do a shade and 
unshade, they have moved up and to the right by 1 pixel (which make sense 
because that's the shade direction).

I played with the MoveByProgramMethod and the FixedPPosition styles, but 
to no avail.  I finally traced the problem to the MWMDecor style.  Is this 
a known issue?

I'm using version 2.5.10.

jpkotta
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: jpkotta <[email-masked]>
Date: Mon, 06 Sep 2004 02:17:43 -0500

I investigated this further.  I found that MWMDecor isn't necessarily the 
cause.  Here's a config file that reproduces the problem.  I've found a 
workaround so this is purely for anyone who encounters something similar.

#-------------------------------------------------------------------------------
# Minimal config to recreate Eterm windowshade bug.
#-------------------------------------------------------------------------------

AddToFunc InitFunction
+ I 	Schedule 1000 None (DesktopEterm) \
	Exec exec Eterm --geometry 120x25+190+0 --trans --shade 50 --scrollbar 0 
--buttonbar 0 --borderless --name DesktopEterm &
+ I 	Schedule 1000 None (DesktopEterm2) \
	Exec exec Eterm --geometry 120x25+190+385 --trans --shade 50 --scrollbar 
0 --buttonbar 0 --borderless --name DesktopEterm2 &

# this one works
Style DesktopEterm* TitleAtRight, !Borders, NoDecorHint

# these three don't: Eterms shift
#Style DesktopEterm* MWMDecor, TitleAtRight
# OR
#Style DesktopEterm* NoTitle, NoHandles, BorderWidth 0, TitleAtRight
# OR
#Style DesktopEterm* NoTitle, !Borders, TitleAtRight

DestroyFunc ShowHideUtils
AddToFunc ShowHideUtils
+ I	All (Desktop*) WindowShade toggle East
+ I	All (Desktop*, Shaded) Lower
+ I	All (Desktop*, !Shaded) Raise
+ I	Next (DesktopEterm*, !Shaded) FlipFocus

Key	B	A	4	Function ShowHideUtils
Key	R	A	CM	Restart

On Sat, 04 Sep 2004 14:27:39 -0500, jpkotta <[email-masked]> wrote:

> (un)hide them via shading.  The trouble is that each time I do a shade 
> and unshade, they have moved up and to the right by 1 pixel (which make 
> sense because that's the shade direction).
>
> to no avail.  I finally traced the problem to the MWMDecor style.  Is 
> this a known issue?
>

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Sep 2004 12:34:40 +0200

> I'm using version 2.5.10.

It's a bug.  I will commit a fix soon.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]