Subject: FVWM: make fails with 2.5.10 on linux/ppc

From: [email-masked]
Date: Fri, 10 Sep 2004 10:11:22 +0000

Make fails with 2.5.10 on my iBook running linux:

[snipped]
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs  -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/X11R6/include -I/usr/X11R6/include  -I/usr/X11R6/include        -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.10\" -DFVWM_DATADIR=\"/usr/local/share/fvwm\" -DFVWM_CONFDIR=\"/usr/local/etc\" -DFVWM_COLORSET_PRIVATE=1 -DLOCALEDIR=\"/usr/local/share/locale\" -g -O2 -Wall -Wno-implicit-int -c `test -f 'borders.c' || echo './'`borders.c
borders.c: In function `border_get_tb_parts_to_draw':
borders.c:796: could not split insn
(insn:TI 2775 3071 2986 (set (reg:SI 8 r8)
        (const_int 4290772992 [0xffc00000])) 296 {*movsi_internal1} (nil)
    (nil))
borders.c:796: Internal compiler error in final_scan_insn, at final.c:2622
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.terrasoftsolutions.com/bugzilla/> for instructions.
make[2]: *** [borders.o] Error 1
make[2]: Leaving directory `/george/fvwm-2.5.10/fvwm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/george/fvwm-2.5.10'
make: *** [all] Error 2

[snip]

Has anyone seen this before?  Is there a work-around?

Thanks
George.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 10 Sep 2004 10:57:40 +0000

> Has anyone seen this before?  Is there a work-around?

What is your gcc version? If you still get the same internal error on
your platform after upgrading to the latest version (3.4 or 3.5), then
you should probably send a bug report as suggested in the error message.

Try also to run this gcc line manually in fvwm/ subdirectory without
"-g -O2" options, there is a very small hope.

Regards,
Mikhael.