Subject: FVWM: fvwm <-> gnome

From: Roeland Moors <[email-masked]>
Date: Sun, 26 Sep 2004 17:33:36 +0200

I started using gnome with fvwm. It works nice, but there is one
small problem.

The function InitFunction in my .fvwm isn't started anymore.
It looks like a conflict with the gnome-session.
The splash screen from the gnome-session doesn't dissapear
automaticly.
The function StartFunction works just fine.

I'm using fvwm-gnome (2.5.10-12) and gnome (2.6)
from debian testing.

--
Roeland
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 Sep 2004 15:45:54 +0000

> The function StartFunction works just fine.

Please search for "InitFunction" in fvwm man page. This section explains
all special functions and their relationship to a session manager.

If you run gnome-session, then you should start the programs using it. I
don't use gnome-session, but I think if you "Save Session" then the next
time you start gnome-session it runs the same programs, including fvwm.

Regards,
Mikhael.

---

From: Roeland Moors <[email-masked]>
Date: Sun, 26 Sep 2004 18:05:30 +0200

> all special functions and their relationship to a session manager.

Thanks, I'm using SessionInitFunction now.

> time you start gnome-session it runs the same programs, including fvwm.

Yes, that's true.

The only problem I have now is that the splash screen from the
gnome session doesn't dissapear.

---

From: Kingsly John <[email-masked]>
Date: Sun, 26 Sep 2004 22:22:04 +0530

> gnome session doesn't dissapear.

It might not be an fvwm issue.. in the few times that I've used gnome I've
noticed the splash screen staying on until I click on it.

Kingsly

---

From: Roeland Moors <[email-masked]>
Date: Sun, 26 Sep 2004 19:34:43 +0200

> noticed the splash screen staying on until I click on it.
You're right it's not a fvwm problem. It's a problem with the
gnome sessions.
I can just disable the splash screen with
'gnome-session-proporties'

---

From: Michelle Konzack <[email-masked]>
Date: Sun, 26 Sep 2004 22:12:28 +0200

> I'm using fvwm-gnome (2.5.10-12) and gnome (2.6)

Maybe you upgrade to 2.5.10-13 ?

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)