Subject: FVWM: fvwm themes

From: synaptical <[email-masked]>
Date: Sat, 25 Sep 2004 10:20:59 -0700 (PDT)

hi - i'm new to fvwm. i have fvwm 2.5.10 and i'm trying to install the themes, but it fails with an error saying i need at least version 2.5.8. (?) 

clutching at straws, i copied the /usr/lib/fvwm/2.5.10 directory to /usr/lib/fvwm/2.5.8 and changed the version to 2.5.8 in /usr/bin/fvwm-config, but it still fails. can anyone tell me how to work around this to get the themes installed? thnks. 

_____________________________________________________________
Thank you for choosing LinuxQuestions.
http://www.linuxquestions.org
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 Sep 2004 21:47:15 +0000

On 25 Sep 2004 10:20:59 -0700, synaptical wrote:
> 
> hi - i'm new to fvwm. i have fvwm 2.5.10 and i'm trying to install the
> themes, but it fails with an error saying i need at least version
> 2.5.8. (?)

I understand that you got an error line "You need at least fvwm-2.5.8".
But there is also the second error line (there are 2 cases) that
should explain what is your problem. Post this second error line
if you can't figure what to do.

> clutching at straws, i copied the /usr/lib/fvwm/2.5.10 directory to
> /usr/lib/fvwm/2.5.8 and changed the version to 2.5.8 in
> /usr/bin/fvwm-config, but it still fails. can anyone tell me how to
> work around this to get the themes installed? thnks.

This is not the correct way to fix the problem. I think you simply have
several fvwm installations and the first fvwm-config in your $PATH is not
from 2.5.10. In this case either uninstall the older version, or follow
the advice from the error message, i.e. supply --with-fvwm-bindir option.

Regards,
Mikhael.