Subject: FVWM: How to start up a program at where I want?

From: Shuxiang Liu <[email-masked]>
Date: Fri, 3 Sep 2004 09:54:59 -0700

Hi, there,

Each time I restart FVWM I want an xterm started at the center of page
0, a firefox
at top left of page 1, thunderbird at page 2....
I am wondering if there is a way to do it in the StartFunction?
Thanks for your input.

Shuxiang
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alexander Kolosov <[email-masked]>
Date: Sat, 04 Sep 2004 00:00:03 +0400

Hi, Shuxiang!

> I am wondering if there is a way to do it in the StartFunction?
Something like this may help you:

+ I GotoPage 0 0
+ I Exec exec xterm
+ I Wait xterm
+ I Current PipeRead "echo Move `expr $[vp.width] / 2 - $[w.width] / 2`p `expr $[vp.height] / 2 - $[w.height] / 2`p"

+ I GotoPage 1 0
+ I Exec exec firefox
+ I Wait "Mozilla Firefox"
+ I Current Move +0 +0

+ I GotoPage 2 0
+ I Exec exec thunderbird
+ I Wait "Mozilla Thunderbird"
+ I Current Move +0 +0

It can be placed in your StartFunction or (may be it's more useful) in
InitFuntction.

-- 
Alexander Kolosov