Subject: FVWM: Titlebar buttons missing in Mozilla & fullscreen mozilla hides my Taskbar

From: "Subbiah" <[email-masked]>
Date: Wed, 1 Sep 2004 10:51:38 +0530

Hi All,

I am having fvwm 2.4.3 with me. I am using fvwm95 style in my PC.

In my mozilla browser (ver 1.3), The popup menus are coming with out close
button at the right corner of the window.

Similar way for the Preference selection window, I am getting only minimize
button.

How to get all the three buttons for the mozilla windows?

In Mozilla in Fullscreen mode hides my Taskbar. How to prevent this also?

With Regards,
L. Subbiah

-----------------------------------------Disclaimer-------------------------------------------------------

This document is intended for transmission to the named recipient only.If you are not that 
person, you should note that legal rights reside in this document and your are not authorized
to access, read, disclose, copy, use or otherwise deal with it and any such actions are prohibited 
and may be unlawful.The views expressed in this document are not necessarily those of HCL Peripherals 
Notice is hereby given that no representation, contract or other binding obligation shall be created
by this e-mail, which must be interpreted accordingly.Any representations, contractual rights or
obligations shall be separately communicated in writing and signed in the original by a duly authorized
officer of the relevant company.

----------------------------------------------------------------------------------------------------------

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 2004 14:39:26 +0200

> How to get all the three buttons for the mozilla windows?

Try

  Style * NoFuncHint, NoDeconHint

This tells fvwm to ignore the hints that disable these buttons
(actually, one of these styles is sufficient, but I don't know
which one).

> In Mozilla in Fullscreen mode hides my Taskbar. How to prevent this also?

You can't make the mozilla window smaller because fullscreen mode
means the whole screen, regardless of what's on it.  You can put
the Taskbar on a higher layer, e.g. with

  Style FvwmTaskBar Layer 20

In 2.5.x, the EwmhBaseStruts command defines aread near the screen
edges that are not used by maximized windows, but that does not
affect fullscreen windows.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 2004 17:03:51 +0200

On Wed, Sep 01, 2004 at 08:10:49PM +0530, Subbiah wrote:
> Dear Dominik,

Please reply to the mailing list, not to me personally.

> Thanks. It works for me.
> It works. But my bottom press bar is leying under the Taskbar. Some other
> application, which needs to be in fullscreen. But the Taskbar is coming
> above.
> Any other way to overcome this.?

Well, you can put that one on an even higher layer, but I see no
better way than that.

  Style windowname Layer 21

Where the windowname is probably FvwmButtons (?).

Ciao

Dominik ^_^  ^_^