Subject: FVWM: title bar

From: m p <[email-masked]>
Date: Mon, 2 Aug 2004 14:30:58 -0700 (PDT)

Hello,
how display xterm name on the title bar and icon
instead
of user name and path,
ie instead of 

USER on machine: /path

get just xterm name.
 
This used to work in twm with command 
xterm ...  -n NAME -T NAME  but not in fvwm2

Thanks,
Mark

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 2 Aug 2004 22:37:14 +0100

On Mon, 2 Aug 2004 14:30:58 -0700 (PDT)

> xterm ...  -n NAME -T NAME  but not in fvwm2

This is probably a facet of how your shell handles the $PROMPT_COMMAND .
In my ~/.bashrc I have:

``
   # If this is an xterm set the title to user@host:dir
    case $TERM in
    #xterm*)
    #    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}:
${PWD}\007"'    #    ;;
    *)
        ;;
    esac
''

Change that as appropriate.

-- Thomas Adam

--
"Thomas is the kinda guy who'd happily write his own OS if it came to
it." -- Richard Gellman, via IRC.