Subject: FVWM: Error messages or increased verbosity

From: Dalibor Straka <[email-masked]>
Date: Tue, 24 Aug 2004 15:48:32 +0200

Hi all,

i downloaded two config files. One of them writes on stderr:
<<ERROR>> can't load picture sound.xpm
and the second one doesn't even it can't find it either!
How to enable this error messages?

Thank you,
-- Dalibor
PS: I know ImagePath fix the problem with sound.xpm ;)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 24 Aug 2004 14:37:03 +0000

> How to enable this error messages?

If you think an error message is not produced in some cases, please post
the config line demonstrating this. Always specify your fvwm version.

Regards,
Mikhael.

---

From: Dalibor Straka <[email-masked]>
Date: Tue, 24 Aug 2004 21:10:28 +0200

Hello,

> the config line demonstrating this. Always specify your fvwm version.

The problem is, that those configs are realy HUGE. Is there an option
to disable error messages? My fvwm version is the latest unstable
2.5.10.

The exact problem is with FvwmButtons,
*FvwmBottomBar: (20x1, Padding 3 4, Left, \
    Icon sound.xpm, Action "Exec exec gnome-volume-control")
The icon sound.xpm doesn't exist and i expected the error message
above.

Thanks,
-- Dalibor

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 24 Aug 2004 20:12:03 +0000

On 24 Aug 2004 21:10:28 +0200, Dalibor Straka wrote:
> to disable error messages?

No. There are only options documented in the man pages.

> My fvwm version is the latest unstable 2.5.10.
> 

This means that FvwmButtons silently ignores the missing image problem.
You (or someone else) are welcome to provide a patch for this case.

Regards,
Mikhael.

---

From: Dalibor Straka <[email-masked]>
Date: Wed, 25 Aug 2004 10:40:43 +0200

> No. There are only options documented in the man pages.
I can't find the right options for enable/disable error messages in man
fvwm. Do you know them?

> You (or someone else) are welcome to provide a patch for this case.

Not exactly, the same line in different config produces an error msg ;).

Thanks,
-- Dalibor

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 25 Aug 2004 09:21:04 +0000

> I can't find the right options for enable/disable error messages in man

As I said, if such option is not in the man page, it does not exist.
The intended operation is to always print missing-image errors. "Silent"
prefix may suppress some kind of errors, but not this one.

> Not exactly, the same line in different config produces an error msg ;).

The error you posted is from the colorset code, not FvwmButtons, so the
line is definitelly different. Something like: Colorset Pixmap sound.xpm.

Regards,
Mikhael.

---

From: Dalibor Straka <[email-masked]>
Date: Wed, 25 Aug 2004 11:27:59 +0200

> line is definitelly different. Something like: Colorset Pixmap sound.xpm.

I seeeeeeeeeeeeeeee, the first config, that writes an error is
complainig about missing sound.xpm, because it misses it at different
place!

Thank you very much,
-- Dalibor