Subject: FVWM: Applications steal focus

From: Nuno Alexandre <[email-masked]>
Date: Tue, 10 Aug 2004 20:08:31 +0200

Hi,
I would like to change the behaviour of the started  applications,
so that they dont steal focus from the task that has focus right now.

For example, if im writing in gvim, and I open firefox, and continue to
write in gvim ( hoping that firefox will open in the background, now
that gvim has focus and priority) instead firefox steals focus and takes
over the screen area.

This situation happens with every application.
I've used google and searched the man pages also, but could not find any
answer to this.

I hope someone can help me with this issue.

Thanks,
-- 

		Nuno Alexandre
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nuno Alexandre <[email-masked]>
Date: Tue, 10 Aug 2004 20:12:20 +0200

On (08/10/04 20:08), Nuno Alexandre wrote:
> To: [email-masked]
> From: Nuno Alexandre <[email-masked]>
> Date: Tue, 10 Aug 2004 20:08:31 +0200
> Subject: Applications steal focus
> 
> Hi,

Can you please CC me, if possible, thanks.

-- 

		Nuno Alexandre

---

From: Atul Awasthi <[email-masked]>
Date: Wed, 11 Aug 2004 00:00:18 +0530

Here is an example from my .fvwmrc

Style "*" Button 1, Button 2, Button 4, Button 6, GrabFocusOff
.
.
Style XTerm*  EWMHMiniIconOverride, ..., GrabFocus

In the first example, none of the windows will grab (or steal) focus..
In the second example, only the terminal window is allowed to do so.
Hope thats what you were looking for.
Regards.

(cant believe he is 'helping' ikaro)

---

From: Nuno Alexandre <[email-masked]>
Date: Wed, 11 Aug 2004 01:01:38 +0200

On (08/11/04 00:00), Atul Awasthi wrote:
> To: [email-masked]
> Cc: Nuno Alexandre <[email-masked]>
> From: Atul Awasthi <[email-masked]>
> Date: Wed, 11 Aug 2004 00:00:18 +0530
> Subject: Re: FVWM: Re: Applications steal focus
> 

Ok, I see why this was not working.

Style "*" etc..etc.. works

Style * etc..etc.. does not.

Thanks,

-- 

		Nuno Alexandre

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 11 Aug 2004 00:19:26 +0000

> Style * etc..etc.. does not.

I don't think so. Quotes are fully optional here. The order of Style
lines matters though.

Regards,
Mikhael.