Subject: FVWM: Module(3) command is too big

From: Mario Domgörgen <[email-masked]>
Date: Mon, 02 Aug 2004 00:06:52 +0200

Hello list,

I'm writing a simple module in scheme, just to play a little bit with
fvwm, but i got into serious problems. The Module should just beep. I
think it's sho short and so understandable for even non schemers that i
can post it.

,---- fvwm.scm
| #!/usr/local/bin/gosh
| 
| (define (main args)
|   (let ((ostream (open-output-fd-port
|                   (string->number (list-ref args 1)))))
|     (display "None" ostream)
|     (display 4 ostream)
|     (display "Beep" ostream)
|     (display 0 ostream)))
`----

The error i get is:

[FVWM][HandleModuleInput]: <<ERROR>> Module(3) command is too big
(875573296), limit is 1000

I'm sure it something totally stupid, so please help me...

Mario

-- 
Out of memory.
We wish to hold the whole sky,
But we never will.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 1 Aug 2004 22:39:06 +0000

> I'm sure it something totally stupid, so please help me...

I suppose you want to run a script, not a module (that is not possible in
scheme as of now). In this case you should call it like "Exec script.scm"
and not "Module script.scm".

Regards,
Mikhael.

---

From: Mario Domgörgen <[email-masked]>
Date: Mon, 2 Aug 2004 00:47:24 +0200

> and not "Module script.scm".

No, not really. I want to write a module similar to perllib and use
scheme as language insead of perl. Is there a special C bridge to perl
to realite modules in perl?

Mario

-- 
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 1 Aug 2004 23:13:54 +0000

> to realite modules in perl?

No, there is no C bridge, it is pure perl.

You can't write modules in language X without first implementing some
kind of fvwm module library in X. This may take many months, even if you
just borrow the design from the perl module library (that should highly
simplify the task), or you choose another path and implement a highly
pared library for simple modules only. You may try if you are ready to
get such errors twice a day and are able to solve them on your own.

The developer section of fvwm.org includes all the info you need.
Theoretically, you don't need to learn the fvwm sources, but practically
this may help in your task.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Aug 2004 12:04:34 +0200

> I'm sure it something totally stupid, so please help me...

Try adding a newline at the end of the fvwm command.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Mario Domgörgen <[email-masked]>
Date: Tue, 03 Aug 2004 00:01:05 +0200

> Try adding a newline at the end of the fvwm command.

My problem was that i didn't of used long unsigned integers but just
normal numbers... :)

So i get a beep now and will try to implement input functions!

Thanks for your ideas neverless...

Mario

-- 
A crash reduces
your expensive computer
to a simple stone.