Subject: FVWM: FvwmButtons: multiple swallows

From: Florian Schmidt <[email-masked]>
Date: Mon, 30 Aug 2004 12:58:06 +0200

Hello,

I am trying to use FvwmButtons (Fvwm 2.5.10) as some sort of systray. That
is, I'm trying to get it to swallow small docklet windows some
applications provide (e.g. the jabber client psi). I wrote a small example
configuration for that matter:

################## FvwmButtons button-bar ################################
KillModule FvwmButtons
DestroyModuleConfig FvwmButtons: *
*FvwmButtons: Geometry 66x22-1+296
*FvwmButtons: Back #484048
*FvwmButtons: Fore steelblue
*FvwmButtons: Rows 1
*FvwmButtons: Columns 3
*FvwmButtons: BoxSize smart
*FvwmButtons: (1x1, Swallow(NoClose, NoOld, Kill) "psidock")

Module FvwmButtons
##########################################################################

When I (re)start Fvwm, everything works fine: FvwmButtons appears, and as
soon as I start psi, the docklet gets swallowed. However, when I close psi
and restart it later, the docklet will not get swallowed again, but
instead float somewhere on the screen, like any other window. Is that a
known limitation I can only avoid by not closing psi after I opened it for
the first time, or am I missing something? 

Many Thanks,

Florian

-- 
Immer hält der Menschenfresser,
wenn er seine Menschen frißt,
links die Gabel, rechts das Messer,
weil er gut erzogen ist.				[Franz Wittkamp]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Roeland Moors <[email-masked]>
Date: Mon, 30 Aug 2004 14:11:01 +0200

> *FvwmButtons: (1x1, Swallow(NoClose, NoOld, Kill) "psidock")

I have the same problem with FvwmScripts in FvwmButtons. It's swallowed on
restart but not on the first start. 
It's possible the size is to small, but why does it work on a
restart?

-- 
Roeland

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 2004 12:25:10 +0200

> *FvwmButtons: (1x1, Swallow(NoClose, NoOld, Kill) "psidock")
                              ^^^^^^^         ^^^^

Note that the (No)Kill setting has no effect when NoClose is used.

> instead float somewhere on the screen, like any other window.

> Is that a known limitation I can only avoid by not closing psi
> after I opened it for the first time, or am I missing something? 

It's a limitation nobody thought of.  I'll add an option
SwallowNew that is like NoRespawn, but if a matching window
appears on its own, the new window is swallowed.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 2004 12:27:20 +0200

> restart but not on the first start. 

Actually, this is a completely different problem.

> It's possible the size is to small, but why does it work on a

There are many subtle things that can go wrong.  If you post your
FvwmButtons configuration I can take a look at it.

Ciao

Dominik ^_^  ^_^