Subject: FVWM: Cycling Pager Navigation

From: "Jason Dobies" <[email-masked]>
Date: Fri, 27 Aug 2004 08:17:19 -0400

I currently have my keys set up such that Ctrl+Meta+<arrow> moves to
another page in the pager (I apologize if I'm using the wrong
terminology). The mappings are defined as follows:

Key Left   A CM Scroll -100 +0
Key Right  A CM Scroll +100 +0
Key Up     A CM Scroll +0 -100
Key Down   A CM Scroll +0 +100

What I want to do is to add the ability to cycle back around the pager.
That is, if the current page is at the left edge of the pager, the next
time I press C-M-Left, the current page would cycle to the right most
edge, but stay in the same row. I want similar functionality for
vertical movement as well.

For the record, I'm using 2.5.10 and my DeskTopSize is 4x3.

Any help is appreciated. Thanks!

- Jay
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 27 Aug 2004 14:08:09 +0000

> For the record, I'm using 2.5.10 and my DeskTopSize is 4x3.

Depending on which kind of wrapping you want, use either this:

  Key Down   A CM Scroll +0 +100000
  Key Up     A CM Scroll +0 -100000
  Key Right  A CM Scroll +100000 +0
  Key Left   A CM Scroll -100000 +0

or this:

  Key Down   A CM Scroll +400000 +0
  Key Up     A CM Scroll -400000 +0
  Key Right  A CM Scroll +0 +300000
  Key Left   A CM Scroll +0 -300000

I think there is a small bug with negative offsets in the last examples.
It is probably a one line patch, feel free to send a fix.

Regards,
Mikhael.