Subject: FVWM: java application on full screen

From: Vladimir Nikolic <[email-masked]>
Date: Thu, 26 Aug 2004 15:29:19 +0200

Hello!

I am using fvwm2-2.5.9 on SuSE 9.1. I need to start fvwm2 and after that 
one java application on full screen. My .fvwm2rc looks like this:
...
fvwm2 &
javaapp
...
Trouble is that I have to double-click on border of java application 
window to get it resized on full screen. Is it possible that fvwm2 do it 
automatically, without mouse clicking? I've tried examples from faq 3.18 
but it didn't help.

Thanks,
Vlado
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 2004 10:25:54 +0200

> automatically, without mouse clicking? I've tried examples from faq 3.18 

I don't quite understand what you are trying to do.  What is the
initial size of the window, and how do you want it (size, with or
without borders, ...)?

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Vladimir Nikolic <[email-masked]>
Date: Mon, 30 Aug 2004 13:00:46 +0200

I've added:
  +      "I"     Exec javaapp
in 'AddToFunc InitFunction' section and line:
Style * Layer 10, NoHandles,NoTitle,StaysOnTop,StaysOnTop,BorderWidth 0
in general setup section.
Now my java application starts on full screen window, users
can't move it, resize it and that is what I've wanted.
Is there some better solution?

Regards,
Vlado

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 31 Aug 2004 12:36:17 +0200

> Style * Layer 10, NoHandles,NoTitle,StaysOnTop,StaysOnTop,BorderWidth 0
                                      ^^^^^^^^^^^^^^^^^^^^^

(one StaysOnTop is enough)

> Is there some better solution?

Hm, what's wrong with that solution?

Ciao

Dominik ^_^  ^_^