Subject: FVWM: Question : Command evaluation when setting environment variables possible ?

From: "Lehmacher Frank" <[email-masked]>
Date: Fri, 6 Aug 2004 07:15:21 +0200

Hello fvwm developers,

I need to set the hostname of my machine dynamically within the .fvwm2rc file.

Unfortunately the command evaluation within back ticks

	SetEnv  HOSTNAME `/bin/hostname`

does not work.

Is there another possibility to do it within .fvwm2rc (or a syntax error within the line shown above) ?

Unfortunately I did not find anything appropriate in the manual.

Thank you for your assistance

	Frank
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Fri, 6 Aug 2004 15:54:28 +1000

> Is there another possibility

One way to do it is to use a PipeRead:

PipeRead 'echo "SetEnv FRANK `hostname`"'
Echo $[FRANK]

SCoTT. :)