Subject: FVWM: Form Question

From: Nicholas Harknett <[email-masked]>
Date: Tue, 24 Aug 2004 09:40:13 -0400

Hello,
   How does one go about destroying / closing / killing a form from
another form?  I basically need to kill a list of forms upon execution
of another form.  I have searched quite a bit and read the FVWMForm
man page in great depth a few times, but I still know not how to achieve
the functionality I am looking for.  Thanks for any and all help.

	Cheers,
	  Nicholas Harknett
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 24 Aug 2004 14:26:25 +0000

> the functionality I am looking for.  Thanks for any and all help.

I suppose you know how to bind an fvwm action. Then something like:

  All (FvwmForm) ThisWindow (!FvwmForm-TheMainForm) Close

or maybe have a function that closes individual windows:

  AddToFunc CloseMyForms
  + I Next (FvwmForm-Secondary) Close
  + I Next (...) Close

Regards,
Mikhael.