Subject: FVWM: Modul FvwmButtons does not start using Fvwm 2.5.x in combination with my .fvwmrc file

From: "Lehmacher Frank" <[email-masked]>
Date: Wed, 11 Aug 2004 09:45:55 +0200

Hello FVWM team,

since SuSE 9.1 which is shiped with FVWM 2.5.9-38
my .fvwm2rc configuration file is not properly loaded anymore,
but can be started with FVWM 2.4.x without any problems.

The problem is that the Module FvwmButtons creating a CDE-like panel does not start anymore.

Even the newest version 2.5.10 fails and gives the following error message :

     MyMainButtonBox: Button out of horizontal range. Quitting.

The module FvwmButtons is used to replicate a CDE-like panel.

=>     Module FvwmButtons MyMainButtonBox

I am not sure if it is a bug, but the 2.5.x version included in SuSE 9.0 accepted my .fvwm2rc while 2.5.10 does not.

Please find enclosed my .fvwmrc file for error tracking ?
The size of the file .fvwm2rc is about 140 kB (see attached tar file).

If you like I can also send all files and pixmaps referenced by .fvwm2rc,
but they are not neccessary to reproduce the error.

My fvwm2 configuration is comparably complex and the complete package
including all files and pixmaps referenced takes about 30 MB.

Is there a possibility to upload this package to a dedicated FTP server ?

Please find also enclosed a picture (fvwm_desk_ok.jpg) showing how the desktop should look like
(after deiconizing the FvwmButton icon in the top left)
when the configuration file is properly loaded (tested with fvwm 2.4.18).

Thank you for your help

Best regards

	Frank

#########################################################################

===========
Environment
===========

CPU           : AMD Athlon XP 2200+
OS            : SuSE 9.1
Xserver       : XFree 4.3.99.902 (4.4.0 RC 2)
Kernel        : 2.6.5-7.104-default
RAM           : 1 GB
Graphic Card  : Nvidia GeForce Ti 4200
Nvidia driver : NVIDIA-Linux-x86-1.0-5336-pkg1.run
Resolution    : 1280x1024, 24bit, 3D acceleration active
Monitor       : Nokia 446XS [31-96 kHz, 50-150Hz]

=====
Notes
=====

The problem seems to be independent of :

  - The kernel version
  - The graphics card driver
  - The version of the Xserver

#########################################################################

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Aug 2004 21:13:08 +0000

On 11 Aug 2004 09:45:55 +0200, Lehmacher Frank wrote:
> I am not sure if it is a bug, but the 2.5.x version included in SuSE
> 9.0 accepted my .fvwm2rc while 2.5.10 does not.
> 

It may be time consuming to learn and fix 30MB or 140KB of complex
configurations, you should not expect this.

Please make a minimal config file (10-20 lines) showing the problem with
"fvwm -f my-minimal-config". It is possible you will be able to reproduce
this problem without any images and even fix it yourself once you nail it.

> Is there a possibility to upload this package to a dedicated FTP server ?

I think you may find a free web hosting, so you could post just urls of
images and simple configs to the mailing list. Large tarballs are not
the best thing to attach.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].