Subject: Re: FVWM: "FvwmTaskbar MailBox" with IMAP

From: Dominik Vogt <[email-masked]>
Date: Tue, 3 Aug 2004 10:20:43 +0200

On Tue, Apr 20, 2004 at 05:54:06AM -0700, uday bhaskar wrote:

Sorry for the late reply.

> Not sure if this is the appropriate place to ask this
> question, please redirect me to the appropriate palce.
> 
> My question is how do I use the "FvwmTaskbar MailBox"
> setting when I use IMAP for my mail access. All fvwm
> says is add the path. Can someone help me out with how
> the path has to be specified. {imap.domain.com}INBOX
> does not work.

FvwmTaskBar just watches a file for new mails.  You could use some
other program such as fetchmail to download the mails to a local
file.  If this is inacceptable, you can make some external script
that checks for new mail and writes something to a fake mailbox,
e.g.:

  #!/bin/sh
  echo > /tmp/have_new_mail
  while true; do
    if new_mail_in_imap_box; then
      echo "new mail" >> /tmp/have_new_mail
    fi
    sleep 300
  done

And tell FvwmTaskBar to watch the /tmp/have_new_mail file instead
of a real mailbox:

  *FvwmTaskBar: MailBox /tmp/have_new_mail

The difficult part is to write the "new_mail_in_imap_box" command
or function.  Since I never used IMAP, I don't know what tools
there are to do it.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 3 Aug 2004 08:47:19 +0000

> or function.  Since I never used IMAP, I don't know what tools

fetchmail may be used to check (or fetch) email on the mail server that
uses POP, IMAP and other protocols. I once played with fetchmail and
found it not configurable enough, however you may add missing
functionality by scripting.

Add one line to ~/.fetchmailrc like:

  skip mail.your-server.com proto imap username uday_p password your_passwd

Then execute:

  fetchmail -c                           mail.your-server.com
  fetchmail -c -r mail/FVWM              mail.your-server.com
  fetchmail -c -r mail/Other-Mail-Folder mail.your-server.com

As I said, you need some parsing of the output to actually tell whether
there is an email in one of the folders, it outputs:

  1623 messages (1621 seen) for uday_p at your-server.com (folder mail/FVWM).

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uday Bhaskar <[email-masked]>
Date: Tue, 24 Aug 2004 00:13:39 +0530 (IST)

>   1623 messages (1621 seen) for uday_p at your-server.com (folder mail/FVWM).

Thanks a lot for this. I'll get this working. Sorry for the delayed reply
I was travelling.

Uday

-- 
Thanks
Uday