Subject: FVWM: Menu /mouse problem

From: m p <[email-masked]>
Date: Tue, 3 Aug 2004 12:01:06 -0700 (PDT)

Hi,
I have the following setup for a menu:

AddToMenu RootMenu      "Windows"       Title
+                       "Move"          Move
+                       "Resize"        Resize
....

and 

Mouse 2 R       A       Menu RootMenu Nop

Why is it that once I open the menu with middle
mouse button and unwillingly click
on the top (Title) a new window pops up with
RootMenu and how to get rid of this?
Thanks,
Mark

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 3 Aug 2004 20:13:54 +0100

> RootMenu and how to get rid of this?

It's a default binding, you can just undefine it if you
don't like it:

Mouse 2 M N -

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 4 Aug 2004 12:17:40 +0200

On Tue, Aug 03, 2004 at 12:01:06PM -0700, m p wrote:
> RootMenu

It's a feature that allows pinning menus to the desktop (aka "tear
off menus").  Usually - for example in gimp - there is a dashed
horizontal bar at the top of a menu that can be clicked to tear a
menu off.  But fvwm supports tearing off for all menus, and
clicking with button 2 on the title bar is one way to achieve this
(pressing Backspace is another).

Unfortunately there is no way to close a tear off menu with the
mouse yet.

> and how to get rid of this?

What Tavis said.  You can close tear off menus by pressing Escape
with the mouse over the menu window.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 04 Aug 2004 07:01:26 -0400

> > I have the following setup for a menu:
...
> Unfortunately there is no way to close a tear off menu with the

My tear off menus have a window title and frame.
I can click on the titlebar close button with the mouse to close the
menu.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: m p <[email-masked]>
Date: Wed, 4 Aug 2004 11:38:35 -0700 (PDT)

Thanks, but it does not look that it works though.
I exited and restarted fvwm but no change.
Here is my mouse setup for the menu 

Mouse 1 R       A       Menu Window-Ops Nop
Mouse 2 R       A       Menu RootMenu Nop
Mouse 3 R       A       Menu Utilities Nop
Mouse 2 M       N -

Any tips?
Thanks,
Mark

		
__________________________________
Do you Yahoo!?
Y! Messenger - Communicate in real time. Download now. 
http://messenger.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].