Subject: FVWM: 2 Hiddenconsoles

From: Stefan Schöllermann <[email-masked]>
Date: Fri, 6 Aug 2004 13:18:32 +0200

hi, 

I'm trying to use 2 Hiddenconsoles on my fvwm-Destop. But it is not
working. Only one Console "pops down", when I move my Mouse above it!

Here is my Config:

AddToFunc StartFunction
+ I Module FvwmAuto FvwmAutohide -menter FuncAutoEnter
+ I StartHiddenConsole
+ I StartHiddenConsole1

DestroyFunc StartHiddenConsole
AddToFunc StartHiddenConsole
+ I Exec exec Eterm --options .... -n "HiddenConsole"

DestroyFunc StartHiddenConsole1
AddToFunc StartHiddenConsole1
+ I Exec exec Eterm --options .... -n "HiddenConsole1"

DestroyFunc FuncAutoEnter
AddToFunc FuncAutoEnter
+ I Autohide HiddenConsole1 500 500 N
+ I Autohide HiddenConsole 250 500 N

AddToFunc Autohide
+ I ThisWindow ($0) Deschedule $[w.id]
+ I TestRc (!Match) Deschedule -$[w.id]
+ I ThisWindow ($0) ThisWindow (shaded) AutohideShow $1 $3
+ I TestRc (!Match) All ($0, !shaded) AutohideHide $2 $3

AddToFunc AutohideShow
+ I Schedule $0 -$[w.id] WindowShade $1 off
+ I Schedule $0 -$[w.id] Raise
+ I Schedule $0 -$[w.id] Deschedule $[w.id]
+ I Schedule $0 -$[w.id] Deschedule -$[w.id]

AddToFunc AutohideHide
+ I Schedule $0 $[w.id] WindowShade $1 on
+ I Schedule $0 $[w.id] Deschedule $[w.id]
+ I Schedule $0 $[w.id] Deschedule -$[w.id]

Please Help me .. ;) Thanks steve
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 7 Aug 2004 01:32:06 +0200

> working. Only one Console "pops down", when I move my Mouse above it!

I see.  My script is broken.  The second call of Autohide:

always deschedules the AutohideShow from the first call.  I can't
think of a simple way to fix this from the top of my head.

> + I Schedule $0 $[w.id] Deschedule -$[w.id]

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]