Subject: FVWM: Trouble with xorg-x11 and fvwm

From: Palko Jukka <[email-masked]>
Date: Thu, 5 Aug 2004 09:31:21 +0300

Greetings

I've been using fvwm for quite some time and it has landed to my desktop
systems as my favourite solution.

Now with the coming of xorg x11 however I have bumped into a minor glitch as I
would like to use my multimedia keyboard to it's full extent. I put a posting
onto my current distributions forum [1] which describes my problems in the
easiest way.

Perhaps I could get hints from this list on the problem. :)

-jpalko

[1] http://forums.gentoo.org/viewtopic.php?t=205004

-- 
     Jukka Palko        [email-masked]
     ICQ: 45463432      [email-masked]
"Only if you want to, will you find a way..." -- Enya
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ben Winslow <[email-masked]>
Date: Thu, 05 Aug 2004 04:55:17 -0400

> [1] http://forums.gentoo.org/viewtopic.php?t=205004
The problem keys don't seem to be listed in your xev output...  perhaps
your keyboard is using different keycodes than the ones you used in your
xkb symbols file?

-- 
Ben Winslow <[email-masked]>

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Aug 2004 10:42:09 +0200

> Perhaps I could get hints from this list on the problem. :)

Run

  $ xmodmap -pke

to see whether these keys are configured properly.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Palko Jukka <[email-masked]>
Date: Thu, 5 Aug 2004 12:59:51 +0300

> > Perhaps I could get hints from this list on the problem. :)

looks like they are there:
keycode 144 = XF86AudioPrev
keycode 153 = XF86AudioNext
keycode 160 = XF86AudioMute
keycode 162 = XF86AudioPlay XF86AudioPause
keycode 164 = XF86AudioStop
keycode 174 = XF86AudioLowerVolume
keycode 176 = XF86AudioRaiseVolume
keycode 178 = XF86HomePage
keycode 225 = XF86Standby
keycode 229 = XF86Search
keycode 230 = XF86Go
keycode 236 = XF86Mail

---

From: Palko Jukka <[email-masked]>
Date: Thu, 5 Aug 2004 13:04:08 +0300

> your keyboard is using different keycodes than the ones you used in your

Looks like I copypasted a bit wrongly to the forum, but the keys are listed:
KeyPress event, serial 31, synthetic NO, window 0x1200001,
    root 0x76, subw 0x0, time 82248, (97,94), root:(936,125),
    state 0x0, keycode 230 (keysym 0x1008ff5f, XF86Go), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x1200001,
    root 0x76, subw 0x0, time 81088, (97,94), root:(936,125),
    state 0x0, keycode 236 (keysym 0x1008ff19, XF86Mail), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

Hmmm... XF86Search has a wrong code though... Must have misread that one. :)

---

From: Palko Jukka <[email-masked]>
Date: Thu, 5 Aug 2004 13:09:58 +0300

> Hmmm... XF86Search has a wrong code though... Must have misread that one. :)

Interesting, the Search and Go keys are giving the same keycode to me at the
moment:

KeyPress event, serial 31, synthetic NO, window 0x2a00001,
    root 0x76, subw 0x0, time 3523077, (15,88), root:(1164,1103),
    state 0x0, keycode 230 (keysym 0x1008ff5f, XF86Go), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x2a00001,
    root 0x76, subw 0x0, time 3523610, (15,88), root:(1164,1103),
    state 0x0, keycode 230 (keysym 0x1008ff5f, XF86Go), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

Oh well, hadn't noticed that before. :)

---

From: Palko Jukka <[email-masked]>
Date: Thu, 5 Aug 2004 13:28:01 +0300

> Oh well, hadn't noticed that before. :)

Okay, fvwm works great, looks like this rolls towards xorg configs... For some
reason the "looking glass" and "running dude" buttons on my keyboard give the
same keycode with xorg x11.

Thanks for the help. :)

My mistake was actually in my config... and those really smart absolute paths to
commands...