Subject: FVWM: basic probelm --prefix dosent work! now what?

From: Chintamani Lonkar <[email-masked]>
Date: Thu, 12 Aug 2004 13:36:25 -0700 (PDT)

HI i am pretty new to installing x windows. 
I am using FVWM version 1 and want to update to
current stable version. 

Well i run the following script. I have write
permissions to "/usr/users/a14fs/cmlonkar/" only

"./configure --enable-debug-msg --help
--prefix=/usr/users/a14fs/cmlonkar/"

Shoudnt --prefix take care of path ? I get the
following error msg:-

"interpreter "/bin/sh" not found
file link resolves to "usr/bin/sh"
./configure: Command not found."

Obviously some script is looking in that path to
write. Which file will have the 'link' that i need to
resolve.

Thanks,
Mani !

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 12 Aug 2004 21:40:12 +0100

> ./configure: Command not found."

What is your $SHELL set to? If it is bash, /bin/sh should be a
symlink to it, normally.

-- Thomas Adam
--
"Frankly, Mr. Shankly, since you ask. You are a flatulent pain in 
the arse." -- Morrissey.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 12 Aug 2004 20:43:26 +0000

On 12 Aug 2004 13:36:25 -0700, Chintamani Lonkar wrote:
> "./configure --enable-debug-msg --help --prefix=/usr/users/a14fs/cmlonkar/"

You don't need --enable-debug-msg.
--help prints the help, don't specify it.

> write. Which file will have the 'link' that i need to

It seems that your system is a bit broken regarding /bin/sh,
make it (or ask your sysadmin) to resymlink it to the real shell.

Alternativelly, you may do "bash configure --prefix=...". But if your
system can't run standard shell scripts, then you will have many problems
including boot problems, I guess.

Regards,
Mikhael.