Subject: FVWM: FvwmTaskBar -- How to change the color of the clock?

From: "Matthew J Kettlewell" <[email-masked]>
Date: Tue, 13 Jul 2004 02:12:55 -0600

Hi all,

It's late and I'm sure I'm missing something easy.  I'm trying to change  
the color of the clock that floats on the right hand side of the taskbar,  
but can't seem to find the correct setting.  It only wants to be black.   
I've seem some screen shots where it is white, but I can't find a .fvwm2rc  
file to explain what it does.

I'm using 2.5.10 (unstable release) on Linux 2.4.18 kernel and XFree86  
4.4.0

I've played with colorsets and the Fore and Back settings to no avail....

Thoughts ??  ( Help would be even better, but I'll even take an insult at  
this point )

Thanks,

Matt

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Jul 2004 12:07:07 +0200

> file to explain what it does.

The clock uses the standard FvwmTaskBar colour set:

  Colorset 99 fg white, bg black
  *FvwmTaskBar: Colorset 99

The obsolete Fore and Back options work too, but they must be set
before the task bar is started, while colour sets can be changed
at any time.

It looks like the clock string is not updated automatically when
the colour set changes, though.  If you start with a black
foreground, start FvwmTaskBar and change the colour set's fg to
white it may take a while before the clock is drawn in white too.
I have committed a fix to CVS.  If it still does not work with the
fix, please post your colour set and FvwmTaskBar configs.

> Thoughts ??  ( Help would be even better, but I'll even take an insult at  

We don't make a habit of insulting people on this list.  There are
no stupid questions, only stupid answers.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: "Matthew J Kettlewell" <[email-masked]>
Date: Tue, 13 Jul 2004 09:32:45 -0600

Hmmmm.... something still not right.... I've put together a minimal  
.fvwm2rc to show what I'm doing.  Anything standout as being obsolete or  
non-standard?  I've been trying to not get *too* crazy with things ( only  
a taskbar and pager )

I'm still getting the foreground text on the clock to be static at black,  
so with my background at black, no clock appears.

Any help is appreciatiated....

Thanks,

Matt

#############################################
#############################################
## Start of .fvwm2rc

ModulePath /usr/local/libexec/fvwm/2.5.10:+

DestroyFunc StartFunction
DestroyFunc InitFunction

AddToFunc StartFunction
+ I Module FvwmTaskBar

AddToFunc InitFunction
+ I Module FvwmPager
+ I Exec aterm -ls -sh 70 -bg black -fg green -tr +sb -fn 7x14 -fb 7x14bold

Mouse 1		R   	A       Menu RootMenu Nop

AddToMenu RootMenu RootMenu Title top
+                       "a&Term " Exec aterm -ls -sh 70 -bg black -fg  
green -tr +sb -fn 7x14 -fb 7x14bold
+			""		Nop
+		 	"Exit Fvwm"	Popup Quit-Verify

AddToMenu Quit-Verify 	"No, Don't Quit"    Nop	
+		      	""		    Nop	
+                       "Restart Fvwm"      Restart
+		      	""		    Nop	
+		      	"Yes, Really Quit"  Quit	

DeskTopSize 2x2
EdgeResistance 100 100
EdgeScroll 100 100
EdgeThickness 2

Style "FvwmTaskBar" NoTitle, BorderWidth 4, HandleWidth 4, Sticky, \
StaysOnTop, WindowListSkip, CirculateSkip

*FvwmTaskBar: Geometry +0-0
*FvwmTaskBar: ClockFormat %T
*FvwmTaskBar: Colorset 99

## End of .fvwm2rc
###############################################
###############################################

-- 
~~  Kettlewell Enterprises, Inc  ~~
web:    http://www.kettlewell.net
email: [email-masked]
phone:  303 - 237 - 3095
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 13 Jul 2004 17:39:29 +0000

On Tue, Jul 13, 2004 at 02:12:55AM -0600, Matthew J Kettlewell wrote:
> Hi all,
> 
> It's late and I'm sure I'm missing something easy.  I'm trying to change  the
> color of the clock that floats on the right hand side of the taskbar,  but
> can't seem to find the correct setting.  It only wants to be black.   I've
> seem some screen shots where it is white, but I can't find a .fvwm2rc  file
> to explain what it does.
> 
> I'm using 2.5.10 (unstable release) on Linux 2.4.18 kernel and XFree86  4.4.0
> 

Try looking at ${HOME}.Xresources and likely config files under /etc

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 13 Jul 2004 20:44:35 +0200

> so with my background at black, no clock appears.

(Please post replies below the quoted portions of the original
mail on the fvwm lists.)

With the code from CVS, you config works exactly as it should on
my machine.  The clock text is white on black, right from the
start.

What exactly do you see?

 * Is the text on the window buttons also black, or is it white?
 * Does the clock text become white after one minute?
 * What if you move the pointer over the TaskBar for a couple of
   seconds?
 * Did you download the lastest CVS code and try that?  If you
   don't want to use CVS, try tomorrow's snapshot (my patches may
   not be in today's snapshot).

> ModulePath /usr/local/libexec/fvwm/2.5.10:+

If you have tried CVS, you're running the old modules against a
current fvwm version.  It should not be necessary to set the
module path to run fvwm.
 
> *FvwmTaskBar: Colorset 99

[snip]

Ciao

Dominik ^_^  ^_^

---

From: "Matthew J Kettlewell" <[email-masked]>
Date: Tue, 13 Jul 2004 13:48:16 -0600

> Dominik ^_^  ^_^

I'm not sure exactly what a window button is, but the buttons on the  
taskbar (window buttons?) have the white text with black background as I  
was expecting.  The clock is the only thing not grabbing the foreground  
color (but it does grab the background color).

The color of the clock doesn't change even over night, and holding the  
mouse over it does nothing either.

I've tried the snapshot today and it is the same, I will try tomorrows  
snapshot as you recommend ( not familiar enough with cvs to "just do it",  
and too tired to figure it out today. )

Any thoughts on any other resources that might be conflicting, ie.  
Xresources, et al ??  I've looked, but don't see anything too strange

Thanks, and sorry for top posting earlier,

Matt

---

From: "Matthew J Kettlewell" <[email-masked]>
Date: Tue, 13 Jul 2004 21:32:05 -0600

All,

Thanks for the reply's and assistance.  In the end, it turns out that it  
has nothing to do with FVWM.  I upgraded to XFree86 4.4.0 and the xfs font  
server has been giving me troubles ever since.  I think I got it's  
problems ironed out, and... whalla.. the clock colors are doing exactly  
what they should.

So, thanks again, and expect more questions as I'm configuring my desktop

Matt