Subject: FVWM: Funny font

From: "Reuben D. Budiardja" <[email-masked]>
Date: Sun, 11 Jul 2004 19:22:51 -0400

Hi,
The text in my FVWM button looks funny. It has a square following every 
letter. 
It looks this has something to do with encoding or LANG environment or 
something like that, but I couldn't find what to do to fix this in the 
archive. I probably just didn't use the correct keywords for searching. Could 
someone please help? 

To be clearer, here's a screenshot of my FVWM desktop. On the first 
screenshot, the letters supposed to read "man" : 

http://voyager.phys.utk.edu/tmp/fvwm_snapshot1.png
http://voyager.phys.utk.edu/tmp/fvwm_snapshot2.png

Thanks for any help.
Reuben D. Budiardja

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Jul 2004 23:57:52 +0000

> http://voyager.phys.utk.edu/tmp/fvwm_snapshot2.png

But you didn't say which fvwm version you run, what font you defined for
FvwmButtons, and what is the output of `locale` in your environment.

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Mon, 12 Jul 2004 14:51:29 +1000

> The text in my FVWM button looks funny. It has a square following every 

Not sure how helpful this is, but ...

On my Redhat 9 machine I edited /etc/sysconfig/i18n to look like this:

LANG="en_AU"
SUPPORTED="en_AU.UTF-8:en_AU:en"
SYSFONT="latarcyrheb-sun16"

Presumably there is a similar config file for your own system.

SCoTT. :)

---

From: Michelle Konzack <[email-masked]>
Date: Mon, 12 Jul 2004 11:11:26 +0200

>SYSFONT="latarcyrheb-sun16"
	  ^^^^^^^^^^^^^^^^^
What has the console font to do with the X-Window-System ?

Maybe you need in .fvwmrc somting like:

  ____ ( '/home/michelle/.fvwm/.fvwmrc' ) ______________________________
 /
|  Style * Font		-*-helvetica-medium-r-*-*-14-*-*-*-*-*-iso10646-1
|  Style * IconFont	-*-helvetica-medium-r-*-*-10-*-*-*-*-*-iso10646-1
 \______________________________________________________________________

>Presumably there is a similar config file for your own system.

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: "Reuben D. Budiardja" <[email-masked]>
Date: Mon, 12 Jul 2004 09:05:44 -0400

On Sunday 11 July 2004 19:57, Mikhael Goikhman wrote:
> > archive. I probably just didn't use the correct keywords for searching.
> > Could someone please help?
> >

I am sorry, I should have known better to include those info (well I wouldn't 
think of `locale`, first time I heard bout that command, all this encoding 
stuff still confuses me)

FVWM-2.5.10. 
In my .fvwmrc (I think I just copy paste this from an example in the manual):
FvwmButtons: Font -*-helvetica-medium-r-*-*-12-*

$ locale 
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Thanks.
RDB