Subject: Re: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)

From: [email-masked]
Date: Sat, 10 Jul 2004 21:37:49 +0800

Hi SCoTT,

In your mail:
>From: Scott Smedley <[email-masked]>
>Reply-To: 
>To: [email-masked]
>Subject: Re: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)
>
>> I'm using fvwm-snap-20040706 with hovericon patch.
> > With the config, when you do a 'fvwm-root -r any.png'
> > all the icons in FvwmButtons will disappear.
> > 
> > I make a small config to test this bug:
> > http://liusd.spymac.net/linux/fvwm/tmp/testBUG.tgz
> 
> I completely rewrote/extended the way HoverIcon works & it appears
> to work fine with your config. I just commited the patch to CVS. Let me know
> how it works for you.
> 
> I also added HoverTitle & HoverColorset options. I think you asked
> for the former feature?
> 
> SCoTT. :)
> --

Now I try the fvwm-snap-20040710, the previous bug is fixed. Great!
Thank you for bringing this great feature into fvwm. I love it.

But the option "Pixmap none" don't work properly, ie it doesn't have
a transparent background as expected.

Here is a small config in case I don't explain clearly.
http://liusd.spymac.net/linux/fvwm/tmp/testBUG2.tgz

Best
Liu

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Sun, 11 Jul 2004 03:33:54 +1000

> a transparent background as expected.

Use:

Colorset $n Transparent
*FvwmButtons: Colorset $n
Style FvwmButtons ParentalRelativity

SCoTT. :)