Subject: Re:FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)

From: [email-masked]
Date: Mon, 05 Jul 2004 20:19:00 +0800

In your mail:
>From: Scott Smedley <[email-masked]>
>Reply-To: 
>To: [email-masked]
>Subject: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)
>
>> Can we have the animated FvwmButtons?
> > For example, the texte on the buttons change the color when mouse pass (like a
link in a web page)?
> 
> I had a go at implementing a "HoverIcon" option for the FvwmButtons module.
> This allows an alternative image to be displayed when the mouse cursor is
> over a button.
> 
> See here:
> 
> http://users.tpg.com.au/users/scottie7/tmp/hoverIcon.html
> 
> As FvwmButtons is used in all kinds of different ways, I need a few people
> to test the patch & find bugs etc.
> 
> Please report any feedback to [email-masked].
> 
> Thanks,
> 
> SCoTT. :)
> --

I've try out this patch.
Pretty stable and efficient.

I've spent quite a lot of time
figure out how to implement a similar
effect using FvwmButtons and FvwmAuto
(http://liusd.spymac.net/linux/fvwm).
If this comes sooner:-)

Best,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Tue, 6 Jul 2004 00:50:18 +1000

Hi Liu,

> Pretty stable and efficient.

Cool! Thanks for the feedback.

> (http://liusd.spymac.net/linux/fvwm).

So you're dynamically changing the icon of FvwmButtons with the
SendToModule command & then creating another dock to display the
enlarged icon - have I understood that correctly?

Out of curiosity, how responsive is this?

SCoTT. :)