Subject: FVWM: Translucency

From: Dalibor Straka <[email-masked]>
Date: Tue, 27 Jul 2004 17:34:58 +0200

Hello,

i've set up a transparent pager and menu acording to FAQ and archive,
but need translucent pager in order to see the text beneath. I also read
about translucent patch. I'm using debian unstable with fvwm 2.5.10,
patching and compiling means to lose all the advantages of debian
packages.

Thank you,
-- Dalibor Straka
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Tue, 27 Jul 2004 16:39:36 +0100

On Tue, 27 Jul 2004 17:34:58 +0200
Dalibor Straka <[email-masked]> wrote:

> but need translucent pager in order to see the text beneath. I also
> read about translucent patch. I'm using debian unstable with fvwm
> 2.5.10, patching and compiling means to lose all the advantages of
> debian packages.

Not necessarily. You can quite easily:

apt-get source fvwm

apply the patchm and run (from within the main debian-fvwm source):

debian/rules binary

install the resultant .deb and rememebr to put it on hold:

echo "fvwm hold" | dpkg --set-selections

-- Thomas Adam

--
"Thomas is the kinda guy who'd happily write his own OS if it came to
it." -- Richard Gellman, via IRC.

---

From: Axel Steiner <[email-masked]>
Date: Tue, 27 Jul 2004 17:49:40 +0200

Hi,

> patching and compiling means to lose all the advantages of debian

I also wanted to patch fvwm 2.5.10 with the translucent patch, but it was not
necessary. Try to set a background with Esetroot (comes with Eterm)
and make a colorset with RootTransparent. I think that is what you want.

Bye,
Axel 

--
$|=1;@a=(a..z,' ','!',"\n");@n=(9,20,19,27,20,15,1,19,20,5,4,28,
29);for($i=10;$i>0;$i--){print$i;sleep(1);for("\b",' ',"\b")
{print$_ x length ($i);}}foreach$e(@n){print$a[$e-1];}print$a[28];

PGP-Fingerprint: 34A0 EF34 5033 14BE B7C3  D857 6FBD 9AE5 7C09 6C6A

---

From: Harshwardhan Nagaonkar <[email-masked]>
Date: Tue, 27 Jul 2004 09:49:53 -0600

> Dalibor Straka <[email-masked]> wrote:
<snip/>
> Not necessarily. You can quite easily:
<snip/>

I was just wondering, is there any reason why that translucency patch 
hasn't been put into the main source? I guess if it breaks other stuff 
that would be bad, but it could just be another option configurable for 
those who wouldn't want translucent pagers.

Apologies if this has already been discussed as being not possible.

Thanks,
-- 
Harshwardhan Nagaonkar
Electrical Engineering Sysop
Brigham Young University - 84602
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Harshwardhan Nagaonkar <[email-masked]>
Date: Tue, 27 Jul 2004 10:10:04 -0600

<snip/>
> and make a colorset with RootTransparent. I think that is what you want.

These are the relevant lines in my .fvwm2rc file. What other changes did 
you have to do to get a translucent pager (you can see windows/text that 
are overlapped by the pager)?

Thanks much,
===========================
CleanupColorsets
Colorset 0 fg white, bg blue, RootTransparent
*FvwmPager: Colorset 0

AddToFunc InitFunction
+ I GoToPage 1 1
+ I exec Esetroot $HOME/downloaded/wapers/hawaii0321280.jpg
===========================

---

From: Axel Steiner <[email-masked]>
Date: Tue, 27 Jul 2004 18:32:00 +0200

Hi,

> are overlapped by the pager)?

my settings for the pager is:

*FvwmPager: LabelsBelow
*FvwmPager: Balloons Pager
*FvwmPager: BalloonYOffset -5
*FvwmPager: MiniIcons
*FvwmPager: Font none
*FvwmPager: UseSkipList

*FvwmPager: Colorset * 6
*FvwmPager: HilightColorset * 7
*FvwmPager: WindowColorsets 8 9
*FvwmPager: BalloonColorset * 10
*FvwmPager: Geometry 200x100+2349+921

Style module-pager NoIcon, NoTitle, NoHandles, WindowListSkip, \
Sticky, NeverFocus, FixedPosition, FixedSize, StaysOnBottom

And the colorsets...

Colorset 6 Foreground white, Background gray, Hilight gray, Shadow gray, RootTransparent, Tint black 40
Colorset 7 Foreground white, Background gray, Hilight gray, Shadow gray, RootTransparent, Tint white 40
Colorset 8 Foreground white, Background gray, Hilight gray, Shadow gray, RootTransparent, Tint gray 40 
...

Bye,
Axel

---

From: Julian Leyh <[email-masked]>
Date: Tue, 27 Jul 2004 19:44:22 +0200

(once again sorry.. should be sent to the list..)

On Tue, 27 Jul 2004 10:10:04 -0600
Harshwardhan Nagaonkar <[email-masked]> wrote:

> These are the relevant lines in my .fvwm2rc file. What other changes
> did you have to do to get a translucent pager (you can see
> windows/text that are overlapped by the pager)?

real transparency (aka translucency) depends on your X server.
if you use XFree86 or X.org, that won't be possible.

The Xserver from freedesktop.org supports real transparency, some other
out there may too.

The translucency patch only works for the menus.. and it's not really
real transparency, only simulated real transparency ;)
you'll notice that the translucent parts won't update if the content of
the underlying window changes.

btw. i asked something similar few days ago..
i solved it using autohide on a FvwmButtons with StaysOnTop, which
swallowed FvwmPager(see the faq, last point).
In fact, i'm using two FvwmPager, one in the autohiding FvwmButtons and
one with StaysOnBottom directly where the unhidden FvwmButtons appears.
This way i see the pager when it is not covered and if it is covered, i
can move the mouse to where it should be and i'll see it.

cu
JRL

-- 
visit my OpenBSD ports page: http://vgai.de/ports
--
If you don't remember something, it never existed...
If you aren't remembered, you never existed...
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Micha Feigin <[email-masked]>
Date: Tue, 27 Jul 2004 22:29:16 +0300

> apply the patchm and run (from within the main debian-fvwm source):

or dpkg-buildpackage -uc -us -rfakeroot
(assuming you have fakeroot, you can also run it as root instead)

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>

---

From: Dalibor Straka <[email-masked]>
Date: Tue, 27 Jul 2004 23:45:37 +0200

> the underlying window changes.

Thank you very much, this saves much my work ;). My idea was clocks and
pager in the right down corner, always on top and translucent.

I will probably move both without trans*ency to the right top corner
which hardly ever contains anything important ;-).
(exactly a bit far from right because of those three window's buttons),

> can move the mouse to where it should be and i'll see it.

Nice people here,
-- Dalibor Straka

---

From: Harshwardhan Nagaonkar <[email-masked]>
Date: Wed, 28 Jul 2004 11:17:28 -0600

<snip/>
<snip/>

Yeah, me too. I'm going to wait for a "proper" implementation of 
translucency from the X-server. I guessed that the translucent parts 
wouldn't update since that's the same kind of hack used in the KDE 
translucent menu feature.

> Nice people here,

You got that right... really friendly and helpful people here.