Subject: RE: FVWM: Changing FVWM's location

From: "Moore, Garron" <[email-masked]>
Date: Fri, 16 Jul 2004 14:17:55 -0700

More simply put, FVWM seems to embed its install location into itself which is making it hard for me to do the following. If I was able to do the following, my requirements would basically be satisfied:

tar xzf fvwm-2.5.10.tar.gz
cd fvwm-2.5.10
./configure --prefix=/opt/fvwm (or whatever options necessary)
make
make install
mv /opt/fvwm /newfolder/othernewfolder/fvwm

And then I would like to be able to run fvwm by doing
/newfolder/othernewfolder/fvwm/bin/fvwm

Is this possible? Is there a way to move the fvwm folder and still have it function?

Thanks again,
Garron Moore

-----Original Message-----
From: Mikhael Goikhman [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 1:45 PM
To: Moore, Garron
Cc: FVWM Users
Subject: Re: FVWM: Changing FVWM's location

On 16 Jul 2004 12:14:56 -0700, Moore, Garron wrote:
> 
> In our setup of FVWM, we need to be able to copy the FVWM installation 
> to other machines where FVWM will be located in different places in 
> the file system. These machines do not have compilers in them and 
> won't be able to build FVWM. It seems that the installation location 
> is inserted in several files at build time. Is it possible to 
> re-locate an FVWM installation or to set up FVWM to use an environment 
> variable like $FVWM_ROOT instead of hard-coded paths?

All reasonable tasks all doable in applications properly using autoconf.

Now, if you explain your problem better (like which version you want to install (stable, from cvs, from tarball), whether installation hosts are of the same architecture as the build host, whether they share certain file systems including your source directory, whether they all should use the same installation prefix and so on), then I may even give you exact ./configure and make options to achieve your specific task.

Also, there are additional fvwm specific solutions for rpm and deb based systems, using "make rpm-dist [params]" and "make deb-dist [params]".

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 16 Jul 2004 22:10:56 +0000

On 16 Jul 2004 14:17:55 -0700, Moore, Garron wrote:
> Is this possible?

The instructions for doing this properly are in another message.

> Is there a way to move the fvwm folder and still have it function?

If the intention is to freely mv it to a location different from the one
configured on the "./configure" step, then the answer is no, this is
unsupported. You will have different things broken, and although it is
possible to fix them one by one, I highly discourage you from doing this.
Please use the proper installation procedure every time you want to
relocate fvwm, you don't really need to disappoint your users by breaking
things. I can think about at least 3 different reasons some modules will
stop to work, ModulePath is just one of them.

It is both faster and easier to repeat the "./configure; make" procedure
than to manually fix all problems the inappropriate "mv" introduces.

Regards,
Mikhael.

---

From: Frederick Potetz <[email-masked]>
Date: Sat, 17 Jul 2004 04:24:45 -0400

>/newfolder/othernewfolder/fvwm/bin/fvwm

Probably a silly question, but can you not just do the move and make a 
symbolic link from the compiled build location?

./configure --prefix=/opt/fvwm && make && make install
mv /opt/fvwm /newfolder/fvwm
ln -s /newfolder/fvwm /opt/fvwm
/opt/fvwm/bin/fvwm

Regards,
Fred.