Subject: Re: FVWM: Switching between desktops

From: Manish <[email-masked]>
Date: Wed, 28 Jul 2004 10:02:19 -0700 (PDT)

I should put this in the .fvwm2rc, right?  I tried
that and then used ExitFvwm->RestartFvwm. and this
didn't do anything.  I'll try to read through the
default fvwm2rc and then the man pages.  I'll give it
a shot after that.

thanks,
manish

--- Dalibor Straka <[email-masked]> wrote:
> On Tue, Jul 27, 2004 at 09:29:44PM -0700, Manish
> wrote:
> > 
> > Hi,
> > 
> > I started using fvwm/cygwin on my windows laptop
> > recently.  It's pretty cool!  
> > 
> > I was wondering if there is anyway to bind keys to
> > specific functions?  I would like to do the
> following:
> > - bind a key to switch from one desktop to the
> next
> Key Left    A   M   Scroll -100 0
> Key Right   A   M   Scroll +100 +0
> Key Up      A   M   Scroll +0   -100
> Key Down    A   M   Scroll +0   +100
> 
> > - bind a key to raise/lower the current window
> Key F10   A    M    Maximize 100 100
> 
> > - not have the console at all and just switch from
> > desktop to desktop by using keys (instead of mouse
> -
> > that's what I use the console for right now; to
> switch
> > between desktops.  I don't care about the clock,
> > etc.).  the console takes up too much of the real
> > estate.
> > 
> > How can I learn more about fvwm customization? any
> > "users guide" ?
> > 
> 
> Best for me was to read FAQ and well commented
> .fvwm2rc ;-)
> Then start reading man page.
> 
> -- Dalibor Straka
> 

__________________________________
Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!
http://promotions.yahoo.com/new_mail
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Manish <[email-masked]>
Date: Wed, 28 Jul 2004 16:27:15 -0700 (PDT)

Got it to work.  Thanks all.  Is there a function to
switch to another window within the same desktop? 
Trying to get alt-tab kind of behaviour in fvwm.

Currently going through FAQ and man pages.  It's huge!

thanks,
- manish

		
Yahoo! Mail - 50x more storage than other providers!

---

From: Manish <[email-masked]>
Date: Wed, 28 Jul 2004 16:37:11 -0700 (PDT)

I'm using it on cygwin/win2k.  I put the following in
my .fvwm2rc following the FAQ but it shows me all
windows (in all desktops; I have 2x2 virtual desktops)

Key F8  A N WindowList Root c c CurrentDesk NoGeometry
Key F12 A N WindowList Root c c NoDeskSort

thanks,
manish

--- Manish <[email-masked]> wrote:
> > > > I was wondering if there is anyway to bind
> keys
> > to

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 29 Jul 2004 01:31:30 +0000

> Key F8  A N WindowList Root c c CurrentDesk NoGeometry

This works. Do you mean the current page rather than the current desk?

  WindowList (CurrentPage) Root c c NoGeometry, NoHotkeys

Still, it is better to place a comma between options, i.e. after
CurrentDesk in your example, and possibly use "A"ny modifier instead of
"N"one, so that the binding works with NumLock pressed too.

P.S. Please don't top-post. Please specify fvwm version in questions.

Regards,
Mikhael.

---

From: Julian Leyh <[email-masked]>
Date: Thu, 29 Jul 2004 15:33:23 +0200

Mikhael Goikhman <[email-masked]> wrote:

> of"N"one, so that the binding works with NumLock pressed too.

or ignore the numlock modifier via IgnoreModifiers...

cu
JRL

-- 
visit my OpenBSD ports page: http://vgai.de/ports
--
If you don't remember something, it never existed...
If you aren't remembered, you never existed...
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].