Subject: RE: FVWM: Changing FVWM's location

From: "Moore, Garron" <[email-masked]>
Date: Fri, 16 Jul 2004 13:55:44 -0700

We are using Solaris. We are using version 2.5.10. All of the machines run the same version of Solaris and use SPARC processors. Some machines are being deployed to and do not have compilers installed. Ideally, fvwm will be installed into its own folder. This folder would then be copied onto a different machine, in a completely different location. 

Part of what I want to achieve is to have fvwm installed at some location, say /foo/bar/fvwm/ in a way that I can move that fvwm folder somewhere else, say into /other/directory/fvwm/ and still have a working installation, but just in a different location.

Our setup is difficult to explain, but I'm giving it my best shot. In our system, we use environment variables to find out where software is located.  For example, FVWM could be moved to any location on the disk, but as long as $FVWM_ROOT is set to that location, we want to be able to run $FVWM_ROOT/bin/fvwm.

Thanks for your help.

Garron Moore

-----Original Message-----
From: Mikhael Goikhman [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 1:45 PM
To: Moore, Garron
Cc: FVWM Users
Subject: Re: FVWM: Changing FVWM's location

On 16 Jul 2004 12:14:56 -0700, Moore, Garron wrote:
> 
> In our setup of FVWM, we need to be able to copy the FVWM installation 
> to other machines where FVWM will be located in different places in 
> the file system. These machines do not have compilers in them and 
> won't be able to build FVWM. It seems that the installation location 
> is inserted in several files at build time. Is it possible to 
> re-locate an FVWM installation or to set up FVWM to use an environment 
> variable like $FVWM_ROOT instead of hard-coded paths?

All reasonable tasks all doable in applications properly using autoconf.

Now, if you explain your problem better (like which version you want to install (stable, from cvs, from tarball), whether installation hosts are of the same architecture as the build host, whether they share certain file systems including your source directory, whether they all should use the same installation prefix and so on), then I may even give you exact ./configure and make options to achieve your specific task.

Also, there are additional fvwm specific solutions for rpm and deb based systems, using "make rpm-dist [params]" and "make deb-dist [params]".

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 16 Jul 2004 21:19:00 +0000

On 16 Jul 2004 13:55:44 -0700, Moore, Garron wrote:
> 
> We are using Solaris. We are using version 2.5.10. All of the machines
> run the same version of Solaris and use SPARC processors. Some machines
> are being deployed to and do not have compilers installed. Ideally,
> fvwm will be installed into its own folder. This folder would then be
> copied onto a different machine, in a completely different location.
> 
> Part of what I want to achieve is to have fvwm installed at some
> location, say /foo/bar/fvwm/ in a way that I can move that fvwm folder
> somewhere else, say into /other/directory/fvwm/ and still have a
> working installation, but just in a different location.
> 
> Our setup is difficult to explain, but I'm giving it my best shot. In
> our system, we use environment variables to find out where software is
> located.  For example, FVWM could be moved to any location on the disk,
> but as long as $FVWM_ROOT is set to that location, we want to be able
> to run $FVWM_ROOT/bin/fvwm.

This is an unreasonable requirements. If you want to relocate software
after it is installed (do you ever do this? or do you do this often?),
you should repeat the build procedure with a different install prefix.

The building is very standard. On the compiler-capable host execute:

  ./configure --prefix=/the/install/prefix/for/fvwm    [other params]
  make

Then you have 2 choices. If the source directory is shared by all
hosts (suggested, you may even share it read-only), then just login to
all mashines and execute the remaining command in the source directory:

  make install

No compilation or any similar activity is done on "make install".

An alternative way (less convenient if you ask me) is to continue with
"make install" on the build host, just specify the temporary directory:

  make install prefix=/tmp/temp-fvwm-prefix

Then transfer /tmp/temp-fvwm-prefix dir to /the/install/prefix/for/fvwm
on all target machines using ftp or whatever you like.

Regards,
Mikhael.