Subject: FVWM: tray icon placement

From: Wojtek Karlowski <[email-masked]>
Date: Sat, 3 Jul 2004 22:40:26 +0200

Hi,

I have a problem forcing a so-called tray icon generated by a program to appear at desired coordinates
on a screen. 

The case involves sylpheed mail client (run on fvwm ver. 2.5.10) and its plugin, which displays a tray
icon informing about mail box status. Because, I don't have a tray, the icon pop ups on the left upper
corner of the screen. My question is if there is any method/function in the fvwm, which can force this
icon to appear at specified coordinates?  Sorry if this has been asked before, but I couldn't find an
answer either in google or in the fvwm faq.

I would appreciate any help. Thanks.

Wojtek
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Mon, 5 Jul 2004 11:21:24 +0100

On Sat, Jul 03, 2004 at 10:40:26PM +0200, Wojtek Karlowski wrote:
> My question is if there is any method/function in the fvwm, which can 
> force this icon to appear at specified coordinates?  Sorry if this has 
> been asked before, but I couldn't find an answer either in google or 
> in the fvwm faq.
> 

take a look at #3.18, if you mean you want it to obey your placement
policy rather than always appear in the top left, maybe you need to set
NoUSPosition/NoPPosition Styles.

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jul 2004 14:07:05 +0200

> NoUSPosition/NoPPosition Styles.

Or maybe NoIconPosition.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Martin Niebergall <[email-masked]>
Date: Mon, 5 Jul 2004 16:25:51 +0200

On Sat, 3 Jul 2004 22:40:26 +0200
Wojtek Karlowski <[email-masked]> wrote:
> force this icon to appear at specified coordinates?

I think the best way would be to create a small system tray for it.  I use a peksystray, swallowed in an FvwmButtons module: 
http://freshmeat.net/projects/peksystray

---

From: "Wojciech M. Karlowski" <[email-masked]>
Date: Sat, 10 Jul 2004 14:31:06 +0200

On Mon, Jul 05, 2004 at 04:25:51PM +0200, Martin Niebergall wrote:
> > My question is if there is any method/function in the fvwm, which can force this icon to appear at
> > specified coordinates?
> 
> I think the best way would be to create a small system tray for it.  I use a peksystray, swallowed
> in an FvwmButtons module: http://freshmeat.net/projects/peksystray
	       
Thanks for all of the hints. Finally, I have succeeded using one of the methods described in the faq
#3.18.

On the other hand, after some struggle, I have compiled the peksystray and got it running. However,
the program doesn't function properly in my hands: after the icon appears in the peksystray window it
doesn't go away after quiting the sylpheed. Strange, but probably not fvwm-related...

Wojtek