Subject: Re: FVWM: Alt+Right mouse resize

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Jul 2004 16:33:41 +0200

On Wed, Jun 30, 2004 at 11:24:12PM -0400, David Wu wrote:
> Hi all, I have been looking to moving from fluxbox to fvwm. I have
> search the mailinglist for emulating the alt+mouse3 resizing that other
> window managers implement.
> 
> Most workaround emulate quite well (i.e WarpToWindow, resizing or
> involving jumping to closest edge + resizing) but i still feel its too
> much of a (ugly?) hack
> 
> I was wondering if anyone was working on implementing it as a built-in
> feature. If not, i would not might digging into the source code to come
> up with a patch myself.
> 
> If it is the latter case, can anyone give me a quick start on how FVWM
> is implemented? does it use Xlib directly? or is there a intermediate
> toolkit/widget class
> 
> Thanks so much for this great piece of software. 

I have just committed a patch that provides this.  With latest CVS
or tomorrow's snapshot, try

  AddToFunc ResizeSE I Resize Direction SE
  Mouse 3 TSIFW M ResizeSE

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Gert Brinkmann <[email-masked]>
Date: Thu, 01 Jul 2004 18:46:07 +0200

>   AddToFunc ResizeSE I Resize Direction SE

Hey, cool. This is what I am waiting for. :)

Does "Direction SE" mean that the window is resized in the right bottom 
corner? Is there a way to use the nearest corner or edge to the current 
mouse position? e.g. by "Direction nearest" or "Direction auto"? This 
would be even greater!

Thank you,

Gert
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Wu <[email-masked]>
Date: Thu, 01 Jul 2004 16:15:45 -0400

Hi again :) I've tried out the new resizing with 
  AddToFunc ResizeSE I Resize Direction SE
  Mouse 3 TSIFW M ResizeSE
This works wonder compare to the previous workaround. ^_^
However when you resize quickly (i.e burst of alt + mouse3 + move)
you will remain in resizing mode even after you release the mouse
buttom. Is there something i can add the the function that will prevent
this? 

Thanks so much 

David