Subject: RE: FVWM: Changing FVWM's location

From: "Moore, Garron" <[email-masked]>
Date: Fri, 16 Jul 2004 15:26:40 -0700

I don't just want to move the location for the sake of moving it. The disk layout of end system that will be using FVWM is unknown to me. I have no knowledge of their filesystem layout and directory structure. I need to prepare FVWM so that wherever they want to place it on their disk, it will work as long as they have the environment variable $FVWM_ROOT pointed at the place they copied it to. They will not have a compiler on their system to rebuild based on their location choice.

-----Original Message-----
From: Mikhael Goikhman [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 3:11 PM
To: Moore, Garron
Cc: FVWM Users
Subject: Re: FVWM: Changing FVWM's location

On 16 Jul 2004 14:17:55 -0700, Moore, Garron wrote:
> 
> And then I would like to be able to run fvwm by doing 
> /newfolder/othernewfolder/fvwm/bin/fvwm
> Is this possible?

The instructions for doing this properly are in another message.

> Is there a way to move the fvwm folder and still have it function?

If the intention is to freely mv it to a location different from the one configured on the "./configure" step, then the answer is no, this is unsupported. You will have different things broken, and although it is possible to fix them one by one, I highly discourage you from doing this. Please use the proper installation procedure every time you want to relocate fvwm, you don't really need to disappoint your users by breaking things. I can think about at least 3 different reasons some modules will stop to work, ModulePath is just one of them.

It is both faster and easier to repeat the "./configure; make" procedure than to manually fix all problems the inappropriate "mv" introduces.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 16 Jul 2004 22:40:13 +0000

On 16 Jul 2004 15:26:40 -0700, Moore, Garron wrote:
> 
> I don't just want to move the location for the sake of moving it. The
> disk layout of end system that will be using FVWM is unknown to me. I
> have no knowledge of their filesystem layout and directory structure. I
> need to prepare FVWM so that wherever they want to place it on their
> disk, it will work as long as they have the environment variable
> $FVWM_ROOT pointed at the place they copied it to. They will not have a
> compiler on their system to rebuild based on their location choice.

You may freely assume that /usr/local/fvwm (or /opt/fvwm) is the location
allocated for FVWM on any unix system, just use it. Require to setup one
symlink at this location to the actual prefix.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Jul 2004 19:21:19 -0400

"Moore, Garron" <[email-masked]> writes:
> I don't just want to move the location for the sake of moving it. The =
> disk layout of end system that will be using FVWM is unknown to me. I =
> have no knowledge of their filesystem layout and directory structure. I =
> need to prepare FVWM so that wherever they want to place it on their =
> disk, it will work as long as they have the environment variable =
> $FVWM_ROOT pointed at the place they copied it to. They will not have a =

There is no such variable in fvwm.

If you do:

 configure --prefix=/something/special
 make
 make install
 grep -r /something/special /something/special

(You need to use a grep that supports -r or use find.)

That will show you all the files that currently have hard coded paths.
(It should always work, but I'm not guaranteeing that.)

If you use a really long path, you might even be able to write an
install script that fixes up the binary files.

You might need to adjust all this for new releases of fvwm.

I don't understand your requirements, I guess you don't have
the cooperation of the admins on the target systems.

Have you thought about installing into /var/tmp?

-- 
Dan Espen                           E-mail: [email-masked]