Subject: Re: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)

From: [email-masked]
Date: Tue, 06 Jul 2004 23:03:47 +0800

Hi SCoTT,

In your mail:
>From: Scott Smedley <[email-masked]>
>Reply-To: [email-masked]
>Subject: Re: FVWM: HoverIcon for FvwmButtons (Was: animated FvwmButtons)
>
>Hi Liu,
>  
> Ditto. FvwmButtons is quite complex. Consequently, I'm not comfortable
> commiting this patch until it's had wider testing. Maybe you can convince
> some fellow FVWMers to try it out? :)
> 
I'll try
 
> > Now I found a bug.
> ...
> > When you init fvwm, FvwmButtons won't display the icons.
> > A Restart will turn on the icons.
> 
> I cannot reproduce this problem. What version of FVWM are you using?
> The config you gave me (with altered Icon images of course) works fine.
> 
> Can you give me any further info?
>

I'm using fvwm-snap-20040706 with hovericon patch.
With the config, when you do a 'fvwm-root -r any.png'
all the icons in FvwmButtons will disappear.

I make a small config to test this bug:
http://liusd.spymac.net/linux/fvwm/tmp/testBUG.tgz
 
> SCoTT. :)
> --

Best,
Liu

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Sat, 10 Jul 2004 19:40:43 +1000

> http://liusd.spymac.net/linux/fvwm/tmp/testBUG.tgz

I completely rewrote/extended the way HoverIcon works & it appears
to work fine with your config. I just commited the patch to CVS. Let me know
how it works for you.

I also added HoverTitle & HoverColorset options. I think you asked
for the former feature?

SCoTT. :)