Subject: FVWM: Suggestion for new Feature (gettext)

From: Michelle Konzack <[email-masked]>
Date: Tue, 20 Jul 2004 14:39:36 +0200

Hello, 

Because I am using a multiuser and multilanguage environement 
in a CyberCenter/InternetCafe I have a wish for a new feature.

Style * TextDomain=...
Style * TextDomainDir=...

I have this two options in many of my BASH-Scripts and they are 
translated to several languages including farsi and arabic...

It is very nice...

I use private mo files im ma $HOME like:

	~/bin
	~/etc
	~/locale/de
		 fa
		 ar
	 
If I have this feature in fvwm, I can make independant locale for 
menus, window titles, icon text, ...

What Do you think about ?

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: Spaceborne Calin <[email-masked]>
Date: Tue, 20 Jul 2004 15:16:36 +0200 (CEST)

--- Michelle Konzack <[email-masked]> a écrit : > Hello, 
> What Do you think about ?

You can set the environment variables LC_ALL and LANG and make 
fvwm at startup source the file coresponding with the environement
Ex. 

> Michelle

Calin 

		
Créez gratuitement votre Yahoo! Mail avec 100 Mo de stockage !
Créez votre Yahoo! Mail sur http://fr.benefits.yahoo.com/

Yahoo! Messenger: dialoguez instantanément avec vos amis. Téléchargez GRATUITEMENT sur http://fr.messenger.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michelle Konzack <[email-masked]>
Date: Tue, 20 Jul 2004 17:29:31 +0200

>fvwm at startup source the file coresponding with the environement

This is not what I want...
And not what it mean...

The curent problem is, that Menus can not be translated...
Whit this feature you have the maximum on flexibility...

Greetings
Michelle

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Jul 2004 15:52:40 +0200

> Style * TextDomainDir=...

Um, what should these styles do exactly?

> menus, window titles, icon text, ...

Do you mean to read different files depending on the user
language?  If so, you can do it with

  Read menus/$LANG

With my next commit, you can even provide a default file:

  Read menus/$LANG
  TestRc (Error) Read menus/default

Is that good enough?

> What Do you think about ?

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Michelle Konzack <[email-masked]>
Date: Tue, 20 Jul 2004 18:08:54 +0200

>Um, what should these styles do exactly?

You can have different private *.mo for menus.
e.g.

MenuStyle TaskBarStartMenu TextDomain=michellesmenu
MenuStyle TaskBarStartMenu TextDomainDir=$HOME/locale

>  TestRc (Error) Read menus/default

For this I neet to rewrite ALL Menu-files... 
Even If I do not like to translate all.

But this is not enough, because I must translate al configs for 
FvwmTaskBar, FvwmButtons ... 

I have arround 40 files to translate...
Which mean, I have for 8 Languages 320 files which must keep 
consistent... Better is to have 40 config-files and 7 locale.

Greetings
Michelle

---

From: Florian Diesch <[email-masked]>
Date: Tue, 20 Jul 2004 23:40:09 +0200

> consistent... Better is to have 40 config-files and 7 locale.

Sounds like a job for FvwmM4