Subject: RE: FVWM: UseBorderStyle

From: "Friedman, Joseph" <[email-masked]>
Date: Tue, 27 Jul 2004 11:48:04 -0400

Thanks for your reply.  It appears that, at least under fvwm 2.4.18,
"Colorset" is not a valid TitleStyle.  You can do ?Gradient, but this
applies only for the background color.  I tried the following:

  TitleStyle LeftJustified
  TitleStyle Inactive HGradient 2 ForestGreen ForestGreen
  TitleStyle ActiveUp HGradient 2 firebrick firebrick
  TitleStyle ActiveDown HGradient 2 firebrick firebrick
  BorderStyle Inactive HGradient 2 grey60 grey60
  BorderStyle Active HGradient 2 grey70 grey70

This has a number of problems besides not having the yellow (foreground)
title text in the active window: (1) Fvwm does not seem to obey the
Inactive BorderStyle: it's using the default dark grey color; (2) the
firebrick active title is only on the face of the title, not the beveled
sides.

Did you try your suggestion and it worked for you?

Thanks again,
-yossi

-----Original Message-----
From: Dominik Vogt [mailto:[email-masked]] 
Sent: Tuesday, July 27, 2004 4:49 AM
To: Friedman, Joseph; fvwm
Subject: Re: FVWM: UseBorderStyle

The problem is that the old ButtonStyle syntax and the new Style syntax
can not be mixed.  If you need the UseBorderStyle flag, you have to use
the old syntax:

  *FvwmTheme: Colorset 10 Foreground white, Background ForestGreen
  *FvwmTheme: Colorset 11 Foreground yellow, Background firebrick
  *FvwmTheme: Colorset 12 Foreground black, Background grey60
  *FvwmTheme: Colorset 13 Foreground black, Background grey70
  ModuleSynchronous Timeout 5 FvwmTheme
  Style * Button 1, Button 2, Button 4, Button 6
  TitleStyle inactive Colorset 10
  TitleStyle active Colorset 11
  BorderStyle inactive Colorset 12
  BorderStyle active Colorset 13
  ButtonStyle All -- Clear UseBorderStyle
  Mouse 0 2 A Close
  Mouse 0 4 A Maximize 100 100
  Mouse 0 6 A Iconify

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Jul 2004 18:58:04 +0200

(Please reply below the quoted sections on this mailing list).

> Did you try your suggestion and it worked for you?

Yes,, I tried it and it works, but you need 2.5.x for the Colorset
option in the ...Style commands.

Ciao

Dominik ^_^  ^_^