Subject: Re: FVWM: Switching between jpegs

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 28 Jul 2004 17:19:15 -0700 (PDT)

< > Is there a fast way to switch between wallpaper jpegs (such as when i'm
< > switching desktops)?
< >
< > xv -quit -root <>.jpg is soooo sloooow.
< >
< > version 5.10 on solaris 5.8
 
< xli is faster than xv.
< 
< I don't know what kind of Sun hardware you have but I know
< a U5 won't be fast enough.
< 
< Using colorsets or solid colors might help.
< 
< I'm happy with the same image on all desks.  To stave off boredom,
< I use cron to change the background every hour.

Running on Ultra10 w/ 8 bit video hardware.

xli (1.16 png) is faster than xv....but still takes 2 seconds to switch,
slow probably due to decompressing jpg.

I tried having one jpg be root and the other be a fullscreen decorless
window, but then i cant reach root menus. I dont suppose X can hold two
root bitmaps and switch between them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Thu, 29 Jul 2004 09:21:43 +0100

> root bitmaps and switch between them.

Did you know fvwm will cache them in Colorsets?

You can read about it here http://www.fvwm.org/documentation/faq/#6.6

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].