Subject: FVWM: Keybindings for FvwmPager

From: Florian Diesch <[email-masked]>
Date: Tue, 20 Jul 2004 23:53:13 +0200

Hi!

I'd like to use the keyboard to move windows in FvwmPager.
I tried this:

DestroyFunc Move-Win-To-Page
AddToFunc Move-Win-To-Page
 + I Module FvwmPager -transient
 + I MoveToPage $0 $1
 + I GotoPage $0 $1

Key Right       A       3      Move-Win-To-Page +1p +0p
Key Left        A       3      Move-Win-To-Page -1p +0p
Key Up          A       3      Move-Win-To-Page +0p -1p
Key Down        A       3      Move-Win-To-Page +0p +1p

It close to what I want, but I have to release mod3 for every step.
Any ideas?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 22 Jul 2004 01:23:42 +0000

> It close to what I want, but I have to release mod3 for every step.

Why exactly do you need a transient and not a permanent FvwmPager?

Anyway, try this config in 2.5.x, should work like you want:

  Style FvwmPager Sticky
  Style * SloppyFocus

  DestroyFunc StartSpecialFvwmPager
  AddToFunc   StartSpecialFvwmPager
  + I KillModule FvwmPager FvwmPager-Special
  + I Module FvwmPager FvwmPager-Special
  + I Wait FvwmPager-Special
  + I Next (FvwmPager-Special, CirculateHit) AnimatedMove -5p -5p

  DestroyFunc Move-Win-To-Page
  AddToFunc   Move-Win-To-Page
  + I Deschedule 1234
  + I Schedule 8000 1234 KillModule FvwmPager FvwmPager-Special
  + I Next (FvwmPager-Special, CirculateHit) Nop
  + I TestRc (!Match) StartSpecialFvwmPager
  + I Raise
  + I MoveToPage $0 $1
  + I GotoPage $0 $1

Regards,
Mikhael.

---

From: Florian Diesch <[email-masked]>
Date: Sat, 24 Jul 2004 01:21:06 +0200

> Why exactly do you need a transient and not a permanent FvwmPager?

I don't want to see it if I don't need it.

>   + I Next (FvwmPager-Special, CirculateHit) AnimatedMove -5p -5p

Without this line it works perfectly. Thanks! :-)