Subject: FVWM: 2 questions?

From: [email-masked]
Date: Fri, 25 Jun 2004 20:46:31 +0800

Hi everyone,

I got 2 questions:

(1) Does FvwmAuto support alias?
Here is an example in FAQ 7.17
  AddToFunc StartFunction
  + I Module FvwmAuto FvwmAutohide -menter enter_handler
Is FvwmAutohide an alias of FvwmAuto?

(2)How to get the number of windows opened in current page?

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 25 Jun 2004 16:11:21 +0000

> I got 2 questions:

Please try to give meaningful Subject lines, this one is not.
One question per thread is good.

> Is FvwmAutohide an alias of FvwmAuto?

See another thread. Please wait for 2 weeks before reposting questions.

> (2)How to get the number of windows opened in current page?

There are several hacky ways, one of them is:

  DestroyFunc ShowNumberOfWindowsOnTheCurrentPage
  AddToFunc   ShowNumberOfWindowsOnTheCurrentPage
  + I SetEnv NUMBER_OF_WINDOWS 0
  + I All (CurrentPage) PipeRead 'echo SetEnv NUMBER_OF_WINDOWS \
        $$$$(($$$$NUMBER_OF_WINDOWS + 1))'
  + I Exec xmessage 'There are $[NUMBER_OF_WINDOWS] windows'

But I don't know what is your final task, maybe it may be solved easier
without calculating the exact number of windows.

Regards,
Mikhael.