Subject: FVWM: FVWM in GNOME (workspaces)

From: Johan Svedberg <[email-masked]>
Date: Tue, 22 Jun 2004 15:47:00 +0200

Hi!

I've been playing around with having FVWM (2.5.10) as my windowmanager
in GNOME (2.6). I followed the instructions in the FAQ (2.8), so I am
using gnome-session. Anyway, things seem to be working well, except for
one thing, my workspaces. I've always been using

    DeskTopSize 6x1

so I want the same in GNOME. So I tried 

    DeskTopSize 1x1
    EWMHNumberOfDesktops 6 0

but that seem to mess upp the GNOME workspaceswitcher. Any ideas on how
I to get this right?

Regards,

-- 
Johan Svedberg, [email-masked], http://johan.svedberg.pp.se/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 22 Jun 2004 17:06:09 +0200

> but that seem to mess upp the GNOME workspaceswitcher. Any ideas on how

What about not using EWMHNumberOfDesktops and setting the
number of desktops via the  GNOME workspaceswitcher (right button
click over the workspaceswitcher ..etc)

Regards, Olivier

---

From: Johan Svedberg <[email-masked]>
Date: Wed, 23 Jun 2004 00:13:52 +0200

* Jun 22 17:43 Olivier Chapuis <[email-masked]>:
> > I've been playing around with having FVWM (2.5.10) as my
> > windowmanager in GNOME (2.6). I followed the instructions in the FAQ
> > (2.8), so I am using gnome-session. Anyway, things seem to be
> > working well, except for one thing, my workspaces. I've always been
> > using
> >
> >     DeskTopSize 6x1
> >
> >     DeskTopSize 1x1 EWMHNumberOfDesktops 6 0
> >
> > but that seem to mess upp the GNOME workspaceswitcher. Any ideas on
> > how I to get this right?
> >
>
> What about not using EWMHNumberOfDesktops and setting the number of
> desktops via the  GNOME workspaceswitcher (right button click over the
> workspaceswitcher ..etc)

I tried this without any luck. The problem seem to be that GotoDesk is
very buggy, or probably the GNOME workspaceswitcher (moving to wrong
desks).

---

From: Johan Svedberg <[email-masked]>
Date: Wed, 23 Jun 2004 13:51:05 +0200

* Jun 23 00:17 Johan Svedberg <[email-masked]>:
> > > windowmanager in GNOME (2.6). I followed the instructions in the
> > > FAQ (2.8), so I am using gnome-session. Anyway, things seem to be
> > > working well, except for one thing, my workspaces. I've always
> > > been using
> > >
> > >     DeskTopSize 6x1
> > >
> > > but that seem to mess upp the GNOME workspaceswitcher. Any ideas
> > > on how I to get this right?
> > >
> >
> > desktops via the  GNOME workspaceswitcher (right button click over
> > the workspaceswitcher ..etc)
>

Could it be that FVWM starts counting Desks at 0 while GNOME starts at
1? Not sure about this though.

---

From: Johan Svedberg <[email-masked]>
Date: Wed, 23 Jun 2004 20:05:38 +0200

* Jun 23 13:55 Johan Svedberg <[email-masked]>:
> > > > FAQ (2.8), so I am using gnome-session. Anyway, things seem to
> > > > be working well, except for one thing, my workspaces. I've
> > > > always been using
> > > >
> > > >     DeskTopSize 6x1
> > > >
> > > What about not using EWMHNumberOfDesktops and setting the number
> > > of desktops via the  GNOME workspaceswitcher (right button click
> > > over the workspaceswitcher ..etc)
> >
> > I tried this without any luck. The problem seem to be that GotoDesk
> > is very buggy, or probably the GNOME workspaceswitcher (moving to
> > wrong desks).
>

Forget this. I must have been on drugs while using EWMHNumberOfDesktops
and GotoDesk.