Subject: FVWM: select/copy/paste issue on FC2

From: Bob Marcan <[email-masked]>
Date: Wed, 23 Jun 2004 17:41:20 +0200

Environment:
Fedora Core2
Linux encijan.interstudio.homeunix.net 2.6.6-1.435
xorg-x11-6.7.0-2
tcl-8.4.5-7
tk-8.4.5-8
fvwm-2.5.10-1
FileRunner-2.5.1-6

Select entry from FileRunner(tcl/tk application) window

copy to xterm, aterm, xemacs:

/var/tmp/01/0.0

Normal, as in RH9 and other Unix machines.

copy to:
Filerunner internal viewer, mozilla, gedit, jpilot:

0.0                             0 040623 08:20:48 rw-r--r-- bob/wheel

What's going on?
Is this X11 or GTK problem?
How to fix this?

Best regards, Bob

-- 
Bob Marcan, Consultant                mailto:[email-masked]
S&T Hermes Plus d.d.                  tel:           +386 (1) 5895-300
Slandrova ul. 2                       fax:           +386 (1) 5895-202
1231 Ljubljana - Crnuce, Slovenia     url:   http://www.hermes-plus.si

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Jun 2004 19:49:37 +0000

> Is this X11 or GTK problem?

One thing for sure, this has nothing to do with FVWM.

There are several (at least two common) mechanisms to store some string
in the clipboard/buffer. I have no FileRunner, but if I understand this
correctly, FileRunner uses two different mechanisms at the same time and
stores different strings. Different applications apply one or another
mechanism on the middle mouse button and you get what you get.

> How to fix this?

Please ask on the FileRunner mailing list.

Regards,
Mikhael.