Subject: FVWM: 3 config questions about Icons(iconified windows)

From: [email-masked]
Date: Sun, 13 Jun 2004 03:29:33 +0800

Hi all,

<1> How to place Icons side by side without GAP in between?

I use 'Style * IconBox 130 12 800 250, IconFill left top' and 
Thumbnail function from the FAQ to iconify windows. Usually,
the iconified windows are placed this way:

+----------+ +----------+
|          | |          |
|    1     | |    2     |
|          | |          |
+----------+ +----------+  ... ...
+----------+ +----------+
| <title>  | | <title>  |
+----------+ +----------+
            ^
            |-------------- Gap

I want them to be placed this way:

+----------+----------+
|          |          |
|    1     |    2     |
|          |          |
+----------+----------+  ... ...
+----------+----------+
| <title>  | <title>  |
+----------+----------+
           ^
           |--------------- No gap

Any ideas?

<2> How to prevent IconTitle from auto-expanding?

Every time I focus a iconified window, it's title
expands to the length of the title text. This is 
sort of annoying for me because the title text is
too long most of the time.

Any ideas how to cut the title text to fit Icon width,
or disable IconTitle auto-expansion?

<3> StippledTitle of uniconified windows, but not iconified windows.

I use:
  Style * Icon, StickyAcrossPagesIcon

And the iconified windows get stippled titles, which are not looking good.
How can I disable ionified windows' stippled title, but keep stippled title
for sticky uniconified windows?

Thank you VERY MUCH!

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Sat, 12 Jun 2004 20:52:51 +0100

> <1> How to place Icons side by side without GAP in between?
<snip>
> Any ideas?

I think you're looking for the IconGrid setting, although I just had a go
and 1x1 pixels is the minimum spacing, so you can't disable it
completely..but it's pretty close :)

> or disable IconTitle auto-expansion?

I don't think that's possible unfortunately, but one way round it would be
to use IndexedIconName, which would make IconTitle's much shorter. 

> <3> StippledTitle of uniconified windows, but not iconified windows.

I don't think that's possible sorry.

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------