Subject: FVWM: How often is an edge command executed

From: Piotr Zielinski <[email-masked]>
Date: Sat, 05 Jun 2004 14:07:03 +0100

Hi,

In my .fvwm2rc, I have a function bound to the edges of the screen
with EdgeCommand (see below for the details).  The problem is that
when the mouse pointer stays on the edge the function is being called
again and again, which prevents fvwm from doing any useful work until
the mouse pointer is moved away from the edge (for example the
scheduled commands do not work).  Can anybody tell me when exactly
the function bound to the edge is called, how can I control the
frequency of it being called?  The only solution I can think of is
removing the edge bindings for a second or so every time the edge
function is called.

The manpage says the following about EdgeCommand

"Function is executed when the mouse pointer enters the invisible pan
frames that surround the visible screen."

but my experience shows that Function can be callled even if the mouse
pointer stays on the edge (and does not reenter the pan frame).

While still on this topic, what is the easier way of testing whether
the mouse pointer is currently over one of the pan frames?

Thanks,

Piotr

EdgeCommand North ShowPager -80 20
EdgeCommand West ShowPager 20 -80
EdgeCommand East ShowPager -180 -80

DestroyFunc Hide
AddToFunc Hide
+ I         Move -10000p -10000p

DestroyFunc HidePager
AddToFunc HidePager
+ I All (FvwmPager) Hide
+ I All (FvwmPager) Layer 0 2

DestroyFunc ShowPager
AddToFunc ShowPager
+ I All (FvwmPager, Layer 2) Move m$0p m$1p
+ I All (FvwmPager, Layer 2) Layer 0 6
+ I Deschedule 21
+ I Schedule 500 21 PointerWindow (!FvwmPager) HidePager

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Sat, 5 Jun 2004 22:42:49 +0200

Hi there,

On 05 Jun 2004 at 14:07:03 +0100, Piotr Zielinski wrote:

> In my .fvwm2rc, I have a function bound to the edges of
> the screen with EdgeCommand (see below for the details). 
> The problem is that when the mouse pointer stays on the
> edge the function is being called again and again, which
> prevents fvwm from doing any useful work until the mouse
> pointer is moved away from the edge (for example the
> scheduled commands do not work).  Can anybody tell me
> when exactly the function bound to the edge is called,
> how can I control the frequency of it being called?  The
> only solution I can think of is removing the edge
> bindings for a second or so every time the edge function
> is called.

Actually the function is (or better should be)
executed/called when the pan frame gets an enter event. For
some reason this event is produced several times if a
complex function is bound to an edge. For example:

   EdgeCommand N Echo EdgeCommandNorth

works as expected while

   AddToFunc EchoFunc I Echo EdgeCommandNorthFunc
   EdgeCommand N EchoFunc

shows the behaviour you describe. This is actually a bug. I
hope we get this fixed soon.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive your mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Jun 2004 15:05:49 +0200

On Sat, Jun 05, 2004 at 02:07:03PM +0100, Piotr Zielinski wrote:
> scheduled commands do not work).

This is already fixed in the latest CVS snapshot.

> Can anybody tell me when exactly

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]