Subject: FVWM: FvwmTabs doesn't open any tabs window

From: Micha Feigin <[email-masked]>
Date: Mon, 7 Jun 2004 05:47:03 +0300

I tried installing the new FvwmTabs (which required installing Tk::PNG
for the sources since debian doesn't seem to have that package).

When I try to start the FvwmTabs module it seems to start ok (got rid
of the startup error messages and ps shows that it is running). However
when pressing Alt-t or trying to open the tabs window using the fvwm
console nothing happens.

How can I find out what the problem is?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Mon, 7 Jun 2004 13:08:13 +1000

: When I try to start the FvwmTabs module it seems to start ok (got rid
: of the startup error messages and ps shows that it is running). However
: when pressing Alt-t or trying to open the tabs window using the fvwm
: console nothing happens.
: 
: How can I find out what the problem is?

Do you override the Alt-t key binding in your .fvwm2rc?

Try executing this line from FvwmConsole:

SendToModule FvwmTabs createNewTabber

Does FvwmTabs output any error messages?

If all else fails, change the debug line to:

Debug => 2

in the FvwmTabs file & restart.

What output do you get now?

SCoTT. :)

---

From: Micha Feigin <[email-masked]>
Date: Mon, 7 Jun 2004 17:45:35 +0300

> Do you override the Alt-t key binding in your .fvwm2rc?

No

> SendToModule FvwmTabs createNewTabber

With the converted rpm for Tk::PNG version 2.003 it gives a message
that it can't find Tk::PNG with a self compiled version (2.005) it just
crashes, no messages.

> Does FvwmTabs output any error messages?

No

> What output do you get now?

On startup the following output is given, on crash no output:

Debug level is: 2
sent [SET_MASK 541851648]
sent [Send_ConfigInfo *FvwmTabs]
got M_CONFIG_INFO [DesktopSize 4 1]
got M_CONFIG_INFO [ImagePath /usr/share/icons:/usr/share/pixmaps:/usr/include/X11/pixmaps:/usr/share/pixmaps/other:/usr/include/X11/bitmaps:/usr/X11R6/include/bitmaps:/usr/share/pixmaps/mgt]
got M_CONFIG_INFO [XineramaConfig 0 0 0 0 1 1]
got M_CONFIG_INFO [Colorset 0 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 1 ffffff bebebe ffffff 5f5f5f 0 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 2 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 3 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 4 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 5 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 6 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 7 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 8 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 9 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset a 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset b 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset c 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset d 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset e 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset f 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 10 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 11 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 12 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 13 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 14 0 b0b0d0 ffffff 54546c 84849c 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 15 0 5050b0 8b8bdc 34344c 3c3c84 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 16 0 101050 8888a8 585885 3c 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 17 0 fff68f ccc572 8c874e bfb96b 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [ClickTime 150]
got M_CONFIG_INFO [MoveThreshold 3]
got M_CONFIG_INFO [*FvwmTabsactiveFG yellow]
got M_CONFIG_INFO [*FvwmTabsactiveBG midnightblue]
got M_CONFIG_INFO [*FvwmTabsinactiveFG antiquewhite]
got M_CONFIG_INFO [*FvwmTabsinactiveBG royalblue]
got M_CONFIG_INFO [*FvwmTabstitleFG black]
got M_CONFIG_INFO [*FvwmTabstitleBG antiquewhite]
got M_CONFIG_INFO [*FvwmTabsactiveRelief sunken]
got M_CONFIG_INFO [*FvwmTabspollRate 250]
got M_CONFIG_INFO [*FvwmTabsbuttonFont Helvetica -12 bold]
got M_CONFIG_INFO [*FvwmTabstitleFont Helvetica -12 bold]
got M_CONFIG_INFO [*FvwmTabsmenuFont Helvetica -12]
got M_CONFIG_INFO [*FvwmTabsfontSelector gfontsel --print -f "%f"]
got M_CONFIG_INFO [*FvwmTabsautoSwallowClass XEyes 1, someClass1 any, someClass2 1]
got M_CONFIG_INFO [*FvwmTabsautoSwallowResource xcalc 0, xload]
got M_CONFIG_INFO [*FvwmTabsautoSwallowName swallowMe lastFocus]
got M_CONFIG_INFO [*FvwmTabsballoonBG #C0C080]
got M_CONFIG_INFO [*FvwmTabsballoonFont Helvetica -12]
got M_CONFIG_INFO [*FvwmTabsballoonWait 350]
got M_CONFIG_INFO [*FvwmTabsballoonMsg Tab %tabNo:\n%iconText\n%title]
got M_CONFIG_INFO [*FvwmTabsautoResize false]
got M_CONFIG_INFO [*FvwmTabsstateFile /home/micha/.fvwm/.fvwmtabs.state]
got M_CONFIG_INFO [*FvwmTabsfixedSizeTabs false]
got M_CONFIG_INFO [*FvwmTabsshowTitlebar true]
got M_CONFIG_INFO [*FvwmTabsuseTMTitlebar false]
got M_CONFIG_INFO [*FvwmTabsdragDropIcon happyMini.xpm]
got M_CONFIG_INFO [*FvwmTabsbBuggyFocus false]
got M_CONFIG_INFO [*FvwmTabsenableSwallowDND false]
got M_CONFIG_INFO [*FvwmTabsswallowDNDTolerance 10]
got M_CONFIG_INFO [*FvwmTabsuseIconsOnTabs true]
got M_CONFIG_INFO [*FvwmTabskillIcon red.png]
got M_CONFIG_INFO [*FvwmTabsaddIcon yellow.png]
got M_CONFIG_INFO [*FvwmTabsreleaseIcon green.png]
got M_CONFIG_INFO [*FvwmTabsmenuIcon green.png]
got M_CONFIG_INFO [DesktopName 0 Shells]
got M_CONFIG_INFO [DesktopName 1 Text]
got M_CONFIG_INFO [DesktopName 2 Devel]
got M_CONFIG_INFO [DesktopName 3 Net]
got M_CONFIG_INFO [IgnoreModifiers 2]
got M_END_CONFIG_INFO
sent [SET_MASK 676069376]
sent [Send_ConfigInfo]
got M_CONFIG_INFO [DesktopSize 4 1]
got M_CONFIG_INFO [ImagePath /usr/share/icons:/usr/share/pixmaps:/usr/include/X11/pixmaps:/usr/share/pixmaps/other:/usr/include/X11/bitmaps:/usr/X11R6/include/bitmaps:/usr/share/pixmaps/mgt]
got M_CONFIG_INFO [XineramaConfig 0 0 0 0 1 1]
got M_CONFIG_INFO [Colorset 0 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 1 ffffff bebebe ffffff 5f5f5f 0 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 2 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 3 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 4 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 5 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 6 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 7 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 8 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 9 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset a 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset b 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset c 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset d 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset e 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset f 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 10 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 11 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 12 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 13 0 bebebe ffffff 5f5f5f 8f8f8f 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 14 0 b0b0d0 ffffff 54546c 84849c 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 15 0 5050b0 8b8bdc 34344c 3c3c84 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 16 0 101050 8888a8 585885 3c 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [Colorset 17 0 fff68f ccc572 8c874e bfb96b 0 0 0 0 64 0 0 0 0 0 0 0 0 0 64]
got M_CONFIG_INFO [ClickTime 150]
got M_CONFIG_INFO [MoveThreshold 3]
got M_CONFIG_INFO [*FvwmProxyFont "xft:snap"]
got M_CONFIG_INFO [*FvwmProxyProxyMove true]
got M_CONFIG_INFO [*FvwmPagerColumns    1]
got M_CONFIG_INFO [*FvwmPagerDesktopScale 14]
got M_CONFIG_INFO [*FvwmPagerUseSkipList]
got M_CONFIG_INFO [*FvwmPagerColorset * 20]
got M_CONFIG_INFO [*FvwmPagerHilightColorset * 20]
got M_CONFIG_INFO [*FvwmPagerWindowColorsets 21 22]
got M_CONFIG_INFO [*FvwmPagerBalloonColorset * 23]
got M_CONFIG_INFO [*FvwmPagerFont none]
got M_CONFIG_INFO [*FvwmPagerSmallFont none]
got M_CONFIG_INFO [*FvwmPagerBalloons All]
got M_CONFIG_INFO [*FvwmPagerBalloonFont "Shadow=1 1 : snap.se"]
got M_CONFIG_INFO [*FvwmPagerBalloonYOffset +2]
got M_CONFIG_INFO [*FvwmPagerBalloonBorderWidth 1]
got M_CONFIG_INFO [*FvwmPagerMoveThreshold 0]
got M_CONFIG_INFO [*FvwmPagerWindowBorderWidth 2]
got M_CONFIG_INFO [*FvwmPagerWindow3DBorders]
got M_CONFIG_INFO [*FvwmPagerMiniIcons]
got M_CONFIG_INFO [*FvwmTabsactiveFG yellow]
Module Config event - "activeFG" changed, new val: "yellow"
got M_CONFIG_INFO [*FvwmTabsactiveBG midnightblue]
Module Config event - "activeBG" changed, new val: "midnightblue"
got M_CONFIG_INFO [*FvwmTabsinactiveFG antiquewhite]
Module Config event - "inactiveFG" changed, new val: "antiquewhite"
got M_CONFIG_INFO [*FvwmTabsinactiveBG royalblue]
Module Config event - "inactiveBG" changed, new val: "royalblue"
got M_CONFIG_INFO [*FvwmTabstitleFG black]
Module Config event - "titleFG" changed, new val: "black"
got M_CONFIG_INFO [*FvwmTabstitleBG antiquewhite]
Module Config event - "titleBG" changed, new val: "antiquewhite"
got M_CONFIG_INFO [*FvwmTabsactiveRelief sunken]
Module Config event - "activeRelief" changed, new val: "sunken"
got M_CONFIG_INFO [*FvwmTabspollRate 250]
Module Config event - "pollRate" changed, new val: "250"
got M_CONFIG_INFO [*FvwmTabsbuttonFont Helvetica -12 bold]
Module Config event - "buttonFont" changed, new val: "Helvetica -12 bold"
got M_CONFIG_INFO [*FvwmTabstitleFont Helvetica -12 bold]
Module Config event - "titleFont" changed, new val: "Helvetica -12 bold"
got M_CONFIG_INFO [*FvwmTabsmenuFont Helvetica -12]
Module Config event - "menuFont" changed, new val: "Helvetica -12"
got M_CONFIG_INFO [*FvwmTabsfontSelector gfontsel --print -f "%f"]
Module Config event - "fontSelector" changed, new val: "gfontsel --print -f "%f""
got M_CONFIG_INFO [*FvwmTabsautoSwallowClass XEyes 1, someClass1 any, someClass2 1]
Module Config event - "autoSwallowClass" changed, new val: "XEyes 1, someClass1 any, someClass2 1"
got M_CONFIG_INFO [*FvwmTabsautoSwallowResource xcalc 0, xload]
Module Config event - "autoSwallowResource" changed, new val: "xcalc 0, xload"
got M_CONFIG_INFO [*FvwmTabsautoSwallowName swallowMe lastFocus]
Module Config event - "autoSwallowName" changed, new val: "swallowMe lastFocus"
got M_CONFIG_INFO [*FvwmTabsballoonBG #C0C080]
Module Config event - "balloonBG" changed, new val: "#C0C080"
got M_CONFIG_INFO [*FvwmTabsballoonFont Helvetica -12]
Module Config event - "balloonFont" changed, new val: "Helvetica -12"
got M_CONFIG_INFO [*FvwmTabsballoonWait 350]
Module Config event - "balloonWait" changed, new val: "350"
got M_CONFIG_INFO [*FvwmTabsballoonMsg Tab %tabNo:\n%iconText\n%title]
Module Config event - "balloonMsg" changed, new val: "Tab %tabNo:\n%iconText\n%title"
got M_CONFIG_INFO [*FvwmTabsautoResize false]
Module Config event - "autoResize" changed, new val: "false"
got M_CONFIG_INFO [*FvwmTabsstateFile /home/micha/.fvwm/.fvwmtabs.state]
Module Config event - "stateFile" changed, new val: "/home/micha/.fvwm/.fvwmtabs.state"
got M_CONFIG_INFO [*FvwmTabsfixedSizeTabs false]
Module Config event - "fixedSizeTabs" changed, new val: "false"
got M_CONFIG_INFO [*FvwmTabsshowTitlebar true]
Module Config event - "showTitlebar" changed, new val: "true"
got M_CONFIG_INFO [*FvwmTabsuseTMTitlebar false]
Module Config event - "useTMTitlebar" changed, new val: "false"
got M_CONFIG_INFO [*FvwmTabsdragDropIcon happyMini.xpm]
Module Config event - "dragDropIcon" changed, new val: "happyMini.xpm"
got M_CONFIG_INFO [*FvwmTabsbBuggyFocus false]
Module Config event - "bBuggyFocus" changed, new val: "false"
got M_CONFIG_INFO [*FvwmTabsenableSwallowDND false]
Module Config event - "enableSwallowDND" changed, new val: "false"
got M_CONFIG_INFO [*FvwmTabsswallowDNDTolerance 10]
Module Config event - "swallowDNDTolerance" changed, new val: "10"
got M_CONFIG_INFO [*FvwmTabsuseIconsOnTabs true]
Module Config event - "useIconsOnTabs" changed, new val: "true"
got M_CONFIG_INFO [*FvwmTabskillIcon red.png]
Module Config event - "killIcon" changed, new val: "red.png"
got M_CONFIG_INFO [*FvwmTabsaddIcon yellow.png]
Module Config event - "addIcon" changed, new val: "yellow.png"
got M_CONFIG_INFO [*FvwmTabsreleaseIcon green.png]
Module Config event - "releaseIcon" changed, new val: "green.png"
got M_CONFIG_INFO [*FvwmTabsmenuIcon green.png]
Module Config event - "menuIcon" changed, new val: "green.png"
got M_CONFIG_INFO [DesktopName 0 Shells]
got M_CONFIG_INFO [DesktopName 1 Text]
got M_CONFIG_INFO [DesktopName 2 Devel]
got M_CONFIG_INFO [DesktopName 3 Net]
got M_CONFIG_INFO [IgnoreModifiers 2]
got M_END_CONFIG_INFO
AutoSwallow: class=XEyes, type=1
AutoSwallow: class=someClass1, type=any
AutoSwallow: class=someClass2, type=1
AutoSwallow: resource=xcalc, type=0
AutoSwallow: resource=xload, type=any
AutoSwallow: name=swallowMe, type=lastFocus
sent [SET_MASK 1749811200]
sent [NOP FINISHED STARTUP]
sent [SET_MASK 1749286912]
got M_ADD_WINDOW
Add Window: win_id = 37748761, window_flags = p

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>

---

From: Scott Smedley <[email-masked]>
Date: Tue, 8 Jun 2004 11:22:23 +1000

Hi Micha,

: With the converted rpm for Tk::PNG version 2.003 it gives a message
: that it can't find Tk::PNG with a self compiled version (2.005) it just
: crashes, no messages.

I'm not sure I understand this, but to find out if its the PNG module
causing problems you can simply remove "Tk::PNG" from the use line in
the FvwmTabs source code. FvwmTabs will spit out lots of errors every
time it tries to load a .png image, but it should still function.

: On startup the following output is given, on crash no output:

That all looks pretty sane, except the last line is probably truncated.

What does FvwmTabs output on stdout/stderr?

In my ~/.xsession file I do a:

exec fvwm >& $HOME/.fvwm/.errorLog

& then any FvwmTabs errors go to ~/.fvwm/.errorLog.
Default would be ~/.xsession-errors? (or is that only stderr? not sure.)

Anyway, I'm interested in a line like:

FvwmTabs (v3.1) started with: Perl 5.8.0, X11::Protocol 0.53, Tk 804.025.

& anything else FvwmTabs might say.

Also, what version of FVWM are you using?

If you're really keen to help out, try & catch me on #fvwm
(IRC: freenode.net - my nick is "scottie7") & we can experiment with a
few things.

SCoTT. :)

---

From: Micha Feigin <[email-masked]>
Date: Fri, 11 Jun 2004 17:44:23 +0300

> What does FvwmTabs output on stdout/stderr?

This version of Tk has buggy drag-&-drop - workaround enabled.
[FvwmTabs Debug]: sent [SET_MASK 541065216]
[FvwmTabs Debug]: sent [SET_SYNC_MASK 0]
FvwmTabs: Swallow overlapping (D&D), & mini icon features require FVWM >= 2.5.11 - these features disabled.
FvwmTabs: Couldn't create D&D icon from happyMini.xpm
FvwmTabs (v3.1) started with: Perl 5.8.4, X11::Protocol 0.52, Tk 800.025.
image "" doesn't exist at /usr/lib/perl5/Tk/Widget.pm line 196.
 at /usr/lib/fvwm/2.5.10/FvwmTabs line 464
	(in cleanup) Can't call method "name" on an undefined value at /usr/lib/fvwm/2.5.10/FvwmTabs line 850 during global destruction.

> Also, what version of FVWM are you using?

fvwm 2.5.10 compiled on May  7 2004 at 07:30:29
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM, Bidi text, Xinerama, XRender, XFT, NLS

> (IRC: freenode.net - my nick is "scottie7") & we can experiment with a

Will try, will need to find some time to see how to setup irc though.

---

From: Scott Smedley <[email-masked]>
Date: Sat, 12 Jun 2004 01:37:36 +1000

Hi Micha,

: FvwmTabs (v3.1) started with: Perl 5.8.4, X11::Protocol 0.52, Tk 800.025.
: image "" doesn't exist at /usr/lib/perl5/Tk/Widget.pm line 196.
:  at /usr/lib/fvwm/2.5.10/FvwmTabs line 464
: 	(in cleanup) Can't call method "name" on an undefined value at /usr/lib/fvwm/2.5.10/FvwmTabs line 850 during global destruction.

Oh ok. You're using an oldish version of Tk & it doesn't appear to handle
empty strings as an image name the way later versions of Tk do. I'll
modify FvwmTabs to get around this in the next release. For now, if
you make sure a valid image is specified for the 4 toolbar icons it
should work ok:

*FvwmTabs: killIcon red.png
*FvwmTabs: addIcon yellow.png
*FvwmTabs: releaseIcon green.png
*FvwmTabs: menuIcon green.png

& make sure the .png images are in your ImagePath.

Let me know if this works.

SCoTT. :)