Subject: Re:FVWM: changing MiniIcon for program setting it themselves

From: [email-masked]
Date: Mon, 07 Jun 2004 09:21:24 +0800

In your mail:
>From: Micha Feigin <[email-masked]>
>Reply-To: 
>To: fvwm <[email-masked]>
>Subject: FVWM: changing MiniIcon for program setting it themselves
>
>Is it possible to change the MiniIcon for programs that set it
> themselves? (I want bigger icons for the programs).
> 
> This is not the actual icon I want for gvim but just for the example
> 
> Style "Gvim"                    MiniIcon Mutt.png
> 
> Doesn't change the icon for gvim. As an alternative, is it possible to
> scale the icons?
> --

1.Style "Gvim"      MiniIcon Mutt.png, EWMHMiniIconOverride
2.Impossible to scale icons now.

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Mon, 7 Jun 2004 11:37:10 +1000

: >Is it possible to change the MiniIcon for programs that set it
: > themselves? (I want bigger icons for the programs).
: > 
: > This is not the actual icon I want for gvim but just for the example
: > 
: > Style "Gvim"                    MiniIcon Mutt.png
: > 
: > Doesn't change the icon for gvim. As an alternative, is it possible to
: > scale the icons?
: 
: 1.Style "Gvim"      MiniIcon Mutt.png, EWMHMiniIconOverride
: 2.Impossible to scale icons now.

It's possible to scale icons manually:

You can extract EWMH icons from an app by using:

http://users.tpg.com.au/users/scottie7/tmp/ewmhIcon.pl

Resize them to whatever size you'd like using gimp, ImageMagik, etc.
& then use EWMHMiniIconOverride as Liu suggested.

But, there is no way to get FVWM to do this for you automatically
(at the moment).

SCoTT. :)