Subject: Re: FVWM: Doubleclick still don't work perfectly

From: [email-masked]
Date: Tue, 01 Jun 2004 20:31:26 +0800

In your mail:
>From: Dominik Vogt <[email-masked]>
>Reply-To: [email-masked]
>To: [email-masked], fvwm <[email-masked]>
>Subject: Re: FVWM: Doubleclick still don't work perfectly
>
>On Mon, May 31, 2004 at 05:02:23PM +0800, [email-masked] wrote:
> > >> > > I tried fvwm-snap-20040529.
> > >> > > And I'm pretty sure that doubleclick still doesn't work the right way.
> > >> > 
> > >> > Doubleclick where and when?
> > >> > 
> > >> > Regards,
> > >> > Mikhael.
> > >> > --
> > >> 
> > >> My settings:
> > >>  AddToFunc Move-or-Maximize
> > >>  + I Raise
> > >>  + M Move
> > >>  + D Maximize
> > >>  Mouse 1     TS   A    Move-or-Maximize
> > >> 
> > >> I can still click mouse1 with any other second mouse button to maximize
the
> > >> window.
> > >
> > >You need a more recent snapshot.  The snapshots are generated only
> > >once per day.
> > 
> > fvwm-snap-20040530 still has this problem.
> 
> You must have an istallation problem.  Are you *sure* you are
> running the correct snapshot?  If you open an FvwmCosole window
> you can see the version that is currently running.
> 
> Ciao
> 
> Dominik ^_^  ^_^
> 
>  --

I assure you the installation is correct.
The version info showing up in the FvwmConsole is `*FvwmConsole version 2.5.11
(snap-20040601)'.

I tried several ways of double-click and found the problem is essentially related
to the moment you click second mouse button, ie. if you click the second mouse
button as soon as you COMPLETELY release Mouse1, the window is maximized, 
otherwise it is fine. I'm sorry I can't explain this any clearer. I hope you can
reproduce this problem.

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 1 Jun 2004 18:55:28 +0200

> otherwise it is fine. I'm sorry I can't explain this any clearer. I hope you can

No, I can't reproduce the problem.  I'm doing exactly what you
describe, and since I committed the fix it works fine.  I even
downloaded and installed the 20040530 snapshot.  I can't imagine
what else could have gone wrong.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]