Subject: FVWM: fvwmbuttons align bottom

From: Roeland Moors <[email-masked]>
Date: Mon, 14 Jun 2004 16:43:08 +0200

I have a fvwmIconMan inside my FvwmButtons. The area for this
IconMan is to large if there are only a couple apps. The IconMan
is then centered. Is it possible to bottom align the IconMan
inside the FvwmButtons?
I found a right, left, center option but not top, center, align.

-- 
Roeland
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Roeland Moors <[email-masked]>
Date: Mon, 14 Jun 2004 17:34:26 +0200

> I found a right, left, center option but not top, center, align.
Here is a screenshot with the problem:
http://users.telenet.be/roeland/fvwm/screen.jpg

The FvwmIconMan should be lower.

---

From: Ruslan Kosolapov <[email-masked]>
Date: Mon, 14 Jun 2004 23:17:43 +0700

>> I found a right, left, center option but not top, center, align.
 RM> Here is a screenshot with the problem:
 RM> http://users.telenet.be/roeland/fvwm/screen.jpg

 RM> The FvwmIconMan should be lower.

  As I understand, to solve this problem you should configure
  FvwmIconMan, not FvwmButtons.

  $ man FvwmIconMan
  .....
  *FvwmIconMan: [id] ManagerGeometry geometry

  Specifies the initial geometry of the manager, in units of but-
  tons. If height is 0, then the manager will use width columns, and
  will grow vertically once it has more than width windows.  Likewise,
  if width is 0, it will use height rows, and grow hori- zontally.  If
  both are nonzero, then the manager window will be exactly that size,
  and stay that way. As columns are created, the buttons will narrow to
  accommodate.  If the geometry is specified with a negative y
  coordinate, then the window manager will grow upwards. Otherwise, it
  will grow downwards.
  ....

  As I see in screenshot, you use something like 
  "*FvwmIconMan: ManagerGeometry 1x0".
  Try to use "*FvwmIconMan: ManagerGeometry 1x0+0-0"
  
  As example you can view my very old config: 
  http://dotfiles.com/files/17/335_.fvwm2rc 
  (screenshot of it is http://rk.somewhere.ru/gfx/fvwm1.jpg)

-- 
Ruslan Kosolapov
Plesk QA Department Second Manager
SWsoft, Inc.
E-mail: [email-masked]
Web Site: www.sw-soft.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Roeland Moors <[email-masked]>
Date: Mon, 14 Jun 2004 20:29:20 +0200

>   (screenshot of it is http://rk.somewhere.ru/gfx/fvwm1.jpg)
I tried "ManagerGeometry 1x0+0-0", but that doesn't make a
difference. 

But I also want to align a 'normal' application like gkrellm to
align to the top/bottom. I could make an area which is smaller
then gkrellm, but I don't like that solution. It may cause
problems with the other FvwmButtons stuff (overlapping).

Here is my config:
http://users.telenet.be/roeland/fvwm/index.html

Thanks for the help

---

From: Ruslan Kosolapov <[email-masked]>
Date: Tue, 15 Jun 2004 02:38:24 +0700

>>   (screenshot of it is http://rk.somewhere.ru/gfx/fvwm1.jpg)
 RM> I tried "ManagerGeometry 1x0+0-0", but that doesn't make a
 RM> difference. 

  You are right, I answered too fast, sorry.
  ManagerGeometry can't solve you problem - window of FvwmIconMan is
  smaller than FvwmButton's place for swallow it.

  Simplest solution is use FvwmIconMan without swallow.
  I can't found a better way.
  
 RM> But I also want to align a 'normal' application like gkrellm to
 RM> align to the top/bottom. I could make an area which is smaller then
 RM> gkrellm, but I don't like that solution. It may cause problems with
 RM> the other FvwmButtons stuff (overlapping).

  Year ago I tryed to make something like this.  Unfortunately I don't
  remember results and can't find configs :(

  Now I use more simple setup (http://rk.somewhere.ru/gfx/fvwm4.png and
  http://rk.somewhere.ru/.fvwm2rc), and no use swallow at all.

PS: AFAIK there no way to set vertical align in FvwmButtons.

---

From: Roeland Moors <[email-masked]>
Date: Tue, 15 Jun 2004 11:10:02 +0200

> PS: AFAIK there no way to set vertical align in FvwmButtons.

Thanks, I use IconMan without FvwmButtons now, that works great.

---

From: Roeland Moors <[email-masked]>
Date: Wed, 16 Jun 2004 09:43:23 +0200

On Tue, Jun 15, 2004 at 09:41:13PM -0400, Chris wrote:
> On Mon, Jun 14, 2004 at 05:34:26PM +0200, Roeland Moors wrote:
> >
>  I really like your backdrop.  My attempts to find a copy of it have
> completely failed; from where did you originally get it?
> 
> 

http://www.linuxforum.com/linux_wallpapers/86.php

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 16 Jun 2004 10:45:17 +0200

> I tried "ManagerGeometry 1x0+0-0", but that doesn't make a

I think FvwmIconMan behaves a bit funny when it comes to
geometries.  I have

  *FvwmIconMan*ManagerGeometry 2x5

With that, FvwmIconMan fills up the whole area allocated by
FvwmButtons.  As far as I remember, it is necessary to specify a
non null width *and* height for this to work.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]