Subject: FVWM: Re: Re: 3 config questions about Icons(iconified windows)

From: [email-masked]
Date: Sun, 13 Jun 2004 19:33:30 +0800

Hi Taviso,

Thank you very much for your nice tips.
But they don't work as expected. Help me out.

> I think you're looking for the IconGrid setting, although I just had a go
> and 1x1 pixels is the minimum spacing, so you can't disable it
> completely..but it's pretty close :)

default setting is 'IconGrid 3 3',
now I use 'IconGrid 1 1'(just following IconBox setting).
But the Icons don't get placed any closer.

Here is the related settings:

#BEGIN
Style * Icon, StickyAcrossPagesIcon, FPGrabFocus
Style * IconBox 130 12 800 250, IconGrid 1 1, IconFill left top
#END

> I don't think that's possible unfortunately, but one way round it would be
> to use IndexedIconName, which would make IconTitle's much shorter.

Now I use 'Style * IndexedIconName', it seems to make the icon title even longer
because the appended <i> number.

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Sun, 13 Jun 2004 13:04:44 +0100

> But the Icons don't get placed any closer.

Try setting: Style * IconBackgroundPadding 0

and depending on your settings:

Style * IconBackgroundRelief 0, IconTitleRelief 0

I can get them pretty close together with these settings.

>> I don't think that's possible unfortunately, but one way round it would
>> be to use IndexedIconName, which would make IconTitle's much shorter.
> 
> Now I use 'Style * IndexedIconName', it seems to make the icon title even
> longer because the appended <i> number.
> 

ahh, i assumed your titles were so long because of a long ExactWindowName
:) 

I suppose the only alternative is to tweak your IconFont...

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------