Subject: FVWM: How can i use the win-logo key in fvwm? Please....

From: lee <[email-masked]>
Date: Sun, 20 Jun 2004 13:50:52 +0800

This is my xmodmap list:
learnman>$xmodmap
xmodmap: up to 2 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_R (0x71)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_L (0x73), Super_R (0x74)
mod5

I just want to popup the RootMenu when i press the win-logo key anywhere
an d anytime! like this:

### Key Keyname Context Action ######
Key Pause A N Popup "Utilities"
..
Key Keyname(what should i set?) A N(what should i set?) Popup RootMenu

I don't know the win-logo key is Modifier or a common key? if it is
Modifiers ,but FVWM have predefined the "M" of Alt.

What i'll do correctly in my fvwm2rc? please.....

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Jun 2004 10:57:59 -0400

> What i'll do correctly in my fvwm2rc? please.....

Use "xev" to find out what the keycode and keysym (if any) are.

Then use xmodmap to assign or change the keysym as needed.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: "B. Zhang" <[email-masked]>
Date: Sun, 20 Jun 2004 17:01:31 +0200

- use xev to find the keycode of the win-logo key, for me it is 115.
- in your .xsession for example, add 
     xmodmap -e 'keycode 115 = winlogo'
- then 
     Key  winlogo  A  N  Popup  RootMenu

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Jun 2004 11:18:35 -0400

>      Key  winlogo  A  N  Popup  RootMenu

On this list, please don't top post.

On my system, that doesn't work.
The keysym must be one of the keys listed in /usr/include/X11/keysymdef.h.

(without the XK_ prefix.)

Pick any unused keysym you like.

---

From: Roeland Moors <[email-masked]>
Date: Sun, 20 Jun 2004 18:05:54 +0200

> What i'll do correctly in my fvwm2rc? please.....

This should work:

# the windows key
Key Super_L		A	N	Action

# the menu key
Key Menu        A   N	Action

Or the windows key as modifier:

# winkey = Super_L = mod4
Key E           A       4       exec Eterm

---

From: Michelle Konzack <[email-masked]>
Date: Sun, 20 Jun 2004 19:13:54 +0200

>     Key  winlogo  A  N  Popup  RootMenu

Hello, 

I have written my own keymap and I have for the three Buttons:

  ____ ( '/home/michelle/.xmodmap/de' ) ________________________________
 /
|  keycode 115 = winlogo_L
|  keycode 116 = winlogo_R
|  keycode 117 = winmenu
|  
|  keycode 161 = XF86AudioLowerVolume
|  keycode 163 = XF86AudioRaiseVolume
|  keycode 176 = XF86AudioMute
|  keycode 162 = XF86AudioPause
|  keycode 146 = XF86AudioNext
|  keycode 164 = XF86AudioPrev
|  keycode 160 = XF86AudioStop
 \______________________________________________________________________

But if I load my keymap I get

  ____ ( 'xmodmap $HOME/.xmodmap/de' ) _________________________________
 /
|  xmodmap:  de:107:  bad keysym name 'winlogo_L' in keysym list
|  xmodmap:  de:108:  bad keysym name 'winlogo_R' in keysym list
|  xmodmap:  de:109:  bad keysym name 'winmenu' in keysym list
|  xmodmap:  3 errors encountered, aborting.
 \____________________________________________

Why ?

The others XF86Audio* are working fine...

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: Michelle Konzack <[email-masked]>
Date: Sun, 20 Jun 2004 19:19:17 +0200

>The keysym must be one of the keys listed in /usr/include/X11/keysymdef.h.

Which mean, I can change the /usr/include/X11/keysymdef.h and recompile it 
with the three Buttons. 

Hmmm, maybe I will post an Bugreport/Wish...

>Pick any unused keysym you like.

This is not easy because I use UTF-8 and need 11 Languages...

Maybe a Bugreport to include the three Buttons is better...

Greetings
Michelle

---

From: "B. Zhang" <[email-masked]>
Date: Sun, 20 Jun 2004 21:03:15 +0200

> |  keycode 160 = XF86AudioStop
I made a mistake as pointed out by Dan Espen. We must use a keysym name
defined in /usr/include/X11/keysymdef.h (for example F15, F20, ...).

---

From: [email-masked]
Date: Mon, 21 Jun 2004 03:56:05 +0300

> defined in /usr/include/X11/keysymdef.h (for example F15, F20, ...).

I belive the right keyseems for that are Super_L and Super_R for the window keys
and menu for the menu key.

For me they actually work out of the box using these. I didn't have to modify
anything to use:

Key Super_L          A       M       Popup Window-Ops
Key Menu        A       A       Popup Root

(I don't have a Super_R on my laptop's keyboard)

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.