Subject: FVWM: providing and osd display for some actions

From: Micha Feigin <[email-masked]>
Date: Fri, 18 Jun 2004 05:44:36 +0300

Is it possible to make a pop-up osd like display with fvwm displaying
some value?

I would like to show on the screen for a couple of seconds the current
sound volume.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Roeland Moors <[email-masked]>
Date: Fri, 18 Jun 2004 09:10:22 +0200

> I would like to show on the screen for a couple of seconds the current

I'm using xosd to display some text:

DestroyFunc FuncFvwmOsdDisplay
AddToFunc   FuncFvwmOsdDisplay
+ I exec echo $0 | osd_cat -p bottom -c blue -d 2

This program also shows the volume level:
http://osdsh.sourceforge.net/
(I never tested it)

-- 
Roeland

---

From: Martin Niebergall <[email-masked]>
Date: Fri, 18 Jun 2004 09:14:17 +0200

Hi,

> Is it possible to make a pop-up osd like display with fvwm displaying

There is xosd from this site:  http://www.ignavus.net/software.html
Included in the package is a program "osd_cat" to display some osd like text. 

> I would like to show on the screen for a couple of seconds the current

That's exactly what I use it for.  I have bindings to my volume-up/down keys like this:

Key F20 A N Exec amixer set Master 2%+ unmute | tail -n 2 | \
    osd_cat -p bottom -A center -c green3 -s 3 -d 2 \
            -f '-*-bitstream vera sans-*-*-*-*-20-*-*-*-*-*-*-*'