Subject: Re: FVWM: Doubleclick still don't work perfectly

From: [email-masked]
Date: Wed, 02 Jun 2004 14:20:07 +0800

In your mail:
>From: Dominik Vogt <[email-masked]>
>Reply-To: [email-masked]
>To: [email-masked], fvwm <[email-masked]>
>Subject: Re: FVWM: Doubleclick still don't work perfectly
>
>On Tue, Jun 01, 2004 at 08:31:26PM +0800, [email-masked] wrote:
>> In your mail:
>> >From: Dominik Vogt <[email-masked]>
>> >Reply-To: [email-masked]
>> >To: [email-masked], fvwm <[email-masked]>
>> >Subject: Re: FVWM: Doubleclick still don't work perfectly
>> >
>> >On Mon, May 31, 2004 at 05:02:23PM +0800, [email-masked]
wrote:
>> > > >> > > I tried fvwm-snap-20040529.
>> > > >> > > And I'm pretty sure that doubleclick still doesn't work the right
way.
>> > > >> > 
>> > > >> > Doubleclick where and when?
>> > > >> > 
>> > > >> > Regards,
>> > > >> > Mikhael.
>> > > >> > --
>> > > >> 
>> > > >> My settings:
>> > > >>  AddToFunc Move-or-Maximize
>> > > >>  + I Raise
>> > > >>  + M Move
>> > > >>  + D Maximize
>> > > >>  Mouse 1     TS   A    Move-or-Maximize
>> > > >> 
>> > > >> I can still click mouse1 with any other second mouse button to maximize
>> the
>> > > >> window.
>> > > >
>> > > >You need a more recent snapshot.  The snapshots are generated only
>> > > >once per day.
>> > > 
>> > > fvwm-snap-20040530 still has this problem.
>> > 
>> > You must have an istallation problem.  Are you *sure* you are
>> > running the correct snapshot?  If you open an FvwmCosole window
>> > you can see the version that is currently running.
>> 
>> I assure you the installation is correct.
>> The version info showing up in the FvwmConsole is `*FvwmConsole version 2.5.11
>> (snap-20040601)'.
>> 
>> I tried several ways of double-click and found the problem is essentially
related
>> to the moment you click second mouse button, ie. if you click the second mouse
>> button as soon as you COMPLETELY release Mouse1, the window is maximized, 
>> otherwise it is fine. I'm sorry I can't explain this any clearer. I hope you
can
>> reproduce this problem.
>
>No, I can't reproduce the problem.  I'm doing exactly what you
>describe, and since I committed the fix it works fine.  I even
>downloaded and installed the 20040530 snapshot.  I can't imagine
>what else could have gone wrong.
>
>Ciao
>
>Dominik ^_^  ^_^
>
> --

I found out where the problem is!
It's the 'ClickTime' command,ie.if you set a short clicktime(ClickTime 150)
you can reproduce this problem.
I have a simple .fvwm2rc like this:
#BEGIN
    IgnoreModifiers L25
    ClickTime 150
    TitleStyle InActive -- Flat
    TitleStyle Active -- Flat
    ButtonStyle All InActive -- Flat
    ButtonStyle All Active -- Flat
    Mouse 0 2 A Maximize
    Mouse 0 4 A Iconify
    Mouse 1     TS   A    Move-or-Maximize
    AddToFunc Move-or-Maximize
     + I Raise
     + M Move
     + D Maximize
#END

If you set 'ClickTime 750', doubleclick works right.

Regards,
Liu Shidai

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 2 Jun 2004 12:04:02 +0200

> If you set 'ClickTime 750', doubleclick works right.

Ah, yes.  Fixed.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]