Subject: FVWM: Help with GTK+ app placement?

From: Chris Alexander <[email-masked]>
Date: Thu, 10 Jun 2004 16:01:57 -0400 (EDT)

I'm using a GTK application called gpsdrive (http://www.gpsdrive.cc) and
I've got it starting on the correct virtual page and in the correct size
for my kiosk like layout BUT it doesn't seem to want to start in the
correct position.

My screen is 800x480, first 200 px x 480 px is a button bar (pager to be
precise); gpsdrive basicly needs to understand "-geometry 600x480+200+0".

Is there a way to make the gtk app start up in the correct location on the 
screen using fvwm?

Any ideas?

T!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 12 Jun 2004 23:11:29 +0200

> Is there a way to make the gtk app start up in the correct location on the 

First, check if the program has some option like "remember window
position" or similar.  It you can't find anything, there are a
number of styles in fvwm to tame the application.  Try in the
given order, one by one:

  Style <appname> nopposition, notransientpposition
  Style <appname> nousposition, notransientusposition
  Style <appname> gnomeignorehints
  Style <appname> ewmhignorestatehints
  Style <appname> fixedpposition
  Style <appname> fixedusposition

(some of these styles require fvwm-2.5.x).

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]