Subject: FVWM: FVWM don't read my xmodmap's setting,why?

From: lee <[email-masked]>
Date: Fri, 25 Jun 2004 19:12:18 +0800

This is i do:
1. I have already install FVWM into my machine, and i commonly enter
FVWM from command console (runlevel 3) with the command'learnman>$ startx'
2. cp /opt/wm/fvwm/fvwm-2.5.8/modules/FvwmSaveDesk/example/xinitrc
~~/.xinitrc
3. The .xinitrc file have these sentences:
...
usermodmap=$HOME/.Xmodmap
...
xmodmap $usermodmap
...
fvwm2 -cmd "FvwmM4 -m4-prefix -m4opt -I$HOME $HOME/.fvwm/.fvwm2rc"
~~~~ I change .fvwm2rc location to /home/learnman/.fvwm/, so i put the
.fvwm2rc file into /home/learnman/.fvwm/ , i think this change is right

4. And I append these keycodes into my ~/.Xmodmap file:
keycode 222 = XF86PowerOff
keycode 223 = XF86Standby
keycode 227 = XF86Wakeup
5. I check my ~/.fvwm/.fvwm2rc file, it have the sentence:
...
Key XF86Standby A A Menu RootMenu Popup
~~~~~~~~~~~~~~~~~~~~~This is test the Key
6. Now i exit FVWM to command console and type"startx" , the key of
XFStandby do not work, i type 'xmodmap -pke |grep 222' to check the key
have setted or not ,the answer is :
...
keycode 222 =
~~~~this is empty, it show me the key have not setted
7.But after i typed 'xmodmap -e "Keycode 222 = XF86Standby" ', and
restart the FVWM(not exit FVWM to command console) , the key works
correctly. Why?

8. By the way, i set some icons into my rootmenu such as:
"%mini.xterm.xpm&Xterm" Exec exec xterm
and i enter FVWM with 'startx', these icos don't display, just display
correctly with restart FVWM (not exit FVWM to command console, just run
restart, and the ImagePath setting is correct).
I think the two problems maybe is one same question, but i can not check
out the answer.

Please.....
Yours
learnman

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Jun 2004 11:56:48 -0400

> fvwm2 -cmd "FvwmM4 -m4-prefix -m4opt -I$HOME $HOME/.fvwm/.fvwm2rc"

I don't think FvwmSaveDesk is in good shape and I don't recommend
using it.  Also using M4 isn't simple.

Try starting fvwm from your .xinitrc with:

exec fvwm

Also remove any .fvwm2rc file that you have and press F1 after you
start fvwm.  Choose one of the options from the menu that creates
a config file.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: lee <[email-masked]>
Date: Sun, 27 Jun 2004 01:36:58 +0800

Thanks Dan.  

   I do all that Dan told me.

  The problem which FVWM cann't display icons in Rootmenu did not appears.

  But FVWM still can not read my xmodmap , like the question why FVWM 
can read the command line "xmodmop -e 'keycode 222 = XF86Poweroff'" and 
works correctly, but it can not read my setting in .Xmodmap regardless 
of i append  "xmodmap $HOME/.xmodmap" or not .  

    I've used another method just set these into my .fvwm2rc file, like 
this:
...
InitFunction
+ I  Exec exec xmodmap $HOME/.xmodmap
...
The problem still exists

---

From: Michelle Konzack <[email-masked]>
Date: Sat, 26 Jun 2004 19:54:40 +0200

>+ I  Exec exec xmodmap $HOME/.xmodmap

Wired... 
At me it works around 10 Minutes and afzter this my "Super_L", 
Super_R", "Menu", "F11" and "F12" do not more work. 

I use "Super_L" to popup a Menu which let me select different 
Keyboards (de, en, fr, ar fa, tr) 

The "Super_R" is my X-ControlCenter, and "Menu" the Root-Menu.

"F11" and "F12" are used with 'cam' to set the master volume 
of my Soundcard. 

This all stops working after 10 or 15 Minutes.

If I start xev, the Butons are working fine, but fvwm does 
not more recognize them. Same is if I restart fvwm before the
10 or 15 minutes. The lost all Keys.

Greetings
Michelle

-- 
Linux-User #280138 with the Linux Counter, http://counter.li.org/ 
Michelle Konzack   Apt. 917                  ICQ #328449886
                   50, rue de Soultz         MSM LinuxMichi
0033/3/88452356    67100 Strasbourg/France   IRC #Debian (irc.icq.com)

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Jun 2004 14:05:13 -0400

Michelle Konzack <[email-masked]> writes:
> > Thanks Dan. =20
> Wired...=20
> At me it works around 10 Minutes and afzter this my "Super_L",=20
> Super_R", "Menu", "F11" and "F12" do not more work.=20
> 
> I use "Super_L" to popup a Menu which let me select different=20
> Keyboards (de, en, fr, ar fa, tr)=20
> 
> "F11" and "F12" are used with 'cam' to set the master volume=20
> of my Soundcard.=20
> 
> If I start xev, the Butons are working fine, but fvwm does=20

For keybindings that suddenly stop working, see question 0.1 in
the FAQ.

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Jun 2004 14:03:59 -0400

> + I  Exec exec xmodmap $HOME/.xmodmap

That should be:

AddToFunc InitFunction
+ I Exec exec xmodmap ~/.xmodmap

On my system, the .xmodmap file should contain:

keycode 222 = 86_Poweroff

If I use the "XF", I get:

home> xmodmap -e 'keycode 222 = XF86Poweroff'
xmodmap:  commandline:0:  bad keysym name 'XF86Poweroff' in keysym list
xmodmap:  1 error encountered, aborting.

---

From: Michelle Konzack <[email-masked]>
Date: Sun, 27 Jun 2004 00:11:01 +0200

>For keybindings that suddenly stop working, see question 0.1 in

I know it, I am very long time (since 1999) Fvwm $USER 

0.1 is not the reason...

Greetings
Michelle

---

From: lee <[email-masked]>
Date: Sun, 27 Jun 2004 10:16:53 +0800

> Dear Dan:

> Maybe you have got a kind of keyboard such as:
> /usr/X1186/bin/xmodmap  /usr/share/xmodmap/xmodmap.us101A_x86
> or /usr/share/xmodmap/xmodmap.uk_x86.... these others keyboard

>
> I've got my keyboard is :
> /usr/X1186/bin/xmodmap /usr/share/xmodmap/xmodmap.gb-105
>                                                                       
>                      ~~~~~~This is a chinese keyboard
>
> I'll try set another kind of keyboard to find out the truth.
>
> Sorry, the "keycode 222 =XF86Poweroff" should be "keycode 222 = 
> XF86PowerOff"
>
> Thanks
>     yours
>           liguohong (learnman , a beginner for linux+fvwm , come from 
> china)