Subject: FVWM: change border styles when shaded?

From: Nicholas Paul Johnson <[email-masked]>
Date: Thu, 27 May 2004 16:16:39 -0400 (EDT)

Hello,

I've revamped my .fvwm2rc as to make the borders big (and beautiful).  My
only issue is that when I shade the window, it looks kind of dumb.  Is
there any way to change the border/handle width settings of a window
depending on whether or not it is shaded?

On a similar note, I've been trying to get a titlebar double click to 
un/shade a window.  Why doesn't this work:

#-------------------------.fvwm2rc-
DestroyFunc ShadeOnDblClick
AddToFunc ShadeOnDblClick
+ "D"		WindowShade

Mouse 1 T A 	Function ShadeOnDblClick
#----------------------------------

thanks,
- -- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  Nicholas Paul Johnson
  o nickjohnson \at\ virginia \dot\ edu
  o 3ebf10a7 subkeys.pgp.net
  o http://manjac.ath.cx/nick
  o "When all you've got is a hammer,
    everything looks like a nail.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Chris Alexander <[email-masked]>
Date: Thu, 27 May 2004 16:31:16 -0400 (EDT)

Sorry, if this is a newbie Q. Been aware from fvwm for about 5 years and 
am still trying to get my head back into its config space.

Is there a why to have a FvwmButton change virtual desktops via a button 
click? If I could "theme" the button that would be great too.

TIA

---

From: Nicholas Paul Johnson <[email-masked]>
Date: Thu, 27 May 2004 16:40:36 -0400 (EDT)

See the GotoDeskAndPage commands 
http://www.fvwm.org/documentation/manpages/unstable/fvwm.php

I.e.,

*FvwmButtons: (Icon next.pbm, Action 'GotoPage +1 +1')

---

From: [email-masked]
Date: Thu, 27 May 2004 15:15:09 -0600

You can change the Style of windows based of its name, class or resource
string, which can almost do the effect you are looking for....
example

AddToFunc FvwmShade
+ I WindowShade
+ I ThisWindow (Shaded) Style $[w.name] BorderWidth 0, HandleWidth 0
+ I ThisWindow (!Shaded) Style $[w.name] BorderWidth 5, HandleWidth 5

you can replace $[w.name] with $[w.class] or $[w.resource], and this
will make the shaded window have no border width, the downside to this
is it will affect all windows of that name, class or resources, which
may not be what ya want...

jaimos

On Thu, May 27, 2004 at 04:16:39PM -0400, Nicholas Paul Johnson wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hello,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
> Comment: Made with pgp4pine 1.75-6
> 
> iD8DBQFAtkyufnGNDj6/EKcRApTgAJ9RCHq/HpOZjWC+1o5k1zOpMewMggCeO/Dy
> gQVuZfG0HMZkDeFR50vDiew=
> =NZxf
> -----END PGP SIGNATURE-----
> 
> 
> --

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 28 May 2004 00:48:50 +0000

> may not be what ya want...

This function of course affects all windows with the same name/class
(think multiple xterms).

In 2.5.x, use "WindowStyle" instead of "Style $[w.name]" to avoid this.

> > Mouse 1 T A 	Function ShadeOnDblClick

This sample works without any problems for me. Is it possible, you define
something like "Mouse 0 TSFW A Something" later in the config?

Of course, I would extend this function to be more functional, like:

  + C Raise
  + M Move
  + H Move

Regards,
Mikhael.