Subject: FVWM: FVWM and Java

From: Don Laurine <[email-masked]>
Date: Wed, 05 May 2004 13:01:28 -0700

Has any one experienced a problem with displays under FVWM generated
using Java? We have several applications which are Java based which
produce displays correctly on all our platforms and window managers,
including FVWM. There is one Java application which works great
everywhere except under FVWM. There, the window size is correct, but the
labeling and buttons are produced in arbritary locations (changes with
each execution). Sometimes the labeling and buttons do not even appear.

Thanks

-- 
Don Laurine 
NOAA, Northwest River Forecast Center
voice: (503) 326-7291 (ext 323)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 06 May 2004 11:47:32 -0400

> each execution). Sometimes the labeling and buttons do not even appear.

Yes, we've heard of Java problems before.
As we understand it, it's entirely a Java problem.
When Java detects a window manager it doesn't "know", it
misbehaves.  Upgrading to the lastest Java and Fvwm (in that order)
might help.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: stu <[email-masked]>
Date: Fri, 7 May 2004 12:21:00 +0200

On Thu, 06 May 2004 11:47:32 -0400
Dan Espen <[email-masked]> wrote:

> > everywhere except under FVWM. There, the window size is correct, but
> > the labeling and buttons are produced in arbritary locations
> > (changes with each execution). Sometimes the labeling and buttons do
> > not even appear.
> 

I haven't had any problems running java 1.4.2 with fvwm 2.5.8. I usually
work thru a browser, using jboss and jetty, but Netbeans and JEdit, as
well as stand-alone swing apps, all work with no problems.

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable