Subject: Fw: FVWM: Different borders for different sides of window

From: Nuno Alexandre <[email-masked]>
Date: Mon, 10 May 2004 16:46:22 +0200

On Mon, 10 May 2004 12:29:54 +0000 
Mikhael Goikhman wrote:

> On 10 May 2004 11:52:12 +0800, init wrote:
> > 
> > Is it possible to make different borders for different sides of
> > window? For example, first pixmap for up/left border, second pixmap
> > for right/down border or blue left border and red right?
> 
> No. Currently a single colorset/pixmap only may be used for all 4
> borders.

actually you can use hi #color sh #color in your color set, that will
make the top/left border using the 'hi' and the 'sh' will be for the
right/ bottom borders.

'hi' hilight ; 'sh' shadow
example:

Colorset 10 fg #000000, bg #f2f2f2, hi #30ff00, sh #ff0000
the top/ left are light green, and right / bottom light red so you can
see the diference.

			nuno

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 10 May 2004 15:16:33 +0000

On 10 May 2004 16:46:22 +0200, Nuno Alexandre wrote:
> 
> On Mon, 10 May 2004 12:29:54 +0000 Mikhael Goikhman wrote:
> 

The actual look highly depends on HandleWidth (BorderWidth) and other
border options.

With most of border widths and options your suggestion does not produce
the desired effect. Although "desired" is something subjective.

Regards,
Mikhael.