Subject: FVWM: How do I make this (transparent menu's and thumbnail icons)?

From: "Berry Bakker" <[email-masked]>
Date: Fri, 21 May 2004 18:52:47 +0200

Hello,

How do I make something like this:
http://www.fvwm.org/screenshots/desktops/Nuno_Alexandre-1600x1200/screenshot
jpg

I REALY like the icons with the thumbnails of the windows in it, how to do
this? How do I make a menu like that (transparent but tinted, you see the
windows under it!)?

I use FVWM 2.5.7, have not downloaded any patch or FVMW-Themes. I tried the
source of this one:
http://www.fvwm.org/screenshots/desktops/Tavis_Ormandy-desk-1152x864/screens
hot.jpg

Which also has the nice iconified windows and transparant, but tinted menus,
but turn out as ugly text and the menus aren't transparent :-(

Also how can I make a transparent but tinted (by tinted I mean it has still
a color) pager?

Do I need something special? A patch? A newer version? A better graphics
chip (I have a Cirrus Logic with 1Mb (SLICK!))?

If I need any patch, do I need to compile the thing myself, or can I apply
it to a FreeBSD package?

Regards,
Berry

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Micha Feigin <[email-masked]>
Date: Sat, 22 May 2004 21:20:09 +0300

> If I need any patch, do I need to compile the thing myself, or can I apply

If I am not mistaken, what you are looking for is the translucency
patch (translucent windows allow showing windows hidden under them and
I believe this is not yet in FVWM, transparent windows show the
background, but not overlapped windows, that is supported in mainstream
fvwm).

If you get the patch you will need to recompile the package (unless
someone supplies a package with the patch included).

I don't know how your chip will deal with that though (didn't know
there were still 1MB graphic cards out there).

I don't know how things are with freebsd (don't think it has
frame buffer support) but if it does there is DirectFB which allows
translucency (don't know how hard it is to setup).

>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
>

---

From: Catherine Luedecker <[email-masked]>
Date: Sat, 22 May 2004 14:40:11 -0700

> background, but not overlapped windows, that is supported in mainstream

That is correct....the patch was on the list a long time ago....dont
know where it is now but I think it was called the translucent menu's
patch.

As far as graphics cards go, mine is nothing special and it works just
fine

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 22 May 2004 22:29:51 +0000

> know where it is now but I think it was called the translucent menu's

It is in FAQ.

Regards,
Mikhael.

---

From: "Berry Bakker" <[email-masked]>
Date: Sat, 22 May 2004 19:34:04 +0200

----- Original Message -----
From: "Marc Schlienger" <[email-masked]>
To: "Berry Bakker" <[email-masked]>
Sent: Friday, May 21, 2004 11:38 PM
Subject: Re: FVWM: How do I make this (transparent menu's and thumbnail
icons)?

> Am Freitag, 21. Mai 2004 18:52 schrieben Sie:
> > Hello,
> >
http://www.fvwm.org/screenshots/desktops/Nuno_Alexandre-1600x1200/screensho
> >t jpg
> > this?
> I copied this from Tavis Ormandy:
>
> #####
> # Name:     Thumbnail
> # Purpose:  Iconify a window with a reduced screenshot of the application
> #           Window, looks really cool.
> #
> #           Uses FvwmEvent to remove the Icon when deiconified, you will
want
> #           to remove this if you use WindowStyle elsewhere.
> #
> #           Thumbnailing example:
[6]http://dev.gentoo.org/~taviso/step2.png
> #
> ##################
>
> SetEnv fvwm_icon_size 64
>
> DestroyFunc Thumbnail
> AddToFunc Thumbnail
> + I Raise
> + I PipeRead "xwd -silent -id $[w.id] | convert -scale $[fvwm_icon_size]
> -frame 1x1 \
>     -mattecolor black -quality 0 xwd:-
png:$[HOME]/.fvwm/icon.tmp.$[w.id].png
> \
>     && echo WindowStyle IconOverride, Icon
$[HOME]/.fvwm/icon.tmp.$[w.id].png,
> \
>     StaysOnBottom || echo Nop"
> + I Iconify
>

The output off xwd is piped to 'convert'... Which application is meant by
that? Where can I download it?

> DestroyFunc DeThumbnail
> AddToFunc DeThumbnail
> + I DestroyWindowStyle
> + I Exec exec rm -f $HOME/.fvwm/icon.tmp.$[w.id].png
>
> # FIXME: This will destroy all Windowstyle settings.
> *FvwmEvent: DeIconify DeThumbnail
>
> Now you have to bind the function to a key or the mouse.
> Example:
>
> Mouse 0 6 A Thumbnail
>
> And you have to add the following to your init function:
>
> + "I" Test (Restart) All (Iconic) Test (f $[HOME]/.fvwm/icon.\
> tmp.$[w.id].png) WindowStyle IconOverride, Icon $[HOME]\
> /.fvwm/icon.tmp.$[w.id].png
>
> The only thing left is to add the following to your exit function:
>
> + "I" Test (!ToRestart) Exec exec rm -f $[HOME]/.fvwm/icon.tmp.*
>
> > How do I make a menu like that (transparent but tinted, you see the
> > windows under it!)?
>
> The screenshot shows a translucent menu since you can see also the windows
> under it. A transparent menu only "shows" the background. For a
translucent
> menu you need Fvwm Themes with an additional patch (see also the FAQ).
> >
http://www.fvwm.org/screenshots/desktops/Tavis_Ormandy-desk-1152x864/screen
> >s hot.jpg
> >
> > Which also has the nice iconified windows and transparant, but tinted
> > menus, but turn out as ugly text and the menus aren't transparent :-(
>
> Tavis uses a transparent Colorset, I think. With the explanations above
you
> can easily get the nice iconified windows.
>
> >
> I don't know.