Subject: FVWM: swallow jpilot

From: Randy Schultz <[email-masked]>
Date: Thu, 13 May 2004 03:06:21 -0500 (CDT)

Hey all,

I've been trying unsuccessfully to get fvwm 2.5.7 to swallow jpilot on startup.
The icon just lands on the desktop.  I've tried various names in the
.fvwm2rc, e.g.
   *FvwmButtonsColumns     1
   *FvwmButtons (1x1 Frame 0 Swallow(UseOld) "FvwmPager" "Module FvwmPager 0 0")
   *FvwmButtons: (Swallow FvwmXclock 'Exec xclock -name "FvwmXclock" -geometry +0+0 -padding 1 -bg grey67 &')
   *FvwmButtons: (Swallow "JPilot" 'Exec jpilot -name "jpilot" -geometry +0+0 -padding 1 -bg grey67 &')

   BorderStyle Inactive -- HiddenHandles NoInset
   Style   "*"     SloppyFocus
   Style   "*"     DecorateTransient
   Style   "*"     StickyIcon
   Style   "*"     SmartPlacement, RandomPlacement
   Style   "*"     MinOverlapPlacement
   Style   "FvwmWinList"   NoTitle, WindowListSkip
   Style   "FvwmButtons"   NoTitle, Sticky, WindowListSkip
   Style   "FvwmBanner"    NoTitle, Sticky, StaysOnTop, WindowListSkip
   Style   "IconManModule" NoTitle, Sticky, NoHandles, Icon toolbox.xpm
   Style   "jpilot"        StartIconic

FvwmIdent identifies the icon as
   Name: 	J-Pilot 0.99.6
   Icon Name:	J-Pilot
   Class:	Jpilot
   Resource:	jpilot

so I've tried swallowing all 4 names to no avail.  Can anybody head me in the
right direction?

--
 Randy    ([email-masked])  715-726-2832          <*>

 The Penguin Cometh
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Thu, 13 May 2004 19:29:24 +1000

>    *FvwmButtons: (Swallow "JPilot" 'Exec jpilot -name "jpilot" -geometry +0+0 -padding 1 -bg grey67 &')

This works for me:

*FvwmButtons(Swallow jpilot "Exec jpilot")

What version of FVWM are you using?

SCoTT. :)

---

From: Randy Schultz <[email-masked]>
Date: Thu, 13 May 2004 07:48:39 -0500 (CDT)

On Thu, 13 May 2004, Scott Smedley wrote:

-}>    *FvwmButtons: (Swallow "JPilot" 'Exec jpilot -name "jpilot" -geometry +0+0 -padding 1 -bg grey67 &')
-}
-}This works for me:
-}
-}*FvwmButtons(Swallow jpilot "Exec jpilot")
-}
-}What version of FVWM are you using?

2.5.7.

Yeah, I guess I left some things unsaid.  Jpilot gets swallowed if I don't
start it iconic but of course then the icon box is fairly hosed since the
full-sized app is jammed inside it.

 The Penguin Cometh

---

From: Phil Stracchino <[email-masked]>
Date: Thu, 13 May 2004 15:56:12 -0400

> so I've tried swallowing all 4 names to no avail.  Can anybody head me in the

Have you tried "Jpilot" instead of "JPilot"?

-- 
 .*********  Fight Back!  It may not be just YOUR life at risk.  *********.
 : phil stracchino : unix ronin : renaissance man : mystic zen biker geek :
 :  [email-masked][email-masked][email-masked]  :
 :   2000 CBR929RR, 1991 VFR750F3 (foully murdered), 1986 VF500F (sold)   :
 :    Linux Now!   ...Because friends don't let friends use Microsoft.    :
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Randy Schultz <[email-masked]>
Date: Thu, 13 May 2004 15:15:03 -0500 (CDT)

On Thu, 13 May 2004, Phil Stracchino wrote:

-}> 
-}> I've been trying unsuccessfully to get fvwm 2.5.7 to swallow jpilot on startup.
-}> The icon just lands on the desktop.  I've tried various names in the
-}> .fvwm2rc, e.g.
-}>    *FvwmButtonsColumns     1
-}>    *FvwmButtons (1x1 Frame 0 Swallow(UseOld) "FvwmPager" "Module FvwmPager 0 0")
-}>    *FvwmButtons: (Swallow FvwmXclock 'Exec xclock -name "FvwmXclock" -geometry +0+0 -padding 1 -bg grey67 &')
-}>    *FvwmButtons: (Swallow "JPilot" 'Exec jpilot -name "jpilot" -geometry +0+0 -padding 1 -bg grey67 &')
-}> 
-}>    BorderStyle Inactive -- HiddenHandles NoInset
-}>    Style   "*"     SloppyFocus
-}>    Style   "*"     DecorateTransient
-}>    Style   "*"     StickyIcon
-}>    Style   "*"     SmartPlacement, RandomPlacement
-}>    Style   "*"     MinOverlapPlacement
-}>    Style   "FvwmWinList"   NoTitle, WindowListSkip
-}>    Style   "FvwmButtons"   NoTitle, Sticky, WindowListSkip
-}>    Style   "FvwmBanner"    NoTitle, Sticky, StaysOnTop, WindowListSkip
-}>    Style   "IconManModule" NoTitle, Sticky, NoHandles, Icon toolbox.xpm
-}>    Style   "jpilot"        StartIconic
-}> 
-}> 
-}> FvwmIdent identifies the icon as
-}>    Name: 	J-Pilot 0.99.6
-}>    Icon Name:	J-Pilot
-}>    Class:	Jpilot
-}>    Resource:	jpilot
-}> 
-}> so I've tried swallowing all 4 names to no avail.  Can anybody head me in the
-}> right direction?
-}
-}Have you tried "Jpilot" instead of "JPilot"?

Yes.  I've tried all 4 of the names I've listed - the "name", the icon name,
the class and the resource.  The space is made in the iconbox for the app
but the app never shows up in the box, it merely iconifies on the desktop.

 The Penguin Cometh