Subject: FVWM: Cannot open display

From: Paulo Góes <[email-masked]>
Date: Fri, 7 May 2004 13:04:46 -0700 (PDT)

I have downloaded the fvwm fonts, compiled them and installed successfully. When I try running it, as root, at the command line the following message is shown:

Cannot open display my_machine_IP:0

The fvwm-config --supports command produces the output

gnome-hints
gtk
gdk-imlib
readline
shape
sm
xinerama
xpm

The fvwm-config --info command produces the output

Package: fvwm
Version: 2.4.18

Instalation options:
	prefix: /usr/local
	exec-prefix: /usr/local
	bindir: /usr/local/bin
	datadir: /usr/local/share
	libexecdir: /usr/local/libexec
	sysconfdir: /usr/local/etc
	mandir: /usr/local/man

Compiled-in paths:
	Module directory: /usr/local/libexec/fvwm/2.4.18
	Data directory: /usr/local/share/fvwm
	Default ImagePath: /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
	Default UserDir: $HOME/.fvwm

Support for features:
	gnome-hints (window manager hints): yes
	gtk (FvwmGtk): yes
	gdk-imlib (in FvwmGtk): yes
	gnome-libs (in FvwmGtk): no
	multibyte: no
	readline: yes
	rplay: no
	shape (shaped windows): yes
	sm (session management): yes
	stroke: no
	xinerama: yes
	xpm: yes

Any help will be welcome

Thanks in advance
Paulo

_____________________________________________________________
Thank you for choosing LinuxQuestions.
http://www.linuxquestions.org
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Sat, 8 May 2004 14:51:42 +1000

> Cannot open display my_machine_IP:0

This sounds like a simple X problem.

What is your $DISPLAY environment variable set to?

Try:

export DISPLAY=:0

or

setenv DISPLAY :0

(depending on your shell)

Then:

fvwm2

If that doesn't work, tell us the output of the 'fvwm2' command.

SCoTT. :)