Subject: FVWM: Referencing windows

From: "Ryan Daly" <[email-masked]>
Date: Wed, 19 May 2004 13:59:12 -0400 (EDT)

All,

Is there a way to reference a window by something other than it's name? 
Like a window class or something?

I'd like to force my icons of a certain class to minimize to a certain
location on my desktop...

Thanks.
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Ryan Daly" <[email-masked]>
Date: Wed, 19 May 2004 14:07:12 -0400 (EDT)

Thomas Adam said:
>  --- Ryan Daly <[email-masked]> wrote:
>
> Window's are matched by:
>
> Reference
> Class
> Title
>
> So you should use one of them instead.

So what would a Style line referencing a window by one of these look like?

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 May 2004 18:13:46 +0000

> location on my desktop...

Yes, you may reference a window by either window name, class or resource
in Style or conditional commands.

It is also possible to refer to a window by its id in WindowId
conditional (as well as to change the style using WindowStyle command
in 2.5.x).

Regards,
Mikhael.

---

From: "Ryan Daly" <[email-masked]>
Date: Wed, 19 May 2004 16:33:32 -0400 (EDT)

> conditional (as well as to change the style using WindowStyle command

Great.  Is there an easy way to add style-like options based on WindowId?

I tried...

Style "0x1a00003" CascadePlacement

...with no luck.

Thanks.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 May 2004 23:13:36 +0000

> Style "0x1a00003" CascadePlacement

First, CascadePlacement works for new windows, it makes no much sense to
change the placement policy of existing windows. Such change affects one
PlaceAgain command. Is this what you need?

Second, if you reread what I said, Style does not work with ids; WindowId
and WindowStyle do. Please refer to the man page. It is:

  WindowId 0x1a00003 WindowStyle CascadePlacement

However you normally never need to use WindowId directly (unless you
restore previously stored id), you need one or another conditional
command producing window context, like:

  All ("Mozilla") WindowStyle CascadePlacement

But again, CascadePlacement option is not something you want to configure
this way, you probably just want:

  Style "Mozilla" CascadePlacement

Regards,
Mikhael.