Subject: FVWM: Can FvwmButtons do this?

From: [email-masked]
Date: Mon, 17 May 2004 18:26:38 +0800

Hi everyone,

I wanna use FvwmButtons to popup root menu this way:
When I push the button, pop up menu.
And the button stay pushed until the menu pop down.

Here is my config:
*FvwmButtons: (2x1 Frame 1 Padding 2 0 Title(side) "Start " ,Left, Icon \
linux.png, Action(Mouse 1) 'Menu RootMenu Rectangle +$left+$top 0 -100m')

Any ideas?

BTW: I use fvwm-snap-20040516.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 May 2004 14:00:34 +0000

> BTW: I use fvwm-snap-20040516.

Please, add commas, make the life of everyone (including yourself) easier.

  *FvwmButtons: (2x1, Frame 1, Padding 2 0, Title(side) "Start ", ...)

Searching for "popup" in FvwmButtons man page returns the answer.

In the example above, you may just replace "Menu" with "Popup" and
it will work as in fvwm itself, or you may add ", ActionOnPress" to
get an alternative behaviour.

Regards,
Mikhael.