Subject: Re: FVWM: Usage of FvwmEvent.

From: [email-masked]
Date: Wed, 19 May 2004 20:18:44 +0200

Mikhael Goikhman wrote:
> On 19 May 2004 16:15:56 +0200, ddtl wrote:
> 
>>>What is your fvwm version and full FvwmEvent config?
>>
>>I use fvwm 2.5.10 (from Debian unstable), .fvwm2rc is at
>>the end of the post (without menu definitions & key bindings,
>>as they are not important)
> 
> 
> I can't reproduce any problem, both "map" and "add_window" work for me.
> 

Did you use the same configuration for FvwmEvent as I did, i.e.
(changed add-window to add_window here):

-----------------------------------------
DestroyModuleConfig FvwmEvent*
*FvwmEvent: add_window Maximize

DestroyFunc StartFunction
AddToFunc StartFunction I FvwmEvent
-----------------------------------------

If yes, then maybe it is a problem with Debian's package and I will
try to ask some Debian users who use the same version to check whether
they encounter the same problem using those options...

> Maybe you had a copy/paste problem. Try to copy line by line
> (without leading spaces and trailing end of lines) into FvwmConsole.
> Remove "AddToFunc StartFunction I " bit if you paste into FvwmConsole.
> 

Did it, but still, no luck :(.

ddtl.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 19 May 2004 17:48:24 +0000

On 19 May 2004 20:18:44 +0200, [email-masked] wrote:
> Did you use the same configuration for FvwmEvent as I did
> 

Yes, I did. Copy-paste the following lines into FvwmConsole. They should
work for 2.5.10. I don't think Debian package may somehow break this.

KillModule FvwmEvent
FvwmEvent

Is it possible you just destroy StartFunction later in your config?
Are you sure you don't run an incorrect fvwm executable?

Regards,
Mikhael.