Subject: Re: FVWM: How do I make this (transparent menu's and thumbnailicons)?

From: "Berry Bakker" <[email-masked]>
Date: Sun, 23 May 2004 12:03:32 +0200

> Am Freitag, 21. Mai 2004 18:52 schrieben Sie:
> > Hello,
> >
> > How do I make something like this:
> >
http://www.fvwm.org/screenshots/desktops/Nuno_Alexandre-1600x1200/screensho
> >t jpg
> >
> > I REALY like the icons with the thumbnails of the windows in it, how to
do
> > this?
> I copied this from Tavis Ormandy:
>
> #####
> # Name:     Thumbnail
> # Purpose:  Iconify a window with a reduced screenshot of the application
> #           Window, looks really cool.
> #
> #           Uses FvwmEvent to remove the Icon when deiconified, you will
want
> #           to remove this if you use WindowStyle elsewhere.
> #
> #           Thumbnailing example:
[6]http://dev.gentoo.org/~taviso/step2.png
> #
> ##################
>
> SetEnv fvwm_icon_size 64
>
> DestroyFunc Thumbnail
> AddToFunc Thumbnail
> + I Raise
> + I PipeRead "xwd -silent -id $[w.id] | convert -scale $[fvwm_icon_size]
> -frame 1x1 \
>     -mattecolor black -quality 0 xwd:-
png:$[HOME]/.fvwm/icon.tmp.$[w.id].png
> \
>     && echo WindowStyle IconOverride, Icon
$[HOME]/.fvwm/icon.tmp.$[w.id].png,
> \
>     StaysOnBottom || echo Nop"
> + I Iconify
>

The output off xwd is piped to 'convert'... Which application is meant by
that? Where can I download it?

Regards,
Berry

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 23 May 2004 12:17:12 -0400

> > I copied this from Tavis Ormandy:
...
> that? Where can I download it?

Convert is part of ImageMagick.

-- 
Dan Espen                           E-mail: [email-masked]