Subject: Re: FVWM: cycling/arranging/moving windows

From: Johan Svedberg <[email-masked]>
Date: Tue, 11 May 2004 15:32:22 +0200

* May 11 14:08 Sharon, Ari <[email-masked]>:
> However, neither of the solutions proposed worked on my 2.4 version.
>
> johan's solutions yields: Unknown option - CurrentAtEnd While

Yes. You will atleast need version 2.5.[don't remember exactly, better
get 10] for that to work.

[...]

-- 
Johan Svedberg, [email-masked], http://johan.svedberg.pp.se/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Sharon, Ari" <[email-masked]>
Date: Tue, 11 May 2004 15:06:50 +0300

Thanks you all for your help !

johan's solutions yields: Unknown option - CurrentAtEnd
While Nicholas's alt-tab section gave me a very strange windows scroll
order.

As for the FvwmArrange - didn't find there any explicit support for
arranging only some (selected) windows from the desktop.

Will be happy to get more suggestions !  

Ari

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Johan Svedberg
Sent: Tuesday, May 11, 2004 11:56 AM
To: [email-masked]
Subject: Re: FVWM: cycling/arranging/moving windows

* May 10 16:29 Sharon, Ari <[email-masked]>:

[...]

> 1. What is the best way to achieve Windows like alt-tab behavior
> (CirculateUp/Next/WindowList) ?

Try this:

    Key Tab    A M  WindowList Root c c CurrentDesk, NoGeometry,
CurrentAtEnd, IconifiedAtEnd

> 2. How can I get WindowMaker-like 'move to' feature : moving window to
> certain desk ? (Dragging windows on the pager is an unsatisfying
> compromise)

Being a big fan of the keyboard, this is how I move my windows between
Pages (MoveToDesk might suite you better:

    Key F1     A S  MoveToPage 0 0
    Key F2     A S  MoveToPage 1 0
    Key F3     A S  MoveToPage 2 0
    Key F4     A S  MoveToPage 3 0
    Key F5     A S  MoveToPage 4 0
    Key F6     A S  MoveToPage 5 0

[...]

---

From: Xavier Maillard <[email-masked]>
Date: Wed, 12 May 2004 00:47:13 +0200

> While Nicholas's alt-tab section gave me a very strange windows scroll

I just love  Nicholas's alt-tab ! This is definitely  neat, I adopt that
behavior.

> Will be happy to get more suggestions !  

Upgrade to the devel version ? :)

P.S: do not CC me please !
-- 
.o.                     | zedek (at) gnu-rox.org
..o Hacker Wonderland   | 
ooo                     |