Subject: Re: FVWM: Changing the button after a window was maximized

From: [email-masked] (Marc Schlienger)
Date: Tue, 18 May 2004 12:13:40 +0200

Am Montag, 17. Mai 2004 14:30 schrieb [email-masked]:
> In your mail:
> >From: [email-masked] (Marc Schlienger)
> >Reply-To:
> >To: [email-masked]
> >Subject: FVWM: Changing the button after a window was maximized
> >
> >Hi all,
> >
> > I'm using Fvwm 2.5.9. I just want to change the button look after
> > maximizing the window. I've read the FAQ and the manpages but I haven't
> > found the answer. Any ideas?
> >
> > Marc
>
> Here is a sample:
>
> AddButtonStyle 4 ActiveUp Pixmap unmaximize_activeup.png
> AddButtonStyle 4 ActiveDown Pixmap unmaximize_activedown.png
> AddButtonStyle 4 Inactive Pixmap unmaximize_inactive.png
> AddButtonStyle 4 ToggledActiveUp Pixmap maximize_activeup.png
> AddButtonStyle 4 ToggledActiveDown Pixmap maximize_activedown.png
> AddButtonStyle 4 ToggledInactive Pixmap maximize_inactive.png
> ButtonStyle 4 - MwmDecorMax
My configuration is:

DetroyDecor DefaultDecor

AddToDecor DefaultDecor
+ TitleStyle LeftJustified
+ TitleStyle --Raised
+ AddButtonStyle 2 Vector 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 \
			     60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 \
			     20x70@0 40x50@1 20x30@0 20x20@1 
+ AddButtonStyle 4 Inactive	     Vector 4 50x24@1 75x74@0 25x74@0 50x24@1
+ AddButtonStyle 4 ActiveUp	     Vector 4 50x24@1 75x74@0 25x74@0 50x24@1
+ AddButtonStyle 4 ActiveDown	     Vector 4 50x24@1 75x74@0 25x74@0 50x24@1
+ AddButtonStyle 4 ToggledInactive   Vector 4 50x74@1 75x24@0 25x24@1 50x74@1
+ AddButtonStyle 4 ToggledActiveUp   Vector 4 50x74@1 75x24@0 25x24@1 50x74@1
+ AddButtonStyle 4 ToggledActiveDown Vector 4 50x74@1 75x24@0 25x24@1 50x74@1
+ AddButtonStyle 6 Vector 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
+ AddButtonStyle 3 Vector 8 35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 
75x15@0 35x15@1
+ ButtonStyle 4 - MwmDecorMax

Since I added "Style * MwmButtons" all works fine except that the state of 
button 2 changes from raised to sunken when button 4 is pushed.
Why? Any ideas?

Marc
 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 May 2004 10:58:45 +0000

> button 2 changes from raised to sunken when button 4 is pushed.

If you use Windows-like buttons, then redefine button hints:

     ButtonStyle 1 - MwmDecorMenu
     ButtonStyle 6 - MwmDecorMin
     ButtonStyle 4 - MwmDecorMax

This is copied from FAQ, as part of another question, but this probably
deserves its own question.

Regards,
Mikhael.

---

From: [email-masked] (Marc Schlienger)
Date: Tue, 18 May 2004 13:30:11 +0200

Am Dienstag, 18. Mai 2004 12:58 schrieb Mikhael Goikhman:
> > Since I added "Style * MwmButtons" all works fine except that the state
> > of button 2 changes from raised to sunken when button 4 is pushed.
> > Why? Any ideas?
>

I already tried this. It doesn't change anything!

> deserves its own question.

Thanks.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 May 2004 11:51:10 +0000

> I already tried this. It doesn't change anything!

Yes, you also need this line:

  ButtonStyle 2 - Clear

I will rework FAQ here.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 18 May 2004 13:39:30 +0200

> I already tried this. It doesn't change anything!

Do you have "Style * MwmButtons" somewhere?

Regards, Olivier

---

From: [email-masked] (Marc Schlienger)
Date: Wed, 19 May 2004 08:09:55 +0200

Am Dienstag, 18. Mai 2004 13:51 schrieb Mikhael Goikhman:
> > > > Since I added "Style * MwmButtons" all works fine except that the
> > > > state of button 2 changes from raised to sunken when button 4 is
> > > > pushed. Why? Any ideas?
> > >

That' s it! Thanks.