Subject: FVWM: How to make 2.5.10 center all new windows (with some exceptions)?

From: Francis Litterio <[email-masked]>
Date: Sun, 16 May 2004 10:35:50 -0400

Is there a way to tell FVWM 2.5.10 to center all newly created windows
(with some exceptions based on the window name)?

Right now, I'm using FvwmEvent's add_window command to do it, but the
window is created first then moved, which looks crappy.  Here's what I'm
doing now, which works but makes windows jump around when they are first
created:

	AddToFunc StartFunction
	+ I Module FvwmEvent

	*FvwmEvent: StartDelay 5
	*FvwmEvent: Cmd
	*FvwmEvent: add_window "Function MyPositionWindow"

	AddToFunc MyPositionWindow
	+ I ThisWindow ("Emacs") Nop
	+ I TestRc (Match) Break
	+ I ThisWindow ("XTerm") Nop
	+ I TestRc (Match) Break
	+ I ThisWindow ("Download:Manager") Move 0 0
	+ I TestRc (Match) Break
	+ I ThisWindow ("asclock") Move -0p -0p
	+ I TestRc (Match) Break
	+ I ThisWindow Function MyCenterWindow     # Center all others by default

Is there a way to do this that prevents windows from being moved after
they are created?
--
Francis Litterio
[email-masked]
http://world.std.com/~franl/
GPG and PGP public keys available on keyservers.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 16 May 2004 17:04:55 +0000

On 16 May 2004 10:35:50 -0400, Francis Litterio wrote:
> Right now, I'm using FvwmEvent's add_window command to do it

> Is there a way to do this that prevents windows from being moved after

FvwmEvent or a similar module is the only way to do it currently.

Until we have CenterPlacement policy, or better yet CustomPlacement
policy with some protocol to interact with modules/scripts.

Regards,
Mikhael.