Subject: FVWM: Get FVWM version from module

From: Scott Smedley <[email-masked]>
Date: Sun, 9 May 2004 01:56:58 +1000

Hi Mikhael,

Is there a way to determine the version of FVWM being used from
within a (Perl) module?

I'd like FvwmTabs to determine if the updated WindowList tracker
is available.

SCoTT. :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Michael A. Plikk" <[email-masked]>
Date: Sun, 9 May 2004 00:32:50 +0000

> Is there a way to determine the version of FVWM being used from

If nothing else you can run 'fvwm -V' and grab the version number using regexp

-- 
Michael A. Plikk
"There are 10 kinds of people; those who know binary,
those who don't and those who start counting at zero"
:: www.golden-ratio.net ::

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 8 May 2004 22:27:17 +0000

> I'd like FvwmTabs to determine if the updated WindowList tracker

Yes, $module->version.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 8 May 2004 22:35:06 +0000

> If nothing else you can run 'fvwm -V' and grab the version number using

No, if nothing else, 'fvwm-config --version' should be used without
regexp. This is the only guaranteed-format string. Or $[version.num].

Regards,
Mikhael.