Subject: FVWM: limitation in DynamicPopupAction?

From: Chris Rouch <[email-masked]>
Date: Mon, 17 May 2004 15:33:36 +0200

Is there a limit of one DynamicPopupAction per menu? I tried using two
and it seems that the second one effectively deletes the first one. 

As an example I have two simple scripts

% showrecent
DestroyMenu recreate "Recent"
AddToMenu "Recent" "Recent Applications" Title

% showrecentdocs
DestroyMenu recreate "EmacsDocs"  
AddToMenu "EmacsDocs" "Emacs Documents%emacs.png%" Title

(not useful, but enough to see if it will work)

The menu is defined as :
AddToMenu   Applications
+ "Applications%package_applications.png%"        	Title
+ "Most Recent &Documents...%emacs.png%"        	Popup EmacsDocs
+ DynamicPopupAction Piperead showrecentdocs
+ "&Most Recent...%package_applications.png%"         	Popup Recent
+ DynamicPopupAction Piperead showrecent

In this case I see all the menu options, but only the second one pops
up. If I reverse the order, then the other one pops up instead.

Is this a limitation or am I doing something stupid?

Regards,

Chris

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 May 2004 14:02:19 +0000

> and it seems that the second one effectively deletes the first one. 

Yes, there is one DynamicPopupAction per menu.

Just create 2 submenus and define DynamicPopupAction for each one.

Regards,
Mikhael.