Subject: Re: FVWM: Cannot open display

From: Paulo Góes <[email-masked]>
Date: Mon, 10 May 2004 07:51:22 -0700 (PDT)

Hi Scott. Thanks for your help but the situation seems to be the  same. Bellow is the fvwm command's output after applying your suggestion

[FVWM][main]: can't open display :0

I also believe this is a X problem. In fact, my intention is to implement a kiosk as explained in http://www.tldp.org/HOWTO/Kiosk-HOWTO.html, which requires fvwm installation. I'm afraid my options are reaching zero in case fvwm doesn't work. Do you know about another way to accomplish the task.

Thanks in advance
Paulo

--- Scott Smedley <[email-masked]> wrote:
> Cannot open display my_machine_IP:0

This sounds like a simple X problem.

What is your $DISPLAY environment variable set to?

Try:

export DISPLAY=:0

or

setenv DISPLAY :0

(depending on your shell)

Then:

fvwm2

If that doesn't work, tell us the output of the 'fvwm2' command.

SCoTT. :)

_____________________________________________________________
Thank you for choosing LinuxQuestions.
http://www.linuxquestions.org
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 10 May 2004 16:00:47 +0100 (BST)

--- Paulo GÃ³es <[email-masked]> wrote: 

> Hi Scott. Thanks for your help but the situation seems to be the  same.
> Bellow is the fvwm command's output after applying your suggestion
> 

Scott's instructions were accurate only in part. But then, you're not
exactly giving us enough information to work with either. The error
message that I have quoted above means that either you have X already
running (and you're trying to run fvwm *NOT* as the user that invoked X11)
or you have some other issue (such as incorrect settings on /tmp).

So, let's assume the former case. If you *do* have X11 running, and you
are trying to launch X11 applications from another user, then do:

export DISPLAY=:0 
xauth merge ~user/.Xauthority

whereby "~user" is the name of the user that already has X11 running. Of
course, that user won't be root because you wouldn't be a foolish as that;
I hope. :)

As for the /tmp settings, ensure they are:

chmod 777 /tmp

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

____________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].