Subject: Re: FVWM: numeric keypad as pointing device.

From: Nicholas Paul Johnson <[email-masked]>
Date: Sun, 16 May 2004 12:10:31 -0400 (EDT)

On Sun, 16 May 2004, Tavis Ormandy wrote:
> 
> Do you know about X11 Mouse Keys? It's an accessibility feature for users
> that have difficulty using a mouse that sounds similar to what you want
> without any need to create bindings, try pressing Shift+Alt+Num_Lock.
>
Wow.  That is Perfect. 
 
> 
> No..I Think he wants to use Num-Lock as a modifier, not totally kill it :)
> 
> You can just add a binding for when Num-Lock is in use.
> 
> Key Tab A M     Blah
> Key Tab A M2    Blah
> 
Again, perfect.

Thank you very much :)
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  Nicholas Paul Johnson
  o nickjohnson \at\ virginia \dot\ edu
  o 3ebf10a7 subkeys.pgp.net
  o http://manjac.ath.cx/nick
  o "When all you've got is a hammer,
    everything looks like a nail.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Sun, 16 May 2004 11:56:06 +0100

--On Sunday, May 16, 2004 11:16:40 +0100 Thomas Adam
<[email-masked]> wrote:

>  --- Nicholas Paul Johnson <[email-masked]> wrote: 
> 
>> 	Whenever NumLock is off, and I push 1,2,3,4,6,7,8, or 9 I would
>> 	like the mouse cursor to be moved in the coresponding direction.  
>> 	If NumLock is off and I push 5, I would like the same behaviour as
>> 	if I had pushed the left mouse button.

> That's possible. Just bind your keypad key's to mouse movements (example
> of this is in  the ~/.fvwm/fvwm2rc file distributed with fvwm

Yes, but not if he uses the IgnoreModifiers command you used below. The
FakeClick command can be used to simulate mouse clicks.

>> 
>> 2. Also, I trigger alt-tab events like this:
>> 
>> 	Key Tab A M     Function Cycle
>> 
>> Which works when NumLock is off.  How do I make it also work when
>> NumLock 
>> is on?
> 
> You can only do this if you have:
> 
> IgnoreModifiers L25

Key Tab A M     Blah
Key Tab A M2    Blah

Also, L25 also disables scroll-lock (according to the man page you should
disable as few modifiers as possible).

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------