Subject: FVWM: creating a fvwm2rc...

From: "Miguel Carmona Bermúdez" <[email-masked]>
Date: Fri, 07 May 2004 20:27:13 +0000

hi!, i am Miguel,
first: congratulations! fvwm is the best.

i'm designing a visual program to create fvwm2rc files.
i'd like to get (very) complex fvwm2rc files. Mi fvwm2rc have 
600 lines with a few menus, but i think it isn't complex file but
it hasn't script code.
any suggestion is wellcome. 
the program is in the first stage. i think that the program must be easy
to configure but you must have the complex side to do other advance
things.
thanks!

PD: i'm sorry. my written english is bad.

best regards,

--
 miguel

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Parv <[email-masked]>
Date: Fri, 7 May 2004 19:06:49 -0400

in message <[email-masked]>,
wrote Miguel Carmona Bermúdez thusly...
>
> i'm designing a visual program to create fvwm2rc files.  i'd like
> to get (very) complex fvwm2rc files. Mi fvwm2rc have 600 lines
> with a few menus, but i think it isn't complex file but it hasn't
> script code.

I take it you want examples of complex fvwm configurations.

Do the following files, under "Current Settings", meet your
definition of complex?

  http://parv.holy.cow/parv/comp/unix/cf/fvwm/

...the actual configuration is divided over 4-6 files, not counting
external programs that create menus/key bindings.

  - Parv

--

---

From: "Miguel Carmona Bermúdez" <[email-masked]>
Date: Sat, 08 May 2004 09:16:48 +0000

thanks! but parv.holy.cow could not be found.

regards,
--
 miguel

---

From: Parv <[email-masked]>
Date: Sat, 8 May 2004 03:31:23 -0400

in message <[email-masked]>,
wrote Miguel Carmona Bermúdez thusly...
> thanks! but parv.holy.cow could not be found.

Oh forgot about that, sorry.  See if /this/ is any useful...

  http://www103.pair.com/parv/comp/unix/cf/fvwm/

  - Parv

--

---

From: "Miguel Carmona Bermúdez" <[email-masked]>
Date: Sat, 08 May 2004 13:34:49 +0000

hello,

please,why is it different?
example:
	MwmDecor / NoDecorHint why? it's better DecorHint / !DecorHint, isn't
it?
 	OldDecor / NoOldDecor why? it's better OldDecor / !OldDecor, isn't it?
...
when i'm reading my fvwm, it's difficult to find errors
example fvwm2rc:
...
style * MwmDecor
...
...
...
style * NoDecorHint
...

ok it is only a example, but i want a MwmDecor style and it isn't like i
hope. i have to find this style option in fvwm man page and i have to
remember a lot of words... this is only a simple idea.

i'm translating into "human readable" language the fvwm style options
(and menustyle)

i think that there iare two principal sections y my program, a style
editor and menustyle editor... and a general option section too, and
more ...

regards,

--
 miguel