Subject: FVWM: the use of DesktopName

From: Joolz <[email-masked]>
Date: Sat, 22 May 2004 22:26:16 +0200

Hi everyone,

I'm experimenting a bit and gave some names to my desktops, like this:

DesktopName 0 log
DesktopName 1 brow

Now I can display these names, but can I do anything else with them?
Something like "Key 1 A MC GotoDesk 0 log" doesn't work...

TIA

-- 
22:23-22:26
Fedora Core release 2 (Tettnang) Linux 2.6.5-1.358
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 22 May 2004 21:13:44 +0000

> Now I can display these names, but can I do anything else with them?

These are desk labels, not alternative ids. Some modules use these labels.

> Something like "Key 1 A MC GotoDesk 0 log" doesn't work...

You can't have a number-by-name lookup (the names may even not be
unique), but you may have a name-by-number lookup. Try this, for example:

  AddToMenu SwitchDesk
  + "Goto desk $[desk.name0]" GotoDesk 0
  + "Goto desk $[desk.name1]" GotoDesk 1
  + "Goto desk $[desk.name2]" GotoDesk 2
  + "Goto desk $[desk.name3]" GotoDesk 3

Regards,
Mikhael.