Subject: FVWM: numeric keypad as pointing device.

From: Nicholas Paul Johnson <[email-masked]>
Date: Sun, 16 May 2004 02:40:35 -0400 (EDT)

Hey,

Two questions,

1. Does anyone know how to do the following:

	Whenever NumLock is off, and I push 1,2,3,4,6,7,8, or 9 I would
	like the mouse cursor to be moved in the coresponding direction.  
	If NumLock is off and I push 5, I would like the same behaviour as
	if I had pushed the left mouse button.

2. Also, I trigger alt-tab events like this:

	Key Tab A M     Function Cycle

Which works when NumLock is off.  How do I make it also work when NumLock 
is on?

w00t,
- -- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  Nicholas Paul Johnson
  o nickjohnson \at\ virginia \dot\ edu
  o 3ebf10a7 subkeys.pgp.net
  o http://manjac.ath.cx/nick
  o "When all you've got is a hammer,
    everything looks like a nail.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Sun, 16 May 2004 11:16:40 +0100 (BST)

> 	if I had pushed the left mouse button.

That's possible. Just bind your keypad key's to mouse movements (example
of this is in  the ~/.fvwm/fvwm2rc file distributed with fvwm
 
> Which works when NumLock is off.  How do I make it also work when

You can only do this if you have:

IgnoreModifiers L25

in your config file, but then this makes no odds either way with the
numlock key. You might also want to see the Fvwm FAQ 0.1 :)

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

____________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 16 May 2004 11:05:06 +0000

> 	if I had pushed the left mouse button.

I believe on most XFree86 systems this keypad-emulates-pointer extension
is loaded and you may activate/disactivate it by pressing Shift-NumLock.
Try it, should work exactly like you want without any action from fvwm.

> Which works when NumLock is off.  How do I make it also work when NumLock 

One of the solution is to add this line:

  Key Tab A M2  WindowList Root c c     # or: Function Cycle

Regards,
Mikhael.