Subject: FVWM: cycling/arranging/moving windows

From: "Sharon, Ari" <[email-masked]>
Date: Mon, 10 May 2004 17:25:37 +0300

Hi,

I migrated recently from CTWM/Window-Maker to FVWM 2.4.3. I am 
overall satisfied, but still trying to get the following behaviour:

1. What is the best way to achieve Windows like alt-tab behavior
(CirculateUp/Next/WindowList) ?

2. How can I get WindowMaker-like 'move to' feature : moving window to
certain desk ?
(Dragging windows on the pager is an unsatisfying compromise) 

3. Is it possible to have auto arrange function that will arrange only
selected items from the WindowList?

Thanks in advance,

Ari

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Xavier Maillard <[email-masked]>
Date: Mon, 10 May 2004 23:29:18 +0200

> Hi,

Yo,
 
> (CirculateUp/Next/WindowList) ?

What do  you mean ? For  each of this, all  is totally up  to the users.
You have several possibilities for each of them.

Actually, you can do Alt-Tab'in just the way you are used to do.

WindowsList is  (for me) bound to  Mouse2 button and a  key binding. You
also can use mouse gestures if you want to (given you have a dynamically
linked agains libstroke FVWM version).

So it is really up to you to choose between all those possibilites. 

FVWM is known to  be really flexible (this is why I  tend to use it more
and more :)).

> (Dragging windows on the pager is an unsatisfying compromise) 

Juste hit  on google for that.  There are gazillons of  examples. Here I
have a menu with different possible windows operations.

> selected items from the WindowList?

I don't understand.

Hope that'll help ;) 

I have to tell I am quite  n00bish at FVWM but everyday I discover a new
cool and neat feature and as a Ion2 user, I am totally amazed by FVWM.

Regards,
-- 
Xavier Maillard
7 rue Jeanne Jugan, 51100 Reims, France
phone: +33 3 26 77 02 21, mobile: +33 6 68 04 64 37
email: [email-masked]

---

From: Nicholas Paul Johnson <[email-masked]>
Date: Mon, 10 May 2004 18:06:21 -0400 (EDT)

> > (Dragging windows on the pager is an unsatisfying compromise) 
If I understand correctly, [2] is asking about a pull down menu with "Move
to page 1", "Move to page 2", ...  If this is correct, then check out my
.fvwm2rc.  Note specifically the alt-tab section and the MoveWindow menu.
	http://manjac.ath.cx/nick/dot_fvwm2rc
 
> > selected items from the WindowList?

You should look at the FvwmRearrange module (I appologize if you already 
have).  I don't know to what degree it allows for selecting only some.

Enjoy,
- -- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
  Nicholas Paul Johnson
  o nickjohnson \at\ virginia \dot\ edu
  o 3ebf10a7 subkeys.pgp.net
  o http://manjac.ath.cx/nick
  o "When all you've got is a hammer,
    everything looks like a nail.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

---

From: Johan Svedberg <[email-masked]>
Date: Tue, 11 May 2004 10:55:32 +0200

* May 10 16:29 Sharon, Ari <[email-masked]>:

[...]

> (CirculateUp/Next/WindowList) ?

Try this:

    Key Tab    A M  WindowList Root c c CurrentDesk, NoGeometry, CurrentAtEnd, IconifiedAtEnd

> certain desk ? (Dragging windows on the pager is an unsatisfying
> compromise)

Being a big fan of the keyboard, this is how I move my windows between
Pages (MoveToDesk might suite you better:

    Key F1     A S  MoveToPage 0 0
    Key F2     A S  MoveToPage 1 0
    Key F3     A S  MoveToPage 2 0
    Key F4     A S  MoveToPage 3 0
    Key F5     A S  MoveToPage 4 0
    Key F6     A S  MoveToPage 5 0

[...]

-- 
Johan Svedberg, [email-masked], http://johan.svedberg.pp.se/

---

From: stu <[email-masked]>
Date: Tue, 11 May 2004 18:56:09 +0200

On Mon, 10 May 2004 17:25:37 +0300
"Sharon, Ari" <[email-masked]> wrote:

> 
> Hi,
> 
> I migrated recently from CTWM/Window-Maker to FVWM 2.4.3. 
> I am overall satisfied, but still trying to get the following
> behaviour:
> 

This is from IIRC an old default fvwm2rc :

# Circulate focus
Key   Tab       A    M      Next [CurrentPage !iconic] focus-and-raise
Key   Tab       A    MS     Prev [CurrentPage !iconic] focus-and-raise
Key   Tab       A    CM     Next [CurrentPage] deiconify-and-focus
Key   Tab       A    CMS    Prev [CurrentPage] deiconify-and-focus

I still use it in mine, though it can be unpredictable sometimes. It is
by no means completely Windows like.

> Ari

Cheers
- -- 
Stuart Logie
Programmer
   
Powered by Debian GNU/Linux - testing/unstable