Subject: FVWM: Shadow on FvwmButtons

From: Johan Svedberg <[email-masked]>
Date: Wed, 21 Apr 2004 21:32:40 +0200

Hi

I've created a nice white colored bar using FvwmButtons, so I thought a
black shadow would look nice on it. How would I accomplish this? I've
tried:

Colorset 2 Foreground black, Background white, Shadow black
*FvwmButtons: Colorset 2

But that doesn't seem to create a shadow on it?

-- 
Johan Svedberg, [email-masked], http://johan.svedberg.pp.se/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 Apr 2004 23:30:36 +0000

> But that doesn't seem to create a shadow on it?

Works for me as expected. What is your full FvwmButtons configuration?
Do you mean "Hilight black" in the colorset defenition too?

Regards,
Mikhael.

---

From: Johan Svedberg <[email-masked]>
Date: Fri, 23 Apr 2004 10:48:54 +0200

* Apr 22 01:33 Mikhael Goikhman <[email-masked]>:
> > I've created a nice white colored bar using FvwmButtons, so I
> > thought a black shadow would look nice on it. How would I accomplish
> > this? I've tried:
> >

I don't see any difference if I add that either. There is a screenshot
at http://johan.svedberg.pp.se/files/tmp/FvwmButtons.png. Strange, I
must be doing something wrong. Here is the full relavent configuration:

Style "FvwmButtons" BorderWidth 0, ClickToFocus, NoHandles, NoTitle, StaysOnTop, Sticky, WindowListSkip

SetEnv FvwmButtonsBorderWidth 0
SetEnv FvwmButtonsHeight      32

PipeRead `printf "SetEnv FvwmButtonsWidth "; expr $[vp.width] - $[FvwmButtonsBorderWidth] - $[FvwmButtonsBorderWidth]`

*FvwmButtons: BoxSize smart
*FvwmButtons: Colorset 2
*FvwmButtons: Columns 4
*FvwmButtons: Font None
*FvwmButtons: Frame 0
*FvwmButtons: Geometry $[FvwmButtonsWidth]x$[FvwmButtonsHeight]+0-0
*FvwmButtons: Padding 0 0
*FvwmButtons: Rows 1
*FvwmButtons: (1x1+0+0, Padding 5 8, Swallow "XClock" 'Exec xclock -bg white -fg black -face "Bitstream Vera Sans:bold:size=8" -digital -strftime "%b %d %R" -padding 0')
*FvwmButtons: (1x1-0+0, Padding 0 3, Swallow "FvwmPager" 'Module FvwmPager')

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 24 Apr 2004 20:56:16 +0000

> must be doing something wrong. Here is the full relavent configuration:

With "Frame 0" there is no 3d relief, so your shadow/hilight colors are
applied to nothing.

Accourding to your screenshot, you may want, instead, to swallow something
(probably another FvwmButtons) and define relief of that swallowed thing.

Regards,
Mikhael.

---

From: Johan Svedberg <[email-masked]>
Date: Sat, 24 Apr 2004 23:29:45 +0200

* Apr 24 22:58 Mikhael Goikhman <[email-masked]>:
> > > > thought a black shadow would look nice on it. How would I
> > > > accomplish this? I've tried:
> > > >
> > > Works for me as expected. What is your full FvwmButtons
> > > configuration? Do you mean "Hilight black" in the colorset
> > > defenition too?
> >
> > I don't see any difference if I add that either. There is a
> > screenshot at http://johan.svedberg.pp.se/files/tmp/FvwmButtons.png.
> > Strange, I must be doing something wrong. Here is the full relavent
> > configuration:
> >
> > *FvwmButtons: Frame 0
>
> With "Frame 0" there is no 3d relief, so your shadow/hilight colors
> are applied to nothing.
>
> Accourding to your screenshot, you may want, instead, to swallow
> something (probably another FvwmButtons) and define relief of that
> swallowed thing.

Ah, yes, that's it. Thank you.