Subject: FVWM: Press the mouse on a button without loosing then move the cursor out of the button,if I can withdraw the action ?

From: xiangbing <[email-masked]>
Date: Sat, 17 Apr 2004 01:32:58 +0800

Hi,all
I sometimes click the close button and suddenly find that I do not really want to close this window.Not loosing the mouse,I move the cursor elsewhere,then loose it.Still,the window closed.
Since my last question seems really foolish,I hope this one not.But If did ,forgive me,please.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 Apr 2004 01:40:49 +0000

On 17 Apr 2004 01:32:58 +0800, xiangbing wrote:
> 
> I sometimes click the close button and suddenly find that I do not
> really want to close this window.Not loosing the mouse,I move the
> cursor elsewhere,then loose it.Still,the window closed.

You may solve this by creating this safety feel (taken from fvwm-themes):

  DestroyFunc DeleteOrDestroy
  AddToFunc   DeleteOrDestroy
  + H Nop
  + M Nop
  + C Delete
  + D Destroy

Then clicking or double clicking close the window. Just holding the mouse
button (with or without moving) does nothing.

Regards,
Mikhael.