Subject: FVWM: Windows key; titlebar buttons

From: Zavie - Julien Guertault <[email-masked]>
Date: Wed, 14 Apr 2004 09:55:05 +0200

Hello,

I'm having some difficulties to make fvwm (2.4.6) do what I want, so
maybe you can help ^_^

As I use it on a PC, I'd like to bind some functions on the famous
windows keys. After testing, it seems it correspond to the modifiers
#4 and #9.
Thus, after having pressed one, everything goes wrong with bindings.
For example emacs starts to make a confusion between Alt (which then
just beeps) and windows (which then acts as the meta key).

How could I do to make it work?

I also have another question about the titlebar buttons...
Is it possible to explicitly disable a button? The purpose is to have
inactive windows buttonless.

Thank you for any help (and for maintaining such a good wm).

Regards,

-- 
							Julien Guertault
		" I just lent you my body, you lent me your dream. "
							(Gattaca, 1997)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 Apr 2004 12:47:06 +0200

> windows keys. After testing, it seems it correspond to the modifiers

There is no modifier "#9" in X.  There are only the modifiers
shift, lock, control, and 1 to 5.

> just beeps) and windows (which then acts as the meta key).

Probably one of the modifiers is locking, which changes the whole
keyboard layout.

> How could I do to make it work?

First, check the output of

  $ xmodmap -pke; xmodmap

None of the modifier keys should appear twice in either list.
Double check that the the target key appears in the modifier list.
if not, add it at the end of your $HOME/.Xmodmap file.  If you do
not have such a file yet, generate it with

  $ xmodmap -pk > "$HOME"/.Xmodmap

Then check the modifiers at the end of the file.  For example, I
have

  clear Shift
  clear Lock
  clear Control
  clear Mod1
  clear Mod2
  clear Mod3
  clear Mod4
  clear Mod5

  add    Shift   = Shift_L Shift_R
  !add    Lock    = Caps_Lock
  add    Control = Control_L Control_R
  !add    Control = Control_L Multi_key
  add    Mod1    = Meta_L
  !add    Mod2    = Num_Lock
  add    Mod3    = Mode_switch
  add    Mod4    = Super_L Super_R
  add    Mod5    = Hyper_R

> inactive windows buttonless.

  Style <windowname> NoButton 7

but that does not differentiate between active and inactive
windows.

Ciao

Dominik ^_^  ^_^

---

From: Zavie - Julien Guertault <[email-masked]>
Date: Mon, 19 Apr 2004 08:43:17 +0200

..Dominik Vogt écrivait un jour :
|
| There is no modifier "#9" in X.  There are only the modifiers
| shift, lock, control, and 1 to 5.

That's what I remember having read in the man, thus I tried up to #10
and some works. Maybe it's not a good idea playing with fire ^_^

| [bindings, xmodmap]

Thanks for all your explanations. The problem it still unsolved, but
as it's definatly not related to fvwm, I'll try to find out by myself.

| > Is it possible to explicitly disable a button? The purpose is to have
| > inactive windows buttonless.
|
|   Style <windowname> NoButton 7
|
| but that does not differentiate between active and inactive
| windows.

The idea was that an inactive window doesn't need buttons, since when
you want to use one, the window becomes active.

May such a behavior be available in a future release?

Regards,

-- 
							Julien Guertault
	" Multiply it by infinity and take it to the depth of forever, and
	  you will still have barely a glimpse of what I'm talking about. "
							(Meet Joe Black, 1998)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].