Subject: FVWM: Mousebinding failed

From: xiangbing <[email-masked]>
Date: Sat, 10 Apr 2004 17:17:56 +0800

Hi,all.
Like everyone do ,I bind some simple Mouse behaviors to Buttons and  Icons in my .fvwm2rc file.Bindings works fine when start fvwm .Though,after about 30 minutes , defined Mouse behaviors worked no more .For examples,I get no responses when I click button 1,2,3...etc .Also no response when I double click the icon .And click mouse two in the root window can not invocate the FvwmWinList as formally did .

I try to find the reasons in file .xsession-errors :
[flamingo@openarch flamingo]$ cat  .xsession-errors |grep FVWM
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
[FVWM][convert_charsets]: WARNING -
No useful details .

I've tried to compile fvwm-2.4.8 and fvwm-2.5.10 by myself but the trouble can not be fixed.And whhen I use fvwm-themes-0.7.0-2,this problem has never occurred .
My Linux box is Redhat9.0(Shrink).fvwm Version 2.5.8-2( rpm package).I attached my .fvwm2rc( really simple ) with this letter .
I have been really bothered by this for months.If anyone can help I would be very appreciated.

----------------------------------------------------
[flamingo@openarch flamingo]$ uname -a
Linux openarch.ddns.neu.edu.cn 2.4.20-8 #1 Thu Mar 13 17:54:28 EST 2003 i686 i686 i386 GNU/Linux
[flamingo@openarch flamingo]$ rpm -q fvwm
fvwm-2.5.8-2

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 10 Apr 2004 08:26:55 -0400

xiangbing <[email-masked]> writes:
> Hi,all.
> Like everyone do ,I bind some simple Mouse behaviors to Buttons and  Icons in
>  my .fvwm2rc file.Bindings works fine when start fvwm .Though,after about 30 
> minutes , defined Mouse behaviors worked no more .For examples,I get no respo
> nses when I click button 1,2,3...etc .Also no response when I double click th
> e icon .And click mouse two in the root window can not invocate the FvwmWinLi
> st as formally did .

Check the FAQ, question 0.1:

http://www.fvwm.org/documentation/faq/

-- 
Dan Espen                           E-mail: [email-masked]