Subject: FVWM: debian

From: "Glaser, Ben I" <[email-masked]>
Date: Fri, 16 Apr 2004 07:57:03 -0700

I'm trying to install on Solaris 8.  I get the following when running a
make.

"make: Fatal error in reader: Makefile, line 333: Badly formed macro
assignment
Current working directory /var/tmp/fvwm-2.5.10/debian
*** Error code 1
make: Fatal error: Command failed for target `install-recursive'

Any ideas?

Ben

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Apr 2004 11:20:37 -0400

> make: Fatal error: Command failed for target `install-recursive'

If you are trying to install from CVS you will need gnumake.
If you are getting these errors from a tar.gz then there is a
problem with the tar.gz.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Athanasius <[email-masked]>
Date: Fri, 16 Apr 2004 16:27:40 +0100

> make: Fatal error: Command failed for target `install-recursive'

  What's line 333 of the Makefile ?  Are you sure you're using GNU make
there ?

-Ath
-- 
- Athanasius = Athanasius(at)miggy.org / http://www.miggy.org/
                  Finger athan(at)fysh.org for PGP key
	   "And it's me who is my enemy. Me who beats me up.
Me who makes the monsters. Me who strips my confidence." Paula Cole - ME
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 Apr 2004 13:36:45 -0400

> make: Fatal error: Command failed for target `install-recursive'

The Makefile in the debian directory is broken.
You can avoid it by changing the Makefile in the top directory.
Remove debian from the list assigned to SUBDIR.

At least these 2 lines in debian/Makefile.am are gnumake only:

arch ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
fullinstdir ?= $(shell cd $(top_srcdir) && pwd)/$(instdir)