Subject: Re: FVWM: Using 'Super_L' as a key modifier

From: stu <[email-masked]>
Date: Thu, 1 Apr 2004 17:59:15 +0200

On Wed, 31 Mar 2004 14:57:18 +0200
Dominik Vogt <[email-masked]> wrote:

> On Wed, Mar 31, 2004 at 02:39:12PM +0200, stu wrote:
> > Is it possible to add a custom key modifier to fvwm(2.5.8)? I want
> > to use Super_L (commonly known as the 'Windows' key - ugh) as a
> > modifier so I can use a key combination like Control-Super_L-Left ie
> > (assuming the 'U' means Super_L) :
> > 
> > Key   Left      A     CU    GotoPage -1p +1p
> > Key   Right     A     CU    GotoPage +1p +1p
> > 
> 
> X defines a mask of eight modifiers (SMC12345 in fvwm).  Which
> keys generate these modifiers depends on your Xmodmap.  To bind
> Super_L to modifier 3 for example, issue
> 
>   $ xmodmap -e "clear Mod3"
>   $ xmodmap -e "add Mod3 = Super_L"
> 
> or put the following at the end of your $HOME/.Xmodmap:
> 
>   clear Mod3
>   add Mod3 = Super_L
> 
> After that, the modifier "3" refers to the Super_L key in fvwm.

Thanks for all the help, everyone. I discovered that on my machine,
Super_L is already bound to mod4 ('xmodmap -pm' revealed). When I
had it bound to mod3 (and then to mod2), still only the mod4 binding
worked. Does the last mod bound to a key get precedence?

Needless to say everything's working now, and I have a new set of
diagonal-up left and right keys!

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable

---

From: Phil Stracchino <[email-masked]>
Date: Thu, 1 Apr 2004 13:01:09 -0500

> worked. Does the last mod bound to a key get precedence?

This turned out to be my problem too.  clear mod4, and suddenly
everything works.

-- 
 .*********  Fight Back!  It may not be just YOUR life at risk.  *********.
 : phil stracchino : unix ronin : renaissance man : mystic zen biker geek :
 :  [email-masked][email-masked][email-masked]  :
 :   2000 CBR929RR, 1991 VFR750F3 (foully murdered), 1986 VF500F (sold)   :
 :    Linux Now!   ...Because friends don't let friends use Microsoft.    :