Subject: FVWM: how to run fvwm AND icewm

From: [email-masked]
Date: Fri, 30 Apr 2004 15:25:35 +0200

hello,

i've tried to run two wm,icewm and fvwm because i need to have the best
from both. icewm is good for the root menu and fvwm for the taskbar. i've
modified my .xinitrc and my .xsession like this :

.xinitrc/.xsession

exec fvwm-themes-start
exec icewm

and viceversa :

.xinitrc/.xsession

exec icewm
exec fvwm-themes-start

but ONLY the first wm start. how can i run both ?

nb : i've disabled the icewm taskbar from the preference file because i
want to use the fvwm taskbar. lemme know 

__________________________________________________________________
Social price: l'ADSL diventa per tutti
Tiscali ADSL Senza Canone 640Kbps: GRATIS fino al 3 maggio costo
di adesione, attivazione e il modem per tutto il 2004. E per i primi 3 mesi,
con il Tiscali social price, navighi a 1,5 euro l'ora! Affrettati!
http://point.tiscali.it/adsl/prodotti/640Kbps/

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Thu, 29 Apr 2004 22:28:55 -0400

On Fri, 30 Apr 2004 15:25:35 +0200
[email-masked] wrote:

> hello,
> 
> i've tried to run two wm,icewm and fvwm because i need to have the
> best from both. icewm is good for the root menu and fvwm for the
> taskbar. i've modified my .xinitrc and my .xsession like this :
> 
> .xinitrc/.xsession
> 
> exec fvwm-themes-start
> exec icewm
> 
> and viceversa :
> 
> .xinitrc/.xsession
> 
> exec icewm
> exec fvwm-themes-start
> 
> nb : i've disabled the icewm taskbar from the preference file because
> i want to use the fvwm taskbar. lemme know 

	You can't run two window managers at the same time under the
same X session.

Cheers,
Bob

---

From: Jonathan Martin <[email-masked]>
Date: Fri, 30 Apr 2004 13:23:39 -0600

On Fri, Apr 30, 2004 at 03:25:35PM +0200, [email-masked] wrote:

<snip>
> but ONLY the first wm start. how can i run both ?

It has nothing to do with the WMs.  .xinitrc and .xsession are usually sh
scripts.  Think about what exec does in sh.  Check the sh man page if
you don't know.

This script will only ever say "hello":

--->
#!/bin/sh
exec echo "hello"
exec echo "goodbye"
<---
-- 
Serve Gonk.
Jon Martin - Undergraduate Labs Systems Administrator (ISG - labadmin)
Department of Computing Science at University of Alberta.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].