Subject: FVWM: Preventing dynamic icons for NoIcon apps

From: Remko Troncon <[email-masked]>
Date: Fri, 2 Apr 2004 11:27:06 +0200

Hi,

I should probably make this a personal question, but since i think a lot
of users use this feature, i thought i'ld ask it publicly. 
When using taviso's rc lines for having dynamic icons for applications
when minimizing (http://dev.gentoo.org/~taviso/screenshot6.png), i would like 
to have that only icons are generated for applications that don't have the
NoIcon windowstyle. Is this possible ?

cheers,
Remko
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Apr 2004 12:02:07 +0200

> NoIcon windowstyle. Is this possible ?

You can make something up using the "State" style.  All windows
for which an icon should be generated have the state set.  You
can then trigger icon generation in a function, e.g.

  Style * state 11
  Style foo !state 11
  addtofunc my_iconify
  + i iconify
  + i thiswindow (State 11) function generate_dynamic_icon
  ...

(the syntax in above example may be wrong, I did not check it).

Ciao

Dominik ^_^  ^_^

---

From: Remko Troncon <[email-masked]>
Date: Fri, 2 Apr 2004 13:16:59 +0200

> can then trigger icon generation in a function, e.g.

Ah, this should indeed do the trick. Only, when i look in the man page,
State can only be used as a command, not as a style ? 

cheers,
Remko

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Apr 2004 14:09:40 +0200

> State can only be used as a command, not as a style ? 

Hm, seems I forgot to code the style part.  I've checked in a
patch to provide the missing feature.

Ciao

Dominik ^_^  ^_^