Subject: FVWM: alt+pageup/down aumix controls in fvwm

From: Nori Heikkinen <[email-masked]>
Date: Wed, 14 Apr 2004 16:20:16 -0400

hi,

A friend of mine recently showed me about the ALT + page-up or
page-down capability to raise or lower the volume by accessing aumix
in WindowMaker.  I'm now trying to implement this on my own system,
but can't figure out the keybindings for it in fvwm.  I've seen this
post:

    http://www.hpc.uh.edu/fvwm/archive/0306/msg00444.html

but (a) I'm not sure what exactly those keybindings do (what's A?
what's N? where are they documented?), and (b) they don't seem to do
what I want.

Anyone got any keybinding for the fvwmrc for this?

Thanks,

</nori>

-- 
    .~.      nori @ sccs.swarthmore.edu
    /V\  http://www.sccs.swarthmore.edu/~nori/jnl/
   // \\          @ maenad.net
  /(   )\       www.maenad.net
   ^`~'^

---

From: stu <[email-masked]>
Date: Thu, 15 Apr 2004 09:49:09 +0200

On Wed, 14 Apr 2004 16:20:16 -0400
Nori Heikkinen <[email-masked]> wrote:

> in WindowMaker.  
> I'm now trying to implement this on my own system,
> but can't figure out the keybindings for it in fvwm.

Start by getting the correct key name for page-up and page-down. Look in

/usr/include/X11/XF86keysym.h
/usr/include/X11/keysymdef.h

Use the name but remove the XK_ prefix (in your fvwm2rc)

> (a) I'm not sure what exactly those keybindings do (what's A?

man fvwm
search for 'Key Keyname Context Modifiers Function'

> Anyone got any keybinding for the fvwmrc for this?

My volume control is bound to 'print screen' and 'pause' ala

Key   Print     A     N     Exec exec aumix -v -5
Key   Pause     A     N     Exec exec aumix -v +5

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable

---

From: Nori Heikkinen <[email-masked]>
Date: Thu, 15 Apr 2004 13:34:55 -0400

> /usr/include/X11/keysymdef.h

great.  i found these by a more careful reading of the manpage, but
they're buried in there!  i've been skimming that manpages every now
and then for months, and never found them :-P

> > what's N? where are they documented?), and (b) they don't seem to do

well, yes, i have been ...

> Key   Pause     A     N     Exec exec aumix -v +5

awesome; thanks!  now i understand the whole keybindings better, and
have a better idea of where to refer to in the manpage.  i love fvwm,
but i wish the explanation for this were displayed somewhere more
prominent.

thanks agian!

</nori>