Subject: FVWM: make pointer stay in place when switching windows (windows list)

From: Micha Feigin <[email-masked]>
Date: Wed, 28 Apr 2004 20:31:35 +0300

When I use windows list to change windows using alt-tab:
Key Tab		A	M	WindowList (CurrentDesk) Root c c NoDeskSort, CurrentAtEnd, IconifiedAtEnd, ShowPageX
The pointer is moved to the top-left corner of the new window. How can
I make it stay at the same location? Its quite annoying having to move
it back to its place every time. This also causes focus problems with
border-less windows and sloppy focus. If I have to move the pointer, a
better behavior would be to move the pointer to the center of the new
window, this would also solve the focus problems I had with sloppy
focus and focusing a window that is not under the mouse when the mouse
is over a different window.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Parv <[email-masked]>
Date: Wed, 28 Apr 2004 20:58:44 -0400

in message <[email-masked]>, wrote Micha
Feigin thusly...
>
> If I have to move the pointer, a better behavior would be to move
> the pointer to the center of the new window, this would also solve
> the focus problems I had with sloppy focus and focusing a window
> that is not under the mouse when the mouse is over a different
> window.

To center them mouse, among other things, (after a selection from WindowList),
i use...

  DestroyFunc  WindowListFunc
  AddToFunc    WindowListFunc
  +  I Function deiconify-func Raise
  +  I FlipFocus
  +  I WarpToWindow 50 50

  DestroyFunc  deiconify-func
  AddToFunc    deiconify-func
  +  I Iconify false
  +  I WindowShade false
  +  I $0

...the big idea is to (re)define WindowListFunc ... eh ... function
which is used by WindowList.  See fvwm(1) for default & other
data.

  - Parv

-- 

----- End forwarded message -----

  - Parv
  - Anubhav

--