Subject: FVWM: Popup menu above button

From: Scott Smedley <[email-masked]>
Date: Sun, 28 Mar 2004 00:01:49 +1100

Hi all,

I'm trying to create a button in my buttonbar to popup a menu.

According to FvwmButtons(1):

# Pop up a module menu directly above the button.
*FvwmButtons: (9x1+3+0, Padding 0, Title "Modules",   \
  Action `Menu Modulepopup rectangle $wx$h+$l+$t o+50 -100m`)

This should work, but it fails for me.

If I do a:

*FvwmButtons: (9x1+3+0, Padding 0, Title "Modules",   \
  Action `Echo Menu Modulepopup rectangle $wx$h+$l+$t o+50 -100m`)

I get:

Menu Modulepopup rectangle $wx$h+$l+$t o+50 -100m

ie. $w & friends don't appear to be evaluated.

Any pointers muchly appreciated.

SCoTT. :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 29 Mar 2004 12:50:06 +0200

> Any pointers muchly appreciated.

I can confirm that problem.  If you use $width, $height, $left and
$top instead it works fine.

Ciao

Dominik ^_^  ^_^

---

From: [email-masked]
Date: Mon, 29 Mar 2004 22:45:30 +0200

> $top instead it works fine.

The example in the man page is wrong.  I probably forgot to adapt
the example once I chose the final syntax.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].