Subject: Re: FVWM: icon style for a file

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 2004 23:05:36 -0500

Bill Jehle <[email-masked]> writes:
> On Wed, Mar 31, 2004 at 09:19:11PM -0500, Dan Espen wrote:
> > Bill Jehle <[email-masked]> writes:
> > > On Sat, Mar 27, 2004 at 08:39:04AM +0100, Marcus Lundblad wrote:
> > > > 
> > > > 
> > > > On Fri, 26 Mar 2004, Bill Jehle wrote:
> > > > 
> > > > >
> > > > > Is it possible to assign a soffice7 spreadheet window, that I use for
>  my
> > > > > addressbook, a unique mini and norm icon for that file without every
> > > > > instance of soffice7 spreadsheet getting the same icon?
> > > > 
> > > > If the title of the window contains something like "addressbook", you
> > > > should be able to assign:
> > > > 
> > > > Style "*addressbook*" Icon icon.xpm, MiniIcon micon.xpm
> > > > 
> > > > in your configuration file.
> > > > 
> > > > //Marcus
> > > 
> > > Thanks, I have the "name" already in .fvwm2rc-wm-icons
> > > 
> > > "Style "*addrress-book.sxc-StarOffice7*"	Icon norm/rolodex1-48.xpm,\
> >               ^^
> > 
> > Is that right?
> 
> Well no it's not right (it's an idiotic mistake) but when I took an "r" away 
> so it's
> actually spelled like the WM_NAME(STRING) = "address-book.sxc -
> StarOffice 7 " it still only gets the default icon.

Please don't forget to reply to the list.

You probably want to look in the man page for the phrase iconoverride.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bill Jehle <[email-masked]>
Date: Wed, 31 Mar 2004 21:14:30 -0800

> You probably want to look in the man page for the phrase iconoverride.

Thanks Dan, according to the man if I put "Style address-book.sxc-StarOffice7 IconOveride"
in my config file I should get my icons. This works with Soffice
(class) but not with  address-book.sxc-StarOffice (name). What am I missing?
 
-- 
Bill Jehle
http://billjehle.com