Subject: FVWM: icon style for a file

From: Bill Jehle <[email-masked]>
Date: Fri, 26 Mar 2004 21:43:26 -0800

Is it possible to assign a soffice7 spreadheet window, that I use for my
addressbook, a unique mini and norm icon for that file without every
instance of soffice7 spreadsheet getting the same icon?
-- 
Bill Jehle
http://billjehle.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 27 Mar 2004 08:39:04 +0100 (CET)

> instance of soffice7 spreadsheet getting the same icon?

If the title of the window contains something like "addressbook", you
should be able to assign:

Style "*addressbook*" Icon icon.xpm, MiniIcon micon.xpm

in your configuration file.

//Marcus

---

From: Bill Jehle <[email-masked]>
Date: Wed, 31 Mar 2004 18:00:06 -0800

> in your configuration file.

Thanks, I have the "name" already in .fvwm2rc-wm-icons

"Style "*addrress-book.sxc-StarOffice7*"	Icon norm/rolodex1-48.xpm,\	MiniIcon mini/rolodex4-16.xpm"

but Staroffice still wants to get the icon from "class". 

How do you make it get the icon from "name"? 

If I read the man right it should get the Style from
"name" right?

---

From: Dan Espen <[email-masked]>
Date: Wed, 31 Mar 2004 21:19:11 -0500

Bill Jehle <[email-masked]> writes:
> "Style "*addrress-book.sxc-StarOffice7*"	Icon norm/rolodex1-48.xpm,\
              ^^

Is that right?

-- 
Dan Espen                           E-mail: [email-masked]