Subject: Re: FVWM: 2.5.9 redrawing still slow

From: Duane Paddock - Personal <[email-masked]>
Date: Wed, 3 Mar 2004 10:31:52 -0500 (EST)

Sorry, 

I was a little to fast to send this, I sent it to you directly by mistake.

Duane.

On Wed, 3 Mar 2004, Mikhael Goikhman wrote:

> On 03 Mar 2004 08:21:19 -0500, Duane Paddock - Personal wrote:
> > 
> > The make still fails on the debian directory was well. I have to remove
> > the debian directory from the SUBDIRS variable of the top level Makefile
> > for the compile to complete successfully;
> > 
> > -- snip --
> > Making all in debian
> > make: Fatal error in reader: Makefile, line 333: Badly formed macro assignment
>   ^^^^^
>           This would be "gmake", I guess.
> 
> > Current working directory 
> > /home/dp130708/source/fvwm-2.5.9/fvwm-2.5.9/debian
> > *** Error code 1
> > make: Fatal error: Command failed for target `all-recursive'
> > Current working directory /home/dp130708/source/fvwm-2.5.9/fvwm-2.5.9
> > *** Error code 1
> > make: Fatal error: Command failed for target `all'
> > Current working directory /home/dp130708/source/fvwm-2.5.9/fvwm-2.5.9
> > *** Error code 1
> > make: Fatal error: Command failed for target `all'
> > 
> > $ cat -n Makefile | ggrep -B 5 -A 5 333     
> 
> It says about debian/Makefile, not Makefile.
> 
> I will replace the strange syntax in that line (is it GNU make-ism?).
> 
> > $ gmake --version
> > GNU Make version 3.79.1, by Richard Stallman and Roland McGrath.
> > Built for sparc-sun-solaris2.7
> 
> Your GNU make version is fine, but it is not clear whether your make and
> gmake are the same thing. Please report your make version output.
> 
> Regards,
> Mikhael.
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
>

Mikhael,

Is there some way we can track down the slow drawing issue?  I'd really 
like to be able to upgrade from 2.5.7 to use a couple of the newer 
features.   I'd be happy to do what I can to help track this down.  I 
couldn't find any reference in the list archives about possible fixes 
since Elliot initially reported the problem with the 2.5.8 release.

http://www.mail-archive.com/[email-masked]/msg04721.html

You were right I am using Sun's make, not gmake, my mistake.

There is no version associated with make, so I've included the pkginfo 
output.
 
$ which make
/usr/ccs/bin/make
$ pkginfo -l SUNWxcu4t
   PKGINST:  SUNWxcu4t
      NAME:  XCU4 make and sccs utilities
  CATEGORY:  system
      ARCH:  sparc
   VERSION:  5.8,REV=1999.12.12.00.00
   BASEDIR:  /
    VENDOR:  Sun Microsystems, Inc.
      DESC:  XCU4 Compliant Versions of make and sccs utilities
    PSTAMP:  wildwood20020408142646
  INSTDATE:  Dec 02 2002 09:34
   HOTLINE:  Please contact your local service provider
    STATUS:  completely installed
     FILES:        7 installed pathnames
                   3 shared pathnames
                   3 directories
                   4 executables
                 830 blocks used (approx)

Thanks,

Duane.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 3 Mar 2004 14:00:10 -0800 (PST)

> Can you try to compile 2.5.9 with the --disable-iconv option to configure
> (this is not the same thing than --with-iconv-library=no).

Fixes it.

--disable-iconv is not listed in INSTALL.fvwm.

I now get a msg when using sun mailtool...

_cdim: --- not moved 0x0011ae50 'Mail Tool V3.6.2 FCS: View Message 4'

Tho i disabled it in events.c by commenting out

#define CR_DETECT_MOTION_METHOD_DEBUG