Subject: FVWM: fvwmtabs make disappear my xterms

From: xavier <[email-masked]>
Date: Tue, 23 Mar 2004 14:41:04 -0500

On Sun, Feb 08, 2004 at 10:47:47AM +1100, Scott Smedley wrote:
|Hi Xavier,
|
|> are you able to reproduce the bug ?
|
|No. I just tried it on my RH7.3 system.
|

In my tries (4 Fvwmtabs holding 6 xterms each),

I'm able to reproduce the bug only if  fvwmtab
is focused...

i don't know really if this is linked or not.

.xsession-errors : 

FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs: Window doesn't exist.
FvwmTabs (v2.8) started with: Perl 5.8.2, X11::Protocol 0.52, Tk 800.024.
_cdim: --- not moved 0x0815ba68 'FvwmTabs [0]'
xterm:  warning, error event received:
xterm:  warning, error event received:
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  76 (X_ImageText8)
  Resource id in failed request:  0x7400018
  Serial number of failed request:  3747
  Current serial number in output stream:  3747
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  76 (X_ImageText8)
  Resource id in failed request:  0x8800018
  Serial number of failed request:  35796
  Current serial number in output stream:  35796
xterm:  warning, error event received:
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  76 (X_ImageText8)
  Resource id in failed request:  0x1e00018
  Serial number of failed request:  15531
  Current serial number in output stream:  15531

-- 
xavier
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: xavier <[email-masked]>
Date: Tue, 23 Mar 2004 15:09:48 -0500

echo test > /tmp/test
cd /tmp
ln -s test .fvwmtabs.state

restart fvwm

/tmp/test is wiped

---

From: xavier <[email-masked]>
Date: Tue, 23 Mar 2004 15:12:06 -0500

On Tue, Mar 23, 2004 at 02:41:04PM -0500, xavier wrote:
|On Sun, Feb 08, 2004 at 10:47:47AM +1100, Scott Smedley wrote:
||Hi Xavier,
||
||> are you able to reproduce the bug ?
||
||No. I just tried it on my RH7.3 system.
||
|
|In my tries (4 Fvwmtabs holding 6 xterms each),
|
|I'm able to reproduce the bug only if  fvwmtab
|is focused...
|
|i don't know really if this is linked or not.
|

hum, today  (fvwmtabs 2.8, fvwm 2.5.10)i'm only able to reproduce
it on :0.1 but not on :0.0 (ie my second screen)

could this be linked ?

thanks

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 23 Mar 2004 20:26:27 +0000

> ln -s test .fvwmtabs.state

I also spotted this, it's a configurable setting though...in the gentoo
package I maintain I changed the default to ~/.fvwmtabs.state.

http://www.gentoo.org/cgi-bin/viewcvs.cgi/*checkout*/x11-wm/fvwm/files/fvwm
tabs-insecure-tmp-handling.diff

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------

---

From: Scott Smedley <[email-masked]>
Date: Wed, 24 Mar 2004 18:10:45 +1100

Hi Xavier,

> I'm able to reproduce the bug only if  fvwmtab

Can you try this for me? - replace the ExitFunction config lines in the
fvwmtabrc file with this:

AddToFunc ExitFunction
+ I Test (ToRestart) Function SaveState
+ I PipeRead 'usleep 100'

If that doesn't work, try increasing the usleep a little.

SCoTT. :)

---

From: Scott Smedley <[email-masked]>
Date: Wed, 24 Mar 2004 18:13:00 +1100

> package I maintain I changed the default to ~/.fvwmtabs.state.

A good idea. I'll make this the default from now on:

*FvwmTabs: stateFile $[HOME]/.fvwmtabs.state

Thanks,

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 24 Mar 2004 14:22:01 +0000

> *FvwmTabs: stateFile $[HOME]/.fvwmtabs.state

Better use $[FVWM_USERDIR]/.fvwmtabs.state to keep $HOME clean.

Regards,
Mikhael.

---

From: xavier <[email-masked]>
Date: Mon, 29 Mar 2004 15:00:29 -0500

On Wed, Mar 24, 2004 at 06:10:45PM +1100, Scott Smedley wrote:
|Hi Xavier,
|
|> In my tries (4 Fvwmtabs holding 6 xterms each),
|> 
|> I'm able to reproduce the bug only if  fvwmtab
|> is focused...
|
|Can you try this for me? - replace the ExitFunction config lines in the
|fvwmtabrc file with this:
|
|AddToFunc ExitFunction
|+ I Test (ToRestart) Function SaveState
|+ I PipeRead 'usleep 100'
|
|If that doesn't work, try increasing the usleep a little.

Hum, no, it didn't work. 

thanks anyway.

---

From: Scott Smedley <[email-masked]>
Date: Wed, 31 Mar 2004 15:33:46 +1000

Hi Xavier,

: |> In my tries (4 Fvwmtabs holding 6 xterms each),
: |> 
: |> I'm able to reproduce the bug only if  fvwmtab
: |> is focused...

What happens if you Ctrl-Alt-K & then Ctrl-Alt-S? (kill FvwmTabs module &
then restart it.) Do the xterms get released & re-swallowed ok?

What does the $FVWM_USERDIR/.fvwmtabs.state file look like after
the FvwmTabs module is killed (but before you restart it)?

SCoTT. :)