Subject: FVWM: Problem with Layer command

From: Rafał Bisingier <[email-masked]>
Date: Tue, 30 Mar 2004 12:10:21 +0200

Hi,

I have problem using Layer command. I'm trying to put two apps on layer 
0 by default, but it doesn't work as expected.
This aplications are gDeskCal and gDesklets (both written in Python).
I've made a defualt style for them like this:
  Style (gDeskCal) Layer 0 0
  Style (gDesklets) Layer 0 0
but this doesn't work (both apps are placed on layer 2)
I've tried also FvwmEvent module for this (similar to Q3.18 in FAQ), but 
this one also failed.
I've also tried something like this:
  Wait gDeskCal
  Next (gDeskCal) Layer 0 0
but this one failed too.
I thought that the Layer command isn't working but when I made a manu 
command like this:

  + "LowerToBottom" Pick lower-to-bottom

  DestroyFunc lower-to-bottom
  AddToFunc lower-to-bottom
  + I Layer 0 0
  + I Lower

then when I chose this option in menu and then chose a window it is 
lowered just like it should.

So now I'm really confused and don't know how to use the Layer 
command... :-(

PS. Sorry for my english

-- 
Greetings
Rafal Bisingier
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 2004 13:27:39 +0200

>  Style (gDesklets) Layer 0 0

The syntax is wrong.  Try

  Style gDeskCal Layer 0
  Style gDesklets Layer 0

>  Next (gDeskCal) Layer 0 0

Likely, both applications set their own layer hints.  Try the
styles

  Style gDeskCal EWMHIgnoreStackingOrderHints, GnomeIgnoreHints, EWMHIgnoreStateHints
  Style gDesklets EWMHIgnoreStackingOrderHints, GnomeIgnoreHints, EWMHIgnoreStateHints

(if probably one of the three options is enough).

> So now I'm really confused and don't know how to use the Layer 

Ciao

Dominik ^_^  ^_^

---

From: Rafał Bisingier <[email-masked]>
Date: Tue, 30 Mar 2004 16:23:33 +0200

> On Tue, Mar 30, 2004 at 12:10:21PM +0200, Rafa? Bisingier wrote:
<cut>
>> Style (gDesklets) Layer 0 0

Shoundn't there be two zeros?
The parenthesis are wrong for sure ;-)

> (if probably one of the three options is enough).
<cut>

Well, none of this works. Both apps are still placed on layer 2 :-(

BTW: is there a method to see what are the styles of a certain window?

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 2004 17:55:57 +0200

> Shoundn't there be two zeros?

No.  The style takes only one argument while the command takes two
:-P

> BTW: is there a method to see what are the styles of a certain window?

Looking into the config file.  In 2.5.10, I implemented a command
that shows the initial name of a window to find the right style
name:

  BugOpts DisplayNewWindowNames

The initial names of new windows (which determine the style used)
are shown on the X console.

Did you try to issue

  Layer 0 0

from FvwmConsole and then click on one of the offending windows?
Does it work?

Ciao

Dominik ^_^  ^_^

---

From: Rafał Bisingier <[email-masked]>
Date: Wed, 31 Mar 2004 09:33:54 +0200

> No.  The style takes only one argument while the command takes two

OK. A little confusing, but I belive you ;-)

<cut>
> are shown on the X console.

I tried that, but I do it again. Maybe I overlooked something...

So I checked it, and both windows have exacly the same names that are 
showed later by FvwmIdent...
BTW I found in the logs something like this:
_cdim: --- not moved 0x08152388 'gDeskCal'
and similar for the gDesklets app...

> from FvwmConsole and then click on one of the offending windows?

Yes, this one works exactly as it should.

-- 
Greetings
Rafal Bisingier

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 2004 10:50:22 +0200

> and similar for the gDesklets app...

This is an unrelated debug message that will go away soon.

> Yes, this one works exactly as it should.

So the application or someone else is fiddling with the window's
layer after it has been mapped.  Do these applications have some
option to remember their position?

Ciao

Dominik ^_^  ^_^

---

From: Rafał Bisingier <[email-masked]>
Date: Wed, 31 Mar 2004 11:15:34 +0200

<cut>
> option to remember their position?

Both this apps remember their position. A suposse that they use
StaysOnBottom Style because when I change DefaultLayers to 1 4 6
both starts on layer 1, and I don't use for them StaysOnBottom style...

-- 
Greetings
Rafal Bisingier