Subject: FVWM: Unbind C-N in menus

From: Frank Gruellich <[email-masked]>
Date: Thu, 18 Mar 2004 20:07:54 +0100

Hello,

from the man page:
,-----
|   MENUS
|       [...]
|       Keyboard Navigation
|              [...]
|              Ctrl-Cursor-Down, Ctrl-J Ctrl-N, Ctrl-Meta-TabP, Page-Down move
|              down five items.
`-----
Well, how can I remove it?  I would like to use
,-----
|MenuStyle WindowList SelectOnRelease Control_L
|Key N A C WindowList
`-----
to move to the very next item in my windowlist.

Thanks in advance,
 regards, Frank.
-- 
Sigmentation fault
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 Mar 2004 14:24:40 -0500

> to move to the very next item in my windowlist.

I think you want to remove Control-J, etc. keybindings
for the menus.

Right now you can't do that.
We recently made a change that allows you to remove the button
2 binding on the title for menu tear off, but that's as far as
it went.

Doing the entire job of being able to customize all the menu
bindings looked pretty hard, but individual cases might not be
as hard.  If you are a programmer, you might want to investigate
and submit a patch...

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Frank Gruellich <[email-masked]>
Date: Fri, 26 Mar 2004 03:51:19 +0100

Hi,

* Dan Espen <[email-masked]> 18. Mar 04:
> > Well, how can I remove it?

D'oh.

> as hard.  If you are a programmer, you might want to investigate

Unfortunately I am not (well, not a very successfull one).  I will poke
around a bit.  Any hints, where I may start to get a general overview?

Still in love with fvwm,
 regards, Frank.

---

From: Dan Espen <[email-masked]>
Date: Thu, 25 Mar 2004 22:03:01 -0500

> around a bit.  Any hints, where I may start to get a general overview?

I haven't used it myself but the FvwmGtk module can serve
as a menu substitute.  Maybe that will do what you want.