Subject: FVWM: Title Bar Button color problem

From: Duane Paddock - Personal <[email-masked]>
Date: Sat, 6 Mar 2004 12:36:16 -0500 (EST)

I'm currently having a problem with the color of the buttons in the title
bar.  With version 2.5.7 the vector lines are drawn using black by
default, but with 2.5.9, they are drawn using a different color.  How can
I force the color of the vector lines to be drawn in black using 2.5.9?

I have the same problem using SUSE linux 9.0 and Solaris 8.

[Linux]$ fvwm-config -s
bidi
gettext
gtk
gdk-imlib
gnome-libs
iconv
perllib
png
readline
shape
shm
sm
stroke
xinerama
xpm
xrender

[Solaris]$ fvwm-config -s
gettext
gtk
gdk-imlib
perllib
png
readline
rplay
shape
shm
sm
stroke
xpm

Here's a sample screen capture of the title bar from 2.5.7 and 2.5.9.

http://members.rogers.com/paddoda/title.html

Here's a minimum config that demonstrates the different behavior;

Colorset 9 NoShape, VGradient 13 1 #f6f6f6 50 #000000, Alpha 50
Colorset 10 VGradient 13 1 #f6f6f6 50 gray40

DestroyDecor DefaultDecor
AddToDecor DefaultDecor
+ TitleStyle LeftJustified Height 13
+ TitleStyle InActive ( Colorset 9 -- Flat ) \
    Active ( Colorset 10 -- Flat )
# Buttons on the title bar
# (1,3,5,7,9 are on the left, 0,8,6,4,2 on the right side of the title bar).
+ ButtonStyle All InActive ( Colorset 9 -- Flat )
+ ButtonStyle All Active ( Colorset 10 -- Flat )
+ AddButtonStyle  4 ActiveUp Vector 7 30x30@2 30x60@2 60x60@2 60x30@2 \
        30x30@2 30x35@2 60x35@2 -- Flat
+ AddButtonStyle  4 Inactive Vector 7 30x30@3 30x60@3 60x60@3 60x30@3 \
        30x30@3 30x35@3 60x35@3 -- Flat
+ AddButtonStyle  4 ActiveDown Vector 7 35x35@2 35x65@2 65x65@2 65x35@2 \
        35x35@2 35x40@2 65x40@2 -- Flat
+ AddButtonStyle  1 Inactive Vector 4 44x44@3 44x45@3 45x45@3 44x44@3 -- Flat
+ AddButtonStyle  1 ActiveUp Vector 4 44x44@2 44x45@2 45x45@2 44x44@2 -- Flat
+ AddButtonStyle  1 ActiveDown Vector 4 49x49@2 49x50@2 50x50@2 49x49@2 -- Flat
+ AddButtonStyle  6 ActiveUp Vector 5 30x60@2 60x60@2 60x50@2 30x50@2 30x60@2 -- Flat
+ AddButtonStyle  6 Inactive Vector 5 30x60@3 60x60@3 60x50@3 30x50@3 30x60@3 -- Flat
+ AddButtonStyle  6 ActiveDown Vector 5 35x65@2 65x65@2 65x55@2 35x55@2 35x65@2 -- Flat
+ AddButtonStyle  2 ActiveUp Vector 5 30x30@2 60x60@2 45x45@2 60x30@2 30x60@2 -- Flat
+ AddButtonStyle  2 Inactive Vector 5 30x30@3 60x60@3 45x45@3 60x30@3 30x60@3 -- Flat
+ AddButtonStyle  2 ActiveDown Vector 5 35x35@2 65x65@2 50x50@2 65x35@2 35x65@2 -- Flat
+ AddButtonStyle  3 ActiveUp Vector 5 30x60@2 60x60@2 60x50@2 30x50@2 30x60@2 -- Flat
+ AddButtonStyle  3 Inactive Vector 5 30x60@3 60x60@3 60x50@3 30x50@3 30x60@3 -- Flat
+ AddButtonStyle  3 ActiveDown Vector 5 35x65@2 65x65@2 65x55@2 35x55@2 35x65@2 -- Flat

Style * UseDecor DefaultDecor

#   for the title bar buttons:
Mouse   0       1       A       Nop
Mouse   0       2       A       Nop
Mouse   0       3       A       Nop
Mouse   0       4       A       Nop
Mouse   0       6       A       Nop

Thanks,

Duane.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Sat, 06 Mar 2004 18:21:25 +0000

> I force the color of the vector lines to be drawn in black using 2.5.9?
...
> Colorset 10 VGradient 13 1 #f6f6f6 50 gray40

you can specify which colour to use for each line, with the @X syntax. you
use @2 and @3 (background and foreground), but dont specify them in the
Colorsets..i would guess the easy way to solve it is to specify an fg and
bg component in your Colorsets.

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------