Subject: FVWM: Ctrl-Alt-Backspace and other key issue

From: Peter Münster <[email-masked]>
Date: Thu, 11 Mar 2004 18:56:13 +0100 (CET)

Hello,
after an update from SuSE-Linux-8.2 to 9.0, that is from fvwm-2.4.15 to
2.5.7, the following strange things happen:

- the line
Key BackSpace	A	CM	Some action
has no more effect.

- when pressing the Alt-key at last (after Shift and Ctrl), the action of
the line
Key Left	A	SCM	Action with Alt
shows the same action as the line
Key Left	A	SC	Action without Alt
But when pressing the Alt-key at first, and then Shift and Ctrl, the action
is ok.

Ok, I could downgrade to fvwm-2.4.15, but perhaps there are other
solutions.

TIA for any hint, Peter

-- 
http://pmrb.free.fr/contact/
----------------------------------------------------------------
FilmSearch engine with a lot of new features: http://f-s.sf.net/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 11 Mar 2004 13:45:25 -0800

> But when pressing the Alt-key at first, and then Shift and Ctrl, the action

   this looks more like X server issue (xev might help). also, 
ctrl-alt-backspace is default key combination to exit X so it doesn't 
seem like a good shortcut to use.

	erik

---

From: Peter Münster <[email-masked]>
Date: Fri, 12 Mar 2004 08:18:19 +0100 (CET)

> seem like a good shortcut to use.

Since I use Option "DontZap" in /etc/X11/XF86Config, ctrl-alt-backspace is
free. xev shows right key-bindings. Anyway
Key BackSpace	A	M	Some action     and
Key BackSpace	A	C	Some action     and other combinations work, only
"CM" is a problem.

But you're right with the other issue: when pressing "Alt" at last, then
xev shows "Meta_L" instead of "Alt_L", I'll take a look into
X-configuration to find the solution...

Thanks, Peter

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 13 Mar 2004 11:06:08 +0100 (CET)

> X-configuration to find the solution...

I use this in my ~/.xmodmaprc

!---------------------
clear mod1
clear mod2
clear mod3
clear mod4
clear mod5
keycode 115 = Meta_L
keycode 116 = Meta_R
keycode 64 = Alt_L
keycode 117 = Menu
add mod1 = Alt_L
add mod4 = Meta_L Meta_R
add mod5 = Menu
!---------------------

This bind Meta to those keys with a flying window (whatever that is
supposed to represent)...
And the Alt key becomes Alt_L

Maybe this is what you want.

//Marcus

---

From: Peter Münster <[email-masked]>
Date: Sun, 14 Mar 2004 16:07:48 +0100 (CET)

On Sat, 13 Mar 2004, Marcus Lundblad wrote:

> On Fri, 12 Mar 2004, [ISO-8859-15] Peter M[fc]nster wrote:
> 

In my case the following line helped me:
keycode  64 = Alt_L Alt_L
Before, it was Alt_L Meta_L

The backspace probem can be resolved by just using another key, so I use
Delete now.

Thanks, Peter