Subject: FVWM: Using 'Super_L' as a key modifier

From: stu <[email-masked]>
Date: Wed, 31 Mar 2004 14:39:12 +0200

Is it possible to add a custom key modifier to fvwm(2.5.8)? I want to
use Super_L (commonly known as the 'Windows' key - ugh) as a modifier so
I can use a key combination like Control-Super_L-Left ie (assuming
the 'U' means Super_L) :

Key   Left      A     CU    GotoPage -1p +1p
Key   Right     A     CU    GotoPage +1p +1p

Or can I only use 'A' for any modifier to effect a similar outcome?

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Mar 2004 14:57:18 +0200

> Or can I only use 'A' for any modifier to effect a similar outcome?

X defines a mask of eight modifiers (SMC12345 in fvwm).  Which
keys generate these modifiers depends on your Xmodmap.  To bind
Super_L to modifier 3 for example, issue

  $ xmodmap -e "clear Mod3"
  $ xmodmap -e "add Mod3 = Super_L"

or put the following at the end of your $HOME/.Xmodmap:

  clear Mod3
  add Mod3 = Super_L

After that, the modifier "3" refers to the Super_L key in fvwm.

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Piotr Zielinski <[email-masked]>
Date: Wed, 31 Mar 2004 14:22:36 +0100

Stuart> [...] I want to use Super_L (commonly known as the 'Windows'
Stuart> key - ugh) as a modifier 

Map Super_L to one of the modifiers in .Xmodmap, for example

clear mod2
add mod2 = Super_L

and then map your keys in .fvwm2rc:

Key   Left      A     2C    GotoPage -1p +1p
Key   Right     A     2C    GotoPage +1p +1p

You can take a look at Super_L-related key and mouse mappings in my
.fvwm2rc, my .Xmodmap, and a very-much-under-construction page about
my thoughts on efficient window manager settings:

http://www.cl.cam.ac.uk/~pz215/editing/config.fvwm2rc
http://www.cl.cam.ac.uk/~pz215/editing/.Xmodmap
http://www.cl.cam.ac.uk/~pz215/editing/windows.html

More info: 

man fvwm
man xmodmap

Thanks,

Piotr