Subject: FVWM: TestRc and function modifiers

From: Uwe Pross <[email-masked]>
Date: Mon, 1 Mar 2004 21:52:08 +0100

Hi there,

I have got the following mouse binding:

  Mouse 1 T A Function MoveOrRaiseOrLowerFunc

If I define MoveOrRaiseOrLowerFunc as

  DestroyFunc MoveOrRaiseOrLowerFunc
  AddToFunc MoveOrRaiseOrLowerFunc
  + I ThisWindow (!Raised) Raise
  + C TestRc (NoMatch) Lower
  + M Move
  + D Maximize 100 100

or 

  DestroyFunc MoveOrRaiseOrLowerFunc
  AddToFunc MoveOrRaiseOrLowerFunc
  + I Current (!Raised) Raise
  + C TestRc (NoMatch) Lower
  + M Move
  + D Maximize 100 100

the window can only be moved/maximized if it was raised.

The definiton 

  DestroyFunc MoveOrRaiseOrLowerFunc 
  AddToFunc MoveOrRaiseOrLowerFunc
  + C ThisWindow (!Raised) Raise
  + C TestRc (NoMatch) Lower
  + M Move
  + D Maximize 100 100

works as expected but raising/lowering is a bit delayed and
the window may be moved or maximized and the window is
lowered.

Any hints how to achieve the desired behaviour?

Thanks in advance.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive your mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Mar 2004 11:31:41 +0100

> Any hints how to achieve the desired behaviour?

It's a bug.  I can fix that particular problem, but it may be much
more widespread.

Ciao

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Mar 2004 12:22:24 +0100

> works as expected but raising/lowering is a bit delayed

Because fvwm has to wait until it's clear whether the action is a
click or double click.  Either you have to get used to it or live
without double click bindings.

> and

Works now.

Ciao

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Tue, 2 Mar 2004 12:55:15 +0100

Hi there,

On 02 Mar 2004 at 12:22:24 +0100, Dominik Vogt wrote:

> Because fvwm has to wait until it's clear whether the
> action is a click or double click. 

That was clear, and that's why I wanted to use "I" instead
of "C".

> Works now.

In the current cvs? Thank you. I am going to wait for the
next release and then grab the debian package.

Cheers, Uwe