Subject: FVWM: Debian ./configure problem

From: Scott Smedley <[email-masked]>
Date: Wed, 17 Mar 2004 16:45:03 +1100

Hi,

I'm trying to compile FVWM on a Debian box. I'm having trouble getting
it to include anti-alias font support.

During ./configure I get this:

checking for freetype-config... /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... yes
checking for fontconfig-config... no
checking for Fontconfig - version >= 1.0.1... no
*** fontconfig was not found in the pkg-config search path.
*** either fontconfig is not installed or perhaps you should
*** add the directory containing fontconfig.pc to the 
*** PKG_CONFIG_PATH environment variable.

It appears there's no fontconfig-config program & the fontconfig
package doesn't use pkg-config. (ie. there's no fontconfig.pc file.)

Any Debian users have any luck with this?

SCoTT. :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Wed, 17 Mar 2004 05:50:11 +0000 (GMT)

> *** PKG_CONFIG_PATH environment variable.

Ensure all the 'pango' and 'atk' files are installed...

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Wed, 17 Mar 2004 16:54:32 +1100

Hi Thomas,

> Ensure all the 'pango' and 'atk' files are installed...

I just did a:

apt-get install libpango1.0-dev
apt-get install libatk1.0-0    

but I still get the same error. :(

SCoTT.

---

From: Thomas Adam <[email-masked]>
Date: Wed, 17 Mar 2004 06:27:55 +0000 (GMT)

> but I still get the same error. :(

fontconfig-config, *might* be part of the freedesktop apps [1], I am not
sure. Certainly there exists no such file in any of the debian
repositories using apt-file.

-- Thomas Adam

[1] http://www.freedesktop.org

=====

---

From: calmar <[email-masked]>
Date: Wed, 17 Mar 2004 10:29:55 +0100

> Any Debian users have any luck with this?

hi,
did you setup the proper environment variables: I have this in my
/ect/profile :

PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig:/lib/pkgconfig
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/lib/pkgconfig:/opt/gnome/lib/pkgconfig
PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/lib/pkgconfig:/usr/local/lib/pkgconfig

greetings
marco candrian

-- 
  calmar
           (o_         GNU/Linux is GREAT
           //\
           V_/_        http://www.calmar.ws

---

From: Remko Troncon <[email-masked]>
Date: Wed, 17 Mar 2004 16:39:28 +0100

> PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/lib/pkgconfig:/usr/local/lib/pkgconfig

Debian avoids the need to set environment variables.
I also had troubles this weekend building the new fvwm, also with
fontconfig. I didn't look into it yet, i suspect it has something to do
with the new X server, but i am not sure.

What version of XFree are you running ?

cheers,
Remko