Subject: FVWM: icons in menu quirk

From: Abilio Carvalho <[email-masked]>
Date: Wed, 03 Mar 2004 08:46:56 +0100

Hi. I was messing around with a downloaded .fvwm2rc yesterday, and I noticed that if a line on a menu has TWO %icon.png% declarations, and the first one can't find the icon, then the second one will be printed as text. Is this normal behaviour?

Thanks, and sorry for the noobish question

Abilio
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Mar 2004 10:15:14 +0100

On Wed, Mar 03, 2004 at 08:46:56AM +0100, Abilio Carvalho wrote:
> Hi. I was messing around with a downloaded .fvwm2rc yesterday, and I 
> noticed that if a line on a menu has TWO %icon.png% declarations, and the 
> first one can't find the icon, then the second one will be printed as text. 
> Is this normal behaviour?

For me it works fine.  Do you have an example?

> Thanks, and sorry for the noobish question

Ciao

Dominik ^_^  ^_^

---

From: Abilio Carvalho <[email-masked]>
Date: Wed, 03 Mar 2004 10:39:50 +0100

> For me it works fine.  Do you have an example?

I will when I get home. I just had two consecutive lines in the menu definition, one a copy of the other.
I changed the name of the first icon in the second line, restarted fvwm, and the second icon disappeared, being replaced by the string "%ctl_alt_o.png%"

Abilio