Subject: FVWM: Trouble in 2.5.9/2.5.8: mouse move with keypress is not work

From: Ruslan Kosolapov <[email-masked]>
Date: Fri, 06 Feb 2004 14:44:58 +0600

=[

  I like move windows by pressing Control-Alt-LeftMouse on any part of
  window. 

  My .fvwm2rc:
  $ cat .fvwm/.fvwm2rc | egrep "Mouse.*Move"
Mouse 1 W CM AnimatedMove

  When I use fvwm 2.5.6 (at my workplace) all working fine.

  At home I use fvwm 2.5.8 with the same config, and this feature is
  not work - I can move window only after I unpress left mouse button.

  I.e. (by steps):

  1. I press Control-Alt-LeftMouse - at this step if I moving the
     mouse window is not moving.
  2. I release LeftMouse (released or pressed Control-Alt - doesn't
     matter) - at this step cursor goes to MOVE cursorstyle, and when
     I moving the mouse, window follows to it, and window stop moving
     when I press LeftMouse again.

  In fvwm 2.5.6 windows follows mouse without just after press
  Control-Alt-LeftMouse, and stops moving after releasing buttons.

  Is this a bug, or this is a feature of 2.5.8?  And what can I do for
  fix a problem? 

PS: I try to build fresh 2.5.9 - the same problem.

-- 
=[ Hа pаботе всегда выкладывайтесь на 100%! 12% в понедельник, 
=[ 23% во втоpник, 40% в сpеду, 20% в четвеpг и 5% в пятницу!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Feb 2004 09:54:39 +0100

On Fri, Feb 06, 2004 at 02:44:58PM +0600, Ruslan Kosolapov wrote:
>   Is this a bug, or this is a feature of 2.5.8?

It's a feature, and it's still undecided whether it will stay in
the code.  In earlier versions, some of the commands that were
usually mouse driven (e.g. Move, Resize) were invoked when the
mouse button was pressed.  Most others were invoked when the
button was released.  The change I made makes all commands use the
latter approach for consistency.

Now, I wouldn't have changed that behaviour if it had not fixed a
subtle bug with bindings on the root window.

>   And what can I do for fix a problem?

Use a function instead of calling AnimatedMove directly.
Functions can be told whether to trigger on button press or
release:

  AddToFunc MyAnimatedMove
  + I AnimatedMove
  Mouse 1 W CM MyAnimatedMove

Ciao

Dominik ^_^  ^_^

---

From: Ruslan Kosolapov <[email-masked]>
Date: Fri, 06 Feb 2004 15:25:00 +0600

>> I like move windows by pressing Control-Alt-LeftMouse on any part
 >> of window.

[....]

 >> And what can I do for fix a problem?
 DV> Use a function instead of calling AnimatedMove directly.
 DV> Functions can be told whether to trigger on button press or
 DV> release:

 DV>   AddToFunc MyAnimatedMove
 DV>   + I AnimatedMove
 DV>   Mouse 1 W CM MyAnimatedMove

  Thank you, I will try this.