Subject: FVWM: Shift + other modifiers

From: calmar <[email-masked]>
Date: Sun, 15 Feb 2004 12:08:26 +0100

Hi,
I  have (and another person too), a problem when we want to bind
somethiing to a Key, when the `S' modifier is involved.
Only the `S' (shift) as modifier works, but something like this

Key K A SM WindowList 

does not.

I don't know why, maybe it has to do with X (at least while
fiddling around, sometimes I get russian letters while typing,
and I don't know why).

Anyway, would anybody know something about this issue (Modifiers
Combinations which should not be used .. especially related to
Shift?)

Many Thanks and Greetings
marco candrian

-- 
  calmar 
           (o_         GNU/Linux is GREAT      
           //\                 
           V_/_        http://www.calmar.ws 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: stu <[email-masked]>
Date: Sun, 15 Feb 2004 15:30:33 +0200

On Sun, 15 Feb 2004 12:08:26 +0100

> Only the `S' (shift) as modifier works, but something like this

This works for me (fvwm 2.5.8, XFree86 Version 4.3.0, Debian unstable).

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable

---

From: calmar <[email-masked]>
Date: Sun, 15 Feb 2004 19:51:41 +0100

> This works for me (fvwm 2.5.8, XFree86 Version 4.3.0, Debian unstable).

I forgot to mention, I have (pretty similar to you):
fvwm 2.5.8
XFree86-4.3.0.1
Linuxfromscratch 5.0

Like this it works:
Key K A S WindowList
Key K A M WindowList

but not like this:
Key K A SM WindowList
Key K A MS WindowList

Then again (new tries)
it workes like this:
Key K A SC WindowList
Key K A MC WindowList

(I even tried in in the very default mode of fvwm (renaming
.fvwmrc).

Then about the same results in the cvs version ( 2.5.9 )

So I have to correct myself, there's a problem here with the
combination of S + M only. (so not much trouble for me actually)

Anyway,

Greetings
Marco Candrian

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 16 Feb 2004 09:35:44 +0100

>From what you write here and in your other mail I conclude you may
be misunderstanding how modifiers work in bindings. With "SM" the
binding is activated if the key is pressed with both modifiers
held.  It does *not* work if only one of them is held.

If that's not your problem, run

  $ xmodmap

and check whether your modifiers are actually bound to keys.  If
you don't understand the output, post it to the list.

> Combinations which should not be used .. especially related to

Ciao

Dominik ^_^  ^_^

---

From: calmar <[email-masked]>
Date: Mon, 16 Feb 2004 21:18:57 +0100

> On Sun, Feb 15, 2004 at 12:08:26PM +0100, calmar wrote:

Hi Dominik,

> held.  It does *not* work if only one of them is held.

Yeah, I know this :) .. I was also thinking about a problem with my
keyboard, but the other person had about a similar problem AFAIK.

> you don't understand the output, post it to the list.

That's the output:
BTW: I changed my layout with xkeycaps.

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x6f)
control     Control_L (0x25),  Control_L (0x42),  Control_R (0x75)
mod1        Alt_L (0x4d),  Alt_L (0x6d),  Alt_L (0x73)
mod2      
mod3      
mod4        Meta_L (0x40),  Meta_R (0x71),  Meta_R (0x74)
mod5     

And you are right, that when I have the xkeycaps's default  settings, it works
:) what I didn't expect, because
 
1. it works when it's bound to only one modifier (S or M)
perfectly or when they are in combination with other modifiers.
2. Then the other person was really complaining also, that it didn't
work with SM.

So at least it obviously has nothing to do with fvwm then, and
I'm happy too because I won't need this SM combination really so.

Thanks for you kindly help,

marco candrian

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 17 Feb 2004 09:28:46 +0100

> Dominik Vogt <[email-masked]> writes:

[snip]

> mod4        Meta_L (0x40),  Meta_R (0x71),  Meta_R (0x74)

Funny, a keyboard layout with three Alt_L keys and, two Control_L
and two Meta_R keys. :-)

> 2. Then the other person was really complaining also, that it didn't

Could you still send me your Xmodmap file, please?  I think it may
be possible to do something about this problem inside fvwm.

Ciao

Dominik ^_^  ^_^

---

From: calmar <[email-masked]>
Date: Tue, 17 Feb 2004 12:00:18 +0100

Hi Dominik,
> be possible to do something about this problem inside fvwm.
Of course !
Greetings and Thanks 
(even so everything would be ok also without the SM combo)
Marco Candrian

##############  my .Xmodmap file below ##########

!
! This is an `xmodmap' input file for 
!   PC 107 key, wide Delete, tall Enter (XFree86; Brazilian ABNT2) keyboards.
! Automatically generated on Wed Jan 21 00:25:47 2004 by calmar with
! XKeyCaps 2.46; Copyright (c) 1999 Jamie Zawinski <[email-masked]>.
! http://www.jwz.org/xkeycaps/
!
! This file makes the following changes:
!
! The "F1" key generates F1 and XF86_Switch_VT_1
! The "F2" key generates F2 and XF86_Switch_VT_2
! The "F3" key generates F3 and XF86_Switch_VT_3
! The "F4" key generates F4 and XF86_Switch_VT_4
! The "F5" key generates F5 and XF86_Switch_VT_5
! The "F6" key generates F6 and XF86_Switch_VT_6
! The "F7" key generates F7 and XF86_Switch_VT_7
! The "F8" key generates F8 and XF86_Switch_VT_8
! The "F9" key generates F9 and XF86_Switch_VT_9
! The "F10" key generates F10 and XF86_Switch_VT_10
! The "F11" key generates F11 and XF86_Switch_VT_11
! The "F12" key generates F12 and XF86_Switch_VT_12
! The "Print Screen" key generates Caps_Lock, and the Lock modifier
! The "Scroll Lock" key generates Scroll_Lock, and has no modifiers
! The "" '" key generates grave, asciitilde, Cyrillic_io, Cyrillic_IO, notsign, and notsign
! The "! 1 ¹" key generates 1, exclam, 1, exclam, onesuperior, and exclamdown
! The "@ 2 ²" key generates 2, at, 2, quotedbl, twosuperior, and oneeighth
! The "# 3 ³" key generates 3, numbersign, 3, numbersign, threesuperior, and sterling
! The "$ 4 £" key generates 4, dollar, 4, asterisk, onequarter, and dollar
! The "% 5 ¢" key generates 5, percent, 5, colon, onehalf, and threeeighths
! The "¨ 6 ¬" key generates 6, asciicircum, 6, comma, threequarters, and fiveeighths
! The "& 7" key generates 7, ampersand, 7, period, braceleft, and seveneighths
! The "* 8" key generates 8, asterisk, 8, semicolon, bracketleft, and trademark
! The "( 9" key generates 9, parenleft, 9, parenleft, bracketright, and plusminus
! The ") 0" key generates 0, parenright, 0, parenright, braceright, and degree
! The "_ -" key generates minus, underscore, minus, underscore, backslash, and questiondown
! The "+ = §" key generates equal, plus, equal, plus, dead_cedilla, and dead_ogonek
! The "Backspace" key generates BackSpace and Terminate_Server
! The "Num Lock" key generates Alt_L and ISO_Prev_Group, and the Mod1 modifier
! The "/" key generates KP_Divide and XF86_Ungrab
! The "*" key generates KP_Multiply and XF86_ClearGrab
! The "-" key generates KP_Subtract and XF86_Prev_VMode
! The "Q" key generates q, Q, Cyrillic_shorti, Cyrillic_SHORTI, at, and Greek_OMEGA
! The "W" key generates w, W, Cyrillic_tse, Cyrillic_TSE, lstroke, and Lstroke
! The "E" key generates e, E, Cyrillic_u, and Cyrillic_U
! The "R" key generates r, R, Cyrillic_ka, Cyrillic_KA, paragraph, and registered
! The "T" key generates t, T, Cyrillic_ie, Cyrillic_IE, tslash, and Tslash
! The "Y" key generates y, Y, Cyrillic_en, Cyrillic_EN, leftarrow, and yen
! The "U" key generates u, U, Cyrillic_ghe, Cyrillic_GHE, downarrow, and uparrow
! The "I" key generates i, I, Cyrillic_sha, Cyrillic_SHA, rightarrow, and idotless
! The "O" key generates o, O, Cyrillic_shcha, Cyrillic_SHCHA, oslash, and Ooblique
! The "P" key generates p, P, Cyrillic_ze, Cyrillic_ZE, thorn, and THORN
! The "` '" key generates bracketleft, braceleft, Cyrillic_ha, Cyrillic_HA, dead_diaeresis, and dead_abovering
! The "{ [ ª" key generates bracketright, braceright, Cyrillic_hardsign, Cyrillic_HARDSIGN, dead_tilde, and dead_macron
! The "7 Home" key generates 7, ampersand, 7, period, braceleft, and seveneighths
! The "8 UpArrow" key generates 8, asterisk, 8, semicolon, bracketleft, and trademark
! The "9 Pg Up" key generates 9, parenleft, 9, parenleft, bracketright, and plusminus
! The "+" key generates KP_Add and XF86_Next_VMode
! The "Caps Lock" key generates Control_L, and the Control modifier
! The "A" key generates a, A, Cyrillic_ef, Cyrillic_EF, ae, and AE
! The "S" key generates s, S, Cyrillic_yeru, Cyrillic_YERU, ssharp, and section
! The "D" key generates d, D, Cyrillic_ve, Cyrillic_VE, eth, and ETH
! The "F" key generates f, F, Cyrillic_a, Cyrillic_A, dstroke, and ordfeminine
! The "G" key generates g, G, Cyrillic_pe, Cyrillic_PE, eng, and ENG
! The "H" key generates h, H, Cyrillic_er, Cyrillic_ER, hstroke, and Hstroke
! The "J" key generates j, J, Cyrillic_o, and Cyrillic_O
! The "K" key generates k, K, Cyrillic_el, Cyrillic_EL, kra, and ampersand
! The "L" key generates l, L, Cyrillic_de, Cyrillic_DE, lstroke, and Lstroke
! The "Ç" key generates semicolon, colon, Cyrillic_zhe, Cyrillic_ZHE, dead_acute, and dead_doubleacute
! The "^ ~" key generates apostrophe, quotedbl, Cyrillic_e, Cyrillic_E, dead_circumflex, and dead_caron
! The "} ] º" key generates backslash, bar, backslash, bar, dead_grave, and dead_breve
! The "4 LeftArrow" key generates 4, dollar, 4, asterisk, onequarter, and dollar
! The "5" key generates 5, percent, 5, colon, onehalf, and threeeighths
! The "6 RightArrow" key generates 6, asciicircum, 6, comma, threequarters, and fiveeighths
! The "." key generates NoSymbol
! The "Shift" key generates Shift_L and ISO_Prev_Group
! The "| \" key generates less, greater, slash, bar, bar, and brokenbar
! The "Z" key generates z, Z, Cyrillic_ya, Cyrillic_YA, guillemotleft, and less
! The "X" key generates x, X, Cyrillic_che, Cyrillic_CHE, guillemotright, and greater
! The "C" key generates c, C, Cyrillic_es, Cyrillic_ES, cent, and copyright
! The "V" key generates v, V, Cyrillic_em, Cyrillic_EM, leftdoublequotemark, and grave
! The "B" key generates b, B, Cyrillic_i, Cyrillic_I, rightdoublequotemark, and apostrophe
! The "N" key generates n, N, Cyrillic_te, and Cyrillic_TE
! The "M" key generates m, M, Cyrillic_softsign, Cyrillic_SOFTSIGN, mu, and masculine
! The "< ," key generates comma, less, Cyrillic_be, Cyrillic_BE, horizconnector, and multiply
! The "> ." key generates period, greater, Cyrillic_yu, Cyrillic_YU, periodcentered, and division
! The ": ;" key generates slash, question, slash, question, dead_belowdot, and dead_abovedot
! The "? / °" key generates NoSymbol
! The "Shift" key generates Shift_R and ISO_Next_Group
! The "1 End" key generates 1, exclam, 1, exclam, onesuperior, and exclamdown
! The "2 DownArrow" key generates 2, at, 2, quotedbl, twosuperior, and oneeighth
! The "3 Pg Dn" key generates 3, numbersign, 3, numbersign, threesuperior, and sterling
! The "Enter" key generates Return
! The "=/+/" key generates Alt_L and ISO_Prev_Group, and the Mod1 modifier
! The "Alt" key generates Meta_L, and the Mod4 modifier
! The "Alt" key generates Meta_R, and the Mod4 modifier
! The "##" key generates Control_R, and the Control modifier
! The "Ctrl" key generates Alt_L and ISO_Prev_Group, and the Mod1 modifier
! The "0 Ins" key generates 0, parenright, 0, parenright, braceright, and degree
! The ", Del" key generates period, greater, Cyrillic_yu, Cyrillic_YU, periodcentered, and division

keycode 0x09 =	Escape
keycode 0x43 =	F1		XF86_Switch_VT_1
keycode 0x44 =	F2		XF86_Switch_VT_2
keycode 0x45 =	F3		XF86_Switch_VT_3
keycode 0x46 =	F4		XF86_Switch_VT_4
keycode 0x47 =	F5		XF86_Switch_VT_5
keycode 0x48 =	F6		XF86_Switch_VT_6
keycode 0x49 =	F7		XF86_Switch_VT_7
keycode 0x4A =	F8		XF86_Switch_VT_8
keycode 0x4B =	F9		XF86_Switch_VT_9
keycode 0x4C =	F10		XF86_Switch_VT_10
keycode 0x5F =	F11		XF86_Switch_VT_11
keycode 0x60 =	F12		XF86_Switch_VT_12
keycode 0x6F =	Caps_Lock
keycode 0x4E =	Scroll_Lock
keycode 0x6E =	Pause		Break
keycode 0x31 =	grave		asciitilde	Cyrillic_io	Cyrillic_IO	notsign		notsign
keycode 0x0A =	1		exclam		1		exclam		onesuperior	exclamdown
keycode 0x0B =	2		at		2		quotedbl	twosuperior	oneeighth
keycode 0x0C =	3		numbersign	3		numbersign	threesuperior	sterling
keycode 0x0D =	4		dollar		4		asterisk	onequarter	dollar
keycode 0x0E =	5		percent		5		colon		onehalf		threeeighths
keycode 0x0F =	6		asciicircum	6		comma		threequarters	fiveeighths
keycode 0x10 =	7		ampersand	7		period		braceleft	seveneighths
keycode 0x11 =	8		asterisk	8		semicolon	bracketleft	trademark
keycode 0x12 =	9		parenleft	9		parenleft	bracketright	plusminus
keycode 0x13 =	0		parenright	0		parenright	braceright	degree
keycode 0x14 =	minus		underscore	minus		underscore	backslash	questiondown
keycode 0x15 =	equal		plus		equal		plus		dead_cedilla	dead_ogonek
keycode 0x16 =	BackSpace	Terminate_Server
keycode 0x6A =	Insert
keycode 0x61 =	Home
keycode 0x63 =	Prior
keycode 0x4D =	Alt_L		ISO_Prev_Group
keycode 0x70 =	KP_Divide	XF86_Ungrab
keycode 0x3F =	KP_Multiply	XF86_ClearGrab
keycode 0x52 =	KP_Subtract	XF86_Prev_VMode
keycode 0x17 =	Tab		ISO_Left_Tab
keycode 0x18 =	q		Q		Cyrillic_shorti	Cyrillic_SHORTI	at		Greek_OMEGA
keycode 0x19 =	w		W		Cyrillic_tse	Cyrillic_TSE	lstroke		Lstroke
keycode 0x1A =	e		E		Cyrillic_u	Cyrillic_U
keycode 0x1B =	r		R		Cyrillic_ka	Cyrillic_KA	paragraph	registered
keycode 0x1C =	t		T		Cyrillic_ie	Cyrillic_IE	tslash		Tslash
keycode 0x1D =	y		Y		Cyrillic_en	Cyrillic_EN	leftarrow	yen
keycode 0x1E =	u		U		Cyrillic_ghe	Cyrillic_GHE	downarrow	uparrow
keycode 0x1F =	i		I		Cyrillic_sha	Cyrillic_SHA	rightarrow	idotless
keycode 0x20 =	o		O		Cyrillic_shcha	Cyrillic_SHCHA	oslash		Ooblique
keycode 0x21 =	p		P		Cyrillic_ze	Cyrillic_ZE	thorn		THORN
keycode 0x22 =	bracketleft	braceleft	Cyrillic_ha	Cyrillic_HA	dead_diaeresis	dead_abovering
keycode 0x23 =	bracketright	braceright	Cyrillic_hardsign	Cyrillic_HARDSIGN	dead_tilde	dead_macron
keycode 0x24 =	Return
keycode 0x6B =	Delete
keycode 0x67 =	End
keycode 0x69 =	Next
keycode 0x4F =	7		ampersand	7		period		braceleft	seveneighths
keycode 0x50 =	8		asterisk	8		semicolon	bracketleft	trademark
keycode 0x51 =	9		parenleft	9		parenleft	bracketright	plusminus
keycode 0x56 =	KP_Add		XF86_Next_VMode
keycode 0x42 =	Control_L
keycode 0x26 =	a		A		Cyrillic_ef	Cyrillic_EF	ae		AE
keycode 0x27 =	s		S		Cyrillic_yeru	Cyrillic_YERU	ssharp		section
keycode 0x28 =	d		D		Cyrillic_ve	Cyrillic_VE	eth		ETH
keycode 0x29 =	f		F		Cyrillic_a	Cyrillic_A	dstroke		ordfeminine
keycode 0x2A =	g		G		Cyrillic_pe	Cyrillic_PE	eng		ENG
keycode 0x2B =	h		H		Cyrillic_er	Cyrillic_ER	hstroke		Hstroke
keycode 0x2C =	j		J		Cyrillic_o	Cyrillic_O
keycode 0x2D =	k		K		Cyrillic_el	Cyrillic_EL	kra		ampersand
keycode 0x2E =	l		L		Cyrillic_de	Cyrillic_DE	lstroke		Lstroke
keycode 0x2F =	semicolon	colon		Cyrillic_zhe	Cyrillic_ZHE	dead_acute	dead_doubleacute
keycode 0x30 =	apostrophe	quotedbl	Cyrillic_e	Cyrillic_E	dead_circumflex	dead_caron
keycode 0x33 =	backslash	bar		backslash	bar		dead_grave	dead_breve
keycode 0x53 =	4		dollar		4		asterisk	onequarter	dollar
keycode 0x54 =	5		percent		5		colon		onehalf		threeeighths
keycode 0x55 =	6		asciicircum	6		comma		threequarters	fiveeighths
keycode 0x86 =	NoSymbol
keycode 0x32 =	Shift_L		ISO_Prev_Group
keycode 0x5E =	less		greater		slash		bar		bar		brokenbar
keycode 0x34 =	z		Z		Cyrillic_ya	Cyrillic_YA	guillemotleft	less
keycode 0x35 =	x		X		Cyrillic_che	Cyrillic_CHE	guillemotright	greater
keycode 0x36 =	c		C		Cyrillic_es	Cyrillic_ES	cent		copyright
keycode 0x37 =	v		V		Cyrillic_em	Cyrillic_EM	leftdoublequotemark	grave
keycode 0x38 =	b		B		Cyrillic_i	Cyrillic_I	rightdoublequotemark	apostrophe
keycode 0x39 =	n		N		Cyrillic_te	Cyrillic_TE
keycode 0x3A =	m		M		Cyrillic_softsign	Cyrillic_SOFTSIGN	mu		masculine
keycode 0x3B =	comma		less		Cyrillic_be	Cyrillic_BE	horizconnector	multiply
keycode 0x3C =	period		greater		Cyrillic_yu	Cyrillic_YU	periodcentered	division
keycode 0x3D =	slash		question	slash		question	dead_belowdot	dead_abovedot
keycode 0x7B =	NoSymbol
keycode 0x3E =	Shift_R		ISO_Next_Group
keycode 0x62 =	Up
keycode 0x57 =	1		exclam		1		exclam		onesuperior	exclamdown
keycode 0x58 =	2		at		2		quotedbl	twosuperior	oneeighth
keycode 0x59 =	3		numbersign	3		numbersign	threesuperior	sterling
keycode 0x6C =	Return
keycode 0x25 =	Control_L
keycode 0x73 =	Alt_L		ISO_Prev_Group
keycode 0x40 =	Meta_L
keycode 0x41 =	space
keycode 0x71 =	Meta_R
keycode 0x74 =	Meta_R
keycode 0x75 =	Control_R
keycode 0x6D =	Alt_L		ISO_Prev_Group
keycode 0x64 =	Left
keycode 0x68 =	Down
keycode 0x66 =	Right
keycode 0x5A =	0		parenright	0		parenright	braceright	degree
keycode 0x5B =	period		greater		Cyrillic_yu	Cyrillic_YU	periodcentered	division

clear Shift
clear Lock
clear Control
clear Mod1
clear Mod2
clear Mod3
clear Mod4
clear Mod5

add    Shift   = Shift_L Shift_R
add    Lock    = Caps_Lock
add    Control = Control_L Control_L Control_R
add    Mod1    = Alt_L Alt_L Alt_L
add    Mod4    = Meta_L Meta_R Meta_R Meta_R