Subject: FVWM: Sending an application a Key-Binding

From: Ukpong Ukpong <[email-masked]>
Date: Sun, 29 Feb 2004 04:28:16 +0000 (GMT)

Here we go....
I some times have mplayer playing mp3's in the backgruond when working
is it possible to configure a key binding that sends a predefined key to 
mplayer. Thus will be extremely usefull, ie cause skip songs that u don't 
like in the current playlist..

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Maciej Delmanowski <[email-masked]>
Date: Sun, 29 Feb 2004 10:58:37 +0100

> like in the current playlist..

I'm doing it with XMMS and xmms-shell. For example playing control is done
like this:

Key z A M Exec exec xmms --rew
Key x A M Exec exec xmms --play-pause
Key b A M Exec exec xmms --next

I know that mplayer uses slave mode to receive commands, but nothing more
actually. Probaby you will have to Exec exec echo 'command' > some_pipe?

Cheers
harnir

-- 
.---- --- -
|   Maciej Delmanowski   .
' http://ble.pl/~harnir/ |
               - --- ----'