Subject: FVWM: Testing custom functions

From: Ryan Daly <[email-masked]>
Date: Mon, 16 Feb 2004 13:21:30 -0500

What's the best way to test the various lines of a function?

Can I start something that will actually run my function and show me the
results without actually needing to put it in my configuration (and
therefore sometimes breaking my config...)?

Thanks.
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 16 Feb 2004 18:24:24 +0000 (GMT)

--- Ryan Daly <[email-masked]> wrote: > What's the best way to test the
various lines of a function?
> therefore sometimes breaking my config...)?

Use:

FvwmConsole

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 16 Feb 2004 19:29:08 +0100 (CET)

> therefore sometimes breaking my config...)?

You can use FvwmCommand.
For this to work you must start the module FvwmCommandS at startup.
Then you can issue Fvwm commands in a shell like this:

$ FvwmCommand "AddToFunc I do 1"
$ FvwmCommand "+ I do 2"

etc. like if it had been in config

//Marcus