Subject: FVWM: applet for displaying the battery status on a laptop

From: [email-masked] (Marc Schlienger)
Date: Fri, 27 Feb 2004 18:57:28 +0100

Hi,

I'm using Fvwm2 and need an applet for displaying the battery status on a 
laptop. I've tried some WindowMaker applets but they did'nt work properly.
For example, wmbatteries does'nt update the status. 
Is there an application which works fine with Fvwm2 and ACPI?

Marc 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Fri, 27 Feb 2004 18:22:18 +0000 (GMT)

> Is there an application which works fine with Fvwm2 and ACPI?

There's a whole plethora of apps out there:

xapm - X program to monitor APM battery status
xbatt - Display battery status
xbattbar - Display battery status in X11
xfce4-battery-plugin - Battery monitor plugin for the XFce4 panel

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: parv <[email-masked]>
Date: Fri, 27 Feb 2004 17:20:52 -0500

in message <[email-masked]>,
wrote Marc Schlienger thusly...
>
> I'm using Fvwm2 and need an applet for displaying the battery
> status on a laptop. I've tried some WindowMaker applets but they
> did'nt work properly.  For example, wmbatteries does'nt update the
> status.  Is there an application which works fine with Fvwm2 and
> ACPI?

Have you tried asapm?  Do not know if it works w/ ACPI going by just
its name.  I do not have any problem w/ it displaying the charge
level & time remaining of batteries in Dell Inspiron 5000e along w/
APM.

  - Parv

--

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 28 Feb 2004 13:27:35 +0100

> Is there an application which works fine with Fvwm2 and ACPI?

I use wmacpi which works fine here. You can found it via

	http://www.ne.jp/asahi/linux/timecop/

Regards, Olivier

---

From: Remko Troncon <[email-masked]>
Date: Sat, 28 Feb 2004 15:19:42 +0100

> Is there an application which works fine with Fvwm2 and ACPI?

Not strictly what you asked, but i use gkrellm for monitoring battery
status and much much more. IMHO, gkrellm is the perfect addition to an
FVWM desktop.

cheers,
Remko

---

From: calmar <[email-masked]>
Date: Sat, 28 Feb 2004 16:37:43 +0100

Remko Troncon <[email-masked]> writes:

> status and much much more. IMHO, gkrellm is the perfect addition to an

I hope xosview is too... (when only basic things are needed), and
everybody has it.

http://tinyurl.com/3xweh

greetings and thanks
marco

-- 
  calmar 
           (o_         GNU/Linux is GREAT      
           //\                 
           V_/_        http://www.calmar.ws

---

From: Micha Feigin <[email-masked]>
Date: Sun, 29 Feb 2004 13:45:31 +0200

> Is there an application which works fine with Fvwm2 and ACPI?

Not exactly what you want but I use a dynamic menu to show to output of
acpi which keeps the desktop unclatered (I don't like much eye candy
since I rairly see the desktop anyway as most of the windows are
maximized).

This also shows the time in the title (can probably be done more
efficiently, but I didn't have the time yet, don't know if sed will be
lighter then perl for this).

DestroyMenu System
AddToMenu System "System" Title
+ DynamicPopUpAction      Function build_system_menu

DestroyFunc build_system_menu
AddToFunc build_system_menu
+ I DestroyMenu System
+ I Piperead 'perl -e \'open TIME, \"date +\\\"%T %a %b %d %Y %Z\\\"|\"; while (<TIME>) { chomp; print \"AddtoMenu System \\\"$_\\\" Title\\n\"}\''
+ I Piperead 'perl -e \'open ACPI, \"acpi -V|\"; while (<ACPI>) { chomp; s/^\\s\\s//; s/%/%%/g; print \"AddtoMenu System \\\"$_\\\" nop\\n\"}\''
+ I AddToMenu System DynamicPopDownAction Function destroy-system-menu
+ I ChangeMenuStyle "NoHotKeys" System

DestroyFunc destroy-system-menu
AddToFunc destroy-system-menu 
+ I DestroyMenu System
+ I AddToMenu System "System" Title
+ I AddToMenu System DynamicPopUpAction Function build_system_menu