Subject: FVWM: GKRellm start placement

From: "Ryan Daly" <[email-masked]>
Date: Tue, 17 Feb 2004 10:47:57 -0500 (EST)

I'm trying to have GKRellm start in a certain location on my desktop. 
For some reason, the app starts, goes to my specified location, but then
warps itself to +0+0.  Is there a Style option that I may be missing?  Am
I not covering something with my function?

AddToFunc "GK-Init"
  + "I" Exec exec /usr/bin/gkrellm
  + "I" Wait gkrellm
  + "I" Next gkrellm ResizeMove 97x449-0+64

Thanks.
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nuno Alexandre <[email-masked]>
Date: Tue, 17 Feb 2004 18:32:34 +0100

On Tue, 17 Feb 2004 10:47:57 -0500 (EST) 
Ryan Daly wrote:

> For some reason, the app starts, goes to my specified location, but
> then warps itself to +0+0.  Is there a Style option that I may be
> missing?  Am I not covering something with my function?
> 
> AddToFunc "GK-Init"

Hi.
Gkrellm2 has an option in its properties, where you can check [x] to
"remember exit position"

That works :)
--
/na

---

From: Thomas Adam <[email-masked]>
Date: Tue, 17 Feb 2004 17:40:41 +0000 (GMT)

--- Nuno Alexandre <[email-masked]> wrote: > On Tue, 17 Feb 2004 10:47:57
-0500 (EST) 

> Gkrellm2 has an option in its properties, where you can check [x] to

You have to also remember that gkrellm, along with xmms like to control
thing themselves and so do not pass any hints back to the WM - which I
consider to be very rude. Not to mention a real pain the backside.

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kingsly John <[email-masked]>
Date: Tue, 17 Feb 2004 23:13:29 +0530

>   + "I" Next gkrellm ResizeMove 97x449-0+64

Whoa!! .. why all this complexity ?

In gkrellm..

Configuration->General(left menu)->Options(tab) 

check "Remember screen location at exit and to it at next startup"

Isn't that what u are trying to do ?

And I have the following style defined so that gkrellm stays on all the
desktops without any decorations.

Style "gkrellm" Sticky, WindowListSkip, StaysOnTop, CirculateSkip, BorderWidth 0, NoTitle, NoHandles, ClickToFocus

Kingsly

---

From: "Ryan Daly" <[email-masked]>
Date: Tue, 17 Feb 2004 14:02:29 -0500 (EST)

> Isn't that what u are trying to do ?

Yep, that's what I'm trying to do.  Key word is trying.  I have that box
checked and still GKRellm goes to +0+0.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Tue, 17 Feb 2004 11:36:38 -0800 (PST)

> checked and still GKRellm goes to +0+0.

Perhaps the remembered position is +0+0.
What happens if you uncheck that box?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Ryan Daly" <[email-masked]>
Date: Tue, 17 Feb 2004 14:44:49 -0500 (EST)

> What happens if you uncheck that box?

That's a good thought.  However, when I unchecked the box, it still warps
to +0+0.  Thanks for the suggestion.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 17 Feb 2004 14:53:56 -0500

> to +0+0.  Thanks for the suggestion.

In ~/.gkrellm/user_config I have a line like this:

save_position 1

In ~/.gkrellm/data/startup_position  I have a line like this:

1438 100

Hope that helps...
-- 
Dan Espen                           E-mail: [email-masked]

---

From: Ryan Daly <[email-masked]>
Date: Tue, 17 Feb 2004 19:10:16 -0500

> In ~/.gkrellm/data/startup_position  I have a line like this:

Yeah, actually I had those config files too.  I think the fact that I
was using ManualPlacement was messing things up.  I changed the Style to
SmartPlacement for gkrellm and things appear to be working just fine.

Thanks for all the hints.

---

From: stu <[email-masked]>
Date: Wed, 18 Feb 2004 10:00:01 +0200

>   + "I" Next gkrellm ResizeMove 97x449-0+64

Have you tried gkrellm --geometry ?

-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 18 Feb 2004 10:03:41 +0100

>   + "I" Next gkrellm ResizeMove 97x449-0+64

How about

  + I exec /usr/bin/gkrellm --geometry 97x449-0+64

?

Ciao

Dominik ^_^  ^_^

---

From: calmar <[email-masked]>
Date: Wed, 18 Feb 2004 11:29:02 +0100

Dominik Vogt <[email-masked]> writes:

Hi Dominik,

>   + I exec /usr/bin/gkrellm --geometry 97x449-0+64

I had(ve) also my problems with something similar like the
above. (Actually it works fine for me, because I found another
solution).

But _why_ is the function-definition GK-Init not working above?
Would there be any explanation? is it because some programs want
to do 'their' own thing? Is it because some p.e Resize.. Commands
have some undocumented limitations? 

Greetings,...

marco candrian

-- 
  calmar 
           (o_         GNU/Linux is GREAT      
           //\                 
           V_/_        http://www.calmar.ws

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 18 Feb 2004 12:15:15 +0100

> But _why_ is the function-definition GK-Init not working above?

Because gkrellm moves its own window after fvwm moves it.  With

  Style gkrellm NoPPosition, FixedPPosition

you should be able to prevent gkrellm from moving its windows.
(The NoPPosition option is probably unnecessary).

Ciao

Dominik ^_^  ^_^

---

From: "Ryan Daly" <[email-masked]>
Date: Wed, 18 Feb 2004 08:51:20 -0500 (EST)

> Have you tried gkrellm --geometry ?

Oh yeah, that was the first thing I tried.  Didn't work, though.

---

From: "Ryan Daly" <[email-masked]>
Date: Wed, 18 Feb 2004 08:53:02 -0500 (EST)

>   + I exec /usr/bin/gkrellm --geometry 97x449-0+64

Yep, had that, too.  I guess the problem I was having was the fact that I
had manual placement in there and it was confusing gkrellm, since it
likes to tell itself where to sit.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: calmar <[email-masked]>
Date: Wed, 18 Feb 2004 20:42:54 +0100

> (The NoPPosition option is probably unnecessary).
I see...

Thanks
Marco Candrian

---

From: Denis Artru <[email-masked]>
Date: Sat, 21 Feb 2004 23:44:47 +0100 (CET)

>likes to tell itself where to sit.

gkrellm option --geometry is +x+y, so the 97x449 is not good.
I launch gkrellm at beginnig on the top right corner using:

Style "*"           DecorateTransient, NoPPosition

Style "gkrellm"         Sticky,WindowListSkip,NoTitle
Style "gkrellm"         CirculateSkipIcon,CirculateSkip

AddToFunc InitFunction
+ "I" exec gkrellm --geometry -0+0

It works fine, I don't know if it can help.

Denis

--
Denis Artru