Subject: FVWM: Ignore a window completely

From: Benjamin Goedeke <[email-masked]>
Date: Mon, 16 Feb 2004 10:04:46 +0100

Hi everybody,

Is there any way to have fvwm (2.5.8) ignore a certain window 
completely? I have a terminal sitting on my desktop that runs a system 
monitor and I want it to behave much like root-tail does. I.e. I want a 
click in this window to be interpreted as a click on the root window. Is 
that possible through some config option in my rc?

Thanks for any pointers,
Ben
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 16 Feb 2004 14:45:05 +0100

On Mon, Feb 16, 2004 at 10:04:46AM +0100, Benjamin Goedeke wrote:
> completely?

No, but I just coded a new style "Unmanaged" to achieve this
effect with the latest development code (i.e. 2.5.9).

> I have a terminal sitting on my desktop that runs a system 
> monitor and I want it to behave much like root-tail does.

Works with the patch.

> I.e. I want a click in this window to be interpreted as a click
> on the root window. Is that possible through some config option
> in my rc?

I'm afraid this can only be done if the application does not
handle button events itself.  But usually terminal applications
eat up mouse events before they reach the root window.

Ciao

Dominik ^_^  ^_^