Subject: FVWM: Automatic menu without mouse click

From: Ukpong Ukpong <[email-masked]>
Date: Mon, 16 Feb 2004 00:51:59 +0000 (GMT)

Hey all 
	Is it possible to make a menu appear without the user the user 
having pressed any buttons..Then make the menu dissapear after a timeout..

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 16 Feb 2004 03:18:06 +0000

On 16 Feb 2004 00:51:59 +0000, Ukpong Ukpong wrote:
> having pressed any buttons..

Yes, using commands from modules or Schedule'd commands.

> Then make the menu dissapear after a timeout..

No, this is not currently possible. Only user may close a menu.

But you may auto popup and then auto close normal windows, like
all kinds of flash windows, dialogs and modules.

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 16 Feb 2004 07:13:02 +0100 (CET)

> No, this is not currently possible. Only user may close a menu.
I've been thinking about adding functionallity like that.
Especially a possibility to open a "torn-off" version of a menu. So you
could for example have double-clicking the root window tear off the root
menu.

But it's not possible currently (and wont be until 2.7.x series).

//Marcus

---

From: Ukpong Ukpong <[email-masked]>
Date: Mon, 16 Feb 2004 06:27:45 +0000 (GMT)

> all kinds of flash windows, dialogs and modules.

Errr  whats a flash window....its seems interesting how does one 
generate it....
I am associating a workin directory with each desktop and need a way of 
notifying the user of the working directory associated to that desktop...