Subject: FVWM: Visually locating mouse cursor

From: Robert Knighten <[email-masked]>
Date: Tue, 17 Feb 2004 15:52:35 -0800

>From time to time I loose track of the location of the mouse cursor, and may
have trouble locating it.  Windows XP has a handy feature whereby pressing the
control key produces a momentary animation pointing to the mouse cursor.  Does
someone have a vaguely similar facility using fvwm?  Anything that will draw
attention to the cursor (e.g. flash it, put a box around it, ???) would be
good, and any short key sequence will do.

Thank you for any help.

-- Bob

-- 
Robert L. Knighten
[email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Wed, 18 Feb 2004 00:04:23 +0000 (GMT)

--- Robert Knighten <[email-masked]> wrote: 

> control key produces a momentary animation pointing to the mouse cursor.

>From the FAQ (#7.16):

Key Super_L A A Exec xmessage -name "SmallBlob" -bg red \
      -fg white -nearmouse -timeout 1 'I am here!'
    Style SmallBlob UsePPosition, NoTitle, NoHandles, BorderWidth 10

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 18 Feb 2004 00:07:55 +0000

> good, and any short key sequence will do.

Take a look at FAQ #7.16.

Or maybe even:

  Key Super_L A N Exec xmessage -name "SmallBlob" -bg red -fg white -nearmouse -timeout 1 -button "" -xrm '*cursorName: none' -xrm '*borderWidth: 2' -xrm '*borderColor: yellow' -xrm '*Margin: 12' 'I am here!'

Regards,
Mikhael.

---

From: Robert Knighten <[email-masked]>
Date: Tue, 17 Feb 2004 16:11:50 -0800

> >From the FAQ (#7.16):

<BLUSH!> I really do know enough to read the FAQ, but I slipped on this.
Thank you.

-- Bob

-- 
Robert L. Knighten
[email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 18 Feb 2004 00:27:17 +0000

>   Key Super_L A N Exec xmessage -name "SmallBlob" -bg red -fg white -nearmouse -timeout 1 -button "" -xrm '*cursorName: none' -xrm '*borderWidth: 2' -xrm '*borderColor: yellow' -xrm '*Margin: 12' '…

BTW, if you are doing this; recent xmessage always puts ugly vertical
sidebar, so it may be a good idea to add this line to ~/.Xdefaults:

  Xmessage*form*scrollVertical: false

Regards,
Mikhael.

---

From: Robert Knighten <[email-masked]>
Date: Tue, 17 Feb 2004 16:44:17 -0800

Thank you, not only for the immediate help but for all of the great and
generous work you do on fvwm.  I've been using fvwm for just shy of 10 years
now having switched from twm shortly after fvwm was released.  It was a good
idea when it appeared and has just gotten better over the years.

-- Bob
-- 
Robert L. Knighten
[email-masked]