Subject: FVWM: Background switching

From: Stephen R Dennison <[email-masked]>
Date: Thu, 05 Feb 2004 19:20:07 -0500

Anyone know of a good program to use in conjunction with FvwmBacker that
caches background images?

I'm just using xloadimage now, and there's a bit of a delay as it has to
read the image each time before displaying it, and if I switch
desks/pages too quickly it sometimes doesn't switch the image to the
right one because the last exec is still running and it trumps the
latter.

--s.r.d.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 5 Feb 2004 06:52:09 +0000 (GMT)

> caches background images?

You could use Rox-Filer[1] to control this, or have a look at 'chbg' (a
debian package).

-- Thomas Adam

[1] http://rox.sf.net

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Feb 2004 10:26:51 +0100

> caches background images?

Fvwm.

Fvwm caches images.  Define colour sets for the backgrounds and
use them in FvwmBacker.  The images can even be used in other
modules or the fvwm core without loading them again:

  colorset 77 tiledpixmap image1.xpm
  colorset 88 tiledpixmap image2.png
  *FvwmBacker: Command (Desk *, Page 0 *) Colorset 77
  *FvwmBacker: Command (Desk *, Page 1 *) Colorset 88
  FvwmBacker

The only drawback I see is that fvwm supports only png, xpm and
xbm.  But there are plenty of programs around to convert your
images to a suitable format.

> right one because the last exec is still running and it trumps the

Ciao

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Thu, 5 Feb 2004 10:39:32 +0100

Hi there,

>   *FvwmBacker: Command (Desk *, Page 1 *) Colorset 88

Wow, I am pretty impressed by the abilities of fvwm :-) One
should put this solution in the FAQ.

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive your mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].