Subject: Re: FVWM: Really StaysOnBottom

From: Thomas Adam <[email-masked]>
Date: Sat, 21 Feb 2004 13:25:40 +0000 (GMT)

--- Stefan Kamphausen <[email-masked]> wrote: 

> 
> Hi Thomas,
> 
> I response in private because this mail doesn't contain much
> information for the world...

I've CC'ed fvwm, since my reply may well do so :)
 
>  > > 2. and in my .fvwm2rc:
>  > >    Style  "hidden"      NoTitle, WindowListSkip, NoHandles, Sticky,
> \
>  > >                         BorderWidth 0, Layer 0, ClickToFocus,
> StaysPut
>  >                                                                 
> ^^^^^^^
>  > Try replacing that with: StaysOnBottom
> 
> Of course I already did that but it didn't work.  Funny enough: today
> it does :-)
> Don't ask me what my error was, probably I am guilty of some plain
> stupidity.  

Probably :) But you have to remember that the commands *have* to be
consistent in terms of spelling:

startsonpage
StartsOnPage
STARTSONPAGE

are all equivilent and should work, yet:

Startsonpage
STartsonpage

will not. 

>  > > (And (just as a side note): is there any way to start a programm at
> a
>  > >  specific position besides the -geometry option?  Like, having my
>  > >  XEmacs always live at +0+0?)
>  > 
>  > Yes, add them to your ~/.Xdefaults file:
>  > 
>  > XEmacs*Geometry: 0+0
> 
> OK, now I have an alias for "xemacs" giving -geometry option.

No, the whole point of that file is so that you do not need the -geometry
option to Xemacs, since the resource hint for geometry is already defined
in the file.
 
> I must admit, though, that I liked the matched-window mechanism in
> Sawfish.
> BTW (and may now this email gets some public interest at all?): is
> there any plan to make the matching in regexp style?
> For example:
> REStyle "^mozilla" StartsOnPage ....

At the moment, nonse, since matching is done, either by Name, Class or
Resource.

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 21 Feb 2004 22:41:17 +0000

> are all equivilent and should work, yet:

Tomas, this is incorrect. All these spellings should work.

> option to Xemacs, since the resource hint for geometry is already defined

This is a good solution, but there may be very good reasons to create a
shortcut wrapper rather that to put such option into ~/.Xdefaults. For
example, to preserve the default behaviour of smart or manual placement.

> At the moment, nonse, since matching is done, either by Name, Class or

Tomas, this is not quite what was asked.

FVWM already supports globs, these are less powerful then regular
exressions, but in practice they are more than enough. So, your
REStyle line may be expressed like:

  Style "mozilla*" StartsOnPage ...

Regards,
Mikhael.

---

From: Thomas Adam <[email-masked]>
Date: Sat, 21 Feb 2004 22:45:32 +0000 (GMT)

> Tomas, this is incorrect. All these spellings should work.

Oh, when was that fixed? I seem to recall that this never used to work.
 
> example, to preserve the default behaviour of smart or manual placement.

Agreed, It is very much situation dependant.
 
>   Style "mozilla*" StartsOnPage ...

Yes, I did not explain that very well at all. I knew globs were supported,
but AFAIK, regexps are not.

Thanks,

-- Thomas Adam

=====