Subject: FVWM: Re: Focus Bug in FvwmTabs (2.6)

From: xavier <[email-masked]>
Date: Sun, 22 Feb 2004 14:12:53 -0500

On Thu, Nov 27, 2003 at 01:34:37AM +0100, Tobias wrote:
|
|Finaly i got time to briefly look into the code.
|I found the error at takeFocus():
|----------
|<...>
|    else
|    {
|        $winId = $tabWin{$tId}{tab}[$tabWin{$tId}{currentTab}]{winId};
|    }
|    # "revert-to" (2nd) arg can be 'Parent', 'PointerRoot' or 'None'.
|    $xServer->SetInputFocus($winId, 'Parent', $tabWin{$tId}{focusTimestamp}); 
|    # $fvwm->debug("takeFocus(end) winId=$winId");
|<...>
|----------
|
|Changing the SetInputFocus() to 
|"$xServer->SetInputFocus($winId, 'Parent', 'CurrentTime');"
|its all working flawless.
|
|The variables in $tabWin{$tId}{focusTimestamp} does look ok though, but
|i dont have any knowledge about the X11-Protocol. Perhaps you know
|what could be wrong.
|

Hi, I have the same problem with fvwmtabs 2.6,
and I patched the line you're talking about,
it works wonderfully.

I have to test fvwmtabs 2.7 tough.

thanks

[ history mode ]

|
|
|
|On Sat, 15 Nov 2003 12:14:24 +1100
|scott <[email-masked]> wrote:
|
|> Hi Tobias,
|> 
|> : > > > After switching between Desktops
|> : > > > i cannot get the focus back to the Tabmanager and
|> : > > > only can get it back by pushing mouse button on the
|> : > > > background (or moving the TabManager by shortcuts).
|> : > 
|> : > I can't reproduce this bug - what system are you using?
|> : > Does FvwmTabs output anything on stdout/stderr?
|> :
|> : <snip>
|> :
|> : I have put my .fvwm dir to download at 
|> : http://www.ownz.de/medlor-fvwm.tar.gz . Perhaps this does help you.
|> 
|> Nice bg piccie! :)
|> 
|> Well I'm using your exact FVWM configuration on my system & I can't
|> reproduce this bug. (focusing works fine after switching desktops.)
|> 
|> I'm using:
|> Redhat Linux 7.3
|> fvwm 2.5.9 (from cvs) compiled on Nov 11 2003
|> FvwmTabs v2.5
|> Module FvwmTabs started with: X11::Protocol 0.52, Tk 800.024.
|> 
|> SCoTTie. :)
|--
|Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
|To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
|message to [email-masked].
|To report problems, send mail to [email-masked].
|

-- 
xavier
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Scott Smedley" <[email-masked]>
Date: Mon, 23 Feb 2004 23:02:04 +1100

> and I patched the line you're talking about,

Yes, this hack will fix your problem but it introduces another - focussing
race conditions. Early versions of FvwmTabs used 'CurrentTime' just as
you have, but in sloppy-focus modes tab-managers were stealing the
focus unnecessarily (extremely annoying when you pass the mouse cursor
over a tab-manager to get to another window! Although I can appreciate
that not focussing at all must be even more annoying!) I've been trying to
fix this bug for some time. Unfortunately I can't reproduce it on any of the
several different systems I have available to me.

I need to investigate further but its not going to be anytime soon. I'm
having
a miserable week - both my home & work systems crashed (independantly)
in the last few days & I've lost a sh*t-load of work ... :( ... I back-up
data
from home system to my work system & vice-versa so the double-failure
is killing me. How unlucky can you get?

Anyway, I didn't realise anyone else had this bug (I thought it was only
Tobias (I think - I can't access my email to check)). What system are you
using?

SCoTT.