Subject: FVWM: Conditionals in fvwm functions

From: Piotr Zgorecki <[email-masked]>
Date: Sat, 3 Jan 2004 13:41:52 +0100

Hi,

I want to achieve something like this (in pseudocode):

if $HOSTNAME == "host1" then
	Exec Command1
else
	Exec Command2
fi

Unfortunately, I can't find in the manpage any command for conditional
execution, which would test environment variables.

Do I really have to resort to a preprocessor?

Thanks,
Piotr Zgorecki
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 03 Jan 2004 08:09:51 -0500

> Do I really have to resort to a preprocessor?

Look in the man page for PipeRead.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Remko Troncon <[email-masked]>
Date: Sat, 3 Jan 2004 15:49:44 +0100

> I want to achieve something like this (in pseudocode):

In this special case, i use a cleaner approach to achieve the same:
in the end of my fvwm2rc (which is the same on all my machines) i have a:
    Read "rc.local"
The rc.local is different on each machine, and contains machine-specific 
settings. Of course, this has not the full power of what you're asking, but 
it's sufficient for what I need.

cheers,
Remko