Subject: Re: FVWM: 2.2 -> 2.4 upgrade

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jan 2004 12:20:42 +0100

On Fri, Dec 19, 2003 at 05:04:54PM -0800, Perry Hutchison wrote:
> After a system upgrade from Red Hat 6.2 to 9.0, which upgraded FVWM
> from 2.2.4 to 2.4.16, I am trying to convert my .fvwm2rc file.
> The fvwm24_convert script did part of the job, but complains about
> placement styles and refers to the man page.  The man page describes
> what to do with several combinations, but not with these:

It *is* in the man page:

  Style * SmartPlacement, RandomPlacement, CleverPlacementOff
    -->
  Style * TileCascadePlacement

It may be a bit confusing since it explicitly lists
CleverPlacementOff which is the default.

>   Style "*"      RandomPlacement, SmartPlacement

  Style * TileCascadePlacement

>   Style "xcalc"  Icon xcalc.xpm, NoButton 2,RandomPlacement,ClickToFocus
>   Style "xmh"    RandomPlacement, NoButton 2
>   Style "xman"   Icon xman.xpm, RandomPlacement, ClickToFocus
>   Style "xmag"   Icon mag_glass.xpm, RandomPlacement, ClickToFocus
>   Style "xgraph" Icon graphs.xpm, RandomPlacement, ClickToFocus

-> Just remove "RandomPlacement".  It does nothing here since it
does not change what you specified with the "*" style.  If you
want to disable SmartPlacement for these windows, use

  Style ... CascadePlacement

(or in 2.2:  Style ... DumbPlacement, RandomPlacement)

> Also, I have a lot of decors similar to this:
> 
>   AddToDecor FvwmCons HilightColor black green
> 
> which apparently should change to
> 
>   AddToDecor FvwmCons HilightFore black, HilightBack green
> 
> This looks like a simple enough transformation to have been done
> automatically, and the script did convert a standalone
> 
>   HilightColor black yellow
> 
> to
> 
>   Style "*" HilightFore black, HilightBack yellow
> 
> but it did not convert HilightColor within AddToDecor or even comment
> on what should be done.  Is there something more to it?

No, the script apparently does not handle commands buried in
decors.  Just change it manually.

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Mon, 5 Jan 2004 16:18:01 -0800 (PST)

> decors.  Just change it manually.

After changing them manually, I get:

  [FVWM][execute_function]: <<ERROR>> Command can not be added to a decor; executing command now: 'HilightFore black, HilightBack green'
  [FVWM][execute_function]: <<ERROR>> No such command 'HilightFore'

and 6 more sets, one for each decor that tries to do this.  All
borders get the black/yellow highlight.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 6 Jan 2004 00:32:45 +0000

> borders get the black/yellow highlight.

The error message is fully correct, only five *Style commands are
accepted in decors. Please see the man page (search for AddToDecor), it
includes the correct usage example, convert your configuration similarly.

Regards,
Mikhael.

---

From: Perry Hutchison <[email-masked]>
Date: Mon, 5 Jan 2004 17:08:27 -0800 (PST)

> includes the correct usage example, convert your configuration similarly.

This turns out to be a nice simplification.  The only reason I had
multiple decors in 2.2.4 was to get different highlight colors.
Now that the highlight colors go directly in the Style command,
all the extra decors can go away.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].