Subject: FVWM: arranging minimized apps and mousecursor

From: Joolz <[email-masked]>
Date: Thu, 1 Jan 2004 08:13:06 +0100

Happy new year everybody!

(Maybe this is pretty basic, but I often get confused about the fvwm /
X syntax for screen location)

I have a very quiet FVWM setup, I spend >8 hours behind a PC, so I
don't want a lot of eyecandy :-) Here's a screenshot:
http://www.xs4all.nl/~kiar/desktop.png . I've been using it for a
while but there are a few things I'm not content with.

Right now, minimized apps are stacked from left to right in the left
bottom part of the screen. They have an icon, some use their own, the
ones that don't have one get it via a style.

What I would like is this:

- minimized apps don't have icons (not even if they have their own on
  board), only a title in a small bar
- minimized apps stack in the right bottom part of the screen, from
  bottom to top
- minimized apps have a fixed width, no matter the size of the title

Something like this:

------------------------------------------------
|                                              |
|                                              |
|                                              |
|                                              |
|                                              |
|                                              |
|                                              |
|                                              |
|                                       --------
|                                       |app 3 |
|                                       --------
|                                       |app 2 |
|                                       --------
|                                       |app 1 |
------------------------------------------------

I hope someone can help me on this one, if I have to do it myself it
would trial and error and take a lot of time :-\

Aother question: a few weeks ago I switched from RH9 to FC1 (Fedora).
I had RH9 configured so it didn't use the alpha mousecursors and I
could do things like:

CursorStyle POSITION left_ptr orange black
CursorStyle TITLE    left_ptr orange black

However, I can't remember how I disabled the fancy cursors... Does
anyone know how I can tell FC1 to use the basic mousecursors?

Thanks for any help!

-- 
07:57-08:13
Fedora Core release 1 (Yarrow) Linux 2.4.22-1.2129.nptl
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Robert Knighten <[email-masked]>
Date: Thu, 1 Jan 2004 00:32:47 -0800

> - minimized apps have a fixed width, no matter the size of the title

I think you want FvwmWinList.  I do this with the apps (actually windows -
there may be multiple windows per app) right now except I have the the list of
minimized windows in the middle of the right side.  Here is the ConfigFvwmList
I use:

##########################FvwmWinList##################################
DestroyModuleConfig FvwmWinList: *
*FvwmWinList: Back #908090
*FvwmWinList: Fore Black
*FvwmWinList: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinList: Action Click1 Iconify false, Focus
*FvwmWinList: Action Click2 Iconify toggle
*FvwmWinList: Action Click3 Module FvwmIdent
*FvwmWinList: UseSkipList
*FvwmWinList: Geometry +0-1

-- Bob

-- 
Robert L. Knighten
[email-masked]

---

From: Joolz <[email-masked]>
Date: Thu, 1 Jan 2004 10:34:08 +0100

> [Robert Knighten schreef op 01-01-2004 00:32 -0800]
>
> Joolz writes:
> I think you want FvwmWinList.

Great, thats it (together with Style * noicon). Thanks!

-- 
10:33-10:34

---

From: Tavis Ormandy <[email-masked]>
Date: Thu, 1 Jan 2004 11:30:06 +0000

> anyone know how I can tell FC1 to use the basic mousecursors?

try adding this to your ~/.Xdefaults

Xcursor.theme: default

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joolz <[email-masked]>
Date: Thu, 1 Jan 2004 14:26:25 +0100

> [Tavis Ormandy schreef op 01-01-2004 11:30 +0000]
>

Thanks, but no difference :-\

-- 
14:25-14:26

---

From: joolz <[email-masked]>
Date: Thu, 1 Jan 2004 15:29:35 +0100

> [Bob Marcan schreef op 01-01-2004 15:22 +0100]
>
> Joolz wrote:
> My .xinitrc:
> ...
> XCURSOR_THEME=default; export XCURSOR_THEME
> ...

Thanks, but no, it doesn't help.

> Regards, Bob
> 
> P.S.
> I hate all this Tokyo by night (eye candy) thing.

LOL!

Same here, this is my desktop (at work & at home):
http://www.xs4all.nl/~kiar/desktop.png

You can imagine what an alpha cursor looks like on that. Like Gary
Glitter in the Pogues :-)

-- 
15:26-15:29

---

From: Shay Hill <[email-masked]>
Date: Fri, 02 Jan 2004 12:05:40 -0600

>- minimized apps have a fixed width, no matter the size of the title
If this list will permit a brief philosophical exchange, I would like to 
ask what problem you have with icons. I can understand not caring for 
their appearance, but it seems to be the utilitarian rather than 
aesthetic types who typically reject icons.

The screen space occupied by a 14x14 pixel mini-icon could at best 
display three small characters in a program's name. An FVWMButtons panel 
with mini-icons can be functional with only the narrow icon column 
visible, whereas a text-only panel requires that multiple letters of 
each program's name be visible.

 -Shay