Subject: FVWM: changing cursor color with CursorStyle

From: Tröller Rudolf <[email-masked]>
Date: Mon, 5 Jan 2004 11:10:44 +0100 (CET)

Hi to all

I want to change the color of the cursor in the root window with
  CursorStyle ROOT left_ptr red black

This worked with fvwm 2.4.8 under suse linux 8.1 but does not work for
fvwm 2.5.7 under suse linux 9.

Any ideas?

TIA

Rudolf
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 5 Jan 2004 11:48:15 +0100

> fvwm 2.5.7 under suse linux 9.

I don't know.  It works fine with the latest development code.
Try fvwm-2.5.8.

Ciao

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Jan 2004 15:30:32 +0000

> fvwm 2.5.7 under suse linux 9.

It seems that your distribution defined alpha-blended animated cursors.
You should disable this, probably ask on SuSE specific mailing lists.

There was one answer on this list some days ago about disabling the
cursor theme, but this procedure may be distribition (or XFree86 version)
specific, since it didn't work for one who asked then.

Regards,
Mikhael.

---

From: "Ryan Daly" <[email-masked]>
Date: Mon, 5 Jan 2004 10:40:08 -0500 (EST)

> You should disable this, probably ask on SuSE specific mailing lists.

It appears that Red Hat does this as well (XFree86 Version 4.3.0 (Red Hat
Enterprise Linux release: 4.3.0-35.EL)).

If anyone determines how to disable them from messing with the cursor,
let me know.  I tried the FVWM way and there was no change.

Thanks.

---

From: Joolz <[email-masked]>
Date: Mon, 5 Jan 2004 22:52:13 +0100

> [Mikhael Goikhman schreef op 05-01-2004 15:30 +0000]
>
> > This worked with fvwm 2.4.8 under suse linux 8.1 but does not work
> > for fvwm 2.5.7 under suse linux 9.
> > 
> > Any ideas?
> 
> It seems that your distribution defined alpha-blended animated
> cursors.  You should disable this, probably ask on SuSE specific
> mailing lists.
> 
> cursor theme, but this procedure may be distribition (or XFree86
> version) specific, since it didn't work for one who asked then.

I have the same problem on Fedora Core 1 (with XFree86 4.3.0). I have
a feeling this is XFree, not the distro. If someone has an answer I
would really like to know, these alpha cursor are really ugly in my
setup.

-- 
22:48-22:52
Fedora Core release 1 (Yarrow) Linux 2.4.22-1.2129.nptl

---

From: Tröller Rudolf <[email-masked]>
Date: Tue, 6 Jan 2004 10:29:42 +0100 (CET)

> let me know.  I tried the FVWM way and there was no change.

After some investigations I finally found this solution:

insert the following line into your ~/.Xdefaults

Xcursor.core: true

see also: http://www.cs.umn.edu/help/linux/xcursor.html

Best Regards

Rudolf

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 6 Jan 2004 11:35:23 +0100

> see also: http://www.cs.umn.edu/help/linux/xcursor.html

Here I've a file:

x11_prefix/lib/X11/icons/default/index.theme

which conatians

[Icon Theme]
Inherits=redglass

If I replace redglass by core, I get the "default" cursor.
Maybe there is a user space corresponding config file.

Regards, Olivier

---

From: Joolz <[email-masked]>
Date: Wed, 7 Jan 2004 07:05:33 +0100

> [Olivier Chapuis schreef op 06-01-2004 11:35 +0100]
>

Solved!!! Thanks a lot!

-- 
07:04-07:05

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 7 Jan 2004 10:39:02 +0100

> > If I replace redglass by core, I get the "default" cursor.

Perhaps someone who has understood the solution could make an FAQ
entry?

Ciao

Dominik ^_^  ^_^