Subject: FVWM: switching between previous and current page/desk

From: Micha Feigin <[email-masked]>
Date: Thu, 1 Jan 2004 21:52:51 +0200

I would like to make a shortcut to switch between the previous and
current desk/page. Something like Alt-tab does for windows (I would
settle for just the current and previous ones on the stack, but it
would be nice to have the whole history actually).

Any suggestions?

thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joolz <[email-masked]>
Date: Thu, 1 Jan 2004 21:17:04 +0100

> [Micha Feigin schreef op 01-01-2004 21:52 +0200]
>
> settle for just the current and previous ones on the stack,

I use control alt left and right to switch like this:

Key Right A MC Scroll  100000 0
Key Left  A MC Scroll -100000 0

> but it would be nice to have the whole history actually).

Here's my setup: http://www.xs4all.nl/~kiar/fvwm_grey.tar.bz2
and a screenshot: http://www.xs4all.nl/~kiar/desktop.png

Use at your own risk, I'm _no_ FVWM expert, but I've been using (and
tuning) this setup for a while and I like it.

-- 
21:13-21:17
Fedora Core release 1 (Yarrow) Linux 2.4.22-1.2129.nptl

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 1 Jan 2004 22:09:41 +0000

> would be nice to have the whole history actually).

To flip pages/desks use one of:

  GotoDesk prev
  GotoPage prev
  GotoDeskAndPage prev

If you want a whole history, setup your own recorder/player, for example
using FvwmEvent listenning to new_page/new_desk, or by writting a short
fvwm module in Perl working with the PageInfo tracker.

Regards,
Mikhael.