Subject: FVWM: FvwmButtons: swallowed clock applet with xft capabilities?

From: [email-masked] (Alexander Fitterling)
Date: Sat, 31 Jan 2004 22:22:49 +0100

Hello to everyone.

I wonder if there is any clock applet available to use it with
FvwmButtons. It should be capable of xft as fvwm 2.5.8 does.

Xft works fine with my configuration, but so far the clock (I use a
swallowed xclock) does get displayed the old style.

Of course it should be a digital clock, much same way as one could see
in MS Windows taskbars.

Any hints?

I appreciate.
Alex

-- 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Sat, 31 Jan 2004 21:27:22 +0000 (GMT)

> swallowed xclock) does get displayed the old style.

You can set the font style of xclock in ~/.Xdefaults (often a symlink to
~/.Xresources):

xclock*font: my_font_name

Then do:

xdrb -merge ~/.Xdefaults 

And load the clock, see if that does it.

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

___________________________________________________________
BT Yahoo! Broadband - Free modem offer, sign up online today and save £80 http://btyahoo.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 31 Jan 2004 23:35:19 +0100

> Of course it should be a digital clock, much same way as one could see

With my XFree (4.4.0-rc1), "xclock -digital" use Xft by default;
I think that this happen too for 4.3.x.

Maybe you can try the "-fa" option (not -fn really -fa):

	xclock -digital -brief -fa "mono:size=11"
 
works fine here.

Regards, Olivier