Subject: FVWM: Style for "class" Zinf

From: Catherine <[email-masked]>
Date: Sun, 25 Jan 2004 19:18:04 -0800

I have a music player, zinf.  In my Style section, I made is so there
isn't a title bar on the player  but if i open the playlist editor or
the preferneces, they too dont have a title bar and I am unable to move
those two items around on the screen.  The player itself can be moved.

The man page says you can set styles for class but when I do, nothing
happens

Here is how I have Zinf set up in my .fvwm2rc

 Style Zinf NoTitle,Handles,!Borders

For the Preferneces Class and the Playlist class I have this:

Style Preferences Title

Have I done this incorrectly?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Mon, 26 Jan 2004 03:28:03 +0000 (GMT)

--- Catherine <[email-masked]> wrote: > I have a music player,
zinf.  In my Style section, I made is so there
> Have I done this incorrectly?

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

________________________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Craig <[email-masked]>
Date: Mon, 26 Jan 2004 14:28:18 +1100

On Sun, Jan 25, 2004 at 07:18:04PM -0800, Catherine wrote:
: I have a music player, zinf.  In my Style section, I made is so there
: isn't a title bar on the player  but if i open the playlist editor or
: the preferneces, they too dont have a title bar and I am unable to move
: those two items around on the screen.  The player itself can be moved.
: 
: The man page says you can set styles for class but when I do, nothing
: happens
: 
: Here is how I have Zinf set up in my .fvwm2rc
: 
:  Style Zinf NoTitle,Handles,!Borders
: 
: For the Preferneces Class and the Playlist class I have this:
: 
: Style Preferences Title
: 
: Have I done this incorrectly?

No, looks good assuming you've got the right class string.

What's important here is the order of your statements as obviously
"Zinf" applies to all windows so if you set that after you set
"Preferences", the prefs setting will be overridden.

Just put the lines given in the order you gave them here and it
should work.

- C

-- 
Craig Smedley
[email-masked]