Subject: FVWM: questions about borderwidth, mouse and key defs, launcher

From: Joel Smith <[email-masked]>
Date: Sat, 24 Jan 2004 15:15:07 -0500

BorderWidth Q:

I'm trying to make my FvwmButtons completely transparent.  I've
followed the directions to use Colorset and that works, but a problem
remains.  I set the borderwidth of the buttons to zero, i.e.

Style "FvwmButtons" BorderWidth 0, CirculateSkip, StaysOnTop

but it still remains, and it seems the only way to get rid of the
border is to use 

Style "*" BorderWidth 0

but that makes all my windows have no border.  Am I missing something?
How can I tell fvwm that just the FvwmButtons have zero borderwidth?
or could i set the color of the border to transparent?  

Mouse and Key defs:

I don't understand these at all and I can't find any documentation.
For instance, what does the following mean, 

Silent Mouse 6 FSTW N RaiseAndFocus
Mouse 3 R N Menu  MP3PlaylistMenu

Just want documentation...

Launcher Q:

Following the advice of the FAQ's I tried to use the following code

     # FvwmButtons icon launcher:
     DestroyFunc Launcher
     AddToFunc Launcher
     + I DestroyModuleConfig $0Launch: *
     + I *$0Launch: Geometry 64x68
     + I *$0Launch: Columns 1
     + I *$0Launch: Rows    4
     + I *$0Launch: Frame   0
     + I *$0Launch: (1x3+0+0, Icon $1, Action (Mouse 1) `Exec $2`)
     + I *$0Launch: Pixmap none
     + I *$0Launch: (1x1+0+3, Font 9x15, Fore White, Back DarkBlue, \
                    Title $0, Action (Mouse 1) `Exec $2`)
     + I Style $0Launch HandleWidth 0, NoTitle
     + I Module FvwmButtons $3 $0Launch
     # Examples:
     Launcher RXVT xterm.xpm "rxvt -bg black" "-g +0+0"
     Launcher XV   xv.xpm    "xv"   "-g +0+100"

it works great but i puts this awful nontransparent box at the
bottom.  I'd prefer to either eliminate the text box altogether or set
its color to transparent just like i did for FvwmButtons.  Is there a
way to do that?  

any help would be greatly appreciated.  

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 24 Jan 2004 15:31:59 -0500

> Style "FvwmButtons" BorderWidth 0, CirculateSkip, StaysOnTop

Style "FvwmButtons" BorderWidth 0, CirculateSkip, StaysOnTop, HandleWidth 0

You don't need the BorderWidth 0, but it doesn't hurt.

> Just want documentation...

Man page.

Search for Silent.

Searching for Mouse is harder, instead search for:

COMMANDS FOR MOUSE, KEY AND STROKE BINDINGS

The things at the end are functions.

> its color to transparent just like i did for FvwmButtons.  Is there a

That's the IconTitle.
Try Style $0Launch NoIconTitle

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Thomas Adam <[email-masked]>
Date: Sat, 24 Jan 2004 20:35:23 +0000 (GMT)

> or could i set the color of the border to transparent?  

You need to set the "HandleWidth" to zero, i.e.:

Style "FvwmButtons" BorderWidth 0, CirculateSkip, StaysOnTop, HandleWidth
0

HTH,

-- Thomas Adam

=====
"The Linux Weekend Mechanic" -- http://linuxgazette.net
"TAG Editor"                 -- http://linuxgazette.net

"<shrug> We'll just save up your sins, Thomas, and punish 
you for all of them at once when you get better. The 
experience will probably kill you. :)"

 -- Benjamin A. Okopnik (Linux Gazette Technical Editor)

________________________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].