Subject: FVWM: automatic maximize of window at startup

From: Thomas Lange <[email-masked]>
Date: Fri, 12 Dec 2003 14:18:16 +0100

Hi,

I like to maximize an application (emacs or xterm) when fvwm starts up
without using a mouse click. Since I like to use the save fvwmrc file
on different resolution, I can't use a specific geometry for this. Is
it possible to start emacs from .xinitrc or .fvwmrc and then to maximize
it without using the mouse?

-- 
regards Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 12 Dec 2003 08:31:39 -0500

> it without using the mouse?

It's possible to set the size of xterm and emacs using x-resources.
Here is part of the x-resources I use for XEmacs:

! Geometry changes based on screen size:
#if ( HEIGHT == 900 )     /* Traditional Sparc */
Emacs.geometry: 81x55+0+0
#elif ( HEIGHT == 1024 )  /* Sparc 21 inch */
Emacs.geometry: 81x63+0+0
#elif ( HEIGHT == 768 )   /* Exceed in 1024x768 mode */
Emacs.geometry: 81x46+0+0
#elif ( HEIGHT == 1200 ) /* My home machine, 1600x1200 use side x side layout */
! No good w. 10x20 Emacs*xmh.geometry: 81x68+757+105
Emacs.geometry: 81x56
#else                     /* I have no idea... */
Emacs.geometry: 81x40+0+0
#endif

-- 
Dan Espen                           E-mail: [email-masked]