Subject: FVWM: maximize and appearance config questions

From: Shay Hill <[email-masked]>
Date: Mon, 08 Dec 2003 08:52:46 -0600

Even knowing if these things are possible would be a great help. Any 
assistance appreciated.

==> Maximize with empty screen on all sides of the window
==> Borderless tool bar buttons
==> TWM style active window title shading http://tinyurl.com/y8ij
==> Remove the bars in Nop lines of a menu

Thank you,
 -Shay

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 8 Dec 2003 17:41:51 +0000

> ==> Maximize with empty screen on all sides of the window

What do you mean here? Please read the Maximize entry in fvwm man page.
It has several types of options. You may browse the man page from
fvwm.org if you don't have fvwm installed.

> ==> Borderless tool bar buttons

Do you mean windows without any borders or flat titlebar buttons?
Both are possible.

> ==> TWM style active window title shading http://tinyurl.com/y8ij

This look is possible with 2.5.x with MultiPixmap.

> ==> Remove the bars in Nop lines of a menu

I can interpret this differently, what do you mean here, give an example.

Regards,
Mikhael.

---

From: Shay Hill <[email-masked]>
Date: Mon, 08 Dec 2003 12:28:22 -0600

>fvwm.org if you don't have fvwm installed.
I have read this section and am still not sure how to get space on all 
four sides of the window using only the Maximize command. I am currently 
using Maximize 90 90, which gives me space on the left and bottom of the 
screen. I am going to experiment with* *EwmhBaseStruts this evening.

>Do you mean windows without any borders or flat titlebar buttons?
I want flat buttons like the ones in the twm screenshot I posted.

>This look is possible with 2.5.x with MultiPixmap.
Thank you. I have now gone over this entry and understand how to 
accomplish this.

>I can interpret this differently, what do you mean here, give an example.
I want a blank space. Just a skipped line.

>Mikhael.
I have quoted our entire exchange in my message. If this is inconsistent 
with the etiquette on this board, please let me know.

 -Shay

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 8 Dec 2003 19:20:02 +0000

> screen. I am going to experiment with* *EwmhBaseStruts this evening.

Ah, you mean "empty space" when you write "empty screen".
Then you should use EWMHBaseStruts.

> I want flat buttons like the ones in the twm screenshot I posted.

  ButtonStyle All -- flat

or:

  ButtonStyle All -- UseTitleStyle flat

Use TitleStyle Height too.

> I want a blank space. Just a skipped line.

Try this menu then (the second Nop is what you want, I think):

  AddToMenu ExampleMenu
  + "Just label" Nop
  + "" Nop
  + " " Nop
  + "Just command" Beep

Regards,
Mikhael.