Subject: FVWM: fvwm2/libstroke

From: "Alex BATKO" <[email-masked]>
Date: Tue, 9 Dec 2003 11:51:25 -0500 (EST)

Hello.  First off, I LOVE fvwm!!!!!!

I am wondering if someone could please assist me with a problem I'm having on
RedHat 9 (Linux 2.4.20-20) with Fvwm2 and libstroke.

I keep getting interference from libstroke, and I can't figure out a solution.
 Could someone please help?

I had to install fvwm2 using nodeps:
% rpm -ivh --nodeps fvwm-2.4.17-1.i386.rpm
because rpm always complains about libstroke.

Below is a bunch of copy/pasted material that I thought might help you... if
you need any other info, please let me know!  Thanks a lot!

% apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  fvwm: Depends: libstroke.so.0 but it is not installable
E: Unmet dependencies. Try using -f.

% apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  fvwm
0 packages upgraded, 0 newly installed, 1 removed and 4 not upgraded. Need to
get 0B of archives.
After unpacking 2749kB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

% locate libstroke.so.0
/usr/local/lib/libstroke.so.0.0.5
/usr/local/lib/libstroke.so.0

% rpm -qa | grep -i fvwm
fvwm-2.4.17-1

% rpm -qa | grep -i stroke

% rpm -qf /usr/local/lib/libstroke.so.0.0.5
file /usr/local/lib/libstroke.so.0.0.5 is not owned by any package

% rpm -qf /usr/local/lib/libstroke.so.0
file /usr/local/lib/libstroke.so.0 is not owned by any package
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 9 Dec 2003 17:17:41 +0000

> Do you want to continue? [Y/n] n

I don't understand how apt-get may work at all, does not it require an
updated list of packages to start to work, how did you define this list?
Unless I miss some apt-get repository that features fvwm-2.4.17 rpm,
do not use apt-get, it can't help you here.

Amyway, just install one of the libstroke rpms that you may find on the
Net and you will be fine with "rpm --upgrade fvwm-2.4.17-1.i386.rpm".

You may find one of the libstroke rpms on our rpm page, should work with
any RedHat version.

> file /usr/local/lib/libstroke.so.0 is not owned by any package

Regards,
Mikhael.