Subject: Re: FVWM: Auto-starting apps at fvwm startup

From: stu <[email-masked]>
Date: Tue, 2 Dec 2003 12:27:41 +0200

On Thu, 27 Nov 2003 12:34:18 +0100
Dominik Vogt <[email-masked]> wrote:

> On Thu, Nov 27, 2003 at 01:22:32PM +0200, stu wrote:
> > I am trying to configure my fvwm (2.5.8) to automatically start
> > certain apps when I start X and fvwm (using the startx command).
> > With the setup I've listed below, only the first app (sylpheed)
> > starts, and once it's started it refuses to respond to any mouse
> > clicks. 
> 
> Fvwm is hanging in the "Wait" command. 

My mistake. I was using the wrong sylpheed window name with my "Wait"
command.

>   xterm -g +<displaywidth>+0
> 
> to place an xterm in the top left corner of page 1 0.

Thanks, I will attempt this with gkrellm.

> 
>   Style sylpheed-claws StartsOnPage 0 1, SkipMapping
> 
> (SkipMapping tells fvwm not to switch to that page when the window
> appears).
> 

This has sorted out my sylpheed placement, though I had to use *ylpheed*

> > I start fvwm from .xinitrc using startx. The relevant line is :
> > 
> > exec fvwm &>fvwm.out 2>&1
> > 
> > The relevant lines from .fvwm2rc are :
> > 
> > # 1 desktop with 16 pages
> > DeskTopSize 4x4

I have simplified the rest of my config to be the following, but I still
can't get things to work as I want :(

Style "*ylpheed*" StartsOnPage 0 1, SkipMapping

DestroyFunc InitFunction
AddToFunc InitFunction
 + I Exec exec sylpheed-claws
 + I GotoPage 2 0
 + I Exec exec konsole
 + I GotoPage 3 0
 + I Exec exec konsole
 + I GotoPage 0 0

I expect the instructions in the above"InitFunction" to be executed
sequentially, ie execute sylpheed, go to page 2, start konsole on that
page, go to page 3, start konsole on that page too, and then go to page
1. However, things are not working as I expect.

The two konsole sessions both start on page 1, instead of on page 2 and
page 3. How could I get around this? Are there any FAQs I can read etc?
konsole doesn't seem to accept the --geometry parameter, and I don't
want to use a "StartsOnPage" style option on it, as I start it up in
more than one place.

Thanks
-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Dec 2003 09:36:32 +0100

> want to use a "StartsOnPage" style option on it, as I start it up in

The commands *are* run sequentially, but without the "Wait" fvwm
does not wait for the "konsole" windows.  Try the --geometry
option for konsole:

  AddToFunc InitFunction
  + I Exec exec sylpheed-claws
  + I Exec exec konsole --geometry +<2xdisplaywidth>+0
  + I Exec exec konsole --geometry +<3xdisplaywidth>+0

Ciao

Dominik ^_^  ^_^

---

From: stu <[email-masked]>
Date: Tue, 2 Dec 2003 20:09:26 +0200

On Tue, 2 Dec 2003 09:36:32 +0100
Dominik Vogt <[email-masked]> wrote:

> > sequentially, ie execute sylpheed, go to page 2, start konsole on
> > that page, go to page 3, start konsole on that page too, and then go
> > to page 1. However, things are not working as I expect.
> 

Thanks! A few lessons in --geometry later and my windows are starting to
appear where I want them. 

Is there any way for fvwm to determine what the current value of
"displaywidth" (used in the example above) is, so that I don't have to
hard-code it into my config?

-- 
Stuart Logie
Programmer

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Dec 2003 17:51:41 +0100

On Tue, Dec 02, 2003 at 08:09:26PM +0200, stu wrote:
> "displaywidth"

Yes, the $[vp.width] variable does this, but for some reason, in

  + I Exec exec konsole --geometry +$[vp.width]+0

it does not get expanded wo a number.  I didn't have the time to
investigate why yet.

> (used in the example above) is, so that I don't have to

Ciao

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 2 Dec 2003 17:35:29 +0000

> it does not get expanded wo a number.  I didn't have the time to

This line works like expected for me within a function or not.

Just keep in mind that you should better be on page 0 0 to do such things.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Dec 2003 10:00:55 +0100

> This line works like expected for me within a function or not.

Ah, I see - konsole is messing with its own position.  It appears
at the specified position, then moves to something like
-26xxx-3xxx.

Ciao

Dominik ^_^  ^_^

---

From: stu <[email-masked]>
Date: Wed, 10 Dec 2003 21:31:52 +0200

On Tue, 2 Dec 2003 17:51:41 +0100
Dominik Vogt <[email-masked]> wrote:

> > > > I expect the instructions in the above"InitFunction" to be
> > > > executed sequentially
> > > 
> Yes, the $[vp.width] variable does this

Thanks Dominik, Mikhael, for all the help. $[vp.width] works perfectly
for me (and is in the man page - blush).

-- 
Stuart Logie
Programmer