Subject: FVWM: Border under titlebar?

From: Shay Hill <[email-masked]>
Date: Thu, 18 Dec 2003 10:08:42 -0600

Is it possible to place a border under the titlebar (twm style)? I plan 
to fake this effect if necessary with a one column pixmap that has 19 
green pixels stacked on top of 2 gray, but I want to make sure first 
that there is not an easier way.

Thank you,
 -Shay

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Dec 2003 19:02:26 +0000

> that there is not an easier way.

Taking a look at fvwm-themes/themes/sa/buttons:

  AddTitleStyle TiledPixmap button/title_bottom.png -- Flat Bottom

This is the best thing you may do. Or just add this bottom line to
all images you use in-place. There are no configuration options to
autogenerate such line at the bottom.

Regards,
Mikhael.

---

From: Tavis Ormandy <[email-masked]>
Date: Sat, 20 Dec 2003 00:04:25 +0000

> autogenerate such line at the bottom.

It would be nice if you could cheat and use Vgradient like "VGradient 2
1 darkgreen 90 lightgrey 10", but that doesnt work...you can make it look
pretty close though by allocating a few more colours :)

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 20 Dec 2003 03:06:42 +0000

> pretty close though by allocating a few more colours :)

Another cheat that would work ok and insert a bottom line is:

  AddTitleStyle Vector 2 0x99@0 99x99@0
  ButtonStyle All -- UseTitleStyle

You just get a 4-pixel breakup in the line between the title and the
right buttons (but not between the left buttons and the title).
This may be fixed, I think.

Regards,
Mikhael.