Subject: FVWM: how to place window in top left corner?

From: Harald Dunkel <[email-masked]>
Date: Wed, 17 Dec 2003 11:03:12 +0100

Hi folks,

I haven't found it in the man page, so hopefully its OK
to ask this question here:

How can I tell fvwm 2.5.8 to place a window (e.g. Mozilla)
in the top left corner? CascadePlacement is not an option
in this case.

If this is not in yet, would it be possible to get something
like

Style	Mozilla*	Placement 0 0

?

Many thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Wed, 17 Dec 2003 10:34:49 +0000

> in the top left corner? CascadePlacement is not an option

Check out http://www.fvwm.org/documentation/faq/#3.18

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Chris Rouch <[email-masked]>
Date: Wed, 17 Dec 2003 11:50:48 +0100

On Wed, 17 Dec 2003 11:03:12 +0100

> Style	Mozilla*	Placement 0 0

I'd really like this too. I know this is possible using FvwmEvent, but
on a slow system it's visually disturbing to have a window mapped first
according to the placement setting and subsequently moved by FvwmEvent.

To answer the origunal question, I use (taken from the FAQ 3.18):

*FvwmEvent-NewWindow: StartDelay 4
*FvwmEvent-NewWindow: add_window FuncFocusWindow SkipMapping

DestroyFunc FuncFocusWindow
AddToFunc   FuncFocusWindow
+ I  ThisWindow ("galeon-bin") Move 0 0

AddToFunc StartFunction 
+   I   FvwmEvent FvwmEvent-NewWindow

---

From: Harald Dunkel <[email-masked]>
Date: Wed, 17 Dec 2003 12:51:05 +0100

> Check out http://www.fvwm.org/documentation/faq/#3.18

If I get this right then your suggestion is to let fvwm
move the window to the top left corner after it appeared
on the screen. Sorry, but this is just a suboptimal
workaround. It would be pretty annoying, especially when
I work remote via a VNC session.

The window should be _placed_ in the top left corner.

Regards

Harri

---

From: Artur Scianek <[email-masked]>
Date: Wed, 17 Dec 2003 13:06:28 +0100

Sorry for the off-topic, but I think that
administrator of this list should set the
Mail-Followup-To: [email-masked] header
because when I reply to the list, original
sender receive doubled mail, because it is
sended to his mail and CCed to [email-masked]

http://www.unicom.com/pw/reply-to-harmful.html

-- 
Regards
Artur Scianek

---

From: Micha Feigin <[email-masked]>
Date: Wed, 17 Dec 2003 23:14:20 +0200

> +   I   FvwmEvent FvwmEvent-NewWindow

Probably not what you are looking for, but what about using the
geometry option in Xresources.