Subject: FVWM: ATerm + transparency

From: Marcin Głogowski <[email-masked]>
Date: Sat, 6 Dec 2003 15:45:10 +0100

Hallo,
Is it possible to define some parameters that allow fvwm to refresh window contents after move,resize?
Few weeks ago some man told me that it can be done by passing some parameters (-bs?) to xinit command, but I would like to know whether is there such built in option (i.e. sawfish has such option).
Thank You for the help.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 6 Dec 2003 20:20:07 +0000

On 06 Dec 2003 15:45:10 +0100, Marcin G?ogowski wrote:
> 
> Is it possible to define some parameters that allow fvwm to refresh
> window contents after move,resize? Few weeks ago some man told me that
> it can be done by passing some parameters (-bs?) to xinit command, but
> I would like to know whether is there such built in option (i.e.
> sawfish has such option).

The best thing I may think about is to use this function instead of Move:

  AddToFunc MoveAndRefresh
  + I Move
  + I ThisWindow (ProblematicApp) RefreshWindow

It may (or may not) help to upgrade the application or XFree86.

Regards,
Mikhael.

---

From: Kingsly John <[email-masked]>
Date: Sun, 7 Dec 2003 13:29:38 +0530

> Is it possible to define some parameters that allow fvwm to refresh window contents after move,resize?

My transparent aterm background changes automatically when I move the term to
a new location.

aterm-0.4.2
XFree86-4.2.0
fvwm-2.5.7

What options are you starting aterm with ?

This is what I use ...

aterm -tn xterm -sh 70 -bg black -fg white -cr red -pr red -tr -trsb -fn 9x15bold

Kingsly

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 7 Dec 2003 12:26:18 +0000

> aterm -tn xterm -sh 70 -bg black -fg white -cr red -pr red -tr -trsb -fn 9x15bold

Just FYI, this line works ok for me except that the scrollbar is not
drawn correctly, this is the aterm fault, Refresh can't help here.
It seems that only +sb option helps (disable scrollbar). The main aterm
area is redrawn/refreshed ok though. aterm 0.3.6. :)

Regards,
Mikhael.