Subject: FVWM: Thanks (and a question)

From: Mike Hunter <[email-masked]>
Date: Mon, 1 Dec 2003 09:33:32 -0800

Hey everybody,

First-off, my sincere thanks to the fvwm team.  I've been using fvwm since
1998, back when I had to get somebody to help me get my cd out of the
drive because I didn't know about `eject` :)

Anyway, I've got a problem with fvwm's interaction with netscape.  When I
do Control-F to find-in-text, it pops up its little window to get the
text, but the window doesn't have any handles.  I'm not sure how to tell
fvwm to force handles onto it.  I don't think this is a netscape-specific
problem...other crappy applications sometimes make similar "pop-ups".

Here's my .fvwm2rc.  I'm using 2.4.16 on FreeBSD-CURRENT.

Thanks guys,

Mike

PS Please CC me as I'm not on the [email-masked] mailing list.

DeskTopSize 3x2

#DefaultColors cyan DarkSlateGray
DefaultColors cyan orange

TitleStyle LeftJustified height 14
TitleStyle -- Flat
TitleStyle ActiveUp (VGradient 16 rgb:47/79/99 black) -- Flat
TitleStyle ActiveDown (VGradient 16 black rgb:47/79/99)-- Flat

ButtonStyle 1 Inactive (VGradient 20 rgb:47/79/99 cyan)-- Flat

ButtonStyle 2 (VGradient 20 rgb:47/79/99 cyan)-- Flat
AddButtonStyle 2 ActiveUp (13 20x20@0 80x80@0 85x80@0 25x20@0 30x20@0 90x80@0 50x50@0 20x80@0 80x20@0 85x20@0 25x80@0 30x80@0 90x20@0)-- Flat
AddButtonStyle 2 ActiveDown (13 20x20@1 80x80@1 85x80@1 25x20@1 30x20@1 90x80@1 50x50@1 20x80@1 80x20@1 85x20@1 25x80@1 30x80@1 90x20@1)-- Flat

ButtonStyle 6 (VGradient 20 rgb:47/79/99 cyan)-- Flat
AddButtonStyle 6 ActiveUp (4 25x80@0 85x80@0 85x75@0 25x75@0 25x70@0 85x70@0)-- Flat
AddButtonStyle 6 ActiveDown (4 25x80@1 85x80@1 85x75@1 25x75@1 25x70@1 85x70@1)-- Flat
# MAXIMIZE
ButtonStyle 4 (VGradient 20 rgb:47/79/99 cyan)-- Flat
AddButtonStyle 4 ActiveUp (7 20x20@0 90x20@0 90x25@0 20x25@0 20x80@0 90x80@0 90x20@0)-- Flat
AddButtonStyle 4 ActiveDown (7 20x20@1 90x20@1 90x25@1 20x25@1 20x80@1 90x80@1 90x20@1)-- Flat

MenuStyle * Background rgb:47/79/79, ActiveFore cyan, ForeGround rgb:9/9/9
MenuStyle * PopupOffset 0 100
MenuStyle * MenuFace HGradient 64 1 rgb:47/79/79 100 rgb:0/255/255,Animation

Style * HilightFore cyan, HilightBack DarkSlateGray

DestroyFunc StartFunction
AddToFunc StartFunction
#+ I Module FvwmTaskBar
+ I Module FvwmPager

OpaqueMoveSize 50
XORvalue 444 
EdgeResistance 750 75
EdgeScroll 100 100
ClickTime 750

# Default Styles:
Style "*"               BorderWidth 3, HandleWidth 2
Style "*"               ForeColor cyan
Style "*"               BackColor rgb:77/79/79
Style "*"               NoPPosition
Style "*"               IconBox 0 -10 -280 -1
Style "*"               FocusFollowsMouse
Style "*"               SloppyFocus
Style "*"               Icon Monitor.xpm
Style "*"               ActivePlacement

# Styles for various Fvwm modules:
Style "Fvwm*"           NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"           BorderWidth 1, CirculateSkipIcon, CirculateSkip

Style "*lock"   NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus
Style "xbatt"   NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus
Style "xeyes"   NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus
Style "xterm"   Icon Monitor.xpm
Style "*term"   Icon Monitor.xpm
#Style "gkrellm"        Sticky,WindowListSkip,CirculateSkip,NoTitle
Style "xmms"    NoTitle, NoHandles

AddToMenu RootMenu "OK Computer"   Title
+ "" Nop
#+ XTerm         Exec exec black-xterm
+ tinyterm Exec exec tinyterm
+ smallterm Exec exec black-rxvt
+ niceterm Exec exec niceterm
+ bigterm      Exec exec bigterm
+ hugeterm     Exec exec hugeterm
+ "" Nop
#+ Opera         Exec exec opera
+ Mozilla       Exec exec mozilla
+ Xcalc          Exec exec black-xcalc
+ "" Nop
+ Xkill          Exec exec xkill
+ "" Nop
+ "Lock Screen" Exec matlock
+ "" Nop
+ "Restart Fvwm"        Restart
+ "Exit Fvwm"   Quit

#*FvwmTaskBar: UseSkipList
#*FvwmTaskBar: UseIconNames
#*FvwmTaskBar: ShowTips
#*FvwmTaskBar: NoIconAction SendToModule FvwmAnimate animate
#*FvwmTaskBar: 3DFvwm
#*FvwmTaskBar: HighlightFocus
#*FvwmTaskBar: StartName tratS
#*FvwmTaskBar: StartMenu RootMenu
#*FvwmTaskBar: Geometry +0-0
#*FvwmTaskBar: Fore cyan
#*FvwmTaskBar: Back DarkSlateGray
#*FvwmTaskBar: TipsFore black
#*FvwmTaskBar: TipsBack bisque
#*FvwmTaskBar: Font anorexia
#*FvwmTaskBar: SelFont anorexia
#*FvwmTaskBar: StatusFont anorexia
#*FvwmTaskBar: AutoStick
#*FvwmTaskBarMailBox /var/spool/mail/root

Mouse 1 R N Menu RootMenu Nop
#Mouse wheel
Mouse 4 R N GotoDesk -1
Mouse 5 R N GotoDesk +1
Mouse 4 A M GotoDesk -1
Mouse 5 A M GotoDesk +1
Mouse 4 A S GotoDesk -1
Mouse 5 A S GotoDesk +1
#Mouse 0 1 A -
Mouse 0 2 A Delete
Mouse 0 4 A Maximize 100 97
Mouse 0 6 A Iconify
#Mouse 3 R N Module FvwmWinList transient
#Mouse 3 2 N Function "Rezise-or-Raise"
#Mouse 1 T N Function "Move-or-Raise"
##Mouse 1 SF N Function "Rezise-or-Raise"
Mouse 3 T N RaiseLower
Mouse 1 I N Function "Move-or-Iconify"
Mouse 3 I N Function "Move-or-Iconify"
Mouse 3 S N Function "Move-or-Iconify"
#Mouse 1         FS      A       Function "Resize-or-Raise-or-Shade"

# ==============================
#  Key Bindings
# ==============================
#
# Syntax:
#	Key keyname Context Modifiers Function
#
# (*) Key names are from /usr/include/X11/keysymdef.h with the
#     leading XK_ stripped. 
#
# (*) Context:
#	R : root window			W : application window
#	T : window title bar		I : Icon window
#	S : window side, top, bottom bar
#	F : window frame (the corners)
#	A : any context except title-bar buttons.  
#	0-9 : title-bar buttons
#     or any combination of these letters. The buttons are numbered:
#			 1 3 5 7 9    0 8 6 4 2
#
# (*) Modifiers: any combination of
#	N : no modifiers	C : control 		S : shift
#	M : Meta		A : any modifier

Key Left 	A	M	Scroll -100 +0
Key Right	A	M	Scroll +100 +0
Key Up		A	M	Scroll +0 -100
Key Down	A	M	Scroll +0 +100
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andy Arbon <[email-masked]>
Date: Mon, 01 Dec 2003 18:32:15 +0000

Mike Hunter wrote:
| Anyway, I've got a problem with fvwm's interaction with netscape.  When I
| do Control-F to find-in-text, it pops up its little window to get the
| text, but the window doesn't have any handles.  I'm not sure how to tell
| fvwm to force handles onto it.  I don't think this is a netscape-specific
| problem...other crappy applications sometimes make similar "pop-ups".

Hello,

The command you want is:
Style * DecorateTransient

This will force all transient (about boxes, error dialogues, etc)
windows to be decorated in the same way that your main windows are.

Cheers,

Andy