Subject: FVWM: Mouse binding to switch window focus to window in direction

From: Ukpong Ukpong <[email-masked]>
Date: Tue, 2 Dec 2003 21:39:14 +0000 (GMT)

When working on one in window i wish to specify a key binding that allows 
on the switch focus to the nearest window i a certain direction of the 
currently focused window using the direction key presed by the user.....is 
this possible ....

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 2 Dec 2003 22:07:27 +0000

> currently focused window using the direction key presed by the user.....is 

Use this:

  DestroyFunc SelectWindow
  AddToFunc   SelectWindow
  + I Focus
  + I Raise
  + I WarpToWindow 50 50

  Key T WTSF CM Direction North (CurrentPage) SelectWindow  # Ctrl-Alt-T

Regards,
Mikhael.

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 2 Dec 2003 22:07:35 +0000

> currently focused window using the direction key presed by the user.....is 

I made some functions a while ago that will move a window to the border
of the nearest window in some direction, you could modify them to do what
you want.

You can see them if you search for PackWindow in my rc file here
http://dev.gentoo.org/~taviso/fvwm2rc.html

Theres probably a better way, but it works fine for me :)

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 2 Dec 2003 22:18:38 +0000

>   Key T WTSF CM Direction North (CurrentPage) SelectWindow  # Ctrl-Alt-T

Neat, I didnt know about that. Thanks Mikhael :)