Subject: Re: FVWM: Dialog placements

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 1 Dec 2003 12:49:59 +0000

On 28 Nov 2003 13:28:14 +0100, Carsten Prescher wrote:
> 
> is it possible to force dialogs to pop up near or on its
> parents? I could not found anything in the documentation.
> Maybe I missed a capable module.

I don't see an easy way to do it currently. But you may write a small
fvwm module in Perl yourself that does Move to a position that you think
is good near the parent, or even just a shell script with FvwmEvent.
Some ideas (not a ready sample):

  parent_id=`xprop -id $[w.id] | grep WM_TRANSIENT_FOR | awk '{print $5}'`

  WindowId $[parent_id] Echo $[w.x] $[w.y]

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Mon, 01 Dec 2003 18:44:43 -0500 (EST)

Mikhael Goikhman <[email-masked]> wrote
on Mon, 1 Dec 2003 12:49:59 +0000:
>
> Subject: Re: FVWM: Dialog placements
>

I've already hacked up a module in C a while ago. It works OK,
as long as the parent app sets its WM_TRANSIENT_FOR hint correctly.
There is a flicker as fvwm moves the window, but I'd guess that
can't be avoided without putting this functionality into the
placement code of fvwm core (which I think would be a great idea,
if someone familiar with that code fancies it).

Let me know if this doesn't work for someone reason, and I'll try
to fix it for you.

http://cns.georgetown.edu/~ric/software/fvwm/FvwmPlaceTransient.tar.gz

Cheers
Ric