Subject: FVWM: Little Emacs question

From: Artur Scianek <[email-masked]>
Date: Sat, 13 Dec 2003 18:52:02 +0100

Hello
How can I make my fvwm-mode.el accesible via M-x fvwm-mode ??
Where shpuld I copy fvwm-mode.el (or maybe fvwm-mode.elc) ??
Thanks for answer
Artur Scianek

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Glyn Millington <[email-masked]>
Date: Sat, 13 Dec 2003 18:51:19 +0000

> Where shpuld I copy fvwm-mode.el (or maybe fvwm-mode.elc) ??

A. Put the fvwm-mode.el file somewhere in your emacs load-path so that
   emacs can find it.  By all means byte-compile it.

B. In your .emacs file put 

 (setq auto-mode-alist (append auto-mode-alist
		   '(("\\.fvwmrc$" . fvwm-mode))))

These instructions should be part of the file!

hth

Glyn

---

From: Dan Espen <[email-masked]>
Date: Sat, 13 Dec 2003 14:00:10 -0500

> These instructions should be part of the file!

Yes, those instructions are part of the file.

In case you can't put the file somewhere in your loadpath,
you can extend the load-path.

First:

mkdir ~/emacs

then in ypur .emacs:

(setq load-path (append  (list (expand-file-name "~/emacs")) load-path))

The put the file in your ~/emacs directory.

I think it makes more sense to modify the auto-mode-alist with:

       '(("\\.fvwm"  . fvwm-mode))

Since some of your .fvwm files may not be recognized by the above pattern.

-- 
Dan Espen                           E-mail: [email-masked]