Subject: FVWM: ClickToFocus Bug?

From: Christoph Litauer <[email-masked]>
Date: Fri, 19 Dec 2003 15:54:54 +0100

Hi,

I am no expert in configuring fvwm but have a little problem where I 
need some help.
Attached is my fvwm2rc Konfiguration. As you can see I use
Style * ClickToFocus
Style * ClickToFocusRaises
Style * ClickToFocusPassesClickOff

as my focus policy for some kiosk terminals.
This works great for some years now.

Two days ago I switched my kiosks from netscape to mozilla firebird. 
Nearly all work the same except for one thing: I have one link on a web 
page, opening a new (maybe transient?) window. This window appears very 
short and the lowers itself under the main window. This happes only if 
my cursor is not in the area where the new window will appear, otherwise 
the new window will stay raised.
This sounds to me like a FocusFollowsMouse policy ... but I didn't 
configure it.

Any help is appreciated.

-- 
Gruß
Christoph Litauer
________________________________________________________________________
Christoph Litauer                  [email-masked]
Uni Koblenz, Rechenzentrum,        http://www.uni-koblenz.de/~litauer
Postfach 201602, 56016 Koblenz     Fon: +49 261 287-1311, Fax: -100 1311
PGP-Key: http://www.uni-koblenz.de/~litauer/public-key.html

#-----------------------------------------------------------------------------#
#
# Sample-95: .fvwm2rc example configuration file for a more or less Windows95
#            look and feel
#
# The suggested way to install this configuration file is to (re)move
# any .fvwm2rc file you have in ~/.fvwm or ~ and run fvwm without any
# startup file.
#
# Then, run the "Setup 95 Script" from the root menu. This creates
# and installs the following configuration files: .fvwm2rc, bindings,
# decorations, functions, globalfeel, menus, modules, startup, styles,
# iconstyles.
# If perl is not installed on your machine (my god), only one file is
# installed: .fvwm2rc (and this configuration should work). Some instructions
# are given below for a first editing of this file. Maybe the first thing
# to do in this case is to segment this file. For that, you can move the
# parts of this file between the marks "#SEG foo" and "#SEG xyz" into a
# file foo and add "Read foo" to this file (until the "#SEG END" mark).
#
# You do need the fvwm_icons distribution installed in the FVWM image path.
# If they are installed in another directory use the ImagePath command
# below or set this directory via the Setup95 Script.
#
# For the sound effects to work you need the fvwm_sounds distribution
# installed and an .au player. The Setup95 Script allows you to set the
# installation directory of this distribution as your sound player (if not,
# manually edit the *FvwmEvent commands). Note that if you use rplay, the
# rplayd daemon must be run.
#
# The Setup95 Script asks you to choose between two looks, one is close
# to Windows and the other one is close to a "classical" FVWM look.
# For switching from the windows look to the FVWM one by hand, comment the
# x lines that follow the #WIN x lines and uncomment the x lines that
# follow the #FVWM x lines.
#
# There is an option for machines with a "low X server (comment #FAST and
# uncomment #SLOW). You may have to use some intermediate values (Base
# Configuration can help and if you "rebuild Sample-95" .FvwmBaseConfig
# may over write the effect of this option). See also the BackingStore and
# SaveUnder style.
#
# I've tried to use very common apps (like Gimp or Netscape) so that this
# configuration file is as universal as possible. For menus, the Setup 95
# Script starts with a big menu.  Comment the menu entries that correspond
# to applications not in your path. Moreover, the Setup95 Script asks you
# to set your preferred terminal, editor and file manager (#PREF). However,
# you surely need to edit the menu definitions and the BarButtons
# configuration to get your preferred applications.
#
# I have a laptop so I have added one laptop option. If you answer yes
# to the Setup95 question: "do you have a laptop?" you will have xapm
# in your BarButtons. To get it by hand, just uncomment the line that
# follows #LAPTOP.
#
# GNOME and KDE menus: FVWM has a perl script that can build GNOME and
# KDE menus: fvwm-menu-desktop (man fvwm-menu-desktop for details). If GNOME
# and/or KDE are installed in your machine, Setup95 will ask you which menus
# you want to add to your Programs sub menus (G_SM_G/F means FvwmGtk/fvwm
# gnome system menu, G_SM_G/F means FvwmGtk/fvwm2 gnome user menu, G_RHM_G/F
# means gnome redhat menu, G_M_G means that we need to start FvwmGtk, K_SM
# means kde system menu and K_UM means kde user menu. You may have to edit
# the line G_*M_* to set your GNOME install directory (Setup95 try to
# find it)). KDE (mini-)Icon Styles and KDE ImagePath (#K_M) are provided
# if you select one of the KDE menus. For GNOME, (mini-)Icon Styles are
# provided if you have the panel installed (#G_ST) and the image path is
# set if you ask for FvwmGtk menus (#G_M_G).
#
# GNOME session: This configuration can be used under gnome-session. In
# this case almost no modules are started (for a first installation).
# However, you may use more modules: this depends on your gnome panel
# configuration. If Setup95 builds a configuration to be used
# under gnome-session, the lines which follow #G_SESSION will be uncommented.
# The panel stays put option  (the line which follow #G_PANEL) try to put
# the panel in the same layers as the other windows.
# Note that it safe to "Build a config for gnome-session" for using with
# a normal FVWM session.
#
# CDE: There is an elementary support for CDE (lines which follow #CDE).
#
# Note: for saving its state (the changes you do via settings-->* up to the
# first separator) Sample-95 uses some files $FVWM_USERDIR/.start-* (see
# section 5), $FVWM_USERDIR/.fvwm-layers (see section 6) and the usual FVWM
# config files: .FvwmAnimate, .FvwmForm, ~/.xinitrc-fvwm, .FvwmBaseConfig
#
# There are many comments, but a good reading of the FVWM FAQ, of the man
# pages of FVWM and its modules is recommended. Also, you can read the
# sample-95 MINI-FAQ that you can find at the end of this file.
#
#!D For the fvwm-workers. These lines will not appear if the Setup95 Script
#!D is used to install this file. I hope that the above lines give enough
#!D information for editing this file at a devel level. Be sure to take a
#!D look to the perl script fvwm-script-setup95.pl and to FvwmScript-Setup95.
#!D More information is given here.
#!D If you add entries to the menus which contains Exec and exec then
#!D fvwm-script-setup95.pl will check if the application run is in
#!D the path. Supported format is
#!D Exec exec app [options]
#!D Exec cd path; /.app [options] (to run path/app in path)
#!D Exec exec killall app
#!D Exec xterm [options] -e app [option]
#!D Moreover, you can use #!E app1:app2:... in the end of a line for
#!D commenting this line unless app1 or app2 or ... is in the path.
#!D This is currently used in icons styles definitions and for line
#!D separator in menu definitions. These ends of line will not appear in the
#!D builded file.
#
#-----------------------------------------------------------------------------#
#
# Summary:
#
# 1.  Module and Image paths. (In this file)
# 2.  Root cursor, Windows Decoration and Menus Style. (In decorations)
# 3.  Set up the Major operating modes. (In globalfeel)
# 4.  Miscellaneous Major operating mode. (In globalfeel)
# 5.  Stuff to do at start-up and on restart. (In startup)
# 6.  Set applications dependent styles. (In styles)
# 7.  Set applications Mini Icons and Icons. (In iconstyles)
# 8.  Define some complex functions. (In functions)
# 9.  Mouse, frame buttons and keyboard bindings. (In bindings)
# 10. Define the menus. (In menus)
# 11. Definitions used by the modules. (In modules)
# 12. MINI-FAQ. (In this file)
#
#-----------------------------------------------------------------------------#

#-----------------------------------------------------------------------------#
#
# 1. Module and Image paths
# These paths are colon-separated lists, just like regular unix PATH
#
#-----------------------------------------------------------------------------#

# ModulePath is builtin, you may add some directories here
#ModulePath $HOME/mymodules:+

# The default image path is:
#         /usr/include/X11/bitmap:/usr/include/X11/pixmaps
# if the fvwm_icons are not installed in one of these directories or if
# you want to add a personal image path uncomment and edit the next line
ImagePath /usr/local/share/fvwm/pixmaps

#K_M 1 for KDE Styles and menus
#ImagePath +:$KDEDIR/share/icons:$KDEDIR/share/apps/kappfinder/pics/:
#G_M_G 1 for FvwmGtk menus
#ImagePath +:/usr/share/pixmaps:
# Warning: you may have to replace /usr by gnomeinstallpath in the previous
# line. gnomeinstallpath may be /usr/local, /opt/gnome, ...

#-----------------------------------------------------------------------------#
#
# Start the Show
#
#-----------------------------------------------------------------------------#

#SEG decorations
#-----------------------------------------------------------------------------#
#
# 2. Root cursor, Windows Decoration and Menu Styles:
#   Default fonts, colors, Border, Title, Button Styles, Menu Styles
#   window button bindings.
#   (this section may be the theme part of the config, but you need to use
#    FvwmTheme to define and propagate the colors)
#-----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
# Set the root cursor
#------------------------------------------------------------------------------

CursorStyle ROOT         left_ptr
CursorStyle TITLE        left_ptr
CursorStyle DEFAULT      left_ptr
CursorStyle SYS          left_ptr
CursorStyle MENU         left_ptr

#------------------------------------------------------------------------------
# Fonts - one for window titles, another for icons, and another for the menus
#------------------------------------------------------------------------------

#WIN 1
Style * Font		-*-lucida-medium-r-*-*-12-*-*-*-*-*-*-*
#FVWM 1
#Style * Font		-*-times-bold-r-*-*-14-*-*-*-*-*-*-*

Style * IconFont	fixed

#------------------------------------------------------------------------------
# Set the default window colors.
#------------------------------------------------------------------------------

# Text and background color for the title bar (overridden in the WIN case),
# and the border of the inactive window (also used by icon title,
# and "hilight" and "shadow" colors).
#WIN 1
Style * ForeColor #c3c3c3, BackColor #c3c3c3
#FVWM 1
#Style * ForeColor #c3c3c3, BackColor grey51

# Text and background color for the title bar (overriden in the WIN case),
# and the border of the active (selected) window (also used by icon title,
# and "hilight" and "shadow" colors).
#WIN 1
Style * HilightFore white, HilightBack #c3c3c3
#FVWM 1
#Style * HilightFore white, HilightBack SlateBlue

#------------------------------------------------------------------------------
# Border, Title and Button Styles
#------------------------------------------------------------------------------
Style * BorderWidth 5, HandleWidth 5

#WIN 13
Style	"*"	FvwmBorder  # MWMBorder
Style	"*"	FvwmButtons
BorderStyle	Inactive -- HiddenHandles NoInset
BorderStyle	Active -- HiddenHandles NoInset
TitleStyle	ActiveUp (solid Blue4 -- Flat)
TitleStyle	ActiveDown (solid Blue4 -- Flat)
TitleStyle	Inactive (solid grey51 -- Flat)
TitleStyle	LeftJustified
ButtonStyle	1	MiniIcon (-- flat)
ButtonStyle	all	-- UseTitleStyle Flat
AddButtonStyle	2	Pixmap mini.winXX-close.xpm
AddButtonStyle	4	Pixmap mini.winXX-maximize.xpm
AddButtonStyle	6	Pixmap mini.winXX-minimize.xpm

#FVWM 11
#Style	"*"	FvwmBorder  # MWMBorder
#Style	"*"	MWMButtons
#TitleStyle	Centered
#ButtonStyle	all	-- UseTitleStyle
#ButtonStyle 2 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
#ButtonStyle 4 4 50x25@1 75x75@0 25x75@0 50x25@1
#ButtonStyle 6 4 50x65@1 35x35@1 65x35@1 50x65@0
#ButtonStyle 1 - Clear MWMDecorMenu
#ButtonStyle 2 - Clear
#ButtonStyle 4 - Clear MWMDecorMax
#ButtonStyle 6 - Clear MWMDecorShade

#------------------------------------------------------------------------------
# The MenuStyle command allows almost full control over menu look and feel.
# We use the preconfigured 'Win' or 'Fvwm' default. This resets most other
# options and must be set first. We also define a menu called winops for
# the windows operations menus and very long one. The menus which use this
# style are (and must) be defined in the end of the menus.
#------------------------------------------------------------------------------

#WIN 4
MenuStyle * win
MenuStyle * font -*-lucida-medium-r-*-*-12-*-*-*-*-*-*-*
MenuStyle * Foreground black, Background grey80
MenuStyle * ActiveFore white, HilightBack Blue4
#FVWM 5
#MenuStyle * fvwm
#MenuStyle * font -*-times-bold-r-*-*-14-*-*-*-*-*-*-*
#MenuStyle * Foreground black, Background grey80
#MenuStyle * ActiveFore black, HilightBack grey85
#MenuStyle * Hilight3DThick

MenuStyle * Greyed grey60  # default is invisible on backgroud grey80
MenuStyle * VerticalItemSpacing 2 4, VerticalTitleSpacing 2 4

CopyMenuStyle * winops

#WIN 1
MenuStyle winops font -*-lucida-medium-r-*-*-12-*-*-*-*-*-*-*
#FVWM 2
#MenuStyle winops font -*-times-bold-r-*-*-12-*-*-*-*-*-*-*
#MenuStyle winops TitleWarpOff

MenuStyle winops VerticalItemSpacing 1 2, VerticalTitleSpacing 1 2

#SEG globalfeel
#-----------------------------------------------------------------------------#
#
# 3. Set up the major operating modes
#
#-----------------------------------------------------------------------------#

# WARNING!!!
#
# If you use (or ever used) Settings-->Configuration-->Base Config
# to configure your major operating modes then all commands in this
# section 3 are overridden by the last line of this section (PipeRead).
# So, you can comment the last line of this section.
# Or, instead, you can remove all the lines of this section but the last one.
#
# If you use Base Config and this section has some application dependent
# styles, a suggested solution is to move them to the styles file.
# This way Base Config does not destroy your application specific
# styles when you use it.

#WIN 1  To have more WIN-like behavior
Emulate win
#FVWM 1
#Emulate fvwm

HideGeometryWindow Never

#WIN 1
SnapAttraction 10 SameType Screen
#FVWM 1
#SnapAttraction 0 SameType Screen

#FAST 3
OpaqueMoveSize 0
Style * ResizeOpaque
Style * WindowShadeSteps 20
#SLOW 3
#OpaqueMoveSize 0
#Style * ResizeOutline
#Style * WindowShadeSteps 0

EdgeScroll 0 0
EdgeResistance 500 0
EdgeThickness 1

#
# The focus policy. Once you are used to clicking *inside* windows to
# raise them you will not want to lose this feature.
#
#Style * SloppyFocus
Style * ClickToFocus 
Style * ClickToFocusRaises
Style * ClickToFocusPassesClickOff

#
# MinOverlapPlacement places window automatically in a way that attempts to be
# place windows 'intelligent'.
#
#Style * MinOverlapPlacement
Style * CascadePlacement

#
# NoPPosition instructs FVWM to ignore the PPosition field in window
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
#

Style * NoPPosition

#Style * GrabFocusOff

# If you ever used Base Config, then the next line overrides this section
# with the settings you defined! In this case you may replace the whole
# section 3 by one command "Read .FvwmBaseConfig".
#PipeRead '[ ! -f $FVWM_USERDIR/.FvwmBaseConfig ] || echo Read .FvwmBaseConfig'

#----------------------------------------------------------------------------#
#
# 4. Miscellaneous Major operating mode
#
#----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
# Set the desk top size in units of physical screen size
#------------------------------------------------------------------------------

DeskTopSize 1x1

#------------------------------------------------------------------------------
# Some good things (in general)
#------------------------------------------------------------------------------
#Style * MWMFunctions
#Style * MWMDecor
#Style * HintOverride
#Style * OLDecor

#BusyCursor DynamicMenu True, Read True

#------------------------------------------------------------------------------
# transient windows
#------------------------------------------------------------------------------

# You can do a lot of things with transient windows. However, you may
# want to set transient style by application (in styles).
# Heres one example:
#
# If you want to decorate transient windows:
#Style * DecorateTransient
# In *general* it is not a good idea to be able to lower transient window
# under its main window, but why not...
#Style * DontRaiseTransient
# In my HO the defaults (which are "Motif" compliant) are good.
Style * RaiseTransient
Style * LowerTransient
Style * DontStackTransientParent

#------------------------------------------------------------------------------
# bogus hack
#------------------------------------------------------------------------------

#
# FVWM has a command for bogus applications. Here an example with KFM
#

#KFM_ICONS 1 uncomment the next line if you use the KFM "icons"
#BugOpts RaiseOverUnmanaged on

#PANEL_PUT 1 you may try this for a "stays put" gnome panel
#DefaultLayers 6 8 10

#SEG startup
#-----------------------------------------------------------------------------#
#
# 5. Stuff to do at start-up and on restart
#
#-----------------------------------------------------------------------------#

# Defines the background
#Read .start-Background
# This file defines which applications manager we start: TaskBarGlobal,
# TaskBarDesk, IconBoxGlobal, IconBoxDesk, ...etc.
#Read .start-apps-man
# This one decides which big buttons we start BarButtons, Wharf or None
#Read .start-FvwmButtons
# This one decides if we start the DeskerPanel
#Read .start-DeskerPanelButtons
# This one decides if we start MiniButtons
#Read .start-MiniButtons
# This one decides if we start WinMakerAppButtons
#Read .start-WinMakerAppButtons
# This file decides if we start FvwmAnimate or not
#Read .start-FvwmAnimate
# This one decides if we start FvwmAuto
#Read .start-FvwmAuto
# This one decides if we start FvwmBanner
#Read .start-FvwmBanner
# Sounds effect (FvwmEvent)
#Read .start-FvwmEvent

# The StartFunction is used at start and restart with or without a Session
# Manager. The above file .start-* defines this function. If
# we want Gtk menus and dialog (defined in the modules section) we start
# FvwmGtk.

#AddToFunc StartFunction
#G_M_G 1
#+ I Module FvwmGtk

# The InitFunction is used at FVWM start

AddToFunc InitFunction
# Load the X Setup Scripts setting if we use it
+ I Exec [ -f $HOME/.xinitrc-fvwm ] && sh $HOME/.xinitrc-fvwm
+ I Exec exec xsetroot -solid DodgerBlue4

# The restart function:

#AddToFunc RestartFunction
#+ I Module FvwmButtons MyButtons

#
# When used with a session manager FVWM uses SessionInitFunction and
# SessionRestartFunction in the place of  InitFunction and RestartFunction
#

AddToFunc SessionInitFunction
# Do not Load the X Setup Scripts setting, some Session Managers have its own
# method (e.g., GNOME)
#+ I Exec [ -f $HOME/.xinitrc-fvwm ] && sh $HOME/.xinitrc-fvwm
#+ I Module FvwmButtons MyButtons

#AddToFunc SessionRestartFunction
#+ I Module FvwmButtons MyButtons

#SEG styles
#-----------------------------------------------------------------------------#
#
# 6. Set application dependent styles
#
# Order is important!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.
#
#-----------------------------------------------------------------------------#

Style *lock        NoTitle, NoHandles, Sticky, WindowListSkip
Style xeyes        NoTitle, Sticky
Style *biff*       NoTitle,            Sticky, WindowListSkip
Style xsysinfo     NoTitle,            Sticky, WindowListSkip
Style xload        NoTitle,            Sticky, WindowListSkip
Style xconsole                         Sticky, StartIconic
Style xpostit                                  WindowListSkip
Style PostitNote                               WindowListSkip
Style Postit       NoHandles,                  WindowListSkip
# gnome panel & icons
Style panel        Sticky, NoTitle, WindowListSkip, CirculateSkip
Style desktop_icon CirculateSkip, WindowListSkip,  NoTitle
# Animation is broken in gnome panel 1.4 with GNOMEUseHints.
# GNOMEIgnoreHints also disables panel moving itself from layer to layer.
Style panel        GNOMEIgnoreHints
# xsm panel
Style xsm          Sticky, NoTitle, WindowListSkip, CirculateSkip

Style FvwmForm-QuitVerify NoButton 1, NoButton 2, NoButton 4, NoButton 6, \
				StaysOnTop, NoHandles, WindowListSkip

# Some version of Netscape need the following if you want that the
# page source (and others horrible banner) to be decorated (but you may
# lost some MWM decor hints)
#Style Netscape NoDecorHint

# I do not like that the "find in page" of netscape cannot be lowered.
# Uncomment the next line if your are agree.
#Style Netscape DontRaiseTransient

#DT 1 for the CDE "desk icon"
#Style popup_* CirculateSkip, WindowListSkip

# Read the layers settings (stays OnTop, Put or OnBottom)
# Read .fvwm-layers

#SEG iconstyles
#-----------------------------------------------------------------------------#
#
# 7. Set applications Mini Icons and Icons
#
#-----------------------------------------------------------------------------#

# Note: Most applications provide an icon.

Style *		IconBox 10 -80 -0 -0, IconGrid 64 64, IconFill left bottom, \
		IconBox 10 +300 -150 -80, IconGrid 64 64, IconFill bottom left
Style *		SlipperyIcon, IconTitle

# default
Style *         	MiniIcon mini.doc.xpm, Icon page.xpm

# Terminals
Style *term*		MiniIcon mini.term.xpm, Icon rterm2.xpm
Style rxvt      	MiniIcon mini.term.xpm, Icon rterm2.xpm #!E rxvt

# Accessories
Style xcalc     	MiniIcon mini.calc.xpm, Icon rcalc2.xpm
Style xconsole  	MiniIcon mini.term.xpm, Icon rtrem2.xpm
Style xmag      	MiniIcon mini.zoom.xpm, Icon mag_glass.xpm
Style xfontsel		MiniIcon mini.font.xpm, Icon toolbox.xpm
Style xgrab		MiniIcon mini.camera.xpm
Style *clock*		MiniIcon mini.clock.xpm
Style ddd		MiniIcon mini.bug2.xpm #!E ddd
Style xgdb		MiniIcon mini.bug2.xpm #!E xgdb
Style XClipboard   	MiniIcon mini.clipboard.xpm, Icon toolbox.xpm
Style *color*		MiniIcon mini.colors.xpm, Icon resize

# Applications
Style lyx		MiniIcon mini.edit.xpm		#!E lyx
Style thot		MiniIcon mini.edit.xpm		#!E thot
Style ghostview 	MiniIcon mini.gv.xpm		#!E ghostview
Style gv	 	MiniIcon mini.gv.xpm		#!E gv
Style xdvi		MiniIcon mini.zoom.xpm		#!E xdvi
Style acroread	 	MiniIcon mini.pdf.xpm		#!E acroread
Style xpdf		MiniIcon mini.pdf.xpm		#!E xpdf
Style plan		MiniIcon mini.calandar.xpm	#!E plan

# Sciences
Style GNUplot		MiniIcon mini.graph.xpm, Icon graphs.xpm #!E gnuplot
Style *maple		MiniIcon mini.zoom.xpm #!E xmpale
Style Scilab    	MiniIcon mini.graph2.xpm #!E scilab
Style Xaos		MiniIcon mini.fractal.xpm #!E xaos
Style fractint		MiniIcon mini.fractal.xpm #!E xfractint
Style xephem		MiniIcon mini.exp.xpm #!E xephem
Style XTide		MiniIcon mini.exp.xpm #!E xtide
Style THX-1138		MiniIcon mini.calc.xpm #!E thx-1138

# System
Style Top		MiniIcon mini.run.xpm, Icon toolbox.xpm
Style tkps		MiniIcon mini.hex.xpm, Icon toolbox.xpm #!E tkps
Style xosview		MiniIcon mini.run.xpm, Icon toolbox.xpm #!E xosview
Style xload		MiniIcon mini.perf.xpm, Icon toolbox.xpm
Style xmem		MiniIcon mini.perf.xpm, Icon toolbox.xpm #!E xmem
Style XSysStats         MiniIcon mini.run.xpm #!E XSysStats
# File Mgr
Style xfm		MiniIcon mini.filemgr.xpm, Icon Xfm.xpm #!E xfm
Style fr		MiniIcon mini.filemgr.xpm, Icon Xfm.xpm	#!E fr
Style Midnight-Commander MiniIcon mini.filemgr.xpm, Icon Xfm.xpm #!E mc

# Editors
Style emacs		MiniIcon mini.edit.xpm, Icon lemacs.xpm #!E emacs:xemacs
Style VIM		MiniIcon mini.edit.xpm, Icon lemacs.xpm #!E gvim
Style *edit		MiniIcon mini.edit.xpm, Icon lemacs.xpm
Style dtpad		MiniIcon mini.edit.xpm, Icon lemacs.xpm #!E /usr/dt/bin/dtpad

# Network
Style *ppp*		MiniIcon mini.connect.xpm, Icon Mosaic.xpm
Style Hifs		MiniIcon mini.connect.xpm, Icon Mosaic.xpm #!E hifs

# Internet
# Netscape resource
Style Netscape  	MiniIcon mini.nscape.xpm
Style Navigator 	MiniIcon mini.nscape.xpm
Style MailFolder 	MiniIcon mini.dirlink.xpm
Style MailThread 	MiniIcon mini.mail.xpm
Style Composition	MiniIcon mini.letter.xpm
Style Composer		MiniIcon mini.editor.xpm
Style *Download*	MiniIcon mini.ftp.xpm
#
Style amaya		MiniIcon mini.nscape.xpm #!E amaya
Style Mozilla		MiniIcon mini.nscape.xpm #!E mozilla
Style lynx		MiniIcon mini.cat.xpm,  Icon Mosaic.xpm #!E lynx
Style xmh		MiniIcon mini.mail.xpm, Icon Mail2.xpm  #!E xmh
Style Mail         	MiniIcon mini.mail.xpm, Icon Mail2.xpm  #!E mail
Style *mail*         	MiniIcon mini.mail.xpm, Icon Mail2.xpm
Style Pine		MiniIcon mini.mail.xpm, Icon Mail2.xpm #!E pine
Style Mutt		MiniIcon mini.mail.xpm, Icon Mail2.xpm #!E mutt
Style NcFtp        	MiniIcon mini.ftp.xpm,  Icon Mosaic.xpm #!E ncftp
Style *ftp*        	MiniIcon mini.ftp.xpm,  Icon Mosaic.xpm
Style "X-Chat*"		MiniIcon mini.doc1.xpm, Icon page.xpm #!E xchat
Style Irc		MiniIcon mini.doc1.xpm #!E irc
Style tkirc		MiniIcon mini.doc1.xpm #!E tkirc
Style Licq		MiniIcon mini.doc1.xpm #!E licq
Style
Style zircon        	MiniIcon mini.zircon.xpm #! zircon
Style xgopher		MiniIcon mini.gopher.xpm #!E xgopher

# Graphics
Style xv        	MiniIcon mini.xv.xpm #!E xv
Style "The GIMP"  	MiniIcon mini.gimp.xpm, Icon gimp.xpm #!E gimp
Style "Gimp"		MiniIcon mini.gimp.xpm, Icon gimp.xpm #!E gimp
Style xfig		MiniIcon mini.xfig.xpm #!E xfig
Style xfpovary		MiniIcon mini.ray.xpm #!E xfpovary
# xpaint resource names
Style xpaint    	MiniIcon mini.palette.xpm
Style Canvas    	MiniIcon mini.palette.xpm
Style fatbits 	        MiniIcon mini.palette.xpm
Style filebrowser	MiniIcon mini.ofolder.xpm
#
Style XbmBrowser   	MiniIcon mini.directory.xpm #!E xbmbrowser
Style ee		MiniIcon mini.palette.xpm #!E ee

# Multimedia
Style *mixer		MiniIcon mini.audiovol.xpm
Style *playcd*      	MiniIcon mini.cdlabel.xpm
Style *cdplay*      	MiniIcon mini.cdlabel.xpm
Style xltwavplay        MiniIcon mini.sound.xpm #!E xltwavplay
Style MiXViews		MiniIcon mini.audiovol.xpm #!E mxv
Style freeamp		MiniIcon mini.audiovol.xpm #!E freeamp
Style XAnim             MiniIcon mini.display.xpm #!E xanim
# Games and amusement
Style *maze		MiniIcon mini.maze.xpm
Style xboard		MiniIcon mini.slon.xpm #!E xboard
Style XGammon		MiniIcon mini.go.xpm #!E xgammon
Style xsokoban		MiniIcon mini.go.xpm #!E xsokoban
Style xlander		MiniIcon mini.xlander.xpm #!E xlander
Style xmahjongg		MiniIcon mini.xmahjongg.xpm #!E xmahjongg
Style xjewel		MiniIcon mini.xjewel.xpm #!E xjewel
Style hextris		MiniIcon mini.hextris.xpm #!E hextris
Style *tetris*		MiniIcon mini.tetris.xpm
Style kpat2		MiniIcon mini.heart.xpm #!E kpat2
Style xeyes     	MiniIcon mini.eyes.xpm
Style xcat		MiniIcon mini.cat.xpm #!E xcat
Style Quake*		MiniIcon mini.destroy.xpm, Icon doomface.xpm
Style Koules		MiniIcon mini.happy.xpm
Style xroach		MiniIcon mini.roach.xpm
Style xlogo		MiniIcon mini.x2.xpm

# Modules, Form and script
Style Fvwm*			MiniIcon -
Style FvwmScript*		MiniIcon mini.fvwm.xpm
Style FvwmForm*			MiniIcon mini.fvwm.xpm
Style FvwmIdent			MiniIcon mini.question.xpm, Icon question.xpm
Style FvwmConsole		MiniIcon mini.xterm.xpm, Icon wterm.xpm
Style FvwmScript-BellSetup	MiniIcon mini.audiovol.xpm, Icon bell.xpm
Style FvwmScript-KeyboardSetup	MiniIcon mini.keyboard.xpm,Icon keyboard.xpm
Style FvwmScript-ScreenSetup	MiniIcon mini.monitor.xpm, Icon screen.xpm
Style FvwmScript-PointerSetup	MiniIcon mini.mouse.xpm, Icon pointer.xpm
Style FvwmScript-BaseConfig	MiniIcon mini.fvwm.xpm, Icon settings.xpm
Style FvwmScript-Find		MiniIcon mini.zoom.xpm, Icon find1.xpm
Style FvwmScript-Quit		MiniIcon mini.question.xpm
Style FvwmScript-Colorset	MiniIcon mini.colors.xpm, Icon settings.xpm
Style FvwmScript-ScreenDump	MiniIcon mini.camera.xpm, Icon resize.xpm
Style FvwmScript-Setup95	MiniIcon mini.fvwm.xpm, Icon settings.xpm
Style FvwmScript-Date		MiniIcon mini.clock.xpm, Icon date.xpm
Style FvwmForm-QuitVerify	MiniIcon mini.question.xpm
Style FvwmForm-Rlogin		MiniIcon mini.connect.xpm, Icon Mosaic.xpm
Style FvwmForm-Capture		MiniIcon mini.camera.xpm, Icon resize.xpm
Style FvwmForm-Talk		MiniIcon mini.telnet.xpm, Icon rterm.xpm
Style FvwmForm-RootCursor	MiniIcon mini.xarchie.xpm, Icon settings.xpm
Style FvwmForm-Form		MiniIcon mini.fvwm.xpm, Icon settings.xpm
Style FvwmForm-Setup		MiniIcon mini.fvwm.xpm, Icon settings.xpm
Style FormFvwmAnimate		MiniIcon mini.iconify.xpm, Icon settings.xpm
Style xmessage			MiniIcon mini.question.xpm, Icon settings.xpm
Style WinMakerAppButtons*	NoIcon

# Help
Style man	  	MiniIcon mini.book1.xpm, Icon help.xpm
# xman resource names
Style topBox    	MiniIcon mini.book1.xpm, Icon help.xpm
Style help      	MiniIcon mini.book2.xpm, Icon help.xpm
Style manualBrowser 	MiniIcon mini.book2.xpm, Icon help.xpm
Style *FAQ*		MiniIcon mini.question.xpm, Icon help.xpm
# others...
Style IDL*      	MiniIcon mini.zoom.xpm
Style XDbx         	MiniIcon mini.bug2.xpm
Style control-panel  	MiniIcon mini.eye.xpm #!E control-panel
Style xvidtune		MiniIcon mini.x2.xpm

# To get the kde mini-icon styles build the system menu (i.e., uncomment
# the lines that follow K_SM)

#G_ST 51 some icons, an alternative is to use fvwm2gnome and fvwm-menu-desktop
#Style "gcolorsel"  MiniIcon mini.colors.xpm,	Icon resize.xpm
#Style "gcalc"	    MiniIcon mini.calc.xpm,     Icon rcalc2.xpm
#Style "gdiskfree"  MiniIcon mini.fdisk.xpm
#Style "gEdit"      MiniIcon mini.edit.xpm,	Icon lemacs.xpm
#Style "gedit"      MiniIcon mini.edit.xpm,	Icon lemacs.xpm
#Style "gfontsel"   MiniIcon mini.font.xpm
#Style "ghex"       MiniIcon mini.hex.xpm,	Icon page.xpm
#Style "gless"      MiniIcon mini.file.xpm	Icon page.xpm
#Style "gmix"       MiniIcon mini.sound.xpm
#Style "gmailman"   MiniIcon mini.mail.xpm,	Icon mail2.xpm
#Style "gmc"        MiniIcon mini.filemgr.xpm,	Icon Xfm.xpm
#Style "gmenu"      MiniIcon mini.doc1.xpm,	Icon dialog_box.xpm
#Style "gnome-help-browser"	MiniIcon mini.book3.xpm,    Icon help.xpm
#Style "GnomeHelpBrowser"	MiniIcon mini.book3.xpm,    Icon help.xpm
#Style "gnome-ppp"	MiniIcon mini.connect.xpm,	Icon Mosaic.xpm
#Style "gnome-run"	MiniIcon mini.hammer.xpm,	Icon run.xpm
#Style "gnome-sync"     MiniIcon mini.folder.xpm,	Icon folder.xpm
#Style "gnomecal"       MiniIcon norm.calendar.xpm,	Icon mini/clock.xpm
#Style "gnomecard"	MiniIcon mini.doc1.xpm,		Icon page2.xpm
#Style "gnomecc"        MiniIcon mini.hammer.xpm,	Icon mini/home.xpm
#Style "GnomeTerminal"  MiniIcon mini.term.xpm,		Icon rterm2.xpm
#Style "gnp"		MiniIcon mini.doc1.xpm,         Icon page2.xpm
#Style "gnp+"		MiniIcon mini.doc1.xpm,         Icon page2.xpm
#Style "gnumeric"	MiniIcon mini.calc2.xpm		Icon rcalc2.xpm
#Style "GQview"		MiniIcon mini.palette.xpm       Icon xpaint.xpm
#Style "gsearchtool"	MiniIcon mini.zoom.xpm,		Icon find1.xpm
#Style "gstripchart"    MiniIcon mini.graph2.xpm
#Style "gtalk"          MiniIcon mini.zircon.xpm
#Style "gtcd"           MiniIcon mini.cdlabel.xpm
#Style "gtk-shell"	MiniIcon mini.doc1.xpm,         Icon page.xpm
#Style "gtop"           MiniIcon mini.run.xpm,		Icon toolbox.xpm
#Style "gtt"            MiniIcon mini.clock.xpm,	Icon toolbox.xpm
#Style "guname"		MiniIcon mini.question.xpm      Icon page2.xpm
#Style "gw"		MiniIcon mini.run.xpm,         Icon page2.xpm
#Style "gxedit"		MiniIcon mini.edit.xpm,		Icon lemacs.xpm
#Style "vumeter"        MiniIcon mini.sound.xpm
#Style "freecell"	MiniIcon mini.heart.xpm
#Style "gnibbles"	MiniIcon mini.happy.xpm
#Style "gnobots"	MiniIcon mini.happy.xpm
#Style "gnobots2"	MiniIcon mini.happy.xpm
#Style "gnome-stones"	MiniIcon mini.happy.xpm
#Style "gnomine"	MiniIcon mini.happy.xpm
#Style "gtali"		MiniIcon mini.happy.xpm
#Style "gturing"	MiniIcon mini.happy.xpm
#Style "iagno"		MiniIcon mini.happy.xpm
#Style "mahjongg"	MiniIcon mini.happy.xpm
#Style "same-gnome"	MiniIcon mini.happy.xpm
#Style "sol"		MiniIcon mini.heart.xpm
#Style "gtkballs"	MiniIcon mini.happy.xpm
#Style "gfpoken"	MiniIcon mini.happy.xpm
#Style "Imlib*"		MiniIcon mini.hammer.xpm

#CDE 10
#Style Dtfile            MiniIcon mini.filemgr.xpm
#Style Dtpad             MiniIcon mini.edit.xpm
#Style Dthelp*           MiniIcon mini.book1.xpm
#Style Dtcm*             MiniIcon mini.calendar.xpm
#Style Dtcalc            MiniIcon mini.calc.xpm
#Style Dticon*           MiniIcon mini.palette.xpm
#Style Dtprint*          MiniIcon mini.fax.xpm
#Style Dtstyle*          MiniIcon mini.desktop.xpm
#Style "Applications Manager" MiniIcon mini.programs.xpm
#Style "Trash Can"      MiniIcon mini.paper.xpm

#SEG functions
#----------------------------------------------------------------------------#
#
# 8. Now define some handy complex functions
#
#----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click, or does a vertical maximize if
# you double click (full screen maximize would be 'Maximize 100 100')
#------------------------------------------------------------------------------

DestroyFunc Move-or-Raise
AddToFunc Move-or-Raise M Move
+                       M Raise
+                       C Raise
+                       D Maximize 0 100

#------------------------------------------------------------------------------
# As above but double click shade
#------------------------------------------------------------------------------

DestroyFunc Move-or-Raise-or-Shade
AddToFunc Move-or-Raise-or-Shade M Move
+                       M Raise
+                       C Raise
+                       D WindowShade

#------------------------------------------------------------------------------
# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click, or does a RaiseLower if you double
# click
#------------------------------------------------------------------------------

DestroyFunc Move-or-Lower
AddToFunc Move-or-Lower M Move
+                       M Lower
+                       C Lower
+                       D RaiseLower

#------------------------------------------------------------------------------
# This one moves or (de)iconifies:
#------------------------------------------------------------------------------

DestroyFunc Move-or-Iconify-or-Raise
AddToFunc Move-or-Iconify-or-Raise M Move
+			  C Raise
+                         D Iconify

#------------------------------------------------------------------------------
# This one maximizes vertically if you click (leaving room for the taskbar
# at the bottom, or does a full maximization if you double click, or a
# true full vertical maximization if you just hold the mouse button down.
#------------------------------------------------------------------------------

DestroyFunc Maximize-Func
AddToFunc Maximize-Func M	Maximize 0 98
+ 			C	Maximize 0 100
+ 			D	Maximize 100 98

#------------------------------------------------------------------------------
# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does shade if you double
# click
#------------------------------------------------------------------------------

DestroyFunc Resize-or-Raise-or-Shade
AddToFunc Resize-or-Raise-or-Shade M Resize
+                         M Raise
+                         C Raise
+                         D WindowShade

#------------------------------------------------------------------------------
# This one focuses and then 'warps' to the window.
#------------------------------------------------------------------------------

DestroyFunc FocusAndWarp
AddToFunc FocusAndWarp I Focus
+                      I WarpToWindow 1 1

#------------------------------------------------------------------------------
# Like the previous one, but de-iconifies first.
#------------------------------------------------------------------------------

DestroyFunc DeiconifyFocusAndWarp
AddToFunc DeiconifyFocusAndWarp I Iconify off
+                               I FocusAndWarp

#------------------------------------------------------------------------------
# Like the previous one, but only Raise.
#------------------------------------------------------------------------------

DestroyFunc DeiconifyFocusAndRaise
AddToFunc DeiconifyFocusAndRaise I Iconify off
+                               I Focus
+				I Raise

#------------------------------------------------------------------------------
# This one is used to modify some style for a window (almost obsolet)
#------------------------------------------------------------------------------

DestroyFunc StyleAndRecapture
AddToFunc StyleAndRecapture I Style "$0" $1
+ I All ("$0") RecaptureWindow

#------------------------------------------------------------------------------
# A really useful one: de-iconifies, warps to the window
# or creates it if it doen't exist (often used with mailtools)
#------------------------------------------------------------------------------

DestroyFunc WarpOrExec
AddToFunc WarpOrExec	   I Next (AcceptsFocus $0) Iconify -1
+		           I Next (AcceptsFocus $0) FocusAndWarp
+			   I None (AcceptsFocus $0) Exec $0 $1

#------------------------------------------------------------------------------
# For the left button
#------------------------------------------------------------------------------

DestroyMenu "window_ops_func"
AddToFunc "window_ops_func" "C" PopUp Window-Ops2
+              "M" PopUp Window-Ops2
+              "D" Delete

#------------------------------------------------------------------------------
# Functions to restart Modules and Restart/Kill FvwmButtons by aliases
#------------------------------------------------------------------------------

DestroyFunc RestartModule
AddToFunc RestartModule
+ I KillModule $0
+ I Module $0

DestroyFunc RestartModuleByAlias
AddToFunc RestartModuleByAlias
+ I All ($2) Close
+ I Module $0 $1

# This function is for WMakerFvwmButtons (start or iconify id started)
DestroyFunc MyPanelButtons
AddToFunc  MyPanelButtons
+ I All ($0) Iconify
+ I None (CirculateHit $0) FvwmButtons -g +$1+$2 $0

#------------------------------------------------------------------------------
# Functions for FvwmScript-BaseConfig
#------------------------------------------------------------------------------

DestroyFunc BaseConfigOkFunc
AddToFunc BaseConfigOkFunc I Read styles

DestroyFunc BaseConfigApplyFunc
AddToFunc BaseConfigApplyFunc I Read styles

#------------------------------------------------------------------------------
# Functions which start and save state for FvwmAnimate, FvwmEvent, etc ...
# $1 $2 is used only by FvwmAuto
#------------------------------------------------------------------------------

DestroyFunc ModuleOn
AddToFunc   ModuleOn
+ I KillModule $0
+ I Module $0 $1 $2
+ I Exec echo "AddToFunc StartFunction I $0 $1 $2" > $FVWM_USERDIR/.start-$0

DestroyFunc ModuleOff
AddToFunc   ModuleOff
+ I KillModule $0
+ I Exec echo "# Do not start $0" > $FVWM_USERDIR/.start-$0

#------------------------------------------------------------------------------
# Functions which start and save state for MiniButtons and WinMakerAppButtons
#------------------------------------------------------------------------------

DestroyFunc ButtonsOn
AddToFunc   ButtonsOn
+ I All ($2) Close
+ I Module $0 $1
+ I Exec echo "AddToFunc StartFunction I $0 $1" > $FVWM_USERDIR/.start-$1

DestroyFunc ButtonsOff
AddToFunc   ButtonsOff
+ I All ($1) Close
+ I Exec echo "# Do not start $0" > $FVWM_USERDIR/.start-$0

#------------------------------------------------------------------------------
# Functions for choosing the "Big" buttons Wharf or BarButtons
#------------------------------------------------------------------------------

DestroyFunc ChangeButtonsOn
AddToFunc  ChangeButtonsOn
+ I All (BarButtons) Close
+ I KillModule FvwmWharf
+ I Exec echo "AddToFunc StartFunction I $0" > $FVWM_USERDIR/.start-FvwmButtons
+ I $0

DestroyFunc ChangeButtonsOff
AddToFunc  ChangeButtonsOff
+ I All (BarButtons) Close
+ I KillModule FvwmWharf
+ I Exec echo "# No Buttons Bar" > $FVWM_USERDIR/.start-FvwmButtons
+ I $0

#------------------------------------------------------------------------------
# Functions for Raising modules only
#------------------------------------------------------------------------------

DestroyFunc StartModulesAutoRaise
AddToFunc StartModulesAutoRaise
+ I Style FvwmDesker Lenience
+ I FvwmAuto 400 Silent ModulesAutoRaise
+ I Exec echo "AddToFunc StartFunction I StartModulesAutoRaise" > $FVWM_USERDIR/.start-FvwmAuto

DestroyFunc ModulesAutoRaise
AddToFunc ModulesAutoRaise
+ I Current (FvwmButtons) Raise
+ I Current (FvwmTaskBar) Raise
+ I Current (FvwmIconBox) Raise
+ I Current (FvwmDesker)  Raise
+ I Current (FvwmIconMan) Raise
+ I Current (FvwmWinList) Raise
+ I Current (FvwmWharf)   Raise
+ I Current (panel)	  Raise

#------------------------------------------------------------------------------
# Functions which start and save a background
#------------------------------------------------------------------------------

DestroyFunc SetBackground
AddToFunc   SetBackground
+ I KillModule FvwmBacker
+ I $0
+ I Exec echo "AddToFunc StartFunction I $0" > $FVWM_USERDIR/.start-Background

DestroyFunc SetBackgroundOff
AddToFunc   SetBackgroundOff
+ I KillModule FvwmBacker
+ I Exec echo "# Background disabled" > $FVWM_USERDIR/.start-Background

#------------------------------------------------------------------------------
# Functions which start and defines which applications manager we use
#------------------------------------------------------------------------------

DestroyFunc ChangeAppsMan
AddToFunc  ChangeAppsMan
+ I KillModule FvwmTaskBar
+ I KillModule FvwmWinList
+ I KillModule FvwmIconMan
+ I KillModule FvwmIconBox
+ I Exec echo "AddToFunc StartFunction I $0" > $FVWM_USERDIR/.start-apps-man
+ I $0

DestroyFunc AppsManNone
AddToFunc  AppsManNone
+  I  Style * NoIcon
+ I KillModule FvwmTaskBar
+ I KillModule FvwmWinList
+ I KillModule FvwmIconMan
+ I KillModule FvwmIconBox
+ I Exec echo "AddToFunc StartFunction I Style * NoIcon # No applications Manager" > $FVWM_USERDIR/.start-apps-man

DestroyFunc UseIcons
AddToFunc  UseIcons
+ I Style * Icon
+ I Read iconstyles
# Need to reaload menus for KDE mini-icons styles
+ I Read menus
+ I KillModule FvwmTaskBar
+ I KillModule FvwmWinList
+ I KillModule FvwmIconMan
+ I KillModule FvwmIconBox
+ I Exec echo "# Use Icons" > $FVWM_USERDIR/.start-apps-man

DestroyFunc WinListDesk
AddToFunc WinListDesk
+ I Style * NoIcon
+ I *FvwmWinList: ShowCurrentDesk
+ I Module FvwmWinList

DestroyFunc WinListGlobal
AddToFunc WinListGlobal
+ I Style * NoIcon
+ I DestroyModuleConfig FvwmWinList: ShowCurrent*
+ I Module FvwmWinList

DestroyFunc TaskBarDesk
AddToFunc TaskBarDesk
+ I Style * NoIcon
+ I DestroyModuleConfig FvwmTaskBar: AutoHid*
+ I *FvwmTaskBar: DeskOnly
+ I Module FvwmTaskBar

DestroyFunc TaskBarGlobal
AddToFunc TaskBarGlobal
+ I Style * NoIcon
+ I DestroyModuleConfig FvwmTaskBar: AutoHid*
+ I DestroyModuleConfig FvwmTaskBar: Desk*
+ I Module FvwmTaskBar

DestroyFunc TaskBarDeskAutoHide
AddToFunc TaskBarDeskAutoHide
+ I Style * NoIcon
+ I *FvwmTaskBar: DeskOnly
+ I *FvwmTaskBar: AutoHide
+ I Module FvwmTaskBar

DestroyFunc TaskBarGlobalAutoHide
AddToFunc TaskBarGlobalAutoHide
+ I Style * NoIcon
+ I DestroyModuleConfig FvwmTaskBar: Desk*
+ I *FvwmTaskBar: AutoHide
+ I Module FvwmTaskBar

DestroyFunc IconManGlobal
AddToFunc IconManGlobal
+ I Style * NoIcon
+ I *FvwmIconMan: *Resolution global
+ I Module FvwmIconMan

DestroyFunc IconManDesk
AddToFunc IconManDesk
+ I Style * NoIcon
+ I *FvwmIconMan: *Resolution desk
+ I Module FvwmIconMan

DestroyFunc IconManPage
AddToFunc IconManPage
+ I Style * NoIcon
+ I *FvwmIconMan: *Resolution page
+ I Module FvwmIconMan

DestroyFunc IconBoxDesk
AddToFunc IconBoxDesk
+ I Style * NoIcon
+ I *FvwmIconBox: ResolutionDesk
+ I Module FvwmIconBox

DestroyFunc IconBoxGlobal
AddToFunc IconBoxGlobal
+ I Style * NoIcon
+ I DestroyModuleConfig FvwmIconBox: Reso*
+ I Module FvwmIconBox

#------------------------------------------------------------------------------
# Functions for Layers
#------------------------------------------------------------------------------

#DestroyFunc SetLayers
#AddToFunc SetLayers
#+ I StyleAndRecapture $n $0
#+ I Exec F=$FVWM_USERDIR; Z=$F/.fvwm-layers; T=$F/.tmp-layers; if grep -qe "$n" $Z; then sed -e "s/\ $n\ .*/\ $n\ $0/" $Z>$T; cat $T>$Z; else echo "Style $n $0" >>$Z; fi
#
#DestroyFunc DestroyLayers
#AddToFunc DestroyLayers
#+ I StyleAndRecapture $n StaysPut
#+ I Exec F=$FVWM_USERDIR; Z=$F/.fvwm-layers; T=$F/.tmp-layers; sed -e "/^Style\ $n\ .*/d" $Z>$T; cat $T>$Z
#
#------------------------------------------------------------------------------
# Function for reloading the icons styles
#------------------------------------------------------------------------------

DestroyFunc ReloadIconStylesAndMenus
AddToFunc ReloadIconStylesAndMenus
+ I Read iconstyles
+ I Read menus
# Need to reload the NoIcon style
+ I PipeRead 'if grep -qe AddToFunc $FVWM_USERDIR/.start-apps-man; then echo "Style * NoIcon"; fi'

#------------------------------------------------------------------------------
# Functions for Loading/Saving/Showing Settings
#------------------------------------------------------------------------------

DestroyFunc SaveAsSettings
AddToFunc SaveAsSettings
+ I Exec F=$FVWM_USERDIR;for i in ~/.xinitrc-fvwm $F/.FvwmBaseConfig $F/.FvwmAnimate $F/.FvwmForm $F/.start-Background $F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons $F/.start-MiniButtons $F/.start-WinMakerAppButtons $F/.start-FvwmAnimate $F/.start-FvwmAuto $F/.start-FvwmBanner $F/.start-FvwmEvent $F/.fvwm-layers; do [ ! -f "$i" ] || /bin/cp $i $i-$0; done;

DestroyFunc LoadSettings
AddToFunc LoadSettings
+ I Exec F=$FVWM_USERDIR; for i in ~/.xinitrc-fvwm $F/.FvwmBaseConfig $F/.FvwmAnimate $F/.FvwmForm $F/.start-Background $F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons $F/.start-MiniButtons $F/.start-WinMakerAppButtons $F/.start-FvwmAnimate $F/.start-FvwmAuto $F/.start-FvwmBanner $F/.start-FvwmEvent $F/.fvwm-layers; do [ ! -f "$i-$0" ] || /bin/cp $i-$0 $i; done;
+ I Exec [ ! -f ~/.xinitrc-fvwm-$0 ] || (xscreensaver-command -exit; ~/.xinitrc-fvwm-$0)
+ I PipeRead '[ ! -f $FVWM_USERDIR/.FvwmBaseConfig ] || (echo Read .FvwmBaseConfig; echo BaseConfigOkFunc)'
+ I Style * StaysPut
+ I Read .fvwm-layers-$0
+ I KillModule FvwmAnimate
+ I KillModule FvwmAuto
+ I KillModule FvwmEvent
+ I KillModule FvwmButtons
+ I KillModule FvwmWharf
+ I KillModule FvwmTaskBar
+ I KillModule FvwmWinList
+ I KillModule FvwmIconMan
+ I KillModule FvwmIconBox
+ I PipeRead 'F=$FVWM_USERDIR; F=$FVWM_USERDIR; for i in $F/.start-Background $F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons $F/.start-MiniButtons $F/.start-WinMakerAppButtons $F/.start-FvwmAnimate $F/.start-FvwmAuto $F/.start-FvwmBanner $F/.start-FvwmEvent; do [ ! -f "$i-$0" ] || sed -e s/AddToFunc\\.StartFunction\\.I\\.// $i-$0; done; if [ -f "$F/.start-apps-man-$0" ]; then if grep -qe Icons $F/.start-apps-man-$0; then echo "Style * Icon"; echo "Read iconstyles"; echo "Read menus"; fi; fi'

DestroyFunc ShowFvwmSettings
AddToFunc ShowFvwmSettings I Exec F=$FVWM_USERDIR;f=$F/.tmp-modules-setting; echo "" > $f; for j in 0 1 2 3 4; do if [ "$j" -eq "0" ]; then j=""; t="Current Setting:"; l="--------------"; else j="-$j"; t="Setting$j:"; l="---------"; fi; echo $t >> $f; echo $l >> $f; for i in $F/.start-Background $F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons $F/.start-MiniButtons $F/.start-WinMakerAppButtons $F/.start-FvwmAnimate $F/.start-FvwmAuto $FVWM_USERDIR/.start-FvwmBanner $F/.start-FvwmEvent; do z="$i$j"; [ ! -f "$z" ] || sed -e s/^\\#\.// -e s/\.*exec/Background:/ -e s/AddToFunc\.StartFunction\.I/Start/ -e s/FvwmEvent/Sounds\ Effect/ $z >> $f; done; echo -n "Base Config: ">>$f; if [ -f $F/.FvwmBaseConfig$j ]; then echo "Used">>$f; else echo "Not Used">>$f; fi; echo "">>$f;done; xmessage -file $f

DestroyFunc ShowXSettings
AddToFunc ShowXSettings \
I Exec T=$FVWM_USERDIR/.tmp-x-set;u=~/.xinitrc-fvwm;echo "">$T;for j in 0 1 2 3 4;do if [ "$j" -eq "0" ];then z=$u;t="Current Setting:";else z="$u-$j";t="Setting-$j:";fi;echo $t >>$T;if grep -qe Bell $z;then grep -e "xset b" $z|sed -e s/xset\.b/Bell:/>>$T;fi;if grep -qe Screen $z;then echo -n "Background: ">>$T;if grep -qe \#xsetroot $z;then echo "disabled">>$T;elif grep -qe xpmroot $z;then grep -e xpmroot $z|sed -e s/xpmroot\.//>>$T;else grep -e xsetroot $z|sed -e s/xsetroot\.//>>$T;fi;grep -e "xset s" $z|sed -e s/xset\.s/xsaver:/>>$T;echo -n "DPMS: ">>$T;grep -e xset\.*dpms $z|sed -e s/xset\.-dpms/Off/ -e s/xset\.dpms/On/>>$T;echo -n "xscreensaver: ">>$T;if grep -qe \#xscreen $z;then echo "Off">>$T;else echo "On">>$T;fi;fi;if grep -qe Keyboard $z;then echo -n "Keyboard: ">>$T;grep -e "xset r" $z|sed -e s/xset\.r/auto\ repeat/ -e s/c/Vol/>>$T;fi;if grep -qe Pointer $z;then echo -n "Mouse: ">>$T;grep -e "xset m" $z|sed -e s/xset\.m//>>$T;fi;echo "">>$T;done;xmessage -file $T

DestroyFunc ShowLayers
AddToFunc ShowLayers I Exec F=$FVWM_USERDIR; T=$F/.tmp-layers; echo -e "A StaysOnTop window is a window which is above \nthe normal (i.e., StaysPut) windows, a StaysOnBottom\nwindow is below the normal windows. Here the list\nof StaysOnTop and StaysOnBottom windows:\n"> $T; u=$F/.fvwm-layers; for j in 0 1 2 3 4; do if [ "$j" -eq "0" ];then z=$u; t="Current Setting:"; l="---------------"; else z="$u-$j"; t="Setting-$j:"; l="----------"; fi; echo $t >>$T; echo $l >>$T; [ ! -f $z ] || cat $z>>$T; echo "" >> $T; done; xmessage -file $T

#SEG bindings
#-----------------------------------------------------------------------------#
#
# 9. Mouse, frame buttons and keyboard bindings
#
#-----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
# First, for the mouse in the root window (Context=R)
# Button 1 gives the Utilities menu
# Button 2 gives the Window Ops menu
# Button 3 gives the WindowList (like TwmWindows)
# I use the AnyModifier (A) option for the modifier field, so you can hold down
# any Shift-Ctrl-whatever combination you want!
# Moreover on a window the same bindings are defined with the Alt modifier
#------------------------------------------------------------------------------

#     Button	Context Modifi 	Function

Mouse 1		R   	A       Menu Empty mouse -1p -1p
Mouse 2		R    	A       Menu Empty mouse -1p -1p
Mouse 3         R       A       WindowList mouse -1p -1p
#Mouse 3         R       C       WindowList mouse -1p -1p OnlyListSkip

#Mouse 1		W   	M       Menu Utilities mouse -1p -1p
#Mouse 2		W    	M       Menu Window mouse -1p -1p
#Mouse 3         W       M       WindowList mouse -1p -1p
#Mouse 3         W       CM      WindowList mouse -1p -1p OnlyListSkip

#G_SESSION 3 bind Shift Mouse * to gnomebutton
#Mouse 1		R	S	GnomeButton
#Mouse 2		R	S	GnomeButton
#Mouse 3		R	S	GnomeButton

#------------------------------------------------------------------------------
# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-Raise-Shade,
# and Resize-or-Raise.
#------------------------------------------------------------------------------

# Button 1 in the corners or sides, with any modifiers, gives resize or raise
Mouse 1		FS	A	Function "Resize-or-Raise-or-Shade"

# Button 1 in the title, sides, w/ any modifiers, gives move or raise or shade
Mouse 1		T	A	Function "Move-or-Raise-or-Shade"
Mouse 1		FS	C	Function "Move-or-Raise-or-Shade"

# Button 1 in an icons gives move for a drag, de-iconify for a double-click,
# raiselower for a single click
Mouse 1		I	A	Function "Move-or-Iconify-or-Raise"
# Alt Button 1 on an icons raise all icons
Mouse 1		I	M	All (CurrentPage Iconic) Raise

# Button 2 in an icon, w/ any modifiers, gives de-iconify
Mouse 2		I	A	Iconify

# Button 2 in the corners, sides, or title-bar gives the window ops menu
Mouse 2		FST	A	Menu Window-Ops2

# Button 3 anywhere in the decoration (except the title-bar buttons)
# does a raise-lower
Mouse 3		TSF	A	RaiseLower

# Button 3 on a icon:
Mouse 3		I	A	Menu Window-Ops3 c+0 -101m

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm
Mouse 3         W       SM       RaiseLower

#-----------------------------------------------------------------------------
# Mouse windows buttons binding
# buttons: 1 3 5 7 9              8 6 4 2
#------------------------------------------------------------------------------

#     Button	Context Modif 	Function
#Mouse 1		1    	A      	Function "window_ops_func"
#Mouse 2         1	A	Menu WindowGroupOps
Mouse 3         1       A       Menu Move-Window
Mouse 1         2       A       Close
Mouse 2		2	A	All ($c) Close
Mouse 3         2       A       Destroy
Mouse 1		4    	A     	Maximize 100 100
Mouse 2         4       A       Maximize 0 100
Mouse 3         4       A       Maximize 100 0
Mouse 1		6    	A     	Iconify
Mouse 2		6    	A     	All ($c) Iconify On
Mouse 3         6       A       All ($c) WindowShade On

#------------------------------------------------------------------------------
# Now some keyboard shortcuts.
#------------------------------------------------------------------------------

#------------------------------------------------------------------------------
# press arrow + Shift anywhere, and scroll by 1 page
#------------------------------------------------------------------------------

#Key Left	A	S	Scroll -100 0
#Key Right	A	S	Scroll +100 +0
#Key Up		A	S	Scroll +0   -100
#Key Down	A	S	Scroll +0   +100

#------------------------------------------------------------------------------
# press arrow + Alt key, and scroll by 1/10 of a page
#------------------------------------------------------------------------------

#Key Left	A	M	Scroll -10 +0
#Key Right	A	M	Scroll +10 +0
#Key Up		A	M	Scroll +0   -10
#Key Down	A	M	Scroll +0   +10

#------------------------------------------------------------------------------
# press arrow + control-meta anywhere, and move the pointer by 1% of a page
#------------------------------------------------------------------------------

#Key Left	A	MC	CursorMove -1 0
#Key Right	A	MC	CursorMove +1 +0
#Key Up		A	MC	CursorMove +0   -1
#Key Down	A	MC	CursorMove +0   +1

#------------------------------------------------------------------------------
# press arrow + Shift-Alt key, and move the pointer by 1/10 of a page
#------------------------------------------------------------------------------

#Key Left	A	SM	CursorMove -10 +0
#Key Right	A	SM	CursorMove +10 +0
#Key Up		A	SM	CursorMove +0   -10
#Key Down	A	SM	CursorMove +0   +10

#------------------------------------------------------------------------------
# Page Up/Page Down keys are used to scroll by one desktop page
# in any context, press page up/down + control + alt
# in root context, just pressing page up/down is OK
#------------------------------------------------------------------------------

#Key Next	A       CM      Desk  -1 0 0 3
#Key Next	R       M       Desk  -1 0 0 3
#Key Prior	A       CM      Desk  +1 0 0 3
#Key Prior	R       M       Desk  +1 0 0 3

#------------------------------------------------------------------------------
# Alt-Shift-Fx window operations
#------------------------------------------------------------------------------
Key F4		A	MS	Close
Key F5		A	MS	RaiseLower
Key F6		A	MS	All (Iconic) Raise  # originally Restore
Key F7		A	MS	Move
Key F8		A	MS	Resize
Key F9		A	MS	Iconify
Key F10		A	MS	Maximize 100 100
#Key F11		A	MS	FvwmIdent
#Key F12		A	MS	FvwmConsole

#------------------------------------------------------------------------------
# The menus via Alt-Shift-Fx
#------------------------------------------------------------------------------
#Key F1		A	MS	Menu Utilities mouse -1p -1p
#Key F2		A	MS	Menu Window mouse -1p -1p
#Key F3		A	MS	WindowList mouse -1p -1p

#------------------------------------------------------------------------------
# The famous Alt-tab binding
#------------------------------------------------------------------------------

DestroyFunc my_dbltab2
AddToFunc   my_dbltab2
+ I WindowListFunc $w
DestroyFunc my_dbltab_prev
AddToFunc   my_dbltab_prev
+ I Prev my_dbltab2

Key Tab A M	WindowList Root c c NoGeometry, NoDeskSort, SelectOnRelease Alt_L my_dbltab_prev
Key Tab	A CM	WindowList Root c c NoGeometry, OnlyListSkip, SelectOnRelease

#------------------------------------------------------------------------------
# Stroke Bindings
#------------------------------------------------------------------------------
#
# You need fvwm compiled with stroke support and libstroke installed
# See the Stroke and StrokeFunc entries in fvwm2 man page
# We use mostly simple stroke motion. For complex stroke motions we need
# to consider many sloppy stroke motions for each action.

#STROKE 2
#Mouse	3	R	N	StrokeFunc FeedBack DrawMotion
#Mouse	3 	W 	M 	StrokeFunc FeedBack DrawMotion

#STROKE 2 We need to redefine the default bindings
#Stroke	0		0 	R 	N 	WindowList mouse -1p -1p
#Stroke	0		0	W	M	WindowList mouse -1p -1p

#PREF 11
#STROKE 2 A | from the top to the bottom
#Stroke	N852		0	R	N	Exec exec xterm
#Stroke	N852		0	W	M       Exec exec xterm

#STROKE 2 A | from the bottom to the top
#Stroke	N258		0	R	N	Exec exec emacs
#Stroke	N258		0	W	M	Exec exec emacs

#STROKE 2 A / from the bottom to the top
#Stroke	N159		0	R	N	Exec exec xfm
#Stroke	N159		0	W	M	Exec exec xfm

#STROKE 2 A C from the top
#Stroke	N9874123	0	R	N	Exec exec xcalc
#Stroke	N9874123	0	W	M	Exec exec xcalc

#STROKE 11 A N (from the bottom)
#Stroke	7415963		0	R	N	Exec exec netscape
#Stroke	74148963	0	R	N	Exec exec netscape
#Stroke	74158963	0	R	N	Exec exec netscape
#Stroke	7418963		0	R	N	Exec exec netscape
#Stroke	415963		0	R	N	Exec exec netscape
#
#Stroke	7415963		0	W	M	Exec exec netscape
#Stroke	74148963	0	W	M	Exec exec netscape
#Stroke	74158963	0	W	M	Exec exec netscape
#Stroke	7418963		0	W	M	Exec exec netscape
#Stroke	415963		0	W	M	Exec exec netscape

#STROKE 4 A clockwise box from the top left
#Stroke	N78963214	0	R	N	FvwmForm FvwmForm-QuitVerify
#Stroke	N789632147	0	R	N	FvwmForm FvwmForm-QuitVerify
#Stroke	N78963214	0	W	M	FvwmForm FvwmForm-QuitVerify
#Stroke	N789632147	0	W	M	FvwmForm FvwmForm-QuitVerify

#SEG menus
#-----------------------------------------------------------------------------#
#
# 10. Now define the menus
#
#-----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
#--------- Taskbar's start menu
#------------------------------------------------------------------------------

DestroyMenu StartMenu
AddToMenu	Empty

#SEG modules
#-----------------------------------------------------------------------------#
#
# 11. Definitions used by the modules
#     (Alphabetic order is used, but the Form are at the end)
#-----------------------------------------------------------------------------#

#------------------------------------------------------------------------------
#------------------ FvwmBacker
#------------------------------------------------------------------------------

#*FvwmBacker: Command(Desk 0, Page * *) -solid Blue
#*FvwmBacker: Command(Desk 1, Page * *) -solid \#7F4B7F
#*FvwmBacker: Command(Desk 2, Page * *) -solid midnightblue
#*FvwmBacker: Command(Desk 3, Page * *) -solid black

#------------------------------------------------------------------------------
#------------------ FvwmBanner
#------------------------------------------------------------------------------
#Style FvwmBanner NoTitle, Sticky, StaysOnTop, WindowListSkip, CirculateSkip
#*FvwmBannerTimeout 2

#------------------------------------------------------------------------------
#------------------ FvwmButtons: BarButtons
#------------------------------------------------------------------------------

Style BarButtons  NoTitle, NoHandles, Sticky, WindowListSkip,\
                   BorderWidth 4, CirculateSkip

DestroyModuleConfig BarButtons: *
*BarButtons: Fore Black
*BarButtons: Back #c3c3c3
*BarButtons: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
# Geometry - really likes to pick its own size, but giving a position is OK
# Warning: I've added a size geometry to avoid pbs if the fvwm_icons are
# not in the image path ! Remove the size in this geometry especially if
# you add buttons
*BarButtons: Geometry 120x445-5-84
# Layout: specify rows or columns, not both
*BarButtons: Columns 2

#LAPTOP 1 Are you a laptop user ?
#*BarButtons: (2x1, Title "xapm", Swallow(Kill) "xapm" "Exec exec xapm -geometry -1500-1500 -p")
# Define the buttons to use.....
#PREF 3
*BarButtons: (1x2, Title FileMgr, Icon Xfm.xpm, Action 'Exec exec xfm')
*BarButtons: (1x2, Title terminal, Icon rterm2.xpm, Action 'Exec exec xterm')
*BarButtons: (1x2, Title editor, Icon lemacs.xpm, Action 'Exec exec emacs')
*BarButtons: (1x2, Title xv,   Icon xv.xpm, Action 'Exec exec xv', \
    Action(Mouse 2) 'Exec exec ee', \
    Action(Mouse 3) 'Exec exec gqview')
*BarButtons: (1x2, Title Gimp,    Icon gimp.xpm,   Action 'Exec exec gimp', \
    Action(Mouse 2) 'Exec exec xpaint', \
    Action(Mouse 3) 'Exec exec kiconedit')
*BarButtons: (1x2, Title gview,   Icon  gv.xpm, Action 'Exec exec ghostview', \
    Action(Mouse 2) 'Exec exec xdvi', \
    Action(Mouse 3) 'Exec exec xpdf')
*BarButtons: (1x2, Title www, Icon nscape.xpm, Action 'Exec exec netscape', \
    Action(Mouse 2) 'Exec exec vppp', \
    Action(Mouse 3) 'Exec exec xterm -geometry 80x30 -e mutt')
*BarButtons: (1x2, Padding 0 0, Container(Padding 0 0, Frame 2, Columns 3))
*BarButtons: (Icon mini.move1.xpm, Action Move)
*BarButtons: (Icon mini.resize3.xpm, Action Resize)
*BarButtons: (Icon mini.iconify1.xpm, Action Iconify)
*BarButtons: (Icon mini.maximize1.xpm, Action Maximize 90 90)
*BarButtons: (Icon mini.shade1.xpm, Action WindowShade)
*BarButtons: (Icon mini.stick1.xpm, Action Stick)
*BarButtons: (Icon mini.cross.xpm, Action Delete)
*BarButtons: (Icon mini.bomb.xpm, Action Destroy)
*BarButtons: (Icon mini.question.xpm, Action Module FvwmIdent)
*BarButtons: (End)
*BarButtons: (1x2, Title "xload", Swallow "xload" "Exec exec nice -16 \
		xload -nolabel -update 4 -bg grey59 -hl grey70 \
		-geometry -1500-1500")
*BarButtons: (1x2, Title "xclock", Swallow "xclock" "Exec \
		exec xclock -padding 0 -geometry -1500-1500")
*BarButtons: (2x2, Swallow "FvwmPagerPager" 'FvwmPager FvwmPagerPager * *')

#------------------------------------------------------------------------------
#------------------ FvwmButtons: MiniButtons
#------------------------------------------------------------------------------

Style "MiniButtons"  NoTitle,NoHandles,Sticky,WindowListSkip,BorderWidth 0,\
	CirculateSkip

DestroyModuleConfig MiniButtons*
*MiniButtons: Fore Black
*MiniButtons: Back #c0c0c0
*MiniButtons: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*MiniButtons: Geometry -2+2
*MiniButtons: Rows 1
*MiniButtons: Padding 1 1
#PREF 3
*MiniButtons: -   mini.term.xpm      Exec exec xterm
*MiniButtons: -   mini.filemgr.xpm   Exec exec xfm
*MiniButtons: -   mini.doc1.xpm	     Exec exec emacs
*MiniButtons: -   mini.calc.xpm      Exec exec xcalc
*MiniButtons: -   mini.cd.xpm        Exec exec xplaycd
*MiniButtons: -   mini.audiovol.xpm  Exec exec xmixer
*MiniButtons: -   mini.happy.xpm     Exec exec xmine
*MiniButtons: -   mini.bomb.xpm      Destroy

#------------------------------------------------------------------------------
#------------------ FvwmButtons: DeskerPanelButtons
#------------------------------------------------------------------------------

Style "DeskerPanelButtons"  NoTitle,NoHandles,Sticky,WindowListSkip,\
			BorderWidth 0, CirculateSkip
#Style "DeskerPanelButtons"  StayOnTop
DestroyModuleConfig DeskerPanelButtons: *
*DeskerPanelButtons: Fore Black
*DeskerPanelButtons: Back grey57
*DeskerPanelButtons: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*DeskerPanelButtons: Geometry 12x79
*DeskerPanelButtons: Rows 1
*DeskerPanelButtons: Frame 1
*DeskerPanelButtons: Padding 0 0
#FAST 1
*DeskerPanelButtons: (Panel(right, steps 12, delay 0, position module top, indicator10) "FvwmDesker" 'Module FvwmPager FvwmDesker 0 3')
#SLOW 1
#*DeskerPanelButtons: (Panel(right, steps 0, position module top, indicator10) "FvwmDesker" 'Module FvwmPager FvwmDesker 0 3')

#------------------------------------------------------------------------------
#------------------ FvwmButtons: WinMakerAppButtons & WinMakerAppPanelCd
#------------------------------------------------------------------------------
Style "WinMakerApp*" NoTitle, NoHandles, BorderWidth 0, Sticky, \
		WindowListSkip, CirculateSkip
DestroyModuleConfig WinMakerAppButtons: *

#-------------------------------------
# Buttons:
# We use "hands panel", the advantage is that we use the applet
# in the panel only when we need it: Button 3 kill the panel

*WinMakerAppButtons: Geometry +0+120
*WinMakerAppButtons: Columns 1
*WinMakerAppButtons: Back #c0c0c0
*WinMakerAppButtons: Fore black
*WinMakerAppButtons: (Frame 1, Size 64 64, \
	Swallow  "wmjmail" 'Exec exec wmjmail', Action(Mouse 1) \
	'MyPanelButtons "WinMakerAppPanelMail" $right $top', \
	Action(Mouse 3) 'All (WinMakerAppPanelMail) Close')
*WinMakerAppButtons: (Frame 1, Size 64 64, \
	Swallow  "wmppp" 'Exec exec wmppp' Action(Mouse 1) \
	'MyPanelButtons "WinMakerAppPanelPPP" $right $top', \
	Action(Mouse 3) 'All (WinMakerAppPanelPPP) Close')
*WinMakerAppButtons: (Frame 1, Size 64 64, \
    Swallow "wmmount" 'Exec exec wmmount -s', Action(Mouse 1) \
    'MyPanelButtons "WinMakerAppPanelCd" $right $top', \
     Action(Mouse 3) 'All (WinMakerAppPanelCd) Close')

#-----------------
# The Mail Panel
*WinMakerAppPanelMail: Rows 1
*WinMakerAppPanelMail: Back #c0c0c0
*WinMakerAppPanelMail: Fore black
*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
    Swallow  "wmCalClock" 'Exec exec  wmCalClock')
*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
    Swallow  "wmglobe" 'Exec exec  wmglobe')
*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
    Swallow  "wmMoonClock" 'Exec exec  wmMoonClock')

#-----------------
# The PPP Panel
*WinMakerAppPanelPPP: Rows 1
*WinMakerAppPanelPPP: Back #c0c0c0
*WinMakerAppPanelPPP: Fore black
*WinMakerAppPanelPPP: (Frame 1, Size 64 64, \
    Swallow  "wminet" 'Exec exec  wminet')
*WinMakerAppPanelPPP: (Frame 1, Size 64 64, \
    Swallow  "wmsysmon" 'Exec exec wmsysmon')

#-----------------
# The Cd Panel
*WinMakerAppPanelCd: Rows 1
*WinMakerAppPanelCd: Back #c0c0c0
*WinMakerAppPanelCd: Fore black
*WinMakerAppPanelCd: (Frame 1, Size 64 64, \
    Swallow  "wmmixer" 'Exec exec  wmmixer -s')
*WinMakerAppPanelCd: (Frame 1, Size 64 64, \
    Swallow  "wmcdplay" 'Exec exec  wmcdplay -s')

#------------------------------------------------------------------------------
#------------------ FvwmEvent
#------------------------------------------------------------------------------

DestroyModuleConfig FvwmEvent: *

# replace rplay by a sound player that can play .au sound file
*FvwmEvent: Cmd "Exec exec rplay "

*FvwmEvent: StartDelay 3
*FvwmEvent: Delay 1

*FvwmEvent: startup          "/usr/share/sounds/gong.au"
*FvwmEvent: add_window       "/usr/share/sounds/wipe.au"
*FvwmEvent: destroy_window   "/usr/share/sounds/pook.au"
*FvwmEvent: iconify          "/usr/share/sounds/clong.au"
*FvwmEvent: deiconify        "/usr/share/sounds/clong.au"
*FvwmEvent: windowshade      "/usr/share/sounds/slide.au"
*FvwmEvent: dewindowshade    "/usr/share/sounds/slide.au"
*FvwmEvent: new_page         "/usr/share/sounds/slide.au"
*FvwmEvent: new_desk         "/usr/share/sounds/slide.au"

#------------------------------------------------------------------------------
#------------------ FvwmGtk for GNOME menus
#------------------------------------------------------------------------------

*FvwmGtk: IconSize 22 22
#G_SM_G 1
#*FvwmGtk: Destroy "gnome-sys"
#G_SM_G 1
#PipeRead "fvwm-menu-desktop --desktop gnome-sys --install-prefix /usr --type gtk --enable-mini-icons"
#G_RHM_G 2
#*FvwmGtk: Destroy "gnome-redhat"
#PipeRead "fvwm-menu-desktop --desktop gnome-redhat --type gtk --enable-mini-icons"
#G_UM_G 2
#*FvwmGtk: Destroy "gnome-user"
#PipeRead "fvwm-menu-desktop --desktop gnome-user --type gtk --enable-mini-icons"

#------------------------------------------------------------------------------
#------------------ IconBox
#------------------------------------------------------------------------------
Style "FvwmIconBox"   NoTitle, NoHandles, Sticky, WindowListSkip, CirculateSkip

DestroyModuleConfig FvwmIconBox: *
*FvwmIconBox: Back #c0c0c0
*FvwmIconBox: Fore  Black
#WIN 1
*FvwmIconBox: IconHiBack Blue4
#FVWM 1
#*FvwmIconBox: IconHiBack SlateBlue
*FvwmIconBox: IconHiFore  white
*FvwmIconBox: Geometry +0-0
*FvwmIconBox: MaxIconSize 48x48
*FvwmIconBox: Font -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBox: SortIcons    IconName
#*FvwmIconBox: SortIcons    ResClass
*FvwmIconBox: Padding 10
*FvwmIconBox: FrameWidth 0 0
*FvwmIconBox: Lines 6
*FvwmIconBox: SBWidth 11
*FvwmIconBox: Placement Left Top
*FvwmIconBox: HideSC Horizontal
*FvwmIconBox: SetWMIconSize
*FvwmIconBox: HilightFocusWin
*FvwmIconBox: Resolution  Desk
*FvwmIconBox: UseSkipList
# mouse bindings
*FvwmIconBox: Mouse 1 Click  DeiconifyFocusAndRaise
*FvwmIconBox: Mouse 1 DoubleClick  DeiconifyFocusAndWarp
*FvwmIconBox: Mouse 2 Click Iconify
*FvwmIconBox: Mouse 3 DoubleClick Iconify off
*FvwmIconBox: Mouse 3 Click Menu Window-Ops3 c+0 -101m
*FvwmIconBox: Mouse 3 DoubleClick FvwmIdent
# Key bindings
*FvwmIconBox: Key r RaiseLower
*FvwmIconBox: Key space Iconify
*FvwmIconBox: Key d Close
# FvwmIconBox built-in functions
*FvwmIconBox: Key n Next
*FvwmIconBox: Key p Prev
*FvwmIconBox: Key h Left
*FvwmIconBox: Key j Down
*FvwmIconBox: Key k Up
*FvwmIconBox: Key l Right
# animation
*FvwmIconBoxNoIconAction SendToModule FvwmAnimate animate

#------------------------------------------------------------------------------
#------------------ IconMan
#------------------------------------------------------------------------------
Style "FvwmIconMan"   NoTitle, NoHandles, Sticky, WindowListSkip, CirculateSkip

DestroyModuleConfig FvwmIconMan: *

# nbr de manager
*FvwmIconMan: *nummanagers 2
#global, desk, or page
#*FvwmIconMan: *Resolution page
*FvwmIconMan: *Resolution global
#*FvwmIconMan: *Resolution desk
*FvwmIconMan: *background  #c0c0c0
*FvwmIconMan: *foreground Black
*FvwmIconMan: *plainbutton up Black #c0c0c0
*FvwmIconMan: *selectbutton down  Black #c0c0c0
#WIN 2
*FvwmIconMan: *focusbutton up white Blue4
*FvwmIconMan: *focusandselectbutton down white Blue4
#FVWM 2
#*FvwmIconMan: *focusbutton up white SlateBlue
#*FvwmIconMan: *focusandselectbutton down white SlateBlue
*FvwmIconMan: *iconbutton down Black grey51
*FvwmIconMan: *font  -adobe-times-bold-r-*-*-12-*-*-*-*-*-*-*-
*FvwmIconMan: *followfocus true
*FvwmIconMan: *usewinlist true
*FvwmIconMan: *sort name
*FvwmIconMan: *drawicons always
*FvwmIconMan: *2*title           "Icon Man"
#PREF 4
*FvwmIconMan: *1*title           " emacs windows"
*FvwmIconMan: *1*iconname        "FvwmIconMan: emacs"
*FvwmIconMan: *1*format          "%i"
*FvwmIconMan: *1*show            resource=*macs
*FvwmIconMan: *2*managergeometry 1x0+0-0
*FvwmIconMan: *1*managergeometry 1x0+260-0
*FvwmIconMan: *1*buttongeometry 200x20
*FvwmIconMan: *2*buttongeometry 250x20
# action
*FvwmIconMan: *action    Mouse    1 N sendcommand DeiconifyFocusAndRaise
*FvwmIconMan: *action    Mouse    2 N sendcommand Iconify
*FvwmIconMan: *action    Mouse    3 N sendcommand "Menu Window-Ops3 c+0 -101m "
*FvwmIconMan: *action    Key    Left N gotobutton Left, select
*FvwmIconMan: *action    Key    Right N gotobutton Right, select
*FvwmIconMan: *action    Key    Up N gotobutton Up, select
*FvwmIconMan: *action    Key    Down N gotobutton Down, select
*FvwmIconMan: *action    Key    q A quit
*FvwmIconMan: *action    Key    i A sendcommand Iconify
*FvwmIconMan: *action    Key    g A sendcommand IconManGlobal
*FvwmIconMan: *action    Key    p A sendcommand IconManPage
*FvwmIconMan: *action    Key    d A sendcommand IconManDesk
# animation
*FvwmIconMan: *NoIconAction "SendToModule FvwmAnimate animate"

#------------------------------------------------------------------------------
#------------------ Identify
#------------------------------------------------------------------------------
Style "FvwmIdent"   Sticky, NoButton 2, NoButton 4, NoButton 6

*FvwmIdent: Back Blue4
*FvwmIdent: Fore Yellow
*FvwmIdent: Font -adobe-times-medium-r-*-*-14-*-*-*-*-*-*-*

#------------------------------------------------------------------------------
#------------------ FvwmPager:  Swallowed by ButtonBar
#------------------------------------------------------------------------------
Style "FvwmPagerPager"   NoTitle, NoHandles, Sticky, WindowListSkip, CirculateSkip

DestroyModuleConfig FvwmPagerPager: *
*FvwmPagerPager: Back grey60
*FvwmPagerPager: Fore black
*FvwmPagerPager: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerPager: Hilight white
*FvwmPagerPager: MiniIcons
*FvwmPagerPager: Balloons
*FvwmPagerPager: BalloonFore black
*FvwmPagerPager: BalloonBack bisque
*FvwmPagerPager: Geometry 319x69+5000+5000
#WIN 1
*FvwmPagerPager: WindowColors white grey51 white Blue4
#FVWM 1
#*FvwmPagerPager: WindowColors white grey51 white SlateBlue
*FvwmPagerPager: Label 0 Fvwm
*FvwmPagerPager: Label 1 Development
*FvwmPagerPager: Label 2 Internet
*FvwmPagerPager: Label 3 Misc
*FvwmPagerPager: SmallFont 5x8

#------------------------------------------------------------------------------
#------------------ FvwmPager: FvwmDesker, the panel of StartPagerButtons
#------------------------------------------------------------------------------
Style "FvwmDesker"   NoTitle, NoHandles, Sticky, WindowListSkip, CirculateSkip

DestroyModuleConfig FvwmDesker: *
*FvwmDesker: Back grey60
*FvwmDesker: Fore black
*FvwmDesker: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmDesker: Hilight white
*FvwmDesker: Geometry 319x69+5000+5000
*FvwmDesker: MiniIcons
*FvwmDesker: Balloons
*FvwmDesker: BalloonFore black
*FvwmDesker: BalloonBack bisque
#WIN 1
*FvwmDesker: WindowColors white grey51 white Blue4
#FVWM 1
*FvwmDesker: Label 0 Fvwm
*FvwmDesker: Label 1 Development
*FvwmDesker: Label 2 Internet
*FvwmDesker: Label 3 Misc
*FvwmDesker: SmallFont 5x8

#------------------------------------------------------------------------------
#------------------ FvwmScript
#------------------------------------------------------------------------------

*FvwmScript: DefaultFont -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmScript: DefaultFore black
*FvwmScript: DefaultBack grey85
*FvwmScript: DefaultHilight grey100
*FvwmScript: DefaultShadow grey55

#------------------------------------------------------------------------------
#------------------ FvwmTaskBar
#------------------------------------------------------------------------------

Style "FvwmTaskBar" NoTitle,Sticky,WindowListSkip,CirculateSkip,NoHandles, \
			TitleAtBottom
# Note: Title at bottom is for shading.

*FvwmTaskBar: Geometry +0-0
*FvwmTaskBar: Fore Black
*FvwmTaskBar: Back #c0c0c0
*FvwmTaskBar: IconFore Black
*FvwmTaskBar: IconBack grey51
*FvwmTaskBar: Font -adobe-times-medium-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBar: SelFont -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBar: StatusFont fixed
*FvwmTaskBar: Action Click1 DeiconifyFocusAndRaise
*FvwmTaskBar: Action Click2 Iconify
*FvwmTaskBar: Action Click3 Menu Window-Ops3 c+0 -101m
*FvwmTaskBar: UseSkipList
*FvwmTaskBar: AutoStick
*FvwmTaskBar: StartName Start
*FvwmTaskBar: StartMenu StartMenu mouse -100p -100m
*FvwmTaskBar: StartIcon mini.penguin.xpm
*FvwmTaskBar: ShowTips
*FvwmTaskBar: ShowTransients
#*FvwmTaskBar: HighlightFocus
*FvwmTaskBar: AutoHide
*FvwmTaskBar: DeskOnly
*FvwmTaskBar: NoIconAction SendToModule FvwmAnimate animate

#------------------------------------------------------------------------------
#------------------ FvwmWharf
#------------------------------------------------------------------------------

Style "FvwmWharf"  NoTitle, NoHandles, Sticky, WindowListSkip,\
                     BorderWidth 2,CirculateSkip

DestroyModuleConfig FvwmWharf: *
*FvwmWharf: Animate
*FvwmWharf: AnimateMain
*FvwmWharf: Geometry -2-50
*FvwmWharf: Columns 1
*FvwmWharf: Bgcolor Grey
#*FvwmWharf: ForceSize
*FvwmWharf: FullPush

*FvwmWharf: TextureType 1
*FvwmWharf: TextureColor WhiteSmoke DarkGrey

*FvwmWharf X           arrows2.xpm      Folder
*FvwmWharf kill        rbomb2.xpm       Close
*FvwmWharf Recycler    Jrecycle.xpm     Restart
*FvwmWharf Exit	       exit.xpm         FvwmForm FvwmForm-QuitVerify
*FvwmWharf xlock       Jlock.xpm        Exec exec xlock -nice 10 -mode random
*FvwmWharf ~Folder
#PREF 3
*FvwmWharf term         rterm2.xpm      Exec exec xterm
*FvwmWharf editor       lemacs.xpm      Exec exec emacs
*FvwmWharf filemgr      Xfm.xpm         Exec exec xfm

*FvwmWharf Y            arrows2.xpm     Folder
*FvwmWharf netscape     nscape.xpm      Exec exec netscape
*FvwmWharf xview        xv.xpm          Exec exec xv
*FvwmWharf gimp         gimp.xpm        Exec exec gimp
*FvwmWharf GV           gv.xpm          Exec exec ghostview
*FvwmWharf ~Folder

*FvwmWharf xclock nil  MaxSwallow "xclock" xclock -padding 0 -bg white
*FvwmWharf xload nil  MaxSwallow "xload" \
		xload -nolabel -update 5  -bg grey51 -geometry -1500-1500
*FvwmWharf pager nil MaxSwallowModule "FvwmPagerPager" FvwmPager FvwmPagerPager * *

#------------------------------------------------------------------------------
#------------------ FvwmWinList
#------------------------------------------------------------------------------
Style "FvwmWinList" NoTitle,Sticky,WindowListSkip,CirculateSkip

DestroyModuleConfig FvwmWinList: *
*FvwmWinList: Back #c3c3c3
*FvwmWinList: Fore Black
#WIN 1
*FvwmWinList: FocusBack Blue4
#FVWM 1
#*FvwmWinList: FocusBack SlateBlue
*FvwmWinList: FocusFore white
*FvwmWinList: IconBack grey51
*FvwmWinList: IconFore Black
*FvwmWinList: Font -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmWinList: Action Click1 DeiconifyFocusAndRaise
*FvwmWinList: Action Click2 Iconify
*FvwmWinList: Action Click3 Menu Window-Ops3 c+0 -101m
*FvwmWinList: UseSkipList
*FvwmWinList: ShowCurrentDesk
*FvwmWinList: MinWidth 180
*FvwmWinList: MaxWidth 250
*FvwmWinList: Geometry +0-0
*FvwmWinList: NoIconAction SendToModule FvwmAnimate animate

#SEG END
#-----------------------------------------------------------------------------#
#
# THAT'S ALL FOLKS!!
#
#-----------------------------------------------------------------------------#
#
#                         -- Sample-95 MINI-FAQ --
#
#
# * Why doesn't this FAQ contain my question?
# * What are the default bindings?
# * Some (mini-)icons are missing in menus and in some buttons!
# * Does Sample-95 support themes?
# * Can I use Sample-95 with GNOME?
# * How can I load saved settings before starting FVWM?
# * Can I use WindowMaker and AfterStep applets with FVWM?
# * Who wrote this configuration file?
#
# ----------------------------------------------------------------------------
#
# * Why doesn't this FAQ contain my question?
#
# Maybe because the answer is in the beginning of the configuration file
# (i.e., this file!), in the FVWM FAQ or in the FVWM man pages.
#
#                  ----------------------------------------
#
# * What are the default bindings?
#
# Mouse bindings:
# --------------
#
# Mouse 1 on the root window:	 main menu
# Mouse 2 on the root window:	 window operations menu
# Mouse 3 on the root window:	 Window List of all normal applications
# Ctrl-Mouse 3 on the root window: Window List of all skipped applications
#
# Alt-Mouse x inside a window: as Mouse x on the root window
# Shift-Alt-Mouse 3 inside a window: Raise or Lower

# If you have built the config for gnome-session:
# Shift-Mouse x on the root window gives the corresponding "GNOME button"

# Mouse 1 on the title: Raise, Move for a drag, shade for a double click
# Mouse 1 on the borders: Raise, Resize for a drag, shade for a double click
# Mouse 1 on an icon: Move, Raise on one click, deiconify for a double
# Alt-Mouse 1 on an icon; Raise all the icons
# Ctrl-Mouse 1 on the borders: As mouse 1 on the title
# Mouse 2 on the title or the borders: window operations menu
# Mouse 2 on an icon: deiconify
# Mouse 3 on the title/borders: Raise or Lower
# Mouse 3 on an icon: The "modules/icons" window operations menu
#
# Window Buttons:
# --------------
#
# - Left button:
# Mouse 1: Window operation menu, double click: close
# Mouse 2: Group operations menu
# Mouse 3: Quick Move window menu
# - Close button (right button)
# Mouse 1: Close
# Mouse 2: Close all the windows with the same class
# Mouse 3: Destroy
# - Maximize button (2nd right button)
# Mouse 1: Full Maximize
# Mouse 2: Maximize Horizontally
# Mouse 3: Maximize Vertically
# - Iconify button (3rd right button)
# Mouse 1: Iconify
# Mouse 2: Iconify all the windows with the same class
# Mouse 3: Shade all the windows with the same class
#
# Key bindings (anywhere):
# ------------
#
# Shift-Left/Right/Up/Down: scroll Left/Right/Up/Down by 1 page
# Alt-Left/Right/Up/Down: scroll Left/Right/Up/Down by 1/10 page
#
# Shift-Ctrl-Left/Right/Up/Down: move the pointer by 1O% of a page
# Alt-Ctrl-Left/Right/Up/Down: move the pointer by 1% of a page
#
# Alt-Ctrl-PageUp/PageDown: scroll by one desktop page
#
# Shift-Alt-F1: Main menu
# Shift-Alt-F2: Window operations menu
# Shift-Alt-F3: WindowList
# Shift-Alt-F4: Close
# Shift-Alt-F5: RaiseLower
# Shift-Alt-F6: Raise all Icons
# Shift-Alt-F7: Move
# Shift-Alt-F8: Resize
# Shift-Alt-F9: Iconify
# Shift-Alt-F10: Maximize
# Shift-Alt-F11: Identify
# Shift-Alt-F12: Console
#
# Alt-Tab released at once: previous (normal) window
# Alt-Tab: WindowList of all normal windows and warp to the selected window
#	   when released
#
# Ctrl-Alt-Tab: WindowList of all skipped windows
#
# Stroke bindings:
# ---------------
#
# You need to have FVWM compiled with stroke support (these bindings
# are defined only in this case) and libstroke installed.
# Mouse button 3 is used (this button must be pressed during the stroke),
# no modifiers are needed when you start your mouse motion on the root
# window and you must use the Alt modifier if you start your mouse motion
# on a window (you cannot start your motion on a window title bar or frame).
# The mouses motion:
#
# A | from the top to the bottom: your preferred terminal
# A | from the bottom to the top: your prefered editor
# A / from the bottom to the top: your prefered file manager
# A C from the top: xcalc
# A N (from the bottom): netscape
# A clockwise box from the top left: FvwmForm-QuitVerify
#
# Add more yourself!
#
#                  ----------------------------------------
#
# * Some (mini-)icons are missing in menus and in buttons!
#
# If you have no mini(-icons) then either your ImagePath does not contain
# the directory of the fvwm_icons or you are using a RedHat/Mandrake/... rpm
# version of fvwm-icons which uses mini- in the place of mini. for
# mini-icons name. If only some mini(-icons) are missing, then you are using
# a too old version of fvwm_icons.
#
#                  ----------------------------------------
#
# * Does Sample-95 support themes?
#
# No. But, it is possible to hack the configuration to have an "elementary"
# themes engine. The basic idea is to use FvwmTheme to propagate the colors
# and to replace "Read decorations" by "Read theme" in .fvwm2rc where theme
# is a symbolic link to a theme. A theme will be a file which look like
# decorations plus the FvwmTheme configuration commands. Other technical
# functions are needed as a function for switching between themes. This is
# left to your own pleasure! Doing elaborated FVWM configurations is one of
# the better games under UNIX.
#
# If you want a powerful themes engine do not use Sample-95, it is not the
# aim of this configuration. There are a powerful themes engine which is
# under fast development: fvwm-themes (http://fvwm-themes.sourceforge.net/).
#
#
#                  ----------------------------------------
#
# * Can I use Sample-95 with GNOME?
#
# Yes. You "need" FVWM compiled with GNOME support and it is preferable to
# run FVWM under gnome-session. Also, do not forget that you have to set
# FVWM_USERDIR, so start the gnome-session as
#	env FVWM_USERDIR="your FVWM_USERDIR" gnome-session
# Of course, it is preferable to set the "build a file for gnome-session"
# option of the Setup95 script. You may use the option "Try a Stays Put panel"
# to put the panel in the same layer than the normal windows, but you may
# have to leave GNOME/FVWM and start again X to avoid problems.
# Note that under session, Sample-95 does not load your "X settings" by
# default (GNOME has its own method). Moreover, read the next question for
# using a different setting when you use GNOME (you may also use the
# Session(Init/Restart)Function functionality, see the startup file).
# One thing that you can add to your configuration file is:
#	GnomeShowDesk x
# where x is the number of desks you want to see in the GNOME pager at
# start (if not the GNOME pager is dynamic).
# Also, for leaving GNOME you must use GNOME or you must "QuitSession" for
# just exiting or "Exec exec save-session --kill" for saving and exiting.
#
#                  ----------------------------------------
#
# * How can I load saved settings before starting FVWM?
#
# Say, you want to use setting 1 under a normal FVWM session, setting 2
# under a gnome-session and setting 3 under a normal FVWM session but the
# shell test FOO is true. Then, your .xinitrc/.xsession file can look
# as follows (where $1 is the "first" argument given by startx, or by kdm or
# gdm ...).
#
# ...
# case $1 in
#   fvwm)
#	F="your FVWM_USERDIR"
#	if FOO; Then $X="3"; else $X=1; fi;
#	for i in $F/.FvwmAnimate $F/.FvwmForm $F/.fvwm-layers \
#	~/.xinitrc-fvwm $F/.FvwmBaseConfig \ $F/.start-Background \
#	$F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons \
#	$F/.start-MiniButtons $F/.start-WinMakerAppButtons \
#	$F/.start-FvwmAnimate $F/.start-FvwmAuto $F/.start-FvwmBanner \
#	$F/.start-FvwmEvent; \
#	 	do /bin/cp $i-$X $i;
#	done;
#	fvwm2
#   ;;
#   gnome)
#	F="your FVWM_USERDIR"
#	for i in $F/.FvwmAnimate $F/.FvwmForm $F/.fvwm-layers \
#	~/.xinitrc-fvwm $F/.FvwmBaseConfig \ $F/.start-Background \
#	$F/.start-apps-man $F/.start-FvwmButtons $F/.start-DeskerPanelButtons \
#	$F/.start-MiniButtons $F/.start-WinMakerAppButtons \
#	$F/.start-FvwmAnimate $F/.start-FvwmAuto $F/.start-FvwmBanner \
#	$F/.start-FvwmEvent; \
#		do /bin/cp $i-2 $i;
#	done;
#	env FVWM_USERDIR="your FVWM_USERDIR" gnome-session
#    ;;
#    ... other cases ...
# esac
#
#               ----------------------------------------
#
# * Can I use WindowMaker and AfterStep applets with FVWM?
#
# Yes most WM and AS applets are FVWM compliant. Moreover, sample-95 provides
# a FvwmButtons for you called WinMakerAppButtons. Of course, you have to
# edit the configuration of this buttons to put your preferred applets. Note
# that you have an applets panel under the 3 first applets. These panels are
# special: Mouse 1 (on the background of the applet) start the panel (or only
# map it if it is already started) if it is not out. If the panel is out,
# Mouse 1 unmaps it (but the panel applets are alive). The special thing is
# that Mouse 3 *kills* the panel: this can save your cpu.
#
#                  ----------------------------------------
#
# * Who wrote this configuration file?
#
# The starting point is "the" fvwm95 configuration file. Then, Dominik
# did some work on it and in particular so that it worked fine with
# fvwm-2.3.x.  Later, olicha spent a lot of time with it, wrote the Setup95
# Script and rewrote all the "Settings" stuff. Some ideas came from
# fvwm-themes (thanks to the fvww-themes workers, and in particular migo).
# Probably, some others fvwm-workers have added improvement but did not take
# the time to update this answer.

---

From: parv <[email-masked]>
Date: Fri, 19 Dec 2003 21:55:38 -0500

in message <[email-masked]>,
wrote Christoph Litauer thusly...
>
> I am no expert in configuring fvwm but have a little problem where
> I need some help.  Attached is my fvwm2rc Konfiguration. As you
> can see I use

86kB of text?  Who has the time to read the epic?

  - Parv

-- 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 20 Dec 2003 03:34:16 +0000

> This sounds to me like a FocusFollowsMouse policy ... but I didn't 

MouseFocus does not raise or lower windows on the mouse motion, it deals
with focus, not auto raising. FvwmAuto module does auto raising/lowering.

> Any help is appreciated.

Seems like this site uses a javascript that opens a new window and raises
or lowers it. Consider to turn off the javascript completely in the
browser, or just its ability to raise/lower (and create?) windows.

Can you post this problematic url to verify its javascript code?

Regards,
Mikhael.