Subject: FVWM: shaded swriter

From: Toshi Isogai <[email-masked]>
Date: Thu, 13 Nov 2003 10:34:57 -0700

When I invoke open office 1.1 swriter, it opens as shaded. I don't
specify shaded window anywhere in config files. I don't even have shaded
command in my menus. I have to issue "windowshade false" from
FvwmConsole to open it up. It only happens on swriter but not other
programs in open office or anything else.

Does anybody have any idea?

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 784-7674  direct
      (303) 790-8499  main
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 13 Nov 2003 15:22:16 -0500

> Does anybody have any idea?

Just a guess...do you have session management enabled?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Toshi Isogai <[email-masked]>
Date: Thu, 13 Nov 2003 14:06:55 -0700

I tried with and without session management enabled.
It doesn't make any difference.

On Thu, 13 Nov 2003 15:22:16 -0500
Dan Espen <[email-masked]> wrote:

|> Toshi Isogai <[email-masked]> writes:
|> > When I invoke open office 1.1 swriter, it opens as shaded. I don't
|> > specify shaded window anywhere in config files. I don't even have shaded
|> > command in my menus. I have to issue "windowshade false" from
|> > FvwmConsole to open it up. It only happens on swriter but not other
|> > programs in open office or anything else.
|> > 
|> > Does anybody have any idea?
|> 
|> Just a guess...do you have session management enabled?
|> 
|> -- 
|> Dan Espen                           E-mail: [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Nov 2003 10:20:24 +0100

> Does anybody have any idea?

Try

  Style OpenOffice* GNOMEIgnoreHints
  Style OpenOffice* EWMHIgnoreStackingOrderHints
  Style OpenOffice* EWMHIgnoreStateHints
  Style OpenOffice* EWMHIgnoreStrutHints
  Style OpenOffice* NoPPosition
  Style OpenOffice* NoUsposition 
  Style OpenOffice* FixedPPosition

(probably a subset will do).

Ciao

Dominik ^_^  ^_^

---

From: Toshi Isogai <[email-masked]>
Date: Fri, 14 Nov 2003 08:59:12 -0700

Thanks, Dominik!
'Style OpenOffice* EWMHIgnoreStateHints' did it. 

What file does open office get these EWMH hints?
I looked at some documents in http://www.freedesktop.org/ site,
but I can't find anything like user's manual type material.

On Fri, 14 Nov 2003 10:20:24 +0100
Dominik Vogt <[email-masked]> wrote:

|> On Thu, Nov 13, 2003 at 10:34:57AM -0700, Toshi Isogai wrote:
|> > When I invoke open office 1.1 swriter, it opens as shaded. I don't
|> > specify shaded window anywhere in config files. I don't even have shaded
|> > command in my menus. I have to issue "windowshade false" from
|> > FvwmConsole to open it up. It only happens on swriter but not other
|> > programs in open office or anything else.
|> > 
|> > Does anybody have any idea?
|> 
|> Try
|> 
|>   Style OpenOffice* GNOMEIgnoreHints
|>   Style OpenOffice* EWMHIgnoreStackingOrderHints
|>   Style OpenOffice* EWMHIgnoreStateHints
|>   Style OpenOffice* EWMHIgnoreStrutHints
|>   Style OpenOffice* NoPPosition
|>   Style OpenOffice* NoUsposition 
|>   Style OpenOffice* FixedPPosition
|> 
|> (probably a subset will do).
|> 
|> Ciao
|> 
|> Dominik ^_^  ^_^
|> --
|> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
|> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
|> message to [email-masked].
|> To report problems, send mail to [email-masked].

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 14 Nov 2003 17:05:55 +0100

> but I can't find anything like user's manual type material.

It's probably hard coded into the open office libraries.

Ciao

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Nov 2003 12:16:15 -0500

> It's probably hard coded into the open office libraries.

I'm running 1.1 and it is not doing that.

To see if it is somewhere in your configuration, you could rename
$HOME/OpenOffice.org1.1.0
and start swriter again.

I think it will go thru setup, but you should find out if it is something
in your settings or in OpenOffice.