Subject: FVWM: Copy and paste problems - fvwm 2.5.X

From: paul harris <[email-masked]>
Date: Wed, 12 Nov 2003 23:50:19 -0600

Hello,

Hello,
I have an issue that my middle mouse button does not paste properly when 
using any of the 2.5.x series of fvwm.  I can paste using the middle 
mouse button from xterm to xterm but not from other programs i have 
found,  e.g. from mozilla to xterm.  I can also copy and paste for apps 
that have pull down menus, e.g. from mozilla to a gnome-terminal or open 
office. Everything worked great in fvwm 2.4.x  Is there a way to fix this? 

Here are my mouse bindings.
Thanks,
Paul

#button bindings
Mouse 1   R     A      Menu RootMenu Nop
Mouse 2   R       A     
Mouse 3   R       A      Menu Window-Ops Nop

#Buttons for menu bar - pbh
Mouse 0 1 A Menu Window-Ops2 Close
Mouse 0 3 A Close
Mouse 1 4 A Maximize 0 100
Mouse 2 4 A Maximize 100 100
Mouse 0 2 A Maximize 100 100
Mouse 0 4 A Iconify

#  for other parts of the window/borders/icons:
Mouse 1   F   A   Resize-or-Raise
Mouse 1   TS   A   Move-or-Raise
Mouse 1   I   A   Move-or-Iconify
Mouse 2   I   A   Iconify
Mouse 2   FST   A   Menu Window-Ops2 Nop
Mouse 3   TSIF   A   RaiseLower

######  strokes ####################################################
######  Pattern  Mouse  na na  Action
#                Button 
#Straight line,  852 goes down,  258 goes up
Stroke   852        2     A   N   Exec exec xterm -fg white -bg black &
Stroke   258        2     A   N   Exec exec gnome-system-monitor &
Stroke   1478963       2     A   N   Popup "Apps"
Stroke   456        2     A   N   Exec exec xmms &
Stroke   7415369       2     A   N   Move

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 13 Nov 2003 10:50:55 +0100

> office. Everything worked great in fvwm 2.4.x  Is there a way to fix this? 

I think this is a problem with mozilla (1.4 here).  I can confirm
the problem, but evidence suggests that it is indeed mozilla which
sometimes does not copy the selected text to the clipboard.  It
always works if I select Edit->Copy from mozilla's menu (or press
Ctrl-C).  Furthermore, when it fails to work, pasting always
inserts the previous selection, so I know that pasting does work.
I don't see how fvwm could prevent mozilla from copying the
selected text to the clipboard.

Ciao

Dominik ^_^  ^_^

---

From: paul harris <[email-masked]>
Date: Thu, 13 Nov 2003 21:14:25 -0600

Hello,
Thanks for the reply Dominik.
Unfortunatey it is not just mozilla  I can not use the middle mouse 
button to paste to Gvim, glade, open office,  gnome-terminal etc.  I am 
hoping it is a setting I am using.  I did try unbind strokes to see if 
that was the issue but the behavior was the same.

Here is the version information:
[pbharris@bugs ~]fvwm -version
fvwm 2.5.8 compiled on Nov  9 2003 at 02:04:45
with support for: ReadLine, Stroke, XPM, PNG, Shape, XShm, SM, Xinerama, 
XRender, XFT, NLS
 
fvwm comes with NO WARRANTY, to the extent permitted by law. You may
redistribute copies of fvwm under the terms of the GNU General Public 
License.
For more information about these matters, see the file named COPYING.
[pbharris@bugs ~]

Paul

---

From: paul harris <[email-masked]>
Date: Fri, 14 Nov 2003 00:15:05 -0600

Hello,
I figured it out - when I have strokes defined then the pasting 
operation does not work properly - having e.g this will break it:

I can live without strokes - but they are nice.

Cheers!
Paul

paul harris wrote:

> button to paste to Gvim, glade, open office,  gnome-terminal etc.  I 
> am hoping it is a setting I am using.  I did try unbind strokes to see 
> if that was the issue but the behavior was the same.
>
>
> with support for: ReadLine, Stroke, XPM, PNG, Shape, XShm, SM, 
> Xinerama, XRender, XFT, NLS
>
>>> I have an issue that my middle mouse button does not paste properly 
>>> when using any of the 2.5.x series of fvwm.  I can paste using the 
>>> middle mouse button from xterm to xterm but not from other programs 
>>> i have found,  e.g. from mozilla to xterm.  I can also copy and 
>>> paste for apps that have pull down menus, e.g. from mozilla to a 
>>> gnome-terminal or open office. Everything worked great in fvwm 
>>> 2.4.x  Is there a way to fix this?   
>>
>>

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 14 Nov 2003 14:02:59 +0000

> I can live without strokes - but they are nice.

With this binding you ask explicitely for your mouse 2 to stop to work in
applications. Do not configure it "A"nywhere.

Here is a better example (a small piece from fvwm-themes):

  # mouse 3 with no modifier on the root window
  Mouse   3       R       A       StrokeFunc FeedBack DrawMotion StrokeWidth 2

  # mouse 3 with Alt on a window
  Mouse   3       WD      M       StrokeFunc FeedBack DrawMotion StrokeWidth 2

  # A | from the top to the bottom
  Stroke  N852    0       R       A       FuncFvwmTerminal
  Stroke  N852    0       WD      M       FuncFvwmTerminal

  # A | from the bottom to the top
  Stroke  N258    0       R       A       FuncFvwmEditor
  Stroke  N258    0       WD      M       FuncFvwmEditor

Regards,
Mikhael.