Subject: Bug also in FvwmTabsv2.4 [ Re: FVWM: FvwmTabs v2.3]

From: Tobias <[email-masked]>
Date: Thu, 6 Nov 2003 14:48:20 +0100

Hi Scott

same bug occurs on newest fvwmtabs.

Greets
Tobias

On Mon, 20 Oct 2003 20:04:27 +0200
Tobias <[email-masked]> wrote:

> Hi Scott
> 
> I found a Bug in the current 2.3 version. In
> old v2.1 its working normaly.
> 
> I use multiple desktops and open the TabManager
> in one desktop. After switching between Desktops
> i cannot get the focus back to the Tabmanager and
> only can get it back by pushing mouse button on the
> background (or moving the TabManager by shortcuts).
> 
> In v2.1 focus is automatically regained after
> entering Desktop with the tabmanager in it.
> 
> 
> 
> Greets
> Tobias
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: scott <[email-masked]>
Date: Sun, 9 Nov 2003 11:38:59 +1100

Hi Tobias,

> > background (or moving the TabManager by shortcuts).

I can't reproduce this bug - what system are you using?
Does FvwmTabs output anything on stdout/stderr?

SCoTT. :)

---

From: Tobias <[email-masked]>
Date: Wed, 12 Nov 2003 00:39:55 +0100

Hi Scott

Sorry for not answering the last week but was on holyday :-)

On Sun, 9 Nov 2003 11:38:59 +1100

> Does FvwmTabs output anything on stdout/stderr?

My .FVWM-errors does only show:
Use of uninitialized value in string eq at /usr/lib/perl5/site_perl/5.8.0/X11/Auth.pm line 97.
Argument "XCMiscGetVersion" isn't numeric in int at /usr/lib/perl5/site_perl/5.8.0/X11/Protocol.pm line 2028.
FvwmTabs: Couldn't create D&D icon from /usr/share/icons/mini/mini-happy.xpmFvwmTabs: Reading state from /tmp/.fvwmtabs.state
Module FvwmTabs started with X11::Protocol version 0.51_2.
-------

I am using gentoo with x11-wm/fvwm-2.5.7-r3 package. 

My config does use multible desktops with only one window
"DeskTopSize 1x1"
and do switch between them with 
"
Key 1 A M GotoDesk 0 0
Key 2 A M GotoDesk 0 1
Key 3 A M GotoDesk 0 2
" bindings. By using these the fvwmtabs does not (only seldom?!)
regain focus.
Its working with aterms without using fvwmtabs. Or with old v2.1 .

I have put my .fvwm dir to download at 
http://www.ownz.de/medlor-fvwm.tar.gz . Perhaps this does help you.

Greets 
Tobias

---

From: Tobias <[email-masked]>
Date: Wed, 12 Nov 2003 00:49:06 +0100

Hi 

Just got this additional errors:

Module FvwmTabs started with X11::Protocol version 0.51_2.
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 133
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 241
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 242
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 264
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 265
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 267
 Opcode (42, 0) = SetInputFocus
FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 687
 Opcode (42, 0) = SetInputFocus
 Bad resource 33554435 (0x2000003)
FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 692
 Opcode (42, 0) = SetInputFocus
 Bad resource 35651587 (0x2200003)
FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 697
 Opcode (42, 0) = SetInputFocus
 Bad resource 39845891 (0x2600003)
FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 702
 Opcode (42, 0) = SetInputFocus
 Bad resource 41943043 (0x2800003)
FvwmTabs: Protocol error: bad 8 (Match); Sequence Number 1993
 Opcode (42, 0) = SetInputFocus

But i can not reproduce these errors.

Greets
Tobias

On Wed, 12 Nov 2003 00:39:55 +0100

---

From: scott <[email-masked]>
Date: Sat, 15 Nov 2003 12:14:24 +1100

Hi Tobias,

: > > > After switching between Desktops
: > > > i cannot get the focus back to the Tabmanager and
: > > > only can get it back by pushing mouse button on the
: > > > background (or moving the TabManager by shortcuts).
: > 
: > I can't reproduce this bug - what system are you using?
: > Does FvwmTabs output anything on stdout/stderr?
:
: <snip>
:
: I have put my .fvwm dir to download at 
: http://www.ownz.de/medlor-fvwm.tar.gz . Perhaps this does help you.

Nice bg piccie! :)

Well I'm using your exact FVWM configuration on my system & I can't
reproduce this bug. (focusing works fine after switching desktops.)

I'm using:
Redhat Linux 7.3
fvwm 2.5.9 (from cvs) compiled on Nov 11 2003
FvwmTabs v2.5
Module FvwmTabs started with: X11::Protocol 0.52, Tk 800.024.

SCoTTie. :)
-- 
[email-masked]

---

From: Tobias <[email-masked]>
Date: Sat, 15 Nov 2003 11:24:41 +0100

HI Scott 

On Sat, 15 Nov 2003 12:14:24 +1100

> Module FvwmTabs started with: X11::Protocol 0.52, Tk 800.024.

Really ? uhm then i should upgrade all packages (X11-Prot,tk,..).

Many Thanks for testing.

Greets
Tobias

---

From: Tobias <[email-masked]>
Date: Thu, 27 Nov 2003 01:34:37 +0100

Hello Scott

Finaly i got time to briefly look into the code.
I found the error at takeFocus():
----------
<...>
    else
    {
        $winId = $tabWin{$tId}{tab}[$tabWin{$tId}{currentTab}]{winId};
    }
    # "revert-to" (2nd) arg can be 'Parent', 'PointerRoot' or 'None'.
    $xServer->SetInputFocus($winId, 'Parent', $tabWin{$tId}{focusTimestamp}); 
    # $fvwm->debug("takeFocus(end) winId=$winId");
<...>
----------

Changing the SetInputFocus() to 
"$xServer->SetInputFocus($winId, 'Parent', 'CurrentTime');"
its all working flawless.

The variables in $tabWin{$tId}{focusTimestamp} does look ok though, but
i dont have any knowledge about the X11-Protocol. Perhaps you know
what could be wrong.

Hopefully i could help you finding the bug.

Greets
Tobias