Subject: FVWM: 4 Desks, 1x2 DeskTops each -- how can I switch by keys

From: Lukas Ruf <[email-masked]>
Date: Tue, 25 Nov 2003 18:34:35 +0100

Dear all,

my fvwm configuration is as described above:
- 4 Desks, organized 1x4
- 2 DeskTops per Desk, organized 1x2

I managed to configure

Key   Up    A M Scroll +0 -100
Key   Down  A M Scroll +0 +100

such that I can press <alt-up> or <alt-down> to switch between the
DeskTops.

However, is there any way that I can configure a key-binding to switch
between the desks?

If possible, I would like to have <alt-Up> to switch the Desk one
Desk upwards if I am already on the upper Desktop, Otherwise, I would
be more than fine if I could bind <alt-PgDown> to switch the Desks
downwards, respectively <alt-PgUp> the other way round...

Gruss,
Lukas
-- 
Lukas Ruf           | Wanna know anything about raw |
<http://www.lpr.ch> | IP? -> <http://www.rawip.org> |
eMail Style Guide: <http://www.rawip.org/style.html>|
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 25 Nov 2003 23:02:38 +0000

> - 2 DeskTops per Desk, organized 1x2

What you call "DeskTop" we call "page" or "virtual page".

> downwards, respectively <alt-PgUp> the other way round...

Key Next  A M GotoDesk +1 0 3
Key Prior A M GotoDesk -1 0 3

Regards,
Mikhael.

---

From: Lukas Ruf <[email-masked]>
Date: Wed, 26 Nov 2003 15:54:45 +0100

Mikhael,

thanks for the response!

> Mikhael Goikhman <[email-masked]> [2003-11-26 00:03]:
>

ok!  Got that!

> Key Prior A M GotoDesk -1 0 3

It works as expected.

wbr,
Lukas