Subject: FVWM: redefined FullScreen-function does not work anymore with 2.5.8

From: Klaus Umbach <[email-masked]>
Date: Mon, 3 Nov 2003 23:02:41 +0100

Hello list,

DestroyFunc FullScreen
AddToFunc FullScreen
+ I ThisWindow (Maximized) Style $n Borders
+ I CondCase (NoMatch) Style $n !Borders
+ I CondCase (NoMatch) Raise
+ I CondCase (NoMatch) UpdateStyles
+ I Maximize

This is what worked with 2.5.7, to have fullscreen-windows without
borders. With 2.5.8 I still have the borders. 

How can I get rid of the borders in fullscreen?

regards
	Klaus

--
5) People say Linux is ugly. How does that make you feel?
Torvalds: They'll be the first against the wall when the revolution comes.
	  Let's see just how ugly they think it is when they have a few
	  bulletholes in them.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 4 Nov 2003 01:15:12 +0000

> How can I get rid of the borders in fullscreen?

See NEWS file, some new commands were renamed. Here is the 2.5.8 way
(taken from fvwm-themes 0.7.0):

DestroyFunc FuncFvwmMaximizeFullScreen
AddToFunc   FuncFvwmMaximizeFullScreen
+ I ThisWindow (Maximized) WindowStyle Title, Borders
+ I TestRc (!Match) WindowStyle !Title, !Borders
+ I TestRc (!Match) Raise
+ I TestRc (!Match) UpdateStyles
+ I Maximize ewmhiwa

Regards,
Mikhael.