Subject: FVWM: FvwmTabs v2.4 : restart fvwm destroy all tabbed windows

From: xavier <[email-masked]>
Date: Mon, 10 Nov 2003 22:54:13 -0500

Hello,

i'm using the standard fvwmtabrc
(and a custom .fvwm2rc),
with fvwm 2.5.8 and fvwmtabs 2.4

when i restart fvwm (calling the Restart function)
fvwmtabs dies and does not give me back the xterms 
it had ! i can still view the process by doing
a ps aux, but they are not listed in my windowlist.

i have no clues how to grab them back.

FvwmTabs restarts fine (i can open a new tabber without starting the module)

here are the messages : (>comments)

>starting X

 Use of uninitialized value in string eq at /usr/share/perl5/X11/Auth.pm line 97.
 Argument "XCMiscGetVersion" isn't numeric in int at /usr/share/perl5/X11/Protocol.pm line 2028.
 FvwmTabs: Couldn't create D&D icon from /usr/share/icons/mini/mini-happy.xpmModule FvwmTabs started with X11::Protocol version 0.51_2.

>end of init

 _cdim: --- not moved 0x08149af0 'FvwmTabs [0]'

>captured 2 xterms

>restarting :

 FvwmTabs: Saving state to /tmp/.fvwmtabs.state
 FvwmTabs: Got ON_EXIT event.
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 314
  Opcode (2, 0) = ChangeWindowAttributes
  Bad resource 6291491 (0x600023)
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 315
  Opcode (7, 0) = ReparentWindow
  Bad resource 12582928 (0xc00010)
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 316
  Opcode (12, 0) = ConfigureWindow
  Bad resource 12582928 (0xc00010)
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 317
  Opcode (8, 0) = MapWindow
  Bad resource 12582928 (0xc00010)
 destroy (1):
  0 0x8895f1c   RV f=00080003 {}(1)(1)
 SV = RV(0x88914b4) at 0x8895f1c
   REFCNT = 1
   FLAGS = (ROK)
   RV = 0x863355c
 Usage $widget->destroy(...) at /usr/lib/fvwm/2.5.8/FvwmTabs line 921.
 TkFocusKeyEvent found dispPtr->focusPtr out of sync:
 expected ??, got .fvwmTabs
 Use of uninitialized value in string eq at /usr/share/perl5/X11/Auth.pm line 97.
 Argument "XCMiscGetVersion" isn't numeric in int at /usr/share/perl5/X11/Protocol.pm line 2028.
 FvwmTabs: Couldn't create D&D icon from /usr/share/icons/mini/mini-happy.xpmFvwmTabs: Reading state from /tmp/.fvwmtabs.state
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 8
  Opcode (20, 0) = GetProperty
  Bad resource 4194320 (0x400010)
 FvwmTabs: Window doesn't exist.
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 9
  Opcode (20, 0) = GetProperty
  Bad resource 12582928 (0xc00010)
 FvwmTabs: Window doesn't exist.
 Module FvwmTabs started with X11::Protocol version 0.51_2.

what did i do wrong ? 

what's wrong with my setup ?

thanks

-- 
xavier
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: xavier <[email-masked]>
Date: Mon, 10 Nov 2003 22:57:28 -0500

another exemple, same manipulations :

#created a tabber
 _cdim: --- not moved 0x0814d548 'FvwmTabs [1]'

# restart
 FvwmTabs: Saving state to /tmp/.fvwmtabs.state
 FvwmTabs: Got ON_EXIT event.
 Tk::Toplevel=HASH(0x8815b0c) is not a Tk Window at /usr/lib/perl5/Tk/Submethods.pm line 37.
 Use of uninitialized value in string eq at /usr/share/perl5/X11/Auth.pm line 97.
 Argument "XCMiscGetVersion" isn't numeric in int at /usr/share/perl5/X11/Protocol.pm line 2028.
 FvwmTabs: Couldn't create D&D icon from /usr/share/icons/mini/mini-happy.xpmFvwmTabs: Reading state from /tmp/.fvwmtabs.state
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 11
  Opcode (20, 0) = GetProperty
  Bad resource 23068688 (0x1600010)
 FvwmTabs: Window doesn't exist.
 FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 12
  Opcode (20, 0) = GetProperty
  Bad resource 25165840 (0x1800010)
 FvwmTabs: Window doesn't exist.
 Module FvwmTabs started with X11::Protocol version 0.51_2.

thanks

---

From: Scott Smedley <[email-masked]>
Date: Tue, 11 Nov 2003 15:45:29 +1100

Hi Xavier, :)

: >starting X
: 
:  Use of uninitialized value in string eq at /usr/share/perl5/X11/Auth.pm line 97.
:  Argument "XCMiscGetVersion" isn't numeric in int at /usr/share/perl5/X11/Protocol.pm line 2028.
:  FvwmTabs: Couldn't create D&D icon from /usr/share/icons/mini/mini-happy.xpmModule FvwmTabs started with X11::Protocol version 0.51_2.

These errors are ok.

:  _cdim: --- not moved 0x08149af0 'FvwmTabs [0]'

This is some rogue debug statement in FVWM - I don't know what it means.

:  FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 314
:   Opcode (2, 0) = ChangeWindowAttributes
:   Bad resource 6291491 (0x600023)
:  FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 315
:   Opcode (7, 0) = ReparentWindow
:   Bad resource 12582928 (0xc00010)
:  FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 316
:   Opcode (12, 0) = ConfigureWindow
:   Bad resource 12582928 (0xc00010)
:  FvwmTabs: Protocol error: bad 3 (Window); Sequence Number 317
:   Opcode (8, 0) = MapWindow
:   Bad resource 12582928 (0xc00010)

These errors are ok too. It just means that some windows that were in
the tab-manager aren't around anymore. The problem is why those
windows disappeared on a simple restart.

:  destroy (1):
:   0 0x8895f1c   RV f=00080003 {}(1)(1)
:  SV = RV(0x88914b4) at 0x8895f1c
:    REFCNT = 1
:    FLAGS = (ROK)
:    RV = 0x863355c
:  Usage $widget->destroy(...) at /usr/lib/fvwm/2.5.8/FvwmTabs line 921.

Mmmm, yeah. This is the killer. What OS are you using? I just noticed I
get this problem on RH9 but everything is fine on my RH7.3 system.

: what did i do wrong ? 

Looks like a good old-fashioned BUG - I will look into it soon.

SCoTTie. :)

---

From: xavier <[email-masked]>
Date: Tue, 11 Nov 2003 12:01:13 -0500

on Restart,

fvwmtabs restart fvwmtabs tabbers,
asking me to place them...

i found myself with a "move" cursor, and i have to click
to place the tabber where i  want.

is it the normal behavior ?

thanks

---

From: xavier <[email-masked]>
Date: Tue, 11 Nov 2003 13:49:27 -0500

On Tue, Nov 11, 2003 at 03:45:29PM +1100, Scott Smedley wrote:

|Mmmm, yeah. This is the killer. What OS are you using? I just noticed I
|get this problem on RH9 but everything is fine on my RH7.3 system.
|

oops, forgot to tell about it.

i'm using debian testing/unstable

ii  libc6                     2.3.2-7        GNU C Library: Shared libraries an
ii  libglib1.2                1.2.10-9       The GLib library of C routines
ii  libgtk1.2                 1.2.10-16      The GIMP Toolkit set of widgets fo
ii  libncurses5               5.3.20030719-1 Shared libraries for terminal hand
ii  libreadline4              4.3-5          GNU readline and history libraries
ii  perl                      5.8.1-4        Larry Wall's Practical Extraction
ii  xlibs                     4.2.1-11       X Window System client libraries

ii  fvwm                    2.5.8-0.20031109 F(?) Virtual Window Manager
ii  libx11-protocol-perl    0.51.2-1         x11 protocol interface for perl
ii  perl-tk                 1:800.024-1.1    Perl module providing the Tk graph

ii  tk8.0          8.0.5-10       The Tk toolkit for TCL and X11 v8.0 - Run-Ti
ii  tk8.3          8.3.5-4        Tk toolkit for Tcl and X11, v8.3 - run-time 

|: what did i do wrong ? 
|
|Looks like a good old-fashioned BUG - I will look into it soon.
|
|SCoTTie. :)
|--
|Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
|To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
|message to [email-masked].
|To report problems, send mail to [email-masked].
|

---

From: xavier <[email-masked]>
Date: Tue, 11 Nov 2003 14:13:10 -0500

Is there a kick fix i could use to release all windows on all tabbers
before fvwmtabs die ?

thanks

---

From: Scott Smedley <[email-masked]>
Date: Wed, 12 Nov 2003 09:47:17 +1100

Hi Xavier,

> to place the tabber where i  want.

This is a symptom of the same bug you reported yesterday.

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 11 Nov 2003 22:53:18 +0000

> ii  fvwm                    2.5.8-0.20031109 F(?) Virtual Window Manager

If you make it downloadable, then how about using release=xaview-2 or
similar? Because I would expect 2.5.9 (cvs) at this date.

> ii  libx11-protocol-perl    0.51.2-1         x11 protocol interface for perl

This package name looks bad to me. A better name would be
perl-x11-protocol (or even more correct, perl-X11-Protocol).

But then I also don't see a good reason for calling FvwmTabs fvwmtabs.

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Wed, 12 Nov 2003 09:52:51 +1100

Hi Xavier,

> |Looks like a good old-fashioned BUG - I will look into it soon.

I tracked this down to a bug in FVWM perllib last night. I sent a
patch to Mikhael, hopefully it will get applied soon.

> Is there a kick fix i could use to release all windows on all tabbers

The 'ReleaseAll' menu-item (or associated key-binding, Ctrl-Alt-Shift-R
I think).

Alternatively you can apply the patch I sent to the fvwm-workers list
yourself.

SCoTT. :)