Subject: FVWM: Auto-starting apps at fvwm startup

From: stu <[email-masked]>
Date: Thu, 27 Nov 2003 13:22:32 +0200

I am trying to configure my fvwm (2.5.8) to automatically start certain
apps when I start X and fvwm (using the startx command). With the setup
I've listed below, only the first app (sylpheed) starts, and once it's
started it refuses to respond to any mouse clicks. None of the other
apps start. Does anyone know where I've gone wrong?

I start fvwm from .xinitrc using startx. The relevant line is :

exec fvwm &>fvwm.out 2>&1

The relevant lines from .fvwm2rc are :

# 1 desktop with 16 pages
DeskTopSize 4x4

# New config to auto-start apps
DestroyFunc InitFunction
AddToFunc InitFunction
 + I Function ExecSylpheed
 + I Function ExecKonsole
 + I Function ExecGkrellm
 + I Function ExecXmms

AddToFunc ExecOnPage            I GotoPage $1 $2
+                               I Exec exec $0
+                               I Wait $0

AddToFunc ExecSylpheed          I ExecOnPage "sylpheed-claws" 0 1

AddToFunc ExecKonsole           I ExecOnPage "konsole" 2 0
+                               I ExecOnPage "konsole" 3 0

AddToFunc ExecGkrellm           I ExecOnPage "gkrellm" 1 1

AddToFunc ExecXmms              I ExecOnPage "xmms" 1 1

Thanks!
-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
A member of South Africa's largest retail software vendor, the UCS Group

Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za

"I am the Unconquerable Spirit."
               -- Poet Unknown
   
Powered by Debian GNU/Linux - testing/unstable
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Nov 2003 12:34:18 +0100

> apps start. Does anyone know where I've gone wrong?

Fvwm is hanging in the "Wait" command.  Since you say only the
first app starts correctly, it must be the "konsole" that does
not start properly.  Using "Wait" is always a dangerous thing.
If you just want to start the apps on a different page you can
also try to set their position via X resources or the command line,
e.g.

  xterm -g +<displaywidth>+0

to place an xterm in the top left corner of page 1 0.  This way,
you can do without the "Wait".  Also, if you want *all* instances
of the program appear on the same page, try

  Style sylpheed-claws StartsOnPage 0 1, SkipMapping

(SkipMapping tells fvwm not to switch to that page when the window
appears).

> AddToFunc ExecXmms              I ExecOnPage "xmms" 1 1

Ciao

Dominik ^_^  ^_^