Subject: FVWM: Re: FVWM: mandrake - missing icons

From: Kostal <[email-masked]>
Date: Fri, 24 Oct 2003 22:44:57 +0200 (CEST)

Well, it is not that. I made damn sure the ImagePath was correct. I also tried to write the image file names with full path name to avoid any problem in the image path - same results.
thanks
Jan

> On Fri, 2003-10-24 at 09:08, Kostal wrote:
> > Hi!
> > I have recently installed fvwm2 on Mandrake 9.1 but I can't see any icons (in the menu and in window decorations). I made double sure that XPM support is on - during ./configure - it does not report any errors. However, after running startx, I get a full page or messages as "can't read /xxx/yyy/fvwm2icons/abc.xpm". I also made sure the xpm files are readable for everyone.
> > 
> > I also am running RedHat9.0 on the same machine, with identical .fvwm2rc file, and there everything is ok. However, on RedHat I installed fvwm2 from a rpm file, while on Mandrake I compiled it from source.
> > 
> > Any ideas?
> > Thank you.
> > 
> > Jan Kostal
> 
> 
> Does the ImagePath reflect where the icons actually are on your Mandrake
> system?  It sounds to me that your ImagePath is not set up correctly.
> 
> 
> 

____________________________________________________________
Nemáš komu říct, že jsi fakt dobrej?  Oskarova nabídka pro studenty - až
600 SMSek a 4 hodiny volání zdarma. Volej Kolej! http://ad2.seznam.cz/redir.cgi?instance=62375%26url=http://www.oskarmobil.cz/services/whatsnew.php#volej
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Oct 2003 16:57:38 -0400

Kostal <[email-masked]> writes:
> Well, it is not that. I made **** sure the ImagePath was correct. I > also tried to write the image file names with full path name to avoid > any problem in the image path - same results.
> thanks
> Jan
> 
> > > I have recently installed fvwm2 on Mandrake 9.1 but I can't see any > icons (in the menu and in window decorations). I made double sure that > XPM support is on - during ./configure - it does not report any errors. > However, after running startx, I get a full page or messages as "can't > read /xxx/yyy/fvwm2icons/abc.xpm". I also made sure the xpm files are > readable for everyone.
> > > 
> > > I also am running RedHat9.0 on the same machine, with identical > .fvwm2rc file, and there everything is ok. However, on RedHat I > installed fvwm2 from a rpm file, while on Mandrake I compiled it from > source.
> > > 
> > > Any ideas?
> > > Thank you.
> > > 
> > > Jan Kostal
> > 
> > 
> > Does the ImagePath reflect where the icons actually are on your > Mandrake

Make sure the files in question really are xpm files.

Do:

file xxx.xpm

you should see:

home> file ~/icons/mini.fvwm.xpm
/home/dane/icons/mini.fvwm.xpm: X pixmap image text

PS: Looks like someones mailer is whacked (equal signs),
and replies aren't being inserted in the "right" place.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Kostal <[email-masked]>
Date: Fri, 24 Oct 2003 23:47:57 +0200 (CEST)

> > Hi!
> > I have recently installed fvwm2 on Mandrake 9.1 but I can't see any
> > icons (in the menu and in window decorations). I made double sure that
> > XPM support is on - during ./configure - it does not report any errors.
> > However, after running startx, I get a full page or messages as "can't
> > read /xxx/yyy/fvwm2icons/abc.xpm". I also made sure the xpm files are
> > readable for everyone.
> > 
> > I also am running RedHat9.0 on the same machine, with identical
> > .fvwm2rc file, and there everything is ok. However, on RedHat I
> > installed fvwm2 from a rpm file, while on Mandrake I compiled it from
> > source.
> >
> > Any ideas?
> > Thank you.
> > 
> > Jan Kostal
> >
> >
> > > Does the ImagePath reflect where the icons actually are on your =
> > Mandrake
> > Well, it is not that. I made **** sure the ImagePath was correct. I
> > also tried to write the image file names with full path name to avoid
> > any problem in the image path - same results.
> > thanks
> > Jan
> > 
>
>
>
>
>

It is on my home computer so I will test that as soon as I am at home, however, those files are installed from the standard package fvwm-icons. Do you still think they may not be real xpm files?
Jan Kostal

____________________________________________________________
Mall [mo:l] - promenáda, široká alej, nákupní středisko (velké) 
Internet Mall - profesionální nákupní galerie na Internetu (http://www.mall.cz)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 24 Oct 2003 17:56:40 -0400

Kostal <[email-masked]> writes:
> > > icons (in the menu and in window decorations). I made double sure > that
> > > XPM support is on - during ./configure - it does not report any > errors.
> > > However, after running startx, I get a full page or messages as > "can't
> > > read /xxx/yyy/fvwm2icons/abc.xpm". I also made sure the xpm files > are
> > > readable for everyone.
> > > 
> > > installed fvwm2 from a rpm file, while on Mandrake I compiled it > from
> > > source.
> > >
> > > Any ideas?
> > > Thank you.
> > > 
> > > Jan Kostal
> > >
> > >
> > > > Does the ImagePath reflect where the icons actually are on your > =
> > > Mandrake
> > > > system?  It sounds to me that your ImagePath is not set up > correctly.
> > >
> > >
> > >
> > 
> > > also tried to write the image file names with full path name to > avoid
> It is on my home computer so I will test that as soon as I am at home, > however, those files are installed from the standard package > fvwm-icons. Do you still think they may not be real xpm files?

No, the fvwm-icons package should be all xpm files.

abc.xpm is not the name of an fvwm icon.
Post the exact text of the error message you get.
Also do:

fvwm -V

(this will show whether fvwm has xpm support)

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 24 Oct 2003 22:14:51 +0000

On 24 Oct 2003 23:47:57 +0200, Kostal wrote:
> It is on my home computer so I will test that as soon as I am at home,
> however, those files are installed from the standard package
> fvwm-icons. Do you still think they may not be real xpm files?

If these are XPM files, then you didn't compiled XPM support in.

Run fvwm-config --info, or try to load these images using fvwm-root.

Regards,
Mikhael.

---

From: Jan Kostal <[email-masked]>
Date: Sat, 25 Oct 2003 11:39:24 -0700 (PDT)

> Run fvwm-config --info, or try to load these images using fvwm-root.

I see ....... You are right:

When I run
	$ fvwm-config --info
I get
	Package: fvwm
	Version: 2.4.16

	Instalation options:
        	prefix: /usr/local
        	exec-prefix: /usr/local
        	bindir: /usr/local/bin
        	datadir: /usr/local/share
        	libexecdir: /usr/local/libexec
        	sysconfdir: /usr/local/etc
        	mandir: /usr/local/man

	Compiled-in paths:
        	Module directory: /usr/local/libexec/fvwm/2.4.16
        	Data directory: /usr/local/share/fvwm
        	Default ImagePath: /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
        	Default UserDir: $HOME/.fvwm

	Support for features:
        	gnome-hints (window manager hints): yes
        	gtk (FvwmGtk): no
        	gdk-imlib (in FvwmGtk): no
        	gnome-libs (in FvwmGtk): no
        	multibyte: no
        	readline: no
        	rplay: no
        	shape (shaped windows): yes
        	sm (session management): yes
        	stroke: no
        	xinerama: yes
        	xpm: no
.....................
But during installation it looked all fine:
in-the-fvwm.src-directory:
# ./configure > aaa
# cat aaa | grep -i xpm
checking for XpmReadFileToXpmImage in -lXpm... yes
checking X11/xpm.h usability... yes
checking X11/xpm.h presence... yes
checking for X11/xpm.h... yes
checking for Xpm 3.4g or better... yes
  With XPM support?                  yes
.........................
What went wrong? Any ideas now?
Thanks a lot!
Jan
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 Oct 2003 19:59:37 +0000

> I see ....... You are right:

You didn't say that you didn't define your own prefix and configure says:

  Executables: /usr/local/bin

You also didn't convince us you did "make install" after that.
Or maybe you did, but it failed without write permissions to /usr/local.

The only sure thing is the /usr/local/bin/fvwm executable on your system
is not that you built with the "XPM support? yes" output above.

Regards,
Mikhael.

---

From: Jan Kostal <[email-masked]>
Date: Sun, 26 Oct 2003 21:44:45 -0800 (PST)

> is not that you built with the "XPM support? yes" output above.
Mikhael, thak you a lot! You solved my problem:
I configured and compiled fvwm more than a month ago. By that time I did not pay
attention to the output of ./configure and probably it was without the xpm
support. My system changed since then, I installed many things and it seems,
also the xpm libraries, but I did not remember that (I am a Linux beginner so
sometimes I do strange things).
Recently that I finally decided to fix the fvwm icons problem, I re-run the
./configure to find out that I had the xpm support libraries, but I did not
re-run make install.
Now I cleaned and reinstalled all fvwm and all is fine, I have my icons!
I good lesson for me!
thank you
Jan
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].