Subject: FVWM: Built in mouse bindings that can not be omitted

From: Marcin Głogowski <[email-masked]>
Date: Thu, 16 Oct 2003 00:57:23 +0200

Hi,
I have asked a man that know FVWM very good why when I click on a menu 
topic with middle mouse button the menu is opened as single window.
He said that this is because built in FVWM functions and there is only 
one way to change that - I must modify the FVWM source code - is it right?
Regards.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 15 Oct 2003 20:58:18 -0400

> one way to change that - I must modify the FVWM source code - is it right?

Yes, that's right.

If the middle button is tearing off the menu, you must be
using a 2.5.x beta release.

Remove the logic around line 4659 in fvwm/menus.c to disable
tear off menus on button 2.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Oct 2003 09:12:47 +0200

> tear off menus on button 2.

However, the issue is not decided yet.  This particular binding
will probably be removed before the next stable release.

Ciao

Dominik ^_^  ^_^