Subject: Re: FVWM: solaris 9 and fvwm misbehavior

From: Steve Goldman <[email-masked]>
Date: Mon, 20 Oct 2003 09:33:44 -0400

[email-masked] said:
> 
> With fvwm 2.4.x I see the following strange behavior:
> 
>   1: fvwm pager eventually disappears. It core dumps with following
>      traceback:
> 
>   [1] XTextWidth(0x780018, 0x37bf8, 0x6, 0x7efefeff, 0x81010100, 0xff00), at 0xff231e00 
>   [2] DrawGrid(desk = 2, erase = 1), line 1510 in "x_pager.c"
>   [3] list_new_desk(body = 0x7), line 944 in "FvwmPager.c"
>   [4] process_message(packet = 0x36958), line 510 in "FvwmPager.c"
>   [5] My_XNextEvent(dpy = (nil), event = 0xffbffb40), line 1366 in "FvwmPager.c"
>   [6] Loop(fd = 0x36400), line 459 in "FvwmPager.c"
>   [7] main(argc = 225280, argv = 0xa), line 436 in "FvwmPager.c"
> 
>   2: Usually once the pager disappears a window used for confirmation with exmh (the
>      What Now? window) which is set for StaysOnTop suddenly decides that Top is Bottom
>      and always send the window to the back.
> 
>   3: I finally noticed that windows never seem to disappear from the Window-List. By
>      now I have a whole lot of windows in the window list! I've wondered if this might
>      somehow be the cause of symptom #1.

Since posting this I've done some more experiments. There had been some suggestion
that the problems noted above were due to problems in the Solaris X server. I could
buy that but I did some more experiments. I went back and I rebuilt 2.0.46 which I
had been running with no problems on Solaris 8 and switched to it. All of the problems
mentioned above have gone away and I've seen no bad behavior. So while it doesn't
exonerate the Solaris 9 X server it must surely be some clues. My next thought
was that maybe this was triggered by some different configuration issue. Unfortunately
the configuration between 2.0.46 and 2.4.x is so drastically different that a
simple comparison doesn't seem productive. However I thought that maybe with the
knowledge that 2.0.46 works properly and the symptoms above (especially #3) that
maybe someone could give me a pointer as to what I could look and while trying
to debug it since I'd like to use 2.4.x if I could.

--
Steve
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 20 Oct 2003 10:34:30 -0400

> to debug it since I'd like to use 2.4.x if I could.

I don't have 2.0.46 handy, but I do have 1.24r.
In that version there is no call to XTextWidth.

If you want to debug this, create a test program with a call to
XTextWidth.  Use the logic in FvwmPager as a guide.
If you can get a test program to fail, you might have a chance
of convincing Sun there X server is broken or you might uncover
something in Fvwm.

-- 
Dan Espen                           E-mail: [email-masked]