Subject: FVWM: FVWM Resizing my Window!

From: Jake Colman <[email-masked]>
Date: Mon, 13 Oct 2003 15:08:40 -0400

I am developing an application using Qt and one of my windows insists on
resizing itself smaller than what it should be.  If I use Qt's adjustSize()
method I can see the window being painted at its larger size and then it gets
resized smaller.  At first I thought I had a bug with Qt but then I started
thinking it might be fvwm.  Sure enough, under CDE I do not have this
problem.  

Why would fvwm be sending a resize even to my window?  What can I do about
it?

fvwm 2.5.7 compiled on Jun 16 2003 at 09:03:26
with support for: ReadLine, XPM, Shape, XShm, SM, NLS

Thanks!

-- 
Jake Colman                     

Principia Partners LLC                    Phone: (201) 209-2467
Harborside Financial Center                 Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                 www.principiapartners.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 13 Oct 2003 15:28:00 -0400

> with support for: ReadLine, XPM, Shape, XShm, SM, NLS

I don't have any experience with Qt apps, but in the past Fvwm has
had problems because it pays attention to the program's size hints.

Try running:

xwininfo -size

click on the window with the problem.
Post the results.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Jake Colman <[email-masked]>
Date: Mon, 13 Oct 2003 16:50:05 -0400

>>>>> "DE" == Dan Espen <[email-masked]> writes:

   DE> I don't have any experience with Qt apps, but in the past Fvwm has
   DE> had problems because it pays attention to the program's size hints.

   DE> Try running:

   DE> xwininfo -size

   DE> click on the window with the problem.
   DE> Post the results.

xwininfo: Window id: 0x6800801 "USD AAA Credit Default Curve"

  Normal window size hints:
      User supplied size: 944 by 623
      Program supplied size: 944 by 623
      Program supplied minimum size: 458 by 277
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

FWIW the size I'm expecting is 944 x 623 (the User supplied size) and the
size I am getting (as given by "Identify" from the window's system menu)
shows 458 x 623.

Does this tell you anything?

-- 
Jake Colman

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Oct 2003 01:52:22 +0300

> Does this tell you anything?

It is hard to say without running the application.

You may experiment with these style options:

  FixedUSSize / VariableUSSize
  FixedPSize / VariablePSize
  FixedSize / VariableSize

For example:

  Style "USD AAA *" FixedUSSize

Regards,
Mikhael.

---

From: Jake Colman <[email-masked]>
Date: Tue, 14 Oct 2003 09:33:23 -0400

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

   MG> It is hard to say without running the application.

   MG> You may experiment with these style options:

   MG>   FixedUSSize / VariableUSSize
   MG>   FixedPSize / VariablePSize
   MG>   FixedSize / VariableSize

   MG> For example:

   MG>   Style "USD AAA *" FixedUSSize

This can be, I am afraid, a generic problem with any of my windows.  How do I
specify this style for all windows?  Based on what xwininfo is showing, why
won't fvwm simply honor the user specified size that I've asked for?

-- 
Jake Colman

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Oct 2003 15:52:43 +0200

On Tue, Oct 14, 2003 at 09:33:23AM -0400, Jake Colman wrote:
> specify this style for all windows?

  Style * ...

But you do not want to do this for all windows.  Use FvwmIdent to
find out a better pattern for all windows of this application.

> Based on what xwininfo is showing, why

That's hard to say without analysing the situation.  The
application does something that causes fvwm to limit the window
size.  It may request that size on its own, request a maximum
window size smaller than the minimum size, or ask for a size
increment step width/height that is so big that fvwm rounds down
to the minimum window size.  Do you get any warnings from fvwm on
the X console related to this problem?

Ciao

Dominik ^_^  ^_^

---

From: Jake Colman <[email-masked]>
Date: Tue, 14 Oct 2003 10:20:36 -0400

>>>>> "DV" == Dominik Vogt <[email-masked]> writes:

   DV>   Style * ...

   DV> But you do not want to do this for all windows.  Use FvwmIdent to
   DV> find out a better pattern for all windows of this application.

   >> won't fvwm simply honor the user specified size that I've asked for?

   DV> That's hard to say without analysing the situation.  The
   DV> application does something that causes fvwm to limit the window
   DV> size.  It may request that size on its own, request a maximum
   DV> window size smaller than the minimum size, or ask for a size
   DV> increment step width/height that is so big that fvwm rounds down
   DV> to the minimum window size.  Do you get any warnings from fvwm on
   DV> the X console related to this problem?

How do I "analyze the situation"?  The size I am asking for is larger than
the size I am getting, and it is a size that should fit without a problem.  I
am not getting any warnings on the console.  I am examining events that
arrive at my window (from a Qt perspective) and something is clearly sending
me a resize event - after I have specified the size I am looking for.

What can I do to help debug why this is happening?

-- 
Jake Colman

---

From: Jake Colman <[email-masked]>
Date: Tue, 14 Oct 2003 09:40:48 -0400

>>>>> "Jake" == Jake Colman <[email-masked]> writes:

   Jake> This can be, I am afraid, a generic problem with any of my windows.
   Jake> How do I specify this style for all windows?  Based on what xwininfo
   Jake> is showing, why won't fvwm simply honor the user specified size that
   Jake> I've asked for?

I apologize for following up on my own posting but...

Using fvwm 2.2.2 I do NOT have this problem.

Attached in my old .fvwm2rc file.  Maybe there is something in this file that
needs to be done in an equivalent way for newer versions of fvwm?

-- 
Jake Colman