Subject: FVWM: How can I add a Windows like "Star Here" button to my Fvwm2?

From: "Brian W.Kernighan" <[email-masked]>
Date: Sat, 18 Oct 2003 12:37:53 +0800

How can I add a Windows like "Star Here" button to my Fvwm2?

Now I have a root menu,  and I want to bind it to a button("Start Button"),
 so When I click on it ,  the Root Menu will display on the screen , 
just as all
Windows  "Start Here" button do.(It may use fvwmbutton, I guess.)

Is there anybody can help?  Thanks in advance!

AddToMenu "Utilities"
+                       "Root"  Title
+                       "&1 Rxvt"       Exec rxvt -bg White -fg Black 
-ls -name "Term" -fn 
-Misc-Fixed-Medium-R-Normal--20-200-75-75-C-100-ISO8859-1
+                       "&2 Gterm" exec   gnome-terminal
+                       "&3 Mozilla" exec   mozilla
+                       "&4 Gimp " exec   gimp
+                       "&7 Xffm " exec   xffm
+                       "&8 Screenshot" exec   gnome-panel-screenshot
+                       "&9 Xterm" exec   xterm -fn 9x15
+                       "&0 Xeyes" exec   xeyes
+                       "Programme &p"  Popup Applications
+                       ""              Nop
+                       "&r Restart"    Restart fvwm2
+                       "&k Kill fvwm2" Quit

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tobias <[email-masked]>
Date: Sat, 18 Oct 2003 11:01:12 +0200

Hi Brian

i dont speak .pl but i found this fvwm-config, which 
does mimic the Win-XP very well.
There is also a Start-Button.

http://student.uci.agh.edu.pl/~artursc/
http://student.uci.agh.edu.pl/~artursc/fvwm/xp.tar.gz

Layout:
http://student.uci.agh.edu.pl/~artursc/fvwm/xp_small.png

PS.: I am new to fvwm and cannot help u directly.

Greets
Tobias

On Sat, 18 Oct 2003 12:37:53 +0800

---

From: Tenebrae <[email-masked]>
Date: Sun, 19 Oct 2003 07:02:08 -0700 (PDT)

> Is there anybody can help?  Thanks in advance!

I started off with fvwm95 and kept some of the features over the years
when I upgraded.  One of these was the little-used Start button...except I
renamed mine "Slut" um...because I could.
There's a screenshot and a copy of my rc file on the fvwm.org web site, if
you're interested.
I think the part you're missing is this:

*FvwmTaskBarStartName Slut
*FvwmTaskBarStartMenu Slut

Or, well...you get the idea. I hope.
								-Tenebrae.
---
The sending of any unsolicited email advertising messages to this domain
may result in the imposition of civil liability against you in accordance
with Cal. Bus. & Prof. Code Section 17538.45.

---

From: Catherine Luedecker <[email-masked]>
Date: Sun, 19 Oct 2003 09:45:43 -0700

Does anyone know what language this site is in?  I dont recognize it.

Thanks

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 Oct 2003 21:25:31 +0300

> Is there anybody can help?  Thanks in advance!

You may use either FvwmButtons or FvwmTaskBar modules, the second has the
Start button support built in, see the man pages.

Here is the line that gives you the good menu position in 2.5.x
for the task bar configured at the bottom:

  *FvwmTaskBar: StartCommand Popup FvwmMenuRoot rectangle $widthx$height+$left+$top -5p -100m

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 Oct 2003 21:28:48 +0300

> http://student.uci.agh.edu.pl/~artursc/

.pl stays for Poland.

Regards,
Mikhael.