Subject: Re: FVWM: Icons

From: Robert Huff <[email-masked]>
Date: Sat, 11 Oct 2003 23:02:32 -0400

This sounds like a good place to jump in.
	I'm upgrading from fvwm 1.24 and I've figured most of how to
make 2.5.x behave like the old installation.
	One bit I do not understand: the old version put an entry in
the iconbox whether the window was iconified or not.  One click
iconified the window; the following click brought it back at the
same position within the current pager space.
	I'd like to ge that behavior back.

				Robert Huff

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 12 Oct 2003 08:54:42 -0400

> 	I'd like to ge that behavior back.

If I understand your question, you are using FvwmIconBox and
its the part about bringing the
window back on the current page that is missing.

I don't have an answer, I'm just trying to clarify what you want.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Robert Huff <[email-masked]>
Date: Sun, 12 Oct 2003 11:04:10 -0400

>  I don't have an answer, I'm just trying to clarify what you want.

	Let me rephrase:
	In v1 it was possible to move a window cleanly from one page to
another by iconifying it (clicking the entry in the iconbox), moving
to the target page, and deiconifying.  This was also useful in
momentarily reducing screen clutter so that one could, for example,
find and dismiss a transient. 
	I'm not wedded to a specific implementation, but would really
like that functionality (or something close to it) back.

				Robert Huff

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 12 Oct 2003 18:24:52 +0300

> like that functionality (or something close to it) back.

This was answered several times on the mailing list.

Suppose this snippet from fvwm-themes:

  *FvwmIconBox: Mouse 1  Click       FuncFvwmDeiconifyFocusAndRaise
  *FvwmIconBox: Mouse 1  DoubleClick FuncFvwmDeiconifyFocusAndWarp
  *FvwmIconBox: Mouse 2  Click       Iconify
  *FvwmIconBox: Mouse 2  DoubleClick Iconify

  DestroyFunc FuncFvwmDeiconifyFocusAndRaise
  AddToFunc   FuncFvwmDeiconifyFocusAndRaise
  + I Iconify off
  + I Focus
  + I Raise

  DestroyFunc FuncFvwmDeiconifyFocusAndWarp
  AddToFunc   FuncFvwmDeiconifyFocusAndWarp
  + I Iconify off
  + I Focus
  + I WarpToWindow 10p 10p

If you for some reason want the window to be deiconified on the current
page then add "+ I MoveToPage" at the beggining of these functions.

You may also use:

  Style * StickyIcon

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sun, 12 Oct 2003 11:27:44 -0400

> like that functionality (or something close to it) back.

I think you are looking for:

Style * StickyIcon