Subject: Re: FVWM: newbie .fvwmrc question

From: Dan Espen <[email-masked]>
Date: Mon, 20 Oct 2003 13:45:18 -0400

Wendell Turner <[email-masked]> writes:
> > > Anyway, I would like to have several Desks each with a 2x2 
> > > Desktop (I think I have the terminology right), similar to
> > > what is at the top of the www.fvwm.org web page.  I've 
> > > searched the faq and mail archives, but am not sure what I was 
> > > supposed to be looking for, hence this mail.
> > > 
> > > Versions of stuff:
> > > 
> > > fvwm-2.4.15-1
> > > fvwm-themes-0.6.2-1
> > > fvwm2-2.2.4-9
> > > fvwm2-icons-2.2.4-9
> > > Red Hat Linux release 7.1 (Seawolf)
> > 
> > You are using either fvwm 2.4.15 OR fvwm 2.2.4.
> > You can't be using both.
> > 
> > Fvwm 2.4.x reads $HOME/.fvwm/.fvwm2rc
> > Fvwm 2.2.x reads $HOME/.fvwm2rc
> 
> Ok, I have
> 
>   FVWM version 2.4.15 compiled on Feb 20 2003 at 13:08:43
>   with support for: ReadLine, Stroke, XPM, GNOME WM hints,
>   Shape, SM, Xinerama
> 
> 
> and a file named ~/.fvwm/.fvwm2rc that contains
> 
>   Module FvwmPager 0 3
> 
>   DeskTopSize 2 2
> 
>   *FvwmPager: Label 0 Main
>   *FvwmPager: Label 1 Web & Mail
>   *FvwmPager: Label 2 Devel
>   *FvwmPager: Label 3 Games
> 
> But still only have the 3x3 Desker/Desktop that is labelled
> 'Main'.
> 
> Also, when I use the mouse to choose Theme Management --> Current
> --> modules -> Choose Pager --> Desker apparently FVWM restarts,
> but nothing is different (except that the window close/open
> animation seems to occur three times).
> 
> Again, Any hints?

Respond to [email-masked], not to me.

The stuff above will create a race condition between the
pager starting and the rest of the config being read.

Start the pager with:

AddToFunc StartFunction I Module FvwmPager

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 Oct 2003 21:30:43 +0300

> > animation seems to occur three times).

You apparently start fvwm-themes-start, not fvwm.
Your ~/.fvwm/.fvwm2rc is ignored in this case.

Either start fvwm or use the fvwm-themes rules to define the personal
adjustments as described in its FAQ.

If you decide to continue with fvwm-themes, then you may create file
~/.fvwm/themes/personal/modules-extra with one "DeskTopSize 2 2" command
and follow the instructions in the fvwm-themes FAQ. Or choose modules
from other themes, some use DeskTopSize 2x2.

Regards,
Mikhael.

---

From: Wendell Turner <[email-masked]>
Date: Mon, 20 Oct 2003 17:18:12 -0400

> > > But still only have the 3x3 Desker/Desktop that is labelled

I think I've at least figured my terminology mistakes:
- the FvwmDesker is a separate window with 4 Desks (Main, Web,
  Devel, Games), each of those are a 3x3 window 'thing' (Desktop?)

- the FvwmButtons is a window with a clock, xload, xbiff, and
  one 3x3 Desktop(?) labelled Main.

I'm trying to get the Desker information into the FvwmButtons,
if that is possible.  It seems that I need to modify something
similar to

  *FvwmButtons: (2x2, Frame 2, \
        Swallow "FvwmPager-Single" "Module FvwmPager FvwmPager-Single * *")

in FvwmButtons and create my own FvwmPager-XXX module, correct?

> If you decide to continue with fvwm-themes,

I suppose I will, as I'm not sure what to do if I abandon it(!).

> then you may create file
> and follow the instructions in the fvwm-themes FAQ.

I did, but it still seemed to be ignored also.

> Or choose modules from other themes, some use DeskTopSize 2x2.

Thanks for the hand holding, but I really want to figure out
fvwm/fvwm2/fvwm-themes.

Wendell

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 21 Oct 2003 01:59:33 +0300

>   one 3x3 Desktop(?) labelled Main.

The fvwm terminology is: FvwmPager shows one or several desks with 3x3
pages inside each desk, FvwmButtons is a kind of an application panel.
Every desk has its name (like "Main").

There is a convention in fvwm-themes to have 2 pagers, one that
shows the current desk (FvwmPager-Single, it is often swallowed in
FvwmButtons) and one that shows 4 desks (FvwmPager-Desker).

> in FvwmButtons and create my own FvwmPager-XXX module, correct?

If you insist to change the modules in the default theme (this is not the
best thing to do, because your changes will be lost on the next install)
then replace the line above with:

  *FvwmButtons: Geometry 100x450-0-0
  *FvwmButtons: Columns 2
  *FvwmButtons: (2x8, Frame 2, \
        Swallow "FvwmPager-Desker" "Module FvwmPager FvwmPager-Desker * *")

You may need to read the FvwmButtons man page to create new button bar
designs (all man pages may be found in the menu).

> I suppose I will, as I'm not sure what to do if I abandon it(!).

If you have fvwm-themes related problems then I suggest you to subscribe
to fvwm-themes-users@ mailing list and describe them again.

You may want first to explore the menu, there are different options to
choose from and different themes have different sets of options. It is
possible there is already something you need.

Regards,
Mikhael.

---

From: Robert Huff <[email-masked]>
Date: Tue, 21 Oct 2003 00:52:45 -0400

>  AddToFunc StartFunction I Module FvwmPager

	Will this have the same effect?

AddToFunc StartFunction
 + I Module FvwmAuto 500
 + I Module FvwmPager 
 + I exec xsetroot -solid DarkGreen

					Robert Huff