Subject: FVWM: How to disable static menu

From: Marcin Głogowski <[email-masked]>
Date: Mon, 13 Oct 2003 23:32:26 +0200

Hello,
Is there a way to disable "static" menu when I push the mouse button?
I would like to see the menu only when the mouse button is pressed.
Sometimes when I'm not moving the mouse cursor menu stays on top even I 
release the button.
Thank you for the answer.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Oct 2003 01:25:12 +0300

> Sometimes when I'm not moving the mouse cursor menu stays on top even I 

If I understand you correctly, you want to use "Popup menuname" command
instead of "Menu menuname" command.

Regards,
Mikhael.

---

From: Marcin G?ogowski <[email-masked]>
Date: Tue, 14 Oct 2003 14:02:15 +0200

> instead of "Menu menuname" command.

Hello,
Not exactly - I want simple menu (like root menu) that will not 
disappear when I choose some sub-menu.
The menu should disappear immediately when I release the mouse button.
For now this is done only when I'm moving the mouse button.
I'm invoking the menu this way:

Mouse 3 A M Menu MenuRoot
DestroyMenu MenuRoot
AddToMenu MenuRoot
+ "abc" Popup MenuAbc

Regards

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Oct 2003 15:17:16 +0300

> Mouse 3 A M Menu MenuRoot

I mean:

  Mouse 3 A M Popup MenuRoot

It does what you explain.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Oct 2003 14:38:58 +0200

> disappear when I choose some sub-menu.

Did you actually try "Popup menuname"?  It does exactly what you
describe (with the exception that the sub menu becomes 'posted'
because of the click).

> Mouse 3 A M Menu MenuRoot

Ciao

Dominik ^_^  ^_^

---

From: Marcin G?ogowski <[email-masked]>
Date: Tue, 14 Oct 2003 14:04:20 +0200

> For now this is done only when I'm moving the mouse button.
Sorry, not mouse button, but mouse :-)