Subject: FVWM: Query about ExitFunction

From: Scott Smedley <[email-masked]>
Date: Sun, 19 Oct 2003 14:05:51 +1000

Hi all,

The FVWM function 'ExitFunction' is invoked prior to FVWM restarting
or exiting (the user logs out).

Is there a function that is _only_ invoked prior to FVWM restarting?

SCoTT. :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 Oct 2003 21:26:01 +0300

> Is there a function that is _only_ invoked prior to FVWM restarting?

In fvwm-2.5.7 use this:

  AddToFunc ExitFunction
  + I Test (ToRestart) do-something-before-restart
  + I Test (Quit) do-something-before-quit

RestartFunction and InitFunction are pretty obsolete now. All you need is
StartFunction:

  AddToFunc StartFunction
  + I Test (Restart) do-something-on-restart
  + I do-something
  + I Test (Init) do-something-on-start

Regards,
Mikhael.