Subject: FVWM: Nested 'PipeRead' commands

From: [email-masked]
Date: Sat, 25 Oct 2003 08:10:39 -0200

Hello.

I am going to try to adapt the icewm-menu-gnome2 program
from IceWM to dynamically generate Gnome2 menus for FVWM.
But for that I need to know if the command PipeRead can
be recursive, that is, the output of the command argument
to PipeRead can contain another PipeRead, and that one
is also executed?

Something like

  PipeRead "fvwm-menu-gnome2 --list /usr/share/gnome/vfolders/"

where the output of the command

  fvwm-menu-gnome2 --list /usr/share/gnome/vfolders/

have calls to PipeRead.

Regards,

Romildo
-- 
Prof. José Romildo Malaquias        [email-masked]
Departamento de Computação       [email-masked]
Univ. Federal de Ouro Preto  http://uber.com.br/romildo
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 Oct 2003 12:15:35 +0000

>   fvwm-menu-gnome2 --list /usr/share/gnome/vfolders/

I am not sure why do you ask rather then just try it:

  PipeRead `echo 'PipeRead "echo Menu MenuFvwmRoot"'`

Yes, nested PipeRead works.

However, you don't really need it. In your script just use loops to
generate several menus at once.

Or use dynamical submenu features to call your script again on submenus.

See the output of existing fvwm-menu-* scripts for different approaches.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 25 Oct 2003 16:10:52 +0200

> from IceWM to dynamically generate Gnome2 menus for FVWM.

I think that the following Python module can be useful
for that:

http://www.cojobo.net/~h_wendel/stuff/pyxdg-0.4.tar.gz

With this module and a few lines of python you can generte
an "elementary" GNOME2 menu for fvwm.

Also, you can take a look at:

http://www.freedesktop.org/Standards/menu-spec
and
http://www.freedesktop.org/Standards/basedir-spec

Regards, Olivier

---

From: [email-masked]
Date: Sat, 25 Oct 2003 20:27:22 -0200

On Sat, Oct 25, 2003 at 12:15:35PM +0000, Mikhael Goikhman wrote:
> [...]
> [...]

I have done some changes to the icewm-menu-gnome2 and now
I have a version supporting FVWM menus.

I would like that someone take a look at the way I have
done it and make comments, as I do not have much
experience with FVWM.

In my FVWM configuration file I have the following:

#----------------------------------------------------------------
DestroyMenu RootMenu
AddToMenu RootMenu
+ "Gnome"	Popup GnomeMenu

AddToMenu GnomeMenu "Gnome" Title
+ DynamicPopupAction Function GnomeMenuF

AddToFunc GnomeMenuF
+ I DestroyMenu GnomeMenu recreate GnomeMenu
+ I AddToMenu GnomeMenu "Gnome" Title
+ I PipeRead '/var/tmp/icewm-1.2/src/icewm-menu-gnome2 --wm fvwm --name GnomeMenu --list /usr/share/gnome/vfolders'
#----------------------------------------------------------------

The output of the command executed with PipeRead above, in
my Gentoo Linux system, is attached to this message.

Any comments?

Romildo