Subject: FVWM: FileRunner & fvwm

From: Bob Marcan <[email-masked]>
Date: Fri, 10 Oct 2003 22:28:47 +0200

Hi.

Weird behaviour of FileRunner under different WM.

When i open a file with the internal viewer (MB3 on the file name),
the new window properly stacks on the main fr window.
When i try to save this file (MB3 Save As...) the weirdness begin:

FileRunner-2.5.1-6 on both platforms.
tcltk-8.3.1-4 on Tru64
tcl-8.3.5-88 on RH9

CDE, Tru64, 5.1B:
MWM, Linux, RH9:
    open save dialog in edit window (MB3)
    edit window pushed behind the main
    save
    edit window pops back, O.K.

Linux, RH9
TWM XFree86-twm-4.3.0-2:
XFCE3 3.8.18:
XFCE4 4.0.0:
    open save dialog in edit window (MB3)
    edit window stays above main
    save
    edit window is not pushed behind the main window
    all the three windows visible all the time, O.K.

FVWM 2.5.7:  (this is the one i'm interested in)
GNOME 2.2.0.*:
KDE 3.1-*:
    open save dialog in edit window (MB3)
    edit window pushed behind the main
    save
    edit window stays behind hidden,
      or partly hidden, depends on the window position

Any solution?

All WM:
When fr runs internal application (ftp,copy) for a long time and i 
switch to another workspace, it opens dialog window in the current 
workspace and not in the workspace where the main window reside.

Is there any workaround?

TIA, Bob

-- 
  Bob Marcan                     mailto:[email-masked]
  Aster^H^H...HermesPlus^H^H^H...S&T
  Slandrova ul. 2                       tel:    +386 (1) 5895-000
  1000 Ljubljana, Slovenia              http://www.hermes-plus.si

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Sat, 11 Oct 2003 10:13:46 +0200

>      or partly hidden, depends on the window position

That is because the dialog window is a transient for the main
window.  In many window managers, when a transient is raised, its
"parent" window is also raised.  The right fix is to make the
dialog a transient window of the qedit window, not of the main
window.  Please report this to the FileRunner developers.  It is
not the fault of the window managers.

In fvwm, you can disable this automatic raising/lowering:

  Style FileRunner !StackTransientParent

(or DontStackTransientParent with fvwm-2.5.3 or earlier).

> workspace and not in the workspace where the main window reside.

In fvwm, you can force all FileRunner windows on a specific desk
or page:

  Style FileRunner StartsOnPage 1 1, Skipmapping

(or try one of the other StartsOn... styles).  This works only if
you start FileRunner always on the same page or desk.

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Marcan <[email-masked]>
Date: Sat, 11 Oct 2003 13:05:04 +0200

[email-masked] wrote:
...
> (or DontStackTransientParent with fvwm-2.5.3 or earlier).
Tnx, this solved the problem:
Style "What file?"   !StackTransientParent
...
> 
> Dominik ^_^  ^_^
> 
>  --
> Dominik Vogt, dominik.????
> Reply-To: dominik.vogt@????
>