Subject: FVWM: FvwmTabs v2.3

From: Scott Smedley <[email-masked]>
Date: Mon, 20 Oct 2003 23:15:53 +1000

Hi all,

A new version of FvwmTabs is available.
  
You can get it at:
  
http://users.tpg.com.au/users/scottie7/fvwmtabs.html                            
  
ChangeLog:
- FvwmTabs can now preserve its state (ie. remember the windows it has
  swallowed as tabs) b/w FVWM restarts. (New stateFile option.)
- Implemented fixedSizeTabs option to force tab-buttons to all have equal sizes.
- Implemented balloonMsg option to set balloon popup text.
- Added ShowLast function to show/select the last selected tab.
- Updated fvwmtabrc file.
- Implemented showTitlebar option & associated menu item.
- Implemented useTMTitlebar option to add title text to main titlebar.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tavis Ormandy <[email-masked]>
Date: Mon, 20 Oct 2003 13:39:25 +0000

> A new version of FvwmTabs is available.

Wow, you sure are keeping us packagers busy :)

-- 
-------------------------------------
[email-masked] | finger me for my gpg key.
-------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tobias <[email-masked]>
Date: Mon, 20 Oct 2003 17:30:57 +0200

Hi Scott

Many thanks ! Equal-width tabs now working perfectly.
The new "showTitlebar"-function is also very convinient.

Just two additions:
1)
The example fvwmtabrc doesnt mention the new feature "fixedSizeTabs".

2)
I am not exactly sure what the State function should do, but according to
the source it should be useful when fvwm is restarted. But then its not
working for me.

What i do is: 
 - Alt-tab for new TabManager
 - auto swallow some aterms
 - fvwm restart
 - <TabManager is gone>

Greets
Tobias

On Mon, 20 Oct 2003 23:15:53 +1000

---

From: Tobias <[email-masked]>
Date: Mon, 20 Oct 2003 20:04:27 +0200

Hi Scott

I found a Bug in the current 2.3 version. In
old v2.1 its working normaly.

I use multiple desktops and open the TabManager
in one desktop. After switching between Desktops
i cannot get the focus back to the Tabmanager and
only can get it back by pushing mouse button on the
background (or moving the TabManager by shortcuts).

In v2.1 focus is automatically regained after
entering Desktop with the tabmanager in it.

Greets
Tobias

---

From: scott <[email-masked]>
Date: Tue, 21 Oct 2003 10:25:37 +1000

Hi Tobias,

: The example fvwmtabrc doesnt mention the new feature "fixedSizeTabs".

Ah, thanks.

: I am not exactly sure what the State function should do, but according to
: the source it should be useful when fvwm is restarted. But then its not
: working for me.
: What i do is:
: - Alt-tab for new TabManager
: - auto swallow some aterms
: - fvwm restart
: - <TabManager is gone>

After you restart FvwmTabs should automatically create a tab-manager &
re-swallow your aterms. (if it's working properly that is!)

Can you replace this line:

+ I Test (ToRestart) Function SaveState

with:

+ I Function SaveState

in the fvwmtabrc file & try again. Tell me what happens.

SCoTT. :)
-- 
[email-masked]

---

From: scott <[email-masked]>
Date: Tue, 21 Oct 2003 10:28:52 +1000

Hi Tavis,

: Wow, you sure are keeping us packagers busy :)

Hey cool! Do you have a webpage that tells users of your distribution
(Gentoo Linux is it?) how to download/install FvwmTabs? I'd love to
put a link on the FvwmTabs webpage (next to Xavier's link for Debian
users).

SCoTT. :)

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 21 Oct 2003 01:30:57 +0000

> put a link on the FvwmTabs webpage (next to Xavier's link for Debian

Yep, Gentoo Linux, All users who have the `perl` and `tcltk` USE flags
set when they install fvwm automatically get FvwmTabs for no extra
charge :)

USE flags are basically configuration options or settings (Gentoo
installs all applications from source, so we can make compile-time
features optional)

To guarantee they get FvwmTabs, a  user might do this

# USE="perl tcltk" emerge fvwm

Thanks!

---

From: scott <[email-masked]>
Date: Tue, 21 Oct 2003 11:36:13 +1000

Hi Tavis,

: Yep, Gentoo Linux, All users who have the `perl` and `tcltk` USE flags
: set when they install fvwm automatically get FvwmTabs for no extra
: charge :)

tcltk?

FvwmTabs is written in Perl/Tk.

: USE flags are basically configuration options or settings (Gentoo
: installs all applications from source, so we can make compile-time
: features optional)
: 
: To guarantee they get FvwmTabs, a  user might do this
: 
: # USE="perl tcltk" emerge fvwm

Cool! I'll put a note about this on the webpage soon.

SCoTT. :)

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 21 Oct 2003 01:57:32 +0000

> FvwmTabs is written in Perl/Tk.

Yep, but we dont have a flag for just Tk, the tcltk flag is described
as "tcltk - Support for Tcl and/or Tk", so with the combination of the
`perl` flag its close enough :)

> Cool! I'll put a note about this on the webpage soon.

Awesome, thanks!

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 21 Oct 2003 05:44:09 +0300

> set when they install fvwm automatically get FvwmTabs for no extra

Actually only Perl is needed. Neither Tcl/Tk nor Perl/Tk nor other things
like X11::Protocol are needed in order to run a properly written perllib
module. It should open an error window describing which Perl classes are
missing in the system for that module. They may be installed later.

Regards,
Mikhael.

---

From: Tobias <[email-masked]>
Date: Tue, 21 Oct 2003 09:30:00 +0200

Hi Tavis

On Tue, 21 Oct 2003 01:30:57 +0000

> set when they install fvwm automatically get FvwmTabs for no extra

I also use gentoo. It seems that the ebuild does not install the patched
X11-protocol package. I got weird errors:
"
Use of uninitialized value in string eq at /usr/lib/perl5/site_perl/5.8.0/X11/Auth.pm line 97.
Argument "XCMiscGetVersion" isn't numeric in int at /usr/lib/perl5/site_perl/5.8.0/X11/Protocol.pm line 2028.
Module FvwmTabs started with X11::Protocol version 0.51_2.
"

But perhaps i am wrong, since i havent looked into it right now.

Greets
Tobias

---

From: Tavis Ormandy <[email-masked]>
Date: Tue, 21 Oct 2003 14:14:36 +0000

> Module FvwmTabs started with X11::Protocol version 0.51_2.

The patch is getting applied, although it looks like Scott has released
a new version since I put a copy of it on to the Gentoo mirrors, I've
updated it. 

Those errors appear to be harmless, but I'll fix them anyway :)

---

From: Tobias <[email-masked]>
Date: Wed, 22 Oct 2003 10:05:24 +0200

Hi Tavis

many thanks for this fast update :-)

Greets
Tobias

On Tue, 21 Oct 2003 14:14:36 +0000

---

From: Tobias <[email-masked]>
Date: Wed, 22 Oct 2003 19:06:21 +0200

Hi Scott

Sorry, i was not at home for the last 2 days.

The Tabmanger is correctly restarted and swallows the specific
aterms if i use the "+ I Function SaveState" line instead.

:-)

Greets
Tobias

On Tue, 21 Oct 2003 10:25:37 +1000