Subject: FVWM: How can I bind a keyboard accelerator to the Microsoft key ?

From: "Brian W.Kernighan" <[email-masked]>
Date: Wed, 08 Oct 2003 17:54:26 +0800

Hi, Everybody:

      Does anyone know how to describe a Microsoft key ?
Now I have the following line in my ~/.fvwm/.fvwm2rc file:
  # Keyboard accelerators
       Key    F1          A       N       Popup "Utilities"
 And I want the "Microsoft" key has the same function as  the above "F1" 
key has.
What should I do?

Thanks in advance.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Glyn Millington <[email-masked]>
Date: Wed, 08 Oct 2003 11:14:17 +0100

>       Does anyone know how to describe a Microsoft key ?

Yes ;-)
>  And I want the "Microsoft" key has the same function as  the above
>  "F1" key has.
> What should I do?

Well I do it this way

In .xinitrc

8<------8<------8<------8<------8<------8<------8<------8<------8<------
# Keyboard tweaks
/usr/X11R6/bin/xmodmap -e "keycode 116 = F31"
/usr/X11R6/bin/xmodmap -e "keycode 117 = F32"
8<------8<------8<------8<------8<------8<------8<------8<------8<------

and in .fvwm2rc

8<------8<------8<------8<------8<------8<------8<------8<------8<------
Key F31         A       N      Scroll -100 +0
Key F32         A       N      Scroll +100 +0
8<------8<------8<------8<------8<------8<------8<------8<------8<------

So that I move backwards and forwards through workspaces

hth

Glyn