Subject: FVWM: Almost solved - static menu

From: Marcin Głogowski <[email-masked]>
Date: Tue, 14 Oct 2003 15:55:33 +0200

Hi,
I have almost solved my problem with static menu.
In my previous configuration I have used the "Popup" command, but I 
forgot to use "Nop" instruction at the end.
My root menu is disappearing now, sience I'm using "Popup RootMenu Nop" 
instead "Menu RootMenu", but when I move the mouse cursor in the root 
menu area and release it, the menu want not dissapear.
Thank you for any suggestions.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 14 Oct 2003 19:54:53 +0300

> My root menu is disappearing now, sience I'm using "Popup RootMenu Nop" 

"Popup RootMenu Nop" is equivalent to "Popup RootMenu".

> menu area and release it, the menu want not dissapear.

When you move the cursor into a submenu (i.e. when you effectivelly click
on it) it gets posted like Dominik mentioned, there are several ways to
unpost a submenu. If you don't want a submenu to be posted, just don't
click on it.

When you move the cursor into an item (i.e. when you effectivelly click
on it) the item action gets executed.

This is all intended. To cancel a Popup menu move the cursor outside of
the menu (or point it to the menu title) and release the mouse button.
Or press Escape.

Regards,
Mikhael.

---

From: Marcin G?ogowski <[email-masked]>
Date: Tue, 14 Oct 2003 19:26:23 +0200

> "Popup RootMenu Nop" is equivalent to "Popup RootMenu".
Sorry, but I have probably something wrong in my config file, because 
there is a difference (Popup with Nop works, but without Nop not).
My config file looks like this:

SnapAttraction	5 All Screen
SnapGrid	5
EdgeThickness	0
DeskTopSize	1x4
DeskTopName	0 Desk
OpaqueMoveSize unlimited

CursorStyle ROOT         left_ptr
CursorStyle TITLE        left_ptr
CursorStyle DEFAULT      left_ptr
CursorStyle SYS          left_ptr
CursorStyle MENU         left_ptr

Style *		Font -*-fixed-medium-r-*-*-10-*-*-*-*-*-iso8859-2
Style *		ForeColor gray60, BackColor #c3c3c3
Style *		HilightFore black, HilightBack #c3c3c3
Style *		BorderWidth 3, HandleWidth 3
Style *		MinOverlapPlacement
Style *		MWMBorder

TitleStyle	LeftJustified

MenuStyle *	BorderWidth 1, Hilight3DOff, PopupOffset 0 100
MenuStyle *	Foreground black, MenuFace TiledPixmap 
"/root/.fvwm/back/marble.xpm"
MenuStyle *	ActiveFore #c3c3c3, HilightBack darkblue
MenuStyle *	Font -*-fixed-medium-r-*-*-13-*-*-*-*-*-iso8859-2

Mouse 1 T       N       FuncTitlebar
Mouse 1 S	C	FuncDragWindow
Mouse 1 R	N	Nop

Mouse 2 R       N	Popup MenuGotoPage
Mouse 2 A       M	Popup MenuGotoPage

Mouse 3 T       N       FuncRaiseLower
Mouse 3 R	N       Popup MenuRoot
Mouse 3 A       M	Popup MenuRoot
....

I'm using FVWM 2.5.7
Regards.