Subject: FVWM: Autoshading windows?

From: Johannes Karlsmyr <[email-masked]>
Date: Thu, 23 Oct 2003 16:47:35 +0200

I am trying to get Gaim windows for example to autoshade when the mouse or focus leaves the window. 

I ripped this function from the mailinglist:

<snip>
DestroyFunc AutoShadeOn
AddToFunc   AutoShadeOn I WindowShade True
DestroyFunc AutoShadeOff
AddToFunc   AutoShadeOff I WindowShade False
Module FvwmAuto 0 "Silent AutoShadeOff" "Silent AutoShadeOn"
</snip>

I would like to be able to use this function for Windows that have the State set to 1 or something else, but how do i set the State command value to something without clicking on a button?
The prefered way would be to do this:

Style Gaim State 1, StaysOnTop, TitleAtLeft, Layer 4

But that doesnt seem to work at all, or is there any other way to decide at a configuration file level which windows are gonna use the above AutoShade function?

I hope some of you fvwm2 hackers can help me out with this.

Best Regards /* Johannes */
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 23 Oct 2003 15:03:29 +0000

On 23 Oct 2003 16:47:35 +0200, Johannes Karlsmyr wrote:
> I would like to be able to use this function for Windows that have the
> State set to 1 or something else, but how do i set the State command
> value to something without clicking on a button? The prefered way would
> be to do this:
> 

Use window context, not style, like:

  Next (Gaim) State 1 on

> But that doesnt seem to work at all, or is there any other way to
> decide at a configuration file level which windows are gonna use the
> above AutoShade function?

You may set the state for some windows when you start them, see FAQ 3.18.

  AddToFunc SetShadabilityForCertainWindows
  + I ThisWindow (Gaim) State 1
  + I ThisWindow (Miag) State 1

Regards,
Mikhael.