Subject: FVWM: How to add the 3d button (close function) to the right side of the window

From: Bob Marcan <[email-masked]>
Date: Thu, 02 Oct 2003 08:47:25 +0200

Hi, i'm novice.
How to add the 3d button (close function) to the right side of the 
window, like in fwvm default setup.
In my setup everything is MWM* and i like this look.
But i like to have this button too.

TIA, Bob
-- 
  Bob Marcan                     mailto:[email-masked]
  Aster^H^H...HermesPlus^H^H^H...S&T
  Slandrova ul. 2                       tel:    +386 (1) 5895-000
  1000 Ljubljana, Slovenia              http://www.hermes-plus.si

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Christian Aistleitner <[email-masked]>
Date: Thu, 02 Oct 2003 09:17:34 +0200

Hello,

> Hi, i'm novice.

me too.

> window, like in fwvm default setup.

actually I have got 5 Buttons on the right side. I'll copy paste the 
relevant parts of my configuration. I guess you'll figure out what you 
need.

put it all in your fvwm configuration file (probably something like 
~/.fvwm/.fvwm2rc)
---------------------------------------------
# Layout of my windows:
#
# +-------------------------------------+
# | (1)    TITLE    (0) (8) (6) (4) (2) |
# +-------------------------------------+
# |                                     |
# |                                     |
# |       CONTENT                       |
# |                                     |
# |                                     |
# +-------------------------------------+
#
#
#Button 1 - the button on the left, which normally opens a menu for you
#           which opens when you click at it
#Button 0 - left click   : raise to top
#           middle click : stay in middle
#           right click  : lower to bottom.
#Button 8 - Stick On/Off
#Button 6 - Iconify
#Button 4 - Maximize
#Button 2 - Close

#turn on all defined buttons for all applications by default
Style *           Button 1, Button 2, Button 4, Button 6, Button 8, Button 
0
#them in order to get the Buttons visible, you must attach functions
#to them:
Mouse 0 1       A       Menu MenuFvwmWindowOps2 Close
Mouse 0 2       A       Close
Mouse 0 4       A       FuncFvwmMaximize
Mouse 0 6       A       Iconify
Mouse 0 8       A       Stick
Mouse 1 0       A       Layer 0 6
Mouse 2 0       A       Layer 0 4
Mouse 3 0       A       Layer 0 2

#tell fvwm what the buttons look like
#you'll probably want to use the things you already have
#instead of my own lousy drawings ;-)
AddButtonStyle 2 Vector 17 10x10@1 10x20@1 40x50@0 10x80@1 10x90@1 20x90@0 
50x60@0 80x90@0 90x90@0 90x80@0 60x50@0 90x20@0 90x10@0 80x10@1 50x40@1 
20x10@1 10x10@1

AddButtonStyle 4 Vector 5 10x10@1 10x90@1 90x90@0 90x10@0 10x10@1

AddButtonStyle 6 Vector 5 10x70@1 10x90@1 90x90@0 90x70@0 10x70@1

AddButtonStyle 8 Vector 11 20x10@1 30x35@1 20x60@1 60x60@0 40x60@0 50x90@1 
60x60@0 80x60@0 70x35@1 80x10@0 20x10@1

AddButtonStyle 0 Vector 8 50x10@1 10x60@1 40x60@0 40x90@1 60x90@0 60x60@0 
90x60@0 50x10@0

#note that you should have the Menu MenuFvwmWindowOps2 and the function
#FuncFvwmMaximize defined. But they come along with the standard
#configuration of fvwm.

---------------------------------------------

Best regards,
Christian