Subject: Re: FVWM: Emacs-like key sequences

From: Dominik Vogt <[email-masked]>
Date: Mon, 1 Sep 2003 10:14:21 +0200

On Sat, Aug 30, 2003 at 04:13:19PM -0400, Dan Espen wrote:
> Erik Steffl <[email-masked]> writes:
> > Mario Domg=F6rgen wrote:
> > > Hallo list!
> > >
> > > Will emacs-like key sequences find their way in fvwm somewhen? I
> > > would
> > > really  like to see such bindings like Mod4 m s for maximize to
> > > screen
> > > and Mod4 m v for maxmize vertically...
> > 
> >    you can specify any keybindings you want... all of them are =
> > specified
> > in config files.
> 
> He's asking for key sequences, not just a single key with a modifier.
> 
> I don't think it can be done reliably.
> 
> You could use "Mod4 m" to start a module that did a keyboard grab
> for the next key, but I don't think the module would start quickly
> enough.
 
> You could do it with a menu, and a menu hotkey, which would be
> fast enough, but would cause something visible to appear.

Actually, that works pretty well for me.  To reduce interference
between application and window manager key sequences, I have my
root menu bound to Meta-Space and use the hotkeys in it to invoke
various actions.  Most window operations are bound to
Ctrl-Meta-<some key>.

> I guess you could make the menu fully transparent, but thats not
> really what the OP was asking for.

Bye

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mario Domgörgen <[email-masked]>
Date: Mon, 01 Sep 2003 11:35:09 +0200

> for the next key, but I don't think the module would start quickly

I will try that in a lazy moment... :)

> really what the OP was asking for.

It's not exactly what i want but it will do ... menus coming up very
fast and i can put them somewhere on the screen where i don't see
them. It's a kind of hack, but a nice hack... :)

Mario

-- 
Windoze not found: (C)heer, (P)arty or (D)ance?