Subject: FVWM: A question about 'affinity'

From: Lars Segerlund <[email-masked]>
Date: Thu, 4 Sep 2003 13:15:14 +0200

How can I set different affinity for placements ( top, bottom, left right and so on ) on a per application basis ?

 I have been looking at the doc's but I think I need a hint to start me off.

 As an example of what I mean, I wan't my  browser windows to the top/left, pdf viewer bottom/left, and shells bottom/right, i.e. different apps sorted differently ?

 ( ps. all this applies to the app when iconized )

 / regrads, Lars Segerlund.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 4 Sep 2003 17:30:30 +0300

On 04 Sep 2003 13:15:14 +0200, Lars Segerlund wrote:
> 
> How can I set different affinity for placements ( top, bottom, left
> right and so on ) on a per application basis ?
> 
> As an example of what I mean, I wan't my  browser windows to the
> top/left, pdf viewer bottom/left, and shells bottom/right, i.e.
> different apps sorted differently ?

To start, for example, pdf viewer at bottom left, run "xpdf -g +0-0".

> ( ps. all this applies to the app when iconized )

This is different, iconic windows are fully managed by a window manager.
This should do what you want:

  Style *      IconBox 400x400+0+0, IconFill l t   # default, browsers etc
  Style Xpdf   IconBox 400x400+0-0, IconFill l b   # pdf viewer
  Style XTerm  IconBox 400x400-0-0, IconFill b r   # terminals
  Style *term* IconBox 400x400-0-0, IconFill b r   # --.--
  Style MyGame IconBox 400x400-0+0, IconFill t r   # something else

There are other Icon* style options that you may add.

Regards,
Mikhael.