Subject: FVWM: Moving windows

From: Johan Svedberg <[email-masked]>
Date: Fri, 12 Sep 2003 17:25:20 +0200

Evning!

Just one quick question. Is it possible to move windows between pages
even though I use this:

    EdgeResistance 10000 10000
    EdgeScroll 0 0
    EdgeThickness 0

With keybindings for example?

-- 
Johan Svedberg, [email-masked], http://johan.svedberg.pp.se/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Sep 2003 10:39:15 +0200

> With keybindings for example?

Not out of the box.  I solve this problem with a high delay before
paging occurs:

  EdgeResistance   500 128
                   ^^^

Whe I hit the edge, I can usually prevent paging.  The pointer has
to hover over the edge for half a second.

Alternatively you can make a function that disables edge
resistance for a move operation:

  addtofunc move_noresist
  + I EdgeResistance 10000 100
  + I Move
  + I EdgeResistance 10000 10000

  mouse 1 t m function move_noresist

Ciao

Dominik ^_^  ^_^

---

From: Johan Svedberg <[email-masked]>
Date: Mon, 15 Sep 2003 18:35:05 +0200

>   mouse 1 t m function move_noresist

Ah, great ideas! Thank you Dominik!

---

From: Johan Svedberg <[email-masked]>
Date: Thu, 18 Sep 2003 18:54:38 +0200

>   mouse 1 t m function move_noresist

Hmmm, I'm trying to use the functionapproach. What I'm trying to produce
is a keybinding F1 with CM as modifiers to move the window in focus to
Page 0 3. Could someone figure out a solution to this?

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Sep 2003 20:05:58 +0300

> With keybindings for example?

Do you mean MoveToPage and MoveToDesk commands? See the man page.

Here are bindings from fvwm-themes:

# move to page, Shift+Ctrl+KP_N  
Key KP_1        A       SC      MoveToPage 0 2
Key KP_2        A       SC      MoveToPage 1 2
Key KP_3        A       SC      MoveToPage 2 2
Key KP_4        A       SC      MoveToPage 0 1
Key KP_5        A       SC      MoveToPage 1 1
Key KP_6        A       SC      MoveToPage 2 1
Key KP_7        A       SC      MoveToPage 0 0
Key KP_8        A       SC      MoveToPage 1 0
Key KP_9        A       SC      MoveToPage 2 0
Key KP_0        A       SC      MoveToPage prev

# move to desk, Shift+Ctrl+N
Key 1           A       SC      MoveToDesk 0 0
Key 2           A       SC      MoveToDesk 0 1
Key 3           A       SC      MoveToDesk 0 2
Key 4           A       SC      MoveToDesk 0 3
Key 0           A       SC      MoveToDesk prev

There are corresponding GotoPage and GotoDesk bindings too, with Ctrl-Alt.

Regards,
Mikhael.

---

From: Johan Svedberg <[email-masked]>
Date: Thu, 18 Sep 2003 19:13:50 +0200

> There are corresponding GotoPage and GotoDesk bindings too, with Ctrl-Alt.

I think you missunderstood. I want to move windows (with the above
settings) between pages (yes pages, I only use one desk), not just
change the viewport. It has to be done with a function, but I can't seem
to get one working.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Sep 2003 20:16:49 +0300

On 18 Sep 2003 18:54:38 +0200, Johan Svedberg wrote:
> 
> is a keybinding F1 with CM as modifiers

Just a note, you usually can't bind anything to Ctrl-Alt-FN, it is
trapped by X Server (or kernel, it is really not important by what).

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Sep 2003 20:18:22 +0300

> change the viewport. It has to be done with a function, but I can't seem

This shows you didn't try these bindings.

Regards,
Mikhael.

---

From: Johan Svedberg <[email-masked]>
Date: Thu, 18 Sep 2003 19:43:37 +0200

> This shows you didn't try these bindings.

Sorry. I read way to fast.

This works great, thanks!