Subject: FVWM: No Window List

From: David Siegal <[email-masked]>
Date: Mon, 15 Sep 2003 17:53:35 -0400 (EDT)

Hi,
   I am an fvwm newbie, so please forgive my ignorance, but...

   How do I prevent the window list that you get by clicking on the
destktop from appearing at all?

   RTFM is a fine answer if you can point me to the place in the
manual. I have been looking...

Thanks,
David

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Siegal <[email-masked]>
Date: Mon, 15 Sep 2003 19:57:44 -0400 (EDT)

How do I prevent the window list, or any other context menu, from
appearing when you click on the desktop?

I have the following lines in my system.fvwm2rc file:
Mouse 1                R       A       WindowList
Mouse 2                R       A       WindowList
Mouse 3                R       A       WindowList

When I either comment them out, or try to remap them as follows
Mouse 1 R A -
Mouse 2 R A -
Mouse 3 R A -

then I end up getting a Builtin Menu (with items, Xterm, Setup Form, etc.)
in its place.

I want to eliminate any context menu altogether.

Thanks in advance,
David

---

From: Mike McNally <[email-masked]>
Date: Mon, 15 Sep 2003 19:12:49 -0500

> I want to eliminate any context menu altogether.

Bind the mouse events to a function that doesn't do anything?

--
[ you are my main foo ] Mike McNally -- [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Mon, 15 Sep 2003 20:16:17 -0400

> I want to eliminate any context menu altogether.

You want to click on the root and get nothing at all?

You should be able to remove this built-in binding:

Mouse 1 R A Menu MenuFvwmRoot

With:

Mouse 1 R A -

If that doesn't work, look for another binding in your .fvwm2rc or tell
us which release you are using.

Also look for bindings to "Mouse 0" (which means any button).

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Sep 2003 09:48:30 +0200

> us which release you are using.

The man page lists all built-in bindings.  You can remove them by
replacing their action with a '-':

  Key Help R A -
  Key F1 R A -
  Key Tab A M -
  Key Escape A MC -
  Mouse 1 R A -
  Mouse 1 T   A -
  Mouse 1 FS  A -
  Mouse 2 FST A -

As Dan noted, you want to remove the "Mouse 1 R A ..." binding.

> Also look for bindings to "Mouse 0" (which means any button).

Ciao

Dominik ^_^  ^_^

---

From: David Siegal <[email-masked]>
Date: Tue, 16 Sep 2003 09:41:12 -0400 (EDT)

Thanks for your reply.
Answers to your questions below...

> You want to click on the root and get nothing at all?

Yes.

> Mouse 1 R A Menu MenuFvwmRoot

It does succeed in getting rid of the window list, but it's replaced with
a menu "Builtin Menu".

> Also look for bindings to "Mouse 0" (which means any button).

There don't appear to be any other mouse bindings.
My fvwm version:
FVWM version 2.4.6 compiled on Apr  8 2002 at 20:52:23
with support for: ReadLine, Stroke, XPM, GNOME WM hints, Shape, SM,
Multibyte, Xinerama

This seems to be the latest stable Debian linux release.

My system.fvwm2rc file is below.
It has been setup to produce a kiosk/task-station which can run a limited
set of programs.
Thanks!
David

#$Revision: 1.14 $

# Features of this system.fvwm2rc file for the kiosk
# Application window does not lose focus when mouse is moved
# Multiple instances of FvwmWharf module to have buttons
# 	in multiple locations
# One button for xterm or application (uses text picture label)
#	see checkstation_start.sh script
# Another button runs xlock (part of xlockmore package)
# Third button runs a script which runs halt (halt is run SUID root -- kludgy)
# Runs xlock

# Centering Buttons: the Launch and Shutdown buttons are by default
#	positioned to be centered in an 800x600 resolution. To recenter
#       for 1024x768, see the "### Launch Button" and "### Shutdown Button"
#       sections below.

ImagePath /usr/X11R6/include/X11/pixmaps/

EdgeResistance 250 10
EdgeScroll 100 100
ClickTime 750

# make sure these fonts exist on your system:
WindowFont -adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
IconFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

# no extra desktops allowed in kiosk mode
HilightColor black palevioletred
DeskTopSize 1x1
MenuStyle maroon grey60 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* fvwm

ColormapFocus FollowsMouse

# default Styles:
Style "*"           BorderWidth 0, HandleWidth 0, notitle, nohandles
Style "*"           Icon unknown1.xpm, Color lightgrey/dimgrey
Style "*"           MWMFunctions, MWMDecor, HintOverride
Style "*"           DecorateTransient, NoPPosition
Style "*"           IconBox 0 -10 -280 -1
Style "*"           ClickToFocus
Style "*"           RandomPlacement, SmartPlacement
#Style "xdaliclock"  StaysOnTop
#Style "sxpm"        StaysOnTop

# Styles for various Fvwm modules:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style "FvwmWharf"   NeverFocus
Style "FvwmWharfPier" NeverFocus
Style "FvwmWharfDock" NeverFocus

# some simple default key bindings:
Key Next         A       SCM     Next [*] Focus
Key Prior        A       SCM     Prev [*] Focus

# some simple default mouse bindings:
#   for the root window:
# Showing WindowList is safe for kiosk
# Don't remove these lines, as it will bring back a window
# that allows an xterm to be run or the window manager to be stopped
# Mouse 1		R    	A      	WindowList
# Mouse 2		R    	A      	WindowList
# Mouse 3		R    	A      	WindowList

# TEMP: ATTEMPT TO REMOVE ALL BINDINGS TO MOUSE CLICKS ON ROOT DESKTOP
Mouse 0               R       A       -
Mouse 1               R       A       -
Mouse 2               R       A       -
Mouse 3               R       A       -

#   for the title bar buttons:
# removed since these controls are removed from kiosk

#   for other parts of the window/borders/icons:
# removed since these controls are removed from kiosk

# TitleStyle removed, no title bars in kiosk mode

# FvwmWharf section (a module ported from the AfterStep window mgr)
# better than FvwmButtons as it allows multiple invocations
# with different configurations

### Lock Button (xlock)
*FvwmWharfGeometry -1+1
*FvwmWharfTextureType 0
# if you change the following invocation, change it in the Initialization Functions section below too
*FvwmWharf lock lock.xpm Exec xlock -logoutButton -1 +usefirst -echokeys +description -info "The UTEC Kiosk is locked."

### Launch Button (starts checkstation)
# Uncomment one of the following 2 lines, for positioning button on 800x600 or 1024x768 display, respectively
*FvwmWharfPierGeometry +325+275
# *FvwmWharfPierGeometry +450+350

*FvwmWharfPierTextureType 0
# line below commented due to being replaced by line following it
# it remains there, because it is part of the future
#*FvwmWharfPier xterm xterm-linux.xpm Exec xterm -geometry 70x8+100+50 -fn 6x13 -fg navy -bg azure2
*FvwmWharfPier checkstation launch.xpm Exec /home/utec/checkstation_start.sh

### Shutdown Button (halts kiosk machine)
# Uncomment one of the following 2 lines, for positioning button on 800x600 or 1024x768 display, respectively
*FvwmWharfDockGeometry +425+275
# *FvwmWharfDockGeometry +550+350

*FvwmWharfDockTextureType 0
*FvwmWharfDock halt shutdown.xpm Exec /home/utec/kiosk_shutdown.sh

######################## Initialization Functions ############################

# runs xlock
# sets the root window to be solid black in color
# starts the three invocations of FvwmWharf

# if you change the following invocation, change it in the ###Lock Button section above too:
AddToFunc InitFunction	  "I" exec xlock -logoutButton -1 +usefirst -echokeys +description -info "The UTEC Kiosk is locked."
AddToFunc InitFunction	  "I" exec /usr/X11R6/bin/xsetroot -solid black
AddToFunc InitFunction 	  "I" Module FvwmWharf
AddToFunc InitFunction 	  "I" Module FvwmWharfPier
AddToFunc InitFunction	  "I" Module FvwmWharfDock

# NO ADDITIONS WERE MADE BELOW THIS POINT

######################## Menus ###################
# no menus in kiosk mode

######################## Sample Functions ##########################

AddToFunc FocusAndWarp "I" Focus
+                      "I" WarpToWindow 2p 2p

AddToFunc DeiconifyFocusAndWarp "I" Iconify -1
+                               "I" FocusAndWarp

AddToFunc ChangeDefaultFocus "I" Style "*" $0
+                            "I" Recapture

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
# FvwmPager module disabled in kiosk

##########################FvwmWinList##################################
# this is for WindowList displayed by pressing any mouse button
# in root window

*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green

---

From: Dan Espen <[email-masked]>
Date: Tue, 16 Sep 2003 12:24:59 -0400

> FVWM version 2.4.6 compiled on Apr  8 2002 at 20:52:23

In 2.4.6, the built in binding was:

Mouse 0 R N Menu MenuFvwmRoot

Remove it with:

Mouse 0 R N -

---

From: David Siegal <[email-masked]>
Date: Wed, 17 Sep 2003 17:01:18 -0400 (EDT)

Yes! That worked! Thanks, Dan.
A followup newbie question:
What do R, N, A, etc. signify? I'm looking through the man page but am not
finding their definitions.

Thanks again,
David

---

From: Dan Espen <[email-masked]>
Date: Wed, 17 Sep 2003 17:24:49 -0400

> finding their definitions.

Look under key/mouse bindings.

R = Root.
A = Any modifier.
N = No modifier.

(On this list, replies are normally placed in context,
unnecessary text is removed.)

> > > > > I have the following lines in my system.fvwm2rc file:
...