Subject: FVWM: [ANNOUNCE] quickselect: a screen like quickselecting script for fvwm written in perl

From: Thomas Glanzmann <[email-masked]>
Date: Thu, 25 Sep 2003 22:17:05 +0200

Hi together,
I just wrote somehting I was missing since a long time. It isn't
directly related to screen but nice to have in the envrionment.

What it does? You press CTRL SHIFT ALT + 0 - 9 get a crosshair and klick
on an X Application. If you want to switch to that application again you
press CTRL SHIFT + 0 - 9 ... that's it.

For more documentation have a look at 'perldoc ./quickselect'.

Greetings,
	Thomas

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 26 Sep 2003 01:41:23 +0300

> press CTRL SHIFT + 0 - 9 ... that's it.

I think it has a bug, it assumes window ids have 6 heximal digits after
0x. They may have (and usually have) 7 digits, but probably 5 and 8 too.

What is the problem with this configuration that does the same without
any external tools (quickselect, xwininfo), I posted it some time ago:

  Key 1 A SCM  Key 1 A SC  WindowId $[w.id] WindowListFunc
  Key 9 A SCM  Key 9 A SC  WindowId $[w.id] WindowListFunc

(In fvwm versions less than 2.4.16 you should use "WindowListFunc $$w").

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 26 Sep 2003 01:52:41 +0300

> (In fvwm versions less than 2.4.16 you should use "WindowListFunc $$w").

This works on focused window if any. IMHO, it is faster and easier.
To always force the crosshair like in your variant, you may use:

  Key 1 A SCM  NoWindow Pick  Key 1 A SC  WindowId $$[w.id] WindowListFunc

Regards,
Mikhael.

---

From: Doug Kearns <[email-masked]>
Date: Fri, 26 Sep 2003 20:52:31 +1000

> press CTRL SHIFT + 0 - 9 ... that's it.

You might be interested in http://ratpoison.sf.net/

<snip>

Regards,
Doug