Subject: FVWM: fvwm-themes Gtk+ and stuff

From: FtR <[email-masked]>
Date: Fri, 12 Sep 2003 16:34:57 +0200

Hi folks,
I am not to deep into GUI's and stuff but since X is a god driver for 4 Xterms I use it.

I succesfully customized fvwm that way, that all my windows present a pixmap as border title-bar etc
even my Pager, Button-bar, and roo-menu does this.

now my Question 
is it possible that all my other application such as sylpheed, gimp, etc (not openoffice)
which seem to use their layout from fvwm do not use that ugly grey for all their dialogs
menubars etc.
it would be cool if i could place a pixmap would be cool there.

I thought fwvm-themes could do that but I do not know where to use the colorset I have created.
for the  normal FvwmForms I got it done (colorset is ok then ) bu the rest for all other applikation ????

hope I could make my self clear.

THX in advance

Eg opera provides an option to do that for him (does not use fvwm native elements i suppose)

-- 
#!/usr/local/bin/perl 
print&f(($_=(3x3)."3+33")=~s=3(?![^3]|$)=&f=eg);
sub f{eval(@_?$_:"'$&+'x3");} 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Fri, 12 Sep 2003 15:51:27 +0100 (BST)

--- FtR <[email-masked]> wrote: > Hi folks,
> rest for all other applikation ????

If these applications are GTK based then you will need to edit "~/.gtkrc".
You should really google for examples of how/what to change.

Apologies for the vagueness of this answer.

HTH,

-- Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Fri, 12 Sep 2003 16:57:13 +0200

Hi there,

On 12 Sep 2003 at 15:51:27 +0100, Thomas Adam wrote:

> If these applications are GTK based then you will need to
> edit "~/.gtkrc".  You should really google for examples of
> how/what to change.

Or you can use the theme settings from gnomecc which points
you to already installed gtkrc's on your system:

/usr/share/themes/BrushedMetalClean/gtk/gtkrc:

----------------------------------------------------------------------
style "default"
{
  font = "-*-lucida-medium-r-normal-*-*-100-*-*-p-*-iso8859-1"
  #fg[NORMAL]      = { 0.00, 0.00, 0.00 }
  #fg[PRELIGHT]    = { 0.25, 0.25, 0.25 }
  #fg[ACTIVE]      = { 0.00, 0.00, 0.00 }
  #fg[SELECTED]    = { 0.00, 0.00, 0.00 }
  #fg[INSENSITIVE] = { 0.25, 0.25, 0.25 }
  #bg[NORMAL]      = { 0.85, 0.85, 0.85 }
  #bg[PRELIGHT]    = { 0.95, 0.95, 0.95 }
  #bg[ACTIVE]      = { 0.40, 0.40, 0.40 }
  #bg[SELECTED]    = { 0.70, 0.68, 0.66 }
  #bg[INSENSITIVE] = { 0.80, 0.80, 0.80 }
  #base[NORMAL]      = { 0.80, 0.80, 0.80 }
  #base[PRELIGHT]    = { 0.90, 0.90, 0.90 }
  #base[ACTIVE]      = { 0.80, 0.80, 0.80 }
  #base[SELECTED]    = { 0.40, 0.60, 0.80 }
  #base[INSENSITIVE] = { 0.60, 0.55, 0.50 }
  bg_pixmap[NORMAL]      = "bc.xpm"
  bg_pixmap[PRELIGHT]    = "bc-light.xpm"
  bg_pixmap[ACTIVE]      = "bc-dark.xpm"
  #bg_pixmap[SELECTED]    = "bc-dark.xpm"
  bg_pixmap[INSENSITIVE] = "bc.xpm"
}

class "GtkWidget" style "default"
----------------------------------------------------------------------

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive our mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: FtR <[email-masked]>
Date: Fri, 12 Sep 2003 17:29:51 +0200

Hi there 
THX for the answers which gave me a lead where to search

my system is just an base Xfree + fvmw 
no gnome, kde, cde, or other overfeatured "framework".
gtk should be installed.