Subject: FVWM: Re: [FVWM-Themes] Getting Started with FVWM Themes

From: Thomas Adam <[email-masked]>
Date: Fri, 5 Sep 2003 11:24:50 +0100 (BST)

--- Mikhael Goikhman <[email-masked]> wrote: 
> On 05 Sep 2003 03:38:33 +0000, David Dickerson wrote:
> > 
> > I added the following line to '.xinitrc':
> > 
> >     exec /usr/bin/fvwm-themes-start
> > 
> > This change worked, but I find that I cannott use any
> > other window manager. No matter which one I select,
> > I end up in FVWM. I hope that your change will resolve
> > this issue, Mikhael. (You are the expert, after all.)
> 
> I don't know which programs do you use to change the window manager.
> If this program writes ~/.Xclients, then you should obviously remove
> your ~/.xinitrc and manually edit ~/.Xclients as I wrote in the previous
> message.

An understanding of the underlying opeations is a good idea here. I'm not
sure how your system is set-up, David, but if you login to your WM via
xdm/gdm/kdm, etc. then adding that line you have there:

exec $(which fvwm-themes-start)

to ~/.xinitrc, **will have no effect**, since all display managers use
"~/.xsession" unless of course "~/.xinitrc" is a symbolic link to
~/.xsession, but I don't recommend this.

The difference between the two files is that "startx" reads "~/.xinitrc"
and all other display managers read ~/.xsession

> > (Today, I printed out ALL of the FVWM documentation; it
> > will not fit in the 200-page binder that I bought for the sole
> > purpose of holding the FVWM documentation!) :-)
> 
> Hmm, I find it a lot more helpful just to run "man" command (manually or
> from the help menu) when I need something specific. At least I can
> search
> the text using "/" key.

That, and also the documentation for FVWM is in a constant state of flux
and will always be updating.

> > Incidentally, Mikhael, I am using the CDE theme but I cannot
> > call up the option to change colors. Is there a certain file that
> > I should check to correct this problem? (I will continue perusing
> > the documentation.) When I select "color," I receive an error
> > that nothing has been selected.
> 
> What is the exact error you get?

He could be talking about colour pallets here

> > I am also trying to add my KDE menu items to FVWM. I will
> > continue my research. Oddly, when I had the previous version
> > of FVWM installed (and I have the latest increment installed now),
> > the KDE and SuSE menu items appeared in FVWM without any
> > action by me.
> 
> It is possible that the KDE 3 menus are not supported by
> fvwm-menu-desktop, but I don't really know what you try to do.

Depends if he is using EWMH's or not.

> > Aso, I want to change the Netscape icon in the CDE panel to
> > Mozilla (which I have not yet installed, because I have been
> > using Konqueror, which does not "like" FVWM). I will research
> > this issue also.
> 
> The CDE theme is not too configurable, ideally you would configure the
> icon and application yourself. The easy way to change this is to edit
> the site wide theme, file themes/cde/modules/buttonbar/large .
> Although I never really suggest to edit the site wide theme, because
> it will be overwritten on the next install.

HTH,

-- Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 6 Sep 2003 13:38:42 +0200

> > fvwm-menu-desktop, but I don't really know what you try to do.

Here, with KDE-3.0 and fvwm-2.5.x, adding something like

PipeRead 'fvwm-menu-desktop --desktop kde-sys --desktop kde-sys --dir=/usr/share/applnk --enable-mini-icons --mini-icons-path=/usr/share/icons/hicolor/16x16/apps/'

in the config file build a menu named "Kde-applnk" that you
can bind to your main root menu. Some "local" and "locale" options
(modification) may be needed depending on LANG and your system.

Regards, Olivier