Subject: FVWM: Ask (:

From: Andrei Mitrofanow <[email-masked]>
Date: Mon, 8 Sep 2003 23:31:52 +0200

<> i have a *.png texture with transparency loadet into menubackground
<> and
<> into title. I have used TiledPixmap to open.
<>
<> The transparency shows not the background but the default color.
<> Are there a way to show this realy transparent?

>You should set background using "fvwm-root -r" or Esetroot.
>You should use "Colorset 5 RootTransparent".
>I don't think that "Colorset 5 RootTransparent, TiledPixmap a.png" will
>work, but try it. If you can't do it, ask on the [email-masked] list.

Now i ask.

i have try, but it don't work

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 9 Sep 2003 02:17:33 +0300

> i have try, but it don't work

What exactly did you try that does not work, did you actually try what I
said? There were several similar questions in the past. It works.

  Exec fvwm-root -r somebg.png
  Colorset 5 RootTransparent
  #MenuStyle * MenuColorset 5  # redundant for fvwm-themes

Or better yet:

  Colorset 5 RootTransparent buffer, bg average, Tint black 30, bgTint black 30

I don't think you may currently have RootTransparent and TiledPixmap,
Olivier may correct me. But RootTransparent and Tint looks well.

P.S. Your subject line does not help to archive users to understand the
problem. How about Subject: transparency in menus with tiled png image

Regards,
Mikhael.

---

From: Andrei Mitrofanow <[email-masked]>
Date: Tue, 9 Sep 2003 04:55:58 +0200

>   Exec fvwm-root -r somebg.png

this: "xli -onroot somebg.png"

> problem. How about Subject: transparency in menus with tiled png image
sorry, i have realy problems with my english
also somewere
Possible i need a school again.

---

From: Andrei Mitrofanow <[email-masked]>
Date: Tue, 9 Sep 2003 22:33:44 +0200

http://localhost/~smilebef/norman.html

this link shows a term in center of screenshot "2.Versuch".
there are buttons shown in the window wood.png from gimp.
transparency buttens without any symbols.
but the screenshot shows symbols under the transparency buttons.
how can i clean up this symbols?
is there a solution?

Andrei

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Sep 2003 10:08:32 +0200

> http://localhost/~smilebef/norman.html
        ^^^^^^^^^^

I don't think there is a machine on the internet named "localhost"
;-)

> how can i clean up this symbols?

Ciao

Dominik ^_^  ^_^

---

From: Andrei Mitrofanow <[email-masked]>
Date: Wed, 10 Sep 2003 10:45:46 +0200

> > http://localhost/~smilebef/norman.html
The head :)
http://smilebef.homelinux.org/~smilebef/norman.html

---

From: Uwe Pross <[email-masked]>
Date: Wed, 10 Sep 2003 11:08:00 +0200

Hi there,

> > > how can i clean up this symbols?

If you want to remove the buttons and get a clean title bar
you may try:

TitleStyle  Inactive  TiledPixmap title-inactive.xpm -- Flat
ButtonStyle All Inactive Simple -- Flat UseTitleStyle

Cheers, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive our mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Sep 2003 12:02:59 +0200

> > > how can i clean up this symbols?

I'm still not sure what the problem is.  Can you cut out the relevant
portion of the picture and post it to the mailing list.  And please
try to reword your description.

Ciao

Dominik ^_^  ^_^

---

From: Andrei Mitrofanow <[email-masked]>
Date: Wed, 10 Sep 2003 17:18:29 +0200

> try to reword your description.

1. colorset ? RootTransparent, fg firebrick 10, bg None, Tint yellow 10, bg Tint yellow 10
The "None" don't exist, but i want bg = tranparent.

2. whitch is the default ButtonStyle
is it posible that this button under my transparent buttons are
and i these see.

Andrei

---

From: Andrei Mitrofanow <[email-masked]>
Date: Thu, 11 Sep 2003 03:37:11 +0200

> ButtonStyle All Inactive Simple -- Flat UseTitleStyle
i have it add to personal/buttons
_______________________________________________________________
FuncFvwmDecorBackground

Style "*" Button 1, Button 2, Button 4, Button 6
TitleStyle  Inactive  TiledPixmap title-inactive.xpm -- Flat
ButtonStyle All Inactive Simple -- Flat UseTitleStyle
#Style "*" FVWMButtons
#MWMButtons
# button relief follows the state
AddButtonStyle (1-6) \
 ActiveUp     (Pixmap button/sphere_gelb.png     -- Flat) \
 ActiveDown   (Pixmap button/sphere_gelb.png   -- Flat) \
 InactiveUp   (Pixmap button/sphere_gelb.png   -- Flat) \
 InactiveDown (Pixmap button/sphere_gelb.png -- Flat)
				
ButtonStyle 1 - Clear MWMDecorMenu
ButtonStyle 2 - Clear
ButtonStyle 4 - Clear MWMDecorMax
ButtonStyle 6 - Clear MWMDecorMin
TitleStyle      Height 14
				
_______________________________________________________________

it does not work

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 10 Sep 2003 18:25:00 +0200

> is it posible that this button under my transparent buttons are

Yes and as explain Uwe Pross you can "clean" it.

Regards, Olivier