Subject: FVWM: animated resize

From: KONTRA Gergely <[email-masked]>
Date: Tue, 16 Sep 2003 18:04:22 +0200

Hi!

If there's animated move, that do fvwm users have animated resize?

Anyway. How to resize a window relatively to current size?
Eg how to grow the window by 10 percent of window/screen?

Thx
-- 
+-[ Kontra, Gergely<[email-masked]> PhD student Room IB113 ]---------+
| http://www.mcl.hu/~kgergely            "Olyan langesz vagyok, hogy  |
| Mobil:(+36 20) 356 9656 ICQ: 175564914   poroltoval kellene jarnom" |
+-- Magyar php mirror es magyar php dokumentacio: http://hu.php.net --+
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mario Domgörgen <[email-masked]>
Date: Tue, 16 Sep 2003 18:57:42 +0200

> Eg how to grow the window by 10 percent of window/screen?

I use the following:

Key KP_Next A S4 ResizeCenter br w+5 w+5
Key KP_Home A S4 ResizeCenter br w-5 w-5
Key KP_Left A S4 ResizeCenter br w-5 keep
Key KP_Right A S4 ResizeCenter br w+5 keep
Key KP_Up A S4 ResizeCenter br keep w-5
Key KP_Down A S4 ResizeCenter br keep w+5

DestroyFunc CenterWindow
AddToFunc   CenterWindow
+ I ThisWindow Piperead "echo Move \
      $(( $[vp.width]/2-$[w.width]/2 ))p \
      $(( $[vp.height]/2-$[w.height]/2 ))p"

DestroyFunc ResizeCenter
AddToFunc ResizeCenter
+ "I" Resize $0 $1 $2
+ "I" CenterWindow

BTW: What is a animated resize?

Mario

-- 
Windows NT crashed.
I am the Blue Screen of Death.
No one hears your screams.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: KONTRA Gergely <[email-masked]>
Date: Tue, 16 Sep 2003 19:10:18 +0200

> BTW: What is a animated resize?

To think it over again, it is not a wise idea.
First try AnimatedMove. In the same fashion AnimatedResize...
Resource-hunger, may be ugly on most apps...

Gergo

---

From: KONTRA Gergely <[email-masked]>
Date: Tue, 16 Sep 2003 19:32:18 +0200

>       $(( $[vp.height]/2-$[w.height]/2 ))p"
        ^^^ What is this? BTW I don't want to be moved, so I don't use
this function.

I get the following error message:
[FVWM][__execute_function]: <<ERROR>> No such command '$(('

However, the focus is lost, if I shrink the window and the mouse pointer
gets out of the window, the window lost the focus.
I tried a little function:

DestroyFunc MyResize
AddToFunc MyResize
+ I Resize $0 $1 $2
+ I Focus ThisWindow

but it doesn't work. :(

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 16 Sep 2003 20:53:39 +0300

On 16 Sep 2003 19:32:18 +0200, KONTRA Gergely wrote:
> 
> On 0916, Mario Domg?rgen wrote:
> > DestroyFunc CenterWindow
> > AddToFunc   CenterWindow

Do you have spaces after backslash?

> I tried a little function:

Focus command does not accept such argument, it may be ThisWindow Focus.
Anyway, ThisWindow is redundant in this example, just Focus would do.
Using SloppyFocus may help too.

Regards,
Mikhael.