Subject: FVWM: Pixmap image in title

From: ChiP <[email-masked]>
Date: Wed, 10 Sep 2003 23:13:23 +0400

Hi.

Can I use image with size 18x16 as button images in Title without scalling it or
resizing? So I need something like this:

I have set of images with size :

% identify closeAD.xpm 
closeAD.xpm XPM 18x16+0+0 DirectClass 16-bit 646.0 0.031u 0:01
% identify minimizeAD.xpm 
minimizeAD.xpm XPM 18x16+0+0 DirectClass 16-bit 634.0 0.039u 0:01
% 

And I want to use it in title as a buttons with height 16:
~ % grep 'TitleStyle.*Height' .fvwm2rc 
TitleStyle Height 16
~ % 

If I use :
TitleStyle Height 16
ButtonStyle Number State Pixmap "somepixmap_18x16.xpm"

fvwm allocate for button 16x16 rectangle, but i need 18x16

What can I do?

ps: sorry for my english, it's not my native language.

.:ChiP:.

-------------------
:wq
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 11 Sep 2003 00:49:25 +0200

> fvwm allocate for button 16x16 rectangle, but i need 18x16

I am not sure to understand what you want exactly But a
titlebar button is always a square in fvwm. But what about

TitleStyle Height 18

you will see a 18x16 button, No?

Regards, Olivier