Subject: FVWM: keyboard shortcuts adon't respond

From: Sanjaya Dharmasena <[email-masked]>
Date: Thu, 11 Sep 2003 23:54:55 -0700

Is there anything that will inhibit keyboard shortcuts from working? I
have the following in the .fvwmrc file (attached). However, these
shortcuts don't work when I have fvwm2 running.  I have a Mandrake Linux
8.0 distribution. 

Thanks
-Sanjaya

#	FVWM 2 initialization file
#	must be either ~/.fvwm2rc or /etc/X11/fvwm2/system.fvwm2rc
#========================================================================#
#
# Fonts - one for window titles, another for icons, and another for the menus
#
#WindowFont	-adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
#WindowFont	-adobe-times-bold-r-*-*-12-*-*-*-*-*-*-*
#IconFont	-adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*
#IconFont	-adobe-times-medium-r-*-*-*-120-*-*-*-*-*-*

#Font                    lucidasanstypewriter-12
#WindowFont              lucidasanstypewriter-12
#IconFont                lucidasanstypewriter-12

#Window list fonts
WindowFont -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
IconFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

#MenuStyle black grey76 grey30 -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-* fvwm
MenuStyle #FFCC00 #666699 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* fvwm
SetAnimation 10 -.01 0 .01 .03 .08 .18 .3 .45 .6 .75 .85 .90 .94 .97 .99 1.0
MenuStyle * Hilight3DThin, Animation
MenuStyle * TrianglesSolid, PopupDelay, PopupOffset -5 100

#========================================================================#
#
# Module path and paths to the icons
# ModulePath is a colon-separated list, just like regular unix PATH
#
ModulePath /usr/X11R6/lib/X11/fvwm2/
#PixmapPath /usr/include/X11/pixmaps/:/usr/X11R6/icons/

IconPath /usr/include/X11ImagePath /usr/share/icons/mini:/usr/share/icons
PixmapPath /usr/share/icons/mini:/usr/share/icons

#*FvwmScriptPath /usr/X11R/lib/X11/fvwm2/Scripts

#========================================================================#
#
# Set the default window colors. The syntax is:
# DefaultColors winforecolor winbackcolor titleforecolor titlebackcolor
# where:
# winbackcolor is the background (border) color of all windows,
# including the menu windows
# winforecolor is used for the menu text
# titlebackcolor is the background color used for title bars of
# non selected windows
# titleforecolor is the color of the title text of non selected windows
#
#DefaultColors Black #c3c3c3 #c3c3c3 grey51
#DefaultColors Black LightSkyBlue Black #c3c3c3

#
# Text and background color for the title bar of the active (selected) window
#
HilightColor Black #c5d5e5
#HilightColor Wheat DimGrey
#
# Text and background color for the title bar of sticky windows
#
#StickyColors grey51 #60c080

# You can also use the Style command to set the colors of individual
# title bars of some non-selected windows

#Style "*" ForeColor Black
#Style "*" BackColor #c3c3c3
Style "*" ForeColor Wheat
Style "*" BackColor DimGrey
#========================================================================#

#moving windows: 1000 means all windows
#OpaqueMoveSize 1000ColormapFocus FollowsMouse

# default Styles:
Style "*"           BorderWidth 5, HandleWidth 5
Style "*"           Icon /usr/share/icons/unknown1.xpm, Color lightgrey/dimgrey
Style "*"           MWMFunctions, MWMDecor, HintOverride
Style "*"           DecorateTransient, NoPPosition
Style "*"           IconBox 0 -10 -280 -1
Style "*"           FocusFollowsMouse
Style "*"           RandomPlacement, SmartPlacement

EdgeScroll 100 100
EdgeResistance 10000 0

#
# RandomPlacement prevents user interaction while placing windows:
#
Style "*" RandomPlacement, SmartPlacement

#want to have windows de-iconified at current screen, not where they were #iconified! Used to be "StubbornIcons", now ...?
#Style "*" StickyIcon

#
# NoPPosition instructs fvwm to ignore the PPosition field in window
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
#
Style "*" NoPPosition

#========================================================================#

#
# Set the desk top size in units of physical screen size
#
DeskTopSize 3x3		#pager size
#Scroll +100 +100	#set the initial position at the center
#Desk 0 4	#this sets the "desk" - not the "page"

#========================================================================#

# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.

# These commands should command before any menus or functions are defined,
# and before the internal pager is started.

#
# Default border and handle widths
#
#Style "*" BorderWidth 5, HandleWidth 5

#Display styles for particular applications

Style "Fvwm*"		NoTitle, Sticky, WindowListSkip
Style "Fvwm Pager"	StaysOnTop, NoHandles
Style "FvwmBanner"	StaysOnTop
Style "FvwmButtons"	NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 5
Style "*clock"		StaysOnTop, NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbiff"		NoTitle, Sticky, WindowListSkip
Style "xrus"		NoTitle, NoHandles, Sticky, WindowListSkip
Style "mount"		NoTitle, NoHandles, Sticky, StaysOnTop
#
# Some mini-icons for the title bar - the option is MiniIcon, not TitleIcon
#
Style "*" MiniIcon mini-x2.xpm
#Style "*xterm*" MiniIcon mini-term.xpm
#Style "XTerm"       Icon /usr/share/icons/xterm.xpm, SloppyFocus
Style "XTerm"       Icon /usr/share/icons/xterm.xpm
Style "rxvt" MiniIcon mini-term.xpm
Style "xcalc" MiniIcon mini-calc.xpm
Style "shell" MiniIcon mini-term.xpm
Style "xv" MiniIcon mini-xv.xpm
Style "Netscape" MiniIcon mini-nscape.xpm
Style "nedit"	MiniIcon mini-doc1.xpm
Style "Ghostview" MiniIcon mini-gv.xpm
Style "Xcolorsel" MiniIcon mini-colors.xpm
Style "IDL*" MiniIcon mini-zoom.xpm

Style "*fm*" MiniIcon mini-filemgr.xpm
Style "mount" MiniIcon mini-filemgr.xpm

Style "topBox" MiniIcon mini-book1.xpm
Style "help" MiniIcon mini-book2.xpm
Style "manualBrowser" MiniIcon mini-book2.xpm

#========================================================================#

#
# Stuff to do at start-up
#

AddToFunc "InitFunction"
+ "I" Module FvwmButtons
#+ "I" Module FvwmButtons MiniButtons
#initialization: programs to run on start
+ "I"	Exec xsetroot -solid #6666aa
#+ "I"	Exec xsetroot -bg black -solid black 
+ "I" Module FvwmAnimate

AddToFunc "RestartFunction"
+ "I" Module FvwmButtons
#+ "I" Module FvwmButtons MiniButtons
+ "I" Module FvwmAnimate

#========================================================================#

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] Focus
+			   "I" None [$0] Exec $0 $1

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Move-or-Raise2	"I" Raise
+				"M" Move
+  				"D" WindowShade

AddToFunc Maximize-Func		"M" Maximize	 0 100
+				"C" Maximize	 0 80
+				"D" Maximize	 100 100

AddToFunc Move-or-Iconify	"I" Raise
+				"M" Move
+				"D" Iconify

*AddToFunc Move-or-Iconify	"I" Iconify
*+				"M" Move

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc PrintReverseFunction  "I" Raise
+                               "I" Exec xdpr 1/2 -h -rv -id $w

SAddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

#========================================================================#

#
# Now define the menus - defer bindings until later
#

# This is for the Start menu of the FvwmTaskBar

Read "menu"
AddToMenu RootMenu	""		Nop
+                       ""              Nop
+ 			"Shells%shells_section.xpm" 	  Popup Shells
+			"Accessories"		  Popup Accessories
+ 			""              Nop 
+ 			"Lock Screen      %mini-lock.xpm%"        Popup   Screenlock
+ 			"Screensaver      %mini-display.xpm%"     Popup   Screensaver
+ 			""              Nop
+			"Fvwm Modules%fvwm2-menuicon.xpm"	          Popup Module-Popup
+                       "Fvwm Window Ops%fvwm2-menuicon.xpm"         Popup Window-Ops
+                       "Fvwm Simple Config Ops%fvwm2-menuicon.xpm"  Popup Misc-Ops
+			""		Nop
+                       "Refresh Screen%mini.refresh.xpm"   Refresh
+                       "Recapture Screen" Recapture
+			""		Nop
+ "Exit Fvwm2 %mini-stop.xpm%" Popup Quit-Verify

AddToMenu Misc-Ops "Misc Config Opts" Title
+                  "Sloppy Focus"        ChangeDefaultFocus SloppyFocus
+                  "Click To Focus"      ChangeDefaultFocus ClickToFocus
+                  "Focus Follows Mouse" ChangeDefaultFocus FocusFollowsMouse
+                  "" Nop
+                  "Colormap Follows Mouse" ColormapFocus FollowsMouse
+                  "Colormap Follows Focus" ColormapFocus FollowsFocus
+                  "" Nop
+                  "Full Paging ON"         EdgeScroll 100 100
+                  "All Paging OFF"         EdgeScroll 0 0
+                  "Horizontal Paging Only" EdgeScroll 100 0
+                  "Vertical Paging Only"   EdgeScroll 0 100
+                  "Partial Paging"         EdgeScroll 50 50
+                  "Full Paging && Edge Wrap" EdgeScroll 100000 100000

AddToMenu Window-Ops	"Window Ops"	Title		
+			"(Un)Stick"	Stick		
+			"Shade"		WindowShade
+			"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Maximize"	Maximize
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"Refresh Window" RefreshWindow

AddToMenu Window-Ops2	"(Un)&Stick"	Stick		
+			"(Un)S&hade"	WindowShade
+			"&Move"		Move
+			"&Resize"	Resize
+			"R&aise"	Raise   	
+			"&Lower"	Lower   	
+			"(De)&Iconify"	Iconify 	
+                       "(Un)Ma&ximize" Maximize
+			""		Nop     	
+			"&Delete"	Delete	
+			"&Close"	Close
+			"Destroy"	Destroy 	
+			""		Nop
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction
+                       "Print Reverse" PrintReverseFunction

DestroyMenu "Module-Popup"
AddToMenu "Module-Popup"
#AddToMenu Module-Popup	"FvwmModules"	Title
+ 			"Configure%mini-hammer.xpm%" Module FvwmConfig
+			"Identify"	Module	FvwmIdent
+ 			"Save Desktop%mini-desktop.xpm%"	Module FvwmSaveDesk
+			"Talk"  	Module	FvwmTalk
+			""		Nop
+			"Button-Bar%mini-ball.xpm%"	Module	FvwmButtons
+ 			"Button Bar (Mini)%mini-ball.xpm%"	Module FvwmButtons MiniButtons
+			"Pager"		Module  FvwmPager 0 0
+			"Pager (2 desks)" Module  FvwmPager 0 1
+ 			"TaskBar" Module FvwmTaskBar
+			"WinList"	Module  FvwmWinList
+			""		Nop
+			"Banner %mini-fvwm.xpm%"	Module	FvwmBanner
+                       "ScrollBar"     Module  FvwmScroll 50 50
+			"Background"	Module  FvwmBacker
+                       "AutoRaise"     Module  FvwmAuto 200 Raise Nop
+                       "Stop AutoRaise" KillModule FvwmAuto
+			""		Nop
+			"IconBox"	Module	FvwmIconBox
+                       "IconMan"       Module  FvwmIconMan
+			""		Nop
+                       "Form - Rlogin"      Module FvwmForm Rlogin
+                       "Form - MyFvwmTalk"  Module FvwmForm MyFvwmTalk

DestroyMenu "Screensaver"
AddToMenu "Screensaver" "Screensaver" Title
+              "Bat" Exec exec xlock -nolock -nice 0 -mode bat &
+              "Blank" Exec exec xlock -nolock -nice 0 -mode blank &
+              "Blot" Exec exec xlock -nolock -nice 0 -mode blot &
+              "Bob" Exec exec xlock -nolock -nice 0 -mode bob &
+              "Bounce" Exec exec xlock -nolock -nice 0 -mode bounce &
+              "Flame" Exec exec xlock -nolock -nice 0 -mode flame &
+              "Galaxy" Exec exec xlock -nolock -nice 0 -mode galaxy &
+              "Grav" Exec exec xlock -nolock -nice 0 -mode grav &
+              "Helix" Exec exec xlock -nolock -nice 0 -mode helix &
+              "Hop" Exec exec xlock -nolock -nice 0 -mode hop &
+              "Hyper" Exec exec xlock -nolock -nice 0 -mode hyper &
+              "Kaleid" Exec exec xlock -nolock -nice 0 -mode kaleid &
+              "Life" Exec exec xlock -nolock -nice 0 -mode life &
+              "Life3d" Exec exec xlock -nolock -nice 0 -mode life3d &
+              "Maze" Exec exec xlock -nolock -nice 0 -mode maze &
+              "Pyro" Exec exec xlock -nolock -nice 0 -mode pyro &
+              "Qix" Exec exec xlock -nolock -nice 0 -mode qix &
+              "Random" Exec exec xlock -nolock -nice 0 -mode random &
+              "Rect" Exec exec xlock -nolock -nice 0 -mode rect &
+              "Rock" Exec exec xlock -nolock -nice 0 -mode rock &
+              "Rotor" Exec exec xlock -nolock -nice 0 -mode rotor &
+              "Sphere" Exec exec xlock -nolock -nice 0 -mode sphere &
+              "Spline" Exec exec xlock -nolock -nice 0 -mode spline &
+              "Swarm" Exec exec xlock -nolock -nice 0 -mode swarm &
+              "Wator" Exec exec xlock -nolock -nice 0 -mode wator &
+              "Worm" Exec exec xlock -nolock -nice 0 -mode worm &
+              "World" Exec exec xlock -nolock -nice 0 -mode world &

DestroyMenu "Screenlock"
AddToMenu "Screenlock" "Lock Screen" Title
+              "Bat" Exec exec xlock -nice 0 -mode bat &
+              "Blank" Exec exec xlock -nice 0 -mode blank &
+              "Blot" Exec exec xlock -nice 0 -mode blot &
+              "Bob" Exec exec xlock -nice 0 -mode bob &
+              "Bounce" Exec exec xlock -nice 0 -mode bounce &
+              "Flame" Exec exec xlock -nice 0 -mode flame &
+              "Galaxy" Exec exec xlock -nice 0 -mode galaxy &
+              "Grav" Exec exec xlock -nice 0 -mode grav &
+              "Helix" Exec exec xlock -nice 0 -mode helix &
+              "Hop" Exec exec xlock -nice 0 -mode hop &
+              "Hyper" Exec exec xlock -nice 0 -mode hyper &
+              "Kaleid" Exec exec xlock -nice 0 -mode kaleid &
+              "Life" Exec exec xlock -nice 0 -mode life &
+              "Life3d" Exec exec xlock -nice 0 -mode life3d &
+              "Maze" Exec exec xlock -nice 0 -mode maze &
+              "Pyro" Exec exec xlock -nice 0 -mode pyro &
+              "Qix" Exec exec xlock -nice 0 -mode qix &
+              "Random" Exec exec xlock -nice 0 -mode random &
+              "Rect" Exec exec xlock -nice 0 -mode rect &
+              "Rock" Exec exec xlock -nice 0 -mode rock &
+              "Rotor" Exec exec xlock -nice 0 -mode rotor &
+              "Sphere" Exec exec xlock -nice 0 -mode sphere &
+              "Spline" Exec exec xlock -nice 0 -mode spline &
+              "Swarm" Exec exec xlock -nice 0 -mode swarm &
+              "Wator" Exec exec xlock -nice 0 -mode wator &
+              "Worm" Exec exec xlock -nice 0 -mode worm &
+              "World" Exec exec xlock -nice 0 -mode world &

DestroyMenu "Shells"
AddToMenu "Shells"
+ "Araliya"	Exec xterm -font  -cronyx-courier-medium-r-normal--17-*-*-*-*-*-koi8-r -T araliya -n araliya -e telnet araliya.eng.sun.com
+ "Xterm	(7x14 font)%mini-term.xpm%"	Exec xterm -sb -sl 500 -j -bg navy -fg white -cr red -title "Color xterm"
+ "Large Xterm	(10x20 font)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 10x20 -bg navy -fg white -cr red
+ ""	Nop
+ "Rxvt	(7x14 font)%mini-term.xpm%"		Exec rxvt -font 7x14 -ls
+ "Rxvt (Courier)%mini-term.xpm%"		Exec rxvt -font "-adobe-courier-medium-r-normal--14-*-*-*-*-*-*-*" -ls
+ "Large Rxvt	(10x20 font)%mini-term.xpm%" 	Exec rxvt -font 10x20 -ls -geometry 80x25
+ ""	Nop

DestroyMenu "Accessories"
AddToMenu "Accessories"
+ "Magnifying glass%mini-zoom.xpm%" Exec xmag
+ "Running Processes (Top)%mini-run.xpm%"	Exec rxvt -font 7x14 -T Top -n Top -e top
+ "Xclipboard%mini-clipboard.xpm%" Exec xclipboard
+ "Dclock%mini-clock.xpm%" Exec xclock -digital -update 1 -bg black -fg green -font 7x14
+ "Aclock%mini-clock.xpm%" Exec xclock -bg bisque3 -fg black -hd black -hl black -padding 0 -update 1
+ "Xkill" Exec xkill
+ "Edit .fvwm2rc" Exec xemacs  ~/.fvwm2rc

#
# This menu is invoked as a sub-menu - it allows you to quit,
# restart, or switch to another WM.
#
DestroyMenu "Quit-Verify"
AddToMenu "Quit-Verify"	"Really quit?" Title
+ "Restart fvwm2%mini-turn.xpm%"	Restart fvwm2
+ "" 					Nop
+ "Choose carefully:" 					Nop
+ "" 					Nop
+ "Yes, really quit X session%mini-exclam.xpm%" Quit
+ "" 					Nop
+ "No, don't quit" 					Nop
+ "" 					Nop
#+ "Start WindowMaker%mini-exp.xpm%"		Restart wmaker

#========================================================================#

#
# One more complex function - couldn't be defined earlier because it used
# pop-up menus
#
# This creates the "system" menu for the title-bar window-ops
# pop-up
#
AddToFunc "window_ops_func" "C" PopUp Window-Ops
+ "M" PopUp Window-Ops
+ "D" Delete

#------------------------------------------------------------------------------
# Now some keyboard shortcuts.
#------------------------------------------------------------------------------

# Press arrow + Control in any context
# to scroll by one page in the direction of the arrow
Key Left            A       C       Scroll -100 0
Key Right           A       C       Scroll +100 +0
Key Up              A       C       Scroll +0   -100
Key Down            A       C       Scroll +0   +100
Key Tab         A       C       Scroll 100000 0
Key F1          A       M       Iconify
Key F2          A       M       Move
Key F3          A       M       Resize
Key F4          A       M       Popup "RootMenu"
Key F5          A       M       Popup "Misc-Ops"
Key F6          A       M       Popup "Utilities"
Key F7          A       M       Popup "Module-Popup"
Key F10         A       M       Restart fvwm2
Key F11		A	SCM	WindowList
Key F12         A       SM      Close
Key Return         A       C       Desk 1 1 1
Key Return         A       SC      Desk -1 0 0

#========================================================================#

#
# Mouse bindings
#
# some simple default mouse bindings:
#   for the root window:
Mouse 3	R   	A       Menu "RootMenu" Nop
Mouse 2	R    	A      	Menu "Window-Ops" Nop
Mouse 1	R    	A      	WindowList

#   for the title bar buttons:
Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	2    	A     	Maximize-Func
Mouse 0	4    	A     	Iconify

#   for other parts of the window/borders/icons:
Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	A	Move-or-Raise2
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	T	A	Menu Window-Ops2 Nop
Mouse 2	SF	A	Resize-or-Raise
Mouse 3	TSIF	A	RaiseLower
#========================================================================#

# Definitions used by the modules

#------------------ Pager
#*FvwmPagerBack DeepSkyBlue3
*FvwmPagerBack #6666aa
*FvwmPagerFore black
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #c3c3c3
*FvwmPagerGeometry -3-23
*FvwmPagerLabel 0 desk
*FvwmPagerSmallFont 5x8
*FvwmPagerBalloons            All
*FvwmPagerBalloonBack         White
*FvwmPagerBalloonFore         Black
*FvwmPagerBalloonFont         lucidasanstypewriter-12
*FvwmPagerBalloonYOffset      +2
*FvwmPagerBalloonBorderWidth  1
*FvwmPagerBalloonBorderColor  Black

#------------------ FvwmButtons

*FvwmButtonsFore Black
*FvwmButtonsBack #666699
*FvwmButtonsFrame 1
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmButtonsGeometry 64x448-2+0
*FvwmButtonsColumns 1
#*FvwmButtonsPixmap /usr/X11R6/include/X11/pixmaps/TOTD.xpm
*FvwmButtons(Swallow xclock 'Exec xclock &')
*FvwmButtons(Icon /usr/share/icons/xterm.xpm, Action 'Exec "" xterm -bg black -fg white  &')
*FvwmButtons(Icon /usr/share/icons/large/emacs.xpm, Action 'Exec "" xemacs &')
*FvwmButtons(Swallow "FvwmPager" "FvwmPager 0 0")
*FvwmButtons(Icon /usr/share/icons/xterm.xpm, Action 'Exec "" xterm -bg navy -fg white  &')
*FvwmButtons(Icon /usr/share/icons/large/netscape.xpm, Action 'Exec "" netscape &')
#*FvwmButtons(Swallow XEyes 'Exec xeyes &')
#*FvwmButtons(Swallow xbiff 'Exec xbiff &')
*FvwmButtons(Icon /usr/share/icons/large/xkill.xpm, Action 'Exec "" xkill &')

#------------------ MiniButtons

Style "MiniButtons" NoTitle, NoHandles, Sticky, StaysOnTop, WindowListSkip, BorderWidth 0

*MiniButtonsFore Black
*MiniButtonsBack #c0c0c0
*MiniButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*MiniButtonsGeometry -2-2
*MiniButtonsRows 1
*MiniButtonsPadding 1 1

*MiniButtons - mini.xterm.xpm Exec "xterm" xterm -fg white -bg black -title "xterm"
*MiniButtons - mini-nscape.xpm Exec "netscape" netscape
*MiniButtons - xemacs-menuicon.xpm Exec "Xemacs" xemacs -geometry 82x34+0+0
*MiniButtons - mini-clock.xpm Exec "Clock"  xclock -bg bisque3 -fg black -hd black -hl black -padding 0 -update 1
*MiniButtons - mini.xterm.xpm Exec "xterm" xterm -fg white -bg navy -title "xterm"
*MiniButtons - mini-nscape.xpm Exec "netscape" /usr/local/netscape/netscape
*MiniButtons - mini-bomb.xpm Destroy

#------------------ Identify
*FvwmIdentBack #000080
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

#------------------ FvwmWinList
*FvwmWinListBack #c3c3c3
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1
*FvwmAnimateEffect Random

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Sep 2003 10:34:41 +0200

On Thu, Sep 11, 2003 at 11:54:55PM -0700, Sanjaya Dharmasena wrote:
> Is there anything that will inhibit keyboard shortcuts from working?

Yes, If your num-lock or scroll-lock key is pressed.  See FAQ
question 0.1 for more details.

> I

Ciao

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].