Subject: FVWM: Finding the width of the pager

From: [email-masked]
Date: Sun, 14 Sep 2003 07:21:51 -0300

Hello

I am starting a pager with the following commands in my
configuration file:

AddToFunc StartFunction I Module FvwmPager 0 3

Style FvwmPager	NoTitle
Style FvwmPager	BorderWidth 0, HandleWidth 0
Style FvwmPager	Sticky, StaysOnTop
Style FvwmPager	WindowListSkip, CirculateSkip

*FvwmPager: Geometry x$[MyTaskBarHeight]+0-0

Now I want to determine its width when calculating the
position and size of an IconMan window, which I want
to put side by side (to the right) of the pager.

How can I accomplish this?

Regards,

Romildo
-- 
Prof. José Romildo Malaquias        [email-masked]
Departamento de Computação       [email-masked]
Univ. Federal de Ouro Preto  http://uber.com.br/romildo
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Sep 2003 10:29:36 +0200

> How can I accomplish this?

Use FvwmButtons to swallow both, the FvwmIconMan and the
FvwmPager.  This way, they both get the same height without any
manual intervention.

Ciao

Dominik ^_^  ^_^