Subject: FVWM: Re: fvwm/xterm

From: [email-masked]
Date: Sat, 20 Sep 2003 19:00:45 +0200

On Fri, Sep 19, 2003 at 07:32:24PM -0400, Thomas Dickey wrote:
> I noticed a problem in the current version of fvwm (2.4.16 on Debian testing)
> that affects xterm, and am curious if you have some idea how to analyze it.  If
> I type
> 	resize -s 40 80
> in xterm, it does an XtMakeResizeRequest for the corresponding number of
> pixels.  Immediately after, X calls the resize function of the xterm vt100
> widget with 40x80 as the pixel size of the window.  That repeats, and I get a
> 3x13 window as a result.

xterm is doing some non-standard things with its geometry that can
confuse some versions of fvwm.  Try fvwm-2.5.7.

> If I run ltrace on fvwm, it slows things down enough that everything works as
> expected - I get a 40x80 character-sized window.  Building 2.4.16 from source,
> I get the same results, so it's not the Debian package.
> 
> This is code that I've been using as-is on different window managers for
> several years, of course, including older versions of fvwm...

Ciao

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Dickey <[email-masked]>
Date: Sat, 20 Sep 2003 13:51:19 -0400 (EDT)

> confuse some versions of fvwm.  Try fvwm-2.5.7.

thanks (will try that).  I'm aware that it's doing some unusual things,
but am reluctant to rewrite it...

-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Dickey <[email-masked]>
Date: Sat, 20 Sep 2003 14:56:57 -0400 (EDT)

> confuse some versions of fvwm.  Try fvwm-2.5.7.

2.5.6 is easier to get, and does work.  (I was confused by the recent
Changelog date for 2.4.16, thinking that it was recent, but see that it
is not).

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Sep 2003 09:52:28 +0200

> Changelog date for 2.4.16, thinking that it was recent, but see that it

The 2.5.x versions are from the development branch and 2.4.x is
the stable branch.  We are working on both branches in parallel.

Ciao

Dominik ^_^  ^_^

---

From: Thomas Dickey <[email-masked]>
Date: Mon, 22 Sep 2003 05:26:25 -0400 (EDT)

> the stable branch.  We are working on both branches in parallel.

yes, I understood that (not late on Friday ;-).

thanks.