Subject: FVWM: help me with sessions to set it up

From: Potapov <[email-masked]>
Date: Mon, 11 Aug 2003 08:30:29 +0500

Dear Sir,

I use

FVWM version 2.4.16 compiled on Aug 10 2003 at 12:12:21
with support for: Stroke, XPM, GNOME WM hints, Shape, SM, Xinerama

but, it seems nothing to happen when I activate function ``SaveSession'' or ``SaveQuitFunction''.

thanks in advance

-- 
Regards,
Denis

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Aug 2003 10:24:33 +0300

> but, it seems nothing to happen when I activate function ``SaveSession'' or ``SaveQuitFunction''.

Do you run fvwm under session manager (xsm or gnome-session)?

Regards,
Mikhael.

---

From: Potapov <[email-masked]>
Date: Mon, 11 Aug 2003 15:23:12 +0500

I start my FVWM2 under gnome-session via ~/.gnome/session:

------------ ~/.gnome/session ------------------
[Default]
0,id=117f000001000106059648400000003580000
0,RestartStyleHint=0
0,Priority=30
0,Program=/usr/local/bin/fvwm2
0,DiscardCommand=rm -f /home/deniska/.fs-Zq0xGJ 
0,RestartCommand=/usr/local/bin/fvwm2 -d :0.0 -s -clientId 117f000001000106059648400000003580000 -restore /home/deniska/.fs-Zq0xGJ 
num_clients=1
------------------------------------------------

when I choose ``SaveSession&Quit'' the session closes, but it doesn't
restore next time I start gnome-session

thanks in advance,
Denis