Subject: FVWM: transparent pager problem.

From: [email-masked] (Mojo B. Nichols)
Date: 01 Aug 2003 23:42:09 -0500

I am running 2.5.7 with fvwm-themes 0.62:  I have a personal them.
with startup, modules, menus,menu-programs,menu-extra, and bindings.

I monkied around with menus quite a bit.... AND didn't do much rtfm'n
before recklessly doing this, but it's working. 

Thanks,

Mojo

my config file for my pager is as follows: 

bash-2.05b$ more FvwmPager-Single
DeskTopSize 4x3

DestroyMenu  MenuFvwmWindowMove
AddToMenu    MenuFvwmWindowMove "Move to ..." Title
+ "&Right       Page%menu/window-move.xpm%"     AnimatedMove w+100 w
+ "&Left        Page%menu/window-move.xpm%"     AnimatedMove w-100 w
+ "&Down        Page%menu/window-move.xpm%"     AnimatedMove w w+100
+ "&Up          Page%menu/window-move.xpm%"     AnimatedMove w w-100

DestroyMenu  MenuFvwmWindowGroupQuickMove
AddToMenu    MenuFvwmWindowGroupQuickMove
+ "&Right       Page%menu/window-move.xpm%" Pick All ($r) MoveToPage +1p +0p
+ "&Left        Page%menu/window-move.xpm%" Pick All ($r) MoveToPage -1p +0p
+ "D&own        Page%menu/window-move.xpm%" Pick All ($r) MoveToPage +0p +1p
+ "&Up          Page%menu/window-move.xpm%" Pick All ($r) MoveToPage +0p -1p

Colorset 15 fg white, Transparent
Colorset 14 fg blue, Transparent

DestroyModuleConfig FvwmPager-Single: *
*FvwmPager-Single: Columns 1

*FvwmPager-Single: Colorset * 14
*FvwmPager-Single: HilightColorset * 15
*FvwmPager-Single: BalloonColorset * 16
*FvwmPager-Single: WindowColorsets 1 2

*FvwmPager-Single: Balloons            All
*FvwmPager-Single: BalloonYOffset      +3
*FvwmPager-Single: BalloonBorderWidth  1

*FvwmPager-Single: Label 0 Main
#*FvwmPager-Single: Label 1 Web & Mail
#*FvwmPager-Single: Label 2 Devel
#*FvwmPager-Single: Label 3 Games

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Mojo B. Nichols)
Date: 01 Aug 2003 23:47:08 -0500

Sorry, I forgot to describe the problem.  If I cause a menu to go over the
pager, it doesn't refresh the pager. so then it is no longer
transparent.  

Thanks,

Mojo

>>>>> "Mojo" == Mojo B Nichols <[email-masked]> writes:

> I monkied around with menus quite a bit.... AND didn't do much
> rtfm'n before recklessly doing this, but it's working.

> bash-2.05b$ more FvwmPager-Single DeskTopSize 4x3

> DestroyMenu MenuFvwmWindowMove AddToMenu MenuFvwmWindowMove "Move to
> ..." Title + "&Right Page%menu/window-move.xpm%" AnimatedMove w+100
> w + "&Left Page%menu/window-move.xpm%" AnimatedMove w-100 w + "&Down
> Page%menu/window-move.xpm%" AnimatedMove w w+100 + "&Up
> Page%menu/window-move.xpm%" AnimatedMove w w-100

> DestroyMenu MenuFvwmWindowGroupQuickMove AddToMenu
> MenuFvwmWindowGroupQuickMove + "&Right Page%menu/window-move.xpm%"
> Pick All ($r) MoveToPage +1p +0p + "&Left
> Page%menu/window-move.xpm%" Pick All ($r) MoveToPage -1p +0p +
> "D&own Page%menu/window-move.xpm%" Pick All ($r) MoveToPage +0p +1p

> Colorset 15 fg white, Transparent Colorset 14 fg blue, Transparent

> DestroyModuleConfig FvwmPager-Single: * *FvwmPager-Single: Columns 1

> *FvwmPager-Single: Colorset * 14 *FvwmPager-Single: HilightColorset
> * 15 *FvwmPager-Single: BalloonColorset * 16 *FvwmPager-Single:
> WindowColorsets 1 2

> *FvwmPager-Single: Balloons All *FvwmPager-Single: BalloonYOffset +3

> *FvwmPager-Single: Label 0 Main #*FvwmPager-Single: Label 1 Web &
> Mail #*FvwmPager-Single: Label 2 Devel #*FvwmPager-Single: Label 3
> Games

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 4 Aug 2003 09:55:38 +0200

> pager, it doesn't refresh the pager. so then it is no longer

You need to add this style line too:

  Style FvwmPager ParentalRelativity

> > Mail #*FvwmPager-Single: Label 2 Devel #*FvwmPager-Single: Label 3

Bye

Dominik ^_^  ^_^