Subject: FVWM: FvwmButtons Panel binding to keystroke

From: Kingsly John <[email-masked]>
Date: Sat, 9 Aug 2003 19:27:09 +0530

Is it possible to bind a Panel becoming visible/retracting to a keystroke ?

Basically I have created a Panel that swallows licq ...

*licq-holder: (Panel(indicator, smooth, down, \
        position module center mtb) "Licq (Schattenjäger)" \
       'Exec exec licq')

Would be easier to have a keyboard shortcut to retract/contract the panel
than having to move my mouse and click.

Kingsly
-- 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Remko Troncon <[email-masked]>
Date: Sun, 10 Aug 2003 10:56:30 +0200

> than having to move my mouse and click.

That isn't possible yet. I'm also interested in this feature, and was
planning to implement it one day if nobody else had yet, but i didn't have 
any time so far.

cheers,
Remko

---

From: "S. Anderson" <[email-masked]>
Date: Sun, 10 Aug 2003 03:59:33 -0600

> planning to implement it one day if nobody else had yet, but i didn't have 

I think the following will do what you want, but you will need to
modify it to suit your needs...

have fun...

DestroyFunc SeeFunc
AddToFunc SeeFunc
  + I All ($0)         Raise
  + I All ($0)         AnimatedMove +0 +0

DestroyFunc HideFunc
AddToFunc HideFunc
  + I All ($0)         Lower
  + I All ($0)         AnimatedMove -100 -100

DestroyFunc SeeHideFunc
AddToFunc SeeHideFunc
  + I All ($0 "!Sticky")   HideFunc $0
  + I All ($0 "Sticky")    SeeFunc  $0
  + I All ($0)         Stick

key f12 A A SeeHideFunc xclock

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Aug 2003 08:12:18 +0200

> than having to move my mouse and click.

All you can do is is to write a function using WarpToWindow to
move the pointer over the button and then use FakeClick to
simulate a button press.

Bye

Dominik ^_^  ^_^