Subject: FVWM: Could FVWM help protesting against SWPats?

From: "Felix E. Klee" <[email-masked]>
Date: Wed, 20 Aug 2003 20:10:36 +0200

Hi,

something else:

I'm a member of the FFII and we are organizing a demonstration on
August 27th (see the latest press release at http://swpat.ffii.org/
neues/03/demo0819/index.en.html) to make people and MEPs (members of the
European parliament) aware of the dangers surrounding the legalization
of software patents that may be up for vote in the European Parliament
as early as September 1st. The main part of the demonstration will take
place in Brussels. In addition there will be an "online demonstration"
whose idea is to simulate the effects of Software Patents by shutting
down web sites on August 27th (http://swpat.ffii.org/gruppe/demo/
index.de.html).

Is there any chance that the FVWM project participates in this event?
Note that the FVWM web site doesn't need to be closed down completely.
On http://swpat.ffii.org/gruppe/demo/index.de.html there are several
examples on how it's possible to show ones concerns without taking such
drastic measures, but there's no need to stick to the examples.

Just as a quick reminder: Many trivial things are already patented in
the US such as tabbed palettes (http://swpat.ffii.org/patente/
wirkungen/palette/index.en.html) which e.g. FVWMTabs is infringing upon.
I for one don't want to have the same situation in Europe and fear that
it will ultimately kill the competitiveness of Free Software. So this
protest is likely to be our last chance to somewhat influence the
decision making process.

Felix

-- 
To contact me in private don't reply but send mail to
    felix DOT klee AT inka DOT de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Thu, 21 Aug 2003 08:31:30 +0200

Hi there,

On 20 Aug 2003 at 20:10:36 +0200, Felix E. Klee wrote:

> Is there any chance that the FVWM project participates in
> this event?  Note that the FVWM web site doesn't need to
> be closed down completely.  On
> http://swpat.ffii.org/gruppe/demo/index.de.html there are
> several examples on how it's possible to show ones
> concerns without taking such drastic measures, but there's
> no need to stick to the examples.
> 
> Just as a quick reminder: Many trivial things are already
> patented in the US such as tabbed palettes
> (http://swpat.ffii.org/patente/
> wirkungen/palette/index.en.html) which e.g. FVWMTabs is
> infringing upon.  I for one don't want to have the same
> situation in Europe and fear that it will ultimately kill
> the competitiveness of Free Software. So this protest is
> likely to be our last chance to somewhat influence the
> decision making process.

I really like if we support this demo. IMO software  patents
are  a serious thing which effects developing free software.
Past examples as gif or even the  current  discussion  about
the  linux  kernel  show what software patents and copyright
issues can cause. 

As seen software patents lead to the situation that only big
companies,  I don't want so say any names, can afford to use
certain patented  ideas,  algorithm  or  methods.  Companies
which  have  the money will buy patents and others will have
to pay them for that.

Having our web site not available for one day for that  good
reason is really worth it.

If nobody minds I could make  the  web  site  to  be  closed
completly  (all  pages  will not work even direct links like
www.fvwm.org/documentation/manpages), closed partialy  (only
the  entry  site will not work) or I could place a statement
about software patents on each page for that day. 

Cheers, Uwe

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 21 Aug 2003 10:59:48 +0300

> Is there any chance that the FVWM project participates in this event?

If all developers agree to participate in this event (by changing the web
site in one or another way) then the FVWM name may be used to protest
software patents in Europe. If any single participant disagrees then
everyone else should fight individually without using the FVWM name.

Personally I am surelly against software patents anywhere. However,
although I support this action, I don't think it will change anything.
Anyone who advocates software patents may hardly change her mind.

> protest is likely to be our last chance to somewhat influence the

Technically I would show 2 versions of every page. The second is the real
one invoked with ?protested=1, the first version (if there is no such
variable passed) shows the protest page and a link to the real version.
This may be done for 3 days.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Aug 2003 10:29:57 +0200

> > likely to be our last chance to somewhat influence the

I fully support this and would like to see the name "fvwm" being
used in a good cause.

> about software patents on each page for that day. 

I'm for closing down the site completely (with a statement, of
course).

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Thu, 21 Aug 2003 22:22:36 +0200

Hi there,

> I'm for closing down the site completely (with a statement, of

The version of the protest page can be seen when adding 
?aswp=1 to any www.fvwm.org address.
http://www.fvwm.org?aswp=1
This site can be made as default for the protest time.

Could please anybody translate the first sentence of the
last paragraph to french? 

Regards, Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive our mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 23 Aug 2003 05:56:45 +0200

> I'm for closing down the site completely (with a statement, of

I am agree.

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 23 Aug 2003 07:11:41 +0200

> last paragraph to french? 

Done.

By the way, I've some problem to browse my local copy of the
fvwm web site. For example if I open

   file:/home/olivier/fvwm/web/index.php

with Mozilla I get the php source. Any tips so that I can
browse my local copy of the fvwm web site as the web one?

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 23 Aug 2003 07:45:48 +0200

> > I'm for closing down the site completely (with a statement, of

Ooops, I am agree to close partially the site as

is done now. How about activating it now?

Regards, Olivier

---

From: Uwe Pross <[email-masked]>
Date: Sat, 23 Aug 2003 13:09:57 +0200

Hi there,

> browse my local copy of the fvwm web site as the web one?

That's normal ;-)

php statements are processed by a web server. The php
statements produce html code which is sent to the user's
browser.
To get the web page work you need a local installed web
server with php-4.3.x module. This should be available for
most distributions. Compiling apache and php is not that
hard. I did it on my box since I got an old suse linux dist
running for which the rpms are not available.

Once it is installed and proper configured you should get
access to the web server by using :

      http://localhost/
e.g.  http://localhost/fvwm-web

If you need some help for configuration please let me know. 
I have got all the statements for http.conf which are
necessary to get the fvwm-web site work.

Thanks for the translation.

Cheers, Uwe

---

From: Uwe Pross <[email-masked]>
Date: Sat, 23 Aug 2003 13:25:57 +0200

Hi there,

> is done now. How about activating it now?

Activating is quite simple.

In file definitions.inc line 270 needs to be changed from 

if( get_user_setting("no_software_patents") || ! get_user_setting("aswp") ) {

to 

if( get_user_setting("no_software_patents") ) {

to activate the protest site by default. 
To see the fvwm sites the string ?no_software_patents=1
needs to be added to the fvwm urls. The links at the protest
site do that automatically.

I could activate it Sunday or Monday. If there are no
protest I will activate the protest at Monday at latest. I
will also insert www.fvwm.org to the protest wiki. 

I am for leaving the site closed till Thursday or Friday.

Cheers, Uwe

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 23 Aug 2003 15:29:58 +0200

> necessary to get the fvwm-web site work.

Just installed appach and add this at the end of my httpd.conf

  Alias /fvwm-web /home/olivier/fvwm/web

  <Directory /home/olivier/fvwm/web>
      Options Indexes FollowSymLinks
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
  </Directory>

works fine.

Thanks, Olivier

---

From: "Felix E. Klee" <[email-masked]>
Date: Sun, 24 Aug 2003 20:21:06 +0200

> This site can be made as default for the protest time.

That's fine! Could you add FVWM to the Wiki at
http://wiki.ael.be/index.php/OnlineDemoPartnersWebsites ? It's always
nice to have as many sites listed there as possible.

Felix

---

From: Uwe Pross <[email-masked]>
Date: Mon, 25 Aug 2003 09:14:31 +0200

Hi there,

> will also insert www.fvwm.org to the protest wiki. 

I activated the protest page and added www.fvwm.org to the
wiki. Currently there are more than 400 web sites in the
wiki - wow
  http://wiki.ael.be/index.php/OnlineDemoPartnersWebsites

The protest site at fvwm.org will be displayed if  the  http
referer  variable  does not contain www.fvwm.org. This means
that any link from a other web site to  www.fvwm.org/*  will
show  the protest page. Links within the fvwm domain supress
the protest page. 

> I am for leaving the site closed till Thursday or Friday.

Let's hope we can bring some people to think.

Cheers, Uwe