Subject: Re: Re: FVWM: Can't install on solaris

From: "Reto Buchli" <[email-masked]>
Date: Thu, 21 Aug 2003 18:42:41 +0200

Dan Espen <[email-masked]> schrieb am 21.08.03 18:21:37:
> 
> "Reto Buchli" <[email-masked]> writes:
> > Dan Espen <[email-masked]> schrieb am 21.08.03 16:11:16:
> > > 
> > > "Reto Buchli" <[email-masked]> writes:
> > > > Hi,
> > > > I'd like to use fvwm instead of CDE on a SunBlade with Solaris 5.9
> > > > This worked fine with 5.8, but now when I run
> > > > ./configure --prefix=/usr
> > > > 
> > > > I get the following:
> > > > .
> > > > checking for sig_atomic_t... yes
> > > > checking for function prototypes... yes
> > > > checking whether setvbuf arguments are reversed... no
> > > > checking for select... yes
> > > > checking for unistd.h... (cached) yes
> > > > checking for sys/types.h... (cached) yes
> > > > checking for sys/time.h... (cached) yes
> > > > checking for sys/select.h... (cached) yes
> > > > checking sys/socket.h usability... no
> > > > checking sys/socket.h presence... yes
> > > > configure: WARNING: sys/socket.h: present but cannot be compiled
> > > > configure: WARNING: sys/socket.h: check for missing prerequisite headers?
> > > > configure: WARNING: sys/socket.h: proceeding with the preprocessor's resu
> > lt
> > > > configure: WARNING:     ## ------------------------------------ ##
> > > > configure: WARNING:     ## Report this to [email-masked]. ##
> > > > configure: WARNING:     ## ------------------------------------ ##
> > > > checking for sys/socket.h... yes
> > > > checking argument types of select()... configure: error: can't determine 
> > argu
> > > > ment types
> > > > 
> > > > I'm using autoconf 2.57.
> > > > On the gnu-page they say, this is coming from the application.
> > > > 
> > > > Does anyone have an idea what I can do to install fvwm on my solaris? 
> > > 
> > > With autoconf 2.13 it builds without problems.
> > Thank's for the answer, but  if I try autoconf 2.13 I get the same error as w
> > ith 2.57.
> 
> Respond to [email-masked].
Sorry about that.
> 
> Time for more information.
> 
> I'm configured to use gcc, I can try cc if that's what you are using.
I have both, but when I see it correct, I'ts using gcc. 
It states it finds gnu c. I'm not sure how to say which one it uses really.

> 
> Did you remove config-cache?
Yes, I did.
> 
> Are you using a snapshot or CVS?
Just the ordinary download function, no CVS.

> 
> If CVS did you run automake --add-missing && autoreconf?
> 
> -- 
> Dan Espen                           E-mail: [email-masked]
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

Thanks.
__________________________________________________________________________
Die sicherste Form der Kommunikation: E-Mails verschluesseln, Spam-Filter,
Adressverifizierung, digitale Unterschrift: http://freemail.web.de

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Aug 2003 12:53:52 -0400

"Reto Buchli" <[email-masked]> writes:
> > > > > configure: WARNING: sys/socket.h: check for missing prerequisite head
> > > > > configure: WARNING: sys/socket.h: proceeding with the preprocessor's 
> > > > > checking argument types of select()... configure: error: can't determ
> > > Thank's for the answer, but  if I try autoconf 2.13 I get the same error 
> > > as with 2.57.
> > 

Hmm, works on my Solaris 9 system, but not yours, using the
same autoconf and compiler...

Either you are missing a Solaris patch or ...

I'm pretty sure you will see details on the problem its having
with sys/socket.h in config.log.  Maybe you should look at that.