Subject: FVWM: Can't install on solaris

From: "Reto Buchli" <[email-masked]>
Date: Thu, 21 Aug 2003 10:06:26 +0200

Hi,
I'd like to use fvwm instead of CDE on a SunBlade with Solaris 5.9
This worked fine with 5.8, but now when I run
./configure --prefix=/usr

I get the following:

.
.
.
checking for sig_atomic_t... yes
checking for function prototypes... yes
checking whether setvbuf arguments are reversed... no
checking for select... yes
checking for unistd.h... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for sys/select.h... (cached) yes
checking sys/socket.h usability... no
checking sys/socket.h presence... yes
configure: WARNING: sys/socket.h: present but cannot be compiled
configure: WARNING: sys/socket.h: check for missing prerequisite headers?
configure: WARNING: sys/socket.h: proceeding with the preprocessor's result
configure: WARNING:     ## ------------------------------------ ##
configure: WARNING:     ## Report this to [email-masked]. ##
configure: WARNING:     ## ------------------------------------ ##
checking for sys/socket.h... yes
checking argument types of select()... configure: error: can't determine argument types

I'm using autoconf 2.57.
On the gnu-page they say, this is coming from the application.

Does anyone have an idea what I can do to install fvwm on my solaris? 

INSTALL.fvwm only states problems with xpm for solaris, but xpm is found.
Any help would be appreciated. 

Thanks, Reto

__________________________________________________________________________
Die sicherste Form der Kommunikation: E-Mails verschluesseln, Spam-Filter,
Adressverifizierung, digitale Unterschrift: http://freemail.web.de

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Aug 2003 10:23:59 +0200

> On the gnu-page they say, this is coming from the application.

Huh?  We are using the stock AC_FUNC_SELECT test.  If that fails,
is *is* an autoconf bug.  Please do report this to the autoconf
developers.

> Does anyone have an idea what I can do to install fvwm on my solaris? 

Try a different autoconf version.  Or delete the corresponding
section from the configure script and hope it works without a
check.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Aug 2003 10:09:39 -0400

> Does anyone have an idea what I can do to install fvwm on my solaris? 

With autoconf 2.13 it builds without problems.

-- 
Dan Espen                           E-mail: [email-masked]