Subject: FVWM: Bringing an iconified window on _current_ page

From: parv <[email-masked]>
Date: Sat, 2 Aug 2003 15:19:14 -0400

Hi,

Is it possible (in fvwm 2.5.7) to display/deiconify a iconified
window on the current page, rather than moving to the page where the
iconified window used to be (to see the deiconified window)?

If this could be set per window name/resource, that would be swell.

Here is one idea[0]...

  - make the iconified window sticky
  - deiconify
  - make it unsticky

  [0] http://groups.google.com/groups?selm=vaf4t2bm75x.fsf%40ramses.ls6.uni-do

...WRT above plan, would making a iconified sticky happen first, if
at all, before deiconification?

I suppose, window could me styled w/ 'SkipMapping' before
deiconification; turned off after being unsticky...

  - make the iconified window sticky
  - apply SkipMapping style
  - deiconify
  - make it unsticky
  - apply !SkipMapping style

...what do you think?

  - Parv

-- 
A programmer, budding Unix system administrator, and amateur photographer
seeks employment:  http://www103.pair.com/parv/work/

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 2 Aug 2003 23:27:37 +0300

> If this could be set per window name/resource, that would be swell.

StickyIcon should do exactly what you want:

  Style XTerm StickyIcon

Regards,
Mikhael.

---

From: parv <[email-masked]>
Date: Sat, 2 Aug 2003 18:34:36 -0400

in message <[email-masked]>,
wrote Mikhael Goikhman thusly...
> > window on the current page ... ?
> 

I be damned!  Yes, it is exactly what i wanted; sorry to miss it in
RTFM.

Thanks much.

  - Parv

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 4 Aug 2003 09:52:31 +0200

>   - apply !SkipMapping style

For the archives:

  AddToFunc deiconify_on_current_page
  + I movetopage
  + I iconify off

But in this specific case:

  Style <window name> StickyIcon

Bye

Dominik ^_^  ^_^