Subject: Re: Re: FVWM: Can't install on solaris

From: "Reto Buchli" <[email-masked]>
Date: Thu, 21 Aug 2003 13:10:10 +0200

Hi Dominik

I tried to remove the check of socket.h, but then make fails somewhere.
Now I placed a question in the qnu-mailinglist, as you said.

Thank you for your fast answer.
Reto

[email-masked] schrieb am 21.08.03 10:23:38:
> 
> On Thu, Aug 21, 2003 at 10:06:26AM +0200, Reto Buchli wrote:
> > Hi,
> > I'd like to use fvwm instead of CDE on a SunBlade with Solaris 5.9
> > This worked fine with 5.8, but now when I run
> > ./configure --prefix=/usr
> > 
> > I get the following:
> > 
> > .
> > .
> > .
> > checking for sig_atomic_t... yes
> > checking for function prototypes... yes
> > checking whether setvbuf arguments are reversed... no
> > checking for select... yes
> > checking for unistd.h... (cached) yes
> > checking for sys/types.h... (cached) yes
> > checking for sys/time.h... (cached) yes
> > checking for sys/select.h... (cached) yes
> > checking sys/socket.h usability... no
> > checking sys/socket.h presence... yes
> > configure: WARNING: sys/socket.h: present but cannot be compiled
> > configure: WARNING: sys/socket.h: check for missing prerequisite headers?
> > configure: WARNING: sys/socket.h: proceeding with the preprocessor's result
> > configure: WARNING:     ## ------------------------------------ ##
> > configure: WARNING:     ## Report this to [email-masked]. ##
> > configure: WARNING:     ## ------------------------------------ ##
> > checking for sys/socket.h... yes
> > checking argument types of select()... configure: error: can't determine argument types
> > 
> > I'm using autoconf 2.57.
> > On the gnu-page they say, this is coming from the application.
> 
> Huh?  We are using the stock AC_FUNC_SELECT test.  If that fails,
> is *is* an autoconf bug.  Please do report this to the autoconf
> developers.
> 
> > Does anyone have an idea what I can do to install fvwm on my solaris? 
> 
> Try a different autoconf version.  Or delete the corresponding
> section from the configure script and hope it works without a
> check.
> 
> Bye
> 
> Dominik ^_^  ^_^
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

__________________________________________________________________________
Die sicherste Form der Kommunikation: E-Mails verschluesseln, Spam-Filter,
Adressverifizierung, digitale Unterschrift: http://freemail.web.de

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Aug 2003 11:55:05 -0400

"Reto Buchli" <[email-masked]> writes:
> Dan Espen <[email-masked]> schrieb am 21.08.03 16:11:16:
> > 
> > "Reto Buchli" <[email-masked]> writes:
> > > Hi,
> > > checking argument types of select()... configure: error: can't determine 
> argu
> > > ment types
> > > 
> > > I'm using autoconf 2.57.
> > With autoconf 2.13 it builds without problems.
> Thank's for the answer, but  if I try autoconf 2.13 I get the same error as w
> ith 2.57.

Respond to [email-masked].

Time for more information.

I'm configured to use gcc, I can try cc if that's what you are using.

Did you remove config-cache?

Are you using a snapshot or CVS?

If CVS did you run automake --add-missing && autoreconf?

-- 
Dan Espen                           E-mail: [email-masked]