Subject: FVWM: Oddities in 2.4.16

From: "Dameron, Gregg" <[email-masked]>
Date: Wed, 13 Aug 2003 14:19:16 -0600

Setup:  fvwm 2.4.16, fvwm-themes 0.6.2 on Solaris 8, dual-head non-Xinerama.

Since upgrading from 2.4.7, and with no substantial changes to my config (other than converting deprecated single-letter variables to their longer counterparts), I am seeing two intermittent startup problems.

1)  Error messages of the form:
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> *** internal error ***
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> Request 7, Error 8, EventType: 20
or
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> *** internal error ***
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> Request 7, Error 8, EventType: 12
or
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> *** internal error ***
    [FVWM.0][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 12
or
    [FVWM.1][FvwmErrorHandler]: <<ERROR>> *** internal error ***
    [FVWM.1][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 2

Whatever causes these errors appears to be self-healing:  when I get one of these, the desktop usually comes up normally anyway.  What do these errors signify?

2)  Failure to execute the StartFunction and InitFunction on *one* of the displays.  Fvwm2 and FvwmTheme are running, my Key and Mouse bindings are all fine, but none of the Modules started in StartFunction are running, nor is the process I "Exec" in InitFunction.  Happens on about one-in-ten logins.  Ctrl-Alt-Escape doesn't help; restarting is required.  (On the opposite display, everything is fine.)  Any help is appreciated.

Gregg Dameron

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 14 Aug 2003 10:43:19 +0200

On Wed, Aug 13, 2003 at 02:19:16PM -0600, Dameron, Gregg wrote:
> Since upgrading from 2.4.7, and with no substantial changes to
> my config (other than converting deprecated single-letter
> variables to their longer counterparts), I am seeing two
> intermittent startup problems.
> 

An XReparentWindow() call caused a BadMatch error.  The error was
delivered with a MapRequest event.  That probably means that fvwm
tried to decorate a window but the window died before it could
do so.  You can ignore it or try to identify the faulty window by
reducing your config until it goes away.

>     [FVWM.0][FvwmErrorHandler]: <<ERROR>> Request 7, Error 8, EventType: 12

The same as above, except that the error occured with an Expose
event.

>     [FVWM.0][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 12

XChangeGC() was called with an invalid font.  Please check which
of your font specs causes the error and strip down your config
file for us to reproduce the problem.  Olivieer may need
additional information like the compiled in font related libs and
their version numbers.

>     [FVWM.1][FvwmErrorHandler]: <<ERROR>> Request 56, Error 7, EventType: 2

Dito.

> Whatever causes these errors appears to be self-healing:  when I
> get one of these, the desktop usually comes up normally anyway. 
> What do these errors signify?

You can look up these X error codes in fvwm/doc/error_codes.

> 2)  Failure to execute the StartFunction and InitFunction on
> *one* of the displays.  Fvwm2 and FvwmTheme are running, my Key
> and Mouse bindings are all fine, but none of the Modules started
> in StartFunction are running, nor is the process I "Exec" in
> InitFunction.  Happens on about one-in-ten logins.
> Ctrl-Alt-Escape doesn't help; restarting is required.  (On the
> opposite display, everything is fine.)  Any help is appreciated.

Bye

Dominik ^_^  ^_^