Subject: FVWM: ModulePath

From: Uwe Pross <[email-masked]>
Date: Thu, 21 Aug 2003 14:46:41 +0200

Hi there,

I often work on different machines on the same network. The
machines have different OS-versions installed and different
versions of libraries avialable. To get the right
fvwm-version I try to start different versions in my
.xinitrc:

if /home/science/pross/installed/fvwm-2.5.7-installed/bin/fvwm -f /home/science/pross/.fvwm/.fvwm2rc-2.5.7  2> ~/.fvwm.log ; then 
    exit 0 ; 
elif /var/tmp/fvwm-2.5.6-installed/bin/fvwm -f /home/science/pross/.fvwm/.fvwm2rc-2.5.6  2> ~/.fvwm.log ; then 
    exit 0 ; 
elif ... 

My problem is that I need for each version a config file
since the ModulePath differs from version to version. All my
.fvwm2rc*-files look like this:

ModulePath /var/tmp/fvwm-2.5.6-installed/libexec/fvwm/2.5.6
Read FvwmConfig

Where FvwmConfig contains configuration statements for all
version. 

Is there a way the avoid the setting of FvwmModulePath? It
might be compiled in fvwm. 

Thanks in advance.

Regards Uwe
-- 
  ,_,   For personal reply/mail put "fvwm"
 (O,O)  in the subject.
 (   )  Otherwise I won't receive our mail.
--"-"----------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Aug 2003 15:12:57 +0200

> might be compiled in fvwm. 

Why don't you just use the compiled in default?  Delete the
ModulePath line and you should be fine.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 21 Aug 2003 09:12:44 -0400

> might be compiled in fvwm. 

The module path IS compiled into fvwm.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Uwe Pross <[email-masked]>
Date: Thu, 21 Aug 2003 15:25:26 +0200

Hi there,

> ModulePath line and you should be fine.

Thanks - Works on the machine I am now. Others will be
checked in the next days ;-)

My config has been grown for a while but I have never put
the ModulePath in question marks - It was just in the
config :-)

I had the same problem at home when I used stable and
unstable version with the same config - Life can be easy.

Regards, Uwe