Subject: FVWM: Fvwm 2.5.7 with XDirectFB 1.0

From: Ahmed Fasih <[email-masked]>
Date: Tue, 15 Jul 2003 20:52:31 -0700 (PDT)

Hi all,

I'm running gentoo, fvwm 2.5.7 development version,
DirectFB v0.9.17, and XDirectFB 1.0. It works
gloriously except for a couple of problems, one of
which is fvwm related. 

I run 3x3 desktops, and when I move my cursor to an
edge of a screen, the desktop changes. That is good,
but the problem is, the cursor remains at that edge of
the screen on the new desktop... Par exemple: I am in
the center desktop, move mouse to the left, desktop
shifts, but cursor remains on the far left of the
screen.

I had fvwm 2.4.14, then got 2.5.7, same problem with
both. Is there some way I can work around this within
the fvwm config, or is it something with (X)DirectFB?

Thanks,

Ahmed

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 16 Jul 2003 07:53:55 +0200 (CEST)

> the fvwm config, or is it something with (X)DirectFB?

Have you tried running without using DirectFB?
This is one of the reported bugs since before.
I cannot reproduce it. Maybe it's related to DirectFB.

//Marcus

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 16 Jul 2003 11:01:21 +0200

> the fvwm config, or is it something with (X)DirectFB?

Seems that it is a XDirectFB problem (not sure). With 2.5.7 you may
found a workaround by using the EdgeCommand command (man fvwm).

Regards, Olivier

---

From: Ahmed Fasih <[email-masked]>
Date: Wed, 16 Jul 2003 03:24:23 -0700 (PDT)

So sorry for not making clearer. Without XDFB, I have
absolutely no problems (sorry if my previous message
made out that it was Fvwm's fault). Both 2.4.14 and
2.5.7 work flawlessly without XDFB, it is only when I
attempt to use it, this problem strikes.

Another related issue (that is also only present with
XDirectFB running) is that my keyboard mappings for
fvwm (for Control, Meta, and Shift) only work for
those buttons on the left side of my keyboard. Their
counterparts on the right side donot function. Again,
this is only present when i use XDFB (I just run
startxdfb instead of startx), which I'd like to know
how to fix.

I will look into the EdgeCommand, thanks. Is there any
other settings or commands that might assist this
issue?

Thanks again,

Ahmed