Subject: FVWM: ./configure doesn't find my xft

From: "[email-masked]" <[email-masked]>
Date: Tue, 22 Jul 2003 16:30:17 +0200

Hi,

I'd be very happy if someone could help me make ./configure (from
fvwm-2.5.7) find my xft. xft is definitly installed (via the gentoo
linux portage mechanism).

After I type ./configure I receive a table with the things that are
going to be supported, however not xft.

Any idea?
Thanks
 Felix

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Jul 2003 18:29:40 +0300

> going to be supported, however not xft.

Try one of the latest snapshots instead.

Regards,
Mikhael.

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 22 Jul 2003 17:46:16 +0200

> Try one of the latest snapshots instead.

Thank You,

but even with the latest snapshot I get the following (see below). As
other apps like OpenOffice seem to use xft (or does it have its own font
mechanism?) I still don't know what I could do next...
Thanks again,
 Felix

[...]

checking for freetype-config... (cached) /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... yes
checking for fontconfig-config... (cached) no
checking for Fontconfig - version >= 1.0.1... yes
checking for xft-config... (cached) /usr/bin/xft-config
checking for Xft - version >= 2.0.0... no
*** The Xft test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.
checking for XftFontOpen in -lXft... no

[...]

FVWM Configuration:

  Version:     2.5.8 (from cvs)

  Executables: /usr/local/bin
  Man pages:   /usr/local/man
  Modules:     /usr/local/libexec/fvwm/2.5.8
  Data files:  /usr/local/share/fvwm
  Perl lib:    /usr/local/share/fvwm/perllib
  Locale msg:  /usr/local/share/locale  ar fr

  With Asian bi-direct. text support? no: No fribidi-config found in
PATH  With Gettext Native Lang Support?   yes (libc)
  With GTK+ required for FvwmGtk?     yes
  With GDK image support in FvwmGtk?  yes
  With GNOME libs support in FvwmGtk? no: Can't find working
gnome-config  With PNG image support?             yes
  With ReadLine sup. in FvwmConsole?  yes
  With RPlay support in FvwmEvent?    no: Can't find working librplay
  With Shaped window support?         yes
  With Shared memory for XImage?      yes
  With Session Management support?    yes
  With Mouse strokes (gestures)?      no: Can't find working libstroke
  With Xinerama multi-head support?   yes
  With Xft anti-alias font support?   no: Can't detect Xft 1 or 2 and
fontconfig  With XPM image support?             yes
  With Xrender image support?         yes

See INSTALL.fvwm for the description of what this may mean.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 24 Jul 2003 07:46:23 +0200

[email-masked]:

> > > fvwm-2.5.7) find my xft. xft is definitly installed (via the
> > > gentoo linux portage mechanism).
> > > 
> > > After I type ./configure I receive a table with the things that
> > > are going to be supported, however not xft.
> > 
> other apps like OpenOffice seem to use xft (or does it have its own
> font mechanism?) I still don't know what I could do next...
> Thanks again,
>  Felix
> 
> 

Hi,
now I've tried to activate xft with fvwm (snapshot from 2003-07-23) via
uninstalling xft and installing a brand new version from xfree86
(4.3.99) as someone told me that xft is integrated in xfree86. But still
fvwm's ./configure doesn't find xft on my system. Here is an extract
from ./configure's output.
Someone else mentioned that all this is due to missing
fontconfig-config?

 Felix

[...]

checking for FreeType - version >= 6.1.0... yes
checking for fontconfig-config... (cached) no
checking for Fontconfig - version >= 1.0.1... yes
checking for xft-config... (cached) no
checking for Xft - version >= 2.0.0... checking for XftFontOpen in
-lXft... yes
checking for XftConfigSubstitute in -lXft... (cached) no

[...]

PATH
  With Gettext Native Lang Support?   yes (libc)
gnome-config
  With PNG image support?             yes
  With Xft anti-alias font support?   no: Can't detect Xft 1 or
fontconfig
  With XPM image support?             yes