Subject: FVWM: install new screen saver ?

From: Nguyen Vu Hung <[email-masked]>
Date: Sat, 12 Jul 2003 01:37:10 +0900 (JST)

Hi all,

I am using fvwm 2.5.7 on redhat 9 default installation with errata
up-to-dated. The kernel is 2.4.20-18.9.
When I right click onto my desktop, A menu shows up: 

FVWM Root Menu
Terminal
Top
Shell
Programms
Modules
Settings
Documents
ScreenSaver
Restart
Exit Fvwm

But when I clicked "Screen Saver", nothing happened.
How can I install a screen saver with password protect enabled on fvwm?

Thanks in advance.

Hung Vu

+----------------------------------------------------------+
|            Nguyen Vu Hung( [email-masked] )              |
| The University of Electro-Communications, Tokyo, Japan   |
| Takeshi's small space http://www.fedu.uec.ac.jp/~vuhung/ |
|  I am looking for a job in Japan or Hanoi. My resume     |
|  http://www.fedu.uec.ac.jp/~vuhung/resume-03.txt         |
+----------------------------------------------------------+

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 12 Jul 2003 01:57:29 +0300

> How can I install a screen saver with password protect enabled on fvwm?

You should have xlock or xscreensaver rpms installed on your system.

Then find a definition of your root menu and its submenus, probably in
the file ~/.fvwm/.fvwm2rc and then fix the entries that do not work.
Search the fvwm man page for the correct menu syntax.

You probably want something like this:

  AddToMenu MenuScreenSavers
  + "Screen Saver" Exec exec xlock -nolock
  + "Lock with password" Exec exec xlock -nice 19

It is also possible to create the screensaver menu automatically using
fvwm-menu-xlock script, read its man page.

Regards,
Mikhael.

---

From: Nguyen Vu Hung <[email-masked]>
Date: Sun, 13 Jul 2003 04:13:10 +0900 (JST)

> fvwm-menu-xlock script, read its man page.

Thank you Mikhael, I got i worked.

Hung Vu