Subject: FVWM: sourcing other text files

From: Eduardo Alvarez <[email-masked]>
Date: Sun, 20 Jul 2003 19:15:14 +0000

Hello, all

One (potentially very silly) question:  is there a command that reads
another text file?  I want to have a different file for the window styles,
and, although I figure I could use PipeRead cat <filename>, I wondered if
there's another method.

-- 
Eduardo Alvarez			http://www.great-atuin.net/~punga
						(offline, at the moment)
"Stercus, stercus stercus, moriturus sum"
    			-- Rincewind the Wizard, "Interesting Times"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Jul 2003 19:16:23 -0400

> and, although I figure I could use PipeRead cat <filename>, I wondered if

Read

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Phil Stracchino <[email-masked]>
Date: Sun, 20 Jul 2003 20:08:30 -0400

> > and, although I figure I could use PipeRead cat <filename>, I wondered if

Now what *I'd* really like is to be able to make this conditional, or
have it evaluate a path.

Something like, say, 

	Read $HOME/bin/$OS/os-specific-settings

Is this possible?

-- 
 .*********  Fight Back!  It may not be just YOUR life at risk.  *********.
 : phil stracchino : unix ronin : renaissance man : mystic zen biker geek :
 :  [email-masked] : [email-masked] : [email-masked]  :
 :   2000 CBR929RR, 1991 VFR750F3 (foully murdered), 1986 VF500F (sold)   :
 :    Linux Now!   ...Because friends don't let friends use Microsoft.    :
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Jul 2003 20:25:31 -0400

> 	Read $HOME/bin/$OS/os-specific-settings

For conditional configs, PipeRead is usually best, but
"Read" will expand environment variables.

I think the preferred syntax is:

Read $[HOME]/bin/$[OS]/os-specific-settings

---

From: Phil Stracchino <[email-masked]>
Date: Sun, 20 Jul 2003 22:15:10 -0400

> Read $[HOME]/bin/$[OS]/os-specific-settings

Cool.  That'll work beautifully.  Now I can have a single .fvwm2rc that
works on all my $UNIX machines, as well as a single .bash_profile.

Thanks!  :)