Subject: FVWM: Build Failures on SunOS 5.7:

From: Harald Dunkel <[email-masked]>
Date: Sat, 5 Jul 2003 21:00:18 +0200

Hi folks,

If I try to build fvwm 2.5.7 on SunOS 5.7, then I get this
error message:

cc -I/usr/local/include -L/usr/local/lib -R/usr/local/lib -DFVWM_MODULEDIR=\"/usr/local/stow/fvwm-2.5.7/libexec/fvwm/2.5.7\" -DFVWM_DATADIR=\"/usr/local/stow/fvwm-2.5.7/share/fvwm\" -DFVWM_CONFDIR=\"/usr/local/stow/fvwm-2.5.7/etc\" -DFVWM_COLORSET_PRIVATE=1 -DLOCALEDIR=\"/usr/local/stow/fvwm-2.5.7/share/locale\" -I/usr/local/include  -L/usr/local/lib -R/usr/local/lib -o fvwm  menus.o style.o events.o move_resize.o add_window.o builtins.o borders.o icons.o fvwm.o module_interface.o frame.o virtual.o stack.o ewmh.o menustyle.o session.o colorset.o placement.o functions.o gnome.o focus.o conditional.o geometry.o ewmh_events.o windowlist.o menuitem.o ewmh_icons.o decorations.o update.o expand.o misc.o functable.o bindings.o cursor.o colormaps.o ewmh_conf.o modconf.o read.o menucmd.o ewmh_names.o icccm2.o schedule.o windowshade.o focus_policy.o repeat.o execcontext.o colors.o menudim.o -L../libs -lfvwm  -L/usr/openwin/lib -R/usr/openwin/lib -lXpm  -lSM -lICE  -lXext -lX11 -lsocket  -lnsl -lm    -lpng -lz  
Undefined                       first referenced
 symbol                             in file
XRenderCreatePicture                ../libs/libfvwm.a(FRender.o)
ld: fatal: Symbol referencing errors. No output written to fvwm
gmake[2]: *** [fvwm] Error 1
gmake[2]: Leaving directory `/u/dunkel/fvwm-2.5.7/fvwm'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/u/dunkel/fvwm-2.5.7'
gmake: *** [all] Error 2

Configure said about my Sun:

% export IMLIBCONF=/usr/local/bin/imlib-config
% export GTK_CONFIG=/usr/local/bin/gtk-config 
% export CFLAGS=-I/usr/local/include
% export LDFLAGS"=-L/usr/local/lib -R/usr/local/lib"
% export CC="cc $CFLAGS $LDFLAGS"
% ./configure --prefix=/usr/local/stow/fvwm-2.5.7 
:
:
  With Asian bi-direct. text support? no: No fribidi-config found in PATH
  With Gettext Native Lang Support?   yes (libc)
  With GTK+ required for FvwmGtk?     yes
  With GDK image support in FvwmGtk?  yes
  With GNOME libs support in FvwmGtk? no: Can't find working gnome-config
  With PNG image support?             yes
  With ReadLine sup. in FvwmConsole?  yes
  With RPlay support in FvwmEvent?    no: Can't find working librplay
  With Shaped window support?         yes
  With Shared memory for XImage?      yes
  With Session Management support?    yes
  With Mouse strokes (gestures)?      no: Can't find working libstroke
  With Xinerama multi-head support?   no: Failed to detect libXinerama
  With Xft anti-alias font support?   no: Can't detect freetype2 >= 6.1.0/2.0.6
  With XPM image support?             yes
  With Xrender image support?         no: Failed to detect libXrender

Any help would be highly appreciated.

Regards

Harri
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Sun, 6 Jul 2003 07:31:48 +0200

On Sat, Jul 05, 2003 at 09:00:18PM +0200, Harald Dunkel wrote:
> [snip]

Fixed in the current cvs. You may use the next snapshot.

Thanks, Olivier