Subject: FVWM: Transparent menus

From: stu <[email-masked]>
Date: Wed, 16 Jul 2003 12:29:45 +0200

Is it possible to have transparent menus with fvwm 2.5.7?
If so, how would I go about doing it?

Regards
-- 
Stuart Logie
Programmer

UNIVERSAL COMPUTER SERVICES (PTY) LTD
Tel : (011) 712 1371   Cell : 082 902 5632
Fax : (011) 339 3421
Internet : http://ucs.co.za
Email    : [email-masked]

To err is human,
To purr feline.
                -- Robert Byrne

Powered by Debian GNU/Linux - testing/unstable
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Jul 2003 00:04:38 +0300

> If so, how would I go about doing it?

It is possible. You should define a colorset with RootTransparent buffer
("buffer" is optional, read FvwmTheme man page) and set a root image
using either Esetroot or "fvwm-root -r".

  Colorset 5 RootTransparent buffer, Tint rgb:00/30/30
  MenuStyle * Colorset 5

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Jul 2003 00:59:32 +0300

>   Colorset 5 RootTransparent buffer, Tint rgb:00/30/30

Sorry, I meant:

  Colorset 5 RootTransparent buffer, Tint rgb:00/30/30 20
  MenuStyle * MenuColorset 5

Regards,
Mikhael.

---

From: stu <[email-masked]>
Date: Thu, 17 Jul 2003 12:36:12 +0200

On Thu, 17 Jul 2003 00:59:32 +0300
Mikhael Goikhman <[email-masked]> wrote:

> > It is possible. You should define a colorset with RootTransparent
> > buffer("buffer" is optional, read FvwmTheme man page) and set a root
> > image using either Esetroot or "fvwm-root -r".
> > 

Brilliant! Thank you very much. 

Fvwm rocks!!

-- 
Stuart Logie
Programmer

To err is human,
To purr feline.
                -- Robert Byrne

---

From: Remko Troncon <[email-masked]>
Date: Fri, 18 Jul 2003 13:37:15 +0200

>   MenuStyle * MenuColorset 5

Keith Packard used his XRender extension to have translucent menus in
TWM (http://keithp.com/~keithp/render/, bottom of the page). Do you
think it would be feasible to get this implemented in FVWM someday ?

cheers,
Remko

---

From: "B. Zhang" <[email-masked]>
Date: Tue, 29 Jul 2003 15:17:35 +0200

> using either Esetroot or "fvwm-root -r".

I want to have a transparent menu with the root image given by xsetroot:
xsetroot -mod 4 4 -bg rgb:10/18/20 -fg rgb:30/38/40

I do this by using gimp to grab "xsetroot -mod 4 4 -bg rgb:10/18/20 -fg
rgb:30/ 38/40" to a image file.
Is there a simple way ?

Regards,
Benoit