Subject: FVWM: problems with iconman

From: Jacques Wainer <[email-masked]>
Date: 07 Jul 2003 20:06:57 -0300

fvwm folks

I am having a problem with FvwmIconMan. With the configuration below
(with work in a previus version of fvwm) I get the following problem -
the buttons only show up in the manager if the window is not iconic -
if the window is iconified the button disappes from the manager

from .fvwm2rc

*FvwmIconMan: managergeometry 5x3
*FvwmIconMan: font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconMan: resolution page
*FvwmIconMan: ButtonGeometry 60x0
*FvwmIconMan: action      Mouse   1 N sendcommand "Iconify"
*FvwmIconMan: action      Mouse   2 N sendcommand "Iconify 1"
*FvwmIconMan: action      Mouse   3 N sendcommand "FvwmIdent"

fvwm version

(localhost)% fvwm -version
FVWM version 2.4.15 compiled on Feb 20 2003 at 13:08:43
with support for: ReadLine, Stroke, XPM, GNOME WM hints, Shape, SM, Xinerama

but the same config works for 2.4.8

thanks 

jacques

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Jul 2003 08:36:10 +0200

> if the window is iconified the button disappes from the manager

I see no such problem in 2.4.15, 2.4.16 and the latest development
version.  Please post your full configuration file and step by
step instructions to reproduce the problem.

> *FvwmIconMan: action      Mouse   3 N sendcommand "FvwmIdent"

Bye

Dominik ^_^  ^_^

---

From: Jacques Wainer <[email-masked]>
Date: 17 Jul 2003 09:10:18 -0300

you were right. the problem was that I had a

Style * NoIcon

which on 2.4.8 worked as 

Style * IconBox 'none'

but on 2.4.15 makes any representation of the iconic window desapear
(including from IconMan)

Thanks

jacques

Dominik Vogt <[email-masked]> writes:

| On Mon, Jul 07, 2003 at 08:06:57PM -0300, Jacques Wainer wrote:
| > 
| > fvwm folks
| > 
| > I am having a problem with FvwmIconMan. With the configuration below
| > (with work in a previus version of fvwm) I get the following problem -
| > the buttons only show up in the manager if the window is not iconic -
| > if the window is iconified the button disappes from the manager
| 
| I see no such problem in 2.4.15, 2.4.16 and the latest development
| version.  Please post your full configuration file and step by
| step instructions to reproduce the problem.
| 
| > from .fvwm2rc
| > 
| > 
| > *FvwmIconMan: managergeometry 5x3
| > *FvwmIconMan: font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
| > *FvwmIconMan: resolution page
| > *FvwmIconMan: ButtonGeometry 60x0
| > *FvwmIconMan: action      Mouse   1 N sendcommand "Iconify"
| > *FvwmIconMan: action      Mouse   2 N sendcommand "Iconify 1"
| > *FvwmIconMan: action      Mouse   3 N sendcommand "FvwmIdent"
| > 
| > 
| > fvwm version
| 
| Bye
| 
| Dominik ^_^  ^_^