Subject: FVWM: New window does not get focus

From: Zhang Le <[email-masked]>
Date: Wed, 9 Jul 2003 16:17:54 +0800

Hi all, 
  I'm using fvwm 2.5.5 and find that whenever I open a new window I have to
  click it to make it focused. This is very annoying.

  Is there a easy way to make new windows get focused when show up?
  I guess it results in some configurations I put in my fvwm2rc (copied
  from others, but can not figure out where is the problem).

  Thanks in advance.
-- 
                                     Sincerely yours,
                                            Zhang Le

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eduardo Alvarez <[email-masked]>
Date: Wed, 9 Jul 2003 12:00:00 +0000

On Wed, Jul 09, 2003 at 04:17:54PM +0800, Zhang Le wrote:

Insert a GrabFocus style, maybe like so:

style * GrabFocus

that should enforce this on everything.

-- 
Eduardo Alvarez			http://www.great-atuin.net/~punga

"Stercus, stercus stercus, moriturus sum"
    			-- Rincewind the Wizard, "Interesting Times"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 9 Jul 2003 19:15:32 +0300

>   from others, but can not figure out where is the problem).

If you need to click to windows to get them focused then remove this line
from your configuration:

  Style * ClickToFocus

The default focus policy is MouseFocus, you may try SloppyFocus too.
And try GrabFocus for new windows to get focus even if they are not under
the mouse pointer.

If you have a lot of settings and don't know which ones may affect your
focus policy search for "Focus" or "FP" in your configuration and either
comment these commands out or contact the man page to read what they mean.

Regards,
Mikhael.

---

From: Zhang Le <[email-masked]>
Date: Thu, 10 Jul 2003 08:04:55 +0800

> that should enforce this on everything.
It does just what I want, Cool!
Thank you.
-- 
                                     Sincerely yours,
                                            Zhang Le

---

From: Zhang Le <[email-masked]>
Date: Thu, 10 Jul 2003 08:21:26 +0800

Hi, 
   I am customizing FvwmTaskBar so it looks and works like Win9x.
   Two problems:
      1. There is always a one pixel border around FvwmTaskBar, how to get
      rid of it?
      2. How to minimize an active window when clicking on its
      corresponding button on FvwmTaskBar?
      For example, when I first click a window on FvwmTaskBar with
      button1 that window should be brought to front. And if I click
      that button again using button1 I want that window get minimized
      (just like win9x).
      How to achieve this? 

   Here is my FvwmTaskBar configuration (not work fine) I can only make
   window active using mouse button1 but can not iconify them with
   button1:

    AddToFunc DeiconifyRaiseAndFocus
    + I Iconify off
    + I Raise
    + I Focus

    AddToFunc ToggleIconify
    + I Current [AcceptsFocus] Iconify
    + I Current [!AcceptsFocus] Raise,Focus

    Style  "FvwmTaskBar"	NoTitle, Sticky, NoHandles
    Style  "FvwmTaskBar"	StaysOnTop, FixedSize, WindowListSkip, CirculateSkip
    *FvwmTaskBar: Action Click1 DeiconifyRaiseAndFocus
    *FvwmTaskBar: Action Click3 Iconify true,  Lower
    *FvwmTaskBar: Action Click2 Iconify false, Raise
-- 
                                     Sincerely yours,
                                            Zhang Le

---

From: Zhang Le <[email-masked]>
Date: Thu, 10 Jul 2003 08:09:16 +0800

On Wed, Jul 09, 2003 at 07:15:32PM +0300, Mikhael Goikhman wrote:
My configuration is:
Style *           ClickToFocus, ClickToFocusPassesClick,MouseFocusClickRaises
> And try GrabFocus for new windows to get focus even if they are not under
I find SloppyFocus does not work as I expect. However, GrabFocus works
fine.
-- 
                                     Sincerely yours,
                                            Zhang Le