Subject: Re: FVWM: Setting up Wallpaper in fvwm

From: "Rouben Rostamian" <[email-masked]>
Date: Tue, 17 Jun 2003 21:44:41 -0400

Subba Rao <[email-masked]> wrote:

> I tried to set a wall paper using GThumb and that did not work.
> How do I setup a wallpaper when fvwm session begins?

Others have already suggested xv and xloadimage (also known with
its aliases xli and xsetbg).

Some time ago I experimented with loading root images with xv, xsetbg
(from xloadimage package), display (from ImageMagick package) and
Esetroot (from the Eterm package) and made note of strengths and
weakness of each.  Here are my observations for whatever they're
worth.

Personally I find xv most suitable for my needs.  Its inability
to handle transparent objects can be compensated by applying the
fvwm-root utility.  See the fvwm-root man page for explanation.

--- xv ------------------------------

Advantages:

  o can handle just about any image
  o is pretty stable and bug-free
  o commonly available
  o high quality smoothing when maximizing image

Disadvantages:

  o big and slow
  o screen momentarily blanks out when changing root image
  o does not handle transparency

--- xli (or its alias xsetbg) -------

Advantages:

  o very fast
  o handles transparency
  o smooth background image transition without screen blanking

Disadvantages:

  o does not recognize pgm, xpm, xbm, ...
  o too fussy; does not recognize certain types of jpg images
  o poor quality smoothing
  o buggy: "xsetbg -fillscreen file.jpg" doesn't fill screen for some images

--- display (from ImageMagick) --------

Advantages:

  o can handle just about any image
  o is pretty stable and bug-free
  o commonly available
  o handles transparency

Disadvantages:

  o syntax cumbersome, setting root image is not one of its strong points
  o not sure if it can do everything
  o very slow

--- Esetroot (from the Eterm package):

Advantages:

  o is fast
  o handles transparency
  
Disadvantages:

  o image quality of maximized images is better than xli but not as good as xv
  o occasionally messes up transparency
  o actually Eterm is supposed to handle pixmaps only, but it manages to work
    with jpeg files too

-- 
Rouben Rostamian <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 17 Jun 2003 22:11:53 -0400

>   o too fussy; does not recognize certain types of jpg images

I'm guessing you have progressive jpgs.  I think you will be able
to find a patch to fix that.

>   o poor quality smoothing

I find -sm works pretty well.

>   o buggy: "xsetbg -fillscreen file.jpg" doesn't fill screen for some images

Depends on the image size, some need -fill, others need -full.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 18 Jun 2003 15:07:46 +1000

On 21:44 17 Jun 2003, Rouben Rostamian <[email-masked]> wrote:
| Subba Rao <[email-masked]> wrote:
| > I tried to set a wall paper using GThumb and that did not work.
| > How do I setup a wallpaper when fvwm session begins?
| 
| Others have already suggested xv and xloadimage (also known with
| its aliases xli and xsetbg).

And of course fvwm-root, from the fvwm package itself.  I tend to size
backgrounds with a separate tool (if they're not the right size already)
and then call fvwm-root with the resized image. This lets one separate
the "set the wallpaper" from the image composition.
-- 
Cameron Simpson <[email-masked]> DoD#743
http://www.cskk.ezoshosting.com/cs/

Some people will tell you that slow is good - and it might be on some days
- but I am here to tell you fast is better. I've always believed this in
spite of the trouble it's caused me.    - Hunter S. Thompson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].