Subject: FVWM: fvwm

From: Salvatore Leone <[email-masked]>
Date: Thu, 19 Jun 2003 22:08:56 +0200

Hi again
I try to compile and everything seems to be ok
this is the messagea the end of the ./configure:

FVWM Configuration:

   Version:     2.4.16

   Executables: /usr/local/bin
   Man pages:   /usr/local/man
   Modules:     /usr/local/libexec/fvwm/2.4.16
   Data files:  /usr/local/share/fvwm

   With GNOME Window Manager hints?   yes
   With GTK support for FvwmGtk?      no: Failed to detect GTK, see
config.log
   With Multibyte support?            no: Use --enable-multibyte to enable
   With ReadLine sup. in FvwmConsole? no: Can't find working libreadline
   With RPlay support in FvwmEvent?   yes
   With Shaped window support?        yes
   With Session Management support?   yes
   With Stroke support?               no: Can't find working libstroke
   With Xinerama support?             yes
   With XPM support?                  no: Can't find working libXpm

but I have some new problem...
when I digit "fvwm" as normal user it says that there isn't a file with
that name, and if I try that as root that there is another VW runnig.
I think this is all ok... but How can I start the pc with fvwm as 
default VM?? I know there is a file named .xinitrc but it don't exist in 
my home and I don't know how to edit it.

sorry for boring you with this questions but I'm only a student...
thanx again

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Jun 2003 10:44:53 +0200

>   With XPM support?                  no: Can't find working libXpm
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

You will most likely want Xpm support.  Check whether the xpm
library and header files are installed properly.

> that name,

You need to have /usr/local/bin in your PATH environment variable.
Check your shell setup if it isn't there.

  $ echo $PATH

If it isn't add something like

  PATH=/usr/locl/bin:"$PATH"

to your shell config file.

> and if I try that as root that there is another VW runnig.

> my home and I don't know how to edit it.

Just create a file .xinitrc in your home directory and make it
executable.  It should look roughly like this:

--------------------------- ~/.xinitrc ---------------------------
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/Xresources
sysmodmap=/etc/Xmodmap

# merge in defaults and keymaps
if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi
if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi
if [ -f $userresources ]; then
    xrdb -merge $userresources
fi
if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# start applications and window manager
xterm &
fvwm
------------------------------ snip ------------------------------

Note that the X server exits when the last command returns.  For
this reason, the last command must not be started in the
background.

Bye

Dominik ^_^  ^_^

---

From: David Hansen <[email-masked]>
Date: Fri, 20 Jun 2003 12:12:35 +0200

> executable.  It should look roughly like this:
[...]

And it's not a bad idea to 

  $ ln -s ~/.xinitrc ~/.xsession

then it's working too if you login with xdm.

David