Subject: FVWM: Vector Buttons

From: Subba Rao <[email-masked]>
Date: Thu, 19 Jun 2003 20:33:05 -0400

I am trying to a "X" as a title bar button to perform the function "Delete". So
far the only way I can do that is by using vector buttons.  How are these
buttons designed?  In the following sample:

ButtonStyle 6 6 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1

How are the numbers determined/calculated?  Is there a utility that does this?

Thank you in advance.
-- 
Subba Rao
[email-masked]
------------------------------------------------------------------------------
Old American Wild West saying:       God created men but Colt made them equal.
Today:                  Linus created Linux and Linux made IT companies equal.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 19 Jun 2003 20:55:08 -0400

Subba Rao <[email-masked]> writes:
> ButtonStyle 6 6 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70
> @1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
> 
> How are the numbers determined/calculated?  Is there a utility that does this

The man page describes how they work, but there are a bunch you can see
and download here:

http://www.fvwm.org/screenshots/windowdecors/

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Perry Hutchison <[email-masked]>
Date: Thu, 19 Jun 2003 18:11:57 -0700 (PDT)

> I am trying to a "X" as a title bar button to perform the function
> "Delete". So far the only way I can do that is by using vector
> buttons.  How are these buttons designed?  In the following sample:
>
> How are the numbers determined/calculated?

For the X effect, I am using this (in 2.2.4):

  Mouse  0  8  A   Close
  # Definition looks a bit goofy, but visual is OK.  A sensible definition
  # produces bad visual results -- go figure.  A pixmap might be better.
  ButtonStyle 8 Vector 14 42x42@0 72x73@0 13x10@0 75x70@0 70x75@0 8x15@0 10x10@0 42x42@0 75x10@0 8x75@0 13x80@0 75x18@0 75x14@0 10x78@0

I got the numbers by trial and error :)

Yes, 2.2.4 is an old version (came with Red Hat 6.2).  I'm not the sysadmin
here, and it works well enough that I haven't agitated to upgrade.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eduardo Alvarez <[email-masked]>
Date: Thu, 19 Jun 2003 22:04:52 -0400 (EDT)

you can also use xfig to draw the desired shape and then use this script
on them:

http://www.xs4all.nl/~josvanr/eps2vector.pl