Subject: FVWM: FvwmPager desktops

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 11:18:22 -0400

Hi,

I have my desktop size setup for 4x3 and on startup FvwmPager starts with
4x2 desktops.  Also I have FvwmButtons and xclock on the desktop which are in
sticky mode.

When I switch to a different pane in the desktop, I do still see FvwmPager as
a small square, FvwmButtons as a small rectangle and xclock as a very small
rectangle.

Is there anyway to not show FvwmPager/FvwmButtons etc. within the FvwmPager on
the desktop?

Thank you in advance for any help.

PS - I hope I was clear and did not confuse you.

-- 
Subba Rao
[email-masked]
------------------------------------------------------------------------------
Old American Wild West saying:       God created men but Colt made them equal.
Today:                  Linus created Linux and Linux made IT companies equal.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 18 Jun 2003 13:33:03 -0400

> Is there anyway to not show FvwmPager/FvwmButtons etc. within the FvwmPager o

       *FvwmPager: UseSkipList
              Tells  FvwmPager  to  not show the windows that are
              using the WindowListSkip style.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 14:19:14 -0400

>               using the WindowListSkip style.

Thank you for replying.

I did as you have suggested. My .fvwm2rc has the following lines:

# Styles for various Fvwm modules:
Style Fvwm*       NoTitle,  Sticky, WindowListSkip
Style Fvwm*       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style FvwmPager   StaysOnTop, NoHandles, BorderWidth 4, WindowListSkip
Style FvwmBanner  StaysOnTop
Style FvwmButtons Icon toolbox.xpm, ClickToFocus, WindowListSkip

and the last line in ConfigFvwmPager file is:
*FvwmPager: UseSkipList

I don't know if I did it right.  Is there anything else that I need to do to
not see these tiny images in FvwmPager?

---

From: Dan Espen <[email-masked]>
Date: Wed, 18 Jun 2003 14:32:02 -0400

Subba Rao <[email-masked]> writes:
> > > Is there anyway to not show FvwmPager/FvwmButtons etc. within the FvwmPag
> er o
> > > n
> > > the desktop?
> > 
> >        *FvwmPager: UseSkipList

You will need

read ConfigFvwmPager
in your .fvwm2rc.

I tried those lines by pasting them into FvwmConsole and
then starting the pager.
Worked for me.

Make sure the pager config is read before the pager is started.

---

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 15:15:36 -0400

> Make sure the pager config is read before the pager is started.

I am reading the ConfigFvwmPager in my .fvwm2rc.  After your email,  I moved
the following lines from the bottom of .fvwm2rc to the top of the file.

# Read config files for modules:
read ConfigFvwmButtons
read ConfigFvwmPager
read ConfigFvwmTaskBar
read ConfigFvwmWinList

I exited fvwm2 and logged back in.  It did not show the desired effect.  I am
running fvwm 2.4.16

---

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 16:24:55 -0400

On  0, Dan Espen <[email-masked]> wrote:
> > <SNIP> 

Now it works fine in the fvwm 2.5.7 version.

Thanks for the help.