Subject: Re: FVWM: help : dual monitors

From: Mukesh Rathor <[email-masked]>
Date: Tue, 10 Jun 2003 20:55:59 -0700

Hi Dominik,

   I still kept on losing windows to other screen, and find myself
   scrolling in all directions to find it. So, I upgraded to 2.5
   and it seems to working fine so far.  However, in the new
   version, I noticed moving windows is different. I used to drag
   with mouse button clicked, but now have to release the button.
   I looked thru the man pages to see if I can get old behavior
   back, do you know if I can do that? 

   While I'm asking for help, another question. I saw TWM the other
   day, and liked the way icons were parked on the screen. Can I do
   that in fvwm? 

   Thanks a lot,
   Mukesh

Dominik Vogt <[email-masked]>  writes:
In your message <[email-masked]>, you wrote:
>On Wed, Apr 23, 2003 at 12:25:58PM -0700, Mukesh Rathor wrote:
>> 
>> Hi,
>>    I've spent last couple hours going thur FAQs and archives, but
>>    still not able to figure out. 
>> 
>>    I've two identical monitors connected to matrox graphics card.
>>    Via the matrox mgapdesk utility, I've configured it to dual-multi
>>    display automatic xinerama setup.
>> 
>>    The problem is : the new windows created are on the screen I'm not
>>    viewing, and everytime it causes me to scan thru all Pages looking for
>>    the new window? Kinda gets annoying, I've way too many windows open...
>> 
>>    In my fvwmrc file : 
>> 
>>    xinerama on
>>    XineramaSls on
>>    XineramaSlsSize 2x1
>> 
>>    Any help will be greatly appreciated. 
>
>Check the man page for the XineramePrimaryScreen command.
>
>Bye
>
>Dominik ^_^  ^_^

Mukesh Rathor (Software Engineer)
Veritas Software Inc.,   Mountain View,  CA  94043
Phone:  (650)527-4078    Email: [email-masked]
----------------------------------------------------------------------------
Opinions, views, questions etc.. expressed above are mine, and not Veritas'.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 19 Jun 2003 15:36:55 +0200

On Tue, Jun 10, 2003 at 08:55:59PM -0700, Mukesh Rathor wrote:
>    and it seems to working fine so far.

>    However, in the new

This is a side effect caused by a bug fix.  We are still
discussing whether it will stay this way in the next stable
release (2.6.0).  You can circumvent your problem by using a
complex function instead of binding the action directly to the
windows.  For example, replace

  Mouse 1 T N Move

with

  AddToFunc my_move
  + M Move
  Mouse 1 T N my_move

>    day, and liked the way icons were parked on the screen. Can I do

Yes.  Remove all IconBox styles from your config and issue

  Style * IconBox none

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].