Subject: RE: FVWM: app opens windows off the screen

From: "Dameron, Gregg" <[email-masked]>
Date: Fri, 13 Jun 2003 15:05:52 -0600

> I'm running fvwm-2.4.16 on Solaris 8 and am running into the 
> following 
> problem:
> 
> There is one app that opens some new windows outside the 
> physical screen 
> area. I can't get to the title bar to move it into view. I've 
> turned off 
> multi screen mode and edge scroll mode and have set my desktop to 1x1 
> like so:
> 
> EdgeScroll 0 0
> DeskTopSize 1x1
> 
> Can I force apps to always open windows on the physical 
> desktop and if 
> so, how?

We have some Java apps that tend to do that.  FAQ 3.18 (FvwmEvent) works
great for us.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 13 Jun 2003 23:45:50 +0000

On 13 Jun 2003 15:05:52 -0600, Dameron, Gregg wrote:
> > following problem:
> > There is one app that opens some new windows outside the physical
> > screen area. I can't get to the title bar to move it into view. I've
> > turned off multi screen mode and edge scroll mode and have set my
> > desktop to 1x1 like so:
> > 
> > EdgeScroll 0 0
> > DeskTopSize 1x1
> > 
> > Can I force apps to always open windows on the physical desktop and
> > if so, how?
> 

Try also press Alt-Tab to bring problematic windows to the screen.
If a window is WindowListSkip, it will not be shown on Alt-Tab, then do
"WindowList OnlyListSkip" (you may bind this to Alt-Shift-Tab like in
fvwm-themes).

Try also:

  Style MyBadWindow NoPPosition, NoUSPosition

Search for "Position" in the fvwm man page.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Jun 2003 20:17:21 -0400

Mikhael Goikhman <[email-masked]> writes:
> > > screen area. I can't get to the title bar to move it into view.

For moving windows where you can't get at the titlebar:

Key F7 A M Move

(Hold down the Meta key, press F7, move the window).

-- 
Dan Espen                           E-mail: [email-masked]