Subject: FVWM: WindowShade

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 19:00:36 -0400

I have been tinkering with windows title bar buttons.  One of the buttons I
have added is with WindowShade.  While reading the features of this function,
there are N, E, S and W to shade a window.  To test, I used "W"  now the
window is a vertical bar.

How do I get these windows back to normal?  I think I like the default
feature for WindowShade which is "North".

Thank for any suggestions.
-- 
Subba Rao
[email-masked]
------------------------------------------------------------------------------
Old American Wild West saying:       God created men but Colt made them equal.
Today:                  Linus created Linux and Linux made IT companies equal.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 18 Jun 2003 20:03:47 -0400

> feature for WindowShade which is "North".

If you windowshade to "W" you might want to put the title on that edge
too.  (The titlebar can be on any edge.)

You don't really need a titlebar to unshade a window though.
The windowshade command can be invoked from a menu, keybinding or
mouse press.  When its not invoked inside a window, you get a crosshair,
just click on the window you want to shade/unshade.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Subba Rao <[email-masked]>
Date: Wed, 18 Jun 2003 21:04:11 -0400

> just click on the window you want to shade/unshade.

I got rid of the "W" and am staying with the default ("N").  I like that
better.  While on the "title bar buttons" subject, is it possible to change
the color of the window once it is made sticky?

Mouse 0 3       A       Stick

Right now, the title bar of the window gets stripes.  I would also like to make
them different color.  Can that be done?

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 20 Jun 2003 10:27:41 +0200

> the color of the window once it is made sticky?

On my machine, double clicking the window border shades the window
in the corresponding direction.  Together with a fast video card
and animated shading it's a pretty cool feature.  I play with it
often out of boredom :-)

  style * windowshadesteps 50

  Mouse 1 FS    N   Function ResizeOrRaise toggle
  Mouse 1 [     N   Function ResizeOrRaise W
  Mouse 1 ]     N   Function ResizeOrRaise E
  Mouse 1 -     N   Function ResizeOrRaise N
  Mouse 1 _     N   Function ResizeOrRaise S
  Mouse 1 <     N   Function ResizeOrRaise NW
  Mouse 1 >     N   Function ResizeOrRaise SE
  Mouse 1 ^     N   Function ResizeOrRaise NE
  Mouse 1 v     N   Function ResizeOrRaise SW

  AddToFunc ResizeOrRaise
  + C Raise
  + M Raise
  + M ResizeMaximize
  + D Current (Shaded) Raise
  + D WindowShade $0

> them different color.  Can that be done?

Not at the moment.

Bye

Dominik ^_^  ^_^