Subject: FVWM: Failed to write descriptor to 'FvwmAnimate'

From: Dennis McGregor <[email-masked]>
Date: Fri, 6 Jun 2003 13:31:24 +1000

Hello.

When I'm tweaking my config file I often restart fvwm using the key combo 
Key Space A CSM   Restart "/home/djm/bin/fvwm" 
Every so often I get timeouts associated with FvwmAnimate while loading FvwmIconMan.

~/bin/fvwm --version
fvwm 2.5.7 (from cvs) compiled on Apr 16 2003 at 11:00:59 
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM, Bidi text, XRender, XFT, NLS

Some possibly relevant lines from my config are:

*FvwmIconMan: NoIconAction "SendToModule FvwmAnimate animate"
SetAnimation  10  -.01 0 .01 .03 .08 .18 .3 .45 .6 .75 .85 .90 .94 .97 .99 1.0

The error message is:
[FVWM] [FlushMessageQueue]: <<ERROR>> Failed to write descriptor to 'FvwmAnimate':
- select rc=0
- terminate signal=N

It doesn't happen every time I restart, and it seems to be random whether 
it happens or not - at least, I can't pinpoint what makes it occur or not. 
It has never occurred when fvwm starts for the first time. 

Any ideas why this might be happening or what I can do about it?

cheers,

^d

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Jun 2003 09:19:55 +0200

> Any ideas why this might be happening or what I can do about it?

Post your config (preferrably stripped down to the minimum that
shows the problem) and try to start FvwmAnimate last.

Bye

Dominik ^_^  ^_^