Subject: Re: FVWM: What does CirculateHit do?

From: "Rouben Rostamian" <[email-masked]>
Date: Tue, 17 Jun 2003 00:19:35 -0400

Dan Espen <[email-masked]> wrote:
> "Rouben Rostamian" <[email-masked]> writes:
> > The fvwm man page repeatedly refers to CirculateHit and CirculateSkip
> > styles, but does not define them.  At least I was unable to locate
> > their definitions.  Would someone please give a brief explanation
> > of what these styles do?
> > 
> > I have looked at the man pages that come with versions 2.2.5 and 2.5.7.
> 
> The Circulate commands are described in the context of the commands
> they affect.  Read about "All", "Next", "Prev", etc.
> (the conditional commands).

I think the descriptions are somewhat circular (no pun!) unfortunately.
Here is what we read under the heading of Current:

      Current [(conditions)] command
          ....
          The Current command implies the conditions
          CirculateHit, CirculateHitIcon and CirculateHitShaded.
          ...

Thus we are told that the Current command implies the condition
CirculateHit.  Neither here nor elsewhere is a description
of what that phrase means.

Paragraphs corresponding to Prev, Next, etc., refer to the
paragraph corresponding to Current.  That is not of much help.

> By giving Circulate skip to a window, you can get one of these
> conditional command to ignore the window.  You might use this for
> a clock as an example.
> 
> That way, a command like this might be useful:
> 
> All (!CirculateHit) iconify on

Thanks for the description and example.  I think I understand it
a little better now.  I will have to experiment a bit to see if
I have gotten the real hang of it.

-- 
Rouben Rostamian <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 17 Jun 2003 10:11:32 +0200

> of what that phrase means.

The options are described for the "Next" command.  I managed to
screw up the cross references in the man page.  The options are
now described for the "Current" command to which all other
conditional commands eventually have a cross reference.

> I have gotten the real hang of it.

Bye

Dominik ^_^  ^_^