Subject: Re: FVWM: theme configuration questions

From: Klaus Zeitler <[email-masked]>
Date: 05 Jun 2003 14:50:21 +0200

>>>>> "Olivier" == Olivier Chapuis <[email-masked]> writes:
    Olivier> 
    Olivier> On Tue, May 27, 2003 at 01:10:14PM +0200, Klaus Zeitler wrote:
    >> 
    >> 1. Can I remove the left button and the right window that shows the
    >>    time on the TaskBar?
    >> 
    Olivier> 
    Olivier> With the future 2.5.7 (or current cvs) add in modules-extra:
    Olivier> 
    Olivier> DestroyModuleConfig FvwmTaskBar: Start*
    Olivier> *FvwmTaskBar: NoDefaultStartButton
    Olivier> *FvwmTaskBar: ClockFormat 
    Olivier> *FvwmTaskBar: DateFormat
    Olivier> *FvwmTaskBar: MailBox None

très bien

    >> 4. when I open the Pager-Desker panel (theme olicha), hide the panel
    >> behind another window, and then bring it back to the foreground,
    >> the border corners, that were hidden, look gaudy (sometimes a
    >> different color, sometimes some weird pixels)
    >> 
    Olivier> 
    Olivier> Hum, I can't reproduce this, but maybe I do not understand the
    Olivier> procedure.  Can you give more details and/or a step by step
    Olivier> procedure

When I move some other window over the desker panel and then move it
away, the border is not redrawn. I've just mailed a better screen shot.

Thanks

Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
Rule of Defactualization:
 Information deteriorates upward through bureaucracies.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Klaus Zeitler <[email-masked]>
Date: 05 Jun 2003 15:21:54 +0200

>>>>> "Mikhael" == Mikhael Goikhman <[email-masked]> writes:
    Mikhael>
    Mikhael> On 27 May 2003 13:10:14 +0200, Klaus Zeitler wrote:
    >> >>
    >> >> 2. I'd like to have a border around FvwmButtons-FvwmApplets>. I
    >> >>    thought I can change this with the following line in styles-extra:
    >> >> Style "FvwmButtons-FvwmApplets" BorderWidth 2
    >> >> but this doesn't help
    Mikhael>
    Mikhael> You should do this in modules-extra, not styles-extra, because
    Mikhael> styles-extra is read before modules.

thanks, you're right, it works

still I don't understand why the line:
*FvwmButtons-FvwmApplets: BorderWidth 2
leads to "FvwmButtons-FvwmApplets: Button confusion! Quitting"

    >> Also it'd be nice if one could see a palette of all sets together. That
    >> would make a choice a lot easier especially for similar colorSets.
    Mikhael>
    Mikhael> You may create such button bar yourself:
    Mikhael>
    Mikhael>   *FvwmButtons-Colorsets: (Text CS0, Colorset 0)
    Mikhael>   *FvwmButtons-Colorsets: (Text CS1, Colorset 1)
    Mikhael>   *FvwmButtons-Colorsets: (Text CS2, Colorset 2)
    Mikhael>   *FvwmButtons-Colorsets: (Text CS3, Colorset 3)
    Mikhael>   ...
    Mikhael>   *FvwmButtons-Colorsets: (Text CS39, Colorset 39)

thanks, I'll have to see if I can figure out how to make a button of this.

Klaus

--
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
You can't start worrying about what's going to happen. You get spastic
enough worrying about what's happening now.           -- Lauren Bacall

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 6 Jun 2003 10:27:19 +0000

> away, the border is not redrawn. I've just mailed a better screen shot.

Klaus said he sent the screenshot, but it didn't show up. I think it will
show up when Jason returns online (attachments are moderated).

In the meantime, here is the image converted from .miff:

  http://fvwm.sf.net/tmp/fvwm-decor-refresh-bug2.png

(People, please don't send 400Kb attachements to the list.)

Regards,
Mikhael.