Subject: FVWM: Window Position

From: Loren M Lang <[email-masked]>
Date: Mon, 16 Jun 2003 00:33:12 -0700 (PDT)

Whenever a new window or dialog box
pops up, fvwm tries to find the least
covered area to place it.  I've had
fvwm setup to do this for years now
and have always liked it, but recently
I've setup a new linux box with a good
monitor and video card.  Previously,
I've always run linux at 1024x768 or
800x600 depending on what my monitor
could do, but now I have a massive
1600x1200 desktop and love it.  The
only problem now is that certain
dialog boxes that are created very
far away from their parent windows,
is there some way of controlling
placement of windows based on parent
child relationships?  I really like
how new and unrelated windows are
placed but it is realing annoying
moving my mouse clear across the
screen just to click the ok button
on an informative dialog box.

- -- 
I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Wed, 18 Jun 2003 15:05:29 -0400 (EDT)

Loren M Lang <[email-masked]> wrote
on Mon, 16 Jun 2003 00:33:12 -0700 (PDT):
>
> Subject: FVWM: Window Position
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

I have the same issue, in fact even worse: on a 3200x1200
desktop the other side is a long way away :-(

I have long thought of implenting a solution like MacOS X, where
dialogs pop down from the title of the parent app. There
are reasons why this is hard in X, but I hacked up a module to
test how I could do it. See:

  http://cns.georgetown.edu/~ric/software/fvwm/FvwmPlaceTransient.tar.gz

This doesn't work a lot of the time for a number of reasons, mainly:

  - some apps create transients that have the root window as owner
    rather than the real parent; we can't do anything about these

  - there is a flicker as fvwm places the window, then the
    FvwmPlaceTransient module moves it

  - there is probably a race condition between fvwm and the module

It does work for most galeon dialogs, which is about 95% of all
dialogs for me, and allows me to warp focus and dismiss the dialog
with the keyboard while surfing.

I think it would be a good idea to integrate this into fvwm to avoid
the last two issues. We could maybe fake our way out of the first
by having a config, something like this:

  Style "dialog_print"   TransientFor "galeon"

We could even have the dialog windowshade out of the titlebar, and
similar eye candy.

If I have time later in the summer I may try to implement this.
That's a big "if", I'm afraid :-(

Cheers
Ric

Richard J Lister
Dept of Neuroscience
Georgetown University Medical Center
http://cns.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].