Subject: FVWM: FvwmPager exits when changing the desktop.

From: Uwe Pross <[email-masked]>
Date: Mon, 2 Jun 2003 12:56:38 +0200

Hi there,

I  have  append  a  partial  fvmw-config  which  produces  a
breakable  pager  on  my system. After changing the desk the
pager gets killed. 
The problem disappears if the three commented lines are used
and the previous two are commented out. 

fvwm 2.5.7
Sun 5.8

Can anybody reproduce this?

Regards, Uwe
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Mon, 2 Jun 2003 13:01:40 +0200

Hi there,

> and the previous two are commented out. 

Sorry, I hit "send" instead of "attach" ;-)
-- 
  ,_,  Uwe Pross
 (O,O) mailto:[email-masked]
 (   ) http://www.tu-chemnitz.de/~uwp
=-"-"-================================

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Jun 2003 13:52:56 +0200

> > and the previous two are commented out. 

(please send bug reports to the fvwm-workers list)

I don't get a crash with your config, but the window colours are
screwed on desk 0 after switching.  Do you get a core dump?  If
so, please post a stack trace:

  $ gdb FvwmPager core
  (gdb) where

> DestroyModuleConfig FvwmTheme
> *FvwmTheme: Colorset 13 fg black,  bg dodgerblue3, VGradient 128 dodgerblue4 dodgerblue1
> *FvwmTheme: Colorset 14 fg black,  bg azure3, HGradient 128 azure4 azure2
> 
> ModuleSynchronous Timeout 5 FvwmTheme
> 
> DestroyModuleConfig FvwmPagerDemo
> KillModule  FvwmPagerDemo
> *FvwmPagerDemo: Rows 1
> *FvwmPagerDemo: Font        none
> *FvwmPagerDemo: SmallFont   none
> 
> *FvwmPagerDemo: Colorset * 14
> *FvwmPagerDemo: HilightColorset * 13
> 
> #*FvwmPagerDemo: Fore        $[fg.cs13]
> #*FvwmPagerDemo: Back        $[bg.cs14]
> #*FvwmPagerDemo: Hilight     $[bg.cs13]
> 
> *FvwmPagerDemo: MiniIcons
> *FvwmPagerDemo: UseSkipList
> *FvwmPagerDemo: WindowBorderWidth 1
> 
> FvwmPager FvwmPagerDemo *
> 
> Style "FvwmPagerDemo" Sticky, StaysOnTop
> 
> # GotoDesk GotoDesk +1 0 2

Bye

Dominik ^_^  ^_^