Subject: FVWM: Happy Birthday

From: Loren M Lang <[email-masked]>
Date: Sun, 1 Jun 2003 14:16:01 -0700 (PDT)

Happy Birthday Fvwm!!!

I've been using fvwm since it was default
with redhat 5.1 and I've tried some others
for a while like WindowMaker and
AnotherLevel including desktops like CDE,
KDE, and GNOME and always come back to
fvwm.  It's a great wm with an easy config.

But recently I've been running into some
difficulties I'd like to find a way to
solve.  One is some way to cause a key
binding set in fvwm to be sent to the app
instead, (i.e. when I'm vnced to another
machine running fvwm with an identical
config).  I'd like to be able to set
vncviewer to receive certain key strokes
I've set to be global for everything like
Ctl-Alt-Arrow for moving around my large
4x4 desktop.

Also, my FvwmButtons with has my pager
in it sometimes gets hidden, not a big deal
since I can just right-click on the window
titlebar to send it to the back, but
sometimes I don't was to mess with the order
of windows like sending an xterm behind my
maximized browser and moving it would mean
moving it back again so I could see the page.

Keep up all the good work!

- -- 
I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Anders Kristian Lyhne Thøgersen <[email-masked]>
Date: Tue, 3 Jun 2003 01:58:56 +0200

Hi

On Sun, Jun 01, 2003 at 02:16:01PM -0700, Loren M Lang wrote:
> ...

I had a similar problem which i found a solution to 
that works fine for me. I got the idea from someone I saw playing 
battlefield 1942 or some kind of shoot'em up game, which had
a HUD (Human User Ding?) that cold be raised and lowered by clicking the right mouse
button. The HUD was used for changing weapon, etc.

I have used this idea for my pager, xload, buttonbar and iconthingy:

All of these thingies which are part of the user interface are named
UIsomething, i.e. UIPager, UIButtons etc. such that the following
function will raise lower them:

AddToFunc UIRaiseLower
+ I ALL (UI*)  RaiseLower

With the following mappings pressing F12 or CTRL-Mouse3 will raise-lower
the UI.

Key F12  A       N       Function UIRaiseLower
Mouse 3         A       C       Function UIRaiseLower

Hope this also helps you!

Anders

-- 
To accuse others for one's own misfortunes is a sign of want of education.
To accuse oneself shows that one's education has begun.  To accuse neither
oneself nor others shows that one's education is complete.
                -- Epictetus
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].