Subject: FVWM: setting button style per window

From: "Rouben Rostamian" <[email-masked]>
Date: Tue, 24 Jun 2003 00:50:32 -0400

Question: Is it possible to set ButtonStyle per window?

Specifically, I have defined titlebar buttons 6 4 2 to maximize
the window horizontally, vertically and fully, respectively.

I wish to change the visual appearance of a button when it is
active.  But if when I do that by changing the ButtonStyle,
the change affects all windows, not just the window that is
being maximized.

So my question is: is there a trick whereby I can change the
appearance of a titlebar buttons individually on different windows?

-- 
Rouben Rostamian <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 24 Jun 2003 09:06:26 +0200

> appearance of a titlebar buttons individually on different windows?

It is possible but unfortunately quite tricky to do.  Try this in
2.5.x:

  buttonstyle 3 - mwmdecormax
  buttonstyle 3 allnormal pixmap foo.xpm
  buttonstyle 3 alltoggled pixmap bar.xpm

In 2.4.x it's a bit more complicated:

  buttonstyle 3 - mwmdecormax
  buttonstyle 3 active pixmap foo.xpm
  buttonstyle 3 inactive pixmap foo.xpm
  buttonstyle 3 active pixmap bar.xpm
  buttonstyle 3 inactive pixmap bar.xpm

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 28 Jun 2003 03:01:45 +0000

>   buttonstyle 3 inactive pixmap bar.xpm

Just for the correctness sake, Dominik actually meant these lines for the
2.4.x equivalent config:

  buttonstyle 3 - mwmdecormax
  buttonstyle 3 ActiveUp   pixmap foo.xpm
  buttonstyle 3 ActiveDown pixmap foo.xpm
  buttonstyle 3 Inactive   pixmap foo.xpm
  buttonstyle 3 ToggledActiveUp   pixmap bar.xpm
  buttonstyle 3 ToggledActiveDown pixmap bar.xpm
  buttonstyle 3 ToggledInactive   pixmap bar.xpm

Regards,
Mikhael.