Subject: Re: FVWM: Setting up Wallpaper in fvwm

From: "Rouben Rostamian" <[email-masked]>
Date: Tue, 17 Jun 2003 23:21:13 -0400

Dan Espen <[email-masked]> wrote:
> "Rouben Rostamian" <[email-masked]> writes:
> > --- xli (or its alias xsetbg) -------
> > 
> > Advantages:
> > 
> >   o very fast
> >   o handles transparency
> >   o smooth background image transition without screen blanking
> > 
> > Disadvantages:
> > 
> >   o does not recognize pgm, xpm, xbm, ...
> >   o too fussy; does not recognize certain types of jpg images
> 
> I'm guessing you have progressive jpgs.  I think you will be able
> to find a patch to fix that.

I don't know what a progressive jpeg is.  I will have to look it up.
But here is an example of what I get:

% file ciscosplace.jpg
ciscosplace.jpg: JPEG image data, JFIF standard 1.01, resolution (DPI), 96 x 96

% xli ciscosplace.jpg
jpegLoad: ciscosplace.jpg - Unsupported SOF marker type 0xc2
ciscosplace.jpg: unknown or unsupported image type

Other viewers have no difficulty in displaying the image.

I have several other jpeg files with the same problem.

> >   o poor quality smoothing
> 
> I find -sm works pretty well.

The -smooth option merely blurs the image.  Applying -smooth multiple
times, as the man page suggests, makes it even worse.  A side-by-side
comparison with what xv does with scaled images can be quite striking.

> >   o buggy: "xsetbg -fillscreen file.jpg" doesn't fill screen for some images
> 
> Depends on the image size, some need -fill, others need -full.

You are right.  But it is not clear which images need which option.
I experimented with images of varying aspect ratios, but gave up at
the end.

My apologies for this off-topic discussion.

-- 
Rouben Rostamian <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 17 Jun 2003 23:46:54 -0400

> I have several other jpeg files with the same problem.

Yep.  Thats what I got until I applied the progressive jpg patch.
See if you can find it with Google.  The one I have is too old
to share.  (Nov 2001).

> comparison with what xv does with scaled images can be quite striking.

OK.

> I experimented with images of varying aspect ratios, but gave up at

You might be able to figure it out programmatically,
by using convert to get the width/height but
I actually keep a file of commands, each image is displayed
with a hand tuned command.

> My apologies for this off-topic discussion.

Background image techniques are discussed every so often on this
list.  I think it fits in.

-- 
Dan Espen                           E-mail: [email-masked]