Subject: FVWM: fvwm on startup

From: Subba Rao <[email-masked]>
Date: Sun, 8 Jun 2003 12:48:45 -0400

Hello,

I am using Slackware 9.0 on my system.  I used the default install fvwm2.
My user $HOME partition was not touched during the installation. Therefore, I
had my .fvwm/.fvwm2rc from 2.4.15.  The fvwm session does not match the way
it worked on other installation.

Now I have upgraded my fvwm to version 2.4.16. The session still does not
appear anywhere close to what I had in the past.  The only thing I get is the
menu for the mouse buttons.  The FvwmPager,  FvwmAuto .....all have to be
loaded thru the menu.   The .xsession does not do anything either.

Please look at the configuration below and let me know if I am doing something
wrong.  There is quite a bit of legacy configuration in it.

Any help appreciated.

Thank you in advance.
 
-- 
Subba Rao
[email-masked]
------------------------------------------------------------------------------
Old American Wild West saying:       God created men but Colt made them equal.
Today:                  Linus created Linux and Linux made IT companies equal.

==============================================================================

# Default system.fvwm2rc for Slackware Linux, adapted from the version
# for fvwm95 (i.e. beware of non-functional commented-out options)
#

#========================================================================#

#
# Fonts - one for window titles, another for icons, and another for the menus
#
WindowFont	-adobe-times-bold-i-normal-*-18-180-*-*-*-98-iso8859-1
IconFont	fixed
#MenuStyle black skyblue brown -adobe-times-medium-r-normal-*-18-180-*-*-p-94-iso8859-* fvwm

#MenuStyle * TitleWarpOff, \
            MenuFace TiledPixmap marble.xpm, \
                                        SidePic fvwm-menu-sidebar.xpm, \
                        Font -sony-fixed-medium-r-normal--24-170-100-100-c-120-jisx0201.1976-0 fvwm

#MenuStyle FancyMenu TitleWarpOff, \
                    MenuFace TiledPixmap marble.xpm, \
                                        SidePic fvwm-menu-sidebar.xpm, \
                        Font -sony-fixed-medium-r-normal--24-170-100-100-c-120-jisx0201.1976-0 fvwm

MenuStyle * SidePic fvwm-menu-sidebar.xpm
MenuStyle black skyblue brown -sony-fixed-medium-r-normal--24-170-100-100-c-120-jisx0201.1976-0 fvwm

#
# Set the default window colors. The syntax is:
#  DefaultColors winforecolor winbackcolor titleforecolor titlebackcolor
# where:
#  winbackcolor    is the background (border) color of all windows,
#                  including the menu windows 
#  winforecolor    is used for the menu text
#  titlebackcolor  is the background color used for title bars of 
#                  non selected windows
#  titleforecolor  is the color of the title text of non selected windows
#
DefaultColors   Black #c3c3c3 blue grey31

#
# Text and background color for the title bar of the active (selected) window
#
HiBackColor    lightblue
HilightColor   yellow brown1
TitleStyle LeftJustified Height 19

#
# Text and background color for the title bar of sticky windows
#
StickyColors    white brown

# You can also use the Style command to set the colors of individual
# title bars of some non-selected windows

Style "*" ForeColor wheat4
Style "*" BackColor grey80

#========================================================================#

#
# Set up the major operating modes
#

# Let's comment this out and be more UNIX-like :^)
# Style "*" ClickToFocus
# If we use the FvwmTaskBar we don't need the icons :-)
# Style "..." Icon is also commented below.
Style "*" NoIcon
Style "*" MWMFunctions
Style "*" HintOverride
Style "*" MWMDecor
Style "*" MWMBorder
Style "*" MWMButtons

OpaqueMoveSize 100
EdgeScroll 100 100
EdgeResistance 10000 0

#
# RandomPlacement prevents user interaction while placing windows:
#
#Style "*" ActivePlacement
Style "*" RandomPlacement

#
# NoPPosition instructs fvwm to ignore the PPosition field in window 
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
#
Style "*" NoPPosition

#========================================================================#

#
# Set the desk top size in units of physical screen size
#
DeskTopSize 3x3

#========================================================================#

#
# Module path and paths to the icons
# ModulePath is a colon-separated list, just like regular unix PATH
#
ModulePath /usr/X11R6/libexec/fvwm/2.4.16
PixmapPath /usr/include/X11/pixmaps/:/usr/share/pixmaps/:/usr/share/xmcd/pixmaps/
IconPath   /usr/include/X11/bitmaps/:/usr/share/icons/:/usr/local/share/icons/

#========================================================================#

ColormapFocus FollowsMouse

# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.

# These commands should command before any menus or functions are defined,
# and before the internal pager is started.

#
# Default border and handle widths
#
Style "*" BorderWidth 4, HandleWidth 4

Style "Fvwm*"        NoTitle, Sticky, WindowListSkip
Style "FvwmPager"    StaysOnTop, NoHandles
Style "FvwmBanner"   StaysOnTop
Style "FvwmButtons"  NoTitle, NoHandles, StaysOnTop, Sticky, WindowListSkip,BorderWidth 3
Style "*lock"        NoTitle, NoHandles, Sticky, WindowListSkip
Style "xload"        NoTitle, NoHandles, Sticky, WindowListSkip
Style "xosview"      NoTitle, NoHandles, Sticky, WindowListSkip
Style "xconsole"     NoTitle, NoHandles, Sticky, WindowListSkip
Style "xlogo"        NoTitle, NoHandles, Sticky, WindowListSkip
Style "wmnd"         NoTitle, NoHandles, Sticky, WindowListSkip,BorderWidth 5
Style "xbiff"        NoTitle,            Sticky, WindowListSkip
#Style "wm*"	     NoTitle, Sticky, WindowListSkip

#
# Some mini-icons for the title bar
#
#Style "*"         TitleIcon mini-x2.xpm
#Style "*xterm*"   TitleIcon mini-term.xpm
#Style "rxvt"      TitleIcon mini-term.xpm
#Style "xcalc"     TitleIcon mini-calc.xpm
#Style "xsession"  TitleIcon mini-bx2.xpm
#Style "xv"        TitleIcon mini-xv.xpm
#Style "Netscape"  TitleIcon mini-nscape.xpm
#Style "xmag"      TitleIcon mini-zoom.xpm
#Style "textedit"  TitleIcon mini-edit.xpm
#Style "tkps"      TitleIcon mini-run.xpm
#Style "Ghostview" TitleIcon mini-gv.xpm
#Style "Xcolorsel" TitleIcon mini-colors.xpm
#Style "IDL*"      TitleIcon mini-zoom.xpm
#Style "xeyes"     TitleIcon mini-eyes.xpm
#Style "*fm*"      TitleIcon mini-filemgr.xpm
# xman resource names
#Style "topBox"    TitleIcon mini-book1.xpm
#Style "help"      TitleIcon mini-book2.xpm
#Style "manualBrowser" TitleIcon mini-book2.xpm
# xpaint resource names
#Style "xpaint"    TitleIcon mini-paint.xpm
#Style "Canvas"    TitleIcon mini-paint.xpm
#Style "fatbits"   TitleIcon mini-paint.xpm
#Style "filebrowser" TitleIcon mini-paint.xpm

#Style "rxvt"       Icon  term.xpm
#Style "xterm"      Icon xterm.xpm
#Style "Appointment" Icon datebook.xpm
#Style "xcalc"      Icon Rcalc.xpm
#Style "xbiff"      Icon mail1.xpm
#Style "xmh"        Icon mail1.xpm, StartsOnDesk 2
#Style "xman"	   Icon xman.xpm
#Style "xvgr"	   Icon graphs.xpm
#Style "matlab"	   Icon math4.xpm
#Style "xmag"	   Icon mag_glass.xpm
#Style "xgraph"	   Icon graphs.xpm
#Style "xv"         Icon xview.xpm
#Style "FvwmButtons"  Icon toolbox.xpm
#Style "xconsole"   Icon koala.xpm
#Style "xsession"   Icon koala.xpm
#Style "textedit"   Icon textedit.xpm
#Style "gv"  Icon gv.xpm

#========================================================================#

#
# Stuff to do at start-up
#

DestroyFunc SessionInitFunction
AddToFunc SessionInitFunction
 + I Module FvwmAudio
 + I Module FvwmAuto 300
 + I Module FvwmCommandS
 + I Module FvwmEvent
 + I Module FvwmButtons
 + I Module FvwmPager 0 0
 + I Module FvwmAnimate
 + I Module FvwmTheme
 + I Module FvwmGtk
 + I Module FvwmSave
 + I Module FvwmSaveDesk
 + I Desk 0 0
 + I Exec gnome-panel &
# + I Exec xterm -sb -sl 1200 -j -ls -fn 10x20 -geometry 110x45+58+63 -T MAILLOG -bg black -fg green -e sudo tail -f /var/log/mail.log
# + I Exec xterm -sb -sl 1200 -j -ls -fn 10x20 -bg black -fg yellow -geometry 173x42+20+241 -T MESSAGES -e sudo tail -f /var/log/messages
# + I Exec xterm -sb -sl 1200 -j -ls -fn 10x20 -bg black -fg red -geometry 135x42+360+400 -T KERNEL-LOG -e sudo tail -f /var/log/kern.log

DestroyFunc SessionRestartFunction
AddToFunc SessionRestartFunction
 + I Module FvwmAudio
 + I Module FvwmAuto 300
 + I Module FvwmCommandS
 + I Module FvwmEvent
 + I Module FvwmButtons
 + I Module FvwmPager 0 0
 + I Module FvwmAnimate
 + I Module FvwmTheme
 + I Module FvwmGtk
 + I Module FvwmSave
 + I Module FvwmSaveDesk

#========================================================================#

# Now define some handy complex functions

#
# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click, or does a full maximize if 
# you double click
#
AddToFunc "Move-or-Raise" "M" Move
+                         "M" Raise
+                         "C" Raise
+                         "D" Maximize 100 100

#
# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click, or does a RaiseLower if you double 
# click
#
AddToFunc "Move-or-Lower" "M" Move
+                         "M" Lower
+                         "C" Lower
+                         "D" RaiseLower

#
# This one moves or (de)iconifies:
#
AddToFunc "Move-or-Iconify" "M" Move
+                           "D" Iconify

#
# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
#
AddToFunc "Resize-or-Raise" "M" Resize
+                           "M" Raise
+                           "C" Raise
+                           "D" RaiseLower

#========================================================================#

#
# Now define the menus - defer bindings until later
#

# This is for the Start menu of the FvwmTaskBar

DestroyMenu "StartMenu"
AddToMenu "StartMenu"
+ "Manual Pages     %mini-book1.xpm%"       Exec    xman &
+ "Magnifying Glass %mini-zoom.xpm%" 	    Exec    xmag &
+ ""                                        Nop 
+ "Accessories%mini-hammer.xpm%"            Popup   Accessories
+ "Applications     %mini-x2.xpm%"          Popup   Applications
+ "File Managers    %mini-filemgr.xpm%"     Popup   Filemanagers
+ "Games            %mini-happy.xpm%"       Popup   Games
+ "Logs             %mini-x2.xpm%"          Popup   Logs
+ "Shells           %mini-term.xpm"         Popup   Shells
+ ""                                        Nop 
+ "Refresh Screen   %mini-ray.xpm%"         Refresh
+ ""                                        Nop
+ "Exit Fvwm2       %mini-stop.xpm%"        Popup   Quit-Verify

DestroyMenu "Shells"
AddToMenu "Shells"
+ "Xterm	(12x24 font)%mini-term.xpm%" 		Exec xterm -sb -sl 500 -j -ls -fn 12x24 -title "Color xterm" &
+ "Large Xterm	(12x24 font)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 &
+ "Black Xterm	(12x24 font)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 -bg black -fg green &
+ "Navy Xterm	(12x24 font)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 -bg navy -fg yellow &

DestroyMenu "Games"
AddToMenu "Games"
+ "Chess%mini-slon.xpm%"        Exec xboard &
+ "Xlander%mini-xlander.xpm%"   Exec xlander &
+ "Xmahjongg%mini-xmahjongg.xpm%" Exec xmahjongg &
+ "Workman%mini-cdlabel.xpm%"	Exec workman &
+ "" Nop
+ "Amusements"                  Popup Amusements

DestroyMenu "Amusements"
AddToMenu "Amusements"
#+ "Xcat%mini-cat.xpm%"   	Exec xcat &
+ "Xeyes%mini-eyes.xpm%"        Exec xeyes &
+ "Xlogo%mini-bx2.xpm%"         Exec xlogo &
+ "Xroach%mini-roach.xpm%"      Exec xroach &
+ "Xsnow%mini-xsnow.xpm%"       Exec xsnow &
+ "Stop Xsnow%mini-stop.xpm%"	Exec killall xsnow &

DestroyMenu "Accessories"
AddToMenu "Accessories"
+ "Font viewer (xfontsel)%mini-font.xpm%"  Exec xfontsel &
+ "Manual pages%mini-book1.xpm%"        Exec xman &
+ "Magnifying glass%mini-zoom.xpm%"     Exec xmag &
+ "Oclock%mini-clock.xpm%"              Exec oclock &
+ "Running Processes (Top)%mini-run.xpm%"	Exec xterm -font 7x14 -T Top -n Top -e top &
+ "System load%mini-perf.xpm%"          Exec xload &
+ "Xclipboard%mini-clipboard.xpm%" Exec xclipboard &
+ "Xclock%mini-clock.xpm%"              Exec xclock &

DestroyMenu "Applications"
AddToMenu "Applications"
+ "NcFTP%mini-ftp.xpm%"         Exec xterm -name NcFtp -T FTP -ls -fn 7x14 -e ncftp &
+ "GIMP%mini-camera.xpm%"       Exec gimp &
+ "Gv%mini-gv.xpm%"		Exec gv &
+ "Gnuplot%mini-zoom.xpm%"      Exec xterm -T "Gnuplot" -name Gnuplot -fn 7x14 -e gnuplot &
+ "Netscape%mini-nscape.xpm%"	Exec /usr/bin/X11/netscape &
+ "Xv%mini-xv.xpm%"		Exec xv &
+ "Xedit%mini-edit.xpm%" 	Exec xedit &
+ "Xfig%mini-xfig.xpm%"         Exec xfig &
+ "Xfractint%mini-fractal.xpm%"	Exec xterm -font 7x14 -e xfractint map=chroma &
+ "Xpaint%mini-paint.xpm%"	Exec xpaint &
+ "Xpdf%mini-pdf.xpm%"          Exec xpdf &
+ "Xxgdb%mini-bug2.xpm%"	Exec xxgdb &

DestroyMenu "Logs"
AddToMenu "Logs"
+ "Mail log	    %mini-term.xpm%" 	    Exec xterm -sb -sl 1200 -j -ls -fn 7x13 -geometry 120x55 -T MAILLOG -bg black -fg green -e sudo -u root tail -f /var/log/mail-log &
+ "Log Messages	    %mini-term.xpm%" 	    Exec xterm -sb -sl 1200 -j -ls -bg black -fg yellow -geometry 206x42 -T MESSAGES -e sudo -u root tail -f /var/log/messages &
+ "Kernel Log	    %mini-term.xpm%" 	    Exec xterm -sb -sl 1200 -j -ls -fn 10x20 -T SYSLOG -e sudo -u root tail -f /var/log/kern.log &
+ "PPPStats	    %mini-term.xpm%" 	    Exec xterm -sb -sl 1200 -j -ls -fn 9x15 -T PPPSTATS -e pppstats -w 1 &
+ "Junkbuster	    %mini-term.xpm%" 	    Exec xterm -sb -sl 1200 -j -ls -fn 9x15 -T Junkbuster -e sudo -u root tail -f /var/log/junkbuster.log &

DestroyMenu "Filemanagers"
AddToMenu "Filemanagers"
+ "TkDesk%mini-desktop.xpm%"	Exec tkdesk &
+ "Xfilemanager%mini-filemgr.xpm%" Exec xfilemanager &
+ "Xfm%mini-filemgr.xpm%"	Exec xfm &

#
# This menu is invoked as a sub-menu - it allows you to quit,
# restart, or switch to another WM.
#
DestroyMenu "Quit-Verify"
AddToMenu "Quit-Verify"
+ "Quit fvwm2%mini-exclam.xpm%"        Quit
+ "" 					Nop
+ "Restart Fvwm2%mini-turn.xpm%"	Restart fvwm2
+ "" 					Nop
+ "Start fvwm95%mini-exp.xpm%"		Restart fvwm95
+ "Start mwm%mini-mwm.xpm%"		Restart mwm
+ "Start olvwm%mini-olwm.xpm%"		Restart /usr/openwin/bin/olvwm
+ "Start olwm%mini-olwm.xpm%"		Restart /usr/openwin/bin/olwm
+ "Start twm%mini-twm.xpm%"		Restart twm

#
# Provides a list of modules to fire off
#
DestroyMenu "Module-Popup"
AddToMenu "Module-Popup"
+ "AutoRaise"				Module FvwmAuto 300
+ "Event (aka Audio)%mini-speaker.xpm%" Module FvwmEvent
+ "Banner%mini.fvwm.xpm%"               Module FvwmBanner
+ "Button Bar%mini-ball.xpm%"		Module FvwmButtons
+ "Button Bar (Mini)%mini-ball.xpm%"	Module FvwmButtons MiniButtons
#+ "Clean-Up%mini-pencil.xpm%"           Module FvwmClean
+ "Configure%mini-hammer.xpm%"          Module FvwmConfig
+ "Debug%mini-bug2.xpm%"		Module FvwmDebug
#+ "Task bar%mini-exp.xpm%"		Module FvwmTaskBar
+ "Identify%mini-question.xpm%"		Module FvwmIdent
+ "Save %mini-diskette.xpm%"     	Module FvwmSave
+ "Save Desktop%mini-desktop.xpm%"	Module FvwmSaveDesk
+ "Pager%mini-pager.xpm%"		Module FvwmPager 0 0
+ "Window List%mini-windows.xpm%"	Module FvwmWinList
+ "Animate%mini-windows.xpm%"		Module FvwmAnimate
+ "Talk%mini-exclam.xpm%"		Module FvwmTalk
+ "Tile Windows%mini.window3d.xpm%"     Module FvwmTile
+ "Theme%mini-windows.xpm%"		Module FvwmTheme

#
# This menu will fire up some very common utilities
#
DestroyMenu "Utilities"
AddToMenu Utilities "Utilities" Title
+ ""					Nop
+ "Xterm (Medium)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 -bg beige -fg red -title "Color xterm" &
+ "Xterm (wheat3)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 -bg wheat3 -fg red -title "Color xterm" -geometry 80x48&
+ "Mail Xterm (10x20 font)%mini-term.xpm%" 	Exec xterm -sb -sl 500 -j -ls -fn 12x24 -bg black -fg green -geometry 80x50+230+40 &
+ ""					Nop
+ "Xmcd%mini-cd.xpm%"			Exec xmcd &
+ "Calculator%mini-calc.xpm%"		Exec xcalc &
+ "Manual pages%mini-book1.xpm%" 	Exec xman &
+ "Magnifying glass%mini-zoom.xpm%" 	Exec xmag &
+ "Oclock%mini-clock.xpm%" 		Exec oclock &
+ ""					Nop
+ "Applications%mini-x2.xpm%"		Popup Applications
+ "File Managers%mini-filemgr.xpm%"     Popup Filemanagers
+ "Games%mini-happy.xpm%"		Popup Games
+ "Logs%mini-x2.xpm%"                   Popup   Logs
+ "Shells%mini-term.xpm"		Popup Shells
+ ""					Nop
+ "Modules%mini-modules.xpm%"		Popup Module-Popup
+ ""					Nop
+ "Refresh Screen%mini-ray.xpm%"	Refresh
+ ""					Nop
+ "Exit Fvwm2%mini-stop.xpm%"		Popup Quit-Verify

#
# This defines the most common window operations
#
DestroyMenu "Window"
AddToMenu "Window" "Window Ops" Title
+ "&Move%mini-move.xpm%"        Function Move-or-Raise
+ "&Resize%mini-resize.xpm%"    Function Resize-or-Raise
+ "R&aise%mini-raise.xpm%"      Raise
+ "&Lower%mini-lower.xpm%"      Lower
+ "(De)Iconify"                 Iconify
+ "(Un)Stick"                   Stick
+ "(Un)Maximize%mini-max1.xpm%" Function maximize_func
+ ""                            Nop
+ "Kill%mini-bomb.xpm%"         Destroy
+ "&Close%mini-cross.xpm%"      Delete
+ ""                            Nop
+ "Switch to..."                WindowList
+ "Refresh Screen%mini-ray.xpm%" Refresh

#
# A trimmed down version of "Window Ops", good for binding to decorations
#
AddToMenu "Window-Ops2" "&Restore"        Iconify -1
+                       "&Move"           Move-or-Raise
+                       "&Size"           Resize-or-Raise
+ 			"(De)Iconify"     Iconify
+                       "(Un)S&tick"      Stick
+                       "(Un)S&hade"      WindowShade
+                       "Mi&nimize"       Iconify 1
+                       "Ma&ximize"       Maximize 100 100
+                       ""                Nop
+                       "&Kill"           Destroy
+                       "&Close	Alt+F4"   Delete

#========================================================================#

#
# One more complex function - couldn't be defined earlier because it used 
# pop-up menus
#
# This creates the "system" menu for the title-bar window-ops
# pop-up
#
AddToFunc "window_ops_func" "C" PopUp Window-Ops2
+              "M" PopUp Window-Ops2
+              "D" Delete  

#========================================================================#

#
# Mouse bindings
#

# First, for the mouse in the root window
# Button 1 gives the Utilities menu
# Button 2 gives the Window Ops menu
# Button 3 gives the WindowList (like TwmWindows)
# I use the AnyModifier (A) option for the modifier field, so you can hold down
# any shift-control-whatever combination you want!

#     Button	Context Modifi 	Function
Mouse 1		R   	A       Menu "Utilities" Nop
Mouse 2		R    	A       Menu "Window Ops" Nop
Mouse 3         R       A       WindowList
#Mouse 3	R    	A      	Module "winlist" FvwmWinList transient

# Now the title bar buttons
# Any button in the left title-bar button gives the window ops menu
# Any button in the first right title-bar button Iconifies the window
# Any button in the second title-bar button full-maximizes
# Note the use of "Mouse 0" for AnyButton.

#     Button	Context Modif 	Function
Mouse 0 	1       A       Function "window_ops_func"
Mouse 0 	2       A       Maximize 100 100
Mouse 0 	4       A       Iconify
Mouse 0 	3       A       Stick
Mouse 0 	5       A       WindowShade

# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-raise,
# and Resize-or-Raise. 
#
# Button 1 in the corner pieces, with any modifiers, gives resize or raise
Mouse 1		F	A	Function "Resize-or-Raise"
# Button 1 in the title, sides, or icon, w/ any modifiers, gives move or raise
Mouse 1		TS	A	Function "Move-or-Raise"

# Button 1 in an icons gives move for a drag, de-iconify for a double-click,
# nothing for a single click
# Button 2 in an icon, w/ any modifiers, gives de-iconify
Mouse 1		I	A	Function "Move-or-Iconify"
Mouse 2		I	A	Iconify

# Button 2 in the corners, sides, or title-bar gives the window ops menu
Mouse 2		FST	A	Function "window_ops_func"

# Button 3 anywhere in the decoration (except the title-bar buttons)
# does a raise-lower
Mouse 3		TSIF	A	RaiseLower

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm
Mouse 3         W       M       RaiseLower

#========================================================================#

# Now some keyboard shortcuts.

# Arrow Keys
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left	A	M	Scroll -10 +0
Key Right	A	M	Scroll +10 +0
Key Up		A	M	Scroll +0   -10
Key Down	A	M	Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10

# Keyboard accelerators
Key F1		A	M	Popup "Utilities"
Key F1		A	M	Popup "Utilities"
Key F2		A	M	Popup "Window Ops"
Key F3		A	M	Module "WindowList" FvwmWinList 
Key F4		A	M	Iconify
Key F5		A	M	Move
Key F6		A	M	Resize
Key F7		A	M	CirculateUp
Key F8		A	M	CirculateDown

#Page Up/Dapge Down keys are used to scroll by one desktop page
# in any context, press page up/down + control
# in root context, just pressing page up/down is OK
# 
# I prefer the non-wrapping scroll. These are for example purposes only
#Key Next	A       C       Scroll 100000 0
#Key Next	R       N       Scroll 100000 0  
#Key Prior	A       C       Scroll -100000 0
#Key Prior	R       N       Scroll -100000 0

Key Tab         A       M       Prev Focus
Key Tab         A       MS      Next Focus

Key Escape      A       C       WindowList

#========================================================================#

# Definitions used by the modules

#------------------ Pager
*FvwmPagerBack grey60
*FvwmPagerFore black
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
#*FvwmPagerHilight #c3c3c3
*FvwmPagerHilight beige 
*FvwmPagerIconGeometry 38x31+0+0
*FvwmPagerGeometry 131x178+1653+0
*FvwmPagerLabel 0 Desktop
*FvwmPagerLabel 1 Work
*FvwmPagerSmallFont 5x8

#------------------ FvwmButtons
*FvwmButtonsFore Black
*FvwmButtonsBack #c3c3c3
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry 65x500+7+1
*FvwmButtons(Swallow(UseOld,NoKill) "wmnd" "Exec wmnd -i eth0 &", Size 64 64, 1x1+0+0)
*FvwmButtons(Swallow(UseOld,NoKill) "wmnd" "Exec wmnd -i eth1 &", Size 64 64, 1x1+0+1)
*FvwmButtons(Swallow(UseOld,NoKill) "pclock" "Exec pclock --background=/home/cperez/paper.xpm -w --second-hand-color=red --second-hand-width=1 --second-hand-length=25 --hands-width=3 &" Size 64 64, 1x1+0+2)
*FvwmButtons(Swallow(UseOld,NoKill) "wmdate" "Exec wmdate &", Size 64 64, 1x1+0+3)
*FvwmButtons(Swallow(UseOld,NoKill) "wmcpuload" "Exec wmcpuload -bw &", Size 64 64, 1x1+0+4)
*FvwmButtons(Swallow(UseOld,NoKill) "wmmemload" "Exec wmmemload -bw &", Size 64 64, 1x1+0+5)
*FvwmButtons(Swallow(UseOld,NoKill) "wmxmms" "Exec wmxmms &", Size 64 64, 1x1+0+6)
*FvwmButtons: (Action beep, ActionIgnoresClientWindow, Swallow xeyes "Exec xeyes", 1x1+0+7)

# Layout: specify rows or columns, not both
*FvwmButtonsRows 9

#------------------ Identify
*FvwmIdentBack #000080
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

#------------------ FvwmWinList
*FvwmWinListBack #c3c3c3
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1
        
#------------------ FvwmTaskBar
#Style "FvwmTaskBar" NoTitle,BorderWidth 4,HandleWidth 4,Sticky,StaysOnTop,WindowListSkip,CirculateSkip
# I don't like the taskbar to stay to top, since it covers the bottom
# part of Netscape in full-screen mode:
#Style "FvwmTaskBar" NoTitle,BorderWidth 4,HandleWidth 4,Sticky,WindowListSkip,CirculateSkip

*FvwmTaskBarGeometry +0-0
*FvwmTaskBarFore Black
*FvwmTaskBarBack #c3c3c3
*FvwmTaskBarTipsFore black
*FvwmTaskBarTipsBack bisque
*FvwmTaskBarFont -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*
*FvwmTaskBarSelFont -adobe-helvetica-bold-r-*-*-*-120-*-*-*-*-*-*
*FvwmTaskBarAction Click1 Iconify -1,Raise,Focus
*FvwmTaskBarAction Click2 Iconify
*FvwmTaskBarAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmTaskBarUseSkipList
*FvwmTaskBarAutoStick
*FvwmTaskBarStartName Start
*FvwmTaskBarStartMenu StartMenu
# Just for fun, let's use the Linux penguin for the Start button:
*FvwmTaskBarStartIcon mini-penguin.xpm
#*FvwmTaskBarStartIcon mini-exp.xpm
*FvwmTaskBarShowTips
*FvwmTaskBarMailProg xterm -e mail

# Icon Manager functions

*FvwmIconMan*numManagers 1
*FvwmIconMan*Resolution  page
*FvwmIconMan*background  steelblue
*FvwmIconMan*foreground  white
*FvwmIconMan*font        7x13
*FvwmIconMan*usewinlist  true
*FvwmIconMan*drawicons   true
*FvwmIconMan*shape   true
*FvwmIconMan*followfocus true
*FvwmIconMan*sort    name
*FvwmIconMan*plainbutton          up white steelblue
*FvwmIconMan*selectbutton         down white steelblue
*FvwmIconMan*focusbutton          up white brown
*FvwmIconMan*focusandselectButton down white brown
*FvwmIconMan*titleButton          raisededge white steelblue

*FvwmIconMan*1*title           "All windows"
*FvwmIconMan*1*iconname        "FvwmIconMan: all"
*FvwmIconMan*1*format          "%c: %i"
*FvwmIconMan*1*dontshow        icon=Untitled
*FvwmIconMan*1*managergeometry 2x4+139+0
*FvwmIconMan*1*buttongeometry  200x0

*FvwmIconMan*transient*geometry 194x100
*FvwmIconMan*transient*dontshow icon=Untitled
*FvwmIconMan*transient*action   Mouse 0 A sendcommand select select Iconify

*FvwmIconMan*action Mouse     1 N sendcommand Iconify
*FvwmIconMan*action Mouse     2 N sendcommand WarpToWindow
*FvwmIconMan*action Mouse     3 N sendcommand "Module FvwmIdent FvwmIdent"
*FvwmIconMan*action Key  Left  N gotobutton Left, select
*FvwmIconMan*action Key  Right N gotobutton Right, select
*FvwmIconMan*action Key  Up    N gotobutton Up, select
*FvwmIconMan*action Key  Down  N gotobutton Down, select
*FvwmIconMan*action Key  q     N quit

# Window Animation with Icon Manager
*FvwmAnimateEffect Random
*FvwmAnimateIterations 12
*FvwmAnimateWidth 16
*FvwmAnimateTwist 0.500000
*FvwmAnimateDelay 1
*FvwmAnimateColor Gold2

# Audio Sounds
*FvwmEventCmd /usr/bin/play
*FvwmAudioDir /usr/share/sounds/wav
*FvwmEventDelay 1
*FvwmEvent startup hdream.wav
*FvwmEvent shutdown cfshut.wav

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 8 Jun 2003 22:11:32 +0000

> wrong.  There is quite a bit of legacy configuration in it.

It seems that you previously ran one of the session managers like xsm
or gnome-session (that started fvwm) and now you run fvwm directly.

There is enough amount of old syntax in your configuration to justify a
clean up (by reading man pages), you may also run fvwm24_convert.

Then remove SessionInitFunction and SessionRestartFunction and replace
them by a single StartFunction that starts all your modules.
Of course, removing ModulePath is a good thing too.

Regards,
Mikhael.