Subject: FVWM: Window Key as Modifier

From: Loren M Lang <[email-masked]>
Date: Mon, 16 Jun 2003 00:37:49 -0700 (PDT)

Is there a way to have fvwm use the
windows key as a fourth modifier key?
This would help me avoid conflicts
with other apps and prevent
complicated bindings like ctl-alt-1,
win-1 would be so much simpler.
Though I have a feeling this is really
and X issue, not fvwm.

- -- 
I sense much NT in you.
NT leads to Bluescreen.
Bluescreen leads to downtime.
Downtime leads to suffering.
NT is the path to the darkside.
Powerful Unix is.

Public Key: ftp://ftp.tallye.com/pub/lorenl_pubkey.asc
Fingerprint: B3B9 D669 69C9 09EC 1BCD  835A FAF3 7A46 E4A3 280C

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Haezebrouck, Sebastien" <[email-masked]>
Date: Mon, 16 Jun 2003 10:32:46 +0200

Loren,

Try "xmodmap -pm". This will give you the list of key modifiers.
On my box, windows key appears as Mod4 (Meta_L, Meta_R). Should be the same
for you unless you explicitely changed it elsewhere.

Then just bind your key to the modifier 4. For example:

Key	1	A	4	GotoPage 1 0

will map Win-1 to "GotoPage 1 0".

This is explained in the man page (oddly enough, you must look at the
beginning of the "Mouse" section to find modifiers definition).

Seb

-----Original Message-----
From: Loren M Lang [mailto:[email-masked]] 
Sent: Monday, June 16, 2003 9:38 AM
To: Fvwm Mailing List
Subject: FVWM: Window Key as Modifier

- -- 
I sense much NT in you.
NT leads to Bluescreen.