Subject: FVWM: Using right panel

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 12:25:40 -0400

I've modified the win95 setup script to suit my needs and would like to use
the right panel mechanism used by the 'desker'.  Unfortunately, I am having
trouble getting the syntax to do it right.

I am displaying my modified version of 'BarButtons; in the upper left corner
of the screen.  I use the following confiugration commands:

Style BarButtons  NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 4, CirculateSkip

DestroyModuleConfig BarButtons: *
*BarButtons: Fore Black
*BarButtons: Back #c3c3c3
*BarButtons: Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*BarButtons: Geometry +1+1
*BarButtons: Rows 1
*BarButtons: BoxSize smart

*BarButtons: (2x1, Swallow "FvwmPagerPager" 'FvwmPager FvwmPagerPager 0 0')
##*BarButtons: (Swallow (NoClose, UseOld) "bubblemon" "Exec exec bubblemon -d -k")
*BarButtons: (Title "xload", Swallow (NoClose, UseOld) "xload" \
              "Exec exec nice -16 \
              xload -nolabel -update 4 -bg grey59 -hl grey70 \
              -geometry -1500-1500")
*BarButtons: (Swallow (NoClose, UseOld) "wmCalClock" \
             'Exec wmCalClock -bc "#789C68" -tc black')
*BarButtons: (Padding 0 0, Container(Padding 0 0, Frame 2, Columns 3))
*BarButtons: (Icon mini.move1.xpm, Action Move)
*BarButtons: (Icon mini.resize3.xpm, Action Resize)
*BarButtons: (Icon mini.iconify1.xpm, Action Iconify)
*BarButtons: (Icon mini.maximize1.xpm, Action Maximize 90 90)
*BarButtons: (Icon mini.shade1.xpm, Action WindowShade)
*BarButtons: (Icon mini.stick1.xpm, Action Stick)
*BarButtons: (Icon mini.cross.xpm, Action Delete)
*BarButtons: (Icon mini.bomb.xpm, Action Destroy)
*BarButtons: (Icon mini.question.xpm, Action Module FvwmIdent)
*BarButtons: (End)
*BarButtons: (Title XTerm, Icon wterm.xpm, Action 'Exec "XTerm" xterm -bg beige -sl 1000 -ls -sb -T `uuname -l` &')

How do I adapt this so that I can have the BarButtons scroll right and left
and become visible/invisible?

-- 
Jake Colman                     

Principia Partners LLC                  Phone: (201) 209-2467
Harborside Financial Center               Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                  www.principiapartners.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 19 May 2003 08:40:55 +0200

> trouble getting the syntax to do it right.

With 2.5.6, you can shade a window in any direction.  Add a button
to the left and right of the bar to shade it towards the given
direction:

  *BarButtons: (+0+0, Action Next (BarButtons, CirculateHit) WindowShade west)
  *BarButtons: (-0+0, Action Next (BarButtons, CirculateHit) WindowShade east)

To unshade it, bind something to the window frame, e.g.

  Mouse 1 SF S WindowShade off

(shift-button 1 to unshade).

Bye

Dominik ^_^  ^_^

---

From: Michelle Konzack <[email-masked]>
Date: Mon, 19 May 2003 14:53:09 +0200

Hello Jake, 

>*BarButtons: Back #c3c3c3

<blablah killed>

>and become visible/invisible?

Can you send the configuration for the ButtonPanel ??? 

;-))

You have send only the Config for the ButtonBar 
Hmmm, I have this in my Config before I call the BarButtons:

Style ButtonPanel NoTitle
Style ButtonPanel NoHandles
Style ButtonPanel Sticky
Style ButtonPanel WindowListSkip
Style ButtonPanel BorderWidth 0
Style ButtonPanel CirculateSkip
Style ButtonPanel StaysOnTop

*ButtonPanel: Fore White
*ButtonPanel: Back NavyBlue
*ButtonPanel: Rows 1
*ButtonPanel: Frame 1
*ButtonPanel: Padding 0 0

*ButtonPanel: Geometry 4x48
*ButtonPanel: (Panel (right, steps 12, delay 0, position module top)
"BarButtons" "Module FvwmButtons BarButtons")

Have a nice Day
Michelle

-- 
Registered Linux-User #280138 with the Linux Counter, http://counter.li.org.
+--------------------------------------------------------------------------+
| Michelle's Internet-Service                    Inh.  Michelle Konzack    |
| FunkLAN-Providerin                                                       |
+--------------------------------------------------------------------------+

---

From: Jake Colman <[email-masked]>
Date: Thu, 22 May 2003 09:44:40 -0400

I'm sorry, Michelle, but I don't understand your question.

I use the following command

  AddToFunc StartFunction I FvwmButtons BarButtons

to display the buttons described by the BarButtons config statements.  What
is the "ButtonPanel" config you are asking for?

>>>>> "MK" == Michelle Konzack <[email-masked]> writes:

   MK> Can you send the configuration for the ButtonPanel ??? 

   MK> ;-))

   MK> You have send only the Config for the ButtonBar 
   MK> Hmmm, I have this in my Config before I call the BarButtons:

-- 
Jake Colman