Subject: FVWM: Installing Stable and Non-Stable at Same Time

From: Jake Colman <[email-masked]>
Date: Sat, 17 May 2003 22:37:05 -0400

I recently installed 2.4.15.  I'm curious to see the latest unstable release
2.5.x. Can both be installed simulataneously without harm?  How?

-- 
Jake Colman                     

Principia Partners LLC                  Phone: (201) 209-2467
Harborside Financial Center               Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                  www.principiapartners.com

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 May 2003 21:38:56 +0000

On 17 May 2003 22:37:05 -0400, Jake Colman wrote:
> 
> I recently installed 2.4.15.  I'm curious to see the latest unstable
> release 2.5.x. Can both be installed simulataneously without harm? 
> How?

Say, I have several fvwm source dirs (all from cvs branches) and several
fvwm installations. The current 2.5.x cvs tree is configured as:

  ./configure --prefix /opt/fvwm

2.4.x tree:

  ./configure --prefix /opt/fvwm-2.4

2.2.x tree:

  ./configure --prefix /opt/fvwm-2.2

The executable to run is /opt/fvwm/bin/fvwm and so on.

Regards,
Mikhael.

---

From: Jake Colman <[email-masked]>
Date: Tue, 20 May 2003 12:34:04 -0400

So by simply pointing at the version to be executed, it will find any
subordinate files that it needs?  It knows whih libexec to look in?

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

   >> release 2.5.x. Can both be installed simulataneously without harm? 

   MG> Say, I have several fvwm source dirs (all from cvs branches) and several
   MG> fvwm installations. The current 2.5.x cvs tree is configured as:

   MG>   ./configure --prefix /opt/fvwm

   MG> 2.4.x tree:

   MG>   ./configure --prefix /opt/fvwm-2.4

   MG> 2.2.x tree:

   MG>   ./configure --prefix /opt/fvwm-2.2

   MG> The executable to run is /opt/fvwm/bin/fvwm and so on.

   MG> Regards,
   MG> Mikhael.

-- 
Jake Colman

---

From: Dan Espen <[email-masked]>
Date: Tue, 20 May 2003 13:32:08 -0400

> subordinate files that it needs?  It knows whih libexec to look in?

The ModulePath gets built into the executable.
So it knows where to find modules.

There are a few pieces of Fvwm that are obtained thru your PATH
like FvwmCommand.

I often run multiple versions of Fvwm, I use a shell to pick
the right version, and the SHELL puts the version of Fvwm being
used at the front of the PATH.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Jake Colman <[email-masked]>
Date: Tue, 20 May 2003 15:43:31 -0400

I start fvwm through a VNC xstartup file containing the single line
"../bin/fvwm2&"

How would I use your idea in this scenario?

>>>>> "DE" == Dan Espen <[email-masked]> writes:

   >> subordinate files that it needs?  It knows whih libexec to look in?

   DE> The ModulePath gets built into the executable.
   DE> So it knows where to find modules.

   DE> There are a few pieces of Fvwm that are obtained thru your PATH
   DE> like FvwmCommand.

   DE> I often run multiple versions of Fvwm, I use a shell to pick
   DE> the right version, and the SHELL puts the version of Fvwm being
   DE> used at the front of the PATH.

   >> >> release 2.5.x. Can both be installed simulataneously without harm? 
   MG> Say, I have several fvwm source dirs (all from cvs branches) and sever
   >> al
   MG> fvwm installations. The current 2.5.x cvs tree is configured as:
   MG> 2.4.x tree:
   MG> 2.2.x tree:
   MG> Regards,
   MG> Mikhael.

   DE> -- 
   DE> Dan Espen                           E-mail: [email-masked]

-- 
Jake Colman

---

From: Dan Espen <[email-masked]>
Date: Tue, 20 May 2003 15:58:00 -0400

> How would I use your idea in this scenario?

The only fvwm2 I have in my initial path is a shell script called fvwm2.

It looks like this:

export FVWMHOME=/opt/public/src/fvwm/2.4.0
export FVWMHOME=/opt/public/src/fvwm/2.2.5
export FVWMHOME=/opt/public/src/fvwm/2.4.13
export FVWMHOME=/opt/public/src/fvwm/2.5.7
export PATH=$PATH:$FVWMHOME
exec $FVWMHOME/fvwm2 "$@"