Subject: Re: FVWM: Rox filer in a fvwm

From: Marco Righele <[email-masked]>
Date: Mon, 26 May 2003 02:11:00 +0200

Alle Saturday 12 April 2003 16:17, Dan Espen ha scritto:
> Ploum <[email-masked]> writes:
> > > See this thread:
> > >
> > > http://www.mail-archive.com/[email-masked]/msg03150.html
> > >
> > > Try:
> > >
> > > Exec nohup rox
> >
> > I try it.
> >
> > It's better because it works if another rox window is open.
> > If not, nothing happens !  What's the deal with this software ?
>
> I haven't looked at the source code, but I believe its
> trying to figure out if its invoked from a tty.
>
> Maybe you should contact the author.

(sorry for the late reply)
I asked to the rox mailing list. They say that the problem is probably due to 
the fact that Fvwm closes stdin in the Exec and later rox tries to divert it
to /dev/null. They suggest that Fvwm should do something similar instead of 
closing stdin directly.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 25 May 2003 23:04:47 -0400

> to /dev/null. They suggest that Fvwm should do something similar instead of 

Can you test what I just checked into CVS and let me know if it helps?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Marco Righele <[email-masked]>
Date: Mon, 26 May 2003 12:05:24 +0200

> Can you test what I just checked into CVS and let me know if it helps?

now it seems to work perfectly ! 
Thank you very much.

Marco