Subject: FVWM: Limiting the Number of Pager Desktops

From: Jake Colman <[email-masked]>
Date: Wed, 14 May 2003 14:49:34 -0400

Do I have to have four pager desktops?  I really only want a single desktop
with 6 pages.  I've tried a few things but it seems that I always get 4
desktops even if I can only view one at a time.

-- 
Jake Colman                     

Principia Partners LLC                  Phone: (201) 209-2467
Harborside Financial Center               Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                  www.principiapartners.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 14 May 2003 14:55:14 -0400

> desktops even if I can only view one at a time.

Try adding this to your .fvwm2rc:

DesktopSize 1x1

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Jake Colman <[email-masked]>
Date: Wed, 14 May 2003 15:03:39 -0400

>>>>> "DE" == Dan Espen <[email-masked]> writes:

   DE> Try adding this to your .fvwm2rc:

   DE> DesktopSize 1x1

As written in the man page:

     The (m by n) size (i.e. number  of  pages)  of  the  virtual
     desktops  can  be changed any time, by using the DeskTopSize
     built-in command.  All virtual desktops must  be  (are)  the

So this controls the number of pages in the desk, not the number of desks.

-- 
Jake Colman

---

From: Dan Espen <[email-masked]>
Date: Wed, 14 May 2003 15:13:10 -0400

> So this controls the number of pages in the desk, not the number of desks.

Sorry, desks are on the FvwmPager command line:

I guess you want:

AddToFunc StartFunction I Module FvwmPager 0 0

---

From: [email-masked]
Date: Wed, 14 May 2003 21:33:59 +0200

> desktops even if I can only view one at a time.

Sorry accidently replied to the person not the list

In the default configuration (fvwm style) the file modules contains a line
     
*DeskerPanelButtons: (Panel(right, steps 12, delay 0, position module top, indicator10)   
+"FvwmDesker" 'Module FvwmPager FvwmDesker 0 3') 
     
setting the 0 3 to 0 0 should fix your problem.
     
Regards,
Mark de Wever

>>>>> "c" == coredump  <[email-masked]> writes:
                                                    
   c> In the default configuration (fvwm style) the file modules contains a line

   c> *DeskerPanelButtons: (Panel(right, steps 12, delay 0, position module
   c> *top, indicator10) "FvwmDesker" 'Module FvwmPager FvwmDesker 0 3')

   c> setting the 0 3 to 0 0 should fix your problem.

Alt-PgDn and Alt-PgUp will still cycle through 4 desktops - only the desktops
won't be labeled.  Does that mean they exist or they do not?

I don't know whether they exist, I guess they do, but I guess an infinite number of desktops exits. 
This behaviour is set in the file bindings 

#------------------------------------------------------------------------------
# Page Up/Page Down keys are used to scroll by one desktop page
# in any context, press page up/down + control + alt
# in root context, just pressing page up/down is OK
#------------------------------------------------------------------------------

Key Next        A       CM      Desk  -1 0 0 3
Key Next        R       M       Desk  -1 0 0 3
Key Prior       A       CM      Desk  +1 0 0 3
Key Prior       R       M       Desk  +1 0 0 3  

Again the 3 is the number of desktops-1 you use.

Regards,
Mark de Wever