Subject: FVWM: Getting Layer of current window?

From: "Felix E. Klee" <[email-masked]>
Date: Fri, 2 May 2003 20:18:04 +0200

Hi,

there seems to be no $[w.layer] variable. How do i get the number of the 
layer that the current window is in? 

Felix

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 2 May 2003 19:26:33 +0000

> layer that the current window is in? 

There is no currently such variable, but it may be added.

Modules can receive the window layers.

Since there are only 12 (usually 3) layers, you may find a layer by a
simple query (several queries) like this:

  ThisWindow (Layer 4) Echo it is on the layer 4

Regards,
Mikhael.

---

From: "Felix E. Klee" <[email-masked]>
Date: Sat, 3 May 2003 17:18:48 +0200

On Friday 02 May 2003 21:26, Mikhael Goikhman wrote:
> > there seems to be no $[w.layer] variable. How do i get the number of
> > the layer that the current window is in?
>

No, there seem to be 20 layers. For example I can move a window to layer 20 
and a test similar to the one below verifies that it is indeed on layer 20. 
But I can't move it higher. Is that correct?

In addition, I have another question: 
With the following procedure I can move a window to layer 0.
    1. Open a window (e.g. an rxvt).
    2. Restart FVWM using the "Restart" function.
    3. Move the window to the default layer with "Layer default".
Is this a bug (I'm still using 2.5.6)?

>   ThisWindow (Layer 4) Echo it is on the layer 4

I wrote an initialization function that creates a function which sets the 
layer name of the current window as the title of a menu (this is useful for 
a window menu which allows changing of layers):

    AddToFunc Create-Move-To-Layer-Menu-Set-Title
    + I SendToModule FvwmPerl eval \
        for ($i=$f::minlayer; $i <= $f::maxlayer; $i++) { \
        command("AddToFunc Move-To-Layer-Menu-Set-Title I ThisWindow (Layer 
$i) AddToMenu Window-Operations-Move-To-Layer $i Title Top"); \
        }

I set the varaibles $f::minlayer and $f::maxlayer somewhere else to 1 and 
20, respectively.

Felix

---

From: "Felix E. Klee" <[email-masked]>
Date: Mon, 5 May 2003 20:27:28 +0200

Hello? Could someone please comment on my bug report and my other question?

Thanks

Felix

-- 
To contact me personally don't reply but send email to 
  felix DOT klee AT inka DOT de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].