Subject: Re: FVWM: Bad Icon bitmap depth

From: Sean Seery <[email-masked]>
Date: Fri, 23 May 2003 09:22:00 -0600

Dominik Vogt <[email-masked]> in a message dated "Fri, 23 May 2003 01:07:19 -0600 dubiously asserts..."

Dominik,

> > 
> > [FVWM][GetIconBitmap]: <<ERROR>> Window '<some window>' has a bad icon
> > bitmap depth 24(should be 1 or 8)! Ignoring icon bitmap.
> 
> You can do little about it.  The application is specifying an icon
> with 24 bitplanes, but your display has only 8 bitplanes.  Fvwm
> copies the pixmap into the window's icon window which of course
> uses only 8 bitplanes.
> 

Thanks for getting back to me. It appears that I am out of luck... or am
I? If I understand what you are saying, the icon window is limited to a
depth of 8. Is this a limitation of the video card/monitor or fvwm
itself? Replacing the monitor/video card is not horribly difficult...

Thanks,

Sean 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Sat, 24 May 2003 16:49:02 +0200

> itself? Replacing the monitor/video card is not horribly difficult...

Forget what I said earlier., I did not look carefully at what you
wrote:

>  visual id:    0x2b
> class:    DirectColor
> depth:    24 planes
> available colormap entries:    256 per subfield
> red, green, blue masks:    0xff, 0xff00, 0xff0000
> significant bits in color specification:    8 bits

So, xdpyinfo claims the display has 24 bit planes but unly 8
bitplanes can be used to specify colours?  That is strange indeed.
Fvwm uses the display's default depth, which is 8 on your system.
Yet, your X server tells the applications that they can use 24
bits.  I have no idea what this could mean.  It may be a bug in
the X server.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Sun, 25 May 2003 17:59:21 +1000

On 16:49 24 May 2003, [email-masked] <[email-masked]> wrote:
| Forget what I said earlier., I did not look carefully at what you
| wrote:
| 
| >  visual id:    0x2b
| > class:    DirectColor
| > depth:    24 planes
| > available colormap entries:    256 per subfield
| > red, green, blue masks:    0xff, 0xff00, 0xff0000
| > significant bits in color specification:    8 bits
| 
| So, xdpyinfo claims the display has 24 bit planes but unly 8
| bitplanes can be used to specify colours?  That is strange indeed.
| Fvwm uses the display's default depth, which is 8 on your system.
| Yet, your X server tells the applications that they can use 24
| bits.  I have no idea what this could mean.  It may be a bug in
| the X server.

Hmm. No, this is saying he has a 24 bit display where each colour component
is 8 bits deep. Which is normal.
-- 
Cameron Simpson <[email-masked]> DoD#743
http://www.cskk.ezoshosting.com/cs/

The more I ride the more I notice and the more fearful I become
        - somebody on rec.moto

---

From: [email-masked]
Date: Sun, 25 May 2003 11:08:39 +0200

> is 8 bits deep. Which is normal.

Ah, I see.  Still, the error message Sean got claims that the root
window has only 8 bitplanes:

                                ^^^

This number was returned by

  DefaultDepth(dpy,Scr.screen)

The DefaultDepth macro returns the depth of the root window of a
specific screen.

In any case, I think that

 a) It's a bug in the application(s),
 
and

 b) Posting the full output of xdpyinfo might help to resolve the
    problem.

Bye

Dominik ^_^  ^_^