Subject: FVWM: Xlib: sequence lost

From: Frank Liu <[email-masked]>
Date: Wed, 14 May 2003 11:39:29 -0700 (PDT)

I am trying the latest stable 2.4.15 with the rc file
copied from sample/system.fvwm2rc
Everything seems to be working except I can't start rxvt
from the menu.
I can start rvxt from a xterm without a problem, but if
I start it from the "root menu" (left click mouse), it
gives the following errors and flashes/quits.
starting xterm from "root menu" works fine.
I am using qnx.
Any ideas?
thanks!
frank

Xlib: sequence lost (0x1315b > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x12020 > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x10808 > 0xbc) in reply type 0x8!
Xlib: sequence lost (0x12020 > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x12020 > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x12008 > 0xbc) in reply type 0x8!
Xlib: sequence lost (0x10808 > 0xbc) in reply type 0x8!
Xlib: sequence lost (0x12020 > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x12008 > 0xbc) in reply type 0x8!
Xlib: sequence lost (0x10808 > 0xbc) in reply type 0x8!
Xlib: sequence lost (0x12020 > 0xbc) in reply type 0x20!
Xlib: sequence lost (0x12008 > 0xbc) in reply type 0x8!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frank Liu <[email-masked]>
Date: Wed, 14 May 2003 14:07:43 -0700 (PDT)

since I don't have this rxvt (2.7.10) problem with other
window managers (eg: blackbox). I looked at how they
spawn the child (rxvt). It seems they don't do "close(0)"
after the "fork".  so I tried to comment out close(0)
in "fvwm/builtins.c" and now my rxvt starts fine !!

Any side effect by commenting out that line? I guess
we may be ok since other people don't do it :)

ideas?

thanks!
frank

---

From: Dan Espen <[email-masked]>
Date: Wed, 14 May 2003 17:26:18 -0400

> we may be ok since other people don't do it :)

The close was put in because gmplayer wouldn't start since
it thought it was in an interactive environment.

-- 
Dan Espen                           E-mail: [email-masked]