Subject: FVWM: On-Screen Display?

From: "Felix E. Klee" <[email-masked]>
Date: Fri, 2 May 2003 20:17:31 +0200

Hi,

I want to have an on-screen display (e.g. for showing the current desktop 
number after switching desktops). When activated it should display a some 
text (with a transparent background) and disappear after say 0.5 sec. 

How could something like this be implemented? 

If there is a program that can display text with a transparent background 
then I think it's easy:
1. killall any running instances of that program.
2. Call the program with the text message.
3. killall any running instances with FVWM's Schedule command.
Does such a program exist? Any ideas how to refine the above setup (I'd like 
to remove that dangerous killall command)?

Felix

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Fri, 02 May 2003 14:23:38 -0400 (EDT)

"Felix E. Klee" <[email-masked]> wrote
on Fri, 2 May 2003 20:17:31 +0200:
>
> Subject: FVWM: On-Screen Display?
>
> Hi,
> 

xosd
http://www.ignavus.net/software.html

Cheers
Ric

---

From: "Felix E. Klee" <[email-masked]>
Date: Fri, 2 May 2003 23:21:22 +0200

On Friday 02 May 2003 20:23, Richard Lister wrote:
> > I want to have an on-screen display (e.g. for showing the current
> > desktop number after switching desktops). When activated it should
> > display a some text (with a transparent background) and disappear after
> > say 0.5 sec.
> >
> > If there is a program that can display text with a transparent
> > background then I think it's easy:
>
> xosd

Thanks, but this one has some problems. When I initiate several on-screen 
displays in a row (e.g. by quickly switching desktops) they overlap. TO 
avoid this I plan to use "killall osd_cat". However, osd_cat doesn't 
disappear immediatly after killing it, and therefore I'll still have 
overlapping osds. Do you have a solution for that? How do you use xosd?

Felix

-- 
To contact me personally don't reply but send email to 
  felix DOT klee AT inka DOT de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].