Subject: FVWM: Why grab the server whenever moving windows?

From: wang yin <[email-masked]>
Date: Sun, 11 May 2003 09:46:59 +0800

Hi,

Why FVWM grab the server whenever I move or resize windows?
All the other applications stopped updating the display that
time.

I think that's not good to grab the server. How can FVWM not to
do it?

Thanks.

-- 
Wang Yin
DA Lab, Tsinghua University,
100084
Beijing China
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ben Winslow <[email-masked]>
Date: 10 May 2003 21:55:31 -0400

> I think that's not good to grab the server. How can FVWM not to

FVWM needs to grab the X server to draw the XOR'd frame type it normally
uses.  You can change the move/resize style by putting this in your
fvwm2rc file:

Style "*" ResizeOpaque
OpaqueMoveSize -1

-- 
Ben Winslow <[email-masked]>

---

From: wang yin <[email-masked]>
Date: Sun, 11 May 2003 10:24:23 +0800

> uses.  You can change the move/resize style by putting this in your

I use OpaqueMoveSize -1,
But it seem it still grabs the server. My xdaliclock stopped
update time when I'm moving windows.

---

From: Dan Espen <[email-masked]>
Date: Sat, 10 May 2003 22:20:44 -0400

> update time when I'm moving windows.

What version of fvwm are you running?

When you move a window does the whole window move or
just an outline?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: wang yin <[email-masked]>
Date: Sun, 11 May 2003 10:37:35 +0800

> When you move a window does the whole window move or

I'm running fvwm 2.5.6.
The window move as a whole, not an outline.

Oh. It seems it's not grabbing the server now.
It's problem of xdaliclock, not FVWM.