Subject: FVWM: 8-bit graphics mode

From: Marcus Lundblad <[email-masked]>
Date: Thu, 8 May 2003 23:13:54 +0200 (CEST)

It seems my AGP port stopped worked.
So now I sit with an old S3 card I found in a drawer in the 
sysadmin's room at work.
The card has only 1 MB VRAM. So I tried to run 1024x768 in 8-bit mode.
But colours in FVWM is screwed up (white is blue). Does it depend on the
X-server? (The test provided by Xconfigurator (Redhat) seems quite OK).

I use FvwmBacker to show backround XPMs, but should FVWM allocate it's
colourmap before, since FvwmBacker is started from FVWM?

Or do I need to tell FVWM to use more colours?
What I find is the command line option -l.
It says in the manpage it uses colourcubes, doesn't this mean pure white
should be available.

//Marcus (who probably needs a new machine) 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 9 May 2003 10:20:53 +0200

> Or do I need to tell FVWM to use more colours?

No, you want to tell it to use *less* colours.  Try starting fvwm
with "--color-limit <number of colours>" to reduce the number of
colours used in pictures.  You should also use private colour maps
on all applications that support it (a la "netscape -install") and
refine the colours used in your applications so that they all use
the same colours.

> It says in the manpage it uses colourcubes, doesn't this mean pure white

Pure black and white are always available.  Hm.

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Fri, 09 May 2003 07:53:39 -0400

> Pure black and white are always available.  Hm.

I think, if the application requests a read-write color, there may
be a second attempt to allocate another white color cell.

-- 
Dan Espen                           E-mail: [email-masked]