Subject: FVWM: Anyone Using bubblemon on Solaris?

From: Jake Colman <[email-masked]>
Date: Thu, 22 May 2003 09:46:35 -0400

I would like to use bubblemon but the colors don't work correctly.  I've
tried this using both fvwm and cde under both VNC and Exceed so I am pretty
sure it's not a WM or X Server problem.  SO what _is_ the problem?  Is anyone
using it successfully on Solaris 7?  Any ideas what could be wrong?

-- 
Jake Colman                     

Principia Partners LLC                  Phone: (201) 209-2467
Harborside Financial Center               Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                  www.principiapartners.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dorothy Robinson <[email-masked]>
Date: Thu, 22 May 2003 23:38:12 -0700

Bubblemon is the wrong color on my Solaris box(en) too.  Instead of blue sky and 
water, the background is red.  It looks more like a bloody duck-hunting scene 
than an idyllic pond.  I took a quick look at the code and I think it's directly 
fiddling the bits of the color specification, so I suspect it assumes 
little-endian x86 byte order and doesn't do the right thing on the big-endian 
sparc. See <http://www.webopedia.com/TERM/b/big_endian.html> I'd probably learn 
something if I tried to fix it, but don't see when I'll ever get time.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Dorothy Robinson
http://www.twobarleycorns.net

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 23 May 2003 09:01:50 +0200

On Thu, May 22, 2003 at 11:38:12PM -0700, Dorothy Robinson wrote:
> Bubblemon is the wrong color on my Solaris box(en) too.  Instead of blue 
> sky and water, the background is red.  It looks more like a bloody 
> duck-hunting scene than an idyllic pond.

> I took a quick look at the code 
> and I think it's directly fiddling the bits of the color specification, so 
> I suspect it assumes little-endian x86 byte order and doesn't do the right 
> thing on the big-endian sparc.

Groan, that's guaranteed not to work on many systems.  X makes no
guarantees at all about the meaning of the individual bits.  I may
work by accident on true colour visuals, but is almost doomed to
fail on every display with less than 24 bitplanes.

> See 
> <http://www.webopedia.com/TERM/b/big_endian.html> I'd probably learn 

Bye

Dominik ^_^  ^_^

---

From: Jake Colman <[email-masked]>
Date: Fri, 23 May 2003 14:09:07 -0400

Dorothy,

Well I'm glad that it's not just me and that it must be something systemic.

I also took a look at th code and I think I have to disagree about your
analysis - unless I'm looking at the wrong thing.

I'm assuming that you are referring to the following code:

    r_air_noswap = (bm.air_noswap >> 16) & 0xff;
    g_air_noswap = (bm.air_noswap >> 8) & 0xff;
    b_air_noswap = (bm.air_noswap) & 0xff;

I added printf statements and and found that it does do the right thing.
Here is my output:

bm.air_noswap: 2299ff
r_air_noswap: 22
g_air_noswap: 99
b_air_noswap: ff

Assuming a color spec 0x2299ff, it does break up the RGB values correctly.

...Jake

>>>>> "DR" == Dorothy Robinson <[email-masked]> writes:

   DR> Bubblemon is the wrong color on my Solaris box(en) too.  Instead of blue sky
   DR> and water, the background is red.  It looks more like a bloody duck-hunting
   DR> scene than an idyllic pond.  I took a quick look at the code and I think it's
   DR> directly fiddling the bits of the color specification, so I suspect it
   DR> assumes little-endian x86 byte order and doesn't do the right thing on the
   DR> big-endian sparc. See <http://www.webopedia.com/TERM/b/big_endian.html> I'd
   DR> probably learn something if I tried to fix it, but don't see when I'll ever
   DR> get time.

-- 
Jake Colman