Subject: FVWM: Bad Icon bitmap depth

From: Sean Seery <[email-masked]>
Date: Thu, 22 May 2003 10:47:36 -0600

Hello,

I cannot seem to figure this out so here is my plaintive cry for help:

How do I get fvwm to support bitmaps with a depth of 24? Every time that I
minimize an application w/such an icon(such as mozilla), fvwm spits out
the following error:

[FVWM][GetIconBitmap]: <<ERROR>> Window '<some window>' has a bad icon
bitmap depth 24(should be 1 or 8)! Ignoring icon bitmap.

I've also tried experimenting w/the -I option setting the visual-id but
that appears not to have made a difference...

It appears that in a brief, inexperienced perusal of the source code that
this value is determined by something in XWMHints... I can't seem to find
any information other than a man page on XWMHints.

Any help would be appreciated.

Some pertinent information:

Solaris 8

fvwm 2.5.6 compiled on May 21 2003 at 08:12:32
with support for: XPM, PNG, Shape, XShm, SM, NLS

xdpyinfo:(truncated...)

name of display:    fletch:0.0
version number:    11.0
vendor string:    Sun Microsystems, Inc.
vendor release number:    6410
maximum request size:  262140 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, MSBFirst, 32
image byte order:    MSBFirst
number of supported pixmap formats:    3
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 132
focus:  window 0x80000d, revert to Parent

Here is the vis-id's I attempted to use:

    visual id:    0x2b
    class:    DirectColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits

    visual id:    0x2d
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff, 0xff00, 0xff0000
    significant bits in color specification:    8 bits

Thanks,

Sean

-----------------------------------------------------------------
| Sean Seery			| No disclaimer needed, lawyers |
| Senior Unix Administrator	| would not heed it anyways...	|
| Quris Inc.			|				|
| [email-masked]		| 				|
-----------------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 23 May 2003 09:08:36 +0200

> bitmap depth 24(should be 1 or 8)! Ignoring icon bitmap.

You can do little about it.  The application is specifying an icon
with 24 bitplanes, but your display has only 8 bitplanes.  Fvwm
copies the pixmap into the window's icon window which of course
uses only 8 bitplanes.

>     significant bits in color specification:    8 bits

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Sat, 24 May 2003 13:37:27 -0400

>     significant bits in color specification:    8 bits

There is a part of the output that shows the depth of the root
window.  What is it set to?

Maybe you should just post the whole thing.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 26 May 2003 09:42:55 +0200

> bitmap depth 24(should be 1 or 8)! Ignoring icon bitmap.

I think I've the solution of the problem (I read all the others mail
of this thread).

Sean has a 8/24 depth screen and the X server start with DefaultDepth = 8.
This is a classical situation (the X server can be configured to start
with DefaultDepth = 24, but as certain "old" apps need depth 8 for read-
write colours the default is depth 8; moreover on such hardware there is
no visual pbs by using certain app under depth 8 and other with depth 24).

BTW, since 2.5.6 fvwm detect this situation and fvwm choose to use the
best visual: TrueColor depth 24 (before 2.5.6 the user had to use
the --visual-id or --visual option; now fvwm need _no_ option).
A lot of apps use this logic too.

So, for applications supplied icon pixmap we have 3 acceptable depth:

- depth 1 (always ok)
- depth 8, the default depth
- depth 24, the fvwm depth

I've just committed a fix.

Sean can you try the next fvwm snapshot?

ftp://ftp.fvwm.org/pub/fvwm/devel/snapshots/fvwm-snap-20030526.tar.gz

should contains the fix and will pop-up soon (tomorrow).

Regards, Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 May 2003 09:50:26 +0200

> I've just committed a fix.

Cool.  Can you backport the fix to 2.4.16 too?  It looks fairly
simple, but I'm not sure I would catch all places I have to touch
to make the patch myself.

Bye

Dominik ^_^  ^_^

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 26 May 2003 11:43:44 +0200

> to make the patch myself.

Ok. But I do not think I should also backport the autodetection of
the best visual on such hardware. What do you think?

Regrads, Olivier

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 May 2003 17:09:02 +0200

> the best visual on such hardware. What do you think?

No, I'd only backport the bug fixes.

Bye

Dominik ^_^  ^_^