Subject: FVWM: StubbornIcons

From: Mandar Mitra <[email-masked]>
Date: Tue, 13 May 2003 17:26:34 +0530

Hello all,

How do I get StubbornIcons in fvwm2.4.15?

All the documentation (FAQ/man pages/Google)
that I looked at simply said this has been
obsoleted. Does that mean it is no longer
possible to have StubbornIcons, or that there
is an alternative way to get this effect?

Thanks for any help,
Mandar.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 13 May 2003 11:21:35 -0400

> is an alternative way to get this effect?

StubbornIcons was an fvwm1 feature:

Changes de-iconification behavior a bit. Instead of having windows
always de-iconify themselves on the current page they de-iconify into
their original position.

I don't think there is an equivalent fvwm2 feature.
Maybe someone else on the list can think of something.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Perry Hutchison <[email-masked]>
Date: Tue, 13 May 2003 09:56:41 -0700 (PDT)

> always de-iconify themselves on the current page they de-iconify into

I don't entirely get the distinction.  AFAIK, when I iconify an app, the
icon goes on the same page where the window was.  In order to de-iconify
by double-clicking the icon, I must be on that same page, and the app
window appears there (in its original position).  I just tried (in 2.2.4)
de-iconifying via the window list while on a different page, and the app
window still reappeared on its original page (where its icon had been),
and in its original position.  Thus it seems that what is described as
StubbornIcon behavior is now in some sense the normal behavior.  Is there
a third de-iconification method which I'm not thinking of?

> Maybe someone else on the list can think of something.

FvwmEvent can presumably be made to do almost anything :)

---

From: Dan Espen <[email-masked]>
Date: Tue, 13 May 2003 13:48:24 -0400

> a third de-iconification method which I'm not thinking of?

I'd have to bring up 1.24r to verify, but I think stubborn icons
work like this:

You iconify on page 1, then uniconify.
Then move the window to page 2. Then iconify.
It iconifies on page 1.

> FvwmEvent can presumably be made to do almost anything :)

Without a shifting of the viewport, I'm not sure.

---

From: Mandar Mitra <[email-masked]>
Date: Wed, 14 May 2003 12:07:48 +0530

> > window appears there (in its original position). 
...
> > a third de-iconification method which I'm not thinking of?

The behaviour I would like is the following:

I want all icons to be sticky, but windows should be
de-iconified to their original positions.

For example, say I have netscape on page 3. I iconify 
it. I move to page 1. I want the netscape icon to follow
me to page 1. But when I de-iconify netscape, fvwm should 
take me back to page 3. 

A combination of StickyIcons and StubbornIcons gave me
this behaviour with fvwm1.24r. I haven't been able to
figure out how to get this with fvwm2.4.15.

Right now, I'm looking at the man pages for IconBox and
IconMan to see if I can use those modules to get what I
want.

Mandar.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 14 May 2003 09:24:48 +0200

> a third de-iconification method which I'm not thinking of?

If the icon intersects the current page, deiconifying also puts
the window on the current page.  You usually won't notice that
unless you use StickyIcons.

> FvwmEvent can presumably be made to do almost anything :)

Bye

Dominik ^_^  ^_^

---

From: Mandar Mitra <[email-masked]>
Date: Wed, 14 May 2003 17:00:17 +0530

Ok, I tried out FvwmWinList and that serves my purpose.
The WinList is sticky, so I see all icons, no matter
what page I am on. I can bind the mouse buttons so that
clicking on an icon takes me to that window on the
appropriate page.

Mandar.