Subject: FVWM: Dialog Boxes Missing Title Bar!

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 12:22:20 -0400

I just upgraded from fvwm 2.2.2 to 2.4.15.  Used the win95 setup script as
the basis for my configuration, teaking it as neeed for my use.

Since the upgrade, dialogue boxes displayed by the application I am
developing no longer are decorated with a title bar.  What happened?  Which
setting might control this or where should I be looking?

Thanks for your help.  This is a real problem for me.

-- 
Jake Colman                     

Principia Partners LLC                  Phone: (201) 209-2467
Harborside Financial Center               Fax: (201) 946-0320
902 Plaza Two                          E-mail: [email-masked]
Jersey City, NJ 07311                  www.principiapartners.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johan Svedberg <[email-masked]>
Date: Fri, 16 May 2003 18:27:56 +0200

> setting might control this or where should I be looking?

Try searching your configuration file for "NoTitle".

-- 
Johan Svedberg, [email-masked], http://www.acc.umu.se/~winkle

---

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 12:36:06 -0400

>>>>> "JS" == Johan Svedberg <[email-masked]> writes:

   JS> Try searching your configuration file for "NoTitle".

Sure, I have NoTitle all over the place.  But it's with respect to
specifically named styles.  How do I derive from that why a dialogue from a
homegrown application should lose its title?  The app's windows all display
correctly.

-- 
Jake Colman

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 May 2003 12:46:33 -0400

> homegrown application should lose its title?  The app's windows all display

Use FvwmIdent to get your windows Name, Class, and Resource.
One of your NoTitle settings is matching your application windows.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 16 May 2003 17:51:35 +0000

> setting might control this or where should I be looking?

Use:

  Style * DecorateTransient

Regards,
Mikhael.

---

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 13:58:18 -0400

>>>>> "DE" == Dan Espen <[email-masked]> writes:

   DE> Use FvwmIdent to get your windows Name, Class, and Resource.
   DE> One of your NoTitle settings is matching your application windows.

Name:     Proceed?
Class:    PAS
Resource: PAS
NoTitle:  Yes

There are no entries like this in any of the config files.  What now?

-- 
Jake Colman

---

From: Dan Espen <[email-masked]>
Date: Fri, 16 May 2003 14:03:20 -0400

>    DE> One of your NoTitle settings is matching your application windows.

Looks like a dialog box.
Follow Mikhael's suggestion about DecorateTransients.

---

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 14:04:46 -0400

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

   MG> Use:

   MG>   Style * DecorateTransient

Where do I put this?  Anywhere I want as a standalone style?

-- 
Jake Colman

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 16 May 2003 18:32:31 +0000

> Where do I put this?  Anywhere I want as a standalone style?

It is unlikely that you use the opposite option, so the order does not
matter here, put this anywhere you want. Say, in ~/.fvwm/styles if you
use win-like config. Then Restart.

You may execute this command on the fly too, without Restart.

Regards,
Mikhael.

---

From: Jake Colman <[email-masked]>
Date: Fri, 16 May 2003 14:44:43 -0400

Thanks.  I added it to globalfeel since there were comments in that file
regarding transient windows.

>>>>> "MG" == Mikhael Goikhman <[email-masked]> writes:

   MG> It is unlikely that you use the opposite option, so the order does not
   MG> matter here, put this anywhere you want. Say, in ~/.fvwm/styles if you
   MG> use win-like config. Then Restart.

   MG> You may execute this command on the fly too, without Restart.

-- 
Jake Colman