Subject: FVWM: Simple Hack: A Run Dialog

From: "Felix E. Klee" <[email-masked]>
Date: Mon, 5 May 2003 23:09:41 +0200

Hi,

here is something I want to share. I found a very simple way to realize a 
run dialog (similar to grun, tkrun, etc.) using an rxvt. The trick is to 
bind the string " &\nexit\n" (I'm using bash) to the return key.

To start the dialog I created the following script:

.fvwm/run-dialog:
    #!/bin/sh
    rxvt +sb -name fvwm-run-dialog -title "run" -geometry 80x1+224+360 \  
    --keysym.0xFF0D: " &\nexit\n" -e bash --init-file \
    $HOME/.fvwm/run-dialog.bash-init

As an initialization script for bash it uses:

.fvwm/run-dialog.bash-init:
    export PS1=""

And in my .fvwm2rc I put:

    Style fvwm-run-dialog GrabFocus
    Key R A 4 Exec exec $[HOME]/.fvwm/run-dialog

Now, I can start the dialog using "Win-R".

Felix

-- 
To contact me in private don't reply but send email to 
  felix DOT klee AT inka DOT de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johan Svedberg <[email-masked]>
Date: Mon, 5 May 2003 23:27:01 +0200

> Now, I can start the dialog using "Win-R".

Why not just use FvwmForm?

-- 
Johan Svedberg, [email-masked], http://www.acc.umu.se/~winkle

---

From: "Felix E. Klee" <[email-masked]>
Date: Tue, 6 May 2003 09:34:32 +0200

> Why not just use FvwmForm?

I haven't looked at it. But I doubt that it is as simple to set up. In 
addition, with rxvt and bash I have tab completion. Is this possible with 
an FvwmForm based solution?

Felix

---

From: Dan Espen <[email-masked]>
Date: Tue, 06 May 2003 06:18:13 -0400

> an FvwmForm based solution?

I think its pretty simple to set up, but it doesn't have tab completion.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Thomas Stibor <[email-masked]>
Date: Fri, 9 May 2003 10:13:22 +0200

> an FvwmForm based solution?

I use FvwmForm with following small code

Key F4          A       M       Module FvwmForm MyRun

*MyRunWarpPointer
*MyRunFont *helvetica*m*r*n*18*
*MyRunButtonFont *helvetica*m*o*n*18*
*MyRunInputFont *cour*m*r*n*18*
*MyRunFore Red
*MyRunBack Gray
*MyRunItemFore Blue
*MyRunItemBack Gray
*MyRunLine center
*MyRunText "execute "
*MyRunInput Func 40 ""
*MyRunLine expand
*MyRunButton quit "Run" ^M
*MyRunCommand Exec $(Func)
*MyRunButton restart "Clear" ^R
*MyRunButton quit "Cancel" ^C
*MyRunCommand Nop

---

From: "Felix E. Klee" <[email-masked]>
Date: Mon, 12 May 2003 09:28:23 +0200

On Friday 09 May 2003 10:13, Thomas Stibor wrote:
> [...]

This looks indeed nice but it doesn't have tab completion. Anyways, with all 
these little hacks another idea comes into my mind:

Wouldn't it be nice to have a Wiki on the FVWM homepage where people can 
post their hacks and read about other peoples hacks?

Felix

---

From: Dan Espen <[email-masked]>
Date: Mon, 12 May 2003 17:26:06 -0400

> post their hacks and read about other peoples hacks?

Sorry for not answering until now.
Email, lately, has been painful.  I'm getting a spam barrage of
monumental proportions.  (Well, anyway, it's a lot of spam.)

As I understand it a wiki is a bunch of web sites linked together.
Fvwm does have a links page.  Isn't that sufficient?

---

From: "Paul Smith" <[email-masked]>
Date: 12 May 2003 17:43:20 -0400

%% Dan Espen <[email-masked]> writes:

  de> As I understand it a wiki is a bunch of web sites linked together.
  de> Fvwm does have a links page.  Isn't that sufficient?

No, you're thinking of a web ring.

A Wiki is a site where the content is user-modifiable, at any time,
simply by using your browser.  You write content in "Wiki style" which
is a very simple textual markup, like *bold*, _italic_, etc.  You can
make simple lists and headers, and most allow for the creation of simple
tables as well.

A Wiki is just about the best/least expensive way I've seen to have real
collaborative self-support on the web.

Start here:

  http://c2.com/cgi/wiki?WikiWikiWeb

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>   HASMAT--HA Software Mthds & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tom Alsberg <[email-masked]>
Date: Tue, 13 May 2003 12:07:31 +0300

> bind the string " &\nexit\n" (I'm using bash) to the return key.

Just something which might be of interest - some old hack of mine -
needs to be updated, and polished up a bit, but is generally useful
to me - written in C, though, so it has to be compiled, but it has 
the advantage of customizability through X resources and actions:

http://www.cs.huji.ac.il/~alsbergt/hacks/xexec-1.0.1.tar.gz

Any suggestions or patches welcome, naturally.

  -- Tom

--
  Tom Alsberg - certified insane, complete illiterate.
        e-mail: <[email-masked]>
	Homepage: http://www.cs.huji.ac.il/~alsbergt/
  * An idea is not responsible for the people who believe in it.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].