Subject: FVWM: Help with conditional commands

From: Tessa Lau <[email-masked]>
Date: Wed, 21 May 2003 16:25:12 -0400

I'm trying to create a function that warps the pointer to the
currently running browser (which could be Phoenix, Galeon, or
Mozilla), and if none of those browsers is running, starts up the
browser of my choice.  Here's what I have:

DestroyFunc Warp-or-Run-Browser
AddToFunc Warp-or-Run-Browser
+ "I" Next ("*Phoenix") Warp-and-Raise
+ "I" Cond (Match) Break
+ "I" Next ("Galeon") Warp-and-Raise
+ "I" Cond (Match) Break
+ "I" Next ("Mozilla") Warp-and-Raise
+ "I" Cond (Match) Break
+ "I" Exec /home/tlau/bin/browser

If I invoke the function when no browsers are running, it correctly
starts up a new browser.

If I invoke this function when Mozilla is running, however, the pointer
warps to the running Mozilla, and also starts up a second instance of
my browser.

What am I doing wrong?

--Tessa

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 May 2003 21:39:38 +0000

> warps to the running Mozilla, and also starts up a second instance of

Run a more current fvwm version where Break is not broken (quirk).

I think I already asked today on the list to always specify your version.

Regards,
Mikhael.

---

From: Tessa Lau <[email-masked]>
Date: Wed, 21 May 2003 18:09:04 -0400

Oops, I forgot to specify the version.  You're right, upgrading from
2.5.5 to 2.5.6 seems to fix it.  Thanks.

--Tessa

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 21 May 2003 23:56:55 +0200

> warps to the running Mozilla, and also starts up a second instance of

Are you sure that "Mozilla" match the name, icon name, class or resource
of your running Mozilla (try FvwmIdent)?
I need Mozilla* (or Mozilla-bin) for matching my Mozilla.

Regards, Olivier