Subject: FVWM: Anatomy of a key or mouse binding

From: Tim Johnson <[email-masked]>
Date: Sat, 26 Apr 2003 09:35:12 -0800

Hello All:
   I could use some further enlightenment on
   the topic of key and mouse bindings.
   In the man pages, web site and config files
   I see examples of bindings, but I've not
   been able to see a breakdown of the components.
   For instance:

   Key F1 R A Popup MenuFvwmRoot
          ^ ^
          | |__ "Needs clarification"
          |__ "Needs clarification"

  Could someone please point me to some very basic
  docs on command structure?
  Web pages, man pages, keywords to search for etc...
  Using fvwm-2.4.15. on RH 7.2

  Kind regards
-- 
Tim Johnson <[email-masked]>
      http://www.alaska-internet-solutions.com
      http://www.johnsons-web.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Apr 2003 14:01:59 -0400

>           |__ "Needs clarification"

Its described in the fvwm man page under the "Mouse" command.
(Both commands use the same meanings.)

The "R" is the context (in this case Root).
The "A" is the modifier (in this case any modifier).

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Tim Johnson <[email-masked]>
Date: Sat, 26 Apr 2003 10:46:56 -0800

Thanks Dan.