Subject: FVWM: FvwmEvent question

From: [email-masked]
Date: Tue, 8 Apr 2003 20:22:56 -0500

Hi all, I can't get FvwmEvent to play sounds..

here's what I am trying to do:

# play sounds
Module FvwmEvent SoundEvent
*FvwmEvent: Cmd Exec /usr/bin/rplay
*FvwmEvent: new_page ~/sounds/new_page.au
*FvwmEvent: new_desk ~/sounds/new_page.au

I have verified that typing /usr/bin/rplay ~/sounds/new_page.au does in fact
play a sound, but when I switch between pages - no sound.

help?

Jim

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 9 Apr 2003 01:44:49 +0000

> play a sound, but when I switch between pages - no sound.

Put quotes:

  *FvwmEvent: Cmd "Exec /usr/bin/rplay"

Regards,
Mikhael.

---

From: [email-masked]
Date: Wed, 9 Apr 2003 22:49:47 -0500

Hi, I put the "Exec /usr/bin/rplay" in quotes but still nothing. I think there is a larger
issue here. I can't figure out where the Module FvwmEvent should go or
what the syntax is for loading it. But all the example .fvwm2rc I have looked
at shows exactly what I have (below)
I have even tried preceeding it with AddToFunc InitFunction.

Thanks!

Jim

---

From: [email-masked]
Date: Wed, 9 Apr 2003 22:56:12 -0500

I got it!

DestroyModuleConfig FvwmEvent: *
Module FvwmEvent

*FvwmEvent: Cmd "Exec exec rplay "

*FvwmEvent: StartDelay 3
*FvwmEvent: Delay 1

*FvwmEvent: new_page "~/sounds/new_page.au"
*FvwmEvent: new_desk "~/sounds/new_page.au"

Thanks for getting me on the right path!

Jim

---

From: Michelle Konzack <[email-masked]>
Date: Wed, 23 Apr 2003 02:07:05 +0200

Hello Jim, 

>> > *FvwmEvent: new_desk ~/sounds/new_page.au

So 'SoundEvent' will be an ALIAS to FvwmEvent... 
Configure your Events like: 

*SoundEvent: Cmd Exec /usr/bin/rplay
*SoundEvent: new_page ~/sounds/new_page.au
*SoundEvent: new_desk ~/sounds/new_page.au

And then it must work for you

Michelle

-- 
Registered Linux-User #280138 with the Linux Counter, http://counter.li.org.
+--------------------------------------------------------------------------+
| Michelle's Internet-Service                    Inh.  Michelle Konzack    |
| FunkLAN-Providerin                                                       |
+--------------------------------------------------------------------------+