Subject: FVWM: What's wrong with my FVWM's menu?

From: [email-masked]
Date: Thu, 24 Apr 2003 12:24:13 +0800 (CST)

Hi all,

   I get a problem with fvwm's menu. My locale output is : zh_CN, and the menu in fvwm works well when I startx , however, after sometime(sometimes long , sometimes   
 one minute), the fvwm's menu is DISAPPEAR( that is when I click my mouse on root window, NO menu popup ). What's wrong with my fvwm? ( my fvwm is checked out from cvs, now version is 2.5.7)
   I notice the console output :
   [FVWM][FlocaleGetFontSet]:(-*-fixed-medium-r-...) Missing font charsets: GB2312.1980-0
   [FVWM][convert-charsets]:WARNING- Invalid byte sequence during conversion from UTF-8 to ISO-8859-1
    
    Can anybody help me?

    Thanks a lot!
------------------------------------------------------------------
Ȩ������ ���ſ�ͣ����黥�� ���Ŵ��顣
��ӭ�������������Ƶ����http://sms.people.com.cn

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 24 Apr 2003 10:20:57 +0200

>  one minute), the fvwm's menu is DISAPPEAR( that is when I click my mouse on root window, NO menu popup ). What's wrong with my fvwm? ( my fvwm is checked out from cvs, now version is 2.5.7)

What is your Mouse root binding fvwm config command? What happen
if you type in FvwmConsole: "Menu the_name_of_your_root_menu" ?

>    [FVWM][convert-charsets]:WARNING- Invalid byte sequence during conversion from UTF-8 to ISO-8859-1

Your locale is zh_CN and X want fonts with a GB2312.1980-0 charset.
And the "font name" -*-fixed-medium-r-... does not match a font with
a GB2312.1980-0 charset. Maybe you should install such fonts or 
change your font name in your fvwm config file(s). I've:

[olivier@snoopy unstable]$ xlsfonts -fn "*-GB2312.1980-0"
-isas-fangsong ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0
-isas-song ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0
-isas-song ti-medium-r-normal--24-240-72-72-c-240-gb2312.1980-0

>    [FVWM][convert-charsets]:WARNING- Invalid byte sequence during conversion from UTF-8 to ISO-8859-1

Then, maybe the title of one of your window use GB2312.1980-0 characters
(in UTF8) and cannot convert these characters to ISO-8859-1 chars (the
charset of the font you load ...).

Take a look at the "FONT NAMES AND FONT LOADING" and the 
"FONT AND STRING ENCODING" sections of the fvwm manual page for
more information.

Regards, Olivier