Subject: FVWM: lenght window title

From: [email-masked]
Date: Thu, 3 Apr 2003 16:21:24 +0000

how can i do the title of a window with fixed lenght?

ex: i want a title with 50% max lenght of titlebar.

thanks
-- 
 karnak
 E-Mail: [email-masked]
 E-Mail: [email-masked]
 IRC: irc.freenode.net #linux-malaga

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 14:58:22 +0000

> ex: i want a title with 50% max lenght of titlebar.

By title do you mean "title text" or "titlebar rectangle"?

If text, you may try using MultiPixmap in 2.5.x and specify RightEnd
(but I don't think it will work very well).

If you mean to make the whole titlebar shorter than the window width,
it is not currently possible.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 3 Apr 2003 17:08:27 +0000

oh, it is title text,
but i dont use a multipixmap, i'd like a multivector xD.

+ TitleStyle ActiveUp Vector 5 51x20@0 98x20@0 98x80@1 51x80@1 51x20@0
and when the title text of my windows is large i'd like that my vetor
title is more short, then it must have a multivector, it don't?
is there another option in fvwm for this?

thanks,

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 16:33:29 +0000

> is there another option in fvwm for this?

No, sorry, not currently. Nothing except for MultiPixmap works with the
actual text length.

I am going to rename MultiPixmap to Multi or MultiFace anyway, so maybe
in the future someone will add a support for Vector to it (what you call
multivector). Currently you should use transparent images for this.

See http://www.netspace.net.au/~rossh/fvwm-bug/description.html
to get an idea how to replace Vector with alpha-blended png.

Regards,
Mikhael.

---

From: [email-masked]
Date: Thu, 3 Apr 2003 18:48:39 +0000

> multivector). Currently you should use transparent images for this.

Multi pixmap
Multi vector
it is only a words game. xD (i didn't know call it)