Subject: FVWM: ButtonBar like in KDE but in plain fvwm2

From: Michelle Konzack <[email-masked]>
Date: Mon, 14 Apr 2003 16:12:56 +0200

Hello, 

I use Debian/stable and fvwm 2.4. I have trashed the default config 
and created my own one. 

Now I like to have a ButtonBar like in KDE which can be hidden to 
the left or the right. How can I do this ? 

I have a FvwmButtons which is working very well and I have two 
buttons on the left and on the right for hiding, but now ? 

Please Cc: me because I am not on the list (too much traffic for my 
Mobil-Telephone). 

Thanks
Michelle

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Apr 2003 10:32:29 +0200

> Please Cc: me because I am not on the list (too much traffic for my 

With 2.5.x, you can shade a window in any direction.  Make a
buttons on the left/right with the actions

  WindowShade W
  WindowShade E

THe buttons will be hidden too, but you can, for example, make a
right click on the window border unshade the window:

  Mouse 3 fs n WindowShade off

With 2.5.x you can also bind a different command on each window
border.  In my config, a double click on any of the eight parts of
the border shades the window in the given direction:

  Mouse 1 [     N   Function ResizeOrRaise W
  Mouse 1 ]     N   Function ResizeOrRaise E
  Mouse 1 -     N   Function ResizeOrRaise N
  Mouse 1 _     N   Function ResizeOrRaise S
  Mouse 1 <     N   Function ResizeOrRaise NW
  Mouse 1 >     N   Function ResizeOrRaise SE
  Mouse 1 ^     N   Function ResizeOrRaise NE
  Mouse 1 v     N   Function ResizeOrRaise SW

  AddToFunc ResizeOrRaise
  + C Raise
  + M Raise
  + M ResizeMaximize
  + D Current (Shaded) Raise
  + D WindowShade $0

This config allows to hide and show *any* window by double
clicking its border, not just FvwmButtons.

Bye

Dominik ^_^  ^_^

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 16 Apr 2003 11:05:07 +1000

I have a CVS checkout (because I want to try some recent stuff,
in particular the autohide ideas).

Naturally this lacks a configure file.

What command do I issue to get to the point where I can say "./configure ..."?

Cheers,
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

The problem with elections is that the government always wins.
	- Chris Rudram <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 Apr 2003 21:23:08 -0400

> What command do I issue to get to the point where I can say "./configure ..."

The commands are in utils/configure_dev.sh

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 16 Apr 2003 11:35:23 +1000

On 21:23 15 Apr 2003, Dan Espen <[email-masked]> wrote:
| Cameron Simpson <[email-masked]> writes:
| > What command do I issue to get to the point where I can say "./configure ..."
| The commands are in utils/configure_dev.sh

Thanks. Any reason this script can't be streamlined to this?

        set -x
        aclocal || exit 1
        autoheader || exit 2
        automake --add-missing || exit 3
        autoreconf || exit 4
        ./configure ${1+"$@"} || exit 5

The reason for final incantation is here:

	http://www.cskk.ezoshosting.com/cs/answers/shell-argument-magic.txt

I do the "set -x" thing for several of my own wrappers whose purpose is
to correctly perform some special incantation. It's succinct and actually
recites all the command arguments, versus the plain "echo command_name"
in the script as it is.

Cheers,

"What do you want to reinstall today?"	- Bob O`Bob <[email-masked]>

---

From: Dan Espen <[email-masked]>
Date: Tue, 15 Apr 2003 21:59:27 -0400

>         ./configure ${1+"$@"} || exit 5

None that I can think of.
Done.

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 16 Apr 2003 12:02:23 +1000

On 21:59 15 Apr 2003, Dan Espen <[email-masked]> wrote:
| Cameron Simpson <[email-masked]> writes:
| > On 21:23 15 Apr 2003, Dan Espen <[email-masked]> wrote:
| > | The commands are in utils/configure_dev.sh
| > Thanks. Any reason this script can't be streamlined to this? [...]
| None that I can think of.
| Done.

Thanks!

If you can keep your head while all those about you are losing theirs,
perhaps you don't understand the situation.
	- Paul Wilson <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michelle Konzack <[email-masked]>
Date: Wed, 23 Apr 2003 02:36:00 +0200

Hello Dominik, 

>> the left or the right. How can I do this ? 

Now I have gotten the FvwmButtons to be a Panel... which can I hide 
to the left... (goten the hint from the setup-95 DeskerPanel)

>With 2.5.x, you can shade a window in any direction.  Make a

Sorry, I am using Debian stable with fvwm v2.4

But nice the new functions... 

Thanks
Michelle

-- 
Registered Linux-User #280138 with the Linux Counter, http://counter.li.org.
+--------------------------------------------------------------------------+
| Michelle's Internet-Service                    Inh.  Michelle Konzack    |
| FunkLAN-Providerin                                                       |
+--------------------------------------------------------------------------+