Subject: FVWM: Getting rid of Icons, but keeping them in the Icon Manager

From: Robert Hathaway <[email-masked]>
Date: Thu, 17 Apr 2003 11:24:19 -0700 (PDT)

I'm trying to use the Icon Manager instead of icons. After starting the Icon Manager, I get both icons and the Icon Manager. So I tried to get rid of the icons using:

Style * NoIcon

But now when I iconify a window it disappears from the Icon Manager too. Can I get rid of the icons, but keep the iconified windows in the Icon Manager too?

Thanks,

Rob

---

From: Dan Espen <[email-masked]>
Date: Thu, 17 Apr 2003 14:33:43 -0400

Robert Hathaway <[email-masked]> writes:
> --0-1000801179-1050603859=:48356
> Content-Type: text/plain; charset=us-ascii
> 
> 
> I'm trying to use the Icon Manager instead of icons. After starting the Icon 
> Manager, I get both icons and the Icon Manager. So I tried to get rid of the 
> icons using:
> 
> Style * NoIcon
> 
> But now when I iconify a window it disappears from the Icon Manager too. Can 
> I get rid of the icons, but keep the iconified windows in the Icon Manager to
> o?

Icon Manager?

I'm guessing you tried FvwmIconBox but what you really want is FvwmIconMan.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Robert Hathaway <[email-masked]>
Date: Thu, 17 Apr 2003 18:38:43 -0700 (PDT)

Actually I am using FvwmIconMan.

Icon Manager?

---

From: parv <[email-masked]>
Date: Sat, 19 Apr 2003 00:10:22 -0400

Do wrap lines around 69 or so characters to give me no incentive to
ignore your mail otherwise.

in message <[email-masked]>,
wrote Robert Hathaway thusly...
>
> 
> I'm trying to use the Icon Manager instead of icons. After
> starting the Icon Manager, I get both icons and the Icon Manager.

You mean icons (scrattered) on the screen?

> So I tried to get rid of the icons using:
> 
> Style * NoIcon
> 
> But now when I iconify a window it disappears from the Icon
> Manager too. Can I get rid of the icons, but keep the iconified
> windows in the Icon Manager too?

Do you mean you do not want to have icons on the screen but want
application icons displayed besides the titles of icons?

If so, RTFM (M: FvwmIconMan)...

  *FvwmIconMan: [id] DrawIcons value
        If your version of fvwm is capable of  using  mini  icons,
        then this option  determines if FvwmIconMan displays the mini
        icons.  Otherwise, it generates an error  message.   "true"
        means  that mini  icons  are  shown for iconified windows,
        "false" that mini icons are never shown, and "always" that
        mini  icons  are  shown for all windows.

  - parv

--