Subject: FVWM: Repost: Mwm hints

From: "Dameron, Gregg" <[email-masked]>
Date: Fri, 11 Apr 2003 09:50:22 -0600

Hmm.  Radio silence.  Reposting.

>  -----Original Message-----
> From: 	Dameron, Gregg  
> Sent:	Monday, April 07, 2003 6:39 PM
> To:	[email-masked]'
> Subject:	Mwm hints
> 
> Running 2.4.7 on Solaris.
> 
> The handling of "MWM_FUNC_CLOSE", in the case where it is turned off,
> differs among (non-mwm) window managers.  Some remove (or dim) the "Close"
> button in the titlebar (if one is defined), as if compensating for the
> fact that there is no such thing as "MWM_DECOR_CLOSE" that would permit
> the Motif GUI developer to hide it programmatically.
> 
> Our configuration is set up to maximally support Motif apps; i.e.,
> 
> Emulate Mwm
> Style * MwmFunctions
> Style * MwmDecor
> Style * NoOverride
> 
> The 2.4.7 release appears to make a strict distinction between function
> and decoration hints.  An application that has MWM_FUNC_CLOSE disabled
> will have a visible "Close" button that simply beeps when clicked.  If a
> Motif GUI developer wishes to hide the "Close" button, he must also add a
> "Style <class> NoButton <n>" to the configuration.  
> 
> My question is this:  Does the latest stable release handle MWM_FUNC_CLOSE
> differently, perhaps obviating the need for the "NoButton"?  (I see that
> some Mwm hints work was done for 2.4.9.)
> 
> Regards,
> Gregg Dameron
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 12 Apr 2003 13:57:02 +0200 (CEST)

> > "Style <class> NoButton <n>" to the configuration.  

Yes, as far as I know, Motif distincts between function hints and
decoration hints.
So, function hints determine which functions are permitted on a window and
decoration hints which window decorations are visible.

And MWM doesn't have a close button, so probably there is no Motif hint to
turn off the close button.

But, I suppose EWMH might define such an hint.
I'm not sure, since I don't have a close button in my FVWM...

//Marcus