Subject: FVWM: fvwm-themes problems

From: Klaus Zeitler <[email-masked]>
Date: 23 Apr 2003 18:23:45 +0200

Hi,

I thought it's about time to give fvwm-themes a try.
(version 0.6.2 built for SunOS 5.8).

We're all forced here in my company to use the dt login/session manager.
I'm using a Dtsession X-resource, i.e. 
"Dtsession*wmStartupCommand:    /usr/local/gnu/bin/fvwm2",
to start fvwm instead of CDE (that's what we're supposed to use).
The docu says to add the startup command to .xsession or .xinitrc
(that's how I do it on my Linux PC), but AFAICS this Dtsession
doesn't read either .xinitrc nor .xsession.

I changed the startup command to "/usr/local/gnu/bin/fvwm-themes-start"
and this worked (the only problem I saw was with FvwmBanner see below)
until I tried to select one of the themes. Than I had
these nice color problems, e.g. menues in black on black.
Thus I've changed the Startup command now to
"/usr/local/gnu/bin/fvwm-themes-start -- -l 61" but now my error log has
a lot more to say:

--- snip ---
awk: syntax error near line 1
awk: illegal statement near line 1
Cannot parse color "CDE_COLOR2_BG"
Cannot parse color "CDE_COLOR2_FG"
Cannot parse color "CDE_COLOR3_BG"
Cannot parse color "CDE_COLOR3_FG"
Cannot parse color "CDE_COLOR1_BG"
Cannot parse color "CDE_COLOR1_FG"
Cannot parse color "CDE_COLOR3_BG"
Cannot parse color "CDE_COLOR3_FG"
Cannot parse color "CDE_COLOR1_BG"
Cannot parse color "CDE_COLOR1_FG"
Cannot parse color "CDE_COLOR6_BG"
couldn't create gradient
... [ more Cannot parse color and couldn't create gradient messages]
[FVWM][parse_colorset]: <<ERROR>> can't do Transparent when root_depth!=fvwm_depth
[FVWM][GetWindowSizeHints]: <<WARNING>> FvwmBanner window 0x5000001 has broken (min_width) size hints
Please send a bug report to the application owner,
	you may use [email-masked] as a reference.
hint override = 0
flags = 373
min_width = -12970356, min_height = -12975536, max_width = -12970356, max_height = -12975536
width_inc = 1, height_inc = 1
min_aspect = 0/0, max_aspect = 0/0
base_width = -12970356, base_height = -12975536
win_gravity = 1
--- snip ---

Thanks for your help

Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
Sodd's Second Law:
 Sooner or later, the worst possible set of circumstances is bound to occur.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Apr 2003 23:12:56 +0000

> (version 0.6.2 built for SunOS 5.8).

But what is your fvwm version?

> Cannot parse color "CDE_COLOR2_FG"

Seems like your awk is not very friendly. I think that I tested awk
without GNU extensions and it worked. Anyway, either don't load
colors@cde and colors@luthien or replace the 2 occuriences of awk with
gawk in 2 files: themes/{cde,luthien}/colors/main.

> [FVWM][parse_colorset]: <<ERROR>> can't do Transparent when root_depth!=fvwm_depth

I prefer someone else to answer this.

> base_width = -12970356, base_height = -12975536

Heh, it is funny, I can't reproduce this. Maybe someone else can answer.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 24 Apr 2003 09:53:58 +0200

> But what is your fvwm version?

Yes, that info may help a lot.

> > [FVWM][parse_colorset]: <<ERROR>> can't do Transparent when root_depth!=fvwm_depth

Yes  the Transparent colorset cannot always be used if the root depth is
different than the fvwm depth.
Can you send the output of xdpyinfo. If you use 2.5.6 (I will recommend
a recent snapshot any way), can you type "PrintInfo Colors" in FvwmConsole
and sent the stderr output of this command which should look like:

FVWM info on colors
  Visual ID: ....

Regards, Olivier

---

From: Klaus Zeitler <[email-masked]>
Date: 24 Apr 2003 10:55:54 +0200

>>>>> "Mikhael" == Mikhael Goikhman <[email-masked]> writes:
    Mikhael> 
    >> (version 0.6.2 built for SunOS 5.8).
    Mikhael> 
    Mikhael> But what is your fvwm version?

oops, sorry I forgot, 2.5.5

    >> Cannot parse color "CDE_COLOR2_FG"

    Mikhael> Seems like your awk is not very friendly. I think that I tested
    Mikhael> awk without GNU extensions and it worked. Anyway, either don't
    Mikhael> load colors@cde and colors@luthien or replace the 2 occuriences
    Mikhael> of awk with gawk in 2 files: themes/{cde,luthien}/colors/main.

that was the "SUN standard" awk, i.e. /usr/bin/awk.
I've made sure that "GNU Awk 3.1.1" is used instead and now it works fine.

Thanks

Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
If you pick up a starving dog and make him prosperous,
he will not bite you. This is the principal difference
between a dog and a man.                 -- Mark Twain
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Klaus Zeitler <[email-masked]>
Date: 25 Apr 2003 12:25:02 +0200

>>>>> "Olivier" == Olivier Chapuis <[email-masked]> writes:
    Olivier>
    >> But what is your fvwm version?
    Olivier>
    Olivier> Yes, that info may help a lot.
    Olivier>

sorry, 2.5.5

    >> > [FVWM][parse_colorset]: <<ERROR>> can't do Transparent when root_depth!=fvwm_depth
    Olivier>
    Olivier> Yes  the Transparent colorset cannot always be used if the root
    Olivier> depth is different than the fvwm depth.  Can you send the output
    Olivier> of xdpyinfo. If you use 2.5.6 (I will recommend a recent snapshot
    Olivier> any way), can you type "PrintInfo Colors" in FvwmConsole and sent
    Olivier> the stderr output of this command which should look like:

ok, I've attached xdpyinfo output

Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
A preposition is not a good thing to end a sentence with.

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 25 Apr 2003 21:27:33 +0200

>From this it seems that you have a 8bit/24bit display and the default
visual used is 8bit (this can be changed by the system administrator
only I think). With 2.5.5 without option the default visual is used so
you run fvwm with at most 256 colors as your display can support 2^24
colours! You should start fvwm as

	fvwm --visual TrueColor

or

	fvwm-themes-start -- --visual TrueColor

With 2.5.6, the situation is auto-detected and no option is needed.
Any way I strongly recommend the use of 2.5.6 (or a recent snapshot)
under your situation. I will be interested by the result of an upgrade
to 2.5.6 (as now I do not understand the "parse_colorset" error msg).

Regards, Olivier

---

From: Klaus Zeitler <[email-masked]>
Date: 30 Apr 2003 14:42:15 +0200

Olivier> 
    >> [FVWM][parse_colorset]: <<ERROR>> can't do Transparent when root_depth!=fvwm_depth
    Olivier> With 2.5.6, the situation is auto-detected and no option is
    Olivier> needed.  Any way I strongly recommend the use of 2.5.6 (or a
    Olivier> recent snapshot) under your situation. I will be interested by
    Olivier> the result of an upgrade to 2.5.6 (as now I do not understand the
    Olivier> "parse_colorset" error msg).

good tip, after the upgrade to 2.5.6 the error message from above disappeared.
Thanks

Klaus

-- 
 ------------------------------------------
|  Klaus Zeitler      Lucent Technologies  |
|  Email:             [email-masked]  |
 ------------------------------------------
---
Have you ever noticed that the people who are always trying to tell you,
"There's a time for work and a time for play," never find the time for play?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].