Subject: FVWM: Transparent Pager

From: "Mario Domgörgen" <[email-masked]>
Date: 03 Apr 2003 01:56:11 +0200

Hey list,

how can i get a transparent pager? I know that it works as i have seen
it on some screenshots, i tried a few things (transparent colorsets) but
i don't get the bend... Probably it's a problem that my pager is in
FvwmButton? My version is 2.5.6

Looking forward for some help!

Mario

-- 
Stay the patient course
Of little worth is your ire
The network is down
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ben Mathews <[email-masked]>
Date: Wed, 02 Apr 2003 20:15:37 -0500

Mario Domgörgen wrote:

>Hey list,
>
>how can i get a transparent pager?  
>
>Mario
>
>  
>

This is sort of a minimal config that should get you going.

############################## Define Colorsets 
#############################
Colorset 0 fg white, Transparent
Colorset 5 fg blue, Transparent

ModuleSynchronous Timeout 5 FvwmTheme

DeskTopSize 1x4

ColormapFocus FollowsMouse
WindowFont -*-fixed-bold-*-*-*-15-*-*-*-*-*-*-*

# Styles for various Fvwm modules:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip
Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style "FvwmPager"   StaysOnTop, BorderWidth 0, HandleWidth 0, 
RootTransparent, ParentalRelativity

######################## Initialization Functions 
############################
DestroyFunc StartFunction
AddToFunc StartFunction
 + I ModuleSynchronous FvwmTheme
 + I exec xv -quit -root -random /home/custom/wallpaper/*.jpg; fvwm-root -d
 + I Module FvwmPager 0 3

DestroyFunc ReStartFunction
AddToFunc ReStartFunction
+ I exec xv -quit -root -random /home/custom/wallpaper/*.jpg; fvwm-root -d

########################### Pager #########################################

*FvwmPager: Rows       4
*FvwmPager: Columns    1
*FvwmPagerGeometry -15-35
*FvwmPagerLabel 0 "Web"
*FvwmPagerLabel 1 "Devel"
*FvwmPagerLabel 2 "Other"
*FvwmPagerLabel 3 "Other2"
*FvwmPager: Colorset * 5
*FvwmPager: HilightColorset * 0

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 02:38:07 +0000

If you already post your config, some comments...

> ############################## Define Colorsets 

You start FvwmTheme here for the first time.
In 2.5.x you don't need it (i.e. remove this line).

> WindowFont -*-fixed-bold-*-*-*-15-*-*-*-*-*-*-*

Don't use WindowFont, see the man page.

> RootTransparent, ParentalRelativity

There is no such style RootTransparent.

> + I ModuleSynchronous FvwmTheme

You start it here for the second time.

> + I exec xv -quit -root -random /home/custom/wallpaper/*.jpg; fvwm-root -d

Do you want xv and fvwm-root to be run twice on restarts?
Remove ReStartFunction function.

> *FvwmPagerGeometry -15-35

Well, is not it nice to be consistent and use colon-space here too? :)

Regards,
Mikhael.

---

From: "Mario Domgörgen" <[email-masked]>
Date: 03 Apr 2003 12:05:37 +0200

> This is sort of a minimal config that should get you going.

I try that and it works for normal pager, but not for pager in
FvwmButton?! Is it possible to get tranperancy there?

Mario

-- 
With searching comes loss
and the presence of absence:
"My Novel" not found.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 10:59:39 +0000

> FvwmButton?! Is it possible to get tranperancy there?

You should make FvwmButtons transparent too using the similar technology.

Regards,
Mikhael.

---

From: "Mario Domgörgen" <[email-masked]>
Date: 03 Apr 2003 13:52:58 +0200

> You should make FvwmButtons transparent too using the similar technology.

Oh, my FvwmButtons is already tranparent, therefor i also want the pager
to be tranparent as now it looks quite ugly... one part tranparent the
other not ... :) 

To achieve a tranparent FvwmButtons i put *FvwmPager: Pixmap none in my fvwm2rc

Mario

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 14:45:00 +0000

> To achieve a tranparent FvwmButtons i put *FvwmPager: Pixmap none in my fvwm2rc

Ok, just typed in FvwmConsole and it works without any problems:

  Colorset 50 Transparent, bg pink3, fg gray20
  Style FvwmButtons-Trans ParentalRelativity

  DestroyModuleConfig FvwmButtons-Trans: *
  *FvwmButtons-Trans: Colorset 50
  *FvwmButtons-Trans: (Icon /some/existing/transparent/image.png)
  *FvwmButtons-Trans: (Swallow FvwmPager-Trans "FvwmPager FvwmPager-Trans")

  DestroyModuleConfig FvwmPager-Trans: *
  *FvwmPager-Trans: Colorset * 50

  FvwmButtons FvwmButtons-Trans

Regards,
Mikhael.

---

From: "Mario Domgörgen" <[email-masked]>
Date: 03 Apr 2003 18:36:50 +0200

Mikhael Goikhman <[email-masked]> writes:

> Ok, just typed in FvwmConsole and it works without any 

That's the way to go! Thank you ... Could it be that you send the mail
to me and the list? Is this here standard? 

Mario

-- 
5) People say Linux is ugly. How does that make you feel?
Torvalds: They'll be the first against the wall when the revolution comes.
	  Let's see just how ugly they think it is when they have a few
	  bulletholes in them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Apr 2003 17:04:31 +0000

> to me and the list? Is this here standard? 

There is no relable way to know for me whether you are subscribed or not
unless you state this explicitely in every message, so, yes, it is the
practice here to reply to the one who asks. You may configure procmail to
avoid duplicates.

If you use one of the mailers that supports Mail-Followup-To: header, you
can configure it to not include your address in replies. Then others with
a good mailer (like me) will use "group reply" and this will only use the
list address.

I don't know whether your mailer (Gnus v5.9.0) supports Mail-Followup-To,
mutt does using 'subscribe' option.

Regards,
Mikhael.