Subject: FVWM: Command Line args lost over a Restart

From: "J.R. Oldroyd" <[email-masked]>
Date: Sun, 13 Apr 2003 17:00:44 -0400

I recently upgraded from Fvwm 2.2.2.5 to 2.4.14 and then on to 2.5.6.

I notice with the 2.4 and 2.5 versions, that Fvwm loses my command line
arguments over a Restart.  Preprocessing of the fvwmrc file is therefore
incorrect after the restart.

To illustrate, this is what I do.  I invoke fvwm like this:

fvwm2 -cmd "FvwmCpp $HOME/.fvwm2rc -DDPY$DISPSZ=1 ${APM:+-DAPM=1}" &

This will define two Cpp variables: DPYnnnxnnnn and APM.  I then test
these and do appropriate things to the display, based on its size and
whether or not APM power management is in use.  On the first run, this
works fine.

However, after a restart, it seems these arguments are completely lost
as neither variable is set when the fvwmrc file is re-processed.

FWIW, this worked perfectly in 2.2.2.5, even after a restart.

	-jr

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 13 Apr 2003 23:10:04 +0200 (CEST)

> as neither variable is set when the fvwmrc file is re-processed.

What command do you use to restart?
(The full line from the menu item or keybinding that restarts).

//Marcus

---

From: Dan Espen <[email-masked]>
Date: Sun, 13 Apr 2003 17:19:36 -0400

> FWIW, this worked perfectly in 2.2.2.5, even after a restart.

There have been some changes in the area of restart.
This is from the man page:

              If  you  need  a  native restart, we suggest
              only to use Restart command without  parame
              ters  unless  there  is a reason not to.  If
              you still use an old command 'Restart fvwm2'
              that  was correct in 2.2.x, all current com
              mand line arguments are  lost.   On  Restart
              without parameters or with --pass-args, they
              are preserved.

There are some other details in the man page that may be of interest.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: "J.R. Oldroyd" <[email-masked]>
Date: Sun, 13 Apr 2003 17:20:29 -0400

<< IMPORTANT INFORMATION! >>

This is an automated message. 

The message you sent (attached below) requires confirmation
before it can be delivered. To confirm that you sent the
message below, just hit the "R"eply button and send this
message back (you don't need to edit anything). Once this is
done, no more confirmations will ne necessary.

This email account is protected by:
Active Spam Killer (ASK) V2.3.beta1 - (C) 2001-2002 by Marco Paganini
For more information visit http://www.paganini.net/ask

--- Original Message Follows ---

To: "J.R. Oldroyd" <nn>
Cc: [email-masked]
Subject: Re: FVWM: Command Line args lost over a Restart 
Date: Sun, 13 Apr 2003 17:19:36 -0400
From: Dan Espen <[email-masked]>

---

From: "J.R. Oldroyd" <[email-masked]>
Date: Sun, 13 Apr 2003 23:55:29 -0400

Bound to a menu item, I have:

+       "%mini.fvwm.xpm%Restart Fvwm" Restart fvwm2

	-jr

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 14 Apr 2003 09:29:45 +0000

> +       "%mini.fvwm.xpm%Restart Fvwm" Restart fvwm2

So, it does exactly what you request, starts the executable without any
arguments. Either add here command line arguments you need or better yet,
use "Restart" to preserve original arguments.

Also, please always see the X output, you will find useful error messages:

<<WARNING>> `Restart fvwm2' might not do what you want, see the man page.
	Use Restart without parameters if you mean to restart the same WM.

Regards,
Mikhael.

---

From: "J.R. Oldroyd" <[email-masked]>
Date: Mon, 14 Apr 2003 11:24:43 -0400

Got it.  In fact, I see now that this change is even documented in
the man page!  Sorry for not having rtfm'd!

Well, with this working, my 2.2.2.5 fvwmrc now works perfectly on
2.5.6.  And, 2.5.6 is considerably faster!  Great work folks, and
thank you.

	-jr