Subject: FVWM: Rox filer in a fvwm

From: Ploum <[email-masked]>
Date: Sat, 12 Apr 2003 15:18:22 +0200

Hi,

I'm using Rox filer as file manager.  http://rox.sourceforge.net

But I'm start rox with a terminal, because it doesn't work in fvwm !

I simply put an entry "Exec exec rox" in my menu. I try again with "rox
-n" and "xterm -e rox"(really bad but ...).
No one works ! ! !  Nothing happens !

What's the matter with this application ?

thx

Ploum
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 12 Apr 2003 09:23:26 -0400

> What's the matter with this application ?

See this thread:

http://www.mail-archive.com/[email-masked]/msg03150.html

Try:

Exec nohup rox

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Ploum <[email-masked]>
Date: Sat, 12 Apr 2003 16:01:55 +0200

> http://www.mail-archive.com/[email-masked]/msg03150.html
I try it.

It's better because it works if another rox window is open.
If not, nothing happens !  What's the deal with this software ?

I read all the thread, but I don't learn more than the nohup option.

Thx anyway

---

From: Dan Espen <[email-masked]>
Date: Sat, 12 Apr 2003 10:17:53 -0400

> If not, nothing happens !  What's the deal with this software ?

I haven't looked at the source code, but I believe its
trying to figure out if its invoked from a tty.

Maybe you should contact the author.

---

From: Dan Espen <[email-masked]>
Date: Sat, 12 Apr 2003 12:08:12 -0400

> If not, nothing happens !  What's the deal with this software ?

It looks like rox tries to put itself in the background when run
from a terminal.   It has this option:

-n, --new

    start a new filer, even if  one already seems  to be running. This
    also  prevents   the     filer  from  forking   (running  in   the
    background). This option is mainly useful for debugging.

You might want to use "-n" to start the first one, or make sure there aren't
any instances currently hanging that might confuse it.

---

From: Marco Righele <[email-masked]>
Date: 17 Apr 2003 22:51:07 +0200

> What's the matter with this application ?
It looks like 'rox' is just a script that calls another script  that 
that handles development related switches (starting rox from the
debugger etc.) and then calls the right binary.
Using just the binary seems to work perfectly.
I added the following line to the menu

+	"Rox"		Exec exec \ /usr/local/apps/ROX-Filer/FreeBSD-ix86/ROX-Filer

Regards, 
Marco

---

From: Ploum <[email-masked]>
Date: Fri, 18 Apr 2003 10:30:24 +0200

Hi,

Thank you for your mail, but it doesn't work for me !

I try with

Exec nohup /usr/apps/ROX-Filer/Linux-ix86/ROX-Filer ~

or

Exec exec /usr/apps/ROX-Filer/Linux-ix86/ROX-Filer ~

nothing seems to work ! !  I really don't understand...

thanx anyway for your help

Ploum
From: Marco Righele <[email-masked]> Date: 180403

---

From: Bob Crochelt <[email-masked]>
Date: Fri, 18 Apr 2003 08:26:09 -0800

Hi,
been lurking trying to figure this out too.

Try:
+	"Rox"		Exec exec /usr/apps/ROX-Filer/Linux-ix86/ROX-Filer

HTH

Bob Crochelt, MD, PhD, FACS

PO Box 9399
Ketchikan, Alaska 99901-4399

at home:  [email-masked]
travel:	 [email-masked]
at work: [email-masked]

--