Subject: Re: FVWM: What's wrong with my FVWM's menu?

From: [email-masked]
Date: Thu, 24 Apr 2003 19:32:36 +0800 (CST)

Hi, Olivier

   First thanks a lot to notice my question ;)
   My answer is in line....

> On Thu, Apr 24, 2003 at 12:24:13PM +0800, [email-masked] wrote:
>>  Hi all,
>> 
>>    I get a problem with fvwm's menu. My locale output is : zh_CN, and the menu in fvwm works well when I startx , however, after sometime(sometimes long , sometimes   
>>  one minute), the fvwm's menu is DISAPPEAR( that is when I click my mouse on root window, NO menu popup ). What's wrong with my fvwm? ( my fvwm is checked out from cvs, now version is 2.5.7)
> 
> What is your Mouse root binding fvwm config command? What happen
> if you type in FvwmConsole: "Menu the_name_of_your_root_menu" ?

in my RootMenu configure file, I write like this:" Mouse 1 R N Menu My_Root_Menu". When I type Menu My_Root_Menu in FvwmConsole, my RootMenu can pop up. BTW, I find a very strange phenomena this afternoon: when I press the key "NumLock", then when I click on root , NO RootMenu pop up, BUT when I press the key "NumLock" again, clicking on root , the RootMenu POP UP!!!  I test it many times, I think it is the key " NumLock " prevents me to pop up RootMenu, but I do not know why it happens , maybe you can give me an explaination.

> 
>>    I notice the console output :
>>    [FVWM][FlocaleGetFontSet]:(-*-fixed-medium-r-...) Missing font charsets: GB2312.1980-0
>>    [FVWM][convert-charsets]:WARNING- Invalid byte sequence during conversion from UTF-8 to ISO-8859-1
>>
> 
> Your locale is zh_CN and X want fonts with a GB2312.1980-0 charset.
> And the "font name" -*-fixed-medium-r-... does not match a font with
> a GB2312.1980-0 charset. Maybe you should install such fonts or 
> change your font name in your fvwm config file(s). I've:
> 
> [olivier@snoopy unstable]$ xlsfonts -fn "*-GB2312.1980-0"
> -isas-fangsong ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0
> -isas-song ti-medium-r-normal--16-160-72-72-c-160-gb2312.1980-0
> -isas-song ti-medium-r-normal--24-240-72-72-c-240-gb2312.1980-0
> 

Okey, I will change another font :)

>>    [FVWM][convert-charsets]:WARNING- Invalid byte sequence during conversion from UTF-8 to ISO-8859-1
>>
> 
> Then, maybe the title of one of your window use GB2312.1980-0 characters
> (in UTF8) and cannot convert these characters to ISO-8859-1 chars (the
> charset of the font you load ...).
> 
> Take a look at the "FONT NAMES AND FONT LOADING" and the 
> "FONT AND STRING ENCODING" sections of the fvwm manual page for
> more information.
> 

I will read it carefully.

> Regards, Olivier

------------------------------------------------------------------
Ȩ������ ���ſ�ͣ����黥�� ���Ŵ��顣
��ӭ�������������Ƶ����http://sms.people.com.cn

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 07:46:20 -0400

[email-masked] writes:
> in my RootMenu configure file, I write like this:" Mouse 1 R N Menu My_Root_M
> enu". When I type Menu My_Root_Menu in FvwmConsole, my RootMenu can pop up. B
> TW, I find a very strange phenomena this afternoon: when I press the key "Num
> Lock", then when I click on root , NO RootMenu pop up, BUT when I press the k
> ey "NumLock" again, clicking on root , the RootMenu POP UP!!!  I test it many
>  times, I think it is the key " NumLock " prevents me to pop up RootMenu, but
>  I do not know why it happens , maybe you can give me an explaination.

Check the FAQ, question 0.1.

-- 
Dan Espen                           E-mail: [email-masked]