Subject: FVWM: Resizing

From: Eli Segal <[email-masked]>
Date: Tue, 22 Apr 2003 08:37:59 +0200

Hi, all

I want to make fvwm resize like blackbox, that when i hit the Alt+right
mouse click
it will start resizing the window, right now i need to larger the window and
only then
in begin resizing

thanx

ELi

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 23 Apr 2003 00:07:11 +0200

> it will start resizing the window, right now i need to larger the window and

That is because fvwm does not know at which border you want to
start resizing.  I once made a patch that warped to pointer to the
closest border, but most people hated that.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eli Segal <[email-masked]>
Date: Thu, 24 Apr 2003 08:45:29 +0200

So ... you want to tell me that i can't do it ???

whats the problem to identified the window i want to resize ???
thats thet window with the focus on or the window where my mouse pointer is
on ??

I really don't see the problem, and its a shame if i can't do this simple
thing
on THIS window manager

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 07:42:04 -0400

Eli Segal <[email-masked]> writes:
> > > it will start resizing the window, right now i need to larger the window
> > > and only then
> > > in begin resizing
> >

One question mark would be enough unless you are trying to
do more than ask a question.

> I really don't see the problem, and its a shame if i can't do this simple

I don't know if your original question was clear enough.
Doing it "like blackbox" doesn't mean anything to me.
If you invoke resize while inside a window, the wire frame will
appear and resizing happens as the pointer reaches an edge.

If you  start resizing the top  edge  then manuver the  pointer to the
corner, then it will resize two edges, and so on.

Fvwm always waits til the pointer gets to an edge.  If it didn't
it would be pretty hard to control the operation so that only the
edge desired got moved.

Dominik referred to a patch where as soon as the resize operation
started, the pointer was moved to the closest edge.  Is that what
you want?  Lots of people don't like the pointer being moved outside
their control.

I don't think thats what you want.  Maybe you should re-ask your
question supplying more detail.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Eli Segal <[email-masked]>
Date: Thu, 24 Apr 2003 15:38:23 +0200

well... that is what i want

sorry i reffer to blackbox still (as i'm using fvwm for sometime now)
there, when you hit alt+mouse right , resize starts right away in the
direction you move your mouse
its like you press the border, but you don't have to get your mouse all the
way there

I think this is Very convinient, I don't see why i have to enlarge a window,
just to make it small

p.s - sorry for the two question mark, a habbit

ELi

---

From: [email-masked]
Date: Fri, 25 Apr 2003 18:45:34 +0200

> I really don't see the problem, and its a shame if i can't do this simple

Well you're welcome to make a patch :-)  We are simply too few
people with too little time to code every possible feature.

Bye

Dominik ^_^  ^_^