Subject: FVWM: Mouse click keyboard shortcut

From: Daniel Acevedo Feliz <[email-masked]>
Date: Wed, 30 Apr 2003 14:49:18 -0400 (EDT)

Hi,

	I have setup the keyboard shortcuts for CursorMove, but I would
like to be able to shortcut the 3 mouse buttons too. Could somebody tell
me how to do it?

	Thanks in advance!

Daniel.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 30 Apr 2003 15:44:42 -0400

> like to be able to shortcut the 3 mouse buttons too. Could somebody tell

Look for "FakeClick" in the man page.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Daniel Acevedo Feliz <[email-masked]>
Date: Wed, 30 Apr 2003 15:54:23 -0400 (EDT)

> Look for "FakeClick" in the man page.

I found it, but I tried many depth values and nothing happens. It works in
the background (no window under the mouse), but not inside, for example,
xemacs or netscape.

Also, the third button shortcut doesn't even work in the background
either, but this is less esential for me.

these are my settings:

# Move the cursor around
Key Left   A   M   CursorMove -5  0
Key Right  A   M   CursorMove +5  0
Key Up     A   M   CursorMove +0  -5
Key Down   A   M   CursorMove +0  +5
Key Left   A   MS  CursorMove -1  0
Key Right  A   MS  CursorMove +1  0
Key Up     A   MS  CursorMove +0  -1
Key Down   A   MS  CursorMove +0  +1  
Key 1      A   M   FakeClick depth 3 press 1 wait 200 release 1
Key 2      A   M   FakeClick depth 3 press 2 wait 200 release 2
Key 3      A   M   FakeClick depth 3 press 3 wait 200 release 3

Any help would be appreciated.

Thanks,

D.

---

From: [email-masked]
Date: Wed, 30 Apr 2003 22:05:55 +0200

> Look for "FakeClick" in the man page.

Better look at FAQ 3.5.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Daniel Acevedo Feliz <[email-masked]>
Date: Wed, 30 Apr 2003 16:45:48 -0400 (EDT)

> > Look for "FakeClick" in the man page.

Beautiful! Thanks Dominik!

D.