Subject: FVWM: fvwm2 and transient window

From: Ondrej Koala Vacha <[email-masked]>
Date: Fri, 11 Apr 2003 11:32:34 +0200 (CEST)

Hi,

I use fvwm2 with configuration such winxx. For example:

...
ButtonStyle 1   MiniIcon -- UseTitleStyle flat
ButtonStyle 2   Pixmap mini.winXX-close.xpm -- UseTitleStyle flat
ButtonStyle 4   Pixmap mini.winXX-maximize.xpm -- UseTitleStyle flat
ButtonStyle 6   Pixmap mini.winXX-minimize.xpm -- UseTitleStyle flat
...

Normal windows has three buttons right 2 4 6 and one left. 
But transient window has only one button right, number 6, but it is button 
minimize, not close. It has left button 1, too.

With default settings fvwm2 transient window has only button 1 left, and 
no buttons right. How can I set buttons for transient windows?

thanks

-- 
Ondrej Koala Vacha

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 Apr 2003 17:00:26 +0000

> no buttons right. How can I set buttons for transient windows?

You should also add the following:

  ButtonStyle 1 - Clear MWMDecorMenu
  ButtonStyle 2 - Clear
  ButtonStyle 4 - Clear MWMDecorMax
  ButtonStyle 6 - Clear MWMDecorMin

Then some transient windows (the ones that requested) will (correctly)
not contain the iconify and maximize buttons. I think it is reasonable to
leave it this way. But if you want to ignore any MWM hints, also add:

  Style * NoFuncHint, NoDecorHint

Then you will always have 4 titlebar buttons on all windows.
As a side effect it also adds a title to windows that you don't want:

  Style xmms MWMDecor
  Style gkrellm MWMDecor

Regards,
Mikhael.

---

From: Ondrej Koala Vacha <[email-masked]>
Date: Fri, 11 Apr 2003 19:40:40 +0200 (CEST)

>   ButtonStyle 6 - Clear MWMDecorMin

Yes, it works! Very, very thanks!

cheers

-- 
Ondrej Koala Vacha