Subject: FVWM: FvwmButton with different actions..

From: Ploum <[email-masked]>
Date: Wed, 23 Apr 2003 12:55:36 +0200

Hi,

I have a fvwmbutton like this :

*fvwmbuttons: (icon tiny/kmidi.png \
                Panel(position top,right,delay 0,UseOld,NoClose) \
                "LongPlayer")

it works great, it hide/unhide the longplayer window.
But I want to do this only with the left mouse button.
I look to add another action for the right mouse button : minimize xmms.

I look in the manual, but the option [mouse n] is only available to
"action", not to panel. 

How can I doing such feature ?

Thx

Ploum
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Apr 2003 13:40:59 +0200

> *fvwmbuttons: (icon tiny/kmidi.png \
                                   ^^^

You should add a ',' here.

> How can I doing such feature ?

Do use "action":

  *fvwmbuttons: \
    (icon tiny/kmidi.png, \
     Panel(position top,right,delay 0,UseOld,NoClose) "LongPlayer", \
     Action (Mouse 3) "All (xmms) iconify on")

Bye

Dominik ^_^  ^_^

---

From: Ploum <[email-masked]>
Date: Wed, 23 Apr 2003 15:10:52 +0200

>      Action (Mouse 3) "All (xmms) iconify on")

Thx for your reply.  I understand better.  But it doesn't work, I don't
know why.

When I add the line "action", the button become 5 time bigger ! ! ! (it's
not pretty at all)  I try different things without success.
It's perhaps related with the rest of my fvwmbutton :

style "fvwmbuttons" sticky, nohandles, notitle, borderwidth 0, staysontop,
parentalrelativity
*fvwmbuttons: columns 1
*fvwmbuttons: pixmap bar.png
*fvwmbuttons: frame 0
*fvwmbuttons: \
    (icon tiny/kmidi.png, \
     Panel(position top,right,delay 0,UseOld,NoClose) "LongPlayer")
*FvwmButtons: (Swallow(UseOld,NoClose) "psi")

---

From: [email-masked]
Date: Fri, 25 Apr 2003 18:41:22 +0200

> It's perhaps related with the rest of my fvwmbutton :

Sounds like something went terribly wrong in your FvwmButtons
config.  Check carefully for syntax errors.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].