Subject: FVWM: changing from :0.1 to :0.0 with keyboard

From: Klaus Umbach <[email-masked]>
Date: Mon, 28 Apr 2003 14:56:34 +0200

Hello List.

Some time ago I asked here how I could change the focus from :0.0 to :0.1
with keybindings.
Nobody knew it, and fvwm itself can't do it.

Now I found a solution!
I wrote a little shellscript:

#!/bin/bash

case "$DISPLAY" in
        :0.0)
                exec xwit -display :0.1 -root -warp 320 240
        ;;
        :0.1)
                exec xwit -display :0.0 -root -warp 640 512
        ;;
esac
exit 0

this script I put on a SHIFT+ALT+TAB and now I can switch between my
monitors without touching my mouse! :-)

Regards
	Klaus

-- 
5) People say Linux is ugly. How does that make you feel?
Torvalds: They'll be the first against the wall when the revolution comes.
	  Let's see just how ugly they think it is when they have a few
	  bulletholes in them.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Henrik Grindal Bakken <[email-masked]>
Date: Mon, 28 Apr 2003 16:54:57 +0200

Klaus Umbach <[email-masked]> writes:

> Hello List.
>
> Some time ago I asked here how I could change the focus from :0.0 to
> :0.1 with keybindings.  Nobody knew it, and fvwm itself can't do it.
>
> Now I found a solution!

Hmm.  xwit.  Never heard of.  Looks like a neat utility.

> monitors without touching my mouse! :-)

Personally, I use a program called warp-pointer, which is written by
Kjetil T. Homme (you can get it from
ftp://ftp.ifi.uio.no/people/kjetilho/warp-pointer.tar.gz).  Looks like
xwit may be just as useful (or more), though.

In my .fvwm2rc (I use C-+ to switch display):
# Swap between multiple displays
Key Plus		A	C	Exec exec warp-pointer

-- 
Henrik Grindal Bakken <[email-masked]>
PGP ID: 8D436E52
Fingerprint: 131D 9590 F0CF 47EF 7963  02AF 9236 D25A 8D43 6E52
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Apr 2003 15:40:00 +0200

> Nobody knew it, and fvwm itself can't do it.

With 2.4.15 and 2.5.x you can use

  WindowId root 1 WarpToWindow 50 50
                ^
                |___ screen number

> monitors without touching my mouse! :-)

Bye

Dominik ^_^  ^_^