Subject: FVWM: FvwmWinList

From: "Mario Domgörgen" <[email-masked]>
Date: 21 Apr 2003 18:26:30 +0200

Hello List,

wonder if it possible to achieve following growth of FvwmWinList?

From:

Eterm1 Eterm3
Eterm2 Eterm4

To:

Eterm1 Eterm3 Eterm5
Eterm2 Eterm4 Eterm6

Thanks in advance!

Mario

-- 
Chaos reigns within.
Reflect, repent, and reboot.
Order shall return.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Mario Domgörgen" <[email-masked]>
Date: 22 Apr 2003 17:02:08 +0200

Dominik Vogt <[email-masked]> writes:

> > To:
> > Eterm1 Eterm3 Eterm5
> > Eterm2 Eterm4 Eterm6
> 
> I don't think that this is possible yet, but I'm not an expert
> here.

Also not: 

Eterm1 Eterm2 Eterm3
Eterm4 Eterm5 Eterm6

?

Mario

-- 
Out of memory.
We wish to hold the whole sky,
But we never will.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 17:16:34 +0200

> > I don't think that this is possible yet, but I'm not an expert

Come to think of it, my FvwmIconMan does exactly this.  But it's
confined in FvwmButtons and can not grow, only shrink the buttons.
This comes close to what you want:

  *FvwmIconMan*ManagerGeometry 0x2

Unfortunately it does not keep the position of the individual
windows constant when new windows are added.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 09:46:13 +0200

Bye

Dominik ^_^  ^_^

---

From: "Mario Domgörgen" <[email-masked]>
Date: 22 Apr 2003 18:24:40 +0200

> windows constant when new windows are added.

Thank you, that's exactly what i searched for! I always associate
FvwmIconMan with my first meeting of it ... a big ugly box with icons in
it, so i haven't looked at it, but it can also look like the
GnomeWindowApplet. Great!

Mario

-- 
Serious error.
All shortcuts have disappeared.
Screen. Mind. Both are blank.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 22 Apr 2003 17:36:15 +0000

On 22 Apr 2003 18:24:40 +0200, Mario Domg?rgen wrote:
> >   *FvwmIconMan: ManagerGeometry 0x2
> > 

You probably confuse it with FvwmIconBox.

Granted, FvwmIconMan is a bad name for what it does. :)

Regards,
Mikhael.

---

From: "Mario Domgörgen" <[email-masked]>
Date: 24 Apr 2003 10:10:40 +0200

Mikhael Goikhman <[email-masked]> writes:

> > Btw.: Is there a way to get rid of the rectangle next to an iconified
> > window? Haven't found a option therefor yet ... i hope there are one...
> 
> Please don't ask me in the private messages, I am too busy.
> 
> I think the only way is to disable this is to use MiniIcons.
> 
> But I don't have a motivation to test it, if it would be asked on the
> list, I would have more motivation, since lists are archived, thus
> helful for many. :)

Shit, this mail shouldn't go to your personally, i am very sorry for
this. Especially as i am very pleased with the mailing list. First there
was a ugly standard debien fvwm and now it's the beautiful wm i ever
dreamed of... Thank you all! :)

I will try it with MiniIcons, but i don't see how that could help me
... but i will see ... :)

Mario

-- 
The Tao that is seen
Is not the true Tao, until
You bring fresh toner.

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 07:12:29 -0400

"Mario Domgörgen" <[email-masked]> writes:
> S**t, this mail shouldn't go to your personally, i am very sorry for

I'm not sure what you mean by rectangle next to an iconified window.

Do you mean the icon title?

Try:

Style * NoIconTitle

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 24 Apr 2003 18:18:27 +0000

On 24 Apr 2003 07:12:29 -0400, Dan Espen wrote:
> 
> "Mario Domg=F6rgen" <[email-masked]> writes:
> > > > Btw.: Is there a way to get rid of the rectangle next to an
> > > > iconified window? Haven't found a option therefor yet ... i hope
> > > > there are on...
> > > 

He means FvwmIconMan, and the option name is DrawIcons, not MiniIcons.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 14:40:16 -0400

> He means FvwmIconMan, and the option name is DrawIcons, not MiniIcons.

I don't see a rectangle:

http://mywebpages.comcast.net/despen/fvwmiconman-big.jpg

but I guess that circled area could end up looking like
a rectangle if I changed the font or colors.

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 14:56:18 -0400

> http://mywebpages.comcast.net/despen/fvwmiconman-big.jpg

Sorry, I'm a bit confused.

Anyway, it does look like there is a small problem when
DrawIcons is used.  (In the circle).

---

From: Dan Espen <[email-masked]>
Date: Thu, 24 Apr 2003 15:05:06 -0400

> DrawIcons is used.  (In the circle).

The problem goes away when I change the font.
This is the config with the problem:

DestroyModuleConfig FvwmIconMan
*FvwmIconMan*nummanagers 1
*FvwmIconMan*resolution  global
*FvwmIconMan*background  slategrey
*FvwmIconMan*foreground  white
*FvwmIconMan*font        7x13
*FvwmIconMan*buttongeometry    128x0
*FvwmIconMan*managergeometry    1x0-0-0
*FvwmIconMan*drawicons true
*FvwmIconMan*followfocus true
*FvwmIconMan*focusbutton up black white

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 24 Apr 2003 20:03:27 +0000

On 24 Apr 2003 15:05:06 -0400, Dan Espen wrote:
> > > > > > > > Btw.: Is there a way to get rid of the rectangle next to
> > > > > > > > an iconified window? Haven't found a option therefor yet
> > > > > > > > ... i hope there are on...
> > > > > > > 
> > > > > > I will try it with MiniIcons, but i don't see how that could
> > > > > > ... help me but i will see ... :)
> > > > > 

You know, this command (without an asterisk) does not do anything.

> *FvwmIconMan*focusbutton up black white

Yes, I see the bug with "drawicons true".
But "drawicons false" and "drawicon always" work fine.

Regards,
Mikhael.

---

From: [email-masked]
Date: Fri, 25 Apr 2003 18:39:34 +0200

> But "drawicons false" and "drawicon always" work fine.

Works for me.  Can you debug this?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Apr 2003 14:07:12 -0400

> Works for me.  Can you debug this?

I'll see what I can do.

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Apr 2003 20:18:51 -0400

> > Works for me.  Can you debug this?

Fixed.

bye,