Subject: FVWM: Focus Prolem with fvwm2 without mouse

From: Kumar <[email-masked]>
Date: Mon, 21 Apr 2003 12:33:41 +0530

Hi,
           I am using Embedded Linux Image on x86 plotfom ,I disabled mouse 
with option -allowMouseOpenFail in /usr/X11R6/bin/startx file.Iam using fvwm2
as window manager.Iam getting focus problem ,when i execute the QT 
application.I moved the cursor to -40 -40 location using CursorMove -40 -40 
command in the .fvwm2rc and system.fvwm2rc files.

The problem is:
My appilcation opens root window,this root window logins and opens a child
window.When i close this child window, the root windows doesn't getting the 
focus, so that nothing works.But it works fine if i move the cursor to 0 0 
position.Can anybody help me please.

--
S.Kumar
Engineer
ASDC-iSOPS
CMC Limited

-- 
S.Kumar
Engineer
ASDC-iSOPS
CMC Limited
Ph:91-040-23000401, Ext:2108
Mobile:9440230974

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Apr 2003 09:44:08 +0200

> position.Can anybody help me please.

In 2.4.x and earlier, try the ClickToFocus style for the windows
involved.  In 2.5.x you can specify every single bit of focus
behaviour manually.  Try

  Style <window name> FPGrabFocus, FPReleaseFocus

*after* setting one of the basic focus policies.

Bye

Dominik ^_^  ^_^