Subject: FVWM: fvwm event names?

From: Xucaen <[email-masked]>
Date: Thu, 10 Apr 2003 09:41:54 -0700 (PDT)

Hi all,
   at the bottom of the man page for fvwm, there
is a listing of audio events that begins like so:

e.g. for audio-events:

        *FvwmEvent: startup TaDa.au
        *FvwmEvent: shutdown Elvis_Left.au

        . . .

My Q is: is this a complete list of all fvwm
events?
If it isn't, where could I find such a list?

thanks!

Jim

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 10 Apr 2003 21:40:29 -0400

> If it isn't, where could I find such a list?

If you see about 30 events, thats the full list.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 11 Apr 2003 11:01:53 +0000

>    at the bottom of the man page for fvwm, there

I suppose you are speaking about the middle of the FvwmEvent man page.

>         *FvwmEvent: shutdown Elvis_Left.au

These are 2 events that are internal to FvwmEvent, noone else knows about
them, FvwmEvent invokes them on its own startup and shutdown.

> If it isn't, where could I find such a list?

The exact list depends on the version. The currnet list (35 event) may be
found on http://fvwm.org/ in the developers section.

Or, if you use 2.5.x, run the following to get the complete event list:

  perl -I`fvwm-perllib dir` -MFVWM::EventNames -e 'print "$_\n" foreach @{allEventNames()}'

Regards,
Mikhael.