Subject: FVWM: Two rats?

From: Timothy Groves <[email-masked]>
Date: Mon, 3 Mar 2003 10:51:17 +0000

This might be a general X question, or even a Gimp question, and thus off-topic in here.  I'm not smart enough to figure out if it is.  But:  Is there any way to get two mice working at once?  I have a wheel mouse and a trackball.  I use the trackball for just about everything.  But when working in Gimp, it would be very nice to have the wheel, and the extra couple of buttons, available.  The extra axes I can ignore, but using the wheel (for example) as a pressure control for an airbrush tool...or for scrolling in documents...whatever.  Is there a way to manage it?

-- 
ICQ#66022322

"Beer is living proof that God loves us and wants us to be happy."
-Benjamin Franklin
______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 03 Mar 2003 11:30:56 -0500

Timothy Groves <[email-masked]> writes:
> This might be a general X question, or even a Gimp question, and thus off-top
> ic in here.  I'm not smart enough to figure out if it is.  But:  Is there any
>  way to get two mice working at once?  I have a wheel mouse and a trackball. 
>  I use the trackball for just about everything.  But when working in Gimp, it
>  would be very nice to have the wheel, and the extra couple of buttons, avail
> able.  The extra axes I can ignore, but using the wheel (for example) as a pr
> essure control for an airbrush tool...or for scrolling in documents...whateve
> r.  Is there a way to manage it?

It's an X question.

I did a Google search using: linux two mice

The search results looked promising.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 3 Mar 2003 17:43:20 +0100

> This might be a general X question, or even a Gimp question, and thus
> off-topic in here.  I'm not smart enough to figure out if it is.  But:  Is
> there any way to get two mice working at once?  I have a wheel mouse and a
> trackball.  I use the trackball for just about everything.  But when working
> in Gimp, it would be very nice to have the wheel, and the extra couple of
> buttons, available.  The extra axes I can ignore, but using the wheel (for
> example) as a pressure control for an airbrush tool...or for scrolling in
> documents...whatever.  Is there a way to manage it?

		      Please put only 80 chars on a line.

There is more then one way to do it. You can configure gpm [1] to handle to mice
and let him repeat it for X. Read the manpage for gpm. The other method is to
configure a second pointer device in X. It is also in the Documentation for X.

	Thomas

---

From: kaple <[email-masked]>
Date: Mon, 03 Mar 2003 21:31:45 -0500

Sample config:

/usr/sbin/gpm -m /dev/ttyS0 -t ms -g1 -M -m /dev/psaux -t PS/2

The -m specifies the device name, the -t the mouse protocol (do
'/usr/sbin/gpm -t help' for a list of protocols), -g1 enables the link
between tapping the touchpad mouse and mouse button 1.  -M
chains two mice together.  This will create a device file
/dev/gpmdata.  When you have both working in console mode, edit
/etc/X11/XF86Config and make the following your pointer section.

Section "Pointer"
Protocol    "MouseSystems"
Device      "/dev/gpmdata"
EndSection

To make this enabled by default, I edited /etc/rc.d/init.d/gpm and
replaced the default command with the working gpm command.