Subject: FVWM: Windows not receiving clicks !

From: Christian Lyra <[email-masked]>
Date: Thu, 20 Mar 2003 12:41:38 -0300

Hi,

	I just upgraded my fvwm to 2.5.6 (from 2.5.4) and now  the windows are not 
receiving any mouse clicks!  Hm... I mean, the applications, not the windows, 
because the close/minimiz/maximize buttons works, but the applications 
buttons dont! they even got the focus, but not the clicks!
	Since without any config files all works ok, I think there's something wrong 
with my .fvwm2rc. Since it was working, I can only think that something has 
changed in configuration syntax. May someone help me?

-- 
Christian Lyra
POP-PR - RNP

  Thus spake the master programmer: 
  ``It is time for you to leave.'' 
						The Tao Of Programing

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 Mar 2003 16:48:36 +0100

> changed in configuration syntax. May someone help me?

Can you strip down the config file to the minimum showing this
behaviour and post it to fvwm-workers, please?

Bye

Dominik ^_^  ^_^

---

From: Christian Lyra <[email-masked]>
Date: Thu, 20 Mar 2003 14:31:00 -0300

> > 	I just upgraded my fvwm to 2.5.6 (from 2.5.4) and now  the windows are
> > not receiving any mouse clicks!  Hm... I mean, the applications, not the
> > windows, because the close/minimiz/maximize buttons works, but the
> > applications buttons dont! they even got the focus, but not the clicks!
> > 	Since without any config files all works ok, I think there's something
> > wrong with my .fvwm2rc. Since it was working, I can only think that
> > something has changed in configuration syntax. May someone help me?
>

	I just found the offending part. it's the stroke configuration! If I strip 
the stroke lines from the config I got the normal behavior... is stroke 
broken or perhaps maybe my stroke libs? (Debian SID).

-- 
Christian Lyra
POP-PR - RNP

  The wise programmer is told about Tao and follows it. The average programmer 
is told about Tao and searches for it. The foolish programmer is told about 
Tao and laughs at it. 
  If it were not for laughter, there would be no Tao. 
						The Tao Of Programing

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 Mar 2003 19:59:42 +0000

On 20 Mar 2003 14:31:00 -0300, Christian Lyra wrote:
> 	I just found the offending part. it's the stroke configuration!
> If I strip the stroke lines from the config I got the normal
> behavior... is stroke broken or perhaps maybe my stroke libs? (Debian
> SID).

We can't know if you don't post your problematic lines (read: we still
can't reproduce your problem).

Actually, it is easy to write a malfunction config that disables
any mouse clicks in the client windows:

  Mouse 1 W N StrokeFunc

Either don't use "W" here or use some non-N modifier, like CM (Ctrl-Alt).

Regards,
Mikhael.

---

From: Christian Lyra <[email-masked]>
Date: Fri, 21 Mar 2003 09:00:56 -0300

> can't reproduce your problem).

any line that denfines a stroke trigger the problem, like this:

Stroke N9632147     0 A A  Exec exec xterm
Stroke N1475369     0 A A  Exec exec netscape

There's a possibility of my libstroke is broken... but since I only use it on 
fvwm and dont even know how to test it!

-- 
Christian Lyra
POP-PR - RNP

  The master programmer moves from program to program without fear. No change 
in management can harm him. He will not be fired, even if the project is 
cancelled. Why is this? He is filled with Tao. 
						The Tao Of Programing

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 21 Mar 2003 12:48:39 +0000

On 21 Mar 2003 09:00:56 -0300, Christian Lyra wrote:
> There's a possibility of my libstroke is broken... but since I only use
> it on fvwm and dont even know how to test it!

This configuration (together with "Mouse 1 A A StrokeFunc") does exactly
what you explain, I would not say anything is broken.

The correct config for what you want is:

  Stroke N9632147 0 R A  Exec exec xterm  # draw in root
  Stroke N9632147 0 W M  Exec exec xterm  # draw in window with Alt pressed
  Stroke N1475369 0 R A  Exec exec netscape
  Stroke N1475369 0 W M  Exec exec netscape

  Mouse 3 R A StrokeFunc  # use mouse 3 for stroke in root
  Mouse 3 W M StrokeFunc  # use mouse 3 for stroke in window

Regards,
Mikhael.