Subject: FVWM: Binding key to cycle through windows

From: Jose Romildo Malaquias <[email-masked]>
Date: Sat, 1 Mar 2003 13:24:50 -0300

Hello.

Currently I have in my .fvwm2rc file

=====================
AddToFunc SelectWindow
+ I Focus
+ I Iconify false
+ I Raise
+ I WarpToWindow 50 8p

Key Tab A M Next [*] SelectWindow
=====================

and I can cycle through windows using M-Tab and choose
the one I want raised and focused. But I am not happy
with the order of the windows when cycling through the
available ones. I want them ordered with the most
recently focused on top.

Also I would like to not have the windows raised
while cycling through them, until I stop cycling,
that is, until I have chosen the window I want.
Is it possible to just present the name/icon of the
window while cycling, and only raise and focus the
chosen one?

Any clues on how to achieve these?

Romildo
-- 
Prof. José Romildo Malaquias        [email-masked]
Departamento de Computação       [email-masked]
Univ. Federal de Ouro Preto  http://uber.com.br/romildo
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Mar 2003 02:14:36 +0000

> Currently I have in my .fvwm2rc file

You want to use WindowList. Try to remove this Key line and use the
default Alt-Tab or give WindowList your own arguments.

See also an answer to a similar question:

  http://www.hpc.uh.edu/fvwm/archive/0212/msg00527.html

Regards,
Mikhael.