Subject: Re: FVWM: key bindings

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 1 Mar 2003 16:02:54 +0000

On 28 Feb 2003 10:24:19 -0500, Jamie Sparks wrote:
> 
> >From: Mikhael Goikhman <[email-masked]>
> >
> > On 26 Feb 2003 16:33:04 -0500, Jamie Sparks wrote:
> > >
> > > I'm running fvwm2 version 2.4.7 with the cygwin package on a windows
> > > 2000 box.  When therein, I'd like to be able to toggle among the
> > > xterms via the keyboard, much like one can do with alt-tab on
> > > windows.  I see a little material on this in the man page, but I
> > > need to know how to map a different key combination to do that task
> > > since ctrl-alt is taken.  I imagine it's a command like: Key A M
> > > <etc.>
> >
> > It is like:
> >
> >   AddToFunc MyFocusAndRaise
> >   + I Focus
> >   + I Raise
> >   + I WarpToWindow 50 7p
> >
> >   Key F5  A  CM  Next (XTerm) MyFocusAndRaise
> 
> Thanks Mikhael.
> 
> I put
>  Key F5  T  Ctrl-Esc  Next (XTerm) MyFocusAndRaise

Well, this is not correct. I don't think you want this binding to work
when you are on a window title only. So don't do "T", but "A" (anywhere)
instead. Then the next argument should be one letter modifiers, C means
Ctrl, M means Meta or Alt, S means Shift. So in my example above you
should press Ctrl-Alt-F5. (Note that in some OSes this combination of
keys, Ctrl-Alt-F5, is reserved for switching to the virtual console number
5, in this case use Shift-Ctrl or anything other you want).

  Key N  A  SC  Next (XTerm) MyFocusAndRaise  # press Shift-Ctrl-N

> into my .fvwmrc.  Now I can cycle through all of my windows,
> including one (and only one) of my fvwm xterms.  The windows
> it cycles through include win2000 windows.  It's as if the
> (XTerm) command is being ignored.  I should've mentioned that
> I'm also using a ReflectionX virtual desktop (not the wm, just
> the virtual desktop).  Could that be confusing fvwm?

If this is a Windows related problem, you should definitely ask the list
not me, I don't run Windows.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Gert Brinkmann <[email-masked]>
Date: Sun, 02 Mar 2003 14:10:52 +0100

>   Key N  A  SC  Next (XTerm) MyFocusAndRaise  # press Shift-Ctrl-N

Can this be done more generally so that it does work with not only 
xterms but with every type of window? Something like:

  ... Next (has same class as current) MyFocusAndRaise

Gert

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Mar 2003 21:41:03 +0000

On 02 Mar 2003 14:10:52 +0100, Gert Brinkmann wrote:
> >   + I WarpToWindow

In 2.5.6:

  Key N  A  SC  Current Next ($[w.class]) MyFocusAndRaise

In older versions (this syntax may be obsolete in the future):

  Key N  A  SC  Current Next ($c) MyFocusAndRaise

Regards,
Mikhael.