Subject: FVWM: match of stylenames

From: Christoph Bauer <[email-masked]>
Date: Wed, 19 Mar 2003 19:05:31 +0100

Hi,

I want to add a tab browsing emulation to the browser dillo.  New and
empty windows (<Ctrl-N>) should be raised, new and non empty windows
(<Button-2>) should be lowered. Both window can be distinguished by
the window title. After a lecture in the manpage [1] I tried this, but it
doesn't work:

Style Dillo:*  StartsLowered     
Style "Dillo: Version 0.7.1" StartsRaised

What is wrong here? My fvwm2 version is 2.4.15.

Thanks in advance,

Christoph

[1]
from the fvwm2 manpage:

> Style stylename options 
> [...]
>              stylename  can  be  a  window's  name,  class,   or
>              resource  string.  It may contain the wildcards '*'
>              and '?', which are matched in the usual Unix  file-
>              name  manner.   They  are  searched  in the reverse
>              order stated. When two conflicting styles apply  to
>              the  same  window,  the style that was changed last
>              wins.

-- 
proc self {} {foreach c [split [info body self] ""] d {14 -7 0 0 4 -67 4 73 11
69 24 -83 -15 6 -4 -84 78 20 11 -78 -1 -1 79 19 -8 4} { binary scan $c c c
if {[catch {append r [format %c [expr $c+$d]]}]} {return $r};}};puts [self]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Glanzmann <[email-masked]>
Date: Thu, 20 Mar 2003 19:50:41 +0100

> Style "Dillo: Version 0.7.1" StartsRaised

It might me possible, that the application is renaiming it's window
title during startup. So that this doesn't work.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 21 Mar 2003 15:26:30 +0000

> title during startup. So that this doesn't work.

If this is actually the case, it is possible to reapply all
styles for a new/changed name using RecaptureWindow.

Regards,
Mikhael.