Subject: FVWM: placing a window relative to another window

From: [email-masked]
Date: Wed, 5 Mar 2003 09:51:51 -0300

Hello.

I want to place the pager and the iconman side by side.
How can I specify their geometry to accomplish this?

I am thinking about something like

*FvwmIconMan: ManagerGeometry	6x1-0-0
*FvwmPager: Geometry x32+<the x position of FvwmIconMan minus the width of FvwmPager>-0

Romildo
-- 
Prof. Jos? Romildo Malaquias        [email-masked]
Departamento de Computa??o       [email-masked]
Univ. Federal de Ouro Preto  http://uber.com.br/romildo
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Thu, 6 Mar 2003 13:34:55 +0100

Hi there,

> *FvwmPager: Geometry x32+<the x position of FvwmIconMan minus the width of FvwmPager>-0

I know my suggestion is not that convenient. I use a couple
of environment variables in my .fvwm2rc to achieve this.

For example:

SetEnv BorderWidth 3 
SetEnv IconManButtonWidth 100
PipeRead `printf "SetEnv IconManWidth $[BorderWidth] + $[BorderWidth] + $[IconManButtonWidth]"` 
...

Style BorderWidth $[BorderWidth], HandleWidth $[BorderWidth]
...

*FvwmIconMan: buttongeometry $[IconManButtonWidth]x20
## IconMan in bottom right corner
*FvwmIconMan: geometry 1x0-0-0
...

## Pager on the left hand side of IconMan
*FvwmPager: geometry 50x32-$[IconManWidth]-0
...

So if you change the size of IconMan or Border the position
of the pager will change as well.

Regards Uwe
-- 
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_/ Uwe Pross                          ,_,
_/ mailto:[email-masked]          (O,O)
_/ http://www.tu-chemnitz.de/~uwp    (   )
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/"-"/_/_/_/_/_/_/_/_/

Die Linke will mehr Rechte, die Rechte will weniger Linke.