Subject: Re: FVWM: Style NoButton requires special order, Bug?

From: David Hansen <[email-masked]>
Date: Mon, 17 Mar 2003 05:25:52 +0100

On Fri, Feb 28 at 14:36+0100 Dominik Vogt wrote:
> On Fri, Feb 28, 2003 at 01:15:54PM +0100, David Hansen wrote:
> > Hi, 
> > 
> > i just noticed that if you want to create a title bar without
> > buttons, you have to take care of the order of the NoButtons
> > directives. 
> > 
> > E.g. this doesn't work:
> > 
> > Style 	MyStyle	NoButton 1
> > Style	MyStyle	NoButton 2
> > Style	MyStyle	NoButton 3
> > Style	MyStyle	NoButton 4
> > 
> > but this is working:
> > 
> > Style	MyStyle	NoButton 3
> > Style	MyStyle	NoButton 4
> > Style 	MyStyle	NoButton 1
> > Style	MyStyle	NoButton 2
> > 
> > I'm not sure if you want to call this a bug. At least it isn't
> > mentioned in the man page.
> 
> Both versions work fine for me.  Can you provide more information
> on this problem?
> 

Ok, sorry for not responding the long time. I had problems too to
reproduce this. 

I played a little bit with my fvwmrc... I think what me confused was
that Buttons without default actions (when you click on them) doesn't
appear, even if you set the `Style "*" Button <n>`. 

This time its reproducable and you can see the differences here

     http://www.physik.fu-berlin.de/~dhansen/wobtn6.png
     http://www.physik.fu-berlin.de/~dhansen/wbtn6.png

At the curser position is the only line that changed in my config.

David

$ fvwm --version
fvwm 2.5.7 (from cvs) compiled on Mar 16 2003 at 22:05:00
with support for: ReadLine, Stroke, XPM, PNG, Shape, XShm, SM, Xinerama, XRender, XFT, NLS

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Mar 2003 10:53:27 +0100

> At the curser position is the only line that changed in my config.

I'm a bit confused.  Do you still think there is a bug?  Buttons
without an action bound to them are never show, yes.  I'm not sure
if it's documented in the man page, but it is how it was designed.

> with support for: ReadLine, Stroke, XPM, PNG, Shape, XShm, SM, Xinerama, XRender, XFT, NLS

Bye

Dominik ^_^  ^_^
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Hansen <[email-masked]>
Date: Mon, 17 Mar 2003 17:57:00 +0100

> if it's documented in the man page, but it is how it was designed.

I just needed about an hour to find the problem. If you play around
with your config it might happen that you have a button without action
defined. But IMHO describing this "feature" in the man page is enough
(maybe it's already somewhere but not in the 'Style' section).

David