Subject: FVWM: Configuration Problem With FvwmEvent and restart of FVWM

From: Thomas Glanzmann <[email-masked]>
Date: Sat, 1 Mar 2003 23:57:20 +0100

Hi FVWMers!

I use the follwing functions to adapt newly created Windows to fullscreen size.

*FvwmEvent-NewWindow: Cmd
*FvwmEvent-NewWindow: PassId
*FvwmEvent-NewWindow: add_window AddWindow

AddToFunc StartFunction
	+ I FvwmEvent FvwmEvent-NewWindow

AddToFunc FullScreen
	+ I ThisWindow (!Maximized) Style $n BorderWidth 0
	+ I ThisWindow ( Maximized, !"bluescreen") Style $n BorderWidth 1
	+ I ThisWindow Maximize
	+ I ThisWindow (!Maximized) WarpToWindow -5p -5p

AddToFunc AddWindow
	+ I Piperead "ls -al / &> /dev/null"
	+ I Piperead "ls -al / &> /dev/null"
	+ I WindowId $0 ("MAINscreen")    FullScreen
	+ I WindowId $0 ("LOCALscreen")   FullScreen
	+ I WindowId $0 ("DEVELscreen")   FullScreen
	+ I WindowId $0 ("CONSOLEscreen") FullScreen
	+ I WindowId $0 ("Opera*")        FullScreen
	+ I WindowId $0 ("Gvim")          FullScreen
	+ I WindowId $0 ("Go to page")    WarpToWindow -10 -50

If I now restart FVWM, FvwmEvent gets some add_window events and tries to resize
them which ends in ununsable windows. They get a little bit smaller then
fullscreen and have borders. So my question is there a way to tell FvwmEvent to
wait ... when restarting until all events caused by the Restart are over?

	Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Mar 2003 00:54:18 +0000

On 01 Mar 2003 23:57:20 +0100, Thomas Glanzmann wrote:
> 
> If I now restart FVWM, FvwmEvent gets some add_window events and tries
> to resize them which ends in ununsable windows. They get a little bit
> smaller then fullscreen and have borders. So my question is there a way
> to tell FvwmEvent to wait ... when restarting until all events caused by
> the Restart are over?

Yes, you will find it if you search the FwmmEvent man page for "delay".
You need StartDelay.

Regards,
Mikhael.

---

From: Thomas Glanzmann <[email-masked]>
Date: Sun, 2 Mar 2003 11:11:01 +0100

> Yes, you will find it if you search the FwmmEvent man page for "delay".

Hrmpf. I had that already (earlier) in my .fvwm2rc. Thnx!