Subject: FVWM: RedHat 8.0 font problems with 2.5.6

From: Richard Lister <[email-masked]>
Date: Mon, 10 Mar 2003 17:43:53 -0500 (EST)

Hi folks

I have 2.5.6 compiled on a RedHat 7.3 box and an 8.0 box.
The 7.3 installation is fine. On 8.0 all text drawn by
fvwm (on titlebars, menus, buttons, etc) has an extra small box
(unknown character?) drawn before each character. This happens
regardless of font. Screenshot included.

fvwm throws out the following message for each font loaded:

[FVWM][FlocaleGetFontSet]: (lucidasanstypewriter-12) Missing font charsets:
ISO10646-1, JISX0208.1983-0, KSC5601.1987-0, GB2312.1980-0, JISX0201.1976-0

Is this related to bidi text support or unicode (I know nothing
about either subject)?

Cheers
Ric

---

From: Alex Wallis <[email-masked]>
Date: Tue, 11 Mar 2003 13:30:03 +1030

This is not fvwm related but is a bug that shipped with redhat 8.0

In Red Hat 8.0 they changed the LANG from en_US to en_US.UTF-8". To make
it work right, edit...

/etc/sysconfig/i18n and change LANG="en_US.UTF-8" to LANG="en_US". 

Then log out from the shell and back in. man and other apps will display
correct characters.

> Is this related to bidi text support or unicode (I know nothing

There are a list of frequently asked questions about other Redhat 8.0
quirks answered at http://redhat.cltonline.com/fom-serve/cache/4.html

Hope this helps.

Alex
-- 
`When you say "I wrote a program that crashed Windows", people just
stare at you blankly and say "Hey, I got those with the system, *for
free*".'
(By Linus Torvalds)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Wed, 12 Mar 2003 16:56:27 -0500 (EST)

Alex Wallis <[email-masked]> wrote
on Tue, 11 Mar 2003 13:30:03 +1030:
>
> Subject: Re: FVWM: RedHat 8.0 font problems with 2.5.6
>

Alex

That completely fixed the problem. Thanks :-)

Ric