Subject: FVWM: Shell scripts in FVWM menus

From: Timothy Groves <[email-masked]>
Date: Sat, 15 Mar 2003 12:25:51 +0000

Okay, I've RTFM, and it doesn't address this question:  How exactly does one run a shell script from an FVWM exec command?

-- 
ICQ#66022322

"Beer is living proof that God loves us and wants us to be happy."
-Benjamin Franklin
______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 15 Mar 2003 12:39:43 -0500

Timothy Groves <[email-masked]> writes:
> Okay, I've RTFM, and it doesn't address this question:  How exactly does one 
> run a shell script from an FVWM exec command?

Nothing special.  If the shell script is in your path, and
named "myshell":

Exec myshell

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 16 Mar 2003 10:16:44 +0100 (CET)

> Okay, I've RTFM, and it doesn't address this question:  How exactly does one run a shell script from an FVWM exec command?

I have a script called opendir that looks like this:

-------------------------------

#!/bin/sh

# this script opens a directory in a file manager

# check if user has set $FILEMAN

if [ -n "$FILEMAN" ]; then
    `$FILEMAN` $* >/dev/null 2>&1
elif which rox > /dev/null 2>&1; then
    rox $* >/dev/null 2>&1
elif [ `which gmc` ]; then
    gmc $* >/dev/null 2>&1
# last resort, use good ol' xfm... :-)
else
    xfm $* >/dev/null 2>&1
fi

--------------------------------

Then I use it like this in .fvwm2rc:

AddToMenu RootMenu      "Root Menu"     Title
+                       "New Window"    Exec exec terminal
+                       "Home Directory"        Exec $HOME/.fvwm/opendir ~

This has always worked.

Maybe it's because of the " >/dev/null 2>&1 " ?

//Marcus

---

From: Timothy Groves <[email-masked]>
Date: Sun, 16 Mar 2003 10:09:45 +0000

On Sun, 16 Mar 2003 10:16:44 +0100 (CET)

> I have a script called opendir that looks like this:

<snip>

> Maybe it's because of the " >/dev/null 2>&1 " ?

I am afraid to say that this approach also fails.  And yet it seems that you can run ROX-Filer just fine.
-- 
ICQ#66022322