Subject: Re: FVWM: Real fullscreen

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Mar 2003 02:33:24 +0000

On 20 Feb 2003 21:57:14 +0100, Ploum wrote:
> 
> is it a way to set a window in "real" full screen with fvwm ?  (by "real
> fullscreen", I mean no more title bar or border... )
> 
> It can be useful to set a console in fullscreen on a viewport...

There was a partial answer. Here is how to do this without gaps (taken
from fvwm-themes). Note that there are always gaps with xterm and similar.

For 2.4.x (two keys):

  DestroyFunc FuncFvwmMaximizeFullScreen
  AddToFunc   FuncFvwmMaximizeFullScreen
  + I Style $n NoTitle, NoHandles, BorderWidth 0
  + I UpdateStyles
  + I WindowId "$w" Maximize true

  DestroyFunc FuncFvwmUnmaximizeFullScreen
  AddToFunc   FuncFvwmUnmaximizeFullScreen
  + I WindowId "$w" Maximize false 
  + I Style $n Title, Handles, BorderWidth 5

  Key F11  A  SC Pick FuncFvwmMaximizeFullScreen
  Key F12  A  SC Pick FuncFvwmUnmaximizeFullScreen

For 2.5.6+ (one toggle key; it was "Border" earlier in 2.5.x):

  DestroyFunc FuncFvwmMaximizeFullScreen
  AddToFunc   FuncFvwmMaximizeFullScreen
  + I ThisWindow (Maximized) Style $n Title, Borders
  + I CondCase (NoMatch) Style $n NoTitle, !Borders
  + I CondCase (NoMatch) Raise
  + I CondCase (NoMatch) UpdateStyles
  + I Maximize

  Key F11  A  SC Pick FuncFvwmMaximizeFullScreen

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ploum <[email-masked]>
Date: Sun, 2 Mar 2003 15:24:56 +0100

>   Key F11  A  SC Pick FuncFvwmMaximizeFullScreen

It works great ! Thx ! :D

Just one thing : I have a tiny iconman on the top left of my screen. How
can I :

- maximize all screen but keep 24 pixels on the left for icon man ?
- be on the top of icon man ?

thx

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Mar 2003 21:50:45 +0000

> - be on the top of icon man ?

Since you use 2.5.6:

  EWMHBaseStruts 24 0 0 0

Regards,
Mikhael.

---

From: Ploum <[email-masked]>
Date: Sun, 2 Mar 2003 23:05:08 +0100

>   EWMHBaseStruts 24 0 0 0
Waw !  What a cool feature ! I like that :)

---

From: Ploum <[email-masked]>
Date: Sun, 2 Mar 2003 23:21:42 +0100

>   EWMHBaseStruts 24 0 0 0
And how about to put the maximized window over the pager ?  can I send the
window on the layer 10 ?

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 3 Mar 2003 01:12:51 +0100

> And how about to put the maximized window over the pager ?  can I send the

Yes you can. This works for me.

AddToFunc FullScreen
	+ I ThisWindow (!Maximized) Style $n BorderWidth 0
	+ I ThisWindow (!Maximized) Layer 10
	+ I ThisWindow ( Maximized) Style $n BorderWidth 1
	+ I ThisWindow ( Maximized) Layer 4
	+ I ThisWindow Maximize

	Thomas

---

From: Ploum <[email-masked]>
Date: Mon, 3 Mar 2003 01:57:15 +0100

Doesn't work well for me.  With this code, I have two problems :

- The window doesn't cover the 20 pixels on the bottom of my screen. (not
  critical but not pretty)
- The window keep the layer 10 and is on top over all the others window.
From: Thomas Glanzmann <[email-masked]> Date: 030303

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 3 Mar 2003 02:18:43 +0100

> - The window doesn't cover the 20 pixels on the bottom of my screen. (not

Use xwininfo -size [1] on the window. If this windows has x or y increments like
the xterm I provided in [1] it means that it can't go fullscreen at all.

> - The window keep the layer 10 and is on top over all the others window.

You could move you pager in layer 4 so you full screen application could step
ontop of your pager.

But just wait. Maybe someone else has a better idea than I do have.

	Thomas

[1] Use xwininfo -size to find out about x ans y increments

 (excalibur) [~] xwininfo -size
 
 xwininfo: Please select the window about which you
           would like information by clicking the
           mouse in that window.
 
 xwininfo: Window id: 0x60000e "MAINscreen"
 
   Normal window size hints:
       Program supplied size: 484 by 316
       Program supplied minimum size: 10 by 17
       Program supplied base size: 4 by 4
       Program supplied x resize increment: 6
       Program supplied y resize increment: 13
       Program supplied size in resize increments:  80 by 24
       Program supplied minimum size in resize increments: 1 by 1
       Program supplied base size in resize increments:  0 by 0
   No zoom window size hints defined
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 3 Mar 2003 01:51:15 +0000

On 03 Mar 2003 02:18:43 +0100, Thomas Glanzmann wrote:
> Use xwininfo -size [1] on the window. If this windows has x or y
> increments like the xterm I provided in [1] it means that it can't go
> fullscreen at all.

No, Thomas, this is not a problem. If you compare your function and mine
you will see the problem. You need UpdateStyles before Maximize otherwise
it maximizes a window as if border+title (20-30 pixels) are still here.

> You could move you pager in layer 4 so you full screen application could
> step ontop of your pager.
> 

Well, you may use Layer 5 not 10, or most probably just Raise is enough.

Regards,
Mikhael.