Subject: FVWM: should FVWM sending application key release events when switching via kotkeys?

From: Thomas Glanzmann <[email-masked]>
Date: Fri, 28 Mar 2003 09:43:06 +0100

Hi FVWMers,
I have problems with some applications:
	Quake
	UMLinux (http://www.umlinux.de/)

When I change from this applications with ALT TAB or some other hot keys
like CTRL + CURSOR to another page or application. The original
application does not get the release of the modifier (ALT or CONTROL) in
this case alt or control. For user mode linux I solved this problem that
I accounted every pressed key and release this keys explicit when the
application looses foucus.

So now comes my Question: Is this the job of the window manager or the
job of the application?

Greetings,
	Thomas

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 28 Mar 2003 20:34:38 +0100

> So now comes my Question: Is this the job of the window manager or the

The job of the application.  When it loses focus with a key
pressed, it can not assume that it will receive the key release
event.  It has to check the state of the keyboard when it receives
the focus again.  Fvwm can not propagate key events to unfocused
windows because it does not know which window should receive them.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].