Subject: FVWM: Focus problem

From: Uwe Pross <[email-masked]>
Date: Mon, 24 Mar 2003 09:38:49 +0100

Hi there,

this morning I experienced a problem using the following
key binding with version 2.5.6

DestroyFunc FocusRaise
AddToFunc FocusRaise I Raise
+ I Focus
+ I Iconify off

Key Tab A 4 Prev ("CurrentPage" "!Iconic" !"Fvwm*") FocusRaise

In version  2.5.3 and previous this keybinding circled
between _all_ windows on the current page starting with the
previous one.

In version 2.5.6 the keybinding toogles between the last
(prev) and the actual window. It seems that the order of
the WindowList is effected by the function above, which
should not be happen since I used "Focus" instead of
"FlipFocus".

Any ideas?

Uwe
-- 
Uwe Pross
mailto:[email-masked]
http://www.tu-chemnitz.de/~uwp
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Tue, 25 Mar 2003 08:55:15 +0100

Hi there,

> should not be happen since I used "Focus" instead of

Is this a silly question? Did I make a mistake? Is the
question not understandable?

Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 25 Mar 2003 10:23:28 +0100

> question not understandable?

I'll check that later.  Probably a new bug.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 25 Mar 2003 12:51:13 +0000

> question not understandable?

I would suggest to wait for more than 23 hours to repeat a question. :)

You are right, there is currently a bug in the developement version.
Focus behaves like FlipFocus. Some time ago it was vice versa in 2.5.x,
FocusFlip behaved like Focus.

Regards,
Mikhael.

---

From: [email-masked]
Date: Fri, 28 Mar 2003 21:17:15 +0100

> should not be happen since I used "Focus" instead of

Yes. Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 28 Mar 2003 21:30:54 +0100

On Tue, Mar 25, 2003 at 12:51:13PM +0000, Mikhael Goikhman wrote:
> Focus behaves like FlipFocus.

Not quite.  It worked like it should for ClickToFocus and like
FlipFocus for MouseFocus and SloppyFocus.

Bye

Dominik ^_^  ^_^