Subject: FVWM: Key Bindings - solaris 5.8

From: coerver <[email-masked]>
Date: Tue, 18 Mar 2003 21:58:09 -0500 (EST)

Can anyone point me on how to do key bindings with dolaris 5.8..I want
alt-tab behavior, switch desk behavior and some key combo that will let me
open a session to one of the 300 hosts I need access to.

I hope this isn't too lazy of a question

thanks

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Wed, 19 Mar 2003 08:05:29 +0100

Hi there,

On Tue, 18 Mar 2003, coerver wrote:

> alt-tab behavior, 

DestroyFunc FocusRaise
AddToFunc FocusRaise I Raise
+ I Focus
+ I Iconify off

Key Tab A 4 Prev ("CurrentPage" "!Iconic") FocusRaise

or

Key Tab A M Prev ("CurrentPage" "!Iconic") FocusRaise

You may exchange "CurrentPage" with "CurrentDesk", and
remove "!Iconic". I you don't want to circle through the
windows you may want to use "windowlist" to get all windows
displayed.

> switch desk behavior 

(Alt|Meta)-(left|right)

Key     Left    A      M      GotoDesk -1 0 2
Key     Right   A      M      GotoDesk +1 0 2

or

Key     Left    A      4      GotoDesk -1 0 2
Key     Right   A      4      GotoDesk +1 0 2
                                            ^
Note: You may have more desks than 3 

> and some key combo that will let me open a session to one
> of the 300 hosts I need access to.
         ^^^
Do you want to have 300 different key bindings?

Otherwise open a xterm and start ssh by hand:

Key x A SM Exec xterm

or 

Key x A S4 Exec xterm

Regards, Uwe
-- 
Uwe Pross
mailto:[email-masked]
http://www.tu-chemnitz.de/~uwp

---

From: coerver <[email-masked]>
Date: Wed, 19 Mar 2003 21:46:58 -0500 (EST)

Thanks I'll try.
I didn't realize how silly it sounds to ask for 300 different key bindings
ahem. But I have a group of homogenous hosts with serialized names i.e:
machine876 - machine888 etc. I was looking for some goofy cool
way to hit a certain key then enter serial number of the host..
Currently I use menu options which launch and xterm -e (expect script) to host.

by the way :: where is @gmx.net anyhow germany?

thanks again
-rob

---

From: Uwe Pross <[email-masked]>
Date: Thu, 20 Mar 2003 08:57:34 +0100

Hi there,

On Wed, 19 Mar 2003, coerver wrote:

> Thanks I'll try. I didn't realize how silly it sounds to
> ask for 300 different key bindings ahem. But I have a
> group of homogenous hosts with serialized names i.e:
> machine876 - machine888 etc. I was looking for some goofy
> cool way to hit a certain key then enter serial number of
> the host.. Currently I use menu options which launch and
> xterm -e (expect script) to host.

You could use FvwmForm to achieve this. 
Create a form which lets you insert the number of the
host you want to contact and start a function by pressing
enter or a button hit.

> by the way :: where is @gmx.net anyhow germany?

I think it is a german provider. One can choose between
severel extensions. (.de, .net, ...)

Regards, Uwe

---

From: Ben Winslow <[email-masked]>
Date: 20 Mar 2003 03:11:02 -0500

> by the way :: where is @gmx.net anyhow germany?

Incidentally, I'd like a way to do something similar...  I don't think
fvwm currently offers a way to do this, and I think fvwm 2.5 is in a
feature freeze right now.  Perhaps 2.7 could offer a way to wait for a
keypress in a complex function and then offer the pressed key key via a
$variable.  This should make it possible to have a function gather, say,
2 keys after it's invoked by a keybinding, glue them together, and do
something useful with them.

As for the present, it's probably possible to build something like this
using perl and FVWM::Module.  It'd probably be pretty simple, but I
haven't made it as far as trying yet.

-- 
Ben Winslow <[email-masked]>