Subject: Re: FVWM: Variable sized apps in 1 dimension FvwmButtons

From: Tenebrae <[email-masked]>
Date: Fri, 28 Feb 2003 22:42:06 -0800 (PST)

On Fri, 28 Feb 2003, Michael Fischer wrote:

> Hi
>
> I searched the past year's worth of archive, which
> at best pointed me to the manpage, and tried
> every combination out of the manpage, but no luck.
>
> I say all this as it probably is the next best thing
> to an FAQ.
>
> What I want is a 1 column, 4 row FvwmButtons, where
> (counting from top to bottom), the sizes are
>
> 68x68
> 68x68
> 68x252
> 68x68
>
> I have tried all combinations I could think of
> of specifying the app's -geometry, geometry as
> an option on the Button, Size, etc.
>
> So far I have gotten at best either a Buttons
> with all parts 68x68, or one with all parts 68x252.
>
> Here is a chunk of .fvwm2rc which does the latter
>
> *MailBoxGeometry -1+1
> *MailBoxBack black
> *MailBoxColumns 1
> *MailBox: (Swallow(UseOld,NoHints,Respawn) "xeyes" \
>                 `Exec exec xeyes -geometry 68x68`)
>
> *MailBox: (Swallow(UseOld,NoHints,Respawn) "xclock" \
>                 `Exec exec xclock -bg black -fg turquoise  -geometry 68x68 \
>                 -hd turquoise -hl turquoise -padding 0 -update 1`)
>
> *MailBox: (Swallow(UseOld,NoHints,Respawn) "gkrellm" \
>                 `Exec exec gkrellm` Size 68 252)
>
> *MailBox: (Swallow(UseOld,NoHints,Respawn) "kbiff" \
>                 `Exec exec kbiff -profile Inbox`)
>
>
>
> Note that changing the first line to
> *MailBoxGeometry 68x456-1+1
>
> Only squishes the 3rd app, making every button
> 114 tall.
>
> Clear 1 column (or 1 row) examples, even if they are complicated
> are most welcome and appreciated.
>
> Thanks in advance, and for the good work.

I could be wrong, but...
I have a comment in my .fvwm2rc that says:

# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -5-34

I believe my button size is determined by the size of the xpm images I
stuck in there.  The only button I have that's larger is xload and it's
double-sized.  Check this out:

*FvwmButtons(2x1, Title load, \
             Swallow(UseOld) "xload" 'Exec xload \
                     -nolabel -bg grey60 -update 5 -geometry -1500-1500 &')

Maybe something like that will work for you, too.
I hope this helps...
								-Tenebrae.
---
The sending of any unsolicited email advertising messages to this domain
may result in the imposition of civil liability against you in accordance
with Cal. Bus. & Prof. Code Section 17538.45.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Fischer <[email-masked]>
Date: Sat, 1 Mar 2003 03:01:31 -0500

> Maybe something like that will work for you, too.

No, 'fraid not. But thanks. Didn't seem to have any effect.

Michael
-- 
Michael Fischer				Happiness is a config option.
[email-masked]			Recompile and be happy.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kingsly John <[email-masked]>
Date: Sat, 1 Mar 2003 16:20:23 +0530

> 68x68

I think Fvwm requires all the buttons to be in some kind of ratio. (ie,252 is
not a multiple of 68)

> *MailBox: (Swallow(UseOld,NoHints,Respawn) "gkrellm" \ `Exec exec
> gkrellm` Size 68 252)

*MailBox: (1x4, Swallow(UseOld,NoHints,Respawn) "gkrellm" \ 
	`Exec exec gkrellm`)

will achieve something close to what you are looking for.

> Clear 1 column (or 1 row) examples, even if they are complicated are most
> welcome and appreciated.

You can read about Containers.. maybe it'll help you achieve what you are
looking for with a couple of  blank buttons ensuring that'll pad gkrellm (top
and bottom) to achieve some kind of ratio relationship.

Kingsly
-- 
---------------------------------------------------------------------------
     Kingsly At Users Dot SourceForge Dot Net  -- http://kingsly.org/
---------------------------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 1 Mar 2003 16:16:31 +0000

On 01 Mar 2003 16:20:23 +0530, Kingsly John wrote:
> I think Fvwm requires all the buttons to be in some kind of ratio.
> (ie,252 is not a multiple of 68)

Nothing like this is required. It is only that if it is a multiple of 68
all proportions may be reduced to 1x1 and so on, but this is optional.
The above may be reduced as well: 17x17, 17x63.

I suggest to use ButtonGeometry to specify the exact size of 1x1 button.
For example try:

  *FvwmButtons: ButtonGeometry 4x4-0+0
  *FvwmButtons: (17x17, ...)
  *FvwmButtons: (17x63, ...)

Regards,
Mikhael.

---

From: Tenebrae <[email-masked]>
Date: Sat, 1 Mar 2003 11:30:03 -0800 (PST)

>   *FvwmButtons: (17x63, ...)

Ohhhh...so he could specify the geometry like:

*FvwmButtons: ButtonGeometry 68x68-0+0

...and then for the larger button, he could put:

...and get rid of the other 68x68 geometry calls and it'll probably do
what he wants?  Well, it'd be 68x272 instead of 252, but...close enough
for government work?
								-Tenebrae.
---
The sending of any unsolicited email advertising messages to this domain
may result in the imposition of civil liability against you in accordance
with Cal. Bus. & Prof. Code Section 17538.45.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 1 Mar 2003 22:39:04 +0000

> what he wants?  Well, it'd be 68x272 instead of 252, but...close enough

I am not sure whether this is a rhetorical question or not. Yes, it would
be close enough to the Michael's needs. My example above gives the exact
sizes. As well as the following:

  *FvwmButtons: ButtonGeometry 1x1-0+0
  *FvwmButtons: Columns 68  # it is vertical
  *FvwmButtons: (68x68, ...)
  *FvwmButtons: (68x252, ...)

Regards,
Mikhael.

---

From: Michael Fischer <[email-masked]>
Date: Sun, 2 Mar 2003 14:33:45 -0500

> > >   *FvwmButtons: (17x63, ...)

*MailBox: ButtonGeometry 4x4-1+1
*MailBoxBack black
*MailBoxColumns 17 
*MailBox: (17x17, Swallow(UseOld,NoHints,Respawn) "xeyes" \
        `Exec exec xeyes -geometry 68x68`)

*MailBox: (17x17, Swallow(UseOld,NoHints,Respawn) "xclock" \
   `Exec exec xclock -bg black -fg turquoise  -geometry 68x68 \
   -hd turquoise -hl turquoise -padding 0 -update 1`)

*MailBox: (17x63, Swallow(UseOld,NoHints,Respawn) "gkrellm" \
        `Exec exec gkrellm`)

*MailBox: (17x17, Swallow(UseOld,NoHints,Respawn) "kbiff" \
        `Exec exec kbiff -profile Inbox`)

Bullseye. Thank you gentlemen. Problem solved.

Michael