Subject: Re: FVWM: Locking everything except mozilla launcher.

From: Prabu Subroto <[email-masked]>
Date: Thu, 6 Feb 2003 05:25:57 -0800 (PST)

Hi.. Martin.

You mean without XWindows? Is it possible?
And How should I write the command in the
"/etc/X11/xinit/xinitrc" to launch the mozilla?

Is it also possible to kick the user out (logout) if
they close the mozilla?
--- martin sepulveda
<[email-masked]> wrote:
> i guess you'll feel better using no windows manager
> at all, but including only a line calling mozilla
> in you xinitrc
> 
> (usually /etc/X11/xinit/xinitrc, or ~/.xinitrc)
> 
> m.
> 
> On Thu, 6 Feb 2003 02:56:45 -0800 (PST)
> Prabu Subroto <[email-masked]> wrote:
> 
> > Hallo.....
> > 
> > I am a newbie for fvwm. 
> > 
> > I have developed a database application with PHP4.
> > This application running on a web server. That's
> why
> > the user need a web browser (mozilla).
> > 
> > But my boss wants that his sales (sellers) can not
> use
> > (see) anything on their computer except the
> database
> > application of mine (mozilla).
> > And he also wants, once the user log-in than the
> > mozilla will be launched and if the user closes
> the
> > mozilla than he/she will be automatically kicked
> out
> > (log-out).
> > During the user is logged in, she/he can not see
> and
> > use any other application except mozilla.
> > 
> > I heard fvwm is better in this situation. But I
> don't
> > know how to implement that.
> > 
> > Please tell me. I am looking for a complete
> > dokumentation of fvwm but I can not find that.
> > 
> > Thank you very much in advance.
> > 
> > 

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Prabu Subroto <[email-masked]>
Date: Thu, 6 Feb 2003 05:54:48 -0800 (PST)

Hi Martin...

What is the syntax to call the mozilla from
"~/xinitrc"?

If the user minimizes the mozilla, it means she/he can
open any other application and play with it. My boss
doesn't want it.

Pffhh.....I will learn bash-shell after this problem
finish.
--- martin sepulveda
<[email-masked]> wrote:
> On Thu, 6 Feb 2003 05:25:57 -0800 (PST)
> that would be with XWindows but without a windows
> manager.
> 
> the X server execs the xinitrc-listed programs, and
> when the last one exits, so does
> the X server.
> 
> if i had to do what your boss requests, I'd install
> any linux ditribution, edit the
> /etc/inittab file, setting the initdefault to the X
> level (4 usually) and use a xinitrc file
> calling just the web browser.
> 
> by doing so the pc would boot, start the X server
> and request for a username/password.
> after that it would start just mozilla, and if the
> user closes it, it would respawn the X server
> and request for a username/password again.
> 
> guess thta's just what you want
> 
> m.

---

From: Prabu Subroto <[email-masked]>
Date: Thu, 6 Feb 2003 06:19:50 -0800 (PST)

Everything is getting clearer.

Hey my friend, martin. I still have two questions. 
1. Do I have to use fvwm or I can use any window
manager to do this thread?
2. What is the difference between XWindow and window
manager?

TAC.
--- martin sepulveda
<[email-masked]> wrote:
> just invoke it the way you would from a xterm, but
> remember you won't
> have a windows manager to move it around or
> anything.
> 
> i'd do something like:
> 
> mozilla  -width 1280 -height 1024
> 
> so it starts full screen (1280x1024 or whatever you
> use)
> 
> since there'e no windows manager, there won't be any
> menu or any other way to 
> start diferent applications.
> 
> BTW, it's ~/.xinitrc, i missed the dot.
> 
> 
> m.
> 
> 
> On Thu, 6 Feb 2003 05:54:48 -0800 (PST)