Subject: FVWM: Sending a 'key press' to an application

From: Thomas Glanzmann <[email-masked]>
Date: Tue, 25 Feb 2003 23:20:38 +0100

I wonder if it is possible to send a 'keypress' to an application.

Say I want that F2 is always go to opera? Or say that when I press the Help
button on my keyboard  - Opera is Focused, Raised, ... and 'F2' is sent to
opera?

Greetings,
	Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 26 Feb 2003 08:32:24 +0100

> button on my keyboard  - Opera is Focused, Raised, ... and 'F2' is sent to

In general, this is almost impossible to do.  Of course keyboard
events can be sent around, but you hardly ever know which window
to send them to.  Usually some cryptic subwindow or the
application wants the event.  And there are a number of
applications that ignore keyboard input if they do not have the
focus (for example xterm).

Bye

Dominik ^_^  ^_^