Subject: FVWM: Warp focus in current viewport only

From: Ploum <[email-masked]>
Date: Thu, 20 Feb 2003 23:24:52 +0100

Hi,

is it a way to use "FocusAndWarp" in the current viewport only ?  

I want to be able to switch between windows in my current viewport only...

Thx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 21 Feb 2003 08:22:43 +0100

> is it a way to use "FocusAndWarp" in the current viewport only ?  

Yes, of course.  You need to add an option to the conditional
command that you use to call that function.  For example, if you
have

  Next FocusAndWarp

or

  Next (some, options) FocusAndWarp

change that to

  Next (CurrentPage) FocusAndWarp

or

  Next (some, options, CurrentPage) FocusAndWarp

Check the man page sections about conditional commands for details.

> I want to be able to switch between windows in my current viewport only...

Bye

Dominik ^_^  ^_^

---

From: Ploum <[email-masked]>
Date: Fri, 21 Feb 2003 08:39:07 +0100

It works great ! Many thx :)
(I add this fucntion to Meta+Mouse4 and Meta+Mouse5, it's great :) )

Ploum
From: Fvwm List <[email-masked]> Date: 210203