Subject: FVWM: Hold mplayer in Layer 4

From: Thomas Glanzmann <[email-masked]>
Date: Fri, 21 Feb 2003 16:57:29 +0100

Hi FVWMers!
I have a problem with mplayer. Always I tell mplayer to go fullscreen it changes
his layer from 4 to 10 ... I don't like this. Is there a way to tell FVWM to
forbid mplayer to change its layer?

I tried the following which doesn't work.

Style "MPlayer" BorderWidth 0, HandleWidth 0, Layer 4

Greetings,
	Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 11:56:05 -0500

> Style "MPlayer" BorderWidth 0, HandleWidth 0, Layer 4

Sorry, right now I can't seem to locate any movie file to test anything.
I do notice that the mplayer man page says to try 7 different -fsmode
values.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Thomas Glanzmann <[email-masked]>
Date: Fri, 21 Feb 2003 18:06:16 +0100

> I do notice that the mplayer man page says to try 7 different -fsmode

Thanks for your support. It isn't that critical. I put a 2.6 M file for you on 

http://wwwcip.informatik.uni-erlangen.de/~sithglan/sqrat_steckt_fest.avi

My mplayer manpages says:

-fsmode-dontuse <0-31> (OBSOLETE) (use -fs option)
      Try this option if you still experience fullscreen problems.

Greetings,
	Thomas

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 13:03:49 -0500

Thomas Glanzmann <[email-masked]> writes:
> > > Hi FVWMers!
> > > I have a problem with mplayer. Always I tell mplayer to go fullscreen it 
> > > chages
> > > his layer from 4 to 10 ... I don't like this. Is there a way to tell FVWM
> > > to forbid mplayer to change its layer?
> > > 

I don't have the necessary w32 codecs.  (Its on my list of things to
deal with someday.)  I found that gmplayer will go fullscreen into
layer 10 without a movie.

You could make the default layer 10:

DefaultLayers 8 10 12

You could set up a key binding:

key f12 w s Layer 0 4

---

From: Thomas Glanzmann <[email-masked]>
Date: Fri, 21 Feb 2003 19:18:58 +0100

> layer 10 without a movie.

You don't need the w32 codes. Get a actual mplayer version instead. :-)

> DefaultLayers 8 10 12

That works. Thanks.

> You could set up a key binding:

I already have a hotkey for that but it is anoying to press it each time. :-)

Thank you again :-)

---

From: [email-masked]
Date: Mon, 24 Feb 2003 01:09:23 +0100

> Style "MPlayer" BorderWidth 0, HandleWidth 0, Layer 4

Try

  Style MPlayer GnomeIgnoreHints, EWMHIgnoreStackingOrderHints

One of those two styles should work.  You need 2.5.x for the
EWMH... style.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 23 Feb 2003 19:42:00 -0500

[email-masked] writes:
> > changes his layer from 4 to 10 ... I don't like this. Is there a way to
> > tell FVWM to forbid mplayer to change its layer?
> > 

Darn.  Its the GnomeIgnoreHints.

I tried the EWMHIgnoreStackingOrderHints and that didn't do it.

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 10:47:34 +0100

> I tried the EWMHIgnoreStackingOrderHints and that didn't do it.

Thanks you too. It is GnomeIgnoreHints and it works like expected.

	Thomas