Subject: FVWM: left Window key (et al) as modifier key?

From: Gert Brinkmann <[email-masked]>
Date: Sun, 16 Feb 2003 21:47:58 +0100

Hello,

after checking the man page, the FAQ and trying to search the web (it's 
difficult to search for this topic "fvwm window key modifier" that 
results in many fvwmrc files) i ask you:

Is it possible to use the following keys as modifiers?

* left window
* (right) Alt Gr
* right window
* menu
* right control as other key as left control (the same for shift)?

Especially the first key would be important for me, because i would like 
to control *window* behaviour by the (left-)window key and do 
desktop/page controlling via ALT-CTRL. (only ALT or only CTRL is to 
critical, as i think, because they are used by applications often)

Thanks,

Gert

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 16 Feb 2003 16:49:39 -0500

> critical, as i think, because they are used by applications often)

On my system, the left window key is Alt_L.
I can see that with xev.

Then I do:

home> xmodmap -pm
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock      
control     Control_L (0x25),  Control_R (0x6d),  Control_L (0x42)
mod1        Meta_L (0x40)
mod2        Num_Lock (0x4d)
mod3      
mod4        Alt_L (0x73)
mod5      

So it looks like the windows key is mod 4.

So to bind Maximize to Alt_L F2, I'd use:

Key F2		A	4	Maximize grow grow

Likewise for other keys.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Gert Brinkmann <[email-masked]>
Date: Mon, 17 Feb 2003 14:40:12 +0100

Thank you, Dan.

> On my system, the left window key is Alt_L.

Ok, i know xev...

> home> xmodmap -pm

But i am not experienced with the whole xmodmap stuff yet. With your 
description i understand the related paragraph in the man page now:

  X11 modifiers mod1 through
  mod5  are  represented  as  the  digits  '1'
  through '5'.

Perhaps this paragraph should mention the two commands "xev" and 
"xmodmap -pm", to avoid other people's questions?

Ciao and thank you again,

Gert