Subject: FVWM: about title bar

From: [email-masked]
Date: Sat, 22 Feb 2003 00:37:46 +0000

hello, i'm a spanish fvwm user. i don't speek english very well, sorry.

i'd like to change the color of title bar, but when i do it, i can see
the frame color behind the title bar color.
ex:
	AddToDecor CDEDecor
	+ BorderStyle -- Raised
	+ TitleStyle LeftJustified Height 21
	#+ TitleStyle Centered
-->	+ TitleStyle ActiveUp Solid green
	+ TitleStyle ActiveDown Solid #336699
	+ TitleStyle -- Raised
	+ ButtonStyle   Reset
	+ ButtonStyle   4 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
	+ ButtonStyle   2 5 20x20@1 20x80@1 80x80@0 80x20@0 20x20@1
	+ ButtonStyle   1 5 20x45@1 80x45@1 80x55@0 20x55@0 20x45@1
	...
	Style CDEStyle UseDecor CDEDecor
	...
	Style *         HilightFore white
-->	Style *         HilightBack #ce8200
	#Style *        Color black/slategrey
	Style *         Color white/#336699
	...

the fvwm version is 2.5.5

i don't know if i explained it very well. is it posible that i want to
do?

thanks very much!.

-- 
 miguel
 E-Mail: [email-masked]
 IRC: irc.openprojects.net #linux-malaga

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Gert Brinkmann <[email-masked]>
Date: Sat, 22 Feb 2003 14:41:49 +0100

> the frame color behind the title bar color.

I am not sure, if i understand you right: You want the focused window to 
have a green title, but it is #ce8200?

> 	AddToDecor CDEDecor

The fvwm man page says that the decor-options are all deprecated. So you 
might try it without this? Just write

TitleStyle ActiveUp Solid green

> -->	Style *         HilightBack #ce8200

As i understand these two options, they are doing the same, aren't they? 
So you overwrite the first color by the second?

Please correct me, if i am wrong. I am experimenting with these options 
for the first time at the moment.

Gert

---

From: [email-masked]
Date: Sat, 22 Feb 2003 15:27:04 +0000

mmm, well, i'll try to explain it better. It's dificult :)

this configuration file was for 2.4.14 version, and it working for 2.5.5
version.

the thing that i want to do is (if it's posible):

first, i'm think that you are wrong because,
Style* HilightBack #ce8200
change the background color of a window (completly, buttonbar
titlebar...), a window that is focused. (is it said in english correct? :) )

and if you add this line before:
AddToDecor CDEDecor
...
+ TitleStyle ActiveUp Solid green
...

then, the window has the first color (#ce8200), and the titlebar has the
second color but, it is my cuestion, why i can't to watch the title
button completely drawed with green color?

i think that i don't make it well.

i have put 2 screenshots in my server (anonymous ftp), please, download
it and you'll understand me better. ftp://isis.no-ip.org/pub

> might try it without this? Just write

and in the fvwm 2.4.14 man page says that the Solid option (in
Titlestyle) is destructive...

> for the first time at the moment.

thanks!

-- 
 KarnaK WorlD

---

From: Gert Brinkmann <[email-masked]>
Date: Sun, 23 Feb 2003 14:27:01 +0100

> it and you'll understand me better. ftp://isis.no-ip.org/pub

Ok, so you want the buttons to be of the same color as the title?

If so, then try an

   ButtonStyle All -- UseTitleStyle

*after* defining the buttons. Does this help?

btw: What does your icon "Amiga Pg" mean? Are you an (Ex-)Amiga-User? 
(Great!)

Gert

---

From: [email-masked]
Date: Sun, 23 Feb 2003 14:50:09 +0000

ahhg! :-)

no, i dont want the buttons to be of same color as the title, that i
want is the title to be of green color but i can see 2 colors, green and
other, and i want that it to be green COMPLETELY...
jeje, it's dificult to explain it in english...
thanks

---

From: Gert Brinkmann <[email-masked]>
Date: Sun, 23 Feb 2003 15:15:24 +0100

> *after* defining the buttons. Does this help?

btw: This is one thing that i do not understand: Why are there the two 
options "ButtonStyle" and "AddButtonStyle"?

As i understand it is like the following: When using ButtonStyle you 
overwrite the old button definitions. To add some more configurations to 
this button you have to use AddButtonStyle.

But know i ask myself:

1) Why is there an "ButtonStyle Reset" when the first usage of 
"ButtonStyle" resets it anyway?

2) Why is "ButtonStyle All -- UseTitleStyle" working without resetting 
the buttons? Why don't you have to use the "AddButtonStyle" here? Can it 
be used here?

Thanks,

Gert

---

From: Gert Brinkmann <[email-masked]>
Date: Sun, 23 Feb 2003 15:05:41 +0100

[email-masked] wrote:

> that i

Ok, you want the title to be green and also the top window border?

Gert