Subject: FVWM: Using taskbar ?

From: Ploum <[email-masked]>
Date: Thu, 20 Feb 2003 21:08:55 +0100

Hi,

Is there a way to have a sort of "mini taskbar" in fvwm ?  

I would like to have mini-icons of windows currently open in my viewport. (by
mini icons, I mean like my fvwm-button, upper left :
http://frimouvy.udev.org/config.html )

Is there a way to have this fvwm button staying always on top ?

Hope that someone understand what I mean...

Ploum

PS : I don't understand why, but my "RaiseOnClick" doesn't work at all ! :(
If someone has try my config, say me if you have the same problem !
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 21 Feb 2003 09:00:55 +0100

> Is there a way to have this fvwm button staying always on top ?

Sure.  Replace "StaysOnBottom" near the end of your config with
"StaysOnTop".

Are you aware that the FvwmButtons config is riddled with syntax
errors?  This is what I get on the console:

  FvwmButtons: Illegal button option "exec"
  FvwmButtons: Illegal button option "zinf"
  FvwmButtons: Illegal Swallow option "position"
  FvwmButtons: Illegal Swallow option "top"
  FvwmButtons: Illegal Swallow option "right"
  FvwmButtons: Illegal Swallow option "delay"
  FvwmButtons: Illegal Swallow option "0"
  FvwmButtons: a button can not have an icon and a swallowed  window at
  the same time. Ignoring iconFvwmButtons: Illegal button option "exec"
  FvwmButtons: Illegal button option "psi"

> If someone has try my config, say me if you have the same problem !

Works fine with your config here.  If you can't figure it out on
your own, strip down your config to the bare minimum so that is
still does not work although you have configured it and post the
lines to the mailing list.

Bye

Dominik ^_^  ^_^

---

From: Ploum <[email-masked]>
Date: Fri, 21 Feb 2003 09:36:30 +0100

From: Fvwm List <[email-masked]> Date: 210203
> > I would like to have mini-icons of windows currently open in my viewport.

I will read about fvwm taskbar... 
If anyone use mini-taskbar, could you send me your config file ?
 
> Sure.  Replace "StaysOnBottom" near the end of your config with

Thx, it works great.. (hm... I was not so intelligent for this ;) )
 
>[...] 

I correct this !  I hear a lot about fvwm console, but how it works ? (and
how start it ?) Ok... I will check the man now !  

I try that button launch the requested program when it is not running...
But this is not essential..
 
> lines to the mailing list.

I will try this !  RaiseOnClick never worked for me ! Since my first config
! (I mean  "Raise when Click inside the window, not only the border and the
titlebar" )
 
Thx for your help :)

Ploum

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 21 Feb 2003 09:59:22 +0100

> how start it ?) Ok... I will check the man now !  

It is just a text window where you can type configuration
commands.  Add it to a menu or a keystroke:

  AddToMenu RootMenu
  + FvwmConsole Module FvwmConsole
  Key c a cm Module FvwmConsole

> But this is not essential..

See question 7.12 in the FAQ for more details.

Bye

Dominik ^_^  ^_^

---

From: Ploum <[email-masked]>
Date: Fri, 21 Feb 2003 10:01:45 +0100

Sorry for noise, but I read the FvwmTaskBar man and I'm still looking for
following options :

- Show icons only (I reduce the width of button to the 32 minimum, but it's
  still big...  )
- Don't show the start menu. (I don't need such thing)
- Have the taskbar vertical... And don't take all the screen, but only
  needed space. (an invisible taskbar when no application is launched !)

Thx

PS: perhaps fvwmTaskBar is not the best way of doing what I want...

Ploum
From: Ploum <[email-masked]> Date: 210203

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 21 Feb 2003 10:13:33 +0100

>   needed space. (an invisible taskbar when no application is launched !)

I don't think the taskbar can do either of this.  You may be
better off using FvwmIconMan of FvwmWinList.

Bye

Dominik ^_^  ^_^

---

From: Ploum <[email-masked]>
Date: Fri, 21 Feb 2003 11:16:29 +0100

Thx for the tips ! I use IconMan and it works really great :)

Ploum