Subject: FVWM: Real fullscreen

From: Ploum <[email-masked]>
Date: Thu, 20 Feb 2003 21:57:14 +0100

is it a way to set a window in "real" full screen with fvwm ?  (by "real
fullscreen", I mean no more title bar or border... )

It can be useful to set a console in fullscreen on a viewport...

Ploum
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 20 Feb 2003 16:12:38 -0500

> It can be useful to set a console in fullscreen on a viewport...

You can do:

Style test HandleWidth 0, BorderWidth 0, NoTitle

then start an xterm like this:

xterm -name test -geometry 150x60

Adjust the geometry to your font and screen size.

That will be almost full screen, but depending on the font and
the dimensions of your screen, there might be a little edge uncovered.
You might be able to use a very narrow border width to cover up the
part left exposed.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Lionel Dricot <[email-masked]>
Date: Thu, 20 Feb 2003 22:26:42 +0100

Thx for reply, but I'm looking for a "fullscreen switch". A kind of
Maximize if you see...
(Sorry if you misunderstood, my english is very bad !)
From: Dan Espen <[email-masked]> Date: 200203

---

From: Ploum <[email-masked]>
Date: Thu, 20 Feb 2003 22:27:14 +0100

---

From: Dan Espen <[email-masked]>
Date: Fri, 21 Feb 2003 08:18:16 -0500

> > You might be able to use a very narrow border width to cover up the

This only works with recent 2.5.x:

DestroyFunc tm
AddToFunc tm
+ I Current (!Maximized) Style "$[w.name]" HandleWidth 0, BorderWidth 0, NoTitle
+ I Current (Maximized) Style "$[w.name]" HandleWidth 6, BorderWidth 6, Title
+ I Maximize
Key F12 w s tm