Subject: FVWM: Can't switch of SelectOnRelease for Windowlist in current cvs and in stable version

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 14:35:58 +0100

Hi FVWMers,
I try to disable the SelectOnRelease Feature for the Windowlist.

The following is from the Manpage:

> The SelectOnRelease option works exactly like the MenuStyle option with the same
> name, but overrides the option given in a menu style.  By default, this option
> is  set  to  the left Alt key.  To switch it off, use SelectOnRelease without a
> key name.

I tried to add the following to my .fvwm2rc but without luck.

MenuStyle WindowList SelectOnRelease

	Thomas
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 24 Feb 2003 15:24:34 +0100

> MenuStyle WindowList SelectOnRelease

I guess it is confusing.  In case of the WindowList, the
WindowList command implicitly adds "SelectOnRelease Meta_L" to its
command line - unless you specify that option manually.  You have
edit ConfigFvwmDefaults and replace

  Key Tab A M WindowList Root c c NoDeskSort

with

  Key Tab A M WindowList Root c c NoDeskSort, SelectOnRelease

I think I will change that and simply put a
"SelectOnRelease Meta_L" in the defaults file.

Bye

Dominik ^_^  ^_^

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 15:28:49 +0100

> I guess it is confusing.  In case of the WindowList, the WindowList command
> implicitly adds "SelectOnRelease Meta_L" to its command line - unless you
> specify that option manually.  You have edit ConfigFvwmDefaults and replace

>   Key Tab A M WindowList Root c c NoDeskSort, SelectOnRelease

Ic. I added the line to my config file and it works :-)

> "SelectOnRelease Meta_L" in the defaults file.

Yep ... or give a hint in the manpage. I was already in the defaults file ...
but I did not see it. :-) I asked that question years ago. And now it is finally
solved. Thnx!

	Thomas

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 24 Feb 2003 15:56:33 +0100

On Mon, Feb 24, 2003 at 03:28:49PM +0100, Thomas Glanzmann wrote:
> Yep ... or give a hint in the manpage.

Could you write a patch for the man page?  I think I am too
involved with fvwm to explain that myself.

> I was already in the defaults file ... but I did not see it. :-)

Because it's not in the defaults file but hard coded in
windowlist.c.  I had already written a patch that adds a
WindowList menu style in ConfigFvwmDefaults.  It worked exactly as
described in the man page and was easy to understand, but
unforunately the window list did not use the default menu style anymore
:-(

> I asked that question years ago. And now it is finally
> solved. Thnx!

Sometimes I miss a message and asking twice helps.

Bye

Dominik ^_^  ^_^

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 16:23:06 +0100

> involved with fvwm to explain that myself.

I'll do.

> Because it's not in the defaults file but hard coded in windowlist.c. 

You're right. I checked it after writing the eMail. :-)

> I had already written a patch that adds a WindowList menu style in
> ConfigFvwmDefaults.  It worked exactly as described in the man page and was
> easy to understand, but unforunately the window list did not use the default
> menu style anymore :-(

I see.

> Sometimes I miss a message and asking twice helps.

No problem. You have surely other things todo.

	Thomas