Subject: FVWM: snap-20030224 compile problem with forte7

From: Tomi Vainio - Sun Finland <[email-masked]>
Date: Tue, 25 Feb 2003 16:38:43 +0200

/v/t/src/fvwm-snap-20030224(418)% make
make  all-recursive
Making all in libs
Making all in fvwm
cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs           -I/usr/openwin/include             -I/usr/local/include -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.5.6\"     -DFVWM_DATADIR=\"/usr/local/share/fvwm\"        -DFVWM_CONFDIR=\"/usr/local/etc\"       -DFVWM_COLORSET_PRIVATE=1       -DLOCALEDIR=\"/usr/local/share/locale\" -xO4 -c focus.c
"eventhandler.h", line 62: warning: syntax error:  empty declaration
"eventhandler.h", line 63: warning: syntax error:  empty declaration
"focus.c", line 822: warning: statement not reached
"focus.c", line 881: void function cannot return value
"focus.c", line 886: void function cannot return value
cc: acomp failed for focus.c
*** Error code 2

  Tomppa
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 25 Feb 2003 11:20:17 -0500

Tomi Vainio - Sun Finland <[email-masked]> writes:
> cc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I../libs           -I/usr/openwin/inclu
> de             -I/usr/local/include -DFVWM_MODULEDIR=\"/usr/local/libexec/fvw
> m/2.5.6\"     -DFVWM_DATADIR=\"/usr/local/share/fvwm\"        -DFVWM_CONFDIR=
> \"/usr/local/etc\"       -DFVWM_COLORSET_PRIVATE=1       -DLOCALEDIR=\"/usr/l
> ocal/share/locale\" -xO4 -c focus.c

I fixed the issues in focus.c.

Maybe you should do "make -k" (keep going) so we can find all
the Forte7 issues.  I'd try it myself, but 6.2 seems to be my
latest version.

-- 
Dan Espen                           E-mail: [email-masked]