Subject: FVWM: Mouse 4/5 default action removal

From: Alexander Kotelnikov <[email-masked]>
Date: Tue, 18 Feb 2003 05:05:36 +0300

Hi.

Is there any way to avoid default actions for Mouse 4 and 5 in a
manner similar to 'Key Tab A M -'. It seems that 'Mouse 4   R  A  Nop'
works, but there is always subtle difference between no action and
null-action...
-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 Feb 2003 02:39:13 +0000

> works, but there is always subtle difference between no action and

The following should do it for you:

  Mouse 0 R N -
  Mouse 1 R N Menu MenuFvwmRoot
  Mouse 2 R N Menu MenuFvwmRoot
  Mouse 3 R N Menu MenuFvwmRoot

I agree here, this should be the built-in default.
Actually, I would only use "Mouse 1 R A" instead of "Mouse 0 R N".

Regards,
Mikhael.

---

From: Alexander Kotelnikov <[email-masked]>
Date: Tue, 18 Feb 2003 06:25:50 +0300

>>>>> On Tue, 18 Feb 2003 02:39:13 +0000
>>>>> "MG" == Mikhael Goikhman <[email-masked]> wrote:
MG> 
>> works, but there is always subtle difference between no action and
MG> 
MG> The following should do it for you:
MG> 
MG>   Mouse 0 R N -

Stragne thing is that  
Mouse 0 R A - 
does not cover
Mouse 0 R N -

Is it ok?

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 18 Feb 2003 04:11:17 +0000

> MG> The following should do it for you:

Yes, the entire binding should match completely to be deleted, not less,
not more. Because the bindings are not auto-deleted even if overlapped.

Regards,
Mikhael.