Subject: FVWM: Doing the monitor always "on" in FVWM2

From: Prabu Subroto <[email-masked]>
Date: Mon, 24 Feb 2003 03:00:57 -0800 (PST)

Dear my friends...

I just succeeded to make XWindows Kiosk with FVWM2. On
FVWM2 it runs perfectly and very easy to imlement.

My boss want the monitor of each computer is on for 24
hours (around the clock). I don't know how to do that.
Must I switch off the screen saver? But How?
Today the monitor is off every 3 minutes.

Please tell me my friends.

Thank you very much in advance.

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 24 Feb 2003 12:27:07 +0100

> Today the monitor is off every 3 minutes.

You probably have the screen blanking feature in the X server
enabled.  Use

  $ xset s off

to turn it off.  If that does not help. look for processes named
xlock, xlockmore, xscreensaver, etc. and prevent that they are
started.

Bye

Dominik ^_^  ^_^

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 12:28:04 +0100

> Please tell me my friends.

It isn't a fvwm related question. But you can disable power saving by disabling
DPMS.

This is from the manpage of my xset utility on Debian (Woody) Linux.

>      -dpms   The -dpms option disables DPMS (Energy Star) features.

so 'xset -dpms' should to the trick.

	Thomas

---

From: Prabu Subroto <[email-masked]>
Date: Mon, 24 Feb 2003 03:35:52 -0800 (PST)

Dear Dominik...

it is still confusing for me. Could you explain more
detail which file should I edit?
Here is my "/etc/X11/fvwm2/system.fvwm2rc":

"
prabu@patrix:/etc/X11/fvwm2> grep -n "xset*"
system.fvwm2rc
63: +   "I"     Exec xsetroot
66: +   "I"     Exec xsetroot
718: + "hard%mini.xapp.xpm%"             Exec xset c
100
719: + "Off%mini.xapp.xpm%"              Exec xset c
off
720: + "soft%mini.xapp.xpm%"             Exec xset c
on
727: + "fast%mini.xapp.xpm%"             Exec xset m 4
2
729: + "normal%mini.xapp.xpm%"           Exec xset m 2
5
730: + "slow%mini.xapp.xpm%"             Exec xset m 1
1
737: + "loud%mini.xapp.xpm%"             Exec xset b 
100 600 50
738: + "normal%mini.xapp.xpm%"           Exec xset b
on
739: + "loud and long%mini.xapp.xpm%"            Exec
xset b 100 600 300
740: + "Off%mini.xapp.xpm%"              Exec xset b
off
747: + "Blank%mini.xapp.xpm%"            Exec xset s
blank
748: + "Off%mini.xapp.xpm%"              Exec xset s
off
749: + "Pattern after 5 min%mini.xapp.xpm%"           
  Exec xset s noblank s 300 300
750: + "Immediately%mini.xapp.xpm%"              Exec
xset s activate
751: + "Default%mini.xapp.xpm%"          Exec xset s
default
prabu@patrix:/etc/X11/fvwm2>
"

Which "xset" should I change?

I am using SuSE Linux 8.1

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 24 Feb 2003 12:42:46 +0100

> detail which file should I edit?

xset is not related to fvwm. It is a programm you can execute and add it to
your fvwm2rc init function:

For example:

DestroyFunc InitFunction
AddToFunc InitFunction
	+ I Exec xset s off
	+ I Exec xset -dpms

	Thomas

---

From: Prabu Subroto <[email-masked]>
Date: Mon, 24 Feb 2003 04:06:34 -0800 (PST)

Hmmm.... and where should I put "xset -dpms" ?
Should I put it in this file :
"/etc/X11/fvwm2/system.fvwm2rc" ?

Does it also work in SuSE 8.1?

Thank you very much, Thomas.
--- Thomas Glanzmann <[email-masked]>