Subject: FVWM: Java Swing window positioning

From: Tessa Lau <[email-masked]>
Date: Mon, 03 Feb 2003 17:46:10 -0500

I'm writing an application in Java Swing (Sun JDK 1.4.1).  When the
application comes up, it's always positioned off the upper-left corner
of the screen, so that the titlebar and left border are not visible.
I use FVWM 2.5.5.

How do I get FVWM to position the window correctly?

Thanks,
--Tessa
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 05 Feb 2003 09:29:57 -0500

> How do I get FVWM to position the window correctly?

I think I've seen this before with Java apps, but right now
I can't reproduce it.  I'm using current CVS (I don't think
thats why its working), and Sun JDK 1.4.1-01.

My placement policy is:

Style * ActivePlacement, SmartPlacement
Style "*" UsePPosition

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Bob Woodside <[email-masked]>
Date: Wed, 5 Feb 2003 11:00:01 -0500

On Wed, 05 Feb 2003 09:29:57 -0500
Dan Espen <[email-masked]> wrote:

> > application comes up, it's always positioned off the upper-left
> > corner of the screen, so that the titlebar and left border are not
> > visible. I use FVWM 2.5.5.
> > 

	You might try adding

        Style * FixedPPosition

in the 2.5 series. I think this is the one that did it for me.

Cheers,
Bob

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 27 Feb 2003 00:07:18 +0100

> How do I get FVWM to position the window correctly?

It seems that Dan and me do not have this problem (without the
FixedPPosition style). Can you send me a minimal java program
which has this problem.

Thanks, Olivier