Subject: FVWM: FvwmAuto core dump

From: Nadim Shaikli <[email-masked]>
Date: Tue, 25 Feb 2003 10:40:29 -0800 (PST)

Greetings, I downloaded 'snap-20030224' and gave it a try.  FvwmAuto
core dumps on me.

  uname -a : SunOS pin 5.8 Generic_108528-15 sun4u
  gcc -v   : gcc version 2.95.2 19991024 (release)

I invoke FvwmAuto via menu as noted below,

 AddToMenu ModulesMenu
 +       "Fvwm Modules"  Title   
 +       "Animate"       Module  FvwmAnimate
 +       "AutoRaise"     Module  FvwmAuto 350
 +       "Backer"        Module  FvwmBacker

I see the following in my stderr upon invocation,

FvwmAuto: em 0, lm 0, enter 'Silent Raise', leave '[FVWM][PositiveWrite]:
<<ERROR>> Failed to read descriptor from 'FvwmAuto':
- data available=Y
- terminate signal=N

Here is the coredump backtrace.

Core was generated by
`/opt/download/fvwm-snap-20030224/done/libexec/fvwm/2.5.6/FvwmA'.
Program terminated with signal 11, Segmentation Fault.
Reading symbols from /usr/lib/libSM.so.6...done.
Reading symbols from /usr/lib/libICE.so.6...done.
Reading symbols from /usr/lib/libXext.so.0...done.
Reading symbols from /usr/lib/libX11.so.4...done.
Reading symbols from /usr/lib/libsocket.so.1...done.
Reading symbols from /usr/lib/libnsl.so.1...done.
Reading symbols from /usr/lib/libc.so.1...done.
Reading symbols from /usr/lib/libdl.so.1...done.
Reading symbols from /usr/lib/libmp.so.2...done.
Reading symbols from /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1...done.
#0  0xff036f3c in unlocked_setkey () from /usr/lib/libc.so.1
(gdb) where
#0  0xff036f3c in unlocked_setkey () from /usr/lib/libc.so.1
#1  0xff08366c in _doprnt () from /usr/lib/libc.so.1
#2  0x11a50 in main (argc=151456, argv=0xffbeeb44) at FvwmAuto.c:342

Regards,

 - Nadim

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 25 Feb 2003 15:13:18 -0500

> Greetings, I downloaded 'snap-20030224' and gave it a try.  FvwmAuto

Should be fixed in the next snapshot.

Thanks.
-- 
Dan Espen                           E-mail: [email-masked]