Subject: FVWM: Locking everything except mozilla launcher.

From: Prabu Subroto <[email-masked]>
Date: Thu, 6 Feb 2003 02:56:45 -0800 (PST)

Hallo.....

I am a newbie for fvwm. 

I have developed a database application with PHP4.
This application running on a web server. That's why
the user need a web browser (mozilla).

But my boss wants that his sales (sellers) can not use
(see) anything on their computer except the database
application of mine (mozilla).
And he also wants, once the user log-in than the
mozilla will be launched and if the user closes the
mozilla than he/she will be automatically kicked out
(log-out).
During the user is logged in, she/he can not see and
use any other application except mozilla.

I heard fvwm is better in this situation. But I don't
know how to implement that.

Please tell me. I am looking for a complete
dokumentation of fvwm but I can not find that.

Thank you very much in advance.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Jules Alberts" <[email-masked]>
Date: Thu, 06 Feb 2003 15:15:37 +0100

> use any other application except mozilla.

Maybe this will help:

http://www.icewalkers.com/doclib/howtos/Kiosk-HOWTO.html

---

From: Prabu Subroto <[email-masked]>
Date: Thu, 6 Feb 2003 06:30:52 -0800 (PST)

Well, it is very of you.

Thank you very much. Now, I have enough brave to start
my task in Sunday (Holiday for the sales).

I will do that. Thank you very much for you and for
Martin.

--- Jules Alberts

---

From: Mike Dennison <[email-masked]>
Date: Thu, 06 Feb 2003 14:30:05 +0000

Why don't you just make the users shell mozilla, then when they exit they log out?

I just tried:

useradd -c 'Mozilla' -d /home/moz -g test -G test -m -s /usr/bin/mozilla  moz

now if I log on as user moz (assuming logging in from xdm or gdm or equivalent) I just get mozilla, and when I quit I get logged out.....

I don't know if there is some way to run shell commands from within mozilla that may need to be removed, and you may need to specify a size for the mozilla window.....

On Thu, 06 Feb 2003 02:56:45 -0800 (PST)

> Thank you very much in advance.

best wishes

Mike

----------------------------------------------------------------------
Mike Dennison,                        email: [email-masked]
WesternGeco
Computer Systems & Support, Gatwick, England
Tel: +44 (0)1293 55 6260                    Mobile: +44 (0)7775 912579
Fax: +44 (0)1293 55 6220
----------------------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Prabu Subroto <[email-masked]>
Date: Tue, 11 Feb 2003 03:16:23 -0800 (PST)

Thanks man, I really appreciate your help.
--- Mike Dennison <[email-masked]> wrote:
> now if I log on as user moz (assuming logging in
> from xdm or gdm or equivalent) I just get mozilla,
> and when I quit I get logged out.....
> 
> I don't know if there is some way to run shell
> commands from within mozilla that may need to be
> removed, and you may need to specify a size for the
> mozilla window.....
> 
> 
> 

__________________________________________________
Do you Yahoo!?
Yahoo! Shopping - Send Flowers for Valentine's Day
http://shopping.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].