Subject: FVWM: fvwm and wine windows

From: Markus Grunwald <[email-masked]>
Date: Wed, 12 Feb 2003 18:47:42 +0100

Hello,

I have a problem with wine - perhaps fvwm can solve it...

When I open "cool edit" (the best sound editor - unfortunately nothing
in the linux world compares to it) and start a longer calculation, I get
a little progress window. The problem is, that I can not move the
window, it stays allways on top and it is sticky on all screens :(

When I run xwininfo on the window, I get this info:
xwininfo: Window id: 0x1a000ee ""

  Absolute upper-left X:  615
  Absolute upper-left Y:  533
  Relative upper-left X:  615
  Relative upper-left Y:  533
  Width: 370
  Height: 134
  Depth: 24
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0xc00001 (not installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +615+533  -1639+533  -1639-533  +615-533
  -geometry 370x134+615+533

Is there any way to give this window a "normal" behaviour ?
The program versions are:

||/ Name           Version        Beschreibung
+++-==============-==============-=====================================
======= ii  fvwm           2.4.10-2       F(?) Virtual Window Manager,
version 2.4 ii  wine           0.0.20020904-1 Windows Emulator (Binary
Emulator)

TIA,
-- 
Markus Grunwald

Registered Linux User Nr 101577
http://counter.li.org          
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 13 Feb 2003 13:05:22 -0500

> window, it stays allways on top and it is sticky on all screens :(

Find this in your ~/.wine/config and change the N to a Y.

; Allow the window manager to manage created windows
"Managed" = "N"

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 13 Feb 2003 21:31:27 +0100

>   Override Redirect State: yes
                             ^^^

This window ask to be not managed by the window manager and
so the situation you describe is normal.
You may try:

BugOpts RaiseOverUnmanaged

but this can leads to some pbs with some other override redirect
window (as tips window in the pager). Maybe, you have to ask
wine developers: why such a window is override redirect?

Regards, Olivier