Subject: FVWM: feature to add.

From: ali rahimi <[email-masked]>
Date: Wed, 12 Feb 2003 22:06:54 -0500

Hi.

I thought I'd tell you folks about this hack I've been using for a few
years. I use fvwm because it doesn't force me to make undue use of the mouse.
I've gone a few steps further and wrote this program which maps each quadrant
of the screen to the keys on the keypad. Pressing a keypad key warps the
pointer to the most representative window in that quadrant of the screen.

For example, pressing KP_7 warps the pointer to the most salient window of
the upper left of the screen. Pressing KP_3, warps the point to the window
in the lower right corner of the screen. The program is simple and is
documented at the top of the source:

   http://www.xcf.berkeley.edu/~ali/wpointer.cc

Hope you find it as useful as I have.
Enjoy!

 Ali.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Glanzmann <[email-masked]>
Date: Thu, 13 Feb 2003 08:20:00 +0100

> years. I use fvwm because it doesn't force me to make undue use of the mouse.

...
Key	Q	A	SC	SmartStart GQ "gq"
Key	X	A	SC	Exec exec xterm -T xterm       -ls
Key	S	A	SC	SmartStart MAINscreen "xterm -T MAINscreen  -ls -e ssh -t $SCREENSERVER /usr/src/tg/screen-3.9.13/screen -x main"
Key	D	A	SC	SmartStart DEVELscreen "xterm -T DEVELscreen -ls -e ssh -t $SCREENSERVER screen -x devel"
Key	L	A	SC	SmartStart LOCALscreen "xterm -T LOCALscreen -ls -e screen -R"
Key	N	A	SC	SmartStart "Netscape:*" $NETSCAPE
Key	O	A	SC	SmartStart "Opera*" $OPERA
Key	B	A	SC	SmartStart "bluescreen" "xterm -T bluescreen -bg \\#${OVERLAYCOLOR} -fg white -ls"
Key	M	A	SC	SmartStart "*Mozilla" $MOZILLA
Key	W	A	SC	SmartStart "faui47" $CITRIX
Key	G	A	SC	SmartStart "*GVIM" $GVIM
Key	C	A	SC	SmartStart CONSOLEscreen "xterm -T CONSOLEscreen -ls -e ssh -t $SCREENSERVER /local/console/bin/cscreen -x"
Key	A	A	SC	SmartStart "*.pdf"
Key	P	A	SC	SmartStart "MPlayer"
Key	U	A	SC	SmartStart "UMLinux"
Key	R	A	SCM	Restart $FVWM
Key	F4	A	M	Exec exec $XLOCK -mode blank -remote

DestroyFunc SmartStart 
AddToFunc SmartStart
	+ I Next ($0) Iconify off
	+ I Next ($0) Raise
	+ I Next (AcceptsFocus, $0) focus
	+ I None ($0) Exec exec $1
...

I use the following setup to not use the mouse. I identify the windows on there
names. When I press CTRL ALT S fvwm looks for a window with the name MAINscreen.
If there is on it will be raised and focused. If not the above command will be
executed.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].