Subject: FVWM: Sleep/Wait in an Fvwm Function.

From: Kingsly John <[email-masked]>
Date: Tue, 28 Jan 2003 00:38:47 +0530

Hi!

I have a function like this to set the wallpaper/background ...

AddToFunc SetWallpaper
+ I Exec xv -root -maxpect -quit $0
+ I Refresh

This doesn't work as I want it to as.. the Refresh command is being issued
before xv finishes painting the root window.

I want to set a sleep/wait period of a couple of seconds before Refresh is
called... how do I achieve it? 

Kingsly

PS: The refresh is needed so that certain tranparency/translucency effects
are updated wrt to the wallpaper.

-- 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Jan 2003 14:16:53 -0500

> called... how do I achieve it? 

+ I PipeRead 'xv -root -maxpect -quit $0'

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Kingsly John <[email-masked]>
Date: Tue, 28 Jan 2003 01:01:27 +0530

> + I PipeRead 'xv -root -maxpect -quit $0'

Works like a charm... never thought of using PipeRead that way! 

Thanks!

Kingsly