Subject: FVWM: Good apps for FvwmButtons to swallow?

From: Rob Park <[email-masked]>
Date: Sun, 5 Jan 2003 17:15:57 -0700

Hey all,

I was just wondering what apps people have swallowed in FvwmButtons.
Right now I've got xbiff, xclock, and xload, but frankly: they're crap.

I was looking at using some WindowMaker DockApps instead, but they're
all 64x64, while my buttons are 48x48, so they don't fit (and I'd rather
not enlarge them because it puts too much whitespace around my buttons).

Thanks ;)

-- 
Rob Park
http://www.ualberta.ca/~rbpark
--
Bachelor:
	A man who chases women and never Mrs. one.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Tue, 7 Jan 2003 17:58:28 +1100

On 17:15 05 Jan 2003, Rob Park <[email-masked]> wrote:
| I was just wondering what apps people have swallowed in FvwmButtons.
| Right now I've got xbiff, xclock, and xload, but frankly: they're crap.

Hey, I like xclock!

| I was looking at using some WindowMaker DockApps instead, but they're
| all 64x64, while my buttons are 48x48, so they don't fit (and I'd rather
| not enlarge them because it puts too much whitespace around my buttons).

I use wmflame and wmapm - they're 48x48...ish. They fit in my 48x48 slot.
I agree most dockapps are too big, and annoyingly most don't resize.
--
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

The only thing necessary for the triumph of evil is for good men to do nothing.
	- Edmund Burke (1729-1797)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Park <[email-masked]>
Date: Tue, 7 Jan 2003 07:05:46 -0700

> | Right now I've got xbiff, xclock, and xload, but frankly: they're crap.

Well, my beef with xclock is that, at least with the version that comes
with X 4.2.99.3, there is no way of changing the colors of anything but
the background when it's in analog mode. That means my clock has an ugly
red hour hand, ugly teal(ish) minute hand, and ugly blue second hand.

Also, in digital mode, as far as I can tell, there's no way to enter a
line break, so it's little use in FvwmButtons.

I did find a nice xbiff replacement, though. It's called asMail
(designed for afterstep, but works anywhere). I just had to modify it's
pixmaps a bit, then it became 48x48 ;)

> I agree most dockapps are too big, and annoyingly most don't resize.

Yeah. wmCalClock looked really nice, too bad it didn't scale. If I can't
find any decent apps, I might have to start programming them myself ;)

-- 
Rob Park
http://www.ualberta.ca/~rbpark
--
Necessity is the plea for every infringement of human freedom.
It is the argument of tyrants; it is the creed of slaves.
		-- William Pitt, 1783
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: martin sepulveda <[email-masked]>
Date: Tue, 7 Jan 2003 15:07:35 +0100

y use popxbiff as a biff replacement. pretty useful.

http://freshmeat.net/redir/popxbiff/8257/url_tgz/popxbiff.0.4.1.tar.gz

m.

...
> pixmaps a bit, then it became 48x48 ;)
....

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 7 Jan 2003 15:19:43 +0100

> red hour hand, ugly teal(ish) minute hand, and ugly blue second hand.

You mean there are no -hd, -hl and -fg options?  By the way,

  $ xclock -help

lists much more options than the man page on my system.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 7 Jan 2003 15:03:08 +0000

> lists much more options than the man page on my system.

Rob is right here, none of these options works with this xclock version,
only -bg works. It is still possible to specify all colors after playing
with editres. Try this:

  xclock -xrm '*majorColor: blue' -xrm '*minorColor: green' -xrm '*minuteColor: red' -xrm '*hourColor: cyan' -bg yellow

What really bothers me is that this new (anti-aliased and very nice BTW)
xclock can't be fooled to be transparent like it was when swallowed in
FvwmButtons, so that -bg is replaced with a gradient. I have no idea yet
why this does not work for me anymore.

Regards,
Mikhael.

---

From: Rob Park <[email-masked]>
Date: Tue, 7 Jan 2003 09:33:42 -0700

>   xclock -xrm '*majorColor: blue' -xrm '*minorColor: green' -xrm '*minuteColor: red' -xrm '*hourColor: cyan' -bg yellow

Ah, thanks. Now xclock is bearable!

There is also '*secondColor:', which gets used when you do -update 1 ;)

> why this does not work for me anymore.

Maybe it's authors found it too hard to anti alias onto transparency? I
have no idea, sorry ;)

-- 
Rob Park
http://www.ualberta.ca/~rbpark
--
Hoare's Law of Large Problems:
	Inside every large problem is a small problem struggling to get out.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 8 Jan 2003 10:18:56 +1100

On 07:05 07 Jan 2003, Rob Park <[email-masked]> wrote:
| Alas! Cameron Simpson spake thus:
| > On 17:15 05 Jan 2003, Rob Park <[email-masked]> wrote:
| > | I was just wondering what apps people have swallowed in FvwmButtons.
| > | Right now I've got xbiff, xclock, and xload, but frankly: they're crap.
| > 
| > Hey, I like xclock!
| 
| Well, my beef with xclock is that, at least with the version that comes
| with X 4.2.99.3, there is no way of changing the colors of anything but
| the background when it's in analog mode. That means my clock has an ugly
| red hour hand, ugly teal(ish) minute hand, and ugly blue second hand.

Colours work just fine for me. Here are my .Xresources for it:

	XClock*mode:                analog
	XClock*borderWidth:         0
	XClock*update:              60
	XClock*geometry:            64x64-0+3
	XClock*borderColor:         black
	XClock*background:          black
	XClock*foreground:          green
	XClock*hands:               black
	XClock*highlight:           cyan
	XClock*padding:             0

Cheers,

The Government that robs Peter to pay Paul, can always count on Paul for
support.	- George Bernard Shaw
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 8 Jan 2003 10:25:03 +1100

On 10:18 08 Jan 2003, IPM Return requested <[email-masked]> wrote:
| On 07:05 07 Jan 2003, Rob Park <[email-masked]> wrote:
| | Well, my beef with xclock is that, at least with the version that comes
| | with X 4.2.99.3, there is no way of changing the colors of anything but
| | the background when it's in analog mode. That means my clock has an ugly
| | red hour hand, ugly teal(ish) minute hand, and ugly blue second hand.
| 
| Colours work just fine for me. Here are my .Xresources for it:
[...]

Ignore me - clearly you have a different xclock release.
And a fix.

Cheers,

No, of course the people don't get to vote for who they want. This is a
democracy. They have to vote for Labour or Liberal.	- John Clarke
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Peter McAlpine <[email-masked]>
Date: Thu, 9 Jan 2003 00:47:52 -0500

> I agree most dockapps are too big, and annoyingly most don't resize.

I don't see how 16 pixels makes that much of a difference. I have
FvwmButtons along the right hand side of my screen, running 64x64
apps:
FvwmPager
wmcalc
wmCalClock
wmmixer
wmusic
bubblefishymon
wmbiff    (which is the coolest mail-watcher I've seen)
wmpinboard (also very cool)

I've still got some space to fill... any good ideas?

-pete =)

-- 
Peter McAlpine
[email-masked]

---

From: Glyn Millington <[email-masked]>
Date: Thu, 09 Jan 2003 08:10:14 +0000

> I've still got some space to fill... any good ideas?

Try 

http://www.bensinclair.com/dockapp/

Lots of good stuff there!  IN addition to those already mentioned, I have
a couple of weather monitors running giving regular updates on local
weather and my wife's home town in Hungary.

hth

Glyn

---

From: Rob Park <[email-masked]>
Date: Thu, 9 Jan 2003 10:19:40 -0700

Alas! Peter McAlpine spake thus:
> I don't see how 16 pixels makes that much of a difference.

16 extra pixels in both the x and y direction means 1792 extra pixels
for each icon: 1792 x 11 icons = 19712 pixels of absolutely wasted space
with _nothing_ in it.

I use FvwmButtons primarily for "quicklaunch" icons for my often-used
apps, and all the icons are 48x48. It just looks bad with an 8 pixel
wide border all the way around each icon.

Short people get rained on last.

---

From: roland Mathieu <[email-masked]>
Date: Fri, 10 Jan 2003 09:53:52 +0100

I've wrote a remplacement for xbiff highly customizable, you can found it
here:
http://roland.mathieu.free.fr/xmbiff

Even if you're not interested, at the end of the webpage you'll find a list
of links on differents "biff" programs. 

Roland.