Subject: FVWM: -geometry xxx calls

From: dick hoogendijk <[email-masked]>
Date: Sun, 19 Jan 2003 20:46:33 +0100

How can I make mozilla (i.e.) make always appear on the same place on
the screen. When I start mozilla I can get a nice readout of the x-specs
of the window (865x692+2+2) so I thought: "this is how I call mozilla
next time, but that won't work.
I cannot put a line like:
Exec exec mozilla -geometry 865x692+2+2 into my .fvwm2rc
Mozilla can't load this page ;-))

How is this done? I'm sure you can put every window exactly on the spot
you want it to appear, having the dimensions I choose.

-- 
dick -- http://www.nagual.st/ -- PGP/GnuPG key: F86289CE
++ Running FreeBSD 4.7 ++ Debian GNU/Linux (Woody)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: dick hoogendijk <[email-masked]>
Date: Mon, 20 Jan 2003 15:00:34 +0100

On 19 Jan Elliot Sowadsky wrote:
> 
> I use FvwmEvent to move mozilla to 0,0.

I checked the manual for this FvwmEvent, but am puzzled on how to use it
exactly. Can you give me an example on how you incorporated this to
place mozilla on 0,0 ?
I use fvwm for one week now and am still dazzled by all possabilities of
this fab windows manager.

---

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 20 Jan 2003 10:50:35 -0800 (PST)

<<

Heres my code

AddToFunc StartFunction
+	I Module FvwmEvent

*FvwmEventPassID
*FvwmEvent add_window add_event

AddToFunc add_event
+	I WindowID $0 ("*Mozilla*") PipeRead `[ $[w.height] -eq 835  -o $[w.height] -eq 836 ] && echo Move 0 0`