Subject: Re: FVWM: QuitFunction

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 2 Jan 2003 13:15:30 -0800 (PST)

< > Speaking of fvwm startup functions, i notice that after doing enough restarts
< > , i'll get a pipe2 read error and my modules wont start.
< >
< > Do pipes automagically get closed on restart?
< > Do i have to manually kill the modules on a restart?
< >
< > running 2.5.5....but above always true.
< >
< > Heres my StartFunction, restarted by a "Restart".
< >
< > AddToFunc StartFunction
< > +     I Exec xsetroot -solid #b15a27
< > +     I Module FvwmPager 0 0
< > +     I Module FvwmEvent
< > +     I Module FvwmTaskBar
< > +     I Module FvwmWindowLister
< 
< I think you might be running into some kind of OS thing.
< What OS is this?
< 
< On my Linux machine I tried:
< 
< home> echo *|wc
<       1      30     236
< home> for i in * ; do (FvwmCommand restart;sleep 10) done
< 
< That restarted Fvwm 30 times.
< I had no problem.
< 
< I have FvwmCommand, FvwmAnimate and FvwmBanner in my
< StartFunction.

I'm running on Sun Solaris 2.5.1..

Other fvwm Quit behavior i notice is that if my cmdtool starts a background
script that loops forever (w/ an embedded "sleep"), if i quit fvwm w/o killing either the script or the "sleep", fvwm wont terminate.
I now get around it by doing the kills as part of my Quit function.

fvwm is started as the last line in a .xinitrc ("exec fvwm2").

Anything obvious about why?

Thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 02 Jan 2003 16:34:06 -0500

> < On my Linux machine I tried:

Next Monday is the soonest I could try this on a Sun,
but 2.5.1 is out of the question.  All our 2.5.1 systems
are long gone.
Maybe you should try something like I did.
See if you can nail down the number of restarts and find
out if its consistently reproducible.

> script that loops forever (w/ an embedded "sleep"), if i quit fvwm w/o killin
> g either the script or the "sleep", fvwm wont terminate.

A stack trace while Fvwm is hanging would be a good place to start.
If you need instructions, just ask.

-- 
Dan Espen                           E-mail: [email-masked]