Subject: Re: FVWM: question: I want change to color of the menu

From: "terry_z" <[email-masked]>
Date: Fri, 17 Jan 2003 08:54:07 -0000

hello.

I have add the config in /etc/X11/fvwm2/system.fvwm2rc 
It make the different color in main menu.  thank you very much.

But if I open the program in fvwm2. example  kmail or kword.
The menu of the program (kmail or kword) has nothing change.
Then how can I change the config of /etc/X11/fvwm2/system.fvwm2rc, change the color of the button when the mouse active of it in (kmail or kword)?
I know it can in KDE or GNOME. but can't in fvwm.

thank you very much.

best regards.

terry

>----- Original Message -----
> From: Dan Espen <[email-masked]>
> To: terry_z <[email-masked]>
> Sent: Thu, 16 Jan 2003 23:33:41 -0500
> Subject: Re: FVWM: question: I want change to color of the menu 
> 
> "terry_z" <[email-masked]> writes:
> > hello.
> > I use the rpm of fvwm2-2.2.5-4.i386.rpm.
> > now I have a question.
> > there is some function in the default menu.
> > expample: there is the main menu. in the menu, there is some button. like tha
> > t:
> > 
> > Xterm
> > Rxvt
> > Program
> > Utillties
> > Fvwm Modules
> > Fvwm Window ops
> > Fvwm Simple Config Ops
> > Refresh Screen
> > Recapture Screen
> > Exit Fvwm
> > 
> > 
> > now I want to change the color of the menu when the mouse active the fuction.
> 
> Try:
> 
> MenuStyle * HilightBack green
> 
> -- 
> Dan Espen                           E-mail: [email-masked]
> 
> 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Fri, 17 Jan 2003 15:27:07 -0700

> I know it can in KDE or GNOME. but can't in fvwm.

If your app was written with the qt toolkit, you need to change its
widgets with "kcontrol". If it was made with gtk+ you need to use a gtk
theme switcher. Window managers don't have any control over your 
toolkits theme.

hopefully this makes sense.
sa

---

From: "S. Anderson" <[email-masked]>
Date: Fri, 17 Jan 2003 15:56:15 -0700

> theme switcher. Window managers don't have any control over your 

oh and If you would like your fvwm menus to look like your gtk theme
you could check out the FvwmGtk module (man FvwmGtk)

hth,
sa