Subject: Re: FVWM: Icon with window title

From: hugo vanwoerkom <[email-masked]>
Date: Wed, 1 Jan 2003 16:57:51 -0800 (PST)

--- Mikhael Goikhman <[email-masked]> wrote:
> If I understand you correctly you want to show a
> mini icon in a titlebar:
> 
>   ButtonStyle 1 MiniIcon
> 
I am still doing something wrong. I do this and
nothing shows up in the button.

> By default, if the program itself supplies a mini
> icon (using EWMH) it is
> shown in the MiniIcon button in 2.5.x. But pre-EWMH
> applications do not
> set a mini icon hint. 

This is a Qt application I wrote. It runs on Qt
versions 1, 2 or the latest, 3. It also runs on M$
windows on Qt 2.3.0, where the icon shows up. Actually
I got here through windows. It showed an annoying text
icon: [Freeware]. That annoyed me so I did a
QWidget::setIcon(QPixmap). I got to believe the latest
version of Qt is EWMH compliant, the latest nightly of
Mozilla certainly should be.

You should define it yourself,
> like:
> 
>   Style * MiniIcon mini/unknown.xpm
>   Style XTerm MiniIcon mini/terminal.xpm

Yes, this I can do, but I want the program supplied
icon to show up. I have enclosed my .fvwm2rc as an
attachment.
I appreciate your help. Thanks.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 2 Jan 2003 03:53:53 +0000

> Mozilla certainly should be.

Your config has dozens of small problems, but this is not related.

Create this minimal config (either replace your .fvwm2rc or create
~/.fvwm/minimal-rc and do "Restart fvwm -f minimal-rc"):

  ButtonStyle 1 MiniIcon
  Mouse 0 1 A WindowShade
  Style * DecorateTransient   # KDE apps are buggy, kcalc is transient...
  Exec kcalc

Do you see the calculator icon that kcalc provides? I do see it.
If yes, run your application, if you don't see an icon, there is a problem
in your application.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: hugo vanwoerkom <[email-masked]>
Date: Fri, 3 Jan 2003 13:50:35 -0800 (PST)

> If yes, run your application, if you don't see an

Absolutely the fact. I see the calculator icon.
Neither do I have a clue how he does it, looking at an
older version of the source, but we are using the same
Qt.
Anyway, thanks a lot for your help!
Hugo.