Subject: FVWM: Can't resize Mozilla using fvwm 2.5.5 within Tightvnc

From: Harald Dunkel <[email-masked]>
Date: Wed, 01 Jan 2003 23:34:49 +0100

Hi folks,

As the subject says: If I try to resize Mozilla, then the
Window manager gets stuck. Configuration:

	Debian (Sid)
	Mozilla 1.3a
	fvwm 2.5.5
	Tightvnc 1.2.6

If I change back to fvwm 2.5.3, then the problem is gone.

The problem does not appear if I use XFree86 instead of
Tightvnc.

Has anybody an idea how to get rid of this?

Regards

Harri

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: wang yin <[email-masked]>
Date: Thu, 2 Jan 2003 08:05:44 +0800

> Has anybody an idea how to get rid of this?
I had similiar problem with Acrobat Reader which can't be moved :)
I solved the problem with
Style AcroRead  VariablePosition

So you'd better try:

Style Mozilla VariableSize,  VariablePSize, VariableUSSize

If you get rid of this problem like this, please tell me.
Thanks.

-- 
Wang Yin
DA Lab, Tsinghua University,
100084
Beijing China

---

From: Harald Dunkel <[email-masked]>
Date: Fri, 03 Jan 2003 12:20:00 +0100

BTW, if I configure fvwm 2.5.5. using

./configure --with-gnome=no --disable-ewmh --disable-gnome-hints

then the problem is gone. Using just '--with-gnome=no'
was not sufficient to make the problem go away, so I would
expect that there is something wrong with the WMH communication
between fvwm2 and Mozilla.

Regards

Harri

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 3 Jan 2003 12:24:15 +0000

> was not sufficient to make the problem go away, so I would

--with-gnome affects FvwmGtk only, like configure itself says.

> between fvwm2 and Mozilla.

This may also mean a bug in Tightvnc if it works with XFree86.

You may try this command then (no idea which option will help):

  Style Mozilla GNOMEIgnoreHints, \
    EWMHIgnoreStateHints, EWMHIgnoreStackingOrderHints

Note, that this will be the only solution with 2.5.6, since there are
no these --disable flags anymore.

Regards,
Mikhael.

---

From: Harald Dunkel <[email-masked]>
Date: Fri, 03 Jan 2003 18:58:33 +0100

Hi Makhael,

> This may also mean a bug in Tightvnc if it works with XFree86.
Sure.Or it might be a problem of Mozilla. (Netscape works.)
I am no Gnome (or KDE) user, so I cannot tell whether
other applications are affected by this problem.

> no these --disable flags anymore.

This did not help. The problem is still there, even if I add
this line to my .fvwm2rc .

Regards

Harri