Subject: FVWM: cursor keys for scrolling the pager

From: [email-masked]
Date: Fri, 24 Jan 2003 21:57:13 -0700 (MST)

I have the following entries in my fvwmrc file
# pager control
Key Left        A       3      Scroll -100 0
Key Right       A       3      Scroll +100 +0
Key Up          A       3      Scroll +0   -100
Key Down        A       3      Scroll +0   +100

where "3" is the windows key.

This lets me change scres in the pager without using the mouse.
The problem is that it does not work anymore  after upgrading to
2.4.14-1.
It seems that the cursor keys are totally ignored.

Robert

PS: I am not a subscriber to the mailing list, so please send me
email back

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 25 Jan 2003 01:19:56 -0500

> PS: I am not a subscriber to the mailing list, so please send me

Most likely, you've got numlock on.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked]
Date: Fri, 24 Jan 2003 22:44:52 -0700 (MST)

Nope, I just checked that.

Robert

---

From: Dan Espen <[email-masked]>
Date: Sat, 25 Jan 2003 09:39:01 -0500

> Nope, I just checked that.

OK, check that you still have Mod3 on the windows key.

Do:

xmodmap -pm

I get:

home> xmodmap -pm
shift       Shift_L (0x32),  Shift_R (0x3e)
lock      
control     Control_L (0x25),  Control_R (0x6d),  Control_L (0x42)
mod1        Meta_L (0x40)
mod2        Num_Lock (0x4d)
mod3      
mod4        Alt_L (0x73)
mod5      

In my case, the windows key is Alt_L and its mod4.

The bindings above work for me, providing I change the 3 to a 4.

You can use "xev" or xkeycaps to verify that the windows key is
Alt_L.

---

From: [email-masked]
Date: Sat, 25 Jan 2003 09:12:47 -0700 (MST)

Dan:

I believe I had tried tried the A and N modifier without success
before. Now I switched to the C modifier and things started to work.
I am still curious what is wrong with my setup:

my xmodmap magic looks like this:
#make capslock into control
xmodmap -e "remove Lock = Caps_Lock" >> $LOGFILE 2>&1
xmodmap -e "keycode 66 = Control_L"  >> $LOGFILE 2>&1
xmodmap -e "add Control = Control_L" >> $LOGFILE 2>&1

#use extra menu key as compose key
xmodmap -e "keycode 117 = Multi_key" >>$LOGFILE 2>&1

# use windows keys as modifiers
xmodmap -e "keycode 115 = Super_L"  >>$LOGFILE 2>&1
xmodmap -e "keycode 116 = Super_R"  >>$LOGFILE 2>&1
xmodmap -e "add Mod3 = Super_L Super_R" >>$LOGFILE 2>&1

# use windows keys as modifiers
xmodmap -e "keycode 234 = Prior"  >>$LOGFILE 2>&1
xmodmap -e "keycode 233 = Next"  >>$LOGFILE 2>&1

>xmodmap -pm
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock
control     Control_L (0x25),  Control_R (0x6d),  Control_L (0x42)
mod1        Alt_L (0x40),  Alt_R (0x71)
mod2        Num_Lock (0x4d)
mod3        Super_L (0x73),  Super_R (0x74)
mod4        Super_L (0x73),  Super_R (0x74)
mod5

Robert

---

From: Dan Espen <[email-masked]>
Date: Sat, 25 Jan 2003 13:10:36 -0500

> I am still curious what is wrong with my setup:

Gee, I don't know.  It sorta looks OK.

There are 2 tools you need to connect the dots. xev and xmodmap.

Use xev to find the scan code and keysym of the key.
You start xev, it creates a window and you type in it.

For me it prints:

KeyPress event, serial 25, synthetic NO, window 0x5800001,
    root 0x26, subw 0x0, time 4132111778, (135,81), root:(1487,364),
    state 0x0, keycode 115 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 30, synthetic NO, window 0x5800001,
    root 0x26, subw 0x0, time 4132111899, (135,81), root:(1487,364),
    state 0x40, keycode 115 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 characters:  ""

This says the keycode is 115 and the keysym in Alt_L.

Then use xmodmap to find the modifier and verify the keycode.
Like this:

home> xmodmap -pm |grep Alt_L
mod4        Alt_L (0x73)
home> xmodmap -pk |grep Alt_L
    115         0xffe9 (Alt_L)  

Since you've moved things around, you need to look at Super_L.

---

From: Glen Lee Edwards <[email-masked]>
Date: Mon, 27 Jan 2003 21:01:19 -0600

Robert,

It's been awhile since I set this up, but I was unable to get the 
behavior I wanted when trying to set more than one modifier for each of 
the windows keys (L & R).  Here is what I'm using:

xmodmap -e "pointer = 3 2 1 4 5"
xmodmap -e 'keycode 115 = Super_L'
xmodmap -e 'keycode 116 = Hyper_L'
xmodmap -e 'keycode 117 = Menu'
xmodmap -e 'keycode 66 = Shift_Lock'
xmodmap -e 'add Mod3 = Super_L'
xmodmap -e 'add Mod4 = Hyper_L'
xmodmap -e 'remove Lock = Caps_Lock'
xmodmap -e 'add Lock = Shift_Lock'

$ xmodmap -pm
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Shift_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_R (0x71)
mod2        Num_Lock (0x4d)
mod3        Super_L (0x73)
mod4        Hyper_L (0x74)
mod5        Scroll_Lock (0x4e)

Set up this way I have separate bindings for Win_L and Win_R:

Key F1    A     3       gotoDesk 0 0
Key F2    A     3       gotoDesk 0 1
Key F3    A     3       gotoDesk 0 2
Key F4    A     3       gotoDesk 0 3
<edit>
Key F1    A     4       MoveToDesk 0 0
Key F2    A     4       MoveToDesk 0 1
Key F3    A     4       MoveToDesk 0 2
Key F4    A     4       MoveToDesk 0 3

I'm currently using Fvwm 2.5.5, but have been using this configuration 
for the last couple of years.

Glen

On Saturday 25 January 2003 10:12 am, [email-masked] wrote:
> > > > > This lets me change scres in the pager without using the
> > > > > mouse. The problem is that it does not work anymore  after
> > > > > upgrading to 2.4.14-1.
> > > > > PS: I am not a subscriber to the mailing list, so please send
> > > > > me email back
> > > >
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of
> a message to [email-masked].