Subject: FVWM: Busy pointer indicator?

From: <[email-masked]>
Date: Thu, 23 Jan 2003 15:11:21 -0800

Dear Sir, Madam, 

I am currently running fvwm 2.4.14with which I am very pleased but could you please tell me if it is possible to make the cursor/pointer change (i.e. to an hourglass/watch)whenever fvwm is starting an application that takes a while.    

Your help is much appreciated.

Dermot Whelan

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 16 Jan 2003 23:56:51 +0000

On 23 Jan 2003 15:11:21 -0800, [email-masked] wrote:
> 
> I am currently running fvwm 2.4.14with which I am very pleased but could
> you please tell me if it is possible to make the cursor/pointer change
> (i.e. to an hourglass/watch)whenever fvwm is starting an application
> that takes a while.

Do the following:

  BusyCursor Wait true

  AddToFunc StartApp
  + I Exec $0
  + I Wait $1

  # use these commands to start your heavy apps
  StartApp "xterm -title SystemLog -e tail -f /var/log/messages" SystemLog
  StartApp "sleep 3; xcalc" XCalc

Of course, this only changes the busy cursor to clock (configurable using
CursorStyle WAIT) on the root window, not inside existing windows.
Press Ctrl-Alt-Esc if your app is not started for some reason to escape
from Wait.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].