Subject: Re: FVWM: QuitFunction

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 2 Jan 2003 09:23:42 +0000

On 02 Oct 2002 10:25:05 +0200, Remko Troncon wrote:
> 
> On 13 Aug 2002, Mikhael Goikhman wrote:
> > Now when I think about this, I see an elegant solution for these problems.
> > We only need 2 functions (not including Session*Function variants),
> > StartFunction and ExitFunction.
> > 
> > StartFunction may include conditions "StartUp" and "Restart", ExitFunction
> > may include conditions "Restart" and "Quit", these conditions are always
> > false anywhere else. This way InitFunction and RestartFunction are not
> > needed (not that RestartFunction is needed now anyway).
> > 
> >   AddToFunc StartFunction
> >   + I FvwmPager
> > 
> >   AddToFunc ExitFunction
> >   + I On (Quit) Exec killall xplanet-runner
> >   + I On (Restart) Exec play /some/ding.au
> >   + I Echo "Either Restart or Quit"
> 
> I know this was a post of a while ago, but has this been implemented
> yet? Will it ever be ?

Should be available in the today's snapshot. Contact the man page.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 2 Jan 2003 13:44:23 -0800 (PST)

< Next Monday is the soonest I could try this on a Sun,

I might even be 5.8 by then.
But no rush....was wondering if someone had a ready made answer.

< Maybe you should try something like I did.
See if you can nail down the number of restarts and find
out if its consistently reproducible.

I'll try that.

Tnanx