Subject: FVWM: Window cycling

From: Piotr Zgorecki <[email-masked]>
Date: Wed, 8 Jan 2003 19:45:49 +0100

Hi,

Is it possible to make fvwm raise windows temporarily
while cycling with the famous Alt-Tab?
A simple
	Next [CurrentPage !iconic] Focus
won't do.
What will, then?

Thanks,
Piotr Zgorecki
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 10 Jan 2003 08:48:54 +0000

> 	Next [CurrentPage !iconic] Focus

You may raise a window together with focusing, just create FocusAndRaise
function and use it instead (here is a more correct syntax for Next):

  Next (CurrentPage, !Iconic) FocusAndRaise

  AddToFunc FocusAndRaise
  + I Raise
  #+ I WarpToWindow
  + I Focus

It is impossible hovewer to raise a window only temporarily and then to
restore it in the window stack on the next key press that is what you
seem to want.

A new module FvwmProxy in 2.5.5 attempts to solve this, but be aware it
may be changed before 2.6.0.

Regards,
Mikhael.