Subject: FVWM: key-triggered focus of app within FvwmButtons

From: Maciej Kalisiak <[email-masked]>
Date: Wed, 15 Jan 2003 22:22:31 -0500

I have an rxvt swallowed inside FvwmButtons, and have this binding:

  Key 8	    A 4 Next (tiny_term) Focus

This works when the rxvt is outside FvwmButtons, but does not focus it when
swallowed.  What is wrong, and how do I go around it?

-- 
Maciej Kalisiak       mac "at" dgp.toronto.edu       www.dgp.toronto.edu/~mac
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Jan 2003 08:19:11 +0100

> swallowed.  What is wrong, and how do I go around it?

The "Next" command works only on top level windows, not the ones
swallowed by some other application.  You can give FvwmButtons
the focus, and then warp the pointer over the rxvt window:

WIth ClickToFocus:

  Key 8 A 4 Next (FvwmButtons) Function foo

  AddToFunc foo
  + I Focus
  + I WarpToWindow <position_of_rxvt>

Or with MouseFocus/SloppyFocus:

  Key 8 A 4 Next (FvwmButtons) WarpToWindow <position_of_rxvt>

See the man page about WarpToWindow for details and make sure you
do not use the NeverFocus style for FvwmButtons.

Bye

Dominik ^_^  ^_^

---

From: Maciej Kalisiak <[email-masked]>
Date: Thu, 16 Jan 2003 09:14:22 -0500

On Thu, Jan 16, 2003 at 08:19:11AM +0100, Dominik Vogt wrote:
> swallowed by some other application.

Ahhh.

> You can give FvwmButtons the focus, and then warp the pointer over the rxvt
> window:
> 
> WIth ClickToFocus:
> 

Now, this assumes that the embedded rxvt has SloppyFocus, no?  Otherwise, just
because the mouse cursor is over it, how does this cause the rxvt to receive
focus in a ClickToFocus setup?

BTW, that's an elegant way to force, or at least strongly suggest that any
replies go to the list. (In his email to me, Dominik set the From: field to
"Dominik Vogt <[email-masked]>")  Short and sweet.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 16 Jan 2003 15:39:16 +0100

> focus in a ClickToFocus setup?

For the same reason as above, a swallowed application does not
have a focus policy either.  I honestly don't know why it works,
but the xterm in my FvwmButtons accepts keyboard input with the
pointer over it, but not when it's somewhere else in FvwmButtons.
Maybe FvwmButtons forwards all keystrokes to the app with the
pointer over it - I don't know.  I have to look it up in the
sources.

> "Dominik Vogt <[email-masked]>")  Short and sweet.

I do this in all fvwm related mails I write at work.  I can't use
any replies to my work address.

Bye

Dominik ^_^  ^_^