Subject: Re: FVWM: QuitFunction

From: Elliot Sowadsky <[email-masked]>
Date: Thu, 2 Jan 2003 09:49:40 -0800 (PST)

Speaking of fvwm startup functions, i notice that after doing enough restarts, i'll get a pipe2 read error and my modules wont start.

Do pipes automagically get closed on restart?
Do i have to manually kill the modules on a restart?

running 2.5.5....but above always true.

Heres my StartFunction, restarted by a "Restart".

AddToFunc StartFunction
+	I Exec xsetroot -solid #b15a27
+	I Module FvwmPager 0 0
+	I Module FvwmEvent
+	I Module FvwmTaskBar
+	I Module FvwmWindowLister
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 02 Jan 2003 13:25:39 -0500

Elliot Sowadsky <[email-masked]> writes:
> 
> Speaking of fvwm startup functions, i notice that after doing enough restarts
> , i'll get a pipe2 read error and my modules wont start.
> 

I think you might be running into some kind of OS thing.
What OS is this?

On my Linux machine I tried:

home> echo *|wc
      1      30     236
home> for i in * ; do (FvwmCommand restart;sleep 10) done

That restarted Fvwm 30 times.
I had no problem.

I have FvwmCommand, FvwmAnimate and FvwmBanner in my
StartFunction.

-- 
Dan Espen                           E-mail: [email-masked]