Subject: FVWM: "Next (..) Layer a b" doesn't work (anymore)

From: Bob Vloon <[email-masked]>
Date: Thu, 16 Jan 2003 10:32:46 +0100

Hi,

When using this:

# ------------------------------------------
AddToFunc "InitFunction"
+ I Module FvwmEvent ExecOnEvent

*ExecOnEventCmd Function
*ExecOnEventPassID

AddToFunc RaiseWindow
+ I Current (GlobalIM) Echo "wow"
+ I Current (GlobalIM) Layer 0 6
+ I Current (AccsIM)   Layer 0 6

*ExecOnEvent enter_window   "RaiseWindow"
# ------------------------------------------

.. the window "GlobalIM" isn't put into layer 6, but "wow" is echoed. "How
is this possible?":)

I'm using the snapshot of january 14.

-- 
Bob Vloon
Software engineer
Edmond Research & Development BV
The Document Solutions Specialist
http://www.edmond.nl
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 16 Jan 2003 23:16:23 +0000

> When using this:

I am sure you will want this on restart too, so just use StartFunction
for modules, not InitFunction.

> *ExecOnEvent enter_window   "RaiseWindow"

Easily possible, the Layer command is still broken in cvs.

> I'm using the snapshot of january 14.

Regards,
Mikhael.