Subject: RE: FVWM: Sleep/Wait in an Fvwm Function.

From: "Dameron, Gregg" <[email-masked]>
Date: Mon, 27 Jan 2003 15:26:52 -0700

> > AddToFunc SetWallpaper
> > + I Exec xv -root -maxpect -quit $0
> > + I Refresh
> > 
> > This doesn't work as I want it to as.. the Refresh command is being
issued
> > before xv finishes painting the root window.
> > 
> > I want to set a sleep/wait period of a couple of seconds before Refresh
is
> > called... how do I achieve it? 
> 
> + I PipeRead 'xv -root -maxpect -quit $0'

I'm curious - does the "Refresh" line in SetWallpaper remain as it is?  Does
fvwm guarantee that PipeReads are processed to completion before moving on
to the next "+ I" statement in a complex function?

(From earlier posts, I would have guessed that

+ I PipeRead 'xv -root -maxpect -quit $0; sleep 2; echo Refresh'

would have been required to guarantee the desired processing sequence.)

Gregg Dameron
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 27 Jan 2003 17:40:12 -0500

> would have been required to guarantee the desired processing sequence.)

Either way would work but the sleep isn't needed.
PipeRead is synchronous.  Fvwm won't go on
to the next command until PipeRead completes.

-- 
Dan Espen                           E-mail: [email-masked]