Subject: FVWM: RE: Notification: incoming/977

From: "EXT-Wilson, William A" <[email-masked]>
Date: Thu, 9 Jan 2003 06:59:35 -0800

Dan,

Attached is a tarball with a sample program.  I have included stripped down
versions of the two files which are required and a tc.m which will make it.
The g_plot file normally resides in 
~/app-defaults/g_plot.  The part of the code which I suspect is not working
correctly with fvwm is:

  /*
   * Turn on backing Store & Save Under
   */
  if (strcmp(expose,"SERVER") == 0) {
    attrib.backing_store = Always;
    attrib.save_under   = True;
  }
  else {
    attrib.backing_store = NotUseful;
    attrib.save_under   = False;
  }
  XChangeWindowAttributes(screen[snum].G_plot_disp,screen[snum].G_plot_win, 
   CWBackingStore | CWSaveUnder,&attrib);

which is in x11_gplot.c.  This code (which I don't understand was coded a
long time ago for a Sun based sonar system which used a Techsource display
VME card.  Things have changed over the years and we keep tinkering with the
plot package to make it work.  Using fvwm delivered with Red Hat 7.2 (maybe
7.3) everything was OK.  You could minimize a g_plot window and bring it
back and you could cover it up with another window and it would restore.
Now, when you bring it back, the covered area is black.  The only part that
comes back is the border and the window title "Gplot Graphics ...".

Any and all suggestions would be appreciated.

Bill Wilson
714-762-4348

-----Original Message-----
From: Dan Espen [mailto:[email-masked]]
Sent: Wednesday, January 08, 2003 1:24 PM
To: EXT-Wilson, William A
Cc: [email-masked]'
Subject: Re: Notification: incoming/977 

"EXT-Wilson, William A" <[email-masked]> writes:
> Dan,
> 
> Thanks for the quick response.  I think I must have made an error in
reading
> the version number; but I updated to 2.4.14 as you suggested.  I still
have
> the same problem.  I think (wild guess by not a strong X programmer) that
> there is a configuration file somewhere controlling fvwm and it got
updated
> when I upgraded to Red Hat 8.0.  The key to this is, "does fvwm repaint
> uncovered portions of a display?".

No.
The application will get expose events and then the application
has to repaint itself.

Can you give us more information about the application or
perhaps a small piece of code.

For 2.4.14, the configuration file for fvwm would be
$HOME/.fvwm/.fvwm2rc.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 10 Jan 2003 06:59:07 +0100

> Any and all suggestions would be appreciated.

Is there any chnace that gplot thinks that backing store is used
when it sets "attrib.backing_store = Always;"?  Can you check if
gplot checks whether backing store is supported by the X server?
I have heard something about newer XFree releases no longer
supporting backing store, but that may not be true.

Bye

Dominik ^_^  ^_^

---

From: Ben Winslow <[email-masked]>
Date: Fri, 10 Jan 2003 01:41:39 -0500

> On Thu, Jan 09, 2003 at 06:59:35AM -0800, EXT-Wilson, William A wrote:
[snip]
> supporting backing store, but that may not be true.

FWIW, I've been using backing store with a fairly recent version of XFree:
XFree86 Version 4.2.1.1 (Debian 4.2.1-4 20021123003806
[email-masked]) / X Window System

It is disabled by default, however, and you'll need to pass +bs on the
server command line for it to work.

-- 
Ben

---

From: Cameron Simpson <[email-masked]>
Date: Fri, 10 Jan 2003 20:32:22 +1100

On 06:59 10 Jan 2003, Dominik Vogt <[email-masked]> wrote:
| On Thu, Jan 09, 2003 at 06:59:35AM -0800, EXT-Wilson, William A wrote:
| Is there any chnace that gplot thinks that backing store is used
| when it sets "attrib.backing_store = Always;"?  Can you check if
| gplot checks whether backing store is supported by the X server?
| I have heard something about newer XFree releases no longer
| supporting backing store, but that may not be true.

As I recall an X server is under no obligation to provide backing store
even if it's "enabled". I'd have thought receiving exposures was a cue
that you didn't get backing store, and have to draw anyway...
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

Volvos ... make a huge statement. That statement is: 'Get out of my
way because I may be asleep'.	- Jeremy Clarkson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 10 Jan 2003 09:10:02 -0500

> supporting backing store, but that may not be true.

I have the above code.  I'll forward it if requested.

The string "expose" is always "SERVER", so it always turns on
backing store.

In addition, it always calls:

XSetGraphicsExposures(screen[snum].G_plot_disp,
  screen[snum].plot_gc,False);

So it tells the X Server it doesn't want expose events.

And, it has no logic to receive expose events.

I tested the code and the screen comes up white, with no detail.
When I cover and uncover it, it remains white.  Perhaps I don't
see any problem because I'm running XFree86 3.3.6.

It does seem to be relying on the X Server to restore the
window content.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 10 Jan 2003 15:49:31 +0100

> It does seem to be relying on the X Server to restore the

Just as I suspected.  Some apps implicitly require that backing
store works, and the main problem is the changed default in XFree.

Bye

Dominik ^_^  ^_^