Subject: FVWM: How to specify multiple disjoint desktops?

From: Jose Romildo Malaquias <[email-masked]>
Date: Sat, 07 Dec 2002 11:39:51 -0200

Hello.

I have found how to specify the number of virtual desktops
in FVWM, using the DeskTopSize command. But I did not
find how to specify the number of multiple disjoint desktops.

Any help?

Romildo
-- 
Prof. José Romildo Malaquias        [email-masked]
Departamento de Computação       [email-masked]
Univ. Federal de Ouro Preto  http://uber.com.br/romildo

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 7 Dec 2002 14:13:30 +0000

> find how to specify the number of multiple disjoint desktops.

There are infinitive number of such desktops including negative numbers
that GotoDesk and MoveToDesk may work with. In practice, EWMH uses only
non-negative numbers, so you may want to follow this too.

To start FvwmPager with 4 desktops (all having DeskTopSize pages) do:

  DeskTopSize 3x2
  FvwmPager 0 3

This means FvwmPager shows desktops 0, 1, 2, 3. Totally 4x3x2 = 24 pages.

Also with 4 visible desktops try these bindings (Ctrl-Alt-8/9):

  Key 8 A CM GotoDesk -1 0 3
  Key 9 A CM GotoDesk +1 0 3

Regards,
Mikhael.