Subject: FVWM: 2.5.x vs. 2.4.x

From: Jeremy Whetzel <[email-masked]>
Date: Mon, 9 Dec 2002 21:25:16 -0500

Hi,

I'm fairly new to FVWM, (only been using it about a week now) and I was
wondering how this group feels about the stability and usability of the 2.5.x
version in comparison to the 2.4.x version.  Are there a lot of incomplete
features?  Does it seem much less stable than 2.4.x?  Are the new features
documented anywhere?

So far, I love FVWM.  It's been a lot to learn, but it's definitely been worth
it.  =0)

Jeremy
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 02:52:43 +0000

> features?  Does it seem much less stable than 2.4.x?  Are the new features

The first 2 links on the home page (after the download) describe all new
features.

I don't want to discuss the 2.5.x stability. It may be rock stable for
your specific configuration that you don't change while running and may
work buggy or even dump core with other configurations.

> So far, I love FVWM.  It's been a lot to learn, but it's definitely been
> worth it.  =0)

Fine, new users are welcome.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Mon, 9 Dec 2002 18:58:12 -0800

* <[email-masked]> [09-Dec-02 18:27 -0800]:
  >
  >I'm fairly new to FVWM, (only been using it about a week
  >now) and I was wondering how this group feels about the
  >stability and usability of the 2.5.x version in
  >comparison to the 2.4.x version.  Are there a lot of
  >incomplete features?  Does it seem much less stable than
  >2.4.x?  Are the new features documented anywhere?
  >
  >So far, I love FVWM.  It's been a lot to learn, but it's
  >definitely been worth it.  =0)
  [...]

I think I am about your fvwm-skill-level, even though I've
been using fvwm for a while, so I'll offer my opinions :)

I've heard some people refer to instabilities in 2.5.x
series once in a while. However, my config is pretty
basic, and I haven't seen problems so far - mostly due to me
misunderstanding the way things should be configured. I dont
know what the *official policy* on encouraging people to try
2.5.x is.

If you look in cvs, "NEWS" file is the one that describes
the improvements. 

You can also find that file online:
               
               http://www.fvwm.org/generated/NEWS.html

(I am not sure if it's lagging couple of days behind the cvs
version, but I haven't noticed). I think between this file,
someone's sample config, and man pages, you are usually able
to figure out how things work :-)

As far as improvements: I *think* the following are not in
the 2.4.x, but I could be wrong. Love colorsets, transparent
pager, and antialiased fonts. At least I think antialiasing
makes a difference - maybe its just the fact that it should
be there + my mind playing games with me ;-) I think alt-tab
behavior has been tweaked to allow for "the other os"-like
behavior (CurrentAtEnd). 

There is much more to what's been updated/added/improved,
but these are just some things I use.

I dont lurk on fvwm-workers much (lack of time), but that's
where people talk about cvs versions and features, problems,
etc. Perhaps if you want to get a feel for what's going on,
you should listen in? 

Anyway, that's how I feel about 2.5.x. Good luck.

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Crochelt <[email-masked]>
Date: Mon, 9 Dec 2002 19:25:31 -0900 (AKST)

Most stable of the window managers I've tried, with no change in 2.5.

-- 
Bob Crochelt, MD, PhD, FACS

PO Box 9399
Ketchikan, Alaska 99901-4399

[email-masked] or
[email-masked]

at work:
[email-masked]

---------

If we neglect the economic imperative at this time 
when we are so concerned with terrorism, we would be 
feeding terrorism by promoting hunger, disease and ignorance.
 
Philippine President Gloria Macapagal Arroyo

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Dec 2002 10:51:48 +0100

On Mon, Dec 09, 2002 at 06:58:12PM -0800, Denis Perelyubskiy wrote:
[snip]

> I dont

The official statements at the moment are "use at your own risk"
and "not recommended for production use".

[snip]

> version, but I haven't noticed).

It is generated from the source tree when a new release is
uploaded.

Bye

Dominik ^_^  ^_^