Subject: FVWM: Problems building from CVS on RH8

From: Andre Bonhote <[email-masked]>
Date: Fri, 6 Dec 2002 09:38:33 +0100

Hi!

I still have problems to build fvwm2 from CVS on RH8. I have
autoconf-2.53 installed. This is what happens after a fresh checkout:

[andre@caradhras build]$ cd fvwm/
[andre@caradhras fvwm]$ autoreconf
autoreconf: `aclocal.m4' is created
configure.in: required file `./install-sh' not found
configure.in: required file `./mkinstalldirs' not found
configure.in: required file `./missing' not found
configure.in:71: required file `./config.h.in' not found
bin/Makefile.am: required file `./depcomp' not found
autoreconf: automake failed with exit status: 1
 at /usr/bin/autoreconf line 368
[andre@caradhras fvwm]$ automake --add-missing
configure.in: installing `./install-sh'
configure.in: installing `./mkinstalldirs'
configure.in: installing `./missing'
configure.in:71: required file `./config.h.in' not found
bin/Makefile.am: installing `./depcomp'

Um ... any hints? I am not quite in to automake/autoconf, in other
words, I have no clue what could be wrong there. It compiles without
any hassle on redhat 7.x.

Please help, I am still forced to use the native RH gnome thing!

TIA

Andr
-- 
Real programmers use "cat > a.out"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Fri, 6 Dec 2002 01:15:54 -0800

hi, Andre.

  >any hassle on redhat 7.x.

bet you did not do utils/configure_dev.sh before building?
just run it to generate all those missing files. at least I
think that's what it does.

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andre Bonhote <[email-masked]>
Date: Fri, 6 Dec 2002 10:24:41 +0100

>   * <[email-masked]> [06-Dec-02 00:42 -0800]:
[snip]
> think that's what it does.

Bet clearly won. But tell me, where should I know? I always followed the
instrutions on http://fvwm.org/cvs.html. There's nothing like that
metioned.

Thanks for the hint. It looks like it's working now.

CU

André

---

From: Denis Perelyubskiy <[email-masked]>
Date: Fri, 6 Dec 2002 01:28:37 -0800

* <[email-masked]> [06-Dec-02 01:26 -0800]:
  >Bet clearly won. But tell me, where should I know? I
  >always followed the instrutions on
  >http://fvwm.org/cvs.html. There's nothing like that
  >metioned.

I picked it up on the fvwm_workers mailing list. Someone had
said that was the problem. I am not too sure how you're
supposed to know :-) Maybe someone who's more familiar with
this can point that out.

denis

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Dec 2002 10:54:02 +0100

> supposed to know :-) Maybe someone who's more familiar with

The complete instructions for building from cvs are in
docs/DEVELOPERS.

Bye

Dominik ^_^  ^_^