Subject: FVWM: send keys

From: dion king <[email-masked]>
Date: Fri, 27 Dec 2002 11:42:59 +0800

Hi:
    How to send the keys, for example, Ctrl+C, to 
a window whose name is 'stop'? I wrote:

         All (stop) Exec..
                    --------
                       |_____which command should 
                                be in here?

Thanks,
Dion
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 26 Dec 2002 23:04:02 -0500

>                        |_____which command should 

Perhaps you really want to issue "Close", "Delete" or "Destroy"?

If you are trying to generate a keystroke for an xterm, the
xterm won't accept a synthetic keystroke unless you've
selected "allow sendevents".  (Its a security hole to allow it.)

Do some Google searches on "xwindows synthetic".
The first hit I got discussed the issues in the context of
a security exploit.  It also mentioned some programs.

As far as I know, Fvwm doesn't have a command to generate keystrokes.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Dorothy Robinson <[email-masked]>
Date: Thu, 26 Dec 2002 21:20:36 -0800

I've been teaching myself how to use colorsets in version 2.5.5,
and also the TaskBar (Macintosh-style, across the top.)
I have my own simple theme-changer setup where I load a small file
that contains button styles, menu styles, title styles, and colorsets.
I put something like this in the theme file:

*FvwmPager: Colorset * 2
*FvwmPager: HilightColorset * 3
*FvwmTaskBar: Colorset 2
*FvwmTaskBar: IconColorset 0
*FvwmTaskBar: FocusColorset 2
*FvwmTaskBar: StartIcon buttons/knot_blue.xpm

Then, when I want to change themes, I have a little function that
reads the decor file and re-starts the TaskBar and Pager:

AddToFunc SwitchDecor
+ I Read $./$0
+ I KillModule FvwmTaskBar
+ I Module FvwmTaskBar
+ I KillModule FvwmPager
+ I Module FvwmPager 0 2

This works to give the TaskBar and Pager the new colorset.  But no
matter what I do, I can't change the TaskBar StartIcon.  It uses the
first one it's given after fvwm starts, and it refuses to change
unless I completely re-start fvwm.  I've tried typing all the
combinations I can think of into the console, and nothing works.

Does anyone know a way to accomplish this?

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Dorothy Robinson
http://www.twobarleycorns.net

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 27 Dec 2002 06:18:26 +0000

> Does anyone know a way to accomplish this?

This should work, place into your function:

  DestroyModuleConfig FvwmTaskBar: StartIcon
  *FvwmTaskBar: StartIcon another.xpm

Regards,
Mikhael.