Subject: FVWM: losing focus when resizing windows

From: [email-masked] (Robert Land)
Date: Thu, 12 Dec 2002 16:08:08 +0100

Actually I would like to use the mouse as rarely as I can.
To get the focus on a window M+tab helps, but after some
desired action - usually maximizing - the window loses
imediatly the focus and I have to M+tab back again.

Is this a general fvwm or windowmanager issue?

Robert
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Robert Land)
Date: Wed, 18 Dec 2002 19:32:57 +0100

> Is this a general fvwm or windowmanager issue?

Does my question involve some ambiguity or am I the only
one experiencing this behaviour?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 18 Dec 2002 16:33:41 -0500

> one experiencing this behaviour?

Did you get no answer at all?

I use:

Style * MouseFocus

and I avoid using the mouse as much as I can.

I can't recall loosing focus on a maximize,
the pointer should still be in the window on a maximize.

When you make it smaller, thats different, the pointer could
leave the window then.  Is that when you loose focus?

I don't use M-tab much though.

What focus model are you using?

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked] (Robert Land)
Date: Sun, 22 Dec 2002 12:30:53 +0100

> What focus model are you using?

Dan, thank you very much for your response.
Actually I didn't dig into the focus issue - in fact 
I didn't know of different focus models.

No I didn't recieve any reaction yet, you were the
only one. I guess most people use the mouse pointer
on X - you mentioned using the mouse aswell.

In fact that is exactly what I would like to avoid.
My intention is to 'park' the pointer somewhere in the
desktop corner and do the rest just using the keyboard.

Making the window smaller (even using some key bindings)
should then not affect the focus. Have you tried just
parking the mouse somewhere on the wallpaper (you do
lose focus on any X-window then) - but regain focus
by M+Tabing through all open windows on the desktop
until you reach the desired one?

Robert

---

From: Klaus Umbach <[email-masked]>
Date: Sun, 22 Dec 2002 14:06:55 +0100

I use

AddToFunc       focus-and-raise
+ "I"   Focus
+ "I"   Raise
#+ "I"   PlaceAgain Anim
+ "I"   warptowindow 5p 5p

That solved that Problem.

Klaus

-- 
Klaus Umbach <[email-masked]>
Pfinztalstr. 60
72667 Karlsruhe
Telefon: 0721-47639442

5) People say Linux is ugly. How does that make you feel?
Torvalds: They'll be the first against the wall when the revolution comes.
	  Let's see just how ugly they think it is when they have a few
	  bulletholes in them.

---

From: [email-masked] (Robert Land)
Date: Sun, 22 Dec 2002 17:47:20 +0100

> That solved that Problem.

My sensere thanks, additionaly as now the pointer
jumps automaticaly to the upper left window corner
I'm able to move the desired window to any place
on the desktop only using the keys.
This makes handling X so much easier.

Thanks again

Robert