Subject: FVWM: editing menus

From: [email-masked] (Robert Land)
Date: Thu, 12 Dec 2002 12:18:09 +0100

To launch rather simple and quick emacs, xterm, lynx
and calctool I edited /etc/X11/fvwm/system.fvwm2rc
in this manner:

# Section: Key bindings

#Key F5    A    M    Prev
#Key F6    A    M    Next
Key F5    A    M    exec calctool &   #<-------edited
Key F6    A    M    lynx              #<-------edited
Key F7    A    M    Move
Key F8    A    M    exec xterm &      #<-------edited
Key F9    A    M    Iconify
Key F10   A    M    Maximize 100 100
Key F11   A    M    Raise
#Key F12   A    M    Stick
Key F12   A    M    exec emacs -nw &  #<-------edited

DestroyMenu Window-Ops
AddToMenu Window-Ops "Alt-F1: Window Ops" Title

#+ "Alt-F5:  Previous"               Prev
+ "Alt-F5:  Calculator"              exec calctool & #<-------edited
#+ "Alt-F6:  Next"                   Next
+ "Alt-F6:  lynx"                    lynx &          #<-------edited
+ "Alt-F7:  Move"                    Move
+ "Alt-F8:  xterm"                   exec xterm &    #<-------edited
+ "Alt-F9:  (De)Iconify"             Iconify
+ "Alt-F10: (Un)Maximize to screen"  Maximize 100 100
+ "Alt-F11: Raise"                   Raise
#+ "Alt-F12: (Un)Stick"              Stick        
+ "Alt-F12: emacs -nw"               exec emacs -nw & #<-------edited

Yet only calctool and xterm want to launch, lynx and emacs
alltogether refuse in menu and keybindings although they
can be started by command in a xterm.

Could someone kindly explain this rather strange behaviour?

Robert
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Dec 2002 14:11:39 +0100

> Key F6    A    M    lynx              #<-------edited
                      ^^^^
> + "Alt-F6:  lynx"                    lynx &          #<-------edited
                                       ^^^^^^

This is wrong.  You need "exec lynx &".  You can not simply put
shell commands in a menu, they must be prefixed with the "exec"
fvwm command.

> + "Alt-F12: emacs -nw"               exec emacs -nw & #<-------edited

Check for some error message in the X console.  Is the PATH set
correctly?

Bye

Dominik ^_^  ^_^

---

From: Dan Espen <[email-masked]>
Date: Thu, 12 Dec 2002 08:25:37 -0500

> Check for some error message in the X console.  Is the PATH set

emacs -nw is emacs without an X windows GUI.  It needs to run in
an xterm, as in:

exec xterm -e emacs -nw

-- 
Dan Espen                           E-mail: [email-masked]

---

From: [email-masked] (Robert Land)
Date: Thu, 12 Dec 2002 15:55:57 +0100

> emacs -nw is emacs without an X windows GUI.  It needs to run in

Thank you very much, this actually was what I had missed
beside the silly mistake forgetting exec (in a xterm aswell)
for the lynx browser.

Robert