Subject: FVWM: title of a window

From: dion king <[email-masked]>
Date: Mon, 30 Dec 2002 16:49:06 +0800

I switched to fvwm about a month ago, but i have began to 
love it. After some hard work, it becomes more and more 
beautiful.

However, I came to a problem. I used fvwmiconman to show the
windows on one page and set:
fvwmiconman: format "%t" 
to show the title of a windows in the title bar.

Then all the 'rxvt' only show 'rxvt' in title. They are same in
"name","icon name","class","resource",only different in windows id.
But it's ugly to show the windows id in title, so it's very hard to
discriminate them. Are there some way to show more infomation?
For example, rxvt(1) for the first one, rxvt(2) for the one runs 
after rxvt(1).

Thank you,
dion

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Dec 2002 09:02:36 +0000

> For example, rxvt(1) for the first one, rxvt(2) for the one runs 

In 2.5.x use:

  Style * IndexedWindowName, IndexedIconName

Regards,
Mikhael.

---

From: dion king <[email-masked]>
Date: Mon, 30 Dec 2002 17:43:21 +0800

But I use 2.4.14...
In the homepage of fvwm, I find 2.4.14 is the latest stable release
and 2.5.5 is an unstable release. I have little experience is fvwm,
so I am afraid to use an unstable release.

thank you
dion

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 30 Dec 2002 12:20:08 +0100

> so I am afraid to use an unstable release.

Hi dion

I was afraid too but I did it and I am completely happy with 2.5.5. For
a couple of days I am using it now and I there was no bug at all. Enjoy
the new features!

Felix

---

From: Dennis McGregor <[email-masked]>
Date: Mon, 30 Dec 2002 22:14:44 +1100

> dion

I use the $PROMPT_COMMAND variable in bash (and others?) to set my term
titles to something descriptive.
This is what I have in ~/.bashrc:
 [ $TERM == "linux" ] \
 && unset  PROMPT_COMMAND \
 || export PROMPT_COMMAND='echo -ne "\033]0;`whoami` | `basename ${DIRSTACK}`\007\033k\033\134"'

This will put $USER and the current directory, seperated by a "|", in your *term titles.
You may strip the last "\033\034" if you don't use screen(1).
This helps me keep track of my terms in FvwmIconMan. Another option is
to use screen - then you won't need to open so many terms ;)

Cheers.

^d

---

From: Bob Crochelt <[email-masked]>
Date: Mon, 30 Dec 2002 07:31:30 -0900

> a couple of days I am using it now and I there was no bug at all. Enjoy

I agree.  I'm an amateur, but 2.5.5 compiles (RH 7.3, Pentium II @ 300mHz) 
fine and runs great.  No problems at all.
Bob Crochelt, MD, PhD, FACS

PO Box 9399
Ketchikan, Alaska 99901-4399

[email-masked] or
[email-masked]

at work:
[email-masked]

In life, sorrow tends to last just a little longer than joy.
So we try to just touch the joy to alleviate the sorrow.

Abdul Razak al-Alawi
Conductor, Baghdad Symphony Orchestra