Subject: FVWM: how to zoom a pixmap to use it in a button?

From: dion king <[email-masked]>
Date: Mon, 9 Dec 2002 09:10:08 +0800

I want to use a pixmap file in a button and the size of
button is fixed.
However the icon is a little bigger so only a part of it can
be show on the button.
Then how to zoom it ?
Thank you for your help.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 9 Dec 2002 10:25:20 +0000

> However the icon is a little bigger so only a part of it can

I suppose you speak about "ButtonStyle n Pixmap /your/image.xpm"
and not "ButtonStyle n MiniIcon".

1) You may enlarge the TitleStyle Height value for the image to fit.

2) You may zoom and save the image using gimp or other image editor.

3) In recent 2.5.5+ you may zoom an image if you use colorsets.

  Colorset 9 AspectPixmap /your/image.png
  ButtonStyle 7 Colorset 9

  # these 2 are not needed for you, just to make button 7 visible
  Style * Button 7
  Mouse 1 7 A Iconify

Regards,
Mikhael.

---

From: dion king <[email-masked]>
Date: Tue, 10 Dec 2002 09:19:07 +0800

>   # these 2 are not needed for you, just to make button 7 visible

Thank you for your help :)
I want to use image in the buttons of module FvwmButtons,
not in the topbar of windows.
I configured the FvwmButtons like following:
 
      Font        5x7
      Back rgb:90/80/90
      Fore        black
      Frame       1
      # 15x15 pixels per button, 4x4 pixels for the frame
      Geometry    904x49+0-0
      Rows        3
      Columns     60
      BoxSize     fixed
      Padding     1 1
       
      # first row of buttons from left to right:
     (2x2+0+0, Icon mozillasmall.xpm, Action `Exec mozilla`)
     (2x2+2+0, Icon rxvt.xpm, Action `Exec exec rxvt`)
     ............

But rxvt.xpm is too bigger to show on the 2x2 button.
Some other xpm impages are also too bigger. 
Of course, I can zoom and save the image using gimp.
But I am too lazy to do it for every big image :)
Is there other way to solve it?

dion

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 02:37:46 +0000

> not in the topbar of windows.

Yes, there are so many key, mouse and reset buttons out there
that you should be more specific.

>      (2x2+2+0, Icon rxvt.xpm, Action `Exec exec rxvt`)

There is no currently way to zoom FvwmButtons Icon image internally.
You may zoom an image specified in the buttons Pixmap or Colorset
(with Pixmap or AspectPixmap). It is auto-zoomed when resized too.

Regards,
Mikhael.