Subject: FVWM: Icon with window title

From: hugo vanwoerkom <[email-masked]>
Date: Tue, 31 Dec 2002 14:29:25 -0800 (PST)

On the michael-desk-1152x900 screenshot on the
screenshot page of fvwm.org it shows windows with
titles and icons. I want to have that, but I am doing
something wrong: titles but no icons...
All my windows have 5 buttons, because I have:
...
AddButtonStyle 1 Pixmap button.xpm 		#HVW1
AddButtonStyle 2 Pixmap button-max.xpm		#HVW1
AddButtonStyle 4 Pixmap button-iconify.xpm	#HVW1
AddButtonStyle 6 Pixmap button-close.xpm	#HVW1

Style "*" MWMButtons  # button relief follows the
state

Mouse 0 3 N Stick
ButtonStyle 3 - Clear MWMDecorStick
ButtonStyle 3 Inactive          Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
ButtonStyle 3 ActiveUp          Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
ButtonStyle 3 ActiveDown        Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
ButtonStyle 3 ToggledInactive   Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
ButtonStyle 3 ToggledActiveUp   Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
ButtonStyle 3 ToggledActiveDown Vector 4 75x25@0
75x75@0 25x75@0 75x25@1
...
Can someone give me a pointer on how to get an icon on
there that the executing program sets?
Thanks!
Hugo.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 31 Dec 2002 17:38:46 -0500

> there that the executing program sets?

You need to bind an action to the button or it won't show.

For example, like you did on button 3 with the Mouse
command.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 1 Jan 2003 01:42:26 +0000

> there that the executing program sets?

If I understand you correctly you want to show a mini icon in a titlebar:

  ButtonStyle 1 MiniIcon

By default, if the program itself supplies a mini icon (using EWMH) it is
shown in the MiniIcon button in 2.5.x. But pre-EWMH applications do not
set a mini icon hint. You should define it yourself, like:

  Style * MiniIcon mini/unknown.xpm
  Style XTerm MiniIcon mini/terminal.xpm

Regards,
Mikhael.