Subject: FVWM: FvwmTabs

From: SCoTT SMeDLeY <[email-masked]>
Date: Wed, 11 Dec 2002 00:50:58 +1100

Hi all,

You can try out FvwmTabs if you like:

http://users.tpg.com.au/users/scottie7/fvwmtabs.html

It only has very basic functionality at the moment but it
sure unclutters your desktop.

SCoTT. :)
-- 
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 11 Dec 2002 14:10:42 +1100

On 00:50 11 Dec 2002, SCoTT SMeDLeY <[email-masked]> wrote:
| You can try out FvwmTabs if you like:
| 
| http://users.tpg.com.au/users/scottie7/fvwmtabs.html
| 
| It only has very basic functionality at the moment but it
| sure unclutters your desktop.

It would be handy if you could have more than one instance of FvwmTabs
and the ability to send a window to an arbitrary tabset. Just a remark.
Cute app.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

No system, regardless of how sophisticated, can repeal the laws of physics or
overcome careless driving actions.	- Mercedes Benz
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: SCoTT SMeDLeY <[email-masked]>
Date: Wed, 11 Dec 2002 15:54:06 +1100

> and the ability to send a window to an arbitrary tabset. Just a remark.

Agreed. Ideally I think the user should select 'Add' from the
FvwmTabs window when they want to add an existing window. When this
happens, FvwmTabs needs some way to ask FVWM to get the user to select
a window & have it pass back the window Id. That'd work nice - that
way you can have as many FvwmTabs running as you like.

I haven't worked out how to control FVWM (from a module) to select a
window with a mouse-click though - anyone?

SCoTT. :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 11 Dec 2002 13:29:12 +0000

> window with a mouse-click though - anyone?

Command/prefix Pick is used to select a window and execute command in the
selected window context or not execute if window selection is canceled.

If there is master FvwmTabs and several aliases, you may do the following.
To create a new tab from the master, send this or similar command:

  Pick Module FvwmTabs FvwmTabs-3  # starts a new module with a new window

or (depending on implementation):

  Pick SendToModule FvwmTabs createnew

The last may send "FvwmTabs FvwmTabs-3" in the received window context.
To add a to-be-selected window to an existing tab, this tab may send:

  Pick SendToModule FvwmTabs-3 addme

BTW, there was a reply on fvwm-workers list and I think you are not
subscribed to it. I agree that such things belong more to a developer
list.

  http://www.hpc.uh.edu/fvwm/archive/0212/msg00200.html

Regards,
Mikhael.