Subject: FVWM: Dependency packages

From: Rahul Rekapalli <[email-masked]>
Date: Tue, 3 Dec 2002 08:04:00 +0530

I update my copy of fvwm from cvs , and when I try to install it, i
get the following error.

#rpm -Uvh /usr/src/redhat/RPMS/i386/fvwm-2.5.6-1.i386.rpm
error: Failed dependencies:
        perl(Gtk) is needed by fvwm-2.5.6-1
        perl(Tk) is needed by fvwm-2.5.6-1
        perl(Tk::Dialog) is needed by fvwm-2.5.6-1

I couldn't find appropriate packages for Redhat 8.0

could someone tell me where I can get these packages?
When compiling, FvwmGtk support was disabled.

Regards
Rahul

-- 
---------------------------------------------------
		the bug stops here
---------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 3 Dec 2002 04:22:12 +0000

> #rpm -Uvh /usr/src/redhat/RPMS/i386/fvwm-2.5.6-1.i386.rpm

Please don't name the release 1, there is no final 2.5.6.
Just leave the default 0.20021203 when doing "make rpm-dist".

> When compiling, FvwmGtk support was disabled.

Hmm, yet another "smart" mechanism that should be turned off somehow.
These perl packages are fully optional. Anyway, a quick search shows:

  http://rpmfind.net//linux/RPM/redhat/8.0/i386/Gtk-Perl-0.7008-25.i386.html
  http://ftp.silug.org/pub/kspei/add-ons/redhat/8.0/i386/perl-Tk-804.024-0.i386.rpm

The first is needed for FvwmGtkDebug, the second is really not needed
unless you want to create your own modules in Perl/Tk.

I will upload the official rpms for the latest stable/unstable versions
today/tomorrow. They should not have these dependency problems.

Note, that 2.5.5 is less stable than 2.5.4. At least for me.

Regards,
Mikhael.