Subject: FVWM: Unshade-On-Hover

From: Timothy Groves <[email-masked]>
Date: Mon, 09 Dec 2002 20:16:51 -0500

Is there a way to cause a window to unshade when the mouse is hovered
over the title bar?  Also, if there is, is there a way to cause the
window to re-shade when focus is lost?
-- 
ICQ#66022322

  "It's a terrifying thing, isn't it?  To live in fear.  
	 That's what it's like to be a slave."
	--Rutger Hauer, Bladerunner
______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 03:02:40 +0000

> window to re-shade when focus is lost?

With SloppyFocus, put this your in menus or StartFunction:

  FvwmAuto 200 "Silent WindowShade off" "Silent WindowShade on"

Although this does exactly what you want and kind of fancy,
I am not sure this is very usable.

  KillModule FvwmAuto

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 16:00:22 +0000

On 10 Dec 2002 08:17:07 -0500, Timothy Groves wrote:
> Mikhael Goikhman wrote:
> Yep, that works all right.  A little too well.  :)  Is there a way to
> limit it to only windows that are already shaded?

Please decide what you want, should it automatically shade on or not?
This makes more sense for me:

  FvwmAuto 300 "ThisWindow (Shaded) WindowShade off"

It is possible to program some more complex logic (once you define it)
using user states in 2.5.x. Also use delay 0 if you intend to mix quick
manual shading with automatical unshading.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Dec 2002 17:41:44 +0100

> Please decide what you want, should it automatically shade on or not?

He wants to shade only windows that were previously unshaded when
they received focus.  Try this one (but personally I hate that).

  AddToFunc funky_shade
  + I WindowId $[funky_shade_w] (!shaded) WindowShade on

  AddToFunc funky_unshade
  + I funky_shade
  + I UnsetEnv funky_shade_w
  + I ThisWindow (shaded) SetEnv funky_shade_w $w
  + I WindowShade off

  AddToFunc StartFunction
  + I UnsetEnv funky_shade_w
  + I FvwmAuto 300 "Silent funky_unshade" "Silent funky_shade"

Maybe it could be done better with using the internal window
states to remember which windows want to be (un)shaded.

> manual shading with automatical unshading.

Bye

Dominik ^_^  ^_^

---

From: Timothy Groves <[email-masked]>
Date: Wed, 11 Dec 2002 00:07:13 -0500

> they received focus.  Try this one (but personally I hate that).

Perfect!  Thanks for all those that replied!

Oh, and I understand that there are those that detest this sort of
function.  Myself, I only use it on xcalc and other small,
often-needed-but-usually-in-the-way applets.
-- 
ICQ#66022322