Subject: FVWM: grabfocustransient not working?

From: Bob Mroczka <[email-masked]>
Date: Sat, 14 Dec 2002 00:47:51 -0600

I have Adobe's Acrobat reader version 5.0.6 installed
on my Linux 2.4.20 box and I can't figure out why
the find dialog window does not receive the focus when it is opened.
The issue occurs with version 4 of the reader too.

I was running fvwm 2.4.0 and just installed 2.4.14 but that didn't fix the problem.
I use the clicktofocus style for all of my windows.

Does anyone have any suggestions for getting these find windows
to get the focus when they are opened?

Thanks.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 14 Dec 2002 08:38:38 +0000

> to get the focus when they are opened?

If you use ClickToFocus, GrabFocusTransient is the default.
What application do you run?

You may have a problem if you define SloppyFocus/MouseFocus for your
window, then you should reissue GrabFocusTransient after SloppyFocus.
Or maybe you listen to add_window in FvwmEvent and then do something.

Does your problem occur with a minimal configuration, i.e. if you run:

  fvwm -cmd "Style * ClickToFocus, DecorateTransient"

I just did:

  Restart /opt/fvwm-2.4/bin/fvwm -cmd "Style * ClickToFocus"

and it works well, transients automatically get focus.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 14 Dec 2002 13:53:59 +0100

> What application do you run?

He says Acrobat reader.

> and it works well, transients automatically get focus.

I've tried with 2.4.14 and the  Acrobat reader. I can reproduce the pbs.
I've also tested with xemacs, some kde apps, and Netscape: no pbs.

Olivier

PS: - I've tried with 2.5.6, the Acrobat reader "pb" is here
only if !FPGrabFocus.
- All test done with SloppyFocus
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 16 Dec 2002 12:01:27 +0100

> I've also tested with xemacs, some kde apps, and Netscape: no pbs.

acroread sets the "transientfor" window to an unmapped, 1x1 window
at a random screen position.  I think fvwm does the right thing by
ignoring the "transient" hint altogether as in many other
situations.  Popping up a transient dialog for a non existing
window is meaningless and might well cause that the window is
never even mapped.  Someone should send a bug report to Adobe.

There *is* a bug in 2.5.x that makes transients lose their
transientfor window if they are created while the transientfor is
iconified or on another desk.  I will commit a fix.

Bye

Dominik ^_^  ^_^