Subject: FVWM: Acrobat Reader refuse to move in FVWM!

From: wang yin <[email-masked]>
Date: Mon, 30 Dec 2002 19:00:22 +0800

Hi,

  If I use Acrobat Reader to open a fullscreen PDF file and then press "Esc" to return to the normal state. Acrobat won't move anymore.

  But it can move in kwin and metacity. Why?

-- 
Wang Yin
DA Lab, Tsinghua University,
100084
Beijing China
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Dec 2002 08:59:39 -0500

wang yin <[email-masked]> writes:
> Hi,
> 
>   If I use Acrobat Reader to open a fullscreen PDF file and then press "Esc" 
> to return to the normal state. Acrobat won't move anymore.
> 

I can't reproduce the problem.

Can you provide more information?

What OS, version of acroread, release of fvwm, how are you trying to move
the window...anything else.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: wang yin <[email-masked]>
Date: Mon, 30 Dec 2002 22:18:14 +0800

If you open this file:
http://www.pragma-ade.com/present/talks/pre-mml.pdf
with Acrobat Reader 5.05 on Redhat Linux 8.0 with FVWM 2.5.4

It will change to fullscreen and you press Esc, it change to normal state
and won't move anymore.

I solved the problem just now with a 

Style "AcroRead"	VariablePosition, VariableUSPosition

But I'm still curious: 
How can Acrobat Reader tell FVWM to use "FixedPosition" style?
EWMHints?

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Dec 2002 14:44:55 +0000

> How can Acrobat Reader tell FVWM to use "FixedPosition" style?

I think, if you run "xwininfo -size" on this window this will answer your
question. (I don't run proprietary programs myself to test this.)

Regards,
Mikhael.

---

From: wang yin <[email-masked]>
Date: Mon, 30 Dec 2002 23:02:59 +0800

Here is what xwininfo says. I can't find any clue:

xwininfo: Window id: 0x180013a "pre-mml.pdf"

  Normal window size hints:
      Program supplied location: 0, 0
      Program supplied size: 800 by 600
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Dec 2002 15:40:49 +0000

On 30 Dec 2002 23:02:59 +0800, wang yin wrote:
> > I think, if you run "xwininfo -size" on this window this will answer
> > your question. (I don't run proprietary programs myself to test this.)
> 

Then my guess was wrong. The +0+0 position is respected or not respected
depending on NoPPosition or UsePPosition. Not quite related.

I suppose you can reproduce this problem with no config at all.
Probably others have more ideas.

P.S. Please respect the reply style used on this and other technical
lists: put your message after the quoted lines and manually remove all
unrelated lines from quotes like mailing list signatures.

Regards,
Mikhael.