Subject: FVWM: centering transients over parents

From: "Neil W. Van Dyke" <[email-masked]>
Date: Mon, 2 Dec 2002 18:00:05 -0500

Can FVWM be configured to place a transient window centered over its parent?

(I've had no luck with the man page and Google.)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 3 Dec 2002 00:37:42 +0000

> (I've had no luck with the man page and Google.)

No, currently there is no option like this.

Regards,
Mikhael.

---

From: Richard Lister <[email-masked]>
Date: Wed, 04 Dec 2002 20:47:15 -0500 (EST)

"Neil W. Van Dyke" <[email-masked]> wrote on Mon, 2 Dec 2002 18:00:05 -0500:
>
> Subject: FVWM: centering transients over parents
>

OK, I've wanted something like this for a while now, so I've
hacked together a little module to do it. It's not too pretty
because fvwm briefly maps the transient before moving it to
the parent window. But it does work.

The module calls an fvwm function with the new coordinates for
the transient, so you can do sort of Aqua-like things like:

  Module FvwmPlaceTransient 50 25

  DestroyFunc PlaceTransient
  AddToFunc PlaceTransient
    + I WindowShade True
    + I Move $0 $1
    + I WindowShade False

I took a quick look at placement.c and it seems like it wouldn't be
too much trouble to put something like this in the core. Maybe as a
style? Then it would be much more slick. Transients could unshade
out of the title bar, for example.

Anyway, the module is at:

  http://cns.georgetown.edu/~ric/software/fvwm/FvwmPlaceTransient.tar.gz

I've not really tested it much, so it's probably full of bugs :-)

Cheers
Ric

Richard J Lister
Dept of Neuroscience
Georgetown University Medical Center
http://cns.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].