Subject: FVWM: Re: [newbie] list of commands for .fvwm2rc

From: Elliot Sowadsky <[email-masked]>
Date: Tue, 10 Dec 2002 09:53:37 -0800 (PST)

Maybe the default .fvwm2rc that comes w/ fvwm should have EVERY command in it (and a one liner of its purpose.

People can then delete/switch what they dont want.
It's easier to see what to delete than to see what to add.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 10 Dec 2002 13:18:32 -0500

>  (and a one liner of its purpose.

That would be pretty hard.  There are a lot of commands, style
options, and modules.  Some of them are contradictory, for example
if you use FvwmIcon, you should set Style NoIcon, so all the
icon related stuff doesn't apply.

> It's easier to see what to delete than to see what to add.

There is no single default configuration.  There are 2 different
automatically generated setups and a few different sample files.
Theres the official Fvwm Themes, and I think a couple of other
themes thingies, and theres the setup you find in some of the
distributions.

This subject keeps coming up, (sometimes is comes up as
"fvwm needs a tutorial").

Face it, the joy of Fvwm is searching thru the man pages and
finding the option you need and inserting into your config file
with an editor.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 18:50:49 +0000

> It's easier to see what to delete than to see what to add.

Most of the commands are dynamical and/or contextual, so dumping them all
without a context would be very silly. Also some of the commands have
dozens of options, that are pretty opposite.

In the mean time, take a look at:

  ftp://ftp.fvwm.org/pub/fvwm/devel/sources/docs/COMMANDS

If you are good at writting short and intuitive descriptions feel free to
complete them using the man page, I don't have a time to do this right now.

Regards,
Mikhael.