Subject: FVWM: Perl modules.

From: SCoTT SMeDLeY <[email-masked]>
Date: Tue, 10 Dec 2002 11:16:26 +1100

Hi all,

My Perl/Tk FvwmTabs module works great!

I'm trying to run it on another OS but I think there's a problem
with FVWM::Module.

I was able to run the demo 'module-tkdesker' successfully on my
Redhat 7.3 box, but when I run it on a Redhat 7.1 box I get this error:

Can't call method "_win_id" without a package or object reference at /tmp/module-tkdesker line 53.

This is a similar error to what I'm getting in my FvwmTabs code.

'perl -v' yields '5.6.1' on RH7.3 & '5.6.0' on RH7.1 ... could that be
important?

On both machines I'm running fvwm-2.5.4.

Any advice/pointers greatly appreciated.

SCoTT. :)
-- 
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 10 Dec 2002 03:35:13 +0000

> My Perl/Tk FvwmTabs module works great!

Hmm, intriguing.

> 'perl -v' yields '5.6.1' on RH7.3 & '5.6.0' on RH7.1 ... could that be

I write it to be 5.004 compatible, but only 5.00503, 5.6.0 and 5.8.0
are tested for now.

> Any advice/pointers greatly appreciated.

Seems like you have several fvwm installations and the one in your $PATH
is 2.5.2 or 2.5.3. What does "fvwm-perllib --version" say?

Regards,
Mikhael.

---

From: SCoTT SMeDLeY <[email-masked]>
Date: Tue, 10 Dec 2002 16:47:53 +1100

> > My Perl/Tk FvwmTabs module works great!

Yeah, it's been lots of fun. You would not believe how many windows
I've unmapped, lost & had disappear into the window manager void
forever ... never to be recovered! :)

It's like dark matter - you know it's there but you can't see it!

> is 2.5.2 or 2.5.3. What does "fvwm-perllib --version" say?

Ah, that's it! Just needed to make sure I got the right 'fvwm-perllib'.

Thanks so much.

SCoTTie! :)