Subject: RE: FVWM: Premature close of OpenInterface GUI

From: "Dameron, Gregg" <[email-masked]>
Date: Tue, 03 Dec 2002 09:55:16 -0700

> > We are trying to run Sun's RAID Manager GUI, rm6.  When it 
> runs, it displays
> > a box of icons that lets the user launch child GUI 
> processes (similar to the
> > CDE App Manager).  FvwmIdent shows all the rm6 GUIs to be class
> > "OpenInterface", resource "openedit".
> > 
> > Some of the child process GUIs have a Toolbar.  When you 
> roam the mouse over
> > one of the toolbar buttons, a popup tooltip is supposed to 
> appear.  What
> > happens is, you get the tooltip for a few milliseconds, 
> then the child GUI's
> > process exits normally (status 0), as if it had received a 
> close request
> > from the window manager.  Truss reveals no obvious "smoking gun".
> > 
> > I tried using the default (built-in) fvwm2 configuration 
> and got the same
> > result.
> > 
> > I went back to my regular configuration and tried using the 
> keyboard mapping
> > to move the mouse (Alt + arrow keys).  I can move the mouse 
> over the toolbar
> > buttons, and the process stays up, but then, the tooltip 
> never appears.
> > 
> > The rm6 GUIs work fine under olwm, dtwm and twm.  Any 
> suggestions are very
> > welcome.
> 
> It's hard to say what is going on without seeing what events
> inside fvwm cause the the frame to disappear.  I can't imagine why
> fvwm should tell the window to close itself.  I guess rm6 isn't
> available freely (and on Linux) so I could try again?
> 

Sun may be willing to provide an evaluation copy to whomever among you runs
Solaris (Dan Espen, perhaps?).  Failing that, I am willing to help debug the
problem -- can you recommend a next step?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 03 Dec 2002 12:16:21 -0500

> problem -- can you recommend a next step?

I've switched my day to  day use to Linux, (sorry  Sun), but I can run
Solaris stuff if needed.  We don't have any Sun raid arrays installed,
I don't know if the rm6 stuff needs hardware.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Tomi Vainio - Sun Finland - <[email-masked]>
Date: Tue, 3 Dec 2002 22:13:53 +0200

> I don't know if the rm6 stuff needs hardware.
You don't need any array just clicking about button will show the
problem.  I've installed this RM6 GUI and I can give access to this
machine to do some testing.

  Tomppa