Subject: FVWM: fvwm default key bindings

From: [email-masked] (Robert Land)
Date: Thu, 12 Dec 2002 17:16:26 +0100

What are the following key bindings defined in
system.fvwm2rc for:

Key F5    A    M    Prev
Key F6    A    M    Next

Using these keys does not seem to result in any
behaviour (I thought it would be a alternative
to M+tab and MS+tab).

What is the 3rd column in the pasted lines for?
The manual declares 'A' would be 'any key' but
this does not make sense to me.

Robert
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Dec 2002 18:23:26 +0100

> What are the following key bindings defined in

You have to ask the person who wrote these lines.  They just
gobble up system resources and prevent that you can use Alt-F5 or
Alt-F6 in any application.  You can safely remove them.
 
> behaviour (I thought it would be a alternative

For this, try

  Key F5    A    M    Prev (AcceptsFocus) Focus
  Key F6    A    M    Next (AcceptsFocus) Focus

> this does not make sense to me.

The third column is the context.  "Any" means that the binding
works everywhere, regardless of where the pointer is.

Bye

Dominik ^_^  ^_^

---

From: Felix Karpfen <[email-masked]>
Date: Fri, 13 Dec 2002 08:08:54 +1100

> works everywhere, regardless of where the pointer is.

Until now I have failed to make sense of references to the "context" and
"modifier" entries.

A very full explanation starts on line 3418 of the fvwm2 man page - easy
to find once you know what to look for.

Maybe, the syntax (context and modifier) and the full range of codes are
also listed in one of the supplied configuration files and my failure
results from using fvwm-themes instead of diligently studying the
supplied samples. 

If so, would it be possible to have an entry in the themes-FAQ, that
summarises the codes and points to the relevant section of the man page?

Felix Karpfen 

-- 
Felix Karpfen
[email-masked]
Public Key 72FDF9DF (DH/DSA)

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 13 Dec 2002 10:18:12 +0100

> to find once you know what to look for.

It's in the entry for the "Mouse" command, and the "Key" entry
says:

  The syntax is the same as for a Mouse binding ...

Isn't that clear enough?  Perhaps you tried to be too clever when
looking for the information?

> results from using fvwm-themes instead of diligently studying the

Look at the man page and you should see it clear as day.

Bye

Dominik ^_^  ^_^