Subject: FVWM: Unexpected window disappear!

From: wang yin <[email-masked]>
Date: Mon, 30 Dec 2002 21:09:12 +0800

Hi,

  I've been using FVWM for several month and get quite involved with it.
  But now I have a strange problem.
  Some of my windows will disappear unexpectly sometimes.
  I don't know when and which will disappear. It seems the problem is not easy to reproduce.

  I only know that rxvt is the most often to disappear of all and the most likely occasion is when I restart FVWM.
  Once the windows vanished, I can't get it back! It's not in the WindowList or else where. Nor can I get it back with a "All () MoveToPage".
  It just closed! Why?

-- 
Wang Yin
DA Lab, Tsinghua University,
100084
Beijing China
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 30 Dec 2002 08:48:35 -0500

wang yin <[email-masked]> writes:
>   Once the windows vanished, I can't get it back! It's not in the WindowList 
> or else where. Nor can I get it back with a "All () MoveToPage".
>   It just closed! Why?

Use this command to see if the window is really gone:

xlsclients | grep rxvt

If the window is really gone, perhaps rxvt printed an error message
and exited.  Find stderr for fvwm and look there.  Stderr might
be on your console, or you may have redirected fvwm's stderr when
you started it:

fvwm2 >/tmp/fvwm.out 2>&1

If that still doesn't help, perhaps rxvt core dumped.

Make sure core dumps are enabled (man ulimit), then look for
$HOME/core.

-- 
Dan Espen                           E-mail: [email-masked]