Subject: FVWM: resize/move mouse bindings

From: Peter McAlpine <[email-masked]>
Date: Fri, 1 Nov 2002 08:56:16 -0500

hi,

I've got the following in my .fvwm2rc:

Mouse 3 W M Resize
Mouse 1 W M Move

It sometimes doesn't work with emacs, sometimes it does. If it doesn't
work, then restarting fvwm fixes it. I've tried running
global-unset-key in emacs, but it didn't fix the problem.

I'm running fvwm ver 2.5.4.

Thanks in advance,
Peter
-- 
Peter McAlpine
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 1 Nov 2002 18:36:02 +0100 (CET)

> global-unset-key in emacs, but it didn't fix the problem.

Is numlock turned on? If so try to turn it off...

//Marcus

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 1 Nov 2002 18:56:48 +0100

> global-unset-key in emacs, but it didn't fix the problem.

Is "sometimes" by any chance when the window is lowered and/or
unfocused?  If so,

  Style * FPAllowFocusClickFunction, FPAllowRaiseClickFunction  

should help.  Even if it does help, please post all your focus
related configuration lines.  And did you have the same problem
with earlier releases?

I rewrote the code handling window focus a while ago and had to
break compatibility at a few places, but this one was not
intended.

> I'm running fvwm ver 2.5.4.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Peter McAlpine <[email-masked]>
Date: Fri, 1 Nov 2002 22:18:59 -0500

sorry, should've mentioned that in my first email... num/caps/scroll
lock are NOT on.

peter =)

---

From: Peter McAlpine <[email-masked]>
Date: Sat, 2 Nov 2002 22:16:16 -0500

Hello,

> Is "sometimes" by any chance when the window is lowered and/or

Ok, I've got it figured out. Sometimes is: whenever emacs is started
within the current fvwm session. Examples:
X loads... start up emacs == Can't resize with mouse bindings.
Restart fvwm (without quitting X) == Resize emacs no problem.
Close emacs, and then reopen == can't resize with mouse bindings.

>   Style * FPAllowFocusClickFunction, FPAllowRaiseClickFunction  

Didn't fix.

> related configuration lines.  And did you have the same problem

Sorry, I can't remember if my old unstable .deb (2.4.8 I think) had
this problem. Maybe, though, as this little annoyance has been on my
wmpinboard todo list for a while.

Here's all my Style "*"s that I thought may be related (or I didn't
know what they did, they were just in the example rc file I started
with):

Note that I tried to turn each of these three off one at a time, but
it didn't solve my problem.
Style "*" MouseFocusClickRaises
Style "*" SloppyFocus
Style "*" GrabFocus

Style "*" MWMFunctions
Style "*" MWMBorder
Style "*" MWMDecor
Style "*" DecorateTransient
Style "*" SmartPlacement
Style "*" NoPPosition
Style "*" MouseFocusClickRaises
Style "*" SloppyFocus
Style "*" GrabFocus

Thanks again,
Peter =)