Subject: Re: FVWM: Mozilla window position

From: Dominik Vogt <[email-masked]>
Date: Fri, 1 Nov 2002 15:45:51 +0100

On Thu, Oct 31, 2002 at 02:32:25PM -0800, Elliot Sowadsky wrote:
> 
> fvwm 2.5.3 on Solaris 5.8
> Mozilla 1.1
> 
> My Mozilla windows always used to open at 0,0.
> Yesterday, some web page opened a window at 0,34.
> Now all Mozilla windows open at 0,34.
> I tried reverting .mozilla to pre-yesterday.
> I moved .netscape
> I reinstalled Mozilla.
> -geometry+0+0 desnt work for Mozilla.
> The NoPPosition stuff doesnt help.
> So i patched in a Move 0,0 on window open.
> But where does the 34 reside so i can reset it back to 0?

I'm not sure where mozilla saves its position, but it usually
saves it when you close (not "kill -9") the last window.  I have
just

  Style * NoPPosition

which prevents mozilla from forcing its window positions.  Maybe
you have the wrong style name?

  Style mozilla-bin NoPPosition

should work too, but to make sure you can add

  Style mozilla-bin FixedPPosition

(which is new in 2.5.x).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Walter Dnes <[email-masked]>
Date: Mon, 4 Nov 2002 19:05:02 -0500

On Thu, Oct 31, 2002 at 02:32:25PM -0800, Elliot Sowadsky wrote
> Now all Mozilla windows open at 0,34.

  Did you, perchance use {F11} for "fullscreen mode"?  In X, there isn't
a true fullscreen mode.  The Mozilla people emulate it in X by increasing
the window so that the decorations/borders are off the screen, and you
see nothing but the web page.  So far, so good.  However, upon returning
to "normal" mode ({F11} again) it's offset a bit for me too.  I define
the following key binding to maximize/restore a window with {ALT-M}

Key M   A       M       Maximize 100 100

-- 
Walter Dnes <[email-masked]>
I'm not repeating myself; I'm an X Window user, I'm an ex-Windows user
Palladium ain't done till linux won't run
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].