Subject: FVWM: complicated PipeRead AddMenu combo

From: Victor Eijkhout <[email-masked]>
Date: Fri, 8 Nov 2002 20:37:19 -0500

AddToFunc Menu1
+ I PipeRead 'echo AddToMenu Menu2 \"` <some shell command> `\" Nop'

Problem: the shell command gives an output of several words and only 
the first word winds up in menu 2. I tried the double quote by 
itself, escaped, doubled, as well as other variants of quoting, but 
no luck.
-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 9 Nov 2002 04:03:05 +0000

> itself, escaped, doubled, as well as other variants of quoting, but 

This works for me:

  AddToFunc Menu1
  + I PipeRead 'echo AddToMenu Menu2 \\\"`date`\\\" Exec xterm'

Regards,
Mikhael.