Subject: FVWM: bug in fvwmpager 2.5.4

From: Klaus Umbach <[email-masked]>
Date: Sat, 30 Nov 2002 02:09:01 +0100

There's a bug I found in fvwmpager 2.5.4
When I set NoSeparators it's got 100% CPU and does not work.
SolidSeparators works fine.

Klaus

-- 
5) People say Linux is ugly. How does that make you feel?
Torvalds: They'll be the first against the wall when the revolution comes.
	  Let's see just how ugly they think it is when they have a few
	  bulletholes in them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 30 Nov 2002 01:17:23 +0000

> SolidSeparators works fine.

This is already fixed a month ago in cvs. Try the latest daily snapshot.

Regards,
Mikhael.

---

From: Klaus Umbach <[email-masked]>
Date: Sat, 30 Nov 2002 02:53:16 +0100

> This is already fixed a month ago in cvs. Try the latest daily snapshot.

Thanks, but I'll wait until 2.5.5 is released. I can live with
SolidSeparators, as long as I can adjust the color. :-)
It even looks nicer if you can barely see them, instead of not seeing
them. :-))

Klaus

-- 
Klaus Umbach <[email-masked]>
Pfinztalstr. 60
72667 Karlsruhe
Telefon: 0721-47639442

---

From: parv <[email-masked]>
Date: Fri, 29 Nov 2002 23:10:26 -0500

in message <[email-masked]>,
wrote Klaus Umbach thusly...
> SolidSeparators works fine.

and i thought i was alone...

  http://www.freebsd.org/cgi/query-pr.cgi?pr=44820

for those who are using fvwm 2.5.4 & don't want to build from cvs,
attached (patch-modules::FvwmPager::x_pager.c) is a patch which
cured the problem.  apply it in fvwm-2.5.4 directory.

patch was generated from differences in x_pager.c versions in fvwm
cvs (as of ~ nov 1 2002) & fvwm 2.5.4 source.

  - parv

-- 

--- modules/FvwmPager/x_pager.c.old	Thu Oct 24 00:46:59 2002
+++ modules/FvwmPager/x_pager.c	Fri Nov  1 19:26:11 2002
@@ -1630,8 +1630,8 @@
 				XDrawLine(
 					dpy,Desks[desk].w,Desks[desk].DashedGC,
 					x1,y1,x1,y2);
-				x += Scr.MyDisplayWidth;
 			}
+			x += Scr.MyDisplayWidth;
 		}
 		y = Scr.MyDisplayHeight;
 		x1 = 0;
@@ -1640,9 +1640,11 @@
 		{
 			y1 = (y * desk_h) / Scr.VHeight;
 			if (!use_no_separators)
+			{
 				XDrawLine(
 					dpy,Desks[desk].w,Desks[desk].DashedGC,
 					x1,y1,x2,y1);
+			}
 			y += Scr.MyDisplayHeight;
 		}
 	}