Subject: FVWM: selective title bar buttons

From: Perry Hutchison <[email-masked]>
Date: Tue, 12 Nov 2002 11:42:55 -0800 (PST)

Is it possible, in 2.2.4 (Red Hat 6.2), to bind a titlebar button
to only some windows?  The impression I get from the manpage is
that the Mouse command applies to all windows.

Specifically, I'd like to define a button 0 action on "xpdf" windows,
without causing button 0 to appear on all the other windows.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Tue, 12 Nov 2002 21:58:01 +0100 (CET)

> without causing button 0 to appear on all the other windows.

You can use the Styles "Button, NoButton"

Like this:

Mouse 0 ...
Mouse 1 ...
<and so on...>

# no window get button 0 
Style * NoButton 0
# turn on button 0 for only xpdf
Style xpdf Button 0

//Marcus