Subject: FVWM: Blue PNGs

From: Dorothy Robinson <[email-masked]>
Date: Thu, 28 Nov 2002 23:04:24 -0800

Hi,

I've just compiled fvwm-2.5.4 on sparc/solaris, partly because I'm
playing with the latest Gnome beta, and its apps close to those
translucency-endowed png bitmaps. But fvwm doesn't render the PNGs
right - they're in shades of blue, the translucent areas are completely
absent, there are weird offsets and splashes of yellow where they don't
belong.

I've tried compiling with two different versions of libpng (1.0.12 that
came with Gnome, and 1.2.4) and it doesn't make any difference.  Also,
the Gimp that I compiled with the very same libraries has no
trouble with the PNGs.  Has anyone seen this before?

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Dorothy Robinson
http://www.twobarleycorns.net

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Nov 2002 12:39:33 +0000

> trouble with the PNGs.  Has anyone seen this before?

There was such color conversion for png, but it was fixed in 2.5.2.

As for transparency/translucency, it all depends on where you try to
apply the png images. If there is no good background to be used as the
basis of png, libpng can't be informed to use translucency.
It may require some preparations.

Please send the relevant configuration and png files, or put them on the
web. Then maybe some suggestions are possible.

Regards,
Mikhael.

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 29 Nov 2002 14:50:43 +0100

> trouble with the PNGs.  Has anyone seen this before?

There is probably a bug in 2.5.x for rendering images on a
machine with bigendian byte ordering (and no XRender ?).

Can you see the following line just after png configure check:

  checking whether byte ordering is bigendian... yes

when you run ./configure?

Also, as you run Solaris I imagine that at the end of configure
you can see:

  With Xrender image support?         no: ...

yes?

Regards, Olivier

---

From: Dorothy Robinson <[email-masked]>
Date: Fri, 29 Nov 2002 12:08:27 -0800

I'm attaching the configure log.  It did check for bigendian byte ordering
after looking for png, or at least it says it did.  And yes, we have no
Xrender. (Is it for XFree86 only?  Anyway I think rendering would cause an
unacceptable performance hit on my poor little 330 MHz ultrasparc.)

Regards,
Dorothy

Olivier Chapuis wrote:

> .

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Dorothy Robinson
http://www.twobarleycorns.net
checking for a BSD-compatible install... /usr/local/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable command logging... no
checking whether to enable debugging messages... no
checking whether to enable fancy pixmap titlebars... yes
checking imagepath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for strerror in -lcposix... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... no
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking for X... libraries /usr/openwin/lib, headers /usr/openwin/include
checking whether -R must be followed by a space... no
checking for gethostbyname... no
checking for gethostbyname in -lnsl... yes
checking for connect... no
checking for connect in -lsocket... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking build system type... sparc-sun-solaris2.8
checking host system type... sparc-sun-solaris2.8
checking whether to enable GNOME window manager hints... yes
checking whether to enable Extended WM Hints Support... yes
checking for SmcOpenConnection in -lSM... yes
checking for XShapeQueryExtension in -lXext... yes
checking for XineramaIsActive in -lXinerama... no
checking whether to enable Xinerama emulation on one screen (useful only for developers)... no
checking for XRenderComposite in -lXrender... no
checking for freetype-config... /usr/gnome/bin/freetype-config
checking for FreeType - version >= 6.1.0... yes
checking for fontconfig-config... no
checking for Fontconfig - version >= 1.0.1... no
checking for XftFontOpen in -lXft... no
checking for XpmReadFileToXpmImage in -lXpm... yes
checking X11/xpm.h usability... yes
checking X11/xpm.h presence... yes
checking for X11/xpm.h... yes
checking for Xpm 3.4g or better... yes
checking for png_read_info in -lpng... yes
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for libpng 1.0.4a or better... yes
checking whether byte ordering is bigendian... yes
checking for rplay_create in -lrplay... yes
checking rplay.h usability... yes
checking rplay.h presence... yes
checking for rplay.h... yes
checking for stroke_init in -lstroke... no
checking with termcap... checking for readline in -lreadline... yes
checking readline/history.h usability... yes
checking readline/history.h presence... yes
checking for readline/history.h... yes
checking for _Xsetlocale in -lX11... no
checking for XOpenOM in -lX11... yes
checking for libiconv_open in -liconv... no
checking for iconv_open... yes
checking check if second arg of iconv is const... yes
checking for nl_langinfo (CODESET)... yes
checking for fribidi-config... no
checking stdarg.h usability... yes
checking stdarg.h presence... yes
checking for stdarg.h... yes
checking for vfprintf... yes
checking for waitpid... yes
checking for cpp... /usr/local/bin/cpp
checking for a BSD-compatible install... /usr/local/bin/install -c
checking whether ln -s works... yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... ranlib
checking for perl... /usr/local/bin/perl
checking for perl 5.002 or better... yes
assuming /usr/local/bin/perl as perl location
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for stdlib.h... (cached) yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking malloc.h usability... yes
checking malloc.h presence... yes
checking for malloc.h... yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for unistd.h... (cached) yes
checking getopt.h usability... no
checking getopt.h presence... no
checking for getopt.h... no
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/systeminfo.h usability... yes
checking sys/systeminfo.h presence... yes
checking for sys/systeminfo.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for gcc option to accept ANSI C... none needed
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for off_t... yes
checking for pid_t... yes
checking for size_t... yes
checking whether time.h and sys/time.h may both be included... yes
checking return type of signal handlers... void
checking for working alloca.h... yes
checking for alloca... yes
checking for strftime... yes
checking whether setpgrp takes no argument... yes
checking for gettimeofday... yes
checking for mkfifo... yes
checking for putenv... yes
checking for setvbuf... yes
checking for socket... no
checking for waitpid... (cached) yes
checking for strdup... yes
checking for strstr... yes
checking for strtol... yes
checking for memmove... yes
checking for memcpy... yes
checking for strchr... yes
checking for sysconf... yes
checking for uname... yes
checking for div... yes
checking for sigaction... yes
checking for siginterrupt... yes
checking for getpwuid... yes
checking for setpgrp... yes
checking for setpgid... yes
checking for sig_atomic_t... yes
checking whether setvbuf arguments are reversed... no
checking for select... yes
checking for unistd.h... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for sys/select.h... (cached) yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking argument types of select()... select(int,fd_set *,...)
checking for gethostname... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for strdup... (cached) yes
checking for strerror... yes
checking for usleep... yes
checking for atexit... yes
checking for gtk-config... /usr/local/bin/gtk-config
checking for GTK - version >= 1.1.0... yes
checking for imlib-config... /usr/local/bin/imlib-config
checking for GDK IMLIB - version >= 1.8.0... yes
checking for gnome-config... no
checking for gnomeConf.sh file in /usr/local/lib... not found
configure: creating ./config.status
config.status: creating Makefile
config.status: creating libs/Makefile
config.status: creating fvwm/Makefile
config.status: creating modules/Makefile
config.status: creating fvwm/fvwm.1
config.status: creating bin/Makefile
config.status: creating bin/fvwm-config
config.status: creating bin/fvwm-bug
config.status: creating bin/fvwm-perllib
config.status: creating bin/fvwm-menu-xlock
config.status: creating bin/fvwm-menu-directory
config.status: creating bin/fvwm-menu-desktop
config.status: creating bin/fvwm-menu-headlines
config.status: creating bin/fvwm-convert-2.4
config.status: creating bin/fvwm-convert-2.6
config.status: creating utils/Makefile
config.status: creating perllib/Makefile
config.status: creating perllib/General/Makefile
config.status: creating perllib/FVWM/Makefile
config.status: creating perllib/FVWM/Module/Makefile
config.status: creating perllib/FVWM/Module.pm
config.status: creating rpm/Makefile
config.status: creating rpm/fvwm.spec
config.status: creating docs/fvwm.lsm
config.status: creating docs/Makefile
config.status: creating sample.fvwmrc/Makefile
config.status: creating tests/Makefile
config.status: creating modules/FvwmAnimate/Makefile
config.status: creating modules/FvwmAuto/Makefile
config.status: creating modules/FvwmBacker/Makefile
config.status: creating modules/FvwmBanner/Makefile
config.status: creating modules/FvwmButtons/Makefile
config.status: creating modules/FvwmCommand/Makefile
config.status: creating modules/FvwmCommand/scripts/Makefile
config.status: creating modules/FvwmConsole/Makefile
config.status: creating modules/FvwmConsole/FvwmConsoleC.pl
config.status: creating modules/FvwmCpp/Makefile
config.status: creating modules/FvwmDebug/Makefile
config.status: creating modules/FvwmDebug/FvwmDebug
config.status: creating modules/FvwmDebug/FvwmGtkDebug
config.status: creating modules/FvwmDragWell/Makefile
config.status: creating modules/FvwmEvent/Makefile
config.status: creating modules/FvwmForm/Makefile
config.status: creating modules/FvwmIconBox/Makefile
config.status: creating modules/FvwmIconMan/Makefile
config.status: creating modules/FvwmIdent/Makefile
config.status: creating modules/FvwmM4/Makefile
config.status: creating modules/FvwmPager/Makefile
config.status: creating modules/FvwmPerl/Makefile
config.status: creating modules/FvwmPerl/FvwmPerl
config.status: creating modules/FvwmRearrange/Makefile
config.status: creating modules/FvwmSave/Makefile
config.status: creating modules/FvwmSaveDesk/Makefile
config.status: creating modules/FvwmScript/Makefile
config.status: creating modules/FvwmScript/Scripts/Makefile
config.status: creating modules/FvwmScript/Widgets/Makefile
config.status: creating modules/FvwmScroll/Makefile
config.status: creating modules/FvwmTaskBar/Makefile
config.status: creating modules/FvwmTheme/Makefile
config.status: creating modules/FvwmWharf/Makefile
config.status: creating modules/FvwmWinList/Makefile
config.status: creating modules/FvwmGtk/Makefile
config.status: creating config.h
config.status: executing default-1 commands

FVWM Configuration:

  Version:     2.5.4

  Executables: /usr/local/bin
  Man pages:   /usr/local/man
  Modules:     /usr/local/libexec/fvwm/2.5.4
  Data files:  /usr/local/share/fvwm
  Perl lib:    /usr/local/share/fvwm/perllib

  With Asian bi-direct. text support? no: No fribidi-config found in PATH
  With Extended Window Manager Hints? yes
  With GNOME Window Manager Hints?    yes
  With GTK+ required for FvwmGtk?     yes
  With GDK image support in FvwmGtk?  yes
  With GNOME libs support in FvwmGtk? no: Can't find working gnome-config
  With PNG image support?             yes
  With ReadLine sup. in FvwmConsole?  yes
  With RPlay support in FvwmEvent?    yes
  With Shaped window support?         yes
  With Session Management support?    yes
  With Mouse strokes (gestures)?      no: Can't find working libstroke
  With Xinerama multi-head support?   no: Failed to detect libXinerama
  With Xft anti-alias font support?   no: Failed to detect Xft 1 or Xft 2 and fontconfig
  With XPM image support?             yes
  With Xrender image support?         no: Failed to detect libXrender

See INSTALL.fvwm for the description of what this may mean.