Subject: FVWM: FvwmIconBox scrollbars broken since 2.4.8

From: Harald van Pee <[email-masked]>
Date: Tue, 12 Nov 2002 17:25:33 +0100

Hi,

I use FvwmIconBox. With 2.2.x everything is o.k.,
with 2.4.3 also,

but at least since 2.4.8 and still with 2.4.13
the scrollbars are not redrawn if an other windows covers it.

I have made no changes at the configuration, only installed a new fvwm2 
version! I use XFree86 Version 4.1.

Whats wrong?

Regards
Harald
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 12:43:05 +0100

> version! I use XFree86 Version 4.1.

Can you  provide a minimal config that shows the problem for you?

Bye

Dominik ^_^  ^_^

---

From: Harald van Pee <[email-masked]>
Date: Wed, 13 Nov 2002 13:48:16 +0100

> Can you  provide a minimal config that shows the problem for you?

Thats a good idea, and I have found the problem,

its the line:

Style  "*"  BackingStore

In general I don't need this Option because I use it in the X-Configuration 
(its necessary for some programs which I use [paw and root]). But for some 
graphics drivers its not enough and I need the option also in the .fvwm2rc 
file. 
I'm sure that it makes no differences for fvwm 2.2.4 w.r.t. FvwmIconBox, but I 
can't say if the problem is not seen in 2.4.3 because I'm start using this 
option a short while ago.

Any idea whats going on? Or a general solution?

Thanks
Harald

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 14:54:55 +0100

> Thats a good idea, and I have found the problem,

Does this line cause the problem or fix it?

> Any idea whats going on? Or a general solution?

I am aware that there are some problems with backing store, but we
were never able to pin them down (and I still can't reproduce your
problem).  We had numerous reports of window parts not getting
drawn, in various applications, but I could not pin down a single
one.  It seems that under certain circumstances *some* X servers
do not always generate an Expose event when necessary.  Thus,
applications do not redraw themselves when they should.  I am
still missing a way to see that myself and to find out what fvwm
might be doing to expose this bug (I think it's an X bug).

Bye

Dominik ^_^  ^_^

---

From: Harald van Pee <[email-masked]>
Date: Wed, 13 Nov 2002 15:22:55 +0100

The option 
Style  "*"  BackingStore
cause the bug!

I have tried some differenent configurations, its always the same behaviour!
I use SuSE Linux 7.0 with suse kernel 2.2 and XFree4.1.0

Maybe I can check it with XFree 4.2 in a couple of weeks.

On Wednesday 13 November 2002 14:54, you wrote:
> > > > I have made no changes at the configuration, only installed a new
> > > > fvwm2 version! I use XFree86 Version 4.1.
> > > >
> > > > Whats wrong?
> > >
> > In general I don't need this Option because I use it in the
> > X-Configuration (its necessary for some programs which I use [paw and
> > root]). But for some graphics drivers its not enough and I need the
> > option also in the .fvwm2rc file.
> > I'm sure that it makes no differences for fvwm 2.2.4 w.r.t. FvwmIconBox,
> > but I can't say if the problem is not seen in 2.4.3 because I'm start
> > using this option a short while ago.
> >

-- 
Harald van Pee

Helmholtz-Institut fuer Strahlen- und Kernphysik der Universitaet Bonn
Nussallee 14-16 - 53115 Bonn - Tel +49-228-732213 - Fax +49-228-732505
mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ben Winslow <[email-masked]>
Date: Wed, 13 Nov 2002 16:07:19 -0500

Dominik Vogt wrote:
[snip]
> might be doing to expose this bug (I think it's an X bug).

I have backing store support enabled (but only a window or two with that 
style forced), and since I've turned it on, I've noticed that the root 
window will not always be redrawn when switching from the console to 
X--I'm voting for the X bug theory.

XFree86 version: 4.2.1
screen #0:
   options:    backing-store YES, save-unders YES

fvwm 2.5.4 (from cvs) compiled on Oct 21 2002 at 22:33:57
with support for: ReadLine, XPM, PNG, GNOME WM hints, EWMH hints, Shape, 
SM, Xinerama, XFT

(but I think the fvwm version is irrelevant)

-- 
Ben