Subject: Re: FVWM: Fvwm on a laptop: setting my physical screen resolution?

From: Tessa Lau <[email-masked]>
Date: Mon, 11 Nov 2002 11:24:11 -0500

> Try adding
>   Style * NoPPosition, NoTransientPPosition

Excellent!  This seems to do the trick.

Now, another question... Can I cause these commands to be loaded into
a running fvwm, from the command line?  I have a shell script that runs
every time I undock the laptop, and I'd like that script to tell fvwm to
reconfigure itself appropriately.

Thanks,
--Tessa
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Nov 2002 17:42:06 +0100

> reconfigure itself appropriately.

Yes, no problem.  Start the FvwmCommandS module in your config file:

  AddToFunc StartFunction
  + I Module FvwmCommandS

This enables a shell interface to fvwm.  On the command line, type

  $ FvwmCommand "Style * NoPPosition, NoTransientPPosition"

(the command has to be put in double quotes).  Of course you can
type them into the FvwmConsole module window or put them into a
menu too.  For example:

  AddToMenu some_menu
  + dock Function dock_machine
  + undock Function un_dock_machine

  AddToFunc dock_machine
  + I Style * NoPPosition, NoTransientPPosition
  + I EwmhBaseStruts 0 rrr 0 bbb
  ...

  AddToFunc undock_machine
  + I Style * UsePPosition, UseTransientPPosition
  + I EwmhBaseStruts 0 0 0 0
  ...

(note that I renamed EWMHBaseStrut to EwmhBaseStruts in the latest
development code.  The old name is no longer supported.)

Bye

Dominik ^_^  ^_^