Subject: Re: FVWM: Control + Left mouse kills application in Windows style.

From: Dan Espen <[email-masked]>
Date: Fri, 08 Nov 2002 10:41:08 -0500

"subbiah .L" <[email-masked]> writes:
> Dear Mr. Dan,
> 
> Thanks or your help.
> 
> I will put the issue in Clear picture.
> 
> I have create a Main Widget class and over it I have created a Main Form. 
> Now I have set the Main form as a Work_Region on the Main Widget class. I am 
> creating a small push button and a Label message over this Main Form.
> 
> I am holding the Control Key and clicking my Left mouse button on the Push 
> Button (The Area covered by the Button widget ) or Even on the Area covered 
> by the Label Widget, Nothing is happening.
> 
> But if I clicked on the Main Form (Free area, not covered by any of the 
> widget), the motif application is giving me segmentation fault error.
> 
> I have tried the suggession given by you in the .fvwmrc file. Still I am 
> facing the problem. Is it problem with the Motif application?.
> 
> I am using fvwm 2.4.3 version.
> 
> Can you Please help me?

The areas you are clicking on are not part of Fvwm.
Fvwm will not cause a segmentation violation in your application.
Fvwm does not interfere with clicks made in your application.

It sounds like you have a problem in your Motif application.
You should look for the core file, and use a debugger to find
out what the problem is.

-- 
Dan Espen                           E-mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "subbiah .L" <[email-masked]>
Date: Fri, 08 Nov 2002 10:38:06 +0530

----Original Message Follows----
From: Dan Espen <[email-masked]>
To: "subbiah .L" <[email-masked]>
CC: [email-masked]
Subject: Re: FVWM: Control + Left mouse kills application in Windows style.
Date: Wed, 06 Nov 2002 13:40:10 -0500

"subbiah .L" <[email-masked]> writes:
 > Hello,

   You've put your reply at the top, making this whole thing very hard to
read and understand.  Please try not to do that.

 > I have customized the fvwm2rc file and checked for the Close/ Destroy/
 > Delete options. I have commented all these options in the 
$HOME/.fvwm/xxxx
 > files (Created by the Windows 95 setup & Customized by me).  When 
analyzing,
 > I found that, If I Right clicked with Control Key on the Motif 
application
 > with a Frame, with out any Widget space( The Frame's Free space even I 
had
 > widget in some other location in the Frame). I have changed the Style 
from
 > Windows 95 to Motif style. Still I am facing the issue.

I can't figure out from the above where you are clicking.

I can't figure out which button you are using either.
In the subject line it says "left mouse" and above it says
"right clicked".

Since you can't seem to find where the mouse binding is,
perhaps you should just override it.

The border fvwm puts around a window has 2 separate parts,
the frame which is the corners, and the sides.

To create a mouse binding for the corners, add this to the end of your
.fvwm2rc:

Mouse 1 F C Menu Move-or-raise

To create a mouse binding for the top/bottom and sides of the border
use this:

Mouse 1 S C Menu Move-or-raise

Replace "Menu Move-or-raise" with what you want Fvwm to do.

To just remove the binding, do this:

Mouse 1 S C -

 > I found that this issue is not present in fvwm 1.24r version ( I tried 
with
 > Motif style)
 >
 > Can any one help me to found the Exact issue.
 >
 > With Thanks and Regards,
 > L. Subbiah
-- Old Message deleted ---
--
Dan Espen                           E-mail: [email-masked]

Dear Mr. Dan,

Thanks or your help.

I have create a Main Widget class and over it I have created a Main Form. 
Now I have set the Main form as a Work_Region on the Main Widget class. I am 
creating a small bush button and a Label message over this Main Form.

I am holding the Control Key and clicking my Left mouse button on the Bush 
Button (The Area covered by the Button widget ) or Even on the Area covered 
by the Label Widget, Nothing is happening.

Can you Please help me?

Thanks in Advance.

With Regards,
L. Subbiah

_________________________________________________________________
The new MSN 8: smart spam protection and 2 months FREE*  
http://join.msn.com/?page=features/junkmail