Subject: FVWM: moving xmms around the screen

From: Denis Perelyubskiy <[email-masked]>
Date: Fri, 8 Nov 2002 13:31:54 -0800

Hello,

I think I had a configuration where I could move xmms around
the screen by simply clicking in its window and moving it.
This is with an "Easy Move" option turned on.

However, now I cant seem to be able to do this, and I
suspect that I screwed up my Style options for xmms somehow.
Or something. Right now, as I have NoTitle, the only way for
me to move xmms is to use my Window-Ops::Move menu. Its
fine, just a little annoying ;)

Could someone who has this working share their xmms
style please?

I am running 2.5.x + xmms 1.2.7
My style is as follows:

   Style xmms          UseUSPosition, UsePPosition
   Style xmms          BorderWidth 0, Handles, HandleWidth 1, NoTitle

thanks.

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 08 Nov 2002 17:06:28 -0500

>    Style xmms          BorderWidth 0, Handles, HandleWidth 1, NoTitle

Hmm,  I see an  "easy move"  option associated  with control-e,  but I
don't seem to  get anything out of selecting  it.  Why don't you solve
this for all windows?  Here, try some of my bindings:

# Button 2 with Meta, moves window:
Mouse 2         W       M       Move
# F7 with Meta moves window:
Key F7		A	M	Move

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Denis Perelyubskiy <[email-masked]>
Date: Fri, 8 Nov 2002 18:46:53 -0800

>> This is with an "Easy Move" option turned on.
  [...]
  >Hmm,  I see an  "easy move"  option associated  with
  >control-e,  but I don't seem to  get anything out of
  >selecting  it.  Why don't you solve this for all windows?
  >Here, try some of my bindings:
  >

While this does not solve my problem, this is a great
suggestion. I can get used to this quickly :-)

thanks, Dan.

denis

---

From: Andrew Haninger <[email-masked]>
Date: Fri, 08 Nov 2002 23:11:30 +0000

> Could someone who has this working share their xmms
Well, mine is as follows:

Style XMMS* Sticky, NoTitle, StaysOnTop, NoHandles, BorderWidth 0, Icon,
GNOMEIgnoreHints

However, I found that I'm unable to move the xmms window if I check "Do
not hide windowmanager decorations. You might check to make sure that
this is unchecked. It's on the bottom left side under Preferences |
Options.

HTH.

-Andy

---

From: Denis Perelyubskiy <[email-masked]>
Date: Fri, 8 Nov 2002 20:44:58 -0800

>this is unchecked. It's on the bottom left side under Preferences |

Ah, yes! that's what it was, thanks. I still like Dan's
suggestion about moving all windows in a similar manner, but
this is exactly what I was looking for. 

thanks again.

denis

---

From: Erik Steffl <[email-masked]>
Date: Sat, 09 Nov 2002 01:21:46 -0800

> This is with an "Easy Move" option turned on.

   isn't this function of xmms, independent of window manager?

   btw I found the fourth mouse button to be perfect for this - I 
configure it to move windows or resize windows with windows key pressed...

	erik

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 9 Nov 2002 11:49:25 +0000

>    Style xmms          BorderWidth 0, Handles, HandleWidth 1, NoTitle

Do you have by a chance this line:

  Style * FixedPPosition

Without letting xmms to fiddle with program specified possition it
can't move itself.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 9 Nov 2002 11:57:49 -0800

>Without letting xmms to fiddle with program specified possition it

no, I dont have the line. it All had to do with this
"Do not hide windowmanager decorations" option being
checked, as suggested by Andrew. I have no idea what it
really does, or how it does it, but after I changed the
value of this option, things started working. Although, by
this time I've been moving windows around the screen using
alt-mouse2, but for xmms this is still a welcome solution :-)

thanks for the suggestion though.

denis

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 9 Nov 2002 11:58:44 -0800

[...]

I dont know, but Mikhael's mail seems to suggest that its
not entirely true, as FixedPPosition could disable this as
well.. I haven't tried it..

denis