Subject: FVWM: Key bindings not working

From: Tim Hanson <[email-masked]>
Date: Thu, 28 Nov 2002 11:40:52 -0800

My root window key bindings have never worked.  This is the set of bindings 
currently shipped with SuSE, with the exception of PointerKey instead of Key, 
because I'm using SloppyFocus.  These bindings didn't work with Key either. 
Mouse bindings work fine.

I looked at the header file for keys, also.

What else would affect these?

PointerKey	Left	A	SM	Scroll -100 +0
PointerKey	Left	A	C	CursorMove -1 0
PointerKey	Left	A	SC	CursorMove -10 +0

PointerKey	Right	A	SM	Scroll +100 +0
PointerKey	Right	A	C	CursorMove +1 0
PointerKey	Right	A	SC	CursorMove +10 +0

PointerKey	Up	A	SM	Scroll +0 -100
PointerKey	Up	A	C	CursorMove +0 -1
PointerKey	Up	A	SC	CursorMove +0 -10

PointerKey	Down	A	SM	Scroll +0 +100
PointerKey	Down	A	C	CursorMove +0 +1
PointerKey	Down	A	SC	CursorMove +0 +10

PointerKey	F1	A	M	Menu	Work_menu268popup	Nop
PointerKey	F2	A	M	WindowList
PointerKey	F3	A	M	Menu	SuSE0popup	Nop
PointerKey	F4	A	M	Iconify
PointerKey	F5	A	M	Move
PointerKey	F6	A	M	Resize
PointerKey	F7	A	M	Raise
PointerKey	F8	A	M	Lower
PointerKey	F9	A	M	Delete
PointerKey	F10	A	M	Destroy

PointerKey	F11	A	M	Prev [*] focus
PointerKey	F12	A	M	Next [*] focus
PointerKey	Tab	A	4	Next [*] focus
PointerKey	Tab	A	S4	Prev [*] focus

PointerKey	F3	A	SM	Maximize
PointerKey	F4	A	SM	Stick
PointerKey	F5	A	SM	Refresh

PointerKey	BackSpace	A	SM	Function "QuitSave"

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 28 Nov 2002 14:06:21 -0800

Tim Hanson wrote:
> My root window key bindings have never worked.  This is the set of 
> bindings currently shipped with SuSE, with the exception of PointerKey 

   numLock? see faq

	erik

---

From: [email-masked]
Date: Thu, 28 Nov 2002 22:30:49 +0100

On Thu, Nov 28, 2002 at 11:40:52AM -0800, Tim Hanson wrote:
> currently shipped with SuSE, with the exception of PointerKey instead of 
> Key, because I'm using SloppyFocus.  These bindings didn't work with Key 
> either. Mouse bindings work fine.
> 

Whether the num-lock, scroll-lock is pressed.  See question 0.1
in the FAQ.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].