Subject: FVWM: FvwmButtons ...How do I get 3 rows?

From: Rick Jones <[email-masked]>
Date: Mon, 25 Nov 2002 20:03:23 -0500 (EST)

For some reason my FvwmButtons won't create 3 rows. 
I've tried 

*FvwmButtons: Rows 3
and 
*FvwmButtonsRows 3

My version is 2.4.7

Rick

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 26 Nov 2002 10:46:36 +0100

> For some reason my FvwmButtons won't create 3 rows. 

This works:

  *FvwmButtons: Rows     3
  *FvwmButtons: Columns  60
  *FvwmButtons: BoxSize  fixed

Bye

Dominik ^_^  ^_^

---

From: Rick Jones <[email-masked]>
Date: Tue, 26 Nov 2002 12:05:21 -0500 (EST)

I tried it here at work.. but I've noticed it's REALLY
flaky... the settings you gave me didn't work.. (just
like FvwmIconMan doesn't work).  I'll try it at home
where I have 2.4.13 - it's the one that REALLY matters
anyway ;-).

Thanks.
Rick

 --- Dominik Vogt <[email-masked]> wrote: > On Mon, Nov
25, 2002 at 08:03:23PM -0500, Rick Jones
> wrote:

---

From: Dan Espen <[email-masked]>
Date: Tue, 26 Nov 2002 12:32:16 -0500

> where I have 2.4.13 - it's the one that REALLY matters

Maybe you should repost the config you are using.
The one from a few days ago seems to be full of problems.
When fvwm read this in, there were probably a load of error
messages being printed on Fvwm's stderr.
You should strive to eliminate all errors too.

Heres your config from a few days ago with some notes:

> #Test Buttonbar

Always start with:

DestroyModuleConfig FvwmButtons:*

that way if you re-read the config its always clean.

> *FvwmButtonsGeometry 800x100-1-1

Use the newer format with the colon:

*FvwmButtons: Geometry 800x100-1-1

its easier to read.

> *FvwmButtonsButtonGeometry 32x32
> #*FvwmButtonsBoxSize dumb

Remove all commented out lines, its easier for us to read.

> *FvwmButtonsBack bisque3
> *FvwmButtonsRows3

The space before the 3 is missing.

> *FvwmButtonsColumns 24
> #*FvwmButtons(Frame 2 Padding 0 0 Container(Rows 3
> Columns 10 Frame 1 \
>                                            Padding 10
> 0))

This looks like its meant to be a continued line, but the
first line is commented out.  The remaining lines should be causing errors.

> #*FvwmButtons(3x2 Frame 2 Swallow "FvwmIconBox"
> "Module FvwmIconBox")

same here.

> *FvwmButtons(6x2 Swallow "FvwmIconMan" "Module
> FvwmIconMan")

Continued lines need a backslash...see more below.

> *FvwmButtons(3x2 Swallow(UseOld) "FvwmPager" "Module
> FvwmPager 0 0")
> *FvwmButtons(2x2 Frame 2 Swallow(UseOld) "wmmp3" `Exec
> exec wmmp3`)
> #*FvwmButtons(1x2 Frame 0 Container(Rows 2 Columns 2
> Frame 0))
> #*FvwmButtons(Frame 2 Swallow(UseOld,NoHints,Respawn)
> "xbiff" `Exec exec xbiff -bg bisque3`)
> *FvwmButtons(2x2 Swallow(UseOld,NoHints,Respawn)
> "xclock" `Exec exec xclock -bg bisque3 -fg black -hd
> black -hl black -padding 0`)
> *FvwmButtons(2x2 Swallow(UseOld,NoHints,Respawn)
> "xload" `Exec exec xload -bg bisque3 -fg black
> -nolabel`)
> *FvwmButtons(End)
> *FvwmButtons(End)
				   
-- 
Dan Espen                           E-mail: [email-masked]

---

From: Rick Jones <[email-masked]>
Date: Wed, 27 Nov 2002 10:48:35 -0500 (EST)

I finally got to working on this at home.  This
solution worked well.  Thanks, Dominik.  I still think
my fvwm that came with my RH7.3 installlation at work
is flaky.  Or maybe the .fvwm2rc that RedHat provides
is trash.  I'll try this new config at work and let
you know.

Rick