Subject: FVWM: bug in fvwm-2.4.13 ??

From: Peter Breitenlohner <[email-masked]>
Date: Thu, 21 Nov 2002 18:22:48 +0100 (CET)

Hi,

I recently built and installed fvwm-2.4.13 (on i686-linux-gnu), upgrading
from 2.4.7. Almost everything works fine,

BUT: after a fvwm-restart all icons are in front of all windows, AND raising
a window does NOT bring the window in front of the icons. The only remedy I
found was to deiconify+iconify all icons. The config file is unchanged!

Is this problem known?
Any chance to get it fixed soon?

Please reply directly to me, I am not on this list.

regards
Peter Breitenlohner <[email-masked]>

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 26 Nov 2002 14:22:55 -0500

> Please reply directly to me, I am not on this list.

I was able to reproduce the problem.
There were a few stacking code changes in
2.4.13, perhaps you should try 2.4.12 until this is fixed.
(Look under "older 2.xx. versions".)

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Peter Breitenlohner <[email-masked]>
Date: Tue, 26 Nov 2002 20:33:03 +0100 (CET)

> (Look under "older 2.xx. versions".)

Hi Dan,
thanks for your reply.

I can actually live with the problem; after all 'fvwm restart' isn't done
too frequently, basically only if something hangs.

Any idea how soon this will be fixed (and the next version released)?

regards

---

From: [email-masked]
Date: Thu, 28 Nov 2002 23:29:56 +0100

> Any idea how soon this will be fixed (and the next version released)?

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 29 Nov 2002 10:02:45 -0500

> > Any idea how soon this will be fixed (and the next version released)?

Dominik,

I guess you haven't committed the fix yet?

When you do, would you like me to test it and then create 2.4.14?

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 29 Nov 2002 16:19:38 +0100

> I guess you haven't committed the fix yet?

I see.  I only committed my changes to the dev branch yesterday.
Later.

> When you do, would you like me to test it and then create 2.4.14?

Yes, that would help a lot.  We spend too little time testing the
stable branch before the releases.

Bye

Dominik ^_^  ^_^