Subject: FVWM: trouble using AspectPixmap ...

From: Cameron Simpson <[email-masked]>
Date: Wed, 27 Nov 2002 14:43:11 +1100

Annoyingly, this seemed to work yesterday :-(
I'm using 2.5.4, full colour display.

I have the following base menu config:

	Colorset 2      fg rgb:90/ff/ff, bg rgb:00/00/20
	MenuStyle "*"   AutomaticHotkeys, Animation, SeparatorsShort, TrianglesRelief, BorderWidth 0, \
			HiLight DeepSkyBlue, Shadow paleblue, \
			MenuColorset 2

That all seems good.

Now, I have a menu-backdrop chooser that says:

	ColorSet 2 plain, bg darkgreen, Tint cyan 50, Alpha 70, AspectPixmap "/path/to/thing.png"

The "bg darkgreen" is a debugging setting to make sure the command got applied.
Anyway, the backdrop pixmap never seems to be applied.
Am I doing something obviously wrong here?
Maybe reapply the MenuColorset?

Also, my final design probably wants to look like this:

	Colorset 2      fg rgb:90/ff/ff, bg rgb:00/00/20
	Colorset 3      fg yellow, bg rgb:00/00/50
	Colorset 4      fg darkgray, bg black
	MenuStyle "*"   AutomaticHotkeys, Animation, SeparatorsShort, TrianglesRelief, BorderWidth 0, \
                	HiLight DeepSkyBlue, Shadow paleblue, \
			MenuColorset 2, ActiveFore, HilightBack, ActiveColorset 3, GreyedColorset 4

I presume I'll have to apply the AspectPixmap to all three colorsets, or
maybe discard them and just use one colorset?
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

I'm never going mountaineering with you again.
	- Kobus Barnard <[email-masked]> in rec.climbing,
	  on things he's heard firsthand
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 27 Nov 2002 21:28:49 +1100

On 14:43 27 Nov 2002, IPM Return requested <[email-masked]> wrote:
| Annoyingly, this seemed to work yesterday :-(

Even more annoyingly, it's working fine now.
I'm at home, on a different machine, but it's the same fvwm.
Hmm. I'll try it again at work tomorrow and see what's up.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 27 Nov 2002 10:31:18 +0000

> 			HiLight DeepSkyBlue, Shadow paleblue, \

This is not good, please take a look at your X output.
There are no such MenuStyle options "HiLight" and "Shadow".

> Am I doing something obviously wrong here?

Works fine for me.

> Maybe reapply the MenuColorset?

You don't need to reapply MenuStyle. Colorsets start to work in all places
where defined in the moment you change them.

> maybe discard them and just use one colorset?

Define all three, but first clean it, remove "HiLight" and "Shadow" as
unexisting options and define shadow colors (sh, hi, fgsh) in colorsets
if needed.

Only the first colorset uses AspectPixmap, other two do not use any
images, so if you define AspectPixmap there, it is ignored.

There may be currently some problems with the new functionality.
For example if you define any *Alpha in the greyed colorset, its
background becomes black until Restart, so just don't do it for now.

Regards,
Mikhael.

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 27 Nov 2002 22:14:40 +1100

Bearing in mind this seems to be working here at home,
further investigation at work tomorrow:-(

On 10:31 27 Nov 2002, Mikhael Goikhman <[email-masked]> wrote:
| > 	Colorset 2      fg rgb:90/ff/ff, bg rgb:00/00/20
| > 	MenuStyle "*"   AutomaticHotkeys, Animation, SeparatorsShort, TrianglesRelief, BorderWidth 0, \
| > 			HiLight DeepSkyBlue, Shadow paleblue, \
| > 			MenuColorset 2
| > That all seems good.
| This is not good, please take a look at your X output.
| There are no such MenuStyle options "HiLight" and "Shadow".

Doh. Right, adjusted per your "sh, hi" remarks below.

| > I presume I'll have to apply the AspectPixmap to all three colorsets, or
| > maybe discard them and just use one colorset?
| Define all three, but first clean it, remove "HiLight" and "Shadow" as
| unexisting options and define shadow colors (sh, hi, fgsh) in colorsets
| if needed.
| Only the first colorset uses AspectPixmap, other two do not use any
| images, so if you define AspectPixmap there, it is ignored.

Noted. Done.

| There may be currently some problems with the new functionality.
| For example if you define any *Alpha in the greyed colorset, its
| background becomes black until Restart, so just don't do it for now.

Ack.

Thanks,

We should measure progress not by how many laws can be passed but by how
little governing people need.	-- Don Baldwin <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Thu, 28 Nov 2002 10:05:34 +1100

On 22:14 27 Nov 2002, IPM Return requested <[email-masked]> wrote:
| Bearing in mind this seems to be working here at home,
| further investigation at work tomorrow:-(

And now it's working at work, too. :-(

My prime suspect here is ImageMagick's mogrify, which I'm using to
convert JPEGs to PNG. (I was doing the colouring with mogrify too,
which is why I wasn't using "djpeg | pnmtopng").

I've discovered that the RedHat version (5.3.8) dumps core on several
files.  After installing 5.5.1 it no longer dumps core, but does emit a
file whose name consists of random binary bytes instead of the supposed
"foo.PNG".

I've hacked my scripts to work around this latter:

	cp foo.jpg tmpdir/.
	cd tmpdir || exit 1
	mogrify -format PNG foo.jpg || exit 1
	rm -f foo.jpg
	mv ./* foo.PNG
	... tell fvwm to load the image ...

which is nice and robust.

And now it all seesms good. No troubles on the fvwm side at all.

Cheers,

Surely it was of this place, now Cambridge but formerly known by the name of
Babylon, that the prophet spoke when he said, 'the wild beasts of the desert
shall dwell there, and their houses shall be full of doleful creatures, and
owls shall build there, and satyrs shall dance there.'
	- Thomas Gray (1716-1771)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].