Subject: FVWM: FvwmTaskBar Action decoding

From: Kyle <[email-masked]>
Date: Tue, 12 Nov 2002 09:02:42 -0700

In FvwmTaskBar, does it decode double clicks on buttons?  The manual 
says "supported actions are: Click1, Click2, Click3 and so  on," but I'm 
not sure what the "so on" is.  Are there other actions besides the three 
single clicks?

I'm trying to do this:

*FvwmTaskBar:  Action Double1 Iconify

Thanks!

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Nov 2002 02:05:53 +0100

> not sure what the "so on" is.  Are there other actions besides the three 

  Click4, Click5, ...

That depends on the number of Mouse buttons that are compiled into
fvwm.  Double clicks are not supported.

> *FvwmTaskBar:  Action Double1 Iconify

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 13 Nov 2002 07:55:09 +0000

> *FvwmTaskBar:  Action Double1 Iconify

You may play with complex functions that have "M", "C" and "D", then you
may get double and triple clicks... Hovewer you should understand that the
first click is handled by FvwmTaksBar and the following ones are by fvwm.

Regards,
Mikhael.

---

From: Kyle <[email-masked]>
Date: Wed, 13 Nov 2002 09:56:25 -0700

>first click is handled by FvwmTaksBar and the following ones are by fvwm.
Hmm, I tried:

DestroyFunc Deiconify-Focus-Raise-or-Iconify
AddToFunc Deiconify-Focus-Raise-or-Iconify
+       I Iconify off
+       I Focus
+       I Raise
+      D Iconify on

*FvwmTaskBar:   Action Click1 Deiconify-Focus-Raise-or-Iconify

and fvwm locks up hard (except I still have cursor motion).  It appears 
that if I add any kind of context other than "I", fvwm locks up, even if 
the action is a Nop.

Kyle