Subject: Re: FVWM: Idea: Improved Window List Menu

From: Dominik Vogt <[email-masked]>
Date: Fri, 1 Nov 2002 15:59:54 +0100

On Fri, Nov 01, 2002 at 12:53:56AM -0500, Chris McCarthy wrote:
> 	I would like to tell you folks how much I support your efforts.
> FVWM Is an awesome system I have used for years & lets me have nearly identical
> desktops between my SUN desktop and my Linux laptop.   Also, I'm often amazed
> that some of the newer windowing systems don't easily allow draging a window
> from desktop to desktop, which FVWM has had all along!!
> 
> 	Now for my IDEA:  
> 	
> When I click right mouse button, I get a menu of all active windows.
> What I would like to do is allow this menu to be sorted according to
> the name of the window in 1 or 2 ways:
> 
> 1.)   All windows with the same file extension or same name (ie xterm, or 
> 	.c ) would be color-coded the same color.
> 	
> 2.) Even better, the menu would include submenus, ie all windows with file
> 	extensions ".c", then look under that list, etc.

What we really need is to allow calling an external program that
filters and sorts the windows and generates the labels of the menu
entries.

> Could these ideas be implemented in future (or present) versions of
> FVWM?

I can't promise how long it will take, but a generic soring
interface would save us a lot of future work.

> Sorry if this email is out of place, please do forward it
> to whomever.

New features are usually discussed on fvwm-workers, but it's not
a big deal.
 
> Also you folks should have a donations page!  If any FVWM developers/
> maintainers are in the Wash DC. area, let me know & I will buy them a
> beer.   Thanks so much,

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 1 Nov 2002 23:02:39 +0000

> Could these ideas be implemented in future (or present) versions of

Here is what is available now.

In 2.5.4 try either SortByResource or SortByClass options to WindowList.
The first one sorts xterms and rxvts separately, the second mixes them.

Richard Lister said he wrote a module that does a customized sorting,
maybe he may change it to create submenus instead. In any case this will
be available in one or another form in the next versions.

Regards,
Mikhael.