Subject: Re: FVWM: MouseFocusClickRaises and mouse bindings on lower windows

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 9 Nov 2002 19:29:36 -0800 (PST)

<<
When I rewrote the focus related options I could not avoid
changing the default behaviour in some situations.

Did you change the focus code that might fix 2.5.4's mishandling of xview
(eg textedit) windows? 

ie: Upon restart or some other fvwm activities (such as menus), xview
windows no longer accept (take) focus. It requires opening the window's menu
but not selecting anything from it for xview windows to take focus again.
Mailtool works fine tho somehow.

Lenience fixes this, but then the 1st click in the window isnt passed to the
window.

2.5.3 works fine.
clicktofocus mode

Thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Elliot Sowadsky <[email-masked]>
Date: Sat, 9 Nov 2002 19:58:32 -0800 (PST)

< When I rewrote the focus related options I could not avoid
< changing the default behaviour in some situations.
< >>
< 
< Did you change the focus code that might fix 2.5.4's mishandling of xview
< (eg textedit) windows?
< 
< ie: Upon restart or some other fvwm activities (such as menus), xview
< windows no longer accept (take) focus. It requires opening the window's menu
< but not selecting anything from it for xview windows to take focus again.
< Mailtool works fine tho somehow.
< 
< Lenience fixes this, but then the 1st click in the window isnt passed to the
< window.
< 
< 2.5.3 works fine.
< clicktofocus mode

Aha....only works on 2.5.3 cuz i changed focus.c in it.
Similarly changing 2.5.4 also fixes it.

// old	if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) &&  sf != NULL && sf->Desk == Scr.CurrentDesk)

	if (!FP_IS_LENIENT(FW_FOCUS_POLICY(fw)) && !focus_does_accept_input_focus(fw) && (sf == NULL || sf->Desk == Scr.CurrentDesk))  // fix