Subject: FVWM: keybinding win-key and menu-key

From: Rick Jones <[email-masked]>
Date: Mon, 4 Nov 2002 15:04:53 -0500 (EST)

I was thinking windows added the win-key and menu-key
to most keyboards..  how can I bind these keys to the
Root-Menu and WindowList Menus?

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 04 Nov 2002 17:50:55 -0500

> Root-Menu and WindowList Menus?

You need to find out what the key is bound to.
A program like "xev" or "xkeycaps" will help with this.

The windows key is normally set up as a modifier, meant to
be used along with other keys.  For example, for me its mod4,
so I use it in conjunction with F2 like this:

Key F2 A 4 Maximize grow grow

The same key is also known as Alt_L, but I can't bind an action
directly to Alt_L, but I think I could if I removed the modifier
from the key.

You might want to look at the xmodmap command for more information.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 4 Nov 2002 23:06:33 +0000

> Root-Menu and WindowList Menus?

Take a look what xev has to say about these keys.
Chances are that these bindings will work for you with Shift pressed:

  Key Super_L  A  S  WindowList (CurrentPage) NoGeometry
  Key Super_R  A  S  WindowList Root c c SelectOnRelease "", NoDeskSort
  Key Menu     A  S  Menu MenuFvwmRoot

If you don't want to additionally press Shift to activate these keys,
replace "S" with "A".

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 4 Nov 2002 23:10:42 +0000

> directly to Alt_L, but I think I could if I removed the modifier

You can bind a single modifier press with FVWM. Try this:

  Key Shift_R A A Exec xterm

  #Key Shift_R A A -

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 04 Nov 2002 18:59:09 -0500

>   Key Shift_R A A Exec xterm

Right, you are PEBKAC.