Subject: Re: FVWM: Control + Left mouse kills application in Windows style.

From: "subbiah .L" <[email-masked]>
Date: Wed, 06 Nov 2002 17:06:32 +0530

Hello,

I have customized the fvwm2rc file and checked for the Close/ Destroy/ 
Delete options. I have commented all these options in the $HOME/.fvwm/xxxx 
files (Created by the Windows 95 setup & Customized by me).  When analyzing, 
I found that, If I Right clicked with Control Key on the Motif application 
with a Frame, with out any Widget space( The Frame's Free space even I had 
widget in some other location in the Frame). I have changed the Style from 
Windows 95 to Motif style. Still I am facing the issue.

I found that this issue is not present in fvwm 1.24r version ( I tried with 
Motif style)

Can any one help me to found the Exact issue.

With Thanks and Regards,
L. Subbiah
----Original Message Follows----
From: Dominik Vogt <[email-masked]>
Reply-To: [email-masked]
To: "subbiah .L" <[email-masked]>, fvwm <[email-masked]>
Subject: Re: FVWM: Control + Left mouse kills application in Windows style.

On Thu, May 16, 2002 at 09:01:22PM +0530, subbiah .L wrote:
 >
 > Hello,
 >
 > I am using fvwm 2.4.3 with Windows 95 style settings given defaultly in 
the
 > fvwm2 itself. I am using ClickToFocus style. My Motif application is 
getting
 >
 > killed if I press mouse left click while holding the Control key in 
pressed
 > condition. Any sepecific settings is needed to take care of this?. I have
 > given Delete respones to Ignore in my Motif application. Still this 
problem
 > is coming.
 >
 > What could be the issue? Can any one help me?.

Check your .fvwm2rc file for and delete/close/destroy functions.
With Close and Destroy, applications are closed even if they
ignore the "DeleteWindow" message.

Bye

Dominik ^_^  ^_^

--
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20

_________________________________________________________________
STOP MORE SPAM with the new MSN 8 and get 2 months FREE* 
http://join.msn.com/?page=features/junkmail

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 06 Nov 2002 13:40:10 -0500

> Hello,

  You've put your reply at the top, making this whole thing very hard to
read and understand.  Please try not to do that.

> Windows 95 to Motif style. Still I am facing the issue.

I can't figure out from the above where you are clicking.

I can't figure out which button you are using either.
In the subject line it says "left mouse" and above it says
"right clicked".

Since you can't seem to find where the mouse binding is,
perhaps you should just override it.

The border fvwm puts around a window has 2 separate parts,
the frame which is the corners, and the sides.

To create a mouse binding for the corners, add this to the end of your
.fvwm2rc:

Mouse 1 F C Menu Move-or-raise

To create a mouse binding for the top/bottom and sides of the border
use this:

Mouse 1 S C Menu Move-or-raise

Replace "Menu Move-or-raise" with what you want Fvwm to do.

To just remove the binding, do this:

Mouse 1 S C -

-- 
Dan Espen                           E-mail: [email-masked]