Subject: RE: FVWM: new fvwm-perllib

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Sat, 9 Nov 2002 12:20:18 +0100

HI

The perllib version gives:

linux:~ # fvwm-perllib --version
2.5.5

When I run from the fvwmconsole: 

FvwmDebug -l logfile

then in the logfile I see entries like M_FOCUS_CHANGE etc.
When I then try to run the module, nothing happens and no 
extra entries apppear. I noticed one strange thing: I tried
to run a non-existing module to see if an error message 
appears when the module is not found, but this does not 
happen. I.e. when I enter in the fvwmconsole

module /home/jos/nonexistingmodule

then no error message appears on the console. On the other
hand, when I type

module nonexistingmodule

then an errormessage does appear, saying that the module is not
found in the module path. 

Now I just tried to run the module from the commandline. Then 
I see this:

linux:/usr/local/src/fvwmperl # perl module-gtkwinlist 
FvwmPerlGtkWinList should be spawned by fvwm normally.
Activating a dummy command line mode for 30 minutes (no events).
----------------------------------------------------------------

and a gtk window appears, but the buttons are not functional and 
no windows appear in the windowlist.

I hope this helps,

jos

-----Original Message-----
From: Mikhael Goikhman
To: Riswick, J.G.A. van
Cc: FVWM
Sent: 11/9/2002 5:26 AM
Subject: Re: FVWM: new fvwm-perllib
ng wrong? 

I am not sure how this may happen.

Do you have a correct fvwm-perllib in $PATH? Run: fvwm-perllib --version

Does FvwmDebug and FvwmGtkDebug work for you?

If you run the test modules from the shell command line do you enter the
dumb module mode without errors? Press Ctrl-C.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 9 Nov 2002 12:23:39 +0000

> found in the module path. 

So you only see what happens in FvwmConsole (can I ask you to name
FvwmConsole as FvwmConsole and not console?).

The error "execution of module /home/jos/nonexistingmodule failed"
appears in the same place you have all X output (including FvwmDebug).

> Activating a dummy command line mode for 30 minutes (no events).

Not quite. If it works from the command line, the problem should be
in the communication code, but if you say FvwmDebug works, I don't know.
Is it possible that only GTK based modules do not work?

Please continue to debug the problem and find where your errors are.

Regards,
Mikhael.