Subject: FVWM: random Xterm being pulled for FvwmButtons

From: Rick Jones <[email-masked]>
Date: Fri, 29 Nov 2002 11:55:48 -0500 (EST)

Since I haven't heard any solutions to FvwmButtons
using any "random" xterm on restart.. I found a simple
solution.

As xterm is not a particularly large program.. in fact
I also found an xterm3d (does anyone know the
difference between these two?)..

I'm currently using xterm3d for the executable on the
button bar.. if I don't have xterm3d at home.. I'll
just create a copy of xterm with a different filename
and execute it that way so it doesn't pull my regular
xterms into the button bar on restart.

I'd be glad to hear any other suggestions.

Rick

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Nov 2002 18:24:28 +0000

> I'd be glad to hear any other suggestions.

People, do you read other messages on the list? :)

Just yesterday, there was an answer to the same question.

  http://www.hpc.uh.edu/fvwm/archive/0211/msg00719.html

Another example. Two days ago there was an answer to the WindowList
question and yesterday someone asked the same question. Strange.

  http://www.hpc.uh.edu/fvwm/archive/0211/msg00706.html
  http://www.hpc.uh.edu/fvwm/archive/0211/msg00736.html

Regards,
Mikhael.

---

From: Rick Jones <[email-masked]>
Date: Fri, 29 Nov 2002 13:33:34 -0500 (EST)

Sorry, Mikhael.  I didn't realize they were one in the
same issue.  I don't see how the WindowList
correlates.. but I did skip over the icon issue
because I avoid icons in general in my FVWM.

So if I assign the "class" on the xterm and use that
with my FvwmButtons... when I restart it won't just
pull any recently clicked xterm from my desktop.. only
the one of that class?

Am I understanding this right?

Rick

 --- Mikhael Goikhman <[email-masked]> wrote: > On

---

From: Rick Jones <[email-masked]>
Date: Fri, 29 Nov 2002 13:40:59 -0500 (EST)

I tried the -class assignment on my swallowed xterm in
my buttonbar...  If I open another xterm.. on restart
the xterm on the desktop (not in the buttonbar) gets
put in the buttonbar.

I'll go back to using a different executable.. xterm
isn't that big to copy

Rick

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Nov 2002 19:09:30 +0000

> the xterm on the desktop (not in the buttonbar) gets

The syntax is this:

  *FvwmButtons: (Swallow "SpecialXterm" `Exec exec xterm -name SpecialXterm`)

> I'll go back to using a different executable.. xterm

You don't need to copy on unix, a mere symbolic link would be enough:

  ln -s /usr/bin/X11/xterm ~/bin/specialxterm

Regards,
Mikhael.