Subject: Re: FVWM: CDE Startup & SSH

From: [email-masked]
Date: Thu, 31 Oct 2002 18:23:57 +0000

Okay getting there :) The problem is that within my script it throws a dialogue
box to the screen where the user has to enter some data.
This generates the environment variable that I would like the desktop to use
throughout. It seems that when it execs the command it then
carries on through the .fvwm2rc file.  Can I make it pause until the user has
entered the data ?

regards

******************************************************************************
CONFIDENTIALITY STATEMENT

This email, its content and any files transmitted with it are intended
solely for the addressee(s) and may be legally privileged and/or
confidential. Access by any other party is unauthorised without the
express written permission of the sender. If you have received this
email in error you may not copy or use the contents, attachments
or information in anyway. Please destroy it and contact the sender
on  0870 840 5000 or via email return. This email has been
prepared using information believed by the author to be reliable
and accurate, but DaimlerChrysler Services UK Ltd. makes no
warranty as to accuracy or completeness. In particular
DaimlerChrysler Services UK Ltd. does not accept responsibility for
changes made to this email after it was sent. Any opinions
expressed in this document are those of the author and do not
necessarily reflect the opinions of DaimlerChrysler Services UK Ltd,
or its affiliates. 

CONFIDENTIALITY STATEMENT
******************************************************************************
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 31 Oct 2002 13:45:06 -0500

> carries on through the .fvwm2rc file.  Can I make it pause until the user has

I must be missing part of the picture.  If you use PipeRead
for an interactive dialog, then Fvwm will stop until the PipeRead
is done.

However, PipeRead is no good for interactive dialogs, 
I don't think you want to try to operate a dialog while Fvwm is frozen.

How about using FvwmCommand?
Start the FvwmCommand server like this:

AddToFunc StartFunction I Module FvwmCommandS

After that, you can send commands to Fvwm with the program
"FvwmCommand".  So have your dialog do something like:

system ("FvwmCommand \"SetEnv MYVAR test\"");

Why don't you want the rest of the .fvwm2rc processed?
Is it going to affect sub processes or the .fvwm2rc itself?

Anyway, using FvwmCommand, you can issue an fvwm read command
to read the parts that are affected, if thats the case.

-- 
Dan Espen                           E-mail: [email-masked]