Subject: FVWM: How to inconify/deinconify a window when clicking on the corresponding button in the icon manager?

From: "Leo Jingyu LEE" <[email-masked]>
Date: Sun, 20 Oct 2002 12:11:42 -0400

Hi, 

I am a real newbie on fvwm and trying it with Cygwin/XFree86.  I am just
not able to figure out this simple behavior (at least it works in twm by
default) after reading and trying various things.  I am also not able to
find a search function in the mail archive so that I have to post the
question.  I will greatly appreciate your help.

-- Leo

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 20 Oct 2002 16:39:31 +0000

On 20 Oct 2002 12:11:42 -0400, Leo Jingyu LEE wrote:
> 
> I am a real newbie on fvwm and trying it with Cygwin/XFree86.

Welcome.

Try to ask your questions in the message body, with more info supplied.

I guess you use one of the latest stable versions, please always specify
the version you use.

I guess you ask about FvwmIconMan that is your icon manager.

You may add something like this to your ~/.fvwm/.fvwm2rc:

  *FvwmIconMan: Action Mouse 1 N sendcommand "DeiconifyFocusAndRaise"
  *FvwmIconMan: Action Mouse 2 N sendcommand "Iconify"
  *FvwmIconMan: Action Mouse 3 N sendcommand "Popup WindowOps Mouse -102m c"

If you use FvwmWinList the syntax is a bit different:

  *FvwmWinList: Action Click1 DeiconifyFocusAndRaise
  *FvwmWinList: Action Click2 Iconify
  *FvwmWinList: Action Click3 Popup WindowOps Mouse -102m c

Where DeiconifyFocusAndRaise is a defined function and WindowOps is a menu.

  DestroyFunc DeiconifyFocusAndRaise
  AddToFunc   DeiconifyFocusAndRaise
  + I Iconify off
  + I Focus
  + I Raise

See also the man pages fvwm(1) and FvwmIconMan(1).

Regards,
Mikhael.