Subject: FVWM: Segmentation fault when drawing menus with default font [patch]

From: Ben Winslow <[email-masked]>
Date: Tue, 22 Oct 2002 00:44:10 -0400

A very recent change to menustyle.c (cvs version 1.18) causes fvwm to segfault if menus are being drawn with the default font.  It looks like it was just an accidental deletion of a code snippet, this patch puts it back.

-- 
Ben

? DEADJOE
Index: fvwm/menustyle.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/menustyle.c,v
retrieving revision 1.18
diff -u -3 -p -r1.18 menustyle.c
--- fvwm/menustyle.c	2002/10/21 22:10:52	1.18
+++ fvwm/menustyle.c	2002/10/22 04:44:07
@@ -539,6 +539,11 @@ void menustyle_update(MenuStyle *ms)
 		c_active.hilight = ST_MENU_RELIEF_COLORS(ms).fore;
 		c_active.shadow = ST_MENU_RELIEF_COLORS(ms).back;
 	}
+	if (ST_USING_DEFAULT_FONT(ms))
+	{
+		ST_PSTDFONT(ms) = Scr.DefaultFont;
+	}
+
 	if (ST_HAS_GREYED_CSET(ms))
 	{
 		c_stipple.fore = greyed_cs->fg;

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Oct 2002 11:00:25 +0200

> A very recent change to menustyle.c (cvs version 1.18) causes fvwm to segfault if menus are being drawn with the default font.  It looks like it was just an accidental deletion of a code snippet, t…

Yes, thank you.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].