Subject: FVWM: open application in root window?

From: rob <[email-masked]>
Date: Tue, 08 Oct 2002 16:06:09 +1000

Is there a way that an application can be opened in the root window.

I would like to be able to do this for the following reasons:

+ The application would use the entire desktop space and always be
   stacked on the bottom.
+ When icons were iconified they would be "on top" of the root window
   therefore I wouldn't have to go behind the window to find them.

If there are other ways to do this please let me know.

Thanks

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Christian MICHON <[email-masked]>
Date: Tue, 8 Oct 2002 10:36:18 +0200 (CEST)

> Is there a way that an application can be opened in the root window.

Yes, if the application provides this as an option.
xv-3.10a does: try launching "xv -root"

> + The application would use the entire desktop space and always be
This is exactly what happens to xv

>    therefore I wouldn't have to go behind the window to find them.
Idem

Christian

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 8 Oct 2002 12:59:45 +0000

> If there are other ways to do this please let me know.

This is the same as remove window decorations, maximize the application to
use the entire screen size and place the application to the lower layer.
Right? If so, here is the solution that works with most of applications.

To remove the decorations:

  Style myappwindow NoHandles, BorderWidth 0, NoTitle

To place the application on the bottom ("Style m Layer 1" is also ok):

  Style myappwindow StaysOnBottom

To maximize the application automatically when it is launched, you may use
one or another method described in FAQ #3.18 (with or without FvwmEvent).

Regards,
Mikhael.

---

From: Bob Crochelt <[email-masked]>
Date: Tue, 8 Oct 2002 16:50:23 -0700 (PDT)

Rob,
I do this by opening the app in an a-term window.
 I set the handles, title and borders off with a
style command.  Only works if its a terminal app
(like top) though

Bob Crochelt
> If there are other ways to do this please let

__________________________________________________
Do you Yahoo!?
Faith Hill - Exclusive Performances, Videos & More
http://faith.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].