Subject: FVWM: alt-tab and applets

From: "Alan T" <[email-masked]>
Date: Thu, 31 Oct 2002 22:41:04 +0000

Hey, two things. Can Fvwm2 do the windows "alt+tab" cycle through the open 
windows? Have a small pop-up in the centre of the screen that cycles through 
windows that are open. And make it so that not every window gets put onto 
the cycle list, only windows that have the properties "show up on the 
windows list" so that button bars and lists of windows do not show up on the 
"alt+tab" list. I don't want to see my xeyes, or fvwmbuttons, or startmenu 
show up.

Second, I have got a few wm applets running (wmCalClock, and wmWeather), and 
I have no way to tell them where to start (at what geometric position). Is 
there some way of doing this directly from fvwm2, (they do not support the 
-geo argument)or is there some way of controlling them using something else, 
maybe a wm applet daemon?

  Thanks

  -a

_________________________________________________________________
Internet access plans that fit your lifestyle -- join MSN. 
http://resourcecenter.msn.com/access/plans/default.asp

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Thu, 31 Oct 2002 16:06:51 -0800

* <[email-masked]> [31-Oct-02 15:50 -0800]:
  >
  >Hey, two things. Can Fvwm2 do the windows "alt+tab" cycle
  >through the open windows? Have a small pop-up in the
  >centre of the screen that cycles through 

Key Tab   A    M    WindowList (CurrentPage) Root c c NoGeometry, \
                  CurrentAtEnd, IconifiedAtEnd

look up in 'man' what they do. 
I *think* this config will work for 2.5.x, but not sure
whether it will work for 2.4.x as is.  I think,
'CurrentAtEnd' and 'IconifiedAtEnd' may be the 2.5.x option

However, I think The CurrentPage option, and 'Root c c'
(position in the center of the root window) position will
work.

In any case, grep man for above, and you shall find lots of
information.

  >windows that are open. And make it so that not every
  >window gets put onto the cycle list, only windows that
  >have the properties "show up on the windows list" so that
  >button bars and lists of windows do not show up on the 
  >"alt+tab" list. I don't want to see my xeyes, or
  >fvwmbuttons, or startmenu show up.

depends on how you want to do it: i think it is easier to
use defaults (i.e. all windows show up) and then add styles
for windows that you dont want to show up. Here is an
example

   Style FvwmPager		WindowListSkip

I am not sure how to specify a style option "show up on the
list", but I am sure someone here does :-) (if it is
possible)

  >maybe a wm applet daemon?

dont know, sorry....

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Peter McAlpine <[email-masked]>
Date: Thu, 31 Oct 2002 20:22:50 -0500

You've got a couple of options... if you're trying to get them to
dock, use FvwmButtons, and have it swallow them. This is what I do,
and I learned everything about it from:
http://www.igs.net/~tril/fvwm/configs/

I would think that there's a way to control where windows pop up, but
I'm not sure what it is. If fvwm can do it (so grep that man page),
then great, otherwise, look into Xdefaults and xrdb.

Of course, if things you don't mind being messy, maybe you can try
opening up different instances of FvwmButtons, and have them each
swallow one wm app.

hope this helps
peter

On Thu, Oct 31, 2002 at 10:41:04PM +0000, Alan T wrote:
> Second, I have got a few wm applets running (wmCalClock, and wmWeather), 
> and I have no way to tell them where to start (at what geometric position). 
> Is there some way of doing this directly from fvwm2, (they do not support 
> the -geo argument)or is there some way of controlling them using something 
> else, maybe a wm applet daemon?
> 
>  Thanks
> 
>  -a

-- 
Peter McAlpine
[email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 1 Nov 2002 02:17:58 +0000

On 31 Oct 2002 22:41:04 +0000, Alan T wrote:
> windows? Have a small pop-up in the centre of the screen that cycles 
> through windows that are open. And make it so that not every window gets 
> put onto the cycle list, only windows that have the properties "show up on 
> the windows list" so that button bars and lists of windows do not show up 
> on the "alt+tab" list. I don't want to see my xeyes, or fvwmbuttons, or 
> startmenu show up.

Once you mark all windows that should not be in the window list as
WindowListSkip, the default Alt-Tab in 2.4.x will work like you want.
You may even have 2 bindings, one for normal and one for WindowListSkip
windows:

  Key Tab A M  WindowList Root c c NoDeskSort, SelectOnRelease Meta_L
  Key Tab A SM WindowList Root c c OnlyListSkip, NoDeskSort, SelectOnRelease

If you want to cycle through windows without WindowList, using Next or
Prev with possible options, you should mark the non circulated windows as
CirculationSkip, they are usually the same as the WindowListSkip ones, but
not necessarily. Say, for Ctrl-Alt-Tab:

  Key Tab A CM  Prev YourFocusRaiseWarpFunction
  Key Tab A SCM Next YourFocusRaiseWarpFunction

> else, maybe a wm applet daemon?

See FAQ #3.18.

Regards,
Mikhael.