Subject: FVWM: alt-tab

From: "Andrey R. Urazov" <[email-masked]>
Date: Thu, 3 Oct 2002 17:37:01 +0700

Hello,

I'm using fvwm 2.5.3 and want to get alt-tab behaviour like the one in
another GUI :). I.e. if I'm using two applications, I would expect that
alt-tab switches between them. This is what I cannot get now.

Windows in the WindowList are shifted cyclically and that means that
when I press alt-tab, the current window goes to the end of the list
(assume CurrentAtEnd is on) and then if I want to switch to it again,
it's not sufficient to just press alt-tab, I have to press it many times
so that to reach the next to last entry at which the previously used
application resides.

Best regards,
  Andrey Urazov
-- 
"... gentlemen do not read each other's mail."
		-- Secretary of State Henry Stimson, on closing down
		   the Black Chamber, the precursor to the National
		   Security Agency.
--
Donnerstag, 03. Oktober 2002, 17:25:35 +0700 - Andrey R. Urazov (mailto:[email-masked])

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 3 Oct 2002 14:10:02 +0000

> so that to reach the next to last entry at which the previously used

This is a bug. I believe it was introduced in 2.5.3 after FP* style
additions. The source problem is that FlipFocus works just like Focus.
I think that when this is fixed, WindowList will work as usual.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 6 Oct 2002 00:29:13 +0200

> I think that when this is fixed, WindowList will work as usual.

Fixed.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Andrey R. Urazov" <[email-masked]>
Date: Sun, 6 Oct 2002 07:46:32 +0700

> > I think that when this is fixed, WindowList will work as usual.
Thanks, this will make using FVWM much more comfortable. Is the fix only
available through CVS or maybe there is a patch somewhere?

Best regards,
  Andrey Urazov
-- 
There is only one way to be happy by means of the heart -- to have none.
		-- Paul Bourget
--
Sonntag, 06. Oktober 2002, 07:40:26 +0700 - Andrey R. Urazov (mailto:[email-masked])

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 6 Oct 2002 01:15:26 +0000

> available through CVS or maybe there is a patch somewhere?

To make the work of Diminik easier I will answer. For 2.5.3:

@@ -302,7 +302,7 @@
 	{
 		return;
 	}
-	__update_windowlist(fw, args->is_focus_by_focus_cmd, args->set_by);
+	__update_windowlist(fw, args->set_by, args->is_focus_by_focus_cmd);
 	if (__try_other_screen_focus(fw) == True)
 	{
 		return;

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 6 Oct 2002 02:02:30 +0000

This time the patch with headers.

Regards,
Mikhael.
Index: focus.c
===================================================================
RCS file: /home/cvs/fvwm/fvwm/fvwm/focus.c,v
retrieving revision 1.121
diff -u -r1.121 focus.c
--- focus.c	2002/08/23 02:31:37	1.121
+++ focus.c	2002/10/06 01:44:23
@@ -302,7 +302,7 @@
 	{
 		return;
 	}
-	__update_windowlist(fw, args->is_focus_by_focus_cmd, args->set_by);
+	__update_windowlist(fw, args->set_by, args->is_focus_by_focus_cmd);
 	if (__try_other_screen_focus(fw) == True)
 	{
 		return;

---

From: "Andrey R. Urazov" <[email-masked]>
Date: Sun, 6 Oct 2002 10:15:21 +0700

> This time the patch with headers.
Thanks a lot. Patched and it now works as intended.

Best regards,
  Andrey Urazov
-- 
Rule of Creative Research:
	(1) Never draw what you can copy.
	(2) Never copy what you can trace.
	(3) Never trace what you can cut out and paste down.
--
Sonntag, 06. Oktober 2002, 10:14:55 +0700 - Andrey R. Urazov (mailto:[email-masked])