Subject: FVWM: manual placement/moving window outlines with hjkl, etc

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 30 Oct 2002 16:51:13 -0800

Hello,

When placing windows using ManualPlacement, I am able to
move the outlines around with my vi-like hjkl keys. I can
also scroll menues this way.  I really like this.

However, I'd like to change increments in which windows are
moved when I press the keys. I did not see them as part of
built-in keys in the man page, and dont seem to have them
defined anywhere in my .fvwm2rc. 

Is the fact that this works undocumented? Or am I missing
something? And in particular, could someone please tell me
if its possible to change the increments in which the window
is moved?
(I know  how to move a window, say, 10% to the right and
whatnot, but I need to know the context for this. Unless I
missed it, I did not see in the manual page that one can
specify some sort of "outline" context, or somethin)

(My only key bindings are included below)

   Key Tab   A    M    WindowList (CurrentPage) Root c c NoGeometry, \
                           CurrentAtEnd, IconifiedAtEnd
   Key Left  A    M    Scroll -100 +0
   Key Up    A    M    Scroll +0 -100
   Key Right A    M    Scroll +100 +0
   Key Down  A    M    Scroll +0 +100
   Key F1    A    M    Popup Window-Ops
   Key F2    A    M    Popup MAIN
   Key F3    A    M    Lower
   Key F5    A    M    Prev
   Key F6    A    M    Next
   Key F7    A    M    Move
   Key F8    A    M    Resize
   Key F9    A    M    Iconify
   Key F10   A    M    Maximize 100 100
   Key F11   A    M    Raise
   Key F12   A    M    Stick

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 31 Oct 2002 09:08:44 +0100

> also scroll menues this way.  I really like this.

The vi keys in menus are used to warp the pointer around the menu.

> defined anywhere in my .fvwm2rc. 

They are currently hard coded:

  no modifiers:   5 pixel
  with control:   1 pixel
  with control: 100 pixels

You can only change the values by editing libs/defaults.h:

  #define DEFAULT_KDB_SHORTCUT_MOVE_DISTANCE 5 /* pixels */
  #define KDB_SHORTCUT_MOVE_DISTANCE_SMALL   1 /* pixels */
  #define KDB_SHORTCUT_MOVE_DISTANCE_BIG   100 /* pixels */
                                          ^^^^^

> something?

It is described in the the "KEYBOARD SHORTCUTS" section in the man
page, although slightly incorrectly.

> And in particular, could someone please tell me

You already asked this above.

>    Key F10   A    M    Maximize 100 100

Bye

Dominik ^_^  ^_^