Subject: FVWM: WindowList and pointer warping

From: Maciej Kalisiak <[email-masked]>
Date: Sat, 26 Oct 2002 02:43:24 -0400

Hello,

I'm using fvwm 2.5.3.  When I select a window using the WindowList
(I've specified "SelectOnRelease"), the mouse pointer is warped to the
upper left corner of said window.  How do I turn this off?  I've tried
a number of things without success.  Here are some .fvwm2rc parts I
consider relevant:

,----
| Key Tab A 4 WindowList (CurrentDesk !Sticky)\
|   CurrentAtEnd SelectOnRelease Super_L IconifiedAtEnd Geometry
| # with Shift, do ALL windows
| Key Tab A S4 WindowList \
|   CurrentAtEnd SelectOnRelease Super_L IconifiedAtEnd Geometry
| 
| # Remove the default Alt-Tab binding
| Key Tab A M -
| 
| Style * ClickToFocus, GrabFocus, MinOverlapPlacement, NoIcon, NoPPosition
| Style * BorderWidth 4
| 
| MenuStyle * \
| 	MenuFace TiledPixmap marble.xpm,\
| 	Font "-monotype-arial-medium-r-*-*-12-*-*-*-p-*-*-*",\
| 	Hilight3dOff, \
| 	AutomaticHotKeys, \
| 	HilightBack blue, \
| 	ActiveFore white, \
| 	BorderWidth 1, \
| 	PopupOffset 0 100, \
| 	PopdownImmediately, \
| 	PopupImmediately, \
| 	TitleUnderlines2,\
| 	!FPFocusByFunctionWarpPointer	
| 
| MenuStyle FancyMenu\
| 	 MenuFace TiledPixmap marble.xpm, \
| 	 SidePic fvwm-menu-sidebar.xpm, \
| 	 Font "-monotype-arial-medium-r-*-*-12-*-*-*-p-*-*-*",\
| 	 Hilight3dOff, \
| 	 VerticalItemSpacing 1 2, \
| 	 AutomaticHotKeys, \
| 	 HilightBack blue, \
| 	 ActiveFore white, \
| 	 BorderWidth 1, \
| 	 PopupOffset 0 100, \
| 	 PopdownImmediately, \
| 	 PopupImmediately, \
| 	 TitleUnderlines2
| 
| ChangeMenuStyle FancyMenu RootMenu
| 
| Style * !FPFocusByFunctionWarpPointer
`----

Any help would be greatly appreciated.

-- 
Maciej Kalisiak       mac "at" dgp.toronto.edu       www.dgp.toronto.edu/~mac
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 26 Oct 2002 02:25:16 -0700

Maciej,

  * <[email-masked]> [26-Oct-02 00:10 -0700]:
  >
  >I'm using fvwm 2.5.3.  When I select a window using the
  >WindowList (I've specified "SelectOnRelease"), the mouse
  >pointer is warped to the upper left corner of said
  >window.  How do I turn this off?  I've tried a number of
  >things without success.  Here 

what behavior would you want?

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Oct 2002 10:19:57 +0000

> |   CurrentAtEnd SelectOnRelease Super_L IconifiedAtEnd Geometry

The function that warps the pointer is WindowListFunc. By default it is:

  AddToFunc WindowListFunc
  + I WindowId $0 Iconify off
  + I WindowId $0 FlipFocus
  + I WindowId $0 Raise
  + I WindowId $0 WarpToWindow 5p 5p

You may redefine this function and it will be used with all WindowList
invocations or you may even specify a separate functions for them, like:

  Key Tab A 4 WindowList (CurrentDesk, !Sticky) CurrentAtEnd, \
    SelectOnRelease Super_L, IconifiedAtEnd, Geometry, Function WindowListFunc2

  DestroyFunc WindowListFunc2
  AddToFunc   WindowListFunc2
  + I WindowId $0 WindowShade off
  + I WindowId $0 Iconify off
  + I WindowId $0 FlipFocus NoWarp
  + I WindowId $0 ThisWindow (!CurrentPage) Raise

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Oct 2002 13:10:06 +0200

> a number of things without success.  Here are some .fvwm2rc parts I

When a window is selected from the WindowList, the function
WindowListFunc is called.  By default it looks like this:

  AddToFunc WindowListFunc

You can write your own function in the .fvwm2rc file, e.g.

  DestroyFunc WindowListFunc
  AddToFunc WindowListFunc
  + I WindowId $0 Iconify off
  + I WindowId $0 FlipFocus
  + I WindowId $0 Raise

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Maciej Kalisiak <[email-masked]>
Date: Sat, 26 Oct 2002 12:05:31 -0400

On Sat, Oct 26, 2002 at 06:19:57AM -0400, Mikhael Goikhman wrote:
> The function that warps the pointer is WindowListFunc.

Ah!  Thanks to all who replied.  I don't know how I missed the
description of the default function in the man page.  Well, I did
actually see it but it just didn't register on the mental radar.