Subject: FVWM: focus for started application

From: Jodok Ole M�llers <[email-masked]>
Date: Thu, 17 Oct 2002 18:48:55 +0200

Hello,

I want my fvwm to give new windows the focus automaticlly.
That means if I e.g. start a new xterm this xterm should get
the focus. I am using SloppyFocus.
How can I change my config to behave like this ?

Regards, j.m.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Oct 2002 19:51:37 +0000

> How can I change my config to behave like this ?

  Style * GrabFocus

Regards,
Mikhael.

---

From: Jodok Ole Müllers <[email-masked]>
Date: Thu, 17 Oct 2002 22:25:17 +0200

Ok, 

GrabFocus works but it excludes SloppyFocus.
I want both: first GrabFocus then SloppyFocus.
This does  not work:

Style * GrabFocus, SloppyFocus

Any ideas?

Regards, j.m.

Mikhael Goikhman wrote:

> > the focus. I am using  SloppyFocus .

-- 
pgp: lynx --dump http://www.muenster.de/~muellers/pgp.asc | gpg --import

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Oct 2002 21:52:35 +0000

> Style * GrabFocus, SloppyFocus

Please explain what you want by giving some examples.
You can't have both at the same time unless you also warp the pointer,
in this case, see FAQ #3.18.

Regards,
Mikhael.

---

From: Peter McAlpine <[email-masked]>
Date: Fri, 18 Oct 2002 10:28:13 -0400 (EDT)

I just did this yesterday... took me 20 minutes to find the part in the
man page about it. If you ask me, the section in the man page about the
Style option should have specific info on what each style does. As it is
now, they're all scattered throughout the manpage(s).

anyway...

SloppyFocus automatically does a GrabFocusOff, so you HAVE to put
GrabFocus AFTER SloppyFocus.

like:
Style * SloppyFocus
Style * GrabFocus

hope this helps,
Peter McAlpine

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 18 Oct 2002 09:31:13 +0200

> Style * GrabFocus, SloppyFocus

In general, SloppyFocus and GrabFocus work together, but there are
soe situations when the focus is taken away immediately.  There is
little you can do except changing the focus policy for such
applications

> > > How can I change my config to behave like this ?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe

---

From: Peter McAlpine <[email-masked]>
Date: Fri, 18 Oct 2002 10:36:48 -0400 (EDT)

Um, I have both at the same time, and my pointer doesn't warp. By doing:
Style * SloppyFocus
Style * GrabFocus

new windows gain focus, and the mouse doesn't focus anything until it
moves (onto another window?).

Cheers,
Peter McAlpine

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 18 Oct 2002 15:36:27 +0000

> moves (onto another window?).

Yes, of course, you can do this. But then you get a modified SloppyFocus.
I.e. the pointer may be in the unfocussed window for some time (i.e. it is
not really SloppyFocus now). This is what I meant when asked to describe
what is the desired behaviour.

And you are right, the following can't work in 2.4.x:

because SloppyFocus implies GrabFocusOff. But this works in 2.5.3+.

The following works in 2.4.x:

  Style * SloppyFocus, GrabFocus

Regards,
Mikhael.

---

From: Jodok Ole M�llers <[email-masked]>
Date: Sat, 19 Oct 2002 06:58:57 +0200

> Please explain what you want by giving some examples.

Okay. When I open a new application e.g. xterm 
I want it to get the focus even if the mouse pointer is not over it. 
(i have got a big screen with lot of space)
If I then open rxvt it should get the focus instead (even if the mouse is not over it).
And from now on I want both applications to behave like in
the  SloppyFocus mode. (that means last active window keeps active
until i move the pointer/mouse in another window).

But as far as I understand the FAQ this is only possible by using
a funktion for each programm.

Regards,
	Jodok

---

From: Jodok Ole M�llers <[email-masked]>
Date: Sat, 19 Oct 2002 07:19:39 +0200

Hello Peter,

Yes, you are right. This works. I am happy now!
Thank you very much!!

Regards,
	Jodok

Peter McAlpine wrote:

> 
> 
> I just did this yesterday... took me 20 minutes to find the part in
> the man page about it. If you ask me, the section in the man page
> about the Style option should have specific info on what each style
> does. As it is now, they're all scattered throughout the manpage(s).
> 
> anyway...
> 
> On Thu, 17 Oct 2002, Jodok Ole M_llers wrote:
> 
> > Ok, 
> >