Subject: FVWM: Troubles installing fvwm2

From: Gabriel Moll <[email-masked]>
Date: Thu, 17 Oct 2002 18:15:58 -0300 (CDT)

Hi, I'm trying to install the fvwm-2.4.6 in a Ultra 1 which
 is running Solaris 2.6

 The problem appears when I do the make install, this ask me
 for ginstall. Where can I find it?

 % make install
  Making install in libs
  Making install in fvwm
  /bin/sh ../mkinstalldirs /usr/local/bin
	/usr/local/bin/ginstall -c  fvwm2 /usr/local/bin/fvwm2
	sh: /usr/local/bin/ginstall: not found
	*** Error code 1
	make: Fatal error: Command failed for target `install-binPROGRAMS'
	Current working directory /local/tmp/fvwm-2.4.6/fvwm
	*** Error code 1
	make: Fatal error: Command failed for target `install-am'
	Current working directory /local/tmp/fvwm-2.4.6/fvwm
	*** Error code 1
	make: Fatal error: Command failed for target `install-recursive'

---
salu2,
      Gabriel Moll Ibacache
      Injenieria Civil en Computacion
      UNIVERSIDAD DE CHILE
      gmoll en dcc punto uchile punto cl

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 17 Oct 2002 17:34:01 -0400

> 	sh: /usr/local/bin/ginstall: not found

2.4.6 is pretty old, 2.4.12 is current.  It may help to try it.

During the configure step, configure checks for
an install program using the names:

ginstall scoinst install

if they don't work correctly, it should use "install_sh".

on Solaris, it should use "install_sh".

During configure I get a message like this:

checking for a BSD-compatible install... ./install-sh -c

You should do:

which ginstall
which scoinst
which install

to see what you have on the machine.

Then rerun configure and see if you can tell what is happening
when it looks for install.

-- 
Dan Espen                           E-mail: [email-masked]