Subject: FVWM: FvwmIdent: invoke from menu, wait for click

From: Victor Eijkhout <[email-masked]>
Date: Sun, 6 Oct 2002 12:47:42 -0400

If I invoke FvwmIdent from the console, it waits for me to click in a 
window (fvwm 2.4.11); if I invoke it as

AddToMenu fvwm
+ "Source fvwmrc" Read /Users/victorle/.fvwm2rc
+ "Restart fvwm" Restart
+ "Console" Module FvwmConsole
+ "Ident" Module FvwmIdent

then it give the information immediately. Is there a way to invoke 
from a menu and still have it wait for me to click somewhere?

-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 6 Oct 2002 17:01:19 +0000

> from a menu and still have it wait for me to click somewhere?

You should be invoking the "fvwm" menu from decorations and not
as the root menu, otherwise you would not have see behaviour.

To trick the window context (i.e. to remove it), you may use:

  None ("abracadabra") Module FvwmIdent

I plan to add a more relable NoWindow to remove the window context.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Oct 2002 19:12:13 +0200

> I plan to add a more relable NoWindow to remove the window context.

Good idea.  However, it's already possible to delete the window
context with the WindowId command:

  WindowId Root Module FvwmIdent

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].