Subject: FVWM: Disabling Dragging feature of FVWM for touchscreen environment

From: Andrew Morelock <[email-masked]>
Date: Wed, 16 Oct 2002 11:15:49 -0500

I am funning FVWM on an embedded install of RedHat that utilizes a touch
screen and is using Mozilla as it's primary UI.  I am looking for a way to
disable the drag feature that most if not all window managers allow.

In mozilla a user has the ability to drag images out of pages and cause
major problems to the user-experience.

Thoughts anyone?

--
Andrew Morelock
onBlur(.org)
612.804.9484

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 16 Oct 2002 12:34:19 -0400

> major problems to the user-experience.

Yes.

I believe your problem has nothing to do with the window manager.
The only part of Fvwm that has anything to do with dragging that
I know about is FvwmDragWell which is an optional module which
I don't believe you are running.

I just dragged a Mozilla image, and it just flew back to where
it started.  I'm curious as to why thats a problem.

I think you might be able to disable drags by asking questions
on the Mozilla lists.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Christian MICHON <[email-masked]>
Date: Thu, 17 Oct 2002 03:56:22 +0200 (CEST)

> I believe your problem has nothing to do with the window manager.

Very correct....

> it started.  I'm curious as to why thats a problem.

It's not a problem, but a feature. When you compile Mozilla with GTK
toolkit, you can then drag any image or component to GTK compiled
application. Typically, you'd drag the image to the gimp for example.

> I think you might be able to disable drags by asking questions

I think Mozilla lists advice would be to recompile...

This is very much inside GTK code. You need to check with the GTK
people. Check first your mozilla bin from RedHat was compiled with
GTK.

Christian

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].