Subject: Re: FVWM: QuitFunction

From: Remko Troncon <[email-masked]>
Date: Wed, 2 Oct 2002 10:25:05 +0200

Hi all,

I know this was a post of a while ago, but has this been implemented
yet? Will it ever be ?

cheers,
Remko

On 13 Aug 2002, Mikhael Goikhman wrote:
> Now when I think about this, I see an elegant solution for these problems.
> We only need 2 functions (not including Session*Function variants),
> StartFunction and ExitFunction.
> 
> StartFunction may include conditions "StartUp" and "Restart", ExitFunction
> may include conditions "Restart" and "Quit", these conditions are always
> false anywhere else. This way InitFunction and RestartFunction are not
> needed (not that RestartFunction is needed now anyway).
> 
>   AddToFunc StartFunction
>   + I FvwmPager
> 
>   AddToFunc ExitFunction
>   + I On (Quit) Exec killall xplanet-runner
>   + I On (Restart) Exec play /some/ding.au
>   + I Echo "Either Restart or Quit"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 2 Oct 2002 16:25:13 +0000

> I know this was a post of a while ago, but has this been implemented

I think I will implement it sometimes. The biggest problem is the syntax.
It should be chosen so that no changes are needed in the future.
We have conditional branches now, maybe "On" is better to be reserved for
them instead. Probably add 3 new prefixes: OnStartUp, OnRestart, OnQuit.

Regards,
Mikhael.