Subject: Re: Re: FVWM: Iconifying Eterms / Default Eterm Style

From: "Ed Powers" <[email-masked]>
Date: Sun, 13 Oct 2002 05:27:25 +0500

Hi Mikhael, et al.

> You say that you don't have any icon for Eterm at all or you have the
> wrong icon? Eterm supplies its own icon picture and you should see it.
> If no, something is wrong here.
> 
> Anyway, if you want to override the icon that Eterm supplies do:
> 
>   Style Eterm* IconOverride
> 
> BTW, Eterm is not the only application that provides icon picture hint.
> If you use unified icon set and don't want applications to add chaos
> (every application may have its own idea how its icon should look and of
> which size), you may do:
> 
>   Style * IconOverride
>   Style XTerm NoActiveIconOverride  # enable: xterm +ai
> 
> Tell us whether this solved your problem or not.
> 
> Regards,
> Mikhael.

Well, here's how I made out:

- I inserted the Style Eterm* IconOverride line with no avail. :(
  Still No icon whatsoever
- I deleted ~/.Eterm
- Re-ran Eterm, and configured it they way I like.
- Minimized Eterm - got the icon back!
- But... Although I have the icon back, it is still not sticking to the iconbox
  like all my other clients are... Eterm icon just goes to the top left of
  the root window. :(

Perhaps I should provide spex now:
FreeBSD 4.6.2R
FVWM 2.4.9 (Built from FreeBSD port)

Thanks again!
-ed
-- 
_______________________________________________
Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 
http://www.net2phone.com/cgi-bin/link.cgi?143 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 13 Oct 2002 02:12:42 +0000

I just tried to actually iconify Eterm-0.9.1 and I can reproduce this bug
with both the latest 2.4.x and 2.5.x. The icon position is always +0+0
regardless of the iconbox. I also see other weird things like the icon
picture is at separate location than the icon title or getting both the
Eterm hint icon (unmanaged) and the icon set by Icon, IconOverride.

Hopefully, this will be fixed.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Sat, 12 Oct 2002 22:57:28 -0400

> Hopefully, this will be fixed.

Style Eterm NoIconPosition

fixes it for me. Ie, it goes into iconbox I defined on my root window.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 13 Oct 2002 03:17:49 +0000

> fixes it for me. Ie, it goes into iconbox I defined on my root window.

Ok, still I remember it worked for Eterm even without this style option
(that is pretty old). So either defaults were changed once again or new
Eterm started to be broken, but it was not such bad some time ago.

The weird things seen with UseIconPosition still should be fixed.
I will rereport this.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 13 Oct 2002 11:29:47 +0200

On Sun, Oct 13, 2002 at 03:17:49AM +0000, Mikhael Goikhman wrote:
> (that is pretty old).

That depends on how you define "pretty old".  NoIconPosition was
introduced in 2.3.23 and was the default in 2.3.23 to 2.3.25
before I switched back to UseIconPosition as the default in
2.3.26.  Overall, NoIconPosition was the default for no more than
16 days (21-Nov-2000 to 6-Dec-2000).

> So either defaults were changed once again or new

I think either your memory or your config is failing you on this
one.

> The weird things seen with UseIconPosition still should be fixed.

I don't see any, but I'm awaiting a bug report.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 13 Oct 2002 10:05:22 +0000

> > Eterm started to be broken, but it was not such bad some time ago.
    ^^^^^^^^^^^^^^^^^^^^^^^^^^

> I think either your memory or your config is failing you on this

No, my memory is ok. Just installed Eterm-0.8.8 and it does not set any
+0+0 icon position, Eterm-0.9.1 does. Both without ~/.Eterm.

> I don't see any, but I'm awaiting a bug report.

Ok, later, and not on this list. :)

Regards,
Mikhael.