Subject: FVWM: fighting back against splash screens

From: Daniel Barclay <[email-masked]>
Date: Sat, 26 Oct 2002 12:03:37 -0400

Where in the documentation should I look for information on how
to tell FVWM to ignore requests from splash screen windows to
suppress normal window-manager decoration?

Thanks,
Daniel
-- 
Daniel Barclay
[email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 26 Oct 2002 17:04:18 +0000

> suppress normal window-manager decoration?

This depends on how such splash screen is implemented.
If it just sets window manager hints, it is possible to ignore them
(different hints require different Style options).
If it is an Override Redirect window, you probably can't do very much.
The output of 'xwininfo -all' usually tells something useful about
such splash window.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 26 Oct 2002 10:33:27 -0700

* <[email-masked]> [26-Oct-02 09:38 -0700]:
  >
  >Where in the documentation should I look for information
  >on how to tell FVWM to ignore requests from splash screen
  >windows to suppress normal window-manager decoration?

I dont know what's customary for splash screens - i.e. are
they always transient, etc. But I will try some suggestions,
which you may already know :)... maybe in the very least
they'll point something out that you can go back and chekc
upon, or extend, or something.

Can you 'identify' the window as it starts? if you can, then
use the information to do what you want in the Style "foo".
(I think quotes may not be necessary). The foo is one of 
from the man page:

         stylename	 can  be a window's name, class, or
         resource string.  It may contain the wildcards '*'
         and '?', which are matched in the usual Unix
         filename manner.  They are searched in the reverse
         order stated.   When	 two  conflicting styles apply
         to the same window, the style that was changed last
         wins.

         Note:  windows  that  have  no  name  (WM_NAME) are
         given a name of "Untitled", and windows that don't
         have a class (WM_CLASS, res_class) are given class
         "NoClass" and those that don't have a resource
         (WM_CLASS, res_name) are given resource
         "NoResource".

Perhaps, if the splash screens have all the same information
as the regular windows, and if you can compile applications
yourself, you could change the window titles and use that
info in the Style

If Splash screens are transient, then there is a number of
transient commands that control their look and feel. I'd be
a bad person to tell you _exactly_ what to do, but man pages
have plenty of info if you grep for "transient". For
example, I have a feeling that gimp's splash is transient,
as it shows up on my fvwm decorated as a transient window
woulld be, while gnome has full decorations on it.

hope any of that helped.
good luck,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Oct 2002 13:43:38 -0400

> The output of 'xwininfo -all' usually tells something useful about

Run "strings" on the binary, look for things like "nologo",
"splash", "banner", etc.  Perhaps theres an option to suppress it.

Other than that, splash screens are often associated with commercial
products.  Ironically, you pay for the product, and they decide
that you are a target for their advertising.

Complain to the vendor.

-- 
Dan Espen                           E-mail: [email-masked]