Subject: FVWM: Re: Fvwm 2.5.4

From: Peter Moore <[email-masked]>
Date: Tue, 29 Oct 2002 08:51:55 -0800

STOP sending these announcements to me.  I have requested you to stop 
several times.
Peter Moore

At 10:19 AM 10/29/02 -0600, you wrote:
>Fvwm is a powerful window manager.  Version 2.5.4 is an
>experimental unstable release that includes new features and
>improvements over unstable 2.5.3 and stable 2.4.12 versions.  You
>are welcome to upgrade and test the new features or help
>stabilizing the code.  Please be aware that any features
>introduced in the 2.5.x development versions may be renamed,
>changed or removed without notice before the next stable release.
>
>The release is available at the fvwm home page: http://www.fvwm.org/
>
>Fixed:
>------
>
>* Fixed flickering in menus, icon title, FvwmButtons, FvwmIconMan
>   and FvwmPager when xft font is used.
>
>* FvwmIconMan options PlainColorset, IconColorset, FocusColorset
>   and SelectColorset are now strictly respected.
>
>* See ChangeLog for more fixes.
>
>Improved:
>---------
>
>* Alpha blending rendering is supported even without XRender
>   support.
>
>* FvwmButtons redrawing improvement: colorsets are now usable with
>   containers.
>
>* The HilightBack and ActiveFore menu styles are independent of
>   each other.  HilightBack without using ActiveFore does no longer
>   hilight the item text.
>
>* Documentation.
>
>New features:
>-------------
>
>* FvwmTaskBar may now include mini launchbuttons using the Button
>   command.  Also has new options for spacing the buttons:
>   WindowButtonsLeftMargin, WindowButtonsRightMargin, and
>   StartButtonRightMargin.  See man page for details.
>
>* Style switches can be prefixed with '!' to inverse their meaning.
>   For example, "Style * Sticky" is the same as "Style * !Slippery".
>   This works *only* for pairs of styles that take no arguments and
>   for the Button and NoButton styles.
>
>* New button property Id in FvwmButtons.  FvwmButtons now accepts
>   dynamical actions using SendToModule, see the man page:
>
>     ChangeButton <button-id> <properties-to-change>
>     ExpandButtonVars <button-id> <command-to-expand>
>
>* New Colorset options bgTint, fgTint (which complete Tint), Alpha,
>   IconTint and IconAlpha.
>
>* Enhanced commands [Add]ButtonStyle, [Add]TitleStyle. ButtonState.
>   Titles and buttons now have 4 main states instead of 3: ActiveUp,
>   ActiveDown, InactiveUp and InactiveDown, plus 4 Toggled variants.
>   Several shortcuts added: Active means ActiveUp + ActiveDown,
>   Inactive means InactiveUp + InactiveDown, similarly for shortcuts
>   ToggledActive and ToggledInactive.
>
>* More shortcuts for button states added: AllNormal, AllToggled,
>   AllActive, AllInactive, AllUp, AllDown.  These six shortcuts are
>   actually different masks for 4 individual states (from 8 total).
>
>* FPClickToFocus and FPClickToRaise work with any modifier by
>   default.
>
>* Perl library API regarding event handlers is changed, so personal
>   modules in Perl should be adjusted.
>
>* Allow the use of mouse buttons other than the first in
>   FvwmWinList when invoked transient.
>
>* ImagePath now supports directories in form "/some/directory;.png"
>   (where semicolon delimits a file extension that files in
>   /some/directory have.  This file extension replaces the original
>   image extension (if any) or it is added if there is no extension.
>   For example with: Style XTerm MiniIcon mini/xterm.xpm
>   the file /some/directory/mini/xterm.png is searched.
>
>* New graphical debugger module FvwmGtkDebug.
>
>* New command NoWindow for removing the window context.
>
>* New FvwmIconMan option ShowTransient.
>
>* All conditions have a negation.
>
>* New FvwmBacker option RetainPixmap.
>
>* New WindowList option SortByResource; the previously added
>   SortClassName option is renamed to SortByClass.
>
>* New command PrintInfo for debugging.
>
>--
>Visit the official FVWM web page at <URL:http://www.fvwm.org/>.
>To unsubscribe from the list, send "unsubscribe fvwm-announce" in the
>body of a message to [email-masked].
>To report problems, send mail to [email-masked].

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul Smith" <[email-masked]>
Date: 29 Oct 2002 12:25:05 -0500

%% Peter Moore <[email-masked]> writes:

  pm> STOP sending these announcements to me.  I have requested you to stop
  pm> several times.

You are subscribed to the fvwm-announce mailing list.  So, you get all
the FVWM announcements.

If you no longer want to be subscribed to the fvwm-announce mailing
list, there are instructions on how to unsubscribe yourself at end of

  >> To report problems, send mail to [email-masked].

These instructions were also sent to you when you subscribed.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]> HASMAT--HA Software Mthds & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 29 Oct 2002 12:14:27 -0600

>>>>> "PM" == Peter Moore <[email-masked]> writes:

PM> STOP sending these announcements to me.  I have requested you to
PM> stop several times.

Ummm, you never unsubscribed from the fvwm-announce list and you never
sent any messages to the list owner requesting removal.  How on earth
do you expect to have been removed?  Are we supposed to be psychic?

I would remove you now, except that there is no address
"[email-masked]" on any mailing list at this site.

 - J<

---

From: Denis Perelyubskiy <[email-masked]>
Date: Tue, 29 Oct 2002 13:09:21 -0800

* <[email-masked]> [29-Oct-02 10:56 -0800]:
  >Ummm, you never unsubscribed from the fvwm-announce list
  >and you never sent any messages to the list owner
  >requesting removal.  How on earth do you expect to have
  >been removed?  Are we supposed to be psychic?
  [...]

wait. you mean the cvs version does not detect that yet?
crap, and I was going to start bugging Dominik and other
guys about configuring it :-)

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].