Subject: FVWM: another windowlist question

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 19 Oct 2002 21:55:30 -0700

Hello,

2.5.4 (cvs) Fvwm:

is there any way to make windowlist switch between windows
back and forth on alt-tab. For example, here is what I am
using now:

Key Tab   A    M    WindowList (CurrentPage) NoGeometry, CurrentAtEnd, IconifiedAtEnd

This makes it convenient to cycle through windows.
However, if i have windows a, b, c is it possible to go from
window a to window b by hitting alt-tab, and then back to
window a by hitting another alt-tab?

Holding alt and hitting tab repeatedly would then cycle
through the rest of the windows (it does so anyway)

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 20 Oct 2002 07:11:55 +0000

> through the rest of the windows (it does so anyway)

You should be using a not up to date cvs version, because the current
one does what you describe. This was broken two weeks ago (and in 2.5.3).

As something totally unrelated, you probably know that you may center
the window list menu:

  Key Tab   A    M    WindowList (CurrentPage) Root c c NoGeometry, CurrentAtEnd, IconifiedAtEnd

or maybe even:

  Key Tab   A    M    WindowList (CurrentPage) Window c c NoGeometry, CurrentAtEnd, IconifiedAtEnd

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 20 Oct 2002 13:41:34 -0700

>> Key Tab   A    M    WindowList (CurrentPage) NoGeometry, CurrentAtEnd, IconifiedAtEnd
  [...]
  >You should be using a not up to date cvs version, because
  >the current one does what you describe. This was broken
  >two weeks ago (and in 2.5.3).
  >

thanks. I think you've told me once about that at some
point. I use it and like it, just temporarily took it out
while trying to figure out the behaviour business :-)

Also, just cvs update'd and rebuilt - still the same
problem.

Using the string just as you suggested, I get the following:

when I have 4 windows open: presently active 'mutt',
inactive FvwmConsole, '.fvwm2rc', and 'vim', and hit
alt-tab, and dont release it, first window is '.fvwm2rc'.
Mutt is now the very last window (probably due to
CurrentAtEnd). Now, I release my alt key, and I am switched
to '.fvwm2rc' window. all is good. 

Now, I repeat the process:
while holding alt-tab, first window is now 'vim', last is
'.fvwm2rc', and pre-last is 'mutt'. So, when I release my
alt, I am switched to console.

What I would like, is get switched back to mutt on my second
operation.

It seems to behave consistently with what I would expect
from CurrentAtEnd, so perhaps this is not really the option
I am looking for? I tried playing with ReverseOrder as well
to chieve the behavior, but can't quite get it.

Please let me know if I am not being clear enough.

denis

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 20 Oct 2002 13:56:41 -0700

Mikhael,

  >Please let me know if I am not being clear enough.

sorry to take up your time with this, but I found another
thread on the subject. You emailed the patch out to fix
this. Is it possible that it did not get propagated into
cvs?

      From: Mikhael Goikhman <[email-masked]>
      Date: Sun, 6 Oct 2002 02:02:30 +0000
      To: FVWM <[email-masked]>
      Subject: Re: FVWM: alt-tab

Andrei, original poster in that thread, reported that it
worked as desired after patch application. If you think it
has been applied, I will go and try to figure out what's
going on.

I will take my 2.5.x questions to fvwm-workers after this
email, I promise ;).

thanks.

denis

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 20 Oct 2002 23:39:15 +0000

> this. Is it possible that it did not get propagated into

Probably we use different cvs repositories or something like this. :)
It got propagated for me and both FlipFocus and WindowList work well.

2002-10-06  Dominik Vogt  <[email-masked]>

	* fvwm/focus.c (__update_windowlist):
	(__set_focus_to_fwin):
	fixed reversal of __update_windowlist arguments causing FlipFocus to
	break [and maybe other things]

If you see this entry in ChangeLog and still have problems with
WindowList, rereport the problems with the reproduction directions.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 20 Oct 2002 17:01:53 -0700

>WindowList, rereport the problems with the reproduction directions.

Ok, I am an idiot. For the benefit of others who may come
accross the same problem: 

   AddToFunc WindowListFunc
   + "I" WindowId $0 Iconify -1
   + "I" WindowId $0 FlipFocus
   + "I" WindowId $0 Raise
   + "I" WindowId $0 WarpToWindow 50 50

In the above function I used to have "Focus", not
"FlipFocus" and things did not work. Now it works. 

YEEEAAAHHHHHHH!!!!!

thanks :-)

denis