Subject: Re: FVWM: getting back to old behavior of pager (just upgraded to 2.4.6)

From: Dominik Vogt <[email-masked]>
Date: Sat, 5 Oct 2002 23:33:49 +0200

On Sat, Sep 28, 2002 at 12:08:25AM -0400, Daniel Barclay wrote:
> 
> 
> How can I configure the pager window so that it behaves as before?
> (I just upgraded to FVWM version 2.4.6 (by upgrading to Debian 3.0 (woody)).)
> 
> 
> Specifically, it used to work like this:
> 
> - if I raised it, it went into stay-on-top mode;
> 
> - if I lowered it, it lowered and partipated normally in the z order 
>   until I raised it again.  (That is if I lowered other windows, it
>   might end up on top of them, but I could re-raise those windows 
>   and it would remain behind them until I raised it directly and it 
>   reverted to stay-on-top mode.

Try something like this:

  AddToFunc my_raise
  + I Current (FvwmPager) Layer 0 6
  + I Current (!FvwmPager) Raise

  AddToFunc my_lower
  + I Current (FvwmPager) Layer 0 4
  + I Current (!FvwmPager) Lower

  Then replace all calls of "Raise" and "Lower" in your config
  file with "my_raise" and "my_lower".  Depending on how you work
  on your desktopn, this may not work very well for you
  (specifically, clicking inside the pager window to raise it does
  not stick it on top).  Feel free to ask again if it's not good
  enough yet.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Daniel Barclay <[email-masked]>
Date: Wed, 09 Oct 2002 20:20:09 -0400

> From: Dominik Vogt <[email-masked]>
> 
> > ...
> > How can I configure the pager window so that ...
> > ...
> >   until I raised it again.  ...
> ...
>   AddToFunc my_raise
>   file with "my_raise" and "my_lower".  ...

Thanks.

Two follow-up questions:

How do I specify multiple actions ("Layer 0 4" followed by "Lower")?

Can I bind mouse actions to a specific window?  That is, can I add
some syntax like "(FvwmPager)" to a configuration statement/line/whatever
like:

  Mouse 1	TS	A	Move-or-Raise

to make it apply to just the named window?

Thanks,
Daniel
-- 
Daniel Barclay
[email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 10 Oct 2002 16:08:53 +0200

> How do I specify multiple actions ("Layer 0 4" followed by "Lower")?

By definig a complex function:

  AddToFunc my_lower_to_layer_4
  + I Layer 0 4
  + I Lower

  AddToFunc my_raise_to_layer_6
  + I Layer 0 6
  + I Lower

Then call

  my_lower_to_layer_4

or

  my_raise_to_layer_6

> to make it apply to just the named window?

Not exactly, but you can simulate it with conditional commands:

  Mouse 2 TS A my_lower

  DestroyFunc Move-or-Raise
  AddToFunc Move-or-Raise
  + C my_raise
  + M my_raise
  + M Move

  AddToFunc my_raise
  + I ThisWindow (FvwmPager) Layer 0 6
  + I Raise

  AddToFunc my_lower
  + I ThisWindow (FvwmPager) Layer 0 4
  + I Lower

Bye

Dominik ^_^  ^_^