Subject: FVWM: FVWM and xft2 problems

From: Rahul Rekapalli <[email-masked]>
Date: Fri, 11 Oct 2002 23:38:11 +0530

Hi,
i downloaded a nightly build of the latest xfree86 server. then i tried
to compile fvwm on it. however, fvwm doesn't detect xft2. I then
searched for xft-config and it was not provided by the new xserver. i
then referred to the fvwm mailing list archives, and found the topic of
discussion abt xft2. someone had tried to use some patch to acinclude.m4
as a solution which was then discarded by others who contested that the
way of patching was wrong. Can anyone help me compile fvwm?
i did find fontconfig-config and freetype-config in /usr/X11R6/bin
I am not stuck because i had removed x b4 and did a clean install of the
xserver the latest cvs build which was built successfully. can anyone
post a patch if there exists one, or provide a solution?

regards
Rahul
-- 
---------------------------------------------------
		the bug stops here
---------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 11 Oct 2002 23:27:25 +0200

> post a patch if there exists one, or provide a solution?

It is strange that xft-config is not installed under the X bin
directory. I just update the current X cvs and make install
fontconfig and Xft and I get a new xft-config at the good place.
Maybe Xft fail to compile (I do not know if make World will
generate a fatal make error in this case). Do you have 
the file /usr/X11/lib/libXft.so.2.0 ?

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Sat, 12 Oct 2002 09:54:55 +0200

On Sat, Oct 12, 2002 at 10:23:08AM +0530, Rahul Rekapalli wrote:
> Yes I have libXft.so.2.0. there are a couple of links in that directory
> which are broken. libXtrap.so, libXrandr.so, libXcursor.so. i wonder if
> it has anything to do with it. 
> 

Do not know.

> and I built X from a nightly build source rpm available at
> fr2.rpmfind.net.
>

Does

rpm -qf /usr/X11R6/lib/libXft.so.2.0

match your new X rpm?

Maybe you should send a bug report to the builder of
the rpm you use.

> do I have to install fontconfig and Xft separately?
>

Maybe. There is a separated package for fontconfig, XRender and
Xft. Its name is "fontconfig" and a source tarball can be found
via http://fontconfig.org

Regards, Olivier

---

From: "S. Anderson" <[email-masked]>
Date: Fri, 11 Oct 2002 12:42:03 -0600

> post a patch if there exists one, or provide a solution?

no patching is needed. if you send the errors someone can help you :-)

cya,
sa