Subject: RE: FVWM: new install on Solaris 9

From: McIntosh Donald <[email-masked]>
Date: Tue, 1 Oct 2002 10:30:11 +0100

Hi...

I just tried logging in there and did Ctrl-Alt-Escape once the it had hung
and nothing happened.  I'm not sure what this key combination was intended
to do, but it had not effect.

By chance, I have found something that does let me log in cleanly every
time.  Bizarrely, and for no reason that I can think of, changing the window
manager startup timeout has an effect.  If I reduce the
Dtsession*waitWmTimeout in my .Xdefaults from 2 seconds to 1 second, the
login works every time.  Apparently when the Window Manager starts up almost
immediately it doesn't encounter the error.

I can't explain why this fixes the problem.  If anyone has an ideas, please
let me know.

Cheers,
Donald.

-----Original Message-----
From: Dan Espen [mailto:[email-masked]]
Sent: Friday, September 27, 2002 5:07 PM
To: McIntosh Donald
Cc: [email-masked]'
Subject: Re: FVWM: new install on Solaris 9 

McIntosh Donald <[email-masked]> writes:
> Hi...
> 
> I've just installed fvwm 2.4.11 on Solaris 9.  It compiled and installed
> without any problems.
> 
> The problem I am having is that during login, it seems to have a problem
> processing the .fvwm2rc file.  It gets so far and then my machine "beeps"
> and I'm left with only the config it's processed up until that point
> (normally just my mouse menus).  I then do a restart of fvwm and it all
> comes up, including my FvwmButtons.  I've tried it with the sample
.fvwm2rc
> files and I still get the same thing, so it's not just my .fvwm2rc file.
> 
> Does anyone know why fvwm2 "hangs" half way through startup and then works
> perfectly after a restart?

Hi.

I've been thinking about this one, and I just saw your newsgroup
post, so I figure you're getting anxious.

Does Ctrl-Alt-Escape help?

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854

ACCA may monitor and read all e-mails as it is presumed that they are sent or received in connection with the business of ACCA or for business use only. ACCA also monitors e-mails for security reasons to ensure that no unauthorised disclosure of ACCAs confidential information is passed via the e-mail system.

This e-mail and any attachments are confidential.  It is intended for the recipient only.  If you are not the intended recipient, any use, disclosure, distribution, printing or copying of this e-mail is unauthorised.  If you have received this e-mail in error, please immediately notify the sender by replying to this e-mail and delete the e-mail from your computer.

The contents of any attachment to this e-mail may contain software viruses, which could damage your own computer system.  While ACCA has taken every reasonable precaution to minimise this risk, we cannot accept liability for any damage which you sustain as a result of software viruses.  You should carry out your own virus checks before opening the attachment.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 01 Oct 2002 06:26:06 -0400

> I can't explain why this fixes the problem.  If anyone has an ideas, please

Hmm, I should have connected Solaris 9 and CDE, but on the Solaris
systems I've used, I disable the CDE login manager.

The FAQ doesn't include your symptom, but question 2.2 does
discuss starting Fvwm with CDE.