Subject: FVWM: set fvwm default wm

From: Eduardo Gargiulo <[email-masked]>
Date: Thu, 17 Oct 2002 16:51:02 -0300

Hi all

I'd recently updated my debian/stable. After that, when I login to xdm,
the wm is blackbox. I want to switch to fvwm, but I don't know how. How
can I force to start fvwm?

TIA

-ejg
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jan Exss <[email-masked]>
Date: Thu, 17 Oct 2002 22:49:13 +0200 (CEST)

> can I force to start fvwm?

Globally as root:

# update-alternatives --config x-window-manager

Then select /usr/bin/fvwm2 as the one with the highest priority.

As a regular user:

Check where fvwm2 is installed:

$ type fvwm2
fvwm2 is /usr/bin/fvwm2

Edit $HOME/.xsession like that:

$ cd
$ cp .xsession .xsession.old
$ echo '#!/bin/sh' > .xsession
$ echo 'exec /usr/bin/fvwm2' >> .xsession
$ chmod 755 .xsession

If you are using xdm that's all. If you are using gdm, select Xsession as
the login session.

Jan

---

From: Glyn Millington <[email-masked]>
Date: Thu, 17 Oct 2002 21:01:38 +0100

> can I force to start fvwm?

update-alternatives --config x-window-manager

Glyn