Subject: FVWM: Conditional Commands

From: Kingsly John <[email-masked]>
Date: Thu, 24 Oct 2002 03:17:49 +0530

Hi!

How does one use the Conditional Commands to select a particular window ?

The only thing that I've been able to get working is WindowId, by explicitly
specifying the window id in this fashion...

Key F10 A M WindowID 0x280000e Iconify toggle

But I just can't figure out how to get it going using window titles with any
of the other commands 

Key F10 A M Any (CurrentDesk, Mutt) Iconify toggle

Key F10 A M Any (CurrentDesk, "Mutt") Iconify toggle

etc have no effect whatsoever.

I guess I'm missing something very basic out here.(I'm using the CVS version
... couldn't wait till 2.5.4 was released before I could use the tinting
effects! :o)

Also is there any way to get windowID of a running window using the window
title ?

Kingsly

-- 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Oct 2002 22:59:21 +0000

> etc have no effect whatsoever.

You should use either "All" or "Next", not "Any".

> ... couldn't wait till 2.5.4 was released before I could use the tinting

It will be released once the recent bug fixes are at least tested for some
days.

> Also is there any way to get windowID of a running window using the window

It is tricky, but possible. From a shell:

  % xwininfo -name "FvwmConsole" | grep "Window id" | cut -d" " -f4

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Oct 2002 00:50:57 +0200

> ... couldn't wait till 2.5.4 was released before I could use the tinting

Specifically, the "Any" command is broken and works like "None".
In any case, it wouldn't do what you want here.  The action of the
"Any" command is executed if a window exists that matches the
conditions.  But it is executed outside of any window context, so
"Iconify" would ask you to select a window.  What you want is

  Key F10 A M Next (CurrentDesk, mutt) Iconify toggle

or

  Key F10 A M All (CurrentDesk, mutt) Iconify toggle

> Also is there any way to get windowID of a running window using the window

Yes.  The "$w" variable is expanded to the WindowId of the
current context window.  For example,

  Next (mutt) echo $w

prints the window id of the next window with the
title/class/resource "mutt".

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 24 Oct 2002 02:51:13 +0200

> It will be released once the recent bug fixes are at least tested for some

Why such an effort for a release marked as "experimental
unstable"?  Things will stabilize much faster with an early
release.

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 24 Oct 2002 01:32:30 +0000

> unstable"?  Things will stabilize much faster with an early

If someone wants an experimental unstable, he already may use daily
snapshots or cvs. I would like to have 2.5.4 to be a hihger quolity than
daily snapshots. Another reason is that I want to base an experimental
fvwm-themes-0.7.0 on fvwm-2.5.4 later.

If there will be no potentially problematic changes in a day or two,
2.5.4 will be released on the weekend.

Regards,
Mikhael.