Subject: FVWM: Iconifying Eterms / Default Eterm Style

From: "Ed Powers" <[email-masked]>
Date: Sun, 13 Oct 2002 01:55:25 +0500

Greetings.

I've been working with iconbox to have my icons be arranged in a certain location of my screen(s) and have had quite a bit of success.

However, I've noticed that my Eterm's (and only my Eterm's at least thus far) do not iconify properly - they completely ignore the iconbox set up.  Upon further investigation I found that the Eterm's do not adhere to the:

  style "*" icon "window.xpm"

line that I have.

So, my guess is iconbox is ignoring them because they don't even *have* an icon.  It seems, however, that only the "icon" option of style is broken.  The Eterms do correctly inherit border, handles, etc from the default style "*" config lines.

For grins, even though I don't want to do it this way, I tried to run an Eterm and specifying the icon with (I really want FVWM to handle this):

  Eterm -name foo

or

  Eterm -title foo

And then, even with:

  style "foo" icon "bar.xpm"

No icon, and (I think hence) no dice with iconbox.

Any info or pointers stating why Eterm is not picking up the icon from my style "*" line would be great.

Thanks!
-ed
-- 
_______________________________________________
Talk More, Pay Less with Net2Phone Direct(R), up to 1500 minutes free! 
http://www.net2phone.com/cgi-bin/link.cgi?143 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 12 Oct 2002 21:58:54 +0000

> Any info or pointers stating why Eterm is not picking up the icon from my style "*" line would be great.

You say that you don't have any icon for Eterm at all or you have the
wrong icon? Eterm supplies its own icon picture and you should see it.
If no, something is wrong here.

Anyway, if you want to override the icon that Eterm supplies do:

  Style Eterm* IconOverride

BTW, Eterm is not the only application that provides icon picture hint.
If you use unified icon set and don't want applications to add chaos
(every application may have its own idea how its icon should look and of
which size), you may do:

  Style * IconOverride
  Style XTerm NoActiveIconOverride  # enable: xterm +ai

Tell us whether this solved your problem or not.

Regards,
Mikhael.