Subject: FVWM: where does stderr go to?

From: Victor Eijkhout <[email-masked]>
Date: Tue, 1 Oct 2002 13:54:10 -0400

'Echo' writes to stderr. Fine, but which xterm is displaying stderr? 
I've even tried "xterm -C", but that didn't show anything either.
-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 01 Oct 2002 14:48:08 -0400

> I've even tried "xterm -C", but that didn't show anything either.

That depends on how you start Fvwm.
Are you using startx, CDE, or some other login manager?

Fvwm doesn't reopen or redirect stderr, whatever the parent
process did with it, stays in effect.

-- 
Dan Espen                           E-mail: [email-masked]

---

From: Victor Eijkhout <[email-masked]>
Date: Tue, 1 Oct 2002 15:06:23 -0400

>Are you using startx, CDE, or some other login manager?

On Mac OS X the whole of X starts by clicking on some application.

I guess that means stderr gets lost somewhere.

I'll see what happens if I start X by 'startx' from a terminal.

But on a normal workstation, after you type 'startx' you don't see 
the original shell anymore. How can you then look at stderr output?

---

From: Dan Espen <[email-masked]>
Date: Tue, 01 Oct 2002 15:17:13 -0400

> the original shell anymore. How can you then look at stderr output?

If you type startx in Linux console 1, you can switch back to
it by typing Ctrl-Alt-F1 and then you see stderr.

For Linux, I sometimes do:

startx >/tmp/startx.out 2>&1

---

From: Victor Eijkhout <[email-masked]>
Date: Tue, 1 Oct 2002 15:35:54 -0400

>startx >/tmp/startx.out 2>&1

And then you can 'tail -F' it, right? That should do the trick.

---

From: Dan Espen <[email-masked]>
Date: Tue, 01 Oct 2002 16:01:22 -0400

> And then you can 'tail -F' it, right? That should do the trick.

Yep, that's the ticket.