Subject: FVWM: transparent parts of xpm icons

From: Rastislav Galia <[email-masked]>
Date: Thu, 5 Sep 2002 19:22:12 +0200 (CEST)

Does fvwm2 allow to create a simple framing window around each individual 
icon in a similar way as MWM does ? Hitting the .xpm icons with 
transparent portions is sometimes a tricky task.

/Rastjo

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 05 Sep 2002 13:32:43 -0400

> transparent portions is sometimes a tricky task.

I answered your question yesterday in comp.windows.x.apps.

Here is the same answer again:

Nope.

I've heard that .png icons with newer releases of XFree86
allow for you to click on the transparent parts.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Thu, 5 Sep 2002 23:29:59 -0600

> allow for you to click on the transparent parts.
I think that was a bug, it seems to be fixed now :-)

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 6 Sep 2002 09:32:06 +0200

> I think that was a bug, it seems to be fixed now :-)

Yes. But you can click on the shaded part of a png icon. Also you may
build png icons with a quasi-transparent part by using an alpha
channel of 1 (for the transparent part). Then, you will be able to click
on the "transparent part". Any way, I hope that with fvwm 2.6 it will
be possible to define (with colorset) backgrounds for icons.
  Note: in the next devel release alpha blending may work with
any X server.

Regards, Olivier