Subject: Re: FVWM: Non iso8995-1 fonts and the TaskBar

From: Dominik Vogt <[email-masked]>
Date: Tue, 3 Sep 2002 23:50:04 +0200

Olivier, have you seen this mail?

On Mon, Aug 12, 2002 at 06:29:28PM +0100, John Latham wrote:
> FvwmTaskBar crashes, quietly without any trace, in 2.4.6 as shipped by Red Hat
> 7.3 (multi-byte is enabled) and also in 2.4.8 when compiled with multibyte
> option, but not otherwise.
> 
> The task bar just refused to appear, and left no error message not even a core
> dump. Don't ask me how I figured out this was with the setting that caused the
> problem
> 
>         *FvwmTaskBarFont -*helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
> 
> and changing it to the following makes it work okay:
> 
>         *FvwmTaskBarFont -*helvetica-medium-r-*-*-12-*-*-*-*-*-iso8859-1
> 
> I assume it was picking up some font encoding that FvwmTaskBar cannot handle
> -- does that make sense?
> 
> This behaviour was still happening after I changed to POSIX locale (see
> previous message): it seems you need BOTH the posix locale and the iso8859-1
> to make it work in 2.4, if multi-byte is emabled.
> 
> Similarly, FvwmPager was using the wrong font until I put the iso8859-1 spec
> on that too. At least it wasn't crashing!
> 
> All this seems to work fine on 2.5.2, no need for locale change or iso8859-1
> specification.
> 
> This all makes me think I could do with learning a *bit* more about X fonts
> and their relationships to locales. Can anyone suggest a good (implies
> short...) summary on the matter?
> 
> Best wishes, John Latham

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Eric Gillespie <[email-masked]>
Date: Tue, 03 Sep 2002 21:14:39 -0500

I may or may not be having a similar problem, though i am running
HEAD as of this afternoon (i've seen this ever since i switched
back to Fvwm a few weeks ago).  When viewing
<http://daemonnews.org/> with Mozilla, my title bar displays the
'ae' character without trouble, but IconMan just shows a question
mark.

I use the following fonts:

Style * Font "xft:Verdana:size=8;fixed"
*FvwmIconMan: font "xft:Verdana:size=10;fixed"

Same font, just different sizes.  I'm guessing something is being
run through iconv in one place but not the other, but that's just
a guess.

--  
Eric Gillespie <*> [email-masked]

Build a fire for a man, and he'll be warm for a day.  Set a man on
fire, and he'll be warm for the rest of his life. -Terry Pratchett
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Wed, 4 Sep 2002 11:38:52 +0200

On Tue, Sep 03, 2002 at 09:14:39PM -0500, Eric Gillespie wrote:
> back to Fvwm a few weeks ago).

The problem is different.

> When viewing

Do you have the pb with 
	*FvwmIconMan: font "xft:Verdana:size=8;fixed"
?

Note that the font loaded depends on the version of xft.

> run through iconv in one place but not the other, but that's just

Maybe

Regards, Olivier

---

From: Eric Gillespie <[email-masked]>
Date: Wed, 04 Sep 2002 19:10:35 -0500

> 	*FvwmIconMan: font "xft:Verdana:size=8;fixed"

Yes, the same problem occurs with that font setting.

> Note that the font loaded depends on the version of xft.

Yeah.  I can tell this is the same font.

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 5 Sep 2002 11:48:26 +0200

> I assume it was picking up some font encoding that FvwmTaskBar cannot handle

There is a bug in the taskbar, if the SelFont is not found the taskbar
exit (the "default" font is not tried!). This will be fixed in the next
stable release. Any way if you use:

	-*-*helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
	 ^^

I think that the taskbar will work as you want (no locale change and this
is better than enforcing the charset).
I still do not understand why with
	"-*helvetica-medium-r-*-*-12-*-*-*-*-*-*-*"
the font loading procedure fails (as xlsfont show me some fonts, but
xlsfont do not use the "i18n" procedure for querying font).
But I do not think that it is fvwm fault. Maybe a "*" count issue.

> on that too. At least it wasn't crashing!

Use "-*-*helvetica-medium-r-*-*-12-*-*-*-*-*-*-*"

> short...) summary on the matter?

"man XCreateFontSet" and the xlfd and i18nFramework documents in the X doc
directory (something like /usr/X11R6/lib/X11/doc). Maybe you will not
find this docs "good".

Regards, Olivier

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 6 Sep 2002 11:35:13 +0200

> Yeah.  I can tell this is the same font.

Ok, what about 

*FvwmIconMan: * format %t

? Maybe this an icon/window name problems.

In any case, can you summit a bug report via the bug tracking system.

Regards, Olivier

---

From: Eric Gillespie <[email-masked]>
Date: Fri, 06 Sep 2002 20:28:40 -0500

> ? Maybe this an icon/window name problems.

Oh, weird.  That's exactly what it was.  So i guess Mozilla is
providing a bogus value for its icon title even though it
provides it correctly for the regular title?  Guess i'll go
submit a Mozilla bug...

Thanks.