Subject: FVWM: 'Next' window based on coordinates?

From: Victor Eijkhout <[email-masked]>
Date: Tue, 24 Sep 2002 06:16:35 -0500

How do I cycle through windows so that Next takes the one with next 
highest x coordinate?
-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Sep 2002 12:54:49 +0200

> How do I cycle through windows so that Next takes the one with next 

Try the "Direction" command.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Victor Eijkhout <[email-masked]>
Date: Wed, 25 Sep 2002 09:03:05 -0500

>Try the "Direction" command.

Cool. I missed that one reading the man pages.

Btw, I think it would also make sense to base the choice of the 
window not on the midpoint but on the edge, for instance left edge if 
you specify Direction East. And maybe look at the lowerleft corner if 
Direction NorthEast, &c.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 25 Sep 2002 16:30:00 +0200

> you specify Direction East. And maybe look at the lowerleft corner if 

The potential tuning possibilities are endless.  I could easily
think of a dozen different scoring algorithms or even a custom
shell script that calculates the score and is called for each
window.

The current algorithm was written to minimize surprises, but the
right one for you looks probably differently.

To sum it up, I'm certainly willing to add tuning options to the
Direction command, but my time to do it myself is limited at the
moment.

Bye

Dominik ^_^  ^_^

---

From: Victor Eijkhout <[email-masked]>
Date: Wed, 25 Sep 2002 20:58:40 -0500

>  > > >Try the "Direction" command.

Could someone look at the source for obvious bugs in this? I set up 
Shift-{Left,Right} to do Direction {West,East} Focus, and if there is 
a window that is (totally, or almost so) contained within the outline 
of another (but not with coincident centres) it gets focus only one 
of the two directions. For instance, if it's offset to the right, it 
only gets focus if I'm arrowing left.

This is fairly reproducible.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 26 Sep 2002 16:02:24 +0200

> only gets focus if I'm arrowing left.

Sure, that's exactly how it's described in the man page.  If the
center of the new window is left of the center of the old window,
only "W" works.  In 2.5.4, there is a new direction "C"enter that
just works on the closest window in any direction.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].