Subject: FVWM: making a selected window stay on top

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 18 Sep 2002 14:19:21 -0700

Hello,

I am trying to add a command to the window to stay on top.
I know of a Style option, but I dont think its appropriate
here?

I'd like to do something like :

   DestroyMenu Window-Ops
   AddToMenu Window-Ops 
   + " Window Ops (ALT-F1)"               Title
   + " [Un] StaysOnTop"                   <WHAT GOES HERE?>

I looked through the built-in fvwm function list, and could
not find a function to call :(

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 18 Sep 2002 22:45:54 +0000

> not find a function to call :(

It is called Layer.

  + "StaysOnTop"    Layer 0 6
  + "StaysPut"      Layer 0 4
  + "StaysOnBottom" Layer 0 2

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 18 Sep 2002 23:12:11 +0000

>   + "StaysOnBottom" Layer 0 2

Or if you really don't want one additional StaysPut menu item, in 2.4.6+:

  + "StaysOnTop"    SwapWithLayer 6
  + "StaysOnBottom" SwapWithLayer 2

  AddToFunc SwapWithLayer
  + I ThisWindow (Layer $0) Layer 0 10
  + I ThisWindow (Layer  4) Layer 0 $0
  + I ThisWindow (Layer 10) Layer 0 4

Actually you may do all this with only one menu item by 3-value looping
(Normal -> OnTop -> OnBottom -> Normal). Left as an exercise.

Regards,
Mikhael.