Subject: Re: FVWM: i can't run fvwm 2.4

From: John Latham <[email-masked]>
Date: Mon, 2 Sep 2002 16:46:48 +0100

> From: Dominik Vogt <[email-masked]>
> Date: Mon, 2 Sep 2002 11:01:14 +0200

> On Thu, Aug 29, 2002 at 07:13:18PM +0100, John Latham wrote:
> > > Date: Thu, 29 Aug 2002 10:17:29 +0200
> > > From: Dominik Vogt <[email-masked]>
> > 
> > > > I > was building a Red Hat ready fvwm2.5.2 RPM
> > >
> > > > which we are probably going to use here at Manchester CS.
> > >
> > > Don't do that!  It's not even alpha quality.

...

> Don't let perceived stability fool you.  You just haven't
> triggered the buggy or crashing parts.  That's fine for you as an
> individual, but don't underestimate the creativity of 700 users.
> Oh, and bugs that were introduced and fixed in the development
> versions *don't* show up in the NEWS, only in the ChangeLog.

...

> Just to make this clear:  No 2.5.x release was 'alpha' quality
> yet.  Being 'alpha' means that it is good enough to consider
> heading for a stable release after extensive tests have been done.
> That's why it's called a 'development release' in the NEWS.

Ah. On the FVWM home page it says:

	Latest Alpha Release:  2.5.3

which I must admit has coloured my thinking a bit.

Thank you for the very sobering warning. *If* we go with 2.5 it will be
monitored very carefully and we will fall straight back to 2.4.x if we have
problems.

But I suspect it is easy for you to underestimate the dire pain already caused
by the Java/FVWM mismatches!!!! (It's also easy to overestimate our users'
creativity -- more to the pity!!) I'll weigh up the 2.4 Java weapons with the
2.5 ones. I've just noticed that the one I thought might be the most helpful,
ResizeHintOverride actually is already there in 2.4 -- for some reason I
thought it was only in 2.5. (I am hoping this will help combat the quite
common but appalling 1x1, modal, nonresizable dialog ``feature''!!!!)

> > Of course, I'll have RPMS for 2.4.[6-9] up my sleeve in case the worst should
> > happen.
>
> Bye
>
> Dominik ^_^  ^_^

Best wishes, John Latham
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Sep 2002 17:55:06 +0200

> which I must admit has coloured my thinking a bit.

Doh.  When the web site is updated the next time it will read
"very unstable" instead of "alpha".

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bruce M Beach <[email-masked]>
Date: Tue, 3 Sep 2002 12:02:41 +0000 (UTC)

> "very unstable" instead of "alpha".

1)  I am at this point using 2.5.2 more or less because I have to.
    I used a very early version of fvmw for years with no problems
    and then upgraded to xwindows 4.2 which caused significant problems
    with the mouse-menu interaction. An upgrade to fvwm-2.4.8 did not
    solve the problems whereas the alpha version fvwm-2.5.2 did. I've
    used fvwm-2.5.2 for a while now and for my use it works fine.
    With fvwm-2.5.3 the problems started again.

2)  It looks like the following are not getting execute permission
    when installed. For instance:
        sh-2.05b# fvwm-bug
        sh: /usr/local/bin/fvwm-bug: Permission denied
    A chmod fixes it.

   fvwm-bug
   fvwm-config
   fvwm-convert-2.4
   fvwm-convert-2.6
   fvwm-menu-desktop
   fvwm-menu-directory
   fvwm-menu-headlines
   fvwm-menu-xlock
   fvwm-perllib

3) I built with the following configure options
       --enable-debug-msgs
       --enable-command-log
   and it builds fine but I don't understand where the messages
   get piped to. syslogd? an fvwm console?

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 3 Sep 2002 08:31:47 +0000

>     With fvwm-2.5.3 the problems started again.

I think your short description (in another thread) is not enough to
understand the problem. Please add more details to that message.
What is the "mouse-menu" problem and what to do exactly to reproduce it.

>         sh: /usr/local/bin/fvwm-bug: Permission denied

Seems unlikely to me that they are installed without a+x.
Please do the following:

  #cd fvwm_installation_dir
  cd bin/
  make uninstall  # as root
  make
  make install  # as root

Then send the output of "make install" and "ls -l /usr/local/bin/fvwm-*".

>    get piped to. syslogd? an fvwm console?

This depends on how you start the fvwm executable. If you call it in
~/.xinitrc without redirection to a file, the output will be together
with the X output, possibly on your virtual console.

Display managers like xdm/gdm/kdm may redirect the output to a file.

I don't think these debugging options are very useful to you, the output
is noisy and hides the real error messages that may appear on stderr.

Regards,
Mikhael.

---

From: Gregg Dameron <[email-masked]>
Date: Tue, 03 Sep 2002 11:27:37 -0600

John Latham wrote:

> I've just noticed that the one I thought might be the most helpful,

If a solution to the 1x1 presents itself, please post it.  We've been fighting this
one in 2.4.7 (and prior to that, under fvwm95 for many years).  It seems to happen
more frequently if the CPU is under load.

Gregg Dameron

---

From: Bruce M Beach <[email-masked]>
Date: Thu, 5 Sep 2002 10:49:36 +0000 (UTC)

> What is the "mouse-menu" problem and what to do exactly to reproduce it.
  It wasn't really a bug report. I was just commenting on
  the two development releases fvwm-2.5.2 and fvwm-2.5.3
  since Dominik is rewriting this area it wouldn't make sense to
  submit a bug report at this time.

> >    fvwm-menu-desktop ...........
>
>   make uninstall  # as root ...........

   I tried the above. Make install works fine but if you
       make -k install-strip
   then the problem occurs.

> with the X output, possibly on your virtual console.
   Thanks for the info. The above idea does what I want. i.e
   startx >>/var/log/win_system_log 2>&1
   gives me everything.

   What I had in mind was the thread on the bash syntax. If
   a log was running I would have immediately seen

  /bin/sh: -c: line 1: syntax error near unexpected token `;'

  and now that I have have the log running I notice that I have
  a million errors in my fvwm2rc script.

  Bruce