Subject: FVWM: auto-raise events in pager? or something..

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 15 Sep 2002 14:31:10 -0700

Hello,

first of all, sorry, I dont know how to properly phrase the
question, so I'll try the example.

I am using gAIM as my instant messenger. When I have some
conversation window open and receive a message, the window
is raised. My focus follows mouse, so the window does not
seem to get the focus.

The question, then, is whether it is possible to be on a
different desktop, and have this Gaim window start blinking,
change color, etc when some raise event is received?

please let me know if the question was not clear.

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 15 Sep 2002 22:11:40 +0000

> please let me know if the question was not clear.

I will answer the following question that may be not what you want, but
at least it is stated clearly. :)

"I have 4 desktops (each one 2x2 pages). My main Gaim window is on desktop
number 0. I am on desktop number 2. A window pops up on desktop 0 (or a
window is raised by Gaim, or deiconified by Gaim). I want to have a more
visual notification when this happens than using a pager."

The answer is: if FVWM does something with this window and you want to add
more operations, setup FvwmEvent to do Beep or Iconify/DeIconify several
times or Maximize/UnMaximize on the appropriate event.

  AddToFunc StartFunction I FvwmEvent FvwmEvent-MyBlink

  *FvwmEvent-MyBlink: PassId
  *FvwmEvent-MyBlink: Cmd
  *FvwmEvent-MyBlink: add_window BlinkSomeWindows
  *FvwmEvent-MyBlink: raise_window BlinkSomeWindows

  AddToFunc BlinkSomeWindows
  + I WindowId $0 (MyGaimWindowIWantToBlink) Beep
  + I WindowId $0 (MyGaimWindowIWantToBlink) WarpToWindow 50 50
  #+ I WindowId $0 (MyGaimWindowIWantToBlink) WindowShade on
  #+ I WindowId $0 (MyGaimWindowIWantToBlink) WindowShade off

You probably only need one "add_window" or "raise_window".
Be careful, you may easily auto-do something that is very annoying.

Regards,
Mikhael.