Subject: FVWM: fvwm2 and hpux11.i

From: Frank Thyes <[email-masked]>
Date: Sun, 22 Sep 2002 08:23:36 +0200

Hy,
i tried to install fvwm-2.4.11 on hp-ux 11.i but the configure
script stops with an error message. Can anybody explain the
meaning of this error? Or better, can anybody show me how to solve
the error?

checking for sys/select.h... (cached) no
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking argument types of select()... configure: error: can't
determine argument types

Config.log

<snip>
int
main ()
{
extern select (unsigned,
 void *,        void *, void *,
 const struct timeval *);
  ;
  return 0;
}
configure:9146: error: can't determine argument types
<snip>

configure (line 9146 - 9151)

<snip>
  if test "$ac_found" = no; then
    { { echo "$as_me:$LINENO: error: can't determine argument types"
>&5
echo "$as_me: error: can't determine argument types" >&2;}
   { (exit 1); exit 1; }; }
  fi
<snip>

Best regards
Frank

-- 
In the beginning was the word and the word was content type:
text/plain

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Sep 2002 07:37:29 -0400

> configure (line 9146 - 9151)

Oops, a little too much snippage.

Just above this area in the config.log, you will see
configure trying to compile different versions of this
routine.

Each time it gets a failure, you will see the error it got,
and then it tries another variation.
It fails because it can't find any variation that works.

On my HPUX 11.11 system, using "cc" (not gcc), this is
the version that works:

#include <sys/time.h>
#include <sys/types.h>
#include <unistd.h>
#include <sys/socket.h>
int
main ()
{
extern select (int,
 fd_set *,	fd_set *, fd_set *,
 struct timeval *);
  ;
  return 0;
}

Does this compile without errors for you?  If not what
errors do you get?

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].