Subject: Re: FVWM: fvwm2 and hpux11.i

From: Dan Espen <[email-masked]>
Date: Sun, 22 Sep 2002 13:06:40 -0400

Frank Thyes <[email-masked]> writes:
> +++ Dan Espen [Sun, Sep 22, 2002 at 01:37:29PM CEST]:
> > #include <sys/time.h>
> > #include <sys/types.h>
> > #include <unistd.h>
> > #include <sys/socket.h>
> > int
> > main ()
> > {
> > extern select (int,
> >  fd_set *,	fd_set *, fd_set *,
> >  struct timeval *);
> >   ;
> >   return 0;
> > }
> > 
> > Does this compile without errors for you?  If not what
> > errors do you get?
> 
> Hy Dan,
> thanks for spending your time... here is the output from the little
> program that i should compile.
> 
> # cc -o test test
> # cd /tmp
> # cc -o test test.c
> (Bundled) cc: "test.c", line 9: error 1000: Unexpected symbol:
> "fd_set".
> (Bundled) cc: "test.c", line 9: error 1000: Unexpected symbol:
> "fd_set".
> (Bundled) cc: "test.c", line 9: error 1000: Unexpected symbol:
> "fd_set".
> (Bundled) cc: "test.c", line 8: error 1705: Function prototypes are
> an ANSI feature.
> 
> What does it mean? My knowledge about programming is not realy big
> :(

Please continue to copy the fvwm list, there are other people
on the list, and if I go astray, one of them is sure to help.

I can reproduce this if I pass the arg "-Ac" or "-Aa" to the
compiler.  Without the arg or with "-Ae" it compiles fine.

You apparently have a different version of the compiler installed
or somehow you are passing different args.

First check and make sure you don't have the environment variable
CCOPTS preset:

echo $CCOPTS

If it is set, unset it and try again.
If its not set, try this:

CCOPTS=-Xe;export CCOPTS

then try to compile the test program.

If that works, try configure.
If that doesn't work, try to find out more about your compiler:

man cc

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frank Thyes <[email-masked]>
Date: Sun, 22 Sep 2002 20:09:48 +0200

> on the list, and if I go astray, one of them is sure to help.

Sorry, i forgot to add the cc-adress

> If that doesn't work, try to find out more about your compiler:

CCOPTS was not set, sure that you mean the option -Xe? Anyway, i'm
going to try -Ae and -Xe

# CCOPTS=-Xe;export CCOPTS
# echo $CCOPTS
-Xe

# cc -o /tmp/test /tmp/test.c
(Bundled) cc: warning 422: Unknown option "X" ignored.
(Bundled) cc: warning 480: The -e option is available only with the
C/ANSI C product; ignored.
(Bundled) cc: "/tmp/test.c", line 9: error 1000: Unexpected symbol:
"fd_set".
(Bundled) cc: "/tmp/test.c", line 9: error 1000: Unexpected symbol:
"fd_set".
(Bundled) cc: "/tmp/test.c", line 9: error 1000: Unexpected symbol:
"fd_set".
(Bundled) cc: "/tmp/test.c", line 8: error 1705: Function prototypes
are an ANSI feature.

The first try -Xe and the second try -Ae, both failed. The last with
message "The -A option is available only with the C/ANSI C product"
rest from output was the same.

The cc compiler:
# what $(which cc)
/usr/bin/cc:
        HP92453-01 A.11.01.21 HP C (Bundled) Compiler
         $   Sep  8 2000 23:13:51 $ 

Cu
Frank
-- 
Diese Mail ist auf Grund von ideologischer Verblendung nach den Regeln
der herkömmlichen Rechtschreibung erstellt. Wer verbleibende Fehler
findet, darf sie behalten oder sammeln, bis sie ein Lösungswort ergeben.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 22 Sep 2002 16:04:05 -0400

> +++ Dan Espen [Sun, Sep 22, 2002 at 07:06:40PM CEST]:
...
>         HP92453-01 A.11.01.21 HP C (Bundled) Compiler

Ok, I see it now.
I did some Google searches.

The bundled compiler apparently only supports K&R C.
I don't think you are going to be able to build Fvwm
with it.

I wasn't able to find any documentation on the compiler
but I do see lots of other programs won't compile with it.

Perhaps you have another compiler installed somewhere else.
On my machine, I have C compilers installed thusly:

 /opt/ansic/bin/cc
 /bin/cc -> /opt/ansic/bin/cc
 /usr/softbench/bin/cc
 /usr/bin/cc -> /opt/ansic/bin/cc
 /usr/ccs/bin/cc -> ./cc_bundled

If you don't have any other HP compiler,  I recommend you
install gcc.

---

From: Frank Thyes <[email-masked]>
Date: Sun, 22 Sep 2002 22:39:09 +0200

> If you don't have any other HP compiler,  I recommend you

That what i have done already... but with the same results. I think i'm
going to compile fvwm with ANSI-C at work, maybe this will work.
If this will work it's a acceptable workaround but the problem still
exist :[

Another idea?

Kindly regards
Frank

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 22 Sep 2002 22:43:48 +0000

> If this will work it's a acceptable workaround but the problem still

I can't add anything to what Dan said. Your compiler is not a correct
compiler. Please install any ANSI-C conforming compiler. Better yet gcc.
If you have problems with these ones, please post the error messages.

Regards,
Mikhael.