Subject: FVWM: Multiple transients getting behind main window

From: Josef Siemes <[email-masked]>
Date: Mon, 2 Sep 2002 20:39:34 +0200

Hi,

I have some problem with transient windows, e.g. in netscape (4.79), also
in java applications.

If I have some transients started from the application the transients sometimes manage
to get behind the main window. For Netscape e.g.:
Netscape -> Settings -> Cache -> Cache Directory. You'll get the main window and
two transients. The problem is: If I click on the title bar from the main netscape
window the second transient (the file-browser) goes behind netscape, while
the first transient (the settings window) stays in front of the main window.
Since netscape wants to have something in the file browser the rest of the windows
are unusable, and the one that's usable is hidden by the others. So I want to have
the file browser before the main window regardless of what I'm doing, or better: all
transients in front of the main window.

Is there any fvwm function that I missed to avoid this? Or do I have to look somewhere
else to get this?

BTW, I use fvwm 2.4.6, 2.4.9 shows the same effect.
In fvwm2rc I have the following things that (AFAIK) refer to transients:
MenuStyle * mwm
Style *  MWMButtons, MWMFunctions, MWMDecor, HintOverride
Style * DecorateTransient
Style * RaiseTransient
Style * LowerTransient
Style * StackTransientParent

Regards,

Josef

______________________________________________________________________________
WEB.DE Club - jetzt testen fur 1 Euro! Nutzen Sie Ihre Chance 
unter https://digitaledienste.web.de/Club/formular/?mc=021105

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 3 Sep 2002 11:03:11 +0200

> Style * StackTransientParent

There is little you can do about it.  Transients of transients are
a very rare case.  Back when we wrote that code we felt it wasn't
worth to take care of that case as it requires a whole lot more
work (on the machine) to do.  If it's a problem I'll eventually
get around to implement it.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].