Subject: Re: FVWM: an idea to Maximization

From: Dominik Vogt <[email-masked]>
Date: Wed, 4 Sep 2002 00:17:05 +0200

On Tue, Aug 20, 2002 at 01:20:30AM +0200, Imre Vida wrote:
> Hi,
> 
> i'm new to fvwm and like it a lot 
> 
> however, i was somewhat puzzled by the way "Maximization" works:
> wanted to define some hotkeys to maximize/grow windows
> horizontally/verticaly or even left/right/up/down
> and by combining these actions to get the best size and location
> (very often i end up with hundreds of windows open and then try to 
> get the "best" out of them  ;-)
> 
> these combinations however do not work: the window switches
> back to it's 'normal' size after the second hotkey and only
> after repeating it, does it do the sec type of maximization
> (and of course only that one this time)
> so obviously, any of these actions is considered as a Maximization 
> and any following action of the same type will be taken as a request 
> to Unmaximize the window (toggle).
> 
> of course, one could use "True" to force the maximizations
> but then the unmaximization "toggle" will not work with the 
> same hotkey
> 
> 
> if there is already the possibility to do vert. and hor.
> maximizations separately, wouldn't it be nicer/more logical
> to also handle them separately (ie. assign two booleans instead of 
> one single)?

Um, actually after reading the man page again I found out that
this is already implemented.  Use

  Maximize true grow 0

and

  Maximize true 0 grow

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 4 Sep 2002 07:29:20 +0000

> > but then the unmaximization "toggle" will not work with the 

    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

> this is already implemented.  Use

This is exactly what the author does not like (read the third paragraphs).

In the private message to me Imre said that what he needed is user window
states to allocate 2 states for vertical and horizontal maximization and
if-else syntax.

Regards,
Mikhael.