Subject: Re: FVWM: Re: 2.5.x questions (Was: i can't run fvwm 2.4)

From: elliot sowadsky <[email-masked]>
Date: Wed, 4 Sep 2002 22:07:19 -0700 (PDT)

<<
   I tried the above. Make install works fine but if you
       make -k install-strip
   then the problem occurs.

Dont know if this is the same thing, but is the "make -k install-strip" to remove the dedebug symbol tables? I just change -g -O2 in configure to -O3.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 5 Sep 2002 08:30:35 +0000

>    I tried the above. Make install works fine but if you

Hmm, I can't reproduce this problem. "/usr/bin/install -c -s ..."
exits with error, but does install a script with +x permissions for me.

Anyway, eventually we'll switch to autoconf-2.53 when creating releases
and "make install-strip" will work well even without -k parameter.

> Dont know if this is the same thing, but is the "make -k install-strip"
> to remove the dedebug symbol tables? I just change -g -O2 in configure
> to -O3.

Yes, more or less the same effect may be done by:

  env CFLAGS="-O3" ./configure

or (before "make install"):

  make CFLAGS="-O3"

Regards,
Mikhael.