Subject: FVWM: FvwmPager in 2.4.9, tips have no background

From: John Latham <[email-masked]>
Date: Tue, 10 Sep 2002 17:13:45 +0100

I'm sure other's must have spotted this, but I can't find a bug report so just
in case:

The balloon windows on the pager have no background -- they appear clear,
except for the label and the think black border. This is when using:

	*FvwmPagerBalloonBack   bisque

and other colours. I haven't tried using a pixmap or a colour set (which may
explain why it has gone unnoticed by many...). I think there may have been
some finger trouble in the latest set of edits -- removing some extraneous
lines, as in the patch below seems to make it work again.

Best wishes, John Latham
---------------------------------------------------------------------------------------------

--- fvwm-2.4.9/modules/FvwmPager/x_pager.c.jtl  Sat Jul 13 23:01:45 2002
+++ fvwm-2.4.9/modules/FvwmPager/x_pager.c      Mon Sep  9 04:14:17 2002
@@ -945,14 +945,6 @@
        Desks[i].balloon.yoffset = 3;
       }
 
-      /* create balloon window
-        -- [email-masked] */
-      valuemask = CWOverrideRedirect | CWEventMask | CWColormap;
-      /* tell WM to ignore this window */
-      attributes.override_redirect = True;
-      attributes.event_mask = ExposureMask;
-      attributes.colormap = Pcmap;
-
       /* now create the window */
       Desks[i].balloon.w = XCreateWindow(dpy, Scr.Root,
                                         0, 0, /* coords set later */
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Sep 2002 18:30:52 +0200

> I'm sure other's must have spotted this, but I can't find a bug report so just

Yup.  Already reported, already fixed.  If all goes well, 2.4.10
is released this week.
 
> except for the label and the think black border.

[snip]

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].