Subject: FVWM: A few fvwm2 questions.

From: "Nils O. Sel�sdal" <[email-masked]>
Date: Tue, 20 Aug 2002 10:16:12 +0200

I have a few fvwm2 questions.
How to display an applications "miniicon" in one of the buttons in the titlebar?
And how to display the miniicon in the window list. (I'm talking about the icon
many apps have "builtin")
How to start an external app at a given location on screen at startup.(it doesnt
support -geometry) ?
And, windows are now iconified at the top left, i want them to start at bottom
left.
--
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Aug 2002 12:46:27 +0200

> How to display an applications "miniicon" in one of the buttons in the titlebar?

First, define the mini icons you want to use:

  Style * miniicon my_default_miniicon.xpm
  Style xterm miniicon my_xterm_miniicon.xpm
  ...

> many apps have "builtin")

The mini icons show up automatically once they are defined, but
you have to do that manually.  The normal icon provided by the
application is not used.

> How to start an external app at a given location on screen at startup.(it doesnt

In the ~/.Xdefaults file you can put something like

  xemacs.geometry: 81x54-0+0

I don't know right know where u find the man page for the syntax.

> And, windows are now iconified at the top left, i want them to start at bottom

Use the IconBox style, e.g.:

  Style * IconBox 1000x200+0-0

(see man page for details).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 Aug 2002 12:15:46 +0000

On 20 Aug 2002 12:46:27 +0200, Dominik Vogt wrote:
> > I have a few fvwm2 questions. How to display an applications
> > "miniicon" in one of the buttons in the titlebar?
> 
> > And how to display the miniicon in the window list. (I'm talking about
> > the icon many apps have "builtin")
> 

In 2.5.x, the mini icon and icon provided by EWMH compliant applications,
for example KDE 2.x/3.x or GNOME 2.x, are used unless explicitly disabled.

So, in 2.5.x you don't need to define MiniIcon and Icon for these apps.
But you can, of course.

> > How to start an external app at a given location on screen at startup.
> > (it doesnt support -geometry) ?
> 

Dominik, you always suggest to edit .Xdefaults, but this usually only
works with apps that already support -geometry or -xrm parameters.

GNOME and KDE applications (or gtk+ and qt applications for that reason)
do not support X resource database, so this suggestion does not work.

Many such applications support --geometry or --position command line
parameters (2 dashes). If no, your solution is FAQ #3.18.

Regards,
Mikhael.