Subject: FVWM: Re: The "great focus policy rewrite"

From: Dominik Vogt <[email-masked]>
Date: Sun, 11 Aug 2002 21:52:41 +0200

On Sun, Aug 11, 2002 at 06:14:06PM +0200, Giuseppe Della Ricca wrote:
> Hi Dominik,
> 
> > > now, the window is focussed but not raised any more (I have the same focus 
> > > options for all my windows)
> > 
> > Fixed.
> 
> no, I'm sorry, I don't think so ...
> 
> the windows are focussed after I click in them ('W') but not raised
> 
> if I start 'FvwmAuto 0' I get what I was used to have, though ...
> 
> > > also, to do the paste of a 'cut-and-paste' between two xterm windows now I 
> > > need 2 clicks (the first changes the focus, the second is the real paste)
> > 
> > Fixed.
> 
> YES !
> 
> > These are not really bugs in the code, but wrong default settings
> > for the four predifined focus policies.  It's a bit difficult to
> > get all of these right so that there is no change in behaviour.
> > 
> > When the work is done, it must not be necessary to change existing
> > configurations (except perhaps in a few *very* strange setups).
> 
> Please feel free to fix it when you think is appropriate !
> There's no hurry !!
> 
> but there's a new thing now: 4 more buttons, 2 on the left and 2 on the 
> right in each window title .... I already have 3+3 buttons, so the corners 
> are really crowded now ... ;-)

All the problems you describe should be gone now.  There is one
incompatibility however.  The ClickToFocus/MouseFocus/SloppyFocus/
NeverFocus style must be set as *first* of all the focus related
styles.  These for reset almost all others when issued, e.g. in

  Style * ClickToFocusRaisesOff, ClickToFocusPassesClickOff
  Style * ClickToFocus

The first line is completely overridden by the second.  Instead,

  Style * ClickToFocus
  Style * ClickToFocusRaisesOff, ClickToFocusPassesClickOff

must be used.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Mon, 12 Aug 2002 10:22:04 +0200 (CEST)

Hi !

> All the problems you describe should be gone now.

YES !! the ClickToFocus is working again !! THANKS !!

the 2+2 extra buttons are still there.

cheers,
Giuseppe.

PS
great work, as usual ! ;-)

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Aug 2002 10:50:12 +0200

> the 2+2 extra buttons are still there.

Hm.  Could you send me your config file please?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Mon, 12 Aug 2002 11:11:41 +0200 (CEST)

Hi !

> Hm.  Could you send me your config file please?

Sure !

Cheers,
Giuseppe.

##########################################################################
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
#

Read ConfigFvwmDefaults

##########################################################################
# PATH Setup 
#

ModulePath ${HOME}/libexec/fvwm/2.5.3

ImagePath \
${HOME}/include/X11/pixmaps:\
${HOME}/include/X11/icons

############################################################################
# COLORS and FONTS
#

CleanupColorsets
Colorset 0 Foreground black, Background grey90
Colorset 1 Foreground black, Background grey80
Colorset 2 Foreground black, Background grey60
Colorset 3 Foreground black, Background grey40

# Set the fore and back border colors for the window that has focus
Style * HilightColorset 1, HilightBorderColorset 1

# Set fore/back border colors for all other windows
Style * Colorset 2, BorderColorset 1

# Set title style
TitleStyle LeftJustified
TitleStyle ActiveUp   TiledPixmap Active.xpm
TitleStyle ActiveDown TiledPixmap Active.xpm
TitleStyle Inactive   TiledPixmap Inactive.xpm

# Set border style
BorderStyle Active   TiledPixmap Active.xpm
BorderStyle Inactive TiledPixmap Inactive.xpm

# Set border width
Style * BorderWidth 5, HandleWidth 5

# Set colors/font for pop-up menus
MenuStyle * Fvwm, Animation
MenuStyle * MenuColorset 1
MenuStyle * ActiveColorset 0, HilightBack
MenuStyle * GreyedColorset 3
MenuStyle * Font -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*

# Set fonts to use on title bar and icon label
Style * Font     -adobe-times-bold-r-*-*-20-*-*-*-*-*-*-*
Style * IconFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*

############################################################################
# ICON Setup
#

# Auto Place Icons is a nice feature (Left Top Right Bottom)
Style * IconBox 768x0+0-1

# If you don't want icons for some or all windows (or all of them!)
#Style * NoIcon

# If you want ALL icons to follow you around the desktop (Sticky)
#Style * StickyIcon

############################################################################
# FOCUS Setup
#

# Does the window with focus control the colormap, or the one under the mouse
ColormapFocus FollowsFocus
#ColormapFocus FollowsMouse

# Uncomment this to force you to click in a window to give it focus
Style * ClickToFocus
#Style * MouseFocus

############################################################################
# MISC Setup
#

# click/release must occur in <n milliseconds to be a "click"
ClickTime 150

# if the window occupies less than n% of the screen, draw it opaque
OpaqueMoveSize 10

# flip by whole pages on the edge of the screen
EdgeScroll     0 0
EdgeResistance 0 100

# MWM Emulation: Don't ignore hints for functions and transient decoration
#Style * MWMFunctions, MWMDecor

# Changes the look of the "rubberband" you see when moving windows (0 - 255)
XORvalue 0

###########################################################################
# PAGER Setup
#

# set the desk top size in units of physical screen size (width x height)
DeskTopSize 2x2

############################################################################
# WINDOW Placement
#

# TileManualPlacement makes new windows pop-up in blank regions of screen
# If TileManualPlacement fails, ManualPlacement is used as a fall-back method
Style * TileManualPlacement

# If during an interactive move the window comes within 10 pixels of another
# the window will be moved to make the borders adjoin.
SnapAttraction 10 All

# Positioning grid
SnapGrid 1 1

############################################################################
# STYLE Flag Setup
#

Style *              Icon unknown1.xpm, MiniIcon mini-x.xpm

Style Fvwm*          NoTitle, NoHandles, Sticky, WindowListSkip
Style Fvwm*          MiniIcon mini.fvwm.xpm

Style FvwmPager      BorderWidth 0, NeverFocus
Style FvwmButtons    BorderWidth 0, NeverFocus

Style XTerm          Icon xterm.xpm, MiniIcon mini.xterm.xpm

Style Pine           Icon pine2.xpm, MiniIcon mini.letter.xpm
Style Pine           SkipMapping, StartsOnPage 4 0 0, TileCascadePlacement

Style Netscape*      MiniIcon mini.netscape.xpm
Style Netscape*      SkipMapping, StartsOnPage 2 0 0, MinOverlapPercentPlacement

Style Mozilla*       MiniIcon mini.mozilla.xpm
Style Mozilla*       SkipMapping, StartsOnPage 2 0 0, MinOverlapPercentPlacement

Style DXConsole      StartIconic
Style DXConsole      WindowListSkip

Style XLoad          NoTitle, NoHandles
Style XLoad          WindowListSkip, NeverFocus
Style XLoad          SkipMapping, StartsOnPage 0 0 0, TileCascadePlacement

Style Zwgc           NoTitle, NoHandles, Sticky
Style Zwgc           WindowListSkip
Style Zwgc           StaysOnTop, TileCascadePlacement

Style Mxconns        BorderWidth 0, NoHandles, Sticky
Style Mxconns        WindowListSkip, NeverFocus
Style Mxconns        NoButton 1, NoButton 2, NoButton 3
Style Mxconns        NoButton 4, NoButton 5, NoButton 6

Style ASClock        NoTitle, NoHandles, Sticky
Style ASClock        WindowListSkip, NeverFocus

Style XApm           NoTitle, NoHandles, Sticky
Style XApm           WindowListSkip, NeverFocus

Style XMMS*          NoTitle, NoHandles
Style XMMS*          NoButton 2

Style xmahjongg      NoTitle, NoHandles
Style xmahjongg      TileCascadePlacement

Style *OpenOffice*   DontRaiseTransient, DontLowerTransient

Style Canvas         MinOverlapPercentPlacement

Style Wfica*         NoTitle, NoHandles, NoBorder

#############################################################################
# START-UP Functions
#

DestroyFunc InitFunction
AddToFunc InitFunction    I Echo Starting fvwm ...
+                         I Module FvwmButtons
+                         I Module FvwmAnimate
+                         I Exec exec ${HOME}/scripts/xvroot.start
+                         I Exec exec ${HOME}/scripts/mxconns.start
+                         I Exec exec ${HOME}/scripts/xscreensaver.start
+                         I Exec exec ${HOME}/scripts/asclock.start
+                         I Exec exec ${HOME}/scripts/xapm.start
+                         I Module FvwmBanner

DestroyFunc RestartFunction
AddToFunc RestartFunction I Echo Restarting fvwm ...
+                         I Module FvwmButtons
+                         I Module FvwmAnimate

# Uncomment this to make windows auto-raise after [x] milliseconds 
#AddToFunc InitFunction    I Module FvwmAuto 0

############################################################################
# BUTTON Setup
#

## Buttons actually being used (duplicated below)
# little box
ButtonStyle 1 Vector 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# small up triangle
ButtonStyle 2 Vector 4 50x35@1 65x65@0 35x65@0 50x35@1
# funky X
ButtonStyle 3 Vector 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
# Expanding Windows (iconify -- looks NICE)
ButtonStyle 4 Vector 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1
# 3 Horizontal bars (sticky)
ButtonStyle 5 Vector 12 20x30@0 80x30@0 80x35@0 20x35@1 20x47@4 80x47@0 80x52@0 20x52@1 20x65@4 80x65@0 80x70@0 20x70@1
# Vertical Line with arrowheads on top and bottom
ButtonStyle 6 Vector 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1

ButtonStyle All --  UseTitleStyle

## Triangles
#
# Small up Triangle
#ButtonStyle * Vector 4 50x35@1 65x65@0 35x65@0 50x35@1
# Small down Triangle
#ButtonStyle * Vector 4 50x65@1 35x35@1 65x35@1 50x65@0
# Large up Triangle
#ButtonStyle * Vector 4 50x25@1 75x75@0 25x75@0 50x25@1
# Large down Triangle
#ButtonStyle * Vector 4 50x75@1 25x25@1 75x25@1 50x75@0

## Boxes
#
# Big Box 
#ButtonStyle * Vector 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# Little Box
#ButtonStyle * Vector 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# Tall Box
#ButtonStyle * Vector 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# Dot
#ButtonStyle * Vector 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# Big Box with arrow to little box (iconify)
#ButtonStyle * Vector 14 20x20@1 20x70@1 70x70@0 70x20@0 20x20@1 60x60@0 60x50@0 60x60@0 50x60@0 60x60@0 60x80@0 80x80@0 80x60@0 60x60@0

## X's
#
# Standard X
#ButtonStyle * Vector 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# Funky X 
#ButtonStyle * Vector 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
# Stylized X
#ButtonStyle * Vector 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1

## Lightning Bolts
#
# Small Lightning Bolt (skinny at both ends)
#ButtonStyle * Vector 7 70x15@0 30x55@1 50x55@0 40x85@1 80x45@0 60x45@1 70x15@0
# Big Lighting Bolt (Fat at top, comes to a point)
#ButtonStyle * Vector 8 35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 75x15@0 35x15@1

## Miscellaneous Buttons
#
# Nested Right Angles (looks kinda crappy)
#ButtonStyle * Vector 13 10x0@1 80x0@1 80x10@1 80x80@0 0x80@0 0x60@1 10x65@1 70x65@0 70x0@0 55x0@1 55x10@1 55x55@0 10x55@0
# Nested Right Angles (looks nice)
#ButtonStyle * Vector 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
# 3 Horizontal bars (sticky)
#ButtonStyle * Vector 12 20x30@0 80x30@0 80x35@0 20x35@1 20x47@4 80x47@0 80x52@0 20x52@1 20x65@4 80x65@0 80x70@0 20x70@1
# Expanding Windows (iconify -- looks NICE)
#ButtonStyle * Vector 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1

## Arrows Galore
#
# Up Arrow
#ButtonStyle * Vector 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# Down Arrow
#ButtonStyle * Vector 8 40x20@1 40x50@1 20x50@1 50x80@1 80x50@0 60x50@0 60x20@0 40x20@1
# Left arrow  ( <- )
#ButtonStyle * Vector 8 80x40@1 50x40@1 50x20@1 20x50@1 50x80@0 50x60@0 80x60@0 80x40@0
# Right arrow ( -> )
#ButtonStyle * Vector 8 20x40@1 50x40@1 50x20@1 80x50@1 50x80@0 50x60@0 20x60@0 20x40@1
# Horizontal Line with arrowheads on left and right ( <-> )
#ButtonStyle * Vector 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1
# Vertical Line with arrowheads on top and bottom
#ButtonStyle * Vector 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1
# Diagonal Line with arrowheads on top and bottom ( / )
#ButtonStyle * Vector 11 80x15@1 45x15@1 55x25@1 25x55@1 15x45@1 15x80@1 50x80@0 40x70@0 70x40@0 80x50@0 80x15@0
# Diagonal Line with arrowheads on top and bottom ( \ )
#ButtonStyle * Vector 12 55x15@0 45x25@0 75x55@0 85x45@0 85x80@0 50x80@0 60x70@1 30x40@1 20x50@1 20x15@1 55x15@1 55x15@0
#
# the number "2"
#ButtonStyle * Vector 12 80x80@0 22x80@0 80x40@0 70x25@0 30x25@0 20x35@0 20x30@1 30x20@1 70x20@1 80x30@1 20x75@1 80x75@1

##############################################################################
# MENU Setup
#

# This defines the most common window operations
DestroyMenu Window-Ops
AddToMenu Window-Ops    "Window Ops"                         Title
+                       "Move%mini.move.xpm%"                Move
+                       "Resize%mini.resize.xpm%"            Resize
+                       "Raise%mini.raise.xpm%"              Raise
+                       "Lower%mini.lower.xpm%"              Lower
+                       "(De)Iconify%mini.iconify.xpm%"      Iconify
+                       "(Un)Stick%mini.stick2.xpm%"         Stick
+                       "(Un)Maximize%mini.maximize.xpm%"    Maximize-Func
+                       ""                                   Nop
+                       "Delete%mini.bomb.xpm%"              Delete
+                       "Close%mini.bomb.xpm%"               Close
+                       "Destroy%mini.destroy.xpm%"          Destroy
+                       ""                                   Nop
+                       "Refresh Screen%mini.refresh.xpm%"   Refresh
+                       ""                                   Nop
+                       "Lock Screen%mini.xlock.xpm%"        Exec exec ${HOME}/scripts/xscreensaver.lock

DestroyMenu Window-Ops2
AddToMenu Window-Ops2   "Move%mini.move.xpm%"                Move
+                       "Resize%mini.resize.xpm%"            Resize
+                       "Raise%mini.raise.xpm%"              Raise
+                       "Lower%mini.lower.xpm%"              Lower
+                       ""                                   Nop
+                       "Delete%mini.bomb.xpm%"              Delete
+                       "Close%mini.bomb.xpm%"               Close
+                       "Destroy%mini.destroy.xpm%"          Destroy
+                       ""                                   Nop
+                       "Refresh%mini.refresh.xpm%"          RefreshWindow

DestroyMenu FvwmCommands
AddToMenu FvwmCommands  "Restart Fvwm%mini.fvwm.xpm%"        Module FvwmForm FvwmForm-Restart
+                       ""                                   Nop
+                       "Start Twm%mini.fvwm.xpm%"           Restart twm
+                       "Start Dummy%mini.fvwm.xpm%"         Restart xterm
+                       ""                                   Nop
+                       "Exit Fvwm%mini.exit.xpm%"           Module FvwmForm FvwmForm-Quit

DestroyMenu FvwmModules
AddToMenu FvwmModules   "%mini.fvwm.xpm%Buttons"             Module FvwmButtons
+                       "%mini.fvwm.xpm%Pager"               Module FvwmPager 0 4
+                       "%mini.fvwm.xpm%TaskBar"             Module FvwmTaskBar
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Animate"             Module FvwmAnimate
+                       "%mini.fvwm.xpm%MenuAnimate"         Popup  MenuFvwmAnimate
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%WinList"             Module FvwmWinList
+                       "%mini.fvwm.xpm%Ident"               Module FvwmIdent
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Console"             Module FvwmConsole
+                       "%mini.fvwm.xpm%CommandS"            Module FvwmCommandS
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Event"               Module FvwmEvent
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Auto"                Module FvwmAuto 0
+                       "%mini.fvwm.xpm%Scroll"              Module FvwmScroll
+                       "%mini.fvwm.xpm%Tile"                Module FvwmRearrange -tile 10 10 90 90
+                       "%mini.fvwm.xpm%Cascade"             Module FvwmRearrange -cascade 10 2 80 70
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Save"                Module FvwmSave
+                       "%mini.fvwm.xpm%SaveDesk"            Module FvwmSaveDesk
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Debug"               Module FvwmDebug
+                       "%mini.fvwm.xpm%Backer"              Module FvwmBacker
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%IconBox"             Module FvwmIconBox
+                       "%mini.fvwm.xpm%IconMan"             Module FvwmIconMan
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Banner"              Module FvwmBanner
+                       ""                                   Nop
+                       "%mini.fvwm.xpm%Talk"                Module FvwmTalk

# This is the root menu
DestroyMenu Root-Menu
AddToMenu Root-Menu     "Root Menu"                          Title
+                       "Terminals%mini.xterm.xpm%"          Popup Terminals
+                       ""                                   Nop
+                       "Remote Logins%mini.xterm.xpm%"      Popup Remote-Logins
+                       ""                                   Nop
+                       "WWW%mini-rball.xpm%"                Popup WWW-Menu
+                       ""                                   Nop
+                       "Utilities%mini-bball.xpm%"          Popup Utilities
+                       ""                                   Nop
+                       "Games%mini-ball.xpm%"               Popup Games
+                       ""                                   Nop
+                       "Fvwm Modules%mini.fvwm.xpm%"        Popup FvwmModules
+                       ""                                   Nop
+                       "Fvwm Commands%mini.fvwm.xpm%"       Popup FvwmCommands

# This menu will fire up some often used programs
DestroyMenu Utilities
AddToMenu Utilities     "Xv%mini-bball.xpm%"                 Exec exec xv
+                       "Gimp%mini-bball.xpm%"               Exec exec gimp
+                       ""                                   Nop
+                       "XApm%mini-bball.xpm%"               Exec exec ${HOME}/scripts/xapm.start
+                       "XOsview%mini-bball.xpm%"            Exec exec ${HOME}/scripts/xosview.start
+                       ""                                   Nop
+                       "XMMS%mini-bball.xpm%"               Exec exec xmms > /dev/null
+                       "RealPlayer%mini-bball.xpm%"         Exec exec realplay
+                       "XPlaycd%mini-bball.xpm%"            Exec exec xplaycd
+                       ""                                   Nop
+                       "XScreenSaver%mini-bball.xpm%"       Popup XScreenSaver-Menu

# Games stuff
DestroyMenu Games
AddToMenu Games         "XMahjongg%mini-ball.xpm%"           Exec exec ${HOME}/scripts/xmahjongg.start
+                       "MirrorMagic%mini-ball.xpm%"         Exec exec ${HOME}/scripts/mirrormagic.start
+                       "Tetris%mini-ball.xpm%"              Exec exec ${HOME}/scripts/tetris.start

# Change Desk
DestroyMenu Change-Desk
AddToMenu Change-Desk   "Desk 1"                             MoveToDesk 0 0
+                       "Desk 2"                             MoveToDesk 0 1
+                       "Desk 3"                             MoveToDesk 0 2
+                       "Desk 4"                             MoveToDesk 0 3
+                       "Desk 5"                             MoveToDesk 0 4

(menu stuff removed here)

############################################################################
# COMPLEX FUNCTIONS
#

DestroyFunc Maximize-Func
AddToFunc Maximize-Func		C Maximize 0   100
+				D Maximize 100 100

DestroyFunc Move-or-Raise
AddToFunc Move-or-Raise		I Raise
+				M Move

DestroyFunc Resize-or-Raise
AddToFunc Resize-or-Raise	I Raise
+				M Resize

DestroyFunc SpawnTelnet
AddToFunc SpawnTelnet           I Exec exec xterm -title $0 -n $0 -e telnet $0.$1

DestroyFunc SpawnSsh
AddToFunc SpawnSsh              I Exec exec xterm -title $0 -n $0 -e ssh $0.$1

DestroyFunc SpawnSshR
AddToFunc SpawnSshR             I Exec exec ssh -n $0.$1 "(xterm -title $0 -n $0 -display ${HOSTDISPLAY} &)"

############################################################################
# MOUSE Setup
#

# First, the root window. Button 1 brings up the Main Menu. Button 2 is the
# window operations list, and Button 3 is the winlist builtin
#     Button    Context Modifi  Function
Mouse 1         R       A       Menu Root-Menu
Mouse 2         R       A       Menu Window-Ops
Mouse 3         R       A       WindowList

# Now, title bar buttons
#     Button    Context Modifi  Function
Mouse 0         1       A       Menu Window-Ops2
Mouse 0         2       A       Maximize-Func
Mouse 0         3       A       Menu Change-Desk
Mouse 0         4       A       Iconify
Mouse 0         5       A       Stick
Mouse 0         6       A       WindowShade

# Button 1 in Frame or Sides is a resize-or-raise, in Icons or Top does a
# move-or-raise, Button 1 +  Meta in Window does a move-or-raise
#     Button    Context Modifi  Function
Mouse 1         FS      A       Resize-or-Raise
Mouse 1         IT      A       Move-or-Raise
Mouse 1         W       M       Move-or-Raise

# Button 2 in an Icon is de-iconify
#     Button    Context Modifi  Function
Mouse 2         I       A       Iconify

############################################################################
# KEYBOARD Setup
#

# press arrow + control anywhere, and scroll by 1 page
Key Left        A       C       Scroll -100 +0
Key Right       A       C       Scroll +100 +0
Key Up          A       C       Scroll +0   -100
Key Down        A       C       Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left        A       M       Scroll -10  +0
Key Right       A       M       Scroll +10  +0
Key Up          A       M       Scroll +0   -10
Key Down        A       M       Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left        A       SC      CursorMove -1  +0
Key Right       A       SC      CursorMove +1  +0
Key Up          A       SC      CursorMove +0  -1
Key Down        A       SC      CursorMove +0  +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left        A       SM      CursorMove -10 +0
Key Right       A       SM      CursorMove +10 +0
Key Up          A       SM      CursorMove +0  -10
Key Down        A       SM      CursorMove +0  +10

# function keys
Key F1          A       S       GotoDesk 0 0
Key F2          A       S       GotoDesk 0 1
Key F3          A       S       GotoDesk 0 2
Key F4          A       S       GotoDesk 0 3
Key F5          A       S       GotoDesk 0 4

############################################################################
# FvwmButtons
#
DestroyModuleConfig FvwmButtons: *

# Colors
*FvwmButtons: Colorset 1

# Font
*FvwmButtons: Font -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*

# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtons: Geometry -0-0

# Layout: specify rows or columns, not both
#*FvwmButtons: Columns 5
*FvwmButtons: Rows 2

# Define the buttons to use.....

(FvwmButtons stuff removed here)

############################################################################
# FvwmIdent
#
DestroyModuleConfig FvwmIdent: *

# Give us colors and a fonts
*FvwmIdent: Colorset 1
*FvwmIdent: Font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

############################################################################
# FvwmPager
#
DestroyModuleConfig FvwmPager: *

*FvwmPager: Colorset * 1
*FvwmPager: WindowColorsets 1 0
*FvwmPager: Geometry -0-0
*FvwmPager: Font -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmPager: SmallFont 6x9
*FvwmPager: HilightColorset * 0
*FvwmPager: Label 0 Misc
*FvwmPager: Label 1 Work
*FvwmPager: Label 2 Net
*FvwmPager: Label 3 Doc
*FvwmPager: Label 4 Mail

*FvwmPager: MiniIcons

*FvwmPager: Balloons
*FvwmPager: BalloonColorset * 0
*FvwmPager: BalloonFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmPager: BalloonBorderWidth 1
*FvwmPager: BalloonYOffset -1

############################################################################
# FvwmTaskBar
#
DestroyModuleConfig FvwmTaskBar: *

*FvwmTaskBar: Colorset 1
*FvwmTaskBar: IconColorset 1
*FvwmTaskBar: TipsColorset 2
*FvwmTaskBar: Geometry +0+0
*FvwmTaskBar: Font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmTaskBar: SelFont -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmTaskBar: StatusFont fixed

*FvwmTaskBar: Action Click1 Iconify false, Raise
*FvwmTaskBar: Action Click2 Iconify true,  Lower
*FvwmTaskBar: Action Click3 Iconify false, Raise

*FvwmTaskBar: UseSkipList
*FvwmTaskBar: UseIconNames
*FvwmTaskBar: AutoHide
*FvwmTaskBar: AutoStick
*FvwmTaskBar: ShowTips

*FvwmTaskBar: ButtonWidth 80
*FvwmTaskBar: BellVolume 20
*FvwmTaskBar: IgnoreOldMail
*FvwmTaskBar: MailCommand Exec exec pine.start

*FvwmTaskBar: ClockFormat %H:%M
*FvwmTaskBar: UpdateInterval 60

*FvwmTaskBar: StartName Start
*FvwmTaskBar: StartMenu Root-Menu
*FvwmTaskBar: StartIcon mini.excl.xpm

############################################################################
# FvwmWinList
#
DestroyModuleConfig FvwmWinList: *

*FvwmWinList: Colorset 1
*FvwmWinList: FocusColorset 0
*FvwmWinList: ListIconColorset 1
*FvwmWinList: Font -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmWinList: Action Click1 Iconify false, Focus
*FvwmWinList: Action Click2 Iconify toggle
*FvwmWinList: Action Click3 Module FvwmIdent
*FvwmWinList: UseSkipList
*FvwmWinList: UseIconNames
*FvwmWinList: LeftJustify
*FvwmWinList: MinWidth 70
*FvwmWinList: MaxWidth 120
*FvwmWinList: Geometry +0-1

############################################################################
# FvwmBacker
#
DestroyModuleConfig FvwmBacker: *

*FvwmBacker: Command (Page * *, Desk 0) -solid steelblue
*FvwmBacker: Command (Page * *, Desk 1) -solid midnightblue
*FvwmBacker: Command (Page * *, Desk 2) -solid steelblue
*FvwmBacker: Command (Page * *, Desk 3) -solid midnightblue
*FvwmBacker: Command (Page * *, Desk 4) -solid steelblue

############################################################################
# FvwmIconMan
#
DestroyModuleConfig FvwmIconMan: *

*FvwmIconMan: NumManagers    1
*FvwmIconMan: Resolution     page
*FvwmIconMan: Colorset       1
*FvwmIconMan: Font           -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconMan: Format         "%t"
*FvwmIconMan: Action         Mouse 1 N sendcommand Focus, sendcommand "Iconify"
*FvwmIconMan: Action         Mouse 2 N sendcommand "Iconify 1"
*FvwmIconMan: Action         Mouse 3 N sendcommand "FvwmIdent"
*FvwmIconMan: FollowFocus    true
*FvwmIconMan: Sort           name
*FvwmIconMan: TitleColorset  1
*FvwmIconMan: PlainButton    up
*FvwmIconMan: PlainColorset  1
*FvwmIconMan: SelectButton   down
*FvwmIconMan: SelectColorset 1
*FvwmIconMan: FocusButton    up
*FvwmIconMan: FocusColorset  0
*FvwmIconMan: FocusAndSelectButton down
*FvwmIconMan: FocusAndSelectColorset 0
*FvwmIconMan: DontShow       icon=Untitled title=Untitled
*FvwmIconMan: DrawIcons      true
*FvwmIconMan: ButtonGeometry  300x0
*FvwmIconMan: ManagerGeometry 1x5

############################################################################
# FvwmIconBox
#
DestroyModuleConfig FvwmIconBox: *

# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     *  NoIcon
#

*FvwmIconBox: IconColorset 1
*FvwmIconBox: IconHiColorset 1
*FvwmIconBox: Colorset 1
*FvwmIconBox: Geometry    5x1+0+0
*FvwmIconBox: MaxIconSize 64x38
*FvwmIconBox: Font        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBox: SortIcons   IconName
*FvwmIconBox: Padding     4
*FvwmIconBox: Lines       10
*FvwmIconBox: SBWidth     11
*FvwmIconBox: Placement   Left Top
*FvwmIconBox: Pixmap      fvwm.xpm
#*FvwmIconBox: HideSC      Horizontal
*FvwmIconBox: SetWMIconSize
*FvwmIconBox: HilightFocusWin
#*FvwmIconBox: Resolution  Desk
*FvwmIconBox: Mouse 1     Click       RaiseLower
*FvwmIconBox: Mouse 1     DoubleClick Iconify toggle
*FvwmIconBox: Mouse 2     Click       Iconify false, Focus
*FvwmIconBox: Mouse 3     Click       Module FvwmIdent
*FvwmIconBox: Key   r     RaiseLower
*FvwmIconBox: Key   space Iconify
*FvwmIconBox: Key   d     Close
*FvwmIconBox: Key   n     Next
*FvwmIconBox: Key   p     Prev
*FvwmIconBox: Key   h     Left
*FvwmIconBox: Key   j     Down
*FvwmIconBox: Key   k     Up
*FvwmIconBox: Key   l     Right

############################################################################
# FvwmScroll
#
DestroyModuleConfig FvwmScroll: *

*FvwmScroll: Colorset 1

############################################################################
# FvwmEvent
#
DestroyModuleConfig FvwmEvent: *

DestroyFunc rplay
AddToFunc   rplay I Exec esdplay ${HOME}/lib/sounds/fvwm2/$0

*FvwmEvent: Cmd   rplay
*FvwmEvent: Delay 0

#*FvwmEvent: startup thank-you.au
#*FvwmEvent: shutdown goodbye.au
#*FvwmEvent: unknown not-programmed.au

*FvwmEvent: new_page drip.au
*FvwmEvent: new_desk drip.au

#*FvwmEvent: add_window gong.au
#*FvwmEvent: raise_window cork.au
#*FvwmEvent: lower_window cork.au
#*FvwmEvent: configure_window cork.au

#*FvwmEvent: focus_change ploop.au

*FvwmEvent: destroy_window aargh.au
*FvwmEvent: iconify whoosh.au
*FvwmEvent: deiconify whoosh.au

#*FvwmEvent: window_name beep.au
#*FvwmEvent: icon_name beep.au
#*FvwmEvent: res_class beep.au
#*FvwmEvent: res_name beep.au

#*FvwmEvent: end_windowlist twang.au
#*FvwmEvent: icon_location beep.au

#*FvwmEvent: map beep.au
#*FvwmEvent: error foghorn.au

#*FvwmEvent: config_info spin.au
#*FvwmEvent: end_config_info spin.au

#*FvwmEvent: icon_file beep.au
#*FvwmEvent: default_icon beep.au
#*FvwmEvent: string beep.au
#*FvwmEvent: mini_icon beep.au

*FvwmEvent: windowshade swish.au
*FvwmEvent: dewindowshade swish.au

############################################################################
# FvwmBanner
#
DestroyModuleConfig FvwmBanner: *

*FvwmBanner: Timeout 3

############################################################################
# FvwmAnimate
#
DestroyModuleConfig FvwmAnimate: *

*FvwmAnimate: Delay 10
*FvwmAnimate: Iterations 32
*FvwmAnimate: Twist 1
*FvwmAnimate: Width 4
*FvwmAnimate: Effect Flip

############################################################################
# FvwmForm
#

# FvwmForm alias - query exit ala mwm
DestroyModuleConfig FvwmForm-Quit: *
*FvwmForm-Quit: GrabServer
*FvwmForm-Quit: WarpPointer
*FvwmForm-Quit: ActivateOnPress on
*FvwmForm-Quit: Colorset 1
*FvwmForm-Quit: ItemColorset 1
*FvwmForm-Quit: Font       -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmForm-Quit: ButtonFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmForm-Quit: InputFont  -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
# begin items
*FvwmForm-Quit: Line       center
*FvwmForm-Quit: Text       "Do you really want to exit FVWM?"
*FvwmForm-Quit: Line       expand
*FvwmForm-Quit: Button     quit "Logout" ^M 
*FvwmForm-Quit: Command    Quit
*FvwmForm-Quit: Button     quit "Cancel"
*FvwmForm-Quit: Command    Nop
*FvwmForm-Quit: Timeout    20 Quit "Automatic logout will occur in %% seconds."

# FvwmForm alias - query restart ala mwm
DestroyModuleConfig FvwmForm-Restart: *
*FvwmForm-Restart: GrabServer
*FvwmForm-Restart: WarpPointer
*FvwmForm-Restart: ActivateOnPress on
*FvwmForm-Restart: Colorset 1
*FvwmForm-Restart: ItemColorset 1
*FvwmForm-Restart: Font       -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmForm-Restart: ButtonFont -adobe-helvetica-bold-r-*-*-11-*-*-*-*-*-*-*
*FvwmForm-Restart: InputFont  -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
# begin items
*FvwmForm-Restart: Line       center
*FvwmForm-Restart: Text       "Do you really want to restart FVWM?"
*FvwmForm-Restart: Line       expand
*FvwmForm-Restart: Button     quit "Restart" ^M 
*FvwmForm-Restart: Command    Restart
*FvwmForm-Restart: Button     quit "Cancel"
*FvwmForm-Restart: Command    Nop
*FvwmForm-Restart: Timeout    10 Restart "Automatic restart will occur in %% seconds."

#######################################################################

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 12 Aug 2002 11:57:03 +0200

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Mon, 12 Aug 2002 12:23:19 +0200 (CEST)

Hi Dominik,

> Fixed.

thanks again !

cheers,
Giuseppe.

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Mon, 19 Aug 2002 18:41:33 +0200 (CEST)

Hi Dominik,

I've just updated to CVS, and I've found your fix:

        * fvwm/style.c (merge_styles):
        fixed style defaults getting stuck to on once set

it works fine, thanks !! 

But now, I see again the problem I described in the thread "The "great 
focus policy rewrite"", i.e. while clicking in the middle of a window, the 
window itself is focussed but not raised any more.

As in that thread, 'FvwmAuto 0' is a possible workaround.

Thanks a lot !!

cheers,
Giuseppe.