Subject: FVWM: "UseStyle" command disappeared

From: Bob Vloon <[email-masked]>
Date: Fri, 16 Aug 2002 10:45:42 +0200

What is its replacement??

Thanx :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 16 Aug 2002 10:50:01 +0200

> What is its replacement??

It's still UseStyle.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Vloon <[email-masked]>
Date: Fri, 16 Aug 2002 14:13:52 +0200

Hi Dominik,

DV> > What is its replacement??
DV> It's still UseStyle.

Ah. Yes. I made a mistake and was slightly confused by the remark in
the manpage that "UseStyle" will dissapear in 3.0 (I'm using one of
the latest snapshots).
Sorry. Nevermind :-))

Then, I've something else (this problem made me think that "UseStyle"
wasn't working): it seems that when I order the BorderWidth
of some window to become "0", it can't be set something else, aftwerwards.

I've this piece of "code", for example:

AddToFunc ReturnToDesk
+               "I" Next [$0] MoveToDesk 0 $1
+               "I" Next [$0] Move +160p 4p
+               "I" Style $0 UseStyle "C64-blue", BorderWidth 0,
HandleWidth 0
+               "I" Next [$0] Layer 0 0
+               "I" UpdateStyles

AddToFunc GetBar
+               "I" Next [$0] MoveToDesk
+               "I" Next [$0] Move m-5 m-10
+               "I" Style $0 UseStyle "C64-black", BorderWidth 1,
HandleWidth 1
+               "I" Next [$0] Layer 0 6
+               "I" UpdateStyles

"GetBar" gets a window ($0), repositions it at my mousecursor and adjusts
the style (and border-/handlewidth). When calling a window with border-
and handlewidth >0, it works. When calling a window with both widths set
to "0", these widths aren't set to "1".

It used to work, but since, ehmm, "I don't know", it stopped doing what
it is supposed to do.

"Help" :)

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 16 Aug 2002 14:43:16 +0200

> to "0", these widths aren't set to "1".

I see.  Once the border width is set to zero, you are stuck with
it.  I'll fix that.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 16 Aug 2002 15:33:53 +0200

> to "0", these widths aren't set to "1".

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Bob Vloon <[email-masked]>
Date: Fri, 16 Aug 2002 15:48:38 +0200

Hi Dominik,

DV> > "GetBar" gets a window ($0), repositions it at my mousecursor and
DV> > adjusts the style (and border-/handlewidth). When calling a window
DV> > with border- and handlewidth >0, it works. When calling a window with
DV> > both widths set to "0", these widths aren't set to "1".

DV> Fixed.

You're too kind :) Thanks!! Oh, and did I already mention that you all
are doing a wonderful job? Fvwm definately is a very fine window manager!!

Regards,

  Bob..