Subject: FVWM: PNG support in 2.5.3

From: Scott Smedley <[email-masked]>
Date: Thu, 29 Aug 2002 21:10:27 +1000

Hi all,

I decided to upgrade to 2.5.3 for the PNG support.

I'm assuming I can do stuff like this now:

AddToMenu "[email-masked]@" "MuLTiMeDia" Title
+ ...

but I get an error:

[FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from gtcd.png

The 'scanForPixmap' looks ominous. Can anyone help me out? Is there
some docco on png support anywhere?

yes, I did compile in PNG support.

DeePBLue>> grep PNG config.h
#define HAVE_PNG 1
DeePBLue>> uname -a
Linux deepblue.milkyway.com.au 2.4.18-5custom #5 SMP Tue Aug 13 19:53:37 EST 2002 i686 unknown
DeePBLue>> fvwm --version
fvwm version 2.5.3 compiled on Aug 29 2002 at 19:55:58
fvwm comes with NO WARRANTY, to the extent permitted
by law.  You may redistribute copies of fvwm under
the terms of the GNU General Public License.  For
more information about these matters, see the file
named COPYING.
with support for: ReadLine, XPM, PNG, GNOME WM hints, EWMH hints, Shape, SM, Xinerama, XFT

SCoTTie! :)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 29 Aug 2002 11:22:46 +0000

> [FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from gtcd.png

Are you sure you have the correct ImagePath?
You may always specify the full file name, like /my/images/gtcd.png.

Can you view this image using some image viewer?

Regards,
Mikhael.

---

From: Scott Smedley <[email-masked]>
Date: Thu, 29 Aug 2002 21:44:23 +1000

Hi,

Thanks for the quick reply.

> Are you sure you have the correct ImagePath?

yup, my .png images are stored with all my .xpm images.

DeePBLue>> grep ImagePath .fvwm2rc 
ImagePath    $HOME/images/icons

> You may always specify the full file name, like /my/images/gtcd.png.

hmmm, well using an absolute path worked! Does 'ImagePath' only
apply to xpms? Is there a 'PNGPath' or similar?

DeePBLue>> grep yellowStar menu 
+    "&CoNTRoL%yellowStar.png%"        Exec exec rxvt -e aumix &
+    "&Testing%/home/deepblue/scott/images/icons/yellowStar.xpm%"        Nop

In the above test I did, I got no image next to 'CoNTRoL', but
I *did* get the image next to 'Testing' ... go figure ...

SCoTTie :)

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Aug 2002 13:58:24 +0200

On Thu, Aug 29, 2002 at 09:44:23PM +1000, Scott Smedley wrote:
> apply to xpms?

> Is there a 'PNGPath' or similar?

No, just one ImagePath for all the image files.

> I *did* get the image next to 'Testing' ... go figure ...

What error message do you see on the console?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Smedley <[email-masked]>
Date: Thu, 29 Aug 2002 22:10:02 +1000

> What error message do you see on the console?

[FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from yellowStar.png

SCoTTie :)

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 29 Aug 2002 12:15:39 +0000

> I *did* get the image next to 'Testing' ... go figure ...

Just tested, everything works for me.

Well, if you have these lines exactly, it means you have yellowStar.xpm,
but not yellowStar.png. Or you don't have png support compiled in.
Or ImagePath is incorrect. Or you run the wrong fvwm executable. :)
Or there is some problem with your png library if it can't load the image.

There is also a small change for a bug somewhere, but until you make it
reproducible using a minimal config and 1-2 pngs, nothing can be done.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Aug 2002 14:24:58 +0200

> [FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from yellowStar.png

Hm, not very helpful.  The Picture library doesn't provide any
information about the reason why it could not load the file.
Unless we're missing something obvious we have to add debug
statements to libs/Picture.c and the subordinate functions.

Bye

Dominik ^_^  ^_^

---

From: Scott Smedley <[email-masked]>
Date: Thu, 29 Aug 2002 22:26:23 +1000

> Just tested, everything works for me.

Bugger! My mistake - I had yellowStar.png in another subdirectory.

You'd think after 3 years of playing with fvwm I could've nutted it out!

Still, thanks so much for your help.

SCoTTie :)