Subject: Re: FVWM: Internal window border line

From: John Latham <[email-masked]>
Date: Tue, 20 Aug 2002 16:03:49 +0100

> From: Dominik Vogt <[email-masked]>
> Date: Tue, 13 Aug 2002 00:22:44 +0200

> On Mon, Aug 12, 2002 at 06:30:07PM +0100, John Latham wrote:
> > Fvwm2.2.4 (and previous) placed a single pixel width black box around the
> > internal window, just inside the border. This has disappeared by 2.4.6, and I
> > cannot find any reference to it in the man page. It's not a big issue, but it
> > does mean some combinations of window decorations look quite different to how
> > they used to -- particularly if the internal window has a similar colour to
> > the border. Could I suggest that you make it an optional BorderStyle? I
> > imagine the box may have disappeared when the new Raised/Flat/Sunk BorderStyle
> > flags apeared.

> That hasn't changed.  I can only guess that the AnotherLevel
> default was changed.  Try this:

>   BorderStyle -- !NoInset

I can see why you suggest this, but no. Some AnotherLevelUp themes use Insets,
and some don't. You are on the right lines, in that it's those that do NOT use
insets that show up the difference most. However, there really was a black box
around the inner window with and without insets in FVWM 2.2 (and 2.0 I think)
and this has gone from 2.4 and 2.5.

I have made some screen shots, and invite you to look at

        http://www.cs.man.ac.uk/~jtl/FVWM-TEMP

to see comparisons of the 2.2 and 2.5 decorations.

It's not a big deal, but I think the little black line was nice! :-)

> Bye
> Dominik ^_^  ^_^

Best wishes, John Latham
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Aug 2002 17:19:04 +0200

> to see comparisons of the 2.2 and 2.5 decorations.

Ah, but that's not part of the window decoration.  The black
border is part of the xterm window itself.  I can't remember any
fvwm release that intentionally showed the client window border,
so it's either a 2.2.x bug or drawn by xterm into its own window.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].