Subject: Re: FVWM: .fvwm2rc syntax guide?

From: szonyi calin <[email-masked]>
Date: Tue, 27 Aug 2002 12:33:49 +0200 (CEST)

--- Imre Vida <[email-masked]> a
écrit : > On Mon, Aug 26, 2002 at 05:28:28PM +0200,
szonyi
> calin wrote:
> > Welcome to *nix
> 
> Well, thanks for the nice welcome.
> 
:-)

> 
> > I think the man page should remain as it is.
> > The man page format is standard. 
> > Man page _is_ a reference. Man page _is not_ a
> > tutorial. Will never be.
> 
> I  was making a benevolent suggestion, what i
> thought would/could
> help some people.  
>   It was not about any kind of tutorial, but only
> about putting 
> a piece of information (that is already in the
> manual) somewhere 
> at the begining, where people reading the man the
> first time can 
> easily spot it.

That's the problem with man pages: the references
are at the end, usually :-)
There was a good manual viewer (X11 based) which
was acting like a browser (i.e. you had a TOC at the
beginning and when you pressed the word on that TOC 
the program took you right to the place where it was
 in the manual.) but it seems it's not on the net
anymore. 

>   I was also not suggesting to change the (holy)
> Format either.
> But i can't fail to note here, that the standard
> does not seem to be 
> that very strictly defined - see man of man:
> 
> "  A manual page consists of several parts.
>   They may be labelled NAME, SYNOPSIS, DESCRIPTION,
> OPTIONS, FILES,
>        SEE ALSO, BUGS, and AUTHOR."
> 
> Please note: MAY be labelled.
> 

Sorry. Next time i'll double check before saying
 something

> 
> So i don't really understand your rather harsh tone.
> Could you explain?
> 

I saw some man pages which were written some kind 
backwards: Name , Synopsys, Description (very long
-literature), Options (command options), real
description of options (after a couple of pages).

I don't want to read man pages where the options 
of command are after ten pages of scrolling.

A tutorial has many literature (by literature
underestanding the part that tells to users 
what's a pager, what's a taskbar and other similar
things.) 

> 
> > If you are impatient and newbie in the same time
> > the chances of screwing things up are big
> 
> The "To the Impatient" was meant to have a pinch of 
> irony/humor.  Well, it seems i could not bring it 
> through - sorry about that.
> 

Sorry, i misunderestood that one :-(
My apologies.

> best
> imre 
Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Aug 2002 12:43:08 +0200

On Tue, Aug 27, 2002 at 12:33:49PM +0200, szonyi calin wrote:
> ?crit?: > On Mon, Aug 26, 2002 at 05:28:28PM +0200,
> szonyi
> Sorry. Next time i'll double check before saying something

Well, the man manpage is not the authorative source for
information about man page formats.  For Linux, there is the
Linux Man Page Howto.  Of course this isn't authorative either,
but the "standard" we use for fvwm.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Felix Karpfen <[email-masked]>
Date: Thu, 29 Aug 2002 10:20:16 +1000

>  in the manual.) but it seems it's not on the net
For the benefit of other recent arrivals to Fvwm2 - who are equally
dismayed by the size (and number) of the relevant man pages:

Typing on the command line "info fvwm2" loads the man page and all the
routines (emacs bindings, I believe) for reading an info file.

This can lighten the reading load (yet to be tried).

There is also a vim plugin for loading the man page into vim and then
use the features of vim (e.g. search, mark, fold, etc) to make the
reading of the man page less daunting (tried it and it works).

Felix Karpfen 
-- 
Felix Karpfen
[email-masked]
Public Key 72FDF9DF (DH/DSA)

---

From: Christoph Claus <[email-masked]>
Date: Fri, 30 Aug 2002 09:29:52 +0200

There is also an emacs-plugin which handles man-pages.

Start emacs, M-x "man", then enter manpage...
has some nice features

chr