Subject: FVWM: Mouse Click sounds in FVWM v2.4.9 Kiosk Environment

From: Andrew Morelock <[email-masked]>
Date: Thu, 22 Aug 2002 21:49:01 -0500

Hi all.  Does anyone know how to attach a sound to the action of a mouse
click?  I'm using a touch screen in a kiosk environment and am looking for a
quick solution for this.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 23 Aug 2002 11:23:26 +0000

On 22 Aug 2002 21:49:01 -0500, Andrew Morelock wrote:
> click?  I'm using a touch screen in a kiosk environment and am looking
> for a quick solution for this.

To bind any mouse button anywhere:

  Mouse 0 A A  Exec play /my/sound.au

To bind only the third mouse button in the root window:

  Mouse 3 R A  Exec esdplay /my/sound.wav

To bind only the first mouse button with Alt in the client window:

  Mouse 1 W M  Exec ogg123 /my/sound.ogg
 
Regards,
Mikhael.