Subject: FVWM: configure can find xft2

From: Wilbert van Bakel <[email-masked]>
Date: Sat, 17 Aug 2002 18:54:15 -0500

Hello fvwm-users,

I installed fvwm-2.5.2 and I want to use xft2 from the 
fcpackage-02.07.28-something.tar.gz.
Maybe I didn't install the fcpackage right, but the header file which 
declares FcBool is found in /usr/X11R6/include/fontconfig/fontconfig.h.

Which steps do I need to take to compile fvwm-2.5.2 with xft2 support?

Looking forward to improve my knowledge!
Wilbert van Bakel
_________________
Gentoo-1.2: "-pipe -O2 -march=i686 -fomit-frame-pointer -fforce-addr"
Gentoo-1.4: "-pipe -O2 -march=athlon-tbird -fomit-frame-pointer 
-fforce-addr"

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 Aug 2002 00:46:10 +0000

> Which steps do I need to take to compile fvwm-2.5.2 with xft2 support?

config.log contains a reason why xft2 was not detected.

Try to specify:

  ./configure --with-freetype-prefix=/usr/X11R6

(or --with-freetype-exec-prefix=/usr/X11R6), this sets a prefix of your
fontconfig-config script, i.e. /usr/X11R6/bin/fontconfig-config .

Regards,
Mikhael.

---

From: Wilbert van Bakel <[email-masked]>
Date: Sat, 17 Aug 2002 20:18:12 -0500

I found font-config-config in /usr/bin and used --with-freetype-prefix=/usr.

I hope I did paste the right part of the config.log:

configure:3192: checking for Xft - version >= 2.0.0
configure:3264: gcc -o conftest -g -O2 -Wall -Wno-implicit-int 
-I/usr/include -I/usr/include/freetype2 -I/usr/include 
-I/usr/X11R6/include   conftest.c -lXft -lfreetype -lfontconfig 
-L/usr/X11R6/lib -lXrender  1>&5
cc1: warning: changing search order for system directory "/usr/include"
cc1: warning:   as it has already been specified as a non-system directory
configure: In function `main':
configure:3248: `FcBool' undeclared (first use in this function)
configure:3248: (Each undeclared identifier is reported only once
configure:3248: for each function it appears in.)
configure:3248: parse error before "result"
configure:3250: `result' undeclared (first use in this function)
configure: failed program was:
#line 3239 "configure"
#include "confdefs.h"

#include <X11/Xft/Xft.h>
#include <stdio.h>
#include <stdlib.h>

int
main()
{
   FcBool result = 1;

   result = XftInit(NULL);

   if (result)
   {
     return 0;
   }
   else
   {
     return 1;
   }
}

configure:3332: checking for XftFontOpen in -lXft

Thank you, Mikhael,
Wilbert van Bakel

---

From: "S. Anderson" <[email-masked]>
Date: Sat, 17 Aug 2002 19:37:24 -0600

> ...
steenking gcc3! j/k :-)
> ...
you might be having the same problem as I once had. see
http://www.hpc.uh.edu/fvwm/archive/0206/msg00276.html
It turns out fcpackage didnt/doesnt install the xft2 headers.

hth,
sa

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 18 Aug 2002 01:50:57 +0000

> It turns out fcpackage didnt/doesnt install the xft2 headers.

In RedHat it is done this way. The headers are installed in
/usr/include/Xft2, i.e. /usr/include/Xft2/X11/Xft/Xft.h and
"xft-config --cflags" returns -I/usr/include/Xft2 among others.

So there are no conflicts with Xft1 in /usr/include/X11/Xft/Xft.h.

Regards,
Mikhael.

---

From: "S. Anderson" <[email-masked]>
Date: Sat, 17 Aug 2002 22:58:22 -0600

> So there are no conflicts with Xft1 in /usr/include/X11/Xft/Xft.h.

Nice. Thanks for the tip!
For non-redhat people,configuring xft2 with the following does the trick:
./configure --sysconfdir=/etc --prefix=/usr --includedir=/usr/include/Xft2

cya,
sa

---

From: Wilbert van Bakel <[email-masked]>
Date: Sun, 18 Aug 2002 18:06:00 -0500

You are right,

I copied the header files into /usr/X11R6/include/Xft and now configure 
recognizes xft2.
Would it be okay to replace xft1 by xft2, since I practically want to 
build the whole system based on the new xft?

Thank you,
Wilbert van Bakel
_______________________________
[email-masked]

---

From: "S. Anderson" <[email-masked]>
Date: Sun, 18 Aug 2002 19:26:41 -0600

> build the whole system based on the new xft?

I dont think you should do that, because some programs can't use xft2 yet.
If you configure xft2 with:
./configure --sysconfdir=/etc --prefix=/usr --includedir=/usr/include/Xft2
or mæbey
./configure --sysconfdir=/etc --prefix=/usr/X11R6 --includedir=/usr/X11R6/include/Xft2
your system will be able to use xft1 or 2 depending on which one is needed.

cya,
sa