Subject: FVWM: i can't run fvwm 2.4

From: Imre Vida <[email-masked]>
Date: Wed, 21 Aug 2002 00:14:21 +0200

Hi,

 i run my machine under Debian woody.

 When i tried to switch to fvwm i had problems running
 fvwm (offical deb package v2.4.8). 
 First i could not get it started with xdm but was still able 
 to launch it from an xterm. Later on, however, i was not able 
 to launch it at all what ever i tried.

 Finally i decided to down load the source and compile it myself,
 First i downloaded v.2.5.2 and it was running fine but later on
 i thought it would be may be safer to have the stable version.
 And now that i compiled and tried to run v2.4.9 i have exactly the
 same problem.

 There are two error messeges about fvwm not being able
 to find a fontset:
 [FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset 'fixed', trying
 '-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*'
  [FVWM][GetFontSetOrFixed]: ERROR -- can't get fontset
  '-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*'

  The xserver /xfontsel/ does know about these fonts so they are
  definitely not missing (and the fontsever is running).

  Originally i had xdm setup to start up the window manager.
  In this case, after a blank window i got back to the login window
  (while any other window man e.g. icewm, sawfish or even gnome-session
  can be started without probs).
  xdm.log says:
  X connection to :0.0 broken (explicit kill or server shutdown).
  warning: process set to nice value 0 instead of -10 as requested
  (but i believe this is not about fvwm)

  I also tried to start fvwm from an xterm only xsession:
  i got the above errormsg about the fontset and nothing
  else hapens interestingly before the restart this worked
  despite the errormsgs.
  I tried this also as root - no difference. And run strace: i find
  the same erromsgs but nothing else that would give me a cue what
  is going on.

  I hope some of you do have an idea what could the problem

  imre

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Latham <[email-masked]>
Date: Wed, 21 Aug 2002 14:00:12 +0100

> Date: Wed, 21 Aug 2002 14:25:34 +0200
> From: Ionel Mugurel Ciobica <[email-masked]>

> =CEn data de 21-08-2002, la 11h 06'39", Mikhael Goikhman (migo) scria c=E3=
> tre fvwm, despre "Re: FVWM: i can't run fvwm 2.4":
> > On 21 Aug 2002 00:14:21 +0200, Imre Vida wrote:
> > >=20
> > >=20
> > >  fvwm (offical deb package v2.4.8).=20
> > > =20
> > >  ....
> >=20
> > Three questions to you.
> >=20
> > 1) Did you built 2.4.x with --enable-multibyte? (run: fvwm-config -s)
> >=20
> > 2) What is your locale? (run: locale)
> >=20
> > 3) Does fvwm immediately exit? If no, do you get the root menu?
>
>
> I have the same problem with fvwm 2.4.x. Every time I install a new
> package with dselect or with apt-get the fvwm get updated to 2.4.x.
> and then I can't login, the error is the same with the fixed font.
> I have to manually downgrade fvwm to 2.2.4 (hopefully I still have a
> *.deb for that).
>
> In my case:
>
> 1. I did not compile fvwm myself. I use the *.deb file from woody.
> 2. I use locale ro_RO.ISO-8859-16.
> 3. fvwm exits immediately.

...

I had similar problems with 2.4.6 as distributed by Red Hat 7.3, and with
2.4.8 when I compiled it myself with the multi-byte option. I ended up
concluding that multi-byte is flakey on the 2.4 series when used with a
non-posix locale, and that Red Hat had been a bit naughty to enable it in
their distro. It all seems fine in 2.5. Nobody on this list confirmed that
summary.

Perhaps Debian has enabled it too?

Two fixes are:

	Recompile without the -enable-multi-byte option.

Or, of you want to use a pre-compiled dodgey 2.4 binary:

	Right near the start of your config file, insert:

		SetEnv LANG C
		SetEnv LC_CTYPE ""

Good luck.

Best wishes, John Latham

P.s. I have been using FVWM 2.5.2 every day since early July, and it has been
very stable.... I'me even thinking of using it here for our 700+ linux users!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Latham <[email-masked]>
Date: Thu, 29 Aug 2002 19:13:18 +0100

> Date: Thu, 29 Aug 2002 10:17:29 +0200
> From: Dominik Vogt <[email-masked]>

> > I > was building a Red Hat ready fvwm2.5.2 RPM
>
> > which we are probably going to use here at Manchester CS.
>
> Don't do that!  It's not even alpha quality.

I can't decide whether your are advising using 2.5.3, or 2.4.9 instead! :-)

2.5.2 does *seem* very stable. I have used it everyday since early July, and
it has not crashed. :-) All (certainly most) of the ~700 users will be using
the same configuration package as I have been using, i.e. AnotherLevelUp
(otherwise it would be a little dangerous, I agree). I have added a patch to
fix the task bar start button context problem I reported yesterday (thanks for
fixing in CVS, Mikhael). The most persuasive motive for using 2.5 rather than
2.4 is it's extra features that *might* help in the desperate war against the
Java/FVWM mismatch -- which has reached critical status now that all our
undergraduates write so much Java.... :-(

Meanwhile, I have switched to using 2.5.3 personally -- so far so good. I have
probably got about 3 weeks to try 2.5.3 and use that instead if there have
been no serious problems.

My current reasoning is this: 2.5.2 was alpha last month, and the problems
found in it since did not screw up AnotherLevelUp. Now, 2.5.3 is alpha, but it
has not been tested with AnotherLevelUp for a month! Maybe the problems in
2.5.3 will screw up AnotherLevelUp -- I'll let you know if they do, but while
I find out, 2.5.2 is actually a safer bet!!!!

Of course, I'll have RPMS for 2.4.[6-9] up my sleeve in case the worst should
happen.

> Bye
> Dominik ^_^  ^_^

Best wishes, John Latham