Subject: FVWM: i can't run fvwm 2.4

From: Imre Vida <[email-masked]>
Date: Wed, 21 Aug 2002 00:14:21 +0200

Hi,

 i run my machine under Debian woody.

 When i tried to switch to fvwm i had problems running
 fvwm (offical deb package v2.4.8). 
 First i could not get it started with xdm but was still able 
 to launch it from an xterm. Later on, however, i was not able 
 to launch it at all what ever i tried.

 Finally i decided to down load the source and compile it myself,
 First i downloaded v.2.5.2 and it was running fine but later on
 i thought it would be may be safer to have the stable version.
 And now that i compiled and tried to run v2.4.9 i have exactly the
 same problem.

 There are two error messeges about fvwm not being able
 to find a fontset:
 [FVWM][GetFontSetOrFixed]: WARNING -- can't get fontset 'fixed', trying
 '-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*'
  [FVWM][GetFontSetOrFixed]: ERROR -- can't get fontset
  '-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*'

  The xserver /xfontsel/ does know about these fonts so they are
  definitely not missing (and the fontsever is running).

  Originally i had xdm setup to start up the window manager.
  In this case, after a blank window i got back to the login window
  (while any other window man e.g. icewm, sawfish or even gnome-session
  can be started without probs).
  xdm.log says:
  X connection to :0.0 broken (explicit kill or server shutdown).
  warning: process set to nice value 0 instead of -10 as requested
  (but i believe this is not about fvwm)

  I also tried to start fvwm from an xterm only xsession:
  i got the above errormsg about the fontset and nothing
  else hapens interestingly before the restart this worked
  despite the errormsgs.
  I tried this also as root - no difference. And run strace: i find
  the same erromsgs but nothing else that would give me a cue what
  is going on.

  I hope some of you do have an idea what could the problem

  imre

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 21 Aug 2002 11:06:39 +0000

>   the same erromsgs but nothing else that would give me a cue what

Three questions to you.

1) Did you built 2.4.x with --enable-multibyte? (run: fvwm-config -s)

2) What is your locale? (run: locale)

3) Does fvwm immediately exit? If no, do you get the root menu?

Regards,
Mikhael.

---

From: Ionel Mugurel Ciobica <[email-masked]>
Date: Wed, 21 Aug 2002 14:25:34 +0200

În data de 21-08-2002, la 11h 06'39", Mikhael Goikhman (migo) scria către fvwm, despre "Re: FVWM: i can't run fvwm 2.4":
> >  ....

I have the same problem with fvwm 2.4.x. Every time I install a new
package with dselect or with apt-get the fvwm get updated to 2.4.x.
and then I can't login, the error is the same with the fixed font.
I have to manually downgrade fvwm to 2.2.4 (hopefully I still have a
*.deb for that).

In my case:

1. I did not compile fvwm myself. I use the *.deb file from woody.
2. I use locale ro_RO.ISO-8859-16.
3. fvwm exits immediately.

I also have compatibilities problems because I use fvwm 2.2.4-2
instead of 2.4.6-2. fvwm recommends fvwm-common, xlibs conflicts with
fvwm-common. I think I need an older xlibs (I have 4.1.0-17).
But I can't find, for instance 4.1.0-14. I never can exit from the
dselect menu. I have to make a full upgrade and then "dpkg -i
fvwm_2.2.4-2.deb".

Thank you,
        Ionel

---

From: Imre Vida <[email-masked]>
Date: Wed, 21 Aug 2002 19:45:56 +0200

Hi Mikhael

> 1) Did you built 2.4.x with --enable-multibyte? (run: fvwm-config -s)
yes, both the Debian package and what i compiled was with
--enable-multibyte
 
> 2) What is your locale? (run: locale)
en_IE@euro 
 
> 3) Does fvwm immediately exit? If no, do you get the root menu?
fvwm exits immediately

Your questions seem to be in the same direction what John wrote.
And now i occurs to me that when i was able to start fvwm from 
an xterm i had a typo and the locale was set back to "C".
So this seem to explain everythin.

Thanks 

imre

---

From: szonyi calin <[email-masked]>
Date: Fri, 23 Aug 2002 17:14:55 +0200 (CEST)

--- Ionel Mugurel Ciobica <[email-masked]> a
écrit : > În data de 21-08-2002, la 11h 06'39",
Mikhael
> Goikhman (migo) scria cãtre fvwm, despre "Re: FVWM:
> i can't run fvwm 2.4":
> 
> 

Try to compile fvwm manually
 
> 2. I use locale ro_RO.ISO-8859-16.

I use 
export LC_ALL=ro_RO
export LANG=ro
in .xinitrc
no problems
I think the locale for Romania should be
ro_RO.ISO-8859-2.
Is there any reason for using ro_RO.ISO-8859-16 ?

> 3. fvwm exits immediately.

What errors are printed ?
Try to redirect stderr from fvwm to a file.

> fvwm-common. I think I need an older xlibs (I have

Packages problems :-)
If you compile it manually maybe you can fool debian 
that you have what he wants while still running 
your favourite version of fvwm.

>         Ionel
Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 23 Aug 2002 18:33:59 +0000

> Is there any reason for using ro_RO.ISO-8859-16 ?

It includes the euro sign and some other small changes AFAIK.

I suppose fvwm-2.4.x exits when it does not find fixed *-iso8859-16 font.
By the way these patches to replace searching for strictly "fixed" font
were demanded by the Debian maintainer, I think he included these or
similar patches before creating debs anyway. I hoped he or someone else
will reply to other Debian specific questions asked in this thread.

I don't have ro_RO.ISO-8859-16 locale on my system to test anything.
Anyway the solution should be to use fonts existing in your locale or
explicitely specify charset (like *-fixed-*-iso8859-2) when defining
fonts, or switch to 2.5.x where i18n and font handling is much improved.
But prepare to get warnings if the used fonts do not match your locale.

Regards,
Mikhael.

---

From: Imre Vida <[email-masked]>
Date: Fri, 23 Aug 2002 23:32:02 +0200

On Fri, Aug 23, 2002 at 06:33:59PM +0000, Mikhael Goikhman wrote:
> similar patches before creating debs anyway. 

Sorry, but i don't understand this:
If such a patch was requested and applied why does the program exit
after not finding one set of fixed fonts?
((There is only one errormsg /to be precise - one msg twice/,
and also it is misleading as it does not specify that it is looking 
for /in my case/ *-iso8859-15 fonts.)) 

This also suggests that the maintainers are aware of (at least some) 
problems on this "front". This is to put it very softly, as John did 
it earlier "a bit naughty" against all those "stupid users" like me.

Imre

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 24 Aug 2002 09:14:54 +0000

> it earlier "a bit naughty" against all those "stupid users" like me.

Well, the multibyte support is marked experimental in 2.4.x and disabled
by default. Sorry it caused you any problems.

Regards,
Mikhael.

---

From: Imre Vida <[email-masked]>
Date: Sat, 24 Aug 2002 13:51:56 +0200

> by default. Sorry it caused you any problems.
 
 sorry, the criticism was not directed against you.
 I was just somewhat puzzled by what you said.
 To have an experimetal feature is fine, but to have it 
 enabled in a "stable" distribution (Debian and RH) is not
 - especially when it is not documented for the user.
 But again this should be directed to a different forum.

 imre

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 Aug 2002 11:00:04 +0200

>  But again this should be directed to a different forum.

Let's put it this way:  It's idiotic.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Christian Lyra <[email-masked]>
Date: Mon, 26 Aug 2002 09:07:34 -0300

HI,

	Last weekend I tried the last snapshot since I was curious about what was 
happening, what is new. And what a surprise! Multipixel titlebar is working 
again!!! Kudos to Suzanne (who wrote the first patch) and the fvwm developers 
that put the patch in the development tree.
	BTW I think this deserve a note in the Changelog :-)

-- 
Christian Lyra
POP-PR - RNP

  The master programmer moves from program to program without fear. No change 
in management can harm him. He will not be fired, even if the project is 
cancelled. Why is this? He is filled with Tao. 
						The Tao Of Programing
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 26 Aug 2002 14:13:29 +0200

>From the ChangeLog:

	* fvwm/borders.c (RenderIntoPixmap):
	(DrawMultiPixmapTitlebar):
	(border_render_into_pixmap):
	(border_draw_multi_pixmap_titlebar):
	applied Suzanne Skinner's multi pixmap titles fix
	renamed functions and changed all callers

A request to everybody who writes patches:  Please include
ChangeLog entries with your patches.  I'm often unable to find the
right words.

Bye

Dominik ^_^  ^_^