Subject: Re: FVWM: Re: The "great focus policy rewrite"

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Aug 2002 12:38:53 +0200

On Tue, Aug 20, 2002 at 10:53:39AM +0200, Giuseppe Della Ricca wrote:
> Hi Dominik,
> 
> > The description is very clear, but it works well here.
> 
> today I updated again (cvs up -Ad), but the things I've described are 
> still there.
> 
> I've restarted my X server from scratch.
> 
> 1- I thought you had fixed the 'ClickToFocus implies GrabFocus as default' 
>    stuff, but I still see newly created windows not being focussed
> 
> 2- the 'ClickToFocus focusses but doesn't raise windows' stuff for me 
>    depends on the position of the 'Style * ClickToFocus' statement: it 
>    works only if it is the last Style statement.
> 
> 3- the fact that a fucussed window loses focus after a desk switch 
>    depends, too, on the position of the 'Style * ClickToFocus' statement:
>    it _stops_ working if this statement is the last Style statement.
> 
> Please let me know if I can help somehow.
> 
> I know that if nobody but me is seeing these things, and you can't 
> reproduce them, we are stuck.

Are you absolutely 100% no-doubt-about-it *sure* that you're
running the right executable?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Tue, 20 Aug 2002 15:01:22 +0200 (CEST)

On Tue, 20 Aug 2002, Dominik Vogt wrote:

[snip]

> >    it _stops_ working if this statement is the last Style statement.

[snip]

> running the right executable?

Yes: on my laptop I have fvwm2-2.4.6-1 (standard from RH 7.3) and
fvwm 2.5.3-devel from CVS, and I'm sure I'm picking up the 2.5.3-devel.

I discovered that I was using the 2.5.3 modules instead of the 2.5.3-devel
ones, but fixing this had no effect on the focus stuff.

I checked out a new fvwm tree from scratch, and rebuild and installed from
there, same problems. I also tried to remove ConfigFvwmDefaults, without 
success.

Some good news:

a) I found thet problem 1 is a 'consequence' of problem 2, i.e. if I put 
   the 'Style * ClickToFocus' after all other Styles statements (with the 
   cavead described below), then GrabFocus is indeed the default for 
   ClickToFocus.

b) I found that problem 3 is not a real one: I was moving the 'Style * 
   ClickToFocus' line after a 'Style FvwmPager NeverFocus', and then I was 
   using the Pager to change desk, and of course the window was losing its 
   focus. Sorry for this additional unwanted 'noise'.

In the end, the problem can be reduced to the fact with a .fvwm2rc like:

Style * Icon unknown1.xpm
Style * ClickToFocus

clicks work (i.e. a click on W both focusses and raises)

Style * ClickToFocus
Style * Icon unknown1.xpm

clicks fail (i.e. a click on W only focusses).

At least, for me :-( ...

cheers,
Giuseppe.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 20 Aug 2002 19:15:32 +0200

> > >    it _stops_ working if this statement is the last Style statement.

Fixed.

Bye

Dominik ^_^  ^_^

---

From: Giuseppe Della Ricca <[email-masked]>
Date: Wed, 21 Aug 2002 09:58:38 +0200 (CEST)

> > > >    it _stops_ working if this statement is the last Style statement.

GREAT !! Thanks !!!!

cheers,
Giuseppe.