Subject: Re: FVWM: .fvwm2rc syntax guide?

From: Imre Vida <[email-masked]>
Date: Mon, 26 Aug 2002 14:45:50 +0200

On Sun, Aug 25, 2002 at 08:29:50PM -0400, Dan Espen wrote:
 > Are you aware that you can start fvwm with no config file at all,
 > press F1 or any mouse button on the root window and fvwm will
 > offer to create a few different configurations for you?
 
 yes, it is mentioned in the man
 but it appears at line 365 in a very 
 modest 2 line sentence (context: .fvwm2rc).  
 it is repeated in a somewhat more extended 
 version at ~1100 (Built in K&M Bindings).
 
 while I agree that structurally these are 
 apropriate locations, i believe not many
 newbies can spot and pick up the message
 (i personally missed them when first read/
 scanned through the manual. mind you it is 
 8000+ lines of heavy text).
 
 I think it would be helpful to 
 - to put a "To the Impatient" setion at the very 
 begining of the man with this info
 - mention this also in one of the INSTALL and/or 
 README files (e.g. README.sysrc).

 imre

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Mon, 26 Aug 2002 17:28:28 +0200 (CEST)

--- Imre Vida <[email-masked]> a
écrit : >  On Sun, Aug 25, 2002 at 08:29:50PM -0400,
Dan Espen
> wrote:

Welcome to *nix

I think the man page should remain as it is.
The man page format is standard.

Man page _is_ a reference. Man page _is not_ a
tutorial. Will never be.

If you are impatient and newbie in the same time
the chances of screwing things up are big, so
my advice is to start with a configuration file
that _works_ and modify it to suit your needs,

I think somebody wrote a tutorial for fvwm.
Use it.

Good luck

>  imre
Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Len Philpot <[email-masked]>
Date: Mon, 26 Aug 2002 12:50:26 -0500

> Welcome to *nix
 
It was hard to write, therefore it should be hard to learn, right? ;-)
This kind of attitude worked for a long time when there weren't
alternatives (at least perceived if not in reality). However, in today's
market, as much as we (I?) sometimes dislike it, the customer deserves
some consideration. Even in free software it helps.

> The man page format is standard.

I wish KDE / Gnome and others would include (more) man pages instead of
all the (*&#%$ HTML documentation.

> Man page _is_ a reference. Man page _is not_ a

I agree - However some explantory text/refernce material might be in
order here and there, whether in the man page or as a separate document.

> that _works_ and modify it to suit your needs,

Well, since I started this thread let me say that I am not new to
computers, nor am I totally new to *nix -- I use and administer Solaris
every day at work in a decent sized production environment and have done
so for almost 4 years. I'm certainly not a guru (I learn every day), but
not a Unix newbie either... an fvwm newbie, certainly, though!

> I think somebody wrote a tutorial for fvwm.

The only one I've found is a bit thin. What's there is useful enough,
but it's not much (as the author freely admits).

-- 
+-----------------------------------------------------+
|  Len Philpot       ><>         http://philpot.org/  |
|  [email-masked]     [email-masked] (alt)  |
+-----------------------------------------------------+
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Imre Vida <[email-masked]>
Date: Mon, 26 Aug 2002 23:14:43 +0200

> Welcome to *nix

Well, thanks for the nice welcome.

> Man page _is_ a reference. Man page _is not_ a

I  was making a benevolent suggestion, what i thought would/could
help some people.  
  It was not about any kind of tutorial, but only about putting 
a piece of information (that is already in the manual) somewhere 
at the begining, where people reading the man the first time can 
easily spot it.
  I was also not suggesting to change the (holy) Format either.
But i can't fail to note here, that the standard does not seem to be 
that very strictly defined - see man of man:

"  A manual page consists of several parts.
  They may be labelled NAME, SYNOPSIS, DESCRIPTION, OPTIONS, FILES,
       SEE ALSO, BUGS, and AUTHOR."

Please note: MAY be labelled.

So i don't really understand your rather harsh tone.
Could you explain?

> the chances of screwing things up are big

The "To the Impatient" was meant to have a pinch of 
irony/humor.  Well, it seems i could not bring it 
through - sorry about that.

best

imre

---

From: szonyi calin <[email-masked]>
Date: Tue, 27 Aug 2002 12:14:36 +0200 (CEST)

--- Len Philpot <[email-masked]> a écrit : > On Mon,
Aug 26, 2002 at 05:28:28PM +0200, szonyi
> calin wrote:

Sorry. I didn't know that people with *nix experience
didn't discovered fvwm yet.

> all the (*?%$ HTML documentation.
> 

They try to emulate windoze (with some success :-) )

> order here and there, whether in the man page or as

I think a separate document will be better.
As someone wrote on this list, the man page 
is too big allready.

> not a Unix newbie either... an fvwm newbie,

Sorry again. :-) 
Many new users which come from windows don't read 
documentation so I thought you are one of those.

My apologies, but i'm became sick of seeing windoze
 lusers who can't configure their pc saying that
*nix is hard to learn, when the only thing they 
have read in their life was the label from the OK
button in a dialog box.

> but it's not much (as the author freely admits).

I found the examples distributed with the source a 
good start. Maybe I'll try to write an extensive
 tutorial. I'm not an expert but with some help I
think I can do it. 
The main problem are the differences between 
versions of fvwm 

Calin