Subject: FVWM: Problem with Button/Menu

From: "Kauri, Sourabh" <[email-masked]>
Date: Fri, 02 Aug 2002 13:20:08 +0530

Hi,

I'm using "Popup MyMenu" for a mouse action on a button of ButtonsBar.
Now the problem is:
as soon as the mouse button is released the menu is closed and if the
mouse pointer was on a menu-item, that item is activated.

This does not happen with the start-menu/ utilities-menu/ root-menu
which are activated from the FvwmTaskBar or the backdrop. Even if I use
"MyMenu" as the TaskBar's start menu then also the menu is not closed
after the mouse-button is released.

Could you please confirm:
whether i can get the same behavior with a menu on ButtonsBar.
To clarify my requirement -
I need the menu(used on FvwmButton) to be still open even after I
release the mouse-button(s).

Thanks in advance.
Sourabh.

--
Sourabh Kauri,
Computer Associates TCG Software Pvt. Ltd.
Bengal Intelligent Park Private Ltd (BIPPL) Building ,
Block EP& GP, Sector V , Calcutta 700 091.
Phone : + 91 33 3575661 to 3575664 (Ext. 342)
Mobile: (0) 98301 77956
Fax   : + 91 33 3575665
e-mail: [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 2 Aug 2002 10:47:25 +0200

> mouse pointer was on a menu-item, that item is activated.

That's exactly how it is supposed to work.  The "Popup" command
opens a menu and closes it as soon as the button is released.  You
should use the "Menu" command instead.  It holds the menu open
when the button is released first and allows you to click the menu
to select an entry.  So, just replace "Popup MyMenu" with
"Menu MyMenu".

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].