Subject: FVWM: Re: Windows for java apps Don't Obey Placement

From: Lee A Shombert <[email-masked]>
Date: Wed, 14 Aug 2002 13:35:21 -0400

It would be great if this information could go into the FAQ.  I switched to
WindowMaker for a while just to get my Java apps working reliably.  At least
with

  BugOpts ModalityIsEvil True

(described in another email in this thread) the Java windows seem to paint
properly.  I can live with the odd initial placements.  This is under Java
1.3, by the way.
                                                  Lee

"Reuben D. Budiardja" <[email-masked]> writes:
> > I am using Java 1.4 SDK, and developing application using Java 1.4. I guess 
> > they didn't fix it correctly yet.
> 
> This is bugid 4401846 on the Java bug database.
> 
> Make sure you vote for this to get fixed.
> 
> > Rdb
> > On Thursday 01 August 2002 11:56 am, Dan Espen wrote:
> > > "Reuben D. Budiardja" <[email-masked]> writes:
> > > > Hi,
> > > > I have a rather annoying problem when running java apps. The windows that
> > > > are produced by java apps don't obey my manual placement. 
> > 
> > > This is a Java problem.
> > >
> > > Java looks for a few different window managers, and if it doesn't
> > > find them, it misbehaves.  Fvwm is not on the list of window managers
> > > that it looks for.
> > >
> > > We've contacted the Java developers, and its my understanding that
> > > Java 1.4 should start working better.
> > 
> 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Wed, 14 Aug 2002 14:49:05 -0400

On Wed, 14 Aug 2002 13:35:21 -0400

> properly.  I can live with the odd initial placements.  This is under Java

	Unfortunately, with Java 1.4, Sun changed the way Java misbehaves once again,
and ModalityIsEvil no longer works. You have to get one of the 2.5 development
versions of FVWM to work with Java 1.4.

	We have a new workaround in 2.5 that works with 1.4 - the FixedPPosition style.
You have to specify something like

Style MyJavaApp FixedPPosition

	A side note: for style matching, the old technique of specifying "Style AWTApp"
 for all Java apps won't work with 1.4. They changed it so that the (Java) Class
name is now used for the Class and Resource names; and it looks like the window
Name picks up the window title if you gave it one instead of just "VendorShell".
(Just so you know they did at least one Good Thing with this release.)

Cheers,
Bob