Subject: FVWM: Clicking on taskbar icons to minimize windows. How to do it?

From: "Seng Huat Yeoh" <[email-masked]>
Date: Wed, 14 Aug 2002 19:52:44 +0800

Hi,

I'm trying to make my taskbar icons work like Windows 98 and up.   The first 
click maximises the window and second click to minimize it.

How is this done?

Regards,
Stanley Yeoh

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 14 Aug 2002 15:46:02 +0000

On 14 Aug 2002 19:52:44 +0800, Seng Huat Yeoh wrote:
> 
> I'm trying to make my taskbar icons work like Windows 98 and up.   The 
> first click maximises the window and second click to minimize it.

Are you sure this is what Windows 98 does? Seems pretty crazy.
Or you mean the second click normalizes a window?
Anyway here is a 3 state window function:

  *FvwmTaskBar: Action Click1 MaximizeOrMinimizeOrNormalize

  DestroyFunc MaximizeOrMinimizeOrNormalize
  AddToFunc   MaximizeOrMinimizeOrNormalize
  + I ThisWindow (Maximized, !Iconic) Iconify on
  + I ThisWindow (!Iconic) Maximize 100 -30p
  + I ThisWindow (!Maximized, Iconic) Iconify off
  + I ThisWindow (Maximized, Iconic) Maximize off

This is for 2.4.6+. There is another if-else solution for 2.5.x.
It is pretty tricky (but possible) to program if-else in 2.4.x.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Wed, 14 Aug 2002 12:01:02 -0400

> Or you mean the second click normalizes a window?

I think he means, first click deiconifies, second click iconifies.
Or maybe the right terms are deminimize and minimize, or map/unmap.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Wed, 14 Aug 2002 12:28:30 -0600

> Or maybe the right terms are deminimize and minimize, or map/unmap.

Well, the last time I used windows, it worked like this:

clicking on a minimized (fvwm's 'iconic') window would deiconify and
raise it, clicking on a deiconified window that was lowered would raise
it, and clicking on a raised, deiconified window would iconify it.

HTH ;)

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
BOFH excuse #37:
Heavy gravity fluctuation, move computer to floor rapidly
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].