Subject: FVWM: centering windows

From: Toshi Isogai <[email-masked]>
Date: Fri, 26 Jul 2002 15:29:55 -0600

I want to center windows (of various size) in a page.
Isn't there a command to calculate window size and screen
size in order to position it at center and middle?

I would search in mail archive if there was a search engine 
in fvwm.org....

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 784-7674  direct
      (303) 790-8499  main
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 26 Jul 2002 21:59:23 +0000

> size in order to position it at center and middle?

Here is a function for this usage: Next (MyWindow) CenterWindow

  DestroyFunc CenterWindow
  AddToFunc   CenterWindow
  + I ThisWindow Piperead "echo Move \
    $(( $[vp.width]/2-$[w.width]/2 ))p \
    $(( $[vp.height]/2-$[w.height]/2 ))p"

ThisWindow may be removed, it is only needed to avoid errors when
CenterWindow is called without a window context.

> I would search in mail archive if there was a search engine 

Yes, this request about centering a window was answered several times...

Regards,
Mikhael.