Subject: FVWM: fvwm-2.5.2: FvwmButtons and swallowed wmaker Applets

From: Erwin Burgstaller <[email-masked]>
Date: Mon, 29 Jul 2002 15:03:13 +0200

Hi,

I've switched from fvwm 2.4.8 to 2.5.2 without any modifications on my
fvwmrc-files. Xmms no doesn't hide anymore, so I'm happy.

But there's one point I'd like to have in 2.4.8 style: I have some
wmaker and gnome dockable app's in FvwmButton (wmbiff,gabber,..). 
In version 2.4.8 'Action(Mouse 1)' was only executed when pressing the
buttons border, 2.5.2 excutes it for the whole button. Am I right?

Is there a way to have v2.5.2 configured to behave like v2.4.8?
In the meantime I have changed all 'Mouse 1' to 'Mouse 2', but now it's
not like a real wmaker applet.

Regards,
Erwin

#Konfiguration:
*WinMakerAppButtons: (Frame 1, Size 64 64, \
		     Swallow  "wmbiff" 'Exec exec wmbiff', Action(Mouse 1) \
   'MyPanelButtons "WinMakerAppPanelMail" $right $top', \
   Action(Mouse 3) 'All (WinMakerAppPanelMail) Close')

#-----------------
# The Mail Panel
*WinMakerAppPanelMail: Rows 1
*WinMakerAppPanelMail: Back #c0c0c0
*WinMakerAppPanelMail: Fore black
*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
    Swallow  "wmCalClock" 'Exec exec  wmCalClock')
#*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
#    Swallow  "wmglobe" 'Exec exec  wmglobe')
*WinMakerAppPanelMail: (Frame 1, Size 64 64, \
    Swallow  "wmMoonClock" 'Exec exec  wmMoonClock -lat 47.33 -lon
15.33')

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 29 Jul 2002 13:46:42 +0000

> buttons border, 2.5.2 excutes it for the whole button. Am I right?

Yes, the default behaviour of Swallow plus Action was changed.

>    Action(Mouse 3) 'All (WinMakerAppPanelMail) Close')

Add ActionIgnoresClientWindow somewhere here (for example, after Size)
to get the 2.4.x behaviour.

Regards,
Mikhael.

---

From: Erwin Burgstaller <[email-masked]>
Date: Mon, 29 Jul 2002 19:25:26 +0200

> to get the 2.4.x behaviour.

Shame on me! I've stopped reading the man-page just one paragraph before
that option is described.

Thanks,
  Erwin