Subject: FVWM: Problems with TitleStyle

From: Gordon Prieur <[email-masked]>
Date: Mon, 08 Jul 2002 16:51:16 -0700

Hi,

     I'm trying to use TitleStyle to give the titlebars theme
support and I'm running into some problems. I'm using a tool
called fvwm-theme to set my themes although the .fvwm2rc I've
attached has had the PipeRead command calling fvwm-theme replaced
with its output.

     What I'm getting when I run with this rc file is the themed
buttons in the title bar but a blank grey area between. I don't
even get any text in the center of the title bar anymore. The
xpm files all exist (I get errors if I move/remove any of them)
so thats not the problem. If I comment out the TitleStyle cmds
setting Active{Up|Down} and Inactive then I get text (and a slightly
different background color.

     I even got the correct titlebar once when I first started
playing with this when I forgot to specify NoTitle on the gnome
panel window.

     So if anyone has any suggestions on how to sucessfully theme
the titlebar I would appreciate it. I'm running 2.5.2 in conjunction
with Gnome 1.4 on a Sparc/Solaris 2.8 machine.

Thanks,
Gordon
# 
# You can retrieve sample .fvwmrc files from
# 	ftp://ftp.best.com/pub/tdgilman/Fvwmrcs
#	[email-masked]

# small up triangle
#ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
#ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0

EdgeResistance 250 10
EdgeScroll 0 0

DeskTopSize 6x3
#Menustyle * fvwm, Font -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
#MenuStyle * Foreground maroon, Background grey60, Greyed grey40
ClickTime 750

#Module FvwmGtk

ColormapFocus FollowsMouse

Style *			Font -adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
Style *			IconFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
Style *			HilightFore black, HilightBack palevioletred
Style *			BorderWidth 5, HandleWidth 5
Style *			Icon unknown1.xpm, Color Black/#40a0c0
Style *			MWMFunctions,MWMDecor,HintOverride
Style *			DecorateTransient,IconBox 0 -10 -280 -1
Style "Panel"		NoTitle, NoHandles, BorderWidth 0, Sticky
Style *			NoIcon	
Style "TkMan*"		Sticky,StartIconic
Style "dtcm*"		Sticky,StartIconic
Style "Fvwm*"		NoTitle, NoHandles, Sticky, WindowListSkip,
Style "Fvwm*"		BorderWidth 0,CirculateSkipIcon
Style "FvwmButtons"	NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmButtons"	BorderWidth 0, CirculateSkip
Style "FvwmButtons"	Icon toolbox.xpm,ClickToFocus
Style "rxvt"		Icon  term.xpm,IconBox -70 1 -1 -140
Style "Terminal.1"	IconBox -70 1 -1 -140
Style "Terminal"	IconBox -70 1 -1 -140
Style "XTerm"		Icon xterm.xpm,IconBox -70 1 -1 -140

# New stuff for Themed title bars
#ImagePath $HOME/.fvwm/themes/Crux:/usr/local/share/fvwm-theme/decors

#PipeRead 'fvwm-theme -init'

# Output from fvwm-theme -init with some editing...
ImagePath +:/usr/local/share/fvwm-theme/decors
AddToMenu ThemeMenu DynamicPopupAction Function MakeThemeMenu
AddToFunc MakeThemeMenu
   + I DestroyMenu recreate ThemeMenu
   + I PipeRead 'fvwm-theme -menu'

AddToMenu DecorMenu DynamicPopupAction Function MakeDecorMenu
AddToFunc MakeDecorMenu
   + I DestroyMenu recreate DecorMenu
   + I PipeRead 'fvwm-theme -decor-menu'

AddToFunc SetBackground I PipeRead 'fvwm-theme -bg    $0'
AddToFunc SetDecor      I PipeRead 'fvwm-theme -decor $0'
ButtonStyle 1 ActiveUp Pixmap sweetpill_jade/options_activeup.xpm
ButtonStyle 6 ActiveUp Pixmap sweetpill_jade/iconify_activeup.xpm
ButtonStyle 4 ActiveUp Pixmap sweetpill_jade/maximize_activeup.xpm
ButtonStyle 2 ActiveUp Pixmap sweetpill_jade/close_activeup.xpm
ButtonStyle 1 ActiveDown Pixmap sweetpill_jade/options_activedown.xpm
ButtonStyle 6 ActiveDown Pixmap sweetpill_jade/iconify_activedown.xpm
ButtonStyle 4 ActiveDown Pixmap sweetpill_jade/maximize_activedown.xpm
ButtonStyle 2 ActiveDown Pixmap sweetpill_jade/close_activedown.xpm
ButtonStyle 1 Inactive Pixmap sweetpill_jade/options_inactive.xpm
ButtonStyle 6 Inactive Pixmap sweetpill_jade/iconify_inactive.xpm
ButtonStyle 4 Inactive Pixmap sweetpill_jade/maximize_inactive.xpm
ButtonStyle 2 Inactive Pixmap sweetpill_jade/close_inactive.xpm
ButtonStyle All -- Flat
#TitleStyle ActiveUp MultiPixmap Main sweetpill_jade/title_active.xpm, LeftEnd sweetpill_jade/titleleft_active.xpm, RightEnd sweetpill_jade/titleright_active.xpm
#TitleStyle ActiveDown MultiPixmap Main sweetpill_jade/title_active.xpm, LeftEnd sweetpill_jade/titleleft_active.xpm, RightEnd sweetpill_jade/titleright_active.xpm
#TitleStyle Inactive MultiPixmap Main sweetpill_jade/title_inactive.xpm, LeftEnd sweetpill_jade/titleleft_inactive.xpm, RightEnd sweetpill_jade/titleright_inactive.xpm
TitleStyle -- Flat
BorderStyle -- HiddenHandles !NoInset Raised
TitleStyle Centered Height 22
Style * Font         -b&h-lucida-bold-r-normal-*-*-100-*-*-p-*-iso8859-1
Style * HandleWidth  4
Style * ForeColor    #404040
Style * BackColor    #808080
Style * HilightFore  #D0D0D0
Style * HilightBack  #909090

# end fwvm-theme output

Key KP_7	A	N	GotoPage 0 0
Key KP_8	A	N	GotoPage 1 0
Key KP_9	A	N	GotoPage 2 0
Key KP_4	A	N	GotoPage 0 1
Key KP_5	A	N	GotoPage 1 1
Key KP_6	A	N	GotoPage 2 1
Key KP_1	A	N	GotoPage 0 2
Key KP_2	A	N	GotoPage 1 2
Key KP_3	A	N	GotoPage 2 2
Key KP_7	A	S	GotoPage 3 0
Key KP_8	A	S	GotoPage 4 0
Key KP_9	A	S	GotoPage 5 0
Key KP_4	A	S	GotoPage 3 1
Key KP_5	A	S	GotoPage 4 1
Key KP_6	A	S	GotoPage 5 1
Key KP_1	A	S	GotoPage 3 2
Key KP_2	A	S	GotoPage 4 2
Key KP_3	A	S	GotoPage 5 2
Key KP_Add	A	N	Raise
Key KP_Enter	A	N	Lower
Key Multi_key	A	N	RaiseLower
Key Mode_switch	A	N	Lower

Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100
Key Left	A	M	Scroll -10 +0
Key Right	A	M	Scroll +10 +0
Key Up		A	M	Scroll +0   -10
Key Down	A	M	Scroll +0   +10
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10
Key F5		A	M	Move        100p 100p
Key F6		A	M	Resize   10 10
Key F7		A	M	Next (AcceptsFocus) focus
Key F8		A	M	Prev (AcceptsFocus) focus
Key F10 	A	A	Next (AcceptsFocus rxvt) Focus
Key F11 	A	A	Prev (AcceptsFocus CurrentDesk rxvt) Focus
Key F15		FTIWS	A	Raise

#Mouse 1		R   	A       SendToModule FvwmGtk Program-Menu 1
Mouse 2		R    	A      	Menu Window-Ops Nop
Mouse 3		R    	A      	WindowList
Mouse 1		1    	N      	Close
Mouse 3		1    	A      	Menu Window-Ops2 Close
Mouse 0		2    	A     	Maximize-Func
Mouse 0		4    	A     	Iconify
Mouse 1		T	A	Move
Mouse 1		FS	A	Resize
Mouse 1		I	A	Move
Mouse 2		FST	A	Move
Mouse 2		I	A	Move
Mouse 3		TSIF	A	RaiseLower

########################Initialization Functions ############################
#AddToFunc StartFunction
#+			  ModuleSynchronous Timeout 5 FvwmTheme

#XX#if SCREEN == 0
#XXAddToFunc SessionInitFunction
#XX+			I exec xscreensaver -lock-mode -no-splash
#XX+			I exec gnome-session --display=:0.1 --choose-session=Screen-1
#XX+			I exec tkman -iconic
#XX+			I exec dtcm -iconic
#XX#endif

#XX#if SCREEN == 1
#XXAddToFunc SessionInitFunction I exec tkman -iconic
#XX#endif

########################Menus ########################################
AddToMenu Utilities	"Utilities"	Title
+			"Terminal"	Exec  exec te &
+			"Remote Logins"	Popup Remote-Logins
+			"Calculator"	Exec  exec xcalc &
+			"Xman"		Exec  exec xman &
+			"Xmag"		Exec  exec xmag &
+			"emacs"		Exec  exec xemacs &
+                       "Mail"          MailFunction xmh "-font fixed"
+			""		Nop
+			"Modules"	Popup Module-Popup
+			""		Nop
+			"Exit Fvwm"	Popup Quit-Verify
AddToMenu Window-Ops	"Window Ops"	Title
+			"Move"		Move-or-Raise2
+			"Resize"	Resize-or-Raise2
+			"Raise"		Raise
+			"Lower"		Lower
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick
+			"(Un)Maximize"	maximize_func
+			""		Nop
+			"Restart"	Restart
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"Refresh Screen" Refresh
AddToMenu Window-Ops2	"Move"		Move-or-Raise
+			"Resize"	Resize-or-Raise
+			"Raise"		Raise
+			"Lower"		Lower
+			"Iconify"	Iconify
+			"(Un)Stick"	Stick
+			""		Nop
+			"Delete"	Delete
+			"Close"		Close
+			"Destroy"	Destroy
+			""		Nop
+			"ScrollBar" 	Module FvwmScroll 2 2
+			"Print"         PrintFunction

AddToMenu Remote-Logins	"extend"	Exec rsh extend te &
+			"extend2"	Exec rsh extend2 te &
+			"extend3"	Exec rsh extend3 te &
+			"extend4"	Exec rsh extend4 te &
+			"andrea"	Exec rsh andrea te &
+			"twinside"	Exec rsh twinside te &

AddToMenu Module-Popup	"Modules"	Title
+			"Button-Bar"	Module	FvwmButtons
+			"Clean-Up"	Module	FvwmClean
+			"Identify"	Module	FvwmIdent
+			"SaveDesktop"	Module  FvwmSave
+			"Debug"		Module	FvwmDebug
+			"Pager"		Module  FvwmPager 0 1
+			"WinList"	Module  FvwmWinList
+			"Background"	Module  FvwmBacker
+			"IconBox"	Module	FvwmIconBox
+			"Banner"	Module	FvwmBanner
+			"Talk"  	Module	FvwmTalk
+			"Prompt"	Module	FvwmPrompt "hello" raise
+			"Console"	Module	FvwmConsole

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title
+		      	"Yes, Really Quit"  Quit
+                       "Restart Fvwm"      Restart
+		      	"Restart Fvwm 1.x"  Restart fvwm -replace
+		      	"Start twm"         Restart twm
+		      	"Start mwm"    	    Restart mwm
+	      	      	"Start olwm"        Restart /usr/openwin/bin/olwm
+		        "Start tvtwm"       Restart vtwm
+		      	"Start dummy"       Restart xterm
+		      	""		    Nop
+		      	"No, Don't Quit"    Nop

########################Functions ########################################

AddToFunc MailFunction	   I Next (AcceptsFocus $0) Iconify -1
+		           I Next (AcceptsFocus $0) focus
+			   I None (AcceptsFocus $0) Exec $0 $1

AddToFunc Move-or-Raise		I Raise
+				M Move
+  				D Lower

AddToFunc Move-or-Raise2	M Raise
+				M Move
+  				D Lower

AddToFunc Maximize-Func		M Maximize	 0 100
+				C Maximize	 0 80
+				D Maximize	 100 100

AddToFunc Move-or-Iconify	I Raise
+				M Move
+				D Iconify

AddToFunc Resize-or-Raise	I Raise
+				M Resize
+				D Lower

AddToFunc Resize-or-Raise2	M Raise
+				M Resize
+				D Lower

AddToFunc PrintFunction		I Raise
+				I Exec xdpr -id $w

AddToFunc Iconify-and-Raise     I Iconify
+                               I Raise

################## FvwmButtons button-bar ################################
# Colors
#*FvwmButtonsFore Black
#*FvwmButtonsBack #908090

# Font
#*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

########################## FvwmGtk definitions #############################
#*FvwmGtk: Menu Program-Menu
#*FvwmGtk: Title "Programs"
#*FvwmGtk: Separator
#*FvwmGtk: Item "Reload Resource Manager" "dtsession_res -load -system -file $HOME/.Xdefaults"
#*FvwmGtk: Item "Mail Reader" "Exec netscape -messenger"
#*FvwmGtk: Item "Clock" "Exec xclock"

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
#*FvwmPagerBack #908090
#*FvwmPagerFore #484048
#*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
#*FvwmPagerHilight #cab3ca
#*FvwmPagerGeometry -1-1
#*FvwmPagerLabel 0 Misc
#*FvwmPagerLabel 1 Maker
#*FvwmPagerLabel 2 Mail
#*FvwmPagerLabel 3 Matlab
#*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

*FvwmScrollBack grey40
*FvwmScrollFore green

############################################################
############################################################
# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     *  NoIcon

############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file specifications
#
# Mostly, you don't have to specify icon files, as FvwmIconBox now
# reads icon files specified in Style commands.
#
*FvwmIconBox            "Fvwm*"         -

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Jul 2002 02:25:57 +0200

> #TitleStyle ActiveUp MultiPixmap ...

The MultiPixmap patch is a victim of a large scale decoration
drawing code rewrite.  It does not work at the moment.  The last
release in any versions after 2.5.1.  I'm still hoping that the
author eventually get's around fixing it since my time to do it
myself is very limited right now.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].