Subject: FVWM: Vim syntax file.

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Sun, 07 Jul 2002 22:11:19 -0600

I don't know about the rest of you guys, but Vim (to me) is the One True
Editor, and whoever made the syntax highlighting file for the fvwmrc
either a) hasn't updated in years or b) was really lazy and didn't
incorporate half of the things that need to be highlighted.

Unless somebody knows of an accurate, up-to-date fvwm.vim file I can
use, I'm going to go and make my own. Anybody?

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
Remark of Dr. Baldwin's concerning upstarts: We don't care to eat toadstools
that think they are truffles.
		-- Mark Twain, "Pudd'nhead Wilson's Calendar"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: parv <[email-masked]>
Date: Mon, 8 Jul 2002 05:02:52 -0400

in message <[email-masked]>,
wrote Rob 'Feztaa' Park thusly...
>
> Unless somebody knows of an accurate, up-to-date fvwm.vim file I
> can use, I'm going to go and make my own. Anybody?

good idea rob.  after you are done, share the url of the resulting
syntax file if it's for at least vim5.  please.  :)

--

---

From: Beej Jørgensen <[email-masked]>
Date: Mon, 8 Jul 2002 11:23:07 -0700

> syntax file if it's for at least vim5.  please.  :)

FWIW, the vim that came with Slackware 8.0 has a syntax file for .fvwmrc
files...as for accurate up-to-date, I can't vouch for it.  (Sorry I'm
not at home so I can't give you the vim version number.)

If this saves you effort, excellent; if not, just ignore me.

-Beej

---

From: Emmanuel Seyman <[email-masked]>
Date: Tue, 9 Jul 2002 00:33:44 +0200

> use, I'm going to go and make my own. Anybody?

FWIW, here are the first few lines of the fvwm.vim syntax file
found in Red Hat 7.3 (fvwm-2.4.6, vim-6.1).

" Vim syntax file
" Language:     Fvwm{1,2} configuration file
" Maintainer:   Haakon Riiser <[email-masked]>
" Last Change:  2001 Apr 25

Emmanuel

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Mon, 08 Jul 2002 18:53:01 -0600

> " Last Change:  2001 Apr 25

Same as mine. I should contact that guy and see what's up.

This fortune intentionally says nothing.

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Mon, 08 Jul 2002 18:51:42 -0600

> not at home so I can't give you the vim version number.)

Well, that's the problem. I compiled and installed vim from source
(which is how you tend to install things when you built the whole system
that way ;), and the fvwm.vim syntax file that *comes*with*vim* tends to
highlight things that are not valid fvwmrc commands, and doesn't
highlight things that are valid commands. I'd post a screenshot, but
it's barely worth it ;)

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
About all some men accomplish in life is to send a son to Harvard.