Subject: FVWM: MoveToPointer Function

From: "S. Anderson" <[email-masked]>
Date: Mon, 1 Jul 2002 17:00:53 -0600

Hi everyone,
with fvwm 2.5.2, I am trying to write a function that moves a window
to the mouse pointer location. This is what I have com up with so far:

 DestroyFunc MoveToPointer
 AddToFunc MoveToPointer
  + I echo $[pointer.x] $[pointer.y]
  + I All ($0) AnimatedMove $[pointer.x] $[pointer.y]

when I issue this:
 MoveToPointer Xmag

I get a:
    [FVWM][Echo]:  238 348
but the window is moved to +3046+3563

is this a bug?

Thanks,
sa

P.S. heres some more...
[FVWM][Echo]:  271 741
xmag is moved to +3468+7587

[FVWM][Echo]:  0 0
xmag is moved to +0+0

[FVWM][Echo]:  10 10
xmag is moved to +128+102

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 1 Jul 2002 23:09:30 +0000

>   + I All ($0) AnimatedMove $[pointer.x] $[pointer.y]

It should be:

  + I All ($0) AnimatedMove $[pointer.x]p $[pointer.y]p

Regards,
Mikhael.