Subject: Re: FVWM: fvwm2 dropped from Red Hat Linux!

From: [email-masked]
Date: Thu, 4 Jul 2002 04:48:10 EDT

In a message dated 7/4/02 1:43:48 AM US Mountain Standard Time, 
[email-masked] writes:

> Fvwm has bad habbits. I mean why a program should 
> free memory when you have so much at your 
> disposal ? :-)) 

I hereby submit a patch to fix this problem:

At the beginning of main(), add

malloc(50*1024*1024);

Now FVWM can compete with Enlightenment!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Beej Jørgensen <[email-masked]>
Date: Fri, 5 Jul 2002 10:34:01 -0700

> At the beginning of main(), add

That makes me think of this:

if (malloc(50*1024*1024)) {
  fprintf(stderr, "You have too much RAM to run fvwm.  Run Gnome instead.\n");
  exit(1);
}

Smirks.

-Beej

---

From: Stan Benoit <[email-masked]>
Date: Fri, 5 Jul 2002 14:54:03 -0400 (EDT)

This made me laugh so hard, thanks I needed it. :) I gave some of the beta 
testers for Redhat a load over fvwm2 not being included. 

-- 
Stan Benoit<[email-masked]>
Mondo Development
http://troff.nakedsoul.org
http://www.mondorescue.org