Subject: FVWM: Problem with colorsets

From: Marcus Lundblad <[email-masked]>
Date: Fri, 19 Jul 2002 17:29:19 +0200 (CEST)

I have a script that outputs a current colour set.
For example the outpu looks like this:
Colorset 0 bg rgb:60/a0/a0, fg rgb:ff/ff/ff
Colorset 1 bg rgb:d3/d3/d3, fg rgb:00/00/00

further I have defined:

Style * ActiveColorset 0
Style * Colorset 1

That script is run using PipeRead during start. But get all window borders
white with black text (I think black on white is default for unitialised
colour sets).
But if I paste these lines (from the output) manually into an FvwmConsole,
it works.
But if I run my function SetColors, which is run from init in the
FvwmConsole I get only white and black like above.

Does it have to do with PipeRead?

Any idea of what's wrong?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 19 Jul 2002 18:02:35 +0200

> Any idea of what's wrong?

The colorset commands should be the first commands in your config
file.  For performance reasons, colorset updates are ignored
during startup when a lot of things happen.  This is probably the
reason for your problem.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 19 Jul 2002 22:38:25 +0200 (CEST)

> during startup when a lot of things happen.  This is probably the

Actually I found an error in my scipt, it didn\t work from the home
directory, so now it works

Thanks for the information anyway!

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 20 Jul 2002 03:57:28 +0000

On 19 Jul 2002 18:02:35 +0200, Dominik Vogt wrote:
> 
> > That script is run using PipeRead during start. But get all window
> > borders white with black text (I think black on white is default for
> > unitialised colour sets).
> 

Well, for most of configurations when windows and modules are started in
StartFunction or InitFunction, the colorset commands may be anywhere in
the config file, even at the end. This is the whole point of these init
functions, they are started after the whole initial configuration is read.

And it is not critical if a colorset is defined (or changed) after some
color is already used. There will be a redraw at most. This is the whole
point of dynamically changeable colorsets. :)

The order of colorset commands can't be a reason for the original problem.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 20 Jul 2002 21:07:41 +0200

> The order of colorset commands can't be a reason for the original problem.

Yes, you're probably right.  Anyway, it's still a very good idea
to define your colour sets before anything else.  There can be a
large number of unnecessary redraws if you define color sets last.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].