Subject: FVWM: fvwm2 problem

From: Jeff Gibson <[email-masked]>
Date: Tue, 30 Jul 2002 17:06:48 -0700 (PDT)

I just compiled and installed fvwm2 version 2.4.8 on a Solaris machine
running with openwin/cde.  It basically works, but whenever I move a
window, the window border and the sizing hashmarks inside the window
leave black lines behind that litter up the display until I explicity
tell fvwm2 to refresh.  This happens even with a blank .fvwm2rc, so it's
not a local configuration issue.  Any idea what I can do?  My
configuration is below.  I'm not using many of the extensions, but it
didn't look to me like any of those extensions would help.
	Thanks,
	Jeff

FVWM Configuration:

  Version:     2.4.8

  Executables: /usr/local/bin
  Man pages:   /usr/local/man
  Modules:     /usr/local/libexec/fvwm/2.4.8
  Data files:  /usr/local/share/fvwm

  With GNOME Window Manager hints?   yes
  With GTK support for FvwmGtk?      no: Failed to detect GTK, see
config.log
  With Multibyte support?            no: Use --enable-multibyte to
enable
  With ReadLine sup. in FvwmConsole? no: Can't find working libreadline
  With RPlay support in FvwmEvent?   no: Can't find working librplay
  With Shaped window support?        yes
  With Session Management support?   yes
  With Stroke support?               no: Can't find working libstroke
  With Xinerama support?             no: Failed to detect libXinerama
  With XPM support?                  no: Can't find working libXpm

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Jul 2002 11:05:03 +0200

On Tue, Jul 30, 2002 at 05:06:48PM -0700, Jeff Gibson wrote:
> configuration is below.

Please try out 2.5.2.  I'm not recommending to use it but merely
try if the problem is still there.  Second, can you make a
screen shot showing the problem and post it?  Please don't post
your whole desktop, a small portion is enough.  Finally, please
apply the attached patch to the sources, recompile and reinstall
fvwm and post the output it produces (just the last twenty lines).

To apply the patch, cd into the directory with the move_resize.c
file in the fvwm source tree, copy the patch file there and issue
the command

  $ patch < moveoutline.patch

> I'm not using many of the extensions, but it

It's not a matter of configuration.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
*** move_resize.c.orig	Wed Jul 31 10:52:59 2002
--- move_resize.c	Wed Jul 31 10:59:36 2002
***************
*** 2969,2974 ****
--- 2969,2977 ----
        get_outline_rects(
  	&(rects[1]), move_resize_grid.geom.x, move_resize_grid.geom.y,
  	move_resize_grid.geom.width, move_resize_grid.geom.height);
+ fprintf(stderr,"dmrg: erasing (%d) %4d %4d %4dx%4d\n", nrects,
+ 	move_resize_grid.geom.x, move_resize_grid.geom.y,
+ 	move_resize_grid.geom.width, move_resize_grid.geom.height);
    }
    if (width && height)
    {
***************
*** 2978,2983 ****
--- 2981,2988 ----
      move_resize_grid.geom.width = width;
      move_resize_grid.geom.height = height;
      nrects += get_outline_rects(&(rects[0]), x, y, width, height);
+ fprintf(stderr,"dmrg: drawing (%d) %4d %4d %4dx%4d\n",
+ 	nrects, x, y, width, height);
    }
    if (nrects > 0)
    {

---

From: Jeff Gibson <[email-masked]>
Date: Wed, 31 Jul 2002 06:42:49 -0700 (PDT)

I'll give 2.5.2 a shot.  Is there a tool that comes with fvwm2 that I
can use to take s screenshot?
	Thanks,
	Jeff

The following words come to us from Dominik Vogt:
> 
> 
> --tjCHc7DPkfUGtrlw
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: inline
> 
> --tjCHc7DPkfUGtrlw
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: attachment; filename="moveoutline.patch"
> 
> --tjCHc7DPkfUGtrlw--

-- 
Jeff Gibson			[email-masked]
Ph. D. Student in EE		Phone:  (Home)   (650) 938-5967
Computer Systems Lab			(Office) (650) 725-3657
Stanford University		http://www-flash.stanford.edu/~jeffg
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 31 Jul 2002 14:33:25 +0000

> can use to take s screenshot?

In fvwm-themes you may create a screenshot of a specific window or the
whole desktop automatically using the "Window Utility" menu.

You may do this manually of cause too. Use xv for this, pretty convenient.
Or import utility from ImageMagick:

  % import -frame /tmp/shot-window.png            # one window
  % import -window root /tmp/shot-window.png      # desktop

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 31 Jul 2002 14:46:36 +0000

Spelling session.

> You may do this manually of cause too. Use xv for this, pretty convenient.
                              ^^^^^ course
>   % import -window root /tmp/shot-window.png      # desktop
                                    ^^^^^^ desktop

There are also gimp, xwd and more utilities to create screenshots.

Regards,
Mikhael.

---

From: Gordon Prieur <[email-masked]>
Date: Wed, 31 Jul 2002 09:01:00 -0700

Jeff,

     The version of fvwm shouldn't make any difference (I've run several
and am now using 2.5.2 on Solaris 8). What is important is the version
of Solaris and patches you have installed (especially your X11/openwin
patches). I don't know what patches you need but Sun's web site does
have a tool for searching for and downloading free patches. I'd go
there and look for X11/OpenWin patches. My guess is that this will take
care of your problem. If your lab has a Sun support contract you might
have your system administrator talk to the Sun support people.

Gordon