Subject: FVWM: FVWM2 OpenLook theme

From: "Michel, Philipp" <[email-masked]>
Date: Thu, 25 Jul 2002 11:15:10 +0100

Hello all,

I am desperately looking for some way to make my fvwm desktop look as much
like Sun's OpenLook / ol(v)wm as possible, so as to ease long-time openlook
users moving to a new desktop. I was wondering whether anyone has done an
openlook theme in the past or if there's any floating around. If I have to
do it myself (by taking lots of screenshots), I would really appreciate some
pointers on how to quickly get at least the window borders and menu to look
somewhat like openlook.

I hope this is not too strange of a query...

Thanks a lot for your time,

-Philipp

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Thu, 25 Jul 2002 05:00:18 -0600

> I hope this is not too strange of a query...

We can't help you if we don't know what it looks like ;)

Upload some screenshots and post the URLs; please don't attach huge
screenshots to the list, though.

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
BOFH excuse #298:
Not enough interrupts

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Jul 2002 10:52:28 +0000

> pointers on how to quickly get at least the window borders and menu to look

Sorry to disappoint you here.

Currently it is impossible to emulate window borders. The best that you
may do is a flat black border without corners, or mwm-like borders.

Border handles may only have the size of the title height, but not half of
the title height. The same about title buttons positions, they can't have
an offset that is half of the title height.

An oval around menu items can't be emulated.
Menus can be "pinned" in 2.5.x, but a pin button is impossible.

A flat box around icon windows (bigger than icons) is impossible.

Regards,
Mikhael.

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Thu, 25 Jul 2002 05:06:43 -0600

> screenshots to the list, though.

Or not, I guess.

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
"Even more amazing was the realization that God has Internet access.  I
wonder if He has a full newsfeed?"
(By Matt Welsh)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Jul 2002 11:01:07 +0000

> screenshots to the list, though.

A web search (if you know how to search) never fails.

  http://www.plig.org/xwinman/screenshots/olwm.gif
  http://www.plig.org/xwinman/screenshots/olvwm-coyote.gif
  http://www.plig.org/xwinman/screenshots/olvwm-yetter.jpg

Regards,
Mikhael.

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Thu, 25 Jul 2002 08:40:06 -0600

> A web search (if you know how to search) never fails.

Nah, I'm just lazy. Leave the personal attacks off-list, please.

Love is being stupid together.
		-- Paul Valery

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Jul 2002 14:44:54 +0000

> Nah, I'm just lazy. Leave the personal attacks off-list, please.

I never attack, but I often suggest what works for me.

I mean, a lot of information that someone needs is already on the
internet, but sometimes you should find good search keywords.

Regards,
Mikhael.

---

From: "Rob 'Feztaa' Park" <[email-masked]>
Date: Thu, 25 Jul 2002 09:17:27 -0600

> I never attack, but I often suggest what works for me.

Right. Off-list you mentioned that you often don't put smilies, even
when you mean them. I suggest you start putting in more smilies; without
them you appear hostile and offensive, to me at least.  I get the
impression that you don't think very highly of me, but that doesn't
bother me, because you wouldn't be the first.

But, whatever. Do your own thing, guy. It's gotten you this far! ;)

Anyway, I'm going for some breakfast. I've been on the computer for a
good 14 hours straight, I need to get off for a bit.

> internet, but sometimes you should find good search keywords.

True; and google is a wonderful tool (I use it often, as it were).

HAND ;)

-- 
Rob 'Feztaa' Park
http://members.shaw.ca/feztaa/
--
"... Microsoft follows standards. In much the same manner that fish
follow migrating caribou." "Now I have this image in my mind of a
fish embracing and extending a caribou."
    -- Paul Tomblin and Christian Bauernfeind in a.s.r
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Fri, 26 Jul 2002 15:11:21 +0200 (CEST)

--- "Michel, Philipp" <[email-masked]> a
écrit : > Hello all,
> I hope this is not too strange of a query...

AddToFunction RestartFunction
+ "Behave like OLVWM" Restart olvwm

:-))

> Thanks a lot for your time,

It seems it's the only way :-)

Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com