Subject: FVWM: FvwmPager

From: Thomas Gardiner <[email-masked]>
Date: Sun, 7 Jul 2002 07:51:53 -0400 (EDT)

Hi,

I'm using fvwm2.4.0 and when I use the following config

*FvwmPager: Label * Current

I expected from the man page that when I switch desk, the pager label
would change to reflect the Current desk.  What happens, however, is that
desk 0 is always labeled Current.  Am I reading the man page correctly?

While I'm on the subject, is there a config option to allow say 3 desks to
show up in the pager with the center one being the current one?

The only thing I could find was invoking FvwmPager as

Module FvwmPager * X

and whatever I put for X was always ignored.

Thanks,

Tom

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 7 Jul 2002 14:36:45 +0200

> desk 0 is always labeled Current.  Am I reading the man page correctly?

No, I don't think so.  How should the pager know the names you
expect if all you specify is 'Current'?  The line above means
"Label all ('*') desks as 'Current'".  You have to label all the
desks you want to use manually:

  *FvwmPager: Label 1 desk1
  *FvwmPager: Label 2 desk2
  *FvwmPager: Label 3 desk3

And start the pager with

  FvwmPager * *

> show up in the pager with the center one being the current one?

No.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Gardiner <[email-masked]>
Date: Sun, 7 Jul 2002 16:19:50 -0400 (EDT)

Okay, then maybe the man page is written incorrectly?  I find this in the
man page for FvwmPager:

       *FvwmPager: Label desk label
              Assigns the text label to desk desk (or the current
              desk if desk is "*") in the  pager  window.  Useful
              for assigning symbolic names to desktops, i.e.

My interpretation of the first sentence is that if I do

*FvwmPager: Label * my_label

that the current desk should be labeled "my_label".

I guess I'm misunderstanding this sentence...  As for the labels for the
rest of the desks, I'm finding that by default they are labeled "Desk #"
where # is the desk number.

Thanks,

Tom

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Jul 2002 00:19:57 +0200

> where # is the desk number.

Ah, sure.  I shouldn't have replied without re-reading the man
page.  The '*' applies to the desk that is currently shown when
the pager is created.  If you start the pager while desk 2 is
shown, the label is applied to desk 2.  If you'r on desk 345, it's
applied to desk 345.  It's not dynamic.

Bye

Dominik ^_^  ^_^