Subject: FVWM: fvwm2 dropped from Red Hat Linux!

From: Jukka Lehti <[email-masked]>
Date: Thu, 4 Jul 2002 00:40:43 -0700 (PDT)

Hi,

I just noticed Red Hat has dropped fvwm2 package from
their latest beta! I think this is outrageous and we
should make an official protest against this
unjustified decision!

I'm going to fill in a bug report to Red Hat's
bugzilla RSN.

__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Thu, 4 Jul 2002 10:41:14 +0200 (CEST)

--- Jukka Lehti <[email-masked]> a écrit : >
Hi,
> should make an official protest against this

You must be joking,  right ?
Why do you think the new computers have huge 
amounts of ram ? To run fvwm ? No
You need something to take advantage of your ram.
Something like Gnome or KDE. That's why they 
are dropping fvwm. In terms of memory usage it 
is not well suited for the new millenium.

Programs these days consume more and more memory 
only fvwm decided: "Hey I can do a lot of things 
without consuming much memory". This is a very
conservative aproach and is not well suited for 
times we are living in :-))

Fvwm has bad habbits. I mean why a program should 
free memory when you have so much at your 
disposal ? :-))

> I'm going to fill in a bug report to Red Hat's

And they will say it's a hardware problem :-))

Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kendrick Vargas <[email-masked]>
Date: Thu, 4 Jul 2002 11:50:59 -0400 (EDT)

And you know... here I am with a 256k 32pin SIM on my keychain and a 512 
meg stick in my computer (that cost next to nothing comparitively), and I 
still think this is funny :-)
			-peace

-- 
Let he who is without clue kiss my ass

---

From: E Frank Ball <[email-masked]>
Date: Thu, 4 Jul 2002 17:57:15 -0700

On Thu, Jul 04, 2002 at 12:40:43AM -0700, Jukka Lehti wrote:
} I just noticed Red Hat has dropped fvwm2 package from
} their latest beta! I think this is outrageous and we
} should make an official protest against this
} unjustified decision!

Speaking of which, the fvwm2 package in RedHat 7.3 seems to be broken.
I could not get the titles on the buttons on my buttonbar to work.  I
tried every possible format for setting the font and labeling the
buttons I could think of.  Also there were no fonts shown in the pager.
Finally I dropped in the source:  configure, make, make install and
everything is working fine.

The fvwm2 package in RedHat 6.2 and 7.2 seem to be fine.

Anybody else notice this?  Anybody get it to work?

RedHat also dropped tin and xv starting with 7.1, two other programs I
can't live without.  I'm starting to learn Debian for this and many
other reasons.

-- 

   E Frank Ball                [email-masked]

---

From: parv <[email-masked]>
Date: Fri, 5 Jul 2002 02:11:53 -0400

in message <[email-masked]>,
wrote E Frank Ball thusly...
>
> RedHat also dropped tin and xv starting with 7.1, two other
> programs I can't live without.  I'm starting to learn Debian for
> this and many other reasons.

i can't imagine how could anyone to drop xv if it had been regular
part of an os install/distribution previously!  it's one neat light
weight graphic program  ... wait for it ...  oh, that reminds of the
earlier comments about reason for dropping fvwm.

disclaimer: i use freebsd, haven't ever used linux.  i suppose i
just love xv so much that the efb's comment caused separation
anxiety.

  - parv

--

---

From: David Fries <[email-masked]>
Date: Tue, 9 Jul 2002 00:51:01 -0500

Speaking of memory usage, has anyone thought about looking for some
memory leaks?  Ok so I've been a lazy Debian user and I'm not up to
what's in CVS (2.4.7 right now), but here's what I'm seeing (from top).

  PID USER     PRI  NI  SIZE SWAP  RSS SHARE STAT %CPU %MEM   TIME COMMAND
  668 david      8   0 15300 8948 6352  3440 S     0.0  1.9   3:35 fvwm2
after restarting fvwm, same windows etc
  668 david     10   0  2468    0 2468  1348 S     0.1  0.7   3:36 fvwm2

Let's see, 15MB vs 2.4MB, could be.  It could also be fixed by now in
CVS.

Does anyone have a favorite memory leak checker?  I've tried two, but
I haven't been to impressed with them.  One was called memusage (at
least on SuSE), and said what was allocated/freed and sizes but I had
no idea where the leak was, or glibc doing exit instead of free..exit.

On Thu, Jul 04, 2002 at 10:41:14AM +0200, szonyi calin wrote:
>  --- Jukka Lehti <[email-masked]> a ?crit?: >
> Hi,
> > 
> Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en fran?ais !

-- 
		+---------------------------------+
		|      David Fries                |
		|      [email-masked]        |
		| http://fries.net/~david/pgp.txt |
		+---------------------------------+
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 9 Jul 2002 11:05:20 +0200

On Tue, Jul 09, 2002 at 12:51:01AM -0500, David Fries wrote:
> memory leaks?

Yes, we regularly run Purify or a similar tool before major
releases.  In the mean time I frequently use efence to detect
other memory problems.

>  Ok so I've been a lazy Debian user and I'm not up to

Unfortunately, the information about memory usage that top shows
has little to do with the real memory consumtion.  Chances are
good that you didn't see a memory leak at all.

> Does anyone have a favorite memory leak checker?

My favourite is insure++, but the company totally freaked out:
they demand about EUR 10000 for a single, CPU locked license.
Since we couldn't convince them to sponsor a license for our work,
we usually run Purify - which is vastly inferior to insure++ - but
we have a few people on the list who can run it.

> I've tried two, but

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, mail: [email-masked], phone: 0721/91374-382
Schlund + Partner AG, Erbprinzenstr. 4-12, D-76133 Karlsruhe
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 11 Jul 2002 08:47:37 +0200

>   668 david     10   0  2468    0 2468  1348 S     0.1  0.7   3:36 fvwm2

Maybe some part the leaks come from the Xlib. I think that the
debian package is compiled with --enable-multibyte. There is some memory
leaks in XCreateFontSet: each time a font is unloaded ~4kb is lost (this
depends on the font, with an utf8 locale and if you use an iso106464-1
font with a big coverage this may be a lot more).

For example:
- if you delete a window ~4kb is lost (0kb with 2.5.2) 
- if you change your font and you have 20 windows, ~80kb is
lost (only 4kb with 2.5.2).

I've recently sent a patch to the XFree developers but no feedback yet ...

Note that I do not claim that all the leak come from the Xlib,
it is just a possibility. So one question and one query:
- Do you do something special regarding the fvwm config
(as regularly changing some config parameters)
- Can you send me your config file(s) if this is possible.

Regards, Olivier

---

From: David Fries <[email-masked]>
Date: Sun, 14 Jul 2002 15:12:42 -0500

I can say for sure that fvwm 2.4.7 is leaking memory per program
window.  I don't think the cvs version 2.5.3 is leaking, but I can't
be completely sure.  I just ran a bunch of xterms and it seemed fine.

I've included a program to ponder, and I'll suggest using Xnest if
anyone wants to run it, or an X session they don't want to use for a
while.

  PID USER     PRI  NI  SIZE SWAP  RSS SHARE STAT %CPU %MEM   TIME COMMAND
23686 david      9   0   856  240  616   616 S     0.0  0.1   0:00 FvwmPager
23677 david      9   0   488  112  376   376 S     0.0  0.1   0:00 FvwmTheme
23653 david      9   0  321M 310M  10M 11060 S     0.0  3.5   2:49 fvwm

The program is simple enough, but here's what it does anyway.
1. open X connection
2. create window
3. destroy window
4. go to #2 n times (I'm using 1000000)
5. close X connection 

I'm just throwing this program out for anyone to look at if they are
interested, I'm not going to look into it myself.  I tried it against
kde maybe I didn't wait long enough (over night) but kde didn't
recover where fvwm fully recovers, although it doesn't give the memory
back to Linux.

---

From: David Fries <[email-masked]>
Date: Sun, 14 Jul 2002 15:17:51 -0500

Sorry I sent the wrong version of the program.  It is fine if I add
the nanosleep in there, apparently it gives fvwm enough time to
cleanup, so if you want a big fvwm you have to remove the nanosleep
line.  Sorry about the confusion if any, at least this way people will
have to read instructions to cause problems.

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 24 Jul 2002 11:49:19 +1000

On 02:11 05 Jul 2002, parv <[email-masked]> wrote:
| in message <[email-masked]>,
| wrote E Frank Ball thusly...
| > RedHat also dropped tin and xv starting with 7.1, two other
| > programs I can't live without.
| i can't imagine how could anyone to drop xv if it had been regular
| part of an os install/distribution previously! [...]

xv is shareware - I don't think RedHat were really allowed to ship it.

I too use xv heavily, with the PNG patches. It's way lighter and faster
than the gimp (which seems the very epitome of bloatware). Not awfully
scriptable though.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

Yes Officer, yes Officer, I will Officer. Thank you.

---

From: Cameron Simpson <[email-masked]>
Date: Wed, 24 Jul 2002 11:54:52 +1000

On 11:05 09 Jul 2002, Dominik Vogt <[email-masked]> wrote:
| On Tue, Jul 09, 2002 at 12:51:01AM -0500, David Fries wrote:
| > Speaking of memory usage, has anyone thought about looking for some
| > memory leaks?
| Yes, we regularly run Purify or a similar tool before major
| releases.  In the mean time I frequently use efence to detect
| other memory problems.
[...]
| Unfortunately, the information about memory usage that top shows
| has little to do with the real memory consumtion.  Chances are
| good that you didn't see a memory leak at all.
[...]

Maybe a better question is: Dominik, what FVWM features consume memory,
and at vaguely what rate? I mean here, statements like "a backdrop
image for a menu will cost you XxYx(native X11 bytes-per-pixel)" *
"per menu"/"per use"/"per ...". Little rules of thumb like that, not so
much to locate leaks but to give the byte-thrifty user an idea of how
much penatly they're incurring with their decorations/styles etc.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

You need a brain the size of a melon to take it [the Isle of Man TT course]
all in and one the size of a walnut to actually race it.	- Peter Salmon
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Tue, 23 Jul 2002 22:42:07 -0700

> xv is shareware - I don't think RedHat were really allowed to ship it.

  debian dropped it too, there's some problem with the licence...

	erik

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Jul 2002 07:53:55 +0200

>   debian dropped it too, there's some problem with the licence...

It's only free for non-commercial use.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Jul 2002 08:18:26 +0200

> much penatly they're incurring with their decorations/styles etc.

Roughly,

 - a few hundred bytes per window, per style name and per menu
   style name
 - the size of the strings in menu entries and function actions
 - the size of the pictures and gradients used
   (width x height x depth / 8)
 - about 20 to 50 bytes for each structure that is used (colour
   sets, menus, vectors, bindings, buttonstyles, titlestyles,
   borderstyles, function

The only interesing things to watch are windows, styles that are
issued in the 'wrong' order and growing menus or functions.  The
wrong order of specifying styles is this:

  Style * A, B
  Style X B, C
  Style * A, notB
  Style X B, notC

Fvwm tries to merge new styles together if possible.  In this
case, nothing can be merged because adjacent styles with different
names override style B.  If one had issued

  Style * A, B
  Style * A, notB
  Style X B, C
  Style X B, notC

The list would have been merged to

  Style * A, notB
  Style X B, notC

thus saving half the memory.  This can be a problem if you use
some scripts or complex functions to change fvwm's behaviour or
the used theme at run time.  If done wrong, the stlye list can
grow beyond limits.

Bye

Dominik ^_^  ^_^