Subject: FVWM: PopupOffset first integer doesn't survive a CopyMenuStyle?

From: Gregg Dameron <[email-masked]>
Date: Tue, 11 Jun 2002 12:28:07 -0600

Running 2.4.7 on Solaris 8.

If I have these lines in my config file:

AddToMenu MyMenu
...

MenuStyle * PopupOffset -7 100
CopyMenuStyle * NewMenuStyle
# not yet:
#MenuStyle NewMenuStyle PopupOffset -7 100
ChangeMenuStyle NewMenuStyle MyMenu

then the PopupOffset for MyMenu is effectively 0 100.  That is, only
the second integer appears to be copied to the new style.  I must
repeat the PopupOffset for the new menu style (that is, uncomment
the second MenuStyle line) in order for MyMenu to have the desired
PopupOffset.

I don't mind putting in the extra line, but it seems redundant.  Can
anyone else reproduce this behavior?

Gregg Dameron

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Tue, 11 Jun 2002 22:39:06 +0200

On Tue, Jun 11, 2002 at 12:28:07PM -0600, Gregg Dameron wrote:
> AddToMenu elease stage).

Yes, there is a bug. It will be fixed in 2.4.8 or 2.4.9 (as 2.4.8
is at release stage).

Thanks, Olivier