Subject: FVWM: Stick from the title bar

From: "Mark A. Nicolosi" <[email-masked]>
Date: Sat, 29 Jun 2002 14:58:55 +0000

Hi!

I've binded (bound?) Stick to a title bar button. I want to use different pixmaps in the title bar button, one for when it's not sticky and one for when it is. I tried writing a function but I couldn't figure out a way to do it.

Thanks in Advance

- Mark A. Nicolosi
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Fri, 28 Jun 2002 14:03:42 -0600

> I've binded (bound?) Stick to a title bar button. I want to use different pixmaps in the title bar button, one for when it's not sticky and one for when it is. I tried writing a function but I coul…
search the man page for MwmDecorStick, ToggledActiveUp, ToggledActiveDown
and  ToggledInactive

sa

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 28 Jun 2002 21:58:02 +0000

On 28 Jun 2002 14:03:42 -0600, S. Anderson wrote:
> > I've binded (bound?) Stick to a title bar button. I want to use
> > different pixmaps in the title bar button, one for when it's not
> > sticky and one for when it is. I tried writing a function but I
> > couldn't figure out a way to do it.
> 

And "Style * MWMButtons". You don't need a function.

Regards,
Mikhael.

---

From: "Mark A. Nicolosi" <[email-masked]>
Date: Sat, 29 Jun 2002 01:11:27 +0000

On Fri, 28 Jun 2002 21:58:02 +0000

> And "Style * MWMButtons". You don't need a function.

How would I tell fvwm to use mini.stick.xpm for when it isn't sticky and to use mini.stickpressed.xpm when it is sticky for a title bar button?

P.S. Sorry Mikhael, didn't mean to send this to your personally.
- Mark A. Nicolosi

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 29 Jun 2002 08:54:42 +0000

On 29 Jun 2002 01:11:27 +0000, Mark A. Nicolosi wrote:
> How would I tell fvwm to use mini.stick.xpm for when it isn't sticky and
> to use mini.stickpressed.xpm when it is sticky for a title bar button?

  Style * MWMButtons

  ButtonStyle 3 ActiveUp   Pixmap mini.stick.xpm
  ButtonStyle 3 ActiveDown Pixmap mini.stickpressed.xpm
  ButtonStyle 3 Inactive   Pixmap mini.stick.xpm
  ButtonStyle 3 ToggledActiveUp   Pixmap mini.stickpressed.xpm
  ButtonStyle 3 ToggledActiveDown Pixmap mini.stick.xpm
  ButtonStyle 3 ToggledInactive   Pixmap mini.stickpressed.xpm

  ButtonStyle 3 - MwmDecorStick

  Mouse 0  3  A  Stick

You may setup 6 different pixmaps, not only 2.
When I answer a question about configuring titlebar buttons, I usually
copy the buttons component from one or another theme in fvwm-themes.

Regards,
Mikhael.

---

From: "Mark A. Nicolosi" <[email-masked]>
Date: Sat, 29 Jun 2002 04:14:49 +0000

On Sat, 29 Jun 2002 08:54:42 +0000

> copy the buttons component from one or another theme in fvwm-themes.

Thanks a bunch. The FVWM man page only dedicates a few sentences to Toggle* in the ButtonStyle section, so I was sure how to use it.

Thanks again.
- Mark A. Nicolosi