Subject: Re: Re: FVWM: DeIconify does *not* deiconify iconified windows

From: [email-masked]
Date: Wed, 26 Jun 2002 15:12:16 +0200

> Sigh, it's another of these situations when fvwm thinks the window
> is mapped but it's actually unmapped.  To debug this, I need your
> fvwm config file (please strip it down as much as possible - that
> saves me a lot of work), access to the application you used and
> detailed instructions to reproduce the problem (a la "start app.,
> click here, click there etc.").
> 
> Bye
> 

Hop this works with my webmail. If not, I'll have to resend this tomorrow from my PC at home.

testapp is a tcl/tk application, you need wish to have installed (www.tcl.tk)
start it with "wish testapp iconify" or "wish testapp withdraw" to test with the new window built eiter iconified (does not work) or withdrawn (does work).
In iconify mode: Try to move other windows over the new window; Click on the iconify button, and the window gets repainted

My config file is very short:

----- start of config file
DeskTopSize 1x1
ModulePath /usr/local/libexec/fvwm/2.4.8
EdgeResistance 100 100
OpaqueMoveSize 40

WindowFont -*-fixed-bold-r-*-*-16-*-*-*-*-*-*-*
MenuStyle "*" Font -adobe-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*

ImagePath /usr/X11R6/lib/X11/fvwm2/pixmaps/

TitleStyle ActiveUp (TiledPixmap "title.xpm" -- flat)
TitleStyle ActiveDown (TiledPixmap "title.xpm" -- flat)
TitleStyle InActive (TiledPixmap "titlei.xpm" -- flat)
ButtonStyle 1 (TiledPixmap "button1.xpm" -- flat)
ButtonStyle 2 (TiledPixmap "button2.xpm" -- flat)
ButtonStyle 4 (TiledPixmap "button4.xpm" -- flat)
ButtonStyle 6 (TiledPixmap "button6.xpm" -- flat)

HilightColor white  #999999
Style "*" Color #999999/#999999
Style "*" MWMBorder
Style "*" HintOverride
Style "*" NoIcon
Style "*" NoButton 3, NoButton 5
Style "*" StickyIcon
Style "*" BorderWidth 4, HandleWidth 4

Style "work" NoTitle, HandleWidth 0, BorderWidth 0,StaysOnBottom
Style "Untitled" NoTitle, HandleWidth 0, BorderWidth 0
Style "LoginShell" StaysOnTop

--- end of config

the application, that's always in the background is : work (cannot supply that, is a commercial product and requires quite a lot config files), but the error also occurs, if no window covers the whole desktop.

Hope this information will help you to track down the bug.

Gerhard

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 30 Jun 2002 02:25:28 +0200

> In iconify mode: Try to move other windows over the new window; Click on the iconify button, and the window gets repainted

Okay, it took me quite some hours to figure this out:  It's *not*
a problem with fvwm.  Although you can't see it, the application
window *is* mapped.  It's just that tk thinks it is not visible
and thus does not draw anything into it.  I couldn't find
anything that fvwm is doing wrong.  Actually, I couldn't even
find any difference in the requests that wish sends to fvwm -
regardless if the deiconify line is in the code or not.  I think
there must be a bug in wish.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].