Subject: FVWM: Customized cursors

From: Christian MICHON <[email-masked]>
Date: Mon, 17 Jun 2002 12:03:16 +0200 (CEST)

Hi,

when I try to use xpm cursors, I can't have any shade of gray in it, like
in windoze. I understand that, due to the standard way of defining cursors
and their mask in b&w, this may not be possible.

If I migrate to 2.5.1+ and PNG support, will the cursors also be black and
white ?

Rgds,
Christian

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 Jun 2002 10:16:45 +0000

> If I migrate to 2.5.1+ and PNG support, will the cursors also be black and

This is not related to xpm vus png.

Cursors have 2 colors, inner and outer, or fg and bg. By default these
colors are black and white. But you may choose any other 2 colors:

  CursorStyle MENU left_ptr yellow black

The same syntax applies to the pixmap cursors.

  CursorStyle MENU myimage.xpm red darkred

If X supports more than 2 colors, we may support this too.

Regards,
Mikhael.