Subject: FVWM: aterm - rxvt problem

From: Philippe Naudin <[email-masked]>
Date: Tue, 25 Jun 2002 11:49:33 +0200

Hello,

Is there a known issue with aterm (0.4.2) or rxvt (2.7.6) ?

With this fvwmrc (and fvwm-2.4.8) :
Style * ClickToFocus, ClickToFocusPassesClickOff

the option ClickToFocusPassesClickOff works fine when I click an
unfocused aterm or rxvt, but not when I click and move the mouse before
releasing the button (the client is focused _and_ a selection is made in
it). 

A workaround would be really appreciated (I have made bad things to my
home directory, when attempting to re-focus aterm and paste some
selection in a burst, before stopping the mouse). "IgnoreModifiers L25"
doesn't help here ... 

Hmm ... I hope these explanations are clear enough. Thanks for your
efforts to understand them ! 

-- 
Philippe Naudin
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 29 Jun 2002 21:53:01 +0200

> efforts to understand them ! 

There is little we can do about that.  It's not the click that
gets passed to the window - insofar fvwm works correctly.  The
problem is that rxvt and aterm request pointer motion events with
any button held down.  Fvwm releases the grab of the pointer after
the click is processed and further mouse events are processed by
the application.  It does not happen with xterm because xterm
requires to receive the click.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].