Subject: FVWM: Looking for a utility

From: Tim Hanson <[email-masked]>
Date: Sat, 01 Jun 2002 14:15:43 -0700

I confess that I'm using the standard FVWM2 that came with SuSE 7.1, so 
I don't have the current program, but I have resisted moving to either 
the standard GNOME or KDE desktops because of familiarity and the small 
footprint of FVWM.  SUSE 8 is on the way in the mail.

Is there a utility which would create menus (either Buttons or the 
standard mouse menus) from a directory of links on the fly?  It sure 
would be nice if I could alter my menu structure simply by moving links 
and icons to a specific "~/FVWM_Menu" directory, rather than dealing 
with .fvwm2rc.
-- 
We ARE as gods and might as well get good at it.
		-- Whole Earth Catalog

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 01 Jun 2002 18:05:12 -0400

> and icons to a specific "~/FVWM_Menu" directory, rather than dealing 

There are 2 shells in the utils directory:

fvwm_make_browse_menu
fvwm_make_directory_menu

that demonstrate how to make a menu from directories.

Maybe, those shells will give you some ideas.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Hanson <[email-masked]>
Date: Sun, 16 Jun 2002 17:22:43 -0700

Mikhael Goikhman wrote:
> On 16 Jun 2002 01:39:17 -0700, Tim Hanson wrote:
> 
> Two issues. 1) If you want to simply create a static menu, just write a
> script that prints "DestroyMenu MyMenu", "AddToMenun MyMenu" lines and run
> it using "PipeRead your_script" command.
> 
> 2) If you want to have dynamical menus, upgrade your FVWM version to
> 2.4.8. The one that is shipped with SuSE 7.1 is too old (2.2.4).
> 
> These 2 shell scripts that create dynamical menus are in:
> 
>   ftp://ftp.fvwm.org/pub/fvwm/devel/sources/utils/
> 
> But check whether one of the 4 fvwm-menu-* scripts that are installed with
> the rest of FVWM (2.4.x or 2.5.x) do the job you need. They have man pages:
> 
>   % man fvwm-menu-desktop
>   % man fvwm-menu-directory
>   % man fvwm-menu-headlines
>   % man fvwm-menu-xlock
> 
> Regards,
> Mikhael.
> --
Thanks for the help.  I've got Suse 8.0 on my laptop; it still needs to 
go on a server
and a desktop, but it's so much different than 7.x I'm going to go 
slowly.  I just found
out how to get Nautilus started without having it load its own background.

-- 
Logic is a little bird, sitting in a tree; that smells *_____awful*.