Subject: FVWM: Numlock + Tab key - Window Kill issue

From: "subbiah .L" <[email-masked]>
Date: Wed, 12 Jun 2002 15:56:17 +0530

Hello,

I am using my own Terminal Emualtor with the fvwm2 2.4.3 window manager.
I have enabled the fvwm2 as windows 95 style window manager by using the 
Rebuild Sample 95 option.

I have set Click to foucs as my style.

If my Num lock key is On and if I press Tab, then my Terminal Emulator 
windows crashes and leaves this message.

  X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  42 (X_SetInputFocus)
  Serial number of failed request:  275
  Current serial number in output stream:  275

I need the Num Lock. I canot disable the Num Lock key.

I am using the XCreateWindow function to create the Terminal Emulator 
window.

  Can any one suggest me to get a solution for this problem ?.

With Thanks and regards,
L. Subbiah

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 12 Jun 2002 19:20:36 +0200

>   Can any one suggest me to get a solution for this problem ?.

Put

  XSynchronize(<display>, 1);

in your program, then single step through it to find out which
X call triggers the crash.  This usually happens when an illegal
resource is referenced or an illegal value is passed to X.  You
have to find out why this happens (e.g. the window has already
died) and take care of that situation.  If all else fails, you
have to write an X error handler that filters out this error
condition.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].