Subject: FVWM: lack of pager

From: Brian Postow <[email-masked]>
Date: Mon, 17 Jun 2002 11:26:15 -0400

I'm having trouble getting a pager to appear. I'm using a .fvwm2rc
that has worked fine in previous versions of fvwm2, so I'm not sure
what I'm doing wrong. I'm running a slightly old version of fvwm
(2.2.5), but that shouldn't have any effect, unless there's a fixed
bug that I don't know about.

Here are the relevant parts of my .fvwm2rc:

DeskTopSize 3x3
DeskTopScale 32
Module FvwmPager * *

.
.
.
Style "FvwmPager" Icon, NoTitle, NoHandles, Sticky, CirculateSkip, WindowListSkip, BackColor Green, ForeColor Black
.
.
.
AddToMenu "Utilities" "Utilities" Title
+ "Calculator"    exec calctool -geometry 0x0 &
+    "Xman"          exec xman &
+    "Xmag"          exec xmag &
+       ""       Nop
+    "Pager"	Module FvwmPager 0 0
.
.
.

Function "InitFunction"
        Module     FvwmPager * * 
#        Exec    "I"     xsetroot -solid blue3
EndFunction

Function "RestartFunction"
        Module   FvwmPager * *
        Exec    "I"     xsetroot -solid Green
EndFunction

.
.
.
########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1 0
*FvwmPagerLabel 0 Misc
#*FvwmPagerLabel 1 FrameMaker
#*FvwmPagerLabel 2 Mail
#*FvwmPagerLabel 3 Matlab
*FvwmPagerSmallFont 5x8

Any thoughts?

Thanks a lot.

Brian

-- 
More incoherent ramblings from:  Brian "Lizard Bench Mango" Postow ('94)
FOOBAR: Foo Of Oberlin Bygone Alumni Retirees   the foo, the proud: the Foo.

The hills are aliiiive with the souuuund of giant slugs!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 17 Jun 2002 18:52:44 +0200 (CEST)

>         Exec    "I"     xsetroot -solid Green

Hmm, this looks like fvwm version 1 systax

It should be

Function "InitFunction"
+         Module     FvwmPager * *
+         Exec    "I"     xsetroot -solid blue3

Function "RestartFunction"
+         Module   FvwmPager * *
+         Exec    "I"     xsetroot -solid Green

Note the "+" to continue a definition. And no EndFunction because + always
adds to the latest "mentioned" function.

//Marcus

---

From: Brian Postow <[email-masked]>
Date: Mon, 17 Jun 2002 12:59:56 -0400

> adds to the latest "mentioned" function.

Ok, I made that change, and it didn't have any effect. It didn't set
the root color or anything, those are the correct names for the
functions that automatically get called when you start and restart
respectively right?

I even added:

Function "StartFuncton"
+         Module   FvwmPager * *
+         Exec    "I"     xsetroot -solid Grey50

and when I re-start, nothing still happens. 

Is there some way that I can see any error messages that fvwm is
giving me?

Thanks

Brian

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 Jun 2002 17:00:55 +0000

> Here are the relevant parts of my .fvwm2rc:

This is ok.

> DeskTopScale 32

You should see "No such command 'DeskTopScale'" error, don't you?
The correct syntax for 2.2.5 is:

  *FvwmPagerDeskTopScale 32

> Module FvwmPager * *

Running a module before defining its configuration is not good.
Modules should be started from StartFunction (works in 2.2.5).

>         Exec    "I"     xsetroot -solid Green

This is an old configuration of fvwm version 1. If you leave it as is, you
should see at least 3 errors on your standard error stream, don't you?

  No such command 'EndFunction'
  /bin/sh: "I": command not found
  No such command 'EndFunction'
  
You should also get 3 pagers running, don't you?

The correct syntax is:

  AddToFunc InitFunction
  + I Module FvwmPager * *
  + I Exec xsetroot -solid blue3

  AddToFunc RestartFunction
  + I Module FvwmPager * *
  + I Exec xsetroot -solid Green

or just:

  AddToFunc StartFunction
  + I Module FvwmPager * *
  + I Exec xsetroot -solid darkcyan

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 Jun 2002 17:04:06 +0000

> +         Exec    "I"     xsetroot -solid Green

No, this is totally incorrect syntax, it misses four "I" after "+"
and two existing "I" should be removed.

Regards,
Mikhael.

---

From: Brian Postow <[email-masked]>
Date: Mon, 17 Jun 2002 13:06:11 -0400

>   *FvwmPagerDeskTopScale 32

Ok, I fixed that

>   No such command 'EndFunction'

I'm not sure, I'm not seeing any error messages in my xconsole... I'm
not sure where else they'd be.

> You should also get 3 pagers running, don't you?

No, I'm getting 0, that's exactly the problem.

>   + I Exec xsetroot -solid darkcyan

Ah, well at least this DOES make my root cyan, which is a start, but
still no pager.

Thanks

Brian

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 17 Jun 2002 19:12:00 +0200 (CEST)

> and two existing "I" should be removed.

Oops, my fault, I didn't really think, I just saw the "EndFunction" and
missing +'s....

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 17 Jun 2002 17:18:28 +0000

> not sure where else they'd be.

This depends on your system setup. The error messages are usually in the
same place the X errors are. But some distributions redirect fvwm2 output
to something like ~/.FVWM2_errors.

I start X using this command:

  % xinit [params] 2>&1 | tee $HOME/x.out 2>&1

So I see X errors (and FVWM errors) in both virtual console and ~/x.out.
You may just redirect xinit or startx to a file without "tee" command.

> No, I'm getting 0, that's exactly the problem.

Probably a problem with ModulePath. Can you run any module at all?
For example, FvwmConsole or FvwmBanner.

Regards,
Mikhael.

---

From: Brian Postow <[email-masked]>
Date: Mon, 17 Jun 2002 13:23:07 -0400

> For example, FvwmConsole or FvwmBanner.

Exactly. I just found the errors (.xsession-errors) and it says:

[FVWM][executeModule]: <<ERROR>> No such module 'FvwmPager' in
ModulePath '/usr/imports/fvwm2/libexec/fvwm/2.2.5:/usr/imports/fvwm/modules'

Ok, I'll track this down. thanks a lot.

Brian

---

From: Brian Postow <[email-masked]>
Date: Mon, 17 Jun 2002 13:25:59 -0400

Bingo. Ok, after finding the correct path, it works now.

Thanks a lot.

Brian