Subject: FVWM: fvwm hangs

From: Bruce M Beach <[email-masked]>
Date: Fri, 14 Jun 2002 21:49:22 +0000 (GMT)

Hello All

  If  I execute a tcl script from the fvwm menu
  that has the  the following line:
    "Tkxset"             Exec exec /scripts/tkxset
  It start up fine and works fine but when I push the "quit"
  button which executes the following tcl procedure

      #!/usr/local/bin/wish  #<----- First line of script
      ..
      ..
      proc quit {} {
      destroy .
      }
  the  button stays depressed and the whole root screen partially
  freezes. Partially because the mouse is still working, but the
  various applications do not respond. (i.e in focus-follows mouse
  the xterms dont' change color as I move the mouse into them,
  raising and lowering window or moving no longer works etc.)

  Now if I'm clever I'll have two xterms
  1) with the line: sh-2.05a# ps x
  2) with the line: sh-2.05a# kill

  I can add a carriage return to the "ps x", get the process
  number (cut and paste) and add it to the kill and kill the
  tk application. It does not kill the application!, or restore
  the window manager. Every thing remains non-functional but the
  usual sequence "cntrl-alt-backspace" still works so I can kill
  the xserver and start again.

  I have the following
        (These comments apply to all tk/tcl applications)

    1)  Start tkset(just a tk/tcl application) from an xterm.
        Works fine and exits fine.
    2)  Start from the root menu and use the window dropdown
        ...
        ...
        Delete
        Close     <-- this partially hangs the window manager
        Destroy   <-- closes the application
        ...
        ...

    I'm using
        fvwm-2.4.8
        linux-2.4.18
        xwindows 4.20
        glibc-2.2.5
        gcc-3.0.4
        no gnome

    I suspect that the problem is not fvwm but
    one of the other major subsystems, but who ?
    I've been using fvwm for 5 or 6 years and
    this is something new.

   Bruce

   Ps I'm behind the great firewall of China and if
   I subscribe to the list I tend to get weird things
   happening like messages from the mailing list saying
   that message are bounceing back with headers that say
   " More than ten words matched. Rejected"
   so if you could cc any replies it would be appreciated.

   [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 18 Jun 2002 11:04:57 +0200

>   raising and lowering window or moving no longer works etc.)

Can you send me the whole tk script?  Pressing ctrl-alt-escape may
help to break the freeze.

>    so if you could cc any replies it would be appreciated.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bruce M Beach <[email-masked]>
Date: Tue, 18 Jun 2002 20:05:46 +0000 (UTC)

On Tue, 18 Jun 2002, Dominik Vogt wrote:

>>   ..................................

> help to break the freeze.

   Thanks for the reply. I can send you the script but I'm not sure
   of the need. I was going to write to the tk/tcl people about the
   problem, but first I thought I would see if there were any new
   versions. There was so I upgraded from tcl8.4a3 to tcl8.4a4,
   likewise with tk and the problem went away. I rebuild the entire
   system from source every week and at one point tcl8.4a3 and fvwm
   were working fine. Then one week something (probably a new glib)
   broke tcl8.4a3. At first I thought it was fvwm-2.4.8, but I went
   back to an older version, tcl was still broken, so it wasn't fvwm.
   As I say tcl8.4a4 fixed the problem.  As far as the script goes,
   all tcl/tk scripts were broken on that term signal. I imagine that
   the tcl/tk people know about the problem but it does seem strange
   that there is a lib/tcl/gcc/... combination where signals are not
   working properly. If you need to know more about this problem let me
   know and I can restore the old tcl again.

   Bruce

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 19 Jun 2002 12:39:11 +0200

>    know and I can restore the old tcl again.

Ah, thanks for the info.  I guess we can ignore the problem then.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].