Subject: FVWM: DeIconify does *not* deiconify iconified windows

From: [email-masked]
Date: Tue, 25 Jun 2002 16:17:43 +0200

Recently I tried to upgrade fvwm from 2.2.5 to 2.4.8. Some bug must have been introduced into function DeIconify (called in events.c line 1177). I have a iconified window, and when I try to deiconify it, only the window frame+decoration  get's repainted. The X-Events the window manager produces, vary a *lot* from version 2.2.5 to 2.4.8.
2.2.5 produces: CreateNotify, MapNotify,CreateNotify,ConfigureNotify amd MapNotify
2.4.8 produces: ReparentNotify, ConfigureNotify,MapNotify, VisibilityNotify,Expose and UnmapNotify.

This is with tcl/tk (8.3.4). The tk-window content get's not painted, if I use the command "update idletasks".
This does not happen with other window managers.
I compared event.c with version 2.2.5 and the code or at least the comments seem to be mixed up.
I tried to changed in line 1174 the IS_ICONIFIED to !IS_ICONIFIED, the problem's gone (that's the reason why I believe the error is in function DeIconify) , but this will definitely have sideeffects. Also the comment above this line seems to belong elsewhere.
Can someone of the "core developers" give a comment on this ?

Thanks
Gerhard

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 26 Jun 2002 12:31:03 +0200

On Tue, Jun 25, 2002 at 04:17:43PM +0200, [email-masked] wrote:
> Recently I tried to upgrade fvwm from 2.2.5 to 2.4.8. Some bug
> must have been introduced into function DeIconify (called in
> events.c line 1177). I have a iconified window, and when I try
> to deiconify it, only the window frame+decoration  get's
> repainted. The X-Events the window manager produces, vary a
> *lot* from version 2.2.5 to 2.4.8.
> This is with tcl/tk (8.3.4). The tk-window content get's not
> painted, if I use the command "update idletasks".
> I compared event.c with version 2.2.5 and the code or at least
> the comments seem to be mixed up.  I tried to changed in line>
> 1174 the IS_ICONIFIED to !IS_ICONIFIED, the problem's gone
> (that's the reason why I believe the error is in function
> DeIconify) , but this will definitely have sideeffects. Also the
> comment above this line seems to belong elsewhere.
>

Sigh, it's another of these situations when fvwm thinks the window
is mapped but it's actually unmapped.  To debug this, I need your
fvwm config file (please strip it down as much as possible - that
saves me a lot of work), access to the application you used and
detailed instructions to reproduce the problem (a la "start app.,
click here, click there etc.").

Bye

Dominik ^_^  ^_^

P.S.:  Please do not reply to the lifebits mail address.  I will
delete that mail account in a few hours.

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].