Subject: FVWM: FVWM 2.4.7 vs CygWin

From: [email-masked] (Perry Hutchison)
Date: Sat, 4 May 02 22:24:00 PDT

While others apparently have had no problems building FVWM under CygWin,
it's not working for me.  Configure claims aclocal and automake are
missing, even though they are in /bin and /bin is in the PATH.  It also
claims that gcc doesn't work.  How do I find out what it's doing wrong?

I'm on the list at another email address, but please Cc: this one :)

========================================================================

phutchis@WIN95B ~
$ cd /download/fvwm-2.4.7

phutchis@WIN95B /download/fvwm-2.4.7
$ ./configure --with-gnome=no > configure3.log 2>&1

phutchis@WIN95B /download/fvwm-2.4.7
$ cat configure3.log
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... found
checking for working automake... missing
checking for working autoheader... found
checking for working makeinfo... missing
checking whether to enable command logging... no
checking whether to enable debugging messages... no
checking whether to enable multibyte character support (experimental)... no
checking whether to enable compound text conversion support... yes
checking imagepath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

phutchis@WIN95B /download/fvwm-2.4.7
$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/COMMAND

phutchis@WIN95B /download/fvwm-2.4.7
$ ls -l /bin/aclocal
-rwxr-xr-x    1 phutchis unknown      4619 Mar 13 00:27 /bin/aclocal

phutchis@WIN95B /download/fvwm-2.4.7
$ ls -l /bin/automake
-rwxr-xr-x    1 phutchis unknown      5531 Mar 13 00:27 /bin/automake

========================================================================

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 5 May 2002 10:52:54 +0000

> claims that gcc doesn't work.  How do I find out what it's doing wrong?

I suppose, there is nothing CygWin specific here.

You only need aclocal and automake for building from cvs sources.
You don't need them to build 2.4.7. Probably the reason ./configure does
not recognize them is that you have old versions, I don't know.

The gcc problem is fatal. Do you have working gcc? Try to compile and run
any hello-world program. Take a look at config.log, it should contain the
exact C program and compiler/linker flags that failed.

Regards,
Mikhael.