Subject: FVWM: WindowList question

From: Eduardo Gargiulo <[email-masked]>
Date: Wed, 22 May 2002 23:41:59 -0400

Hi all.

I'd customized .fvwm2rc, but now, when I hit F4 to show up WindowList,
the process list disappear when i release the key and next time it
appear in the upper left corner of the window focused. How can I freeze
the WindowList so i could choose any process?

Another question: how can I customize (eg: desktop #) the text of each
process in windowlist?

TIA and sorry for my english

-- 
Eduardo Gargiulo
ejg @ ar.homelinux.org
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 23 May 2002 21:11:31 +0000

> the WindowList so i could choose any process?

I assume you press Alt-F4 not F4 and WindowList disappears when you
release Alt. Add SelectOnRelease option with no parameter.

  Key F4 A M WindowList Root c c NoDeskSort, SelectOnRelease

> Another question: how can I customize (eg: desktop #) the text of each

I am not sure what do you mean here. There are several options that affect
the menu item format and several options that affect the sorting. Try:

  WindowList Geometry
  WindowList NoGeometry
  WindowList NoGeometryWithInfo
  WindowList NoDeskNum, NoNumInDeskTitle
  WindowList NoCurrentDeskTitle, TitleForAllDesks

The options in the last two lines are only available in 2.5.x.
Please contact the man page for the description of WindowList options.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 23 May 2002 11:49:35 +0200

> the WindowList so i could choose any process?

It's hard to say why this is happening without your config.  Can
you send the lines that are responsible for said behaviour, please?
Anyway,

  Key F4 A N WindowList

should do the trick.

> Another question: how can I customize (eg: desktop #) the text of each

There are some options that modify the displayed string, e.g.
NoGeometry, NoGeometryWithInfo, NoDeskNum, NoNumInDeskTitle,
NoCurrentDeskTitle.

For example, use

  WindowList NoGeometry

to get the bare list of window names without any additional
information.  For more details, take a look at the man page.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].