Subject: RE: FVWM: Module.pm to write module in perl.. documentation?

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Sat, 25 May 2002 18:09:32 +0200

HI

I managed to convert my setup script to a Perl based
fvwm module, and it works great. Popup menus that have
dynamically added entries in them, now pup up much faster.

At first I used the module to do the entire configuration 
of fvwm, but this turned out to be much slower than reading
the commands from a file. So now I only use the module for 
on-the-fly changes of single components, like the color scheme.
The first time fvwm starts up, I write all commands to a file
and read that.

best regards

jos

-----Original Message-----
From: Mikhael Goikhman
To: Riswick, J.G.A. van
Cc: FVWM
Sent: 5/24/2002 10:11 PM
Subject: Re: FVWM: Module.pm to write module in perl.. documentation?

On 24 May 2002 01:36:45 +0200, Riswick, J.G.A. van wrote:
> 
> In my fvwm setup I use a perl script that interacts with fvwm
> using FvwmCommand. For instance, when the root menu pops up, 
> I use a perl script to insert some items dynamically, like an 
> entry 'Close connection' that kills wvdial when it is running. Now, 
> sometimes, especially when a lot of applications are running,
> this makes popping up the root menu rather slow. 
> 
> So I was wondering if it is any faster when I'd convert 
> the perl script into a fvwm module. 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 May 2002 17:24:59 +0000

On 25 May 2002 18:09:32 +0200, Riswick, J.G.A. van wrote:
> the commands from a file.

Yes, Read command is much faster (especially if there are thousand of
Style lines) than doing the same by sending one command after another,
because it does many updates only at the end unless there is UpdateStyles
command in the middle.

For such task it is better to use "FvwmPerl --preprocess fvwmrc.ppp" (when
I finish it) that will work just like FvwmCpp or FvwmM4, but embed perl.

Another solutions would be to use your module to write to a file and then
send one Read command. Or create a function from all these commands by
prepending "+ I " and then send a command to execute that function.
I didn't test this, but this should be much faster than sending thousand
commands as is.

> So now I only use the module for 

Regards,
Mikhael.