Subject: FVWM: alt-tab windowlist weirdness?

From: Denis Perelyubskiy <[email-masked]>
Date: Tue, 21 May 2002 17:25:29 -0700

Hello,

I am trying to get the fvwm2.4.6 do the alt-tab windowlist
thing, but I only want the "Current Page" windows to show
up.

I should say that the following line does what I want, with
a mouse-button:

   Mouse 3   R  A  WindowList [CurrentPage]

I've also tried the following, but it did not work for me:

   Key Tab   A    CMS  WindowList [CurrentPage]

this showed _all_ windows, not only the ones on the desk

So then, I went ahead, and removed Tab line from the key
mapping section, and it still works :( ? ... 

So, the question is 
a) Is there some sort of build-in Alt-Tab Windowlist
functionality?
b) How to make fvwm show only CurrentPage hits when pressing
alt-tab?

I know it either works on my laptop (can't check now), or
used to work on this machine, so I think I am missing
something simple.

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 21 May 2002 20:59:09 -0400

> a) Is there some sort of build-in Alt-Tab Windowlist

Yes, its described in the man page under
"BUILT IN KEY AND MOUSE BINDINGS".

> b) How to make fvwm show only CurrentPage hits when pressing

The information in the man page should give you all the hints
you need.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 22 May 2002 11:47:44 +0000

> this showed _all_ windows, not only the ones on the desk

I can't reproduce this with 2.4.7 or 2.5.1. It works well.
Although a non-deprecated syntax is "WindowList (CurrentPage)".

> b) How to make fvwm show only CurrentPage hits when pressing

  Key Tab A M WindowList (CurrentPage) Root c c NoDeskSort

> used to work on this machine, so I think I am missing

Probably you have different configs on your machines.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 22 May 2002 14:07:37 +0200

> Although a non-deprecated syntax is "WindowList (CurrentPage)".

OT:

I added the new syntax a long time ago, mainly because the syntax
description in the man page looks odd:

  WindowList [[options]]

It's not clear that the inner [] is to be taken literally.  I've
no intention of ever removing the braces from the syntax.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].