Subject: FVWM: Imagepath problem

From: Salim RENANE <[email-masked]>
Date: Mon, 13 May 2002 14:04:55 +0200

Hi,

I'm a fvwm2 2.4.7 user and I'm using it under sunOS 2.5 (sparc ULTRA 10)
I want to use my pixmap set to add to buttons, but I can't
add the specific paths to force fvwm search in.
I tried to add the following line  in my .fvwm2rc

ImagePath oldpath:+:my_path:+

where oldpath is the path given when I run fvwm-config with
the -I option, and my_path is my personal pixmap path.
I dont know how fvwm did to specifie the initial Imagepath ???

As this doesn't work I tried to put the new path in the
fvwm-config itself in the line 

fvwm_imagepath = oldpath:my_path

but without success.

when starting or restarting fvwm2 I got this message in my console:

[FVWM][scanForPixmap]: <<WARNING>> Couldn't load image from Letters

If somebody can help me ??

Best Regards.

-- 
+------------------------------------------------------+
|        Salim RENANE    -   TIMA Trainee              |
+------------------------------------------------------+
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 13 May 2002 14:23:50 +0200

> If somebody can help me ??

Can you post your complete config file?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Salim RENANE <[email-masked]>
Date: Mon, 13 May 2002 14:53:09 +0200

Hi,
this is the config part of the fvwm-config file

################################################################################################################

prefix="/softs/fvwm2_4_7"
exec_prefix="${prefix}"
bindir="${exec_prefix}/bin"
datadir="${prefix}/share"
libexecdir="${exec_prefix}/libexec"
sysconfdir="${prefix}/etc"
mandir="${prefix}/man"

fvwm_moduledir="${libexecdir}/fvwm/2.4.7"
fvwm_datadir="${datadir}/fvwm"

#fvwm_imagepath="/usr/include/X11/bitmaps:/usr/include/X11/pixmaps" 
<--- removed the initial path and added the one below

fvwm_imagepath="/usr/include/X11/bitmaps:/softs/X11R6.3/include/X11/bitmaps:/softs/X11R6.3/include/X11/pixmaps"

fvwm_userdir='$HOME/.fvwm'
fvwm_exe='fvwm2'

with_gnomehints=yes
with_gtk=yes
with_gdkimlib=no
with_gnomelibs=no
with_multibyte=no
with_readline=yes
with_rplay=no
with_shape=yes
with_sm=yes
with_stroke=no
with_xinerama=no
with_xpm=no

################################################################################################################

Note that the initial path used by fvwm-config was

fvwm_imagepath="/usr/include/X11/bitmaps:/usr/include/X11/pixmaps"

And actualy the /usr/include/X11/pixmaps path doesn't existes, so why
did fvwm choose it ????

---

From: Salim RENANE <[email-masked]>
Date: Mon, 13 May 2002 17:30:55 +0200

Hi,
since my last e-mail I tried to do something with my problem.
The problem is not in the ImagePath commande itself since I could
specifie it, (Yes finally), but in the pixmaps.
My pixmap path is linked to my old (2.0.45) fvwm2 icons path.
When I try to put an *.xpm color file in a button that doesn't work
but when I put a monchrome icon (X11 bitmap) it works
in both buttons and menus.
Does the fvwm compilation failed or did I forgot somthing ??
Do I need an aditional library.
Jut wanna say that with my old version such line in .fvwm2rc
works without any problems.

*FvwmButtons - www.xpm Exec ""  netscape &

But in the 2.4.7 version it doesn't and without any error message.

Thanks for your help.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 13 May 2002 15:45:14 +0000

> fvwm_imagepath="/usr/include/X11/bitmaps:/softs/X11R6.3/include/X11/bitmaps:/softs/X11R6.3/include/X11/pixmaps"

Don't change fvwm-config, it is not used by the fvwm executable itself.

Instead, specify: ./configure --with-imagepath=/usr/include/X11/bitmaps:/softs/X11R6.3/include/X11/bitmaps:/softs/X11R6.3/include/X11/pixmaps

This path will then be built-in to both fvwm2 and fvwm-config.

> with_xpm=no

You should add xpm support. See INSTALL.fvwm and FAQ, there are Solaris
specific issues.

> And actualy the /usr/include/X11/pixmaps path doesn't existes, so why

This is a default, probably fvwm should try harder to set a good imagepath
default, but you may change it using ./configure anyway.

Regards,
Mikhael.