Subject: FVWM: FvwmWarf bevel

From: Salim RENANE <[email-masked]>
Date: Wed, 15 May 2002 19:28:48 +0200

Hi everybody,
Could someone tell me if it's possible
to change the bevel colors in FvwmWarf.
All what I can change is the background.
In the default drawig the buttons seem to
receive light from the upper left corner
and I would they seem to be lightened from
the right down corner.

I tried to use colorsets with "sh" and "hi"
but without success.

Thanks.
-- 
+------------------------------------------------------+
|        Salim RENANE    -   TIMA Trainee              |
+------------------------------------------------------+
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 15 May 2002 20:16:44 +0000

> I tried to use colorsets with "sh" and "hi"

We suggest to switch from FvwmWharf to FvwmButtons. FvwmWharf is basically
frozen, it works, but does not get new features like internationalization.

Still Colorset option works just fine in FvwmWharf, you may define
background using something like:

  FvwmTheme # run it if not yet
  *FvwmTheme: Colorset 50 HGradient 100 blue green, \
    bg rgb:B0/20/20, sh rgb:70/10/10, hi rgb:D0/40/40
  *FvwmWharf: Colorset 50

Or usually it is enough to just say "bg average", no "sh" and "hi" needed.
If you want to switch hi and sh, like you said, you may do this:

  *FvwmTheme: Colorset 50 SGradient 100 2 gray40 1 gray80 2 gray0, bg gray40
  *FvwmTheme: Colorset 50 shadow $[hilight.cs50], hilight $[shadow.cs50]

The first line creates "raised" relief, the second switches to "sunken".

Regards,
Mikhael.