Subject: FVWM: Strange interaction between fvwm and matlab

From: "Robert L. Knighten" <[email-masked]>
Date: Thu, 2 May 2002 16:45:34 -0700

I am encountering the following peculiar problem.  I use the "MiniButtons" and
use one of them to start Matlab using

*MiniButtons -   matlab32c_icon.xpm   Exec exec matlab

When I do this I have the unfortunate effect that using control-c at the
Matlab command line, which should stop the currently executing Matlab command,
kills the X server and all programs running under X.

If instead I use

*MiniButtons -   matlab32c_icon.xpm   Exec exec xterm -e matlab

everything works fine, except of course I have an extra xterm hanging around.

The same behavior occurs if I invoke matlab from a menu.

The people at Mathworks (home of Matlab) are trying to reproduce and then
understand this problem, but so far there has been no success.  Does this ring
a bell with any of you?

-- Bob

-- 
Robert L. Knighten
15580 S.W. Bridle Hills Drive
Beaverton, OR 97007
(503) 626-4965
[email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 3 May 2002 12:24:40 +0200

> The same behavior occurs if I invoke matlab from a menu.

Strange.  What fvwm version is this?  Does any of the programs
leave a core dump on the disk?

> understand this problem, but so far there has been no success.  Does this ring

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Robert L. Knighten" <[email-masked]>
Date: Fri, 3 May 2002 10:14:55 -0700

> leave a core dump on the disk?

Fvwm2 version 2.4.6.  No core files are created.  None of the log files show
anything odd.  Here are the messages from X:

XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
	If the server is older than 6-12 months, or if your card is
	newer than the above date, look for a newer version before
	reporting problems.  (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-1mdksmp i686 [ELF] 
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri May  3 10:08:34 2002
(==) Using config file: "/etc/X11/XF86Config-4"

waiting for X server to shut down Terminal:  fatal IO error 32 (Broken pipe) or KillClient on X server ":0.0"
X connection to :0.0 broken (explicit kill or server shutdown).
X connection to :0.0 broken (explicit kill or server shutdown).
X connection to :0.0 broken (explicit kill or server shutdown).
X connection to :0.0 broken (explicit kill or server shutdown).
Connection lost to X server `:0.0'
X connection to :0.0 broken (explicit kill or server shutdown).

As you can see the only thing odd is that the X connection is repeatedly
killed.  I have now found a problem with the use of control-c in Matlab when
it is started using a button in KDE, so I strongly suspect there is something
wrong in Matlab.

-- Bob

Robert L. Knighten

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 7 May 2002 12:08:57 +0200

On Fri, May 03, 2002 at 10:14:55AM -0700, Robert L. Knighten wrote:
> ...
> ...

That looks as if matlab does something that crashes the X server.
Should that be true, there may be a matlab bug involved, but it
definitely is an X server bug.  No matter what happens, the X
server must never crash (except when it runs out of resources).

Bye

Dominik ^_^  ^_^