Subject: Re: FVWM: X11 crashes with fvwm 2.4.6

From: Markus Grunwald <[email-masked]>
Date: Sat, 4 May 2002 13:34:17 +0200

Hi,

On Fri, 03 May 2002 12:09:08 -0400
Dan Espen <[email-masked]> wrote:

[...]
> > So I did that:
> > 
> > markus@Eddie: > gdb -core=./core
> > Core was generated by `/etc/alternatives/x-window-manager'.
> > Program terminated with signal 11, Segmentation fault.
> > #0  0x08065dc4 in ?? ()
> > (gdb) markus@Eddie: > l /etc/alternatives/x-window-manager
> > lrwxrwxrwx    1 root     root           14 23. Apr 16:42
> > /etc/alternatives/x-window-manager -> /usr/bin/fvwm2*
> > 
> > I'm sorry, this looks like fvwm, not XFree...
> 
> OK.
> 
> > So:
> > 
> > markus@Eddie: > gdb /etc/alternatives/x-window-manager ./core
> 
> It might be better to do:
> 
> gdb /usr/bin/fvwm2 ./core
I did that, with the same result :
> 
> > warning: core file may not match specified executable file.
> 
> This is a problem.  Did you recompile after you created the core file?
No, I didn't.

> > (gdb) where
> > #0  0x08065dc4 in XMapRaised ()
> > #1  0x00000000 in ?? ()
> 
> I think this isn't working because of he above issue with the
> core file not matching the executable.
That's strange. I have no Idea, why this could be so...
 
> You should ask questions on the FVWM list.  Theres lots of folks
> over there that want to help. :)
Damn... Sorry, I forgot to edit the adress...
Does anyone know, how to teach sylpheed to do that automatically ?

Nevertheless, I have a workaround: I disposed fvwm-2.4.6 and use 2.4.3.
No errors until now (two days)...

-- 
Markus Grunwald

Registered Linux User Nr 101577      
http://counter.li.org                http://www.grunwald.2xs.de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Markus Grunwald <[email-masked]>
Date: Sat, 4 May 2002 13:28:48 +0200

Hi !
Accidently replied to Dan, not to the mailinglist...

Begin forwarded message:

Hello,

I did nearly as you said. "Nearly", because my system doesn't know the
"whence" command, you mentioned. I suspect you meant "which" ?

So I did that:

markus@Eddie: > gdb -core=./core
GNU gdb 5.1.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are welcome to change it and/or distribute copies of it under certain
conditions. Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details. This GDB was configured as "i386-linux".
Core was generated by `/etc/alternatives/x-window-manager'.
Program terminated with signal 11, Segmentation fault.
#0  0x08065dc4 in ?? ()
(gdb) markus@Eddie: > l /etc/alternatives/x-window-manager
lrwxrwxrwx    1 root     root           14 23. Apr 16:42
/etc/alternatives/x-window-manager -> /usr/bin/fvwm2*

So:

markus@Eddie: > gdb /etc/alternatives/x-window-manager ./core
GNU gdb 5.1.1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are welcome to change it and/or distribute copies of it under certain
conditions. Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details. This GDB was configured as "i386-linux"...(no debugging symbols
found)...

warning: core file may not match specified executable file.
Core was generated by `/etc/alternatives/x-window-manager'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4...
(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libXpm.so.4
Reading symbols from /usr/lib/libstroke.so.0...(no debugging symbols
found)... done.
Loaded symbols for /usr/lib/libstroke.so.0
Reading symbols from /usr/X11R6/lib/libSM.so.6...
(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...
(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libXext.so.6...
(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...
(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /lib/libm.so.6...(no debugging symbols
found)...done. Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libc.so.6...(no debugging symbols
found)...done. Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols
found)...done. Loaded symbols for /lib/ld-linux.so.2
#0  0x08065dc4 in XMapRaised ()
(gdb) where
#0  0x08065dc4 in XMapRaised ()
#1  0x00000000 in ?? ()

Can you help me, please ?

-- 
Markus Grunwald