Subject: FVWM: Complicated window placement ;)

From: Andy Arbon <[email-masked]>
Date: Thu, 30 May 2002 21:25:50 +0100

Hello,

I use dual monitors with FVWM's SLS feature, and for the most part it 
works quite well.. however, I would like to tailor the window placement 
a bit but I have no idea if it's possible.

What I'd like is for the windows to be placed according to one of the 
normal placement schemes, but to be placed on the screen that contains 
the mouse pointer at the time the window pops up.

Is that possible? Probably not in big demand, so I'll understand if it's 
not, but I thought I'd ask. It would just relieve the minor irritation 
of launching something from a menu and then having to trek across the 
screen to retrieve it all the time :)

Cheers,

-- 
Andy

Real Men don't make backups. They upload it via ftp and let the world 
mirror it. -- Linus Torvalds

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: parv <[email-masked]>
Date: Thu, 30 May 2002 16:59:14 -0400

in message <[email-masked]>,
wrote Andy Arbon thusly...
>
> I use dual monitors with FVWM's SLS feature

i have no experience w/ dual monitors, but...

> What I'd like is for the windows to be placed according to one of
> the normal placement schemes, but to be placed on the screen that
> contains the mouse pointer at the time the window pops up.

...you could try various ManualPlacement* "Style" options.  after
finding about other kinds of placement, namely MinOverlap*Placement,
i now hate that style.

--

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 31 May 2002 11:24:24 +0200

> finding about other kinds of placement, namely MinOverlap*Placement,

Oops, I must have missed the original message.  Anyway, the right
way to achieve this is the StartsOnScreen style:

  Style * StartsOnScreen c

(c = current screen = screen with the pointer).  Put that line in
your .fvwm2rc file.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Gregg Dameron <[email-masked]>
Date: Fri, 31 May 2002 10:08:51 -0600

> (c = current screen = screen with the pointer).  Put that line in

The man page (2.4.7) speaks of this Style only in an Xinerama context.
Does it work for dual fvwm instances as well?

Gregg Dameron