Subject: FVWM: Codes used in <Key|Mouse> Bindingd

From: Felix Karpfen <[email-masked]>
Date: Fri, 3 May 2002 08:40:54 +1000

Below is the start of a quote from the fvwm2 man page.

BUILT IN KEY AND MOUSE BINDINGS
       The following commands are built-in to fvwm:

            Key Help R A Popup MenuFvwmRoot
            Key F1 R A Popup MenuFvwmRoot
            Key Tab A M WindowList Root c c NoDeskSort
            Key Escape A MC EscapeFunc
            Mouse 0 R N Menu MenuFvwmRoot
            Mouse 1 TS A FuncFvwmRaiseLowerX Move
            Mouse 1 F  A FuncFvwmRaiseLowerX Resize
            AddToFunc FuncFvwmRaiseLowerX I Raise
            + M $0
            + D Lower

Since I am attempting to understand one screen of the man page, before I
move on to the next (with an occasional resort to a search command), I
have so far failed in my attempt to locate the place where the codes:

R, A, M, N, TS, 0, 1, etc are defined.

Some of the meanings can readily be deduced from the subsequent
examples; others can not.  If a location exists where all the codes are
defined, what do I search for?

Felix Karpfen
-- 
Felix Karpfen
[email-masked]
Public Key 72FDF9DF (DH/DSA)

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 03 May 2002 19:09:31 -0400

> defined, what do I search for?

Those letters are arguments to the "Key" and "Mouse" commands.

The "Key" and "Mouse" commands are described under
"mouse, key and stroke bindings".

The R field in the Key and Mouse commands is the "context".
That's described in the Mouse command section.

              Context  describes  where
              the  binding  applies.   Valid contexts are 'R' for
              the root window...
-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].