Subject: FVWM: fvwm1 -> fvwm2

From: Jukka Lehti <[email-masked]>
Date: Mon, 27 May 2002 08:37:21 -0700 (PDT)

Hi,

I've finally decided to move from fvwm-1.24r to latest
fvwm2. I've already converted my config file
succesfully, but two minor problems remain. Could any
one help with these?

1) Keyboard accelerators F11 and F12 seem to "steal"
bindings from F1 and F2, respectively. I have in my
.fvwm2rc:

Key F1          A       M       RaiseLower
Key F2          A       M       Popup "Window Ops"
...
Key F11         A       M       Maximize 100 100
Key F12         A       M       Close

If I use Meta+F1, it maximizes the window! If F11 line
is commented out, Meta+F1 does RaiseLower. What's
going on here?

2) I have a menu containing few Popups:

AddToMenu "Utilities"
+              "Program Menu" Title
+              "xterm" Exec exec xterm &
+              "Mozilla" Exec exec mozilla &
+              "" Nop
+              "Applications" Popup Apps
+              "Utilities" Popup Utils
...

There seems to be short delay before a Popup is shown
when I move pointer there. How can I disable this
delay?

My system is RHL7.3.

PS. Is there any plans for fvwm3? If so, does it
understand my new fvwm2 config files?

Thanks in advance!

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 27 May 2002 17:49:12 +0200

> when I move pointer there. How can I disable this

Take a look at the MenuStyle command.  You prabably want something
like

  MenuStyle * PopupImmediately

There are a whole lot of options to the MenuStyle command that you
might want to check (all in the man page).

> understand my new fvwm2 config files?

Yes, there are plans for a major version 3 and no, if it is ever
released, the config file will be incompatible in large parts.  We
will provide a script to convert configs as usual, but my guess is
that it won't do a very good job.  All this is far into the
future, though (at least a year or two).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jukka Lehti <[email-masked]>
Date: Mon, 27 May 2002 09:13:15 -0700 (PDT)

> Take a look at the MenuStyle command.  You prabably
> want something like
> 

I've already tried that, no result. I have following
line in my config file:

MenuStyle Wheat DimGrey Black lucidasanstypewriter-12
Mwm PopupImmediately PopdownImmediately

(all in a single line). It doesn't help even if I use
MenuStyle "*" PopupImmediately separately.

One more question I noticed: in fvwm1 was options
StickyForeColor and StickyBackColor. How can I set
colors for Sticky windows in fvwm2?

> future, though (at least a year or two).

Ok, thanks for the info.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 27 May 2002 16:16:59 +0000

On 27 May 2002 08:37:21 -0700, Jukka Lehti wrote:
> fvwm2.

Does this mean fvwm version 2.4.6 that is shipped with RedHat 7.3?

> I've already converted my config file

What is the output of:

  % xmodmap -pk | grep 'F[12]'

Does it help if you put the binding lines for F11 + F12 before F1 + F2?

Regards,
Mikhael.

---

From: Jukka Lehti <[email-masked]>
Date: Mon, 27 May 2002 09:31:31 -0700 (PDT)

> Does this mean fvwm version 2.4.6 that is shipped

Yes:

root@home:~> rpm -q fvwm2
fvwm2-2.4.6-1

> Does it help if you put the binding lines for F11 +

A great idea, it worked! There seems to be for some
obscure reason definition for F1 and F11 in my F1-key,
but of course that's not fvwm related.

Thanks.

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 27 May 2002 19:14:21 +0200 (CEST)

> future, though (at least a year or two).

Hint: Wouldn't September 2003 be a good date? ;-)
(10 years anniversory of fvwm 1 announcement)

//Marcus

---

From: Ulrich Fahrenberg <[email-masked]>
Date: Mon, 27 May 2002 20:22:48 +0200 (MEST)

> +              "Utilities" Popup Utils

(Answering a question you didn't ask:) The & in your menu probably
don't cause any trouble, but they are unnecessary, as ``Exec exec''
already means that the shell is running the command in background and
exits immediately.

uli

-- 
Ulrich Fahrenberg -- http://www.math.auc.dk/~uli

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 27 May 2002 20:24:23 +0000

> already means that the shell is running the command in background and

The "&" is indead redudant here, but your explanation is not correct.
The only way to run something in the shell background is to specify "&".

Since this question is raised a lot, here is what actually happens.
Arrow actually means 2 operations: fork and exec in the forked process.

-----------------------------------------------------------------------
1) Exec xterm

  fvwm   ->   shell   ->   xterm
  pid=1       pid=2        pid=3

  Process table after 1 second: pid=1, pid=2, pid=3.

fvwm does not wait for shell, shell waits for xterm.
(Some shells like bash do optimizations here, automatically add "exec".)

-----------------------------------------------------------------------
2) Exec exec xterm

  fvwm   ->   shell  exec  xterm
  pid=1       pid=2        pid=2

  Process table after 1 second: pid=1, pid=2.

fvwm does not wait for shell, shell is replaced by xterm.

-----------------------------------------------------------------------
3) Exec xterm &

  fvwm   ->   shell   ->   shell   ->   xterm
  pid=1       pid=2        pid=3        pid=4

  Process table after 1 second: pid=1, pid=3, pid=4.

fvwm does not wait for shell, shell pid=2 forks because of "&" and
immediately exits. shell pid=3 waits for xterm.
(Many shells do optimizations here and behave just like in the case 4.)

-----------------------------------------------------------------------
4) Exec exec xterm &

  fvwm   ->   shell   ->   shell  exec  xterm
  pid=1       pid=2        pid=3        pid=3

  Process table after 1 second: pid=1, pid=3.

fvwm does not wait for shell, shell pid=2 forks because of "&" and
immediately exits. shell pid=3 is replaced by xterm.

You see, the most optimal is "Exec exec xterm".

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 28 May 2002 14:13:46 +0200

> (10 years anniversory of fvwm 1 announcement)

No way.  I'm happy if we get 2.6 out until then :-/

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 28 May 2002 14:15:22 +0200

> but of course that's not fvwm related.

It should work fine with 2.4.7 regardless of the order of the
binding commands.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 28 May 2002 14:23:57 +0200

> Mwm PopupImmediately PopdownImmediately

That's not a legal MenuStyle line.  You are mixing the old and the
new MenuStyle syntax.  Remove all your MenuStyle lines and try
this instead:

  MenuStyle * mwm, Font lucidasanstypewriter-12
  MenuStyle * Foreground Wheat, Background DimGrey, Greyed Black
  MenuStyle * PopupImmediately, PopdownImmediately

It's important to issue the mwm style first because it resets most
of the other options, including PopupImmediately.

> colors for Sticky windows in fvwm2?

They were removed for some reason in fvwm2.  I don't know exactly
why.  One day the functionality will come back, but right now you
can't do anything about it.

Bye

Dominik ^_^  ^_^

---

From: Jukka Lehti <[email-masked]>
Date: Tue, 28 May 2002 07:08:02 -0700 (PDT)

> of the other options, including PopupImmediately.

Thanks a lot, it worked!
 
> can't do anything about it.

Ok, I made a "workaround" (usually my only Sticky
window is xload so it set colors for it), so don't
worry.

Excellent, I've now ready to finally move from fvwm1
to fvwm2. It took quite a long, but finally it
happened :) Cheers!

---

From: Thomas Adam <[email-masked]>
Date: Wed, 29 May 2002 13:01:09 +0100 (BST)

[..much elided..]

> > > future, though (at least a year or two).

I wouldn't mind seeing some sort of graphical
customisation tool. Unfortunately the dot-file
generator doesn't really cover enough of the features
that fvwm2 has to offer. 

If fvwm3 were to be released for a date in the future,
Dominik, would you consider some kind of "graphical"
customisation tool, similar to what Enlightenment
offers???

> > (10 years anniversory of fvwm 1 announcement)

Err...to be truthful, I am already amazed at the rate
of development that takes place on Fvwm2, especially
for a volenterr effort.
 
> No way.  I'm happy if we get 2.6 out until then :-/

hear hear.

-- Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 May 2002 14:34:42 +0200

> customisation tool, similar to what Enlightenment

Unfortunately, that's not really a matter of consideration.  We're
simply too few developers, and the few that do most of the work
don't feel inclined to do it.  In my eyes, a nice and powerful
config tool ist the most important improvement we could make.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 May 2002 14:42:16 +0200

On Wed, May 29, 2002 at 02:34:42PM +0200, fvwm wrote:
> Unfortunately, that's not really a matter of consideration.

Um, I want to say that we do consider it, but that it lacks the
people to do it.

Bye

Dominik ^_^  ^_^

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 29 May 2002 14:47:30 +0200 (CEST)

> config tool ist the most important improvement we could make.

And this should be feasable to do with FvwmScript, so somebodyu who wants
to do it could, I guess..

And I'm doing a config that's customisable using menues. I plan to write
to forms to edit colours and so on.
But this will not be a complete cutomisation tool, only those thing *I*
want to be able to change in run-time =)

//Marcus

---

From: [email-masked]
Date: Wed, 29 May 2002 08:56:06 -0400 (EDT)

> config tool ist the most important improvement we could make.

I had started working on something that used tcl/tk to do
customizations, along with an "apply" and "restore" options to allow
users to get out of trouble as part of tkgoodstuff.  However, the
extremely long lag time between fvwm2.3 "feature freeze" and 2.4 made
that project fall by the wayside.  However, if anybody would like my
design details (how the applet would work), I still have all those
things.  (What I had in mind was a LOT more useful than the dotfile
generator I had seen in the past, supporting user-defined functions,
etc.)

I might even take on the job once again, but right now, volunteer work
for Destination Imagination and other work has my spare time occupied.

-- 
Larry Gensch                                          [email-masked]

            Working for COMPAQ for over a fourteenth of a century

---

From: Alex Wallis <[email-masked]>
Date: Thu, 30 May 2002 00:41:37 +0930

> want to be able to change in run-time =)

I know I get mostly ignored on these lists, but I've proven that Dan's
nicely modified FvwmForm can save configs and I had a set of forms to
configure EVERY option for fvwm half-built before the fvwm-themes
project even got started. However I recieved zero interest in it from
anybody so I dropped the project since I lacked the skills to do it
properly, and didn't get any feedback at all except some polite comments
from Dan.

Sure FvwmScript is probably a better tool for this, but FvwmForm is a
lot easier. Maybe if anyone was interested, I could dig up my old forms
or start afresh. I've been meaning to try and devise a set of forms for
fvwm-themes configs actually. Or even use FvwmGtk for this, but that
module lacks the read option of FvwmForm.

Alex

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 May 2002 15:34:27 +0000

On 30 May 2002 00:41:37 +0930, Alex Wallis wrote:
> 
> I know I get mostly ignored on these lists

Alex, I don't think you are ignored. Please don't feel like this.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 29 May 2002 15:50:54 +0000

> > > customisation tool, similar to what Enlightenment

There were tries to add such tool into FVWM, but not very successfull.
Try for example to run a nice small "FvwmScript FvwmScript-BaseConfig".
Maybe this is because no many FVWM users need such tool? I think the
real reason is that any graphic tool is very limited by its definition.

Either this tool will be dumbed down to some predefined configurations
having users a feeling that FVWM is not configurable, or it will be very
complex and include dozens of screens with dozens of options each.
And this is very optimistic, it may easily include thousands of screens,
with hundrens of options each.

Just think about this. Some statistics about FVWM. We have as of now:

  * 166 commands (and the number grows)
  * 199 Style options (and the number grows)
  * 54 MenuStyle options
  * a lot of TitleStyle/ButtonStyle/BorderStyle options
  * 33 window circulation options
  * 37 WindowList options
  * each Colorset has 23 options (probably 30+ in 2.6.x)
  * 28 modules, some are very configurable with dozens of options each
  * 13 menu placement hints, 7 bug-options, 24 cursor contexts
  * 26 binding contexts, 2^8 modifiers and so on

Now, consider a user configuration that includes dozens of global feel
lines (Style *), many individual Style patterns, several MenuStyle
patterns, dozens of colorsets, dozens of fonts, dozens of menus, dozens
of functions, dozens of keyboard, mouse and stroke bindings. Window
decorations is another endless story. Now, modules. Even if a user is
limited to one FvwmButtons with one FvwmIconMan and FvwmPager swallowed
and several other applications swallowed, there are still millions of
combinations to create such FvwmButtons panel.

So everyone should choose what he wants, a full control or simplified
graphical tool with predefined configurations. You can't do everything
with graphical tools only.

Saying all this, we do have graphical tools in fvwm-themes for defining a
full global feel, settings like animation/sound-player/gnome/kde, a menu
editor and (started) bindings editor. Is this something that Thomas Adam
originally asked for? What do you miss in fvwm-themes, except that it is
not integrated directly into fvwm (which is a plus)?

> to do it could, I guess..

I believe that such tool should be written as a module using Perl/Gtk.
As much as I like FvwmScript, its scripting ability is far down to the
perl scripting, and its widget functionality is not as good as GTK+.

> want to be able to change in run-time =)

Exactly. Someone should limit his graphical tool to some predefined
hardcoded configuration just to make such graphical tool possible at all.

For example, I write a completely new module (it will be available in
fvwm-themes) that enables persistent dynamical configuration of a panel
using menus. This module is useless in other themes that don't have such
panel. Every theme has its own configuration.

No graphical tool enables a full customization, some manual configuration
or even programming is always needed to create something good and new.

Anyway, if some programmer wants to seriously work (many months) on a
generic graphical tool, he should contact me and Olivier first to discuss
the design of such tool, we have some experience in doing this.

Regards,
Mikhael.

---

From: Erik Steffl <[email-masked]>
Date: Wed, 29 May 2002 09:39:25 -0700

Mikhael Goikhman wrote:
...
> combinations to create such FvwmButtons panel.

  and user defined functions - how would one add functions in gui tool?
and make gui tool aware of them? the tool would have to be something
like delphi/c++builder/visual basic programming environment. not
impossible but it would be a BIG project...

	erik

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 May 2002 20:07:27 -0400

Mikhael Goikhman <[email-masked]> writes:
> There were tries to add such tool into FVWM, but not very successful.
> Maybe this is because not many FVWM users need such tool? I think the

I agree that FVWM should always expect vi (or Emacs) to
be the configuration tool of choice.  There are so many things a
gui can't anticipate.

I guess I should have known about "FvwmScript FvwmScript-BaseConfig",
maybe I've seen it before but I forgot about it.  I'll have
to add it to my menus.
Maybe we should do more work on the FVWM built-in menu.
(Like add this tool to it.)

FVWM does have some GUI configuration already, its just
not very visible.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 30 May 2002 12:33:32 +0000

> Mikhael Goikhman <[email-masked]> writes:
[...]
> (Like add this tool to it.)

FvwmScript-BaseConfig by itself is not very useful, it should be
integrated somewhere. It is integrated into the Setup95 that we have
in the default menu. Setup95 is a good start for new to FVWM users,
it has some elements of fvwm-themes, but in a very stripped form.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 31 May 2002 11:18:36 +0200

> properly, and didn't get any feedback at all except some polite comments

No, you are not ignored.  It's just that we really need somebody
who manages that project.  I have virtually no time for that and I
gues it's the same with Mikhael and Olivier.  I would take part in
any discussion that someone else brings up, but I'm unable to
start it myself.

Bye

Dominik ^_^  ^_^