Subject: FVWM: Click-Hold & trackpad

From: Victor Eijkhout <[email-masked]>
Date: Wed, 15 May 2002 11:21:12 -0400

I have an Apple TiBook, and have set the trackpad to be used for 
clicks and drags. This means that a click-hold is a tap followed by a 
tap--and--hold-down--then--drag.

Problem is that if the tap-drag comes too quickly after the first 
tap, nothing happens (well, the title bar that I click in gets 
pressed). A click-hold just as fast with Aqua windows works as it 
should.

Double clicks work fine: I use

Mouse 0 T N MoveOrRaiseOrShade
AddToFunc MoveOrRaiseOrShade
+ C Raise
+ H Move
+ D WindowShade

Any idea how I can shorten this needed delay?

Oh, other question: DoubleClickTime is only listed as a menustyle 
option in the man page. Can I use it as a stand-alone command?

-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 15 May 2002 15:54:58 +0000

+ M Move

> option in the man page. Can I use it as a stand-alone command?

A double click delay for mouse bindings is the same as a single click
delay and controlled using the ClickTime command.

Regards,
Mikhael.

---

From: Victor Eijkhout <[email-masked]>
Date: Wed, 15 May 2002 14:10:44 -0400

>AddToFunc MoveOrRaiseOrShade

Interesting. That works, and is actually conceptually better. So what 
would be a legit application for click-hold?
-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 15 May 2002 20:50:41 +0000

> would be a legit application for click-hold?

Granted, usually you should just duplicate "H" and "M" lines, but you may
for example give different Maximize parameters on them. Another usage is
to do something on click and cancel the click action by specifying Nop on
"M" or/and "H". I.e. if you clicked by a mistake, you may just hold the
button or drag it to cancel the action.

  DestroyFunc MyMaximize
  AddToFunc   MyMaximize
  + M Nop
  + H Maximize 0 95   
  + C Maximize 100 95
  + D Maximize 100 100

  DestroyFunc MyMoveOrDeleteOrDestroy
  AddToFunc   MyMoveOrDeleteOrDestroy
  + M Move
  + H Nop    
  + C Delete 
  + D Destroy

Also, you get a different feel on all these cases ("D" is like "C"):

  "M" specified
  "H" specified
  "C" specified
  "M" and "C" specified
  "H" and "C" specified
  "M" and "H" specified
  "M", "H" and "C" specified

Regards,
Mikhael.