Subject: FVWM: Startup

From: Stephen Dennison <[email-masked]>
Date: Thu, 16 May 2002 16:02:29 -0400 (EDT)

When fvwm starts up, I can see the background being set, I see the
applications start up for the pager, and then they are swallowed by the
pager and somewhere along the way the banner pops up just before Fvwm is
done loading.

Is there some sort of support in fvwm to show a splash screen, wait for
fvwm to finish starting up, and then display the desktop?  (Would
FvwmBanner do something like this for me without using too large of an
image?)  This would hide the background stuff and make the startup look
better on my system.

--s.r.d.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephen Dennison <[email-masked]>
Date: Mon, 20 May 2002 00:18:07 -0400 (EDT)

Is there really no one on the list who can help me?

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 20 May 2002 08:37:53 +0200 (CEST)

> > image?)  This would hide the background stuff and make the startup look

I think you can use FvwmBanner to do this
In InitFunction (or StartFunction if you want to show this for restarts
also).

AddToFunc InitFunction I Module FvwmBanner
....	# some other initialisation here...
+	I	KillModule FvwmBanner

Then you need to configure FvwmBanner to show a fullscreen picture and
have a longer time out than the default 3 seconds.

*FvwmBanner: Pixmap	<your pixmap>
*FvwmBanner: TimeOut	10	# wait for 10 s (replace 10 if too short)
*FvwmBanner: NoDecor		# turn off window decorations

---

From: Dan Espen <[email-masked]>
Date: Mon, 20 May 2002 09:07:48 -0400

> *FvwmBanner: NoDecor		# turn off window decorations

That gets close, but doesn't really do all the things
Stephen asked for.

To suppress the desktop,
there used to be a -blackout commmand line option that
just blacked out the display during startup, but that was
removed.  That didn't allow for a splash screen though.

FvwmEvent gets a message at "end_config_info" perhaps that
could be used instead of a timeout to remove the splash screen.

To hide the desktop, perhaps you could find a program that created
a full screen window and put that window in the top layer.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 May 2002 13:24:05 +0000

> pager and somewhere along the way the banner pops up just before Fvwm is

You probably mean applications swallowed by FvwmButtons, not a pager.
You may specify a geometry for such applications that is out of the
screen. Search for "-geometry" in the FvwmButtons man page.

> image?)  This would hide the background stuff and make the startup look

You may add such splash yourself if you want. Here is an idea for 2.4.x.
Add these lines as the first lines of your .fvwm2rc:

  Style MySplash NoTitle, NoHandles, BorderWidth 0, Layer 12
  Exec exec xeyes -name MySplash -fg rgb:88/77/55 -bg rgb:55/44/33 -outline rgb:aa/a0/80 -center rgb:ef/d8/90 +shape -g $[vp.width]x$[vp.height]+0+0

And these lines as the last lines of your .fvwm2rc:

  AddToFunc InitFunction I All (MySplash) Close
  AddToFunc RestartFunction I All (MySplash) Close

Regards,
Mikhael.