Subject: RE: FVWM: Graphical configuration tool for FVWM

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Fri, 31 May 2002 12:17:59 +0200

Mmm I'm looking forward to see this. Are
you using gtk-perl to do this? I'm thinking 
about writing a cde-like panel for my setup.
Although I'm not shure yet if I should write
such a panel from scratch, or, alternatively,
write an applet for the gnome panel that mimicks
the look of the cde panel. This way one can
inherit the functionality of the gnome panel. 

best regards

jos

-----Original Message-----
From: Mikhael Goikhman
Cc: FVWM
Sent: 5/29/2002 5:50 PM
Subject: FVWM: Graphical configuration tool for FVWM

For example, I write a completely new module (it will be available in
fvwm-themes) that enables persistent dynamical configuration of a panel
using menus. This module is useless in other themes that don't have such
panel. Every theme has its own configuration.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 31 May 2002 11:27:50 +0000

On 31 May 2002 12:17:59 +0200, Riswick, J.G.A. van wrote:
> Mmm I'm looking forward to see this.

It is in the fvwm-themes cvs. But it has a long way to go, first
FvwmButtons is going to be modified to be more dynamic (add button/
delete button/hide container without restarting FvwmButtons).

> Are you using gtk-perl to do this?

No, it uses FVWM menus and in the future FvwmGtk or FvwmForm for dialogs.

> I'm thinking 

The CDE panel included in fvwm-themes is pretty good. Two FvwmButtons
configs (small and large) are generated by a script, based on your work.

But if you want a gtk-based solution, why not to use xfce? It is a stand
alone gtk-based configurable CDE panel that may be used with FVWM.

Regards,
Mikhael.