Subject: FVWM: Xft font help for newbie

From: "Paul Redman" <[email-masked]>
Date: 26 May 2002 13:11:13 -0000

Tired with restrictions in other window managers I have settled into fvwm (a cvs version from last week).  I have managed to solve most of my configuration problems and created a pixmapped style, but the xft text mentioned in the change log is eluding me.  

I have searched the last couple of months of the mailing list, and done some extensive googling... but the only mention is in that change log.  It refers me to the man pages, but for some reason or other I do not have those on my system.  I have seen the ones for 2.4.7, but there is no font loading section in there.  

Any help would be greatly appreciated.  Thanks.  

Paul

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 26 May 2002 09:25:11 -0400

"Paul Redman" <[email-masked]> writes:
> Tired with restrictions in other window managers I have settled into fvwm (a 
> cvs version from last week).  I have managed to solve most of my configuratio
> n problems and created a pixmapped style, but the xft text mentioned in the c
> hange log is eluding me.  
> 
> I have searched the last couple of months of the mailing list, and done some 
> extensive googling... but the only mention is in that change log.  It refers 
> me to the man pages, but for some reason or other I do not have those on my s
> ystem.  I have seen the ones for 2.4.7, but there is no font loading section 
> in there.  
> 

If you are using FVWM from CVS, the file name for the man page
has changed from fvwm2.1 to fvwm.1.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 May 2002 13:36:55 +0000

> > Any help would be greatly appreciated.  Thanks.  

Are you sure you installed the cvs version as you said (make install)?
There is a FONT section in the man that describes Free Type font loading.

Try this line (such font names obviously do not work in 2.4.7):

  Style * Font "xft:Luxi Serif:Bold:pixelsize=14:minspace=true"

> has changed from fvwm2.1 to fvwm.1.

No, "man fvwm2" is equivalent to "man fvwm" unless $MANPATH has problems.

Regards,
Mikhael.