Subject: FVWM: FvwmPager window title question

From: Marcus Lundblad <[email-masked]>
Date: Sun, 19 May 2002 20:16:21 +0200 (CEST)

I run fvwm 2.5.1
My pager always has the window title "Desk 0", regardless of desk.
(the pager is stucky).
But the icon title changes depending on the desk.

Before the title was always "FvwmPager", but I like the idea to have the
title reflect the current desk.
Is this a behaviour that is changing in the beta version?

The relevant part of the config looks like this (generated by a script):

*FvwmPager: Font none
*FvwmPager: Geometry +0+0
*FvwmPager: DeskTopScale 24
*FvwmPager: DeskPixmap 0 /home/marcus/.fvwm/backdrops/0
*FvwmPager: DeskPixmap 1 /home/marcus/.fvwm/backdrops/1
*FvwmPager: DeskPixmap 2 /home/marcus/.fvwm/backdrops/2
*FvwmPager: DeskPixmap 3 /home/marcus/.fvwm/backdrops/3
*FvwmPager: NoDeskHilight
*FvwmPager: SmallFont 5x8
*FvwmPager: Balloons
*FvwmPager: BalloonFore black
*FvwmPager: BalloonBack rgb:ff/ff/9c

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 May 2002 19:12:21 +0000

> Is this a behaviour that is changing in the beta version?

This bahaviour was not changed in 2.5.x.

But you may have any title you want, even change it dynamically:

  DesktopName 0 "<0>"

> *FvwmPager: BalloonBack rgb:ff/ff/9c

This configuration does not affect FvwmPager labels.

I think you launch FvwmPager without arguments and it defaults to "0 0",
i.e. shows one Desk 0. Run it as "FvwmPager * *" instead if you want it
to show the current desk.

I once wanted to change the default to "* *", but Dominik argued some
folks may depend on the current default. Hmm, just tested, FvwmPager in
2.2.x does not have any default, it refuses to start without 2 arguments.
I think I will change the default to the everyone's benefit.

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Sun, 19 May 2002 21:19:55 +0200 (CEST)

> to show the current desk.

No, I launch it as "Module FvwmPager 0 3"
The pager has 4 desks.
I was just wondering why the icon name changes, but not the window title.

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 19 May 2002 19:37:29 +0000

> I was just wondering why the icon name changes, but not the window title.

This is a kind of bug, I will fix it.

Regards,
Mikhael.

---

From: "Robert L. Knighten" <[email-masked]>
Date: Sun, 19 May 2002 17:34:07 -0700

> But you may have any title you want, even change it dynamically:

 . . .

  > Mikhael.

The title on the pager is a minor thing that I have wanted to change, so I was
happy to see this.  But when I tried it I got an error that there is no such
function.  And quickly grepping around in the source I didn't find DesktopName
or any trivial variation.  Is that the right name?

-- Bob

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 May 2002 11:27:09 +0000

> The title on the pager is a minor thing that I have wanted to change, so
> I was happy to see this.  But when I tried it I got an error that there
> is no such function.  And quickly grepping around in the source I didn't
> find DesktopName or any trivial variation.  Is that the right name?

All user visible changes in FVWM are listed at this url:

  http://fvwm.org/generated/NEWS.html

As you may see, DesktopName was added in 2.5.0 (man fvwm).

You may change labels in 2.4.x or 2.2.x too, just not dynamically.
Search for Label option in the FvwmPager man page.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 May 2002 12:00:52 +0200

> This is a kind of bug, I will fix it.

I'll commit a patch soon.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].