Subject: FVWM: Style * MwmButtons

From: Marcus Lundblad <[email-masked]>
Date: Mon, 20 May 2002 21:30:45 +0200 (CEST)

Is there a way to get a window decor button that is tied to a menu to not
remain pressed in when the mouse button is released, althogh the menu is
still posted? (this is the way it behaves in mwm)
Maybe this should be implied by Style MWMButtons

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 May 2002 20:06:07 +0000

> Maybe this should be implied by Style MWMButtons

With 2.5.1 (only) replace the line:

  Mouse 1 1 A Menu WindowOps Delete

with:

  Mouse 1 1 A Schedule 0 Menu WindowOps Delete

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 20 May 2002 22:44:53 +0200 (CEST)

>   Mouse 1 1 A Schedule 0 Menu WindowOps Delete

Thank you.
But there are some problems with this.
The menu doesn't appear until the mouse button is released and when
selecting an entry in the menu it's operation are not directly applied to
the window in question, instead the pointer changes to a crosshair to
select a window for the operation > 
(This is using 2.5.1)

//Marcus

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 20 May 2002 21:43:00 +0000

> The menu doesn't appear until the mouse button is released and when

When a menu is activated, no buttons may be pressed/depressed.
So a menu button should be depressed either before a menu started or
after it is closed.

> select a window for the operation > 

I would suggest:

  Mouse 1 1 A Schedule 0 WindowId $w Menu WindowOps Delete

but this only makes Delete work, not a menu.
I think you can't run an arbitrary menu in a window context.

So currently what you want seems impossible to me. The behaviour where the
menu button is pressed on a menu popup is not bad, you may get used to it.
Also some people may like Popup instead of Menu (don't add Delete here):

  Mouse 1 1 A Popup WindowOps

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 20 May 2002 23:57:00 +0200 (CEST)

> Also some people may like Popup instead of Menu (don't add Delete here):

I tried using a function with different actions for click, hold and
double-click with som variations using Schedule, but I didn't get it to
work that way.
So I guess it's not possible.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 May 2002 12:39:19 +0200

> Maybe this should be implied by Style MWMButtons

You can reverse the button relief for that specific button when it
is pressed:

  buttonstyle 1 inactivedown (-- sunk)
  buttonstyle 1 activedown (-- sunk)

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].