Subject: FVWM: Shortcut at desktop

From: "Ripalda-Marin, Miguel-Angel" <[email-masked]>
Date: Mon, 29 Apr 2002 13:29:39 +0100

Hello,

I am trying to set a Shortcut in my desktop, to load an alternate keyboard
layout... I have tried with the following commands within my $HOME/.fvwm2rc,
but when I start X, it tells me that I cannot find any button. What am I
doing wrong? I'm with FVWM 2.5.5 on RH 7.2

ImagePath $HOME/.fvwm_icons

AddToFunc StartFunction "I" Module FvwmButtons
*FvwmButtons:Back black
*FvwmButtons:BoxSize smart
*FvwmButtons:Columns 2
*FvwmButtons:Font fixed
*FvwmButtons:Fore
*FvwmButtons:Frame 0
*FvwmButtons:Geometry +0+0
*FvwmButtons:Padding 2 2
*FvwmButtons:Pixmap none
*FvwmButtons:Rows 1
*FvwmButtons:(Title "Spanish layout",Icon bomb.xpm,Center,`Exec loadkeys
es`)
*FvwmButtons:(End)

Best regards,

Miguel Ángel Ripalda Marín
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Apr 2002 14:29:08 +0200

> *FvwmButtons:(Title "Spanish layout",Icon bomb.xpm,Center,`Exec loadkeys

....
*FvwmButtons:Fore white
                  ^^^^^
....
## specify either Rows or Columns 
#*FvwmButtons:Columns 2
*FvwmButtons:Rows 1
....
*FvwmButtons:(Title "Spanish layout",Icon bomb.xpm,Center,Action `Exec loadkeys es`)
                                                          ^^^^^^  
....
## Following line is only needed if you use containers
## *FvwmButtons:(End) 

Uwe
-- 
+--------------------------------------------------
| Uwe Pross 
| mail : mailto:[email-masked]
| www  : http://www.tu-chemnitz.de/~uwp
+--------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].