Subject: FVWM: fvwm2.4.6 freeze

From: Frank Liu <[email-masked]>
Date: Mon, 1 Apr 2002 22:42:31 +0000 (GMT)

fvwm2.4.6, xfree 4.2.0, qnx4.25

when I run fvwm2 from the xterm, the mouse pointer becomes busy,
and the only way to get out is "ctrl-alt-backspace" to get back console.

I enabled debug and see it is in an infinite loop waiting for events.
any ideas?

....
[FVWM][HandlePropertyNotify]: <<DEBUG>> Routine Entered
[FVWM][DispatchEvent]: <<DEBUG>> Leaving Routine
[FVWM][My_XNextEvent]: <<DEBUG>> Routine Entered
[FVWM][My_XNextEvent]: <<DEBUG>> taking care of queued up events & returning
(1)
[FVWM][DispatchEvent]: <<DEBUG>> Routine Entered
[FVWM][HandlePropertyNotify]: <<DEBUG>> Routine Entered
[FVWM][DispatchEvent]: <<DEBUG>> Leaving Routine
[FVWM][My_XNextEvent]: <<DEBUG>> Routine Entered
[FVWM][My_XNextEvent]: <<DEBUG>> waiting for module input/output
[FVWM][My_XNextEvent]: <<DEBUG>> waiting for module input/output
[FVWM][My_XNextEvent]: <<DEBUG>> waiting for module input/output
[FVWM][My_XNextEvent]: <<DEBUG>> waiting for module input/output
[FVWM][My_XNextEvent]: <<DEBUG>> waiting for module input/output
(this last line keeps flushing out, forever, until I ctrl-alt-backspace out
 of X).

Frank

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tom Alsberg <[email-masked]>
Date: Fri, 5 Apr 2002 21:50:56 +0300

Hi there, Frank.

> and the only way to get out is "ctrl-alt-backspace" to get back console.

Hmm... Does Ctrl+Alt+Escape a few times get you out of it?
Probably FVWM is waiting for some window to appear or something like
that...
Could you post your .fvwm2rc (and other files included or Read by it,
if any)? We might be able to help figure it out with it.

> (this last line keeps flushing out, forever, until I ctrl-alt-backspace out

  Best regards,
  -- Tom

-- 
  Tom Alsberg - certified insane, complete illiterate.
        e-mail: <[email-masked]>
	Homepage: http://www.cs.huji.ac.il/~alsbergt/
  * An idea is not responsible for the people who believe in it.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas R. Shannon" <[email-masked]>
Date: Fri, 5 Apr 2002 13:48:47 -0600

I didn't see this in the FAQ.  Is there a way to get fvwm2 to focus a
new window by default.  This is a particular problem for me with
GNUPlot where new windows are generated every time I make a new graph.

Thanks,
Tom S.
-- 
Quote of the Day for April 4, 2002
The man who reads nothing at all is better educated than the man who
reads nothing but newspapers.
            -- Thomas Jefferson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 5 Apr 2002 20:12:53 +0000

> GNUPlot where new windows are generated every time I make a new graph.

  Style * GrabFocus   # or: Style GNUPlot GrabFocus

Another (generic) solution is in the FAQ question 3.18.

Regards,
Mikhael.

---

From: Alexander Kotelnikov <[email-masked]>
Date: Sat, 06 Apr 2002 00:41:32 +0400

>>>>> On Fri, 5 Apr 2002 13:48:47 -0600
>>>>> "Thomas" == Thomas R Shannon <[email-masked]> wrote:
Thomas> 
Thomas> I didn't see this in the FAQ.  Is there a way to get fvwm2 to focus a
Thomas> new window by default.  This is a particular problem for me with
Thomas> GNUPlot where new windows are generated every time I make a new graph.

man fvwm:
GrabFocus causes a newly mapped window to grab the focus, while
GrabFocusOff turns this off.

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Frank Liu <[email-masked]>
Date: Tue, 9 Apr 2002 22:40:47 +0000 (GMT)

any thoughts on what further debugging/testing I can do to
find out the root cause?

thanks!
frank

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 9 Apr 2002 23:04:59 +0000

> any thoughts on what further debugging/testing I can do to

I think it was fixed on 2002-04-02 by Dominik.
Can you try the latest snapshot?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Apr 2002 11:48:05 +0200

> I think it was fixed on 2002-04-02 by Dominik.

No, that's was something I built into the development version.

> Can you try the latest snapshot?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Wed, 10 Apr 2002 13:13:55 +0200 (CEST)

--- Frank Liu <[email-masked]> a écrit : > 
> any thoughts on what further debugging/testing I can

if you have in fvwm2rc lines like this
+    "text"        Exec program
instead of
+       "text"     Exec exec program 
this could be the cause

Fvwm is waiting for a comand to finnish and it is
busy until that command finishes

Maybe you have a module which is waiting for some sort
of I/O. (FvwmEvent ?)
Posting your config will help

Bye
Calin

=====
--------------------------------------------
                         ,-----.
                       ," ^   ^ ",
                       |  @   @  |
             ----OOOO---------------OOOO----

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Apr 2002 11:56:47 +0000

> busy until that command finishes

No, this is not correct. Exec is always done in a forked process that is
not waited. Exec is asynchronous. PipeRead is synchronous.

"Exec" and "Exec exec" have exactly the same effect from the window
manager point of view. Some shells (say, GNU bash) even add "exec"
themselves if needed, so program is executed with no additional fork.
Other shells fork, so there are 2 processes, shell and program.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Apr 2002 12:04:28 +0000

> and the only way to get out is "ctrl-alt-backspace" to get back console.

I guess someone should port FVWM to QNX first.

> (this last line keeps flushing out, forever, until I ctrl-alt-backspace out

Here are my suggestions.

If you want to port, subscribe to fvwm-workers list.

Start with an empty fvwmrc file: fvwm2 -f no-fvwmrc

Debug libs/fvwmsignal.c functions. It seems that fvwmSelect (a wrapper
for select) does not work as expected on QNX, but I can only guess.

Regards,
Mikhael.

---

From: Frank Liu <[email-masked]>
Date: Wed, 10 Apr 2002 16:08:28 +0000 (GMT)

> Probably FVWM is waiting for some window to appear or something like

no help.

> if any)? We might be able to help figure it out with it.

I don't have a customized .fvwm2rc file. All I did was copying those
example RC files included in the source.

Frank

---

From: Frank Liu <[email-masked]>
Date: Wed, 10 Apr 2002 16:09:55 +0000 (GMT)

> Posting your config will help

As I mentioned in another email, I tried those examples that
are included in the source code, WITHOUT any modifications.
fvwm2 just won't come up.

Frank

---

From: Frank Liu <[email-masked]>
Date: Wed, 10 Apr 2002 19:09:35 +0000 (GMT)

> Start with an empty fvwmrc file: fvwm2 -f no-fvwmrc

I was doing that already and no help.

> for select) does not work as expected on QNX, but I can only guess.

thanks for the hint. I tracked down to the invalid fdwidth that is
passed to the fvwmSelect.
I then looked at the function GetFdWidth() in the libs/System.c
and fixed it by this:

--- System.c.orig       Sun Jan 23 07:06:33 2000
+++ System.c    Wed Apr 10 11:56:45 2002
@@ -26,6 +26,10 @@
 #endif
 #include <sys/stat.h>

+#if HAVE_SYS_SELECT_H
+#include <sys/select.h>
+#endif
+

 /*
 ** just in case...

The include of select.h brings in the FD_SETSIZE (on qnx, it is 32)
and now the "min" in the GetFdWidth actually works and I am getting
32 rather than 512 as the fdwidth.

Everything is working now.
Thanks!
Frank

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Apr 2002 19:25:22 +0000

> I then looked at the function GetFdWidth() in the libs/System.c

Ok, will be fixed in 2.4.7.

Regards,
Mikhael.

---

From: szonyi calin <[email-masked]>
Date: Thu, 11 Apr 2002 08:17:13 +0200 (CEST)

--- Mikhael Goikhman <[email-masked]> a écrit : >

>From my experience they are not similar.
I had problems in the past with this (Fvwm waiting
for the command to finish and having to kill X)

Maybe with newer versions of fvwm they are the same
but in older versions i am sure that you should
specify either
+        "Label"      Exec program &
or
+        "Label"      Exec exec program

Anyway, I haven't try 
+        "Label"      Exec program
from some time because I had a slow computer and
killing X wasn't a nice thing to do (on that old
 computer). :-)

Bye 
Calin

=====

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 11 Apr 2002 11:41:18 +0200

> Ok, will be fixed in 2.4.7.

Ah, great!  That's a good point to build the 2.4.7 release now,
right?  I need a volunteer to test the new release building
instructions in docs/DEVELOPER :-)

Bye

Dominik ^_^  ^_^

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 11 Apr 2002 11:25:36 +0000

> instructions in docs/DEVELOPER :-)

Do you mean we release 2.4.7 today when I finally got 2.4.6 rpms? :)

No problems, I will do this.

Regards,
Mikhael.

---

From: Uwe Pross <[email-masked]>
Date: Thu, 11 Apr 2002 13:27:57 +0200

> instructions in docs/DEVELOPER :-)

I followed the steps in docs/DEVELOPER. Seems to work:

....
===========================================
fvwm-2.4.7.tar.gz is ready for distribution
===========================================
gzip -dc fvwm-2.4.7.tar.gz | bzip2 -9 >fvwm-2.4.7.tar.bz2
fvwm-2.4.7.tar.bz2 - ready for distribution
===========================================

I recorded the whole building process und put the log file (about 200k) on
the web:

http://www-user.tu-chemnitz.de/~uwp/download/typescript_build_fvwm-2.4.7

Uwe
-- 
+--------------------------------------------------
| Uwe Pross 
| mail : mailto:[email-masked]
| www  : http://www.tu-chemnitz.de/~uwp
+--------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 11 Apr 2002 14:57:38 +0200

> I followed the steps in docs/DEVELOPER. Seems to work:

The instructions are clear enough so that a complete fvwm-release-
building newbie can build a stable release?  Great!  :-D

Well, we can't really use your tarballs because you didn't have
commit privileges in CVS to tag the sources and make the necessary
documentation changes.  But who knows, if you plan to work on fvwm
in the future there's no reason not to give you commit rights.

Bye

Dominik ^_^  ^_^

---

From: Uwe Pross <[email-masked]>
Date: Thu, 11 Apr 2002 15:16:34 +0200

> building newbie can build a stable release?  Great!  :-D

I think so.

> Well, we can't really use your tarballs ....

I have not put any tarballs on the web. It was just the output of the
building process.

I thought you looked just for somebody who checks out if the building
instructions are clear enought and if it is possible to do that on
another maschine.

No worries ;-)

Uwe