Subject: FVWM: Short keys problem

From: Denis Prost <[email-masked]>
Date: Sun, 21 Apr 2002 17:42:09 +0200

Hi all,

I'm using fvwm 2.4.6 on my Linux box.

Here's what I have in my config file :

---------------

Style * NoIcon

AddToFunc MyIconifyAll
+ I All (!sticky) Iconify true

key a A MS MyIconifyAll

--------------

When I press Alt+Shift+a, all my non sticky windows are iconified (i.e every 
window but my gnome panel), that's OK, but then, all my fvwm short keys do 
not work anymore (for example Alt+Tab does nothing). I've got to deiconify 
one window with my mouse on the gnome taskbar, and then the short keys are 
back again.

This is not a gnome specific problem, since it happens also with an fvwm 
IconManager instead of the gnome panel. 

Any idea about what's happening ?

Thanks,

Denis

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 22 Apr 2002 12:02:39 +0200

> Here's what I have in my config file :

What kind of keyboard shzortcuts do not work?  I believe,
something like this should still work:

  key f1 a m gotopage 0 0
  key f2 a m gotopage 1 0

Probably you have something like

  key tab a m next focus

As it is, next will happily select windows that are iconified and
don't have an icon and try to focus them.  This should work:

  key tab a m next (!iconic) focus

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Prost <[email-masked]>
Date: Tue, 23 Apr 2002 07:12:50 +0200

Hi Dominik,

Thanks for your answer. 

Le Lundi 22 Avril 2002 12:02, vous avez écrit :
> > When I press Alt+Shift+a, all my non sticky windows are iconified (i.e
> > every window but my gnome panel), that's OK, but then, all my fvwm short
> > keys do not work anymore (for example Alt+Tab does nothing). I've got to
> > deiconify one window with my mouse on the gnome taskbar, and then the
> > short keys are back again.
> >

I checked but all my short keys are broken, even some ones like :

key F2 A M Exec exec xfrun.

I investigated further and I noticed that, when I select "focus follow mouse" 
 instead of "click to focus" in the globalfeel GUI (maybe I should Have said 
that I'm using fvwm-themes), everything works fine. But I'd rather use the 
click to focus behaviour. Is there anything else I could try ?

Thanks,

Denis

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 23 Apr 2002 17:07:37 +0000

On 23 Apr 2002 07:12:50 +0200, Denis Prost wrote:
> > > When I press Alt+Shift+a, all my non sticky windows are iconified
> > > (i.e every window but my gnome panel), that's OK, but then, all my
> > > fvwm short keys do not work anymore (for example Alt+Tab does
> > > nothing). I've got to deiconify one window with my mouse on the
> > > gnome taskbar, and then the short keys are back again.
> > >
> > > This is not a gnome specific problem, since it happens also with an
> > > fvwm IconManager instead of the gnome panel.
> > >
> I investigated further and I noticed that, when I select "focus follow
> mouse" instead of "click to focus" in the globalfeel GUI (maybe I should
> Have said that I'm using fvwm-themes), everything works fine. But I'd
> rather use the click to focus behaviour. Is there anything else I could
> try ?

This is strange. I can't reproduce any problem like this with pre-2.5.1
or 2.4.7.

If you use fvwm-themes as you say, send me (not to the list this time),
the output of `fvwm-themes-config -e`, it is large.

And please explain the problem again.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Apr 2002 01:57:56 +0000

On 24 Apr 2002 06:53:34 +0200, Denis Prost wrote:
> 
> Hi Mikhael,
> 
> Thanks a lot for your help.
> 
> I send you 2 files :
> 
> 1) MouseFocus.output (works)
> 2) ClickToFocus.output  (does not work)
> 
> that are both outputs from "fvwm-themes-config -e" with the corresponding 
> focus behaviour set through the global feel GUI.
> 
> Here is the sequence I tried with both files :
> 
> 1) start "fvwm2 -f  <one of these files>"
> 2) open 2 gnome terminals through the root window shells submenu
> 3) Press Alt+Shift+a (iconifies both windows, empty screen)
> 4) Press Alt+F2 (supposed to start xfrun) :
>        - with MouseFocus.output, xfrun starts
>        - with ClickToFucus.output, nothing happens
> 
> Strangely, if I start at step 2) not two but only one gnome Terminal, Alt+F2
> works also with ClickToFocus.output.

> > the output of `fvwm-themes-config -e`, it is large.

I can reproduce this problem in 2.4.7 with the files you sent me.
But keyboard bindings don't disappear for me with the current pre-2.5.1.

I may try to minimize this 230Kb config file to several lines showing the
problem, but I would just suggest you to upgrade, even if we will never
know the problem source, only that it is fixed.

You may get the latest fvwm snapshot. fvwm-themes-0.6.0 should still work
well with it. Or wait for the soon to be released beta 2.5.1.

Please rereport if you ever see the problem again.

Regards,
Mikhael.