Subject: FVWM: Change from 2.2.5 to 2.5.x easy ?

From: Markus Grunwald <[email-masked]>
Date: Wed, 10 Apr 2002 18:24:59 +0200

Hi!

I saw in the list, that there is a version 2.5 of fvwm. Will my old
config files work with that one without lots of editing?

Thanks,
-- 
Markus Grunwald

Registered Linux User Nr 101577      
http://counter.li.org                http://www.grunwald.2xs.de
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 10 Apr 2002 18:39:02 +0000

> config files work with that one without lots of editing?

It is suggested to use the stable 2.4.6 version unless you badly need
some feature in the unstable branch.

Run fvwm24_convert script, it may do the convertion from 2.2.x for you.
In any case pay attention to warnings and error messages, they usually
say that the syntax is changed, contact the man page to see a new syntax.

There were no big syntax changes from 2.4.x to 2.5.x until now.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Fri, 12 Apr 2002 14:45:14 -0400

> config files work with that one without lots of editing?

If you are coming from 2.2.5, you should go to
the stable official release. Ie. 2.4.6.
There is a conversion script included
that will handle the differences.
I think its worth it.

The 2.5 branch is beta software, there are lots of great improvements,
but its occasionally unstable.  I use 2.5.x every day with only minor
problems, but I wouldn't install it for others to use.
No config file changes are needed to go from 2.4.x to 2.5.x.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].