Subject: FVWM: man page error

From: John Smith <[email-masked]>
Date: Tue, 2 Apr 2002 18:37:25 -0800

Hello again, I'm not 100% sure this is an error, but correct me if I'm wrong
about this.  Have a look in the FvwmTheme man page where it shows the example
on line 312 with the FvwmIconMan colorset configuration.

The lines go like this:

        *FvwmIconMan: *Colorset 6
        *FvwmIconMan: *FocusColorset 2
        *FvwmIconMan: *FocusAndSelectColorset 2
        *FvwmIconMan: *PlainColorset 6
        *FvwmIconMan: *SelectColorset 6
        *FvwmIconMan: *TitleColorset 6

Isn't it supposed to be like:

*FvwmIconMan*Colorset 6

[ and so on ]

I assume this since the FvwmIconMan man page specifically says the syntax is
like that.

Cya

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Apr 2002 11:43:17 +0200

> I assume this since the FvwmIconMan man page specifically says the syntax is

You're right. The syntax is either

  *FvwmIconMan: Colorset 6

or

  *FvwmIconMan*Colorset 6

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 3 Apr 2002 13:17:01 +0000

On 03 Apr 2002 11:43:17 +0200, Dominik Vogt wrote:
> > Hello again, I'm not 100% sure this is an error, but correct me if I'm
> > wrong about this.  Have a look in the FvwmTheme man page where it
> > shows the example on line 312 with the FvwmIconMan colorset
> > configuration.
> > 
> > The lines go like this:
> > 

Please also read the section "MODULE COMMANDS" in the main man page.
All 3 man pages (fvwm2, FvwmThemes, FvwmIconMan) are correct.

> > [ and so on ]
> > 
> > I assume this since the FvwmIconMan man page specifically says the
> > syntax is like that.
> 

The first example is not correct; _currently_ it should still be:

Because FvwmIconMan uses their own delimiters to separate id. We can't
simply strip leading stars without breaking backward compatibility.

Regards,
Mikhael.