Subject: FVWM: How to have a title bar without any text in it?

From: Francis Litterio <[email-masked]>
Date: Thu, 18 Apr 2002 11:37:47 -0400

First, kudos to the FVWM developers!  This is the coolest and most
powerful WM I've ever used.

I'm trying to configure FvwmButtons to have a title bar without the
title string in it.  I'm wondering if there's anything analagous to
NoButton but which makes FVWM omit the text from a window's title bar?

Thanks in advance.
--
Francis Litterio
[email-masked]
http://world.std.com/~franl/
PGP public keys available on keyservers.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 Apr 2002 12:05:49 -0400

> powerful WM I've ever used.

No argument from this quarter.

> NoButton but which makes FVWM omit the text from a window's title bar?

No, I don't see any obvious way to create a blank title.

I'd guess most people run FvwmButtons with no title at all:

Style FvwmButtons NoTitle

I suppose you could try using a very short name, maybe an underscore
or period, or setting the foreground and the background to the same
color, but I think you'll be happiest with NoTitle.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 18 Apr 2002 17:06:16 +0000

> NoButton but which makes FVWM omit the text from a window's title bar?

1) It was already suggested to setup the same bg and fg colors for
the FvwmButtons window only.

2) Or define invisible font for the FvwmButtons title.

3) Or use an alias name "_".

4) It is also possible to patch FvwmButtons.c:

-  myclasshints.res_name=safestrdup(MyName);
+  myclasshints.res_name="  ";

5) And finally, a trick that works, but don't tell anyone I suggested it,
it is more like a bug than a working solution. You _may_ have an alias
consisting of spaces only, say "  ", but many operations will not work on
such alias, like killing a module by alias name using KillModule, sending
module commands using SendToModule. Even DestroyModuleConfig does not work
on such alias. As well as a non-conflicting module syntax using a colon.

  *  Geometry 100x100-0+0
  *  (1x1, Swallow XClock `Exec xclock`)

  Style "  " Title, Sticky, CirculateSkip, WindowListSkip

  # start FvwmButtons using our "empty" alias
  FvwmButtons "  "

This trick works now, but it may stop working in the future. Maybe in the
future it will be possible to filter a title text, so no tricks needed.

Regards,
Mikhael.