Subject: RE: FVWM: Shortcut at desktop

From: "Ripalda-Marin, Miguel-Angel" <[email-masked]>
Date: Mon, 29 Apr 2002 15:23:23 +0100

I have included all the suggestions made by Uwe, and now my .fvwm2rc look
like this:

ImagePath $HOME/.fvwm_icons

AddToFunc StartFunction
+ "I" Module FvwmButtons
*FvwmButtons:Back black
*FvwmButtons:BoxSize smart
*FvwmButtons:Font fixed
*FvwmButtons:Fore white
*FvwmButtons:Frame 0
*FvwmButtons:Geometry +0+0
*FvwmButtons:Padding 2 2
*FvwmButtons:Pixmap none
*FvwmButtons:Rows 1
*FvwmButtons:(Title "Spanish layout",Icon bomb.xpm,Center,`Exec loadkeys
es`)

But it still keeps on saying the 'No buttons defined. Quitting'... I have
browsed the whole man page for FvwmButtons and cannot understand what's
missing.

Regards,

Miguel Ángel
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 29 Apr 2002 15:34:07 +0200 (CEST)

> browsed the whole man page for FvwmButtons and cannot understand what's

The last line should be:

*FvwmButtons:(Title "Spanish layout",Icon bomb.xpm,Center, Action `Exec
loadkeys es`)

(Note the keyword Action, defining the action the button performes.

//Marcus

---

From: Uwe Pross <[email-masked]>
Date: Mon, 29 Apr 2002 15:46:46 +0200

> browsed the whole man page for FvwmButtons and cannot understand what's

Are you sure, you are using the right module version and fvwm version?
I have tried the following (even without the Action keyword) and it works
with version 2.4.3. At least the button appears:

DestroyModuleConfig FvwmButtonsTest
*FvwmButtonsTest:Back black
*FvwmButtonsTest:BoxSize smart
*FvwmButtonsTest:Font fixed
*FvwmButtonsTest:Fore white
*FvwmButtonsTest:Frame 0
*FvwmButtonsTest:Geometry +0+0
*FvwmButtonsTest:Padding 2 2
*FvwmButtonsTest:Pixmap none
*FvwmButtonsTest:Rows 1
*FvwmButtonsTest:(Title "Spanish layout",Icon bomb.xpm,Center,`Exec loadkeys es`)
Module FvwmButtons FvwmButtonsTest
  
You can copy the previous lines in FvwmConsole. The button should
appear immediately.

Uwe
-- 
+--------------------------------------------------
| Uwe Pross 
| mail : mailto:[email-masked]
| www  : http://www.tu-chemnitz.de/~uwp
+--------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].