Subject: FVWM: Exec question

From: Victor Eijkhout <[email-masked]>
Date: Sat, 30 Mar 2002 11:42:16 -0500

What's the difference between
+ "Something" Exec program
and
+ "Something" Exec exec program
?

-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Suzanne Skinner" <[email-masked]>
Date: Sat, 30 Mar 2002 16:18:14 -0500

> + "Something" Exec exec program

Exec command
       Executes  command.  You should not use an ampersand
       '&' at the end of the command. You probably want to
       use  an  additional "exec" at the beginning of com-
       mand.  Without that, the shell that fvwm invokes to
       run your command stays until the command exits.  In
       effect, you'll have twice as many processes running
       as  you  need.   Note  that  some  shells are smart
       enough to avoid this, but it never hurts to include
       the "exec" anyway.

Suzanne

-- 
[email-masked] - http://www.igs.net/~tril/
"That's when it dawned on me that what I really disliked about procmail was the
recipe format. I didn't want to handle my mail with a collection of colons,
zeroes, and single-letter commands that made sendmail.cf look like a
Shakespearean sonnet."      -- Simon Cozens
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].