Subject: FVWM: Start+Maximize

From: hugo vanwoerkom <[email-masked]>
Date: Thu, 28 Mar 2002 04:49:16 -0800 (PST)

What's the way to start an application and have it be
maximized to screensize when started?

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Thu, 28 Mar 2002 17:14:37 -0700

> maximized to screensize when started?

DestroyFunc MaxStart
AddToFunc MaxStart
+ I Exec exec $*
+ I Wait $0
+ I Current ($0) Maximize

MaxStart rxvt

It's not perfect, It only works if the GrabFocus Style is used.
Mabey 'Current' needs to be replaced with a different Conditional 
command.

hmmm mabey:
DestroyFunc MaxStart
AddToFunc MaxStart
+ I Style $0 GrabFocus
+ I Exec exec $*
+ I Wait $0
+ I Current ($0) Maximize
+ I Style $0 GrabFocusOff

hth,
sa

---

From: szonyi calin <[email-masked]>
Date: Fri, 29 Mar 2002 08:18:09 +0100 (CET)

--- hugo vanwoerkom <[email-masked]> a
écrit : > What's the way to start an application and
have it
> be

Well that depends.
1. If it's a well written X application use
program-name -geometry XxY+0+0

X - the horizontal dimension of your screen in pixels
Y - the vertical dimension of your screen in pixels

example: i have a screen 640x480

xclock -geometry 640x480+0+0

2. If it's not a well written X application (some 
toolkits seem to forget that they are using X :-( )

depends of the application 

Maybe you can do something like

Style name-of-the-application Maximize

but i'm not sure.

Hope it helps

Bye 

Calin

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Mar 2002 12:17:28 +0000

> maximized to screensize when started?

You may use the solutions explained in the FAQ #3.18.

Regards,
Mikhael.