Subject: FVWM: FvwmAudio Issues... Please Advise

From: "Peter J. Milanese" <[email-masked]>
Date: Tue, 26 Mar 2002 21:32:57 -0500 (EST)

Greetings-

After recomiling kernels for about a day and a half, I now have sound on my SE440BX. I'd love to use the facilities within fvwm, but they're giving me problems. I'm running 2.4.6, and I included rplay support (although I'm using 'play').

Please Advise!!!!!

Pete

Here's my config Excerpt:

*FvwmAudioPlayCmd /usr/bin/play
*FvwmAudioDir /usr/share/sounds
*FvwmAudio startup startup3.wav
*FvwmAudio shutdown shutdown1.wav
#*FvwmAudio unknown cat-1.au
#*FvwmAudio destroy_window oh_my_god.au
*FvwmAudio iconify clong.au
*FvwmAudio deiconify wipe.au

#*FvwmAudio add_window    ??
#*FvwmAudio toggle_paging ??

#*FvwmAudioDelay 3

*FvwmAudio focus_change pop.wav
*FvwmAudio raise_window pop.wav
#*FvwmAudio lower_window goodmorning.au

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "S. Anderson" <[email-masked]>
Date: Thu, 28 Mar 2002 16:26:09 -0700

> After recomiling kernels for about a day and a half, I now have sound on my SE440BX. I'd love to use the facilities within fvwm, but they're giving me problems. I'm running 2.4.6, and I included rp…
...
man FvwmEvent
...
SYNOPSIS
       FvwmEvent  is  a more versatile replacement for FvwmAudio.

:-)

hth,
sa

---

From: Johannes Gajdosik <[email-masked]>
Date: Fri, 29 Mar 2002 11:45:43 +0100

Subject: Re: FVWM: FvwmAudio Issues... Please Advise
From: Johannes Gajdosik <[email-masked]>
To: "Peter J . Milanese" <[email-masked]>
Date: Fri, 29 Mar 2002 11:39:49 +0100

> After recomiling kernels for about a day and a half, I now have sound
> on my SE440BX. I'd love to use the facilities within fvwm, but they're
> giving me problems. I'm running 2.4.6, and I included rplay support
> (although I'm using 'play').
> 
> Please Advise!!!!!
> 
> Pete

Dear Pete!
I have also had a hard time configuring FvwmEvent,
chiefly because of the bad or missing documentation of
rplay/rplayd and FvwmEvent.
But by doing this you will get some sounds:

1)
Copy some .au files onto your harddisk, e.g:
# ls /usr/local/share/sounds/fvwm
clong.au  gong.au  pook.au  slide.au  wipe.au

2)
change into this very same directory and start rplayd
as user root:
# cd /usr/local/share/sounds/fvwm
# rplayd

3)
open another xterm and test with rplay:
# rplay clong.au
Now you should hear some sound.

4)
Edit your .fvwm2rc:
add some lines for starting FvwmEvent,
*FvwmEvent: Cmd builtin-rplay
*FvwmEvent: StartDelay 3
*FvwmEvent: iconify wipe.au
*FvwmEvent: deiconify slide.au
*FvwmEvent: add_window pook.au
*FvwmEvent: destroy_window clong.au
Restart fvwm2.
Now you should hear some sounds when
a window is opened or closed.

What I don't like about this are two things:
1) Since I start FvwmEvent fvwm2 takes a break of
about 15 seconds when it is (re)started.
During this time I can do nothing but wait.
2) rplay gives me haedache.
How is one supposed to specify the paths
where rplay finds the sound files?
Rplay plays the sound over the network, this is good.
Nevertheless it seems that rplayd needs access
to the soundfiles, this is very bad. Because one has
to install the sound files on the server side.

Yours, Johannes Gajdosik

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Mar 2002 11:26:00 +0000

> #*FvwmAudio lower_window goodmorning.au

It seems that FvwmAudio (that is a compatible mode in FvwmEvent) with a
non builtin-rplay player was always broken. In 2.2.x it didn't support
PlayCmd. In 2.4.x it supports it but in the way it does not really work.

I will fix this before 2.4.7, so your sample above works.
If you need this now, use FvwmEvent and "Cmd Exec" instead of "PlayCmd".

Probably esdplay works a bit smoother than play.

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Mar 2002 12:10:42 +0000

> During this time I can do nothing but wait.

This is not normal.  Do you see anything on the standard error, like
"[FVWM][PositiveWrite] <<ERROR>> Failed to read descriptor from FvwmEvent"

Can you write a minimal .fvwm2rc to reproduce this?

> to install the sound files on the server side.

I am not sure why it is bad to install sound files on the server side to
be accessible for everyone and configure the path in /etc/rplay/rplay.conf
or similar.

But it is possible to play the file that is on the client side, rplay
should see it (use absolute path if needed), rplayd should not see it.

Anyway it is not related to the window manager. :)

Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Mar 2002 16:12:14 +0000

Please reply to the list.

On 29 Mar 2002 14:07:11 +0100, Johannes Gajdosik wrote:
> 
> On 2002.03.29 13:10 Mikhael Goikhman wrote:
> I do not have a standard output. I start fvwm2 from gdm.

Try "man gdm" to see where is the standard output/error file.

> I will try.
> The idea is that X (and rplayd) run on many tiny machines (X-Terminals)
> and fvwm2 runs on a big host, which is used by many people.
> Then I can log into my account on the server from any of the
> tiny machines and have my working environment there.
> But alas! I will have to install my private sounds on any
> of the tiny machines! Whenever a new tiny terminal is installed
> I will have to install my private sound files on the new terminal!
> And again alas! Perhaps I am not the system administrator and not allowed
> to install any private files on the tiny machines!
> 
> Of course it is related to the windowmanager.
> Because I do not use rplay, but Cmd:buildin-rplay.
> And there is no possibility to tell the windowmanager
> where my private sound files are (on the client side).
> Or is there something like ~/.rplay ?
> I did not find anything like that.

Did you try to specify an absolute path? For 2.4.x it may be:

  *FvwmEvent: add_window $[HOME]/audio/waterfall.au

You should have this file on the machine where FvwmEvent is run. Having it
on the machine where rplayd is run may speed up things, but not needed.

I hope it works for you, because it works for me.

Regards,
Mikhael.

---

From: Johannes Gajdosik <[email-masked]>
Date: Fri, 29 Mar 2002 21:45:03 +0100

Subject: Re: FVWM: FvwmAudio Issues... Please Advise [rplay]
From: Johannes Gajdosik <[email-masked]>
To: Mikhael Goikhman <[email-masked]>
Date: Fri, 29 Mar 2002 21:42:17 +0100

> I hope it works for you, because it works for me.

It works also for me. I did not think about that.
Thank you!

Johannes Gajdosik

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 31 Mar 2002 14:11:27 +0200

>        FvwmEvent  is  a more versatile replacement for FvwmAudio.

Today, FvwmAudio is simply a shell script that calls FvwmEvent.
The old syntax works exactly as it did before.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].