Subject: Re: FVWM: ``Style "XMMS*" NoTitle'' breaks xmms main window position

From: Jerome Breviere <[email-masked]>
Date: Tue, 5 Mar 2002 23:10:55 +0100

I had the same problem some month ago when upgrading from 2.3.16 to 2.4.x.
I finally found out that 2.4.x came with new placement policy options.
Everything went back to normal with :

Style "XMMS*" 			UsePPosition

( i use : Style "*"  NoPPosition  in my general desktop entry)

Jerome

Mon, 18 Feb 2002 16:02:02 +0300
Alexander Kotelnikov <[email-masked]> écrivait:

> Historically I had line form subject in my .fvwm2rc and some
> months ago xmms started to behave bad to me: its main window is
> randomly placed on start instead of beng placed on saved
> coordinates. Removing NoTitle helps, but this is rather strange...
> -- 
> Alexander Kotelnikov
> Saint-Petersburg, Russia
> --

-------------------------------------------------
Jerome Breviere     -    [email-masked]
		Use Linux :-)
-------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Mar 2002 23:49:25 +0100

> Style "XMMS*" 			UsePPosition

The 'new' options are rather the old ones merged into a single
line of options (instead of the various combinations you could
have before).  Little new functionality was added.  Anyway, it is
definitely xmms that is or was doing funny things old versions
moved their own windows instead of providing the proper placement
hints to fvwm.  This circumvented the NoPPosition option.  Also,
xmms 1.24 moved the window to strange and random positions.  So in
the end, fvwm had nothing to do with the problem.  The xmms
ChangeLog sais something about having fixed placement of xmms
windows with a title under certain window managers (1.25).  I
tried the latest release and it behaves as it should.

> ( i use : Style "*"  NoPPosition  in my general desktop entry)

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jerome Breviere <[email-masked]>
Date: Sat, 9 Mar 2002 22:19:14 +0100

Tue, 5 Mar 2002 23:49:25 +0100
Dominik Vogt <[email-masked]> écrivait:

> > I had the same problem some month ago when upgrading from 2.3.16 to
2.4.x.> > I finally found out that 2.4.x came with new placement policy
> tried the latest release and it behaves as it should.

Mmmh, i've just complied xmms 1.27 and i've still the same problem. I have
to use "UsePPosition" to have main window with proper placement.
I must admit i have the same problem with freeamp (but it is ok with
gqmpeg). Maybe a problem with my fvwm config files ....

Jerome

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 10 Mar 2002 09:02:38 +0100

> gqmpeg). Maybe a problem with my fvwm config files ....

We may be talking about different problems.  To allow xmms to
place its windows at all, you need UsePPosition (because that
style was explicitly designed for that purpose).  But even with
UsePPosition xmms-1.24 does funny things with the window position
that xmms-1.27 does not.

Bye

Dominik ^_^  ^_^