Subject: FVWM: fvwm and SunRays.

From: Marcus Lundblad <[email-masked]>
Date: Tue, 12 Mar 2002 20:29:14 +0100 (CET)

Has more people than me experienced problems running fvwm on Sun's SunRay
thin clients?
Sometimes when loggin out, X seems frozen (thogh the pointer still moves).

This occured before using 2.0.46. I compiled 2.5.0 and thoght that this
problem would be gone. But now it occured again. It seems to be random.

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Keith Kaple <[email-masked]>
Date: Tue, 12 Mar 2002 14:42:38 -0500

I'm having no problem for about a year now, my sessions run like this:

starting:
login using failsafe mode
run fvwm in the naked xterm

exiting:
exit fvwm via the quit function
type exit in the naked xterm

my .xinitrc is just

#!/bin/sh
#
xterm

..been bulletproof for me...with the smart card too..

---

From: Marcus Lundblad <[email-masked]>
Date: Tue, 12 Mar 2002 20:48:59 +0100 (CET)

> type exit in the naked xterm

what version of Solaris are you running? We have Solaris 7.
Does it run .xinitrc when using failsafe?
Normally it ignores .xinitrc (or .xession etc.)
I start fvwm from .dtprofile

//Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Tue, 12 Mar 2002 20:57:01 +0100 (CET)

Also, no processes are left on the machine.
ps -A | grep fvwm2 gives nothing
and ps -A | grep wm gives only a few dtwm:s

Though ps -A | grep def shows some zombies.
but ps -u malu9369 | grep def shows they are not owned by me...

//Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 15 Mar 2002 18:00:37 +0100 (CET)

> run fvwm in the naked xterm

I tried this also.
> type exit in the naked xterm

But now at one time, when I quit fvwm, it went well and the terminal
(actaully a dtterm) was left undecorated. But when I exited the dtterm (by
exit in the shell) the screen went gray. (I now call this "The Gray Screen
of Death)..

So my conclusion is that it's only possible to use CDE on SunRays...

//Marcus

---

From: Keith Kaple <[email-masked]>
Date: Fri, 15 Mar 2002 12:23:14 -0500

Bummer, but I think if you get rid of .dtprofile and use .xinitrc with a lone xterm:

#!/bin/sh
xterm

it would work...

avoid backgrounding (xterm &)..

The grey screen is an indication that some process is keeping X active (is mouse still active?).

So it isn't an fvwm problem, just an X/login environment problem.

What do you have to do, power cycle the sunray?

Keith

---

From: Dan Espen <[email-masked]>
Date: Fri, 15 Mar 2002 12:53:01 -0500

> So my conclusion is that it's only possible to use CDE on SunRays...

I've never used one, but the FAQ has a proceedure for making FVWM
part of the CDE choices.  Perhaps that would work better?

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 15 Mar 2002 19:07:58 +0100 (CET)

> part of the CDE choices.  Perhaps that would work better?

Yep, it might, although I don't dare to ask our sysadmin... (I think he's
quite pissed at having to restart X-servers all the time... :-( )

//Marcus

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 15 Mar 2002 19:13:28 +0100 (CET)

> avoid backgrounding (xterm &)..
Yes, the only thing I did in the failsafe terminal was to run fvwm2
(without "&")
Then I minimised it and logged out as usual using the menu and ran exit at
the terminal.

> The grey screen is an indication that some process is keeping X active (is mouse still active?).

Yes, mouse is still active. If that's the case, it's none of my processes
(tried a ps -u, while logged on to the machine with ssh, only a bash...)
So this leaves the Xserver and perhaps some deamons..

> What do you have to do, power cycle the sunray?

Power cycle doesn't help.
Only root can restore it to a working state (AFAIK).

//Marcus