Subject: FVWM: Border colors

From: Fernando Herrero Carrón <[email-masked]>
Date: Tue, 5 Mar 2002 23:57:05 +0000

This is my first post to the list, so hello to everyone here :-)

I have managed to change the color of the border of windows when they have no focus with

Style "*"               Color Black/#a0a060

but this doesn't seem to change the color when they DO have the focus.

Any help, please?

Thanks,

Fernando Herrero Carrón
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Tue, 5 Mar 2002 15:12:29 -0800 (PST)

> but this doesn't seem to change the color when they DO have the focus.

    AddToDecor <decorname> HilightColor <foreground> <background>

together with

    Style "<pattern>" UseDecor <decorname>

is one way to do it.

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 5 Mar 2002 23:40:26 +0000

> but this doesn't seem to change the color when they DO have the focus.

Try the man page, it describes all available functionality.

  # colors of unfocused window
  Style "*" ForeColor   rgb:00/00/60, BackColor   rgb:80/80/78
  # colors of focused window
  Style "*" HilightFore rgb:00/00/90, HilightBack rgb:C0/C0/B4

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 01:58:51 +0100

>     Style "<pattern>" UseDecor <decorname>

Don't use decors for that.  Decors are at the very top of the list
of things that will be removed from fvwm if there ever is a
version 3.0.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Tue, 5 Mar 2002 17:04:30 -0800 (PST)

> of things that will be removed from fvwm if there ever is a

What would be the preferred method, usable in 2.2.4?

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Mar 2002 01:08:47 +0000

> What would be the preferred method, usable in 2.2.4?

http://www.hpc.uh.edu/fvwm/archive/0102/msg00096.html

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 02:15:13 +0100

> What would be the preferred method, usable in 2.2.4?

Simply use the HilightColor command outside any decors.  I think
the original question was how to set the hilight colours at all,
now how to set them differently for each window.  In 2.2.x you
still need decors to do this, but not in 2.4.x.

Bye

Dominik ^_^  ^_^