Subject: FVWM: FvwmForm, reset on source .fvwm2rc

From: Victor Eijkhout <[email-masked]>
Date: Thu, 14 Mar 2002 12:39:45 -0500

This is what I have (I'm just starting to play with this)

DestroyFunc NameThisDesk
AddToFunc NameThisDesk
+ "I" KillModule FvwmForm
+ "I" Module FvwmForm NameDesk
*NameDeskLine left
*NameDeskText "Name this desktop:"
*NameDeskLine expand
*NameDeskInput deskname 20 ""
*NameDeskButton quit "OK" ^M

Problem: after repeated re-sourcing of the rc file I now have a 
screen high stack of form inputs and OK buttons. How do I reset the 
definition of a form?

-- 
Victor Eijkhout <[email-masked]>
tel: 865 974 9308 (W), 865 673 6998 (H), 865 974 8296 (F)
http://www.cs.utk.edu/~eijkhout/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 14 Mar 2002 12:53:40 -0500

> screen high stack of form inputs and OK buttons. How do I reset the 

DestroyModuleConfig.

Using the new module command syntax:

DestroyFunc NameThisDesk
AddToFunc NameThisDesk
+ "I" KillModule FvwmForm
+ "I" Module FvwmForm NameDesk
DestroyModuleConfig  NameDesk: *
*NameDesk: Line left
*NameDesk: Text "Name this desktop:"
*NameDesk: Line expand
*NameDesk: Input deskname 20 ""
*NameDesk: Button quit "OK" ^M

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].