Subject: FVWM: Hide command

From: Marcus Lundblad <[email-masked]>
Date: Tue, 5 Mar 2002 23:51:08 +0100 (CET)

I have a suggestion for a new command:
Hide
This would hide a window. Yes I know it's possible to specify that certain
(or all) windows should not have an icon. But I got an idea to have an
option (in the root menu for example) to hide my pager, but still it could
be handy somtimes to be able to do a normal iconification.

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 02:05:05 +0100

> be handy somtimes to be able to do a normal iconification.

You can put windows on an unused desk to hide them: 

  MoveToDesk 0 -123456

and to show them again:

  MoveToDesk

Is that good enough?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Wed, 6 Mar 2002 15:33:18 +0100 (CET)

> You can put windows on an unused desk to hide them: 

Yes. That'll do.
I was thinking in the lines of using Style NoIcon / Style Icon, to turn
off/on icons
Something like ("pseudo code").
function Hide
	Style desired_window NoIcon
	Iconify desired_window true

function Unhide
	Style desired_window Icon
	Iconify desired_window false

but I didn't find a way to make this wok for arbitrary windows.
So, I think your solution is more than adequate.

Thanks!

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Mar 2002 22:24:44 +0000

> > You can put windows on an unused desk to hide them: 

Just remember that issuing this command crashes the gnome pager that is
swallowed in the gnome panel, it is crashed even on "MoveToDesk 0 50".
EWMH also says negative desktop numbers are not allowed, so there may be
more applications that stop working. Just tested - both GNOME panel and
kicker (KDE panel) crashed after "GotoDesk 0 -12".

> So, I think your solution is more than adequate.

There are 2 issues here. The first is styles for individual windows that
are still under the developement.

The second is that there is no opposite boolean style option for NoIcon.
I plan to add later new Style option HasIcon that is what you need here.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Mar 2002 10:20:01 +0100

> kicker (KDE panel) crashed after "GotoDesk 0 -12".

Yeah, I remember the discussion about negative desktop numbers on
the ewmh mailing list.  Nobody seemed to care about compatibility
with existing window managers.  Anyway, you can think of this as
being very large positive numbers, so dumping core is still a bug
in these applications.  If you like, report it to the GNOME/KDE
people.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].