Subject: FVWM: fvwm-2.4.6 Build Problem

From: Kenneth Jacker <[email-masked]>
Date: 14 Mar 2002 08:39:41 -0500

After untaring the 2.4.6 distribution on an Alpha running
DU/Tru64-v4.0D, I ran /configure/.  It stopped with the following error:

     checking for X... conftestdir: No such file or directory

Though I've successfully built and have been running fvwm-2.2 on my
Alpha for a *long* time, the more recent versions all have given me the
same error during /configure/.

Thanks for any ideas!

-- 
Prof Kenneth H Jacker       [email-masked]
Computer Science Dept       www.cs.appstate.edu/~khj
Appalachian State Univ
Boone, NC  28608  USA        
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 14 Mar 2002 14:47:47 +0000

> same error during /configure/.

There is the same X detection in 2.2.x and 2.4.x.

This code is generated by autoconf anyway, so we may only do a work around
if the problem is known.

The code is this:

  if mkdir conftestdir; then
    cd conftestdir

I guess (I don't have Tru64) that mkdir failed but still returned
successful 0 status. Then "cd" generates the error you see.
Do you have write permissions in the build directory?
Or mkdir on Tru64 does not return the error status when failed?

Please debug this problem, I don't think it is FVWM related.

Regards,
Mikhael.