Subject: FVWM: Hide Windows in FvwmPager

From: Uwe Pross <[email-masked]>
Date: Mon, 11 Mar 2002 09:19:59 +0100

Hi there,

Is there any way that certain windows are not shown in FvwmPager?

I would like to keep track of some files using aterm with tail -f. Using
the Styles Sticky, ClickToFocus, StaysOnBottom, HandleWidth 0,
BorderWith 0, WindowSkipList do exactly what I want, since I can use
copy and paste within this aterm which is not possible by using
root-tail.

I would prefer if those windows would not be displayed in FvwmPager. 
Can anybody help me to get this work?

(Currently I use fvwm2 version 2.4.3, maybe I have to upgrade)

Thanks in advance, Uwe

-- 
+--------------------------------------------------
| Uwe Pross 
| mail : mailto:[email-masked]
| www  : http://www.tu-chemnitz.de/~uwp
+--------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Mar 2002 08:37:38 +0000

> (Currently I use fvwm2 version 2.4.3, maybe I have to upgrade)

You may upgrade to 2.5.0 or some february's snapshot (the current week
snapshot is less recommended). Then use:

  *FvwmPager: UseSkipList

BTW, you may try NeverFocus for this window, so you don't lose focus
when pasting from it. You also want CirculateSkip if you use Next/Prev.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Mar 2002 10:38:27 +0100

On Mon, Mar 11, 2002 at 08:37:38AM +0000, Mikhael Goikhman wrote:
> You may upgrade to 2.5.0

> or some february's snapshot (the current week snapshot is less
> recommended).

It's not just "less recommended", it's completely broken in
certain respects.  I even played with the thought to commit the
totally screwed new frame layout code I wrote on the weekend.  I'd
not even consider this code "alpha" quality.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Uwe Pross <[email-masked]>
Date: Mon, 11 Mar 2002 11:09:32 +0100

> not even consider this code "alpha" quality.

So how about version 2.5.0  - how stable is this one? I am quite happy
with version 2.4.3 since it runs really stable. If I switch to version
2.5 do need to change a lot in the .fvwm2rc file or does it run with the
config file of version 2.4.x?

Uwe

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Mar 2002 11:39:53 +0100

On Mon, Mar 11, 2002 at 11:09:32AM +0100, Uwe Pross wrote:
> So how about version 2.5.0  - how stable is this one?

Very stable and with less bugs than 2.4.3.  I'm not sure about the
--enable-multibyte option, but if you don't use that it's
definitely safe.  The next few 2.5.x releases will be no more
than "develpoment" quality though.

> I am quite happy with version 2.4.3 since it runs really stable.
> If I switch to version 2.5 do need to change a lot in the
> .fvwm2rc file or does it run with the config file of version
> 2.4.x?

No changes are necessary.  Probably the whole 2.5.x branch will
not make syntax changes.

Bye

Dominik ^_^  ^_^