Subject: FVWM: config files from fvwm 2.2 to fvwm 2.4

From: [email-masked]
Date: Fri, 8 Mar 2002 21:10:29 -0500

Hi all, I just upgraded my Debian GNU/Linux system to 3.0 (from 2.2r3), 
using linux kernal 2.2.18 pre21 and X 3.3.6. In the upgrade, fvwm was 
upgraded from 2.2 to 2.4. My config files no longer work, as if they 
are not being read. How do I get my old config files to work? My config files 
are in ~/.fvwm/default-style.hook which is read in from /etc/X11/fvwm/system.fvwm2rc
I'm attaching both.

thanks!!!

xucaen

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 9 Mar 2002 19:20:37 +0000

> are in ~/.fvwm/default-style.hook which is read in from /etc/X11/fvwm/system.fvwm2rc

I understand that you posted a config not written by you, but I comment on
it anyway.

> DestroyDecor default-decor                                                      
> AddToDecor default-decor                                                        
> + HilightColor black orangered    

HilightColor command is obsoleted in 2.4.x and will be eventually removed.

> Style "default-style" HilightFore white
> Style "default-style" HilightBack steelblue
> 
> Style "default-style" UseDecor default-decor, Color Black/DarkGrey

Color is again obsoleted. HilightFore and HilightBack is a correct syntax.
But the resulting color for highlighted windows is not well defined (both
white on steelblue and black on orangered are specified in this config).

> Read /etc/X11/fvwm/default-style.hook Quiet
> #Read default-style.hook Quiet
> Read ~/.fvwm/default-style.hook Quiet

The commented out Read line is correct, the last one is not, because tilde
is not expanded in the Read. command So, please restore the commented out
line if you want to read default-style.hook file or write something like:
Read $[HOME]/.fvwm/default-style.hook Quiet

> Style "*" UseStyle default-style

[...]
> 
> DestroyFunc StartFunction
> AddToFunc StartFunction
> Read /etc/X11/fvwm/init-restart.hook Quiet
> Read init-restart.hook Quiet
> 
> DestroyFunc InitFunction
> AddToFunc InitFunction
> Read /etc/X11/fvwm/init.hook Quiet
> Read init.hook Quiet
> #Exec exec setup-background
> 
> DestroyFunc RestartFunction
> AddToFunc RestartFunction
> Read /etc/X11/fvwm/restart.hook Quiet
> Read restart.hook Quiet

This is a bug in a debian package. Here always all six files are included
on both start-up and restart. It should be:

  DestroyFunc StartFunction
  AddToFunc StartFunction  
  + I Read /etc/X11/fvwm/init-restart.hook Quiet
  + I Read init-restart.hook Quiet

  DestroyFunc InitFunction
  AddToFunc InitFunction  
  + I Read /etc/X11/fvwm/init.hook Quiet
  + I Read init.hook Quiet
  #+ I Exec exec setup-background

  DestroyFunc RestartFunction
  AddToFunc RestartFunction  
  + I Read /etc/X11/fvwm/restart.hook Quiet
  + I Read restart.hook Quiet

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].