Subject: FVWM: Borders around menus

From: Bob Vloon <[email-masked]>
Date: Wed, 6 Mar 2002 11:17:38 +0100

Hi all,

I was wondering: is it possible to draw flat borders around menus? I've
looked intensively into the docs, but it seems quite impossible ;)
What I want: I've "flat windows", and this requires (yeah) a flat
menu! So I got rid of the standard border, the 3D-look, but then,
well, the menus are quite borderless.
Am I overlooking something, and if not, could this be done in future
versions of Fvwm?
Next to that, I want to assign a color to the inner bevel myself, otherwise,
my windows sometimes get this "borderless look" also. With two colors, this
problem gets out of the way (being able to use different pixmaps for all the
four borders would help also =)

Regards,

  Bob
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 18:40:40 +0100

> four borders would help also =)

The menu border can be controlled with a colour set.  An example
from my configuration file (except the colours).

  MenuStyle * MenuColorset 3
  ...
  *FvwmThemeColorset 3 fg red, bg green, hi blue, sh yellow
  ...
  # run FvwmTheme before anything else is done
  ModuleSynchronous Timeout 5 FvwmTheme

Use the same shadow (sh) and hilight (hi) colours to get flat
menu borders.  Unfortunately, menu separators use the same
colours and look a bit blocky without the 3d effect.

For more details, read the FvwmTheme man page.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].