Subject: FVWM: TitleStyle gradient - convert to colorset?

From: Gregg Dameron <[email-masked]>
Date: Wed, 20 Mar 2002 12:58:48 -0700

Running 2.4.5 on Solaris.

I've got TitleStyles set up with an HGradient:

     :
SetEnv GrayBackgnd   rgb:d4/d0/c8
SetEnv ActiveGradL   rgb:0a/24/6a
SetEnv ActiveGradR   rgb:a6/ca/f0
SetEnv InactiveGradL rgb:80/80/80
SetEnv InactiveGradR rgb:c0/c0/c0

Style * ForeColor gray87, BackColor $[GrayBackgnd]
Style * HilightFore white, HilightBack $[GrayBackgnd]

TitleStyle ActiveUp HGradient 80 $[ActiveGradL] $[ActiveGradR] -- Flat
TitleStyle ActiveDown HGradient 80 $[ActiveGradL] $[ActiveGradR] -- Flat

TitleStyle Inactive HGradient 80 $[InactiveGradL] $[InactiveGradR] --
Flat
     :

I'd like to convert to FvwmTheme colorsets.  I tried:

     :
[same SetEnv's]

*FvwmTheme: Colorset 1 fg gray87, bg $[GrayBackgnd], \
    HGradient 80 $[InactiveGradL] $[InactiveGradR]
*FvwmTheme: Colorset 2 fg white, bg $[GrayBackgnd], \
    HGradient 80 $[ActiveGradL] $[ActiveGradR]

ModuleSynchronous Timeout 5 FvwmTheme

Style * Colorset 1, BorderColorset 1
Style * HilightColorset 2, HilightBorderColorset 2

TitleStyle ActiveUp -- Flat
TitleStyle ActiveDown -- Flat
TitleStyle Inactive -- Flat
     :

The "fg" and "bg" colorset settings are honored, but I'm not getting the
gradients -- window titlebars are always the (solid) "bg" color, whether
focused or not.  Suggestions?

Gregg Dameron

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 20 Mar 2002 20:57:48 +0000

On 20 Mar 2002 12:58:48 -0700, Gregg Dameron wrote:
> TitleStyle Inactive HGradient 80 $[InactiveGradL] $[InactiveGradR] -- Flat
>      :
> 
> 

Window titles, buttons and borders do not fully support colorsets yet.
So you still should use TitleStyle, ButtonStyle and BorderStyle for now
if you want something more than fg/bg.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 20 Mar 2002 23:10:24 +0100

> > I've got TitleStyles set up with an HGradient:

[snip]

> if you want something more than fg/bg.

The reson is that the title bar is redrawn a lot and using the
current implementation of colour sets is way too slow.  This will
change within the next few weeks when I finish my work on the
window decorations.  This will reduce the amount of redraws
dramatically and allows to finally implement gradients via a
colour set.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].