Subject: FVWM: pages in windowlist

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 20 Mar 2002 14:22:07 -0800 (PST)

I use pages rather than desks (i dont remember why i didnt like desks)
and i added code to windowlist to display my relative page by dividing my x values by my hard coded screen #'s.

        if(t->frame_g.x > 1151)
          sprintf(loc,"+%d ",(t->frame_g.x)/1152);
        else if(t->frame_g.x < 0)
          sprintf(loc,"%d ",((t->frame_g.x)-1151)/1152);
        else
          sprintf(loc,"  0 ");

What's the right way to display absolute page #'s ?

My windowlist also sorts windows by class name (displaying class) , so all
of similar types are together.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 21 Mar 2002 11:00:28 +0100

> What's the right way to display absolute page #'s ?

 - Choose a point of the window to compare against.  E.g. the top
   left corner or the middle of the window.
 - Add Scr.Vx and Scr.Vy to the x/y coordinates.
 - Divide by Scr.MyDisplayWidth/Height.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].