Subject: FVWM: active placement of transients?

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 31 Mar 2002 17:30:00 -0800

Hello,

I am using fvwm 2.4, and I wonder if there is a way to do
active placement of transient windows? I seem to remember
seeing this, but now can't track it down in the man page.

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 1 Apr 2002 02:06:53 +0000

> seeing this, but now can't track it down in the man page.

If you want to manually place transient windows and only those, it is not
easily possible. Currently you may specify ManualPlacement for windows by
their names. Probably in the future it will be possible to specify styles
by window types.

To define manual placement for transient windows those names you know,
use something like:

  Style "Netscape: Find" ManualPlacement
  Style "Netscape: Print" ManualPlacement
  Style "Netscape" NoTransientUSPosition, NoTransientPPosition

The first lines are for 2.4.0+, the last one is for 2.4.1+.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 31 Mar 2002 18:07:56 -0800

>The first lines are for 2.4.0+, the last one is for 2.4.1+.

This is good enough. Thanks for a quick response!

denis