Subject: FVWM: FvwmButtons problems..

From: John Smith <[email-masked]>
Date: Sun, 10 Mar 2002 16:03:05 -0800

Ok, so I've got this configuration, and I have problems:

Module FvwmButtons

(Further down)

*FvwmButtons: Back black
*FvwmButtons: Fore red
*FvwmButtons: BoxSize smart
*FvwmButtons: Columns 5
*FvwmButtons: Geometry 400x112+0-0
*FvwmButtons: ButtonGeometry 100x100
*FvwmButtons: (Swallow XEyes 'Exec xeyes -bg black -fg red')
*FvwmButtons: (Swallow xbiff 'Exec xbiff -bg black -fg white')
*FvwmButtons: (Swallow xosview xosview)
*FvwmButtons: (Swallow XLoad 'Exec xload -update 1 -bg black -fg white -font 5x7
')
*FvwmButtons: (2x2+2+0, Swallow XClock 'Exec xclock -bg black -fg white -hd dark
blue -hl cyan -bd purple -chime')
DestroyFunc xosview
AddToFunc   xosview
+ I Exec xosview -name BarXosview -xrm 'xosview*background:black' -load \
+mem -net +cpu -int -swap -page -battery -disk -geometry 100x50+0-0 -font 5x7 \
2>/dev/null

The geometry doesn't work at all.  It becomes a tiny 50x20 window at +0+0

I also tried passing -g in the Module line, but it still doesn't work. :(
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Mar 2002 00:39:15 +0000

> I also tried passing -g in the Module line, but it still doesn't work. :(

With this config (ok, I used the alias name FvwmButtons-New so it does not
affect my other FvwmButtons aliases) I get a 500x200 window as requested.

The Geometry line is ignored if there is ButtonGeometry. Specify position:

  *FvwmButtons: ButtonGeometry 100x100+0-0

I don't know how it became 50x20 for you. Do you have an additional line
like "*FvwmButtons: ButtonGeometry 10x10" somewhere?

I suggest you to create a minimal fvwm2rc file that only has the sample
above, this will give you correct 5x2 buttons (100x100 each). Then try to
find the problem in your current config. Or come back with more info.

Regards,
Mikhael.

---

From: John Smith <[email-masked]>
Date: Sun, 10 Mar 2002 16:52:50 -0800

Ok, I removed ButtonGeometry and it's all good now.  I have another question, 
what if I want to have one row with a bunch of swallowed apps of different 
geometries?  How do I do that?  Like for instance, I want xosview to have be 
wider than the other swallowed apps.. is there a way to set it for that 
individual app?

Btw, I keep getting an error in my fvwm2 log saying "Bad style option: NoBorder", when I look this up in the fvwm2 man page, it says it was part of 1.xx.  I'm also a bit confused by the difference between handles and borders.  I suppose handles are just the parts around the window that let you do some move/resize/user config thing?  And borders are around the handles?  Please explain.

Thanks again

PS: I hope I'm not killing all your time with my silly questions :(

---

From: Ulrich Fahrenberg <[email-masked]>
Date: Mon, 11 Mar 2002 08:46:57 +0100

John Smith wrote:

> I'm also a bit confused by the difference between handles and borders.

> I suppose handles are just the parts around the window that let you

> do some move/resize/user config thing?

> And borders are around the handles?  Please explain.

Borders are the borders around undecorated windows, i.e. without titles 
and resize _handles_. Handles are the borders around decorated windows.

Uli Fahrenberg

PS. You didn't kill my time, but please keep your lines no longer than 
70-something characters.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Mar 2002 10:32:49 +0100

On Sun, Mar 10, 2002 at 04:52:50PM -0800, John Smith wrote:
> geometries?  How do I do that?
> Like for instance, I want xosview to have be 

You can find an example for that at the end of the FvwmButtons man
page.
 
> Btw, I keep getting an error in my fvwm2 log saying "Bad style
> option: NoBorder", when I look this up in the fvwm2 man page, it
> says it was part of 1.xx.

  Style * HandleWidth 0, BorderWidth 0

> I'm also a bit confused by the
> difference between handles and borders.  I suppose handles are
> just the parts around the window that let you do some
> move/resize/user config thing?  And borders are around the
> handles?  Please explain.

The handles are indeed the invisible windows that can be grabbed
with the pointer to resize the window.  The terminology is a bit
confusing.  The BorderWidth and HandleWidth styles both control
the size of the relief around the window.  HandleWidth is used if
the window has handles and the BorderWidth otherwise.

> PS: I hope I'm not killing all your time with my silly questions :(

Nonsense!  It's important for me to get feedback so I can judge
what we can do better in the future.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Walter Dnes <[email-masked]>
Date: Mon, 11 Mar 2002 23:39:30 -0500

On Sun, Mar 10, 2002 at 04:52:50PM -0800, John Smith wrote

> I have another question, what if I want to have one row with a
> bunch of swallowed apps of different geometries?  How do I do that?
> Like for instance, I want xosview to have be wider than the other
> swallowed apps.. is there a way to set it for that individual app?

  I have something like that at the bottom left of my screen.  It looks
like so...

  -------------------------------
 |Datetime text display|         |
 |----------------------  FVWM   |
 |                     | PAGER   |
 |      xload          |         |
 |                     |         |
  -------------------------------

  I specify a "Container" 3 rows by 5 columns.  Then specify the size of
each swallowed app.  Note that it's columns X rows ("3x1" and "2x3" and
"3x2"), to confuse the issue.  Anyhow, here's my module.  Feel free to
modify it to your needs.  Remove the "> " at the beginning of each line.
I've put them in to prevent line-breaking.  Program code and long URLs
are generally the only times I use over-long, non-breaking lines in
email/news.

> ################## FvwmButtons button-bar ################################
> KillModule FvwmButtons
> DestroyModuleConfig FvwmButtons: *
> *FvwmButtons: Geometry 310x80+0-0
> *FvwmButtons: (Frame 0, Padding 0 0, Container(Rows 3 Columns 5 Frame 0 Padding 0 0))
> *FvwmButtons: (3x1, Frame 0 Padding 1 1, Swallow(UseOld,NoHints,Respawn) "xclock" `Exec exec xclock -bg rgb:00/00/00 -fg rgb:00/C0/80 -padding 5 -update 1 -digital -font 7x13`)
> *FvwmButtons: (2x3, Frame 0, Swallow(UseOld,NoHints) "Inline" "Module FvwmPager  Inline 0 0")
> *FvwmButtons: (3x2, Frame 0, Swallow(UseOld,NoHints,Respawn) "xload" `Exec exec xload -bg rgb:7A/8B/8B -fg rgb:00/00/00 -update 5 -nolabel`)
> *FvwmButtons: (End)
> 
> DestroyModuleConfig Inline: *
> *Inline: Balloons
> *Inline: Font none
> 
> Style FvwmButtons WindowListSkip, NoTitle, NoHandles, BorderWidth 1
> 
> Module FvwmButtons

-- 
Walter Dnes <[email-masked]>
If you had purchased $1000 of @home stock in 1999, today you would
have $1.30.  If you had purchased $1000 of beer in 1999, today you
would still have $59 in empty cans.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].