Subject: Re: FVWM: Mouse buttons

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Mar 2002 08:15:25 +0100

On Thu, Feb 28, 2002 at 03:18:43PM +0100, Ripalda-Marin, Miguel-Angel wrote:
> Hi,
> 
> but, as far as I can know... I think that the conf that you propose configs
> the mouse for a left-handed person... what I would like is both right and
> left buttons to behave as if they were the right button... but, when I try
> to use:
> xmodmap -e "pointer=1 2 1"
> 
> it doesn't work... is there anything that I'm doing wrong?

That may not be possible at all.  You'd best ask the X11 or XFree
developers about that.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 2 Mar 2002 20:13:15 +0000

On 28 Feb 2002 15:18:43 +0100, Ripalda-Marin, Miguel-Angel wrote:
> left buttons to behave as if they were the right button...

If you want your FVWM bindings to work this way, just duplicate all lines
that read "Mouse 1" with "Mouse 3". Like this:

  Mouse 1	R	A	Menu MenuFvwmRoot
  Mouse 3	R	A	Menu MenuFvwmRoot

  Mouse 1	SF	A	FuncFvwmResizeOrRaiseOrShade
  Mouse 3	SF	A	FuncFvwmResizeOrRaiseOrShade

  Mouse 1	T	A	FuncFvwmMoveOrRaiseOrShade
  Mouse 3	T	A	FuncFvwmMoveOrRaiseOrShade

  Mouse 1	I	A	FuncFvwmMoveOrIconify
  Mouse 3	I	A	FuncFvwmMoveOrIconify

  Mouse 1	WI	M	Menu MenuFvwmRoot
  Mouse 3	WI	M	Menu MenuFvwmRoot

If you want to duplicate bindings in other applications as well, see their
documentation to learn how to do it, like "man xterm".

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Mar 2002 08:15:25 +0100

Bye

Dominik ^_^  ^_^