Subject: FVWM: FVWM2.4.5 StaysOnTop

From: "David Dwyer" <[email-masked]>
Date: Thu, 7 Mar 2002 13:36:18 -0600

Does anyone know how to keep a window on-top using StaysOnTop in system.fvwm2rc?  I'm setting up a Linux kiosk using Fvwm-2.4.5 and followed the instructions  described in w.linuxdoc.org's Kiosk HOWTO by Gene Wilburn.  The image masks load properly with X but the Netscape window (layer) is on top.  So the images don't cover the bookmarks, print, and security buttons; they're end up behind the browser window.  I've check everything.  Any suggestions would be greatly appreciated.  

Double D.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Mar 2002 10:29:24 +0100

On Thu, Mar 07, 2002 at 01:36:18PM -0600, David Dwyer wrote:
> Does anyone know how to keep a window on-top using StaysOnTop
> in system.fvwm2rc?  I'm setting up a Linux kiosk using
> Fvwm-2.4.5 and followed the instructions  described in
> w.linuxdoc.org's Kiosk HOWTO by Gene Wilburn.  The image masks
> load properly with X but the Netscape window (layer) is on top.
> So the images don't cover the bookmarks, print, and security
> buttons; they're end up behind the browser window.  I've check
> everything.  Any suggestions would be greatly appreciated.  

  Style <windowname> StaysOnTop

should work.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 17 Mar 2002 20:54:56 +0000

On 07 Mar 2002 13:36:18 -0600, David Dwyer wrote:
> 
> Does anyone know how to keep a window on-top using StaysOnTop in
> system.fvwm2rc?  I'm setting up a Linux kiosk using Fvwm-2.4.5 and
> followed the instructions described in w.linuxdoc.org's Kiosk HOWTO by
> Gene Wilburn.  The image masks load properly with X but the Netscape
> window (layer) is on top.  So the images don't cover the bookmarks,
> print, and security buttons; they're end up behind the browser window. 
> I've check everything.  Any suggestions would be greatly appreciated.

Reading this HOWTO, it should work.

Are you sure sxpm images are started? You say that you don't see them,
because Netscape is on top. sxpm package should be installed for this.

I may suggest you to press Alt-Tab to see what windows are started.
You should see something like this:

  Netscape: Something             0(4):some-geometry
  Sxpm: some-image1.xpm           0(6):some-geometry
  Sxpm: some-image2.xpm           0(6):some-geometry
  Dali Clock                      0(6):some-geometry

If you don't see this, please rerad the HOWTO again. :)
If you do see this and Netscape that is on layer 4 covers all other
windows that are on layer 6, tell us.

More notes about this HOWTO at:

  http://www.linuxdoc.org/HOWTO/Kiosk-HOWTO.html

I would not run anything as root, expecially a public Netscape window.
The following HOWTO makes more sence if you need a good security:

  http://www.linuxdoc.org/HOWTO/mini/Public-Web-Browser.html

You don't really need FVWM for a kiosk, even if you want mask images and
expect netscape to crash. But it may be easier with FVWM and StaysOnTop.

Regards,
Mikhael.