Subject: FVWM: When do buttons show up?

From: Fernando Herrero Carrón <[email-masked]>
Date: Thu, 7 Mar 2002 14:34:05 +0000

Hi there,

How buttons supposed to show up in the title bar? If I define ButtonStyle or AddToButtonStyle nothing happens, even with Style * Button [N] only the title is shown.

(I'm afraid I'm going to get another RTM, sorry)

Thanks for your help,

Fernando Herrero Carrón 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Thu, 7 Mar 2002 13:46:12 +0000 (GMT)

Hello,

> Hi there,
> 
> How buttons supposed to show up in the title bar? If
> I define ButtonStyle or AddToButtonStyle nothing
> happens, even with Style * Button [N] only the title
> is shown.

The buttons on the title-bar, are numbered, thus:

1 3 5 7					2 4 6

Thus, to specify a particular button

ButtonStyle 1 blah, blah, commands, etc

> (I'm afraid I'm going to get another RTM, sorry)

:-) Nah...as it happens though, it *is* in the fvwm2
man page, thus:

man fvwm2 | col -b | grep -i "buttonstyle" >
/$HOME/fvwm2man.txt

:-) Honest....

Hope That Helps,
Regards,

Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 07 Mar 2002 08:51:05 -0500

Fernando Herrero Carrón <[email-masked]> writes:
> Hi there,
> 
> How buttons supposed to show up in the title bar? If I define ButtonStyle or 
> AddToButtonStyle nothing happens, even with Style * Button [N] only the title
> is shown.

Defining the button is not enough, you need to bind an action to
the button.

For example, this is an action on button 1:

Mouse 0 1 A Iconify

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 07 Mar 2002 09:03:30 -0500

> man fvwm2 | col -b | grep -i "buttonstyle" >

(x)emacs&
M-x man <ret>
fvwm2 <ret>
C-s buttonsytle

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Mar 2002 14:44:57 +0100

On Thu, Mar 07, 2002 at 02:34:05PM +0000, Fernando Herrero Carrón wrote:
> Hi there,
> 
> How buttons supposed to show up in the title bar? If I define
> ButtonStyle or AddToButtonStyle nothing happens, even with
> Style * Button [N] only the title is shown.

Buttons show up if some action is bound to them with the Key or
Mouse commands.  For example, if you want to use button 7, define
an action:

  Mouse 1 7 A Beep

> (I'm afraid I'm going to get another RTM, sorry)

You won't get that on the fvwm lists.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20