Subject: FVWM: WindowShade-ing

From: Stephen Dennison <[email-masked]>
Date: Tue, 5 Mar 2002 18:47:01 -0500 (EST)

I wanted to bind doubleclicking the window title bar to shading the
window, the best I was able to do was set one of icons in the titlebar to
doing it.  I read thru the online documentation that seemed relevant to
what I wanted to do, but none of it seemed to have what I needed.

Anyone know how I could bind DoubleClicking the title bar to
shading the window?

Thanks

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alexander Kotelnikov <[email-masked]>
Date: Wed, 06 Mar 2002 03:19:21 +0300

>>>>> On Tue, 5 Mar 2002 18:47:01 -0500 (EST)
>>>>> "Stephen" == Stephen Dennison <[email-masked]> wrote:
Stephen> 
Stephen> I wanted to bind doubleclicking the window title bar to shading the
Stephen> window, the best I was able to do was set one of icons in the titlebar to
Stephen> doing it.  I read thru the online documentation that seemed relevant to
Stephen> what I wanted to do, but none of it seemed to have what I needed.
Stephen> 
Stephen> Anyone know how I could bind DoubleClicking the title bar to
Stephen> shading the window?

1. bind click on title to a function

Mouse 1 T A MyTitleClickFunction

2. define your function like
DestroyFunc MyTitleClickFunction
AddToFunc MyTitleClickFunction
+ "M" Move
+ "D" WindowShade

man fvwm should help you
-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 01:56:38 +0100

> Anyone know how I could bind DoubleClicking the title bar to

The function I use looks like this:

  AddToFunc MoveOrRaise
  + C Raise
  + M Raise
  + M Move
  + D Pick (Shaded) Raise
  + D WindowShade toggle

  Mouse 1 T A MoveOrRaise

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].