Subject: FVWM: FvwmPager - desks ordered vertically?

From: Richard Curnow <[email-masked]>
Date: Thu, 14 Mar 2002 15:02:28 +0000

I'd like to set up FvwmPager so that the desks are shown in a 8 row by 2 column
arrangement (tall and thin).  I'd like the desk numbers arranged like this:

 0   8
 1   9
 2  10
 ...
 7  15

I can't find a way of specifying this, I always get

 0   1
 2   3
 4   5
 etc
14  15

Looking at the source code, I don't think it's currently possible to get what I
want.  Can somebody confirm that before I think about hacking to try and add
this?

Thanks
Richard

-- 
Richard \\\ SuperH Core+Debug Architect ///            .... At home ...
  P.    /// [email-masked]      /// [email-masked]
Curnow  \\\ http://www.superh.com/    ///      www.rrbcurnow.freeuk.com
Speaking for myself, not on behalf of SuperH
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 14 Mar 2002 15:28:36 +0000

> want.  Can somebody confirm that before I think about hacking to try and add

No magic here, there is no hidden option in the source code that is not
documented in the man page, to switch vertical and horizontal loops. :)

But it is still currently possible to get what you want. Just create
FvwmButtons that swallows 2 pagers without borders. You may use aliases
for pagers and FvwmButtons. Or just one pager config without geometry
that is used twice, once with arguments 0 7 and once with arguments 8 15.

Another solution is to implement a boolean option in FvwmPager.

Regards,
Mikhael.

---

From: Richard Curnow <[email-masked]>
Date: Fri, 15 Mar 2002 10:18:57 +0000

> > arrangement (tall and thin).  I'd like the desk numbers arranged like this:

[etc]

> Just create FvwmButtons that swallows 2 pagers without borders. You may use
> aliases for pagers and FvwmButtons. Or just one pager config without geometry

Luckily I already had FvwmButtons swallowing a single FvwmPager, so this was a
very good solution for me - thanks!  For anyone else who's interested, this is
the relevant bit of .fvwm2rc that I ended up with:

#####################################################################
#! Now start pager (1st column)
Module FvwmPager FirstPager 0 7
*FirstPager: Back #303030
*FirstPager: Fore White
*FirstPager: Rows 8
*FirstPager: Hilight #c04040
*FirstPager: Geometry 275x53-0+0
*FirstPager: SmallFont -*-times-medium-r-*-*-*-80-*-*-*-*-*-*
*FirstPager: Font 5x7
*FirstPager: DeskTopScale 48
*FirstPager: MiniIcons

#####################################################################
#! Now start pager (2nd column)
Module FvwmPager SecondPager 8 15
*SecondPager: Back #303030
*SecondPager: Fore White
*SecondPager: Rows 8
*SecondPager: Hilight #c04040
*SecondPager: Geometry 275x53-0+0
*SecondPager: SmallFont -*-times-medium-r-*-*-*-80-*-*-*-*-*-*
*SecondPager: Font 5x7
*SecondPager: DeskTopScale 48
*SecondPager: MiniIcons

#####################################################################
# FvwmButtons stuff

Module FvwmButtons
*FvwmButtons: Columns 1
*FvwmButtons: BoxSize smart
*FvwmButtons: Geometry +0-0
*FvwmButtons: Font -*-helvetica-medium-r-*-*-10-*

*FvwmButtons: (Title Terminals, Icon xterm.xpm, Panel(right, steps 3) Terminals, "Module FvwmButtons -transientpanel Terminals")
*FvwmButtons: (Title Tools, Icon toolbox.xpm, Panel(right, steps 3) Tools, "Module FvwmButtons -transientpanel Tools")
*FvwmButtons: (1x3, Swallow "maildir-biff-notext" `Exec /data/curnowr/bin/maildir-biff-notext &`)
*FvwmButtons: (Title Fetchmail, Icon mail1.xpm, Action `Exec "" /usr/bin/fetchmail > /dev/null 2>&1 &`)
*FvwmButtons: (Title Screenlock, Icon xlock.xpm, Action `Exec "" sleep 2 ; /usr/local/bin/xscreensaver-command -lock &`)
*FvwmButtons: (Title Restart, Icon fvwm.xpm, Action Restart /usr/local/bin/fvwm2)
*FvwmButtons: (1x4, Container(Rows 1,Frame 1))
*FvwmButtons: (Swallow(UseOld,NoKill) "FirstPager" `FvwmPager 0 7`)
*FvwmButtons: (Swallow(UseOld,NoKill) "SecondPager" `FvwmPager 8 15`)
*FvwmButtons: (End)

Cheers
Richard