Subject: FVWM: FvwmIconMan instead of regular icons?

From: John Smith <[email-masked]>
Date: Wed, 6 Mar 2002 23:42:54 -0800

Hi, I'm still a bit new to fvwm2, but I'm starting to really like it.  I
have a question though.  How do I get things to minimize to FvwmIconMan
instead of an icon?  Basically, I want to disable using icons entirely,
and just use a WindowList or FvwmIconMan to restore windows.

Any help would be appreciated,

Thank you
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Thu, 7 Mar 2002 10:25:10 +0100 (CET)

> Any help would be appreciated,

You will add this to your .fvwm2rc

Style * NoIcon

this turns off "normal" icons.
Then you will add a command to start FvwmIconMan in the function StartFunc
like this:
AddToFunc StartFunction "I" Module FvwmIconMan
+                         .... more stuff here possible....

//Marcus

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 7 Mar 2002 10:31:07 +0100

> and just use a WindowList or FvwmIconMan to restore windows.

There is no magic here.  Simply disable the use of icons:

  Style * NoIcon

(you may have to remove some "Icon" styles too), and add a
FvwmIconMan configuration.  Mine looks like this (excapt colours):

  *FvwmThemeColorset 2 fg red, bg green
  *FvwmThemeColorset 6 fg blue, bg yellow, SGradient 100 red green
  # run FvwmTheme before anything else is done
  ModuleSynchronous Timeout 5 FvwmTheme

  Style FvwmIconMan NoTitle, Sticky, NoHandles
  Style FvwmIconMan WindowListSkip, CirculateSkip
  *FvwmIconMan*Action Mouse 3 N sendcommand close
  *FvwmIconMan*FollowFocus true
  *FvwmIconMan*Font 5x7
  *FvwmIconMan*Format "%t"
  *FvwmIconMan*ManagerGeometry 2x5
  *FvwmIconMan*Resolution page
  *FvwmIconMan*Title ""
  *FvwmIconMan*UseWinList true
  *FvwmIconMan*Action Mouse 2 N sendcommand Focus
  *FvwmIconMan*Colorset 6
  *FvwmIconMan*FocusColorset 2
  *FvwmIconMan*FocusAndSelectColorset 2
  *FvwmIconMan*PlainColorset 6
  *FvwmIconMan*SelectColorset 6
  *FvwmIconMan*TitleColorset 6
  *FvwmIconMan*FocusButton up
  *FvwmIconMan*PlainButton up
  *FvwmIconMan*SelectButton flat
  *FvwmIconMan*FocusAndSelectButton flat
  *FvwmIconMan*TitleButton flat

  AddToFunc StartFunction
  + I FvwmIconMan

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Smith <[email-masked]>
Date: Thu, 7 Mar 2002 08:06:21 -0800

Okay, NoIcon works.  However, when I'm using FvwmIconMan with
FvwmAnimate, the animation doesn't really happen.  I'm not too bothered
by it, but I do like the twist effect, it would be cool to have it twist
down to FvwmIconMan :-)

---

From: Dan Espen <[email-masked]>
Date: Thu, 07 Mar 2002 12:56:15 -0500

> by it, but I do like the twist effect, it would be cool to have it twist

I like icons, so I've never tried it, but:

  *FvwmIconMan*NoIconAction         "SendToModule FvwmAnimate animate"

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Smith <[email-masked]>
Date: Thu, 7 Mar 2002 10:05:17 -0800

Ahh, that works. Thanks :)