Subject: Re: FVWM: FVWM2 on solaris 2.6

From: Dan Espen <[email-masked]>
Date: Fri, 15 Mar 2002 13:22:19 -0500

"Nikul Raval" <[email-masked]> writes:
> 
> Thank you for  taking time out to help.

Your'e welcome, but please respond to the fvwm list.

> User is running  eXceed in
> single window mode   and  logs in exactly   as  he would on  a  UNIX
> workstation. (not running multiple xstarts)

Can you describe this in more detail.

I've always started Exceed using XStart, but I guess you can
just bring up X on the PC and separately telnet to the UNIX
machine, set $DISPLAY and then start up each X application
you want.  Is that what the user is doing?

If you do that, the X applications you start, including FVWM
will die when the telnet session is closed, unless you
detach the command from the telnet session.  I do this detaching
under ksh like this:

(fvwm&)&

> >I'm not sure I understand everything.
> 
> >The "x" you mention, must be the Windows Close button on the Exceed
> >window.
> Yes.

OK, so the user is  not ending each  application,  he's killing the  X
server   and  hoping each   client   application recognizes  this  and
terminates cleanly.  I've had mixed success with this.

> >Whats  the Console screen?   Do  you mean the  background  of  the Sun
> >Workstation?
> Yes. The same screen you see for command line login.

I'm not completely sure whats going on, but if you start
applications from telnet, and telnet goes away, I think the output
might go to the program that started telnet on the workstation.
That might get the output to the console.

If the user is taking the telnet approach, (I don't recommend it),
then this might be a better way to run commands:

(fvwm 2&>1 >/tmp/fvwm.out &)&

> > Once  in a long  while  it does this   on UNIX workstation  (Ultra1)
> > without eXceed also.  He can  open new  xterms  from the toolbar  on
> > UNIX but can't type into any of the windows.
> 
> >By Toolbar, you mean FvwmButtons or something else?
> Yes.  The toolbar with FvwmButtons for changing screens, holding mailtool etc
> ...
> 
> >When he can't type into xterms is the window manager running,
> >Ie. are there frames around the windows?
> Yes.  He can select different windows but can't type into any.
> All typing comes on black/white login screen.
> 
> >With xterm, you can tell if the window gets focus because the
> >cursor changes from an empty box to a solid.  Are the xterm
> >windows getting focus?
> Yes again.
> > This goes away when he  logs out and logs back  in.  Is this a  bug?
> > How do I fix  this so next time window  manager doesn't die on  UNIX
> > when he kills  eXceed session on  PC.  How does  one restart xserver
> > and get control of the windows without logging out?
> 
> >What goes on on the PC should not affect the workstation,
> >assuming each is started independently.  Ie. using Xstart for
> >Exceed and running xinit from the console on the UNIX workstation.
> Not running multiple xterms but running in single window mode.
> It looks similar being on the workstation and loggin on the console.

I'm not clear on this part, but what happens if the user
goes into a xterm and does:

echo "testing" >/dev/console

(There should be a console app running, for example "xterm -C" to
catch anything headed for /dev/console.)  If there isn't, the above
will appear on the background.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Walter Dnes <[email-masked]>
Date: Sat, 16 Mar 2002 02:52:50 -0500

On Fri, Mar 15, 2002 at 01:22:19PM -0500, Dan Espen wrote
> Your'e welcome, but please respond to the fvwm list.

  A bit of administrivia stuff.  I also hit that booby-trap when I first
subscribed.  The list is set up such that by default, replies go only to
the original sender.  Is this intentional on the list-admin's part ?  I
subscribe to more than one list with this "feature".  Here's a snippet
of the procmail code I use to write a proper "Reply-To:" line to cause
my replies to default to the list...

:0 fhw
* ^Return-Path: .owner-fvwm@hpc\.uh\.edu
* !^Reply-To:.*fvwm@hpc\.uh\.edu
  | formail -i "Reply-To: [email-masked] (FVWM list)"

-- 
Walter Dnes <[email-masked]>
If you had purchased $1000 of @home stock in 1999, today you would
have $1.30.  If you had purchased $1000 of beer in 1999, today you
would still have $59 in empty cans.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].