Subject: FVWM: FvwmAnimate

From: "Thomas A. Gardiner" <[email-masked]>
Date: Thu, 7 Mar 2002 11:27:46 -0500 (EST)

Hi Folks,

I just upgraded to RH 7.2 and installed the fvwm rpm binary from the
fvwm-themes site:

fvwm-2.4.4-2.rh7.i386.rpm

When I use FvwmAnimate with Flip I am finding that the lines it draws
during the flip are being left on the screen.  Can anyone confirm this?
For the record here's the config file:

$ cat .fvwm/.FvwmAnimate
# This file created by FvwmAnimate

*FvwmAnimate: Effect Flip
*FvwmAnimate: Iterations 32
*FvwmAnimate: Width 0
*FvwmAnimate: Twist 2.000000
*FvwmAnimate: Delay 10
*FvwmAnimate: Color white

If I drag a window across the residual lines they are erased, but not by
say switching desktops or pages.  Any idea who's at fault?

Tom

Ps. Just in case you're wondering:

$ rpm -q XFree86
XFree86-4.1.0-15

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 07 Mar 2002 13:05:12 -0500

> Ps. Just in case you're wondering:

I can't see how this could be anything other than an XFree bug.

During animation, lines are drawn with the sequence:

  XGrabServer(dpy);
  XInstallColormap(dpy, ...)
  XDrawLines(dpy, Scr.root, ...);
  XFlush(dpy);
  XDrawLines(dpy, Scr.root, ...);
  XUngrabServer(dpy);

The second XDrawLines should erase the first.
The Grab should ensure that nothing else happens to the display
 during the draws.  The gc for XDrawLines is setup for xor'ing.

The only time I've seen line dropping is using Exceed, where Exceed
doesn't have total control of the display.

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].