Subject: FVWM: closing windows

From: "Anders K. Lyhne Th0gersen" <[email-masked]>
Date: Sat, 9 Mar 2002 13:43:37 +0100 (CET)

Hi there...

I would like to close a handfull of windows whose name i know.
for this i try to use FvwmCommands(The module has been started)
and the current command to specify which windows i would like to
have closed

        FvwmCommands "Current (man_fvwm2 info_m4) Close"

But alas nothing happens... Anyone have an idea how i could do this?

Regards
 Anders

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 09 Mar 2002 08:07:43 -0500

> But alas nothing happens... Anyone have an idea how i could do this?

Matching functions have to satisfy all conditions.
I think you want Next, not current.  There's no "s" at the end
of FvwmCommand.  In a shell, use single quotes if you don't want
the shell to interfere.

You want:

FvwmCommand 'Next (man_fvwm2) Close';FvwmCommand 'Next (info_m4) Close'

-- 
Dan Espen                           E-mail: [email-masked]
444 Hoes Lane  Room RRC 1C-214      Phone: (732) 699-5570
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Anders T." <[email-masked]>
Date: Sat, 9 Mar 2002 14:42:46 +0100 (CET)

> FvwmCommand 'Next (man_fvwm2) Close';FvwmCommand 'Next (info_m4) Close'

Yep that did the trick!!

Thanks
Anders