Subject: FVWM: Key Bindings

From: "JedTheHead" <[email-masked]>
Date: Tue, 5 Mar 2002 22:00:40 -0500

Hi all!

I was just wondering what the best found way to bind key combinations to external progs / scripts is?   I.e.  hit a 3 key combo while in any prog in FVWM and run a shell script to halt the machine.  

TIA!

JedTheHead

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 6 Mar 2002 18:17:42 +0100

On Tue, Mar 05, 2002 at 10:00:40PM -0500, JedTheHead wrote:
> Hi all!
> 
> I was just wondering what the best found way to bind key
> combinations to external progs / scripts is?   I.e.  hit a 3
> key combo while in any prog in FVWM and run a shell script to
> halt the machine.  

Write a shell script that does what you need and then bind it to
a key stroke by placing this line (or some similar line) in your
.fvwm2rc file:

  Key Delete A CM Exec my_shutdown_script
   ^     ^   ^  ^ ^
   |     |   |  | |____ The command to run with "Exec" in front
   |     |   |  |______ Needs (C)trl+(M)eta (= Alt) to work
   |     |   |_________ The binding works in (A)ny context
   |     |_____________ The key name
   |___________________ The command to create a key binding

For more details, read the section about the "Key" and "Mouse"
commands in the fvwm2 man page:

  $ man fvwm2

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].