Subject: FVWM: WindowId and FvwmCommand

From: Keith Kaple <kak01@earth1inkd0tnett>
Date: Wed, 6 Feb 2002 11:32:23 -0500

how does one set window id's using FvwmCommand (or is there a better way)

looking for somethig like:

/usr/X11R6/bin/FvwmCommand '+I WindowId foo Exec xterm'
/usr/X11R6/bin/FvwmCommand '+I WindowId bar Exec xterm'
/usr/X11R6/bin/FvwmCommand '+I WindowId doo Exec xterm'

so then I can make a function that finds any foo bar and doo and moves them to the current desk.

Once again, if there is a better way to gather "groups" of xterms and perform operations on them, please advise.

Thanks 

-- 
    _..._	
   |_____|
   |_____|
   |_____|
   |_____|
   |_____|
  / _____ \   It is time to stop
  ||  '  ||   the little spammers. 
  ||  |  ||
  ||- | -||)  If you are a human, 
  ||   \ ||   I'm sure you can get 
  ||__.__||   an address from this
  \_______/   email.
   |_____|
   |_____|          -Keith
   |_____|
   |_____|
   |_   _|
     ```
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Feb 2002 15:03:33 +0000

> Once again, if there is a better way to gather "groups" of xterms and perform operations on them, please advise.

  All  (xterm) MoveToDesk +1 0 3
  Next (xterm) Raise
  None (xterm) Exec exec xterm
  Pick (xterm) Iconify

You only use WindowId if you know a window id (rare case) or want to
operate on the _current_ window using: WindowId $w (conditions) Command

Regards,
Mikhael.

---

From: Keith Kaple <kak01@earth1inkd0tnett>
Date: Wed, 6 Feb 2002 12:57:50 -0500

OK :-)  

A little more information.

Let's say I have 50 xterms open, 19 of which are "special" for the moment, meaning they have been started with a specific purpose in mind.  In my case they are router consoles started with a bash script line by something like:

xterm $xtermopts -T 'otto 172.18.194.167' -e telnet $commserver 2019 &

What is the easiest way to classify this xterm window from another xterm so with a function I can gather all my router consoles into one desk and cacade them?  

thanks

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 6 Feb 2002 16:55:18 +0000

> What is the easiest way to classify this xterm window from another xterm so with a function I can gather all my router consoles into one desk and cacade them?  

You already classify them using -T; -n is stronger; -name is even more.
Use FvwmIdent to find out what all these 3 options do.

  All ('otto 172.18.194.167') Close

Or if you want to automate things, bind this menu to a window button:

DestroyMenu  MenuFvwmWindowGroupOps
AddToMenu    MenuFvwmWindowGroupOps "Resource Group Ops" Title       
+ "&Iconify%menu/window-iconify.xpm%"   Pick All ($r) Iconify on     
+ "De&Iconify%menu/window-iconify.xpm%" Pick All ($r) Iconify off    
+ "&Shade%menu/window-shade.xpm%"       Pick All ($r) WindowShade on 
+ "Un&Shade%menu/window-shade.xpm%"     Pick All ($r) WindowShade off
+ "R&aise%menu/window-raise.xpm%"       Pick All ($r) Raise
+ "Lo&wer%menu/window-lower.xpm%"       Pick All ($r) Lower
+ "" Nop
+ "&Delete%menu/window-delete.xpm%"     Pick All ($r) Delete
+ "&Close%menu/window-close.xpm%"       Pick All ($r) Close  
+ "Destroy%menu/window-destroy.xpm%"    Pick All ($r) Destroy
+ "" Nop
+ "Quick Move To ...%menu/window-move.xpm%" Popup MenuFvwmWindowGroupQuickMove

This menu is copied from the fvwm-themes package.
The "Pick" word is not needed, but it ensures that this menu is usable
outside a window button too, when the current resource $r is not defined.

BTW, how about to use a valid "From:" header?

Regards,
Mikhael.

---

From: Ulrich Fahrenberg <[email-masked]>
Date: Wed, 06 Feb 2002 18:55:08 +0100

> /usr/X11R6/bin/FvwmCommand '+I WindowId doo Exec xterm'

Do you mean `xterm -n foo'? As far as I'm aware of, FVWM2 cannot change
WindowId's.

uli

---

From: Keith Kaple <kak01@earth1inkd0tnett>
Date: Wed, 6 Feb 2002 16:27:53 -0500

thanks!

I didn't get the FvwmIdent connection from the man page, that makes sense now.

I wonder why when I use -n the string appears for a moment and then is overwritten what looks like values tied to the PS1 shell variable...

---

From: Cameron Simpson <[email-masked]>
Date: Thu, 7 Feb 2002 10:50:19 +1100

On 16:27 06 Feb 2002, Keith Kaple <kak01@earth1inkd0tnett> wrote:
| I didn't get the FvwmIdent connection from the man page, that makes sense now.
| 
| I wonder why when I use -n the string appears for a moment and then is overwri
| tten what looks like values tied to the PS1 shell variable...

Because your shell is rewriting the terminal name with an escape sequence
embedded in $PS1. Get rid of that misfeature and you'll be happier.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

I once ended up sending a copy of my resume to misc.resumes, alt.sex.bondage
and alt.personals. How that misc.resumes newsgroup got in there, I'll never
know.	- John Benfield <[email-masked]>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].