Subject: Re: FVWM: facing problem in fvwm2.4.4

From: Srivathsa Rao U <[email-masked]>
Date: Fri, 01 Feb 2002 09:20:10 +0530

hi,
    thanx for your prompt reply.

nedit version - 5.1
I didnt downloaded nedit at the time of fvwm. It was there.
In my .Xdefault file i setted nedit geometry as - nedit*geometry:        85X40

    Attached is the gtar file contains following.
        file - junk --> a file with big memory. if I open this file in nedit im
getting problem.
        file - .fvwm2rc  -> my fvwm settings.
        file - .nedit    -> my nedit settings.

But size is changing only for the file conating big memory. why it is like that ?

pls update me ASAP

thanx & rgds
srivathsa

>Dominik Vogt wrote:
>We've heard this report once already but could not reproduce the
 > problem.  Please provide the following information.

>   1) Which nedit version do you have?
>  2) Did you upgrade nedit at the same time as fvwm?
>   3) Can you give me an example data file along with the .nedit
>      file from your home directory?  Please send these files not to
>      the mailing list but directly to me - and make sure to
>      compress teh data file aggressively, ("bzip2 -9" if possible,
>      or "gzip --best").

>  Regardless of these questions, you can try to force nedit to
>  behave with several styles:

>    Style nedit MaxWindowSize 100 100

>  limits nedit windows to the actual screen size.  Or if that
>  does not suit your needs you could try

>    Style nedit MaxWindowSize 753p 100

>  753 pixels is the default width of the nedit window for me.  It
>  may be different on your system, depending on font size and the
>  width of the window borders.  To find out the precise value, use
>  "xwininfo" on the nedit window, add twice the size of the border
>  to the number after "Width:" and use that instead.

>  If using an alpha release is an option for you, you can also try
>  out the 2.5.0 release (actually, it's much more stable than the
>  term "alpha" suggests, but there are no guarantees).  Using one of
>  the styles

>    Style nedit FixedPSize

>  or

>    Style nedit FixedUSSize

>  may help.  Note that you won't be able to resize the window
>  manually if you use the second one.

>  Bye

>  Dominik ^_^  ^_^

John Latham wrote:

> > From: Dominik Vogt <[email-masked]>
> > To: Srivathsa Rao U <[email-masked]>, fvwm <[email-masked]>
> > Subject: Re: FVWM: facing problem in fvwm2.4.4
>
> >  1) Which nedit version do you have?
> >  2) Did you upgrade nedit at the same time as fvwm?
>
> This might help. In nedit 5.0 (and prior) geometries were expressed in pixels.
> In nedit 5.1, geometries are expressed as columns and rows!!!! You can imagine
> the horrible effect for anyone with geometry specs in their WM configs!
>
> John Latham

---

From: Srivathsa Rao U <[email-masked]>
Date: Wed, 13 Feb 2002 15:43:14 +0530

hi,

     I switched my WM from 2.0 to 2.4.4.
     Now every thing working fine & i got the settings how I want. But
 Iam facing problem with nedit.
 
     Iam working in Unix & using solaris system (sun7).
 
     Iam using " nedit" as text editer everywhere. But after i started
 using  new fvwm2.4.4 the size of this nedit is not fixed . For some
file
 which have more memory like  700k the size ( geometry) is very big .
But
 it is maintaing the height & only the width is increasing (may be
arround some 5 time of screen width) .
 It is crossing window size also.
 
 why it is like that. ?  How can i correct this?
 This problem was not there in fvwm 2.0
 
 my default geometry for nedit is 80X40.
 
 This is not only my problem . here whoever using 2.4.4  they are also
 facing this.
 pls give the solution .

nedit version - 5.1

    Attached is the gtar file contains following.
        file - junk --> a file with big memory. if I open this file in
nedit i am getting problem.
        file - .fvwm2rc  -> my fvwm settings.
        file - .nedit    -> my nedit settings.

But size is changing only for the file conating big memory. why it is
like that ?

pls update me ASAP

thanx & rgds
srivathsa

---

From: Srivathsa Rao U <[email-masked]>
Date: Tue, 26 Feb 2002 14:52:23 +0530

hi ,

        thanx for your pormpt reply.

        I reported this problem to nedit. waiting for their reply.

        Is there any workaround for this ? If there pls let me know how to
fix.

        You have mentioned that in your setting  width_inc = 9 .
        How to set this ? If it set to 9 this porblem will go ?

Pls let me know it any solution is there for this .

thanx & rgds
srivathsa

Dominik Vogt wrote:

> On Wed, Feb 13, 2002 at 03:43:14PM +0530, Srivathsa Rao U wrote:
> > hi,
> >
> With the files you posted I can reproduce the problem.  Actually
> it does not depend on the .fvwm2rc, but I need your .nedit file
> as well as the data file (using nedit-5.1.1).
>
> What happens is this:
>
>  1) Start nedit
>  2) nedit opens its main window with a width of 803 pixels and
>     requests a character width (width_inc in the size hints) of 9
>     pixels (for me).  All is fine for now.
>  3) From the file dialog, load the data file you sent.
>  4) nedit provides new size hints.  It again requests a width of
>     803 pixels, but a width_inc if 1.  Now this is where the
>     problem starts: according to the ICCCM2, the new requested
>     width is ignored (honoured only when the window is mapped),
>     but the width_inc is honoured.  So, the window shrinks to a
>     width of 154 pixels.
>  5) nedit resizes its window to 803 pixels width.  Actually, it
>     seems to believe it still has this size.  Keep in mind that
>     the character width is still 1.
>  6) Again, nedit provides new size hints, with a width of 803 and
>     a width_inc of 9.  Fvwm ignores the width as it should and
>     honours the width .  Thus, the width of the interior of the
>     window is multiplied by 9 which results in a window that is
>     about 5500 pixels wide :-P
>
> This is clearly a bug in nedit.  There is no reason to change the
> width_inc to 1.  Also, it seems the author misunderstood the way
> the size hints work.  For other files, nedit neither resizes its
> window nor does it provide new size hints.
>
> The reason why you don't see this with earlier versions and
> probably not with any other window manager is that fvwm-2.2 and
> above is the only window manager I know of that properly
> implements changing the width_inc and height_inc hints.
>
> Please report this to the nedit developers.
>
> Bye
>
> Dominik ^_^  ^_^
>
>  --
> Dominik Vogt, [email-masked]
> Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].