Subject: FVWM: Date: Mon, 25 Feb 2002 09:45:47 -0000

From: "luca Messori" <[email-masked]>

I would like change the fvwm background on my PC.
I've read the man page of FvwmBacker module; he said:

>AddToFunc StartFunction I Module FvwmBacker
>in the .fvwm2rc file.
>...
>The following is the only supported option at present:
>*FvwmBacker: Command (Desk d, Page x y) command

I don't understand were I have to put it in the .fvwm2rc file.
I have tried to append il at the end of file, but the background remain the
default one.
.fvwm2rc file is readable from anyone.
What can I do?

Thanks,
Luca Messori

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 25 Feb 2002 12:51:38 +0000

> .fvwm2rc file is readable from anyone.

Did you replace "d", "x", "y" and "command" with correct values?
Try this (the end of ~/.fvwm/.fvwm2rc is ok):

  AddToFunc StartFunction I Module FvwmBacker
  *FvwmBacker: Command (Desk 0) Exec xsetroot -mod 4 4 -fg navy -bg grey20
  *FvwmBacker: Command (Desk 1) Exec xsetroot -solid bisque
  *FvwmBacker: Command (Desk 2) Exec xpmroot /usr/share/icons/fvwm.xpm
  *FvwmBacker: Command (Desk 3) Exec xv -root -quit /usr/share/pixmaps/panel-knob.png

Or, if you need a static background just put this instead:

  AddToFunc StartFunction I Exec xsetroot -mod 4 4 -fg navy -bg grey20

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Mon, 25 Feb 2002 08:47:19 -0500

> .fvwm2rc file is readable from anyone.

If you just want one background for all your desks and pages,
see question 6.6 in the FAQ.

You should be able to put the backer commands anywhere in
your .fvwm2rc.  Heres something that works for 1 desk, and
a 2x2 page setup:

*FvwmBacker: Command (Desk 0, Page 0 0) Exec xsetroot -solid blue
*FvwmBacker: Command (Desk 0, Page 1 0) Exec xsetroot -solid purple
*FvwmBacker: Command (Desk 0, Page 0 1) Exec xsetroot -solid black
*FvwmBacker: Command (Desk 0, Page 1 1) Exec xsetroot -solid cyan

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].