Subject: FVWM: need help to set taskbar setting

From: Srivathsa Rao U <[email-masked]>
Date: Fri, 01 Feb 2002 16:14:26 +0530

hi,
    Im using fvwm2.4.4.
    I want to know how to change the color of buttons in task bar.
    Now i have grey for inactive window. white for minimized window &
ligth grey for raised window.
    ( above mentioned are Bg colour Fg - black)
    I want to change these colours.
    how can i change these ?

I read man page of fvwmtheme - i didnt understand about colorset . what
is it accualy ?
how we can set the Colorset?

thanx & rgds
srivathas

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 2 Feb 2002 13:28:37 +0100

> how we can set the Colorset?

Colour sets are used to specify the foreground, background, shadow
and hilight colours, pixmaps, etc. of most of the widgets in all
of fvwm's modules and most of the core.  The main benefit is that
colour sets are controlled centrally by FvwmTheme.  New
decorations are applied to all windows and modules immediately -
without restarting the modules or fvwm.  The proper way to set up
colour sets is this:

 1) Put the *FvwmTheme lines at the front of you .fvwm2rc file.
 2) Start FvwmTheme with ModuleSynchronous directly from the
    .fvwm2rc, *not* from the StartFunction or InitFunction.
 3) Use these colour sets wherever you like (module configs, fvwm
    core).
 
When fvwm is running, existing colour sets can be changed by
sending a message to the FvwmTheme module:

  SendToModule FvwmTheme Colorset <cset_number> <options>

Here is an example from my own config file (with fake colours).
The option you need is

  *FvwmTaskBarIconColorset  6

------------------------------- snip ---------------------------
#
# FvwmTheme
#
# 0 = Default colours
# 1 = Inactive windows
# 2 = Active windows
# 3 = Inactive menu entry and menu background
# 4 = Active menu entry
# 5 = greyed out menu entry (only bg used)
# 6 = module foreground and background
# 7 = hilight colours
# 8 = transparent module background
*FvwmThemeColorset 0 fg red, bg green
*FvwmThemeColorset 1 fg red, bg blue
*FvwmThemeColorset 2 fg red, bg yellow
*FvwmThemeColorset 3 fg red, bg orange
*FvwmThemeColorset 4 fg red, bg orange
*FvwmThemeColorset 5 fg grey, bg orange
*FvwmThemeColorset 6 fg red, bg orange
*FvwmThemeColorset 7 fg red, bg pink
*FvwmThemeColorset 8 fg red, bg orange, Transparent

# run FvwmTheme before anything else is done
ModuleSynchronous Timeout 5 FvwmTheme

#
# FvwmTaskBar
#
Style FvwmTaskBar NeverFocus, NoTitle, HandleWidth 0, BorderWidth 0
Style FvwmTaskBar WindowListSkip, CirculateSkip

*FvwmTaskBarBack #c3c3c3
*FvwmTaskBarFore black
*FvwmTaskBarTipsBack bisque
*FvwmTaskBarTipsFore black
*FvwmTaskBarAutoHide 1
*FvwmTaskBarAutoStick 1
*FvwmTaskBarGeometry +0-1
*FvwmTaskBarFont -adobe-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarSelFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarStatusFont fixed

*FvwmTaskBarAction Click1 Iconify off, Raise
*FvwmTaskBarAction Click2 Popup windowmenu
*FvwmTaskBarAction Click3 Iconify on

*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAutoStick
*FvwmTaskBarShowTips

*FvwmTaskBarButtonWidth 180
*FvwmTaskBarBellVolume 20
*FvwmTaskBarMailBox /var/spool/mail/
*FvwmTaskBarMailBox None
*FvwmTaskBarClockFormat %I:%M %p

*FvwmTaskBarBack yellow
*FvwmTaskBarColorset      6
*FvwmTaskBarIconColorset  6
*FvwmTaskBarFocusColorset 2
*FvwmTaskBarTipsColorset  0
------------------------------- snip ---------------------------

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].