Subject: FVWM: mapping alt-tab to start windowlist from second window

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 10 Feb 2002 22:38:51 -0800

hello,

right now, i have my alt-tab mapped as follows:

   Key Tab   A    M    WindowList [CurrentPage]

this brings up windowlist with the window currently in
focus (or, if none, i think last which was in focus)
hilighted.

how would i make my fvwm 2.4.3 bring up windowlist so that
the next entry on the list is hilighted?

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 11 Feb 2002 11:50:13 +0000

> the next entry on the list is hilighted?

You can't. Currently menus only start from the first item.

If you want to play with it, try this:

  Key Tab   A    M    MyWindowList

  DestroyFunc MyWindowList
  AddToFunc   MyWindowList
  + I Next (CurrentPage) FlipFocus
  + I WindowList (CurrentPage) Root c c

Or use Focus instead of FlipFocus. But this, while starting from the next
(not current) window, changes order of other windows. Probably not what
you want, but I don't really know what you prefer, so maybe it helps.

Regards,
Mikhael.

---

From: Denis Perelyubskiy <[email-masked]>
Date: Mon, 11 Feb 2002 19:32:17 -0800

* Mikhael Goikhman <[email-masked]> [11-Feb-02 03:50 -0800]:
  >Or use Focus instead of FlipFocus. But this, while
  >starting from the next (not current) window, changes
  >order of other windows. Probably not what you want, but I
  >don't really know what you prefer, so maybe it helps.

thanks. yeah, i'd prefer the order of other things not be
changed, but i will give it a try, see what happens... worst
comes to worst, i will just get used to hitting tab twice :)

thanks anyway.

denis