Subject: FVWM: Mouse buttons and menus changing randomly

From: Thomas Adam <[email-masked]>
Date: Thu, 7 Feb 2002 16:00:56 +0000 (GMT)

Dear List,

I am having a rather strange problem. Currently I have
a three-button mouse (X11 recognises this). I have
configured FVWM2 so that the following happens:

Mouse 1 (root window)  "Root Menu"
Mouse 3 (middle button) (root window) "Window List"
Mouse 2 (right button) (root window) "Program menu"

The configurations for clicking on frames, windows,
borders have been left via the de facto.

My problem is that after a while, of using the mouse,
I find that my mappings of buttons to the menus
suddenly changes, so that for example, if I click the
left hand mouse button to iconify my window, it will
bring up a "Window Config" menu, and not iconify.

Other menus are also mapped to other buttons.
Restarting FVWM2 has no effect. The only way to fix
it, is to completely restart xdm.

Would anybody know why this would occur?? On inital
loading of AnotherLevel, all the mappings of menus to
buttons work fine.

Thanks in Advance,

Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 7 Feb 2002 20:03:16 +0000

> loading of AnotherLevel, all the mappings of menus to

Seems like an X problem. Run xev to see what button numbers your mouse
returns at different times.

It is possible to renumber mouse buttons using something like:

  xmodmap -e "pointer = 3 1 2"
  xmodmap -e "pointer = 1 2 3 8 4 5 6 7"   # a line from my ~/.xinitrc

Regards,
Mikhael.