Subject: FVWM: focus-link for FvwmCommand

From: hugo vanwoerkom <[email-masked]>
Date: Thu, 14 Feb 2002 16:08:34 -0800 (PST)

1. Works great, except some minor things:
Line 72 is wrong: points off to where install did not
put FvwmCommand, so the server wont be started.
2. I use it (a) to position communicator which never
fills the screen and that works great.
But (b) is to resize the Mozilla Mail Account Wizard,
which makes its window too small when 100dpi
characters are used. That ONLY works when you catch
all mozilla windows, because Class and Resource are
both always set to `mozilla-bin`. On the other hand
`Assigned name` is `Account Wizard` which xwininfo
shows too, but is there a way to catch that in
focus-link? Regards. Hugo. 

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: toshi isogai <[email-masked]>
Date: Thu, 14 Feb 2002 17:51:55 -0700

> focus-link? Regards. Hugo. 

You can run FvwmIdent on Account Wizard and see if any property is
unique, at least semi permanently, from the other commnunicator
windows.  If there is such, it should not be hard to modify
class_matches function to select/deselect Account Wizard.

I am surprised that focus-link still works. The last time I checked
FvwmCommand, fvwm message decoding mechanism seems to be outdated...

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499

---

From: Cameron Simpson <[email-masked]>
Date: Fri, 15 Feb 2002 21:42:44 +1100

On 16:08 14 Feb 2002, hugo vanwoerkom <[email-masked]> wrote:
| But (b) is to resize the Mozilla Mail Account Wizard,
| which makes its window too small when 100dpi
| characters are used. That ONLY works when you catch
| all mozilla windows, because Class and Resource are
| both always set to `mozilla-bin`. On the other hand
| `Assigned name` is `Account Wizard` which xwininfo
| shows too, but is there a way to catch that in
| focus-link? Regards. Hugo. 

I can't speak for focus-link. Run an FvwmCommandS to accept external
commands and then FvwmCommand to stream events to a perl script which
watches for stuff. WHat stuff? Bloody Mozilla, like you do!

Anyway, this lets you watch the window titles, which suffices. When you
see the right ones you spit commands back to the FvwmCommandS.

The script is here:

	http://www.zip.com.au/~cs/scripts/fvwmmon

the setup is a bit fiddly, but works ok.
-- 
Cameron Simpson, DoD#743        [email-masked]    http://www.zip.com.au/~cs/

I've seen things you people wouldn't believe.  Attack ships on fire off the
shoulder of Orion. I've watched C-beams glitter in the dark near the
Tannhauser Gate.  All these memories will be lost in time, like tears in rain.
	- Roy Baty, _Blade Runner_
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].