Subject: FVWM: xfishtank breaks fvwm 2.4 root mouse bindings

From: Alexander Kotelnikov <[email-masked]>
Date: Thu, 14 Feb 2002 16:09:36 +0300

Hello.

I got report that fvwm 2.4 does not respect
Mouse 1   R  A <some action>
if xfishtank is running.

It worked with 2.2 versions and works with other WM, so it seems to be
an fvwm trouble
-- 
Alexander Kotelnikov
Saint-Petersburg, Russia
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Thu, 14 Feb 2002 18:21:59 +0100 (CET)

> Mouse 1   R  A <some action>

It seems xfishtank opens it's own window to draw in.
You can see this by running xwininfo and click on the backround and
compare with and without xfishtank.
Also when exiting xfishtank, the rootwindow gets immediatly restored (this
is how I saw it).

> It worked with 2.2 versions and works with other WM, so it seems to be

Is it the same version of xfishtank?

//Marcus

---

From: Alexander Kotelnikov <[email-masked]>
Date: Fri, 15 Feb 2002 01:02:07 +0300

>>>>> On Thu, 14 Feb 2002 18:21:59 +0100 (CET)
>>>>> "Marcus" == Marcus Lundblad <[email-masked]> wrote:
Marcus> 
>> Mouse 1   R  A <some action>
Marcus> 
Marcus> It seems xfishtank opens it's own window to draw in.
Marcus> You can see this by running xwininfo and click on the backround and
Marcus> compare with and without xfishtank.
Marcus> Also when exiting xfishtank, the rootwindow gets immediatly restored (this
Marcus> is how I saw it).
Marcus> 
>> It worked with 2.2 versions and works with other WM, so it seems to be
Marcus> 
Marcus> Is it the same version of xfishtank?

sure

seems that xfishtank translates its events to root's ones, but it does
not work for fvwm 2.4, even it works for overs.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 22 Feb 2002 23:07:29 +0100

> It worked with 2.2 versions and works with other WM, so it seems to be

Fixed in CVS and with the next snapshots/releases (2.4.6/2.5.1).

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].