Subject: FVWM: FvwmTaskBar + Gradient

From: hugo vanwoerkom <[email-masked]>
Date: Mon, 18 Feb 2002 06:19:55 -0800 (PST)

I use:
MenuStyle * MenuFace YGradient 128 3 orange 33 yellow
33 violet 34 lightblue

and all the menus have the ygradient facing.

But when I use:

*FvwmTaskBarBack YGradient 128 3 orange 33 yellow 33
violet 34 lightblue

the taskbar is black. What am I doing wrong?

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - Coverage of the 2002 Olympic Games
http://sports.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 18 Feb 2002 15:49:35 +0000

> the taskbar is black. What am I doing wrong?

You specify a non existing color, so it is equivalent to "Back black".
>From the FvwmTaskBar man page:

  *FvwmTaskBar: Back color
      Specifies the background color for the bar and buttons.

  *FvwmTaskBar: Colorset colorset
      Tells the module to use colorset colorset for the window background
      and the foreground color of the buttons.  Please refer to the man
      page of the FvwmTheme module for details about colorsets.

Try this instead:

  AddToFunc StartFunction I ModuleSynchronous FvwmTheme

  *FvwmTheme: Colorset 5 fg black, bg yellow, Plain, NoShape, \
    YGradient 128 3 orange 33 yellow 33 violet 34 lightblue

  MenuStyle * MenuFace  # just to ensure it's not used
  MenuStyle * MenuColorset 5

  *FvwmTaskBar: Colorset 5

Regards,
Mikhael.