Subject: Re: FVWM: Automatically starting xterms on startup of fvwm2.2.4

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 1 Feb 2002 10:56:27 +0000

On 01 Feb 2002 11:21:27 +1100, David Crisp wrote:
> 
> Ive just converted over to a new install of Debian 2.2r4 which uses fvwm
> 2.2.4. 
> 
> Below are the relevant sections of my .fvwmrc ( 1.24r)  and the new
> .fvwm2rc (2.2.4)  files.  on my original setup I had 6 lines in the
> InitFunction which were there to fire up 6 Xterms on the desktop in
> prearanged places.  This worked fine. (Im not sure if it was the right way
> of doign things.  but it worked and I never had any problem with it). 
> WHen I converted over to 2.2.4, and include the six lines in the
> InitFunction they dont work.  My questions are: 
> 
> 1)  Is there a better way of doing that 
> 2)  Is there somethign blindingly obvious im missing 
> 3)  How do I do the equivilent in a 2.2.4 .fvwm2rc file. 
>     What do I have to add to the initfunction ion the .fvwm2rc file to do
> the equivilent of the six lines in the .fvwmrc file? 
> 
> Current .fvwmrc file
> #############################################################################
> 
> # Stuff to do at start-up
> 
> Function "InitFunction"
>         Exec    "I"     xsetroot -solid "#266294"
> #       Exec    "I"     xsetroot -solid Darkred
>         Module  "I"     GoodStuff
> #       Module  "I"     FvwmPager 0 0
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+0 -font 10x20 &
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+980 -font 10x20 &
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+1955 -font 10x20 &
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+0 -font 10x20 &
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+980 -font 10x20 &
>         Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+1955 -font 10x20 &
> EndFunction
> 
> Function "RestartFunction"
>         Exec    "I"     xsetroot -solid "#266294"
> #       Exec    "I"     xsetroot -solid Darkred
>         Module  "I"     GoodStuff
> #       Module  "I"     FvwmPager 0 0
> EndFunction
> ############################################################################

One of the possible equivalents for 2.2.3 and greater is:

AddToFunc StartFunction
+ I Exec xsetroot -solid "#266294"
+ I Module FvwmButtons

AddToFunc InitFunction
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+0 -font 10x20
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+980 -font 10x20
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+1955 -font 10x20
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+0 -font 10x20
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+980 -font 10x20
+ I Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+1955 -font 10x20

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 1 Feb 2002 12:15:24 +0100

> the equivilent of the six lines in the .fvwmrc file? 

I never used fvwm version 1 myself, so I can only take the syntax
as granted.

  Function "InitFunction"

becomes

  AddToFunc "InitFunction"
  + "I" Exec xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+980 -font 10x20

and so on.  Fvwm 2.2.x comes with a script that converts fvwm
version 1 config files to version 2.  It's called "fvwmrc_convert"
and even has its own man page.

> Current .fvwm2rc file
> AddToFunc "InitFunction"
> +             "I" Exec xsetroot -solid "#266294"
> +             "I" Module FvwmButtons
> 
> AddToFunc "RestartFunction" 
> +              "I" Exec xsetroot -solid "#266294"
> +              "I" Module FvwmButtons

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].