Subject: FVWM: GrabFocus?

From: KONTRA Gergely <[email-masked]>
Date: Tue, 8 Jan 2002 16:44:07 +0100 (CET)

Hi!

I'd like to give focus to newly popped up windows.
This works, but sometimes (often on startup) the cursor becomes a +, and
needs a click (I don't know why...)

Any idea?

+-[Kontra Gergely @ Budapest University of Technology and Economics]-+
| Email: CHANGED! [email-masked] [email-masked] (old)    |
| URL:   turul.eet.bme.hu/~kgergely    Mobile: (+36 20) 356 9656     |
+-------"Olyan langesz vagyok, hogy poroltoval kellene jarnom!"------+
.
Magyar php mirror es magyar php dokumentacio: http://hu.php.net

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Jan 2002 19:46:52 +0100

> needs a click (I don't know why...)

You probably have some function in your configuration file that
requires a window when no window has focus.  For example, if you
had

  AddToFunc StratFunction
  + I move

in your config file, the "move" operation doesn't know what window
to operate on and asks the user instead.  If you can find out the
responsible command, you can suppress the feedback by adding
"silent" before the command:

  + I silent move

But on the other hand you can probably just remove the command.
To pin it down a working approach would be to remove the commands
from your config file successively to find out which one causes
the problem.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].