Subject: FVWM: Borderless ICQ applet popups, Again

From: Marcus Lundblad <[email-masked]>
Date: Mon, 14 Jan 2002 19:09:20 +0100 (CET)

I installed the latest snapshot as afviced (20020114).
And I tried to reproduce the unmanaged window problem, I never got an
unmanged window again, but once I got a popup saying something like:
XmPopup
XtGrabPointer failed

Now the window manager (or X) had hang (although ctrl-alt-backspace
worked, XFree86).
I run this applet from Netscape, so the message leads me to believe that
the origin of the problem is within (the statically linked) Motif
library of Netscape (4.76 on Linux x86).
The problem seems to arise because when you click on a contact 
a menu is popped up and on the second click (a double click) a message
dialog is opened (in a new window).
Maybe this window gets the menus properties of being unmanaged.
This would ofcourse be a bug in Netscape (not Fvwm).

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 11:43:50 +0100

On Mon, Jan 14, 2002 at 07:09:20PM +0100, Marcus Lundblad wrote:
> I installed the latest snapshot as

> afviced

Uh, what?

> (20020114).
> And I tried to reproduce the unmanaged window problem,
> I never got an unmanged window again,

Okay, that's a step in the right direction.

> but once I got a popup saying something like:
> XmPopup
> XtGrabPointer failed

Unless the window is placed manually, fvwm does not grab the
pointer when placing windows (although it grabs the server, but
that shouldn't make a difference here).  Maybe the client does
something wrong in the calls to 

> Now the window manager (or X) had hang (although ctrl-alt-backspace

If ctrl-alt-backspace still works, X does not hang.  This is
usually caused by an application grabbing the server and never
releasing it.  All other X programs appear to be frozen (including
the window manager).  Might that application be stupid enough to
grab the server and then grab the pointer?  Sou7nds a bit like
this.  If it would grab the server while another application had
grabben the pointer, the latter would never get the chance to
release the pointer again.

Can I get the source code of that application somewhere?

> This would ofcourse be a bug in Netscape (not Fvwm).

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Tue, 15 Jan 2002 14:09:27 +0100 (CET)

> > I installed the latest snapshot as
I meant "adviced" (sorry)

> something wrong in the calls to 

No, the window is not placed manually.
> Can I get the source code of that application somewhere?

This is a Java applet run in Netscape.
The URL to the applet is: http://web.icq.com/icqlite

Maybe it's possible to decompile the java byte code (I remeber I saw a
"decompiler" for Java byte code once).

> > This would ofcourse be a bug in Netscape (not Fvwm).

Bye.

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 14:31:52 +0100

> I meant "adviced" (sorry)

Oh, I thought that was one of these fancy abbreviations :-)

> "decompiler" for Java byte code once).

Urk!  It's a Java applet?  Come to think of it - maybe I don't
want to see the source code at all ;-)

Bye

Dominik ^_^  ^_^

---

From: Marcus Lundblad <[email-masked]>
Date: Tue, 15 Jan 2002 14:39:26 +0100 (CET)

> want to see the source code at all ;-)

I managed to decompile the applet (using a program called "jad")
I don't think I can give you the "source", that would probably be illegal
(although I already commited a crime by decompilation...)
But it's possible if tou really want....

(This reminds me of an old manual for building a modem for the VIC-20,
first there was a descriptoin on how to build a modem that you place
against the speaker of the phone.
Then came chapter 2 describing how to connect directly to the phone line.
It started: "This is illegal and you should not do this. OK, here how you
do it..." :) )

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 15 Jan 2002 16:02:11 +0100

> It started: "This is illegal and you should not do this. OK, here how you

It won't help since I can't see the X function calls.

Bye

Dominik ^_^  ^_^