Subject: FVWM: Re: simple .fvwm2rc that crashes fvwm on start

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Jan 2002 19:47:38 +0100

On Sun, Jan 06, 2002 at 10:20:39PM +0300, Alexander Kotelnikov wrote:
> He it is:
> 
> Style "default-style" HilightBack steelblue
> Style "*" UseStyle "default-style"
> Style "*" UseStyle "default-style"
> Style "*" UseStyle "default-style"

Doesn't crash for me.  Which version are you using?  Can you fetch
a stack trace?

  $ gdb fvwm2 core
  (gdb) where

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alexander Kotelnikov <[email-masked]>
Date: Mon, 07 Jan 2002 22:13:15 +0300

>>>>> On Mon, 7 Jan 2002 19:47:38 +0100
>>>>> "Dominik" == Dominik Vogt <[email-masked]> wrote:
Dominik> 
>> Style "*" UseStyle "default-style"
Dominik> 
Dominik> Doesn't crash for me.  Which version are you using?  Can you fetch
Dominik> a stack trace?
Dominik> 
Dominik>   $ gdb fvwm2 core
Dominik>   (gdb) where

I use fvwm-2.4.4, it crashed whan it was 2.4.0 also.

(gdb) where
#0  0x401c9239 in malloc () from /lib/libc.so.6
#1  0x401c9094 in malloc () from /lib/libc.so.6
#2  0x400d8d07 in _XlcCreateLocaleDataBase () from /usr/X11R6/lib/libX11.so.6
#3  0x400d8e45 in _XlcCreateLocaleDataBase () from /usr/X11R6/lib/libX11.so.6
#4  0x400d6293 in _XlcCreateDefaultCharSet () from /usr/X11R6/lib/libX11.so.6
#5  0x400d66ec in _XlcSetConverter () from /usr/X11R6/lib/libX11.so.6
#6  0x400d67ee in _XlcOpenConverter () from /usr/X11R6/lib/libX11.so.6
#7  0x400eb40b in _XomInitConverter () from /usr/X11R6/lib/libX11.so.6
#8  0x400ea254 in _Xutf8GenericDrawString () from /usr/X11R6/lib/libX11.so.6
#9  0x400ea32b in _XmbGenericTextEscapement () from /usr/X11R6/lib/libX11.so.6
#10 0x400a515f in XmbTextEscapement () from /usr/X11R6/lib/libX11.so.6
#11 0x0806e3c8 in XMapRaised ()
#12 0x08086512 in XMapRaised ()
#13 0x4017465f in __libc_start_main () from /lib/libc.so.6

actually this is for fvwm configured as follows:
        ./configure  --prefix=/usr\
        --sysconfdir=/etc/X11/fvwm --bindir=/usr/X11R6/bin\
        --libexecdir=/usr/X11R6/lib/X11 --libdir=/usr/X11R6/lib/X11\
        --mandir=/usr/X11R6/man --without-gnome\
        --without-rplay-library --without-stroke-library\
        --enable-multibyte

If I remove '--enable-multibyte' stack content looks like

(gdb) where
#0  0x401c9239 in malloc () from /lib/libc.so.6
#1  0x401c9094 in malloc () from /lib/libc.so.6
#2  0x40040d9d in IceRegisterForProtocolSetup ()
   from /usr/X11R6/lib/libICE.so.6
#3  0x4002e2ad in SmcOpenConnection () from /usr/X11R6/lib/libSM.so.6
#4  0x0808314e in XMapRaised ()
#5  0x080860a5 in XMapRaised ()
#6  0x4017465f in __libc_start_main () from /lib/libc.so.6

-- 
Alexander Kotelnikov
Saint-Petersburg, Russia

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Jan 2002 11:24:10 +0100

> #13 0x4017465f in __libc_start_main () from /lib/libc.so.6

Funny, that doesn't look like an fvwm stack trace at all.  Did you
compile fvwm with full debug info?  Does gdb say that the core
file was generated by fvwm?  This really looks as if the libc
started an X application on its own.  There must be some kind of
reference to the program somewhere.

Bye

Dominik ^_^  ^_^