Subject: FVWM: Synchronous command execution

From: "Pier Paolo Glave" <[email-masked]>
Date: Thu, 17 Jan 2002 12:08:29 +0100

Hi all,

Is it possible to let fvwm wait for a command completion, or pause for
a certain amount of milliseconds, before executing the following action?

I'm looking for this kind of feature, because in my RestartFunction I have
this kind of operation sequence:

+ I FvwmM4 <file_to_be_read_with_FvwmM4>
+ I <function_which_is_declared_in_that_file>

and the sequence appears to be not synchronized (the function is not
executed
because not yet read, I think).

I tried with FakeClick wait <milliseconds>, but with no success.

Thank you for your help!

--
Pier

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Thu, 17 Jan 2002 12:21:25 +0100

> + I <function_which_is_declared_in_that_file>

You may try to run FvwmM4 as follows:

ModuleSynchronous FvwmM4 -lock <file_to_be_read_with_FvwmM4>

I am not sure that this will work.

Olivier

---

From: "Pier Paolo Glave" <[email-masked]>
Date: Thu, 17 Jan 2002 13:18:44 +0100

----- Original Message ----- 
From: "Olivier Chapuis"

> I am not sure that this will work.

Yes, it does!
Thank you very much for the hint.

Pier