Subject: Re: FVWM: how to upgrade fvwm 2.0.x to 2.4.4

From: Dan Espen <[email-masked]>
Date: Fri, 11 Jan 2002 09:42:32 -0500

Srivathsa Rao U <[email-masked]> writes:
> Dan Espen wrote:
> > Srivathsa Rao U <[email-masked]> writes:
> > > hello,
> > >
> > >     I have downloaded the fvwm 2.4.4 . Now im using 2.0.43 , how to
> > > upgrade this to 2.4.4 . I need to install it or any other way to upgrade?
> >
> > After you install 2.4.4, you will find it contains 2 conversion
> > scripts, fvwmrc_convert and fvwm24_convert.  These 2 scripts
> > will change your .fvwm2rc file so that it works with 2.4.4.
> >
> > Read the man page for both scripts.
>     thanx for ypur prompt reply.
> 
>     I have installed fvwm2.4.4 & i ran fvwm24_convert script i got fvwm2rc .
>     But when i invoked fvwm, my modules & all not comming. (Task bar, button
> bar etc. are not comming.)
> some where i read that module path compliled in fvwm. in which step it
> will do. & from where it will take.
> How i can get back that modules & if i want change the prperties like
> geometry , size where should i do this
> 
> pls update me asap.

Hi,

Since you started with 2.0.43, you should first run fvwmrc_convert
and then run fvwm24_convert.  Since neither conversion is perfect,
you should look at each file after the conversion.

After the conversions, there should not be a ModulePath statement
in your config file $HOME/.fvwm/.fvwm2rc.  If there is, remove it.

Also look for error messages being printed by fvwm during startup
on your console.

If you are still having problems, post the parts of your config
file that are not working.  To start a module, you should have
something like this in your config file:

AddToFunc StartFunction "I" Module FvwmTaskBar

PS: Please don't send html to this list, some of the readers
of this list don't like it.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 11 Jan 2002 16:37:46 +0100

> of this list don't like it.

... I can't even read it.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].