Subject: FVWM: Working around netscrape "features"

From: szonyi calin <[email-masked]>
Date: Mon, 28 Jan 2002 10:21:17 +0100 (CET)

Hi
I would like to work around a Netscape behaviour which
is really desgusting.
This is what's happenning:
I surf the net with netscape, have some windows
openned
on various sites and i decide i wanna see some news
and
go to www.google.com (and others). I type the url in 
the location bar, press enter and switch to another
 window. After some time the window with google raises
and take focus automatically. Is there a way to stop 
this ? .
I have focusfollow mouse but i saw the same behaviour 
on windoze so i think in OS independent.
The question is: Is there a way to tell fvwm to ignore
this (eventually to make a Click to focus _only_ for
netscape ? ) ?
Thanks
Bye

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.fr
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Mon, 28 Jan 2002 01:34:25 -0800

> this (eventually to make a Click to focus _only_ for

  quite a few programs on ms win are this annoying but I haven't noticed
anything like this under linux&fvwm (at least not with netscape).

  it might be something in your configuration (I also use focus follow
mouse). which version of fvwm you use?

	erik

---

From: szonyi calin <[email-masked]>
Date: Mon, 28 Jan 2002 11:04:50 +0100 (CET)

--- Erik Steffl <[email-masked]> a écrit : >
> anything like this under linux&fvwm (at least not

there are specific sites at which this problem occur:
groups.google.com, www.hotmail.com
If you have a very fast internet connexion you won't
notice that.
The window is raising when it is loading. You can see
this problem _if you have a slow internet connexion 
and switch to another window when the other page is
loading_.
It seems (it's just a speculation) that netscape
issues
some kind of MapRequest (as described in the FAQ at
Q5.7)

> mouse). which version of fvwm you use?

fvwm 2.4.3

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jan 2002 12:54:27 +0100

> this (eventually to make a Click to focus _only_ for

Which netscape version do you have?

You can tell fvwm not to give netscape windows the focus
automatically:

  Style Navigator GrabFocusOff, GrabFocusTransientOff

You also can also start new netscape windows below all other
windows, but this is probably a bit inconvenient:

  Style Navigator StartsLowered

If you know the precise name of the annoying windows you could use
that name in the style to limit it to only these windows:

  Style "*The World's FREE Web-based E-mail*" StartsLowered

Does any of this help?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Mon, 28 Jan 2002 13:58:23 +0100 (CET)

--- Dominik Vogt <[email-masked]> a écrit : > On Mon,
Jan 28, 2002 at 10:21:17AM +0100, szonyi
> calin wrote:

4.77, 4.78, 4.79 -- all the same

>   Style "*The World's FREE Web-based E-mail*"

No, the same behaviour.
I was debugging the problem with xev
Here are the results:
cristi@spaceborne:~/vnc_x86_linux_2.0$ xev -id
0xc00572

EnterNotify event, serial 9, synthetic NO, window
0xc00572,
    root 0x25, subw 0xc00573, time 2904672237,
(271,18), root:(342,427),
    mode NotifyNormal, detail NotifyNonlinearVirtual,
same_screen YES,
    focus NO, state 0

KeymapNotify event, serial 9, synthetic NO, window
0x0,
    keys:  37  0   0   0   0   0   0   0   0   0   0  
0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0  
0   0   0   0   0   

FocusIn event, serial 9, synthetic NO, window
0xc00572,
    mode NotifyNormal, detail NotifyNonlinear

KeymapNotify event, serial 9, synthetic NO, window
0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0  
0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0  
0   0   0   0   0   

VisibilityNotify event, serial 9, synthetic NO, window
0xc00572,
    state VisibilityUnobscured

LeaveNotify event, serial 9, synthetic NO, window
0xc00572,
    root 0x25, subw 0xc00573, time 2904673211,
(443,-3), root:(514,406),
    mode NotifyNormal, detail NotifyNonlinearVirtual,
same_screen YES,
    focus YES, state 0

FocusOut event, serial 9, synthetic NO, window
0xc00572,
    mode NotifyNormal, detail NotifyNonlinear

PropertyNotify event, serial 9, synthetic NO, window
0xc00572,
    atom 0xb9 (_MOTIF_DRAG_RECEIVER_INFO), time
2904673526, state PropertyNewValue

PropertyNotify event, serial 9, synthetic NO, window
0xc00572,
    atom 0xe1 (_MOZILLA_URL), time 2904673532, state
PropertyNewValue

PropertyNotify event, serial 11, synthetic NO, window
0xc00572,
    atom 0x27 (WM_NAME), time 2904673579, state
PropertyNewValue

PropertyNotify event, serial 11, synthetic NO, window
0xc00572,
    atom 0x25 (WM_ICON_NAME), time 2904673579, state
PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window
0xc00572,
    atom 0xb9 (_MOTIF_DRAG_RECEIVER_INFO), time
2904673685, state PropertyNewValue

PropertyNotify event, serial 13, synthetic NO, window
0xc00572,
    atom 0xb9 (_MOTIF_DRAG_RECEIVER_INFO), time
2904673709, state PropertyNewValue

VisibilityNotify event, serial 13, synthetic NO,
window 0xc00572,
    state VisibilityPartiallyObscured

PropertyNotify event, serial 13, synthetic NO, window
0xc00572,
    atom 0xb9 (_MOTIF_DRAG_RECEIVER_INFO), time
2904674391, state PropertyNewValue

VisibilityNotify event, serial 13, synthetic NO,
window 0xc00572,
    state VisibilityUnobscured

ConfigureNotify event, serial 13, synthetic YES,
window 0xc00572,
    event 0xc00572, window 0xc00572, (70,408), width
916, height 354,
    border_width 1, above 0x400128, override NO

ConfigureNotify event, serial 13, synthetic YES,
window 0xc00572,
    event 0xc00572, window 0xc00572, (70,408), width
916, height 354,
    border_width 1, above 0x400128, override NO

VisibilityNotify event, serial 13, synthetic NO,
window 0xc00572,
    state VisibilityPartiallyObscured

----
it seems that Netscape issues a VisibilityNotify event
which makes the window to appear on top of the others

Bye
Thanks

---

From: E Frank Ball <[email-masked]>
Date: Mon, 28 Jan 2002 07:24:31 -0800

On Mon, Jan 28, 2002 at 10:21:17AM +0100, szonyi calin wrote:
} go to www.google.com (and others). I type the url in 
} the location bar, press enter and switch to another
}  window. After some time the window with google raises
} and take focus automatically. Is there a way to stop 
} this ? .

Turn off Javascript in Netscape.

-- 

   E Frank Ball                [email-masked]

---

From: szonyi calin <[email-masked]>
Date: Mon, 28 Jan 2002 16:33:29 +0100 (CET)

--- E Frank Ball <[email-masked]> a écrit : > On
Mon, Jan 28, 2002 at 10:21:17AM +0100, szonyi

Thanks