Subject: FVWM: Appearence of feedback windows.

From: Marcus Lundblad <[email-masked]>
Date: Thu, 17 Jan 2002 23:02:45 +0100 (CET)

Is there any chance that it could be possible to change the appearence of
the move and resize feedback windows in a future version (I believe it's
currently not possible, or did I miss something?)
For example to show (x, y) instead of +x +y as it does now.
There could be options to leave out the plus sign for positive values for
exaple, maybe with some sort of format string.

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Jan 2002 23:38:11 +0100

> exaple, maybe with some sort of format string.

That would be quite easy to do.  The format string is defined in
libs/defaults.h:

  #define GEOMETRY_WINDOW_POS_STRING         " %+-4d %+-4d "

At the moment, you would have to change that string to

  #define GEOMETRY_WINDOW_POS_STRING         " (%-4d, %-4d) "

It would be no problem to make that string configurable.  However,
there would be a wide range of possible misuse since this string
is directly passed to sprintf().

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 18 Jan 2002 13:19:48 +0100 (CET)

>   #define GEOMETRY_WINDOW_POS_STRING         " (%-4d, %-4d) "

Just out of curiosity, what is 
#define GEOMETRY_WINDOW_STRING             " +8888 x +8888 "
used for, is it to compute the width of the feedback windows. Since this
is the most wide string that could appear?

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 18 Jan 2002 14:41:54 +0100

> is the most wide string that could appear?

Yes, exactly.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].