Subject: FVWM: Automatically starting xterms on startup of fvwm2.2.4

From: David Crisp <[email-masked]>
Date: Fri, 1 Feb 2002 11:21:27 +1100 (EST)

Ive just converted over to a new install of Debian 2.2r4 which uses fvwm
2.2.4. 

Below are the relevant sections of my .fvwmrc ( 1.24r)  and the new
.fvwm2rc (2.2.4)  files.  on my original setup I had 6 lines in the
InitFunction which were there to fire up 6 Xterms on the desktop in
prearanged places.  This worked fine. (Im not sure if it was the right way
of doign things.  but it worked and I never had any problem with it). 
WHen I converted over to 2.2.4, and include the six lines in the
InitFunction they dont work.  My questions are: 

1)  Is there a better way of doing that 
2)  Is there somethign blindingly obvious im missing 
3)  How do I do the equivilent in a 2.2.4 .fvwm2rc file. 
    What do I have to add to the initfunction ion the .fvwm2rc file to do
the equivilent of the six lines in the .fvwmrc file? 

Current .fvwmrc file
#############################################################################

# Stuff to do at start-up

Function "InitFunction"
        Exec    "I"     xsetroot -solid "#266294"
#       Exec    "I"     xsetroot -solid Darkred
        Module  "I"     GoodStuff
#       Module  "I"     FvwmPager 0 0
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+0 -font 10x20 &
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+980 -font 10x20 &
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+0+1955 -font 10x20 &
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+0 -font 10x20 &
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+980 -font 10x20 &
        Exec    "I"     xterm -ls -rv +vb -sb -T xterm -sl 1000 -geometry 114x47+1280+1955 -font 10x20 &
EndFunction

Function "RestartFunction"
        Exec    "I"     xsetroot -solid "#266294"
#       Exec    "I"     xsetroot -solid Darkred
        Module  "I"     GoodStuff
#       Module  "I"     FvwmPager 0 0
EndFunction
############################################################################

Current .fvwm2rc file

#############################################################################
# Stuff to do at start-up

AddToFunc "InitFunction"
+             "I" Exec xsetroot -solid "#266294"
+             "I" Module FvwmButtons

AddToFunc "RestartFunction" 
+              "I" Exec xsetroot -solid "#266294"
+              "I" Module FvwmButtons
############################################################################

Regards, 

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Thu, 31 Jan 2002 20:03:22 -0800

> of doign things.  but it worked and I never had any problem with it).

  IMO it makes more sense to start the xterms from X startup instead of
fvwm startup files.

  That way you don't have to worry about restarting fvwm, starting
another wm, changes in fvwm configuration files etc.

	erik