Subject: FVWM: Re: your mail

From: Anton Kazennikov <[email-masked]>
Date: Thu, 17 Jan 2002 14:06:28 +0300

I want to customize the windowlook. And when I set the button styles using ActiveUp,ActiveDown,Inactive, for example:
AddButtonStyle 2 ActiveUp Pixmap button/wm-window-close.xpm
AddButtonStyle 2 ActiveDown Pixmap button/wm-window-close-pressed.xpm
AddButtonStyle 2 Inactive Pixmap button/wm-window-close.xpm
I get a delay between pushing button and the action what is performed. Can I change that?
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 17 Jan 2002 13:52:48 +0100

> I get a delay between pushing button and the action what is performed. Can I change that?

That depends on what action you have bound to the button.  If it
is a complex function with a double click action, fvwm can not
determine if you made a spimple or a double click until the
specified ClickTime was exceeded:

  ClickTime 500
  AddToFunc func1
  + C Raise
  + D Lower
  Mouse 1 3 N func1

The example above waits 500 milliseconds after a click before
actually raising the window.  The next one raises the window
immediately:

  ClickTime 500
  AddToFunc func1
  + C Raise
  Mouse 1 3 N func1

You can also use a smaller value for ClickTime (see man page).
The default value is 150.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].