Subject: FVWM: Bug or (l)user error ?

From: szonyi calin <[email-masked]>
Date: Fri, 25 Jan 2002 11:37:55 +0100 (CET)

Hi
We have a server with fvwm 2.4.3 and we are
experiencing the following problems:
1. Sometimes the menus and keybindings in fvwm stop
working. The only solution is to kill X (CTRL + ALT +
Backspace) and restart X (4.1.0).
2. Sometimes we cannot write text in any application
until we kill Netscape. It seems like Netscape is
keeping focus (Style is FocusFollowMouse) and the WM
(fvwm) refuses to switch (keyboard) focus to the
window
where the mouse pointer is in (example: an xterm 
window)
If you want i can send the config files.
System is:
Slackware 8.0, Kernel 2.4.16, X 4.1.0 (compiled from
source) , Fvwm 2.4.3 (compiled from source), gcc
2.95.3
CFLAGS='-O2 '
Thanks 
Bye

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.fr
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 25 Jan 2002 11:59:54 +0100

>From our FAQ:

---------------------------------------------------------------------
0.1  A few minutes after fvwm is started my keyboard and mouse
     bindings stop working.  What can I do?

A: Probably your NumLock, CapsLock or ScrollLock key is pressed.  See
   Q 5.5 for more details.
---------------------------------------------------------------------

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Fri, 25 Jan 2002 12:32:34 +0100 (CET)

--- Dominik Vogt <[email-masked]> a écrit : > On Fri,
Jan 25, 2002 at 11:37:55AM +0100, szonyi
> calin wrote:
> A: Probably your NumLock, CapsLock or ScrollLock key

I was reading the FAQ before posting the NumLock 
CapsLock or ScrollLock are _not_ pressed.
What's happening is that the menu from .fvwm2rc in no
 longer  prezent when we press the left mouse button 
in the root window but instead the builtin menu is
there which is quite strange. 
bye

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Jan 2002 07:44:01 -0500

> > > Backspace) and restart X (4.1.0).

Do you have a key, mouse, or menu that would cause Fvwm
to be restarted without reading the users .fvwm2rc?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Fri, 25 Jan 2002 14:48:08 +0100 (CET)

--- Dan Espen <[email-masked]> a écrit : >
szonyi calin <[email-masked]> writes:
> > > > working. The only solution is to kill X (CTRL
> +
> > > ALT +
> > > 0.1  A few minutes after fvwm is started my
> keyboard
> > > and mouse
> > > A: Probably your NumLock, CapsLock or ScrollLock
> key
> > > is pressed.  See
> > >    Q 5.5 for more details.
> > > 
> > 

No
Atached is .fvwm2rc (dos text -- sorry -- the original
 is linux text but i had to convert it to dos so i can
 read it in dos and atach it)
Bye

# Font configuration
#
# WindowFont 		Sets the font to be used in window title-bars
#
# IconFont		Sets the font that will be used for icon labels.
#
WindowFont	-adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
IconFont	-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

# HighlightColor
#
# This sets the textcolor and background color for the active window
# Format: HilightColor textcolor backgroundcolor
HilightColor #ffffff #0000ff 
#HilightFore #00ff00
#HilightBack #ff0000
#HilightBorderColorset #0000ff

# BorderStyle

TitleStyle ActiveDown Solid #7777ff -- flat
TitleStyle Inactive Solid  #888800 -- flat
TitleStyle LeftJustified height 16

# Button Styles
#
# X
AddButtonStyle 2 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# max
AddButtonStyle 4 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
# <->
AddButtonStyle 6 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1
# v
AddButtonStyle 8  4 50x75@1 25x25@1 75x25@1 50x75@0

# MenuStyle
#
#
# Background sets the default menu background color
#
# ActiveFore sets the foreground color of the currently selected menu-item
#
# ForeGround sets the foreground color of non-selected menu-items
# 
# Popupoffset sets the offset of child-menus.  
#   Format: Popupoffset pixels percent
#	We set the percent to 100, making the child-menus pop-up to the right
#	of the existing menus.
#
# MenuFace sets the background of the menu using the 'fancy' options.
# 	Menuface is another complicated one so again, check the man-page,
#	but I'll explain the one here:
#	This menuface command sets the background of the menus to a 
#	   Horizontal gradient using 64 colors, with one pair of colors,
#	   from the color #758591 to the color #102030.
#	
# Animation turns menu animations on.  If you pop-up a submenu on the right
# 	edge of the screen, the menu will move over so it is fully visible.
#
MenuStyle * Background #7777ff, Foreground #222222, ActiveFore blue 
MenuStyle * popupoffset 0 100, HilightBack
MenuStyle * MenuFace Solid #777888, Animation, BorderWidth 0
MenuStyle * Hilight3DOff, SeparatorsLong, VerticalItemSpacing 20

# Set up some desktop options
# 
# Desktop [Horizontal]x[vertical]  Defines the virtual desktop size, 
#	1x1 = one physical screen size (no virtual desktop
DesktopSize	3x3

# EdgeResistance scrolling moving
#   Sets how hard it is to change the desktop viewport
#   scrolling is in milliseconds 
#   moving is in pixels (how far a window's edge must move to move off-screen
#
# These values don't much matter in this configuration as our viewport
# is only as big as our screen anyway.
EdgeResistance	500 75

# EdgeScroll horizontal vertical
#   Sets the percentage of a page to scroll when the cursor is on the edge
#   of the screen.   Again, not useful in this configuration since we only
#   have a viewport as big as our screen.
EdgeScroll	100 100

# OpaqueMoveSize percentage
#   This option tells fvwm the maximum size window that it should move
#   with contents intact (ie, not 'rubber-banding')  You should keep this
#   low if you don't have good video hardware.
OpaqueMoveSize 50

# Style related options
#
# Styles are used to set-up how windows are treated by the window manager.
# They allow you to change the way windows are placed, decorated and treated
# in general.  You can give different options to different windows, so that
# your xterms may be decorated differently than, say, your netscape window.
# 
# The format of the style commands are:
# 	Style windowname options
#
# The windowname is the window's name class or resource string that you want
# this option to affect.  You can use wildcards (such as * or ?), thus 
# "*" specifies options for all windows.
# The options that you can specify with the Style command are many and varied
# and really warrant a look at the fvwm2 man page.
#
#  We set up some global defaults here for all windows.
Style "*" ForeColor black
Style "*" BackColor #888888
#Style "*" SmartPlacement
Style "*" MinOverlapPlacement
Style "*" StickyIcon
Style "*" IconBox	5 -50 -134 -5
Style "*" BorderWidth 1, HandleWidth 1
Style "*" NoPPosition
Style "*" NakedTransient
Style "*" DecorateTransient

# Some Fvwm-Related Styles
Style "Fvwm*"	NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmWinList"	 BorderWidth 0, Handlewidth 0
Style "FvwmPager"	BorderWidth 0, StaysOnTop,Nohandles, NoTitle
Style "FvwmButtons"  NoTitle, NoHandles, Sticky, WindowListSkip,BorderWidth 5
# My own settings
Style "XTerm"	BorderWidth 1, Handlewidth 1, Icon Monitor.xpm UseStyle DecorDemo
Style "Netscape*" BorderWidth 1, Handlewidth 1, StartsOnPage 1 1, SkipMapping
Style * RecaptureHonorsStartsOnPage, CaptureHonorsStartsOnPage
Style "*clock"	BorderWidth 0,NoTitle,NoHandles,WindowListSkip,Sticky
#Style "kicq"	Sticky, NoTitle, WindowListSkip
Style "*Dialog_popup" WindowListSkip
Style "*Download" WindowListSkip
Style "xbiff"	NoTitle,BorderWidth 0,NoHandles,WindowListSkip,Sticky
Style gv StartsOnPage 1 1, SkipMapping
Style xpdf StartsOnPage 2 0, SkipMapping
Style X-Chat StartsOnPage 0 1, SkipMapping
Style "xmms*" NoTitle

# Resources for Modules
# 
# Resources are usually of the form
# *ModulenameOption value
# 
# Resources are used to configure fvwm modules. See the man page for each
# module to find out what resources you can set
#
# FvwmPager

*FvwmPagerBack #777888
*FvwmPagerFore #cccccc
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #7777ff 
*FvwmPagerDeskTopScale 25 
*FvwmPagerGeometry -0-0
*FvwmPagerSmallFont 5x8
*FvwmPagerColumns 1
*FvwmPagerLabel * virtual
*FvwmPagerBalloons Pager
*FvwmPagerBalloonfore #0000ff 
#*FvwmPager: WindowBorderWidth 0
*FvwmPager: NoSeparators
*FvwmPager: ShapeLabels

#------------------ Identify
*FvwmIdentBack #000080
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

#FvwmAnimate
*FvwmAnimateEffect Turn 

# Function definitions
# 
# Functions let you define more complex events than fvwm provides
#  in it's default configuration.  It allows you to do multiple things
#  when something happens... for example.  The following function
#  can be used on the titlebar of a window, and will allow you to move,
#  raise or windowshade a window when you move, click, or doubleclick 
#  the titlebar, respectively. 
AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" Maximize 100 100

AddToFunc "Move-or-Iconify" "M" Move
+              "D" Iconify
+              "C" RaiseLower

AddToFunc "Resize-or-Raise" "M" Resize
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

AddToFunc "InitFunction" "Immediate" Module FvwmPager 0 0
+		"Immediate" Module FvwmAuto 750
+              "Immediate" Exec xsetroot -solid \#777888
+              "Immediate" Desk 0 0
+              "Immediate" Module FvwmAnimate
#+		"Immediate" Exec  rclock -geometry 74x74-100-0 -bg \#777888 -fg black
#+		"Immediate" Exec /usr/X11R6/bin/xv -root /home/marius/etc/gfx/sunset01.jpg -quit
+		"Immediate" Exec xclock -update 1 -geometry 106x106-120-0 -bg \#777888 -fg white -hl blue

AddToFunc "RestartFunction" "Immediate" Module FvwmPager 0 0
+              "Immediate" Exec xsetroot -solid \#777888
+	       "Immediate" Module FvwmAuto 750
+              "Immediate" Module FvwmAnimate
#+		"Immediate" Exec /usr/X11R6/bin/xv -root /home/marius/etc/gfx/sunset01.jpg -quit

# Popup menus
# 
# Now we start defining menus.  The Window-popups are used for 
# window-operations.
# 
# Application and root-menu definitions come later

AddToMenu "Window-Popup" "Window Ops" Title
+              "Move" Function Move-or-Raise
+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
+              "Lower" Lower
+              "(De)Iconify" Iconify
+              "(Un)Stick" Stick
+              "(Un)Maximize" Function maximize_func
+              "Identify" Module FvwmIdent
+              "" Nop
+              "Destroy" Destroy
+              "Close" Close
+              "" Nop
+              "Refresh Screen" Refresh

AddToMenu "Window-ops-Popup" 
+              "Move to" Popup mv-to
+		"Move" Function Move-or-Raise
#+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
#+              "Lower" Lower
+              "Iconify" Iconify
#+       $      "(Un)Stick" Stick
#+              "Identify" Module FvwmIdent
+              "" Nop
+              "Destroy" Destroy
+              "Close" Close
#+              "" Nop
#+              "Scrollbar" Module FvwmScroll 2 2

AddToMenu "mv-to" 
+		"pag 1" MoveToPage 0 0
+		"pag 2" MoveToPage 1 0
+		"pag 3" MoveToPage 0 1
+		"pag 4" MoveToPage 1 1
+		"pag 5" MoveToPage 0 2
+		"pag 6" MoveToPage 1 2

# Key bindings
#   
#  Now we set-up some hot-keys.  
#  The format for Key-bindings is:
#
#  Key keyname context modifier function
#
#  context describes where the binding applies, W for an application window,
#     R for root window, A for anywhere, T for title, etc.
#  modifier is keyboard meta-keys which should be pressed, N for none,
#     S for Shift, M for Meta, C for Control, or A for any. You can combine
#     these, so things like SM (shift-Meta) are valid.
#
Key w W M Iconify 
Key w I M Iconify 
Key F4 W M Close 
Key F11 A C Exec exec xlock -mode matrix &
Key F9 A M Desk 0 0
Key F10 A M Desk 0 1
Key F11 A M Desk 0 2
Key F12 A M Desk 0 3

# These are some neat ones.  They allow you to hit control-<Arrow-key>
# to switch focus to the window next to your current window in that direction.
# Some people don't like this, if you don't, comment out these lines
#
Key Right A C Direction East (CurrentDesk !Iconic) Focus
Key Left A C Direction West (CurrentDesk !Iconic) Focus
Key Up A C Direction North (CurrentDesk !Iconic) Focus
Key Down A C Direction South (CurrentDesk !Iconic) Focus

# Familiar alt-tabbing
Key Tab A M Next (CurrentDesk !Iconic) Focus
Key Tab A SM Prev (CurrentDesk !Iconic) Focus
#close
Key 0 A M Quit

# Mouse bindings
# 
# Mouse bindings work in very much the same way as key bindings
#
# Format:  Mouse Button Context Modifiers function
# 
Mouse 1 R N Menu "Utilities" Nop
Mouse 2 R N Menu "Window-Popup" Nop 
Mouse 3 R N Module FvwmWinList transient

#title bar
#Mouse 0 	1       A       Function "window_ops_func"
#Mouse 0 	2       A       Maximize 100 100
#Mouse 0 	4       A       Iconify

#Mouse 1 1 N Iconify 
Mouse 1 1 N Menu "Window-ops-Popup" Nop 

Mouse 1 4 N Maximize 100 100
#Mouse 3 2 N Function "Resize-or-Raise"

Mouse 1 6 N Maximize 100 0
#Mouse 1 6 N Maximize 100 0
Mouse 1 2 N Delete 
Mouse 1 8 N Iconify

Mouse 1 T N Function "Move-or-Raise"
Mouse 1 SF N Function "Resize-or-Raise"
Mouse 3 T N RaiseLower 
Mouse 1 I N Function "Move-or-Iconify"
Mouse 3 I N Function "Move-or-Iconify"
Mouse 2 TSFI N Menu "Window-ops-Popup" Nop
Mouse 3 S N Function "Move-or-Iconify"

#
# Some Example Menus
#
#
DestroyMenu "Utilities"
AddToMenu "Utilities" "Utilities" Title
+              "Rxvt" Exec rxvt -ls +sb  
#+              "xterm" Exec xterm -ls +sb  
#+		"Vim" Exec rxvt -bg black -fg blue -e vim 
+              "" Nop
+              "Internet" Popup Internet-Popup
+              "Aplicatii" Popup Aplicatii-Popup
+              "Ssh" Popup ssh-Popup
+              "" Nop
+		"Lock" Exec xlock -mode nose
+              "Refresh" Refresh
+              "Quit X" Popup Quit-Verify

DestroyMenu "Internet-Popup"
AddToMenu "Internet-Popup"  "Netscape" Exec /usr/bin/netscape 
+		"Xchat"		Exec xchat
+		"Y!"		Exec ymessenger
#+		"Kicq"		Exec /opt/kde/bin/kicq
#+		"Licq"		Exec /usr/local/bin/licq
#+		"ag"		Exec cd /home/marius/.ag/ ; ag

DestroyMenu "Aplicatii-Popup
AddToMenu "Aplicatii-Popup"
+              "Gv" Exec gv 
+              "Xpdf" Exec xpdf 
#+	       "Xmag" Exec xmag
#+              "XView" Exec xv 
+              "Gimp" Exec gimp 
+		"Gvim" Exec gvim
+		"Xmms" Exec xmms

DestroyMenu "ssh-Popup"
AddToMenu "ssh-Popup"  "Hpe" Exec xterm -e ssh -x -l marius 193.230.232.65
+              "Faraday" Exec xterm -e ssh -x -l marius 193.226.10.1
+              "Meo" Exec xterm -e ssh -x -l marius 193.226.10.33 
+              "Hermes" Exec xterm -e ssh -x -l marius 193.226.10.90 

DestroyMenu
AddToMenu "Quit-Verify" "Restart" Restart
+              "Quit" Quit

################################
*FvwmWinListBack #777888
*FvwmWinListFore white
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1
*FvwmWinListButtonFrameWidth 0

---

From: Dan Espen <[email-masked]>
Date: Fri, 25 Jan 2002 09:05:24 -0500

szonyi calin <[email-masked]> writes:
> > >  --- Dominik Vogt <[email-masked]> a écrit : > On
> Atached is .fvwm2rc
...
> Key 0 A M Quit

If you hit this key by accident, does FVWM quit, or
do you have something in your .xinitrc to restart fvwm?
(possibly incorrectly)

> DestroyMenu

The menu name is missing from this command.
I don't see how it could cause a problem.

> AddToMenu "Quit-Verify" "Restart" Restart

Sorry, so far, I don't have any other ideas.
I'm sure someone else will though.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 27 Jan 2002 10:39:53 +0000

On 25 Jan 2002 14:48:08 +0100, szonyi calin wrote:
> > > Jan 25, 2002 at 11:37:55AM +0100, szonyi calin wrote:

I would still suggest that your keybindings stop working when one of the
modifiers returned by `xmodmap` on your system are pressed.

> Mouse 3 R N Module FvwmWinList transient

So, if some unknown modifier is pressed, "N" does not work. Use "A" - any.

  Mouse 1 R A Menu "Utilities" Nop
  Mouse 2 R A Menu "Window-Popup" Nop
  Mouse 3 R A Module FvwmWinList transient

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 27 Jan 2002 15:11:27 +0100

> where the mouse pointer is in (example: an xterm 

I think that is a bug in netscape, at least in the newer versions.
With netscape 4.x I never had such problems, but with netscape 6
or mozilla, netscape sometimes freezes the keyboard, the pointer
or even the whole X server while waiting for a connection.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: szonyi calin <[email-masked]>
Date: Mon, 28 Jan 2002 09:53:06 +0100 (CET)

--- Dominik Vogt <[email-masked]> a écrit : > On
Fri, Jan 25, 2002 at 11:37:55AM +0100, szonyi
> or even the whole X server while waiting for a

Thanks for the reply.

Bye