Subject: FVWM: config file for themes

From: "Ian Truelsen" <[email-masked]>
Date: Thu, 17 Jan 2002 02:12:22 GMT

I got fvwm working (many thanks to all who helped out), now I want to add 
some programs and such. Now, I am using one of the themes, Afterstep to be 
precise, and I don't really want to do all the heavy lifting of designing 
all the theme based stuff right now. Where do I find the fvwmrc file that is 
used by the theme? I haven't been able to find it with either a locate or 
find search. 

Ian. 

Ian Truelsen
Masters program in Philosophy
University of Manitoba, Winnipeg, Canada
BA (Wilfrid Laurier University)
Email: [email-masked] 

Current favourite quote:
"No great civilisation likes forests."
K.F. O'Connor
Lincoln College, Christchurch, New Zealand 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 17 Jan 2002 09:47:38 +0000

> used by the theme? I haven't been able to find it with either a locate or 

Please read the supplied doc/FAQ, it should answer most of your questions.
Since you installed from rpm, just run "rpm -ql fvwm-themes-base". But
you don't need to change themes. Usual things a user wants to customize:

1) Add startup programs. Solution: create ~/.fvwm/themes/personal/startup
which looks like:

  AddToFunc InitFunction
  + I Exec exec gtop
  + I FuncFvwmRunInXterm "Top" top  # one of the standard themed functions

2) Add your own menus. Solution: create ~/.fvwm/themes/personal/menus-extra
which looks like:

  AddToMenu MenuFvwmPersonal
  + "Something 1" something 1
  + "Something 2" something 2

Read the FAQ and other documentation in /usr/share/doc/fvwm-themes-0.6.0/
if you need to customize more things like the editor/terminal/browser used
or change/add more bindings.

Regards,
Mikhael.

---

From: Walter Dnes <[email-masked]>
Date: Thu, 17 Jan 2002 19:24:54 -0500

On Thu, Jan 17, 2002 at 02:12:22AM +0000, Ian Truelsen wrote
> used by the theme? I haven't been able to find it with either a locate or 

  Your "master" file is ~/.fvwm/.fvwm2rc

  It can contain multiple "Read" commands, which will read in
instructions from other files.  To get a menu to pop up, you have to
bind it to keyboard or mouse action.  Before you do, here's the most
common booby-trap in FVWM.  Make sure that the statement...

IgnoreModifiers L25

  is executed somwhere by fvwm.  This prevents shift/capslock/scrollock
from interfering.  I set {ALT-F10} to pop up "Mymenu"

Key F10 AT M Menu MyMenu Nop

  Oh yeah, we really should define "MyMenu".  The syntax for adding
programs is...

+ "visible label" Exec exec program-name

  You don't have to use the full path if PATH is set up properly, but I
was a bit pedantic when I was setting up.  Here's my main menu.  Use it
as a working example.  If you don't have one of the listed programs on
your system, it obviously won't run.  Modify to suit your needs.

AddToMenu MyMenu "My Menu" Title
+ "Root Menu"     Popup MenuFvwmRoot
+ "FVWM manuals"  Popup FvwmManPage
+ ""              Nop
+ "Citrix config" Exec exec /usr/lib/ICAClient/wfcmgr
+ "Citrix"        Exec exec /usr/lib/ICAClient/wfica
+ ""              Nop
+ "&AbiWord"      Exec exec /usr/bin/AbiWord
+ "&Gimp"         Exec exec /usr/bin/gimp
+ "&Mozilla"      Exec exec /misc/mozilla/mozilla
+ "&Netscape"     Exec exec /usr/bin/netscape
+ "&Spreadsheet"  Exec exec /usr/bin/gnumeric
+ ""              Nop
+ "&Realplayer"   Exec exec /usr/lib/RealPlayer8/realplay
+ "&XMMS"         Exec exec /usr/bin/xmms
+ ""              Nop
+ "&Freecell"     Exec exec /usr/bin/freecell
+ ""              Nop
+ "&Quit"         Quit

-- 
Walter Dnes <[email-masked]>
If you had purchased $1000 of @home stock in 1999, today you would
have $1.30.  If you had purchased $1000 of beer in 1999, today you
would still have $59 in empty cans.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].