Subject: FVWM: fvwm2 and other window managers

From: Neil Zanella <[email-masked]>
Date: Fri, 4 Jan 2002 01:50:59 -0330 (NST)

Hello,

It would be nice if it were possible to start other window
managers from within fvwm2 in such a way that when the started
window manager is exited fvwm2 is restored. This makes it possible
to test applications under different window managers without
having to exit each window manager individually and reopen
all the windows that were on the desktop.

Alternatively is there a way to exit fvwm2 without quitting X
so as to temporarily obtain undecorated windows.

BTW, thanks to all fvwm2 developers. Keep up the good work!

Thanks,

Neil

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Fri, 04 Jan 2002 00:28:11 -0800

> all the windows that were on the desktop.

  debian works that way, most of the WMs in debian have menu that
enables you to run other WM (WMs, like other apps, are automatically
added to system menu when they are installed).

  this is the relevant menu:

DestroyMenu "/Debian/WindowManagers"
AddToMenu "/Debian/WindowManagers" "WindowManagers" Title Top
+ "&9Wm" Restart 9wm
+ "&AfterStep" Restart /usr/X11R6/bin/afterstep
+ "A&fterstep Classic" Restart /usr/X11R6/bin/asclassic
+ "&Blackbox" Restart /usr/bin/blackbox
+ "&Ctwm" Restart ctwm
+ "&Enlightenment" Restart /usr/bin/enlightenment
+ "&Fvwm" Restart /usr/bin/X11/fvwm2
+ "&Gwm" Restart gwm
+ "&IceWM" Restart /usr/bin/X11/icewm
+ "&KDE" Restart /usr/bin/kde2
+ "&Modules" Popup "/Debian/WindowManagers/Modules"
+ "&Sawfish" Restart sawfish
+ "S&cwm" Restart /usr/bin/X11/scwm
+ "&Twm" Restart twm
+ "&Vtwm" Restart vtwm
+ "&Window Maker" Restart /usr/bin/wmaker
+ "&XFwm/XFce" Restart startxfce
+ "&aewm" Restart /usr/bin/aewm
+ "&lwm" Restart /usr/bin/X11/lwm
+ "&qvwm" Restart /usr/X11R6/bin/qvwm
+ "&uwm" Restart /usr/bin/X11/uwm
+ "&wm2" Restart /usr/bin/X11/wm2

  that's for fvwm, other WMs often have the same ability (not all, they
said kde wm cannot do that...)

> so as to temporarily obtain undecorated windows.

  that depends on how you start fvwm - if you start it as last command
in .xinitrc (in your home dir or system one or .xsession if you use xdm)
then X considers the exit of fvwm to be the end and quits - you would
need to replace fvwm with something else as last command (any X program
that wouldn't exit - xterm, xeyes, whatever, just remember that when you
quit that program X exits).

  I use xdm so I put the WM in ~/.xsession:

jojda:~...cvs/OpenRaider-0.0.2>cat ~/.xsession
# alternative to system, I just want to start x-window-manager,
# not x-session-manager

x-window-manager

# end

  x-window-manager is link to fvwm (debian alternatives system). if I
would want to use other program as 'anchor' I'd replace x-window-manager
line by something similar to the following lines:

x-window-manager& # starts in background
xterm             # when you quit this, X exits

  you can also:

  - start another X server (you can start plain X if you don't want
default window manager)

  - start nested X (never tried it)

  - start vncserver and use x vncviewer to view it within your current X
session (that's how I tested fvwm configuration)

  etc. there are probably other ways...

	erik

---

From: Dan Espen <[email-masked]>
Date: Fri, 04 Jan 2002 08:18:19 -0500

> so as to temporarily obtain undecorated windows.

I've always found this to be the simplest approach, in my .xinitrc:

loopwm fvwm2 &
exec xlogout -iconic

The shell "loopwm":

#first run the wm, then prompt for which one to run next":
wm=$@
while [ 0 ] ; do
  $wm
  wm=`xprompt -geometry +100+100 -re -warp -rlen 44 -p 'WM/end (fvwm2, twm, mwm, olwm)'`
  if [ $? != 0 ] ; then
    exit
  fi
  if [ "$wm" = "end" ] ; then
    exit
  fi
done

You'll probably need to download xprompt and  xlogout, for some reason
they are not included with most X packages.

xlogout holds the session, click on the icon, then
click on "logout" to exit X.
xprompt and loopwm lets  you start up any  window
manager or any other program in place of the window manager.
xprompt and loopwm also protect you from window manager crashes,
through I don't see many of those.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].