Subject: Re: FVWM: can't read feedback window

From: toshi isogai <[email-masked]>
Date: Wed, 2 Jan 2002 12:12:23 -0700

Dominik Vogt writes:
 > On Tue, Nov 06, 2001 at 09:58:24AM -0700, toshi isogai wrote:
 > > 
 > > I tried XmbTextEscapement and also XmbDrawString in move_resize.c but
 > > no luck. I am not sure how multibyte has some effect here. Window
 > > position and size information are always alpha-numeric. But when I
 > > recompiled without multibyte option, the feedback shows correctly...
 > > 
 > > As far as multibyte concerns, it works in popup menu but not in title.
 > 
 > 
 > I think we found that bug.  Could you try again with a recent
 > snapshot?
 > 

What a nice surprise from the beginning of the year!

I compiled 20020102 and feedback window works, title can handle kanji :)

Popup menu is a little weird. After I set the menu font, I can add a
menu with kanji correctly from FvwmCommand but if I include the same
exact command in .fvwm2rc, it won't show up correctly. The string is
not handled as multibyte characters. I thought the command will be fed
through the same process routine whether it was read from 
configuration file or invoked from FvwmCommand.

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 3 Jan 2002 11:24:26 +0100

> I compiled 20020102 and feedback window works, title can handle kanji :)

I thought your problem was about the size of the geometry window
in the first place. (?)

> configuration file or invoked from FvwmCommand.

That may depend on the characters in the command.  What does it
look like?  Are there any characters that may be treated
differently by the shell than by fvwm.  What is the exact command,
and what are your language related settings?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: toshi isogai <[email-masked]>
Date: Thu, 3 Jan 2002 09:32:40 -0700

> I thought your problem was about the size of the geometry window

My problem was that "can't read feedback window" in the first place.
And now it works correctly, I can read it. It is good. I am happy.

 > and what are your language related settings?

Never mind the popup issue. My XEmacs character coding was set
incorrectly. 

Everything I mentioned in this thread seems to work now. Thank you.

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499