Subject: FVWM: Menus

From: Anton Kazennikov <[email-masked]>
Date: Wed, 23 Jan 2002 14:38:00 +0300

I've got some troubles with menu style.
Can I make that menus are poped down only on a keypress, not on mouse motion?
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jan 2002 12:42:33 +0100

> Can I make that menus are poped down only on a keypress, not on mouse motion?

Can you please describe exactly what your problem is?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Anton Kazennikov <[email-masked]>
Date: Wed, 23 Jan 2002 16:44:04 +0300

On Wed, 23 Jan 2002 12:42:33 +0100
Dominik Vogt <[email-masked]> wrote:

>> Can I make that menus are poped down only on a keypress, not on mouse motion?

DV> Can you please describe exactly what your problem is?
When I move mouse cursor through the menu and the cursor is on triangle, a submenu pops up. I  want to popup submenus only on a mouse click. But they are popped up also on mouse move to the triangle.
Can I do that?
--
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 23 Jan 2002 14:56:54 +0000

On 23 Jan 2002 16:44:04 +0300, Anton Kazennikov wrote:
> >> I've got some troubles with menu style. Can I make that menus are
> >> poped down only on a keypress, not on mouse motion?
> 
> When I move mouse cursor through the menu and the cursor is on triangle,
> a submenu pops up. I want to popup submenus only on a mouse click. But
> they are popped up also on mouse move to the triangle. Can I do that?

I don't think you may currently change this behaviour, 25% of a menu item
at the right near the triangle is always "popup immediately or after
popdown delay if another submenu is up".

If you absolutely want it to be activated only on mouse click or key, you
may use Menu keyword instead of Popup. But there are "side" effects, no
triangle, your parent menu is closed and (by default) position is under
cursor. Maybe this is what you prefer anyway?

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jan 2002 16:13:31 +0100

> When I move mouse cursor through the menu and the cursor is on triangle, a submenu pops up. I  want to popup submenus only on a mouse click. But they are popped up also on mouse move to the triangl…

No, not with the version you have right now, but yes, if you
download tomorrow's snapshot and use the new menu style I just
wrote:

  MenuStyle * PopupDelayed, PopupDelay 0, PopupActiveArea 100

Bye

Dominik ^_^  ^_^