Subject: FVWM: Upgrading from FVWM 2.2.x to 2.4.x

From: Kieron Dunbar <[email-masked]>
Date: Mon, 17 Dec 2001 02:22:21 +0000

I recently downloaded FVWM 2.4.0 from Debian and installed it with dpkg.
Unfortunately, this caused it to ignore the configuration in my home directory
entirely in favour of what I assume to have been the configuration in
/etc/X11/fvwm. Replacing the files there with the configuration in my home
directory solved some of the problems, but there were many (such as the right
mouse button mimicing the left one if pressed whilst I am moving a window) which
I didn't manage to solve. Reinstalling 2.2.5 removed all of this unpleasantness.

I would quite like to have a more up-to-date version of FVWM, however, so I'm
curious as to what I'd need to do to update it without causing the look and feel
of my desktop to change too much.

-- 
kwaheri, Kieron             (reverse username to reply)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sun, 16 Dec 2001 21:41:28 -0500

> of my desktop to change too much.

Version 2.4.0 reads the config file in
$HOME/.fvwm/.fvwm2rc

There are some incompatible changes between 2.2.x and 2.4.x.
If you have an existing config file, you may want to run it
thru fvwm24_convert which comes with 2.4.x.  There is a bug
in the 2.4.0 version of that script, change
"$$HOME" to "$ENV{'HOME'}" in 2 places.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].