Subject: FVWM: Mini and Window buttons

From: Hugo Vanwoerkom <[email-masked]>
Date: Wed, 19 Dec 2001 18:01:06 -0600

2 questions:
Some of my minibuttons stay pressed down (e.g.netscape) others don't 
(e.g.xmms) what does that? I would like them to go down when I press and 
up when I don't.
To get the 'delete' window button I have:

>ButtonStyle All -- UseTitleStyle flat
>AddButtonStyle 1 Pixmap button.xpm
>AddButtonStyle 2 Pixmap button-max.xpm
>AddButtonStyle 4 Pixmap button-vert.xpm
>AddButtonStyle 6 Pixmap button-horiz.xpm
>AddButtonStyle 8 Pixmap button-close.xpm
>
Yet it never shows up. Thanks. Hugo Vanwoerkom.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 20 Dec 2001 01:40:29 +0000

> (e.g.xmms) what does that? I would like them to go down when I press and 

I am not sure I understand. I suppose you mean buttons in FvwmButtons.
If so, you probably have an incorrect pattern in the Action quoted string.
If you have something like the following line, the button stays pressed
until you open a "Notscape" window, like with "xterm -name Notscape".

  *FvwmButtons: (Icon mini/netscape.xpm, Action Exec "Notscape" netscape)

Or maybe you run mozilla while waiting for "Netscape". Just replace the
quoted string. Or explain the problem better, with configuration included.

> Yet it never shows up.

By default windows have no button 8 even if you specified a pixmap for it.
And you should bind something to it to actually see it. Add this:

  Style * Button 8
  Mouse 0  8  A  Close

Regards,
Mikhael.

---

From: Hugo Vanwoerkom <[email-masked]>
Date: Wed, 19 Dec 2001 20:42:44 -0600

Right. Works like a charm. I found the "hangon string" in the FvwmButton 
manpage.
Thanks for the quick reply.
Regards.
Hugo Vanwoerkom