Subject: FVWM: Automatically raise certain windows

From: Tom Alsberg <[email-masked]>
Date: Sun, 2 Dec 2001 00:24:37 +0200

Hi there.
Is there a way to automatically raise and lower some windows?

FvwmAuto lets me automatically raise and lower all windows. But I
don't see how I can auto-raise only some windows, like icon managers,
xclock, FvwmButtons, etc.

  -- Tom

-- 
  Tom Alsberg - certified insane, complete illiterate.
        e-mail: <[email-masked]>
	Homepage: http://www.cs.huji.ac.il/~alsbergt/
  * An idea is not responsible for the people who believe in it.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 1 Dec 2001 22:47:20 +0000

> xclock, FvwmButtons, etc.

Use the following to apply the action only to some windows:

  FvwmAuto 300 'MyWindowAction Silent Raise' 'MyWindowAction Silent Lower'

  AddToFunc MyWindowAction
  + I WindowId $w ("FvwmIconMan") $*
  + I WindowId $w ("FvwmButtons") $*
  + I WindowId $w ("xclock") $*

This is for 2.3.x and 2.4.x versions.
Also don't forget this line for your xclock: Style xclock Lenience

Regards,
Mikhael.

---

From: Tom Alsberg <[email-masked]>
Date: Sun, 2 Dec 2001 10:58:56 +0200

On Sat, Dec 01, 2001 at 10:47:20PM +0000, Mikhael Goikhman wrote:
<snip />
>   + I WindowId $w ("xclock") $*
<snip />

Thanks much... This really works.
I yet have a problem, though.

FvwmAuto raises on keyboard focus, not on mouse pointer position. Most
of the windows I want to auto-raise are those I set the ClickToFocus
style for. Also for FvwmIconMan I have it set the focus for the
selected window, so it immediately lowers again.

Is there a way to raise on pointer in window, and not on keyboard
focus?

Thanks,
  -- Tom

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 2 Dec 2001 15:25:43 +0000

> Is there a way to raise on pointer in window, and not on keyboard

FvwmAuto only operates on focus change, so you can't do it with NeverFocus
or ClickToFocus windows. There is no enter-window and leave-window internal
events in FVWM, so I doubt your request is currently possible.

I can only suggest to use Alt-Mouse2 to Raise/Lower a window, like:

  Mouse 2  WI  M  MoveOrRaiseLower

or maybe use some unused mice button:

  Mouse 4  WI  A  RaiseLower

Regards,
Mikhael.

---

From: Tom Alsberg <[email-masked]>
Date: Wed, 12 Dec 2001 15:20:28 +0200

> events in FVWM, so I doubt your request is currently possible.

  How difficult would it be to add this to FVWM? I'm really missing
this feature from CTWM... I might try to make a patch, or could I make
this a feature request?

> or maybe use some unused mice button:

  That doesn't really help. I do this, but for some windows I just
want them auto-raised and auto-lowered...

> Mikhael.

  Thanks, any help appreciated,
  -- Tom