Subject: FVWM: About FvwmSaveDesk

From: "Hubert S." <[email-masked]>
Date: Wed, 12 Dec 2001 13:15:17 +0100 (CET)

Hi!

lately I was trying to use FvwmSaveDesk module. so I did some changes in
.fvwm2rc
wrote a function MySaveSession
AddToFunc MySaveSession
+ "I" Module FvwmSaveDesk
and add to Quit-Verify menu
+ "save session" MySaveSession
and in the end of the file
Read /home/who/.fvwm2desk

and after I choose "save session" from Quit-Verify menu the session is
saved.
But I've found a problem with rxvt. when I run 'rxvt -vb -e mc -c'
.fvwm2desk looks like that
AddToFunc InitFunction  "I" Desk 0 0
+               "I" Exec rxvt -vb -e mc -c -geometry 80x24+18+36 &

but the synopsis of rxvt is
rxvt [options] [-e command [ args ]]
so You can see what the problem is. rxvt shows just for a second and
ends imediately.
the problem is the same for 'rxvt -e' with all other commands that end
when they get unknonw option (-geometry in that case).
running rxvt without -e works fine and the session loads.
is this a problem with the module or rxvt?

very few other x applications are being saved to .fvwm2desk, i.e. xv,
xspread, xman, xcalc. you can't save netscape, gimp, xmms, gvim.
is there any sollution for this problem?
I would be happy with the ability to save sessions.

please Cc me.

greetings from Poland :-)
hs

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 12 Dec 2001 08:56:48 -0500

> lately I was trying to use FvwmSaveDesk module. so I did some changes in
...

Recent versions of FVWM support "Session Management".
I think you will find that works better that the FvwmSaveDesk module.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 13 Dec 2001 00:47:48 +0000

> I think you will find that works better that the FvwmSaveDesk module.

You should also run a session manager to achieve this, like xsm or
gnome-session. A session manager is responsible for saving sessions, i.e.
remembering all application arguments and informing all compliant
application, including FVWM, to save/restore their data during sessions.

Regards,
Mikhael.

---

From: "Hubert S." <[email-masked]>
Date: Thu, 13 Dec 2001 12:55:07 +0100 (CET)

Hi!

I have tried xsm. I did everything that should be
done as explained in man xsm. fvwm loads, but it doesn't
run InitFunction, so no modules are loaded automatically.
and when saving checkpoint in xsm I get many warnings about
problems with saving some apps. only xman, xcalc and few
others are saved well.
I don't want to use gnome. fvwm2 is very fast and small
and I like, I just want to save my sessions. how do You do
that? do You use xsm? if you want to use gnome-session manager
you have to run the BIG gnome, right?

thanks for Your reply,
cheers :-) bye
hs

...

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 13 Dec 2001 13:21:30 +0000

> run InitFunction, so no modules are loaded automatically.

If you run modules in StartFunction (instead of duplicating them in both
InitFunction and RestartFunction) everything should work ok.

When a session manager is detected, SessionInitFunction is used, not
InitFunction, please read the man page. This is because InitFunction often
starts xterms, netscape and other apps that should be started by xsm now.

So I suggest (regardless of whether you use SM or not) to start all
FVWM modules from StartFunction that is introduced in fvwm-2.2.3.

> you have to run the BIG gnome, right?

gnome-session shows a flash screen, requires gnome-smproxy like xsm
requires smproxy, but it does not require any graphical apps to be run
(you may remove panel that it starts by default) or particular WM.
But, yes, you need most of GNOME libs and some apps to be installed.
You may run session-properties graphical tool from command line.

If you ask me, I like to have a static startup, i.e. the same apps to
appear every time, so I don't use a session manager.

Running under any session manager has its own advantages and
disadvantages. But you need it if you want real sessions, i.e. to start
X with applications that you left previously. FVWM does not handles apps.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Thu, 13 Dec 2001 08:29:00 -0500

> run InitFunction, so no modules are loaded automatically.

Look in the man page at SessionInitFunction.

> you have to run the BIG gnome, right?

I don't know about this stuff, someone else will answer.

---

From: "Hubert S." <[email-masked]>
Date: Thu, 13 Dec 2001 19:52:15 +0100 (CET)

thanks for your help :-)
now with StartFunction it works fine,

greetings
hs