Subject: Re: FVWM: Resizing Windows using KEY bindings - or: Why can't fvwm calculate?

From: Elliot Sowadsky <[email-masked]>
Date: Mon, 3 Dec 2001 11:09:57 -0800 (PST)

<  + I WindowId $0 Resize $[w.width]-10 keep

How is what this is trying to accomplish any different than my

+	I Resize br w-10p w-27p
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marc-Jano Knopp <[email-masked]>
Date: Tue, 4 Dec 2001 10:21:22 +0100

> +	I Resize br w-10p w-27p

Wow, this works! The information about this behavior is well hidden
in the man page, though :-) (Last sentence of "Move" description).

But there seems to be a bug:

  + I Resize br w-10p keep    - works like a charm
  + I Resize br w+10p keep    - works like a charm
  + I Resize br keep w-10p    - works like a charm
  + I Resize br keep w+10p    - does nothing!

I then tried

  + I Resize br keep 10p+w

instead, but obviously, '+' is not commutative, as it reduces the
height of my xterm always to one line.

Using a percent-of-screen value works, though:

  + I Resize br keep w+10     - works like a charm

Marc-Jano