Subject: Re: FVWM: Howto execute a apllication maximized and how the hellcan I move windows over my virtual screen && where the hell is 2.4.4 (it isnot on the ftp but announced on the page && the links are a

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 17 Dec 2001 03:12:28 +0100 (CET)

I found the _bug_!

When I use my menues to select move, I can move.

But normally ... and for all my tests I used my keyboard short cut

ctrl + alt + m

Try it with my current config. If I want to switch to other desk, it is not
working when using the keyboard shortcut and when I try the same thing with
my menue entry it is working. Is it a bug or a feature?

So what do I have to do to get it working with my keyboard short cut?

Anybody knows?

--
Thomas Glanzmann
Rathsbergerstrasse 28 D-91054 Erlangen / Burgberg

On Mon, 17 Dec 2001, Alex Wallis wrote:

> Thomas Glanzmann wrote:
> >
> > Hi out there,
> > I habe _still_ problems to move my windows from one virtual screen to
> > another.
> >
>
> You may be confusing yourself here.
>
> A desk can have many pages which you can easily drag & drop windows
> between.
> To move windows to another desk requires the window to be either
> "Sticky" or to use the MoveToDesk or GotoDesk commands. (refer to man
> fvwm2)
>
>
> Hope this helps.
>
>
> Alex
>

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Glanzmann <[email-masked]>
Date: Mon, 17 Dec 2001 03:22:30 +0100 (CET)

And now guess what ... I tried the same scenario with 2.4.0 and its working
with my keyboard shortcuts ... I am now going to track the version down ...

Who writes the bug report? *g*

Greetings,

And thank you a lot for your help ... without I would be still confused by
fvwm ;)

On Sun, 16 Dec 2001, Dan Espen wrote:

> Thomas Glanzmann <[email-masked]> writes:
> > Hi out there,
> > I have a problem to resize or move windows within my virtual desktops, I
> > tried many sthing, read the man page but I am unable to solve the problem.
>
> I guess by virtual desktop, you mean FvwmPager?
> It doesn't matter, I don't know how to do that.
>
> > Is there a way to execute an application maximized?
>
> Usually, an application will accept the "-iconic" flag,
> as in:
>
> Key N A SC Exec /local/netscape-4.79/.arch.os/bin/netscape -iconic
>
> There is also the "StartIconic" style.
>
> > Is there an way that fvwm does not load ConfigFvwmDefaults?
> > or do I have to delete that file?
>
> It will always attempt to load the default config file.
>
> > Where is fvwm 2.4.4 - it is announced at the web page, but the links to
> > 2.4.4 are broken and it is not at the ftp server?!
>
> It was released a couple of hours ago, wait a little while.
> I seemed to be able to download it, perhaps you should reload
> the page.
>
> > At the momement I am using fvwm2.4.3 with ConfigFvwmDefaults deleted and the
> > config file you can find under
> > http://wwwcip.informatik.uni-erlangen.de/~sithglan/fvwm2rc
>
> You have part of ConfigFvwmDefaults in your .fvwm2rc.
> It should work in some fashion like this, but I wouldn't
> recommend it.
>
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
> Piscataway, NJ 08854                     Phone: (732) 699-5570
>

On Sun, 16 Dec 2001, Mikhael Goikhman wrote:

> On 16 Dec 2001 23:15:10 +0100, Thomas Glanzmann wrote:
> >
> > On Sun, 16 Dec 2001, Dan Espen wrote:
> >
> > > Thomas Glanzmann <[email-masked]> writes:
> > >
> > > > I have a problem to resize or move windows within my virtual desktops, I
> > > > tried many sthing, read the man page but I am unable to solve the problem.
> > >
> > > I guess by virtual desktop, you mean FvwmPager?
> > > It doesn't matter, I don't know how to do that.
> >
> > Nope, not that way. I have 16 Virtual Screens. Now the thing I want to do is
> > to move a Window (like an xterm or so) from on Virtual screen to the other
> > virtual screen via my mouse. But When I try to move my mouse over to the
> > right or so, the mouse stops. There is a way ... i know it because i used it
> > some time ago, but I don't know how. It does not work with EdgeScroll 100
> > 100 with EdgeResistanze 10000 1 and so on. I do _not_ know why.
>
> I have no problem to drag windows across virtual pages with your linked
> config. Of course, "EdgeResistance 10000 1" disables moving just like the
> man pages says, and with "EdgeResistance 100 100" you should drag mouse
> for 100 pixels (second argument) for a window to jump to another page.
> But "EdgeResistance 500 10" or your "EdgeResistance 0 0" work ok.
>
> Do you still have a problem?
>
> > > > Is there a way to execute an application maximized?
> > >
> > > Usually, an application will accept the "-iconic" flag,
> > > as in:
> > >
> > > Key N A SC Exec /local/netscape-4.79/.arch.os/bin/netscape -iconic
> >
> > It does not work that way ;( but I keep trying.
> >
> > > There is also the "StartIconic" style.
>
> Well, Dan suggested two ways to start application iconified.
> To start it maximized you may use FAQ #3.18.
>
> Regards,
> Mikhael.
>

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Dec 2001 11:25:00 +0100

> my menue entry it is working. Is it a bug or a feature?

It's a bug and it's already fixed in the development sources.

> So what do I have to do to get it working with my keyboard short cut?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].