Subject: FVWM: FvwmPager: MiniIcons

From: Marcus Lundblad <[email-masked]>
Date: Fri, 14 Dec 2001 19:50:29 +0100 (CET)

I tried to turn on the option "FvwmPager: MiniIcons"
But nothing happens... is this something new that has been added since
2.4.3 in the CVS? 
I tried to set "*FvwmPagerSmallFont none", but then the miniwindows don't
get marked at all. The same if I remove (comment out) that line all
together.

It does however say: "Allow the pager to display a window's mini icon in
the pager, if it has one,.."

in the man page, but I think some program should have one...

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 14 Dec 2001 21:46:30 +0100

> But nothing happens... is this something new that has been added since

So you use CVS and you've get mini icon in your pager with 2.4.3?
This is strange ... So first I assume that your are new with mini
icons, sorry if it is not the case.

Do you have lines of the form:

Style * MiniIcon a_default_small_icons
Style "match" MiniIcon a_small_icons

in your config files? If not add at least

Style * MiniIcon a_default_small_icons

If you use the current CVS some mini icons should appear
automatically (without MiniIcon config lines) in the pager
for KDE version 2 applications.
So yes there were changes in the CVS regarding MiniIcon
but it should not break old config (but for KDE2 and GNOME2
apps).

If all the above is stupid regarding your config, maybe you
can try a full rebuild (some fvwm2 to modules communication
types have changed recently and this may cause problems (??)
if you rebuild fvwm2 only).

Regards, Olivier

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 15 Dec 2001 21:14:55 +0100 (CET)

> So you use CVS and you've get mini icon in your pager with 2.4.3?

No, I use 2.4.3. I don't currently use CVS.
I was wondering if this feature was added after 2.4.3 (in the snapshots on
CVS).

> Style "match" MiniIcon a_small_icons

No, I shall try those also.
> but it should not break old config (but for KDE2 and GNOME2
OK, so then the CVS version might work.
I never tried mini icons before. I just happend to come across the
description in the man page (on the web...) and thought I should try it
and see if I like that.

---

From: Dan Espen <[email-masked]>
Date: Sat, 15 Dec 2001 17:41:31 -0500

> I was wondering if this feature was added after 2.4.3 (in the snapshots on

In order to see mini-icons in the pager, you need to have
a mini icon associated with the window that the pager shows.
For example, if you are looking at an xterm in the pager,
you need:

Style xterm MiniIcon mini.xterm.xpm

Its easiest to start with:

Style * MiniIcon mini.xterm.xpm

of course you need a mini icon with that name around too.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].