Subject: FVWM: mouse pointer placing upon windowlist switch

From: Denis Perelyubskiy <[email-masked]>
Date: Tue, 27 Nov 2001 20:41:59 -0800

hello,

is it somehow possible to place mouse pointer in the middle
of the window i am switching to from the windowlist (alt-tab
or whatnot), as opposed to placing it somewhere in the very
upper left corner?

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 28 Nov 2001 08:42:10 +0100

> or whatnot), as opposed to placing it somewhere in the very

Yes.  The default action for the window list is

  AddToFunc WindowListFunc I WindowId $0 Iconify off
  + I WindowId $0 FlipFocus
  + I WindowId $0 Raise
  + I WindowId $0 WarpToWindow 5p 5p

You can destroy that function and replace it with anything you
like, e.g.

  DestroyFunc WindowListFunc
  AddToFunc WindowListFunc I WindowId $0 Iconify off
  + I WindowId $0 FlipFocus
  + I WindowId $0 Raise
  + I WindowId $0 WarpToWindow 50 50
                               ^^^^^

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Wed, 28 Nov 2001 10:08:17 -0800 (PST)

>   + I WindowId $0 WarpToWindow 50 50

Or, simpler and more robust, just add this to .fvwm2rc somewhere

  AddToFunc WindowListFunc I WindowId $0 WarpToWindow 50 50

This appends the "move to center" to the previous action without
having to destroy and re-create the whole thing.  This way, it
will still work if the default action changes in a future release.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 29 Nov 2001 05:54:17 +0100

> will still work if the default action changes in a future release.

Of course this warps the cursor first to the top left corner of
the window and then to its center.

Bye

Dominik ^_^  ^_^

---

From: Denis Perelyubskiy <[email-masked]>
Date: Thu, 29 Nov 2001 00:17:53 -0800

>> >   + I WindowId $0 WarpToWindow 50 50
  [...]
  >>   AddToFunc WindowListFunc I WindowId $0 WarpToWindow 50 50
  [...]
  >the window and then to its center.
  [...]

thanks, guys. this is precisely what i was looking for...
every so often i am reminded why it is i like this WM :)

denis