Subject: FVWM: Autofocus new windows

From: Max Ischenko <[email-masked]>
Date: Wed, 7 Nov 2001 10:23:00 +0200

I'm trying to make fvwm to focus newly opened windows.
The following doesn't work:
*FvwmEvent: PassID
*FvwmEvent: add_window windowid $0 Focus

FvwmEvent is running. Any other ideas/fixes?

-- 
The UNIX Guru's View of Sex: "unzip ; strip ; touch ; finger ; \
  mount ; fsck ; more ; yes ; umount ; sleep"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Johannes Karlsmyr <[email-masked]>
Date: Wed, 7 Nov 2001 10:46:21 +0100

I asked the same thing one week ago and got the answer:

Style "*" GrabFocus

that works nice for me.

/* johannes */

-- 
...................
..................

---

From: Max Ischenko <[email-masked]>
Date: Wed, 7 Nov 2001 11:59:57 +0200

> I asked the same thing one week ago and got the answer:
Oops, not enough RTFM from my side. ;-)

-- 
The only difference between a car salesman and a computer salesman is
that the car salesman knows he's lying.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 7 Nov 2001 15:43:40 +0000

> FvwmEvent is running. Any other ideas/fixes?

$0 is only expanded in the function lines. So this would works (from FAQ):

  *FvwmEvent: Cmd
  *FvwmEvent: PassId
  *FvwmEvent: add_window SwitchToWindow

  AddToFunc SwitchToWindow
  + I WindowId $0 Focus
  #+ I WindowId $0 WarpToWindow  # Lower / Maximize off

Regards,
Mikhael.