Subject: FVWM: can't read feedback window

From: toshi isogai <[email-masked]>
Date: Mon, 5 Nov 2001 10:28:26 -0700

I just compiled and started using 2.4.3. Feedback window during move
or resize is about 2 pixel wide. (It is trying to show some numbers in
that narrow space.) 

Would anyone tell me how to correct this?

Thanks.

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Nov 2001 17:13:52 +0000

> Would anyone tell me how to correct this?

Probably the font used is unreadable, like "-misc-nil-*".
The default font is "fixed", it normally should exist in X.

Open FvwmConsole or FvwmTalk and execute:

  DefaultFont fixed
  DefaultFont 7x13
  DefaultFont any-other-existing-font

Check that your font path in X or font server is configured correctly.
If this does not help, post your .fvwm2rc (try to minimize it).

Regards,
Mikhael.

---

From: toshi isogai <[email-masked]>
Date: Mon, 5 Nov 2001 11:52:39 -0700

> If this does not help, post your .fvwm2rc (try to minimize it).

I don't think font is the cause. I have already tried several fonts.
While the feedback window is showing this 2 pixel width, I can see a
part of character that has good height. If I move a window, I can see
characters are changing. The window is just too small, 12x2 pixels or
so (it is 12x0 now). Menus and title fonts show up just fine...

# This file is copied to a new user's FVWM_USERDIR by FvwmForm-Setup form.
# This file contains the commands fvwm2 reads while starting.
#

EdgeResistance 350 100
EdgeScroll 100 100
EdgeThickness 1

ClickTime 750

DeskTopSize 3x3

ColormapFocus FollowsMouse
ImagePath /usr/X11R6/include/X11/pixmaps:/home/tisogai/pixmaps

# default Styles:
# make sure these fonts exist on your system:
Style *           Font -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
Style *           IconFont -adobe-times-bold-r-*-*-12-*-*-*-*-*-*-*
Style *           HilightFore black, HilightBack #ff0000
Style *           BorderWidth 3, HandleWidth 3
Style *           Icon unknown1.xpm, Color lightgrey/dimgrey
Style *           MWMFunctions, MWMDecor, HintOverride
Style *           DecorateTransient, NoPPosition
Style *           IconBox 0 -10 -280 -1
Style *           FocusFollowsMouse
Style *           TileCascadePlacement

# Styles for various Fvwm modules:
Style Fvwm*       NoTitle,  Sticky, WindowListSkip
Style Fvwm*       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style FvwmPager   StaysOnTop
Style FvwmBanner  StaysOnTop
Style FvwmButtons Icon toolbox.xpm, ClickToFocus

# Styles for your common terminal emulator programs.
# xterms and rxvts in a separate icon box:
Style XTerm       Icon xterm.xpm, SloppyFocus, IconBox -70 1 -1 -140
Style rxvt        Icon term.xpm, SloppyFocus, IconBox -70 1 -1 -140
Style rxvt        MWMBorder, MWMButtons

# Styles for various common programs:
Style *lock       NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus
Style xbiff       NoTitle, Sticky, WindowListSkip, ClickToFocus
Style xcalc       Icon xcalc.xpm, NoButton 2,ClickToFocus
Style xmh         Icon mail1.xpm, NoIconTitle,StickyIcon
Style xmh         NoButton 2
Style xman        Icon xman.xpm, ClickToFocus
Style xmag        Icon mag_glass.xpm, ClickToFocus
Style xgraph      Icon graphs.xpm, ClickToFocus
Style xmosaic     Color Green/Yellow, ClickToFocus

style xload  NoTitle, NoHandles, Sticky, WindowListSkip, ClickToFocus, borderWidth 0
# skip mapping mainwin !!!
style MainWin  StartsOnPage 1 2, SkipMapping
style emacs   StartsOnPage 2 0
style mozilla-bin   StartsOnPage 1 0

# title bar
TitleStyle ActiveUp DGradient 64 orange red -- flat
TitleStyle Inactive Hgradient 128 #112300 #8888cc -- flat

# menu
MenuStyle * Font -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
MenuStyle * fvwm, foreground white, MenuFace DGradient 64 1 #999900 100  #0044aa, Animation

# buttons
ButtonStyle All -- UseTitleStyle flat

# some simple default key bindings:
Key Next         A       SCM     Next [*] Focus
Key Prior        A       SCM     Prev [*] Focus

#page mover
Key KP_7 a s gotopage 0 0
Key KP_8 a s gotopage 1 0
Key KP_9 a s gotopage 2 0
Key KP_4 a s gotopage 0 1
Key KP_5 a s gotopage 1 1
Key KP_6 a s gotopage 2 1
Key KP_1 a s gotopage 0 2
Key KP_2 a s gotopage 1 2
Key KP_3 a s gotopage 2 2

#menu ctrl to move window to a different page
Key KP_7 w 4c MoveToPage 0 0
Key KP_8 w 4c MoveToPage 1 0
Key KP_9 w 4c MoveToPage 2 0
Key KP_4 w 4c MoveToPage 0 1
Key KP_5 w 4c MoveToPage 1 1
Key KP_6 w 4c MoveToPage 2 1
Key KP_1 w 4c MoveToPage 0 2
Key KP_2 w 4c MoveToPage 1 2
Key KP_3 w 4c MoveToPage 2 2

#move cursor to focus window at position
DestroyFunc MoveCursorToFocus
AddToFunc MoveCursorToFocus
+ I WindowId root 1 WarpToWindow 1 1
+ I CursorMove $0 $1
Key KP_7 w sc MoveCursorToFocus 10 10
Key KP_8 w sc MoveCursorToFocus 60 10
Key KP_4 w sc MoveCursorToFocus 10 50
Key KP_5 w sc MoveCursorToFocus 60 50

# move/resize window. mod 4 is menu key
key m w 4 move
key slash w 4 resize

# some simple default mouse bindings:
#   for the root window:
Mouse 1 R       A       Menu MenuFvwmRoot Nop
Mouse 2 R       A       Menu MenuFvwmWindowOps Nop
Mouse 3 R       A       WindowList

#   for the title bar buttons:
Mouse 0 1       A       Menu MenuFvwmWindowOps2 Close
Mouse 0 2       A       FuncFvwmMaximize
Mouse 0 4       A       Iconify

#   for other parts of the window/borders/icons:
Mouse 1 F       A       FuncFvwmResizeOrRaise
Mouse 1 TS      A       FuncFvwmMoveOrRaise
Mouse 1 I       A       FuncFvwmMoveOrIconify
Mouse 2 I       A       Iconify
Mouse 2 FST     A       Menu MenuFvwmWindowOps2 Nop
Mouse 3 TSIF    A       RaiseLower

######################## Initialization Functions ############################
AddToFunc StartFunction
+ I Module FvwmAnimate
+ I Module FvwmBanner
#+ I Module FvwmButtons
+ I Module FvwmAuto 300 Raise Nop
#+ I Module FvwmPager

AddToFunc InitFunction
+ I exec kinput2 -canna 
+ I exec xmodmap .xmodmaprc 
+ I exec xhost + 
+ I exec Esetroot pics/fall-bg01.jpg

# For some SM-s (like gnome-session) there is an internal background setter.
AddToFunc SessionInitFunction
+ I exec kinput2 -canna 
+ I exec xmodmap .xmodmaprc 
+ I exec xhost + 
+ I exec Esetroot pics/fall-bg01.jpg

######################## Menus ###################
DestroyMenu MenuFvwmRoot
AddToMenu MenuFvwmRoot  "Root Menu"             Title
+                       "&1. XTerm"             Exec exec xterm
+                       "&2. Rxvt"              Exec exec rxvt
+                       "&3. Eterm"   Exec exec Eterm --cmod-red 0x33 --cmod-green 0xcc --cmod-blue 0xdd --trans --select-line

+                       "&s. ssp terms" exec /home/tisogai/scripts/ssp_terms
+                       "%/usr/lib/xemacs-21.1.14/etc/xemacs-icon.xpm%&x. XEmacs"    exec xemacs
+                       "%/usr/lib/mozilla/icons/mozicon50.xpm%&m.  Mozilla"   exec LANG=ja_JP;mozilla
+                       ""              Nop
+ "ssp1" exec Eterm -g +0+0 --cmod-red 0xcc --cmod-green 0xcc --cmod-blue 0x66  --trans --select-line -e rsh ssp1 & 
+ "ssp2" exec Eterm -g +0+370 --cmod-red 0xcc --cmod-green 0x66 --cmod-blue 0xff --trans --select-line -e rsh ssp2 &  		
+ "ssp3" exec Eterm -g +450+0 --cmod-red 0xdd --cmod-green 0x88 --cmod-blue 0x33 --trans --select-line -e rsh ssp3 &  		
+ "ssp3" exec Eterm -g +450+370 --cmod-red 0xdd --cmod-green 0x00 --cmod-blue 0x33 --trans --select-line -e rsh ssp4 &
+                       ""              Nop
+                       "&R. Remote Logins"     Popup MenuFvwmLogins
+                       ""              Nop
+                       "&U. Utilities"         Popup MenuFvwmUtilities
+                       ""              Nop
+                       "&M. Fvwm Modules"      Popup MenuFvwmModules
+                       "&W. Fvwm Window Ops"   Popup MenuFvwmWindowOps
+                       "&S. Fvwm Config Ops"   Popup MenuFvwmConfig
+                       ""              Nop
+                       "&F. Refresh Screen"   Refresh
+                       "&C. Recapture Screen" Recapture
+                       ""              Nop
+                       "&X. Exit Fvwm" Popup MenuFvwmQuitVerify

DestroyMenu MenuFvwmUtilities
AddToMenu MenuFvwmUtilities     "MenuFvwmUtilities" Title
+                       "&T. Top"       Exec exec xterm -T Top -n Top -e top
+                       "&C. Calculator" Exec exec xcalc
+                       "&M. Xman"      Exec exec xman
+                       "&G. Xmag"      Exec exec xmag
+                       "&R. Editres"   Exec exec editres
+                       ""              Nop
+                       "&E. XEmacs"    Exec exec xemacs
+                       "&A. Xmh Mail"  FuncFvwmMailXmh xmh "-font fixed"
+                       ""              Nop
+                       "&L. XLock"     Exec exec xlock -mode random
+                       ""              Nop
+                       "&D. Reset X defaults" Exec xrdb -load $HOME/.Xdefaults

DestroyMenu MenuFvwmConfig
AddToMenu MenuFvwmConfig "Fvwm Config Ops" Title
+ "&S. Sloppy Focus"        FuncFvwmFocusPolicyChange SloppyFocus
+ "&C. Click To Focus"      FuncFvwmFocusPolicyChange ClickToFocus
+ "&F. Focus Follows Mouse" FuncFvwmFocusPolicyChange FocusFollowsMouse
+ "" Nop
+ "&1. Colormap Follows Mouse" ColormapFocus FollowsMouse
+ "&2. Colormap Follows Focus" ColormapFocus FollowsFocus
+ "" Nop
+ "&3. Full Paging ON"           EdgeScroll 100 100
+ "&4. All Paging OFF"           EdgeScroll 0 0
+ "&5. Horizontal Paging Only"   EdgeScroll 100 0
+ "&6. Vertical Paging Only"     EdgeScroll 0 100
+ "&7. Partial Paging"           EdgeScroll 50 50
+ "&8. Full Paging && Edge Wrap" EdgeScroll 100000 100000

# The window Ops menus exhibit a different HotKey style.
# There are 2 versions of the WindowOps Menu, meant to be bound to different
# things.  Here is the "common" part:
DestroyFunc FuncFvwmWindowCommon
AddToFunc FuncFvwmWindowCommon
+ I AddToMenu $0 &Move              Move
+ I AddToMenu $0 &Resize            Resize
+ I AddToMenu $0 R&aise             Raise
+ I AddToMenu $0 &Lower             Lower
+ I AddToMenu $0 (De)&Iconify       Iconify
+ I AddToMenu $0 (Un)&Stick         Stick
+ I AddToMenu $0 (Un)Ma&ximize      Maximize
+ I AddToMenu $0 "Move to page"     popup MenuMoveToPage
+ I AddToMenu $0 ""                 Nop
+ I AddToMenu $0 &Delete            Delete
+ I AddToMenu $0 &Close             Close
+ I AddToMenu $0 Destroy            Destroy
+ I AddToMenu $0 ""                 Nop

# First windowops menu, bound to:
# mouse 2 on root
# Root menu
DestroyMenu MenuFvwmWindowOps
AddToMenu MenuFvwmWindowOps     "Window Ops"    Title
FuncFvwmWindowCommon MenuFvwmWindowOps
+ "Re&fresh Window" RefreshWindow

# Second windowops menu, bound to:
# any mouse on titlebar button 1
# mouse 2 on frame, side or titlebar
DestroyMenu MenuFvwmWindowOps2
AddToMenu MenuFvwmWindowOps2
FuncFvwmWindowCommon MenuFvwmWindowOps2
+ Scroll&Bar       Module FvwmScroll 2 2
+ &Print           FuncFvwmPrint
+ "Print Re&verse" FuncFvwmPrintReverse

# 3 different ways to log on, take your pick:
DestroyFunc FuncFvwmRloginXterm
AddToFunc FuncFvwmRloginXterm \
  I Exec xterm -name $0 -title "$USER @ $0" -e rlogin $0
DestroyFunc FuncFvwmRloginRxvt
AddToFunc FuncFvwmRloginRxvt \
  I Exec rxvt -name $0 -n $0 -title $USER@$0 -e rlogin $0
DestroyFunc FuncFvwmRloginRshRxvt
AddToFunc FuncFvwmRloginRshRxvt \
  I Exec Exec rsh $0 rxvt -display $HOSTDISPLAY

# be sure to fill these in with your correct machine names:
DestroyMenu MenuFvwmLogins
AddToMenu MenuFvwmLogins
+ &dopey  FuncFvwmRloginXterm dopey
+ &snoopy FuncFvwmRloginXterm snoopy
+ s&ignal Exec rxterm signal

DestroyMenu MenuFvwmModules
AddToMenu MenuFvwmModules "Fvwm Modules"        Title
+ "&1. Control Animation" Popup  MenuFvwmAnimate
+ "&B. Button-Bar"        Module FvwmButtons
+ "&O. IconBox"           FuncFvwmConfigureIconBox
+ "&F. Forms"             Popup  MenuFvwmForms
+ "&I. Identify"          Module FvwmIdent
+ "&M. IconMan"           Module FvwmIconMan
+ "&N. Banner"            Module FvwmBanner
+ "&C. Console"           Module FvwmConsole
+ "&P. Pager"             Module FvwmPager 0 0
+ "&2. Pager (2 desks)"   Module FvwmPager 0 1
+ "&R. Backer"            Module FvwmBacker
+ "&S. ScrollBar"         Module FvwmScroll 50 50
+ "&T. FvwmTaskBar"       Module FvwmTaskBar
+ "&U. AutoRaise"         Module FvwmAuto 200 Raise Nop
+ "&W. WinList"           Module FvwmWinList
+ "&X. Stop Module Menu"  Popup  MenuFvwmStopModule

DestroyMenu MenuFvwmStopModule
AddToMenu MenuFvwmStopModule "Stop Fvwm Modules" Title
+ "&B. Stop Button-Bar"  KillModule FvwmButtons
+ "&O. Stop IconBox"     KillModule FvwmIconBox
+ "&M. Stop IconMan"     KillModule FvwmIconMan
+ "&P. Stop Pager"       KillModule FvwmPager
+ "&R. Stop Backer"      KillModule FvwmBacker
+ "&S. Stop ScrollBar"   KillModule FvwmScroll
+ "&T. Stop FvwmTaskBar" KillModule FvwmTaskBar
+ "&U. Stop AutoRaise"   KillModule FvwmAuto
+ "&W. Stop WinList"     KillModule FvwmWinList

DestroyMenu MenuFvwmForms
AddToMenu MenuFvwmForms
+ "&C. Capture"       Module FvwmForm FvwmForm-Capture
+ "&D. Form Defaults" Module FvwmForm FvwmForm-Form
+ "&R. Rlogin"        Module FvwmForm FvwmForm-Rlogin
+ "&P. RootCursor"    Module FvwmForm FvwmForm-RootCursor
+ "&S. Setup"         Module FvwmForm FvwmForm-Setup
+ "&T. Talk Form"     Module FvwmForm FvwmForm-Talk
+ "&Q. QuitVerify"    Module FvwmForm FvwmForm-QuitVerify

# Configure and start using an iconbox on the fly
DestroyFunc FuncFvwmConfigureIconBox
AddToFunc FuncFvwmConfigureIconBox
+ I Module FvwmIconBox
+ I Style     *  NoIcon

DestroyMenu MenuFvwmQuitVerify
AddToMenu MenuFvwmQuitVerify "Really Quit Fvwm?" Title
+ "&Q. Yes, Really Quit" Quit
+ ""                     Nop
+ "&R. Restart"          Restart
+ ""                     Nop
+ "&T. Start twm"        Restart twm
+ "&C. Start ctwm"       Restart ctwm
+ "&2. Start tvtwm"      Restart tvtwm
+ "&V. Start vtwm"       Restart vtwm
+ "&M. Start mwm"        Restart mwm
+ "&O. Start olwm"       Restart /usr/openwin/bin/olwm
+ ""                     Nop
+ "&X. Just an Xterm"    Restart xterm -n '"X Console"' -T '"X Console"'
+ ""                     Nop
+ "&N. No, Don't Quit"   Nop

######################## Sample Functions ##########################

DestroyFunc FuncFvwmMailXmh
AddToFunc FuncFvwmMailXmh
+ I Next [$0] Iconify false
+ I Next [$0] Focus
+ I None [$0] Exec $0 $1

DestroyFunc FuncFvwmMoveOrRaise
AddToFunc FuncFvwmMoveOrRaise
+ I Raise
+ M Move
+ D Lower

DestroyFunc FuncFvwmMaximize
AddToFunc FuncFvwmMaximize
+ M Maximize   0 100
+ H Maximize   0 100
+ C Maximize   0  80
+ D Maximize 100 100

DestroyFunc FuncFvwmMoveOrIconify
AddToFunc FuncFvwmMoveOrIconify
+ I Raise
+ M Move
+ D Iconify

DestroyFunc FuncFvwmResizeOrRaise
AddToFunc FuncFvwmResizeOrRaise
+ I Raise
+ M Resize
+ D Lower

DestroyFunc FuncFvwmPrint
AddToFunc FuncFvwmPrint
+ I Raise
+ I Exec xdpr -id $w

DestroyFunc FuncFvwmPrintReverse
AddToFunc FuncFvwmPrintReverse
+ I Raise
+ I Exec xdpr 1/2 -h -rv -id $w

DestroyFunc FuncFvwmFocusPolicyChange
AddToFunc FuncFvwmFocusPolicyChange
+ I Style * $0
+ I Recapture

DestroyMenu MenuMoveToPage
AddToMenu MenuMoveToPage "Move to page" title
+ "Top Left" MoveToPage 0 0
+ "Top Center" MoveToPage 1 0
+ "Top Right" MoveToPage 2 0
+ "Mid Left" MoveToPage 0 1 
+ "Mid Center" MoveToPage 1 1 
+ "Mid Right" MoveToPage 2 1 
+ "Bot Left" MoveToPage 0 2
+ "Bot Center" MoveToPage 1 2
+ "Bot Right" MoveToPage 2 2

# Read config files for modules:
read ConfigFvwmBacker
read ConfigFvwmButtons
read ConfigFvwmIconBox
read ConfigFvwmIconMan
read ConfigFvwmIdent
read ConfigFvwmPager
read ConfigFvwmScroll
read ConfigFvwmTaskBar
read ConfigFvwmWinList

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 5 Nov 2001 18:51:21 +0000

On 05 Nov 2001 11:52:39 -0700, toshi isogai wrote:
Content-Description: message body text
> so (it is 12x0 now). Menus and title fonts show up just fine...

If fonts are not the problem, I don't know then.

I see a normal default feedback window in 2.4.3 with your posted .fvwm2rc,
with or without multibyte support.

Regards,
Mikhael.

---

From: Dan Espen <[email-masked]>
Date: Tue, 06 Nov 2001 08:38:38 -0500

> with or without multibyte support.

Toshi,

Would you be using a multibyte font for the default font?

I see in borders.c we have this:

#ifdef I18N_MB
    text_width = XmbTextEscapement(window->title_font.fontset, title,
                                   strlen(title));
#else
    text_width = XTextWidth(window->title_font.font, title, strlen(title));
#endif

but in move_resize.c we have this:

  Scr.SizeStringWidth =
    XTextWidth(Scr.DefaultFont.font, GEOMETRY_WINDOW_STRING,
	       sizeof(GEOMETRY_WINDOW_STRING));

(No special logic for multibyte.)

Perhaps you can add some fprintfs in move_resize.c?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: toshi isogai <[email-masked]>
Date: Tue, 6 Nov 2001 09:58:24 -0700

I tried XmbTextEscapement and also XmbDrawString in move_resize.c but
no luck. I am not sure how multibyte has some effect here. Window
position and size information are always alpha-numeric. But when I
recompiled without multibyte option, the feedback shows correctly...

As far as multibyte concerns, it works in popup menu but not in title.

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 10 Nov 2001 18:23:07 +0100

> Would anyone tell me how to correct this?

Are there any error messages on the console about fonts?  Does it
heal if you issue "DefaultFont <any font you like>" via
FvwmConsole or FvwmCommand after fvwm has started?  Can you add
these lines into the resize_geometry_window() function, please?
I'd like to know if the geometry window is resized to an incorrect
size or it it is never resized at all.

    if (w != sizew_g.width || h != sizew_g.height)
    {
      XResizeWindow(dpy, Scr.SizeWindow, w, h);
      sizew_g.width = w;
      sizew_g.height = h;
-->   fprintf(stderr, "rgw: size changed\n");
    }
--> fprintf(stderr, "rgw: gw size: %dx%d\n", w, h);
    if (cset >= 0)
    {
      SetWindowBackground(
    ...

(new lines marked with -->)

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].