Subject: re: FVWM: Icon's page

From: [email-masked] (Elliot Sowadsky)
Date: Thu, 22 Nov 2001 10:16:29 -0800 (PST)

<<
> Is there a way to find out what page an icon was on before it was opened?
> I have a program that when it opens itself, it opens on the page i'm on, not
> the page its icon was on. If i knew what page the icon was on, i can
> redirect it and my view back to that page.

Usually, the window is deiconified on the page with the icon.  If
it deiconifies to the current page, the reason is probably that
the icon overlapped the current page by a feew pixels.

The (xview) program deiconifies on its own, not via fvwm.
The icon can be more than one page away from current.
But if i can grab the icon's page, i can swing back to it.

Thanx
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 27 Nov 2001 10:18:06 +0100

> But if i can grab the icon's page, i can swing back to it.

Hm, I can't think of anything to do this.  You can only find out
the window's position with the $[w.x] and $[w.y] variables, but
not the icon's position.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: KONTRA Gergely <[email-masked]>
Date: Tue, 27 Nov 2001 15:32:23 +0100 (CET)

Hi!

I use FvwmTaskBar which is at the bottom.
For my maximizing problem, sombody said, that I should modify the
maximize function.
I do so, but
Maximize 100 -24p doesn't gives me the correct result.
When invoking with -20p there is a hole between the window and the
FvwmTasBar, with -19p the two applications overlap ;(
Is it a bug or a feature?

+-[Kontra Gergely @ Budapest University of Technology and Economics]-+
| Email: CHANGED! [email-masked] [email-masked] (old)    |
| URL:   turul.eet.bme.hu/~kgergely    Mobile: (+36 20) 356 9656     |
+-------"Olyan langesz vagyok, hogy poroltoval kellene jarnom!"------+
.
Magyar php mirror es magyar php dokumentacio: http://hu.php.net

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 27 Nov 2001 21:36:16 +0000

> Is it a bug or a feature?

Seems like you maximize a window that does not allow any given size in
pixels. For example, xterm or other terminal emulators allow only certain
sizes, i.e. with 7x13 font: 200 on 200 pixels, 213 on 207 pixels etc.
Try to resize such window manually and you will notice it jumps in size.

Regards,
Mikhael.