Subject: FVWM: Borderless (and transparent) sliding panel

From: Thomas Adam <[email-masked]>
Date: Wed, 7 Nov 2001 11:49:57 +0000 (GMT)

Dear List,

Is it possible to produce a borderless (and
transparent) sliding panel at the bottom of my
desktop?? I was thinking along the lines of something
similar to what KDE has.

When I say transparent, I mean that it should be the
colour of my background. Also, would it be possible to
include a feature so that when the sliding-panel is
"rolled up", the panel's button becomes invisible
(hidden) until a particular key (such as F1) is
pressed???

Sorry for being so demanding. It was just an idea of
mine :-)

Any help you can offer is greately appreciated.
Regards,

Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 7 Nov 2001 17:06:44 +0000

> Sorry for being so demanding. It was just an idea of

Looks like you want a one-button FvwmButton that opens sub-panel (another
FvwmButton config). man FvwmButtons.

I suppose you know how to make any window borderless using Style command.

I believe it is possible to make FvwmButtons transparent (I didn't do it)
just like it is possible to get transparent FvwmIdent and FvwmIconMan.
This is done using colorsets. man FvwmTheme.

You can't bind F1 in FvwmButtons, but if you keep it focussed on mouse,
you may use Enter (or a mouse click) to roll the subpanel up and down.

Or you may use another solution, one FvwmButtons (without sub-panels)
and bind this on Ctrl-Shift-F1:

  Style MyPanel \                        # don't really use comments here
    NoTitle, NoHandle, BorderWidth 0, \  # make it borderless
    Sticky, StaysOnTop, \                # probably makes sense
    WindowListSkip, CirculateSkip, \     # usually used for sticky windows
    TitleAtBottom                        # so it is shaded to the bottom

  Key F1  A  SC  All (MyPanel) WindowShade

> Any help you can offer is greately appreciated.

Regards,
Mikhael.