Subject: FVWM: Cycling through windows with Alt+Tab

From: Tom Alsberg <[email-masked]>
Date: Fri, 2 Nov 2001 17:12:00 +0200

Hi there :-)

  I would like to have FVWM cycle between my windows when I use
Alt+Tab. I don't want a window list, but the behaviour I'm used to
from CTWM - just cycling through the windows currently visible.

  I tried putting something like this in my .fvwm2rc:

Key	Tab	A	M	Next (CurrentPage) Focus

  But it didn't	quite do well - firstly, if I had just restarted FVWM,
it forgot about the windows, so Alt+Tab didn't cycle through quite
some of them. Secondly, when pressing Alt+Tab on the last window, it
doesn't cycle to the first one.

  Does anyone have any idea how I could do what I want?

  I'm a FVWM newbie, I just switched from CTWM and found most of what
I wanted in it after some configuring, I'd love if I get Alt+Tab
cycling like I am used to it again.

  Any help appreciated,
  -- Tom

-- 
  Tom Alsberg - certified insane, complete illiterate.
        e-mail: <[email-masked]>
	Homepage: http://www.cs.huji.ac.il/~alsbergt/
  * An idea is not responsible for the people who believe in it.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 02 Nov 2001 10:36:06 -0500

> cycling like I am used to it again.

Check the FAQ or the man page.
You need to avoid windows that won't accept focus.
Look for "acceptsfocus".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].