Subject: FVWM: which styles are applied to window?

From: Erik Steffl <[email-masked]>
Date: Sun, 11 Nov 2001 04:14:48 -0800

is there any way to find out which styles are applied to a window?
e.g. I am trying lenience style with vncviewer but how do I know it was
actually applied (what if I have the name wrong or something...)?

  TIA

	erik
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 11 Nov 2001 19:59:05 +0000

> actually applied (what if I have the name wrong or something...)?

You can't get information whether a specific Style line was applied for a
specific window or not. But you can get information about the result.

Run FvwmCommandS module (from FvwmConsole or in your StartFunction).
Then to get an internal fvwm info about your window, start it using:

  FvwmCommand -i2 'Exec exec xcalc'

Note, that window flags is not the same as window styles; flags are
constructed from all matched Style lines (order matters) and flag names
often differ from the corresponding Style options.

The output is not fully up to date, but should help you.

Regards,
Mikhael.

---

From: Erik Steffl <[email-masked]>
Date: Sun, 11 Nov 2001 13:26:13 -0800

> often differ from the corresponding Style options.

  thanks, vnc opens few windows (one window for username, another for
password and finally the third window is the actual vncviewer) so I used
-m option and got following info:

is_lenient: 1
...
0x04e00026 window               TightVNC: esteffl's X desktop
(panther:1)
0x04e00026 icon                 TightVNC: esteffl's X desktop
(panther:1)
0x04e00026 class                Vncviewer
0x04e00026 resource             xvncviewer

  so I guess lenience style was successfully applied but when I switch
to fullscreen mode the vncviewer still does not get keyboard events (it
does not react to any keys I press).

  is there any way to make vncviewer to accept keyboard events (it
accepts mouse events). TIA.

	erik

PS: full list of what FvwmCommand say about vncviewer window (the last
one opened, the actual viewer window, theis is before it is switched to
fullscreen but even after I switch it to fullscreen there is no more
info printed out by FvwmCommand):

Packet flags
is_sticky: 0
has_icon_font: 0
has_window_font: 1
do_circulate_skip: 0
do_circulate_skip_icon: 0
do_circulate_skip_shaded: 0
do_grab_focus_when_created: 0
do_grab_focus_when_transient_created: 1
do_ignore_restack: 0
do_lower_transient: 1
do_not_show_on_map: 0
do_not_pass_click_focus_click: 0
do_not_raise_click_focus_click: 0
do_raise_mouse_focus_click: 0
do_raise_transient: 1
do_resize_opaque: 0
do_shrink_windowshade: 0
do_stack_transient_parent: 1
do_start_iconic: 0
do_window_list_skip: 0
focus_mode: 0
has_bottom_title: 0
has_depressable_border: 0
has_mwm_border: 1
has_mwm_buttons: 0
has_mwm_override: 0
has_no_icon_title: 0
has_override_size: 0
has_stippled_title: 0
is_fixed: 0
is_sticky_icon: 0
is_icon_suppressed: 0
is_lenient: 1
does_wm_delete_window: 0
does_wm_take_focus: 0
do_iconify_after_map: 0
do_reuse_destroyed: 0
has_border: 1
has_title: 1
is_deiconify_pending: 0
is_fully_visible: 0
is_iconified: 0
is_iconfied_by_parent: 0
is_icon_entered: 0
is_icon_font_loaded: 1
is_icon_moved: 0
is_icon_ours: 0
is_icon_shaped: 0
is_icon_unmapped: 0
is_mapped: 0
is_map_pending: 0
is_maximized: 0
is_name_changed: 0
is_partially_visible: 0
is_pixmap_ours: 0
is_placed_wb3: 0
is_size_inc_set: 0
is_transient: 0
is_window_drawn_once: 0
is_viewport_moved: 0
is_window_being_moved_opaque: 0
is_window_font_loaded: 1
is_window_shaded 0
0x04e00026 title height         17
0x04e00026 border width         6
0x04e00026 base size            width 0, height 0
0x04e00026 size increment       width 1, height 1
0x04e00026 min size             width 1, height 1
0x04e00026 max size             width 1152, height 864
0x04e00026 gravity              NorthWest
0x04e00026 pixel                text 0x0, back 0xad55
0x04e00026 window               TightVNC: esteffl's X desktop
(panther:1)
0x04e00026 icon                 TightVNC: esteffl's X desktop
(panther:1)
0x04e00026 class                Vncviewer
0x04e00026 resource             xvncviewer
-------------------------------------- end
-------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: toshi isogai <[email-masked]>
Date: Mon, 12 Nov 2001 16:40:51 -0700

> info printed out by FvwmCommand):

I noticed there are cases FvwmCommand does not report all fvwm
activities even with -i 3 option. I could not pin point exactly
when. But for just monitoring, you can use FvwmDebug, with file
argument.

-- 
--------------------------------------------------------------------
Toshi Isogai          [email-masked]

SEAKR Engineering, Inc.
6221 S. Racine Circle
Centennial, CO  80111
Phone (303) 790-8499