Subject: FVWM: Re: your mail

From: Faiz Kazi <[email-masked]>
Date: Mon, 29 Oct 2001 23:45:50 +0530 (IST)

Hello,

Is there anyone who uses FvwmGtk extensively?

I'm trying to create some basic dialog boxes with FvwmGtk
instead of the usual FvwmForm.

I tried invoking a test dialog box both these ways:

	Module FvwmForm FvwmForm-Form
        SendToModule FvwmGtk FvwmGtk-Test

The file FvwmGtk-Test I created under /usr/local/share/fvwm,
the directory where the other FvwmForms/Scripts are kept.
-->
--------
DestroyModuleConfig  FvwmGtk-Test: *
*FvwmGtk-Test:  Dialog FvwmGtk-Test "Testing FvwmGtk"
*FvwmGtk-Test:  Label "Testing FvwmGtk"
--------

Should'nt I be atleast seeing an empty box,
whenever I invoke it?

I wasn't able to get it to work, maybe I missed something..
the man page I did go through, but some more explanation
or perhps an example or two would be very useful.

I use FvwmForm and FvwmScript for a lot of tasks and I'd
like to try the same with FvwmGtk, as well. Gtk has some
keyboard bindings which may make things easy for a user.

I'm running fvwm 2.4.0, compiled from source,
and configured during compilation to include the FvwmGtk
module with gtk support.

I also have gtk on my system, latest version, compiled
from source.

Any tips on this particalar Module would be very welcome.

Faiz

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Tue, 30 Oct 2001 01:16:10 +0000

> Is there anyone who uses FvwmGtk extensively?

I think FvwmGtk is very underestimated, its widget set is very good.
The scriptability of FvwmGtk is not the best though.
I can't find any screenshot of FvwmGtk except for this one:

  http://fvwm-themes.sf.net/screenshots/full/gnome.gif

> The file FvwmGtk-Test I created under /usr/local/share/fvwm,
           ^^^^^^^^^^^^
                |
                v
            file name

> *FvwmGtk-Test:  Dialog FvwmGtk-Test "Testing FvwmGtk"
   ^^^^^^^^^^^^          ^^^^^^^^^^^^
         |                     |
         v                     v
    alias name            dialog name

> Should'nt I be atleast seeing an empty box,

The man page of FvwmGtk implies that you know how to run this module
(by running Module FvwmGtk with optional alias).
You should also explicetly Read the configuration; unlike FvwmForm and
FvwmScript files are not automatically found and read. So you should do:

  Read file-name
  Module FvwmGtk alias-name
  SendToModule alias-name dialog-name

You used the same name for file, alias and dialog, but this is not
required. So in your case you should do:

  Read FvwmGtk-Test
  Module FvwmGtk FvwmGtk-Test
  SendToModule FvwmGtk-Test FvwmGtk-Test

> Any tips on this particalar Module would be very welcome.

If you have more questions, I would like to answer.

Regards,
Mikhael.