Subject: FVWM: fvwm2 and kdm setup

From: Neil Zanella <[email-masked]>
Date: Thu, 18 Oct 2001 22:34:47 -0230 (NDT)

Hello,

I would like to be able to select fvwm2 directly from kdm rather than
choosing failsafe at the kdm login and then running fvwm2 manually.
I would still like to have kdm rather than xdm on the login screen.
I am running Red Hat 7.1 with kde 2.1.1 and the latest fvwm2 version
of course. I have done the following to /etc/X11/xdm/kdmrc:

#SessionTypes=default,kde,gnome,failsafe
SessionTypes=default,kde,gnome,fvwm2,failsafe

This shows me an fvwm2 option but when I log in I end up with kde rather
than fvwm2. What other configuration files must I configure for fvwm2
to start up when I log in?

Thanks,

Neil

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Fri, 19 Oct 2001 07:00:48 +0200

> to start up when I log in?

You should edit (or create) an ~/.xsession file that look like:

# things you want to do before starting your session

case in $1 
    
    default)
       fvwm2
    ;;

    kde)
       startkde
    ;;

    gnome)
       gnome-session
    ;;

    fvwm2)
       fvwm2
    ;;

    *)
       fvwm2
    ;;

esac
    
# things you want to do before leaving X

Olivier

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 19 Oct 2001 11:19:53 +0200 (CEST)

> You should edit (or create) an ~/.xsession file that look like:

This can alsom be done system-wide in /etc/X11/xdm/Xsession

---

From: E Frank Ball <[email-masked]>
Date: Fri, 19 Oct 2001 10:36:21 -0700

On Fri, Oct 19, 2001 at 11:19:53AM +0200, Marcus Lundblad wrote:
} 
} 
} On Fri, 19 Oct 2001, Olivier Chapuis wrote:
} 
} > On Thu, Oct 18, 2001 at 10:34:47PM -0230, Neil Zanella wrote:
} > > 
} > 
} > You should edit (or create) an ~/.xsession file that look like:
} 
} This can alsom be done system-wide in /etc/X11/xdm/Xsession

I got rid of the /etc/X11/xinit/Xclients file
and replaced it with this: 

#!/bin/bash 
exec fvwm2 

-- 

   E Frank Ball                [email-masked]