Subject: RE: FVWM: wait cursor

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Thu, 18 Oct 2001 14:34:37 +0200

>
>Send your waitcursorshade pixmap if you still 
>have problems with it.
>
>Regards,
>Mikhael.

HI!

I still have difficulty displaying the right cursor. To 
test the cursor commands, I made a .fvwm2rc with only
these three lines:

BusyCursor * True
CursorStyle WAIT /home/jos/waitcursorshade.xpm white black
CursorStyle ROOT /home/jos/waitcursorshade.xpm white black

then on the root the cursor is displayed correctly, but
when I start up netscape, or when netscape is looking for
a www page, I still see a watch. Could it be that netscape
displays it's own cursor, or that this has to be set in 
an xresources file? I'll include the xpm file below.

best regards

jos

-----CUT HERE: waitcursorshade.xpm -----------------------------

/* XPM */
static char * cdewaitcursor_xpm[] = {
"36 34 3 1",
" 	c None",
".	c #FFFFFF",
"+	c #000000",
"....................................",
".++++++++++++++++++++++++++++++++++.",
".++++++++++++++++++++++++++++++++++.",
" .++  .+                    +.  ++. ",
" .++ .+                      +. ++. ",
" .++ .+                      +. ++. ",
" .++ .+                      +. ++. ",
" .++ .+                      +. ++. ",
" .++ .+                      +. ++. ",
" .++ .+                      +. ++. ",
" .++  .+                    +.  ++. ",
" .++   .+++++++++  +++++++++.   ++. ",
" .++    .++++++++++++++++++.    ++. ",
" .++     ..++++++++++++++..     ++. ",
" .++       ..++++++++++.        ++. ",
" .++         ..++++++..         ++. ",
" .++            .++.            ++. ",
" .++            .++.            ++. ",
" .++         ..++  ++..         ++. ",
" .++       ..++      ++..       ++. ",
" .++     ..++          ++..     ++. ",
" .++    .++              ++.    ++. ",
" .++   .+                  +.   ++. ",
" .++  .+                    +.  ++. ",
" .++ .+          +           +. ++. ",
" .++ .+        +++++         +. ++. ",
" .++ .+       +++++++        +. ++. ",
" .++ .+    +++++++++++++     +. ++. ",
" .++ .++++++++++++++++++++++++. ++. ",
" .++ .++++++++++++++++++++++++. ++. ",
" .++  .++++++++++++++++++++++.  ++. ",
".++++++++++++++++++++++++++++++++++.",
".++++++++++++++++++++++++++++++++++.",
"...................................."};
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 Oct 2001 08:50:44 -0400

> an xresources file? I'll include the xpm file below.

Exactly.

This is in my Netscape.ad file:

! Mouse cursor when awaiting a reply.
*busyCursor:			watch

FVWM only controls the cursors in the FVWM areas of the screen,
the menus, titlebars, frames, screen edges...

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].