Subject: FVWM: Window decorations for icons

From: jos <[email-masked]>
Date: Thu, 04 Oct 2001 16:33:48 +0200

HI!!

Is it possible with fvwm2 to give icons normal window
decorations (a border) and a fixed size (where the 
icon image is then placed in the center of the icon
window), like in Motif mwm?

best regards

jos
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 Oct 2001 08:11:11 -0400

> window), like in Motif mwm?

Not without source code changes, or using uniform icons.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephane Rosa <[email-masked]>
Date: Thu, 04 Oct 2001 17:33:17 +0200 (CEST)

>  window), like in Motif mwm?

Oh my... I would love that so much. That's the ONLY thing
I like in other wm like WindowMaker. I hate those floating
icons of different sizes and shape swimming on my desktop.

And I'd like them to have a common pixmap in the background,
that could be different based on a rule, i.e. all terminal
icons would have a blue pixmap behind, all netscape icons
would have a red one, etc.

Unfortunately I asked that a while ago and the answer at that
time was that "the current behavior is a wanted feature" or
something...

I'm interested in the developer's answer on that again ;-)

Stephane

-- 
SILICON GRAPHICS                 EUROPEAN MANUFACTURING CENTER
##############################################################
Stephane Rosa                     Tel :     +41 (0)32 843-3638
Business Analyst                  Fax :     +41 (0)32 843-3909
APS/FP  Project                   GSM :     +41 (0)79 616-0828
--------------------------------------------------------------
ircnoc.neu.sgi.com  SGI Intranet  IRC :   EuroOper on #irchelp
irc.stealth.net     Euro-IRCNet   IRC :   Clipper on #radionet
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Perry Hutchison <[email-masked]>
Date: Thu, 4 Oct 2001 10:46:46 -0700 (PDT)

> I hate those floating icons of different sizes and shape
> swimming on my desktop.

IconBox and IconGrid can reduce the chaos to some extent.
I suppose creative use of xsetroot (or some such) could
arrange for a different background in the areas that will
be used by IconBox than in the rest of the desktop.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 6 Oct 2001 21:12:49 +0000

> >  window), like in Motif mwm?

The icon in FVWM is drawn with a 3d border a-la motif if the pixmap is
not transparent (i.e. has no color "None"). You can't specify a spacing.

> I hate those floating

Then you may use wm-icons - themable distribution that currently includes
17 one-sized icon sets, each set implements the list of 84 names.

Regards,
Mikhael.

---

From: Marcus Lundblad <[email-masked]>
Date: Sat, 6 Oct 2001 23:37:24 +0200 (CEST)

> not transparent (i.e. has no color "None"). You can't specify a spacing.

Yes, but then it's not possible to use applicattion supplied icocs, you
will have to override all icons.

I also would like to have the possibility to get Mwm/CDE like icon frames
(with configurable backgrounf colour used in conjunction with
transperancy)...