Subject: FVWM: help? gtk_window_set_title doesn't work?

From: "rick herbel" <[email-masked]>
Date: Wed, 24 Oct 2001 17:25:49 -0700

gtk_window_set_title doesn't work?
In my app I wnat to have my popup window look different than my main
app which is a windowless app how can I do this ?

gtk_window_set_title
calls

 XmbSetWMProperties

Also tried

gtk_window_set_wmclass

which I think calls XsetClasssHint

Can anyone tell me the right X call to communicate with the window manager
so my window can get decorated correctly?

Rick

using fvwm2-2.2.4-9

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Oct 2001 20:23:25 +0000

> so my window can get decorated correctly?

gtk_window_set_title works for me. As well as gtk_window_set_wmclass.

gtk_window_set_wmclass has no effect (run-time warning) if you call it
after gtk_widget_show(window); gtk_window_set_title works dynamically.

If you still have problems with these 2 functions, create a minimal
example that shows the problem and sent it.

Regards,
Mikhael.

---

From: "rick herbel" <[email-masked]>
Date: Thu, 25 Oct 2001 15:06:16 -0700

Thanks,

Spent too many hours at it.   Was logic problem.   It works :).

Rick

-----Original Message-----
From: Mikhael Goikhman [mailto:[email-masked]]
Sent: Thursday, October 25, 2001 1:23 PM
To: rick herbel
Cc: [email-masked]
Subject: Re: FVWM: help? gtk_window_set_title doesn't work?

Regards,
Mikhael.