Subject: FVWM: Using Icons in fvwm 1.x menu

From: "Reuben D Budiardja" <[email-masked]>
Date: Sun, 28 Oct 2001 18:58:31 -0500

Hi,
I am rather new to fvwm. I use fvwm 1 and got fvwmrc file from a friend, and 
now trying to re-configure it myself. I am still too lazy to move to fvwm2.

My question: is it possible to use icon in menu, beside the text in fvwm 1.x? 
If yes, how? I've seen some screenshot of this in fvwm homepage, but I think 
that's is using fvwm2. 

Thanks for any replies.
Reuben D. Budiardja

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 28 Oct 2001 23:59:08 +0000

> If yes, how? I've seen some screenshot of this in fvwm homepage, but I think 

The only icons fvwm-1.x supports is the ones used for iconified windows.
It does not support menu icons or application mini icons.

Regards,
Mikhael.

---

From: Thomas Adam <[email-masked]>
Date: Mon, 29 Oct 2001 12:46:09 +0000 (GMT)

--- Reuben D Budiardja <[email-masked]> wrote: >
Hi,
> fvwm homepage, but I think 

Fvwm1 does not offer the menu icon facility.
Furthermore, Fvwm1 is no longer supported by the FVWM
team.

I really do recommend that you upgrade to the latest
stable release of FVWM2 (I'm using
Fvwm2-2.4.2)......it's still the best window manager
for Linux :-)

Kind Regards,

Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

____________________________________________________________
Nokia Game is on again. 
Go to http://uk.yahoo.com/nokiagame/ and join the new
all media adventure before November 3rd.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Reuben D Budiardja" <[email-masked]>
Date: Mon, 29 Oct 2001 09:32:42 -0500

> Fvwm2-2.4.2)......it's still the best window manager

Yeah. Now I am thinking about it (upgrading). I'll do it when I have time to 
re-write the rc files.
One thing that would be helpful is that if there are the rc files in fvwm 
homepage. I saw some beautiful screenshot there. It should be great if there 
are rc files together with the screenshot that we can download. and then we 
can re-configure it ourselves.

Rdb

-- 
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
"God is the unrestricted act of understanding, the eternal rapture
glimpsed in every Archimedean cry of Eureka."

                     	- Bernard Lonergan -
~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^~^

Reuben Donald Budiardja
[email-masked]
Homepage: http://www.goshen.edu/~reubendb

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Oct 2001 09:39:22 -0500

> can re-configure it ourselves.

Fvwm(2)  comes  with a conversion  script that  will  convert an fvwm1
.fvwmrc file to .fvwm2rc format.

You can use fvwm-themes which comes with lots of pre-configured
looks.

One of the screenshots does have a link to its .fvwm2rc file.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 29 Oct 2001 15:50:17 +0100 (CET)

> can re-configure it ourselves.

There are some screenshots with accompanying rc-files at
http://www.xwinman.org

//Marcus

---

From: "Reuben D Budiardja" <[email-masked]>
Date: Mon, 29 Oct 2001 10:38:37 -0500

> .fvwmrc file to .fvwm2rc format.

I just installed fvwm-2.4.3, and it only has fvwm24_convert, which the manual 
page says it only converts fvwm-2.2.x files. I need to use fvwmrc_convert to 
convert from 1.x rc file to 2.2.x convert files first. But I don't find that 
script.

Does this mean I have to install fvwm-2.2.x first? 

Thanks.
Reuben D. Budiardja

---

From: Dan Espen <[email-masked]>
Date: Mon, 29 Oct 2001 10:37:09 -0500

> Does this mean I have to install fvwm-2.2.x first? 

fvwmrc_convert should be there,
in a separate mail, I sent you a copy.

---

From: Thomas Adam <[email-masked]>
Date: Mon, 29 Oct 2001 17:04:53 +0000 (GMT)

I saw some beautiful screenshot there. It
> should be great if there 

This is something that *I* would love to see......what
does Dominik think of this??? Obviously some part of
the webpage would have to be added to, and the
original person that submitted the screenshot would
have to submit their .fvwm2rc file.

But I don't think there's a problem?!?

Regards,

Thomas Adam

------------
"This is Linux country. If you listen carefully you
can hear the sound of Windows rebooting......"

=====
Thomas Adam

---

From: Tenebrae <[email-masked]>
Date: Mon, 29 Oct 2001 09:16:34 -0800 (PST)

> But I don't think there's a problem?!?

In the meantime, I'm sure some of the people whose screenshots grace the
online world may still be lurking in here (like me).  If there's a
screenshot or two that you'd like the rc file for, ask and you may
receive.
								-Tenebrae.

---

From: Dan Espen <[email-masked]>
Date: Tue, 30 Oct 2001 15:56:54 -0500

> have to submit their .fvwm2rc file.

Some users that submitted screenshots also submitted
.fvwm2rc files.  My original position was NOT to include
.fvwm2rc files on the screenshot page.

Since then, I've had a change of heart and will now accept
them.  (Theres one there now.)

If you previously submitted a screen shot and would like to
submit an .fvwm2rc file, feel free to do so.

Try to make sure that your .fvwm2rc doesn't produce errors
and is reasonably up-to-date.

Screenshots or .fvwm2rc files can be sent to [email-masked]
(as attachments).

---

From: J C Lawrence <[email-masked]>
Date: Tue, 30 Oct 2001 14:18:56 -0800

On Tue, 30 Oct 2001 15:56:54 -0500 
Dan Espen <[email-masked]> wrote:

> Since then, I've had a change of heart and will now accept them.
> (Theres one there now.)

<bow>

I've minorly updated my RC for 2.4 (smaller/thinner?less obtrusive
widgets mostly).  I'm not quite ready to roll a new screenshot or
RC, but if there's interest, drop me a note and I'll send what I've
got.

-- 
J C Lawrence
---------(*)                Satan, oscillate my metallic sonatas.
[email-masked]               He lived as a devil, eh?
http://www.kanga.nu/~claw/  Evil is a name of a foeman, as I live.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Adam <[email-masked]>
Date: Wed, 31 Oct 2001 16:57:23 +0000 (GMT)

It seems like Christmas has come early :-)

Thank you Dan Espen!!

--Thomas Adam

 --- Dan Espen <[email-masked]> wrote: > Thomas
Adam <[email-masked]> writes:
> > > are rc files together with the screenshot that
> we
> > > can download. and then we 

=====
Thomas Adam