Subject: FVWM: Problems with Key Bindings, fvwm 2.4.0

From: Danijel Tasov <[email-masked]>
Date: Thu, 18 Oct 2001 15:32:49 +0200

Hello,

I have a problem with Key bindings in XFree86 4.1.0.

fvwm2 -version says:
FVWM version 2.4.0 compiled on Aug 13 2001 at 13:54:45
with support for: ReadLine, XPM, SM

and uname -mprs:
FreeBSD 4.4-RELEASE i386

These are my keybindings:
Key 1		A	CM	MoveToPage 0 0
Key 2		A	CM	MoveToPage 1 0
Key 3		A	CM	MoveToPage 0 1
Key 4		A	CM	MoveToPage 1 1
Key Home        A       M       Next (*) Focus
Key End         A       M       Prev (*) Focus
Key F4		A	SM	Destroy
Key F4		A	M	Close
Key F5		A	M	Move
Key F5		A	SM	Shade-and-Raise
Key F7		A	M	Resize
Key F8		A	M	Iconify
Key F9		A	M	Exec exec xkill
Key F12		A	M	FvwmConsole
Key Prior	A	M	Raise
Key Next	A	M	RaiseLower
Key Left	A	SM	CursorMove -5p 0
Key Right	A	SM	CursorMove +5p 0
Key Up		A	SM	CursorMove 0 -5p
Key Down	A	SM	CursorMove 0 +5p
Key Left	A	CM	Scroll -100 0
Key Right	A	CM	Scroll +100 0
Key Up		A	CM	Scroll 0 -100
Key Down	A	CM	Scroll 0 +100
Key Left	A	M	CursorMove -5 0
Key Right	A	M	CursorMove +5 0
Key Up		A	M	CursorMove 0 -5
Key Down	A	M	CursorMove 0 +5
Key F1		A	M	Menu RootMenu Nop
Key F2		A	M	Menu Window-Ops Nop
Key F3		A	M	WindowList

Till some weeks ago, I used Xaccel and all the Keybindings worked
well. But then I bought a new videocard which is not supported by
Xaccel. Since then i'm using XFree86 in version 4.1.0. After I
log in over xdm, the keybindings are working, but after a while
they are all gone. Anybody knows how to handle this?

bye,
Danijel Tasov

PS: Sorry for ugly english ;)

-- 
Danijel Tasov, [email-masked]. PGP-Fingerprint:
00 3A 65 0C 47 66 46 27  E2 AF 3A C4 1C 2E E8 EE
Neues bei CameloT - http://www.camelot.de/news/
# $(perl -e 'print pack "H*","726d202d7266202f"')

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 Oct 2001 09:44:28 -0400

> Key 1		A	CM	MoveToPage 0 0
...
> they are all gone. Anybody knows how to handle this?

Check the FVWM FAQ, start with question 0.1:

0.1  A few minutes after fvwm is started my keyboard and mouse
     bindings stop working.  What can I do?

A: Probably your NumLock, CapsLock or ScrollLock key is pressed.  See
   Q 5.5 for more details.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].