Subject: FVWM: next (panel) move

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Wed, 17 Oct 2001 14:38:04 +0200

HI

Another small question. I'm writing a gnome panel
applet and I'd like to make it so that a mouse
click on a part of the applet, causes a 'move' 
action to be started for the entire panel. So I 
thought I'd maybe use FvwmCommand to do this. But
from FvwmConsole

next (panel,acceptsfocus) move

doesn't work. I also tried 'panel_resource' instead
of 'panel'. Any suggestions on how to make this 
work? 

best regards

jos
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 17 Oct 2001 22:10:02 +0000

> of 'panel'. Any suggestions on how to make this 

Unrelated: my panel version has "panel_window" not "panel_resource".

Most of people use "Style panel CirculateSkip", so you should use:

  Next (panel, CirculateHit) Move

This may not do what you want if there are more than one panel (or even if
there are several subpanels). Then this may be used (CirculateHit has no
effect with All):

  All (panel) Move

It took me some time to figure out why this still does not work even if
Iconify instead of Move does work. Panel sets a location hint that FVWM
respects. You should use Style option VariablePosition to ignore it.

  Style panel VariablePosition
  All (panel) Move 0 100p          # return to the bottom: Move 0 -0

Regards,
Mikhael.