Subject: FVWM: 2.4.3: Module Ident weird (or is it a weird user) ?

From: Denis Perelyubskiy <[email-masked]>
Date: Sat, 13 Oct 2001 12:36:55 -0700

hello,

so i was playing with my pager, and i did an FvwmIdent on it.

it said that geometry is 44x33+0+0, but that the width is
179, Height is 33, X(Current Page) is 0, Y(Current page) is
0

the question is, should the geometry not have read:

179x33+0+0?

is is a bug with a problem, or is it a bug with the user (in
that i am confused about what geometry is supposed to mean)?

thanks.

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 13 Oct 2001 22:11:02 +0000

> that i am confused about what geometry is supposed to mean)?

Geometry means logical units specific to the given application window.

Compare, for example, xv and xterm. The actual width and height of xv
window is the same as its geometry, i.e. its logical unit has size 1x1.
But in xterm the logical unit is a character cell, something like 7x13
depending on a font you use. In addition, there is a non-removable part
in xterm, its scrollbar, that is not included in geometry.

In case of FvwmPager, the geometry is the size of a single page.
You use the desk that has 4x1 pages and you disable the pager label. So:
  The total X size is 44*4 plus 3 separators = 179.
  The total Y size is 33.

If you would use 3x2 pages with fixed-font label you would get:
  The total X size is 44*3 plus 2 separators = 134.
  The total Y size is 33*2 plus 1 separator + 16-pixel label = 83.

In both cases above, the geometry of the pager would still be 44x33.
If this is still mysterious, think what should happen when you resize
xv, xterm, FvwmPager. The geometry is changed in +1 / -1 logical unit.

Regards,
Mikhael.

---

From: Laurent Evain <[email-masked]>
Date: Mon, 15 Oct 2001 17:16:56 +0200

> in xterm, its scrollbar, that is not included in geometry.

Hi,

Suppose that I want to put a window in a free space whose size is 
MxN. Suppose that the application in the window is such that
using multiples of the logical unit cannot be MxN for reasons of 
divisibility. 
Is there a way to put the window in such a way that it exactly 
fills the free space. 
(I have such problems with emacs: I cannot adjust the size 
so that it coincides exactly with what is free on my screen).

Thanks,
Laurent.

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Oct 2001 18:21:52 +0200

> so that it coincides exactly with what is free on my screen).

The only thing you can do is to try different font sizes.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].