Subject: FVWM: How does FVWM read from the keyboard?

From: Glen Lee Edwards <[email-masked]>
Date: Fri, 5 Oct 2001 14:37:30 -0500 (CDT)

I'm not real clear on exactly what question to ask or how to ask it (short
version), so here's the long version:

   I have a keyboard, don't see a brand name, model SK-6000 (made in China), that
has the Windows keys on it and one other key I've never seen before (upper right
hand corner, larger than the others, has a diamond shape arrow on it pointing
left).  
   The windows keys kick out a keycode (125 - 127 on showkey, 115-117 on xev),
but the "diamond" key in the upper right hand doesn't.  xev and showkey -k don't
even register that it's been pressed.  showkey -m returns on keyevent: 

àhàè ( 0xe0 0x68 0xe0 0xe8 )

These questions probable can't be answered here, but I didn't get a response on
the Red Hat list, so:
Running Red Hat Linux 7.0
1) What do I have to do to the windows keys so that FVWM will recognize them?
2) What do I have to do to Red Hat so that the diamond key kicks out a keycode.

Glen
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 05 Oct 2001 15:52:01 -0400

> 1) What do I have to do to the windows keys so that FVWM will recognize them?

For the key that has a scancode, use xmodmap to assign the
scancode to a keysym, then you are in business.

> 2) What do I have to do to Red Hat so that the diamond key kicks out a keycod

Don't know.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Marcus Lundblad <[email-masked]>
Date: Fri, 5 Oct 2001 23:49:00 +0200 (CEST)

> 2) What do I have to do to Red Hat so that the diamond key kicks out a keycode.

This is for RH 7.1 (shouldn't be so different)

Edit the file: /etc/X11/XF86Config
Mine contains these lines a bit down:

    XkbModel    "pc105"	
    Xkbkeycodes "xfree86"
    XkbLayout   "us"
    XkbTypes    "default"
    XkbCompat   "default"
    XkbSymbols  "en_US(pc105)"
    XkbGeometry "pc"

But make sure you make a backup of the file first....

To view differnt keboards available run "xkeycaps".

Then restart your X server. Switch virtual console to a text console
(Ctrl-Alt-1) log in as root at the text login prompt.
Then run the command "init 3"
Now the system goes down to runlevel 3 and the X server quits.
When this has happend (press enter a couple of times to get back the
prompt if it doesn't show up in a short moment)
Now run "init 5".
Now the system goes to runlevel 5 and the X server restarts.
To get back to X switch to virtual console 7 (ctrl-alt-7).

//Marcus

---

From: Ionel Mugurel Ciobîcă <[email-masked]>
Date: Sat, 6 Oct 2001 13:45:50 +0200

Try xkeymaps, it let you change the value of a key. You may assign the
value Meta for the windoze key. I don't understand the other key, it
is Alt, or AltGr, or menu, or maybe diamond key...

Ionel

În data de  5/10/2001, 14:37:30, Glen Lee Edwards a scris:
> ?h?? ( 0xe0 0x68 0xe0 0xe8 )
> 
>