Subject: FVWM: FvwmButtons without title and no stipled titlebar

From: Marcus Lundblad <[email-masked]>
Date: Fri, 12 Oct 2001 11:29:56 +0200 (CEST)

Is it possible to remove the title of the FvwmButtons window?
And is it also possible to turn of the "stipledness" for individual
windows when they are "sticky" (in this case FvwmButtons).
I did set the title font of FvwmButtons to a smaller one than the normal
title font so that the window will get a thinner title bar that
"normal" windows.
Setting: Style "FvwmButtons" NoTitle
removes the title bar entirely. I would still like it to have a title bar.
Can this be done by creating a new decor?

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 12 Oct 2001 13:17:33 +0000

> windows when they are "sticky" (in this case FvwmButtons).

No, you can't currently disable stipples for sticky windows, you can only
enable stipples for non-sticky windows.

> Can this be done by creating a new decor?

It took me some time to understand that you want to disable a title text.
The title name of FvwmButtons is either "FvwmButtons" or the module alias
name. You may do some not nice tricks like creating a short alias like "_"
(you can only use alphanumeric chars in alias) or use the same color for
text foreground and background or use invisible font.

Probably a feature to specify a customized static title name for some
windows to display would be interesting, but it is not currently possible.

Or if you really want it now, find the line: list[0] = MyName;
in FvwmButtons.c and specify an empty string "" instead of MyName.

Regards,
Mikhael.

---

From: Thomas Adam <[email-masked]>
Date: Fri, 12 Oct 2001 14:29:41 +0100 (BST)

> enable stipples for non-sticky windows.

I know that from my own personal preference, I would
like to be able to disable the "stippling" of sticky
windows.

Do you think that this will be implemented in the next
release??? Is it difficult to do??

What do the developers think??

--Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 14 Oct 2001 22:03:11 +0200

> What do the developers think??

I'm planning to vastly enhance the concept of styles anyway.  Part
of this will be to allow state specific styles, e.g. something
like

  Style (sticky) StipledTitlesOff

BUt don't expect this to work soon.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].