Subject: FVWM: Fvwm warps to other desktop when tearoff menu pops up

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Mon, 22 Oct 2001 20:56:22 +0200

HI!!

I'm writing gtk program which lets pop up
a gtk menu in the torn-off state, ie the
menu has it's own window with decorations,
and a window name.

Now, when the menu pops up for the first time,
it works fine. But, when it pops again, 
fvwm warps back to the desktop on which the 
menu appeared for the first time. Maybe gtk
just hides the window, and when it is unhidden
fvwm thinks that it has to be displayed in 
another desktop. 

Does anyone know an fvwm workaround for this?

best regards

jos
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 25 Oct 2001 20:45:18 +0000

> Does anyone know an fvwm workaround for this?

I see this with all gtk programs, weird.

The problem is solved if you make the menu window sticky:

  Style "My tearoff menu" Sticky

A better solution, I guess, is to set a sticky window hint for tearoff
menus using gnome hints.

Probably there is another solution, I don't quite understand yet why
this happens in the first place.

Regards,
Mikhael.