Subject: Re: FVWM: FWD: Re: [TAG] determining screen resolution

From: Glen Lee Edwards <[email-masked]>
Date: Mon, 8 Oct 2001 17:23:49 -0500 (CDT)

Is there a way to mathmatically modify these values from within .fvwm2rc?  If I
use $[vp.width], the bar extends app 12p beyond the viewing range of my screen.
I tried 

*MyBar2Geometry $[vp.width]-12x115+0-0
and
*MyBar2Geometry $[vp.width-12]x115+0-0

but neither worked, instead moving the bar to the top of the screen (it's
supposed to be on the bottom).

Glen

Dominik Vogt writes:
 > On Sun, Oct 07, 2001 at 12:28:56PM +0100, Thomas Adam wrote:
 > > [ FWD: e-mail....all replies to this e-mail should be
 > > CC'ed to:
 > > 
 > > [email-masked]
 > > 
 > > --Thomas Adam]
 > > 
 > > > I'm using RedHat 6.2 and the fvwm2 window manager. 
 > > > In my fvwm2rc
 > > > file I tell the system where to put my calendar,
 > > > browser, and other
 > > > windows
 > > > on my desktop.  I specify the locations and the size
 > > > of the windows.  If
 > > > I
 > > > switch to a different display with a lower screen
 > > > resolution then these
 > > > values will be inappropriate.  Is there a way to get
 > > > the screen
 > > > resolution
 > > > so that I can scale the values appropriately?
 > 
 > In 2.4.x, you can use $[vp.width] and $[vp.height] to get the
 > screen's (viewport's) dimensions.
 > 
 > Bye
 > 
 > Dominik ^_^  ^_^
 > 
 > -- 
 > Dominik Vogt, email: [email-masked]
 > LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
 > fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
 > --
 > Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
 > To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
 > message to [email-masked].
 > To report problems, send mail to [email-masked].
 > 
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 08 Oct 2001 21:48:06 -0400

Glen Lee Edwards <[email-masked]> writes:
> use $[vp.width], the bar extends app 12p beyond the viewing range of my
> screen. I tried 
> 

Use PipeRead to do arithmetic:

PipeRead 'echo "*MyBar2Geometry `expr $[vp.width] - 12`x115+0-0"'

(Warning, lightly tested.)

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].