Subject: Re: FVWM: How about voting for FVWM!

From: Glen Lee Edwards <[email-masked]>
Date: Wed, 10 Oct 2001 03:54:34 -0500 (CDT)

Denis Perelyubskiy writes:
 >   * Marcus Lundblad <[email-masked]> [10-Oct-01 00:45 -0700]:
 >   >
 >   >
 >   >
 >   >On Tue, 9 Oct 2001, Glen Lee Edwards wrote:
 >   >
 >   >> Don't know if this has been posted here or not, just stumbled on it, but you can
 >   >> vote for your favorite window manager at:
 >   >> 
 >   >> http://www.plig.org/xwinman/vote.html
 >   >> 
 >   >> I just voted for FVWM. It's currently in 6th place out of 19.
 >   >
 >   >No it's actually 5:th right now ^_^ with 3 more votes to pass KDE yeah...
 >   [...]
 > 
 > actually, now that i voted, it just passed KDE :)
 > 
 > denis

Cool.  FVWM is definitely the best window manager.  Some may work better out of
the box - the Windows style of window manager where it does all the thinking for
you and all you do is click and point.  But FVWM lets us do it our way.  

A friend of mine emailed me a couple of weeks back.  He's using Gnome.  He was
really irritated because every time he accidentally clicked on the upper left
hand corner of the window it closed it.  Not sure why he's clicking up there,
move or resize maybe, but I told him that he won't have that problem with
FVWM. You can configure the corners, buttons, etc., any way you want.  FVWM is
the best!

Glen
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 10 Oct 2001 02:10:21 -0700

* Glen Lee Edwards <[email-masked]> [10-Oct-01 01:56 -0700]:
  [...]
  >Cool.  FVWM is definitely the best window manager.  Some
  >may work better out of the box - the Windows style of
  >window manager where it does all the thinking for you and
  >all you do is click and point.  But FVWM lets us do it
  >our way.  
  [...]

i like programs to do exactly what i like them to do, no
matter if i have to spend 2 days configuring them, and i
dont have a pretty gui, which makes me coffee, at the same
time as it is trying to figure out what it is i would like
to do.... (which is why i also like vim, mutt, slrn :)

also, i am not sure if this observation has any basis, but
somehow fvwm always seemed to be much faster then
enlightenment, sawfish, kde, and the likes.

i am sure, there are probably other small wm's out there,
but I just like fvwm way too much to even try them (and now 
that it stops annoying transient windows from popping up in
the 0,0 corner, i am in love....)

so, the thing that always bothered me is why people started
new wm projects, as opposed to helping out with existing
ones, like fvwm? i mean, i saw some "small, configurable,
theme-able" wm's out there, but that's exactly what FVWM
is... i wonder if that's because "they can do it better?"
attitude seems to be pretty common in open source (and not
open source) ? ... just seems so much more could've been
accomplished if people who have the time to contribute used
that time to enhance things that are there ... 

but i digress

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Suzanne Britton <[email-masked]>
Date: Wed, 10 Oct 2001 05:49:33 -0400

> matter if i have to spend 2 days configuring them

Yes! I could write a 10-page rant about arrogant applications that
think they're smarter than the user.

One of the things I love about fvwm is the single, hand-tweakable configuration
file, and the fact that fvwm doesn't write over it unless you darned well tell
it to. I'm fed up with config files that take up whole directory trees, get
written out every time you quit whether you changed the config or not, and/or
have threatening headers like "<automatically generated, do not edit!>"
Blegh. Why don't you use a proprietary binary format, while you're at it?

The worst offender I can recall is an app called FancyLauncher that I tried
briefly. It writes out its config every time it exits, whether you've changed
anything or not--and even if you're right in the middle of editing the
config file. Now, it lets you specify relative offsets for button locations,
so that you can easily, say, insert new buttons in the middle without changing
the location data for the rest. But when it writes its config out upon
exiting, it *always* writes out absolute button locations! So much for that
useful feature...

> enlightenment, sawfish, kde, and the likes.

WindowMaker is pretty zippy, but eventually I tired of its inflexible design.

> ones, like fvwm?

Well, count me in as someone who's trying to help out with fvwm :-) I've
created a patch to make titlebars more themable, but right now it's heavily in
development and I've only been posting it on fvwm-workers. For a preview of
its abilities, check out the screenshots at http://www.igs.net/~tril/fvwm/.

I think one of the problems with fvwm is that it is vastly underrated.
Few people seem to know how beautiful it can be, as well as functional.

Suzanne

-- 
[email-masked] - http://www.igs.net/~tril/
"I'm aware of that, sweetheart. It's just that when I wake up to a hissing
goat skull on my nightstand, and it hops off and runs across the floor on
spider legs, I sleep a lot better knowing where it ran off to."
                                                          - Ted (Red Meat)
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Laurent Evain <[email-masked]>
Date: Wed, 10 Oct 2001 11:17:13 +0200

> time 

That's the point. The coffee they do is generally not so good !

There's no doubt that Fvwm can do exactly what you want it to do
and I recommend it to my friends :))
However, there is a bad point that I would like to point out:
it misses a general documentation towards the end user 
that would introduce the more specific documentation.
Something which could be read in an evening (5 or 6 pages)
explaining the philosophy and the 
organisation of fvwm (its links with X, its organisation
in Modules, a synthetic presentation of the various modules,
the way the windows are configured using styles...). 
At the moment,
the documentation supposes the user know all these things and 
the first step is a bit high. A short presentation should be 
sufficient to get a working configuration and to be ready 
to read the more specific documention. A possible plan 
would be
-what is a window manager 
-why should I choose or not choose fvwm
-the general organisation of fvwm:
	-its links with X
	-what do fvwm without any module
	-the modules
	-the styles
-commented examples of configurations

Concerning the philosophy, I also think it should be explained
on the web page. 
When I decided to choose a wm a few months ago, it was not very
clear if fvwm was the one I was looking for. 
If you 
-want something light and fast
-want the wm to do exactly what YOU want 
-want a perennial organisation of your desktop
-like efficient keyboard or mouse shorcuts
-are ready to spend some time configuring

then fvwm is done for you ;-))))))

But if you

-feel nervous if you need to write 5 lines of code
-want all the possible features installed at the same
time (including coffee !), no matter if your computer becomes slow 
-leave someone else organize the desktop for you, 
no matter if its next idea will be different
-think that everything on a computer can be done with a mouse

then you should choose another wm. 

Hope these comments will help...
Laurent.

---

From: Ionel Mugurel Ciobîcă <[email-masked]>
Date: Wed, 10 Oct 2001 12:21:07 +0200

> think they're smarter than the user.

I recommended the voting site to an other mailing list and
I start to get e-mails which complained about the fact that
fvwm (and others from wm family) are toghether with kde and gnome,
which supposely are not window managers, but desktops. Can someone
help me to understand why kde and gnome are not simply window managers?
For me kde and gnome are just slow and imposible to configure.
This is the definition of desktops?

Thank you,

Ionel

---

From: Louis LeBlanc <[email-masked]>
Date: Wed, 10 Oct 2001 07:32:47 -0400

>   >all you do is click and point.  But FVWM lets us do it

I just voted myself.  Fvwm is in 4th place behind WindowMaker, IceWM
and AfterStep.  Not sure why Fvwm isn't first.  I have to agree with
all the pro Fvwm comments I've seen so far.  I won't work on a
computer until I have it up and running.  I haven't gotten around to
running it over Exceed on my Windoze box, but then again, I haven't
even turned the stupid thing on in weeks :)

I have spent a lot of time learning the 'pick your own bells and
whistles' apps, like vim and mutt (I keep threatening to learn slrn,
but I found a mutt patch to read news instead).  Because of this, I
have learned to coexist pretty well in a Windoze bootcamp - so long as
I only have to *read* the Wincrap, not put it out :)

Now that I have my Fvwm config tweaked, I hardly ever touch it.  Even
when upgrading, I often just put the tried and true config in place
and it's like magic.  Everything works.  The only thing I have to
fiddle with regularly is the menus.

And fast?  Forget it!  It's the fastest thing I've seen on a computer!
(especially now that I'm on FreeBSD :)

And just try to restart you MS window manager without dumping EVERY
app running into the crapper!  I'm always tweaking my menu then
restarting the wm so I don't have to think about it.  It's just there.

My $0.02
Lou
-- 
Louis LeBlanc       [email-masked]
Fully Funded Hobbyist, KeySlapper Extrordinaire :)
http://acadia.ne.mediaone.net                 Ô¿Ô¬

Madness has no purpose.  Or reason.  But it may have a goal.
    -- Spock, "The Alternative Factor", stardate 3088.7

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Jul 2001 17:57:24 +0200

> Blegh. Why don't you use a proprietary binary format, while you're at it?

Hey, I might get some ideas for the .fvwm2rc format!  :-)=)

> I think one of the problems with fvwm is that it is vastly underrated.

So true.  Fvwm is often referred to in statements like 'blablaWM
can be configured for the simple fvwm look as well as ...'.  And
just look at the config that comes with SuSE!  It's so ugly, I
can't even fathom why I ever chose fvwm.

> Few people seem to know how beautiful it can be, as well as functional.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Jul 2001 17:48:08 +0200

> enlightenment, sawfish, kde, and the likes.

We have taken great pains to make the fvwm code fast, but with
the feature list growing and growing some things start to slow
down noticably.  Moving windows is a fine example.  With all that
paging and SnapAttraction stuff going on it is definitely slower
than on some other window managers.  Also, the code drawing
complex window decorations could be much faster.

> the 0,0 corner, i am in love....)

I've seen window managers that are no lager than 40k or so and
probably very fast.

> that time to enhance things that are there ... 

Yes, it's a shame.  I often take a look at other window managers
like enlightenment, kwm, blackbox, icewm or saawmill.  They all
have some nifty features (e.g. the window decoration code in E or
some menu features in icewm), but when it comes down to usability
there is almost nothing you can configure to your likings.

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Jul 2001 18:04:14 +0200

On Wed, Oct 10, 2001 at 07:32:47AM -0400, Louis LeBlanc wrote:
> and AfterStep.  Not sure why Fvwm isn't first.

Well, that poll has been around for years without any significant
changes :-)

Bye

Dominik ^_^  ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 10 Jul 2001 18:03:02 +0200

> This is the definition of desktops?

No, not exactly :-)

A 'desktop environment' does a whole lot more than a window
manager - it depends on an underlying WM, e.g. dtwm for CDE, kwm
for KDE, sawmill for gnome etc.  Usually, the WM can be replaced
with a different one.  I guess the ratings on the web site refer
to the defaultt window manager coming with the desktop
environment.  DEs aim at providing a consistent application
framework like a common help engine, printing services and tool
bars.

Bye

Dominik ^_^  ^_^