Subject: Re: FVWM: FvwmIconMan

From: Dominik Vogt <[email-masked]>
Date: Thu, 30 Sep 2021 22:57:09 +0200

On Sun, Sep 30, 2001 at 11:11:51AM -0400, Jean-Pierre Sutto wrote:
> Hi,
> 
> I'm using fvwm2-2.2.4 and FvwmIconMan. I have some little questions.
> Howto:
> 
> 1) center the name in each box ?

I don't think there is an option to control this.

> 2) mark the name of a window to reflect when it's iconified. For example
> parenthesis as in WinList ? Or a different color ?

A small box should appear next to the label when the window is
iconified.

> 3) I tried fvwm-2.4.0, and with the same ~/.fvwm2rc file, the
> FvwmIconMan have now a gray outline and a 3D push/depress effect that I
> don't like. Where does it come from and how can I remove it ?

You're probably not happy with the new hilight colour
calculations.  In 2.4.x, there are several ways to control this.
First, if you simply want a flat, non-3d look, you should use
'flat' instead of 'up' or 'down' in your config.  Second, hilight
and shadow colours can be controlled with colour sets (try
"man FvwmTheme" for details).

> Here is my actual setting in ~/.fvwm2rc:
 
> Module FvwmIconMan

This line beongs after the config lines for FvwmIconMan or in your
InitFunc/RestartFunc.

> Style FvwmIconMan NoTitle,NoHandles,WindowListSkip,BorderWidth 0,NoIcon,
> CirculateSkip,Sticky
> *FvwmIconMan*nummanagers 1
> *FvwmIconMan*Action Mouse 1 N sendcommand Focus-and-Raise
> *FvwmIconMan*Action Mouse 2 N sendcommand Iconify
> *FvwmIconMan*background black
> *FvwmIconMan*ButtonGeometry 978x0
> *FvwmIconMan*drawicons False

> *FvwmIconMan*focusbutton up yellow black
> *FvwmIconMan*focusbutton down yellow black

It does not make sense to first specify 'up' looks and the
override them with 'down'.

> *FvwmIconMan*focusandselectbutton up yellow black
> *FvwmIconMan*focusandselectbutton down yellow black
> *FvwmIconMan*Font -adobe-helvetica-bold-r-normal--10-*-75-75-*-*-iso8859-1
> *FvwmIconMan*Foreground blue
> *FvwmIconMan*Format %i
> *FvwmIconMan*iconname (FvwmIconMan)
> *FvwmIconMan*ManagerGeometry 1x1+0-0
> *FvwmIconMan*plainbutton up white black
> *FvwmIconMan*plainbutton down white black
> *FvwmIconMan*selectbutton up white black
> *FvwmIconMan*selectbutton down white black
> *FvwmIconMan*shape false
> *FvwmIconMan*title .
> *FvwmIconMan*usewinlist True
> *FvwmIconMan*followfocus True
> *FvwmIconMan*sort None

This config works for me:

  DestroyModuleConfig FvwmIconMan*
  Style FvwmIconMan NoTitle,NoHandles,WindowListSkip,BorderWidth 0,NoIcon, CirculateSkip,Sticky
  *FvwmIconMan*nummanagers 1
  *FvwmIconMan*Action Mouse 1 N sendcommand Focus-and-Raise
  *FvwmIconMan*Action Mouse 2 N sendcommand Iconify
  *FvwmIconMan*background black
  *FvwmIconMan*ButtonGeometry 978x0
  *FvwmIconMan*drawicons False
  *FvwmIconMan*focusbutton flat yellow black
  *FvwmIconMan*focusandselectbutton flat yellow black
  *FvwmIconMan*Font -adobe-helvetica-bold-r-normal--10-*-75-75-*-*-iso8859-1
  *FvwmIconMan*Foreground blue
  *FvwmIconMan*Format %i
  *FvwmIconMan*iconname (FvwmIconMan)
  *FvwmIconMan*ManagerGeometry 1x1+0-0
  *FvwmIconMan*plainbutton flat white black
  *FvwmIconMan*selectbutton flat white black
  *FvwmIconMan*shape false
  *FvwmIconMan*title .
  *FvwmIconMan*usewinlist True
  *FvwmIconMan*followfocus True
  *FvwmIconMan*sort None
  
  Module FvwmIconMan

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Jean-Pierre S u t t o)
Date: Wed, 3 Oct 2001 18:51:36 -0400 (EDT)

> I don't think there is an option to control this.

Not very important.

> A small box should appear next to the label when the window is

Good. I see it in fvwm-2.4.0. I had not noticed it in fvwm2-2.2.4.
And, for curiosity, is it a way to turn this fonction off ?

[...]

>   *FvwmIconMan*followfocus True

Great. All works well now with fvwm-2.4.0. I was sure it was a solution, but
wasn't unable to find it myself. Thanks.

-- 
Jean-Pierre Sutto             -+-            Attention: je suis vexable.
Photographies: <http://jpsn.free.fr/photos/index.html>
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Oct 2001 13:01:38 +0200

> And, for curiosity, is it a way to turn this fonction off ?

I looked at the code and it doesn't seem to be possible to turn
off the boxes.  It looks as if mini icons are drawn over the box
if they are used, but I didn't try that.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Jean-Pierre S u t t o)
Date: Thu, 4 Oct 2001 22:15:10 -0400 (EDT)

> if they are used, but I didn't try that.

Strange however that I don't see these boxes using fvwm2-2.2.4 with the
same config file...