Subject: FVWM: Strange behavour of command Move

From: Marcus Lundblad <[email-masked]>
Date: Wed, 31 Oct 2001 01:59:03 +0100 (CET)

If the command "Move" is used from a menu in a window when the
mousepointer is outside of the window and the keyboard is used to move the
window, the window stoppes when the pointer (not the window) reaches the
border of the screen.

Is is intended that the pointer is suppoed to follow the movement?
(I have sloppy focus on all windows)

This is using 1x1 desks (1 frame per desk)

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 31 Oct 2001 10:10:28 +0000

> This is using 1x1 desks (1 frame per desk)

Yes, this is the way it works.

If you want pointer not to disturb the movement, you may warp it first:

  AddToMenu WindowOps
  + "Move to right or bottom" MoveToRightBottom
  + "Move to left or top"     MoveToLeftTop

  DestroyFunc MoveToRightBottom
  AddToFunc   MoveToRightBottom
  + I WarpToWindow 0 0
  + I Move

  DestroyFunc MoveToLeftTop
  AddToFunc   MoveToLeftTop
  + I WarpToWindow 100 100
  + I Move

Or if you want to move a window partially outside the screen use Move from
the window borders not the window menu:

  Mouse 2 TSF A MoveOrRaiseLower

  DestroyFunc MoveOrRaiseLower
  AddToFunc   MoveOrRaiseLower
  + H Move
  + M Move
  + C RaiseLower

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Oct 2001 14:11:30 +0100

> This is using 1x1 desks (1 frame per desk)

That should already be fixed in CVS.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 31 Oct 2001 15:43:10 +0100

> That should already be fixed in CVS.

Oops, I misread the problem. please ignore me :)

Bye

Dominik ^_^  ^_^