Subject: FVWM: wait cursor

From: "Riswick, J.G.A. van" <[email-masked]>
Date: Wed, 17 Oct 2001 14:16:26 +0200

HI

I tried to set the 'wait' cursor to my own xpm file by 
using

CursorStyle WAIT /home/jos/waitcursorshade.xpm
BusyCursor * True

but still, my wait cursor is not displayed.
Eg when I start netscape from the commandline, 
I still see a watch. To see if the xpm file
is valid I tried

CursorStyle NORMAL /home/jos/waitcursorshade.xpm

Then I do see the my cursor, however the black
and white colors are reversed. After I manually 
reversed the colors in the xpm file, it displayed
correctly. I use fvwm-2.4.2. Should the cursor 
maybe be bm file?

best regards

jos
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 17 Oct 2001 20:57:49 +0000

On 17 Oct 2001 14:16:26 +0200, Riswick, J.G.A. van wrote:
> 
> I tried to set the 'wait' cursor to my own xpm file by using
> 
> 

There is no cursor context NORMAL (there is DEFAULT), so I don't know what
exactly worked for you.

The pixmap cursor should be xpm with 3 colors:

  None    - the transparent part
  black   - outer cursor color (foreground)
  white   - inner cursor color (background)

As usual you may specify actual colors in the CursorStyle command itself:

  CursorStyle ROOT top_left_arrow.xpm yellow navy

If you have fvwm-themes, take a look under themes/multichoice/cursors/,
there are several pixmap cursor configs and xpms.

Send your waitcursorshade pixmap if you still have problems with it.

Regards,
Mikhael.