Subject: FVWM: constraining "maximized" window to some portion of the screen

From: Denis Perelyubskiy <[email-masked]>
Date: Sun, 14 Oct 2001 18:20:32 -0700

hello,

is it possible to maximize a window, but so that it only
goes up to something like 150 pixels from the top of the
page, but takes up the whole width?

thanks,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 15 Oct 2001 12:20:25 +0200

> page, but takes up the whole width?

I don't exactly understand if you want.  Try one of these:

  # 150 pixels high at 0 0
  Maximize 0 +150p

  # (screen height - 150 pixels) at 0 0
  Maximize 0 -150p

  # 150 pixels high at bottom of screen
  AddToFunc MaximizeAtBottom
  + I Maximize $0 $1
  + Move -0 -0
  MaximizeAtBottom 0 150p

  # (screen height - 150 pixels) at bottom of screen
  AddToFunc MaximizeAtBottom
  + I Maximize $0 $1
  + Move -0 -0
  MaximizeAtBottom 0 -150p

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Thu, 18 Oct 2001 20:51:55 -0700

>I don't exactly understand if you want.  Try one of these:
  [...]
  >  AddToFunc MaximizeAtBottom
  [...]

i wanted almost this, thanks! (i should've looked in the
manual pages more, but Move -0 -0 is a nice trick which i
did not know about)

   + "I" Maximize $0 $1
   + "I" Move -0 -0

   MaximizeAtBottom 100 -90p

the problem now, however, is that once i maximize the
window, it is fine, but once i click my button to
de-maximize it, it stays with its lower-right corner in the
lower-right portion of the screen. this makes sense, since
that's exactly what Move -0 -0 did.

the question, is whether i can somehow figure out where the
window was positions before executing my MaximizeAtBottom,
and moving the window back?

thanks,

denis