Subject: FVWM: What do "D" "I" "C" "M" etc. stand for in a function context

From: Glen Lee Edwards <[email-masked]>
Date: Wed, 26 Sep 2001 15:06:14 -0500 (CDT)

In the following context:

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

what do "I" "M" "D" etc., stand for, and what man page can I find them referenced
in?

Glen

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Denis Perelyubskiy <[email-masked]>
Date: Wed, 26 Sep 2001 14:16:20 -0700

* Glen Lee Edwards <[email-masked]> [09-Wed-01 14:06 -0700]:
 [...]
 >what do "I" "M" "D" etc., stand for, and what man page can I find them referenced
 [...]

dont remember the rest, but "D" is double-click.
man fvwm2, then search for "D"

hth,

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Keith Kaple <[email-masked]>
Date: Wed, 26 Sep 2001 17:37:43 -0400

>From the man page:

The  quoted portion of the function tells what kind
of action will trigger the  command  which  follows
it.   "I"  stands for Immediate, and is executed as
soon as the function is invoked.   "M"  stands  for
Motion,  i.e.  if the user starts moving the mouse.
"C" stands for Click, i.e., if the user presses and
releases  the  mouse  in  a  short  period  of time
(ClickTime milliseconds).  "D" stands  for  double-
click.   The  action "I" will cause an action to be
performed on the button-press, if the  function  is
invoked with prior knowledge of which window to act
on.

-- 
------------------------------------------------
Keith Kaple                   |           |       	
919-392-5759                 |||         |||       
RTP, NC                     |||||       |||||    
Packet Telephony         .:|||||||:...:|||||||:.
------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Sep 2001 15:21:00 +0200

> what do "I" "M" "D" etc., stand for, and what man page can I find them referenced

 "C"lick
 "D"oubleclick
 "M"otion
 "I"mmediate
 "H"old

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Sep 2001 10:02:52 -0400

Dominik Vogt <[email-masked]> writes:
> > what do "I" "M" "D" etc., stand for, and what man page can I find them
> > referenced in?
> 
>  "C"lick
>  "D"oubleclick
>  "M"otion
>  "I"mmediate
>  "H"old

They are described in the 
"COMMANDS FOR USER FUNCTIONS AND SHELL" section
right near the front of the AddToFunc description.
They don't really have a name, they are just referred to
as "The letter before the action".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joseph Manning <[email-masked]>
Date: Thu, 27 Sep 2001 15:14:09 +0100 (IST)

>> > what do "I" "M" "D" etc., stand for, and what man page can I find them referenced

While on this topic, I would like to ask about the double quotes
around the "C", "D", "M", "I", "H".

Although I see them in many of the examples posted here,
they are not present in the examples on the fvwm2 man page.
I happily omit the quotes in my .fvwm2rc, and things work just fine.

If they are not needed, why does anyone use them?  Backward compatibility?

Cheers, Joseph

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Joseph Manning / Computer Science / University College Cork / [email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Thomas Adam <[email-masked]>
Date: Thu, 27 Sep 2001 16:03:36 +0100 (BST)

--- Joseph Manning <[email-masked]> wrote: > On
> If they are not needed, why does anyone use them? 

I doesn't matter if you use them or not. I use them,
for asthetic purposes only, since it makes it easier
when editing my "fvwm2rc.functions.m4" file :-)

So either way, it doesn't matter...

Regards,

Thomas Adam

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 27 Sep 2001 17:48:38 +0200

> If they are not needed, why does anyone use them?  Backward compatibility?

I think they were necessary in some obscure, very outdated
version.  Many people simply have not yet updated their config
files and removed them because they are still allowed.  You won't
find the double quotes in the current man page anymore.

Bye

Dominik ^_^  ^_^