Subject: FVWM: GotoDeskAndPage prev

From: Marcus Lundblad <[email-masked]>
Date: Fri, 7 Sep 2001 23:23:30 +0200 (CEST)

I have set up a command bind to Meta-Tab like this:
Key Tab          A       M	 GotoDeskAndPage prev

to switch to the page (and desk visited last), but I doesn't behave as I
would expect.
Example: I have 4 desks with each desk having 2x2 pages.
Visit desk 1 page (0,0) then desk 2 page(0,0) then desk 2 page(1,0)
Now I use my shortcut, it goes back to desk 1 page (0,0)
So it seems it considers I visited desk 1 before desk 2 beacause the last
switch was within the same desk.
Is this intentional? If so can the behaviour I desire be implemented,
perhaps using FvwmBacker?

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 9 Sep 2001 02:50:12 +0200

On Fri, Sep 07, 2001 at 11:23:30PM +0200, Marcus Lundblad wrote:
> Is this intentional?

I guess nobody thought of this case yet.  I'll make a patch that
fixes it in 2.4.1.  For the moment, You could do so by using a
kind of dynamic function that is changed whenever one of the
Goto... functions is used:

  Key Tab A M MyGotoPrevDeskAndOrPage
  AddToFunc MyGotoPrevDeskOrPage
  + I GotoDeskAndPage prev

  AddToFunc MyGotoPage
  + I GotoPage $0 $1
  + I DestroyFunc MyGotoPrevDeskAndOrPage
  + I AddToFunc MyGotoPrevDeskAndOrPage I GotoPage prev

  AddToFunc MyGotoDesk
  + I GotoPage $0 $1
  + I DestroyFunc MyGotoPrevDeskAndOrPage
  + I AddToFunc MyGotoPrevDeskAndOrPage I GotoDesk prev

  AddToFunc MyGotoDeskAndPage
  + I GotoPage $0 $1 $2
  + I DestroyFunc MyGotoPrevDeskAndOrPage
  + I AddToFunc MyGotoPrevDeskAndOrPage I GotoDeskAndPage prev

Then replace all occurences of GotoDesk, GotoPage and
GotoDeskAndPage with MyGoto... in your config file (should work in
priciple, but completely untested).

> If so can the behaviour I desire be implemented,

FvwmBacker won't help here.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].