Subject: FVWM: Fvwm (2.4.0): FvwmButtons, FvwmPager and "Desker"

From: Thomas Adam <[email-masked]>
Date: Sat, 8 Sep 2001 22:11:54 +0100 (BST)

Dear List,

I have just upgraded my version of FVWM to 2.4.0 and I
have to say that it is awesome. Thank you to everyone
that spends their time contributing to it :-)

I was most intrigued by the "Desker" module. I like
the idea of having a retractable desktop view. My
question concerns this. Before I upgraded,
FvwmButtons, would swallow a 2x2 desktop panel and
place that in
the bottom right-hand corner of my screen.

Is it possible to replace the four desktops which are
currently assigned to FvwmDesker, and make the Desker
module swallow my original 2x2 desktop pane (which is
swallowed by FvwmButtons) and which also takes up the
geometry in the bottom right-hand corner?? I would
also like the side button (the one which retracts and
opens the sliding panel), to take on the height of the
2x2 deskop pane. I have tried everything but I cannot
seem to do it. 

My ORIGINAL module code(s) for FvwmPager and
FvwmButtons are included below.

Thanks in Anticipation,
Regards,

Thomas Adam

----------------------snip: code
(original)-----------------------------------------
###########################################################################
##### FvwmButtons
*FvwmButtonsFore WINFORE_COLOR
*FvwmButtonsBack WINBACK_COLOR
#*FvwmButtonsFont
BASIC_FONT-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmButtonsFont None
define(`FVWM_BUTTONS_WIDTH',eval(50 + 50 *
NUM_DESKTOPS))
*FvwmButtonsGeometry
FVWM_BUTTONS_WIDTH`'x50-0-BOTTOM_EDGE
# Layout: specify rows or columns, not both
*FvwmButtonsRows 1
# Define the buttons to use.....
#*FvwmButtons(Swallow XLoad 'Exec nice NICELEVEL xload
-nolabel -geometry 32x20+0+0 -bg grey60 -update 5')
#*FvwmButtons(Swallow xclock 'Exec nice NICELEVEL
xclock -nolabel -geometry 32x20+0+0 -bg grey60 -update
5')
ifelse(`NUM_DESKTOPS', `', `',
`NUM_DESKTOPS', `0', `',
*FvwmButtons(NUM_DESKTOPS`'x1,Swallow "FvwmPager"
"FvwmPager 0 decr(NUM_DESKTOPS)")
)
Style "FvwmButtons"	StickyOnTop, WinCircSkip,
NoDecoration

###########################################################################
##### Pager - each module configures the pager in it's
own way
Style "FvwmPager"	StickyOnTop, WinCircSkip,
NoDecoration
*FvwmPagerFont -BASIC_FONT-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerGeometry +0+0
*FvwmPagerDeskTopScale 40
*FvwmPagerLabel 0 Linux
*FvwmPagerLabel 1 Penguin
*FvwmPagerSmallFont SMALL_FONT
#*FvwmPagerBack #908090
#*FvwmPagerFore #484048
*FvwmPagerHilight #CAB3CA
*FvwmPagerBack WINBACK_COLOR
*FvwmPagerFore WINFORE_COLOR
*FvwmPagerWindowColors WINFORE_COLOR WINBACK_COLOR
HILIGHTFORE_COLOR HILIGHTBACK_COLOR
*FvwmPagerBalloons
*FvwmPagerBalloonBack	bisque
*FvwmPagerBalloonFore	black

--------------------------------end: snip code---------------------------------------------------------

=====
Thomas Adam

"The Linux Weekend Mechanic" -- www.linuxgazette.com

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 10 Sep 2001 23:15:31 +0200

> that spends their time contributing to it :-)

:^)

> the bottom right-hand corner of my screen.

Actually, there is no FvwmDesker module that comes with fvwm, so
its hard for me to answer your question.

> FvwmButtons are included below.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].