Subject: FVWM: alternative to xsetroot

From: Johannes Zellner <[email-masked]>
Date: Fri, 7 Sep 2001 00:53:18 +0200

Hi,

I'm looking to a program similar to xsetroot which takes a bitmap
and fg and bg colors but doesn't tile as xsetroot, if the bitmap
is smaller than the root window. What I'm doing is something like

DestroyFunc FuncBackground
AddToFunc FuncBackground
+ "I" Exec exec xsetroot -bitmap $HOME/.fvwm/$[page.ny]$[page.nx].xbm -bg \#386da6 -fg \#3060a0

which gets triggered each time I change pages.
The xbm files are much smaller than the root window and it would be nice
to specify where they should be placed on the root window.

-- 
   Johannes
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 7 Sep 2001 03:40:39 +0200

> is smaller than the root window. What I'm doing is something like

xv can do this:

  $ xv -root -quit -viewonly -rbg red +noresetroot -rmode 5 foo.xpm
 
> which gets triggered each time I change pages.

Then you should also use the FvwmBacker module (man FvwmBacker).

> to specify where they should be placed on the root window.

Refer to the xv postscript documentation for further details.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].