Subject: FVWM: hmm, location of system.fvwm2rc? + Swallow

From: "Nikolaj G." <[email-masked]>
Date: Mon, 10 Sep 2001 03:39:51 -0700 (PDT)

Stupid question, you might think, but where is fvwm2rc
located. Iv'e made the standard installation
(compiled, and no changes of paths) of 2.4, with
Themes-base + Themes-extra (0.5) ? Been looking at the
themes-rc and so on, but it doesn't seem to reflect my
menu?

Finally, Im using "wminet" (can only recommend that
program) and dont want the captionbar, howto remove
that? Tried with swallow, without luck. Thanks. /nikolaj

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger
http://im.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tenebrae <[email-masked]>
Date: Mon, 10 Sep 2001 06:22:56 -0700 (PDT)

> themes-rc and so on, but it doesn't seem to reflect my

locate fvwm2rc
find / -name .fvwm2rc* -print
find / -name fvwm2rc* -print
(you get the idea)

Hopefully one of those will return something...
								-Tenebrae.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 16 Sep 2001 03:09:47 +0000

> themes-rc and so on, but it doesn't seem to reflect my

You should choose whether to use your own fvwm2rc or the fvwm-themes
functionality in which case you should create your personal configuration
parts in the format that fvwm-themes expects, see the FVWM Themes FAQ.

As for the location of system.fvwm2rc, run the following to find it out:

  % fvwm-config --fvwm-datadir

For compatibility reasons (only) FVWM also searches for system.fvwm2rc in
this directory:

  % fvwm-config --sysconfdir

We suggest to put all system wide configuration files into FVWM_DATADIR
that is by default /usr/local/share/fvwm, or /usr/share/fvwm in rpm.

User configuration file .fvwm2rc is searched in:

  % fvwm-config --default-userdir

that is $HOME/.fvwm starting from 2.3.17.
For compatibility reasons (only) this file is also searched in $HOME.
And to be complete, .fvwm2rc is also searched in FVWM_DATADIR as usual.

Here is the search order, the first found file is used:

  $FVWM_USERDIR/.fvwm2rc        # /home/joe/.fvwm/.fvwm2rc
  $HOME/.fvwm2rc                # /home/joe/.fvwm2rc (compatibility only)
  $FVWM_DATADIR/.fvwm2rc        # /usr/local/share/fvwm/.fvwm2rc
  $FVWM_DATADIR/system.fvwm2rc  # /usr/local/share/fvwm/system.fvwm2rc
  $SYSCONFDIR/system.fvwm2rc    # /usr/local/etc/system.fvwm2rc (compat.)

Note, the existing interface to fvwm-config is intended to be supported
forever (that can't be said for configuration directories and file names)
and it should be used to query your existing FVWM instalation, see:

  http://fvwm.org/generated/manpages/fvwm-config.html

Regards,
Mikhael.

---

From: "Nikolaj G." <[email-masked]>
Date: Sun, 16 Sep 2001 01:52:49 -0700 (PDT)

Hi Mikhael
Just read your mail (not at home) - thanks. I'll try
it out when I get back. But still, none of my
system.fvwm2rc or .fvwm2rc files around (locate) has
anything to do with my installation (?) - anyway, I'll
have to read the theme-faq and the other documentation
before asking more, I think. Also to try the
"fvwm-config", never tried it, so maybe it reveals
some other info. Ok, I'll get back. Thanks. /nikolaj

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].