Subject: FVWM: colormap issues

From: Craig Morris <[email-masked]>
Date: Thu, 27 Sep 2001 14:38:25 -0700 (PDT)

Perhaps you can help me out.  I am running on a SGI
O2. 

I was previously using irix 6.3.  The default window
manager had trouble allocating colormaps when too many
programs were open.  I switched to fvwm 2.2.4 and saw
no colormap issues since.

Recently I was just upgraded to irix 6.5.  The new
default window manager did not seem to have any
colormap issues.  I compiled the latest fvwm 2.4.2 and
the colormap issues have come back big time.  I get
"cannot allocate colormap entry for xxx" after only
having as little as two apps running (ie netscape and
the cdplayer).

I have tried both FollowsFocus and FollowsMouse and it
does not seem to make a difference.  Any suggestions?

Thanks
Craig

__________________________________________________
Do You Yahoo!?
Listen to your Yahoo! Mail messages from any phone.
http://phone.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Sep 2001 19:30:34 -0400

> does not seem to make a difference.  Any suggestions?

Focus settings won't make any difference.

You must be running with a limited colormap, most likely
256 colors.  If you think your hardware should allow you
to display more colors, you should look into what you have
to do to accomplish that.  The rest of this assumes you
have to run with a limited colormap.

Netscape will always take all available colors,
if there are 240 colors available when netscape
starts, it will take 240.
You must run Netscape with the "-install" argument.

There are a few other badly behaved applications,
anything tk based (exmh), and FrameMaker come to mind.
Let me know if you are using either of those,
I have fixes for them.

FVWM 2.4.x will automatically limit the amount
of color it uses in icons and pixmaps.
You can't use FVWM gradients with a limited colormap.

I have a program called "colormap" that will show you
the number of free colors in your colormap.  If you still
don't know which program is using up your colors, this
program may help.  If you'd like a copy let me know.

I think I've covered everything in the FVWM FAQ question
6.7, but you may want to check it out anyway.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].