Subject: FVWM: Upgrading 2.2.4 to 2.4.0

From: Bart Schaefer <[email-masked]>
Date: Fri, 14 Sep 2001 13:02:46 -0700 (PDT)

Is there any reason I should be concerned that my fvwm2rc from 2.2.4 will
not work correctly with 2.4.0?

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Sep 2001 16:21:58 -0400

> not work correctly with 2.4.0?

2.4.0 comes with a conversion script that will take care of
the minor differences bewteen 2.2.4 and 2.4.0.

After you install 2.4.0, try:

man fvwm24_convert

or you can go over to www.fvwm.org, pick "Manual Pages" and then
"fvwm24_convert.1".

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bart Schaefer <[email-masked]>
Date: Fri, 14 Sep 2001 18:50:50 -0700 (PDT)

> the minor differences bewteen 2.2.4 and 2.4.0.

Thanks.  I had two small problems I thought I should report.

First, fvwm-2.4.0-2.i386.rpm requires libstroke.so.0, which is not present
by default on any version of RedHat.  Fortunately, the Mandrake cooker RPM
libstroke0-0.5.1-1mdk.i586.rpm installed fine for me.

Second, I had trouble with fvwm24_convert, because of this:

if ( $source eq "") {
  $source = "$$HOME/.fvwm2rc";
}

and this:

if ($dest eq "") {
  $dest = "$$HOME/.fvwm/.fvwm2rc";
}

I don't know what $$HOME is supposed to mean; it should be $ENV{HOME}.

---

From: Dan Espen <[email-masked]>
Date: Fri, 14 Sep 2001 22:41:11 -0400

> libstroke0-0.5.1-1mdk.i586.rpm installed fine for me.

No comment on this.

> I don't know what $$HOME is supposed to mean; it should be $ENV{HOME}.

My mistake.  
Its already fixed and will be in 2.4.1.
I should have warned you.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 15 Sep 2001 10:02:19 +0200

> libstroke0-0.5.1-1mdk.i586.rpm installed fine for me.

If the stroke library is not present on the machine where fvwm is
build, stroke support should not be compiled in.  Can you provide
the relevant portions of the config.log file generated by
configure?

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 15 Sep 2001 06:41:08 -0400

> the relevant portions of the config.log file generated by

There was no configure, Bart was using an RPM.

---

From: Bart Schaefer <[email-masked]>
Date: Sat, 15 Sep 2001 10:28:37 -0700 (PDT)

> the relevant portions of the config.log file generated by

No, I can't, because I didn't compile fvwm.  I got the binary RPM from the
downloads page on www.fvwm.org and installed it.  I was merely reporting
that whoever built the RPM did so on a machine that had a "nonstandard"
library installed.  The downloads page says it's suitable for installing
on RedHat 6.x and 7.x, but that isn't quite accurate.