Subject: FVWM: FvwmPager -transient and Focus

From: Shao Zhang <[email-masked]>
Date: 04 Sep 2001 15:53:11 +1000

Hi,

I have the following binding defined in my .fvwm2rc:
Key quoteleft   A       M     Module FvwmPager -transient 0 3

It works fine, except that when pressing the key in an active window, the
FvwmPager is brought up, but the focus stays in the active window. This prevents
me of using arrow keys to move between the virtual desktop. After reading man
pages, I tried this with no luck: Style "FvwmPager" GrabTransientFocus

Thanks for any help in advance.

Regards,

Shao.
-- 
Shao Zhang                          Tel:  (02) 9209 4838
Software Engineer                   Fax:  (02) 9209 4992
Redfern Broadband Networks (RBN)    Mail: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 4 Sep 2001 11:29:48 +0200

> Hi,

Please state which fvwm release you use.

> pages, I tried this with no luck: Style "FvwmPager" GrabTransientFocus

First of all, the right style is GrabFocusTransient, not
GrabTransientFocus.  Anyway, the pager only behaves like a
transient window, but does not set the transient hint for fvwm (I
will fix this), so you have to use

  Style FvwmPager GrabFocus

instead of GrabFocusTransient.  If that does not help, the Pager
may have set the wrong focus policy, e.g. NeverFocus.  If you
can't figure it out on your own, I can take a look at your config
file.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Shao Zhang <[email-masked]>
Date: 05 Sep 2001 10:18:18 +1000

Hi,

> Please state which fvwm release you use.

Sorry, I am using 2.4.0 on FreeBSD 4.2.

>   Style FvwmPager GrabFocus

I have tried them all.

GrabFocus/GrabFocusTransient/NeverFocus all behaves the same.
That is, when press the key in the background, the pager is focused, 
when press the key in one of the active window, the pager is not focused.

On the second thought, I would actually prefer the behaviour NeverFocus for
FvwmPager -transient assuming it works, but then I don't know how to turn 
it off using a key.

> can't figure it out on your own, I can take a look at your config

Thanks for the help. I have uploaded all my fvwm config file here:
http://linux.blueskyhost.com/~shao/fvwm/

.fvwm2rc is renamed to fvwm2rc in order for apache to pickup.

Regards,

Shao.

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 16 Sep 2001 01:10:41 +0200

> .fvwm2rc is renamed to fvwm2rc in order for apache to pickup.

Ah, I see.  The transient pager should actively grab the keyboard
on one hand and asks not to be focused on the other hand.  I will
fix this.  In the mean time,

  Style FvwmPager GrabFocusTransient, Lenience

should help.

Bye

Dominik ^_^  ^_^