Subject: FVWM: Window placement on restart with multiple pages.

From: Marcus Lundblad <[email-masked]>
Date: Sun, 16 Sep 2001 18:30:43 +0200 (CEST)

Hi!

I have noted that sometime windows are moved to page 1,1 in their desk
when fvwm2 is restarted.
This happens to xv's windows but not mozilla and rxvt f.ex.
I have compiled 2.4.1 myself. But this happend in 2.4.0 also.
This is on a RH 7.1 Linux machine.

//Marcus

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Sep 2001 13:48:03 +0200

> This is on a RH 7.1 Linux machine.

Can you explain 'sometimes' in more detail?  What would I have to
do to make it happen on my machine?  How do you restart fvwm
(which options)?

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 17 Sep 2001 13:50:06 +0200

> This is on a RH 7.1 Linux machine.

... and does it happen with any applications other than xv?  xv
has a strange notion of window management.  When the WM dies, it
moves itself around and often interferes with the WMs placement
when fvwm starts up again.

Bye

Dominik ^_^  ^_^

---

From: Marcus Lundblad <[email-masked]>
Date: Mon, 17 Sep 2001 17:57:17 +0200 (CEST)

> when fvwm starts up again.

It actually only seems to happen with xv's windows. Sometimes was a bit
vague description...
I suspected it might be a problem on application level...

//Marcus

---

From: Denis Perelyubskiy <[email-masked]>
Date: Mon, 17 Sep 2001 10:07:55 -0700

>when fvwm starts up again.

i've seen this with applications other then xv. cant
pinpoint now, i will let you know if there is  a erliable
way to reproduce.

denis

-- 
// mailto: Denis Perelyubskiy <[email-masked]>
// icq   : 12359698
// PGP   : http://www.cs.ucla.edu/~denisp/files/pgp.asc
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Erik Steffl <[email-masked]>
Date: Wed, 19 Sep 2001 08:34:30 -0700

> when fvwm starts up again.

  I have seen the same thing happen. it also happens when you ask xv to
display another picture and switch to another screen before it actually
displays the picture.

  it looks like the xv picture window is actually deleted and a new
window is created when picture is displayed (or re-displayed, like in
the case of fvwm restart).

	erik