Subject: FVWM: pre-stretching an xterm

From: Randy Bush <[email-masked]>
Date: Tue, 04 Sep 2001 13:23:56 -0700

in tvtwm, i had it so that 
  o when i opened an xterm
  o it was manually placed
  o if i placed it with f1 all is as you expect
  o if i placed it with f3, it extended to the bottom of the screen

i have not been able to figure out how to do this in fvwm2.  any clues
appreciated.

randy
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: J C Lawrence <[email-masked]>
Date: Tue, 04 Sep 2001 13:54:04 -0700

On Tue, 04 Sep 2001 13:23:56 -0700 
Randy Bush <[email-masked]> wrote:

> i have not been able to figure out how to do this in fvwm2.  any
> clues appreciated.

I can't answer your question directly as I haven't investigated
placement, but the following may help:

  Key F10         WFST    M       MaximiseVertically
  Key F10         WFST    C       MaximiseHorizontally
  Key F10         WFST    S       MaximiseMaximise

  Key F11         WFST    M       MaximiseHalfVertically
  Key F11         WFST    C       MaximiseHalfHorizontally
  Key F11         WFST    S       MaximiseHalfMaximise

  Mouse    0  2      A       Maximize-Func
  Mouse    1  2      A       Maximize-Func 0 100
  Mouse    2  2      A       Maximize-Func 100 0
  Mouse    3  2      A       Maximize-Func 100 100
  Mouse    0  4      A       Iconify

  AddToFunc Maximize-Func    "C" Maximize   $0 $1
  +                          "D" Maximize
  +                          "M" Resize

  AddToFunc MaximiseVertically       "I"  Maximize 0 100
  AddToFunc MaximiseHorizontally     "I"  Maximize 100 0
  AddToFunc MaximiseMaximise         "I"  Maximize 100 100 

  AddToFunc MaximiseHalfVertically   "I"  Maximize 0 50
  AddToFunc MaximiseHalfHorizontally "I"  Maximize 50 0
  AddToFunc MaximiseHalfMaximise     "I"  Maximize 50 50 

The above ripped out of my RC which can be found with screenshots
at:

  ftp://ftp.kanga.nu/pub/users/claw/screenshots/Desktop
  ftp://ftp.kanga.nu/pub/users/claw/screenshots/Desktop/JCL.Desktop.18.png
  ftp://ftp.kanga.nu/pub/users/claw/screenshots/Desktop/fvwm2rc

(I keep meaning to (and forgetting to) throw that at -workers for
inclusion in the fvwm.org screenshots)

-- 
J C Lawrence
---------(*)                Satan, oscillate my metallic sonatas.
[email-masked]               He lived as a devil, eh?
http://www.kanga.nu/~claw/  Evil is a name of a foeman, as I live.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Randy Bush <[email-masked]>
Date: Tue, 04 Sep 2001 14:18:26 -0700

>   AddToFunc MaximiseHalfMaximise     "I"  Maximize 50 50 

but how do i do it when i drop an xterm.  i.e. when i 

    AddToMenu rlogins "rlogins" Title
    +   "xterm"         Exec exec xterm -ls -sb -sl 500 -rw &

randy

---

From: Dan Espen <[email-masked]>
Date: Tue, 04 Sep 2001 19:10:30 -0400

> i have not been able to figure out how to do this in fvwm2.  any clues

The man page has something close to what you want but it uses
a mouse button.  Search for PlacedByButton3.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Randy Bush <[email-masked]>
Date: Tue, 04 Sep 2001 16:17:17 -0700

> a mouse button.  Search for PlacedByButton3.

yes!!!  and, idiot that i am, i meant mouse buttons, not fn keys anyway.
your prescience amazes me!:-)

randy