Subject: FVWM: followup to 664

From: Ravi Subramanya <[email-masked]>
Date: Thu, 27 Sep 2001 14:30:49 -0600

This is a followup to message 664 on the bug-list at the fvwm.org
website

We are having similar problems with
 - unpainted gui components
 - window migration to the top left with zero size etc.

when using java 1.3.1 on fvwm 2.2.4

would appreciate any information on whether there is there a fix in the
works ? 

thx
[email-masked]

============================Bug Report664=============================
Date: Wed, 25 Oct 2000 13:18:44 -0500 (CDT)
                 From: [email-masked]
                 To: [email-masked]
                 Subject: Java2 (1.2.2, 1.3) broken GUIs under fvwm2

                 Full_Name: Jason Gabler
                 Version: [FVWM][main]:  Fvwm Version 2.3.21 compiled on
Sep 15 2000 at
                 14:27:59

                 CVS_Date: 
                 OS: SunOS kinabalu 5.8 Generic sun4u sparc
SUNW,Ultra-5_10

                 X_Server: openwin
                 Submission from: (NULL) (209.101.239.108)

                 Using /usr/opewnin/bin/xinit with the version of fvwm2
described above
                 Java2 VM will not correctly draw many GUI components,
especially labels
                 and pictures.  I have run the same java classes using
the same VM
                 binaries under the same account using different window
managers (
                 including
                 twm and dtwm ) and not had these problems.  As a side
not fvwm seems to 
                 ingore AWT directions on how to layer Windows ( as
oppose to Frames ).
--------------5CBA90FE1C61C276665150EF
Content-Type: text/x-vcard; charset=us-ascii;
 name="ravi.vcf"
Content-Transfer-Encoding: 7bit
Content-Description: Card for Ravi Subramanya
Content-Disposition: attachment;
 filename="ravi.vcf"

begin:vcard 
n:Subramanya;Ravi
tel;fax:(505) 984-3070
tel;work:(505) 955-1400
x-mozilla-html:FALSE
org:Prediction Company
adr:;;;;;;
version:2.1
email;internet:[email-masked]
title:Sr. Systems Developer
x-mozilla-cpt:;-6056
fn:Ravi Subramanya
end:vcard

--------------5CBA90FE1C61C276665150EF--

---

From: Dan Espen <[email-masked]>
Date: Thu, 27 Sep 2001 23:05:15 -0400

> would appreciate any information on whether there is there a fix in the

I've been told that "J2SE v1.4 beta3" which should be released in
a month or so will work better with fvwm.

There may be some fvwm changes coming too.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].