Subject: FVWM: FVWM and Gnome Panel

From: Subba Rao <[email-masked]>
Date: Fri, 31 Aug 2001 06:44:06 -0400

I am ruuning FVWM2 version 2.4.0 on Slackware 8. I have started the GNOME
panel in FVWM. One of the features of the panel is that it has a menu style
tool bar along with the large panel bar at the bottom of the screen. The menu
style bar (I don't know what it is called) at the top is positioned a little
low on the physical screen. How do I move this mene style bar to the top of the
screen? I have attached a screen shot of the desktop to help you understand
what I am trying to explain.

Thank you in advance for any help.
-- 

Subba Rao
[email-masked]
http://members.home.net/subba9/

GPG public key ID CCB7344E
Key fingerprint = A8DD 4CBA 1E9B D962 A55B  2B55 BAFE 92C5 CCB7 344E

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 31 Aug 2001 13:23:08 +0200

> what I am trying to explain.

I guess that's a question for the GNOME developers.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Subba Rao <[email-masked]>
Date: Fri, 31 Aug 2001 09:30:23 -0400

> I guess that's a question for the GNOME developers.

I got this one straightened out. After I restarted the system, the top menu
bar at the top of the physical screen.

Another question related to FVWM + GNOME is, how to execute the FVWM "Quit"
function from the GNOME Panel ("Log Out")?
-- 

Subba Rao
[email-masked]

---

From: Allin Cottrell <[email-masked]>
Date: Fri, 31 Aug 2001 09:33:20 -0400 (EDT)

On Fri, 31 Aug 2001, Subba Rao wrote:

> I am ruuning FVWM2 version 2.4.0 on Slackware 8. I have started
> the GNOME panel in FVWM. One of the features of the panel is that
> it has a menu style tool bar along with the large panel bar at the
> bottom of the screen. The menu style bar (I don't know what it is
> called) at the top is positioned a little low on the physical
> screen. How do I move this mene style bar to the top of the
> screen?

This is a gnome issue, not an fvwm one.  Right-click on the panel and
go to panel, properties, type.  If it's not an "edge panel", make it
one or alternatively if it's a "floating panel" go to "All properties"
and adjust its geometry.

Allin Cottrell.

---

From: Subba Rao <[email-masked]>
Date: Fri, 31 Aug 2001 10:35:16 -0400

> one or alternatively if it's a "floating panel" go to "All properties"

I am opted to use GNOME session to manage the FVWM. I followed the instructions
in FVWM FAQ. My window settings are read from the .fvwm/.fvwm2rc but some of the
features are missing, such as "AutoRaise". My FVWM menus does show up fine.

One other feature is the FvwmPager. It does show up as a miniscule icon on
the panel bar. I can go to the FVWM Menu and call "Module FvwmPager" and it
does show up with the defined (prefered) geometry on the desktop.

How do I get these last 2 features to work in Gnome-session?
-- 

Subba Rao
[email-masked]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 31 Aug 2001 19:25:42 +0200

> function from the GNOME Panel ("Log Out")?

Fvwm commands can be issued via the command line.  To do this,
make sure the FvwmCommandS module is started, e.g. from the
StartFunction:

  AddToFunc StartFunction
  + I Module FvwmCommandS

After that, fvwm commands can be issues from a shell:

  $ FvwmCommand "Quit"

Or if you know the process id, simply send it the QUIT signal:

  $ kill -QUIT <fvwm's process id>

or

  $ pkill -QUIT fvwm2

or

  $ killall -QUIT fvwm2

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Subba Rao <[email-masked]>
Date: Fri, 31 Aug 2001 14:49:21 -0400

> After that, fvwm commands can be issues from a shell:

I have done this but I get the following error message.

subba9@myhost:~$ FvwmCommand "Quit"
No such file or directory FvwmCommand error in opening message fifo
subba9@myhost:~$

-- 

Subba Rao
[email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 31 Aug 2001 15:08:28 -0400

> No such file or directory FvwmCommand error in opening message fifo

FvwmCommand does this when it can't communicate with
FvwmCommandS.

using "ps" check to see if FvwmCommandS is running.
Look for errors coming from fvwm.

Did you restart fvwm after you added FvwmCommandS to your .fvwm2rc?

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Subba Rao <[email-masked]>
Date: Fri, 31 Aug 2001 15:33:47 -0400

> Did you restart fvwm after you added FvwmCommandS to your .fvwm2rc?

Thank you for replying.

This is a bit strange. FvwmCommandS does not get listed in the process list.

AddToFunc "InitFunction"
+                           "I" Module FvwmAuto 500
+                           "I" Module FvwmCommandS

AddToFunc "RestartFunction"
+                           "I" Module FvwmAuto 500
+                           "I" Module FvwmCommandS

In fact FvwmAuto is not running either. I followed the instruction in FVWM FAQ
(section 2.7) to run fvwm via a Gnome session. The only thing that is showing
up now is my fvwm menus defined in ~/.fvwm/.fvwm2rc.

The display manager I am using is GDM. (Don't know if this info will help).
What is the bestway to trouble shoot GNOME and FVWM integration? The fvwm2
version is 2.4.0

-- 

Subba Rao
[email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 31 Aug 2001 15:53:46 -0400

Subba Rao <[email-masked]> writes:
> > > > > Another question related to FVWM + GNOME is, how to execute the FVWM 
> > > > > Quit function from the GNOME Panel ("Log Out")?
> > > > 
> In fact FvwmAuto is not running either. I followed the instruction in FVWM FA

I don't run Gnome but the FAQ (and Dominik above) suggest that you use
StartFunction.  If you are running gnome-session, that would explain
why the modules aren't starting.