Subject: FVWM: configure

From: "Nikolaj G." <[email-masked]>
Date: Sat, 25 Aug 2001 11:59:42 +0000

Hi.

Im installing fvwm2.4.0 on Redhat 7.0 and get these errors.

  Have ReadLine support?             yes
  Have RPlay support in FvwmEvent?   yes
  Have Stroke support?               no: Can't find required libstroke
  Have XPM support?                  no: Can't find required libXpm
  Have GNOME Window Manager support? yes
  Have Session Management support?   no: Failed to detect libSM
  Have GTK support for FvwmGtk?      no: Failed to detect GTK, see
config.log
  Have Multibyte support?            no: This is the suggested default

I've tried to install libstroke (rpmfind)
Also installing XPM seemed to go well (have elf, Xfree86 develop (to run
the xmkmf -a), strange world)

I gave up on the rest libSM.
I have gtk+-1.2.8-7 on the machine.
Dont know about Multibyte support.

Any help out there?

My last question... I use the Xfree86 startup login window. How do I
disable that if I want to start in text-mode?

Thanks, nikolaj, copenhagen, denmark
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 25 Aug 2001 12:17:15 +0000

On 25 Aug 2001 11:59:42 +0000, Nikolaj G. wrote:
>   Have GTK support for FvwmGtk?      no: Failed to detect GTK, see config.log

This are not really errors, the errors are when you run "make".
The symptoms are that you don't have XFree86-devel rpm installed.

> I gave up on the rest libSM.

libSM.a is shipped with XFree86-devel.

> Dont know about Multibyte support.

If you normally don't build anything yourself I suggest you to install
rpm, so you don't need all developement libraries and headers:

  http://fvwm-themes.sf.net/rpm/

> disable that if I want to start in text-mode?

Try line "id:3:initdefault:" in /etc/inittab.

Regards,
Mikhael.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 25 Aug 2001 14:46:02 +0200

> Im installing fvwm2.4.0 on Redhat 7.0 and get these errors.

First of all: these are *not* error messages.  This is simply a
summary of the features that will be compiled into fvwm and the
reasons why some will not.  You should still be able to compile
fvwm.

>   Have Stroke support?               no: Can't find required libstroke

Some older versions of libstroke did not install themselves
properly.  There should be a file stroke.h in /usr/include or
/usr/local/include ore some other include directory.  If not, you
have to copy it there manually.  You can skip this if you do not
need stroke support.

>   Have XPM support?                  no: Can't find required libXpm

For some reason, configure could not find out where the xpm
library was installed.  There should be some hint what went wrong
in the config.log file.  If you can't figure it out with that
information, post the config.log file to the mailing list and
we'll try to help you.

>   Have Session Management support?   no: Failed to detect libSM

Probably the library is not installed.  Most people do not need
this anyway.

>   Have GTK support for FvwmGtk?      no: Failed to detect GTK, see

You need this only if you plan to use the FvwmGtk module.

>   Have Multibyte support?            no: This is the suggested default

This feature has to be enabled explicitly with

  $ ./configure --enable-multibyte
 
> disable that if I want to start in text-mode?

Since I have a SuSE system, the following information may not be
100% accurate for RedHat:

The decision between graphical/text mode boot is made in the file
/etc/inittab.  You should find an entries similar to this one in
there:

  # default runlevel
  id:5:initdefault:
  # runlevel 2  is  Local multiuser without remote network (e.g. NFS)
  # runlevel 3  is  Full multiuser with network
  # runlevel 5  is  Full multiuser with network and xdm

The initdefault level of 5 specified that the system uses
graphical boot.  Change this to 3 and the system starts with a
text console:

  id:3:initdefault:

It should be possible to do this somewhere in RedHat's config
tool too.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Nikolaj G." <[email-masked]>
Date: Sun, 26 Aug 2001 12:09:17 +0000

Okay, I'll wait with the "configure error" (libstroke, xdm (looked at
the config.log), Gtk) and take one thing at the time.

You say I need to install XFree86 devel, so I installed (from
rpmfind.net):

  XFree86-devel-4.0.1-1.i386.rpm

This is what I get from rpm -q -a:

Xaw3d-1.5-7
Xconfigurator-4.4.3-1
XFree86-100dpi-fonts-4.0.1-1
XFree86-4.0.1-1
XFree86-75dpi-fonts-4.0.1-1
XFree86-devel-4.0.1-1
XFree86-ISO8859-2-100dpi-fonts-1.0-12
XFree86-ISO8859-2-1.0-12
XFree86-ISO8859-2-75dpi-fonts-4.0.1-1
XFree86-ISO8859-2-Type1-fonts-1.0-12
XFree86-libs-4.0.1-1
XFree86-SVGA-3.3.6-33
XFree86-tools-4.0.1-1
XFree86-xdm-4.0.1-1
XFree86-xf86cfg-4.0.1-1
XFree86-xfs-4.0.1-1

, and wait, I just try to make a configure and make to get some fresh
logs....

This is from make:

gcc -DFVWM_MODULEDIR=\"/usr/local/libexec/fvwm/2.4.0\" 
-DFVWM_DATADIR=\"/usr/local/share/fvwm\"       
-DFVWM_CONFDIR=\"/usr/local/etc\" -g -O2  -o fvwm2  menus.o borders.o
placement.o focus.o read.o style.o module_interface.o stack.o misc.o
fvwmdebug.o events.o icons.o conditional.o colormaps.o repeat.o
move_resize.o functions.o decorations.o bindings.o colors.o builtins.o
virtual.o cursor.o update.o add_window.o session.o windowlist.o
modconf.o fvwm.o gnome.o geometry.o icccm2.o -L../libs  -lfvwm       
-lXext -lX11  -lm 
/usr/bin/ld: cannot find -lXext
collect2: ld returned 1 exit status
make[2]: *** [fvwm2] Error 1
make[2]: Leaving directory `/home/alexis/down/fvwm2/fvwm-2.4.0/fvwm'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/alexis/down/fvwm2/fvwm-2.4.0'
make: *** [all-recursive-am] Error 2

, its the same, didn't find the "develop" packes. Where did you download
it, as said, I got from rpmfind.net.

Thanks. nikolaj, copenhagen, denmark.

PS should I upgrade XFree86?

> It should be possible to do this somewhere in RedHat's config

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:622: checking for a BSD compatible install
configure:675: checking whether build environment is sane
configure:732: checking whether make sets ${MAKE}
configure:778: checking for working aclocal
configure:791: checking for working autoconf
configure:804: checking for working automake
configure:817: checking for working autoheader
configure:830: checking for working makeinfo
configure:886: checking whether to enable debugging messages
configure:907: checking whether to enable command logging
configure:928: checking whether to enable multibyte character support (experimental)
configure:949: checking whether to enable shape extensions
configure:980: checking imagepath
configure:1008: checking for gcc
configure:1121: checking whether the C compiler (gcc  ) works
configure:1137: gcc -o conftest    conftest.c  1>&5
configure:1163: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1168: checking whether we are using GNU C
configure:1196: checking whether gcc accepts -g
configure:1228: checking how to run the C preprocessor
configure:1309: checking for POSIXized ISC
configure:1331: checking for minix/config.h
configure:1384: checking for X
configure:2220: checking whether to enable GNOME window manager hints
configure:2266: checking for SmcOpenConnection in -lSM
configure:2285: gcc -o conftest -g -O2   conftest.c -lSM   -lX11   1>&5
/usr/bin/ld: cannot find -lSM
collect2: ld returned 1 exit status
configure: failed program was:
#line 2274 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char SmcOpenConnection();

int main() {
SmcOpenConnection()
; return 0; }
configure:2355: checking for XpmReadFileToXpmImage in -lXpm
configure:2374: gcc -o conftest -g -O2   conftest.c -lXpm -lXpm   -lX11   1>&5
/usr/bin/ld: cannot find -lXpm
collect2: ld returned 1 exit status
configure: failed program was:
#line 2363 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char XpmReadFileToXpmImage();

int main() {
XpmReadFileToXpmImage()
; return 0; }
configure:2579: checking for rplay_create in -lrplay
configure:2598: gcc -o conftest -g -O2   conftest.c -lrplay -lrplay   1>&5
configure:2642: checking for rplay.h
configure:2652: gcc -E   conftest.c >/dev/null 2>conftest.out
configure:2745: checking for stroke_init in -lstroke
configure:2764: gcc -o conftest -g -O2   conftest.c -lstroke -lstroke   1>&5
/usr/bin/ld: cannot find -lstroke
collect2: ld returned 1 exit status
configure: failed program was:
#line 2753 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char stroke_init();

int main() {
stroke_init()
; return 0; }
configure:2911: checking with termcap
configure:2949: checking for readline in -lreadline
configure:2968: gcc -o conftest -g -O2   conftest.c -lreadline -lreadline -ltermcap  1>&5
configure:3012: checking for readline/history.h
configure:3022: gcc -E   conftest.c >/dev/null 2>conftest.out
configure:3364: checking for _Xsetlocale in -lX11
configure:3413: checking for stdarg.h
configure:3452: checking for vfprintf
configure:3512: checking for waitpid
configure:3630: checking for cpp
configure:3680: checking for a BSD compatible install
configure:3733: checking whether ln -s works
configure:3754: checking whether make sets ${MAKE}
configure:3783: checking for ranlib
configure:3813: checking for perl
configure:3848: checking for perl 5.002 or better
configure:3861: checking for ANSI C header files
configure:3965: checking for sys/wait.h that is POSIX.1 compatible
configure:4010: checking for stdlib.h
configure:4010: checking for fcntl.h
configure:4010: checking for limits.h
configure:4010: checking for malloc.h
configure:4010: checking for string.h
configure:4010: checking for memory.h
configure:4010: checking for unistd.h
configure:4050: checking for getopt.h
configure:4050: checking for sys/select.h
configure:4050: checking for sys/systeminfo.h
configure:4088: checking for working const
configure:4163: checking for inline
configure:4203: checking for off_t
configure:4236: checking for pid_t
configure:4269: checking for size_t
configure:4303: checking return type of signal handlers
configure:4346: checking for working alloca.h
configure:4379: checking for alloca
configure:4578: checking for strftime
configure:4676: checking for gettimeofday
configure:4676: checking for mkfifo
configure:4676: checking for putenv
configure:4676: checking for setvbuf
configure:4676: checking for socket
configure:4676: checking for waitpid
configure:4731: checking for strdup
configure:4731: checking for strstr
configure:4731: checking for strtol
configure:4731: checking for memmove
configure:4731: checking for memcpy
configure:4731: checking for strchr
configure:4731: checking for sysconf
configure:4731: checking for uname
configure:4731: checking for div
configure:4786: checking for sigaction
configure:4786: checking for siginterrupt
configure:4786: checking for getpwuid
configure:4840: checking for sig_atomic_t
configure:4876: checking whether setvbuf arguments are reversed
configure:4926: checking for select
configure:4983: checking for unistd.h
configure:4983: checking for sys/types.h
configure:4983: checking for sys/time.h
configure:4983: checking for sys/select.h
configure:4983: checking for sys/socket.h
configure:5020: checking argument types of select()
configure:5133: checking for gethostname
configure:5133: checking for strcasecmp
configure:5133: checking for strncasecmp
configure:5133: checking for strdup
configure:5133: checking for strerror
configure:5133: checking for usleep
configure:5133: checking for atexit
configure:5289: checking for gtk-config
configure:5324: checking for GTK - version >= 1.1.0
configure:5556: checking for imlib-config
configure:5591: checking for GDK IMLIB - version >= 1.8.0
*** The imlib-config script installed by IMLIB could not be found
*** If IMLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the IMLIBCONF environment variable to the
*** full path to imlib-config.
configure:5817: checking for gnome-config
configure:5880: checking for gnomeConf.sh file in /usr/local/lib

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 Aug 2001 10:47:45 +0000

>   XFree86-devel-4.0.1-1.i386.rpm

After installing X developement libs (or any other lib that you want to be
automatically found) you should run "ldconfig" as root.
There is a solution without running ldconfig by giving parameters to
configure, but you'd better just run "ldconfig".
I hope, you have /usr/X11R6/lib line in your /etc/ld.so.conf.
Then rerun "./configure; make".

> PS should I upgrade XFree86?

You don't need.

Regards,
Mikhael.

---

From: "Nikolaj G." <[email-masked]>
Date: Sun, 26 Aug 2001 13:18:04 +0000

Ok, I just tried the "ldconfig" command as root. It was running ok.
Also, my ld.so.conf has

/usr/X11R6/lib
/usr/kerberos/lib
/usr/lib

Afterwards I run ./configure and make (both as user and root). I get the 
same error - can't find -lXext.

---

From: Mikhael Goikhman <[email-masked]>
Date: Sun, 26 Aug 2001 11:50:31 +0000

> same error - can't find -lXext.

./configure can't find your X developement libraries.

Don't proceed with make until you have SM support and optionally XPM
support from ./configure (that means your X libs are found ok).

Execute:
  rm config.cache
  ./configure
  make clean  # not really needed, but anyway

If this does not help, execute:
  ./configure --x-libraries=/usr/X11R6/lib

If this does not help, send the output of:
  ls -l `rpm -ql XFree86-devel | grep libXext`

Good luck.

Regards,
Mikhael.

---

From: "Nikolaj G." <[email-masked]>
Date: Sun, 26 Aug 2001 16:38:33 +0000

To Mikhael & Dominik:

Ok, if you were a girl, and you were here, I would give you a kiss *s* -
make is working, thanks!

"rm config.cache" did the trick (after ldconfig).

Also I made libstroke work too - SM also works because of the above and 
XFree dev..

So, I want to test before removing the old fvwm2. Iv'e tried to startup 
in consol mode and use "startx path/fvwm2" but it just starts up the old 
fvwm2, maybe because it uses the old system.fvwm2rc (redhat). By the way 
initd:3 is working (i forgot about Crtl+Alt+backspace).

Also, I would like to make configure find the GTK. As said, I have Gtk+ 
on the machine. Maybe I should install Gtk? (looked at their homepage, 
but couldn't find it, there's only Gtk+).

Ok, thanks. Im finally close to the installation!
/nikolaj, copenhagen, denmark.

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 27 Aug 2001 00:34:25 +0000

> "rm config.cache" did the trick

Eventually we will move to a more recent autoconf version that does not
use caching in configure by default.

Regards,
Mikhael.