Subject: FVWM: a sticky question

From: Randy Schultz <[email-masked]>
Date: Fri, 3 Aug 2001 16:27:02 -0500 (CDT)

Hey all,

Just upgraded to 2.4.0 on RH 6.2 and am having a 'sticky' problem(sorry,
couldn't help myself).  I have a button that kicks off xmms:
*FvwmButtons(NoSize Title xmms, Icon starMask, Action `exec /usr/bin/xmms &`)

it's just like other I have:
*FvwmButtons(NoSize Title Moz, Icon wingdogs, Action `exec /usr/bin/netscape &`)

except xmms now, with 2.4.0, is sticky.  I've even tried a line like:
Style "*xmms"       NoSticky

to no avail.  Anybody have any ideas why?  A pointer to some docs that I
might have missed would be much appreciated.

--
Randy    ([email-masked])  715-726-2832          <*>

The Penguin Cometh

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 5 Aug 2001 12:15:05 +0200

> except xmms now, with 2.4.0, is sticky.  I've even tried a line like:

There is no style named "NoSticky".  Try this one instead:

  Style xmms Slippery

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Randy Schultz <[email-masked]>
Date: Mon, 6 Aug 2001 11:05:22 -0500 (CDT)

On Sun, 5 Aug 2001, Dominik Vogt spaketh thusly:

-{On Fri, Aug 03, 2001 at 04:27:02PM -0500, Randy Schultz wrote:
-{> Hey all,
-{>
-{> Just upgraded to 2.4.0 on RH 6.2 and am having a 'sticky' problem(sorry,
-{> couldn't help myself).  I have a button that kicks off xmms:
-{> *FvwmButtons(NoSize Title xmms, Icon starMask, Action `exec /usr/bin/xmms &`)
-{>
-{> it's just like other I have:
-{> *FvwmButtons(NoSize Title Moz, Icon wingdogs, Action `exec /usr/bin/netscape &`)
-{>
-{> except xmms now, with 2.4.0, is sticky.  I've even tried a line like:
-{> Style "*xmms"       NoSticky
-{
-{There is no style named "NoSticky".  Try this one instead:
-{
-{  Style xmms Slippery

No go - it is still sticky.

Some further info that may or may not be useful.  I looked for anything xmms
in the .fvwm2rc.  There are only the 2 lines:
Style "*xmms*"      Slippery
*FvwmButtons(NoSize Title xmms, Icon starMask, Action `exec /usr/bin/xmms &`)

I was wondering if it was getting started somehow linked to fvwm so tried
changing the line:
Style "Fvwm*"       NoTitle,  Sticky, WindowListSkip

to
Style "Fvwm*"       NoTitle,  Slippery, WindowListSkip

with no effect.

I also tried global Slippery, e.g.:
Style "*"           Slippery

still no effect.

Thoughts?

The Penguin Cometh

---

From: Eric Mc Sween <[email-masked]>
Date: Mon, 6 Aug 2001 14:16:50 -0400

> No go - it is still sticky.

<snip>

There's a "Sticky" checkbox in xmms' Options menu that seems to override
the Slippery style.  Did you try disabling that option?

HTH

Eric

---

From: Dmitry Derevyanko <[email-masked]>
Date: Mon, 6 Aug 2001 11:52:41 -0700 (PDT)

> Style "*xmms*"      Slippery

Try "XMMS*" instead.

-Dmitry

____________________________________________________
Get Your Slack at http://www.slackware.com/getslack/

---

From: Randy Schultz <[email-masked]>
Date: Mon, 6 Aug 2001 14:18:30 -0500 (CDT)

On Mon, 6 Aug 2001, Eric Mc Sween spaketh thusly:

-{There's a "Sticky" checkbox in xmms' Options menu that seems to override
-{the Slippery style.  Did you try disabling that option?

Aack!  That was it.

I never thought to check xmms itself since there was no problem until the
upgrade to fvwm2.4.

Tnx all for the pointers.

The Penguin Cometh

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 6 Aug 2001 20:01:42 +0000

> I never thought to check xmms itself since there was no problem until the

If you want to simulate the previous behavior, i.e. ignore all xmms hints,
you may use:

  Style xmms GNOMEIgnoreHints

Regards,
Mikhael.