Subject: FVWM: Using FvwmEvent to close a window

From: Thomas Adam <[email-masked]>
Date: Fri, 10 Aug 2001 21:43:57 +0100 (BST)

Dear List,

I have yet another problem. This time, I am trying to
get FVWM2 to recognise a particular window, based on
its ID. I have tried using FvwmEvent to capture this
window ID, but so far, I am not having much luck.

What I would like to happen, is once FVWM2 detects
that this window has appeared, I would like for it to
be
"closed" and NOT killed, since killing this window
closes the entire application. Has anyone got any
ideas??

I have tried to follow the examples in the manual
pages (FVWM2 and FvwmEvent), but either I am a
luddite, or
I do not fully understand what I am doing!!

I assume that the FvwmEvent modules is what I am
supposed to be using??

Thank You for your help,
Regards,

Thomas Adam

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Sat, 11 Aug 2001 00:26:06 +0000

> I assume that the FvwmEvent modules is what I am

See FAQ question 3.18, it explains several solutions with and without
FvwmEvent depending on your needs.

If you know window id or window title or both use one of the commands:

  Next ("My Window Title") Close
  WindowId 0x140000e Close
  WindowId $w ("My Window Title") Close

Regards,
Mikhael.