Subject: FVWM: Gnome Icons On FVWM

From: Ariel Cas <[email-masked]>
Date: Wed, 22 Aug 2001 10:33:28 -0700 (PDT)

Hello all,
I'm using a few gnome icons in xpm format for my
FvwmButton bar.  Under gnome the icons look fine but
when in fvwm the icons are displayed on my button bar
with a black background.  My button bar is grey, so
the only thing I should see is the icon with a grey
background.  I have a graphics file viewer called
Xnview, and I can view all my fvwm and gnome icons. 
When I view them via Xnview the fvwm and gnome icons
are indeed displayed with a black background but when
placed on the button bar only the fvwm icons show up
as they are supposed to.  

Why does this only happen with gnome icons?  They're
both in xpm format.

Is there something I should add to my .fvwm2rc file?

I'm using fvwm 2.2.4

Thanks in advance!

-arielc

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 22 Aug 2001 22:33:38 +0000

> Is there something I should add to my .fvwm2rc file?

Original GNOME icons are png, not xpm. I think your converting program
replaced the transparent color with the black one.

You may open your xpm files in an editor and replace "black" or "#000000"
with "None" to restore transparency. Or use a more correct convertor like
GIMP to transform png to xpm. You should get color "None" in xpm.

Regards,
Mikhael.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ariel Cas <[email-masked]>
Date: Wed, 22 Aug 2001 16:10:36 -0700 (PDT)

Well I used Xnview to convert gnome's png's to xpm's. 
I decided to use gimp and it does it perfectly fine.

Thanks all!

-arielc