Subject: FVWM: FvwmPager crashes ?

From: Xavier Renaut <[email-masked]>
Date: Tue, 14 Aug 2001 11:35:40 -0400 (EDT)

hello,

I'm running fvwm 2.4

and, after an uptime of 2 days, FvwmPager begin to crash when i change from
desk...

I had to add this line to make the pager re-appear :
Key F10 A S FvwmPager * *
(and i have to press shift-F10 when the pager crashes)

relevant parts of .fvwm2rc :
--------------------------------

Style "Fvwm" Sticky
Style "FvwmPager" Sticky

Style FvwmPager NoTitle
OpaqueMoveSize 10
Style "*" SloppyFocus
*FvwmPagerBack CadetBlue
*FvwmPagerFore Black
*FvwmPagerFont none
*FvwmPagerHilight Lightgrey
*FvwmPagerGeometry 200-5-2
*FvwmPagerSmallFont -adobe-times-*-r-*-*-12-*-*-*-*-*-*-*
*FvwmPagerDeskTopScale 32

DeskTopSize 10x7

FvwmPager * *
#AddToFunc "InitFunction"   "I" Module  FvwmPager * *

*FvwmPagerGeometry		230x120+1037+890

Key F10 A S FvwmPager * *

Key 1              	W       C      MoveToDesk 0 0 0 3
Key 2              	W       C      MoveToDesk 0 1 0 3 
Key 3              	W       C      MoveToDesk 0 2 0 3
Key 4              	W       C      MoveToDesk 0 3 0 3

Key 1          		A      M	Desk 0 0 0 3 
Key 2                	A      M	Desk 0 1 0 3
Key 3                	A      M	Desk 0 2 0 3
Key 4                	A      M	Desk 0 3 0 3

EOF

Is there a way to print debug information ? when the pager crash ?

thanks

xavier

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Aug 2001 17:43:20 +0200

On Tue, Aug 14, 2001 at 11:35:40AM -0400, Xavier Renaut wrote:
>... 

You have to locate the core file generated by the pager.  Then,
call

  $ gdb FvwmPager core
  (gdb) where

(assuming you have gdb).  This prints a stack trace of where the
pager has crashed.  Also, there may be some interesting output on
the console.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].