Subject: FVWM: mouse 2 no longer pastes

From: Randy Bush <[email-masked]>
Date: Wed, 22 Aug 2001 15:14:31 -0700

freebsd 4.3-stable
fvwm 2.4.0

i do not have any mouse 2 actions defined outside the root, i.e. 

% grep -i ^mouse .fvwm2rc
    Mouse 1         R       A       Menu rlogins Nop
    Mouse 2         R       A       Menu Window-Ops Nop
    Mouse 3         R       A       Menu FvwmCmds Nop
    Mouse 0         1       A       Menu Window-Ops2 Close
    Mouse 0         3       A       Iconify
    Mouse 0         4       A       Stick
    Mouse 0         2       A       Maximize-Func
    Mouse 1         FS      A       Resize-or-Raise
    Mouse 1         I       A       Move-or-Iconify
    Mouse 1         T       A       Move-or-Raise
    Mouse 3         TSIF    A       RaiseLower

mouse-2 no longer pastes in an xterm or in emacs (it used to in tvtwm).
i can not see anything in the list archive, so thought i would whine for
help on the list.

randy
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Wed, 22 Aug 2001 22:49:54 +0000

> i can not see anything in the list archive, so thought i would whine for

Did you do any changes to your X configuration recently?
It is likely that your X does not recognize the middle mouse button.

Regards,
Mikhael.

---

From: Randy Bush <[email-masked]>
Date: Wed, 22 Aug 2001 21:01:28 -0700

> Did you do any changes to your X configuration recently?

no

> It is likely that your X does not recognize the middle mouse button.

something not obvious is happening.  it now works on one host which has a
real three button mouse, but is not on another that has to emulate three
button.  but the pseudo-mouse-2 is working on that host, as i can get the
appropriate menu in the root window.

randy

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 23 Aug 2001 09:26:30 +0000

> appropriate menu in the root window.

Maybe X maps your middle button to number 4 not 2. xterm and emacs paste
using mouse button number 2 only. Start xev to see which (if at all)
ButtonPress/ButtonRelease events this button generates.

By default, all mouse buttons (say mouse button number 4) open menu
MenuFvwmRoot on the root. This binding and menu are built-in.

Regards,
Mikhael.