Subject: FVWM: oclock background not updating

From: Stephen <[email-masked]>
Date: Thu, 23 Aug 2001 11:12:02 -0500

I recently moved from fvwm 2.2.4 to 2.4.0.  I use the clock program
"oclock" with the transparent option, and noticed with fvwm 2.4.0 it
doesn't update the background behind the clock.  The clock hands smear as
they advance.  Since I've tried 2.4.0 on both Solaris and FreeBSD with the
same result, my guess is I'm missing something in fvwm's config file.

Any help appreciated,
Steve.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 23 Aug 2001 13:16:14 -0400

> same result, my guess is I'm missing something in fvwm's config file.

I can't reproduce that.

I tried with Solaris 8 and no special X-Resources.
I'm using an Exceed server right now though.

What command line/X-Resources are you using?

I see backing-store is slightly different on Exceed:

xdpyinfo | grep backing:
  options:    backing-store WHEN MAPPED, save-unders YES
vs. Solaris:
  options:    backing-store YES, save-unders YES

You might want to try oclock's "-backing" argument with some variations.
Let us know what happens.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Thu, 23 Aug 2001 20:21:41 +0000

> same result, my guess is I'm missing something in fvwm's config file.

Please run oclock without FVWM to see whether the problem is in oclock or
in X. You may do this in several ways, for example, while in FVWM execute
"Restart xterm" from FvwmTalk or FvwmConsole. Then start oclock in xterm.
To return to FVWM, type "fvwm2" in xterm.

Regards,
Mikhael.

---

From: Stephen <[email-masked]>
Date: Thu, 23 Aug 2001 22:10:45 -0500

On Thu, Aug 23, 2001 at 10:00:59PM -0500, Stephen wrote:
> On Thu, Aug 23, 2001 at 08:21:41PM +0000, Mikhael Goikhman wrote:
> First, I forgot to mention before that I'm not on the list.  Please cc all
> replies to my email address.
> 
> In my .xinitrc file I replaced "exec fvwm2" with "exec xterm".  I ran an
> oclock from within that xterm and it functions properly.
> 
> As for my fvwm2, I compiled it very minimally (if that makes a difference).
> Here's the "fvwm-config -info" output:
> 
[...]

I used the FreeBSD fvwm2 package instead, which includes:

Support for features:
        readline: yes
        rplay: no
        stroke: no
        xpm: yes
        gnome-wm (window manager hints): no
        sm (session management): yes
        gtk (FvwmGtk): yes
        gdk-imlib (in FvwmGtk): yes
        gnome-libs (in FvwmGtk): no
        multibyte: no

And oclock works correctly.

Thanks for the help,
Steve

---

From: Stephen <[email-masked]>
Date: Thu, 23 Aug 2001 22:00:59 -0500

********

Package: fvwm
Version: 2.4.0

Instalation options:
        prefix: /opt/fvwm2
        exec-prefix: /opt/fvwm2
        bindir: /opt/fvwm2/bin
        datadir: /opt/fvwm2/share
        libexecdir: /opt/fvwm2/libexec
        sysconfdir: /opt/fvwm2/etc
        mandir: /opt/fvwm2/man

Compiled-in paths:
        Module directory: /opt/fvwm2/libexec/fvwm/2.4.0
        Data directory: /opt/fvwm2/share/fvwm
        Default ImagePath:
/usr/include/X11/bitmaps:/usr/include/X11/pixmaps
        Default UserDir: $HOME/.fvwm

Support for features:
        readline: yes
        rplay: no
        stroke: no
        xpm: no
        gnome-wm (window manager hints): no
        sm (session management): no
        gtk (FvwmGtk): no
        gdk-imlib (in FvwmGtk): no
        gnome-libs (in FvwmGtk): no
        multibyte: no

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 24 Aug 2001 20:05:15 +0000

> oclock from within that xterm and it functions properly.

So, you claim this is indeed an FVWM problem. I am clueless.

>         gnome-libs (in FvwmGtk): no

Yes, it's minimal, but I can't think that the features above are related.

In the current snapshots "fvwm-config --info" also reports about:
	shape (shaped windows): yes/no

It would be interesting to know whether you compiled with or without X
shape extension. You may execute "grep SHAPE config.h" to determine this.

Please also play with these style options to see whether they matter:

  Style oclock BackingStore, SaveUnder
  Style oclock BackingStoreOff, SaveUnderOff
	
Regards,
Mikhael.

---

From: Mikhael Goikhman <[email-masked]>
Date: Fri, 24 Aug 2001 20:14:23 +0000

> So, you claim this is indeed an FVWM problem. I am clueless.

My English sux. s/clueless/confused/. :)

Regards,
Mikhael.