Subject: FVWM: understanding

From: brendan strejcek <[email-masked]>
Date: Tue, 14 Aug 2001 01:39:36 -0500

i have teh following line in my .fvwm2rc:

Mouse 1 W M Move

that is, hold alt and click anywhere in a window with the left mouse button
to start a move operation.

i use click to focus.

so, this binding only works on the focused window.

i would like hold alt and be able to click on an unfocused window and have
it behave the same way. i have tried to implement this with a function:

AddToFunc "raise meta move"
	+ I Raise
	+ I Move

AddToFunc "raise meta move"
	+ I Raise
	+ M Move

AddToFunc "raise meta move"
	+ I Focus
	+ M Move

... etc ...

but none of these variations seem to work.

Style * ClickToFocusPassesClick

doesn't help. by its name it *really* seems like it should fix my problem,
so i guess i don't understand something.

any ideas?
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 14 Aug 2001 12:34:20 +0200

> so i guess i don't understand something.

I guess nobody ever thought of this problem.  When the focus click
occurs, and ClickToFocusPassesClick is set, fvwm focuses the
window and passes the click to the application, but does not check
for bindings.  Anyway, since the window will always get focus when
you do this, you just have to click on the windows once and can
use alt-click immediately afterwards.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].