Subject: Re: FVWM: oclock background not updating

From: Dan Espen <[email-masked]>
Date: Thu, 23 Aug 2001 15:29:41 -0400

Stephen Krans <[email-masked]> writes:
> On Thu, Aug 23, 2001 at 01:16:14PM -0400, Dan Espen wrote:
> > Stephen <[email-masked]> writes:
> > > I recently moved from fvwm 2.2.4 to 2.4.0.  I use the clock program
> > > "oclock" with the transparent option, and noticed with fvwm 2.4.0 it
> > > doesn't update the background behind the clock.  The clock hands smear as
> > > they advance.  Since I've tried 2.4.0 on both Solaris and FreeBSD with
> > > the same result, my guess is I'm missing something in fvwm's config file.
> > 
> > I can't reproduce that.
> > 
> > I tried with Solaris 8 and no special X-Resources.
> > I'm using an Exceed server right now though.
> > 
> > What command line/X-Resources are you using?
> > 
> > I see backing-store is slightly different on Exceed:
> > 
> > xdpyinfo | grep backing:
> >   options:    backing-store WHEN MAPPED, save-unders YES
> > vs. Solaris:
> >   options:    backing-store YES, save-unders YES
> > 
> > You might want to try oclock's "-backing" argument with some variations.
> > Let us know what happens.
> > 
> 
> I tried the 3 backing options: WhenMapped Always NotUseful.  No change.
> 
> My XDefaults for oclock:
> 
> Clock*BorderColor: black
> Clock*hour:        red
> Clock*jewel:       red
> Clock*minute:      red
> Clock*transparent: on
> 
> And my fvwm2 styles:
> 
> Style "oclock" BorderWidth 0,StaysOnTop
> Style "*"      BorderWidth 2, HandleWidth 4, Icon xterm-blank.xpm
> Style "*"      BackColor gray55,ForeColor Black
> Style "*"      NoPPosition
> Style "*       DecorateTransient
> Style "*"      ActivePlacement, DumbPlacement
> Style "*lock"  NoTitle,NoHandles,Sticky,WindowListSkip
> 
> I tried the system rc file "system.fvwm2rc-sample-95" instead of my own and
> had the same problem.  Any ideas?

Not yet.

Please respond to the list, not the person that answers.

I tried those resources and config file settings and
still couldn't reproduce the problem.

Perhaps someone else on the list has an idea.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 25 Aug 2001 15:31:21 +0200

> > Clock*transparent: on

As suggested in some other posting, you have compiled fvwm without
shape support

  $ ./configure --disable-shape

Thus, fvwm does not do anything abot shaped window which is also
the reason why you need

> Style "oclock" BorderWidth 0,StaysOnTop
                 ^^^^^^^^^^^^^

Otherwise, a border would be drawn.  Since fvwm doe not use shape
masks, the transparent background of the window is never drawn.
Try to move the oclock window:  there is no transparency, the
backgorund just moves with the window.  To make it work, don't
use --disable-shape.

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephen <[email-masked]>
Date: Sat, 25 Aug 2001 10:26:13 -0500

> > Style "oclock" BorderWidth 0,StaysOnTop

Thanks, that worked.  I recompiled a minimal fvwm2 but included shape
support and oclock works as expected.

Steve