Subject: FVWM: Emacs window positioning

From: Andriy <[email-masked]>
Date: Wed, 08 Aug 2001 07:46:15 -0400

Hello,

   in the Emacs init file I have code to position it's window on startup 
in the left upper corner. It is positioned correctly under KDE. (2.1.1) 
Under fvwm (2.4.0-2.rh7, RedHat 7.1) the window title is out the screen. 
It seems the title size and border is not accounted in the left corner 
position calculations.

I had to correct the position like this:
(setq initial-frame-alist '((top . 22) (left . 5) (width . 110) (height 
. 43)))

Now under KDE the emacs window is shifted lower.

Question: is this supposed behavior of fvwm?

Thank you,
Andriy

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 8 Aug 2001 15:02:17 +0200

> Question: is this supposed behavior of fvwm?

Yes.  There is a clean way to position a window on the screen that
works for all window managers, but it seems that emacs does not
use it.

Bye

Dominik ^_^  ^_^

-- 
Dominik Vogt, email: [email-masked]
LifeBits Aktiengesellschaft, Albrechtstr. 9, D-72072 Tuebingen
fon: ++49 (0) 7071/7965-0, fax: ++49 (0) 7071/7965-20
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].