Subject: FVWM: FVWM2 and Java 1.3 Frame Centering

From: Paul Powell <[email-masked]>
Date: Fri, 27 Jul 2001 05:16:26 -0700 (PDT)

Hello,

It doesn't seem IBM Java 1.3 takes into account the
FVWM2 borders when calculating frame size.

For example, when I run my application in a 640 x 480
environment, and set my application frame to be size
640 x 480, the application is shifted so that the
title bar is offscreen and so is the left border.

Is this a known problem?  Any work arounds?

Thanks,
Paul

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 27 Jul 2001 11:20:05 -0400

> Is this a known problem?  Any work arounds?

This shows up in Sun's bug parade:

4401846

They've marked it as commit to fix in "Tiger" (whatever that is).

I'm not sure what relationship this has to IBM Java 1.3.

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Paul Powell <[email-masked]>
Date: Fri, 27 Jul 2001 09:52:05 -0700 (PDT)

Thanks for the help.  I searched bug parade but only
found a bug reported against Java 1.1.  This one is
against 1.3.

Thanks again,
Paul

---

From: Bob Woodside <[email-masked]>
Date: Fri, 27 Jul 2001 13:55:59 -0400

> I'm not sure what relationship this has to IBM Java 1.3.

        If he's talking about IBM's 1.3 JDK for Linux, he may not have
seen the problem with some other port of 1.3, say Blackdown's. Though it
theoretically shouldn't be so, I've definitely noticed that different
bugs seem to crop up in different implementers' ports of what is
supposed to be the same release.

Cheers,
Bob

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 28 Jul 2001 12:44:41 +0200

> supposed to be the same release.

You must be wrong!  We are talking about software written by big,
professional companies, not the trash open source kiddies like us
are writing ;-)

Bye

Dominik ^_^  ^_^

 --
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].