Subject: FVWM: installing fvwm-1.24r

From: Sergey Katalichenka <[email-masked]>
Date: Mon, 16 Jul 2001 17:44:22 -0400 (EDT)

Hi,

I am trying to compile fvwm-1.24r on solaris 8 Box.

OS: Solaris 8
GCC: gcc 2.95.2
XPM: xpm 3.4k

error:

gcc -O -Xc -xF -xcg92    -I/usr/openwin/include  -Dsun -Dsparc -DSVR4
-DSYSV      -c  CatString3.c
gcc: unrecognized option `-Xc'
gcc: language cg92 not recognized

All library build fail this way. Was wondering if this is a know issue,
and possible work-around.

Thank you.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 16 Jul 2001 18:41:22 -0400

> and possible work-around.

Using  fvwm1 is  a   bad idea.  (In  my opinion.)    There is  no  one
supporting fvwm1.

Fvwm2 uses configure so you won't run into this problem.

Your xmkmf config files are set up for Sun's compiler.
You can adjust them to gcc or override CCOPTIONS from the command line.
(You may need to use gnumake to get the override to work.)

-- 
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].