Subject: FVWM: size of maximised windows

From: Thomas Adam <[email-masked]>
Date: Sun, 29 Jul 2001 22:52:48 +0100 (BST)

Dear List,

This question is probably a simple one, but I have
been puzzling over it for days. 

Is it possible to tell FVWM that when a window is
maximsied, that it places the window at the top left
hand corner of the screen, and that the bottom line of
the window appears "x" distance from the bottom of the
screen, and that the remaining two sides of the
window, fill out to touch the sides of the screen.
Does this make sense???

Thankyou for your help,
Regards,

Thomas Adam

=====
Thomas Adam
Linux Co-ordinator for The Purbeck School

e-mail (school): [email-masked]
e-mail (yahoo) : [email-masked]

____________________________________________________________
Do You Yahoo!?
Get your free @yahoo.co.uk address at http://mail.yahoo.co.uk
or your free @yahoo.ie address at http://mail.yahoo.ie
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mikhael Goikhman <[email-masked]>
Date: Mon, 30 Jul 2001 11:41:05 +0000

> window, fill out to touch the sides of the screen.

In your case, you may have this function MyMaximize:

  DestroyFunc MyMaximize
  AddToFunc   MyMaximize
  + I Maximize 100 -48p $0        # x = 48

Use MyMaximize instead of Maximize, it gets one optional argument
"True"/"On", "False"/"Off" or "Toggle" (the default is "Toggle").

In the fvwm-ewmh patch, which will be integrated to fvwm sometimes soon,
there are other commands to change the behaviour of the Maximize command.

Regards,
Mikhael.